Vue d'ensemble de la documentation d'installation de SQL Server

Aide du programme d'installation de SQL Server 2008 R2
Vue d'ensemble de la documentation d'installation de SQL Server

La documentation du programme d'installation de SQL Server est disponible sur le support d'installation et en ligne.

Documentation disponible pendant l'installation

Durant l'installation de SQL Server vous sont fournies les informations immédiates nécessaires pour terminer l'opération.

Documentation en ligne de SQL Server

Le support d'installation inclut également la documentation en ligne SQL Server, qui fournit davantage de détails à propos du programme d'installation de SQL Server.

Vous pouvez consulter la documentation dans la documentation en ligne de SQL Server en choisissant l'une des options suivantes :

  • Installer la documentation en ligne de SQL Server à partir du support d'installation.

  • Télécharger la documentation en ligne de SQL Server à partir du Centre de téléchargement.

  • Afficher la documentation la plus récente dans la Documentation en ligne de SQL Server.

Vue d'ensemble des rubriques d'installation de SQL Server

Que vous utilisiez l'Assistant Installation de SQL Server ou l'invite de commandes pour installer SQL Server, vous pouvez vous préparer en lisant les sections suivantes :

  • Planification d'une installation SQL Server.

    Décrit comment préparer une installation de SQL Server.

  • Installation ou Mise à niveau d'une installation SQL Server.

    Décrit les options d'installation ou de mise à niveau de SQL Server.

  • Configuration d'une installation SQL Server.

    Explique comment configurer une installation SQL Server.

Si vous installez un cluster de basculement SQL Server, examinez les éléments suivants :

  • Mise en route avec le clustering avec basculement de SQL Server.

  • Avant l'installation du clustering avec basculement.


À propos des termes du contrat de licence SQL Server

À propos des termes du contrat de licence SQL Server |
 | Voir aussi
Vue d'ensemble de la documentation d'installation de SQL Server >

Les termes de la Licence d'utilisation du logiciel Microsoft sont copiés vers l'ordinateur local lorsque SQL Server est installé. Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue. Les fichiers sont enregistrés dans : %ProgramFiles%\Microsoft SQL Server\100\License Terms\ ou %ProgramFiles(x86)%\Microsoft SQL Server\100\License Terms\.

Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue.

Le nom de fichier des termes du contrat de licence indique l'édition de SQL Server ainsi que l'édition linguistique de SQL Server : Par exemple :

  • License_DEV_ENU.txt pour SQL Server Developer, édition en langue anglaise.

  • License_STD_ITA.txt pour SQL Server Standard, édition en langue italienne.

  • License_UA_JPN.txt pour le Conseiller de mise à niveau SQL Server, édition en langue japonaise.

  • License_SQLNCLI_ENU.txt pour SQL Server Native Client, édition en langue anglaise.

  • License_SQLXML4_KOR.txt pour SQLXML, édition en langue coréenne.

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • DC - Datacenter

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - Conseiller de mise à niveau

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • ENU - Anglais

  • JPN - Japonais

  • FRA - Français

  • ITA - Italien

  • KOR - Coréen

  • DEU - Allemand

  • ESN - Espagnol

  • CHS - Chinois simplifié

  • CHT - Chinois traditionnel

  • NLA - Néerlandais

  • PTB - Portugais (Brésil)

  • SVE - Suédois

  • RUS - Russe

Options de licences de SQL Server

Pour plus d'informations sur les prix et les options de licences de SQL Server, consultez le site Web Microsoft SQL Server 2008 R2.

Voir aussi

Concepts

Déclaration de confidentialité de SQL Server 2008 R2
Mentions légales relatives à la documentation

© 2010 Microsoft Corporation. Tous droits réservés.


Déclaration de confidentialité de SQL Server 2008 R2

Déclaration de confidentialité de SQL Server 2008 R2
Vue d'ensemble de la documentation d'installation de SQL Server >

Dernière mise à jour : janvier 2010

Microsoft s'efforce de garantir votre confidentialité tout en offrant des produits qui répondent à vos besoins informatiques personnels en termes de performances, de puissance et de convivialité. La présente déclaration de confidentialité décrit la plupart des principes de collecte de données et d'utilisation de Microsoft SQL Server 2008 R2 (« SQL Server »). Elle est axée sur les fonctionnalités qui communiquent avec Internet. Elle ne s'applique pas à d'autres sites, produits ou services en ligne ou hors connexion de Microsoft.

Collecte et utilisation de vos informations personnelles

Les informations collectées vous concernant seront utilisées par Microsoft et ses filiales ou affiliés pour activer les fonctionnalités que vous utilisez et fournir les services ou effectuer les transactions que vous avez demandés ou autorisés. Elles peuvent également être utilisées à des fins d'analyse et d'amélioration des produits et services Microsoft.

Sauf indication contraire dans cette déclaration, les informations personnelles que vous fournissez ne seront pas transférées à des tiers sans votre consentement. Nous faisons parfois appel à d'autres sociétés pour fournir certains services en notre nom et pour notre compte, tels que l'emballage, l'expédition et la livraison de commandes et d'autres courriers, les réponses aux questions des clients sur des produits ou services, le traitement des inscriptions aux événements ou l'analyse statistique de nos services. Nous transmettrons à ces sociétés uniquement les informations dont elles ont besoin pour fournir le service, lesquelles ne sont en aucun cas autorisées à utiliser lesdites informations à d'autres fins.

Microsoft se réserve le droit de communiquer ou d'accéder à des informations vous concernant, y compris le contenu de vos communications, si cela est nécessaire pour : (a) se conformer à une loi ou répondre à des demandes juridiques ou à une procédure légale ; (b) protéger les droits ou la propriété de Microsoft ou de ses clients, y compris l'application de nos contrats ou politiques régissant votre utilisation des services ; ou (c) agir si nous pensons en toute bonne fois que cet accès ou cette divulgation est nécessaire pour protéger la sécurité personnelle des employés de Microsoft, des clients ou du grand public.

Les informations collectées ou reçues par Microsoft par le biais de SQL Server peuvent être stockées et utilisées aux États-Unis ainsi que dans tout autre pays où Microsoft, ses affiliés, ses filiales ou ses fournisseurs de services sont implantés, et en utilisant un site ou service Microsoft, vous consentez à ces transferts d'informations personnelles en dehors de votre pays. À cette fin, Microsoft se conforme aux principes de protection des données (« Safe Harbor Principles ») définis par le département américain du commerce (U.S. Department of Commerce) en matière de collecte, d'utilisation et de conservation des données provenant de l'Union européenne.

Collecte et utilisation des informations relatives à votre ordinateur

SQL Server contient des fonctionnalités Internet susceptibles de collecter et d'envoyer des informations relatives à votre ordinateur (« informations standard sur l'ordinateur ») à Microsoft. Les informations standard sur l'ordinateur comprennent généralement des informations telles que votre adresse IP, la version du système d'exploitation, la version du navigateur, ainsi que vos paramètres régionaux et linguistiques. Dans certains cas, elles peuvent aussi comprendre l'ID du matériel, qui indique le fabricant, le nom et la version du dispositif. Si une fonctionnalité ou un service en particulier envoie des informations à Microsoft, les informations standard sont transmises également.

Pour chaque fonctionnalité de SQL Server décrite dans la présente déclaration de confidentialité, les informations de confidentialité décrivent les informations supplémentaires qui sont collectées et de quelle manière elles sont utilisées.

Sécurité de vos informations

Microsoft s'engage à protéger vos informations. Nous utilisons diverses technologies et procédures de sécurité pour protéger vos informations contre des accès, utilisations ou divulgations non autorisés. Par exemple, nous stockons les informations que vous nous fournissez sur des serveurs dont l'accès est limité et qui se trouvent dans des installations surveillées.

Modifications de la déclaration de confidentialité

Nous mettons à jour occasionnellement cette déclaration de confidentialité afin de répercuter les modifications apportées dans nos produits et services ainsi que les commentaires de nos clients. La date de la « dernière mise à jour » qui figure en haut de la déclaration de confidentialité est mise à jour à chaque révision de cette déclaration. En cas de modifications substantielles de la présente déclaration ou de la façon dont Microsoft va utiliser vos informations personnelles, nous vous en informons par la publication d'une notification de ces modifications ou nous vous envoyons directement une notification avant de mettre en œuvre ces modifications. Nous vous encourageons à consulter régulièrement la présente déclaration afin d'être informé sur la façon dont Microsoft protège vos informations.

Pour plus d'informations

Si vous avez des questions sur cette déclaration de confidentialité ou si vous estimez que nous n'y avons pas adhéré, contactez-nous par courrier électronique à l'adresse sqlpriv@microsoft.com.

Vous pouvez également nous joindre par courrier postal :

Déclaration de confidentialité de SQL Server

Microsoft Corporation, One Microsoft Way, Redmond, Washington 98052

Fonctionnalités spécifiques :

Programme d'amélioration du produit

Objet de cette fonctionnalité :

La fonctionnalité Programme d'amélioration du produit (CEIP, « Customer Experience Improvement Program ») de SQL Server Business Intelligence Development Studio et SQL Server Management Studio collecte des informations sur votre configuration matérielle et sur votre utilisation des logiciels et services Microsoft, dans le but d'identifier les tendances et les modes d'utilisation. Ces informations sont utilisées pour améliorer la qualité, la fiabilité et les performances des logiciels et des services Microsoft.

Informations collectées, traitées ou transmises :

La fonctionnalité Programme d'amélioration du produit collecte également le type et le nombre d'erreurs rencontrées, les performances logicielles et matérielles, ainsi que la vitesse des services. Microsoft ne collecte ni votre nom, ni votre adresse, ni aucune autre information permettant de vous contacter.

Cette fonctionnalité génère un identificateur global unique (GUID, Globally Unique Identifier) qui est stocké sur votre ordinateur pour l'identifier de manière unique. Le GUID est un nombre généré de manière aléatoire ; il ne contient aucune information personnelle et ne sera pas utilisé pour vous identifier. Le Programme d'amélioration du produit utilise le GUID pour déterminer l'étendue des commentaires que nous recueillons et définir des priorités. Par exemple, ce nombre permet à Microsoft de distinguer un client qui reçoit la même erreur 100 fois de 100 clients qui reçoivent la même erreur une fois. Le GUID est permanent.

Utilisation des informations :

Les informations recueillies sont utilisées pour contribuer à améliorer les produits de Microsoft. Les employés, prestataires et fournisseurs de Microsoft qui doivent utiliser les données pour des raisons professionnelles sont autorisés à y accéder, le cas échéant.

Choix/contrôle

Vous aurez l'opportunité de participer au Programme d'amélioration du produit durant l'installation de SQL Server. Pour les versions préliminaires de SQL Server, le Programme d’amélioration du produit est activé par défaut. Vous pourrez ultérieurement modifier votre choix d'installation en suivant les instructions ci-dessous.

Pour modifier vos paramètres de Programme d'amélioration du produit

  1. Démarrez SQL Server Management Studio ou SQL Server Business Intelligence Development Studio, puis ouvrez un projet Analysis Services ou DTS (Data Transformation Services) nouveau ou existant.

  2. Dans le menu ? (Aide) de SQL Server Management Studio, sélectionnez Options pour les commentaires des utilisateurs de Microsoft SQL Server ou, dans le menu ? (Aide) de SQL Server Business Intelligence Development Studio, sélectionnez Paramètres pour les commentaires client Microsoft SQL Server.

  3. Pour désactiver le Programme d'amélioration du produit, cliquez sur Non, je ne souhaite pas participer. Pour activer le Programme d'amélioration du produit, cliquez sur Oui, je souhaite participer.

  4. Cliquez sur OK.

Informations importantes :

Les clients d'entreprises peuvent construire une stratégie de groupe pour s'abonner au Programme d'amélioration du produit ou annuler l'abonnement en définissant une stratégie basée sur le Registre. La clé de Registre et les paramètres pertinents se présentent comme suit :

Clé = HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\100

Nom de l'entrée de Registre = CustomerFeedback

Type d'entrée DWORD :

  • 0 pour annuler l'abonnement

  • 1 pour s'abonner

Attention :

Une modification incorrecte du Registre peut sérieusement endommager votre système. Avant d'apporter des modifications au Registre, il convient de sauvegarder les données importantes qui se trouvent sur l'ordinateur. Vous pouvez également utiliser l'option de démarrage Dernière bonne configuration connue si vous rencontrez des problèmes après l'application de modifications manuelles.

Pour plus d'informations sur le Programme d'amélioration du produit, lisez l'article Déclaration de confidentialité pour le programme d'amélioration de l'expérience utilisateur de Microsoft®

Rapports d'erreurs individuels

Objet de cette fonctionnalité :

Les rapports d'erreurs individuels vous permettent de signaler les problèmes qui peuvent se poser avec SQL Server et tous ses composants qui ont des interfaces utilisateur. Le rapport d'erreurs pour les composants et services qui n'ont pas d'interface utilisateur (par exemple, le moteur de base de données SQL Server, SQL Agent, Analysis Services, Reporting Services, Notification Services, la réplication SQL, le composant Assistant Paramétrage de base de données, le service SQL Browser et SQL Writer) est géré par l'outil de rapports d'erreurs et d'utilisation, décrit ci-dessous.

Informations collectées, traitées ou transmises :

Les Rapports d'erreurs individuels collectent des informations informatiques standard qui ne sont pas utilisés pour vous identifier. Ils ne collectent pas intentionnellement le nom, l'adresse, l'adresse de messagerie, le nom de l'ordinateur, ni aucune autre information qui pourrait permettre de vous identifier ou de vous contacter. Il est possible que ces informations soient conservées en mémoire ou dans les données collectées dans des fichiers ouverts, mais elles ne sont pas utilisées par Microsoft pour vous identifier.

Dans de rares cas, notamment pour des problèmes particulièrement difficiles à résoudre, Microsoft peut vous demander des données supplémentaires, y compris des sections de mémoire (qui peuvent inclure la mémoire partagée par tout ou partie des applications en cours d'exécution lors de la survenue du problème), certains paramètres du Registre, et un ou plusieurs fichiers de votre ordinateur. Vos documents actifs peuvent également être concernés. Lorsque des données supplémentaires sont demandées, vous pouvez les examiner et choisir de les envoyer.

Dans certains cas, il peut vous être demandé de répondre à une enquête facultative après avoir envoyé un rapport d'erreurs. Si vous envoyez un rapport d'erreurs sans envoyer d'informations pour l'enquête, aucune des informations du rapport d'erreurs n'est utilisée pour vous identifier. Si vous décidez d'indiquer un numéro de téléphone ou une adresse de messagerie, nous pouvons être amenés à vous contacter pour vous demander des données supplémentaires qui nous aideront à résoudre un problème. Dans certains cas, vous pouvez également avoir l'opportunité d'effectuer le suivi de votre rapport d'erreurs. Si vous choisissez d'effectuer le suivi d'une erreur, votre rapport est associé à votre adresse de messagerie.

Utilisation des informations :

Ces données sont utilisées pour diagnostiquer et résoudre les problèmes des clients et pour améliorer la qualité des logiciels et services Microsoft.

Choix/contrôle :

Chaque fois qu'une erreur se produit dans un composant SQL Server avec une interface utilisateur, un rapport est généré et il vous est demandé si vous voulez l'envoyer à Microsoft. Vous avez la possibilité d'examiner les informations contenues dans le rapport d'erreurs avant de décider de l'envoyer.

Les clients d'entreprises peuvent utiliser une stratégie de groupe pour configurer le comportement du rapport d'erreurs sur leurs ordinateurs. Les options de configuration comprennent la possibilité de désactiver entièrement le rapport d'erreurs. Pour plus d'informations sur la configuration d'une stratégie de groupe pour Rapport d'erreurs pour les administrateurs, consultez le site TechNet de Windows Server 2003. Pour plus d'informations sur les détails techniques relatifs à Windows Server 2008, consultez le Guide de planification et de déploiement de la stratégie de groupe.

Informations importantes :

Pour plus d'informations sur les données collectées et leur utilisation, consultez la Déclaration de confidentialité du service de rapport d'erreurs Microsoft.

Rapports d'erreurs et d'utilisation

Objet de cette fonctionnalité :

La fonctionnalité de rapport d'erreurs vous permet d'envoyer automatiquement des rapports d'erreur à Microsoft pour les composants et serveurs SQL Server qui n'ont pas d'interface utilisateur et s'exécutent en arrière-plan, tels que le moteur de base de données SQL Server, SQL Agent, Analysis Services, Reporting Services, Notification Services, la réplication SQL, le composant Assistant Paramétrage de base de données, le service SQL Browser et SQL Writer (« Services d'arrière-plan »). Si vous y consentez, la fonctionnalité de rapport d'erreurs vous permet de signaler automatiquement les problèmes qui peuvent se poser avec les Services d'arrière-plan à Microsoft et de recevoir des informations qui peuvent vous aider à contourner ou résoudre de tels problèmes.

La fonctionnalité de rapport d'utilisation vous permet d'envoyer automatiquement des informations liées à l'utilisation à Microsoft. Si vous y consentez, la fonctionnalité de rapport d'utilisation collectera et enverra à Microsoft des informations sur votre configuration matérielle et les fonctionnalités SQL Server utilisées sur ce matériel, afin que nous puissions identifier les tendances et les modes d'utilisation.

Informations collectées, traitées ou transmises :

La fonctionnalité de rapport d'erreurs de SQL Server collecte les mêmes types d'informations que les rapports d'erreurs individuels. Elle collecte en outre des informations complètes propres à l'utilisation au moment où l'erreur survient, qui comprennent par exemple les caractéristiques de l'ordinateur (vitesse de l'UC, nombre de processeurs, etc.), la pile des appels des threads défaillants (ou de tous les threads pour certains types d'erreurs), les plans d'exécution et d'autres données d'exécution, ainsi que des informations sur les fichiers ouverts. Elle peut aussi collecter des informations d'historique sur le comportement du système d'exploitation et de SQL Server, et, pour certains types d'erreurs, le contenu de pages de données. Il est possible que des renseignements permettant de vous identifier personnellement soient conservés en mémoire ou dans les données collectées dans des fichiers ouverts, mais ils ne sont pas utilisés par Microsoft pour vous identifier. Contrairement aux rapports d'erreurs individuels décrits plus haut, la fonctionnalité de rapport d'erreurs ne permet pas de passer en revue les informations des rapports qu'elle génère avant leur envoi.

La fonctionnalité de rapport d'utilisation collecte des informations sur votre configuration matérielle, les fonctionnalités qui sont installées et utilisées par chacun des produits SQL Server installés sur ce matériel et le fonctionnement de celles-ci. Microsoft ne collecte ni votre nom, ni votre adresse, ni aucune autre information permettant de vous contacter. Cette fonctionnalité génère également un GUID qui est stocké sur votre ordinateur pour l'identifier de manière unique. Le GUID est un nombre généré de manière aléatoire ; il ne contient aucune information personnelle et ne sera pas utilisé pour vous identifier.

Utilisation des informations :

Les données envoyées par les rapports d'erreurs et d'utilisation sont utilisées pour localiser et résoudre les problèmes rencontrés par les utilisateurs, et pour contribuer à améliorer les produits de Microsoft. Les rapports d'utilisation sont employés par le Programme d'amélioration du produit, qui nous aide à améliorer nos logiciels. En participant à ce programme, vous influencez directement le mode de conception de nos logiciels.

Choix/contrôle :

Lors de l'installation, vous aurez l'opportunité d'envoyer automatiquement des rapports d'erreurs et d'utilisation à Microsoft. Pour les versions préliminaires de SQL Server, la fonctionnalité Rapport d'erreurs est activée par défaut. Pour activer ou désactiver ces fonctionnalités ultérieurement, employez l'outil de rapports d'erreurs et d'utilisation, qui est disponible en cliquant dans le menu Démarrer sur Programmes, sur SQL Server 2005, sur Outils de configuration, puis sur Rapports d'erreurs et d'utilisation SQL Server.

Les clients d'entreprises peuvent utiliser une stratégie de groupe pour configurer le comportement de la fonctionnalité de rapport d'erreurs sur leurs ordinateurs. Les options de configuration comprennent la possibilité de désactiver entièrement le rapport d'erreurs. Pour plus d'informations sur la configuration d'une stratégie de groupe pour Rapport d'erreurs pour les administrateurs, consultez le site TechNet de Windows Server 2003. Pour plus d'informations sur les détails techniques relatifs à Windows Server 2008, consultez Guide de planification et de déploiement de la stratégie de groupe

Informations importantes :

Certains rapports d'erreurs peuvent être envoyés à Microsoft même si vous choisissez de ne pas utiliser la fonctionnalité de rapport d'erreur de SQL Server si vous avez configuré Windows pour qu'il utilise le Rapport d'erreur Microsoft.

Documentation en ligne de SQL Server : fonctionnalité de commentaires sur le contenu

Objet de cette fonctionnalité :

Pour chaque rubrique d'aide de la documentation en ligne de SQL Server, vous pouvez fournir des commentaires à l'équipe chargée de la documentation de SQL Server pour leur indiquer si le contenu vous a été ou non utile. Au bas de chaque rubrique d'aide figure la question « Ces informations vous ont-elles été utiles ? ». Si vous cliquez sur le bouton Oui ou sur le bouton Non, un message électronique est généré dans votre client de messagerie et la ligne Objet de ce message est automatiquement renseignée avec des informations relatives au contenu que vous commentez. Vous pouvez ajouter des commentaires spécifiques concernant le contenu dans le corps de ce message électronique.

Informations collectées, traitées ou transmises :

Pour fournir à l'équipe chargée de la documentation de SQL Server les informations de contexte nécessaires relativement à vos commentaires, la ligne Objet du message électronique des commentaires contiendra certaines ou l'ensemble des informations suivantes : titre de rubrique, nom du produit, version du produit, version de la documentation, nom du fichier d'aide, URL de rubrique, note d'évaluation de la rubrique (qui varie selon que vous avez cliqué sur Oui ou sur Non), type du fichier d'aide (.chm ou .hxs), langue utilisée (par exemple, le français) et numéro de version du script des commentaires de l'aide. Notez que, si la rubrique d'aide est au format .chm, le chemin d'installation du fichier d'aide sur votre ordinateur peut également être inclus.

Utilisation des informations :

Les informations que vous fournissez sont utilisées par l'équipe chargée de la documentation de SQL Server afin d'apporter des corrections ou améliorations à la documentation qui accompagne SQL Server.

Choix/contrôle :

Le message électronique des commentaires n'est pas généré tant que vous n'avez pas cliqué sur Oui ou sur Non, et il n'est pas envoyé à Microsoft tant que vous n'avez pas cliqué sur Envoyer dans votre client de messagerie.

Informations importantes :

Votre adresse de messagerie ne sera pas utilisée à des fins de marketing sans votre accord préalable.

Documentation en ligne de Microsoft SQL Server : paramètres de contenu en ligne pour l'aide

Objet de cette fonctionnalité :

La fonctionnalité de contenu en ligne vous permet d'interroger automatiquement des sites Web en ligne lorsque vous effectuez une recherche, y compris le site Web MSDN Online de Microsoft et les sites Web de communauté tiers. En outre, en appuyant sur la touche F1 des mots clés de langage dans la fenêtre de code, vous pouvez obtenir en réponse des informations provenant de ces mêmes sites Web.

Informations collectées, traitées ou transmises :

Afin de retourner des résultats pertinents, la fonctionnalité de contenu en ligne transmet à MSDN Online (et à tout site Web tiers que vous désignez dans l'option de contenu en ligne) des informations qui incluent les informations standard sur l'ordinateur, la chaîne de texte de recherche entrée ou les mots clés associés au mot clé de langage de la touche F1 sur laquelle vous avez appuyé, et les sources dans lesquelles effectuer la recherche (telles que MSDN Online).

Utilisation des informations :

Les informations sont utilisées pour répondre à la requête de recherche ou à l'utilisation de la touche F1. Microsoft utilise également ces informations pour développer un nouveau contenu et réviser le contenu existant.

Choix/contrôle :

Par défaut, SQL Server recherche l'aide uniquement sur votre ordinateur. Aucune information n'est envoyée à Microsoft si vous ne décidez pas d'utiliser le paramètre d'utilisation du contenu en ligne. Pour choisir vos paramètres de recherche :

  1. Dans la documentation en ligne, sélectionnez Outils, Options, puis sous Aide, sélectionnez En ligne.

  2. Sélectionnez l'une des trois options suivantes : Essayer d'utiliser le contenu local uniquement et non le contenu en ligne, Essayer d'utiliser le contenu local avant le contenu en ligne ou Essayer d'utiliser le contenu en ligne avant le contenu local.

  3. Dans la zone Rechercher chez ces fournisseurs, vous pouvez sélectionner ou désélectionner n'importe quel fournisseur et, à l'aide des flèches vers le haut et vers le bas, vous pouvez définir l'ordre d'utilisation des fournisseurs.

  4. Cliquez sur OK.

Informations importantes :

Cette divulgation couvre uniquement les interactions avec MSDN Online ; la façon dont d'autres sites Web désignés collectent et utilisent les informations de recherche dépend du site particulier sélectionné. Pour plus d'informations sur la politique de confidentialité de MSDN Online, consultez la déclaration de confidentialité de Microsoft Online.

Utilisation de Microsoft Bing Maps avec SQL Server Reporting Services
Objet de cette fonctionnalité :

SQL Server Reporting Services vous permet de créer des rapports qui s'intègrent à Microsoft Bing Maps. Pour activer cette fonction, certaines informations sont envoyées de votre serveur vers le service Web Bing Maps.

Informations collectées, traitées ou transmises :

Si vous configurez SQL Server avec votre ID Bing Maps, cet ID sera envoyé à Bing Maps avec vos demandes de données chaque fois vous exécuterez un rapport qui utilise la fonctionnalité Bing Maps.

Utilisation des informations :

Microsoft utilise ces informations pour faire fonctionner et améliorer Microsoft Bing Maps et d'autres sites et services Microsoft. Pour plus d'informations, consultez la Déclaration de confidentialité de Microsoft Online.

Choix/contrôle :

Par défaut, un identificateur unique n'est pas envoyé avec les demandes à Microsoft Bing Maps. Consultez votre documentation SQL Server pour savoir comment ajouter votre ID Bing Maps à votre configuration SQL Server.


Mentions légales relatives à la documentation

Mentions légales relatives à la documentation
Vue d'ensemble de la documentation d'installation de SQL Server >

Le présent document porte sur la version commerciale définitive du logiciel « SQL Server 2008 R2 ». Ce document est confidentiel et demeure la propriété de Microsoft Corporation.

Il est fourni « en l'état ». Les informations et les opinions exprimées dans ce document, y compris les adresses URL et les autres références à des sites Internet, peuvent faire l'objet de modifications sans préavis. Vous assumez tous les risques liés à son utilisation. Certains exemples mentionnés dans ce documents ne sont fournis qu'à titre indicatif et sont fictifs. Toute ressemblance ou similitude avec des éléments réels est purement fortuite et involontaire.

Ce document ne vous concède aucun droit de propriété intellectuelle portant sur les produits Microsoft. Vous pouvez copier et utiliser ce document à titre de référence pour un usage interne.

© 2010 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server et Windows Vista sont des marques du groupe Microsoft.

SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

Documentation - Stratégie de support et de mise à niveau

La documentation de Microsoft SQL Server 2008 R2 inclut la documentation en ligne de SQL Server, les fichiers Lisez-moi, les documents relatifs aux problèmes connus, les exemples de code et d'applications, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux fonctions et fonctionnalités SQL Server (l'ensemble de la « Documentation »). Le résumé ci-dessous décrit la stratégie de support et de mise à niveau pour certaines fonctions et fonctionnalités référencées dans la Documentation.

Exemples. Les exemples présentés dans cette Documentation servent principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Le support technique de Microsoft n'est pas disponible pour les exemples contenus dans la Documentation.

Espaces réservés. Dans certains cas, une fonctionnalité particulière de SQL Server 2008 R2 n'a pas été suffisamment testée ou développée pour être utilisée. Ces fonctionnalités sont souvent répertoriées dans la documentation en ligne, un fichier Lisez-moi ou toute autre Documentation sous forme d'espaces réservés et sont fournies à titre de notations pour une utilisation interne par Microsoft. Elles ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Toute tentative d'utilisation de ces fonctionnalités peut provoquer une perte de données.

Contenu tiers. Sauf spécification contraire de la Documentation, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec SQL Server 2008 R2, n'est pas pris en charge par le support technique de Microsoft.

Points d'entrée non documentés. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent des points d'entrée non documentés comme les API non documentées, y compris, entre autres, les éléments suivants : procédures stockées, procédures stockées étendues, fonctions, vues, tables, colonnes, propriétés ou métadonnées. Une telle utilisation peut provoquer une perte de données.

Mises à niveau. Les mises à niveau de serveur et de base de données vers les versions ultérieures de SQL Server 2008 R2 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge par le support technique de Microsoft.

Pour plus d'informations sur la stratégie de cycle de vie du support technique de Microsoft, visitez le site Web à l'adresse suivante : http://support.microsoft.com/lifecycle.


Considérations relatives aux licences de SQL Server 2008 R2

Considérations relatives aux licences de SQL Server 2008 R2 |
 | Voir aussi
Vue d'ensemble de la documentation d'installation de SQL Server >

Pour plus d'informations sur les options de licences de SQL Server, consultez ce site Web de Microsoft SQL Server.

Voir aussi

Référence

À propos des termes du contrat de licence SQL Server

Concepts

Déclaration de confidentialité de SQL Server 2008 R2
Mentions légales relatives à la documentation


Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server |
 | Voir aussi

Une installation de SQL Server se compose d'une ou de plusieurs instances distinctes. Une instance, qu'elle soit par défaut ou nommée, possède son propre jeu de fichiers programmes et de fichiers de données, ainsi qu'un ensemble de fichiers communs partagés entre toutes les instances de SQL Server présentes sur l'ordinateur.

Pour une instance SQL Server qui inclut le moteur de base de données, Analysis Services et Reporting Services, chaque composant a un jeu complet de fichiers de données et de fichiers exécutables, ainsi que des fichiers communs partagés par tous les composants.

Pour isoler l'emplacement d'installation de chaque composant, un ID d'instance unique est généré pour chaque composant d'une instance SQL Server donnée.

Important :
Les fichiers programmes et les fichiers de données ne peuvent pas être installés sur un lecteur de disque amovible, dans un système de fichiers utilisant la compression, dans un répertoire où figurent des fichiers système ni sur des lecteurs partagés sur une instance de cluster de basculement.

Vous ne devez supprimer ni les répertoires suivants ni leur contenu : Binn, Data, Ftdata, HTML ou 1033. Si besoin est, vous pouvez supprimer d'autres répertoires mais il est possible que vous ne puissiez pas récupérer certaines fonctionnalités ou données sans désinstaller puis réinstaller SQL Server. Ne supprimez pas et ne modifiez pas les fichiers .htm se trouvant dans le répertoire HTML. Ils sont nécessaires pour que les outils de SQL Server fonctionnent correctement.

Fichiers partagés pour toutes les instances SQL Server

Les fichiers communs utilisés par toutes les instances d'un même ordinateur sont installés dans le dossier <lecteur>:\Program Files\Microsoft SQL Server\100\, <drive> désignant la lettre du lecteur sur lequel les composants sont installés. La valeur par défaut est généralement le lecteur C.

Emplacements des fichiers et mappage du Registre

Au cours de l'installation de SQL Server, un ID d'instance est généré pour chaque composant serveur. Les composants de cette version SQL Server sont le moteur de base de données, Analysis Services et Reporting Services.

L'ID d'instance par défaut est construit à l'aide du format suivant :

  • MSSQL pour le moteur de base de données, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

  • MSAS pour Analysis Services, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

  • MSRS pour Reporting Services, suivi du numéro de version principale, puis d'un trait de soulignement et du numéro de version secondaire, le cas échéant, puis d'un point et du nom de l'instance.

Voici quelques exemples d'ID d'instance par défaut dans cette version de SQL Server 2008 R2 :

  • MSSQL10_50.MSSQLSERVER pour une instance par défaut de SQL Server 2008 R2.

  • MSAS10_50.MSSQLSERVER pour une instance par défaut de Analysis Services.

  • MSSQL10_50.MyInstance pour une instance nommée de SQL Server 2008 R2 intitulée « MyInstance ».

La structure de répertoire pour une instance nommée de SQL Server 2008 R2 incluant moteur de base de données et Analysis Services, intitulée « MyInstance » et installée sur les répertoires par défaut se présenterait de la façon suivante :

  • C:\Program Files\Microsoft SQL Server\MSSQL10_50.MyInstance\

  • C:\Program Files\Microsoft SQL Server\MSASSQL10_50.MyInstance\

Vous pouvez spécifier n'importe quelle valeur pour l'ID d'instance, mais évitez les caractères spéciaux et les mots clé réservés. Pour plus d'informations, consultez Mots clés réservés (programme d'installation).

Vous pouvez spécifier un ID d'instance non défini par défaut pendant l'installation de SQL Server. Si l'utilisateur choisit de changer de répertoire d'installation par défaut, un <chemin personnalisé>\Microsoft SQL Server est utilisé à la place de <Program Files>\Microsoft SQL Server. Notez que les ID d'instance qui commencent avec un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Remarque :
Integration Services et les composants clients ne sont pas dépendants d'une instance et, par conséquent, ne se voient pas attribuer d'ID d'instance. Par défaut, les composants ne dépendant pas d'une instance sont installés dans un répertoire unique : <lecteur>:\Program Files\Microsoft SQL Server\100\. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placent des composants ne prenant pas en charge les instances dans le même répertoire que celui prévu par l'installation d'origine.

SQL Server Analysis Services est le seul composant SQL Server qui prend en charge l'attribution d'un nouveau nom à une instance après l'installation. Si une instance de Analysis Services est renommée, l'ID d'instance ne change pas. Une fois l'attribution du nouveau nom de l'instance terminée, les répertoires et les clés de Registre continuent à utiliser l'ID d'instance créé pendant l'installation.

La ruche du Registre est créée sous HKLM\Software\Microsoft\Microsoft SQL Server\<ID_instance> pour les composants qui prennent les instances en charge. Par exemple :

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10_50.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSASSQL10_50.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

Le Registre maintient également le mappage d'un ID d'instance sur un nom d'instance. Le mappage de l'ID d'instance sur le nom d'instance se maintient comme suit :

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL10_50"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="MSASSQL10_50"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="MSRSSQL10_50"

Spécification des chemins d'accès des fichiers

Pendant l'installation, vous pouvez modifier le chemin d'installation des fonctionnalités suivantes :

Ce chemin d'installation s'affiche uniquement dans le programme d'installation pour les fonctionnalités dotées d'un dossier de destination configurable par l'utilisateur.

Composant | Chemin d'accès par défaut1, 2 | Chemin configurable ou fixe3
Composants serveur du moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\ | Configurable
Fichiers de données du moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\ | Configurable
Serveur Analysis Services | \Program Files\Microsoft SQL Server\MSAS10_50.<ID_instance>\ | Configurable
Fichiers de données d'Analysis Services | \Program Files\Microsoft SQL Server\MSAS10_50.<ID_instance>\ | Configurable
Serveur de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS10_50.<ID_instance>\Reporting Services\ReportServer\Bin\ | Configurable
Gestionnaire de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS10_50.<ID_instance>\Reporting Services\ReportManager\ | Chemin fixe
Integration Services | <Répertoire d'installation>\100\DTS\ | Configurable4
Composants clients | <Répertoire d'installation>\100\Tools\ | Configurable4
Objets COM côté serveur et de réplication | <lecteur>:\Program Files\Microsoft SQL Server\100\COM\5 | Chemin fixe
DLL des composants Integration Services pour le moteur d'exécution de transformation des données, le moteur pipeline de transformation des données et l'utilitaire d'invite de commandes dtexec | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\Binn | Chemin fixe
DLL qui assurent la prise en charge de connexions managées pour Integration Services | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\Connections | Chemin fixe
DLL pour chaque type d'énumérateur que Integration Services prend en charge | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\ForEachEnumerators | Chemin fixe
Service SQL Browser SQL Server, fournisseurs WMI | <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\ | Chemin fixe
Composants qui sont partagés entre toutes les instances SQL Server | <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\ | Chemin fixe

1Vérifiez que le dossier \Program Files\Microsoft SQL Server\ est protégé par des autorisations limitées.

2 Le lecteur par défaut de ces emplacements est systemdrive, en général le lecteur C.

3Les chemins d'installation des composants enfants sont déterminés par le chemin d'installation de la fonctionnalité parente.

4Un chemin d'installation unique est partagé par Integration Services et les composants clients. La modification du chemin d'installation d'un composant affecte également les autres composants. En effet, les installations ultérieures placent les composants dans l'emplacement prévu par l'installation d'origine.

5Ce répertoire est utilisé par toutes les instances de SQL Server sur un ordinateur. Si vous effectuez une mise à jour sur l'une des instances situées sur l'ordinateur, toute modification apportée aux fichiers de ce dossier affecte toutes les instances de l'ordinateur. Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité. Vous devez soit installer les fonctionnalités supplémentaires dans les répertoires déjà établis par le programme d'installation, soit désinstaller et réinstaller le produit.

Remarque :
Pour les configurations en cluster, vous devez sélectionner un lecteur local disponible sur chaque nœud du cluster.

Lorsque, pendant l'installation, vous indiquez un chemin d'installation pour les composants serveur ou les fichiers de données, le programme d'installation utilise l'ID de l'instance, en plus de l'emplacement spécifié pour les fichiers programmes et les fichiers de données. Le programme d'installation n'utilise pas l'ID d'instance pour les outils et les autres fichiers partagés. S'il ne l'utilise pas non plus pour les fichiers programmes et les fichiers de données de Analysis Services, il l'utilise en revanche pour le référentiel de Analysis Services.

Si vous définissez le chemin d'installation de la fonctionnalité du moteur de base de données, le programme d'installation de SQL Server utilise ce chemin comme répertoire racine de tous les dossiers spécifiques à l'instance pour cette installation, y compris les fichiers de données SQL. Dans ce cas, si vous définissez comme racine « C:\Program Files\Microsoft SQL Server\MSSQL10_50\MSSQL\ », les répertoires spécifiques à l'instance sont ajoutés à la fin du chemin.

Les clients qui choisissent d'utiliser la fonctionnalité de mise à niveau USESYSDB dans l'Assistant Installation de SQL Server (mode d'interface utilisateur du programme d'installation) peuvent aisément se trouver dans une situation où le produit est installé dans une structure de dossiers récursive. Par exemple, <SQLProgramFiles>\MSSQL10_50\MSSQL\MSSQL10_50\MSSQL\Data\. Pour utiliser la fonctionnalité USESYSDB, il est donc conseillé de définir un chemin d'installation pour la fonctionnalité fichiers de données SQL au lieu de la fonctionnalité du moteur de base de données.

Remarque :
Les fichiers de données se situent généralement dans un répertoire enfant nommé « Data ». Par exemple, spécifiez C:\Program Files\Microsoft SQL Server\MSSQL10_50\ comme chemin d'accès racine au répertoire de données des bases de données système durant la mise à niveau lorsque les fichiers de données se trouvent sous C:\Program Files\Microsoft SQL Server\MSSQL10_50\MSSQL\Data.

Voir aussi

Référence

Configuration du moteur de base de données – Répertoires de données
Configuration de Analysis Services – Répertoires de données


Procédure : afficher et lire les fichiers journaux d'installation de SQL Server

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server |
 | Voir aussi

La journalisation du programme d'installation de SQL Server a changé dans cette version.

Chaque fois que le programme d'installation est exécuté, des fichiers journaux sont créés dans un nouveau dossier de journal horodaté à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\. Le format du nom du dossier de journal horodaté est AAAAMMJJ_hhmmss. Lorsque le programme d'installation est exécuté en mode sans assistance, les journaux sont créés à l'emplacement % temp%\sqlsetup*.log. Tous les fichiers du dossier de journal sont archivés dans le fichier Log*.cab dans leur dossier de journal respectif.

Une demande d'Installation typique passe par trois phases d'exécution :

  1. Texte de règles globales

  2. Mise à jour du composant

  3. Action demandée par l'utilisateur

Dans chaque phase, le programme d'installation génère des journaux résumés et détaillés, ainsi que des journaux supplémentaires si besoin est. Le programme d'installation est appelé au moins trois fois par action d'installation demandée par l'utilisateur.

Les fichiers de banque de données contiennent une capture instantanée de l'état de tous les objets de configuration qui sont suivis par le processus d'installation et qui sont utiles pour réparer les erreurs de configuration. Des vidages de fichiers XML sont créés pour les objets de banque de données pour chaque phase d'exécution. Ils sont enregistrés dans leur propre sous-dossier de journal sous le dossier de journal horodaté, comme suit :

  • Datastore_GlobalRules

  • Datastore_ComponentUpdated

  • Datastore

Les sections suivantes décrivent les fichiers journaux d'installation de SQL Server.

Texte de résumé

Vue d'ensemble

Ce fichier montre les composants SQL Server détectés au cours de l'installation, l'environnement du système d'exploitation, les valeurs des paramètres de ligne de commande (si elles sont spécifiées) et l'état d'ensemble de chaque fichier MSI/MSP exécuté.

Le journal comprend les sections suivantes :

  • un résumé d'ensemble de l'exécution ;

  • les propriétés et la configuration de l'ordinateur sur lequel le programme d'installation de SQL Server a été exécuté ;

  • les fonctionnalités du produit SQL Server précédemment installées sur l'ordinateur ;

  • la description des propriétés de la version d'installation et du package d'installation ;

  • les paramètres d'entrée d'exécution fournis au cours de l'installation ;

  • l'emplacement du fichier de configuration ;

  • les détails des résultats d'exécution ;

  • les règles globales ;

  • les règles spécifiques au scénario d'installation ;

  • les règles ayant échoué ;

  • l'emplacement du fichier du rapport de règles.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\.

Pour trouver les erreurs dans le fichier texte résumé, recherchez les mots clés « error » ou « failed » dans le fichier.

Summary_engine-base_YYYYMMDD_HHMMss.txt

Vue d'ensemble

Le fichier de base summary_engine est semblable au fichier résumé et est généré au cours du flux de travail principal.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Summary_engine-base_YYYYMMDD_HHMMss_ComponentUpdate.txt

Vue d'ensemble

Le fichier journal résumé de mise à jour des composants est semblable au fichier résumé et est généré au cours du flux de travail de mise à jour des composants.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Summary_engine-base_20080503_040551_GlobalRules.txt

Vue d'ensemble

Le fichier journal résumé des règles globales est semblable au fichier résumé généré au cours du flux de travail des règles globales.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Detail.txt

Vue d'ensemble

Detail.txt est généré pour le flux de travail principal, par exemple l'installation ou la mise à niveau, et fournit les détails de l'exécution. Les journaux dans le fichier sont générés en fonction de l'heure à laquelle chaque action pour l'installation a été appelée, et indiquent l'ordre dans lequel les actions ont été exécutées et leurs dépendances.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup.

Bootstrap\Log\<AAAAMMJJ_HHMM>\Detail.txt.

Si une erreur se produit au cours du processus d'installation, l'exception ou l'erreur est journalisée à la fin de ce fichier. Pour trouver les erreurs dans ce fichier, examinez d'abord la fin du fichier, puis lancez une recherche sur les mots clés « error » ou « exception » dans le fichier.

Detail_ComponentUpdate.txt

Vue d'ensemble

Le fichier Detail_ComponentUpdate.txt est généré pour le flux de travail de mise à jour des composants et est semblable au fichier Detail.txt.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Detail_GlobalRules.txt

Vue d'ensemble

Le fichier Detail_GlobalRules.txt est généré pour l'exécution des règles globales et est semblable au fichier Detail.txt.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Fichiers journaux MSI

Vue d'ensemble

Les fichiers journaux MSI fournissent des détails sur le processus du package d'installation. Ils sont générés par le programme MSIEXEC lors de l'installation du package spécifié.

Types de fichiers journaux MSI :

  • <Fonctionnalité>_<Architecture>_<Itération>.log

  • <Fonctionnalité>_<Architecture>_<Langue>_<Itération>.log

  • <Fonctionnalité>_<Architecture>_<Itération>_<Flux de travail>.log

Emplacement

Les fichiers journaux MSI se trouvent à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\<Nom>.log.

À la fin du fichier se trouve un résumé de l'exécution qui indique l'état de réussite ou d'échec et les propriétés. Pour trouver l'erreur dans le fichier MSI, recherchez « value 3 ». Les erreurs se trouvent généralement à proximité de cette chaîne.

ConfigurationFile.ini

Vue d'ensemble

Le fichier de configuration contient les paramètres d'entrée fournis au cours de l'installation. Vous pouvez l'utiliser pour redémarrer l'installation sans entrer les paramètres manuellement. Toutefois, les mots de passe pour les comptes, PID et certains paramètres ne sont pas enregistrés dans le fichier de configuration. Les paramètres peuvent être soit ajoutés au fichier, soit fournis à l'aide de la ligne de commande ou de l'interface utilisateur du programme d'installation. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 R2 à l'aide d'un fichier de configuration.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

SystemConfigurationCheck_Report.htm

Vue d'ensemble

Le rapport de vérification de la configuration du système contient une brève description de chaque rôle exécuté et de l'état d'exécution.

Emplacement

Il se trouve à l'emplacement %programfiles%\Microsoft SQL Server\100\Setup Bootstrap\Log\<AAAAMMJJ_HHMM>\.

Voir aussi

Concepts

Dépannage d'une installation de SQL Server


Dépannage d'une installation de SQL Server

Dépannage d'une installation de SQL Server |
 | Voir aussi

Pour consulter des informations de résolution des problèmes à propos de l'installation et des problèmes de mise à niveau, consultez le fichier Readme de SQL Server 2008 R2.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Guide de référence de l'interface utilisateur du programme d'installation de SQL Server

Guide de référence de l'interface utilisateur du programme d'installation de SQL Server

Cette section décrit les options d'installation proposées par l'Assistant Installation de SQL Server.


Accepter les termes du contrat de licence

Accepter les termes du contrat de licence |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Accepter les termes du contrat de licence de l'Assistant Installation de SQL Server pour accepter les termes du contrat de licence de cette version de SQL Server.

Vous pouvez imprimer le contrat de licence ou le copier dans le Presse-papiers. Pour continuer, acceptez le contrat de licence, puis cliquez sur Suivant. Pour quitter l'installation, cliquez sur Annuler.

Création de rapports sur l'utilisation des fonctionnalités

Si vous activez la création de rapports sur l'utilisation des fonctionnalités, SQL Server est configuré pour envoyer régulièrement un rapport à Microsoft. Ces rapports incluent des informations sur votre configuration matérielle et sur la façon dont vous utilisez SQL Server et les composants. Microsoft utilise les données d'utilisation des fonctionnalités pour améliorer SQL Server. Les composants suivants font partie des composants SQL Server analysés :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Business Intelligence Development Studio

  • Programme d'installation de SQL Server

Les informations sur l'utilisation des fonctionnalités sont envoyées à Microsoft, puis stockées avec un accès limité.

Pour désactiver la création de rapports sur l'utilisation des fonctionnalités une fois l'installation terminée, utilisez l'outil Rapports d'erreurs et d'utilisation SQL Server dans le menu Outils de configuration de SQL Server.

Pour les actions du programme d'installation, telles que l'installation, la mise à niveau, la réparation, entre autres, les informations sont recueillies et téléchargées uniquement pendant l'exécution du programme d'installation

Pour tous les autres composants SQL Server, les informations sont recueillies une fois par jour pour toutes les instances activées de SQL Server. Par défaut, la collecte est effectuée à minuit afin de réduire la charge sur le serveur. Si vous souhaitez changer l'heure de la collecte, vous pouvez modifier manuellement la clé du Registre concernée. Chaque instance de SQL Server possède sa propre clé de Registre :

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10_50.<ID_instance>\CPE\TimeofReporting

La valeur de cette clé de Registre inclut l'heure de la collecte ainsi que le nombre de minutes qui s'écoulent à partir de 00:00 (minuit). Par exemple, la valeur 60 fixe l'exécution de la collecte à 1:00 a.m., la valeur 1200 fixe l'exécution de la collecte à 8:00 p.m., et ainsi de suite.

Voir aussi

Référence

À propos des termes du contrat de licence SQL Server


Ajouter un nœud de cluster de basculement SQL Server

Ajouter un nœud de cluster de basculement SQL Server |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.

Voir aussi

Référence

Règles de support du programme d'installation


Configuration Analysis Services – Mise en service de compte

Configuration Analysis Services – Mise en service de compte |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration d'Analysis Services de l'Assistant Installation de SQL Server pour accorder des autorisations administratives aux utilisateurs ou services qui requièrent un accès non restreint à Analysis Services.

Si vous installez PowerPivot pour SharePoint, accordez des autorisations administratives aux administrateurs de batterie de serveurs SharePoint ou aux administrateurs de service qui sont responsables d'un déploiement de SQL Server PowerPivot pour SharePoint dans une batterie de serveurs SharePoint 2010.

Remarque :
Dans un déploiement PowerPivot pour SharePoint, une application de service PowerPivot requiert des autorisations administratives sur le service Analysis Services pour prendre en charge la communication serveur et les fonctions coordonnées. Les autorisations administratives sont accordées automatiquement lorsque vous créez une application de service PowerPivot dans l'Administration centrale de SharePoint. Les autorisations administratives sont également accordées par le programme d'installation si vous installez PowerPivot pour SharePoint à l'aide de l'option Nouveau serveur. Pour plus d'informations sur les conditions requises pour l'installation et le compte de service, consultez Procédure : installer Analysis Services sur un nouveau serveur SharePoint.

Considérations relatives à la configuration de SQL Server

Amorcées dans SQL Server 2005, des modifications significatives ont été implémentées pour garantir que SQL Server était plus sécurisé que les versions antérieures. Les modifications incluaient une stratégie que l'on pourrait appeler « stratégie de sécurisation par conception, de sécurisation par défaut et de sécurisation dans le déploiement » et destinée à protéger l'instance du serveur et ses bases de données des attaques contre la sécurité.

SQL Server 2008 poursuit le processus de renforcement de la sécurité en apportant de nouvelles modifications aux composants du serveur et aux composants de base de données. Les modifications introduites dans SQL Server 2008 réduisent davantage la surface et les zones d'attaque du serveur et de ses bases de données en instituant une stratégie basée sur le principe des privilèges minimum et augmentent la séparation entre les administrateurs de Windows et l'administration de SQL Server. Cette stratégie signifie que les comptes internes sont protégés et séparés en deux catégories : les fonctions du système d'exploitation et les fonctions SQL Server. Ces mesures sont les suivantes :

  • Les nouvelles installations SQL Server 2008 n'ajoutent plus le groupe Windows local BUILTIN\Administrateurs au rôle serveur fixe sysadmin Analysis Services.

  • Possibilité de configurer un ou plusieurs serveurs principaux Windows dans le rôle serveur sysadmin dans SQL Server. Cette option est disponible durant l'installation de SQL Server pour les nouvelles installations de SQL Server 2008.

  • L'outil Configuration de la surface d'exposition a été supprimé et remplacé par une gestion basée sur des stratégies et des modifications de l'outil Gestionnaire de configuration SQL Server.

Ces modifications affectent votre plan de sécurité pour SQL Server et vous aident à créer un profil de sécurité plus complet pour votre système.

Considérations relatives à l'exécution de SQL Server 2008 sous Windows Vista et Windows Server 2008

Windows Vista et Windows Server 2008 incluent une nouvelle fonctionnalité, le contrôle de compte d'utilisateur, qui permet aux administrateurs de gérer les autorisations élevées qu'ils utilisent. Par défaut, dans Windows Vista et Windows Server 2008, les administrateurs n'utilisent pas leurs droits d'administration. À la place, ils effectuent la plupart des actions en tant qu'utilisateurs standard, n'assumant temporairement leurs droits d'administration que lorsque cela est nécessaire. Toutefois, au lieu d'élever des privilèges, nous recommandons la création d'un compte d'utilisateur Windows disposant des autorisations suffisantes pour effectuer toutes les tâches d'administration nécessaires.

Le Contrôle de compte d'utilisateur entraîne certains problèmes connus. Pour plus d'informations, consultez les pages Web suivantes :

  • Considérations relatives à l'exécution de SQL Server 2005 sous Windows Vista

  • Contrôle de compte d'utilisateur

  • Guide pas à pas du contrôle de compte d'utilisateur pour Windows Vista et Windows Server 2008

Options

Spécifiez les administrateurs Analysis Services - Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server.

  • Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur le bouton Ajouter l'utilisateur actuel.

  • Pour ajouter d'autres utilisateurs ou services, cliquez sur le bouton Ajouter… et entrez les comptes d'utilisateurs de domaine Windows pour la personne ou le service qui requiert des autorisations administratives.

  • Pour supprimer des comptes de la liste des administrateurs système, cliquez sur Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour cette instance de SQL Server.

Lorsque vous avez terminé de modifier la liste, cliquez sur OK, puis vérifiez la liste des administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

Voir aussi

Autres ressources

Configuration des comptes de service Windows
How to: Install Analysis Services on a Standalone SharePoint Server (en anglais)
Configuration du compte de service d'Analysis Services


Configuration de Analysis Services – Répertoires de données

Configuration de Analysis Services – Répertoires de données |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les répertoires par défaut indiqués dans le tableau suivant sont configurables par l'utilisateur pendant l'installation de SQL Server. Le tableau spécifie les répertoires par défaut à la fois pour les installations en mode natif et en mode intégré SharePoint. Toutes les installations d'Analysis Services en mode intégré SharePoint incluent le nom d'instance PowerPivot dans le nom du chemin d'accès.

Description | Répertoire par défaut | Recommandations
Répertoire de données racine | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_instance>\OLAP\Data\ - OU - C:\Program Files\Microsoft SQL Server\MSAS10_50.POWERPIVOT\OLAP\Data\ | Assurez-vous que le dossier \Program files\Microsoft SQL Server\ est protégé avec des autorisations limitées. Le fonctionnement de Analysis Services dépend, dans de nombreuses configurations, de la performance de l'emplacement de stockage sur lequel le répertoire de données se trouve. Placez ce répertoire sur l'emplacement de stockage le plus performant raccordé au système. Pour les installations de cluster de basculement, vérifiez que les répertoires de données sont placés sur le disque partagé.
Répertoire de fichiers journaux | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_instance>\OLAP\Log\ - OU - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Log\ | C'est le répertoire des fichiers journaux Analysis Services ; il inclut le journal FlightRecorder. Si vous augmentez la durée de la boîte noire, assurez-vous que le répertoire de journal dispose de l'espace adéquat.
Répertoire Temp | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_instance>\OLAP\Temp\ - OU - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Temp\ | Placez le répertoire Temp sur le sous-système de stockage le plus performant.
Répertoire de sauvegarde | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_instance>\OLAP\Backup\ - OU - C:\Program Files\Microsoft SQL Server\MSAS10_50.PowerPivot\OLAP\Backup\ | Il s'agit du répertoire pour les fichiers de sauvegarde par défaut Analysis Services. Sur une batterie de serveurs SharePoint, ce répertoire est utilisé pour mettre en cache des sources de données PowerPivot. Vérifiez que des autorisations appropriées sont définies pour empêcher la perte de données et vérifiez que le groupe d'utilisateurs pour le service Analysis Services a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.
Journaux de suivi SharePoint | C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Logs | Il s'agit du répertoire pour les journaux de suivi SharePoint. Les instances d'Analysis Services déployées sur une batterie de serveurs enregistreront des messages d'erreur et d'événement dans ce journal.

Remarques

  • Les instances d'Analysis Services déployées sur une batterie de serveurs SharePoint stockent des fichiers d'application, des fichiers de données et des propriétés dans les bases de données de contenu et les bases de données d'application de service.

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur des lecteurs partagés sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server

Autres ressources

Protection des fichiers programmes, des composants communs et des fichiers de données


Sélection du disque du cluster

Sélection du disque du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection du disque du cluster de l'Assistant Installation de SQL Server pour sélectionner la ressource de disque de cluster partagée pour votre cluster de basculement SQL Server. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Options

Disques partagés

Sélectionnez un disque dans la liste. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Un seul disque peut être spécifié. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affiche. Il est recommandé de ne pas procéder à l'installation dans cette ressource.

Disques partagés disponibles

Affiche une liste de disques disponibles, indique si chacun d'eux est qualifié en tant que disque partagé et fournit une description de chaque ressource de disque.


Sélection du réseau du cluster

Sélection du réseau du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection du réseau du cluster pour spécifier les ressources réseau de votre instance de cluster de basculement.

Options

Nom réseau du cluster de basculement SQL Server - Il s'agit du nom identifiant votre instance de cluster de basculement sur le réseau.

Paramètres réseau - Spécifiez le type IP et l'adresse IP de votre instance de cluster de basculement.


Configuration du nœud de clusters

Configuration du nœud de clusters
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du nœud de clusters pour ajouter ou supprimer des nœuds d'une instance de cluster de basculement. Notez que les opérations d'installation pour le clustering de basculement SQL Server ont été modifiées dans cette version finale. Pour installer ou mettre à niveau un cluster de basculement SQL Server, vous devez exécuter le programme d'installation sur chaque nœud du cluster de basculement. Pour ajouter un nœud à un cluster de basculement SQL Server existant, vous devez exécuter le programme d'installation de SQL Server sur le nœud destiné à être ajouté à l'instance de cluster de basculement SQL Server. N'exécutez pas l'installation sur le nœud actif.

Options

Nom de l'instance SQL Server - Utilisez la liste déroulante pour sélectionner l'instance de cluster de basculement SQL Server à modifier.

Nom de ce nœud - Ce champ contiendra le nom de l'ordinateur qui exécute le programme d'installation de SQL Server. Il s'agit du nœud de cluster de basculement qui sera ajouté ou supprimé de l'instance de cluster de basculement SQL Server.


Configuration du nœud de clusters (Complète)

Configuration du nœud de clusters (Complète)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du nœud de clusters (Complète) pour spécifier une instance existante de SQL Server préparée pour le clustering. Notez que les opérations d'installation pour le clustering de basculement SQL Server ont été modifiées dans cette version finale. Pour installer ou mettre à niveau un cluster de basculement SQL Server, vous devez exécuter le programme d'installation sur chaque nœud du cluster de basculement. Pour ajouter un nœud à un cluster de basculement SQL Server existant, vous devez exécuter le programme d'installation de SQL Server sur le nœud destiné à être ajouté à l'instance de cluster de basculement SQL Server. N'exécutez pas l'installation sur le nœud actif.

Options

Dans les zones de liste déroulante :

  • Nom de l'instance SQL Server — Sélectionnez le nom de l'instance pour le cluster de basculement SQL Server.

  • Nom de ce nœud — Ce champ est prérempli avec le nom de l'ordinateur où le programme d'installation de SQL Server s'exécute.

  • Nom réseau du cluster de basculement SQL Server— Ce champ n'est pas prérempli. Indiquez le nom réseau de la nouvelle instance de cluster de basculement SQL Server. Il s'agit du nom qui identifie l'instance de cluster de basculement sur le réseau.


Groupe de ressources de cluster

Groupe de ressources de cluster |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Groupe de ressources de cluster pour spécifier le disque où les ressources du serveur virtuel SQL Server seront hébergées.

Options

Spécifiez le nom du groupe de ressources de cluster SQL Server. vous avez le choix entre deux options :

  • Utilisez la zone de liste déroulante pour spécifier un groupe existant à utiliser.

  • Tapez le nom d'un groupe à créer. Notez que le nom « Stockage disponible » n'est pas un nom de groupe valide.

Voir aussi

Autres ressources

Procédure : créer un cluster de basculement SQL Server


Stratégie de sécurité du cluster

Stratégie de sécurité du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Stratégie de sécurité du cluster pour configurer la stratégie de sécurité pour votre instance de cluster de basculement.

Options

Spécifiez des groupes de domaines locaux ou globaux pour les services cluster. Toutes les autorisations de ressources sont gérées par des groupes au niveau du domaine qui incluent des comptes de service SQL Server en tant que membres de groupe. Pour plus d'informations sur les fonctionnalités des ID de sécurité (SID) d'un service sur Windows Server 2008, consultez Configuration des comptes de service Windows.

Si vous installez une instance de cluster de basculement SQL Server 2008 dans un domaine Windows 2000 en mode mixte, vous devez utiliser les groupes globaux de domaine pour les services cluster SQL Server.

Remarque :
Les contrôleurs de domaine Windows 2000 peuvent fonctionner en mode mixte et en mode natif. Le mode mixte autorise l'utilisation de contrôleurs de domaine de bas niveau dans le même domaine.


Finaliser - Finaliser l'image

Finaliser - Finaliser l'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Finaliser pour vérifier que la configuration de l'instance préparée est finalisée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour terminer l'installation, cliquez sur Fermer.


Progression de la finalisation d'image

Progression de la finalisation d'image |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression de la finalisation d'image de l'Assistant Installation de SQL Server pour contrôler l'état d'installation de la finalisation d'image SQL Server. À l'issue de cette étape, cette page répertorie l'état de chaque fonctionnalité SQL Server configurée et finalisée.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Règles de finalisation d'image

Règles de finalisation d'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server
MediaPathLength | Vérifie si le support d'installation SQL Server est trop long. | Vérifiez que le chemin d'accès du support d'installation SQL Server n'est pas trop long.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Le système d'exploitation doit être conforme à la configuration minimale requise pour ce produit. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Le service WMI doit être en cours d'exécution.
FacetDomainControllerCheck | Vérifie si l'ordinateur est un contrôleur de domaine. L'installation de SQL Server sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis de SQL Server Express with Advanced Services. | Pour les installations de SQL Server Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Permet de déterminer si le programme d'installation est pris en charge sur la plate-forme de système d'exploitation. | Cette règle bloquera toutes les installations non prises en charge sur une plateforme 64 bits. Les installations WOW ne sont pas prises en charge pour SysPrep.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur est requis en raison d'une bibliothèque ATL de fusion endommagée. Un redémarrage en attente peut provoquer l'échec de l'installation de SQL Server. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer l'ordinateur avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
IsFirewallEnabled | Vérifie si le Pare-feu Windows est activé. | Assurez-vous que le pare-feu est activé et que les ports appropriés sont ouverts pour permettre l'accès à distance. Pour plus d'informations sur les ports à ouvrir pour chaque fonctionnalité, consultez Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server
AS_ValidateEditionUpgrade | Vérifie si SQL Server Analysis Services est en cours de mise à niveau vers l'édition appropriée |
InstanceClashRule | Vérifie si le nom d'instance spécifié est déjà utilisé par une instance de SQL Server existante. | Utilisez un nom d'instance unique qui n'est actuellement pas utilisé par d'autres instances installées sur l'ordinateur.
LibertyASInstallRule | Vérifie si une instance par défaut de SQL Server 2000 (64 bits) Analysis Services est installée. |
Sql2005SsmsExpressFacet | Vérifie si SQL Server 2005 Express Edition Tools est installé. |
VSShellInstalledRule | Recherche les versions antérieures de Visual Studio 2008 ou l'existence de sa mise à niveau vers le Service Pack 1. | Vous devez effectuer la mise à niveau vers Visual Studio 2008 SP1 avant d'installer SQL Server 2008 R2.
EditionDownGradeCheck | Vérifie si l'édition de l'instance sélectionnée de SQL Server est prise en charge dans ce scénario. | Certaines éditions sont prises en charge pour la mise à niveau. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
EditionRequirementCheck | Vérifie si l'édition SQL Server est prise en charge sur ce système d'exploitation. | Vous devez confirmer que l'édition SQL Server que vous installez est prise en charge sur le système d'exploitation de cet ordinateur. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
EditionUpgradeMatrixCheck | Vérifie si l'instance sélectionnée de SQL Server répond aux besoins de la matrice de mise à niveau. | Certaines éditions sont prises en charge pour la mise à niveau. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
FAT32FileSystemCheck | Vérifie si le lecteur spécifié est un volume de système de fichiers FAT32. L'installation sur un système de fichiers FAT32 est prise en charge mais n'est pas recommandée car elle est moins sécurisée que le système de fichiers NTFS. | Vérifiez que le lecteur que vous spécifiez pour installer SQL Server n'est pas un système de fichiers FAT32.


Complète - Installation

Complète - Installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Cliquez sur Fermer pour terminer l'installation.

Voir aussi

Autres ressources

Validation d'une installation SQL Server

© 2010 Microsoft Corporation. Tous droits réservés.


Finaliser - Préparer l'image

Finaliser - Préparer l'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Finaliser pour vérifier que la préparation d'image est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour terminer la préparation d'image, cliquez sur Fermer.


Finaliser - Réparer

Finaliser - Réparer
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Finaliser - Réparer pour vérifier que la réparation est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour continuer, cliquez sur Fermer.


Complète - Mise à niveau

Complète - Mise à niveau
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Complète (Mise à niveau) pour vérifier que la mise à niveau est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour continuer, cliquez sur Fermer.


Informations d'identification pour la mise à niveau de base de données distante

Informations d'identification pour la mise à niveau de base de données distante |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Informations d'identification pour la mise à niveau de base de données distante de l'Assistant Installation de SQL Server pour spécifier une connexion à une base de données à une base de données du serveur de rapports distante.

Si vous mettez à niveau une base de données de serveur de rapports sur une instance Moteur de base de données distante et que vous exécutez le programme d'installation sous des informations d'identification qui n'ont pas d'autorisations de mise à jour de base de données sur une instance distante, vous devez entrer des informations d'identification que le programme d'installation peut utiliser pour se connecter à la base de données du serveur de rapports et la modifier.

Options

Nom d'utilisateur

Spécifie une connexion de base de données SQL Server utilisée de manière ponctuelle durant une opération de mise à niveau pour la connexion à l'instance du Moteur de base de données qui héberge la base de données du serveur de rapports. Le compte doit avoir l'autorisation de mettre à jour le schéma de base de données du serveur de rapports.

Requise si les informations d'identification que vous utilisez pour exécuter le programme d'installation ne disposent pas d'autorisations sysadmin ou de propriétaire de base de données sur la base de données du serveur de rapports.

Cette valeur doit être spécifiée si vous mettez à niveau un serveur de rapports qui utilise une base de données de serveur de rapports distante pour stocker des données d'application et que les informations d'identification que vous avez utilisées pour exécuter le programme d'installation ne disposent pas d'autorisations suffisantes sur le serveur distant.

Mot de passe

Mot de passe pour la connexion ou une chaîne vide si la connexion n'a pas de mot de passe.

Voir aussi

Autres ressources

Considérations sur la mise à niveau de Reporting Services
Considérations sur l'installation de Reporting Services


Configuration du moteur de base de données – Mise en service de compte

Configuration du moteur de base de données – Mise en service de compte |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Amorcées dans SQL Server 2005, des modifications significatives ont été implémentées pour garantir que SQL Server était plus sécurisé que les versions antérieures. Les modifications incluaient une stratégie que l'on pourrait appeler « stratégie de sécurisation par conception, de sécurisation par défaut et de sécurisation dans le déploiement » et destinée à protéger l'instance du serveur et ses bases de données des attaques contre la sécurité.

SQL Server 2008 poursuit le processus de renforcement de la sécurité en apportant de nouvelles modifications aux composants du serveur et aux composants de base de données. Les modifications introduites dans SQL Server 2008 réduisent davantage la surface et les zones d'attaque du serveur et de ses bases de données en instituant une stratégie basée sur le principe des privilèges minimum et augmentent la séparation entre les administrateurs de Windows et l'administration de SQL Server. Cette stratégie signifie que les comptes internes sont protégés et séparés en deux catégories : les fonctions du système d'exploitation et les fonctions SQL Server. Ces mesures sont les suivantes :

  • Les nouvelles installations SQL Server 2008 n'ajoutent plus le groupe Windows local BUILTIN\Administrateurs au rôle serveur fixe sysadmin SQL Server.

  • Possibilité de configurer un ou plusieurs principaux Windows dans le rôle serveur sysadmin dans SQL Server. Cette option est disponible durant l'installation de SQL Server pour les nouvelles installations de SQL Server 2008.

  • L'outil Configuration de la surface d'exposition a été supprimé et remplacé par une gestion basée sur des stratégies et des modifications de l'outil Gestionnaire de configuration SQL Server.

Ces modifications affectent votre plan de sécurité pour SQL Server et vous aident à créer un profil de sécurité plus complet pour votre système.

Considérations relatives à l'exécution de SQL Server 2008 sous Windows Vista et Windows Server 2008

Windows Vista et Windows Server 2008 incluent une nouvelle fonctionnalité, le contrôle de compte d'utilisateur, qui permet aux administrateurs de gérer les autorisations élevées qu'ils utilisent. Par défaut, dans Windows Vista et Windows Server 2008, les administrateurs n'utilisent pas leurs droits d'administration. À la place, ils effectuent la plupart des actions en tant qu'utilisateurs standard, n'assumant temporairement leurs droits d'administration que lorsque cela est nécessaire. Toutefois, nous vous conseillons l'une des options suivantes à la place de l'élévation des privilèges :

  • Si vous utilisez le mode d'authentification Windows, vous devez créer un compte d'utilisateur Windows avec des autorisations suffisantes pour effectuer toutes les tâches d'administration nécessaires.

  • Si vous utilisez le mode mixte (authentification SQL Server et authentification Windows), vous pouvez envisager de créer un compte de connexion SQL Server utilisé uniquement pour l'administration.

Le Contrôle de compte d'utilisateur entraîne certains problèmes connus. Pour plus d'informations, consultez les pages Web suivantes :

  • Considérations relatives à l'exécution de SQL Server 2005 sous Windows Vista

  • Contrôle de compte d'utilisateur

Options

Mode de sécurité - Sélectionnez l'authentification Windows ou l'authentification de mode mixte pour votre installation.

Configuration du principal Windows - Dans les versions antérieures de SQL Server, le groupe local de Windows BUILTIN\Administrateurs a été placé dans le rôle serveur sysadmin de SQL Server, en accordant aux administrateurs Windows l'accès à l'instance de SQL Server. Dans SQL Server 2008, le groupe BUILTIN\Administrateurs n'est pas mis en service dans le rôle serveur sysadmin. Au lieu de cela, vous devez configurer de manière explicite des administrateurs SQL Server pour les nouvelles installations lors de l'installation.

Important :
Si les processus ou le code de votre organisation dépendent de l'accès au groupe local Windows BUILTIN\Administrateurs, vous devez mettre en service de manière explicite des administrateurs SQL Server pour les nouvelles installations pendant l'installation. L'installation ne vous permet pas de continuer tant que cette étape n'a pas été effectuée.

Spécifiez les administrateurs SQL Server - Vous devez spécifier au moins un principal Windows pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur le bouton Utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server.

Lorsque vous avez terminé de modifier la liste, cliquez sur OK, puis vérifiez la liste des administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

Si vous sélectionnez l'authentification de mode mixte, vous devez fournir les informations d'identification de session pour le compte de l'administrateur système SQL Server intégré.

Remarque relative à la sécurité :
N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Mode d'authentification Windows

Quand un utilisateur se connecte par le biais d'un compte d'utilisateur Windows, SQL Server valide le nom et le mot de passe du compte à l'aide du jeton du principal Windows du système d'exploitation. Il s'agit du mode d'authentification par défaut et il est plus fiable que le mode mixte. L'authentification Windows utilise le protocole de sécurité Kerberos, met en œuvre les stratégies de mot de passe en termes de validation de la complexité des mots de passe forts et prend en charge le verrouillage des comptes et l'expiration des mots de passe.

Remarque relative à la sécurité :
Lorsque c'est possible, utilisez l'authentification Windows.

Important :
N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort. Ne définissez jamais un mot de passe d'administrateur système (SA) vide ou faible.

Mode mixte (authentification Windows ou authentification SQL Server)

Permet aux utilisateurs de se connecter en utilisant l'authentification Windows ou l'authentification SQL Server. Les utilisateurs qui se connectent via un compte d'utilisateur Windows peuvent utiliser des connexions approuvées qui sont validées par Windows.

Si vous devez choisir l'authentification en mode mixte et utiliser des connexions SQL pour vous adapter à des applications héritées, définissez des mots de passe forts pour tous les comptes SQL Server.

Remarque :
L'authentification SQL Server est fournie uniquement dans un souci de compatibilité descendante. Lorsque c'est possible, utilisez l'authentification Windows.

Entrer le mot de passe

Entrez et confirmez la connexion d'administrateur système (sa). Les mots de passe constituant la première ligne de défense contre les intrus, le choix de mots de passe forts est essentiel à la sécurité de votre système. Ne définissez jamais un mot de passe sa vide ou faible.

Remarque :
Les mots de passe SQL Server peuvent contenir de 1 à 128 caractères, notamment des lettres, des symboles et des chiffres. Si vous choisissez l'authentification en mode mixte, vous devez d'abord entrer un mot de passe sa fort avant de passer à la page suivante de l'Assistant Installation.

Instructions sur les mots de passe forts

Les mots de passe forts ne peuvent pas être aisément devinés par une personne et ils ne sont pas aisément piratés par un programme informatique. Les mots de passe forts ne peuvent pas utiliser des conditions ou des termes interdits, notamment :

  • Une condition vide ou NULL

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

Un mot de passe fort ne peut pas se composer des termes suivants associés à l'ordinateur d'installation :

  • Le nom de l'utilisateur qui a ouvert la session sur l'ordinateur.

  • Nom de l'ordinateur.

Un mot de passe fort doit contenir plus de 8 caractères et satisfaire au moins trois des quatre critères suivants :

  • Il doit contenir des lettres majuscules.

  • Il doit contenir des lettres minuscules.

  • Il doit contenir des chiffres.

  • Il doit contenir des caractères non alphanumériques, comme #, % ou ^.

Les mots de passe entrés sur cette page doivent répondre aux exigences des stratégies de mots de passe forts. Si vous avez un processus automatisé qui utilise l'authentification SQL Server, assurez-vous que le mot de passe répond aux exigences des stratégies de mots de passe forts.

Voir aussi

Autres ressources

Configuration des comptes de service Windows


Configuration du moteur de base de données – Répertoires de données

Configuration du moteur de base de données – Répertoires de données |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le tableau suivant affiche les répertoires par défaut qui sont configurables par l'utilisateur pendant l'installation de SQL Server :

Description | Répertoire par défaut | Recommandations
Répertoire de données racine | C:\Program Files\Microsoft SQL Server\ | Le programme d'installation de SQL Server configurera les listes de contrôle d'accès pour les répertoires SQL Server et rompra l'héritage dans le cadre de la configuration.
Répertoire de base de données utilisateur | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\Data | Les meilleures pratiques recommandées pour les répertoires de données utilisateur dépendent de la charge de travail et des exigences en matière de performances. Pour les installations de cluster de basculement, vérifiez que les répertoires de données sont placés sur le disque partagé.
Répertoire du journal de la base de données utilisateur | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire Temp de base de données | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\Data | Les meilleures pratiques recommandées pour le répertoire Temp dépendent de la charge de travail et des exigences en matière de performances.
Répertoire Temp du journal de base de données | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire de sauvegarde | C:\Program Files\Microsoft SQL Server\MSSQL10_50.<ID_instance>\Backup | Définissez les autorisations appropriées pour empêcher la perte de données et vérifiez que le groupe d'utilisateurs pour le service SQL Server a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

Remarques

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur des lecteurs partagés sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server


Configuration du moteur de base de données - Filestream

Configuration du moteur de base de données - Filestream |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez cette page pour activer FILESTREAM pour cette installation de SQL Server 2008. FILESTREAM intègre le moteur de base de données Microsoft SQL Server avec un système de fichiers NTFS en stockant les données d'objet blob varbinary(max) en tant que fichiers dans le système de fichiers. Les instructions Transact-SQL peuvent insérer, mettre à jour, interroger, rechercher et sauvegarder des données FILESTREAM. Les interfaces de système de fichiers Win32 fournissent l'accès de diffusion en continu aux données.

Activer FILESTREAM pour l'accès Transact-SQL

Sélectionnez cette option pour activer FILESTREAM pour l'accès Transact-SQL. Ce contrôle doit être activé pour que les autres options de contrôle soient disponibles.

Activer FILESTREAM pour l'accès en continu des E/S de fichier

Sélectionnez cette option pour activer l'accès en continu Win32 pour FILESTREAM.

Nom du partage Windows

Utilisez ce contrôle pour entrer le nom du partage Windows dans lequel les données FILESTREAM doivent être stockées.

Permettre aux clients distants d'avoir un accès en continu aux données FILESTREAM

Sélectionnez ce contrôle pour permettre aux clients distants d'accéder à ces données FILESTREAM sur ce serveur.

Voir aussi

Autres ressources

Mise en route du stockage FILESTREAM
sp_configure (Transact-SQL)


Configuration du moteur de base de données – Instance utilisateur

Configuration du moteur de base de données – Instance utilisateur
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Instance utilisateur permet de générer une instance distincte du Moteur de base de données pour les utilisateurs sans autorisations d'administrateur et d'ajouter des utilisateurs dans le rôle d'administrateur.

Option

Activer les instances utilisateur

Par défaut, cette option est activée. Pour désactiver la fonction qui active les instances utilisateur, désactivez cette case à cocher.

L'instance utilisateur, également désignée comme instance enfant ou client, est une instance de SQL Server qui est générée par l'instance parent (l'instance principale exécutée en tant que service, telle que SQLExpress) pour le compte d'un utilisateur. L'instance utilisateur s'exécute en tant que processus utilisateur dans le contexte de sécurité de cet utilisateur. L'instance utilisateur est isolée de l'instance parent et de toutes les autres instances utilisateur exécutées sur l'ordinateur. La fonction d'instance utilisateur est également appelée RANU (« Run As Normal User », exécution en tant qu'utilisateur normal).

Ajouter l'utilisateur au rôle Administrateur SQL Server

Par défaut, cette option est désactivée. Pour ajouter l'utilisateur du programme d'installation en cours au rôle Administrateur SQL Server, activez la case à cocher.

Les utilisateurs Windows Vista qui sont membres de BUILTIN\Administrateurs ne sont pas ajoutés automatiquement au rôle serveur fixe sysadmin lorsqu'ils se connectent à SQL Server Express. Seuls les utilisateurs Windows Vista qui ont été ajoutés explicitement à un rôle d'administrateur de niveau serveur peuvent administrer SQL Server Express. Tous les membres du groupe Built-In\Users peuvent se connecter à l'instance de SQL Server Express, mais ils auront des autorisations limitées pour effectuer les tâches de base de données. Pour cette raison, les utilisateurs dont les privilèges SQL Server Express sont hérités de BUILTIN\Administrateurs et de Built-In\Utilisateurs dans les versions précédentes de Windows doivent bénéficier explicitement des privilèges d'administrateur dans les instances de SQL Server Express qui s'exécutent sur Windows Vista.

Pour apporter des modifications quelconques aux rôles d'utilisateur une fois le programme d'installation terminé, utilisez l'outil Configuration de la surface d'exposition SQL Server 2005 (SQLSAC.exe). Pour mettre à jour la liste des utilisateurs dans le rôle SQL Server Administrateur système, cliquez sur le lien Ajouter un nouvel administrateur.

Assurez-vous que le champ Utilisateur à mettre en service contient les paramètres DomainName\UserName de l'utilisateur dont les autorisations doivent être mises à jour. Sélectionnez le rôle à mettre à jour dans la liste des instances de SQL Server dans le volet Privilèges disponibles, puis cliquez sur la flèche droite. Pour ajouter l'utilisateur à tous les rôles disponibles pour toutes les instances disponibles de SQL Server et tous les rôles disponibles, cliquez sur la double flèche vers la droite.

Pour implémenter les modifications une fois votre sélection terminée, cliquez sur OK. Pour quitter l'outil sans apporter de modification, cliquez sur Annuler.


Espace disque nécessaire

Espace disque nécessaire |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Résumé sur l'espace nécessaire pour examiner l'espace disque nécessaire pour les fonctionnalités SQL Server sélectionnées pour votre installation.

Options

Si la quantité d'espace disque requis est trop élevée, envisagez les options suivantes :

  • Remplacez les répertoires d'installation par un lecteur disposant de davantage d'espace disque.

  • Modifiez les fonctionnalités SQL Server pour votre installation.

  • Créez davantage d'espace libre sur le lecteur spécifié en déplaçant d'autres fichiers ou applications.

Voir aussi

Autres ressources

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2


Règles de mise à niveau de l'édition

Règles de mise à niveau de l'édition |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
Engine_OnlySupportedFeaturesUsedCheckSystem | Vérifie les bases de données système pour les fonctionnalités qui ne sont pas prises en charge dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau. | Désactivez les fonctionnalités utilisées dans les bases de données système qui ne sont pas disponibles dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau.
Engine_OnlySupportedFeaturesUsedCheckUser | Vérifie toutes les bases de données utilisateur pour les fonctionnalités qui ne sont pas prises en charge par l'édition SQL Server. | Désactivez les fonctionnalités utilisées dans les bases de données système qui ne sont pas disponibles dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau.
Engine_SqlEngineRestartCheck | Vérifie si le service SQL Server peut être redémarré. | Identifiez et corrigez le problème qui empêche la mise en ligne du service SQL Server.
Engine_SqlServerServiceDisabled_Id | Vérifie que le service SQL Server n'a pas la valeur Désactivé. | Définissez le type de démarrage manuel ou automatique pour le service SQL Server.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008 R2. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
EditionUpgradeMatrixCheck | Vérifie si l'instance sélectionnée de SQL Server répond aux besoins de la matrice de mise à niveau. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
AS_ValidateEditionUpgrade | Vérifie si Analysis Services est mis à niveau vers une édition valide. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
Cluster_EditionDownGradeCheck | Vérifie si l'édition de l'instance sélectionnée de SQL Server est prise en charge dans ce scénario. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Certains scénarios de mise à niveau multiplateformes ne sont pas pris en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.
EditionDownGradeCheck | Vérifie si l'édition de l'instance sélectionnée de SQL Server est prise en charge dans ce scénario. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.

Voir aussi

Référence

Règles de support du programme d'installation


Création de rapports d'erreurs

Création de rapports d'erreurs
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Rapport d'erreurs de l'Assistant Installation de SQL Server pour activer la fonctionnalité de création de rapports d'erreurs dans SQL Server.

Options

Par défaut, les fonctionnalités de rapport d'erreurs sont désactivées pour SQL Server et ses composants dans SQL Server 2008 R2.

Rapport d'erreurs

Si vous activez la fonctionnalité Rapport d'erreurs, SQL Server est configuré pour envoyer automatiquement un rapport à Microsoft si une erreur irrécupérable se produit dans l'un des composants SQL Server suivants :

  • Le moteur de base de données

  • Agent SQL Server

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

Microsoft utilise les rapports d'erreurs pour améliorer le fonctionnement de SQL Server. Ces informations sont traitées en toute confidentialité.

Des informations sur les erreurs sont envoyées à Microsoft par le biais d'une connexion sécurisée (https) et elles sont stockées avec un accès limité. Des rapports d'erreurs peuvent également être envoyés sur votre propre serveur de rapports d'erreurs d'entreprise.

Les rapports d'erreurs comprennent les informations suivantes :

  • la condition de SQL Server lorsque le problème s'est produit ;

  • des informations sur la version du système d'exploitation et le matériel ;

  • votre ID de produit numérique, qui n'est pas utilisé pour identifier votre licence ;

  • l'adresse IP réseau de votre ordinateur ou de votre serveur proxy ;

  • des informations provenant de la mémoire ou des fichiers du processus à l'origine de l'erreur.

Microsoft ne regroupe pas de manière intentionnelle vos fichiers, nom, adresse, adresse électronique ou tout autre forme d'informations personnelles. Le rapport d'erreurs peut toutefois contenir des informations personnelles qui proviennent de la mémoire ou des fichiers du processus à l'origine de l'erreur. Bien que ces informations permettent à priori de déterminer votre identité, Microsoft ne les exploite pas à cette fin.

Pour plus d'informations sur la politique de confidentialité et la procédure de collecte de données de SQL Server, consultez la déclaration de confidentialité de Microsoft SQL Server.

Si vous activez les rapports d'erreurs et qu'une erreur irrémédiable se produit, vous pouvez voir une réponse de Microsoft dans le journal des événements Windows, qui pointe sur un article de la Base de connaissances Microsoft traitant cette erreur.

Pour désactiver la fonction de rapports d'erreurs pour toutes les instances de SQL Server et leurs composants une fois l'installation terminée, accédez à l'outil Création de rapports d'erreurs et d'utilisation et désactivez les cases à cocher pour Rapport d'erreurs. Si l'option Rapport d'erreurs est activée pour plusieurs composants SQL Server (le moteur de base de données SQL Server, Analysis Services, Reporting Services et les composants partagés), vous pouvez la désactiver individuellement pour l'instance de chaque composant, ainsi que pour les composants partagés répertoriés comme Autres.


Rapport sur le cluster de basculement

Rapport sur le cluster de basculement
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Rapport sur le cluster de basculement pour afficher les résultats du rapport de l'analyse du système du programme d'installation pour cette opération.

Options

Pour afficher un rapport détaillé pour l'analyse, cliquez sur le lien de rapport.


Vérification des fonctionnalités

Vérification des fonctionnalités
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Vérification des fonctionnalités est une liste en lecture seule des fonctionnalités qui ont été préparées et qui seront configurées et finalisées à la fin de l'étape de finalisation d'image. La liste de fonctionnalités est sélectionnée pendant l'étape de préparation d'image et ne peut pas être modifiée pendant l'étape de finalisation d'image. En plus des fonctionnalités affichées, une instance préparée inclut également SQL Server Browser, Enregistreur SQL Server et SQL Server Native Client.

Vous pouvez ajouter des autres fonctionnalités non incluses dans l'instance préparée de l'instance SQL Server après avoir finalisé la configuration de l'instance préparée de SQL Server.

Groupe de composants

Composants et fonctionnalités

Services du moteur de base de données

Le Moteur de base de données SQL Server inclut les composants suivants :

  • Le moteur de base de données est le service central qui permet de stocker, traiter et sécuriser les données.

    • Réplication : (Facultatif) La réplication est un ensemble de technologies qui permettent de copier et de distribuer des données et des objets de base de données d'une base de données vers une autre, puis de synchroniser les bases de données afin de préserver leur cohérence.

    • Recherche en texte intégral : (Facultatif) La recherche en texte intégral fournit les fonctionnalités nécessaires à l'émission de requêtes de texte intégral sur les données caractères en texte brut des tables SQL Server.

Reporting Services

Reporting Services inclut les composants serveur et clients permettant de créer, de gérer et de déployer des rapports tabulaires, de matrice, graphiques et de forme libre. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports.


Rôle d'installation

Rôle d'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez cette page pour spécifier s'il convient d'utiliser la page Sélection de composant pour sélectionner des fonctionnalités individuelles, ou de procéder à l'installation à l'aide d'un rôle d'installation.

Un setup role est une sélection fixe de toutes les fonctionnalités et composants partagés qui sont requis pour implémenter une configuration SQL Server prédéfinie.

Options

Installation de fonctionnalités SQL Server

Choisissez cette option pour sélectionner des fonctionnalités individuelles et des composants partagés. Les fonctionnalités incluent les services Moteur de base de données, Analysis Services (mode natif), Reporting Services et Service Broker.

SQL Server PowerPivot pour SharePoint

Choisissez cette option pour installer les composants serveur Analysis Services dans une batterie de serveurs SharePoint 2010. Cette option déploie le service système PowerPivot et le service Analysis Services dans une batterie de serveurs, ce qui active le traitement des requêtes et des données pour les classeurs Excel publiés qui contiennent des données PowerPivot incorporées.

Il existe deux options de configuration pour PowerPivot pour SharePoint :

  • Batterie de serveurs existante ajoute PowerPivot pour SharePoint à une batterie ou un serveur autonome qui est déjà configuré.

  • Nouveau serveur permet de déployer PowerPivot pour SharePoint en le moins d'étapes possible. Ce rôle requiert que vous ayez installé le serveur SharePoint sans l'avoir configuré. Le programme d'installation de SQL Server configurera SharePoint pour vous et créera une application Web, une collection de sites et une configuration du serveur optimisée pour les fonctionnalités PowerPivot.

Pour ce rôle, le programme d'installation effectue les opérations suivantes :

  • Configure l'instance du service Analysis Services.

  • Installe des fichiers programme sur un serveur d'applications SharePoint.

  • Déploie deux packages de la solution PowerPivot qui ajoutent des fichiers d'application aux serveurs Web frontaux.

  • (Nouveau serveur uniquement) Ajoute les services Moteur de base de données à l'installation et les utilise comme serveur de base de données pour la batterie.

  • (Nouveau serveur uniquement) Ajoute SQL Server Management Studio, des outils de configuration et des outils de performances.

  • (Nouveau serveur uniquement) Crée une application de service PowerPivot et une base de données d'application.

Une installation basée sur les rôles n'inclut pas l'application cliente SQL Server PowerPivot pour Excel. L'application cliente est installée séparément.

Toutes les fonctionnalités avec les valeurs par défaut

Choisissez ce rôle d'installation pour installer toutes les fonctionnalités qui sont disponibles pour cette version. Notez que PowerPivot pour SharePoint est exclu de ce rôle. Vous devez utiliser le rôle d'installation PowerPivot pour SharePoint pour installer cette fonctionnalité.

Le moteur de base de données est configuré pour démarrer à l'aide du compte NT AUTHORITY\NETWORK SERVICE. L'utilisateur actuel sera configuré en tant que membre du rôle sysadmin SQL Server. Les valeurs définies par cette option peuvent être remplacées en spécifiant des paramètres de ligne de commande supplémentaires.

Sur Windows Vista ou Windows Server 2008 ou version ultérieure, lorsque le système d'exploitation n'est pas un contrôleur de domaine, par défaut, le moteur de base de données et Reporting Services utiliseront le compte NTAUTHORITY\NETWORK SERVICE, Integration Services utilisera le compte NTAUTHORITY\NETWORK SERVICE et le Lanceur de démon de filtre de texte intégral SQL utilisera le compte NTAUTHORITY\LOCAL SERVICE.

Voir aussi

Référence

Sélection de fonctionnalités
Nouvelle configuration de batterie de serveurs SharePoint

Autres ressources

Installation (Analysis Services SharePoint integration) (en anglais)
Configuration matérielle et logicielle requise
How to: Install Analysis Services on a Standalone SharePoint Server (en anglais)


Sélection de fonctionnalités

Sélection de fonctionnalités |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez les cases à cocher de la page Sélection de fonctionnalités de l'Assistant Installation de SQL Server pour sélectionner les composants de votre installation de SQL Server.

Options

Une description de chaque groupe de composants s'affiche dans le volet Description en cas de sélection. Vous pouvez activer toute combinaison de cases à cocher. Pour continuer, vous devez faire une sélection.

SQL Server SysPrep : les composants du moteur de base de données et Reporting Services sont les seules fonctionnalités SQL Server 2008 R2 qui prennent en charge SQL Server SysPrep. Vous pouvez sélectionner ces fonctionnalités et composants pendant l'étape de préparation d'image du processus. Vous ne pouvez pas effectuer la sélection lors de la finalisation d'une image préparée de SQL Server. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 R2 à l'aide de SysPrep .

Clusters de basculement SQL Server : les composants Moteur de base de données et Analysis Services sont les seules fonctionnalités de SQL Server 2008 R2 qui prennent en charge le clustering avec basculement. Vous pouvez installer d'autres composants, tels que Reporting Services ou Integration Services, sur un nœud de cluster de basculement, mais ils ne prennent pas en charge les clusters et leurs services ne basculent pas si le nœud est placé hors connexion. Pour plus d'informations, consultez Mise en route avec le clustering avec basculement de SQL Server.

Groupe de composants Composants et fonctionnalités

Services du moteur de base de données

Le moteur de base de données SQL Server inclut les composants suivants :

  • Le moteur de base de données est le service central qui permet de stocker, traiter et sécuriser les données.

    • Réplication : facultatif : la réplication est un ensemble de technologies qui permettent de copier et de distribuer des données et des objets de base de données d'une base de données vers une autre, puis de synchroniser les bases de données afin de préserver leur cohérence.

Clusters de basculement SQL Server : la réplication est requise et sélectionnée automatiquement par le programme d'installation pour les installations du clustering avec basculement SQL Server lorsque vous sélectionnez Services Moteur de base de données.

  • Recherche en texte intégral : facultatif : la recherche en texte intégral fournit les fonctionnalités nécessaires à l'émission de requêtes de texte intégral sur les données caractères en texte brut des tables SQL Server.

Clusters de basculement SQL Server : la recherche en texte intégral est requise et sélectionnée automatiquement par le programme d'installation pour les installations du clustering avec basculement SQL Server lorsque vous sélectionnez Services Moteur de base de données.

  • Outils de gestion de données relationnelles et XML.

Analysis Services

Analysis Services inclut les outils de création et de gestion d'applications de traitement analytique en ligne (OLAP, OnLine Analytical Processing) et d'exploration de données.

Reporting Services 2,3

Reporting Services inclut les composants serveur et clients à l'aide desquels vous pouvez créer, gérer et déployer des rapports tabulaires, matriciels, graphiques et libres. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Fonctionnalités partagées :

  • Outils clients

  • Documentation en ligne de SQL Server

  • Business Intelligence Development Studio 4,5

  • Integration Services

Les outils clients incluent les composants permettant la communication entre les clients et les serveurs, notamment les bibliothèques réseau pour DB-Library, OLEDB pour OLAP, ODBC, ADODB et ADOMD+, ainsi que les outils d'administration SQL Server suivants :

  • SQL Server Management Studio (SSMS) est un environnement intégré d'accès, de configuration, de gestion, d'administration et de développement de tous les composants de SQL Server. SSMS réunit les fonctionnalités d'Enterprise Manager, de l'Analyseur de requêtes et d'Analysis Manager, inclus dans les versions précédentes de SQL Server, dans un environnement unique qui fournit l'accès de SQL Server aux développeurs et aux administrateurs de tous les niveaux de compétence.

  • Le Gestionnaire de configuration SQL Server permet de gérer la configuration de base des services SQL Server, des protocoles serveur et clients et des alias clients.

  • Générateur de profils SQL Server fournit une interface utilisateur graphique qui permet d'analyser une instance du moteur de base de données ou une instance Analysis Services.

  • L'Assistant Paramétrage du moteur de base de données permet de créer des ensembles d'index, des vues indexées et des partitions optimaux.

  • Le Moniteur de réplication permet de suivre l'état et les performances des publications et des abonnements dans une topologie de réplication.

  • Fonctionnalités clientes SQLXML

  • La documentation en ligne de SQL Server est fournie avec la documentation principale de SQL Server.

Business Intelligence Development Studio est un environnement de développement intégré pour les solutions Analysis Services, Reporting Services et Integration Services.

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Compatibilité descendante des outils clients

La compatibilité descendante des outils clients inclut les composants suivants :

  • Objets SQL-DMO (Distributed Management Objects). Pour plus d'informations, consultez Fonctionnalités SQL Server supprimées dans SQL Server 2008 R2.

  • DSO (Decision Support Objects). Pour plus d'informations, consultez Changements essentiels apportés aux fonctionnalités Analysis Services dans SQL Server 2008 R2.

  • DTS (Data Transformation Services). Pour plus d'informations, consultez Fonctionnalités Integration Services déconseillées dans SQL Server 2008 R2 .

1Le programme d'installation ne configure pas l'équilibrage de charge et l'adressage par URL unique pour les nœuds multiples d'un déploiement avec montée en puissance parallèle de Reporting Services. Pour effectuer un déploiement avec montée en puissance parallèle, vous devez utiliser Windows Server, Microsoft Application Center ou un logiciel tiers de gestion de clusters. Pour plus d'informations sur la configuration du déploiement d'une batterie de serveurs Web, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

2 Microsoft Internet Explorer 6.0 SP 1 est requis pour le composant Concepteur de rapports de Reporting Services.

3 Reporting Services n'est pas pris en charge simultanément dans les configurations côte à côte sur la plateforme 64 bits et sur le sous-système 32 bits (WOW64) d'un serveur 64 bits.

4Internet Explorer 6.0 SP1 est requis pour les installations de SQL Server Management Studio.

5Internet Explorer 6.0 SP1 est requis pour les installations de Business Intelligence Development Studio.

Répertoire de composants partagé

Les fonctionnalités partagées par toutes les instances de SQL Server sur un même ordinateur sont installées dans un répertoire unique. Elles incluent les éléments suivants :

  • Outils clients

  • Documentation en ligne de SQL Server

  • Business Intelligence Development Studio

  • Integration Services

Par défaut, ces composants partagés sont installés dans %Program Files%Microsoft SQL Server\. Pour modifier le chemin d'installation, cliquez sur le bouton Parcourir. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placeront les composants partagés dans le même emplacement que celui de l'installation d'origine.

Sur les systèmes d'exploitation x64, vous pouvez spécifier où les composants 64 bits doivent être installés et où les composants 32 bits doivent l'être sur le sous-système WOW64.

Installation des exemples et des exemples de bases de données

Par défaut, les exemples de bases de données et les exemples de code ne sont pas installés dans le cadre de l'installation de SQL Server. Pour plus d'informations sur l'installation des exemples de bases de données et des exemples de code, consultez le site Web de CodePlex.

Les informations supplémentaires sur les exemples sont disponibles après que SQL Server 2008 R2 a été installé. Dans le menu Démarrer, cliquez sur Tous les programmes, sur Microsoft SQL Server 2008 R2, sur Documentation et didacticiels, puis sur Vue d'ensemble des exemples pour Microsoft SQL Server.

Voir aussi

Autres ressources

Éditions et composants de SQL Server 2008 R2


Sélection de composant (Désinstaller)

Sélection de composant (Désinstaller)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection de composant — Désinstaller pour sélectionner les fonctionnalités à supprimer de l'instance spécifiée de SQL Server.

Options

Vous pouvez choisir n'importe quelle combinaison de fonctionnalités.


Fonctionnalités à mettre à niveau

Fonctionnalités à mettre à niveau |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Fonctionnalités à mettre à niveau de l'Assistant Installation SQL Server 2008 pour spécifier les fonctionnalités à mettre à niveau vers SQL Server 2008.

Options

  • Il n'est pas possible de modifier les fonctionnalités à mettre à niveau dans cette version.

Voir aussi

Autres ressources

Mises à niveau de la version et de l'édition
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions de SQL Server


Options de mise à niveau de recherche en texte intégral

Options de mise à niveau de recherche en texte intégral |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page des options de mise à niveau de recherche en texte intégral de l'Assistant Installation SQL Server pour sélectionner l'option de mise à niveau de recherche en texte intégral à utiliser pour les bases de données que vous mettez à niveau cette fois.

Dans SQL Server 2005 et les versions antérieures, chaque index de recherche en texte intégral réside dans un catalogue de texte intégral qui appartient à un groupe de fichiers, a un chemin d'accès physique et est traité en tant que fichier de base de données. À compter de SQL Server 2008, un catalogue de texte intégral est un concept logique – objet virtuel – qui renvoie à un groupe d'index de recherche en texte intégral. Par conséquent, un nouveau catalogue de texte intégral n'est pas traité en tant que fichier de base de données avec un chemin d'accès physique. Toutefois, un nouveau groupe de fichiers est créé sur le même disque pendant la mise à niveau de tout catalogue de texte intégral qui contient des fichiers de données. Cela maintient le comportement d'E/S de l'ancien disque après la mise à niveau. Tout index de recherche en texte intégral de ce catalogue est placé dans le nouveau groupe de fichiers si le chemin d'accès racine existe. Si l'ancien chemin de catalogue de texte intégral est non valide, la mise à niveau conserve l'index de recherche en texte intégral dans le même groupe de fichiers comme table de base ou, pour une table partitionnée, dans le groupe de fichiers principal.

Options

Lorsque vous effectuez une mise à niveau vers SQL Server 2008 R2, choisissez l'une des options de mise à niveau de texte intégral ci-dessous.

Importer

Les catalogues de texte intégral sont importés. En général, l'importation est considérablement plus rapide que lors d'une reconstruction (rebuild). Par exemple, lorsque vous utilisez un seul processeur, l'importation s'exécute approximativement 10 fois plus vite que lors de la reconstruction. Toutefois, un catalogue de texte intégral importé n'utilise pas les analyseurs lexicaux nouveaux et améliorés introduits dans SQL Server 2008, ce qui fait que vous pouvez le cas échéant reconstruire vos catalogues de texte intégral au final.

Remarque :
Le processus de reconstruction peut s'exécuter en mode multithread, et si plus de 10 processeurs sont disponibles, la reconstruction peut s'effectuer plus vite que l'importation si vous la laissez utiliser tous les processeurs.

Si aucun catalogue de texte intégral n'est disponible, les index de recherche en texte intégral associés sont reconstruits. Cette option est disponible uniquement pour les bases de données SQL Server 2005.

Pour plus d'informations sur l'impact de l'importation de l'index de recherche en texte intégral, consultez « Considérations relatives au choix d'une option de mise à niveau », plus loin dans cette rubrique.

Reconstruire

Les catalogues de texte intégral sont reconstruits à l'aide des analyseurs lexicaux nouveaux et améliorés. La reconstruction des index peut prendre un moment, et une quantité importante de ressources en termes d'UC et de mémoire peut être requise après la mise à niveau.

Réinitialiser

Les catalogues de texte intégral sont réinitialisés. Les fichiers de catalogue de texte intégral SQL Server 2005 sont supprimés, mais les métadonnées pour les catalogues de texte intégral et les index de recherche en texte intégral sont conservés. Après leur mise à niveau, tous les index de recherche en texte intégral ont le suivi des modifications désactivé et aucune analyse n'est démarrée automatiquement. Le catalogue reste vide tant que vous n'avez pas procédé manuellement à une alimentation complète, au terme de la mise à niveau.

Toutes ces options de mise à niveau garantissent que les bases de données mises à niveau bénéficient pleinement des améliorations en termes de performances du texte intégral de SQL Server 2008.

Important :
Pour plus d'informations sur l'utilisation des nouveaux analyseurs lexicaux et la mise à niveau des fichiers de mots parasites vers les liste de mots vides après avoir importé un index de recherche en texte intégral SQL Server 2005, consultez Mise à niveau de la fonction de recherche en texte intégral.

Considérations relatives au choix d'une option de mise à niveau de texte intégral

Au moment de choisir l'option de mise à niveau pour votre mise à niveau, tenez compte des éléments suivants :

  • Comment est-ce que vous utilisez les analyseurs lexicaux ?

    À compter de SQL Server 2008, le service de recherche en texte intégral inclut de nouveaux analyseurs lexicaux et générateurs de formes dérivées. Ceux-ci peuvent modifier les résultats de requêtes de texte intégral de versions précédentes pour un modèle ou scénario de texte spécifique. Par conséquent, la manière dont vous utilisez les analyseurs lexicaux est importante lors du choix d'une option de mise à niveau appropriée :

    • Si les analyseurs lexicaux de la langue de texte intégral que vous utilisez n'ont pas changé dans SQL Server 2008, ou si l'exactitude de rappel n'est pas critique pour vous, l'importation est appropriée. Ultérieurement, si vous rencontrez des problèmes de rappel, vous pouvez effectuer une mise à niveau vers les nouveaux analyseurs lexicaux en reconstruisant vos catalogues de texte intégral. Pour plus d'informations, consultez Mise à niveau de la fonction de recherche en texte intégral.

    • Si vous tenez à l'exactitude de rappel et que vous utilisez l'un des analyseurs lexicaux améliorés dans SQL Server 2008, la reconstruction est appropriée.

  • Certains index de recherche en texte intégral ont-ils été construits sur la base de colonnes de clés de texte intégral de type Integer ?

    La reconstruction effectue, dans quelques cas, des optimisations internes qui améliorent le performances des requêtes de l'index de recherche en texte intégral mis à niveau. Spécifiquement, si vous avez des catalogues de texte intégral qui contiennent des index de recherche en texte intégral dont la colonne de clé de texte intégral de la table de base correspond à un type de données Integer, la reconstruction permet d'obtenir une performance idéale des requêtes de texte intégral après la mise à niveau. Nous recommandons vivement que vous utilisiez l'option Reconstruire dans ce cas.

    Remarque :
    Pour les index de recherche en texte intégral dans SQL Server 2008 R2, nous recommandons que la colonne servant de clé de texte intégral corresponde à un type de données Integer. Pour plus d'informations, consultez Paramétrage et optimisation des performances (recherche en texte intégral).

  • Quelle est la priorité pour obtenir votre instance de serveur en ligne ?

    L'importation ou la reconstruction pendant la mise à niveau mobilise beaucoup de ressources processeur, ce qui retarde la mise à niveau et en ligne du reste de l'instance serveur. Si le fait d'avoir l'instance de serveur en ligne dès que possible est important et si vous êtes disposé à exécuter une alimentation manuelle après la mise à niveau, la réinitialisation est appropriée.

Ressources supplémentaires

Modifications importantes de la recherche en texte intégral dans SQL Server 2008

Modifications du comportement de la recherche en texte intégral dans SQL Server 2008

Fonctionnalités du moteur de base de données déconseillées dans SQL Server 2008

Recherche de la colonne clé de texte intégral

Analyseurs lexicaux et générateurs de formes dérivées

Voir aussi

Autres ressources

Procédure : installer SQL Server 2008 R2 (programme d'installation)


Conditions préalables d'installation

Conditions préalables d'installation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Pour que SQL Server soit correctement installé, les composants logiciels suivants sont requis sur l'ordinateur d'installation. Ils sont installés par le programme d'installation de SQL Server :

  • .NET Framework version 2.0 SP2 pour SQL Server Express

  • .NET Framework version 3.5 SP1 pour SQL Server Express with Tools et SQL Server Express Advanced

  • .NET Framework version 2.0 SP2 pour SQL Server 2008 sur Windows Server 2003 (64 bits) IA64 SP1

  • .NET Framework version 3.5 SP1 pour toutes les autres éditions de SQL Server 2008

  • Fichiers de support d'installation de SQL Server

  • SQL Server Native Client

Remarque :
En cas d'échec ou d'annulation de l'installation, ces composants ne sont pas supprimés. Pour les supprimer, utilisez Ajout/Suppression de programmes dans le Panneau de configuration.

Remarque :
Installation de .NET Framework 2.0 SP2 : .NET Framework 2.0 SP2 n'est pas disponible sous forme de téléchargement distinct. Vous devez installer .NET Framework 3.5 SP1 qui inclut .NET Framework 2.0 SP2.

Options

Pour installer les fichiers requis, cliquez sur Installer. Pour quitter l'installation, cliquez sur Annuler.


progression de l'installation

progression de l'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression de l'installation de l'Assistant Installation de SQL Server pour vérifier l'état du programme d'installation de SQL Server.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Règles d'installation

Règles d'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Le système d'exploitation doit être conforme à la configuration minimale requise pour ce produit. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Le service WMI doit être en cours d'exécution.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis de SQL Server Express with Advanced Services. | Pour les installations de SQL Server Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Permet de déterminer si le programme d'installation est pris en charge sur la plate-forme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.
BlockCrossLanguageInstall | Vérifie si la langue d'installation est la même que la langue des fonctionnalités SQL Server existantes. | Vous devez mettre à niveau SQL Server en utilisant la même version linguistique que l'instance existante de SQL Server.
BlockMixedArchitectureInstall | Vérifie si les fonctionnalités d'installation sont la même architecture de processeur que l'instance spécifiée. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
RS_DoesCatalogExist | Vérifie si le fichier de base de données de catalogue existe. | Renommez, déplacez ou supprimez les fichiers.
RS_DoesCatalogTempDBExist | Vérifie si le fichier de base de données temporaire de catalogue existe. | Renommez, déplacez ou supprimez les fichiers.
StandaloneInstall_HasClusteredOrPreparedInstanceCheck | Vérifie si le nom d'instance sélectionné est déjà utilisé par une instance préparée par cluster ou en cluster existante sur tout nœud de cluster. | Vous ne pouvez pas utiliser le nom d'instance sélectionné, car il est déjà utilisé. Indiquez un autre nom d'instance pour SQL Server.
Versions antérieures de Microsoft Visual Studio 2008 | Recherche les versions antérieures de Visual Studio 2008 ou l'existence de sa mise à niveau vers le Service Pack 1. | Vous devez effectuer une mise à niveau vers Visual Studio 2008 SP1 avant d'installer SQL Server 2008 R2.

Voir aussi

Référence

Règles de support du programme d'installation


Type d'installation

Type d'installation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Type d'installation de l'Assistant Installation de SQL Server pour spécifier s'il convient d'installer une nouvelle instance de SQL Server 2008 ou d'ajouter des fonctionnalités à une instance existante.

Options

Sélectionnez la case d'option qui correspond à votre choix :

  • Effectuer une nouvelle installation de SQL Server 2008

  • Ajouter des fonctionnalités à une instance existante de SQL Server 2008

    Si vous choisissez d'ajouter des fonctionnalités à une instance existante, utilisez la liste déroulante pour sélectionner l'instance de SQL Server à mettre à jour.

Vous pouvez uniquement ajouter les fonctionnalités prises en charge par SysPrep (moteur de base de données et Reporting Services) à une image préparée de SQL Server. Les autres fonctionnalités qui ne sont pas prises en charge par SysPrep peuvent être ajoutées après que l'instance préparée a été finalisée.

Remarque Vous ne pouvez pas ajouter des fonctionnalités à une instance de cluster de basculement après son installation. Pour ajouter des fonctionnalités SQL Server à un cluster de basculement existant, vous devez effectuer une nouvelle installation pour installer une instance séparée de SQL Server.


Configuration d'une instance

Configuration d'une instance
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration d'une instance de l'Assistant Installation de SQL Server pour spécifier s'il faut créer une instance par défaut ou une instance nommée de SQL Server. Si une instance de SQL Server n'est pas déjà installée, une instance par défaut sera créée à moins que vous ne spécifiiez une instance nommée.

Chaque instance de SQL Server consiste en un ensemble distinct de services avec des paramètres spécifiques pour les classements et les autres options. La structure des répertoires, la structure du Registre et les noms de services reflètent tous le nom de l'instance et l'ID spécifique de l'instance créé durant l'installation de SQL Server.

Une instance est soit l'instance par défaut, soit une instance nommée. MSSQLSERVER est le nom de l'instance par défaut. Il n'est pas nécessaire qu'un client spécifie le nom de l'instance pour établir une connexion. Une instance nommée est déterminée par l'utilisateur au cours de l'installation. Vous pouvez installer SQL Server comme instance nommée sans installer d'abord l'instance par défaut. L'instance par défaut peut être une installation de SQL Server 2000, SQL Server 2005, SQL Server 2008 ou de SQL Server 2008 R2. Une seule installation de SQL Server, indépendamment de la version, peut être à un instant donné l'instance par défaut.

Remarque :
SQL Server SysPrep vous permet de spécifier le nom de l'instance lorsque vous finalisez une instance préparée dans la page Configuration de l'instance. Vous pouvez choisir de configurer l'instance préparée que vous finalisez comme instance par défaut s'il n'existe aucune instance par défaut de SQL Server sur l'ordinateur. Pour plus d'informations, consultez Procédure : installer SQL Server à l'aide de SysPrep.

Instances multiples

SQL Server prend en charge plusieurs instances de SQL Server sur un seul serveur ou processeur, mais une seule instance peut être l'instance par défaut. Toutes les autres instances doivent être des instances nommées. Un ordinateur peut exécuter simultanément plusieurs instances SQL Server et chaque instance s'exécute indépendamment des autres.

Pour plus d'informations, consultez Spécifications des capacités maximales pour SQL Server.

Options

Instances de cluster de basculement uniquement — Indiquez le nom réseau du cluster de basculement SQL Server. Ce nom identifie l'instance de cluster de basculement sur le réseau.

Instance par défaut ou instance nommée — Prenez ces informations en compte lorsque vous décidez d'installer une instance par défaut ou une instance nommée de SQL Server :

  • Si vous envisagez d'installer une seule instance de SQL Server sur un serveur de bases de données, ce doit être une instance par défaut.

  • Utilisez une instance nommée lorsque vous envisagez plusieurs instances sur le même ordinateur. Un serveur ne peut héberger qu'une seule instance par défaut.

  • Toute application qui installe SQL Server Express doit l'installer en tant qu'instance nommée. Ce procédé réduit au minimum les conflits liés à l'installation de plusieurs applications sur le même ordinateur.

Instance par défaut

Choisissez cette option pour installer une instance par défaut de SQL Server. Un ordinateur ne peut héberger qu'une instance par défaut ; toutes les autres instances doivent être nommées. Toutefois, si vous avez une instance par défaut de SQL Server installée, vous pouvez ajouter une instance par défaut de Analysis Services sur le même ordinateur.

Instance nommée

Sélectionnez cette option pour créer une nouvelle instance nommée. Prenez en compte les points suivants lorsque vous nommez une instance de SQL Server :

  • Les noms d'instance ne respectent pas la casse.

  • Les noms d'instance ne peuvent pas contenir le terme « Default » ou autres mots clés réservés. Si un mot clé réservé est utilisé dans le nom d'une instance, une erreur d'installation se produit. Pour plus d'informations, consultez Mots clés réservés (programme d'installation).

  • Si vous spécifiez MSSQLServer comme nom d'instance, une instance par défaut est créée. Pour SQL Server Express, si vous spécifiez SQLExpress comme nom d'instance, une instance par défaut est créée.

  • Microsoft SQL Server PowerPivot pour SharePoint est toujours installé comme une instance nommée de « PowerPivot ». Vous ne pouvez pas spécifier de nom d'instance différent pour ce rôle de fonctionnalité.

  • Les noms d'instance sont limités à 16 caractères.

  • Le premier caractère d'un nom d'instance doit être une lettre. Les lettres acceptables sont celles définies par la norme Unicode 2.0. Elles incluent les caractères latins a-z, A-Z et les caractères littéraux des autres langues.

  • Les autres caractères d'un nom d'instance peuvent être des lettres définies par le standard Unicode 2.0, des nombres décimaux provenant de scripts de latin de base ou nationaux, le symbole dollar ($) ou le trait de soulignement (_).

  • Les espaces incorporés ou autres caractères spéciaux ne sont pas autorisés dans les noms d'instance. La barre oblique inverse (\), la virgule (), les deux-points (:), le point-virgule (;), le guillemet simple ('), l'esperluette (&) et l'arobase (@) ne sont pas autorisés non plus.

    Remarque :
    Seuls les caractères valides dans la page de codes Windows en cours sont autorisés dans les noms d'instance SQL Server. En cas d'utilisation d'un caractère Unicode non pris en charge, une erreur d'installation se produit.

Instances et fonctionnalités détectées

Consultez la liste des instances et des composants de SQL Server installés sur l'ordinateur sur lequel le programme d'installation de SQL Server est en cours d'exécution.

ID d'instance - Par défaut, le nom de l'instance est utilisé comme ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et l'ID d'instance sont MSSQLSERVER. Pour utiliser un ID d'instance non défini par défaut, spécifiez-le dans le champ ID d'instance.

Important :
Avec SQL Server SysPrep, l'ID d'instance affiché dans cette page correspond à l'ID d'instance spécifié pendant l'étape de préparation d'image du processus SQL Server SysPrep. Vous ne serez pas en mesure de spécifier un ID d'instance différent pendant l'étape de finalisation d'image.

Remarque :
Les ID d'instance qui commencent par un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Pour plus d'informations sur les répertoires, les emplacements de fichiers et la dénomination d'ID d'instance, consultez Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server.

Répertoire racine de l'instance - Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, cliquez sur le bouton Parcourir ou fournissez un nom de chemin d'accès.

Tous les composants d'une instance donnée de SQL Server sont gérés comme une unité. Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

Tous les composants de SQL Server qui partagent le même nom d'instance doivent remplir les critères suivants :

  • Même version

  • Même édition

  • Mêmes paramètres de langue

  • Même état cluster

    Remarque :
    Reporting Services n'est pas sensible aux clusters.

  • Même système d'exploitation


Sélection de l'instance (Désinstaller)

Sélection de l'instance (Désinstaller)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Dans la page Sélection de l'instance — Désinstaller, utilisez la zone de liste déroulante pour spécifier l'instance de SQL Server à désinstaller.

Options

Vous pouvez spécifier une instance entière de SQL Server ou bien indiquer que seuls les fonctionnalités partagées et les outils d'administration doivent être désinstallés.


Sélection de l'instance (Mise à niveau)

Sélection de l'instance (Mise à niveau)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection de l'instance (Mise à niveau) pour spécifier l'instance de SQL Server à mettre à niveau.

Options

Tous les composants d'une instance doivent être mis à niveau simultanément. Vous ne pouvez ajouter ni supprimer des fonctionnalités au cours de la mise à niveau.


Instance à mettre à niveau

Instance à mettre à niveau |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Instance à mettre à niveau de l'Assistant Installation de SQL Server pour spécifier l'instance de SQL Server 2000 ou SQL Server 2005 que vous souhaitez mettre à niveau vers SQL Server 2008.

Options

Utilisez les cases d'option pour spécifier s'il faut mettre à niveau l'instance de SQL Server et ses composants partagés, ou uniquement les composants partagés. Les composants partagés dans cette version de SQL Server sont les suivants :

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

Pour plus d'informations sur les scénarios de mise à niveau pris en charge et sur les problèmes de mise à niveau connus, consultez Mises à niveau de la version et de l'édition.

Voir aussi

Autres ressources

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions de SQL Server


Minimiser la surface d'exposition de SQL Server 2008

Minimiser la surface d'exposition de SQL Server 2008 |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La réduction de la surface d'exposition est une mesure de sécurité qui implique l'arrêt ou la désactivation de composants inutilisés. La réduction de la surface d'exposition permet de renforcer la sécurité car les risques d'attaque à l'encontre d'un système sont minimisés.

Pour les nouvelles installations de SQL Server 2008, certains services, certaines fonctionnalités et connexions sont désactivés ou arrêtés pour réduire la surface d'exposition de SQL Server. Dans le cas d'installations mises à niveau, tous les services, fonctionnalités et connexions demeurent dans l'état préalable à la mise à niveau.

  • Utilisez le Gestionnaire de configuration de SQL Server pour activer, désactiver, démarrer ou arrêter des services et configurer la connectivité distante de votre moteur de base de données.

  • Utilisez la Gestion basée sur des stratégies pour activer et désactiver des fonctionnalités facultatives.

Utilisation du Gestionnaire de configuration SQL Server

Le Gestionnaire de configuration SQL Server est installé avec toutes les éditions de SQL Server.

Pour ouvrir le Gestionnaire de configuration SQL Server

  1. Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008 R2 et sur Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.
Pour configurer un service de façon à ce qu'il démarre automatiquement

  1. Dans le Gestionnaire de configuration SQL Server, développez Services SQL Server.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur l'un des services SQL Server, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, définissez le Mode de démarrage à Automatique.
Pour configurer le moteur de base de données de façon à accepter les connexions distantes

  1. Dans le Gestionnaire de configuration SQL Server, développez Configuration du réseau SQL Server, puis cliquez sur Protocoles pour <nom_instance>.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur l'un des protocoles disponibles, puis cliquez sur Propriétés.

    Remarque :
    Le protocole de mémoire partagée ne peut pas être activé pour les connexions distantes.

  3. Pour activer un protocole pour les connexions distantes, affectez la valeur Oui à la zone Active.

Pour obtenir de l'assistance concernant le Gestionnaire de configuration SQL Server, consultez le fichier d'aide du Gestionnaire de configuration SQL Server ou la documentation en ligne de SQL Server. Pour configurer les points de terminaison SOAP et Service Broker, utilisez CREATE ENDPOINT et ALTER ENDPOINT.

Utilisation de la Gestion basée sur des stratégies

La configuration de la Gestion basée sur des stratégies s'effectue à l'aide de SQL Server Management Studio. Si Management Studio n'est pas installé, exécutez le programme d'installation et installez les outils clients. Management Studio ne fait pas partie de l'installation de SQL Server Express. Téléchargez Management Studio Express à partir de Microsoft.com. Les fonctionnalités de la Gestion basée sur des stratégies sont décrites dans la documentation en ligne de SQL Server.

Pour ouvrir SQL Server Management Studio

  1. Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008 R2, puis cliquez sur SQL Server Management Studio.
Pour configurer la Gestion basée sur des stratégies

  1. Dans Management Studio, connectez-vous à une instance du moteur de base de données, développez Gestion, puis Gestion de la stratégie.

  2. Configurez la Gestion basée sur des stratégies en utilisant les trois facettes suivantes :

    • Configuration de la surface d'exposition

    • Configuration de la surface d'exposition pour Analysis Services

    • Configuration de la surface d'exposition pour Reporting Services

    Les fonctionnalités de configuration de la surface d'exposition désactivées par défaut ne doivent pas être activées, sauf si les besoins spécifiques de l'entreprise l'exigent.

Paramètres recommandés :

  • Paramètres recommandés pour le moteur de base de données

    Définissez toutes les propriétés de la facette Configuration de la surface d'exposition avec la valeur « faux ».

  • Paramètres recommandés pour Analysis Services

    Définissez toutes les propriétés de la facette Configuration de la surface d'exposition pour Analysis Services avec la valeur « faux ».

  • Paramètres recommandés pour Reporting Services

    Utilisez la Configuration de la surface d'exposition pour Reporting Services afin de désactiver les fonctionnalités Reporting Services dont vous n'avez pas besoin.

Voir aussi

Autres ressources

Procédure : activer ou désactiver un protocole réseau de serveur (Gestionnaire de configuration SQL Server)
Procédure : activer ou désactiver un protocole réseau de serveur (SQL Server PowerShell)
Présentation de la configuration de la surface d'exposition


Nouvelle configuration de batterie de serveurs SharePoint

Nouvelle configuration de batterie de serveurs SharePoint |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Configuration d'une nouvelle batterie de serveurs s'affiche lorsque vous sélectionnez l'option Nouveau Serveur pour le rôle d'installation SQL Server PowerPivot pour SharePoint dans le programme d'installation de SQL Server.

Pour configurer une nouvelle batterie, vous devez disposer d'un serveur SharePoint précédemment installé et non configuré. Le serveur doit être Microsoft SharePoint 2010.

Utilisez cette page pour fournir les informations que le programme d'installation utilise pour initialiser le programme de configuration des produits et technologies SharePoint (psconfig.exe). Le programme d'installation exécutera en arrière-plan le programme de configuration dans le cadre de la procédure d'installation. Le serveur SharePoint sera configuré comme suit :

  • Une base de données de configuration sera créée à l'aide de l'instance du moteur de base de données installé avec Analysis Services lorsque vous sélectionnez le rôle d'installation SQL Server PowerPivot pour SharePoint. L'instance de moteur de base de données sera installée comme une instance nommée PowerPivot.

  • Une application Web et une collection de sites racine seront créées à l'aide de valeurs par défaut.

  • Un service Analysis Services sera installé et configuré. Une application de service PowerPivot par défaut et une base de données seront créées, configurées et associées à l'application Web SharePoint par défaut.

  • Les packages de solution PowerPivot seront déployés dans la batterie de serveurs et dans l'application Web par défaut. La fonctionnalité d'intégration Analysis Services sera activée pour la collection de sites. Une bibliothèque Galerie PowerPivot sera créée.

Options

Spécifier les informations d'identification du compte de la batterie de serveurs.

Spécifiez le compte d'utilisateur de domaine et le mot de passe qui seront utilisés pour exécuter le service de l'Administration centrale de SharePoint et accéder à la base de données de configuration. Vous devez spécifier le compte sous ce format : domaine\nom_utilisateur.

Spécifier les paramètres de sécurité de la batterie de serveurs.

Entrez une phrase secrète que les administrateurs doivent fournir lors de l'ajout de nouveaux serveurs d'applications SharePoint ou serveurs Web frontaux à la batterie.

Configurer l'application Web de l'Administration centrale de SharePoint.

L'Administration centrale est une application Web pour la gestion de la batterie. Le programme d'installation créera cette application sur l'ordinateur actuel. L'accès à l'Administration centrale s'effectue via un numéro de port que vous spécifiez.

Voir aussi

Référence

Sélection de fonctionnalités
Nouvelle configuration de batterie de serveurs SharePoint
Rôle d'installation

Autres ressources

Installation (Analysis Services SharePoint integration) (en anglais)
Configuration matérielle et logicielle requise
How to: Install Analysis Services on a Standalone SharePoint Server (en anglais)


Post-désinstallation

Post-désinstallation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Post-désinstallation pour vérifier que l'opération a été correctement effectuée.

Options

© 2010 Microsoft Corporation. Tous droits réservés.


Progression de la préparation de l'image

Progression de la préparation de l'image |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression de la préparation de l'image de l'Assistant Installation de SQL Server pour contrôler l'état d'installation de la préparation de l'image SQL Server. À l'issue de cette étape, cette page répertorie l'état de chaque fonctionnalité SQL Server préparée durant ce processus.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Règles de préparation d'image

Règles de préparation d'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le programme d'installation de SQL Server valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server
MediaPathLength | Vérifie si le support d'installation SQL Server est trop long. | Vérifiez que le chemin d'accès du support d'installation SQL Server n'est pas trop long
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Le système d'exploitation doit être conforme à la configuration minimale requise pour ce produit. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Le service WMI doit être en cours d'exécution.
Bids2005InstalledCheck | Recherche les versions antérieures de BI Development Studio. | Vous devez effectuer la mise à niveau vers Visual Studio 2008 SP1 avant d'installer SQL Server 2008 R2.
ConfiguredDownlevelFeaturesCheck | Vérifie si une version de SQL Server est installée sans prendre en charge SysPrep. |
FacetDomainControllerCheck | Vérifie si l'ordinateur est un contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera toutes les installations non prises en charge sur une plateforme 64 bits. Les installations WOW ne sont pas prises en charge pour SysPrep.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur est requis en raison d'une bibliothèque ATL de fusion endommagée. Un redémarrage en attente peut provoquer l'échec de l'installation de SQL Server. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer l'ordinateur avant d'installer SQL Server.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
Sql2005SsmsExpressFacet | Vérifie si SQL Server 2005 Express Edition Tools est installé. |
Unconfigured_AsFeatureStateCheck | Vérifie si la fonctionnalité SQL Server SSAS est dans un état non configuré. |
VSShellInstalledRule | Recherche les versions antérieures de Visual Studio 2008. | Vous devez effectuer la mise à niveau vers Visual Studio 2008 SP1 avant d'installer SQL Server 2008 R2.
BlockCrossLanguageInstall | Vérifie si la langue d'installation est la même que la langue des fonctionnalités SQL Server existantes. | Vous devez mettre à niveau SQL Server en utilisant la même version linguistique que l'instance existante de SQL Server.
BlockMixedArchitectureInstall | Vérifie si les fonctionnalités d'installation sont la même architecture de processeur que l'instance spécifiée. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
FAT32FileSystemCheck | Vérifie si le lecteur spécifié est un volume de système de fichiers FAT32. L'installation sur un système de fichiers FAT32 est prise en charge mais n'est pas recommandée car elle est moins sécurisée que le système de fichiers NTFS. | Vérifiez que le lecteur que vous spécifiez pour installer SQL Server n'est pas un système de fichiers FAT32.
Unconfigured_RsFeatureStateCheck | Vérifie si la fonctionnalité Reporting Services est dans un état non configuré. |
Unconfigured_SqlFeatureStateCheck | Vérifie si la fonctionnalité du moteur de base de données SQL Server est dans un état non configuré. |


Préparer le type d'image

Préparer le type d'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Préparer le type d'image de l'Assistant Installation de SQL Server pour spécifier s'il convient d'installer une nouvelle instance de SQL Server 2008 R2 ou d'ajouter des fonctionnalités à une instance existante.

Options

Sélectionnez la case d'option qui correspond à votre choix :

  • Préparer une nouvelle instance de SQL Server 2008 R2

  • Ajouter des fonctionnalités à une instance préparée existante de SQL Server 2008 R2

    Si vous choisissez d'ajouter des fonctionnalités à une instance existante, utilisez la liste déroulante pour sélectionner l'instance préparée de SQL Server à mettre à jour.

    Remarque :
    Vous pouvez ajouter les fonctionnalités prises en charge SQL Server SysPrep (Moteur de base de données et Reporting Services) à une image préparée de SQL Server. Les autres fonctionnalités qui ne sont pas prises en charge par SQL Server SysPrep peuvent être ajoutées uniquement après que l'instance préparée a été finalisée.


Clé du produit

Clé du produit
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Clé du produit pour valider votre instance de SQL Server ou indiquer l'édition gratuite de SQL Server à installer.

Options

Pour indiquer une édition gratuite de SQL Server, sélectionnez la case d'option qui correspond aux installations gratuites, puis utilisez la zone de liste déroulante pour identifier l'édition à installer.

Pour valider une édition payante de SQL Server, sélectionnez la case d'option qui correspond à la clé du produit, puis indiquez votre clé dans l'espace fourni.

Pour les installations de cluster de basculement, utilisez la même clé de produit pour chaque nœud de cluster de basculement. Si la clé du produit provient d'une autre édition de SQL Server, une erreur se produit.


Progression (Désinstaller)

Progression (Désinstaller) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression (Désinstaller) pour contrôler la progression du programme l'installation.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Prêt à finaliser l'image

Prêt à finaliser l'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Prêt à finaliser l'image fournit un résumé des paramètres de configuration appliqués à la configuration de l'instance préparée.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.


Prêt pour l'installation

Prêt pour l'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Prêt pour l'installation fournit un résumé des fonctionnalités qui doivent être installées ou à modifiées par le programme d'installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Prêt à préparer l'image

Prêt à préparer l'image
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Prêt à préparer l'image fournit un résumé des fonctionnalités devant être préparées par le programme d'installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.


Prêt à réparer

Prêt à réparer |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Prêt à réparer fournit un résumé du processus de réparation par le programme d’installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Méthode de récupération

Méthode de récupération
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Faites une sélection, puis cliquez sur Suivant pour continuer.


Supprimer un nœud de cluster de basculement SQL Server

Supprimer un nœud de cluster de basculement SQL Server
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Supprimer un nœud de cluster de basculement pour identifier l'ordinateur à supprimer en tant que nœud de cluster de basculement SQL Server 2008.


Progression de la réparation

Progression de la réparation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression de la réparation de l'Assistant Installation de SQL Server pour vérifier l'état de la réparation de SQL Server.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Options d'installation du serveur de rapports

Options d'installation du serveur de rapports |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Options d'installation du serveur de rapports de l'Assistant Installation de Microsoft SQL Server pour spécifier les options qui déterminent le mode d'installation de l'instance d'un serveur de rapports. La disponibilité d'une option d'installation dépend du fait que vous installez également ou non une instance locale du moteur de base de données SQL Server lors de l'installation du serveur de rapports ; cette disponibilité dépend également de l'existence ou non d'autres valeurs par défaut.

Si le programme d'installation ne peut pas configurer le serveur de rapports par défaut, car une ou plusieurs conditions requises ne sont pas respectées, l'Assistant Installation n'autorise que l'option d'installation minimale ; les fichiers dont vous avez besoin sont copiés mais vous êtes obligé d'utiliser l'outil de configuration de Reporting Services pour configurer le serveur de rapports à la fin de l'installation.

Dans certains cas, si un certificat SSL (Secure Sockets Layer) est installé sur l'ordinateur et lié à un caractère générique fort, le programme d'installation crée les URL Reporting Services à l'aide du préfixe HTTPS. Pour plus d'informations sur la façon dont les certificats sont mappés aux URL Reporting Services, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Remarque :
Un fichier de base de données de serveur de rapports existant peut entraîner l'échec de l'installation si vous choisissez l'une des options d'installation par défaut. Lorsque vous choisissez une option d'installation par défaut, le programme d'installation tente de créer une base de données de serveur de rapports à l'aide du nom par défaut. Si une base de données existe déjà sous ce nom, le programme d'installation échoue et vous devez annuler l'installation. Pour éviter ce problème, vous pouvez renommer la base de données existante avant d'exécuter le programme d'installation ou choisir l'option Installer mais ne pas configurer le serveur afin de pouvoir spécifier des paramètres de base de données personnalisés une fois l'installation terminée.

Options

Installer la configuration par défaut en mode natif

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. Lorsque vous choisissez cette option, l'instance du serveur de rapports est prête à être utilisée à la fin de l'installation. Le programme d'installation crée la base de données du serveur de rapports à l'aide d'une instance locale de moteur de base de données, puis configure un serveur de rapports pour l'utilisation des valeurs par défaut.

Cette option n'est disponible que si les valeurs par défaut utilisées dans l'installation d'un serveur de rapports sont valides pour votre système. Cette option est recommandée pour les développeurs qui souhaitent installer tous les composants localement, ainsi que pour les utilisateurs qui évaluent le logiciel.

Pour afficher les informations relatives aux paramètres par défaut utilisés par le programme d'installation ou pour déterminer la raison pour laquelle la configuration par défaut ne peut pas être installée, cliquez sur Détails. Pour plus d'informations sur la configuration par défaut pour un serveur de rapports en mode natif, consultez Configuration par défaut pour une installation en mode natif (Reporting Services).

Installer la configuration par défaut en mode intégré SharePoint

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. La base de données du serveur de rapports est créée dans un format qui prend en charge le stockage et l'adressage de contenu à partir d'un site SharePoint. Pour plus d'informations sur cette option d'installation, consultez Configuration par défaut pour le mode intégré SharePoint (Reporting Services).

Après l'installation d'une instance du serveur de rapports en mode intégré SharePoint, des étapes de configuration supplémentaires doivent être réalisées afin de finaliser l'intégration à un environnement SharePoint. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

Installer mais ne pas configurer le serveur

Installe les fichiers programme du serveur de rapports, crée le compte de service Report Server et inscrit le fournisseur WMI (Windows Management Instrumentation) du serveur de rapports. Cette option d'installation porte également le nom d'installation de « fichiers uniquement ». Sélectionnez cette option si vous ne souhaitez pas utiliser la configuration par défaut. Si la configuration par défaut ne peut pas être installée, ou si vous installez un cluster de basculement SQL Server qui inclut Reporting Services, cette option est la seule disponible. Pour plus d'informations sur l'installation de fichiers uniquement, consultez Installation de fichiers uniquement (Reporting Services).

Une fois l'installation terminée, vous devez créer la base de données du serveur de rapports et configurer le serveur de rapports de sorte qu'il puisse être utilisé. Pour configurer un serveur de rapports et créer la base de données correspondante, utilisez l'outil de configuration de Reporting Services. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports et Configuration d'une connexion de base de données de serveur de rapports.

Voir aussi

Autres ressources

Procédure : lancer la configuration de Reporting Services
Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)
Considérations sur l'installation de Reporting Services
Configuration par défaut pour une installation en mode natif (Reporting Services)


Options de configuration et d'installation de Reporting Services

Options de configuration et d'installation de Reporting Services
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du serveur de rapports de l'Assistant Installation de Microsoft SQL Server pour spécifier les options qui déterminent le mode d'installation de l'instance d'un serveur de rapports. La disponibilité d'une option d'installation dépend du fait que vous installez également ou non une instance locale du moteur de base de données SQL Server lors de l'installation du serveur de rapports ; cette disponibilité dépend également de l'existence ou non d'autres valeurs par défaut.

Si le programme d'installation ne peut pas configurer le serveur de rapports par défaut, car une ou plusieurs conditions requises ne sont pas respectées, l'Assistant Installation n'autorise que l'option d'installation minimale ; les fichiers dont vous avez besoin sont copiés mais vous êtes obligé d'utiliser l'outil de configuration de Reporting Services pour configurer le serveur de rapports à la fin de l'installation.

Dans certains cas, si un certificat SSL (Secure Sockets Layer) est installé sur l'ordinateur et lié à un caractère générique fort, le programme d'installation crée les URL Reporting Services à l'aide du préfixe HTTPS. Pour plus d'informations sur la façon dont les certificats sont mappés aux URL Reporting Services, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Remarque :
Un fichier de base de données de serveur de rapports existant peut entraîner l'échec de l'installation si vous choisissez l'une des options d'installation par défaut. Lorsque vous choisissez une option d'installation par défaut, le programme d'installation tente de créer une base de données de serveur de rapports à l'aide du nom par défaut. Si une base de données existe déjà sous ce nom, le programme d'installation échoue et vous devez annuler l'installation. Pour éviter ce problème, vous pouvez renommer la base de données existante avant d'exécuter le programme d'installation ou choisir l'option Installer mais ne pas configurer le serveur afin de pouvoir spécifier des paramètres de base de données personnalisés une fois l'installation terminée.

Options

Installer la configuration par défaut en mode natif

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. Lorsque vous choisissez cette option, l'instance du serveur de rapports est prête à être utilisée à la fin de l'installation. Le programme d'installation crée la base de données du serveur de rapports à l'aide d'une instance locale du moteur de base de données, puis configure un serveur de rapports pour l'utilisation des valeurs par défaut.

Cette option n'est disponible que si les valeurs par défaut utilisées dans l'installation d'un serveur de rapports sont valides pour votre système. Cette option est recommandée pour les développeurs qui souhaitent installer tous les composants localement, ainsi que pour les utilisateurs qui évaluent le logiciel.

Pour afficher les informations relatives aux paramètres par défaut utilisés par le programme d'installation ou pour déterminer la raison pour laquelle la configuration par défaut ne peut pas être installée, cliquez sur Détails. Pour plus d'informations sur la configuration par défaut pour un serveur de rapports en mode natif, consultez Configuration par défaut pour une installation en mode natif (Reporting Services).

Installer la configuration par défaut en mode intégré SharePoint

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. La base de données du serveur de rapports est créée dans un format qui prend en charge le stockage et l'adressage de contenu à partir d'un site SharePoint.

Pour plus d'informations sur cette option d'installation, consultez Configuration par défaut pour le mode intégré SharePoint (Reporting Services).

Installer mais ne pas configurer le serveur

Installe les fichiers programme du serveur de rapports, crée le compte de service Report Server et inscrit le fournisseur WMI (Windows Management Instrumentation) du serveur de rapports. Cette option d'installation porte également le nom d'installation de « fichiers uniquement ». Sélectionnez cette option si vous ne souhaitez pas utiliser la configuration par défaut. Si la configuration par défaut ne peut pas être installée, ou si vous installez un cluster de basculement SQL Server qui inclut Reporting Services, cette option est la seule disponible. Pour plus d'informations sur l'installation de fichiers uniquement, consultez Installation de fichiers uniquement (Reporting Services).

Une fois l'installation terminée, vous devez créer la base de données du serveur de rapports et configurer le serveur de rapports de sorte qu'il puisse être utilisé. Pour configurer un serveur de rapports et créer la base de données correspondante, utilisez l'outil de configuration de Reporting Services. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports et Configuration d'une connexion de base de données de serveur de rapports.

Installation du complément Reporting Services pour SharePoint Technologies

Pour installer le complément Reporting Services pour SharePoint Technologies, cliquez sur le fichier rsSharePoint.msi dans le dossier d'installation sur le média d'installation SQL Server après avoir complété l'installation de SQL Server. Vous pouvez également télécharger le complément. Pour plus d'informations, consultez Complément SQL Server® 2008 R2 Reporting Services CTP NOV pour Microsoft SharePoint® Technologies 2010.


Mots clés réservés (programme d'installation)

Mots clés réservés (programme d'installation)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

SQL Server utilise des mots clés réservés pour définir, manipuler et ajouter des bases de données. Les mots clés réservés font partie de la grammaire Transact-SQL, qui est utilisée par SQL Server pour analyser et comprendre les instructions et les lots Transact-SQL.

Les noms des instances SQL Server ne peuvent pas correspondre à un mot clé réservé. Aidez-vous du tableau suivant pour vous assurer que les mots clés réservés ne sont pas utilisés dans les noms des instances SQL Server.

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

De plus, la norme ISO définit une liste de mots clés réservés. Évitez d'utiliser des mots clés réservés ISO pour des identificateurs et des noms d'objets. La liste des mots clés réservés ODBC figurant dans le tableau ci-dessous est identique à celle des mots clés réservés ISO.

Remarque :
La liste des mots clés réservés ISO peut être parfois plus restrictive ou moins restrictive que la liste SQL Server. Par exemple, la liste de mots clés réservés ISO contient INT. SQL Server ne traite pas INT comme un mot clé réservé.

Mots clés réservés ODBC

Les mots suivants sont réservés et utilisés dans les appels de fonctions ODBC. Ces mots ne limitent pas la grammaire SQL minimale. Cependant, pour garantir la compatibilité avec les pilotes qui gèrent la grammaire SQL de base, il est préférable de ne pas utiliser ces mots clés dans les noms d'instance SQL Server.

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |


Sélectionner une instance préparée

Sélectionner une instance préparée
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélectionner une instance préparée pour spécifier l'instance préparée que vous souhaitez finaliser.

Options

La zone Sélectionner un ID d'instance répertorie les instances préparées que vous pouvez finaliser. Sélectionnez une instance préparée que vous souhaitez finaliser.

Sélectionner un ID d'instance

La liste inclut toutes les instances préparées que vous pouvez finaliser sur l'ordinateur sur lequel le programme d'installation SQL Server s'exécute. Sélectionnez une instance préparée que vous souhaitez finaliser.

Instances installées

Cette liste inclut les instances installées, préparées et finalisées.


Configuration du serveur - Classement

Configuration du serveur - Classement |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Dans la page Configuration du serveur - Classement de l'Assistant Installation de SQL Server, vous pouvez modifier les paramètres de classement utilisés par le moteur de base de données et Analysis Services pour le tri. Sélectionnez l'option pour correspondre aux paramètres de classement de différentes installations de SQL Server ou d'un autre ordinateur.

Options

Personnaliser pour SQL Server et Analysis Services

SQL Server fournit deux groupes de classements : les classements Windows et les classements SQL Server. Vous pouvez spécifier des paramètres de classement distincts pour le moteur de base de données et pour Analysis Services ou spécifier le même classement pour tous les deux.

Par défaut, un classement SQL Server est sélectionné pour les paramètres régionaux système de langue anglaise (US). Le classement par défaut pour les versions localisées de SQL Server est la valeur des paramètres régionaux système Windows pour votre ordinateur. Pour plus d'informations, consultez Utilisation des classements SQL Server.

Les paramètres par défaut ne doivent être modifiés que si le paramètre de classement de cette installation de SQL Server doit se conformer aux paramètres de classement utilisés par une autre instance de SQL Server ou aux paramètres régionaux système Windows d'un autre ordinateur.

Remarque Analysis Services utilise uniquement les classements Windows. Si vous prévoyez d'installer Analysis Services, sélectionnez un classement Windows pendant l'exécution du programme d'installation de SQL Server afin de garantir des résultats cohérents entre le moteur de base de données SQL Server et Analysis Services.

Pour plus d'informations, consultez Paramètres de classement du programme d'installation.

Recommandations

Pour plus d'informations sur une table de paramètres régionaux système Windows et les classements par défaut correspondants utilisés par le programme d'installation de SQL Server, consultez Paramètres de classement du programme d'installation.

Dans la mesure du possible, choisissez un classement unique pour votre organisation. De cette manière, vous n'avez pas à spécifier explicitement le classement pour chaque base de données, colonne, expression ou identificateur. Si vous devez utiliser plusieurs classements et paramètres de page de codes, codez vos requêtes conformément aux règles de priorité des classements. Pour plus d'informations, consultez la rubrique Priorité de classement (Transact-SQL) dans la documentation en ligne.

Lorsque vous sélectionnez un classement pour SQL Server, considérez les recommandations suivantes :

  • Sélectionnez un classement BINARY2 si le classement basé sur les points de code binaires est acceptable.

  • Sélectionnez un classement Windows pour une comparaison cohérente entre les différents types de données.

  • Utilisez le nouveau classement de niveau 100 pour une meilleure prise en charge du tri linguistique. Pour plus d'informations, consultez Prise en charge d'Unicode et du classement.

  • Si vous prévoyez de migrer une base de données vers l'instance mise à niveau de SQL Server, sélectionnez le classement qui correspond au classement existant de la base de données.

Voir aussi

Autres ressources

Options de classement et prise en charge d'Unicode
Paramètres de classement du programme d'installation


Configuration du serveur - Comptes de service

Configuration du serveur - Comptes de service |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du serveur de l'Assistant Installation de SQL Server pour attribuer des comptes de connexion aux services SQL Server. Les services configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

Options

Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration des comptes de service Windows.

Configurer les comptes de service SQL Server individuellement (recommandé)

Utilisez la grille pour attribuer à chaque service SQL Server un nom d'utilisateur et un mot de passe d'ouverture de session et définir le type de démarrage pour le service. Vous pouvez utiliser des comptes système intégrés, un compte local, un groupe local, un groupe de domaine ou des comptes d'utilisateurs de domaine pour les services SQL Server.

Sélectionnez l'un des services suivants pour en personnaliser les paramètres.

Sélectionnez ce service Pour configurer les paramètres d'authentification pour

SQL Server Agent

Service qui exécute les travaux, analyse SQL Server et autorise l'automatisation de certaines tâches administratives.

Il n'y a aucun compte d'ouverture de session par défaut pour ce service.

Le type de démarrage par défaut est Manuel.

SQL Server

Le moteur de base de données SQL Server.

Il n'y a aucun compte d'ouverture de session par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

SQL Server Browser

SQL Server Browser est le service de résolution des noms qui fournit des informations de connexion SQL Server aux ordinateurs clients. Ce service est partagé entre plusieurs instances SQL Server et Integration Services.

Le compte d'ouverture de session par défaut est AUTORITE NT\Service local ; il ne peut pas être modifié durant l'installation de SQL Server. Vous pouvez modifier le compte une fois l'installation terminée.

Si le type de démarrage n'est pas spécifié pendant l'installation, il est déterminé comme suit :

  • La valeur Automatique est affectée au démarrage de SQL Server Browser et ce dernier s'exécute dans les scénarios d'installation décrits ci-dessous :

    • Instance de cluster de basculement SQL Server

    • Instance nommée de SQL Server où est activé le protocole TCP ou celui des canaux nommés

    • Instance nommée du serveur d'analyse non cluster

    • Mise à niveau de SQL Server 2000 ou existence d'une instance de SQL Server 2000 sur l'ordinateur

  • Si aucun des scénarios ci-dessus ne s'applique et si SQL Server Browser est déjà installé, l'état actuel de SQL Server Browser est conservé.

  • La valeur Désactivé est affectée au type de démarrage et ce dernier est arrêté en l'absence d'une instance de SQL Server 2005 ou de SQL Server 2008 avant l'installation.

Analysis Services

Analysis Services.

Il n'y a aucun compte d'ouverture de session par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

Pour le mode intégré SharePoint, vous devez spécifier un compte d'utilisateur de domaine Windows. Le compte que vous spécifiez est utilisé pour le service Analysis Services. Le compte que vous spécifiez pour l'instance actuelle doit également être utilisé pour toutes les instances supplémentaires d'Analysis Services que vous ajoutez par la suite à la même batterie. Pour plus d'informations, consultez Procédure : installer PowerPivot pour SharePoint sur un nouveau serveur SharePoint.

Reporting Services

Reporting Services. Les comptes de service sont utilisés pour configurer une connexion à la base de données du serveur de rapports. Choisissez le service réseau intégré si vous souhaitez utiliser les paramètres d'authentification par défaut. Si vous spécifiez un compte d'utilisateur de domaine, assurez-vous d'inscrire un nom principal de service (SPN) pour ce compte si vous utilisez l'authentification Windows sur le serveur de rapports. Pour plus d'informations, consultez Procédure : configurer l'authentification Windows dans Reporting Services.

Important :
Microsoft vous recommande de ne pas utiliser le compte Service réseau pour les services SQL Server ou SQL Server Agent si un compte disposant de privilèges moindres est disponible, car Service réseau est un compte partageable. Service réseau convient uniquement à une utilisation comme compte de service SQL Server si vous pouvez garantir qu'aucun autre service qui utilise le compte n'est installé sur l'ordinateur. Les comptes Utilisateur local ou Utilisateur de domaine qui ne sont pas administrateur Windows sont plus appropriés pour les services SQL Server.

Il n'y a aucun compte d'ouverture de session par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Le compte d'ouverture de session par défaut pour ce service est NT Authority\Service réseau.

Le type de démarrage par défaut est Automatique.

Lanceur de démon de filtre de texte intégral SQL Server

Service qui crée les processus fdhost.exe. Ce service est obligatoire pour héberger les analyseurs lexicaux et filtres qui traitent les données textuelles pour l'indexation de texte intégral.

Fournissez un compte dans lequel exécuter le service du lanceur FDHOST. Nous vous recommandons vivement d'utiliser un compte à faibles privilèges. Ce compte doit être différent de celui que vous utilisez pour le service SQL Server. Sur Windows Vista et Windows Server 2008, le compte du service du lanceur FDHOST prend pour valeur par défaut SERVICE LOCAL.

Pour des raisons de sécurité, sur des versions de Windows antérieures à Windows Vista et Windows Server 2008, nous vous recommandons d'utiliser un compte UTILISATEUR LOCAL créé spécialement comme compte du service du lanceur FDHOST. L'utilisation d'un compte SYSTÈME LOCAL, SERVICE LOCAL ou SERVICE RÉSEAU risque de fournir accidentellement des privilèges accrus pour le service et de réduire ainsi la sécurité de votre installation de SQL Server.

Le service du lanceur FDHOST est démarré automatiquement sauf si le compte de service n'est pas valide ou que vous n'en spécifiez pas (sur Windows Server 2003 ou Windows XP).

Voir aussi

Autres ressources

Considérations de sécurité pour une installation SQL Server


Assistant Cluster de basculement SQL Server - Terminé

Assistant Cluster de basculement SQL Server - Terminé |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008 R2. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.

Voir aussi

Référence

Règles de support du programme d'installation


Assistant Cluster de basculement SQL Server - Installer

Assistant Cluster de basculement SQL Server - Installer |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008 R2. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.

Voir aussi

Référence

Règles de support du programme d'installation


Assistant Cluster de basculement SQL Server - Préparer

Assistant Cluster de basculement SQL Server - Préparer |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008 R2. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Référence

Règles de support du programme d'installation


Résumé (Mise à niveau)

Résumé (Mise à niveau)
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Résumé pour afficher les options spécifiées pour cette mise à niveau.


Règles de support du programme d'installation

Règles de support du programme d'installation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Analyse de la configuration système de l'Assistant Installation de SQL Server indique la progression de l'outil de validation du système. Les routines de l'Analyse de la configuration système recherchent sur l'ordinateur où SQL Server sera installé les conditions susceptibles de bloquer le programme d'installation.

Options

Le bouton Suivant est uniquement disponible si tous les résultats d'analyse sont positifs ou si les échecs d'analyse ne bloquent pas le programme d'installation.

Utilisez le bouton Afficher les détails pour afficher le résumé des règles et des résultats d'analyse. La colonne État à droite des résultats de l'analyse affiche l'état de chaque élément. Cliquez sur l'état d'un élément pour consulter les détails.

Le tableau suivant décrit les paramètres de contrôle pour le SCC, les spécifications et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Vérifiez que la version du système d'exploitation est conforme à la configuration minimale requise pour ce produit. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des droits d'administrateur sur l'ordinateur. | Vérifiez que le compte qui exécute le programme d'installation de SQL Server a des droits d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Vérifiez que le service WMI (Windows Management Instrumentation) est en cours d'exécution.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis de SQL Server 2008 R2 Express with Advanced Services. | Pour les installations de Microsoft SQL Server 2008 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Permet de déterminer si le programme d'installation est pris en charge sur la plate-forme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.

Rubriques supplémentaires relatives aux règles

Consultez les rubriques suivantes pour des règles d'installation spécifiques au scénario :

  • Règles d'installation

  • Mettre à niveau le contrôle des règles

  • Règles de mise à niveau de l'édition

  • Règles de désinstallation

  • Règles de préparation d'image

  • Règles de finalisation d'image


Règles de désinstallation

Règles de désinstallation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Règles de désinstallation exécute un ensemble de règles pour garantir le succès de l'installation.

Options

Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système, les spécifications et la résolution des problèmes bloquants :

Élément d'analyse | Description | Action de l'utilisateur
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Vérifiez que la version du système d'exploitation est conforme à la configuration minimale requise pour ce produit.
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Vérifiez que le service WMI fonctionne.
BlockMismatchedArchitectureUninstall | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de supprimer est différente de celle de ce programme d'installation. | L'architecture du programme d'installation doit être identique à celle de l'instance de SQL Server que vous désinstallez.

Rubriques supplémentaires relatives aux règles

Pour plus d'informations, consultez la rubrique suivante :

  • Règles de support du programme d'installation.


Progression de la mise à niveau

Progression de la mise à niveau |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression de la mise à niveau de l'Assistant Installation de SQL Server pour vérifier l'état de la mise à niveau de SQL Server.

Voir aussi

Concepts

Procédure : afficher et lire les fichiers journaux d'installation de SQL Server


Mettre à niveau le contrôle des règles

Mettre à niveau le contrôle des règles |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 R2 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Pour plus d'informations, consultez Considérations de sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008 R2. | Pour les installations de SQL Server 2008 R2 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 R2 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 R2 sur un autre ordinateur.
UCPEditionDowngradeCheck | Détermine si un UCP SQL Server est pris en charge sur cette édition de SQL Server. | Un UCP SQL Server est pris en charge sur SQL Server 2008 R2 Datacenter, Enterprise, Developer ou Enterprise Evaluation.

Voir aussi

Référence

Règles de support du programme d'installation


Vérifier les options de désinstallation

Vérifier les options de désinstallation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Vérifiez votre sélection, puis cliquez sur Suivant pour continuer.


La rubrique que vous recherchez n'est pas disponible tant que le programme d'installation n'a pas terminé l'installation de la documentation en ligne.

La rubrique que vous recherchez n'est pas disponible tant que le programme d'installation n'a pas terminé l'installation de la documentation en ligne.

Une fois l'installation terminée, vous pouvez consulter la documentation de SQL Server en cliquant sur Aide, en appuyant sur la touche F1 dans les boîtes de dialogue ou les éléments d'interface, ou (à partir du menu Démarrer) en pointant sur Tous les programmes, sur Microsoft SQL Server 2005, sur Documentation et didacticiels, puis en cliquant sur Documentation en ligne de SQL Server.