Vue d'ensemble de l'installation de SQL Server

Aide du programme d'installation de SQL Server
Vue d'ensemble de l'installation de SQL Server |
 | Voir aussi

L'Assistant Installation de SQL Server est basé sur Windows Installer. Il fournit une arborescence de fonctionnalités unique pour l'installation de tous les composants SQL Server :

  • Le Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Outils d'administration

  • Documentation et exemples

Remarque SQL Server est disponible en éditions 32 bits et 64 bits. Pour plus d'informations, consultez Planification d'une installation SQL Server.

Que vous utilisiez l'Assistant Installation de SQL Server ou l'invite de commandes pour installer SQL Server, le processus d'installation implique les étapes suivantes :

Dans cette section

Planification d'une installation SQL Server

Décrit comment préparer l'ordinateur pour SQL Server :

  • Vérifier les configurations matérielle et logicielle requises.

  • Vérifier les spécifications de l'Outil d'analyse de configuration système et les problèmes bloquants.

  • Vérifier les remarques sur la sécurité d'une installation SQL Server.

Installation de SQL Server 2008

Décrit les options d'installation de SQL Server :

  • Installer à l'aide de l'Assistant Installation.

  • Installer à partir d'une invite de commandes.

Configuration de SQL Server 2008

Décrit comment configurer SQL Server à l'aide des utilitaires graphiques et d'invite de commandes.

Sections connexes

Considérations relatives à l'installation du moteur de base de données SQL Server

Explique comment installer et configurer le Moteur de base de données SQL Server.

Considérations sur l'installation d'Analysis Services

Explique comment installer et configurer SQL Server Analysis Services.

Considérations sur l'installation de Reporting Services

Explique comment installer et configurer SQL Server Reporting Services.

Considérations sur l'installation de SQL Server Integration Services

Explique comment installer et configurer SQL Server Integration Services.

Considérations sur l'installation de la réplication SQL Server

Explique comment installer et configurer la réplication SQL Server.

Directives pour l'installation des outils d'administration SQL Server

Décrit comment installer et configurer les outils d'administration SQL Server.

Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server

Explique comment installer et configurer les exemples SQL Server.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

© 2008 Microsoft Corporation. Tous droits réservés.


Nouveautés liées à l'installation de SQL Server

Nouveautés liées à l'installation de SQL Server |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

SQL Server 2008 dispose d'une nouvelle architecture d'installation pour les scénarios suivants : installation, mise à niveau, maintenance, clustering de basculement et installations d'invite de commandes.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)
Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)
Procédure : créer un cluster de basculement SQL Server (programme d'installation)

Concepts

Planification d'une installation SQL Server
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Installation de démarrage rapide de SQL Server 2008

Installation de démarrage rapide de SQL Server 2008 |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

L'Assistant Installation de SQL Server fournit une arborescence de fonctionnalités unique pour l'installation de tous les composants SQL Server suivants :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Outils d'administration

  • Composants de connectivité

  • Exemples de bases de données, exemples et documentation en ligne de SQL Server

Ces rubriques supplémentaires décrivent d'autres façons d'installer SQL Server 2008 :

  • Pour installer SQL Server à partir de l'invite de commandes, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

  • Pour installer un cluster de basculement, consultez Procédure : créer un cluster de basculement SQL Server (programme d'installation).

  • Pour mettre à niveau une instance existante de SQL Server to SQL Server 2008, consultez Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation).

Configuration requise

Avant d'installer SQL Server, consultez la rubrique Planification d'une installation SQL Server.

Remarque :
Pour les installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine doté d'autorisations de lecture et d'exécution sur le partage distant.

Procédures

Pour installer SQL Server 2008

  1. Insérez le support d'installation SQL Server et, dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis réexécutez le programme d'installation de SQL Server 2008.

  4. Une fois que les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour créer une installation de SQL Server 2008, cliquez sur Nouvelle installation ou ajouter des fonctionnalités à une installation existante.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. À ce stade, des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. Dans la page Clé de produit, cliquez sur une case d'option pour indiquer si vous installez une édition gratuite de SQL Server ou si vous disposez d'une clé PID pour une version de production du produit. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008.

  7. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour mettre fin au programme d'installation, cliquez sur Annuler.

  8. L'Assistant Installation installera les composants SQL Server requis s'ils ne sont pas déjà présents sur l'ordinateur. Cela comprend les éléments suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  9. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive. Lorsque la vérification est terminée, cliquez sur Suivant pour poursuivre.

  10. Dans la page Sélection de fonctionnalités, sélectionnez les composants que vous voulez installer. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Vous pouvez activer les cases à cocher de votre choix, quelle qu'en soit la combinaison. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008.

    Vous pouvez également spécifier un répertoire personnalisé pour les composants partagés en utilisant le champ situé au bas de cette page. Pour modifier le chemin d'installation des composants partagés, mettez à jour le nom du chemin d'accès dans le champ fourni en bas de la boîte de dialogue ou cliquez sur le bouton Parcourir pour accéder à un répertoire d'installation. Le chemin d'installation par défaut est C:\Program Files\Microsoft SQL Server\.

  11. Dans la page Configuration de l'instance, spécifiez s'il faut installer une instance par défaut ou une instance nommée. Pour plus d'informations, consultez Configuration d'une instance. Pour continuer, cliquez sur Suivant.

    Suffixe de l'ID d'instance - Par défaut, le nom de l'instance est utilisé comme suffixe de l'ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et le suffixe de l'ID d'instance seront MSSQLSERVER. Pour utiliser un suffixe d'ID d'instance non défini par défaut, activez la case à cocher Suffixe de l'ID d'instance et entrez une valeur.

    Remarque :
    Les instances autonomes typiques de SQL Server 2008, qu'il s'agisse d'instances par défaut ou d'instances nommées, n'utilisent pas de valeur non définie par défaut pour la case à cocher Suffixe de l'ID d'instance.

    Répertoire racine de l'instance - Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, utilisez le champ fourni ou cliquez sur Parcourir pour rechercher un dossier d'installation.

    Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

    Instances et fonctionnalités détectées - La grille affiche les instances de SQL Server qui se trouvent sur l'ordinateur où le programme d'installation s'exécute. Si une instance par défaut est déjà installée sur l'ordinateur, vous devez installer une instance nommée de SQL Server 2008. Pour continuer, cliquez sur Suivant.

  12. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez. Elle compare ensuite ces besoins à l'espace disque disponible. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  13. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  14. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

    Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte d'ouverture de session pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  15. Utilisez l'onglet Configuration du serveur - Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  16. Utilisez la page Configuration du moteur de base de données – Mise en service du compte pour spécifier les éléments suivants :

    • Mode de sécurité - sélectionnez l'authentification Windows ou le mode d'authentification mixte pour votre instance de SQL Server. Si vous sélectionnez Mode d'authentification mixte, vous devez fournir un mot de passe fort pour le compte administrateur système SQL Server intégré.

      Lorsque la connexion d'un périphérique à SQL Server est établie, le mécanisme de sécurité est le même pour l'authentification Windows et le mode mixte. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    • Administrateurs SQL Server - Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou sur Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  17. Utilisez la page Configuration du Moteur de base de données – Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration du moteur de base de données – Répertoires de données.

  18. Utilisez la page Configuration du Moteur de base de données - FILESTREAM pour activer FILESTREAM pour votre instance de SQL Server. Pour plus d'informations sur FILESTREAM, consultez Configuration du moteur de base de données - Filestream. Pour continuer, cliquez sur Suivant.

  19. Utilisez la page Configuration d'Analysis Services - Attribution de privilèges d'accès aux comptes pour spécifier les utilisateurs ou comptes qui ont les autorisations d'administrateur pour Analysis Services. Vous devez spécifier au moins un administrateur système pour Analysis Services. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour Analysis Services. Pour plus d'informations, consultez Configuration Analysis Services – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  20. Utilisez la page Configuration du Analysis Services – Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration de Analysis Services – Répertoires de données.

  21. Utilisez la page Configuration de Reporting Services pour spécifier le type d'installation de Reporting Services à créer. Vous pouvez choisir entre les options suivantes :

    • Configuration par défaut en mode Natif

    • Configuration par défaut en mode SharePoint

    • Installation de Reporting Services non configurée

    Pour plus d'informations sur les modes de configuration de Reporting Services, consultez Options d'installation du serveur de rapports.

  22. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  23. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  24. La page Prêt pour l'installation affichage une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  25. Au cours de l'installation, la page Progression de l'installation fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  26. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  27. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Configurer votre nouvelle installation de SQL Server

  • Pour réduire la surface d'exposition d'un système, SQL Server installe et active de façon sélective les services et les fonctionnalités clés. Pour plus d'informations, consultez Présentation de la configuration de la surface d'exposition sur MSDN.

  • Pour plus d'informations sur l'utilisation des outils graphiques et des utilitaires d'invite de commandes, consultez Configuration de SQL Server 2008.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Éditions et composants de SQL Server 2008

Éditions et composants de SQL Server 2008 |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

La configuration requise pour l'installation varie selon vos besoins applicatifs. Les différentes éditions de SQL Server s'adaptent aux exigences de chaque organisation et de chaque individu en termes de performances, d'exécution et de prix. Les composants SQL Server que vous installez dépendent également de vos exigences spécifiques. Les sections suivantes vous aident à choisir au mieux les éditions et les composants disponibles dans SQL Server 2008.

Éditions serveur de SQL Server 2008

Le tableau ci-dessous décrit les éditions serveur de SQL Server 2008 :

Intitulé Définition

Enterprise (x86, x64 et IA64)1

SQL Server Enterprise est une plateforme de données complète qui offre une évolutivité, des performances, une haute disponibilité et des fonctions Business Intelligence avancées de classe d'entreprise pour exécuter des applications sécurisées, vitales pour l'entreprise. Pour plus d'informations, consultez Fonctionnalités prises en charge par les éditions de SQL Server 2008.

Standard (x86 et x64)

SQL Server Standard est une plateforme de données complète qui offre facilité d'utilisation et facilité de gestion. Elle inclut des fonctions décisionnelles intégrées pour exécuter des applications au sein des divers services de l'entreprise. Pour plus d'informations, consultez Fonctionnalités prises en charge par les éditions de SQL Server 2008.

SQL Server Standard for Small Business renferme tous les composants et les fonctions techniques de l'édition SQL Server Standard. Disponible sous licence pour fonctionner dans un environnement de PME de 75 ordinateurs ou moins.

1Enterprise est disponible dans la version d'évaluation de SQL Server 2008 Enterprise pendant une période de 180 jours. Pour plus d'informations, consultez le site Web de SQL Server.

Éditions spécialisées de SQL Server 2008

Les éditions spécialisées de SQL Server 2008 sont conçues pour des scénarios client spécifiques. Le tableau ci-dessous décrit ces éditions de SQL Server 2008 :

Intitulé Définition

SQL Server 2008 Developer Edition (x86, x64 et IA64)

SQL Server 2008 Developer Edition permet aux développeurs de créer des applications par-dessus SQL Server. Elle inclut toutes les fonctionnalités de SQL Server 2008 Enterprise Edition, mais sa licence permet de l'utiliser comme un système de développement et de test, et non comme un serveur de production. SQL Server 2008 Developer Edition constitue le choix idéal pour les personnes qui génèrent et testent des applications. Vous pouvez mettre à niveau SQL Server 2008 Developer Edition à des fins de production.

Workgroup (x86 et x64)

SQL Server Workgroup est idéal pour exécuter les bases de données à emplacement de branche qui fournissent une gestion de données fiable et une plateforme de création de rapports qui inclut la synchronisation sécurisée, distante et les fonctions de gestion.

Web (x86, x64)

SQL Server 2008 Web est une option avec un coût total de possession faible pour les hôtes Web et les sites Web qui fournissent des fonctions d'évolutivité et de facilité de gestion pour les propriétés Web à petite ou grande échelle.

SQL Server Express (x86 et x64)

SQL Server Express with Advanced Services (x86 et x64)

La plateforme de base de données SQL Server Express s'appuie sur SQL Server 2008. Elle permet également de remplacer Microsoft Desktop Engine (MSDE). Intégré à Visual Studio, SQL Server Express facilite le développement d'applications pilotées par des données qui sont riches en possibilités, fiables au niveau du stockage et rapides à déployer.

SQL Server Express est libre et peut être redistribué par un éditeur de logiciels (selon le contrat). SQL Server Express est idéal pour apprendre et créer des applications bureau et de petites applications serveur. Cette édition constitue la solution idéale pour les éditeurs de logiciels, les développeurs non professionnels et les amateurs de création d'applications clientes. Si vous avez besoin de fonctionnalités de base de données plus évoluées, vous pouvez mettre à niveau de manière transparente SQL Server Express vers des versions plus sophistiquées de SQL Server.

Compact 3.5 SP1 (x86)

Compact 3.1 (x86)

SQL Server Compact 3.5 est une base de données gratuite et intégrée, qui convient parfaitement au développement d'applications autonomes et occasionnellement connectées pour les périphériques mobiles, les bureaux et les clients Web, sur toutes les plateformes Windows.

Pour plus d'informations sur les éditions spécialisées de SQL Server 2008, consultez le site SQL Server Web.

Utilisation de SQL Server avec un serveur Internet

Sur un serveur Internet, comme un serveur exécutant les services Internet (IIS), vous installez généralement les outils clients SQL Server. Les outils clients comprennent les composants de connectivité clients utilisés par une application qui se connecte à une instance SQL Server.

Remarque :
Bien que vous puissiez installer une instance SQL Server sur un ordinateur exécutant les services Internet (IIS), ceci ne se fait en général que pour des sites Web de petite taille qui ne possèdent qu'un seul ordinateur serveur. La plupart des sites Web disposent de leur système IIS de niveau intermédiaire sur un serveur ou sur un cluster de serveurs, et de leurs bases de données sur un serveur distinct ou sur une fédération distincte de serveurs. Pour plus d'informations sur les exigences logicielles pour SSRS, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008. Pour plus d'informations sur les fédérations, consultez la rubrique Serveurs de bases de données fédérés dans la documentation en ligne de SQL Server.

Utilisation de SQL Server avec des applications client/serveur

Vous pouvez installer uniquement les composants clients de SQL Server sur un ordinateur exécutant des applications client/serveur qui se connectent directement à une instance de SQL Server. Une installation de composants clients est également un bon choix si vous administrez une instance SQL Server sur un serveur de base de données ou si vous prévoyez de développer des applications SQL Server.

L'option de composants clients installe les fonctionnalités SQL Server suivantes : outils d'invite de commandes, outils Reporting Services, composants de connectivité, modèles de programmation, outils d'administration, outils de développement et Documentation en ligne deSQL Server. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 (programme d'installation).

Choix des composants SQL Server

Utilisez la page Sélection de composant de l'Assistant Installation de SQL Server pour sélectionner les composants à inclure dans une installation de SQL Server. Par défaut, aucune des fonctionnalités incluses dans l'arborescence n'est sélectionnée.

Utilisez les informations des tableaux suivants pour déterminer le jeu de fonctionnalités qui répond le mieux à vos besoins :

Composants serveur | Description
Moteur de base de données SQL Server | Moteur de base de données SQL Server inclut le Moteur de base de données, le service principal de stockage, de traitement et de protection des données, la réplication, la recherche en texte intégral et les outils de gestion de données relationnelles et XML.
Analysis Services | Analysis Services inclut les outils de création et de gestion d'applications de traitement analytique en ligne (OLAP, OnLine Analytical Processing) et d'exploration de données.
Reporting Services | Reporting Services inclut les composants serveur et clients permettant de créer, de gérer et de déployer des rapports tabulaires, de matrice, graphiques et de forme libre. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports.
Integration Services | Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Outils d'administration | Description
SQL Server Management Studio | SQL Server Management Studio est un environnement intégré qui permet d'avoir accès, de configurer, de gérer, d'administrer et de développer des composants de SQL Server. Management Studio permet aux développeurs et aux administrateurs de tous niveaux d'utiliser SQL Server. Internet Explorer 6.0 SP1 ou version ultérieure est requis pour l'installation de Management Studio.
Gestionnaire de configuration SQL Server | Le Gestionnaire de configuration SQL Server permet de gérer la configuration de base des servicesSQL Server, des protocoles serveur et clients et des alias clients.
Générateur de profils SQL Server | Générateur de profils SQL Server fournit une interface utilisateur graphique qui permet d'analyser une instance du Moteur de base de données ou Analysis Services.
Assistant Paramétrage du moteur de base de données | L'Assistant Paramétrage du moteur de base de données permet de créer des jeux d'index, des vues indexées et des partitions optimaux.
Business Intelligence Development Studio | Le Business Intelligence Development Studio est un IDE pour les solutions Analysis Services, Reporting Services et Integration Services. Internet Explorer 6.0 SP1 ou version ultérieure est requis pour l'installation de BI Development Studio.
Composants de connectivité | Installe des composants permettant la communication entre les clients et les serveurs, et des bibliothèques réseau pour DB-Library, ODBC et OLE DB.

Documentation | Description
Documentation en ligne de SQL Server | Documentation de base de SQL Server.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Concepts

Planification d'une installation SQL Server


Fonctionnalités prises en charge par les éditions de SQL Server 2008

Fonctionnalités prises en charge par les éditions de SQL Server 2008 |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

Aidez-vous des tableaux suivants pour déterminer les fonctionnalités prises en charge par les différentes éditions de Microsoft SQL Server 2008.

Remarque :
SQL Server Enterprise est disponible dans une édition d'évaluation pour une période d'essai de 180 jours. Pour plus d'informations sur l'obtention d'une copie d'évaluation de SQL Server 2008, consultez ce site Web de Microsoft.

Évolutivité

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Partitionnement | Oui |  |  |  |  |
Compression des données | Oui |  |  |  |  |
Gouverneur de ressources | Oui |  |  |  |  |
Parallélisme de table de partition | Oui |  |  |  |  |

Haute disponibilité

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Prise en charge de plusieurs instances | 50 | 16 | 16 | 16 | 16 | 16
Modifications de système en ligne | Oui | Oui | Oui | Oui | Oui | Oui
Copie du journal de sauvegarde | Oui | Oui | Oui | Oui |  |
Mise en miroir de bases de données | Oui (niveau complet) | Oui (niveau complet sécurité uniquement) | Témoin uniquement | Témoin uniquement | Témoin uniquement | Témoin uniquement
Gestion de clusters de basculement | Maximum du système d'exploitation1 | 2 nœuds |  |  |  |
AWE dynamique | Oui | Oui |  |  |  |
Basculement sans configuration client | Oui | Oui |  |  |  |
Récupération d'altération automatique à partir du miroir | Oui | Oui |  |  |  |
Captures instantanées de base de données | Oui |  |  |  |  |
Récupération rapide | Oui |  |  |  |  |
Indexation en ligne | Oui |  |  |  |  |
Restauration en ligne | Oui |  |  |  |  |
sauvegardes en miroir | Oui |  |  |  |  |
Ajout de mémoire à chaud | Oui |  |  |  |  |
Configuration en ligne de nœuds P2P | Oui |  |  |  |  |
Ajout d'un processeur à chaud | Oui |  |  |  |  |
Compression de sauvegarde | Oui |  |  |  |  |

1Windows Server 2003 prend en charge un maximum de 8 nœuds de cluster de basculement. Windows Server 2008 prend en charge un maximum de 64 nœuds de cluster de basculement.

Sécurité

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Suivi conforme C2 | Oui | Oui | Oui | Oui | Oui | Oui
Fondation d'audit SQL | Oui | Oui | Oui | Oui | Oui | Oui
Audit à granularité fine | Oui |  |  |  |  |
Chiffrement transparent de base de données | Oui |  |  |  |  |
Chiffrement ISV (gestion de clés Off-box) | Oui |  |  |  |  |

Réplication

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Réplication de fusion | Oui | Oui | Abonné uniquement | Abonné uniquement | Abonné uniquement | Abonné uniquement
Réplication transactionnelle | Oui | Oui | Abonné uniquement | Abonné uniquement | Abonné uniquement | Abonné uniquement
Réplication de capture instantanée | Oui | Oui | Abonné uniquement | Abonné uniquement | Abonné uniquement | Abonné uniquement
Suivi des modifications SQL Server | Oui | Oui | Oui | Oui | Oui | Oui
Abonnés hétérogènes | Oui | Oui |  |  |  |
publication Oracle | Oui |  |  |  |  |
Réplication transactionnelle P2P | Oui |  |  |  |  |

Simplicité de gestion

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Instances d'utilisateur |  |  |  |  | Oui | Oui
Connexion administrateur dédiée | Oui | Oui | Oui | Oui | Oui (Sous indicateur de trace) | Oui (Sous indicateur de trace)
Configuration basée sur une stratégie | Oui | Oui | Oui | Oui | Oui | Oui
Gestion basée sur des stratégies | Oui | Oui | Oui | Oui | Oui | Oui
Collecte de données de performance et entrepôt | Oui | Oui | Oui | Oui |  |
Rapports de performances standard | Oui | Oui |  |  |  |
Repères de plan | Oui | Oui |  |  |  |
Gel de plan pour les repères de plan | Oui | Oui |  |  |  |
Meilleures pratiques recommandées basées sur une stratégie | Oui | Oui |  |  |  |
Gestion basée sur des stratégies multiserveur | Oui | Oui |  |  |  |
Vues partitionnées distribuées | Oui |  |  |  |  |
Opérations d'index parallèles | Oui |  |  |  |  |
Correspondance automatique requête et vue indexée | Oui |  |  |  |  |
Contrôle de somme de la sauvegarde de la base de données en parallèle | Oui |  |  |  |  |
Messagerie de base de données | Oui | Oui | Oui | Oui |  |
Outils de migration de base de données | Oui | Oui | Oui | Oui | Oui | Oui

Outils de gestion

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
SQL management objects (SMO) | Oui | Oui | Oui | Oui | Oui | Oui
Gestionnaire de configuration SQL | Oui | Oui | Oui | Oui | Oui | Oui
SQL CMD (outil d'invite de commandes) | Oui | Oui | Oui | Oui | Oui | Oui
SQL Server Management Studio | Oui | Oui | Oui | Oui (version Express) |  | Oui (version Express)
Générateur de profils SQL | Oui | Oui | Oui | Oui |  |
Agent SQL Server | Oui | Oui | Oui | Oui |  |
Assistant Paramétrage de base de données . | Oui | Oui | Oui | Oui |  |
Pack Microsoft Operations Manager | Oui | Oui | Oui | Oui |  |

Outils de développement

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Intégration de Microsoft Visual Studio | Oui | Oui | Oui | Oui | Oui | Oui
Outils de conception et de modification de requêtes SQL | Oui | Oui | Oui |  |  |
Intellisense (Transact-SQL et MDX) | Oui | Oui | Oui |  |  |
Prise en charge du contrôle des versions | Oui | Oui | Oui |  |  |
Business Intelligence Development Studio | Oui | Oui |  |  |  |
Outils de conception, de modification et de débogage MDX | Oui | Oui |  |  |  |

Programmabilité

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Intégration du CLR (Common Language Runtime) | Oui | Oui | Oui | Oui | Oui | Oui
Prise en charge XML natif | Oui | Oui | Oui | Oui | Oui | Oui
Indexation XML | Oui | Oui | Oui | Oui | Oui | Oui
Fonctions MERGE et UPSERT | Oui | Oui | Oui | Oui | Oui | Oui
prise en charge de FILESTREAM | Oui | Oui | Oui | Oui | Oui | Oui
Types de données de date et d'heure | Oui | Oui | Oui | Oui | Oui | Oui
Support d'internationalisation | Oui | Oui | Oui | Oui | Oui | Oui
Recherche en texte intégral | Oui | Oui | Oui | Oui |  | Oui
Spécification d'une langue dans une requête | Oui | Oui | Oui | Oui |  | Oui
Service broker (messagerie) | Oui | Oui | Oui | Client uniquement | Client uniquement | Client uniquement
Prise en charge de XML/A | Oui | Oui |  |  |  |
Services Web (points de terminaison HTTP/SOAP) | Oui | Oui |  |  |  |

Services d'emplacement et spatiaux

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Index spatiaux | Oui | Oui | Oui | Oui | Oui | Oui
Type de données géodésique | Oui | Oui | Oui | Oui | Oui | Oui
Bibliothèques spatiales avancées | Oui | Oui | Oui | Oui | Oui | Oui
Prise en charge spatiale reposant sur des standards | Oui | Oui | Oui | Oui | Oui | Oui

Integration Services

Fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Assistant Importation et Exportation SQL Server avec les sources de base et les destinations ainsi que la tâche d'exécution SQL | Oui | Oui | Oui | Oui | Oui | Oui
runtime Integration Services | Oui | Oui | Oui | Oui | Oui | Oui
Modèle d'objet et API Integration Services | Oui | Oui | Oui | Oui |  |
Concepteur SSIS y compris les scripts VSTA | Oui | Oui |  |  |  |
Service Integration Services, Assistants et utilitaires d'invite de commandes | Oui | Oui |  |  |  |
Tâches de base et transformations | Oui | Oui |  |  |  |
Modules fournisseurs d'informations et journalisation | Oui | Oui |  |  |  |
Outils de profilage des données | Oui | Oui |  |  |  |
Sources supplémentaires et destinations : Source de fichier brut Source XML Destination DataReader Destination de fichier brut Destination du jeu d'enregistrements Destination SQL Server Compact Destination SQL Server | Oui | Oui |  |  |  |
Sources avancées, transformations et destinations : Transformation de requête d'exploration de données Transformations de recherche floue et de regroupement probable Extraction de terme et Transformation de recherche de terme Destination d'apprentissage du modèle d'exploration de données Destination de traitement de dimension Destination de traitement de partition | Oui |  |  |  |  |

Création d'entrepôt de données

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Création de cubes sans une base de données | Oui | Oui |  |  |  |
Génération automatique de la zone de transit et du schéma de l'entrepôt de données | Oui | Oui |  |  |  |
Concepteur de relations d'attributs | Oui | Oui |  |  |  |
Concepteurs d'agrégation efficaces | Oui | Oui |  |  |  |

Échelle d'entrepôt de données et de performance

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Capture de données modifiées | Oui |  |  |  |  |
Optimisation de requête jointure en étoile | Oui |  |  |  |  |
///Configuration AS en lecture seule évolutive | Oui |  |  |  |  |
Mise en cache proactive | Oui |  |  |  |  |
Traitement automatique des partitions parallèles | Oui |  |  |  |  |
Cubes partitionnés | Oui |  |  |  |  |
Cubes partitionnés distribués | Oui |  |  |  |  |

Analyse multidimensionnelle

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Service SQL Server Analysis Services | Oui | Oui |  |  |  |
Sauvegarde SQL Server Analysis Services | Oui | Oui |  |  |  |
Amélioration générale des performances/d'échelle | Oui | Oui |  |  |  |
Amélioration de dimension, de relation d'attribut, d'agrégat et de conception de cube | Oui | Oui |  |  |  |
Extensions de personnalisation | Oui | Oui |  |  |  |
Agrégations financières | Oui |  |  |  |  |
Clients partitionnés | Oui |  |  |  |  |
Cumuls personnalisés | Oui |  |  |  |  |
Mesures semi-additives | Oui |  |  |  |  |
Dimensions d'écriture différée | Oui |  |  |  |  |
Dimensions et mesures liées | Oui |  |  |  |  |
Transport XML binaire et compressé | Oui |  |  |  |  |
Intelligence comptable | Oui |  |  |  |  |
Perspectives | Oui |  |  |  |  |
Analysis Services partagés, bases de données évolutives | Oui |  |  |  |  |

Exploration de données

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Algorithmes standard | Oui | Oui |  |  |  |
Outils d'exploration de données: Assistant, éditeurs, générateurs de requête | Oui | Oui |  |  |  |
Validation croisée | Oui |  |  |  |  |
Modèles sur les sous-ensembles filtrés de données de structure d'exploration de données | Oui |  |  |  |  |
Série chronologique : fusion personnalisée entre les modèles ARTXP et ARIMA | Oui |  |  |  |  |
Série chronologique : prédiction avec les nouvelles données | Oui |  |  |  |  |
Requêtes d'exploration de données simultanées illimitées | Oui |  |  |  |  |
Configuration avancée et paramétrage des algorithmes | Oui |  |  |  |  |
API de plug-ins d'algorithmes | Oui |  |  |  |  |
Traitement parallèle | Oui |  |  |  |  |
Série chronologique : prédiction inter-série | Oui |  |  |  |  |
Attributs illimités pour les règles d'association | Oui |  |  |  |  |
Prédiction de séquence | Oui |  |  |  |  |
Plusieurs cibles de prédiction pour naïve Bayes, réseau neuronal et régression logistique | Oui |  |  |  |  |

Création de rapports

Nom de la fonctionnalité | Enterprise | Standard | Workgroup | Web | Express | Express Advanced
Report Server | Oui | Oui | Oui | Oui |  | Oui
Concepteur de rapports | Oui | Oui | Oui | Oui |  | Oui
Gestionnaire de rapports | Oui | Oui | Oui | Oui (Gestionnaire de rapports) |  | Oui (Gestionnaire de rapports)
Sécurité basée sur les rôles | Oui | Oui | Oui (Rôles fixes) | Oui (Rôles fixes) |  | Oui (Rôles fixes)
Création de rapports ad-hoc [Générateur de rapports] | Oui | Oui | Oui |  |  |
Exportation Word et mise en forme de texte améliorée | Oui | Oui | Oui | Oui |  | Oui
Moteur de création de rapports à l'échelle de l'entreprise | Oui | Oui | Oui | Oui |  | Oui
Déploiement de rapport de diagnostic IIS | Oui | Oui | Oui | Oui |  | Oui
Outils d'administration mis à jour | Oui | Oui | Oui | Oui |  | Oui
Report Definition Customization Extension (RDCE) | Oui | Oui | Oui | Oui |  | Oui
Intégration SharePoint | Oui | Oui |  |  |  |
Jauges et graphiques SSRS améliorés | Oui | Oui | Oui | Oui |  | Oui
Authentification personnalisée | Oui | Oui | Oui | Oui |  |
Exporter vers Excel, PDF et images | Oui | Oui | Oui | Oui |  | Oui
Prise en charge de sources de données distantes et non relationnelles | Oui | Oui |  |  |  |
Remise par messagerie électronique et partage de fichiers | Oui | Oui |  |  |  |
Historique de rapport, planification, abonnements et mise en cache | Oui | Oui |  |  |  |
Source de données, remise et extensibilité de rendu | Oui | Oui |  |  |  |
Montée en puissance parallèle (batteries de serveurs Web) | Oui |  |  |  |  |
Rapport généré interactif infini | Oui |  |  |  |  |
Abonnements pilotés par les données | Oui |  |  |  |  |
Limites de la mémoire Reporting Services | Illimité | Illimité | 4 Go | 4 Go |  | 4 Go

Voir aussi

Référence

Mises à niveau de la version et de l'édition

Concepts

Vue d'ensemble de l'installation de SQL Server
Installation de démarrage rapide de SQL Server 2008

Autres ressources

Spécifications de produit pour SQL Server 2008


À propos des termes du contrat de licence SQL Server

À propos des termes du contrat de licence SQL Server |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

Les termes de la Licence d'utilisation du logiciel Microsoft sont copiés vers l'ordinateur local lorsque SQL Server est installé. Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue. Les fichiers sont enregistrés dans : %ProgramFiles%\Microsoft SQL Server\100\EULA\ ou %ProgramFiles(x86)%\Microsoft SQL Server\100\EULA\.

Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue.

Le nom de fichier des termes du contrat de licence indique l'édition de SQL Server ainsi que l'édition linguistique de SQL Server : Par exemple :

  • License_DEV_ENU.txt pour SQL Server 2008 Developer Edition, édition en langue anglaise.

  • License_STD_ITA.txt pour SQL Server Standard, édition en langue italienne.

  • License_UA_JPN.txt pour le Conseiller de mise à niveau SQL Server, édition en langue japonaise.

  • License_SQLNCLI_ENU.txt pour SQL Native Client, édition en langue anglaise.

  • License_SQLXML4_KOR.txt pour SQLXML, édition en langue coréenne.

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - Conseiller de mise à niveau

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • ENU - Anglais

  • JPN - Japonais

  • FRA - Français

  • ITA - Italien

  • KOR - Coréen

  • DEU - Allemand

  • ESN - Espagnol

  • CHS - Chinois simplifié

  • CHT - Chinois traditionnel

  • NLA - Néerlandais

  • PTB - Portugais (Brésil)

  • SVE - Suédois

  • RUS - Russe

Options de licences de SQL Server

Pour plus d'informations sur les prix et les options de licences de SQL Server, consultez le site Web Microsoft SQL Server.

Voir aussi

Concepts

Déclaration de confidentialité SQL Server
Notice légale pour documentation


Déclaration de confidentialité SQL Server

Déclaration de confidentialité SQL Server
Vue d'ensemble de l'installation de SQL Server >

Pour plus d'informations sur les composants de la collecte de données utilisateur de SQL Server 2008, consultez la Déclaration de confidentialité de SQL Server 2008.


Notice légale pour documentation

Notice légale pour documentation
Vue d'ensemble de l'installation de SQL Server >

Cette documentation, ainsi que les exemples d'applications inclus, est fourni à titre d'information uniquement et Microsoft Corporation et ses fournisseurs n'assurent aucune garantie, expresse ou implicite, dans le cadre de la présente documentation. Les informations contenues dans cette documentation, notamment les URL et autres références à des sites Web Internet, pourront faire l'objet de modifications sans préavis. L'utilisateur reconnaît assumer tous les risques liés à l'utilisation ou aux résultats de l'utilisation de cette documentation.

Sauf mention contraire, les exemples de sociétés, d'organisations, de produits, de noms de domaine, d'adresses de messagerie, de personnes, de lieux et d'événements sont fictifs et toute ressemblance avec des sociétés, des organisations, des produits, des noms de domaine, des adresses de messagerie, des personnes, des lieux ou des événements réels serait tout à fait fortuite. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Aucune partie de cette documentation ne peut être reproduite, stockée ou introduite dans un système de restitution, ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, photocopie, enregistrement ou autre) sans la permission expresse et écrite de Microsoft Corporation.

Les produits mentionnés dans cette documentation peuvent faire l'objet de brevets, de dépôts de brevets en cours, de marques, de droits d'auteur ou d'autres droits de propriété intellectuelle et industrielle de Microsoft. Sauf stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de cette documentation n'a pas pour effet de vous concéder une licence sur ces brevets, marques, ni de vous céder des droits d'auteur ou autres droits de propriété intellectuelle quels qu'ils soient.

© 2008 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Serve et Windows Vista sont soit des marques de Microsoft Corporation, soit des marques déposées de Microsoft Corporation, aux États-Unis d'Amérique et/ou dans d'autres pays.

SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

La documentation de SQL Server 2008 inclut la documentation en ligne de SQL Server, les fichiers Lisez-moi, les documents relatifs aux problèmes recensés, les exemple de code, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux caractéristiques et fonctionnalités SQL Server. Cette stratégie de support et de mise à niveau s'applique à la totalité de la documentation de SQL Server 2008, y compris aux fichiers Lisez-moi des versions et Services Packs SQL Server 2008 ; un fichier Lisez-moi est considéré comme une extension de la documentation en ligne de SQL Server 2008.

Un exemple présenté dans cette documentation sert principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Aucun support technique n'est disponible pour ces exemples, ni pour le code source fourni.

Dans certains cas, une fonctionnalité particulière de Microsoft SQL Server 2008 n'a pas été suffisamment testée ou développée, et n'est pas destinée à votre utilisation. De telles fonctionnalités se retrouvent alors sous forme d'espaces réservés. Par conséquent, certaines fonctionnalités incluses dans le logiciel ne sont pas documentées. Les fonctionnalités qui ne sont pas documentées ou qui sont incluses comme notation pour une utilisation interne de Microsoft ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Sauf spécification contraire de la documentation de Microsoft SQL Server 2008, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec Microsoft SQL Server 2008, n'est pas pris en charge par le support technique de Microsoft et peut également entraîner une perte des données. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent les points d'entrée non documentés comme les API non documentées, y compris, entre autres, les éléments suivants : des procédures stockées, des procédures stockées étendues, des fonctions, des vues, des tables, des colonnes, des propriétés ou des métadonnées.

Les mises à niveau de serveur et de base de données vers les versions ultérieures de SQL Server 2008 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge. L'utilisation des fonctionnalités SQL Server et de celles incluses dans Microsoft SQL Server sans être documentées dans la documentation SQL Server 2008 destinée à votre utilisation n'est pas prise en charge et peut provoquer une perte des données.


Considérations relatives aux licences de SQL Server 2008

Considérations relatives aux licences de SQL Server 2008 |
 | Voir aussi
Vue d'ensemble de l'installation de SQL Server >

Pour plus d'informations sur les options de licences de SQL Server 2008, consultez ce site Web de Microsoft SQL Server .

Voir aussi

Référence

À propos des termes du contrat de licence SQL Server

Concepts

Déclaration de confidentialité SQL Server
Notice légale pour documentation


Planification d'une installation SQL Server

Planification d'une installation SQL Server |
 | Voir aussi

Pour installer SQL Server 2008, suivez ces étapes :

  • Prenez connaissance des conditions requises pour l'installation, des options d'installation, des contrôles de configuration du système et des considérations sur la sécurité pour une installation SQL Server 2008.

  • Exécutez le programme d'installation de SQL Server pour installer ou mettre à niveau SQL Server 2008.

  • Configurez SQL Server à l'aide des utilitaires SQL Server.

Que vous utilisiez l'Assistant Installation de SQL Server ou l'invite de commandes pour installer SQL Server, les rubriques suivantes présentent le processus de planification de SQL Server.

Dans cette section

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Décrit les configurations matérielle et logicielle requises pour SQL Server, la prise en charge du système d'exploitation, les considérations relatives au réseau et à Internet, et l'espace disque requis.

Paramètres de l'outil d'analyse de configuration système

Décrit la configuration requise pour l'Outil d'analyse de configuration système SQL Server.

Considérations sur la sécurité pour une installation SQL Server

Décrit des considérations sur la sécurité pour une installation SQL Server.

Éditions et composants de SQL Server 2008

Décrit les éditions et composants de SQL Server.

Mise à niveau vers SQL Server 2008

Décrit les options pour mettre à niveau à SQL Server.

Migration vers SQL Server 2008

Décrit les options pour migrer vers SQL Server.

Configuration de SQL Server 2008

Décrit les outils de configuration de SQL Server.

Sections connexes

Considérations relatives à l'installation du moteur de base de données SQL Server

Cette section explique comment installer et configurer le Moteur de base de données SQL Server.

Considérations sur l'installation d'Analysis Services

Cette section explique comment installer et configurer SQL Server Analysis Services.

Considérations sur l'installation de Reporting Services

Cette section explique comment installer et configurer SQL Server Reporting Services.

Considérations sur l'installation de SQL Server Integration Services

Cette section décrit comment installer et configurer Integration Services.

Considérations sur l'installation de la réplication SQL Server

Cette section explique comment installer et configurer la réplication SQL Server.

Mise en route avec le clustering de basculement de SQL Server 2008

Décrit des scénarios pour le clustering avec basculement SQL Server.

Directives pour l'installation des outils d'administration SQL Server

Cette section explique comment installer et configurer les outils de gestion SQL Server.

Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server

Cette section explique comment installer les exemples AdventureWorks.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Concepts

Installation de démarrage rapide de SQL Server 2008
Procédure : installer SQL Server 2008 à partir de l'invite de commandes
Avant l'installation du clustering de basculement

Autres ressources

Vue d'ensemble des solutions à haute disponibilité


Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 |
 | Voir aussi
Planification d'une installation SQL Server >

Les sections suivantes présentent les configurations matérielle et logicielle minimales requises pour l'exécution de SQL Server 2008.

Pour les éditions 32 bits et 64 bits de SQL Server 2008, les remarques suivantes s'appliquent :

  • SQL Server 2008 Enterprise est disponible pour évaluation pendant une période d'essai de 180 jours. Pour plus d'informations, consultez le site Web relatif à l'achat de SQL Server.

  • Microsoft vous recommande d'exécuter SQL Server 2008 sur des ordinateurs dotés du format de fichier NTFS. Pour les mises à niveau vers SQL Server 2008, les systèmes de fichiers FAT32 ne seront pas bloqués.

  • Le programme d'installation de SQL Server bloquera les installations sur les lecteurs en lecture seule ou les lecteurs compressés.

  • Pour plus d'informations sur les outils SQL Server 2008 permettant de préparer une mise à niveau vers SQL Server 2008, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

  • SQL Server n'installe pas le kit de développement logiciel (SDK) de .NET Framework 3.5. Toutefois, le Kit de développement logiciel (SDK) contient des outils qui sont utiles lorsque vous utilisez le .NET Framework pour le développement SQL Server. Vous pouvez télécharger le Kit de développement .NET Framework SDK à partir du site Web .NET Framework (en anglais).

  • Nécessité de redémarrer les ordinateurs pendant l'installation de SQL Server : l'installation du .NET Framework requiert un redémarrage du système d'exploitation. Si l'installation effectuée avec Windows Installer requiert également un redémarrage, le programme d'installation attendra que les composants .NET Framework et Windows Installer soient installés avant de redémarrer.

  • Pour plus d'informations sur les fonctionnalités de SQL Server 2008, consultez les sites suivants :

    • Éditions et composants de SQL Server 2008

    • Fonctionnalités prises en charge par les éditions de SQL Server 2008

Configuration matérielle et logicielle requise

La configuration requise suivante s'applique à toutes les installations de SQL Server 2008 :

Composant Configuration requise

Framework2

Le programme d'installation de SQL Server installe les composants logiciels suivants requis par le produit :

  • .NET Framework 3.51

  • SQL Server Native Client

  • Fichiers de support d'installation de SQL Server

Logiciels2

Le programme d'installation de SQL Server nécessite Microsoft Windows Installer 4.5 ou version ultérieure et Microsoft Data Access Components (MDAC) 2.8 SP1 ou version ultérieure. Vous pouvez télécharger MDAC 2.8 SP1 à partir du site Web des téléchargements MDAC.

Après avoir installé les composants requis, le programme d'installation de SQL Server vérifie si l'ordinateur sur lequel SQL Server 2008 doit être installé est conforme à la configuration requise pour s'assurer du succès de l'installation. Pour plus d'informations, consultez Paramètres de l'outil d'analyse de configuration système.

Logiciel réseau

La configuration logicielle réseau requise pour les versions 64 bits de SQL Server 2008 est identique à celle requise pour les versions 32 bits.

Les systèmes d'exploitation pris en charge possèdent un logiciel réseau intégré. Les instances par défaut et les instances nommées autonomes prennent en charge les protocoles réseau suivants :

  • Mémoire partagée

  • Canaux nommés

  • TCP/IP

  • VIA

Remarque Le protocole de mémoire partagée et le protocole VIA ne sont pas pris en charge sur les clusters de basculement.

Virtualisation

SQL Server 2008 est pris en charge dans les environnements d'ordinateur virtuel qui s'exécutent sur le rôle Hyper-V dans les éditions Standard, Enterprise et Data Center de Windows Server 2008. L'ordinateur virtuel doit exécuter un système d'exploitation pris en charge pour l'édition SQL Server 2008 spécifique répertoriée ultérieurement dans cette rubrique.

En plus des ressources requises par la partition parente, chaque ordinateur virtuel (partition enfant) doit être fourni avec des ressources processeur, mémoire et disque suffisantes pour son instance de SQL Server 2008. Les configurations requises sont répertoriées ultérieurement dans cette rubrique.3

Dans le rôle Hyper-V sur Windows Server 2008, un maximum de quatre processeurs virtuels peuvent être alloués aux ordinateurs virtuels qui exécutent les éditions 32 bits ou 64 bits de Windows Server 2008. Un maximum de 2 processeurs virtuels peut être alloué aux ordinateurs virtuels qui exécutent les éditions 32 bits de Windows Server 2003. Pour les ordinateurs virtuels qui hébergent d'autres systèmes d'exploitation, un maximum d'un processeur virtuel peut leur être alloué.

Remarques :

  • Il est recommandé d'arrêter SQL Server 2008 avant d'arrêter l'ordinateur virtuel.

  • Le clustering avec basculement d'invité (configuration du clustering avec basculement dans SQL Server 2008) n'est pas pris en charge dans un environnement Hyper-V.

  • Pour plus d'informations sur le rôle Hyper-V dans Windows Server 2008, consultez le site Web Windows Server 2008.

Logiciel Internet

Microsoft Internet Explorer 6.0 SP1 ou version ultérieure est requis pour toutes les installations de SQL Server 2008. Internet Explorer 6.0 SP1 ou version ultérieure est requis pour la console MMC (Microsoft Management Console), SQL Server Management Studio, Business Intelligence Development Studio, le composant Concepteur de rapports de Reporting Services et l'aide HTML.

Disque dur

L'espace disque requis varie avec les composants SQL Server 2008 que vous installez. Pour plus d'informations, consultez Espace disque requis plus loin dans cette rubrique.

Lecteur

Un lecteur de CD ou de DVD, selon le cas, est obligatoire pour l'installation à partir d'un CD ou d'un DVD.

Écran

Les outils graphiques SQL Server 2008 requièrent une résolution VGA ou supérieure : 1 024 x 768 pixels, au minimum.

Autres périphériques

Dispositif de pointage : une souris Microsoft ou un dispositif de pointage compatible est requis.

1Les versions suivantes de .NET Framework sont requises :

  • SQL Server 2008 sur Windows Server 2003 (64 bits) IA64 — .NET Framework 2.0 SP1

  • Toutes les autres éditions deSQL Server 2008 — .NET Framework 3.5

L'installation du composant .NET Framework nécessite le redémarrage du système d'exploitation. Si l'installation effectuée avec Windows Installer requiert également un redémarrage, le programme d'installation attendra que les composants .NET Framework et Windows Installer soient installés avant de redémarrer.

2 Le programme d'installation de SQL Server n'installera pas les composants requis suivants pour SQL Server Express et SQL Server Express with Advanced Services. Vous devez installer ces composants manuellement avant d'exécuter le programme d'installation de SQL Server :

  • SQL Server Express — ..NET Framework 2.0 SP2 et Windows installer 4.5. Sur Windows Vista, utilisez .NET Framework 3.5 SP1.

  • SQL Server Express with Advanced Services — .NET Framework 3.5 SP1, Windows Installer 4.5 et Windows PowerShell 1.0.

3Comme avec toutes les technologies de virtualisation, SQL Server 2008 s'exécutant sur un ordinateur virtuel Hyper-V Windows Server 2008 sera plus lent que sur un ordinateur physique disposant des mêmes ressources physiques.

Processeur, mémoire et système d'exploitation requis

Pour consulter la configuration requise, sélectionnez une édition de SQL Server 2008 :

Éditions serveur de SQL Server 2008

  • SQL Server 2008 Enterprise (64 bits) IA64

  • SQL Server 2008 Enterprise (64 bits) x64

  • SQL Server 2008 Standard (64 bits) x64

  • SQL Server 2008 Enterprise (32 bits)

  • SQL Server 2008 Standard (32 bits)

Éditions spécialisées de SQL Server 2008

  • SQL Server 2008 Developer (64 bits) IA64

  • SQL Server 2008 Developer (64 bits) x64

  • SQL Server 2008 Workgroup (64 bits) x64

  • SQL Server 2008 Web (64 bits) x64

  • SQL Server 2008 Express (64 bits) x64

  • SQL Server 2008 Express Advanced (64 bits) x64

  • SQL Server 2008 Developer (32 bits)

  • SQL Server 2008 Workgroup (32 bits)

  • SQL Server 2008 Web (32 bits)

  • SQL Server 2008 Express et Express with Advanced Services (32 bits)

Informations supplémentaires dans cette rubrique

  • Espace disque dur requis

  • Prise en charge multilingue

  • Prise en charge de l'installation de SQL Server 2008 sur un contrôleur de domaine

Éditions serveur (64 bits et 32 bits)

SQL Server 2008 Enterprise (64 bits) IA64

Le tableau suivant contient la configuration requise pour SQL Server 2008 Enterprise (64 bits) IA64. Notez que cette édition de SQL Server 2008 n'est pas disponible dans les versions localisées suivantes : italien, espagnol, brésilien (portugais) et russe.

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur Itanium ou plus rapide

Vitesse du processeur :

  • Recommandé : 1 GHz ou plus

Système d'exploitation

Windows Server 2008 64 bits Itanium1,2

Windows Server 2003 SP2 64 bits Itanium Data Center1,2

Windows Server 2003 SP2 64 bits Itanium Enterprise1

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Les outils d'administration sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter de façon native en mode 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

2 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Enterprise (64 bits) x64

Le tableau suivant contient la configuration requise pour SQL Server 2008 Enterprise (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel 2003 64 bits x643

Windows Server 2003 SP2 64 bits x64 Standard1

Windows Server 2003 SP2 64 bits x64 Data Center1

Windows Server 2003 SP2 64 bits x64 Enterprise1

Windows Vista 64 bits x64 Édition Intégrale 3

Windows Vista 64 bits x64 Édition Familiale Premium 3

Windows Vista 64 bits x64 Édition Familiale Basique 3

Windows Vista 64 bits x64 Enterprise3

Windows Vista 64 bits x64 Professionnel 3

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V2,4

Windows Server 2008 64 bits x64 Data Center

Windows Server 2008 64 bits x64 Data Center sans Hyper-V1,2

Windows Server 2008 64 bits x64 Enterprise,

Windows Server 2008 64 bits x64 Enterprise sans Hyper-V1,2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Les outils d'administration sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter de façon native en mode 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

2 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

3Cette version de Windows prend en chargeSQL Server 2008 Enterprise Evaluation, pas Enterprise.

SQL Server 2008 Standard (64 bits) x64

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Standard (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel x64

Windows Server 2003 SP2 64 bits x64 Standard1,2

Windows Server 2003 SP2 64 bits x64 Data Center1,2

Windows Server 2003 SP2 64 bits x64 Enterprise1,2

Windows Vista Édition Intégrale x64

Windows Vista Enterprise x64

Windows Vista Professionnel x64

Windows Server 2008 x64 Web1

Windows Server 2008 x64 Standard, Windows Server 2008 x64 Standard sans Hyper-V1,2

Windows Server 2008 x64 Data Center, Windows Server 2008 x64 Data Center sans Hyper-V1,2

Windows Server 2008 x64 Enterprise, Windows Server 2008 x64 Enterprise sans Hyper-V1,2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

2 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Enterprise (32 bits)

Le tableau suivant contient la configuration requise pour SQL Server 2008 Enterprise (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel SP21

Windows XP SP2 Tablet1

Windows XP SP2 Media Center 20021

Windows XP SP2 Media Center 20041

Windows XP Media Center 20051

Windows XP Professionnel Édition multimédia condensée1

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 Small Business Server SP2 Standard

Windows Server 2003 Small Business Server SP2 Premium

Windows Server 2003 SP2 64 bits x64 Standard2

Windows Server 2003 SP2 64 bits x64 Data Center2

Windows Server 2003 SP2 64 bits x64 Enterprise2

Windows Vista Édition Intégrale1

Windows Vista Édition Familiale Premium1

Windows Vista Édition Familiale Basique1

Windows Vista Enterprise1

Windows Vista Professionnel1

Windows Vista 64 bits x64 Édition Intégrale 1,2

Windows Vista 64 bits x64 Édition Familiale Premium1,2

Windows Vista 64 bits x64 Édition Familiale Basique1,2

Windows Vista 64 bits x64 Enterprise1,2

Windows Vista 64 bits x64 Professionnel1,2

Windows Server 2008 Standard (avec et sans Hyper-V)

Windows Server 2008 Web

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard sans Hyper-V2

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center sans Hyper-V2

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise sans Hyper-V2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Cette version de Windows prend en charge SQL Server 2008 Enterprise Evaluation, pas Enterprise.

2Cette édition de SQL Server peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

SQL Server 2008 Standard (32 bits)

Le tableau suivant contient la configuration requise pour SQL Server 2008 Standard (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel SP2

Windows XP SP2 Tablet

Windows XP x64 Professionnel 20031

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professionnel Édition multimédia condensée

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 bits x64 Standard1

Windows Server 2003 SP2 64 bits x64 Data Center1

Windows Server 2003 SP2 64 bits x64 Enterprise1

Windows Vista Édition Intégrale

Windows Vista Entreprise

Windows Vista Professionnel

Windows Vista Édition Intégrale x641

Windows Vista Enterprise x641

Windows Vista Professionnel x641

Windows Server 2008 Web

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server sans Hyper-V

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard sans Hyper-V1

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center sans Hyper-V1

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise sans Hyper-V1

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Cette édition de SQL Server peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

Éditions spécialisées (64 bits et 32 bits)

SQL Server 2008 Developer (64 bits) IA64

Le tableau suivant contient la configuration système requise pour SQL Server 2008Developer (64 bits) IA64. Notez que cette édition de SQL Server 2008 n'est pas disponible dans les versions localisées suivantes : italien, espagnol, brésilien (portugais) et russe.

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : processeur Itanium ou plus rapide

Vitesse du processeur :

  • Minimum : 1 GHz ou plus rapide

Système d'exploitation

Windows Server 2003 SP2 64 bits Itanium Data Center2

Windows Server 2003 SP2 64 bits Itanium Enterprise2

Windows Server 2008 64 bits Itanium Edition2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

4 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Developer (64 bits) x64

Le tableau suivant contient la configuration système requise pour SQL Server 2008Developer (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2,0 GHz ou plus

Système d'exploitation

Windows XP x64 Professionnel 2003

Windows Server 2003 SP2 64 bits x64 Standard2

Windows Server 2003 SP2 64 bits x64 Data Center2

Windows Server 2003 SP2 64 bits x64 Enterprise2

Windows Vista Édition Intégrale x64

Windows Vista Édition Familiale Premium x64

Windows Vista Édition Familiale Basique x64

Windows Vista Entreprise x64

Windows Vista Professionnel x64

Windows Server 2008 64 bits x64 Standard, Windows Server 2008 64 bits x64 Standard sans Hyper-V2

Windows Server 2008 64 bits x64 Data Center, Windows Server 2008 64 bits x64 Data Center sans Hyper-V2

Windows Server 2008 64 bits x64 Enterprise, Windows Server 2008 64 bits x64 Enterprise sans Hyper-V2

Windows Server 2008 x64 Web2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

4 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Workgroup (64 bits) x64

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Workgroup (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2,0 GHz ou plus

Système d'exploitation

Windows XP x64 Professionnel 2003

Windows Server 2003 SP2 64 bits x64 Standard2

Windows Server 2003 SP2 64 bits x64 Data Center2

Windows Server 2003 SP2 64 bits x64 Enterprise2

Windows Vista Édition Intégrale x64

Windows Vista Édition Familiale Premium x64

Windows Vista Édition Familiale Basique x64

Windows Vista Entreprise x64

Windows Vista Professionnel x64

Windows Server 2008 x64 Web2

Windows Server 2008 64 bits x64 Standard, Windows Server 2008 64 bits x64 Standard sans Hyper-V2

Windows Server 2008 64 bits x64 Data Center, Windows Server 2008 64 bits x64 Data Center sans Hyper-V2

Windows Server 2008 64 bits x64 Enterprise, Windows Server 2008 64 bits x64 Enterprise sans Hyper-V2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

4 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Web (64 bits) x64

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Web (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP x64 Professionnel 2003

Windows Server 2003 SP2 64 bits x64 Standard2

Windows Server 2003 SP2 64 bits x64 Data Center2

Windows Server 2003 SP2 64 bits x64 Enterprise2

Windows Vista Édition Intégrale x64

Windows Vista Enterprise x64

Windows Vista Professionnel x64

Windows Server 2008 x64 Web

Windows Server 2008 x64 Standard, Windows Server 2008 x64 Standard sans Hyper-V2

Windows Server 2008 x64 Data Center, Windows Server 2008 x64 Data Center sans Hyper-V2

Windows Server 2008 x64 Enterprise, Windows Server 2008 x64 Enterprise sans Hyper-V2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

4 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server 2008 Express Advanced (64 bits) x64

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Express Advanced (64 bits) x64 :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows Server 2003 x64

Windows Server 2003 SP2 64 bits x64 Standard1

Windows Server 2003 SP2 64 bits x64 Data Center1

Windows Server 2003 SP2 64 bits x64 Enterprise1

Windows Vista Édition Intégrale x64

Windows Vista Édition Familiale Premium x64

Windows Vista Édition Familiale Basique x64

Windows Vista Enterprise x64

Windows Vista Professionnel x64

Windows Server 2008 64 bits x64 Web1

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V1

Windows Server 2008 64 bits x64 Data Center

Windows Server 2008 64 bits x64 Data Center sans Hyper-V1

Windows Server 2008 64 bits x64 Enterprise

Windows Server 2008 64 bits x64 Enterprise sans Hyper-V1

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 1 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils d'administration sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter de façon native en mode 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

SQL Server Developer (32 bits)

Le tableau suivant contient la configuration système requise pour SQL Server 2008Developer (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Édition familiale SP2

Windows XP Professionnel SP2

Windows XP Tablet SP2

Windows XP Professionnel x64 SP21

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professionnel Édition multimédia condensée

Windows XP Édition familiale Édition multimédia condensée

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 bits x64 Standard2

Windows Server 2003 SP2 64 bits x64 Data Center2

Windows Server 2003 SP2 64 bits x64 Enterprise2

Windows Vista Édition Intégrale

Windows Vista Édition Familiale Premium

Windows Vista Édition Familiale Basique

Windows Vista Starter Edition

Windows Vista Entreprise

Windows Vista Professionnel

Windows Vista Ultimate 64 bits x642

Windows Vista Édition Familiale Premium 64 bits x642

Windows Vista Édition Familiale Basique 64 bits x642

Windows Vista Entreprise 64 bits x642

Windows Vista Professionnel 64 bits x642

Windows Server 2008 Web

Windows Server 2008 Standard

Windows Server 2008 Standard sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V2

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V2

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V2

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

1Cette édition de SQL Server 2008 peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

2 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server Workgroup (32 bits)

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Workgroup (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel SP2

Windows XP SP2 Tablet

Windows XP Professionnel 64 bits x643

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professionnel Édition multimédia condensée

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 64 bits x64 Standard3

Windows Server 2003 64 bits x64 Data Center3

Windows Server 2003 64 bits x64 Enterprise3

Windows Vista Édition Intégrale

Windows Vista Entreprise

Windows Vista Professionnel

Windows Vista 64 bits x64 Édition Intégrale 3

Windows Vista 64 bits x64 Enterprise3

Windows Vista 64 bits x64 Professionnel 3

Windows Server 2008 2008 Web

Windows Server 2008 Standard

Windows Server 2008 Standard sans Hyper-V

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V3

Windows Server 2008 64 bits x64 Data Center

Windows Server 2008 64 bits x64 Data Center sans Hyper-V3

Windows Server 2008 64 bits x64 Enterprise

Windows Server 2008 64 bits x64 Enterprise sans Hyper-V3

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

3Cette édition de SQL Server 2008 peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

5 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server Web (32 bits)

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Web (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows XP Professionnel SP2

Windows XP SP2 Tablet

Windows XP Professionnel XP x643

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows XP Professionnel Édition multimédia condensée

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 bits x64 Standard3

Windows Server 2003 SP2 64 bits x64 Data Center3

Windows Server 2003 SP2 64 bits x64 Enterprise3

Windows Vista Édition Intégrale

Windows Vista Entreprise

Windows Vista Professionnel

Windows Vista Édition Intégrale x643

Windows Vista Enterprise x643

Windows Vista Professionnel x643

Windows Server 2008 Web

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server sans Hyper-V

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 x64 Standard

Windows Server 2008 x64 Standard sans Hyper-V3

Windows Server 2008 x64 Data Center

Windows Server 2008 x64 Data Center sans Hyper-V3

Windows Server 2008 x64 Enterprise

Windows Server 2008 x64 Enterprise sans Hyper-V3

Mémoire

RAM :

  • Minimum : 512 Mo

  • Recommandé : 2,048 Go ou plus

  • Maximum : maximum du système d'exploitation

3Cette édition de SQL Server 2008 peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

5 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

SQL Server Express (32 bits) et Express with Advanced Services (32 bits)

Le tableau suivant contient la configuration système requise pour SQL Server 2008 Express (32 bits) et Express with Advanced Services (32 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Processeur compatible Pentium III ou supérieur

Vitesse du processeur :

  • Minimum : 1,0 GHz

  • Recommandé : 2,0 GHz ou plus

Système d'exploitation

Windows XP SP2 Édition familiale

Windows XP SP2 Professionnel

Windows XP SP2 Tablet

Windows XP SP2 Media Center 2002

Windows XP SP2 Media Center 2004

Windows XP Media Center 2005

Windows Server 2003 Édition multimédia condensée

Windows XP Édition familiale Édition multimédia condensée

Windows Server 2003 Small Business Server R2 Standard

Windows Server 2003 Small Business Server R2 Premium

Windows Server 2003 SP2 Standard

Windows Server 2003 2003 SP2 Enterprise

Windows Server 2003 SP2 Data Center

Windows Server 2003 SP2 Web Edition

Windows Server 2003 SP2 Small Business Server Standard

Windows Server 2003 SP2 Small Business Server Premium

Windows Server 2003 SP2 64 bits x64 Standard3

Windows Server 2003 SP2 64 bits x64 Data Center3

Windows Server 2003 SP2 64 bits x64 Enterprise3

Windows Vista Édition Intégrale

Windows Vista Édition Familiale Premium

Windows Vista Édition Familiale Basique

Windows Vista Entreprise

Windows Vista Professionnel

Windows Vista Ultimate 64 bits x648

Windows Vista Édition Familiale Premium 64 bits x648

Windows Vista Édition Familiale Basique 64 bits x648

Windows Vista Entreprise 64 bits x648

Windows Vista Professionnel 64 bits x648

Windows Server 2008 Standard Server

Windows Server 2008 Standard Server sans Hyper-V

Windows Server 2008 Enterprise

Windows Server 2008 Enterprise sans Hyper-V

Windows Server 2008 Data Center

Windows Server 2008 Data Center sans Hyper-V

Windows Server 2008 Web Edition

Windows Server 2008 64 bits x64 Web Edition3

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V3

Windows Server 2008 64 bits x64 Data Center

Windows Server 2008 64 bits x64 Data Center sans Hyper-V3

Windows Server 2008 64 bits x64 Enterprise

Windows Server 2008 64 bits x64 Enterprise sans Hyper-V3

Windows XP Embedded SP2 Feature Pack 2007?7

Windows Embedded for Point of Service SP2?7

Mémoire

RAM :

  • Minimum : 256 Mo

  • Recommandé : 1,024 Go ou plus

  • Maximum : maximum du système d'exploitation

3Cette édition de SQL Server 2008 peut être installée sur le sous-système Windows on Windows (WOW64) 32 bits d'un serveur 64 bits.

5 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

6 La prise en charge de SQL Server 2008 sur Windows Server 2003 R2 est la même que sur Windows Server 2003 SP2.

7prend en charge SQL Server 2008 Express, pas SQL Server 2008 Express with Advanced Services.

8 SQL Server 2008 Express Advanced peut être installé sur le sous-système 32 bits de Windows on Windows (WOW64) d'un serveur 64 bits avec ce système d'exploitation.

SQL Server 2008 Express x64 (64 bits)

Le tableau suivant contient la configuration requise pour SQL Server 2008 Express x64 (64 bits) :

Composant Configuration requise

Processeur

Type de processeur :

  • Minimum : AMD Opteron, AMD Athlon 64, Intel Xeon avec prise en charge Intel EM64T, Intel Pentium IV avec prise en charge EM64T

Vitesse du processeur :

  • Minimum : 1,4 GHz

  • Recommandé : 2 GHz ou plus

Système d'exploitation

Windows Server 2003 x64

Windows Server 2003 SP2 64 bits x64 Standard

Windows Server 2003 SP2 64 bits x64 Data Center

Windows Server 2003 SP2 64 bits x64 Enterprise

Windows Vista Édition Intégrale x64

Windows Vista Édition Familiale Premium x64

Windows Vista Édition Familiale Basique x64

Windows Vista Enterprise x64

Windows Vista Professionnel x64

Windows Server 2008 64 bits x64 Web

Windows Server 2008 64 bits x64 Standard

Windows Server 2008 64 bits x64 Standard sans Hyper-V

Windows Server 2008 64 bits x64 Data Center

Windows Server 2008 64 bits x64 Data Center sans Hyper-V

Windows Server 2008 64 bits x64 Enterprise

Windows Server 2008 64 bits x64 Enterprise sans Hyper-V

Mémoire

RAM :

  • Minimum : 256 Mo

  • Recommandé : 1,024 Go ou plus

  • Maximum : maximum du système d'exploitation

2Les outils de gestion sont pris en charge dans WOW64, fonctionnalité des éditions 64 bits de Microsoft Windows qui permet aux applications 32 bits de s'exécuter en mode natif 32 bits. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

4 SQL Server 2008 n'est pas pris en charge sur les installations serveur principales de Windows Server 2008.

Prise en charge multilingue

  • La version anglaise de SQL Server 2008 est prise en charge sur toutes les versions traduites des systèmes d'exploitation pris en charge.

  • Les versions traduites de SQL Server 2008 sont prises en charge sur les systèmes d'exploitation traduits dans la même langue que la version traduite de SQL Server 2008.

  • Les versions traduites de SQL Server peuvent être mises à niveau vers des versions traduites de SQL Server 2008 dans la même langue.

  • Les versions traduites de SQL Server ne peuvent pas être mises à niveau vers une version de SQL Server 2008 en anglais.

  • Les versions traduites de SQL Server ne peuvent pas être mises à niveau vers des versions traduites de SQL Server 2008 dans une autre langue.

  • Les versions traduites de SQL Server 2008 sont également prises en charge dans les versions anglaises des systèmes d'exploitation pris en charge grâce aux paramètres du Pack Windows d'interface utilisateur multilingue. Vous devez toutefois vérifier certains paramètres du système d'exploitation avant d'installer une version localisée de SQL Server 2008 sur un serveur qui exécute un système d'exploitation en langue anglaise avec un paramétrage MUI non anglais. Vous devez vous assurer que les paramètres suivants du système d'exploitation correspondent à la version traduite de SQL Server 2008 à installer :

    • Définition de l'interface utilisateur du système d'exploitation

    • Définition des paramètres régionaux utilisateur du système d'exploitation

    • Définition des paramètres régionaux du système

    Si les paramètres du système d'exploitation ne correspondent pas à la version traduite de SQL Server, vous devez alors les définir correctement avant d'installer SQL Server 2008.

Prise en charge des systèmes étendus

Les versions SQL Server 2008 64 bits intègrent une fonction de prise en charge des systèmes étendus, également appelée Windows on Windows (WOW64). WOW64 est une fonctionnalité des éditions 64 bits de Windows qui permet aux applications 32 bits de s'exécuter en mode 32 bits natif. Les applications fonctionnent en mode 32 bits, même si le système d'exploitation sous-jacent fonctionne sur une plateforme 64 bits.

Espace disque requis (32 et 64 bits)

Pendant l'installation de SQL Server 2008, Windows Installer crée des fichiers temporaires sur le lecteur système. Avant d'exécuter le programme d'installation ou de mise à niveau de SQL Server, vérifiez que vous disposez d'au moins 2,0 Go d'espace disponible sur le lecteur système pour ces fichiers. Cette configuration requise s'applique même lorsque vous installez tous les composants SQL Server sur un lecteur différent du lecteur par défaut.

L'espace disque requis peut varier selon la configuration du système et les fonctionnalités installées. Le tableau suivant présente l'espace disque requis pour les composants SQL Server 2008 :

Fonctionnalité | Espace disque disponible requis
Moteur de base de données et fichiers de données, réplication et recherche en texte intégral | 280 Mo
Analysis Services et fichiers de données | 90 Mo
Reporting Services et Gestionnaire de rapports | 120 Mo
Integration Services | 120 Mo
Composants clients | 850 Mo
Documentation en ligne de SQL Server et documentation compacte en ligne de SQL Server | 240 Mo

Installation de SQL Server sur un contrôleur de domaine

Pour des raisons de sécurité, Microsoft recommande de ne pas installer SQL Server 2008 sur un contrôleur de domaine. Le programme d'installation SQL Server ne bloquera pas l'installation sur un ordinateur qui est contrôleur de domaine, mais les limitations suivantes s'appliquent :

  • Sur Windows Server 2003, les services SQL Server peuvent s'exécuter sous un compte de domaine ou un compte système local.

  • Vous ne pouvez pas exécuter de services SQL Server sur un contrôleur de domaine sous un compte de service local ou un compte de service réseau.

  • Après avoir installé sur un ordinateur SQL Server, vous ne pouvez pas modifier l'ordinateur d'un membre de domaine en un contrôleur de domaine. Vous devez désinstaller SQL Server avant de modifier l'ordinateur hôte en un contrôleur de domaine.

  • Après avoir installé sur un ordinateur SQL Server, vous ne pouvez pas modifier l'ordinateur d'un contrôleur de domaine en un membre de domaine. Vous devez désinstaller SQL Server avant de modifier l'ordinateur hôte en un membre de domaine.

  • Les instances de cluster de basculement SQL Server ne sont pas prises en charge lorsque les nœuds du cluster sont des contrôleurs de domaine.

  • Le programme d'installation de SQL Server ne peut pas créer de groupes de sécurité ni configurer de comptes de service SQL Server sur un contrôleur de domaine en lecture seule. Dans ce scénario, le programme d'installation échoue.

Clients pris en charge (64 bits)

Les composants clients SQL Server 2008 64 bits peuvent être installés sur Windows Server 2003 (64 bits).

Voir aussi

Référence

Paramètres de l'outil d'analyse de configuration système
Éditions et composants de SQL Server 2008

Concepts

Planification d'une installation SQL Server
Considérations sur la sécurité pour une installation SQL Server
Installation de démarrage rapide de SQL Server 2008


Paramètres de l'outil d'analyse de configuration système

Paramètres de l'outil d'analyse de configuration système |
 | Voir aussi
Planification d'une installation SQL Server >

Lors de l'exécution du programme d'installation de SQL Server, l'outil d'analyse de configuration système analyse l'ordinateur sur lequel SQL Server sera installé. L'outil SCC recherche toute anomalie susceptible d'empêcher une installation correcte de SQL Server. Avant que le programme d'installation ne démarre l'Assistant Installation de SQL Server, le SCC extrait l'état de chaque élément. Puis, il compare le résultat avec les conditions requises et fournit une aide pour la suppression des problèmes importants.

Rubriques supplémentaires relatives aux règles

Consultez les rubriques suivantes pour des règles d'installation spécifiques au scénario :

  • Règles d'installation des fonctionnalités

  • Contrôle des règles de mise à niveau et de réparation

  • Règles de mise à niveau de l'édition

  • Règles de désinstallation

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008
Mises à niveau de la version et de l'édition

Concepts

Considérations sur la sécurité pour une installation SQL Server


Considérations sur la sécurité pour une installation SQL Server

Considérations sur la sécurité pour une installation SQL Server
Planification d'une installation SQL Server >

La sécurité est importante pour chaque produit et chaque activité. En respectant les recommandations les plus simples, vous pouvez éviter de nombreuses failles de sécurité. Cette rubrique traite des recommandations qu'il est conseillé de prendre en considération en matière de sécurité avant d'installer SQL Server et après l'avoir installé. Des conseils en matière de sécurité concernant des fonctionnalités spécifiques sont inclus dans les rubriques de référence de ces fonctionnalités.

Avant d'installer SQL Server

Suivez ces recommandations lors de la définition de l'environnement du serveur :

  • Renforcez la sécurité physique.

  • Utilisez des pare-feu.

  • Isolez les services.

  • Configurez un système de fichiers sécurisé

  • Désactivation des protocoles NetBIOS et SMB (Server Message Block)

Renforcement de la sécurité physique

L'isolement au niveau physique et logique est à la base de la sécurité de SQL Server. Pour améliorer la sécurité de l'installation SQL Server au niveau physique, procédez comme suit :

  • Placez le serveur dans une pièce à laquelle seules les personnes autorisées peuvent accéder.

  • Placez les ordinateurs qui hébergent une base de données dans un lieu protégé physiquement, idéalement dans une salle fermée à clé, équipée de systèmes pour la détection et la lutte contre les inondations et les incendies.

  • Installez les bases de données dans une zone sécurisée de l'intranet d'entreprise, sans connecter vos serveurs SQL Server directement à Internet.

  • Sauvegardez régulièrement toutes les données et conservez les copies de sauvegarde dans un lieu sécurisé situé en dehors de l'entreprise.

Utilisation de pare-feu

Les pare-feu sont importants afin d'aider à sécuriser l'installation de SQL Server. Les pare-feu seront d'autant plus efficaces que vous suivrez ces directives :

  • Placez un pare-feu entre le serveur et Internet. Activez votre pare-feu. Si votre pare-feu est désactivé, activez-le. Si votre pare-feu est activé, ne le désactivez pas.

  • Divisez le réseau en zones de sécurité séparées par des pare-feu. Bloquez tout le trafic, puis sélectionnez uniquement ce qui est obligatoire.

  • Dans un environnement à plusieurs niveaux, utilisez plusieurs pare-feu pour créer des sous-réseaux filtrés.

  • Lorsque vous installez le serveur à l'intérieur d'un domaine Windows, configurez des pare-feu internes pour autoriser l'authentification Windows.

  • Si votre application utilise des transactions distribuées, vous devrez éventuellement configurer le pare-feu pour autoriser le trafic MS DTC (Microsoft Distributed Transaction Coordinator) entre des instances MS DTC distinctes. Vous devrez configurer également le pare-feu afin de permettre au trafic de s'écouler entre les instances MS DTC et les gestionnaires des ressources tels que SQL Server.

Pour plus d'informations sur le paramètres par défaut du Pare-feu Windows et obtenir une description des ports TCP qui affectent le Moteur de base de données, Analysis Services, Reporting Services et Integration Services, consultez Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server.

Isolement des services

Le fait d'isoler les services réduit le risque qu'un service compromis soit utilisé pour en compromettre d'autres. Pour isoler des services, tenez compte des consignes suivantes :

  • Exécutez chaque service SQL Server sous des comptes Windows distincts. Si possible, utilisez des comptes d'utilisateurs locaux ou Windows distincts et à faibles droits pour chaque service SQL Server. Pour plus d'informations, consultez Configuration des comptes de service Windows.

Configurer un système de fichiers sécurisé

L'utilisation du système de fichiers correct accroît la sécurité. Pour les installations SQL Server, vous devez effectuer les tâches suivantes :

  • Utiliser le système de fichiers NTFS. NTFS est le système de fichiers par défaut pour les installations de SQL Server car il est plus stable et récupérable que les systèmes de fichiers FAT. NTFS active également des options de sécurité telles que les listes de contrôle d'accès de fichiers et de répertoires et le chiffrement de fichiers EFS (Encrypting File System). Pendant l'installation, SQL Server définit les listes de contrôle d'accès appropriées sur les clés de Registre et les fichiers s'il détecte NTFS. Ces autorisations ne doivent pas être modifiées. Il se peut que les versions futures de SQL Server ne prennent pas en charge l'installation sur des ordinateurs dotés de systèmes de fichiers FAT.

    Remarque :
    Si vous utilisez le chiffrement EFS, les fichiers de base de données seront chiffrés sous l'identité du compte qui exécute SQL Server. Seul ce compte sera en mesure de déchiffrer les fichiers. Si vous devez modifier le compte qui exécute SQL Server, vous devez d'abord déchiffrer les fichiers sous l'ancien compte, puis les rechiffrer sous le nouveau compte.

  • Utilisez la technologie RAID pour les fichiers de données critiques.

Désactivez les protocoles NetBIOS et SMB (Server Message Block)

Les protocoles non nécessaires doivent tous être désactivés sur les serveurs du réseau de périmètre, y compris les protocoles NetBIOS et SMB.

Le protocole NetBIOS utilise les ports suivants :

  • UDP/137 (service de noms NetBIOS)

  • UDP/138 (service de datagrammes NetBIOS)

  • TCP/139 (service de sessions NetBIOS)

Le protocole SMB utilise les ports suivants :

  • TCP/139

  • TCP/445

Les serveurs Web et les serveurs DNS (Domain Name System) ne nécessitent pas l'utilisation du protocole NetBIOS ou SMB. Désactivez ces protocoles sur ces serveurs afin de réduire le risque lié à l'énumération utilisateur.

Après l'installation de SQL Server

Après l'installation, vous pouvez renforcer la sécurité de l'installation SQL Server en suivant les recommandations suivantes pour les comptes et les modes d'authentification :

Comptes de service

  • Exécutez les services SQL Server en utilisant les autorisations les plus basses possibles.

  • Associez les services SQL Server à des comptes d'utilisateurs locaux Windows à faibles privilèges ou à des comptes d'utilisateurs de domaine.

  • Pour plus d'informations, consultez Configuration des comptes de service Windows.

Mode d'authentification

  • Exigez l'authentification Windows pour les connexions à SQL Server.

Mots de passe forts

  • Affectez toujours un mot de passe fort au compte sa.

  • Activez toujours la vérification de la stratégie de mot de passe pour la puissance et l'expiration du mot de passe.

  • Utilisez toujours des mots de passe forts pour toutes les connexions SQL Server. Pour plus d'informations, consultez le livre blanc SQL Server 2008 Security Overview for Database Administrators (en anglais).


Configuration des comptes de service Windows

Configuration des comptes de service Windows |
 | Voir aussi
Planification d'une installation SQL Server >

Chaque service de SQL Server représente un processus ou un ensemble de processus permettant de gérer l'authentification des opérations de SQL Server avec Windows. Cette rubrique décrit la configuration par défaut des services inclus dans cette version de SQL Server, ainsi que les options de configuration des services SQL Server susceptibles d'être définies durant l'installation de SQL Server.

Remarque relative à la sécurité :
Exécutez toujours les services SQL Server avec le niveau de droits d'utilisateur le plus bas possible. Utilisez un compte d'utilisateur ou un compte de domaine spécifique au lieu d'un compte partagé pour les services SQL Server. Utilisez des comptes distincts pour différents services SQL Server. N'accordez aucune autorisation supplémentaire au compte de service SQL Server. Les autorisations seront accordées par le biais de l'appartenance aux groupes ou accordées directement à un SID de service.

En fonction des composants que vous décidez d'installer, le programme d'installation de SQL Server installe les services suivants :

  • Services de base de données SQL Server : service pour le moteur de base de données relationnel SQL Server.

  • Agent SQL Server : exécute les travaux, surveille SQL Server, déclenche les alertes et autorise l'automatisation de certaines tâches administratives.

    Remarque :
    Pour que SQL Server et l'Agent SQL Server fonctionnent comme des services dans Windows, un compte d'utilisateur Windows doit leur être attribué. Pour plus d'informations sur la personnalisation des informations de compte pour chaque service, consultez Procédure : installer SQL Server 2008 (programme d'installation).

  • Analysis Services : fournit des fonctionnalités OLAP et d'exploration de données pour les applications de décisionnel.

  • Reporting Services : gère, exécute, crée, planifie et remet les rapports.

  • Integration Services : assure la prise en charge de la gestion du stockage et de l'exécution des packages Integration Services.

  • Navigateur SQL Server : service de résolution de noms qui fournit des informations de connexion SQL Server pour les ordinateurs clients.

  • Recherche en texte intégral - Crée rapidement des index de recherche en texte intégral sur le contenu et des propriétés de données structurées et semi-structurées pour fournir un filtrage de document et l'analyse lexicale pour SQL Server.

  • SQL Server Active Directory Helper : publie et gère les services SQL Server dans Active Directory.

  • SQL Writer : permet aux applications de sauvegarde et restauration de fonctionner dans l'infrastructure du service VSS (cliché instantané de volume).

Le reste de cette rubrique est constitué des sections suivantes :

  • Configuration du type de démarrage du service

  • Utilisation des comptes de démarrage pour les services SQL Server

  • Utilisation des SID de service pour des services SQL Server

  • Identification des services dépendant et ne dépendant pas des instances

  • Vérification des droits et privilèges NT accordés aux comptes de services SQL Server

  • Vérification des listes de contrôle d'accès créées pour les comptes de service SQL Server

  • Récapitulation des autorisations Windows pour les services SQL Server

  • Récapitulation des considérations supplémentaires

  • Noms de services localisés

Configuration du type de démarrage du service

Pendant l'installation de SQL Server, vous pouvez configurer le type de démarrage - désactivé, manuel ou automatique - pour certains services SQL Server. Le tableau suivant répertorie les services SQL Server susceptibles d'être configurés durant l'installation. Pour les installations sans assistance, vous pouvez employer les commutateurs dans un fichier de configuration ou à l'invite de commandes.

Nom du service SQL Server | Configurable dans l'Assistant Installation ? | Commutateurs pour les installations sans assistance1
MSSQLSERVER | Oui | SQLACCOUNT, SQLPASSWORD, SQLAUTOSTART
SQLServerAgent2 | Oui | AGTACCOUNT, AGTPASSWORD, AGTAUTOSTART
MSSQLServerOLAPService | Oui | ASACCOUNT, ASPASSWORD, ASAUTOSTART
ReportServer | Oui | RSACCOUNT, RSPASSWORD, RSAUTOSTART
Integration Services | Oui | ISSVSAccount, ISSVCPassword, ISSVCStartupType

1Pour plus d'informations et obtenir un exemple de syntaxe des installations sans assistance, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

2Le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

Utilisation des comptes de démarrage pour les services SQL Server

Pour démarrer et s'exécuter, chaque service dans SQL Server doit posséder un compte d'utilisateur qui est configuré lors de l'installation. Les comptes d'utilisateurs peuvent être des comptes système intégrés, des comptes d'utilisateur local ou des comptes d'utilisateur de domaine.

Outre qu'il doit posséder un compte d'utilisateur, chaque service a trois états de démarrage possibles, que les utilisateurs peuvent contrôler :

  • Désactivé Le service est installé mais pas en cours d'exécution.

  • Manuel Le service est installé, mais ne démarre que lorsqu'un autre service ou une autre application a besoin de ses fonctionnalités.

  • Automatique Le service est démarré automatiquement par le système d'exploitation.

Le tableau ci-dessous indique les comptes optionnels pour chaque service SQL Server, ainsi que les états de démarrage de chaque service.

Nom du service SQL Server | Comptes optionnels | Type de démarrage | État par défaut après l'installation
SQL Server | SQL Server Express : Utilisateur de domaine, Système local, Service réseau1 Toutes les autres éditions : Utilisateur de domaine, Système local, Service réseau1 | Automatique2 | Démarré Arrêté uniquement si l'utilisateur ne choisit pas le démarrage automatique
Agent SQL Server | Utilisateur de domaine, Système local, Service réseau1 | Manuel3 Automatique uniquement si l'utilisateur choisit le démarrage automatique | Arrêté Démarré uniquement si l'utilisateur choisit le démarrage automatique
Analysis Services | Utilisateur de domaine, Service réseau, Service local, Système local | Automatique | Démarré Arrêté uniquement si l'utilisateur ne choisit pas le démarrage automatique
Reporting Services | Utilisateur de domaine, Système local, Service réseau, Service local | Automatique | Démarré Arrêté uniquement si l'utilisateur ne choisit pas le démarrage automatique
Integration Services | Utilisateur de domaine, Système local, Service réseau, Service local | Automatique | Démarré Arrêté uniquement si l'utilisateur ne choisit pas le démarrage automatique.
Recherche en texte intégral | Utilisez un compte différent du compte du service SQL Server. Le compte utilisera par défaut le Service local sur Windows Server 2008 et Windows Vista. | Automatique | Démarré Arrêté uniquement si un compte n'est pas spécifié sur Windows Server 2003 ni Windows XP.
Navigateur SQL Server | Service local | Désactivé4 Automatique uniquement si l'utilisateur choisit le démarrage automatique. | Arrêté Démarré uniquement si l'utilisateur choisit le démarrage automatique.
SQL Server Active Directory Helper | Système local, Service réseau | Désactivé | Arrêté
SQL Writer | Système local | Automatique | Démarré

1 Important Il est recommandé de ne pas utiliser le compte de service réseau pour les services SQL Server. Service réseau est un compte partageable qui convient uniquement à une utilisation comme compte de service SQL Server si vous pouvez garantir qu'aucun autre service qui utilise le compte n'est installé sur l'ordinateur. Les comptes Utilisateur de domaine qui ne sont pas administrateur Windows sont plus appropriés pour les services SQL Server. Sachez que le compte Service local n'est pas pris en charge pour l'Agent SQL Server.

2Définissez comme manuel dans les configurations de cluster de basculement.

3Le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

4Par défaut, pour les installations de cluster de basculement et les instances nommées, le navigateur SQL Server est défini en démarrage automatique une fois l'installation terminée.

Utilisation d'un compte d'utilisateur de domaine

Si le service doit interagir avec des services réseau, des ressources de domaine telles que des partages de fichiers, ou s'il utilise des connexions de serveur liées à d'autres ordinateurs qui exécutent SQL Server, vous pouvez utiliser un compte de serveur de domaine à privilèges minimaux. De nombreuses activités de serveur à serveur ne peuvent être exécutées qu'avec un compte utilisateur de domaine.

Utilisation du compte de service local

Le compte de service local est un compte intégré qui bénéficie du même niveau d'accès aux ressources et aux objets que les membres du groupe Utilisateurs. Cet accès limité constitue une mesure de sécurité pour le système, au cas où le fonctionnement de services ou de processus individuels serait compromis. Les services qui s'exécutent en tant que compte de service local accèdent aux ressources réseau dans le cadre d'une session Null, sans informations d'identification. Sachez que le compte Service local n'est pas pris en charge pour les services SQL Server ou SQL Server Agent.

Utilisation d'un compte d'utilisateur local

Si l'ordinateur ne fait pas partie d'un domaine, un compte d'utilisateur local sans autorisations d'administrateur Windows est recommandé.

Utilisation du compte de service réseau

Le compte de service réseau est un compte intégré qui bénéficie d'un niveau d'accès aux ressources et aux objets supérieur à celui des membres du groupe Utilisateurs. Les services qui exécutent le compte de service réseau accèdent aux ressources réseau à l'aide des informations d'identification du compte d'ordinateur.

Important :
Il est déconseillé d'utiliser le compte de service réseau pour les services SQL Server. Service réseau est un compte partageable qui convient uniquement à une utilisation comme compte de service SQL Server si vous pouvez garantir qu'aucun autre service qui utilise le compte n'est installé sur l'ordinateur.

Utilisation du compte de système local

Soyez vigilant lorsque vous assignez les autorisations Système local aux comptes de service SQL Server. Système local est un compte doté de privilèges très élevés.

Utilisation des SID de service pour les configurations de services SQL Server

Les SID (Service Security ID) sont disponibles dans SQL Server 2008 sur Windows Server 2008 et les systèmes d'exploitation Windows Vista pour permettre l'isolation de service. L'isolation de service permet aux services d'accéder à des objets spécifiques sans avoir à s'exécuter sous un compte à privilèges élevés ni affaiblir la protection de sécurité de l'objet. Un service SQL Server peut utiliser cette identité pour restreindre l'accès à ses ressources par d'autres services ou applications.

Un service isole un objet pour son utilisation exclusive en sécurisant la ressource via une entrée de contrôle d'accès qui contient un SID de service. Ce SID par service est dérivé du nom du service et est propre à ce service ; par exemple, un nom de SID pour un service SQL Server peut être NT Service\MSSQL$<NomInstance>. Une fois activé pour un service, le SID est ajouté au groupe de sécurité local dans Windows. Le propriétaire de service peut modifier la liste de contrôle d'accès pour un objet afin de donner accès au SID. Par exemple, une clé de Registre dans HKEY_LOCAL_MACHINE\SOFTWARE serait habituellement uniquement disponible aux services qui ont des informations d'identification d'administration. L'ajout du SID par service à la liste de contrôle d'accès de la clé permet au service de s'exécuter sous un compte à privilège inférieur, tout en ayant accès à la clé.

Pendant l'installation, le programme d'installationSQL Server crée un groupe de service pour chaque composant de SQL Server. Sur Windows Server 2003 et Windows XP, les comptes de service pour les services SQL Server sont ajoutés aux groupes de service local et fonctionnent sur ces systèmes d'exploitation comme c'était le cas dans les versions finales SQL Server précédentes : les services SQL Server se connectent à une instance de SQL Server en tant que membres du groupe local. Sur Windows Server 2008 et Windows Vista, le SID de service est ajouté au groupe de sécurité local à la place du compte de service SQL Server.

Configurations du service prises en charge

L'installation de SQL Server 2008 sur un contrôleur de domaine Windows Server 2008 ou Windows Vista requiert que les services SQL Server disposent d'un SID de service. SQL Server 2008 n'est pas pris en charge dans les cas où les nœuds cluster de basculement sont des contrôleurs de domaine. Le tableau suivant montre les configurations du service pour Des installations nouvelles et mises à niveau sur Windows Server 2008 ou Windows Vista.

Nouvelle installation Mise à niveau
  • Instance autonome - Service de groupe avec SID de service

  • Instance de cluster de basculement – SID de service
  • Instance autonome - Service de groupe avec SID de service

  • Instance de cluster de basculement - Service de groupe avec compte de service

L'installation de SQL Server 2008 sur un contrôleur de domaine Windows Server 2003 ou Windows XP requiert que le domaine pour les services SQL Server dispose d'un compte de domaine. SQL Server 2008 n'est pas pris en charge dans les cas où les nœuds cluster de basculement sont des contrôleurs de domaine. Le tableau suivant montre les configurations du service pour les installations nouvelles et mises à niveau sur Windows Server 2003 ou Windows XP.

Nouvelle installation Mise à niveau
  • Instance autonome - Service de groupe avec compte de service

  • Instance de cluster de basculement - Service de domaine avec compte de service
  • Instance autonome - Service de groupe avec compte de service

  • Instance de cluster de basculement - Service de groupe avec compte de service

Modification des comptes d'utilisateur

Pour modifier les comptes de service, le mot de passe, le type de démarrage du service ou d'autres propriétés d'un service quelconque lié à SQL Server, utilisez le Gestionnaire de configuration SQL Server. Notez que le changement du nom de l'instance de SQL Server ne change pas le nom des groupes de sécurité SQL Server. Les groupes de sécurité continuent de fonctionner avec les anciens noms après le changement de nom.

Identification des services dépendant et ne dépendant pas des instances

Chaque service dépendant d'une instance est associé à une instance spécifique de SQL Server et possède sa propre ruche de Registre. Vous pouvez installer plusieurs exemplaires de services dépendant d'une instance en exécutant le programme d'installation de SQL Server pour chaque composant ou service. Les services ne dépendant pas d'une instance sont partagés entre toutes les instances SQL Server installées. Ils ne sont pas associés à une instance spécifique, ne sont installés qu'une seule fois et ne peuvent pas être installés côte à côte.

Les services dépendant d'une instance dans SQL Server incluent les éléments suivants :

  • SQL Server

  • Agent SQL Server

    Sachez que le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

  • Analysis Services

  • Reporting Services

  • Recherche en texte intégral

Les services ne dépendant pas d'une instance dans SQL Server incluent les éléments suivants :

  • Integration Services

  • Navigateur SQL Server

  • SQL Server Active Directory Helper

  • SQL Writer

Vérification des droits et privilèges Windows NT accordés aux comptes de services SQL Server

Le programme d'installation de SQL Server crée des groupes de service local pour différents services SQL Server et y ajoute les comptes de service ou les SID de service en fonction des besoins. Ces groupes facilitent l'octroi des autorisations nécessaires pour exécuter les services SQL Server et autres exécutables, et aident à sécuriser les fichiers SQL Server. Pour les instances autonomes de SQL Server sur les systèmes d'exploitation Windows Vista et Windows Server 2008, les SID de service sont ajoutés automatiquement au groupe. Pour les instances de cluster de basculement sur Windows Server 2008, le programme d'installation ne crée pas de groupe d'utilisateurs par défaut. À la place, le programme d'installation ajoute des ressources SQL Server aux listes de contrôle d'accès par SID de service. Les utilisateurs peuvent également employer des comptes et groupes de domaine pour exécuter les services SQL Server. Notez que, pour utiliser les groupes de domaine, ceux-ci doivent être créés avant d'exécuter le programme d'installation de SQL Server.

Les noms de groupe de service uniques sont requis lorsque vous installez SQL Server sur un contrôleur de domaine, et seuls les comptes de domaine peuvent être utilisés pour ces groupes.

Le tableau suivant indique les droits spécifiques d'utilisateur Windows NT qui sont accordés aux groupes d'utilisateurs que crée le programme d'installation de SQL Server.

Service SQL Server | Groupe d'utilisateurs | Autorisations par défaut accordées par le programme d'installation de SQL Server
SQL Server | Instance par défaut : SQLServerMSSQLUser$ComputerName$MSSQLSERVER Instance nommée : SQLServerMSSQLUser$ComputerName$InstanceName | Ouvrir une session en tant que service (SeServiceLogonRight)1 Ouvrir une session en tant que programme de traitement par lots (SeBatchLogonRight) Remplacer un jeton de niveau processus (SeAssignPrimaryTokenPrivilege) Outrepasser le contrôle de parcours (SeChangeNotifyPrivilege) Changer les quotas de mémoire d'un processus (SeIncreaseQuotaPrivilege) Autorisation de démarrer SQL Server Active Directory Helper Autorisation de démarrer SQL Writer Autorisation de lire le service Journal des événements Autorisation de lire le service d'appel de procédure distante (RPC)
SQL Server Agent3 | Instance par défaut : SQLServerSQLAgentUser$ComputerName$MSSQLSERVER Instance nommée : SQLServerSQLAgentUser$ComputerName$InstanceName | Ouvrir une session en tant que service (SeServiceLogonRight) Ouvrir une session en tant que programme de traitement par lots (SeBatchLogonRight) Remplacer un jeton de niveau processus (SeAssignPrimaryTokenPrivilege) Outrepasser le contrôle de parcours (SeChangeNotifyPrivilege) Changer les quotas de mémoire d'un processus (SeIncreaseQuotaPrivilege)
Analysis Services | Instance par défaut : SQLServerMSOLAPUser$ComputerName$MSSQLSERVER Instance nommée : SQLServerMSOLAPUser$ComputerName$InstanceName | Ouvrir une session en tant que service (SeServiceLogonRight)
SSRS | Instance par défaut : SQLServerReportServerUser$ComputerName$MSRS10.MSSQLSERVER Instance nommée : SQLServerReportServerUser$ComputerName$MSRS10.InstanceName | Ouvrir une session en tant que service (SeServiceLogonRight)
Integration Services | Instance par défaut ou instance nommée : SQLServerDTSUser$ComputerName | Ouvrir une session en tant que service (SeServiceLogonRight) Autorisation d'écrire dans le journal des événements d'application Outrepasser le contrôle de parcours (SeChangeNotifyPrivilege) Emprunter l'identité d'un client après authentification (SeImpersonatePrivilege)
Recherche en texte intégral | Instance par défaut : SQLServerFDHostUser$ ComputerName$MSSQL10.MSSQLSERVER Instance nommée : SQLServerFDHostUser$ComputerName$MSSQL10.InstanceName | Ouvrir une session en tant que service (SeServiceLogonRight)
Navigateur SQL Server | Instance par défaut ou instance nommée : SQLServerSQLBrowserUser$ComputerName | Ouvrir une session en tant que service (SeServiceLogonRight)
SQL Server Active Directory Helper | Instance par défaut ou instance nommée : SQLServerMSSQLServerADHelperUser$ComputerName | Aucune2
SQL Writer | Non applicable | Aucune2

1Cette autorisation est accordée par défaut à tous les services SQL Server.

2 Le programme d'installation de SQL Server ne vérifie pas et n'accorde pas d'autorisations pour ce service.

3Le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

Vérification des listes de contrôle d'accès créées pour les comptes de service SQL Server

Les comptes de service SQL Server doivent avoir accès aux ressources. Des listes de contrôle d'accès (ACL) sont définies au niveau des groupes d'utilisateurs.

Important :
Pour les installations de clusters de basculement, les ressources des disques partagés doivent être attribuées à la liste ACL d'un compte local.

Le tableau suivant répertorie les listes ACL définies par le programme d'installation de SQL Server.

Compte de service1 pour | Fichiers et dossiers | Accès
MSSQLServer | Instid\MSSQL\backup | Contrôle total
 | Instid\MSSQL\binn | Lecture, exécution
 | Instid\MSSQL\data | Contrôle total
 | Instid\MSSQL\FTData | Contrôle total
 | Instid\MSSQL\Install | Lecture, exécution
 | Instid\MSSQL\Log | Contrôle total
 | Instid\MSSQL\Repldata | Contrôle total
 | 100\shared | Lecture, exécution
 | Données Instid\MSSQL\Template (SQL Server Express uniquement) | Lecture
SQLServerAgent2 | Instid\MSSQL\binn | Contrôle total
 | Instid\MSSQL\binn | Contrôle total
 | Instid\MSSQL\Log | Lecture, écriture, exécution, suppression (Read, Write, Execute, Delete)
 | 100\com | Lecture, exécution
 | 100\shared | Lecture, exécution
 | 100\shared\Errordumps | Lecture, écriture
FTS | Instid\MSSQL\FTData | Contrôle total
 | Instid\MSSQL\FTRef | Lecture, exécution
 | 100\shared | Lecture, exécution
 | 100\shared\Errordumps | Lecture, écriture
 | Instid\MSSQL\Install | Lecture, exécution
 | Instid\MSSQL\jobs | Lecture, écriture
MSSQLServerOLAPservice | 100\shared\ASConfig | Contrôle total
 | Instid\OLAP | Lecture, exécution
 | Instid\Olap\Data | Contrôle total
 | Instid\Olap\Log | Lecture, écriture
 | Instid\OLAP\Backup | Lecture, écriture
 | Instid\OLAP\Temp | Lecture, écriture
 | 100\shared\Errordumps | Lecture, écriture
SQLServerReportServerUser | Instid\Reporting Services\Log Files | Lecture, écriture, suppression
 | Instid\Reporting Services\ReportServer | Lecture, exécution
 | Instid\Reportingservices\Reportserver\global.asax | Contrôle total
 | Instid\Reportingservices\Reportserver\Reportserver.config | Lecture
 | Instid\Reporting Services\reportManager | Lecture, exécution
 | Instid\Reporting Services\RSTempfiles | Lecture, écriture, exécution, suppression (Read, Write, Execute, Delete)
 | 100\shared | Lecture, exécution
 | 100\shared\Errordumps | Lecture, écriture
MSDTSServer100 | 100\dts\binn\MsDtsSrvr.ini.xml | Lecture
 | 100\dts\binn | Lecture, exécution
 | 100\shared | Lecture, exécution
 | 100\shared\Errordumps | Lecture, écriture
Navigateur SQL Server | 100\shared\ASConfig | Lecture
 | 100\shared | Lecture, exécution
 | 100\shared\Errordumps | Lecture, écriture
MSADHelper | N/A (S'exécute sous le compte de service réseau) |
SQLWriter | Non applicable (s'exécute en tant que système local) |
Utilisateur | Instid\MSSQL\binn | Lecture, exécution
 | Instid\Reporting Services\ReportServer | Lecture, exécution, listage du contenu des dossiers
 | Instid\Reportingservices\Reportserver\global.asax | Lecture
 | Instid\Reporting Services\ReportManager | Lecture, exécution
 | Instid\Reporting Services\ReportManager\pages | Lecture
 | Instid\Reporting Services\ReportManager\Styles | Lecture
 | 100\dts | Lecture, exécution
 | 100\tools | Lecture, exécution
 | 90\tools | Lecture, exécution
 | 80\tools | Lecture, exécution
 | 100\sdk | Lecture
 | Microsoft SQL Server\100\Setup Bootstrap | Lecture, exécution

1 Dans certains scénarios, tels que le clustering avec basculement et l'installation de SQL Server sur un contrôleur de domaine, les listes ACL seront définies pour le SID de service SQL Server au lieu d'être définies pour le service SQL Server.

2Le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

Certaines autorisations de contrôle d'accès peuvent avoir été accordées à des comptes intégrés ou à d'autres comptes de services SQL Server. Le tableau suivant répertorie les listes ACL supplémentaires définies par le programme d'installation de SQL Server.

Composant demandeur | compte | Resource | Permissions
MSSQLServer | Utilisateurs du journal des performances | Instid\MSSQL\binn | Lister le contenu des dossiers
 | Utilisateurs de l'Analyseur de performances | Instid\MSSQL\binn | Lister le contenu des dossiers
 | Utilisateurs du journal des performances, Utilisateurs de l'Analyseur de performances | \WINNT\system32\sqlctr100.dll | Lecture, exécution
 | Administrateur uniquement | \\.\root\Microsoft\SqlServer\ServerEvents\<sql_instance_name>1 | Contrôle total
 | Administrateurs, système | \tools\binn\schemas\sqlserver\2003\03\showplan | Contrôle total
 | Users | \tools\binn\schemas\sqlserver\2003\03\showplan | Lecture, exécution
Reporting Services | <Compte de service Web du serveur de rapports> | <install>\Reporting Services\LogFiles | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Identité du pool de l'Application du Gestionnaire de rapports, compte ASP.NET, Tout le monde | <installer>\Reporting Services\ReportManager, <installer>\Reporting Services\ReportManager\Pages\*.*, <installer>\Reporting Services\ReportManager\Styles\*.*, <installer>\Reporting Services\ReportManager\webctrl_client\1_0\*.* | Lecture
 | Identité du pool d'applications du Gestionnaire de rapports | <install>\Reporting Services\ReportManager\Pages\*.* | Lecture
 | <Compte de service Web du serveur de rapports> | <install>\Reporting Services\ReportServer | Lecture
 | <Compte de service Web du serveur de rapports> | <install>\Reporting Services\ReportServer\global.asax | Complète
 | Tout le monde | <install>\Reporting Services\ReportServer\global.asax | READ_CONTROL FILE_READ_DATA FILE_READ_EA FILE_READ_ATTRIBUTES
 | Service réseau | <installer>\Reporting Services\ReportServer\ReportService.asmx | Complète
 | Tout le monde | <installer>\Reporting Services\ReportServer\ReportService.asmx | READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_EXECUTE FILE_READ_DATA FILE_READ_EA FILE_EXECUTE FILE_READ_ATTRIBUTES
 | Compte des services Windows ReportServer | <install>\Reporting Services\ReportServer\RSReportServer.config | DELETE READ_CONTROL SYNCHRONIZE FILE_GENERIC_READ FILE_GENERIC_WRITE FILE_READ_DATA FILE_WRITE_DATA FILE_APPEND_DATA FILE_READ_EA FILE_WRITE_EA FILE_READ_ATTRIBUTES FILE_WRITE_ATTRIBUTES
 | Tout le monde | Clés Report Server (ruche Instid) | Demander la valeur Énumérer les sous-clés Notifier Contrôle en lecture
 | Utilisateur de Terminal Services | Clés Report Server (ruche Instid) | Demander la valeur Définir la valeur Créer une sous-clé Énumérer les sous-clés Notifier Supprimer Contrôle en lecture
 | Utilisateurs avec pouvoir | Clés Report Server (ruche Instid) | Demander la valeur Définir la valeur Créer une sous-clé Énumérer les sous-clés Notifier Supprimer Contrôle en lecture

1Ceci est l'espace de noms du fournisseur WMI.

Récapitulation des autorisations Windows pour les services SQL Server

Le tableau suivant donne les noms des services, le terme utilisé pour faire référence aux instances par défaut et nommées des services SQL Server, une description de la fonction du service et les autorisations minimales requises.

Nom affiché Nom du service Description Autorisations requises

SQL Server (InstanceName)

Instance par défaut : MSSQLSERVER

Instance nommée : MSSQL$InstanceName

Moteur de base de données SQL Server.

Le chemin d'accès du fichier exécutable est \MSSQL\Binn\sqlservr.exe.

L'utilisateur local ou le compte d'utilisateur de domaine est recommandé.

Autorisations minimales Fonctionnalité

Compte de démarrage du service MSSQLServer

Le compte doit se trouver dans la liste des comptes dotés des autorisations « Liste du dossier » sur le lecteur racine où est installé SQL Server. Il doit aussi être à la racine de tout autre lecteur où les fichiers SQL Server sont stockés.

Remarque :
Les autorisations « Liste du dossier » sur le lecteur racine ne sont pas obligatoirement héritées par les sous-dossiers.

Compte de démarrage du service MSSQLServer

Le compte doit avoir les autorisations « Contrôle total » sur tous les dossiers dans lesquels résident les fichiers de données ou les fichiers journaux (.mdf, .ndf, .ldf).

Agent SQL Server (InstanceName)1

Instance par défaut : SQLServerAgent

Instance nommée : SQLAgent$InstanceName

Exécute les travaux, surveille SQL Server, déclenche les alertes et permet d'automatiser certaines tâches administratives.

Le chemin d'accès du fichier exécutable est \MSSQL\Binn\sqlagent.exe.

Autorisations minimales | Fonctionnalité
Le compte doit être membre du rôle serveur fixe sysadmin. |
Le compte doit avoir les autorisations Windows suivantes : | Ouvrir une session en tant que service. Ouvrir une session en tant que programme de traitement par lots. Remplacer un jeton au niveau du processus. Changer les quotas de mémoire d'un processus. Outrepasser le contrôle de parcours.

Services Analysis Services (InstanceName)

Instance par défaut : MSSQLServerOLAPService

Instance nommée : MSOLAP$InstanceName

Service qui fournit des fonctionnalités OLAP (online analytical processing) et d'exploitation de données pour les applications d'aide à la décision.

Le chemin d'accès du fichier exécutable est \OLAP\Bin\msmdsrv.exe.

Reporting Services

Instance par défaut : ReportServer

Instance nommée : ReportServer$InstanceName

Gère, exécute, crée, planifie et remet les rapports.

Le chemin d'accès du fichier exécutable est \Reporting Services\ReportServer\Bin\ReportingServicesService.exe.

Integration Services

Instance par défaut ou instance nommée : MSDTSServer

Assure la prise en charge de la gestion du stockage et de l'exécution des packages Integration Services.

Le chemin d'accès du fichier exécutable est \DTS\Binn\msdtssrv.exe.

Recherche en texte intégral

Instance par défaut ou instance nommée : lanceur du démon de filtre de texte intégral SQL

Service de lancement du processus de démon de filtre de texte intégral afin d'effectuer filtrage de document et l'analyse lexicale pour la recherche en texte intégral SQL Server.

Navigateur SQL Server

Instance par défaut ou instance nommée : SQLBrowser

Service de résolution de noms qui fournit les informations de connexion SQL Server pour les ordinateurs clients. Ce service est partagé entre plusieurs instances SQL Server et SSIS.

Le chemin d'accès du fichier exécutable est <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\sqlbrowser.exe.

SQL Server Active Directory Helper

Instance par défaut ou instance nommée : MSSQLServerADHelper

Publie et gère les services SQL Server dans Windows Active Directory.

Le chemin d'accès du fichier exécutable est <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\sqladhelper.exe.

SQL Writer

SQLWriter

Permet aux applications de sauvegarde et de restauration de fonctionner dans l'infrastructure du service VSS (cliché instantané de volume). Il existe une seule instance du service SQL Writer pour toutes les instances de SQL Server sur le serveur.

Le chemin d'accès du fichier exécutable est <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\sqlwriter.exe.

1Le service de l'Agent SQL Server est désactivé sur les instances SQL Server Express et SQL Server Express with Advanced Services.

Récapitulation des considérations supplémentaires

Le tableau suivant indique les autorisations nécessaires pour que les services SQL Server fournissent des fonctionnalités supplémentaires.

Service/Application | Fonctionnalité | Autorisation requise
SQL Server (MSSQLSERVER) | Écrire sur MailSlot avec xp_sendmail. | autorisations d'écriture réseau.
SQL Server (MSSQLSERVER) | Exécuter xp_cmdshell pour un utilisateur autre qu'un administrateur SQL Server. | Fonctionne comme un composant du système d'exploitation et remplace le jeton de niveau processus.
Agent SQL Server (MSSQLSERVER) | Utiliser la fonctionnalité de redémarrage automatique | Doit être membre du groupe local Administrateurs.
Assistant Paramétrage du moteur de base de données | Règle les bases de données pour des performances de requête optimales. | À la première utilisation, un utilisateur doté des informations d'identification d'administrateur système doit initialiser l'application. Après l'initialisation, les utilisateurs dbo peuvent utiliser l'Assistant Paramétrage du Moteur de base de données pour régler les tables dont ils sont propriétaires. Pour plus d'informations, consultez « Initialisation de l'Assistant Paramétrage du Moteur de base de données » dans la documentation en ligne de SQL Server.
Important :
Avant de procéder à une mise à niveau vers SQL Server, activez l'authentification Windows pour l'Agent SQL Server et vérifiez la configuration par défaut requise : si le compte de service de l'Agent SQL Server est membre du groupe sysadmin SQL Server.

Noms de services localisés

Le tableau ci-dessous indique les noms de services affichés dans les versions localisées de Windows.

Langue | Nom du service local | Nom du service réseau | Nom du système local | Nom du groupe Admin
Anglais Chinois simplifié Chinois traditionnel Coréen Japonais | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
Allemand | NT-AUTORITÄT\LOKALER DIENST | NT-AUTORITÄT\NETZWERKDIENST | NT-AUTORITÄT\SYSTEM | VORDEFINIERT\Administratoren
Français | AUTORITE NT\SERVICE LOCAL | AUTORITE NT\SERVICE RÉSEAU | AUTORITE NT\SYSTEM | BUILTIN\Administrateurs
Italien | NT AUTHORITY\SERVIZIO LOCALE | NT AUTHORITY\SERVIZIO DI RETE | NT AUTHORITY\SYSTEM | BUILTIN\Administrators
Espagnol | NT AUTHORITY\SERVICIO LOC | NT AUTHORITY\SERVICIO DE RED | NT AUTHORITY\SYSTEM | BUILTIN\Administradores
Russe | NT AUTHORITY\LOCAL SERVICE | NT AUTHORITY\NETWORK SERVICE | NT AUTHORITY\SYSTEM | BUILTIN\??????????????

Voir aussi

Référence

Configuration du moteur de base de données – Mise en service de compte
Configuration Analysis Services – Mise en service de compte

Concepts

Considérations sur la sécurité pour une installation SQL Server
Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server


Protocoles réseau et bibliothèques réseau

Protocoles réseau et bibliothèques réseau |
 | Voir aussi
Planification d'une installation SQL Server >

Un serveur peut être à l'écoute ou contrôler plusieurs protocoles réseau simultanément. Cependant, chaque protocole doit être configuré. Lorsqu'un protocole spécifique n'est pas configuré, le serveur ne peut pas se placer à l'écoute de ce protocole. Après l'installation, vous pouvez modifier ces configurations de protocole avec le Gestionnaire de configuration SQL Server.

Configuration réseau par défaut de SQL Server

Une instance par défaut de SQL Server est configurée pour le port TCP/IP 1433, tandis qu'un canal est nommé \\.\pipe\sql\query. Les instances nommées de SQL Server sont configurées pour les ports dynamiques TCP, avec un numéro de port attribué par le système d'exploitation.

Si vous ne pouvez pas utiliser les adresses de port dynamiques (par exemple, lorsque les connexions SQL Server doivent transiter par un serveur pare-feu configuré pour passer par des adresses de port spécifiques, ou lorsque certaines connexions sont réalisées avec les composants clients à partir de SQL Server version 7.0 ou antérieure), il est conseillé d’utiliser une adresse de port inférieure à 1024. Choisissez un port dans cette plage qui ne soit pas utilisé par le système d'exploitation ou toute autre application.

Pour renforcer la sécurité, la connectivité réseau n'est pas entièrement activée lorsque SQL Server est installé. Pour activer, désactiver et configurer les protocoles réseau une fois l'installation terminée, utilisez la zone Configuration du réseau SQL Server du Gestionnaire de configuration SQL Server.

Types de points de terminaison

SQL Server introduit un nouveau concept pour les connexions SQL Server ; la connexion est représentée à l'extrémité du serveur sous la forme d'un point de terminaison Transact-SQL. Des autorisations peuvent être accordées, retirées et refusées pour les points de terminaison Transact-SQL. Par défaut, tous les utilisateurs ont l'autorisation d'accéder à un point de terminaison sauf si cette autorisation est refusée ou retirée par un membre du groupe sysadmin ou par le propriétaire du point de terminaison. La syntaxe GRANT, REVOKE et DENY ENDPOINT utilise un ID de point de terminaison que l'administrateur doit prendre dans l'affichage catalogue du point de terminaison.

Le programme d'installation de SQL Server crée des points de terminaison Transact-SQL pour tous les protocoles réseau pris en charge, ainsi que pour la connexion administrateur dédiée.

Les points de terminaison Transact-SQL créés par le programme d'installation de SQL Server se présentent comme suit :

  • Ordinateur local Transact-SQL

  • Canaux nommés Transact-SQL

  • TCP par défaut Transact-SQL

  • VIA par défaut Transact-SQL

Pour plus d'informations sur les points de terminaison Transact-SQL, consultez « Network Protocols and TDS Endpoints (Protocoles réseau et points de terminaison TDS, éventuellement en anglais) » dans la documentation en ligne de SQL Server.

Pour plus d'informations sur les configurations réseau SQL Server, consultez les rubriques suivantes dans la documentation en ligne de SQL Server :

  • « Configuration réseau du serveur »

  • « Configuration des bibliothèques réseau et des protocoles réseau du serveur »

  • « Configuration réseau par défaut de SQL Server »

  • « Bibliothèques réseau et protocoles réseau »

Voir aussi

Concepts

Planification d'une installation SQL Server

Autres ressources

Présentation de la configuration de la surface d'exposition


Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server |
 | Voir aussi
Planification d'une installation SQL Server >

Une installation de SQL Server se compose d'une ou de plusieurs instances distinctes. Une instance, qu'elle soit par défaut ou nommée, possède son propre jeu de fichiers programmes et de fichiers de données, ainsi qu'un ensemble de fichiers communs partagés entre toutes les instances de SQL Server présentes sur l'ordinateur.

Pour une instance SQL Server qui inclut le Moteur de base de données, Analysis Services et Reporting Services, chaque composant a un jeu complet de fichiers de données et de fichiers exécutables, ainsi que des fichiers communs partagés par tous les composants.

Pour isoler l'emplacement d'installation de chaque composant, un ID d'instance unique est généré pour chaque composant d'une instance SQL Server donnée.

Important :
Les fichiers programmes et les fichiers de données ne peuvent pas être installés sur un lecteur de disque amovible, dans un système de fichiers utilisant la compression, dans un répertoire où figurent des fichiers système ni sur des lecteurs partagés sur une instance de cluster de basculement.

Vous ne devez supprimer ni les répertoires suivants ni leur contenu : Binn, Data, Ftdata, HTML ou 1033. Si besoin est, vous pouvez supprimer d'autres répertoires mais il est possible que vous ne puissiez pas récupérer certaines fonctionnalités ou données sans désinstaller puis réinstaller SQL Server. Ne supprimez ni ne modifiez aucun des fichiers .htm du répertoire HTML. Ils sont nécessaires pour que les outils de SQL Server fonctionnent correctement.

Fichiers partagés pour toutes les instances SQL Server

Les fichiers communs utilisés par toutes les instances d'un même ordinateur sont installés dans le dossier <lecteur>:\Program Files\Microsoft SQL Server\100\, <drive> désignant la lettre du lecteur sur lequel les composants sont installés. Généralement, il s'agit du lecteur C.

Emplacements des fichiers et mappage du Registre

Au cours de l'installation de SQL Server, un ID d'instance est généré pour chaque composant serveur. Les composants de cette version SQL Server sont le Moteur de base de données, Analysis Services et Reporting Services.

L'ID d'instance par défaut est construit à l'aide du format suivant :

  • MSSQL pour le Moteur de base de données, suivi du numéro de version principale et d'un point, puis du nom de l'instance.

  • MSAS pour Analysis Services, suivi du numéro de version principale et d'un point, puis du nom de l'instance.

  • MSRS pour Reporting Services, suivi du numéro de version principale et d'un point, puis du nom de l'instance.

Voici quelques exemples d'ID d'instance par défaut dans cette version de SQL Server :

  • MSSQL10.MSSQLSERVER pour une instance par défaut de SQL Server.

  • MSAS10.MSSQLSERVER pour une instance par défaut de Analysis Services.

  • MSSQL10.MyInstance pour une instance nommée de SQL Server intitulée « MyInstance ».

La structure de répertoire pour un instance nommée de SQL Server 2008 incluant Moteur de base de données et Analysis Services, intitulée « MyInstance » et installée sur les répertoires par défaut se présenterait de la façon suivante :

  • C:\Program Files\Microsoft SQL Server\MSSQL10.MyInstance\

  • C:\Program Files\Microsoft SQL Server\ASSQL10.MyInstance\

Vous pouvez spécifier n'importe quelle valeur pour l'ID d'instance, mais évitez les caractères spéciaux et les mots clé réservés. Pour plus d'informations, consultez Mots clés réservés (programme d'installation).

Vous pouvez spécifier un ID d'instance non défini par défaut pendant l'installation de SQL Server. Si l'utilisateur choisit de changer de répertoire d'installation par défaut, un <chemin personnalisé>\Microsoft SQL Server est utilisé à la place de <Program Files>\Microsoft SQL Server. Notez que les ID d'instance qui commencent avec un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Remarque :
Integration Services et les composants clients ne sont pas dépendants d'une instance et, par conséquent, ne se voient pas attribuer d'ID d'instance. Par défaut, les composants ne dépendant pas d'une instance sont installés dans un répertoire unique : <lecteur>:\Program Files\Microsoft SQL Server\100\. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placent des composants ne prenant pas en charge les instances dans le même répertoire que celui prévu par l'installation d'origine.

SQL Server Analysis Services est le seul composant SQL Server qui prend en charge l'attribution d'un nouveau nom à une instance après l'installation. Si une instance de Analysis Services est renommée, l'ID d'instance ne change pas. Une fois l'attribution du nouveau nom de l'instance terminée, les répertoires et les clés de Registre continuent à utiliser l'ID d'instance créé pendant l'installation.

La ruche du Registre est créée sous HKLM\Software\Microsoft\Microsoft SQL Server\<ID_instance> pour les composants qui prennent les instances en charge. Par exemple :

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\ASSQL10.MyInstance

  • HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.3

Le Registre maintient également le mappage d'un ID d'instance sur un nom d'instance. Le mappage de l'ID d'instance sur le nom d'instance se maintient comme suit :

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\SQL] "InstanceName"="MSSQL10"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\OLAP] "InstanceName"="ASSQL10"

  • [HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Names\RS] "InstanceName"="RSSQL10"

Spécification des chemins d'accès des fichiers

Pendant l'installation, vous pouvez modifier le chemin d'installation des fonctionnalités suivantes :

Ce chemin d'installation s'affiche uniquement dans le programme d'installation pour les fonctionnalités dotées d'un dossier de destination configurable par l'utilisateur.

Composant | Chemin d'accès par défaut1, 2 | Chemin configurable ou fixe3
Composants serveur du Moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL10.<InstanceID>\ | Configurable
Fichiers de données du Moteur de base de données | \Program Files\Microsoft SQL Server\MSSQL10.<InstanceID>\ | Configurable
Serveur Analysis Services | \Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\ | Configurable
Fichiers de données Analysis Services | \Program Files\Microsoft SQL Server\MSAS10.<InstanceID>\ | Configurable
Serveur de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS10.<InstanceID>\Reporting Services\ReportServer\Bin\ | Configurable
Gestionnaire de rapports Reporting Services | \Program Files\Microsoft SQL Server\MSRS10.<InstanceID>\Reporting Services\ReportManager\ | Chemin fixe
Integration Services | <Répertoire d'installation>\100\DTS\ | Configurable4
Composants clients | <Répertoire d'installation>\100\Tools\ | Configurable4
Objets COM côté serveur et de réplication | <lecteur>:\Program Files\Microsoft SQL Server\100\COM\5 | Chemin fixe
DLL des composants Integration Services pour le moteur d'exécution de transformation des données, le moteur pipeline de transformation des données et l'utilitaire d'invite de commandes dtexec | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\Binn | Chemin fixe
DLL qui assurent la prise en charge de connexions managées pour Integration Services | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\Connections | Chemin fixe
DLL pour chaque type d'énumérateur que Integration Services prend en charge | <lecteur>:\Program Files\Microsoft SQL Server\100\DTS\ForEachEnumerators | Chemin fixe
Service SQL Browser SQL Server, fournisseurs WMI | <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\ | Chemin fixe
Composants qui sont partagés entre toutes les instances SQL Server | <lecteur>:\Program Files\Microsoft SQL Server\100\Shared\ | Chemin fixe

1Vérifiez que le dossier \Program Files\Microsoft SQL Server\ est protégé par des autorisations limitées.

2 Le lecteur par défaut de ces emplacements est systemdrive, en général le lecteur C.

3Les chemins d'installation des composants enfants sont déterminés par le chemin d'installation de la fonctionnalité parent.

4Un chemin d'installation unique est partagé par Integration Services et les composants clients. La modification du chemin d'installation d'un composant affecte également les autres composants. En effet, les installations ultérieures placent les composants dans l'emplacement prévu par l'installation d'origine.

5Ce répertoire est utilisé par toutes les instances de SQL Server sur un ordinateur. Si vous effectuez une mise à jour sur l'une des instances situées sur l'ordinateur, toute modification apportée aux fichiers de ce dossier affecte toutes les instances de l'ordinateur. Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité. Vous devez soit installer les fonctionnalités supplémentaires dans les répertoires déjà établis par le programme d'installation, soit désinstaller et réinstaller le produit.

Remarque :
Pour les configurations en cluster, vous devez sélectionner un lecteur local disponible sur chaque nœud du cluster.

Lorsque, pendant l'installation, vous indiquez un chemin d'installation pour les composants serveur ou les fichiers de données, le programme d'installation utilise l'ID de l'instance, en plus de l'emplacement spécifié pour les fichiers programmes et les fichiers de données. Le programme d'installation n'utilise pas l'ID d'instance pour les outils et les autres fichiers partagés. S'il ne l'utilise pas non plus pour les fichiers programmes et les fichiers de données de Analysis Services, il l'utilise en revanche pour le référentiel de Analysis Services.

Si vous définissez le chemin d'installation de la fonctionnalité du Moteur de base de données, le programme d'installation de SQL Server utilise ce chemin comme répertoire racine de tous les dossiers spécifiques à l'instance pour cette installation, y compris les fichiers de données SQL. Dans ce cas, si vous définissez comme racine « C:\Program Files\Microsoft SQL Server\MSSQL10\MSSQL\ », les répertoires spécifiques à l'instance sont ajoutés à la fin du chemin.

Les clients qui choisissent d'utiliser la fonctionnalité de mise à niveau USESYSDB dans l'Assistant Installation de SQL Server (mode d'interface utilisateur du programme d'installation) peuvent aisément se trouver dans une situation où le produit est installé dans une structure de dossiers récursive. Par exemple, <SQLProgramFiles>\MSSQL10\MSSQL\MSSQL10\MSSQL\Data\. Pour utiliser la fonctionnalité USESYSDB, il est donc conseillé de définir un chemin d'installation pour la fonctionnalité fichiers de données SQL au lieu de la fonctionnalité Moteur de base de données.

Remarque :
Les fichiers de données se situent généralement dans un répertoire enfant nommé « Data ». Par exemple, spécifiez C:\Program Files\Microsoft SQL Server\MSSQL10\ comme chemin d'accès racine au répertoire de données des bases de données système durant la mise à niveau lorsque les fichiers de données se trouvent sous C:\Program Files\Microsoft SQL Server\MSSQL10\MSSQL\Data.

Voir aussi

Référence

Configuration du moteur de base de données – Répertoires de données
Configuration de Analysis Services – Répertoires de données

Concepts

Planification d'une installation SQL Server


Utilisation de plusieurs versions et instances de SQL Server

Utilisation de plusieurs versions et instances de SQL Server |
 | Voir aussi
Planification d'une installation SQL Server >

SQL Server prend en charge plusieurs instances du Moteur de base de données, de Analysis Services et de Reporting Services sur le même ordinateur. Vous pouvez également mettre à niveau des versions antérieures de SQL Server ou installer SQL Server sur un ordinateur où des versions précédentes de SQL Server sont déjà installées. Pour obtenir la liste des scénarios de mise à niveau pris en charge, consultez Mises à niveau de la version et de l'édition.

Utilisation de SQL Server côte à côte avec les versions précédentes de SQL Server

Vous pouvez installer SQL Server sur un ordinateur exécutant déjà les instances d'une version précédente de SQL Server. Si une instance par défaut existe sur l'ordinateur, SQL Server doit être installé comme instance nommée.

Le tableau suivant répertorie la prise en charge côte à côte de SQL Server 2008 :

Instance existante de SQL Server 2008 | Prise en charge côte à côte
SQL Server 2008 (32 bits) | SQL Server 2000 (32 bits) SQL Server 2000 (64 bits) x64 SQL Server 2005 (32 bits) SQL Server 2005 (64 bits) x64
SQL Server 2008 (64 bits) IA64 | SQL Server 2005 (64 bits) IA64
SQL Server 2008 (64 bits) x64 | SQL Server 2000 (32 bits) SQL Server 2000 (64 bits) x64 SQL Server 2005 (32 bits) SQL Server 2005 (64 bits) x64

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008
Mises à niveau de la version et de l'édition

Concepts

Mise à niveau vers SQL Server 2008
Compatibilité ascendante
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau


Prise en charge d'Unicode et du classement

Prise en charge d'Unicode et du classement |
 | Voir aussi
Planification d'une installation SQL Server >

Comme les bases de données se développent pour prendre en charge un marché mondial croissant, les utilisateurs doivent être en mesure d'utiliser les données caractères de façons significatives. Les classements permettent aux utilisateurs de trier et comparer les chaînes selon leurs propres conventions. Les classements sont une partie critique de la création d'une base de données et de la manipulation de données.

SQL Server 2008 est pleinement aligné avec les classements dans Windows Server 2008.

Nouveautés dans les classements de SQL Server 2008

Les modifications suivantes sont nouvelles dans les classements de SQL Server 2008 :

SQL Server 2008 introduit de nouveaux classements qui sont en alignement complet avec les classements que fournit Windows Server 2008. Ces 80 nouveaux classements sont dénotés par des références de version *_100. Ils offrent aux utilisateurs les conventions de tri culturelles les plus exactes linguistiquement et les plus récentes. La prise en charge inclut ce qui suit :

  • Nouveaux standards publics d'Extrême-Orient.

  • Substituts corrects linguistiquement.

  • Scripts de minorité chinoise.

  • Table de cas Unicode 5.0.

  • La pondération a été ajoutée aux caractères qui n'étaient pas pondérés précédemment et dont la comparaison aurait abouti à une égalité.

Les nouvelles versions sont ajoutées aux classements Windows existants de SQL Server 2000 et SQL Server 2005 pour tenir compte de ces modifications. Tous les classements actuels seront conservés dans SQL Server 2005 à des fins de compatibilité descendante. Aucune modification n'a été apportée aux classements SQL_*.

Abandon des classements Windows Korean_Wansung_Unicode, Hindi_CI_AS, Macedonian_CI_AS, Lithuanian_Classic_CI_AS, Cyrillic_90_CI_AS et Azeri_Latin_90_CI_AS, et abandon du classement SQL SQL_ALTDiction_CP1253_CS_AS. Ces classements étaient pris en charge dans SQL Server 2005 , et sont pris en charge dans SQL Server 2008. Cependant, ils ne sont pas affichés dans la liste des classements du programme d'installation et n'apparaissent pas lorsque vous utilisez la fonction système ::fn_helpcollations() pour interroger la liste des classements pris en charge dans SQL Server 2008.

Voir aussi

Référence

Paramètres de classement du programme d'installation
Choix d'un classement SQL Server

Concepts

Classement et terminologie internationale


Classement et terminologie internationale

Classement et terminologie internationale |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement >

Les classements dans SQL Server fournissent les règles de tri et les propriétés de respect de la casse et des accents pour vos données. Les classements utilisés avec les types de données character, tels que char et varchar, déterminent la page de codes et les caractères correspondants qui peuvent être représentés pour ce type de données. Que vous installiez une nouvelle instance de SQL Server, restauriez une sauvegarde de base de données ou connectiez un serveur à des bases de données clientes, il est important que vous compreniez les besoins en termes de paramètres régionaux, ordre de tri et respect de la casse et des accents des données avec lesquelles vous travaillez.

Lorsque vous sélectionnez un classement pour votre serveur, base de données, colonne ou expression, vous assignez certaines caractéristiques à vos données qui affecteront les résultats de nombreuses opérations dans votre base de données. Par exemple, lorsque vous construisez une requête à l'aide d'ORDER BY, l'ordre de tri de votre jeu de résultats peut dépendre du classement appliqué à la base de données ou stipulé dans une clause COLLATE au niveau expression de la requête.

Un classement peut avoir tout ou partie des caractéristiques suivantes :

  • Respect de la casse

  • Respect des accents

  • Respect du jeu de caractères Kana

  • Respect de la largeur

Pour exploiter au mieux la prise en charge des classements dans SQL Server, vous devez comprendre les termes qui sont définis dans cette rubrique et la relation qu'ils entretiennent avec les caractéristiques de vos données.

Termes

  • Classement

  • Paramètres régionaux

  • Unicode

  • Page de codes

  • Type de données

  • Ordre de tri

Classement

Un classement désigne les modèles binaires qui représentent chaque caractère dans un jeu de données. Les classements déterminent également les règles de tri et de comparaison de données. SQL Server prend en charge le stockage d'objets ayant des classements différents dans une même base de données. Pour les colonnes non-Unicode, le paramètre de classement spécifie la page de codes pour les données et les caractères qui peuvent être représentés. Les données déplacées entre des colonnes non-Unicode doivent être converties de la page de codes source vers la page de codes de destination.

Le résultat d'une instruction Transact-SQL peut varier lorsque cette dernière est exécutée dans un contexte réunissant plusieurs bases de données dont chacune a un paramètre de classement différent. Dans la mesure du possible, choisissez un classement normalisé pour votre organisation. De cette manière, vous n'avez pas à spécifier explicitement le classement dans chaque caractère ou expression Unicode. Si vous devez utiliser des objets qui ont des paramètres de classement et de page de codes différents, codez vos requêtes conformément aux règles de priorité des classements. Pour plus d'informations, consultez Priorité de classement (Transact-SQL).

Un classement se caractérise par le respect de la langue, de la casse, des accents, des caractères Kana et de la largeur.

Les classements SQL Server incluent les jeux de classements suivants :

Classements Windows

Les classements Windows définissent les règles de stockage des données de type caractère selon les paramètres régionaux système Windows associés. Pour un classement Windows, la comparaison de données non-Unicode est implémentée via le même algorithme que les données Unicode. Les règles de classement Windows de base spécifient l'alphabet ou la langue utilisée pour le tri du dictionnaire, et la page de codes utilisée pour stocker les données de type caractère non-Unicode. Les tris Unicode et non-Unicode sont compatibles avec les comparaisons de chaînes dans une version particulière de Windows. Les types de données sont ainsi cohérents dans SQL Server, ce qui permet aux développeurs de trier les chaînes dans leurs applications en appliquant les mêmes règles que celles utilisées par SQL Server. Pour plus d'informations, consultez Paramètres de classement du programme d'installation.

Classements binaires

Les classements binaires trient les données en fonction de la séquence des valeurs codées qui sont définies par les paramètres régionaux et le type de données. Ils respectent la casse. Un classement binaire dans SQL Server définit les paramètres régionaux et la page de codes ANSI à utiliser. Cela applique un ordre de tri binaire. Parce qu'ils sont relativement simples, les classements binaires aident à améliorer les performances de l'application. Pour les types de données non-Unicode, les comparaisons de données sont basées sur les points de code qui sont définis dans la page de codes ANSI. Pour les données de type Unicode, les comparaisons de données se basent sur les points de code Unicode. Pour le classement binaire des types de données Unicode, les paramètres régionaux (la langue) ne sont pas pris en compte dans les tris de données. Par exemple, Latin_1_General_BIN et Japanese_BIN produisent des résultats de tri identiques quand ils sont utilisés avec des données Unicode.

Les classements binaires des précédentes versions de SQL Server comparaient le premier caractère comme WCHAR, suivi d'une comparaison octet par octet. Pour des raisons de compatibilité descendante, la sémantique des classements binaires existante ne sera pas modifiée.

Les classements binaires de cette version de SQL Server incluent un ensemble de classements de comparaison de points de code purs. Vous pouvez migrer vers les classements binaires pour tirer parti de comparaisons de point de code vraies. Vous devez utiliser des classements binaires pour développer de nouvelles applications. Le suffixe BIN2 identifie le nom des classements qui implémentent la sémantique des nouveaux classements par points de code. Il y a également un indicateur de comparaison qui correspond à BIN2 pour le nouveau tri binaire. Pour plus d'informations, consultez Principes d'utilisation des classements BIN et BIN2.

SQL Server

Les classements (SQL_*) SQL Server fournissent la compatibilité d'ordre de tri avec les versions antérieures de SQL Server. Les règles de tri du dictionnaire pour les données non-Unicode ne sont pas compatibles avec les routines de tri fournies par les systèmes d'exploitation Windows. Toutefois, le tri de données Unicode est compatible avec une version particulière de règles de tri Windows. Comme les classements SQL Server utilisent des règles de comparaison différentes pour les données Unicode et non-Unicode, vous pouvez obtenir des résultats différents pour des comparaisons traitant des mêmes données, selon le type de données sous-jacent. Pour plus d'informations, consultez Utilisation des classements SQL Server.

Remarque :
Lorsque vous mettez à niveau une instance anglaise SQL Server, vous pouvez spécifier les classements (SQL_*) SQL Server pour permettre la compatibilité avec les instances SQL Server existantes. Le classement par défaut d'une instance SQL Server étant défini au cours de la procédure d'installation, il est important de spécifier soigneusement les paramètres de classement dans les cas suivants :

  • Votre code d'application dépend du comportement des classements SQL Server précédents.

  • Vous utiliserez la fonctionnalité de réplication SQL Server avec des instances existantes de SQL Server version 6.5 ou SQL Server version 7.0.

  • Vous devez stocker des données de caractères de plusieurs langues.

Les paramétrages des classements sont pris en charge aux niveaux suivants d'une instance SQL Server :

Classements au niveau du serveur

Le classement par défaut est défini durant l'installation de SQL Server, et devient également le classement par défaut des bases de données système. Notez que les classements Unicode ne peuvent pas être sélectionnés pendant la procédure d'installation de SQL Server car ils ne sont pas pris en charge en tant que classements au niveau serveur.

Lorsqu'un classement a été attribué à un objet autre qu'une colonne ou une base de données, vous ne pouvez le modifier qu'en supprimant et en recréant l'objet. Au lieu de modifier le classement par défaut d'une instance SQL Server, vous pouvez spécifier un classement pour chaque nouvelle base de données ou colonne de base de données.

Pour demander le classement du serveur dans une instance SQL Server, utilisez la fonction Transact-SQL SERVERPROPERTY suivante :

Copier le code
SELECT CONVERT (varchar, SERVERPROPERTY('collation'))

Pour demander au serveur tous les classements disponibles, utilisez la fonction intégrée fn_helpcollations() suivante :

Copier le code
SELECT * from ::fn_helpcollations()
Classements au niveau de la base de données

Lorsque vous créez une base de données, vous pouvez utiliser la clause COLLATE de l'instruction CREATE DATABASE pour spécifier le classement par défaut de la base de données. Si aucun classement n'est spécifié, la base de données reçoit le classement par défaut de la base de données model. Le classement de la base de données model est identique au classement par défaut de l'instance SQL Server.

Le classement d'une base de données utilisateur peut être modifié à l'aide une instruction ALTER DATABASE telle que la suivante :

Copier le code
ALTER DATABASE myDB COLLATE Greek_CS_AI

Le classement courant d'une base de données peut être extrait à l'aide d'une instruction telle que la suivante :

Copier le code
SELECT CONVERT (varchar, DATABASEPROPERTYEX('database_name','collation'))
Remarque :
Le fait de changer le classement au niveau de la base de données n'a aucune incidence sur les classements au niveau des expressions et des colonnes.

Classements au niveau des colonnes

Lorsque vous créez une table, vous pouvez spécifier les classements de chaque colonne de chaînes de caractères à l'aide de la clause COLLATE de l'instruction CREATE TABLE. Si aucun classement n'est spécifié, le classement par défaut de la base de données est attribué à la colonne.

Le classement d'une colonne peut être modifié à l'aide une instruction ALTER TABLE telle que la suivante :

Copier le code
ALTER TABLE myTable ALTER COLUMN mycol NVARCHAR(10) COLLATE Greek_CS_AI
Classements au niveau de l'expression

Les classements au niveau de l'expression sont définis lors de l'exécution d'une instruction et ils affectent la façon dont l'ensemble de résultats est retourné. Cela permet aux résultats de tri ORDER BY d'être spécifiques aux paramètres régionaux. Utilisez une clause COLLATE telle que la suivante pour implémenter les classements au niveau de l'expression :

Copier le code
SELECT name FROM customer ORDER BY name COLLATE Latin1_General_CS_AI

Retour en haut

Paramètres régionaux

Les paramètres régionaux sont un ensemble d'informations associées à un lieu ou à une culture. Il peut s'agir du nom et de l'identificateur de la langue parlée, du script utilisé pour écrire la langue et des conventions culturelles. Les classements peuvent être associés à un ou plusieurs ensembles de paramètres régionaux.

Retour en haut

Unicode

Si vous stockez des données de caractères de plusieurs langues, utilisez toujours les types de données Unicode (nchar, nvarchar et ntext) à la place des types de données non-Unicode (char, varchar et text).

Des limitations significatives sont associées aux types de données non-Unicode. C'est parce qu'un ordinateur non-Unicode sera restreint quant à l'utilisation d'une page de codes unique. Vous pouvez bénéficier de gains de performances en utilisant Unicode parce qu'un moins grand nombre de conversions de page de codes est requis. Les classements unicode doivent être sélectionnés individuellement au niveau de la base de données, de la colonne ou de l'expression parce qu'ils ne sont pas pris en charge au niveau serveur.

Les pages de codes qu'utilise un client sont déterminées par les paramètres de votre système d'exploitation. Pour définir les pages de codes du client sur les systèmes d'exploitation Windows 2000, Windows XP, Windows Server 2003 ou Windows Server 2008, utilisez Paramètres régionaux dans le Panneau de configuration.

Lorsque vous déplacez des données d'un serveur vers un client, votre classement du serveur peut ne pas être reconnu par les pilotes de clients plus anciens. Cela peut se produire le plus souvent lorsque vous déplacez des données d'un serveur Unicode vers un client non Unicode. La meilleure solution peut alors consister à mettre à niveau le système d'exploitation du client afin de mettre aussi à jour les classements du système sous-jacent. Si le client est équipé du logiciel client de base de données, vous pouvez envisager de lui appliquer une mise à jour du service.

Vous pouvez également essayer d'utiliser un autre classement pour les données du serveur. Choisissez un classement qui effectue un mappage à une page de codes du client. Pour plus d'informations, consultez la rubrique « Définition et modification des classements » dans la documentation en ligne de SQL Server.

Pour déterminer les problèmes qui sont liés à l'utilisation des types de données Unicode ou non-Unicode, testez votre scénario pour mesurer les écarts de performances dans votre environnement. Vous devez normaliser le classement utilisé sur les systèmes de votre organisation et déployer des serveurs et clients Unicode partout où vous le pouvez. Pour plus d'informations sur Unicode, consultez le site Web du consortium Unicode (en anglais).

Dans de nombreuses situations, SQL Server entre en interaction avec d'autres serveurs ou clients et votre organisation peut utiliser différentes normes d'accès aux données entre les applications et les instances de serveur. Les clients SQL Server sont l'un des deux types principaux :

  • Les clients Unicode qui utilisent OLE DB et ODBC (Open Database Connectivity) 3.7 ou version ultérieure.

  • Les clients non-Unicode qui utilisent DB-Library et ODBC 3.6 ou version antérieure.

Le tableau suivant présente des informations sur l'utilisation des données multilingues avec diverses combinaisons de serveurs Unicode et non-Unicode.

Serveur | Client | Avantages ou restrictions
Unicode | Unicode | Comme les données Unicode seront utilisées dans la totalité du système, ce scénario fournit les meilleures performances et la meilleure protection contre la modification des données extraites. C'est le cas avec ActiveX Data Objects (ADO), OLE DB et ODBC 3.7 ou version ultérieure.
Unicode | Non-Unicode | Dans ce scénario, et surtout avec les connexions entre un serveur exécutant un système d'exploitation récent et un client exécutant une version antérieure de SQL Server, ou un système d'exploitation plus ancien, il peut y avoir des limitations ou des erreurs lorsque vous déplacez des données vers un ordinateur client. Les données Unicode sur le serveur tenteront d'établir un mappage à une page de codes correspondante sur le client non-Unicode afin de convertir les données.
Non-Unicode | Unicode | Cette configuration n'est pas idéale pour l'utilisation de données multilingues. Vous ne pouvez pas écrire des données Unicode sur le serveur non-Unicode. Des problèmes peuvent survenir lorsque les données sont envoyées à des serveurs qui sont en dehors de la page de codes du serveur.
Non-Unicode | Non-Unicode | Cette configuration est la plus limitée pour des données multilingues. Vous pouvez utiliser uniquement une seule page de codes.

Si vous rencontrez des erreurs ou des problèmes lors du déplacement de données d'un serveur vers un client (spécifiquement, d'un serveur Unicode vers un client non-Unicode), votre classement de serveur risque de ne pas être reconnu par d'anciens pilotes clients. Dans ce cas, la meilleure solution est de mettre à niveau le système d'exploitation du client afin de mettre à jour les classements du système sous-jacent. Si le client est équipé du logiciel client de base de données, vous pouvez envisager de lui appliquer une mise à jour du service.

Vous pouvez également essayer d'utiliser un autre classement pour les données du serveur. Choisissez un classement qui établit un mappage à une page de codes du client. Pour plus d'informations sur la modification des classements, consultez la rubrique « Définition et modification des classements dans SQL Server » dans la documentation en ligne de SQL Server. Pour plus d'informations sur la modification des classements, consultez le livre blanc des « meilleures pratiques recommandées pour la modification des classements SQL Server » à l'adresse suivante . Pour plus d'informations sur la façon d'effectuer une migration de types de données non-Unicode vers Unicode, consultez le livre blanc des « meilleures pratiques recommandées SQL Server pour migrer vers Unicode à l'adresse suivante.

Rubriques connexes : Unicode : concepts de base

Retour en haut

Page de codes

Une page de codes est le jeu de caractères ordonné d'un script donné dans lequel un index numérique (ou une valeur de point de code) est associé à chaque caractère. Une page de codes Windows est généralement appelée jeu de caractères ou charset. Les pages de codes permettent d'assurer la prise en charge des jeux de caractères et des dispositions du clavier utilisés par différents paramètres régionaux système Windows.

Tous les classements Unicode Windows Server 2008 sont basés sur Unicode 5.0.

Retour en haut

Types de données

Un type de données est une définition qui spécifie une plage de valeurs, les opérations qui peuvent être effectuées sur ces valeurs et la façon dont les valeurs sont stockées dans la mémoire de l'ordinateur. Définir des types de données permet à SQL Server de manipuler les données de manière prévisible. Les types de données de caractères non-Unicode sont char, varchar et text. Les types de données Unicode sont nchar, nvarchar et ntext. Nous vous recommandons d'utiliser les types de données Unicode dans vos applications, notamment si vous stockez des données de caractères de plusieurs langues.

Pour plus d'informations sur la façon d'effectuer une migration de types de données non-Unicode vers Unicode, consultez le livre blanc des « meilleures pratiques recommandées SQL Server pour migrer vers Unicode à l'adresse suivante.

Rubriques connexes : Types de données (Moteur de base de données), Types de données (Transact-SQL), Types de données d'Integration Services

Retour en haut

Ordre de tri

L'ordre de tri spécifie comment sont triées les valeurs de données. Cela affecte les résultats de comparaison de données. Les données sont triées en utilisant les classements et peuvent être optimisées à l'aide des index.

Rubriques connexes : Styles de tri des classements Windows, Index

Retour en haut

Voir aussi

Référence

Prise en charge d'Unicode et du classement


Paramètres de classement du programme d'installation

Paramètres de classement du programme d'installation |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement >

De nombreuses activités de serveur à serveur peuvent échouer ou produire des résultats contradictoires si les paramètres de classement ne sont pas cohérents sur les différents serveurs. Pour éviter ce problème, sélectionnez des paramètres régionaux Windows ou un classement (SQL_*) SQL Server correspondant aux paramètres de classement dans les autres instances de SQL Server.

SQL Server 2008 assure le paramétrage des classements aux niveaux suivants :

  • Serveur

  • Base de données

  • Colonne

  • Expression

Pour plus d'informations, consultez Classement et terminologie internationale et Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Classements binaires

Les classements binaires trient et comparent les données de SQL Server à partir du modèle binaire de chaque caractère. Dans SQL Server, chaque classement binaire correspond à des paramètres régionaux linguistiques et à une page de codes ANSI donnés et effectue des tris de données qui respectent la casse et les accents. Pour plus d'informations, consultez Styles de tri des classements Windows et Principes d'utilisation des classements BIN et BIN2.

Classements SQL Server (SQL_*)

Sélectionnez cette option pour une compatibilité des paramètres avec les versions anglaises de SQL Server 2005 ou versions antérieures. Pour plus d'informations, consultez Utilisation des classements SQL Server.

Paramètres régionaux système de Windows

Les paramètres d'installation par défaut dépendent des paramètres régionaux du système Windows. Le classement au niveau du serveur peut être modifié pendant l'installation, ou en modifiant les paramètres régionaux du système Windows avant l'installation. Les classements par défaut sont définis selon la version disponible la plus ancienne associée à chaque ensemble de paramètres régionaux spécifiques. Cette approche se justifie pour des raisons de compatibilité descendante. Par conséquent, ce ne sont pas toujours les classements recommandés. Pour tirer avantage des fonctionnalités de SQL Server 2008, modifiez les paramètres d'installation par défaut pour les classements Windows.

Pour configurer les paramètres régionaux Windows pour les systèmes d'exploitation antérieurs à Windows Vista, cliquez sur Options régionales et linguistiques dans le Panneau de configuration, puis sur l'onglet Options régionales pour connaître le nom de l'ensemble des paramètres régionaux du système Windows actifs. Dans Windows Vista, utilisez l'onglet Formats.

Indicateur de classement

Sélectionnez le nom d'un classement Windows spécifique dans la liste Indicateur de classement. Par exemple, utilisez Latin1_General pour le jeu de caractères Anglais (États-Unis) – page de codes 1252.

Ordre de tri

Sélectionnez les options d'ordre de tri à utiliser avec l'indicateur de classement désigné. L'ordre de tri binaire est le plus rapide et respecte la casse, mais il peut produire des ordres de tri inattendus. Si Binaire est activé, les options Respecter la casse, Respecter les accents, Respecter les caractères Kana et Respecter la largeur ne sont pas disponibles. Pour plus d'informations, consultez Styles de tri des classements Windows.

Classements par défaut dans le programme d'installation de SQL Server

Dans le Panneau de configuration, recherchez le nom des paramètres régionaux système Windows sous l'onglet Avancé dans Options régionales et linguistiques. Dans Windows Vista, utilisez l'onglet Formats. Le tableau suivant contient l'indicateur de classement et la page de codes destinés à faire correspondre les paramètres de classement avec les paramètres régionaux Windows existants :

Paramètres régionaux Windows | LCID Windows | Valeur par défaut | Page de codes
Afrikaans (Afrique du Sud) | 0x0436 | Latin1_General_CI_AS | 1252
Albanais (Albanie) | 0x041c | Albanian_CI_AS | 1252
Alsacien (France) | 0x0484 | Latin1_General_100_CI_AS | 1252
Amharique (Éthiopie) | 0x045e | Latin1_General_100_CI_AS | 1252
Arabe (Algérie) | 0x1401 | Arabic_CI_AS | 1256
Arabe (Bahreïn) | 0x3c01 | Arabic_CI_AS | 1256
Arabe (Égypte) | 0x0c01 | Arabic_CI_AS | 1256
Arabe (Irak) | 0x0801 | Arabic_CI_AS | 1256
Arabe (Jordanie) | 0x2c01 | Arabic_CI_AS | 1256
Arabe (Koweït) | 0x3401 | Arabic_CI_AS | 1256
Arabe (Liban) | 0x3001 | Arabic_CI_AS | 1256
Arabe (Libye) | 0x1001 | Arabic_CI_AS | 1256
Arabe (Maroc) | 0x1801 | Arabic_CI_AS | 1256
Arabe (Oman) | 0x2001 | Arabic_CI_AS | 1256
Arabe (Qatar) | 0x4001 | Arabic_CI_AS | 1256
Arabe (Arabie Saoudite) | 0x0401 | Arabic_CI_AS | 1256
Arabe (Syrie) | 0x2801 | Arabic_CI_AS | 1256
Arabe (Tunisie) | 0x1c01 | Arabic_CI_AS | 1256
Arabe (E.A.U.) | 0x3801 | Arabic_CI_AS | 1256
Arabe (Yémen) | 0x2401 | Arabic_CI_AS | 1256
Arménien (Arménie) | 0x042b | Cyrillic_General_100_CI_AS | 1251
Assamais (Inde) | 0x044d | Non disponible au niveau du serveur | Unicode
Azéri (Azerbaïdjan, cyrillique) | 0x082c | Azeri_Cyrillic_90_CI_AS | 1251
Azéri (Azerbaïdjan, latin) | 0x042c | Azeri_Latin_90_CI_AS | 1254
Bachkir (Russie) | 0x046d | Bashkir_100_CI_AS | 1251
Basque (Basque) | 0x042d | Latin1_General_100_CI_AS | 1252
Bélarussien (Bélarus) | 0x0423 | Cyrillic_General_CI_AS | 1251
Bengali (Bangladesh) | 0x0845 | Non disponible au niveau du serveur | Unicode
Bengali (Inde) | 0x0445 | Non disponible au niveau du serveur | Unicode
Bosniaque (Bosnie-Herzégovine, cyrillique) | 0x201a | Bosnian_Cyrillic_100_CI_AS | 1251
Bosniaque (Bosnie-Herzégovine, latin) | 0x141a | Bosnian_Latin_100_CI_AS | 1250
Breton (France) | 0x047e | Breton_100_CI_AS | 1252
Bulgare (Bulgarie) | 0x0402 | Cyrillic_General_CI_AS | 1251
Catalan (Catalan) | 0x0403 | Latin1_General_CI_AS | 1252
Chinois (Hong Kong SAR, PRC) | 0x0c04 | Chinese_Hong_Kong_Stroke_90_CI_AS | 950
Chinois (Macao R.A.S.) | 0x1404 | Chinese_Traditional_Pinyin_100_CI_AS | 950
Chinois (Macao) | 0x21404 | Chinese_Traditional_Stroke_Order_100_CI_AS | 950
Chinois (République populaire de Chine) | 0x0804 | Chinese_PRC_CI_AS | 936
Chinois (RPC) | 0x20804 | Chinese_PRC_Stroke_CI_AS | 936
Chinois (Singapour) | 0x1004 | Chinese_PRC_CI_AS | 936
Chinois (Singapour) | 0x21004 | Chinese_Simplified_Stroke_Order_100_CI_AS | 936
Chinois (Taïwan) | 0x30404 | Chinese_Taiwan_Bopomofo_CI_AS | 950
Chinois (Taïwan) | 0x0404 | Chinese_Taiwan_Stroke_CI_AS | 950
Corse (France) | 0x0483 | Corsican_100_CI_AS | 1252
Croate (Bosnie-Herzégovine, latin) | 0x101a | Croatian_100_CI_AS | 1250
Croate (Croatie) | 0x041a | Croatian_CI_AS | 1250
Tchèque (République tchèque) | 0x0405 | Czech_CI_AS | 1250
Danois (Danemark) | 0x0406 | Danish_Norwegian_CI_AS | 1252
Dari (Afghanistan) | 0x048c | Dari_100_CI_AS | 1256
Maldivien (Maldives) | 0x0465 | Non disponible au niveau du serveur | Unicode
Néerlandais (Belgique) | 0x0813 | Latin1_General_CI_AS | 1252
Néerlandais (Pays-Bas) | 0x0413 | Latin1_General_CI_AS | 1252
Anglais (Australie) | 0x0c09 | Latin1_General_CI_AS | 1252
Anglais (Belize) | 0x2809 | Latin1_General_CI_AS | 1252
Anglais (Canada) | 0x1009 | Latin1_General_CI_AS | 1252
Anglais (Caraïbes) | 0x2409 | Latin1_General_CI_AS | 1252
Anglais (Inde) | 0x4009 | Latin1_General_100_CI_AS | 1252
Anglais (Irlande) | 0x1809 | Latin1_General_CI_AS | 1252
Anglais (Jamaïque) | 0x2009 | Latin1_General_CI_AS | 1252
Anglais (Malaisie) | 0x4409 | Latin1_General_100_CI_AS | 1252
Anglais (Nouvelle-Zélande) | 0x1409 | Latin1_General_CI_AS | 1252
Anglais (Philippines) | 0x3409 | Latin1_General_CI_AS | 1252
Anglais (Singapour) | 0x4809 | Latin1_General_100_CI_AS | 1252
Anglais (Afrique du Sud) | 0x1c09 | Latin1_General_CI_AS | 1252
Anglais (Trinidad-et-Tobago) | 0x2c09 | Latin1_General_CI_AS | 1252
Anglais (Royaume-Uni) | 0x0809 | Latin1_General_CI_AS | 1252
Anglais (États-Unis) | 0x0409 | SQL_Latin1_General_CP1_CI_AS | 1252
Anglais (Zimbabwe) | 0x3009 | Latin1_General_CI_AS | 1252
Estonien (Estonie) | 0x0425 | Estonian_CI_AS | 1257
Féroïen (Îles Féroé) | 0x0438 | Latin1_General_CI_AS | 1252
Filipino (Philippines) | 0x0464 | Latin1_General_100_CI_AS | 1252
Finnois (Finlande) | 0x040b | Finnish_Swedish_CI_AS | 1252
Français (Belgique) | 0x080c | French_CI_AS | 1252
Français (Canada) | 0x0c0c | French_CI_AS | 1252
Français (France) | 0x040c | French_CI_AS | 1252
Français (Luxembourg) | 0x140c | French_CI_AS | 1252
Français (Monaco) | 0x180c | French_CI_AS | 1252
Français (Suisse) | 0x100c | French_CI_AS | 1252
Frison (Pays-Bas) | 0x0462 | Frisian_100_CI_AS | 1252
Galicien (Espagne) | 0x0456 | Latin1_General_CI_AS | 1252
Géorgien (Géorgie) | 0x0437 | Cyrillic_General_100_CI_AS | 1251
Géorgien (Géorgie) | 0x10437 | Georgian_Modern_Sort_CI_AS |
Allemand - Annuaire téléphonique (DIN) | 0x10407 | German_PhoneBook_CI_AS | 1252
Allemand (Autriche) | 0x0c07 | Latin1_General_CI_AS | 1252
Allemand (Allemagne) | 0x0407 | Latin1_General_CI_AS | 1252
Allemand (Liechtenstein) | 0x1407 | Latin1_General_CI_AS | 1252
Allemand (Luxembourg) | 0x1007 | Latin1_General_CI_AS | 1252
Allemand (Suisse) | 0x0807 | Latin1_General_CI_AS | 1252
Grec (Grèce) | 0x0408 | Greek_CI_AS | 1253
Groenlandais (Groenland) | 0x046f | Danish_Greenlandic_100_CI_AS | 1252
Goudjrati (Inde) | 0x0447 | Non disponible au niveau du serveur | Unicode
Haoussa (Nigeria, latin) | 0x0468 | Latin1_General_100_CI_AS | 1252
Hébreu (Israël) | 0x040d | Hebrew_CI_AS | 1255
Hindi (Inde) | 0x0439 | Non disponible au niveau du serveur | Unicode
Hongrois (Hongrie) | 0x040e | Hungarian_CI_AS | 1250
Hongrois - Technique | 0x1040e | Hungarian_Technical_CI_AS | 1250
Islandais (Islande) | 0x040f | Icelandic_CI_AS | 1252
Igbo (Nigeria) | 0x0470 | Latin1_General_100_CI_AS | 1252
Indonésien (Indonésie) | 0x0421 | Latin1_General_CI_AS | 1252
Inuktitut (Canada, latin) | 0x085d | Latin1_General_100_CI_AS | 1252
Inuktitut (syllabique, Canada) | 0x045d | Latin1_General_100_CI_AS | 1252
Irlandais (Irlande) | 0x083c | Latin1_General_100_CI_AS | 1252
Italien (Italie) | 0x0410 | Latin1_General_CI_AS | 1252
Italien (Suisse) | 0x0810 | Latin1_General_CI_AS | 1252
Japonais (Japon XJIS) | 0x0411 | Japanese_CI_AS | 932
Japonais (Japon) | 0x040411 | Japanese_Bushu_Kakusu_100_CI_AS | 932
Kannada (Inde) | 0x044b | Non disponible au niveau du serveur | Unicode
Kazakh (Kazakhstan) | 0x043f | Kazakh_90_CI_AS | 1251
Khmer (Cambodge) | 0x0453 | Non disponible au niveau du serveur | Unicode
Quiché (Guatemala) | 0x0486 | Modern_Spanish_100_CI_AS | 1252
Kinyarwanda (Rwanda) | 0x0487 | Latin1_General_100_CI_AS | 1252
Konkani (Inde) | 0x0457 | Non disponible au niveau du serveur | Unicode
Coréen (Corée - Dictionnaire) | 0x0412 | Korean_Wansung_CI_AS | 949
Kirghiz (Kirghizistan) | 0x0440 | Cyrillic_General_CI_AS | 1251
Lao (RDP Lao) | 0x0454 | Non disponible au niveau du serveur | Unicode
Letton (Lettonie) | 0x0426 | Latvian_CI_AS | 1257
Lituanien (Lituanie) | 0x0427 | Lithuanian_CI_AS | 1257
Bas-sorabe (Allemagne) | 0x082e | Latin1_General_100_CI_AS | 1252
Luxembourgeois (Luxembourg) | 0x046e | Latin1_General_100_CI_AS | 1252
Macédonien (Ex-Rép. yougoslave de Macédoine) | 0x042f | Macedonian_FYROM_90_CI_AS | 1251
Malais (Brunei Darussalam) | 0x083e | Latin1_General_CI_AS | 1252
Malais (Malaisie) | 0x043e | Latin1_General_CI_AS | 1252
Malayalam (Inde) | 0x044c | Non disponible au niveau du serveur | Unicode
Maltais (Malte) | 0x043a | Maltese_100_CI_AS | 1252
Maori (Nouvelle-Zélande) | 0x0481 | Maori_100_CI_AS | 1252
Mapudungun (Chili) | 0x047a | Mapudungan_100_CI_AS | 1252
Marathe(Inde) | 0x044e | Non disponible au niveau du serveur | Unicode
Mohawk (Canada) | 0x047c | Mohawk_100_CI_AS | 1252
Mongol (Mongolie) | 0x0450 | Cyrillic_General_CI_AS | 1251
Mongol (République populaire de Chine) | 0x0850 | Cyrillic_General_100_CI_AS | 1251
Népalais (Népal) | 0x0461 | Non disponible au niveau du serveur | Unicode
Norvégien (Bokmål, Norvège) | 0x0414 | Norwegian_100_CI_AS | 1252
Norvégien (Nynorsk, Norvège) | 0x0814 | Norwegian_100_CI_AS | 1252
Occitan (France) | 0x0482 | French_100_CI_AS | 1252
Oriya (Inde) | 0x0448 | Non disponible au niveau du serveur | Unicode
Pachtou (Afghanistan) | 0x0463 | Non disponible au niveau du serveur | Unicode
Persan (Iran) | 0x0429 | Persian_100_CI_AS | 1256
Polonais (Pologne) | 0x0415 | Polish_CI_AS | 1250
Portugais (Brésil) | 0x0416 | Latin1_General_CI_AS | 1252
Portugais (Portugal) | 0x0816 | Latin1_General_CI_AS | 1252
Pendjabi (Inde) | 0x0446 | Non disponible au niveau du serveur | Unicode
Quechua (Bolivie) | 0x046b | Latin1_General_100_CI_AS | 1252
Quechua (Équateur) | 0x086b | Latin1_General_100_CI_AS | 1252
Quechua (Pérou) | 0x0c6b | Latin1_General_100_CI_AS | 1252
Roumain (Roumanie) | 0x0418 | Romanian_CI_AS | 1250
Romanche (Suisse) | 0x0417 | Romansh_100_CI_AS | 1252
Russe (Russie) | 0x0419 | Cyrillic_General_CI_AS | 1251
Same d'Inari (Finlande) | 0x243b | Sami_Sweden_Finland_100_CI_AS | 1252
Same de Lule (Norvège) | 0x103b | Sami_Norway_100_CI_AS | 1252
Same de Lule (Suède) | 0x143b | Sami_Sweden_Finland_100_CI_AS | 1252
Same du nord (Finlande) | 0x0c3b | Sami_Sweden_Finland_100_CI_AS | 1252
Same du nord (Norvège) | 0x043b | Sami_Norway_100_CI_AS | 1252
Same du nord (Suède) | 0x083b | Sami_Sweden_Finland_100_CI_AS | 1252
Same de Skolt (Finlande) | 0x203b | Sami_Sweden_Finland_100_CI_AS | 1252
Same du sud (Norvège) | 0x183b | Sami_Norway_100_CI_AS | 1252
Same du sud (Suède) | 0x1c3b | Sami_Sweden_Finland_100_CI_AS | 1252
Sanskrit (Inde) | 0x044f | Non disponible au niveau du serveur | Unicode
Serbe (Bosnie-Herzégovine, cyrillique) | 0x1c1a | Cyrillic_General_CI_AS | 1251
Serbe (Bosnie-Herzégovine, latin) | 0x181a | Latin1_General_CI_AS | 1250
Serbe (Serbie, cyrillique) | 0x0c1a | Cyrillic_General_CI_AS | 1251
Serbe (latin, Serbie) | 0x081a | Latin1_General_CI_AS | 1250
Sesotho sa Leboa/Sotho du Nord (Afrique du Sud) | 0x046c | Latin1_General_100_CI_AS | 1252
Setswana/Tswana (Afrique du Sud) | 0x0432 | Latin1_General_100_CI_AS | 1252
Cinghalais (Sri Lanka) | 0x045b | Non disponible au niveau du serveur | Unicode
Slovaque (Slovaquie) | 0x041b | Slovak_CI_AS | 1250
Slovène (Slovénie) | 0x0424 | Slovenian_CI_AS | 1250
Espagnol (Argentine) | 0x2c0a | Modern_Spanish_CI_AS | 1252
Espagnol (Bolivie) | 0x400a | Modern_Spanish_CI_AS | 1252
Espagnol (Chili) | 0x340a | Modern_Spanish_CI_AS | 1252
Espagnol (Colombie) | 0x240a | Modern_Spanish_CI_AS | 1252
Espagnol (Costa Rica) | 0x140a | Modern_Spanish_CI_AS | 1252
Espagnol (République Dominicaine) | 0x1c0a | Modern_Spanish_CI_AS | 1252
Espagnol (Équateur) | 0x300a | Modern_Spanish_CI_AS | 1252
Espagnol (Salvador) | 0x440a | Modern_Spanish_CI_AS | 1252
Espagnol (Guatemala) | 0x100a | Modern_Spanish_CI_AS | 1252
Espagnol (Honduras) | 0x480a | Modern_Spanish_CI_AS | 1252
Espagnol (Mexique) | 0x080a | Modern_Spanish_CI_AS | 1252
Espagnol (Nicaragua) | 0x4c0a | Modern_Spanish_CI_AS | 1252
Espagnol (Panama) | 0x180a | Modern_Spanish_CI_AS | 1252
Espagnol (Paraguay) | 0x3c0a | Modern_Spanish_CI_AS | 1252
Espagnol (Pérou) | 0x280a | Modern_Spanish_CI_AS | 1252
Espagnol (Porto Rico) | 0x500a | Modern_Spanish_CI_AS | 1252
Espagnol (Espagne) | 0x0c0a | Modern_Spanish_CI_AS | 1252
Espagnol (Espagne, traditionnel) | 0x040a | Traditional_Spanish_CI_AS | 1252
Espagnol (États-Unis) | 0x540a | Latin1_General_100_CI_AS | 1252
Espagnol (Uruguay) | 0x380a | Modern_Spanish_CI_AS | 1252
Espagnol (Venezuela) | 0x200a | Modern_Spanish_CI_AS | 1252
Swahili (Kenya) | 0x0441 | Latin1_General_100_CI_AS | 1252
Suédois (Finlande) | 0x081d | Finnish_Swedish_CI_AS | 1252
Suédois (Suède) | 0x041d | Finnish_Swedish_CI_AS | 1252
Syriaque (Syrie) | 0x045a | Non disponible au niveau du serveur | Unicode
Tadjik (Tadjikistan) | 0x0428 | Cyrillic_General_100_CI_AS | 1251
Tamazight (Algérie, latin) | 0x085f | Tamazight_100_CI_AS | 1252
Tamoul (Inde) | 0x0449 | Non disponible au niveau du serveur | Unicode
Tatar (Russie) | 0x0444 | Cyrillic_General_CI_AS | 1251
Télougou (Inde) | 0x044a | Non disponible au niveau du serveur | Unicode
Thaï (Thaïlande) | 0x041e | Thai_CI_AS | 874
Tibétain (RPC) | 0x0451 | Non disponible au niveau du serveur | Unicode
Turc (Turquie) | 0x041f | Turkish_CI_AS | 1254
Turkmène (Turkménistan) | 0x0442 | Turkmen_100_CI_AS | 1250
Ouïgour (RPC) | 0x0480 | Uighur_100_CI_AS | 1256
Ukrainien (Ukraine) | 0x0422 | Ukrainian_100_CI_AS | 1251
Haut-sorabe (Allemagne) | 0x042e | Upper_Sorbian_100_CI_AS | 1252
Ourdou (Pakistan) | 0x0420 | Urdu_100_CI_AS | 1256
Ouszbek (Ouzbékistan, cyrillique) | 0x0843 | Cyrillic_General_CI_AS | 1251
Ouszbek (Ouzbékistan, latin) | 0x0443 | Uzbek_Latin_90_CI_AS | 1254
Vietnamien (Vietnam) | 0x042a | Vietnamese_CI_AS | 1258
Gallois (Royaume-Uni) | 0x0452 | Welsh_100_CI_AS | 1252
Wolof (Sénégal) | 0x0488 | French_100_CI_AS | 1252
Xhosa (Afrique du Sud) | 0x0434 | Latin1_General_100_CI_AS | 1252
Iakoute (Russie) | 0x0485 | Yakut_100_CI_AS | 1251
Yi (RPC) | 0x0478 | Latin1_General_100_CI_AS | 1252
Yorouba (Nigeria) | 0x046a | Latin1_General_100_CI_AS | 1252
Zoulou (Afrique du Sud) | 0x0435 | Latin1_General_100_CI_AS | 1252

Voir aussi

Référence

Prise en charge d'Unicode et du classement
Styles de tri des classements Windows

Concepts

Utilisation des classements SQL Server


Styles de tri des classements Windows

Styles de tri des classements Windows |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement >

Au cours de l'installation de SQL Server, vous êtes invité à sélectionner des classements Windows ou des classements binaires. Votre choix de classements affecte les comportements de comparaison et d'ordre de tri des données de votre instance Microsoft SQL Server. Cette rubrique contient des observations qui vous aideront à choisir des classements Microsoft Windows ou des classements binaires pour votre implémentation de SQL Server.

Remarque :
Pour les classements Windows, les types de données Unicode nchar, nvarchar et ntext ont le même comportement de tri que les types de données non-Unicode char, varchar ettext.

Les classements Windows définissent les règles de stockage des données de type caractère en fonction de paramètres régionaux associés. Les règles de base du classement Windows spécifient l'alphabet ou la langue utilisée lorsque le tri du dictionnaire est appliqué, ainsi que la page de codes utilisée pour stocker les données de type caractère non-Unicode. Les classements binaires trient les données selon la séquence de valeurs codées définie par les paramètres régionaux et le type de données. Un classement binaire dans SQL Server définit les paramètres régionaux et la page de codes ANSI à utiliser, en appliquant un ordre de tri binaire. Grâce à leur relative simplicité, les classements binaires aident à renforcer les performances applicatives. Pour les données de type non-Unicode, les comparaisons de données se basent sur les points de code définis dans la page de codes ANSI. Pour les données de type Unicode, les comparaisons de données se basent sur les points de code Unicode. Pour le classement binaire des types de données Unicode, les paramètres régionaux (la langue) ne sont pas pris en compte dans les tris de données. Par exemple, Latin_1_General_BIN et Japanese_BIN produisent des résultats de tri identiques s'ils sont utilisés avec des données Unicode.

Les classements binaires précédents de SQL Server effectuaient une comparaison de point de code à point de code incomplète pour les données Unicode, car ils comparaient le premier caractère comme WCHAR, suivi d'une comparaison octet par octet. Pour des raisons de compatibilité descendante, la sémantique des classements binaires existante ne sera pas modifiée.

Les classements binaires de cette version de SQL Server incluent également un ensemble de classements de comparaison de points de code purs. Les clients peuvent choisir de migrer vers les classements binaires pour bénéficier des comparaisons de points de code et il est conseillé d'utiliser ces classements pour développer des applications. Le suffixe BIN2 identifie le nom des classements qui implémentent la sémantique des classements par points de code. Il y a également un indicateur de comparaison qui correspond à BIN2 pour le nouveau tri binaire. Pour plus d'informations, consultez Principes d'utilisation des classements BIN et BIN2.

Le tableau suivant décrit les options d'ordre de tri des classements Windows pour SQL Server.

Ordre de tri (suffixe) Description de l'ordre de tri

Binaire (_BIN)1

Trie et compare les données dans les tables SQL Server en fonction des modèles de bits définis pour chaque caractère. L'ordre de tri binaire respecte casse et accents. Il s'agit de l'ordre de tri le plus rapide. Pour plus d'informations, consultez Principes d'utilisation des classements BIN et BIN2.

Si cette option n'est pas sélectionnée, SQL Server suit les règles de tri et de comparaison définies dans les dictionnaires pour la langue ou l'alphabet associé.

Point de code binaire (_BIN2)1

Trie et compare les données des tables SQL Server en fonction des points de code Unicode pour les données Unicode. Pour les données non-Unicode, le point de code binaire utilise les mêmes comparaisons que les tris binaires.

L'utilisation d'un ordre de tri de point de code binaire présente l'avantage de ne pas avoir à retrier les données dans les applications qui comparent les données triées de SQL Server. Par conséquent, un ordre de tri de point de code binaire simplifie le développement des applications et permet d'améliorer les performances. Pour plus d'informations, consultez Principes d'utilisation des classements BIN et BIN2.

Respecter la casse (_CS)

Différencie les majuscules et les minuscules. Si cette option est sélectionnée, les lettres minuscules précèdent leurs versions majuscules.

Si cette option n'est pas sélectionnée, SQL Server ne différencie pas les lettres minuscules et majuscules lors du tri.

Respecter les accents (_AS)

Différencie les caractères accentuées et les caractères sans accent. Par exemple, 'a' n'est pas équivalent à '?'.

Si cette option n'est pas sélectionnée, SQL Server ne différencie pas les lettres minuscules et majuscules lors du tri.

Respecter le jeu de caractères Kana (_KS)

Différencie les deux types de caractères Kana japonais : Hiragana et Katakana.

Si cette option n'est pas sélectionnée, SQL Server ne différencie pas les caractères Hiragana et Katakana lors du tri.

Respecter la largeur (_WS)

Différencie un caractère codé sur un octet et le même caractère représenté sur deux octets.

Si cette option n'est pas sélectionnée, SQL Server ne fait pas de différence de représentation entre les caractères sur un octet et ceux sur deux octets lors du tri.

1 Si Binaire est activé, les options Respecter la casse, Respecter les accents, Respecter le jeu de caractères Kana et Respecter la largeur ne sont pas disponibles.

Exemples de classements Windows

Chaque classement Windows se présente comme une série de suffixes permettant de définir le respect de la casse, des accents, de la largeur ou des caractères Kana. Les exemples suivants décrivent le comportement de l'ordre de tri selon diverses combinaisons de suffixes.

Suffixe de classement Windows | Description de l'ordre de tri
_BIN1 | Tri binaire
_BIN21 | Ordre de tri de point de code binaire.
_CI_AI | Non-respect de la casse, non-respect des accents, non-respect des caractères Kana, non-respect de la largeur
_CI_AI_KS | Non-respect de la casse, non-respect des accents, respect des caractères Kana, non-respect de la largeur
_CI_AI_KS_WS | Non-respect de la casse, non-respect des accents, respect des caractères Kana, respect de la largeur
_CI_AI_WS | Non-respect de la casse, non-respect des accents, non-respect des caractères Kana, respect de la largeur
_CI_AS | Non-respect de la casse, respect des accents, non-respect des caractères Kana, non-respect de la largeur
_CI_AS_KS | Non-respect de la casse, respect des accents, respect des caractères Kana, non-respect de la largeur
_CI_AS_KS_WS | Non-respect de la casse, respect des accents, respect des caractères Kana, respect de la largeur
_CI_AS_WS | Non-respect de la casse, respect des accents, non-respect des caractères Kana, respect de la largeur
_CS_AI | Respect de la casse, non-respect des accents, non-respect des caractères Kana, non-respect de la largeur
_CS_AI_KS | Respect de la casse, non-respect des accents, respect des caractères Kana, non-respect de la largeur
_CS_AI_KS_WS | Respect de la casse, non-respect des accents, respect des caractères Kana, respect de la largeur
_CS_AI_WS | Respect de la casse, non-respect des accents, non-respect des caractères Kana, respect de la largeur
_CS_AS | Respect de la casse, respect des accents, non-respect des caractères Kana, non-respect de la largeur
_CS_AS_KS | Respect de la casse, respect des accents, respect des caractères Kana, non-respect de la largeur
_CS_AS_KS_WS | Respect de la casse, respect des accents, respect des caractères Kana, respect de la largeur
_CS_AS_WS | Respect de la casse, respect des accents, non-respect des caractères Kana, respect de la largeur

1 Si BIN2 ou le point de code binaire est activé, les options Respecter la casse, Respecter les accents, Respecter les caractères Kana et Respecter la largeur ne sont pas disponibles.

Voir aussi

Référence

Paramètres de classement du programme d'installation

Concepts

Principes d'utilisation des classements BIN et BIN2


Principes d'utilisation des classements BIN et BIN2

Principes d'utilisation des classements BIN et BIN2 |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement >

Les observations suivantes vous aideront à décider si les anciens classements binaires BIN ou BIN2 sont adaptés à votre implémentation de SQL Server.

Les classements binaires trient les données selon la séquence de valeurs codées définie par les paramètres régionaux et le type de données. Un classement binaire dans SQL Server définit les paramètres régionaux et la page de codes ANSI à utiliser, en appliquant un ordre de tri binaire. Grâce à leur relative simplicité, les classements binaires aident à renforcer les performances applicatives. Pour les données de type non-Unicode, les comparaisons de données se basent sur les points de code définis dans la page de codes ANSI. Pour les données de type Unicode, les comparaisons de données se basent sur les points de code Unicode. Pour le classement binaire des types de données Unicode, les paramètres régionaux (la langue) ne sont pas pris en compte dans les tris de données. Par exemple, Latin_1_General_BIN et Japanese_BIN produisent des résultats de tri identiques s'ils sont utilisés avec des données Unicode.

Les précédents classements binaires de SQL Server, ceux se terminant par « _BIN », effectuaient une comparaison incomplète de point de code à point de code pour les données Unicode. En effet, ils comparaient le premier caractère comme WCHAR, suivi d'une comparaison octet par octet. Pour des raisons de compatibilité descendante, la sémantique des classements binaires existante ne sera pas modifiée.

Principes d'utilisation des classements BIN

Si vos applications SQL Server interagissent avec des versions antérieures de SQL Server utilisant les classements binaires, continuez à utiliser le classement binaire. Les classements binaires peuvent être plus adaptés à des environnements mixtes.

Conseils d'utilisation des classements BIN2

Les classements binaires de cette version de SQL Server incluent un ensemble de classements de comparaison de points de code purs. Vous pouvez migrer vers les classements binaires pour bénéficier des comparaisons de points de code et il est conseillé d'utiliser les nouveaux classements binaires pour développer de nouvelles applications. Le suffixe BIN2 identifie le nom des classements qui implémentent la sémantique des nouveaux classements par points de code. Il y a également un indicateur de comparaison qui correspond à BIN2 pour le tri binaire. Les avantages incluent la simplification du développement d'applications et de la sémantique.

Voir aussi

Référence

Prise en charge d'Unicode et du classement
Paramètres de classement du programme d'installation


Utilisation des classements SQL Server

Utilisation des classements SQL Server |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement >

Les paramètres de classement SQL Server 2008 dépendent du type d'installation. En règle générale, vous devez choisir un classement SQL Server qui prend en charge les paramètres régionaux système de Windows les plus communément utilisés dans votre organisation. Pour connaître les paramètres régionaux système de Windows sur les ordinateurs qui exécutent Windows 2000, cliquez sur Paramètres régionaux dans le Panneau de configuration, puis cliquez sur Avancé. Dans Windows Vista, utilisez l'onglet Formats. Pour connaître les paramètres régionaux système de Windows sur les ordinateurs qui exécutent Windows Server 2003, cliquez sur Options régionales et linguistiques dans le Panneau de configuration, puis sur l'onglet Options régionales. Dans la plupart des cas, un ordinateur exécute les paramètres régionaux système de Windows qui correspondent aux exigences liées à la langue de l'utilisateur. Le programme d'installation de SQL Server détecte donc automatiquement les paramètres régionaux système de Windows et sélectionne le classement SQL Server approprié. Pour la compatibilité descendante, le classement de langue anglaise (US) par défaut est SQL_Latin1_General *.

Les classements SQL Server 2008 contrôlent les éléments suivants :

  • Page de codes utilisée pour stocker des données non Unicode dans SQL Server.

  • Les règles qui régissent la façon dont SQL Server trie et compare les caractères stockés dans les types de données non Unicode. Le programme d'installation de SQL Server détecte le classement Windows sur l'ordinateur où SQL Server est installé. Ensuite, il sélectionne automatiquement le classement pour votre instance de SQL Server. Les tris et les comparaisons peuvent être différents pour les caractères Unicode et non Unicode.

Utilisez le tableau ci-dessous pour déterminer quel classement choisir, s'il y a lieu.

Remarque :
Si vous effectuez une mise à niveau d'une version antérieure d'un paramètre de classement SQL Server, aucun choix de classement n'est requis.

Tâche Classement

Installer sur un nouveau système sans besoin de synchronisation avec aucun système existant.

Utilisez le classement qui est identifié par le programme d'installation, puis choisissez l'option binaire, de casse ou autre.

Lorsque le programme d'installation de SQL Server détecte que l'ordinateur exécute les paramètres régionaux système anglais (États-Unis), il sélectionne alors automatiquement le Classement du dictionnaire, non-respect de la casse, à utiliser avec le jeu de caractères 1252 SQL Server 2008.

Pour sélectionner le classement Windows équivalent, sélectionnez Indicateur de classement, sélectionnez Latin1_General, puis désactivez Respecter la casse et sélectionnez Respecter les accents.

Mettre à niveau une installation de SQL Server 6.5 ou SQL Server 7.0 vers une instance par défaut de SQL Server, ou installer une instance par défaut de SQL Server 2008 qui permutera la version avec une installation de SQL Server 6.5.

Utilisez le classement SQL Server 2008 que le programme d'installation sélectionne.

Synchronisez avec une instance existante de SQL Server.

Sélectionnez SERVERPROPERTY(N'Collation') dans l'éditeur de code sur l'instance existante et spécifiez Classement. Pour plus d'informations, consultez SERVERPROPERTY (Transact-SQL). Si le nom du classement de l'instance existante commence par « SQL », sélectionnez le même classement SQL Server dans le programme d'installation. Si le nom du classement de l'instance existante ne commence pas par « SQL », il fait référence à un nom de classement Windows. Il se compose du nom d'indicateur de classement suivi d'une description des options qui sont spécifiées (binaire, respecter la casse, les accents, le jeu de caractère kana et la largeur). Sélectionnez le même indicateur de classement Windows et les mêmes options de tri dans le programme d'installation de SQL Server.

Pour plus d'informations, consultez Styles de tri des classements Windows.

Synchroniser avec une installation existante de SQL Server 6.5, SQL Server 7.0 ou SQL Server 2000.

Exécutez sp_helpsort sur le système existant. Ensuite, exécutez l'identificateur de tri pour sélectionner un classement SQL Server et rendre votre instance de SQL Server compatible avec une installation existante.

Pour plus d'informations, consultez Choix d'un classement SQL Server.

Synchroniser avec les paramètres régionaux système de Windows d'un autre ordinateur.

Dans le Panneau de configuration, recherchez le nom des paramètres régionaux sous Options régionales (Windows 2000 ou Windows Server 2003) ou Options régionales et linguistiques (Windows XP), puis utilisez le tableau qui est fourni dans la Paramètres de classement du programme d'installation. Définissez les options de tri, comme décrit dans la rubrique Styles de tri des classements Windows.
Remarque :
Lorsque vous effectuez une action qui dépend des classements, le classement SQL Server qui est utilisé par l'objet référencé doit utiliser une page de codes prise en charge par le système d'exploitation.

Voir aussi

Référence

Choix d'un classement SQL Server

Autres ressources

Setting Client Code Pages
Nom du classement SQL Server (Transact-SQL)


Choix d'un classement SQL Server

Choix d'un classement SQL Server |
 | Voir aussi
Planification d'une installation SQL Server > Prise en charge d'Unicode et du classement > Utilisation des classements SQL Server >

Cette rubrique décrit les options de classement de SQL Server 2008 pour les instances de SQL Server qui doivent être compatibles avec les versions de SQL Server qui n'utilisent pas les classements.

Les classements SQL suivants sont répertoriés dans la page Paramètres de classement de l'Assistant Installation de SQL Server.

ID de l'ordre de tri SQL | Nom de l'ordre de tri | Description | classement SQL
31 | diction.437 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp437_CS_AS_KI_WI
32 | nocase.437 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp437_CI_AS_KI_WI
33 | nocasepr.437 | Ordre du dictionnaire, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_Latin1_General_Pref_Cp437_CI_AS_KI_WI
34 | noaccent.437 | Ordre du dictionnaire, sans différence entre majuscules et minuscules, sans distinction des accents | SQL_Latin1_General_Cp437_CI_AI_KI_WI
40 | cp437bin.437 | Binaire | SQL_Latin1_General_Cp437_BIN
40 | cp850bin.850 | Binaire | SQL_Latin1_General_Cp850_BIN
41 | diction.850 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp850_CS_AS_KI_WI
42 | nocase.850 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp850_CI_AS_KI_WI
44 | noaccent.850 | Ordre du dictionnaire, sans différence entre majuscules et minuscules, sans distinction des accents | SQL_Latin1_General_Cp850_CI_AI_KI_WI
44 | nocase34.850 | Ordre du dictionnaire, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_Latin1_General_Pref_Cp850_CI_AS_KI_WI
49 | nocase34.850 | Stricte compatibilité avec les bases de données 1.x ne respectant pas la casse | SQL_1xCompat_Cp850_CI_AS_KI_WI
51 | diction.iso | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1_CS_AS_KI_WI
52 | nocase.iso | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1_CI_AS_KI_WI
53 | nocasepr.iso | Ordre du dictionnaire, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_Latin1_General_Pref_Cp1_CI_AS_KI_WI
54 | noaccent.iso | Ordre du dictionnaire, sans différence entre majuscules et minuscules, sans distinction des accents | SQL_Latin1_General_Cp1_CI_AI_KI_WI
55 | altdict.850 | Ordre du dictionnaire de remplacement, respect de la casse | SQL_AltDiction_Cp850_CS_AS_KI_WI
56 | altnocsp.850 | Ordre du dictionnaire de remplacement, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_AltDiction_Pref_Cp850_CI_AS_KI_WI
57 | altnoacc.850 | Ordre du dictionnaire de remplacement, sans différence entre majuscules et minuscules, sans distinction des accents | SQL_AltDiction_Cp850_CI_AI_KI_WI
58 | scan.850 | Classement du dictionnaire scandinave, non-respect de la casse, préférence pour les majuscules | SQL_Scandainavian_Pref_Cp850_CI_AS_KI_WI
59 | scandict.850 | Classement du dictionnaire scandinave, respect de la casse | SQL_Scandainavian_Cp850_CS_AS_KI_WI
60 | scannocase.850 | Classement du dictionnaire scandinave, non-respect de la casse, sans préférence pour les majuscules | SQL_Scandainavian_Cp850_CI_AS_KI_WI
61 | altnocs.850 | Ordre du dictionnaire de remplacement, non respect de la casse | SQL_AltDiction_Cp850_CI_AS_KI_WI
80 | binary.250 | Binaire | SQL_Latin1_General_1250_BIN
81 | diction.250 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1250_CS_AS_KI_WI
82 | nocase.250 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1250_CI_AS_KI_WI
83 | csydic.250 | Ordre du dictionnaire tchèque, respect de la casse | SQL_Czech_Cp1250_CS_AS_KI_WI
84 | csync.250 | Ordre du dictionnaire tchèque, non respect de la casse | SQL_Czech_Cp1250_CI_AS_KI_WI
85 | hundic.250 | Ordre du dictionnaire hongrois, respect de la casse | SQL_Hungarian_Cp1250_CS_AS_KI_WI
86 | hunnc.250 | Ordre du dictionnaire hongrois, non respect de la casse | SQL_Hungarian_Cp1250_CI_AS_KI_WI
87 | plkdic.250 | Ordre du dictionnaire polonais, respect de la casse | SQL_Polish_Cp1250_CS_AS_KI_WI
88 | plknc.250 | Ordre du dictionnaire polonais, non respect de la casse | SQL_Polish_Cp1250_CI_AS_KI_WI
89 | romdic.250 | Ordre du dictionnaire roumain, respect de la casse | SQL_Romanian_Cp1250_CS_AS_KI_WI
90 | romnc.250 | Ordre du dictionnaire roumain, non respect de la casse | SQL_Romanian_Cp1250_CI_AS_KI_WI
91 | shldic.250 | Ordre du dictionnaire croate, respect de la casse | SQL_Croatian_Cp1250_CS_AS_KI_WI
92 | shlnc.250 | Ordre du dictionnaire croate, non respect de la casse | SQL_Croatian_Cp1250_CI_AS_KI_WI
93 | skydic.250 | Ordre du dictionnaire slovaque, respect de la casse | SQL_Slovak_Cp1250_CS_AS_KI_WI
94 | skync.250 | Ordre du dictionnaire slovaque, non respect de la casse | SQL_Slovak_Cp1250_CI_AS_KI_WI
95 | slvdic.250 | Ordre du dictionnaire slovénien, respect de la casse | SQL_Slovenian_Cp1250_CS_AS_KI_WI
96 | slvnc.250 | Ordre du dictionnaire slovénien, non respect de la casse | SQL_Slovenian_Cp1250_CI_AS_KI_WI
104 | binary.250 | Binaire | SQL_Latin1_General_1251_BIN
105 | diction.251 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1251_CS_AS_KI_WI
106 | nocase.251 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1251_CI_AS_KI_WI
107 | ukrdic.251 | Ordre du dictionnaire ukrainien, respect de la casse | SQL_Ukrainian_Cp1251_CS_AS_KI_WI
108 | ukrnc.251 | Ordre du dictionnaire ukrainien, non respect de la casse | SQL_Ukrainian_Cp1251_CI_AS_KI_WI
112 | binary.253 | Binaire | SQL_Latin1_General_1253_BIN
113 | diction.253 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1253_CS_AS_KI_WI
114 | nocase.253 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
121 | graltdct.253 | Ordre du dictionnaire, avec différence entre majuscules et minuscules, avec distinction des accents | SQL_Latin1_General_Cp1253_CI_AS_KI_WI
124 | grnoacce.253 | Ordre du dictionnaire, sans différence entre majuscules et minuscules, sans distinction des accents | SQL_Latin1_General_Cp1253_CI_AI_KI_WI
128 | binary.254 | Binaire | SQL_Latin1_General_1254_BIN
129 | diction.254 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1254_CS_AS_KI_WI
130 | nocase.254 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1254_CI_AS_KI_WI
136 | binary.255 | Binaire | SQL_Latin1_General_1255_BIN
137 | diction.255 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1255_CS_AS_KI_WI
138 | nocase.255 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1255_CI_AS_KI_WI
144 | binary.256 | Binaire | SQL_Latin1_General_1256_BIN
145 | diction.256 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1256_CS_AS_KI_WI
146 | nocase.256 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1256_CI_AS_KI_WI
152 | binary.257 | Binaire | SQL_Latin1_General_1257_BIN
153 | diction.257 | Ordre du dictionnaire, respect de la casse | SQL_Latin1_General_Cp1257_CS_AS_KI_WI
154 | nocase.257 | Ordre du dictionnaire, sans différence entre majuscules et minuscules | SQL_Latin1_General_Cp1257_CI_AS_KI_WI
155 | etidic.257 | Ordre du dictionnaire estonien, respect de la casse | SQL_Estonian_Cp1257_CS_AS_KI_WI
156 | etinc.257 | Ordre du dictionnaire estonien, non respect de la casse | SQL_Estonian_Cp1257_CI_AS_KI_WI
157 | lvidic.257 | Ordre du dictionnaire letton, respect de la casse | SQL_Latvian_Cp1257_CS_AS_KI_WI
158 | lvinc.257 | Ordre du dictionnaire letton, non respect de la casse | SQL_Latvian_Cp1257_CI_AS_KI_WI
159 | lthdic.257 | Ordre du dictionnaire lithuanien, respect de la casse | SQL_Lithuanian_Cp1257_CS_AS_KI_WI
160 | lthnc.257 | Ordre du dictionnaire lithuanien, non respect de la casse | SQL_Lithuanian_Cp1257_CI_AS_KI_WI
183 | danonocp.iso | Ordre du dictionnaire danois/norvégien, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_Danish_Pref_Cp1_CI_AS_KI_WI
184 | islanocp.iso | Classement du dictionnaire suédois/finnois (phonétique), non-respect de la casse, avec préférence aux majuscules | SQL_SwedishPhone_Pref_Cp1_CI_AS_KI_WI
185 | svf2nocp.iso.iso | Classement du dictionnaire suédois/finnois (Std), non-respect de la casse, avec préférence aux majuscules | SQL_SwedishStd_Pref_Cp1_CI_AS_KI_WI
186 | islanocp.iso | Ordre du dictionnaire islandais, sans différence entre majuscules et minuscules, avec préférence aux majuscules | SQL_Icelandic_Pref_Cp1_CI_AS_KI_WI
Remarque :
Chaque nom de classement SQL possède une chaîne équivalente en code Transact-Transact-SQL. Pour plus d'informations, consultez Nom du classement SQL Server (Transact-SQL).

Voir aussi

Référence

Paramètres de classement du programme d'installation

Concepts

Utilisation des classements SQL Server


Spécifications de produit pour SQL Server 2008

Spécifications de produit pour SQL Server 2008
Planification d'une installation SQL Server >

La rubrique suivante décrit dans le détail les spécifications de produit de cette version.

Éditions et composants de SQL Server 2008

Sélection des composants et des fonctionnalités à installer

Spécifications des capacités maximales pour SQL Server

Capacités maximales d'objets de SQL Server

Nombre maximal de processeurs pris en charge par les éditions de SQL Server

Nombre maximal de processeurs pris en charge par chaque édition de SQL Server


Spécifications des capacités maximales pour SQL Server

Spécifications des capacités maximales pour SQL Server |
 | Voir aussi
Planification d'une installation SQL Server > Spécifications de produit pour SQL Server 2008 >

Les tableaux suivants présentent la taille maximale et le nombre maximal des différents objets définis dans les composants SQL Server.

Objets du moteur de base de données

Le tableau suivant présente la taille maximale et le nombre maximal des différents objets définis dans les bases de données SQL Server ou référencés dans les instructions Transact-SQL.

Objet du moteur de base de données SQL Server | Taille maximale/nombre maximal dans SQL Server (32 bits) | Taille maximale/nombre maximal dans SQL Server (64 bits)
Taille du traitement1 | 65 536 * Taille des paquets réseau | 65 536 * Taille des paquets réseau
Octets par colonne de chaîne courte | 8,000 | 8,000
Octets par clause GROUP BY, ORDER BY | 8,060 | 8,060
Octets par clé d'index2 | 900 | 900
Octets par clé étrangère | 900 | 900
Octets par clé primaire | 900 | 900
Octets par ligne8 | 8,060 | 8,060
Octets dans le texte source d'une procédure stockée | Taille de lot inférieure ou 250 Mo | Taille de lot inférieure ou 250 Mo
Octets par colonne varchar(max), varbinary(max), xml, text ou image | 2^31-1 | 2^31-1
Caractères par colonne ntext ou nvarchar(max) | 2^30-1 | 2^30-1
Index cluster par table | 1 | 1
Colonnes dans les clauses GROUP BY, ORDER BY | Limité uniquement par le nombre d'octets | Limité uniquement par le nombre d'octets
Colonnes ou expressions dans une instruction GROUP BY WITH CUBE ou WITH ROLLUP | 10 | 10
Colonnes par clé d'index7 | 16 | 16
Colonnes par clé étrangère | 16 | 16
Colonnes par clé primaire | 16 | 16
Colonnes par tableau non large | 1,024 | 1,024
Colonnes par tableau large | 30,000 | 30,000
Colonnes par instruction SELECT | 4,096 | 4,096
Colonnes par instruction INSERT | 4096 | 4096
Connexions par client | Valeur maximale des connexions configurées | Valeur maximale des connexions configurées
Taille de la base de données | 524 272 téraoctets | 524 272 téraoctets
Bases de données par instance SQL Server | 32,767 | 32,767
Groupes de fichiers par base de données | 32,767 | 32,767
Fichiers par base de données | 32,767 | 32,767
Taille de fichier (données) | 16 téraoctets | 16 téraoctets
Taille de fichier (journal) | 2 téraoctets | 2 téraoctets
Références de table de clé étrangère par table4 | 253 | 253
Longueur d'identificateur (en caractères) | 128 | 128
Instances par ordinateur | 50 instances sur un serveur autonome pour toutes les éditions de SQL Server, à l'exception de Workgroup. Workgroup prend en charge un maximum de 16 instances par ordinateur. SQL Server prend en charge 25 instances sur un cluster de basculement. | 50 instances sur un serveur autonome. 25 instances sur un cluster de basculement.
Longueur d'une chaîne contenant des instructions SQL (taille du traitement)1 | 65 536 * Taille des paquets réseau | 65 536 * Taille des paquets réseau
Verrous par connexion | Verrous maximaux par serveur | Verrous maximaux par serveur
Verrous par instance SQL Server5 | Jusqu'à 2 147 483 647 | Limité uniquement par la mémoire
Niveaux d'imbrication des procédures stockées6 | 32 | 32
Sous-requêtes imbriquées | 32 | 32
Niveaux de déclencheurs imbriqués | 32 | 32
Index non-cluster par table | 999 | 999
Nombre d'expressions distinctes dans la clause GROUP BY lorsque l'un des éléments suivants est présent : CUBE, ROLLUP, GROUPING SETS, WITH CUBE, WITH ROLLUP | 32 | 32
Nombre de jeux de regroupement générés par les opérateurs dans la clause GROUP BY | 4,096 | 4,096
Paramètres par procédure stockée | 2,100 | 2,100
Paramètres par fonction définie par l'utilisateur | 2,100 | 2,100
REFERENCES par table | 253 | 253
Lignes par table | Limité par le stockage disponible | Limité par le stockage disponible
Tables par base de données3 | Limité par le nombre d'objets dans une base de données | Limité par le nombre d'objets dans une base de données
Partitions par table ou index partitionné | 1,000 | 1,000
Statistiques sur les colonnes non indexées | 30,000 | 30,000
Tables par instruction SELECT | 256 | 256
Déclencheurs par table3 | Limité par le nombre d'objets dans une base de données | Limité par le nombre d'objets dans une base de données
Colonnes par instruction UPDATE (tableaux larges) | 4096 | 4096
Connexions utilisateur | 32,767 | 32,767
Index XML | 249 | 249

1 La taille des paquets réseau représente la taille des paquets TDS (Tabular Data Stream) utilisés pour la communication entre des applications et le moteur de base de données relationnel Moteur de base de données. La taille par défaut s'élève à 4 Ko ; elle est contrôlée par l'option de configuration Taille du paquet réseau.

2 Le nombre maximal d'octets dans une clé d'index s'élève à 900 dans SQL Server. Vous pouvez définir une clé en utilisant des colonnes de longueur variable dont la taille n'excède pas 900, à condition qu'aucune ligne de plus de 900 octets de données ne soit insérée dans ces colonnes. Dans SQL Server, vous pouvez inclure des colonnes non-clés dans un index non-cluster afin d'éviter la taille de clé d'index maximale de 900 octets.

3 Les objets de base de données comprennent des tables, des vues, des procédures stockées, des fonctions définies par l'utilisateur, des déclencheurs, des règles, des valeurs par défaut et des contraintes. Au total, le nombre de tous les objets d'une base de données ne peut pas dépasser 2 147 483 647.

4Bien qu'une table puisse contenir un nombre illimité de contraintes FOREIGN KEY, le maximum recommandé est 253. Selon la configuration matérielle qui héberge SQL Server, la spécification de contraintes FOREIGN KEY supplémentaires peut représenter un coût de traitement élevé pour l'optimiseur de requête.

5 Cette valeur s'applique à l'allocation de verrouillage statique. Les verrous dynamiques sont uniquement limités par la mémoire.

6 Si une procédure stockée accède à plus de 8 bases de données ou à plus de 2 bases entrelacées, vous recevez un message d'erreur.

7 Si la table contient au moins un index XML, la clé de cluster de la table d'utilisateur est limitée à 15 colonnes, car la colonne XML est ajoutée à la clé de cluster du principal index XML. Dans SQL Server, vous pouvez inclure des colonnes non-clés dans un index non-cluster afin d'éviter la limitation à un maximum de 16 colonnes clés. Pour plus d'informations, consultez Index avec colonnes incluses.

8 SQL Server prend en charge le stockage avec dépassement de ligne, qui permet d'envoyer hors ligne les colonnes de longueur variable. Seule une racine de 24 octets est stockée dans l'enregistrement principal des colonnes de longueur variable envoyées hors ligne ; par conséquent, la limite effective par ligne est supérieure dans les versions antérieures de SQL Server. Pour plus d'informations, consultez la rubrique « Données de dépassement de ligne de plus de 8 Ko » dans la documentation en ligne de SQL Server.

Objets de réplication

Le tableau suivant présente la taille maximale et le nombre maximal des différents objets définis dans Réplication SQL Server.

Objet de réplication SQL Server 2005 | Taille maximale/nombre maximal dans SQL Server (32 bits) | Taille maximale/nombre maximal dans SQL Server (64 bits)
Articles (publication de fusion) | 256 | 256
Articles (publication de capture instantanée ou transactionnelle) | 32,767 | 32,767
Colonnes dans une table1 (publication de fusion) | 246 | 246
Colonnes d'une table2 (publication de capture instantanée ou transactionnelle SQL Server) | 1,000 | 1,000
Colonnes dans une table2 (publication de capture instantanée ou transactionnelle Oracle) | 995 | 995
Octets pour une colonne utilisée dans un filtre de lignes (publication de fusion) | 1,024 | 1,024
Octets pour une colonne utilisée dans un filtre de lignes (publication de capture instantanée ou transactionnelle) | 8,000 | 8,000

1 Si le suivi de niveau ligne est utilisé pour la détection des conflits (méthode par défaut), la table de base peut inclure un maximum de 1 024 colonnes, mais ces colonnes doivent être filtrées à partir de l'article, afin que 246 colonnes soient publiées au maximum. Si le suivi de niveau colonne est utilisé, la table de base peut inclure 246 colonnes au maximum. Pour plus d'informations sur le niveau de suivi, consultez la section « Niveau de suivi » dans Comment la réplication de fusion détecte et résout les conflits.

2 La table de base peut inclure le nombre maximal de colonnes autorisées dans la base de données de publication (1 024 pour SQL Server), mais les colonnes doivent être filtrées à partir de l'article si elles sont plus nombreuses que le maximum spécifié pour le type de publication.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008
Paramètres de l'outil d'analyse de configuration système


Nombre maximal de processeurs pris en charge par les éditions de SQL Server

Nombre maximal de processeurs pris en charge par les éditions de SQL Server |
 | Voir aussi
Planification d'une installation SQL Server > Spécifications de produit pour SQL Server 2008 >

SQL Server prend en charge le nombre spécifié de sockets de processeur multiplié par le nombre d'UC logiques de chaque socket. Par exemple, les éléments suivants sont considérés comme constituant un seul processeur pour les besoins de ce tableau :

  • processeur multithread à noyau unique avec 2 UC logiques par socket ;

  • processeur à double noyau avec 2 UC logiques ;

  • processeur à quatre noyaux avec 4 UC logiques.

SQL Server est concédé sous licence sur une base « par socket de processeur » et non « par UC logique ».

Édition de SQL Server 2008 | Nombre de processeurs pris en charge
Enterprise | Maximum du système d'exploitation
Standard | 4
Web | 4
Workgroup | 2
Express | 1
Express with Advanced Services | 1

Voir aussi

Référence

Mémoire prise en charge par les éditions de SQL Server 2008
Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Autres ressources

Spécifications de produit pour SQL Server 2008


Mémoire prise en charge par les éditions de SQL Server 2008

Mémoire prise en charge par les éditions de SQL Server 2008 |
 | Voir aussi
Planification d'une installation SQL Server > Spécifications de produit pour SQL Server 2008 >

Le tableau suivant spécifie la quantité maximale de mémoire prise en charge pour chaque édition de SQL Server 2008.

Édition SQL Server | Mémoire maximale prise en charge
Enterprise | Maximum du système d'exploitation
Developer | Maximum du système d'exploitation
Standard | Maximum du système d'exploitation
Web | Maximum du système d'exploitation
Workgroup | 4 Go (64 bits), maximum du système d'exploitation (32 bits)
Express | 1 Go
Express with Advanced Services | 1 Go

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Autres ressources

Spécifications de produit pour SQL Server 2008


Vue d'ensemble des solutions à haute disponibilité

Vue d'ensemble des solutions à haute disponibilité |
 | Voir aussi
Planification d'une installation SQL Server >

Cette section présente plusieurs solutions haute disponibilité SQL Server qui améliorent la disponibilité des serveurs ou des bases de données. Une solution haute disponibilité masque l'impact d'un dysfonctionnement matériel ou logiciel et gère la disponibilité des applications pour réduire le temps d'immobilisation que perçoit l'utilisateur.

SQL Server fournit des options permettant de garantir un haut niveau de disponibilité pour un serveur ou une base de données. Les options de haute disponibilité sont les suivantes :

  • Clustering de basculement

    Les clusters de basculement garantissent une prise en charge de la haute disponibilité pour l'intégralité d'une instance de SQL Server. Un cluster de basculement est une combinaison d'un ou de plusieurs nœuds, ou serveurs, avec plusieurs disques partagés. Les applications sont installées dans un groupe de clusters Microsoft Cluster Service (MSCS), appelé groupe de ressources. Chaque groupe de ressources est systématiquement détenu par un seul nœud du cluster à la fois. Le service d'application possède un nom virtuel indépendant des noms des nœuds, et il est désigné par les termes nom d'instance de cluster de basculement. Une application peut se connecter à l'instance de cluster de basculement en référençant le nom de l'instance de cluster de basculement. Il n'est pas nécessaire que l'application sache quel nœud héberge l'instance de cluster de basculement.

    Une instance de cluster de basculement SQL Server apparaît sur le réseau sous la forme d'un ordinateur unique, mais elle est en mesure de basculer d'un nœud vers un autre en cas d'indisponibilité du nœud actuel. Par exemple, au cours d'une défaillance d'un matériel autre qu'un disque, du système d'exploitation ou de la mise à niveau planifiée du système d'exploitation, vous pouvez configurer une instance de SQL Server sur un nœud d'un cluster de basculement de sorte qu'elle bascule vers n'importe quel autre nœud du groupe de disques.

    Un cluster de basculement ne fournit aucune protection contre une défaillance de disque. Vous pouvez utiliser le clustering de basculement pour réduire l'immobilisation du système et améliorer le niveau de disponibilité des applications. Le cluster de basculement est pris en charge dans SQL Server Enterprise et SQL Server Developer, et, avec certaines restrictions, dans SQL Server Standard. Pour plus d'informations sur le clustering de basculement, consultez Mise en route avec le clustering de basculement de SQL Server 2008 et Installation d'un cluster de basculement SQL Server 2008.

  • Mise en miroir d'une base de données

    La mise en miroir de base de données est principalement une solution logicielle qui permet d'optimiser la disponibilité d'une base de données en utilisant presque instantanément le basculement. La mise en miroir de base de données peut être utilisée pour gérer une base de données de secours ou une base de données miroir pour une base de données de production correspondante désignée sous le nom de base de données principale.

    La base de données miroir est créée en restaurant une sauvegarde de base de données complète de la base de données principale sans récupération. Ainsi, la base de données miroir n'est pas accessible aux clients. Toutefois, il est possible de l'utiliser indirectement pour créer des rapports en créant une capture instantanée de base de données sur la base de données miroir. La capture instantanée de base de données fournit aux clients un accès en lecture seule aux données de la base de données, telles qu'elles existaient lors de la création de la capture instantanée.

    Chaque configuration de mise en miroir d'une base de données fait intervenir un serveur principal qui contient la base de données principale, et un serveur miroir qui contient la base de données en miroir. Le serveur miroir met régulièrement à jour la base de données miroir avec la base de données principale.

    La mise en miroir de base de données s'exécute de manière synchrone en mode haute sécurité, ou de manière asynchrone en mode hautes performances. En mode hautes performances, les transactions sont validées sans attendre que le serveur miroir écrive le journal sur le disque, ce qui contribue à optimiser les performances. En mode haute sécurité, une transaction validée est validée sur les deux partenaires, mais au détriment d'une latence accrue des transactions.

    Dans sa configuration la plus simple, la mise en miroir de bases de données implique uniquement les serveurs miroir et principal. Dans cette configuration, en cas de perte du serveur principal, le serveur miroir peut faire office de serveur de secours semi-automatique, avec une perte de données possible. Le mode haute sécurité prend en charge une autre configuration, le mode haute sécurité de basculement automatique. Cette configuration fait intervenir un troisième serveur, appelé témoin, qui permet au serveur miroir de faire office de serveur de secours à chaud. Le basculement de la base de données principale vers la base de données miroir dure généralement plusieurs secondes.

    Les serveurs partenaires et témoins de mise en miroir de bases de données sont pris en charge par SQL Server 2005 Standard SP1 et par SQL Server 2005 Enterprise Edition SP1 et versions ultérieures. Mais les serveurs partenaires doivent utiliser la même édition et la mise en miroir de bases de données asynchrone (mode hautes performances) est prise en charge uniquement par SQL Server 2005 Enterprise Edition SP1 et versions ultérieures. Les témoins sont également pris en charge par SQL Server 2005 Workgroup SP1 et versions ultérieures et par SQL Server 2005 Express Edition SP1 et versions ultérieures. Pour plus d'informations sur la mise en miroir de bases de données, consultez Mise en miroir de bases de données.

  • Copie des journaux de transaction

    Comme la mise en miroir d'une base de données, la copie des journaux de transaction fonctionne au niveau de la base de données. Vous pouvez utiliser la copie des journaux de transaction pour gérer une ou plusieurs bases de données de secours semi-automatique pour une base de données de production correspondante appelée base de données principale. Les bases de données de secours sont également appelées bases de données secondaires. Chaque base de données secondaire est créée en restaurant une sauvegarde de la base de données primaire sans récupération ou avec l'exécution de WITH STANDBY. La restauration avec l'exécution de WITH STANDBY permet l'utilisation de la base de données secondaire à des fins limitées de génération de rapports.

    Une configuration de la copie des journaux de transaction inclut un serveur principal qui contient la base de données primaire, un ou plusieurs serveurs secondaires qui possèdent chacun une base de données secondaire, et un serveur miroir. Chaque serveur secondaire met à jour sa base de données secondaire à intervalles définis à partir des sauvegardes de fichiers journaux de la base de données primaire. La copie des journaux de transaction implique un délai modifiable par l'utilisateur entre le moment où le serveur principal crée une sauvegarde de fichier journal de la base de données primaire et le moment où le serveur secondaire restaure la sauvegarde du fichier journal. Pour qu'un basculement puisse avoir lieu, une base de données secondaire doit être mise à jour complètement en appliquant manuellement toutes les sauvegardes de fichiers journaux non restaurés.

    La copie des journaux de transaction permet de prendre en charge plusieurs bases de données de secours. Si vous avez besoin de plusieurs bases de données de secours, vous pouvez utiliser la copie des journaux de transaction seule ou avec la mise en miroir de la base de données. Lorsque vous utilisez ces solutions ensemble, la base de données principale actuelle de la configuration de la mise en miroir de la base de données constitue également la base de données principale actuelle de la configuration de la copie des journaux de transaction.

    Les éditions SQL Server Enterprise, Standard et Workgroup prennent en charge la copie des journaux de transaction. Pour plus d'informations sur l'utilisation de la copie des journaux de transaction, consultez Vue d'ensemble de la copie des journaux de transaction et Administration de la copie des journaux de transaction.

  • Réplication

    La réplication utilise un modèle publier/abonner. Ce modèle permet à un serveur principal, appelé serveur de publication, de distribuer les données à un ou plusieurs serveurs secondaires, appelés Abonnés. La réplication fournit une disponibilité et une évolutivité en temps réel sur ces serveurs. Elle prend en charge le filtrage pour fournir un sous-ensemble de données aux Abonnés et permet également de partitionner les mises à jour. Les abonnés sont en ligne et disponibles pour la génération de rapports ou d'autres fonctions, sans requête de récupération. SQL Server offre trois types de réplication : capture instantanée, transactionnelle et de fusion. La réplication transactionnelle garantit le niveau de latence le plus bas, et elle est généralement utilisée pour offrir une haute disponibilité. Pour plus d'informations, consultez Amélioration de l'adaptabilité et de la disponibilité.

    La réplication est prise en charge dans toutes les éditions de SQL Server. La publication de réplication n'est pas disponible dans SQL Server Express ou SQL Server Compact 3.5 SP1.

    Important :
    Une stratégie de sauvegarde et de restauration bien conçue et implémentée est importante pour une solution haute disponibilité. Pour plus d'informations, consultez Sauvegarde et restauration de bases de données dans SQL Server et Sauvegarde et restauration de bases de données répliquées.

  • Bases de données partagées évolutives

    La fonctionnalité de base de données partagée évolutive vous permet de développer une base de données en lecture seule créée exclusivement pour générer des rapports. La base de données de rapports doit résider sur un ensemble de volumes dédiés en lecture seule dont le rôle principal est d'héberger la base de données. À l'aide du matériel de base pour les serveurs et les volumes, vous pouvez procéder au déploiement évolutif d'une base de données de création de rapports offrant le même aperçu des données de création de rapports sur plusieurs serveurs de rapports. Cette fonctionnalité permet également la mise à jour en douceur de la base de données de création de rapports. Pour plus d'informations, consultez Vue d'ensemble des bases de données partagées évolutives.

Dans cette section

Rubrique | Description
Sélection d'une solution haute disponibilité | Présente les éléments à prendre en compte pour sélectionner une solution haute disponibilité.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Autres ressources

Présentation de la mise en miroir de bases de données
Vue d'ensemble de la copie des journaux de transaction
Réplication SQL Server


Sélection d'une solution haute disponibilité

Sélection d'une solution haute disponibilité
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité >

La liste suivante contient les éléments à prendre en compte pour sélectionner une solution haute disponibilité :

  • Le cluster de basculement et la mise en miroir de bases de données fournissent les éléments suivants :

    • Détection et basculement automatiques

    • Basculement manuel

    • Redirection transparente des clients

    Le clustering de basculement impose les contraintes suivantes :

    • Fonctionne au niveau de la portée de l'instance du serveur

    • Requiert un matériel signé

    • Ne fournit aucun rapport sur la base de données de secours

    • Utilise une seule copie de la base de données

    • N'offre aucune protection contre les défaillances de disque

    La mise en miroir de bases de données présente les avantages suivants :

    • Fonctionne au niveau de la portée de la base de données.

    • Utilise une seule copie dupliquée de la base de données

      Remarque :
      Si vous avez besoin d'autres copies, vous pouvez utiliser la copie des journaux de transaction sur la base de données en complément de la mise en miroir des bases de données.

    • Utilise des serveurs standard

    • Fournit des rapports limités sur le serveur miroir en utilisant des captures instantanées de la base de données.

    • Utilisée de manière synchrone, elle évite de perdre des données en différant la validation dans la base de données principale.

    La mise en miroir de bases de données permet d'améliorer substantiellement la disponibilité par rapport au niveau de disponibilité offert à l'aide de SQL Server, et elle offre une alternative simple à gérer au cluster de basculement.

  • Copie des journaux de transaction

    Cette opération peut offrir une alternative ou un complément à la mise en miroir des bases de données. Bien que similaires au niveau des concepts, la mise en miroir asynchrone de bases de données et la copie des journaux de transaction présentent des différences importantes. La copie des journaux de transaction fournit les fonctions distinctes suivantes :

    • Prise en charge de plusieurs bases de données secondaires sur plusieurs instances de serveur pour une base de données primaire unique.

    • Possibilité de spécifier un délai défini par l'utilisateur entre la sauvegarde du fichier journal de la base de données principale par le serveur principal et la restauration de la sauvegarde du fichier journal par les serveurs secondaires. Un délai plus long peut s'avérer utile en cas, par exemple, de modification accidentelle des données sur la base de données primaire. Si la modification accidentelle est remarquée rapidement, un délai peut vous permettre de récupérer à partir de la base de données secondaire les données n'ayant pas encore été modifiées, avant que la modification n'y soit reflétée.

      La mise en miroir asynchrone de bases de données offre, par rapport à la copie des journaux de transaction, l'avantage virtuel d'un délai plus court lorsqu'une modification est effectuée dans la base de données primaire et lorsque cette modification est reflétée dans la base de données miroir.

      La mise en miroir d'une base de données offre un avantage par rapport à la copie des journaux de transaction dans la mesure où le mode de sécurité élevée est une configuration sans perte de données qui est prise en charge sous la forme d'une stratégie de basculement simple.

      Remarque :
      Pour plus d'informations sur l'utilisation de la copie des journaux de transaction avec la mise en miroir de bases de données, consultez Mise en miroir de base de données et copie des journaux de transaction.

  • Réplication

    La réplication offre les avantages suivants :

    • Elle permet le filtrage dans la base de données pour fournir un sous-ensemble des données sur les bases de données secondaires car elle fonctionne au niveau de la portée de la base de données.

    • Elle permet d'utiliser plusieurs copies redondantes de la base de données.

    • Elle fournit une disponibilité et une évolutivité en temps réel sur plusieurs bases de données et prend en charge les mises à jour partitionnées.

    • Elle garantit la disponibilité totale des bases de données secondaires pour la génération de rapports ou d'autres fonctions, sans requête de récupération.

    Remarque :
    Pour plus d'informations sur les solutions haute disponibilité supplémentaires avec réplication, consultez Réplication et mise en miroir des bases de données et Réplication et copie des journaux de transaction.


Mise en route avec le clustering de basculement de SQL Server 2008

Mise en route avec le clustering de basculement de SQL Server 2008 |
 | Voir aussi
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité >

Le clustering de basculement dans SQL Server assure un degré élevé de disponibilité pour une instance complète de SQL Server. Par exemple, vous pouvez configurer une instance SQL Server sur un nœud d'un cluster de basculement de manière à prévoir un basculement vers un autre nœud du cluster lors d'une panne matérielle, d'une défaillance du système d'exploitation ou d'une mise à niveau planifiée.

Un cluster de basculement est une combinaison d'un ou de plusieurs nœuds (serveurs) avec plusieurs disques partagés, formant ce qui est convenu d'appeler un groupe de ressources. La combinaison d'un groupe de ressources, de son nom de réseau et d'une adresse IP (Internet Protocol) qui constitue l'application ou le serveur cluster, est qualifiée de cluster de basculement ou d'instance de cluster de basculement. Un cluster de basculement SQL Server apparaît sur le réseau sous la forme d'un ordinateur unique, mais il dispose de la fonctionnalité qui permet de basculer d'un nœud vers un autre en cas d'indisponibilité du nœud actuel. Un cluster de basculement apparaît sur le réseau comme une application normale ou un ordinateur unique, mais il est doté d'une fonctionnalité supplémentaire augmentant sa disponibilité.

Le clustering avec basculement possède une nouvelle architecture et un nouveau flux de travail pour tous les scénarios d'installation dans SQL Server 2008. Les deux options pour l'installation sont l'installation intégrée et l'installation avancée/entreprise. L'installation intégrée crée et configure une instance du cluster de basculement SQL Server à un seul nœud. Les nœuds supplémentaires sont ajoutés en utilisant la fonction Ajouter un nœud du programme d'installation. Par exemple, pour l'installation intégrée, vous exécutez le programme d'installation pour créer un cluster de basculement à un seul nœud. Puis, vous exécutez à nouveau le programme d'installation pour chaque nœud que vous voulez ajouter au cluster. L'installation avancée/entreprise se compose de deux étapes. L'étape de préparation prépare tous les nœuds du cluster de basculement pour qu'ils soient opérationnels. Les nœuds sont définis et préparés pendant cette étape initiale. Après avoir préparé les nœuds, l'étape de fin est exécutée sur le nœud actif – le nœud qui possède le disque partagé – pour terminer la création de l'instance de cluster de basculement et la rendre opérationnelle.

Quand utiliser le clustering de basculement

Utilisez le clustering de basculement pour effectuer les opérations suivantes :

  • Administrer un cluster de basculement à partir de n'importe quel nœud dans la configuration cluster de SQL Server. Pour plus d'informations, consultez Installation d'un cluster de basculement SQL Server 2008.

  • Autoriser un nœud du cluster à basculer vers n'importe quel autre nœud dans la configuration de cluster de basculement. Pour plus d'informations, consultez Installation d'un cluster de basculement SQL Server 2008.

  • Configurer Analysis Services pour le clustering de basculement. Pour plus d'informations, consultez How to: install Analysis Services on a failover cluster.

  • Effectuer des requêtes de texte intégral à l'aide du service Microsoft Search et du clustering de basculement. Pour plus d'informations, consultez Utilisation des outils SQL Server dans le clustering de basculement.

Installation du clustering de basculement

Pour utiliser le clustering de basculement, suivez les étapes d'installation ci-après.

Pour installer, configurer et gérer un cluster de basculement SQL Server, utilisez le programme d'installation de SQL Server. Utilisez le programme d'installation de SQL Server dans un cluster de basculement pour effectuer les tâches suivantes :

  • Installez SQL Server pour créer un cluster de basculement.

    Avant d'installer un clustering de basculement, vous devez vous assurer que votre système offre la configuration minimale requise, puis configurer Microsoft Cluster Service (MSCS). Pour plus d'informations sur les conditions spécifiques d'un cluster de basculement, consultez Avant l'installation du clustering de basculement.

    Tous les nœuds d'un cluster de basculement doivent être de la même plateforme (32 bits ou 64 bits) et exécuter le même système d'exploitation et la même version. En outre, les éditions 64 bits de SQL Server doivent être installées sur un matériel 64 bits utilisant les versions 64 bits des systèmes d'exploitation Windows. Il n'existe pas de prise en charge WOW64 pour les clusters de basculement dans cette version.

  • Ajouter ou retirer des nœuds d'une configuration de cluster de basculement sans aucune incidence sur les autres nœuds du cluster. Pour plus d'informations, consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

  • Spécifier plusieurs adresses IP pour chaque instance de cluster de basculement. Vous pouvez spécifier plusieurs adresses IP pour chaque serveur, ce qui vous permet d'utiliser tous les sous-réseaux IP disponibles. SQL Server vous limite à une adresse IP par réseau. Cela fournit des connexions de réseau de remplacement en cas de défaillance d'un sous-réseau.

Prise en charge du clustering de basculement

Dans SQL Server, le nombre de nœuds pris en charge pour le clustering de basculement varie selon le système d'exploitation et l'édition de SQL Server. Pour une liste d'outils, de fonctions et de services pris en charge par le clustering de basculement de SQL Server, consultez Features Supported by the Editions of SQL Server 2005.

Voir aussi

Tâches

Procédure : créer un cluster de basculement SQL Server (programme d'installation)

Concepts

Avant l'installation du clustering de basculement
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Avant l'installation du clustering de basculement

Avant l'installation du clustering de basculement |
 | Voir aussi
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 >

Avant d'installer un cluster de basculement SQL Server, vous devez sélectionner le matériel et le système d'exploitation que SQL Server utilisera. Vous devez également configurer Microsoft Cluster Service (MSCS) et examiner le réseau, la sécurité ainsi que les points importants à prendre en compte pour les autres logiciels qui seront exécutés sur votre cluster de basculement.

Liste de vérification avant l'installation

Avant d'entamer le processus d'installation du cluster de basculement, vérifiez les éléments indiqués ci-dessous.

Vérifiez votre solution matérielle

  • Pour Windows Server 2003, votre matériel doit figurer dans le Catalogue Windows et la liste des matériels compatibles avec Windows. Le système de matériel doit apparaître sous la catégorie d'une solution de cluster. Windows Server 2008 a un utilitaire qui évalue la compatibilité du matériel pour les solutions de clusters de basculement.

    Important :
    L'ajout de différents composants de cluster ne constitue pas un système approuvé pour le clustering de basculement. Seuls les systèmes achetés dans le cadre d'une solution de cluster et figurant dans le groupe de clusters sont approuvés. Lorsque vous vérifiez le Catalogue Windows et la liste des matériels compatibles avec Windows, indiquez la catégorie « cluster ». Toutes les autres catégories sont réservées à un usage OEM. Pour plus d'informations, consultez Stratégie de prise en charge Microsoft pour les clusters serveur, liste du matériel compatible et Catalogue Windows Server.

  • Des tests de compatibilité matérielle spéciaux sont nécessaires lors de l'implémentation d'un cluster de serveurs de basculement sur un réseau de stockage (SAN). L'intégralité de la solution matérielle doit figurer dans la catégorie « Périphérique cluster/multi-cluster » de la liste des matériels compatibles avec Windows et du Catalogue Windows.

  • Si la solution de cluster inclut des nœuds de cluster dispersés géographiquement, il est important de vérifier d'autres éléments, tels que la prise en charge de disques partagés et le temps de réponse du réseau. La solution complète doit figurer dans la liste de compatibilité matérielle des clusters géographiques. Pour plus d'informations, consultez Windows Clustering et sites séparés sur le plan géographique dans la Base de connaissances Microsoft.

  • Les configurations SAN sont également prises en charge sous Windows 2000 éditions Advanced Server et Datacenter Server. La catégorie « Périphérique cluster/multi-cluster » du Catalogue Windows et de la liste des matériels compatibles avec Windows répertorie les unités de stockage compatibles SAN qui ont été testées et qui sont prises en charge en tant qu'unités de stockage SAN avec plusieurs clusters MSCS associés. Si vous faites correspondre les unités de cette liste et les configurations de cluster complètes définies dans la catégorie « Cluster » du Catalogue Windows et de la liste des matériels compatibles avec Windows, vous pouvez déployer un groupe de serveurs et de clusters Windows dans un contexte SAN avec des périphériques de stockage partagés, d'une manière prise en charge par Microsoft. Pour plus d'informations, consultez Le programme Datacenter et Windows 2000 Datacenter Server dans la Base de connaissances Microsoft.

  • Si vous déployez un cluster de basculement SQL Server sur des composants de la technologie iSCSI, nous vous recommandons de prendre les précautions qui s'imposent. Pour plus d'informations, consultez Support for SQL Server 2000 on iSCSI technology components (en anglais) dans la Base de connaissances Microsoft.

  • Pour obtenir des informations de support technique, consultez SQL Server support policy for Microsoft Clustering (en anglais) dans la Base de connaissances Microsoft.

  • Déterminez le partage de ressources de disque quorum. Dans un cluster de serveurs, le disque quorum contient une copie principale de la configuration du cluster de serveurs, et il est également utilisé comme ressource de contrôle décisive si toutes les communications réseau tombent en panne entre les nœuds du cluster. En fonction du type de cluster de serveurs que vous implémentez, le disque quorum peut être, ou non, un disque physique sur la baie de disques de cluster partagée. Bien qu'il soit conseillé de réserver un disque de cluster entier afin de l'utiliser comme disque quorum, des ressources autres que la ressource quorum peuvent être autorisées à accéder au disque quorum.

    Cependant, si vous faites en sorte que la ressource quorum partage le même disque avec d'autres ressources, vous êtes contraint de choisir parmi deux alternatives non souhaitables. Vous devez soit configurer la ressource afin que sa défaillance n'affecte pas le groupe, soit autoriser le groupe à être affecté par les défaillances de l'autre ressource. Dans le premier cas, le basculement n'est plus assuré pour la ressource ; dans le second cas, la ressource quorum bascule avec le reste du groupe qui contient la ressource quorum et la ressource défaillante. Par conséquent, la totalité du cluster est hors connexion, et ce, pendant toute la durée nécessaire au basculement du groupe.

    Pour plus d'informations sur la configuration appropriée d'un lecteur quorum, consultez l'article Informations concernant la configuration de lecteur quorum dans la Base de connaissances Microsoft.

  • Pour installer un cluster de basculement SQL Server lorsque les fichiers d'installation source et le cluster se trouvent dans des domaines différents, copiez les fichiers d'installation sur le nœud principal du cluster, puis démarrez l'installation à partir de ce nœud principal.

Vérifiez les paramètres de votre système d'exploitation

  • Assurez-vous que votre système d'exploitation est installé correctement et qu'il prend en charge le clustering de basculement. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

  • Activez le fournisseur de services de chiffrement Windows sur Windows Server 2003. Si le service de ce fournisseur est arrêté ou désactivé sur un nœud de cluster, le programme d'installation de SQL Server échoue et affiche une boîte de dialogue relative à la configuration requise pour le programme Windows Logo.

  • SQL Server prend en charge les points de montage ; les installations en cluster de SQL Server sont limitées au nombre de lettres de lecteurs disponibles. Si l'on part du principe que vous utilisez une seule lettre de lecteur pour le système d'exploitation et que toutes les autres lettres de lecteurs peuvent être utilisées comme lecteurs en cluster standard ou lecteurs en cluster hébergeant des points de montage, vous êtes limité à un maximum de 25 instances de SQL Server par cluster de basculement.

    Un volume monté, ou point de montage, vous permet d'utiliser une seule lettre de lecteur pour faire référence à de nombreux disques ou volumes. Si vous disposez d'une lettre de lecteur D: qui fait référence à un disque ou volume traditionnel, vous pouvez connecter ou « monter » d'autres disques ou volumes comme répertoires sous la lettre de lecteur D: sans que les disques ou volumes supplémentaires ne nécessitent des lettres de lecteurs qui leur sont propres.

    Remarques supplémentaires relatives aux points de montage pour le clustering de basculement SQL Server :

    • Pour le programme d'installation de SQL Server, le lecteur de base d'un lecteur monté doit posséder une lettre de lecteur associée. Pour les installations de clusters de basculement, ce lecteur de base doit être un lecteur en cluster. Les GUID du volume ne sont pas pris en charge dans cette version.

    • Le lecteur de base (celui doté de la lettre de lecteur) ne peut pas être partagé entre des instances de clusters de basculement. Cette restriction est normale pour les clusters de basculement, mais elle ne s'applique pas aux serveurs autonomes à plusieurs instances.

    • Soyez vigilant lorsque vous configurez votre cluster de basculement : vérifiez que le lecteur de base et les disques ou volumes montés sont répertoriés comme ressources dans le groupe de ressources. Le programme d'installation de SQL Server valide la configuration du lecteur dans le cadre d'une installation de cluster de basculement.

  • Le programme d'installation de SQL Server définit automatiquement les dépendances entre le groupe de clusters SQL Server et les disques qui figurent dans le cluster de basculement. Ne définissez pas de dépendances pour les disques avant l'installation.

  • Pour activer l'authentification Kerberos avec SQL Server 2008, consultez l'article Comment faire pour utiliser l'authentification Kerberos dans SQL Server dans la Base de connaissances Microsoft.

Configurez Microsoft Cluster Server

  • Le logiciel MSCS (Microsoft Cluster Server) doit être configuré sur au moins l'un des nœuds de votre cluster de serveurs. MSCS est pris en charge uniquement si la configuration du matériel sur lequel il est installé a été testée et est compatible avec le logiciel MSCS. Vous devez également exécuter SQL Server Enterprise ou SQL Server Standard avec MSCS. SQL Server Enterprise prend en charge les clusters de basculement contenant jusqu'à 8 nœuds. SQL Server Standard prend en charge les clusters de basculement à 2 nœuds.

    Pour plus d'informations sur l'installation et la configuration de MSCS sur Windows Server 2003, consultez Server clusters (en anglais).

  • La DLL de ressource pour le service SQL Server exporte deux fonctions utilisées par le gestionnaire de cluster MSCS pour vérifier la disponibilité de la ressource SQL Server. Il existe une vérification simple, LooksAlive, qui interroge l'état du service par le biais du Gestionnaire de contrôle des services Windows NT. Il existe également une vérification plus rigoureuse, IsAlive, qui se connecte à SQL Server en tant qu'utilisateur de test pour effectuer une requête simple. Par défaut, LooksAlive se déclenche toutes les 5 secondes et IsAlive se déclenche toutes les 60 secondes. Les fréquences d'interrogation de LooksAlive et d'IsAlive peuvent être modifiées dans l'Administrateur de cluster MSCS à partir de l'onglet Avancé pour la ressource SQL Server ou à l'aide de l'utilitaire d'invite de commandes Cluster.exe.

  • MSCS doit être en mesure de vérifier que l'instance de cluster de basculement s'exécute à l'aide de la vérification IsAlive. Cela signifie qu'il convient de se connecter au serveur à l'aide d'une connexion approuvée. Par défaut, le compte qui exécute le service de cluster n'est pas configuré en tant qu'administrateur sur les nœuds du cluster, et le groupe BUILTIN\Administrateurs n'a pas l'autorisation de se connecter à SQL Server. Ces paramètres changent uniquement si vous modifiez les autorisations définies sur les nœuds du cluster.

    Assurez-vous que le groupe ou le compte sous lequel le service de cluster s'exécute peut se connecter à SQL Server pour la vérification IsAlive. Dans le cas contraire, la vérification IsAlive échouera. Le compte Cluster Service (MSCS) doit disposer des autorisations minimales public sur SQL Server pour qu'il soit possible d'exécuter SELECT @@servername régulièrement.

  • Lorsque vous installez MSCS, il est très important d'utiliser des comptes de services séparés pour la connexion à MSCS et à SQL Server. Dans le cas contraire, le mot de passe du service de cluster ne peut pas être modifié à l'aide de la commande de cluster.

  • Lors de l'utilisation de MSCS, un nœud doit contrôler le bus SCSI partagé avant que l'autre nœud soit en ligne. Sinon, l'application risque de basculer vers un état d'attente en ligne, sans pouvoir basculer vers l'autre mode, ou alors le basculement échouera totalement. Si votre système de cluster dispose d'un processus d'installation propriétaire, celui-ci doit être utilisé.

Installation de Microsoft Distributed Transaction Coordinator

Avant d'installer SQL Server sur un cluster de basculement, déterminez si la ressource de cluster Microsoft Distributed Transaction Coordinator (MSDTC) doit être créée. Si vous installez uniquement le moteur de base de données, la ressource de cluster MSDTC n'est pas nécessaire. Si vous installez le moteur de base de données et SSIS, les composants de station de travail, ou si vous comptez utiliser les transactions distribuées, vous devez installer MSDTC. Notez que MSDTC n'est pas requis pour les instances d'Analysis Services uniquement.

Configurez MS DTC (Microsoft Distributed Transaction Coordinator)

Une fois que vous avez installé le système d'exploitation et configuré votre cluster, vous devez configurer MSDTC pour qu'il fonctionne dans un cluster à l'aide de l'Administrateur de cluster. L'échec de la mise en cluster de MSDTC ne bloquera pas l'installation de SQL Server, mais les fonctionnalités des applications SQL Server peuvent être affectées si MSDTC n'est pas configuré correctement.

Autres remarques relatives aux logiciels

  • Vérifiez que tous les nœuds du cluster sont configurés de la même manière, y compris COM+, les lettres de lecteur de disque et les utilisateurs dans le groupe Administrateurs.

  • Vérifiez que l'interconnexion (pulsation) de cluster est configurée de manière appropriée. Pour plus d'informations, consultez l'article de la Base de connaissances intitulé Configuration de pulsation privée recommandée sur un serveur cluster.

  • Vérifiez que vous avez effacé les journaux système dans tous les nœuds, puis affiché de nouveau les journaux système. Vérifiez que les journaux ne contiennent aucun message d'erreur avant de continuer.

  • Pour les installations SQL Server dans des configurations côte à côte avec des versions antérieures, les services SQL Server doivent utiliser des comptes figurant uniquement dans le groupe global des domaines. En outre, les comptes utilisés par les services SQL Server ne doivent pas figurer dans le groupe local Administrateurs. Ne pas se conformer à cette consigne entraînera un comportement de sécurité inattendu.

  • Si vous déployez des nœuds de cluster Windows Server 2003 dans un environnement ne comprenant aucun contrôleur de domaine Windows Server 2003 préexistant, consultez Nœuds de clusters Windows 2000 et Windows Server 2003 en tant que contrôleurs de domaine.

  • Pour utiliser le chiffrement, installez le certificat du serveur avec le nom DNS complet du cluster MSCS sur tous les nœuds du cluster de basculement SQL Server. Par exemple, si vous disposez d'un cluster à deux nœuds appelés « Test1.NomDomaine.com » et « Test2.NomDomaine.com » et d'une instance de cluster de basculement SQL Server appelée « Virtsql », vous devez vous procurer un certificat pour « Virtsql.NomDomaine.com » et installer le certificat sur les nœuds test1 et test2. Vous pouvez ensuite activer la case à cocher Forcer le chiffrement du protocole dans le Gestionnaire de configuration SQL Server pour configurer votre cluster de basculement à des fins de chiffrement.

    Important :
    N'activez pas la case à cocher Forcer le chiffrement du protocole tant que les certificats n'ont pas été installés sur tous les nœuds participants de votre instance de cluster de basculement.

  • Vérifiez qu'aucun logiciel antivirus n'est installé sur votre cluster MSCS. Pour plus d'informations, consultez l'article Antivirus software may cause problems with cluster services (en anglais) dans la Base de connaissances Microsoft.

  • Vérifiez que le disque sur lequel SQL Server doit être installé n'est pas compressé. Si vous tentez d'installer SQL Server sur un lecteur compressé, l'installation de SQL Server échoue.

  • Lorsque vous nommez un groupe de clusters pour votre installation de clusters de basculement, vous ne devez pas utiliser les caractères suivants dans le nom du groupe de clusters :

    • Opérateur inférieur à (<)

    • Opérateur supérieur à (>)

    • Guillemet (")

    • Apostrophe (')

    • et commercial (&)

    Vérifiez également que les noms de groupes de clusters existants ne contiennent pas de caractères non pris en charge.

Considérations relatives aux réseau, port et pare-feu

  • Vérifiez que vous avez désactivé NetBIOS pour toutes les cartes réseau privées avant d'entamer la procédure d'installation de SQL Server.

  • Le nom réseau et l'adresse IP de SQL Server ne doivent pas être utilisés à d'autres fins, telles que le partage de fichiers. Si vous souhaitez créer une ressource de partage de fichier, utilisez un nom réseau et une adresse IP différents et uniques pour la ressource.

    Important :
    Microsoft vous déconseille d'utiliser des partages de fichiers sur des lecteurs de données, car ils ont une incidence sur les performances et le comportement de SQL Server.

  • Bien que SQL Server prenne en charge les canaux nommés et les sockets TCP/IP sur TCP/IP au sein d'un cluster, Microsoft vous recommande d'utiliser des sockets TCP/IP dans une configuration en cluster.

  • Pour garantir un fonctionnement correct du cluster de basculement, ajoutez des exceptions aux paramètres de configuration de pare-feu pour le port SQL Server, le port SQL Browser, Partage de fichiers et d'imprimantes (TCP 139/445 et UDP 137/138), et l'appel de procédure distante (port TCP 135).

  • Le service Registre distant doit être en état de fonctionner.

  • L'administration à distance doit être activée.

  • Pour le port SQL Server, utilisez le Gestionnaire de configuration SQL Server pour vérifier la configuration réseau SQL Server du protocole TCP/IP pour l'instance à débloquer. Vous devez activer le port TCP pour IPALL si vous voulez vous connecter à SQL Server à l'aide de TCP après l'installation. SQL Browser écoute sur le port UDP 1434 par défaut.

Autres considérations

  • Pour créer un cluster de basculement, vous devez être un administrateur local autorisé à se connecter en tant que service et à agir dans le cadre du système d'exploitation sur tous les nœuds de l'instance de cluster de basculement.

  • Avant d'installer ou de mettre à jour un cluster de basculement SQL Server, désactivez l'ensemble des applications et des services susceptibles d'utiliser les composants SQL Server au cours de l'installation, mais maintenez en ligne les ressources de disque.

  • Sur Windows Server 2008, les SID de service sont générés automatiquement pour une utilisation avec les services SQL Server 2008. Pour les instances de cluster de basculement SQL Server 2008 mises à niveau à partir de SQL Server 2000 ou SQL Server 2005, les groupes de domaines et configurations des listes de contrôle d'accès existants seront conservés.

  • Sur Windows Server 2003, créez des groupes de domaines pour les services cluster qui seront installés dans le cadre de votre cluster de basculement SQL Server. Le service SQL Server, le service SQL Server Agent, le service Analysis Services et le service Recherche en texte intégral doivent être exécutés en tant que comptes de domaine, membres du groupe de domaines. Si nécessaire, demandez à votre administrateur de domaine les noms des groupes de domaines existants, ou demandez-lui de créer des groupes de domaines pour votre cluster de basculement. Pour plus d'informations, consultez Domain Groups for Clustered Services.

  • Le clustering de basculement SQL Server n'est pas pris en charge lorsque les nœuds du cluster sont des contrôleurs de domaine.

  • Configurez le service DNS (Domain Name Service) ou le service WINS (Windows Internet Name Service). Un serveur DNS ou un serveur WINS doit s'exécuter dans l'environnement où votre cluster de basculement SQL Server sera installé. Le programme d'installation de SQL Server nécessite un enregistrement DNS dynamique de la référence virtuelle de l'interface IP SQL Server. Si l'enregistrement dynamique ne peut pas être effectué, le programme d'installation échoue et l'installation est restaurée. Si aucun enregistrement dynamique n'est disponible, vous devez avoir pré-enregistré votre serveur dans DNS.

  • Consultez le contenu de Considérations sur la sécurité pour une installation SQL Server.

  • Consultez le contenu de Paramètres de l'outil d'analyse de configuration système.

  • Déterminez si les outils, fonctionnalités et composants de SQL Server que vous souhaitez utiliser sont pris en charge dans le cadre du clustering de basculement. Pour plus d'informations, consultez Mise en route avec le clustering de basculement de SQL Server 2008.

  • Déterminez la méthode d'analyse et de gestion que vous adopterez pour votre cluster de basculement afin d'atteindre vos objectifs de haute disponibilité. Pour plus d'informations, consultez Maintenance d'un cluster de basculement et Utilisation des outils SQL Server dans le clustering de basculement.

  • Pour réduire le temps nécessaire à l'installation d'un cluster de basculement SQL Server, vous pouvez préinstaller .NET Framework 2.0 2.0 sur tous les nœuds du cluster de basculement avant d'exécuter le programme d'installation de SQL Server.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008
Paramètres de l'outil d'analyse de configuration système

Concepts

Installation d'un cluster de basculement SQL Server 2008
Considérations sur la sécurité pour une installation SQL Server


Installation d'un cluster de basculement SQL Server 2008

Installation d'un cluster de basculement SQL Server 2008 |
 | Voir aussi
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 >

Pour installer un cluster de basculement SQL Server, vous devez créer et configurer une instance de cluster de basculement en exécutant le programme d'installation de SQL Server. Cette rubrique explique les éléments d'un cluster de basculement et fournit des informations importantes sur l'attribution d'un nom à une instance de cluster de basculement. Elle présente également les étapes de base de l'installation d'un cluster de basculement.

Éléments d'une instance de cluster de basculement

Une instance de cluster de basculement peut s'exécuter sur un ou plusieurs ordinateurs qui sont des nœuds participant à un cluster de basculement. Une instance de cluster de basculement contient :

  • un ensemble composé d'un ou de plusieurs disques dans un groupe de clusters Microsoft Cluster Server (MSCS), également appelé groupe de ressources ; chaque groupe de ressources peut contenir au plus une instance de SQL Server ;

  • un nom réseau pour l'instance de cluster de basculement ;

  • une ou plusieurs adresses IP attribuées à l'instance de cluster de basculement ;

  • une instance de SQL Server incluant SQL Server, l'Agent SQL Server, le service de recherche en texte intégral et la réplication. Vous pouvez installer un cluster de basculement avec SQL Server seul, Analysis Services seul ou SQL Server et Analysis Services.

Attribution d'un nom à une instance de cluster de basculement

Une instance de cluster de basculement SQL Server apparaît toujours sur le réseau comme étant un ordinateur unique. Vous devez utiliser le nom de l'instance de cluster de basculement SQL Server pour la connexion au cluster de basculement SQL Server, et non le nom de l'ordinateur du nœud sur lequel il s'exécute. Ainsi, vous avez la garantie que vous serez toujours en mesure de vous connecter à l'instance de cluster de basculement avec le même nom, quel que soit le nœud qui exécute SQL Server.

Le nom de votre instance de cluster de basculement doit être unique dans votre domaine. SQL Server n'écoute pas l'adresse IP des serveurs locaux. À la place, SQL Server considère uniquement l'adresse IP virtuelle créée au cours de l'installation de l'instance de cluster de basculement SQL Server.

SQL Server dépend de clés de Registre et de noms de service différents au sein du cluster de basculement, de manière à s'assurer que SQL Server continue de s'exécuter correctement après un basculement. Par conséquent, le nom choisi pour l'instance de SQL Server, y compris l'instance par défaut, doit être unique au sein de tous les nœuds du cluster de basculement. L'utilisation de noms d'instance uniques garantit que les instances SQL Server qui sont configurées pour basculer sur un seul serveur possèdent des clés de Registre et des noms de services différents.

Considérations relatives à la consolidation de SQL Server avec un cluster de basculement

  • Lorsque vous planifiez la consolidation de plusieurs serveurs autonomes en instances de cluster de basculement SQL Server, nous vous conseillons, dans le cadre de la planification, de vérifier que la configuration matérielle du nœud de cluster est capable d'accommoder le nombre d'instances SQL Server à héberger.

    Ci-dessous vous voyez deux scénarios typiques ainsi que les éléments de base des solutions préconisées ; celles-ci peuvent servir à la configuration de votre site.

    Scénario 1

    Vous hébergez un site et vous souhaitez proposer jusqu'à 23 instances SQL Server avec les conditions de ressources suivantes :

    • 2 processeurs pour les 23 instances SQL Server regroupées en un seul nœud de cluster exigeraient 46 unités centrales.

    • 2 gigaoctets (Go) de mémoire pour les 23 instances SQL Server regroupées en un seul nœud de cluster exigeraient 48 Go de RAM (2 Go de mémoire supplémentaire pour le système d'exploitation).

    • 4 disques pour les 23 instances SQL Server regroupées en une baie de disques de cluster exigeraient 92 disques.

    Si vous limitez les membres du basculement à la moitié seulement des nœuds disponibles, la configuration matérielle requise serait revue à la baisse :

    • 23 processeurs, 24 Go de mémoire par nœud et disponibilité de 46 disques.

    Grâce à la prise en charge des points de montage, le nombre de disques pourrait être réduit davantage. SQL Server nécessiterait 23 disques tous les 3 points de montage pour l'hébergement, pour une disponibilité optimale de l'espace disque.

    Il se peut qu'une limitation apparaisse si les besoins en mémoire et processeurs augmentent, car le matériel existant risque de ne pas pouvoir gérer ces besoins sans affecter les performances des instances SQL Server existantes.

    Scénario 2

    Migration des instances existantes de SQL Server vers un cluster de basculement

    Tout d'abord, vous devez collecter les lignes de base actuelles des serveurs existants, en répertoriant les goulots d'étranglement existants. En supposant que les statistiques des performances de base indiquent les besoins suivants et qu'un seul disque avec des points montage serait capable d'y répondre, cela donnerait la configuration suivante :

    • SQL Server 1 : 8 processeurs, 16 Go of RAM

    • SQL Server 2 : 4 processeurs, 8 Go of RAM (RAM requise, prévision de 12 Go)

    • SQL Server 3 : 2 processeurs, 16 Go de RAM (la ligne de base indique que des processeurs supplémentaires sont requis)

    • SQL Server 4 : 4 processeurs, 8 Go de RAM (il faut plus de bande passante réseau ; ajoutez des cartes réseau pour 4 connexions dédiées)

    Pour remplacer ces quatre serveurs, le nœud de cluster nécessiterait la configuration minimale suivante :

    • 18 processeurs, 54 Go de RAM et 6 cartes réseau

Le calcul de la configuration minimale d'un seul nœud dans un cluster de basculement tient compte des éléments suivants :

  • Total des conditions requises pour l'UC

  • Total des conditions requises pour la mémoire

  • Disques nécessaires

  • Ajoutez 2 Go de RAM pour le système d'exploitation

Notez que la contrainte de disque rencontrée dans les versions précédentes de SQL Server n'affecte pas SQL Server 2008. Chaque instance SQL Server nécessite seulement un disque de cluster pour les fichiers de données.

Installation d'un cluster de basculement

Pour installer un cluster de basculement, vous devez être un administrateur local autorisé à vous connecter en tant que service et à agir dans le cadre du système d'exploitation sur tous les nœuds du cluster de basculement.

Pour installer un cluster de basculement à l'aide du programme d'installation de SQL Server, procédez comme suit :

  1. Identifiez les informations dont vous aurez besoin pour créer votre instance de cluster de basculement (par exemple, une ressource de disque de cluster, des adresses IP et un nom réseau) et les nœuds disponibles pour le basculement. Pour plus d'informations, consultez :

    • Avant l'installation du clustering de basculement

    • Considérations de sécurité pour une installation SQL Server

    Ces étapes de configuration doivent se dérouler avant l'exécution du programme d'installation de SQL Server ; pour cela, utilisez l'Administrateur de cluster Windows. Vous avez besoin d'un groupe MSCS pour chaque instance de cluster de basculement que vous souhaitez configurer.

  2. Exécutez le programme d'installation de SQL Server pour commencer l'installation de votre cluster de basculement. Le clustering avec basculement possède une nouvelle architecture et un nouveau flux de travail pour tous les scénarios d'installation dans SQL Server 2008. Les deux options pour l'installation sont l'installation intégrée et l'installation avancée/entreprise. L'installation intégrée crée et configure une instance du cluster de basculement SQL Server à un seul nœud. Les nœuds supplémentaires sont ajoutés en utilisant la fonction Ajouter un nœud du programme d'installation. Par exemple, pour l'installation intégrée, vous exécutez le programme d'installation pour créer un cluster de basculement à un seul nœud. Puis, vous exécutez à nouveau le programme d'installation pour chaque nœud que vous voulez ajouter au cluster. L'installation avancée/entreprise se compose de deux étapes. L'étape de préparation prépare tous les nœuds du cluster de basculement pour qu'ils soient opérationnels. Les nœuds sont définis et préparés pendant cette étape initiale. Après avoir préparé les nœuds, l'étape de fin est exécutée sur le nœud actif – le nœud qui possède le disque partagé – pour terminer la création de l'instance de cluster de basculement et la rendre opérationnelle.

Voir aussi

Tâches

Procédure : créer un cluster de basculement SQL Server (programme d'installation)

Concepts

Avant l'installation du clustering de basculement
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Mise à niveau d'un cluster de basculement SQL Server 2008

Mise à niveau d'un cluster de basculement SQL Server 2008 |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Installation d'un cluster de basculement SQL Server 2008 >

SQL Server prend en charge la mise à niveau des clusters de basculement du Moteur de base de données et d'Analysis Services à partir de SQL Server 2000 et SQL Server 2005 séparément sur tous les nœuds de cluster de basculement.

Voici les détails de prise en charge :

  • La mise à niveau est prise en charge par le biais de l'interface utilisateur et à partir de l'invite de commandes. Pour plus d'informations, consultez Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation) et Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

  • Mise à niveau à partir de SQL Server 2005 — Vous pouvez exécuter une mise à niveau à partir de l'invite de commandes sur chaque nœud de cluster de basculement. Vous pouvez aussi utiliser l'interface utilisateur du programme d'installation pour mettre à niveau chaque nœud de cluster. Si les fonctionnalités Recherche en texte intégral et Réplication n'existent pas sur l'instance mise à niveau, elles seront automatiquement installées, sans option pour les omettre.

  • Mise à niveau à partir de SQL Server 2005 — Similaire à une mise à niveau à partir de SQL Server 2005 : vous pouvez exécuter une mise à niveau à partir de l'invite de commandes sur chaque nœud de cluster de basculement ou utiliser l'interface utilisateur du programme d'installation pour mettre à niveau chaque nœud de cluster. La prise en charge est assurée pour les scénarios 32 bits uniquement. Les mises à niveau de cluster de basculement à partir de SQL Server 2000 (64 bits) ne sont pas prises en charge. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition.

  • Installation de Service Packs - Vous devez appliquer les Service Packs et correctifs logiciels SQL Server aux clusters de basculement SQL Server 2008 séparément sur tous les nœuds.

  • Les scénarios suivants ne sont pas pris en charge dans SQL Server 2008 :

    • Vous ne pouvez pas effectuer une migration à partir d'une instance autonome de SQL Server vers un cluster de basculement SQL Server 2008.

    • Vous ne pouvez pas ajouter de fonctionnalités à un cluster de basculement SQL Server 2008, par exemple ajouter le Moteur de base de données à un cluster de basculement existant Analysis Services uniquement.

    • Vous ne pouvez pas rétrograder un nœud de cluster de basculement SQL Server 2008 à une instance autonome de SQL Server 2008.

  • Pour plus d'informations, consultez Mise en route avec le clustering de basculement de SQL Server 2008.

Voir aussi

Tâches

Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation)

Référence

Mises à niveau de la version et de l'édition

Concepts

Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Maintenance d'un cluster de basculement

Maintenance d'un cluster de basculement |
 | Voir aussi
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 >

Après avoir installé un cluster de basculement SQL Server, vous pouvez le changer ou le réparer au moyen du programme d'installation SQL Server. Par exemple, vous pouvez ajouter des nœuds supplémentaires à une instance cluster de basculement, exécuter une instance en cluster en tant qu'instance indépendante ou supprimer un nœud d'une configuration d'instance en cluster.

Ajout d'un nœud à une instance cluster de basculement existante

Le programme d'installation de SQL Server permet de maintenir une instance cluster de basculement existante. Si vous choisissez cette option, vous pouvez ajouter d'autres nœuds à votre configuration de cluster de basculement en exécutant le programme d'installation de SQL Server sur l'ordinateur que vous souhaitez ajouter au cluster. Pour plus d'informations, consultez Procédure : créer un cluster de basculement SQL Server (programme d'installation) et Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Suppression d'un nœud dans une instance cluster de basculement existante

Vous pouvez supprimer un nœud d'une configuration de cluster de basculement en exécutant le programme d'installation SQL Server sur l'ordinateur que vous souhaitez supprimer du cluster. Chaque nœud d'une configuration de cluster de basculement SQL Server est considéré comme équivalent, sans aucune dépendance sur d'autres nœuds du cluster, ce qui vous permet de supprimer n'importe quel nœud. Il n'est pas nécessaire qu'un nœud endommagé soit disponible pour le supprimer : la suppression ne désinstalle aucun binaire SQL Server du nœud indisponible. Un nœud supprimé peut être à nouveau ajouté à un cluster de basculement à tout moment. Pour plus d'informations, consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Exécution d'une instance cluster de SQL Server en tant qu'instance indépendante

En règle générale, vous exécutez une instance cluster SQL Server sous le contrôle de Microsoft Cluster Services (MSCS). Cependant, il peut s'avérer nécessaire d'exécuter une instance cluster SQL Server comme une instance indépendante. Par exemple, pour exécuter une instance SQL Server en mode mono-utilisateur, il peut être nécessaire d'exécuter une instance cluster SQL Server comme une instance indépendante au lieu de démarrer SQL Server par l'intermédiaire de MSCS. Pour se connecter à une instance cluster de SQL Server en mode autonome à l'aide de sockets, les ressources d'adresse IP et de nom réseau doivent être en ligne pour le cluster de basculement sur lequel l'instance a été installée.

Si ces ressources ne peuvent pas être en ligne, connectez-vous à l'aide des canaux nommés. Vous devez créer un alias côté client pour communiquer avec le nom du canal sur lequel l'instance de SQL Server est à l'écoute. Pour connaître le nom du canal, utilisez le Gestionnaire de configuration SQL Server.

Modification des comptes de service

Vous ne devez pas modifier les mots de passe des comptes de service SQL Server lorsqu'un nœud de cluster de basculement est arrêté ou hors ligne. Si vous êtes amené à le faire, vous devrez redéfinir le mot de passe à l'aide du Gestionnaire de configuration SQL Server lorsque tous les nœuds seront de nouveau en ligne.

Si le compte de service SQL Server n'est pas un administrateur de votre cluster, il n'est pas possible de supprimer les partages administratifs sur les nœuds du cluster. Les partages administratifs doivent être disponibles dans un cluster pour que SQL Server fonctionne.

Important :
N'utilisez pas le même compte pour le compte du service SQL Server et pour le compte MSCS. Si le mot de passe du compte MSCS change, votre installation SQL Server échouera.

Sur Windows Server 2008, des SID de service sont utilisés pour les comptes de service SQL Server. Pour plus d'informations, consultez Configuration des comptes de service Windows.

Voir aussi

Tâches

Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 1
Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 2
Procédure : supprimer une instance de cluster de basculement SQL Server (programme d'installation)

Concepts

Avant l'installation du clustering de basculement


Optimisation des performances de cluster de basculement

Optimisation des performances de cluster de basculement |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Maintenance d'un cluster de basculement >

Pour optimiser les performances lors de l'utilisation de clustering de basculement, tenez compte des points suivants :

Écriture en cache

Si le contrôleur de disque n'est pas externe à votre ordinateur organisé en clusters, vous devez désactiver l'écriture en cache dans le contrôleur pour éviter toute perte de données lors d'un basculement.

La mise en cache en écriture différée ne peut être utilisée sur des contrôleurs hôtes dans un cluster sans affecter négativement les performances. Néanmoins, si vous utilisez des contrôleurs externes, vous continuez à améliorer les performances. Les modules de disques externes ne sont pas affectés par le clustering de basculement et peuvent synchroniser correctement le cache, même via un bus SCSI.

Partage de fichiers

N'utilisez pas le même lecteur pour les partages de fichiers et les bases de données SQL Server en clusters. L'utilisation de ce lecteur peut affecter le délai de récupération et provoquer un basculement du groupe de clusters en cas de défaillance d'une ressource.

Taille maximale de mémoire

Les performances de clustering de basculement reposent sur une allocation de mémoire conséquente. La mémoire maximale théorique correspond à la mémoire totale disponible moins la mémoire pour le système d'exploitation et les autres ressources de cluster, ainsi que celles installées depuis un ordinateur local sur un nœud, divisée par les instances de Microsoft SQL Server installées. Déterminez la taille de mémoire maximale à l'aide de cette formule. Nous vous recommandons de fixer la taille maximale de mémoire de travail entre 80 et 90% par rapport à cette quantité, puis de collecter des statistiques de base pour optimiser ce paramètre.

Taille minimale de mémoire

La taille minimale de mémoire doit être définie lorsqu'il existe plusieurs instances SQL Server et que les paramètres de taille maximale de mémoire sont définis. La définition de la taille minimale de mémoire réduit le délai du basculement.

Affinité de processeur de cluster

Il est préférable d'utiliser les paramètres par défaut d'affinité de processeur dans la plupart des cas. Toutefois, si l'installation dépasse les seuils maximaux de performance recommandés, définissez l'affinité de processeur de cluster en utilisant un scénario N-1.

Ports IP fixes et paramètres de mémoire fixes

Utilisez des ports IP fixes et des paramètres de mémoire fixes.

Voir aussi

Autres ressources

Définition des options de configuration de serveur


Utilisation des outils SQL Server dans le clustering de basculement

Utilisation des outils SQL Server dans le clustering de basculement |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Maintenance d'un cluster de basculement >

Vous pouvez utiliser un grand nombre d'outils et de services Microsoft SQL Server dans le clustering de basculement. Toutefois, avant de commencer, il convient de passer en revue les quelques éléments suivants :

Requêtes de texte intégral

Pour utiliser le service Microsoft Search et effectuer des requêtes de texte intégral lors du clustering de basculement, respectez les conditions suivants :

  • Pour que les requêtes de texte intégral fonctionnent sur les clusters de basculement, une instance de SQL Server doit être exécutée sur le même compte système sur tous les nœuds du cluster de basculement.

    Remarque :
    Notez que cette condition n'est pas propre au service Microsoft mais qu'elle est générale au clustering de basculement.

  • Pour modifier le compte de démarrage de SQL Server dans le cluster de basculement, vous devez utiliser le Gestionnaire de configuration SQL Server. Si vous utilisez le Panneau de configuration ou l'application Services dans Microsoft Windows pour modifier le compte de démarrage, vous altérerez la configuration en texte intégral pour SQL Server.

Gestionnaire de configuration SQL Server

Pour utiliser SQL Server Configuration Manager avec le clustering de basculement, tenez compte des éléments suivants :

  • Pour modifier le compte de démarrage de SQL Server dans le cluster de basculement, vous devez utiliser le Gestionnaire de configuration SQL Server. Si vous utilisez le Panneau de configuration ou l'application Services dans Windows, vous risquez d'altérer la configuration de votre serveur.

  • Lors de la création ou de la modification de bases de données, vous ne pourrez voir que les disques de cluster pour l'instance locale de cluster de basculement.

  • Si vous utilisez le Gestionnaire de configuration SQL Server pour réinitialiser les propriétés du compte de service SQL Server, vous serez invité à redémarrer SQL Server. Dans une configuration de cluster de basculement, ceci entraînera la mise hors connexion des ressources en texte SQL Server intégral et des ressources de l'Agent SQL Server. Celles-ci ne seront toutefois pas remises en ligne lors du redémarrage de SQL Server. Vous devrez donc redémarrer ces ressources manuellement à l'aide de l'Administrateur de cluster Windows.

SQL Server Management Studio

  • Si vous explorez une table à l'aide de SQL Server Management Studio et que vous perdez la connexion à SQL Server durant un basculement, vous recevez le message d'erreur : « Échec de la liaison de communication ». Vous devez alors appuyer sur la touche Échap et annuler les modifications avant de quitter la fenêtre de SQL Server Management Studio.

    Vous ne pouvez ni exécuter une requête, ni enregistrer des modifications, ni modifier la grille.

Gestionnaire de contrôle des services

Utilisez le Gestionnaire de contrôle des services pour démarrer ou arrêter une instance cluster de SQL Server. Vous ne pouvez pas suspendre une instance cluster de SQL Server.

Générateur de profils SQL Server

Vous pouvez utiliser le Générateur de profils SQL Server avec clustering de basculement. Toutefois, si un basculement a lieu pendant que vous exécutez une trace Générateur de profils SQL Server, vous devrez redémarrer la trace une fois que le serveur revient en ligne.

SQL Mail

SQL Mail peut être configuré à distance par le Gestionnaire de configurations.

Voir aussi

Autres ressources

Features Supported by Editions of SQL Server 2005


Dépannage de clusters de basculement

Dépannage de clusters de basculement |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Maintenance d'un cluster de basculement >

Cette rubrique aborde les sujets suivants :

  • Étapes de dépannage de base

  • Récupération à partir d'une défaillance de cluster de basculement

  • Résolution des principaux problèmes de gestion de clusters de basculement

  • Utilisation de procédures stockées étendues et d'objets COM

Étapes de dépannage de base

Lorsque vous utilisez le clustering de basculement de SQL Server, gardez à l'esprit que le cluster de serveurs comprend une instance de clustering de basculement qui s'exécute sous Microsoft Cluster Services (MSCS). L'instance SQL Server peut être hébergée par des nœuds Microsoft MSCS qui fournissent le cluster de serveurs Microsoft.

Si les nœuds qui hébergent le cluster de serveurs connaissent des problèmes, ceux-ci peuvent se répercuter sur votre instance de cluster de basculement. Pour analyser et résoudre ces problèmes, dépannez un cluster de basculement SQL Server comme suit :

  1. Matériel : passez en revue les journaux des événements système Microsoft Windows.

  2. Système d'exploitation : examinez les journaux des événements d'application et des événements système Windows.

  3. Réseau : examinez les journaux des événements d'application et des événements système Windows. Pour vérifier la configuration actuelle, consultez l'article de la Base de connaissances Configuration de carte réseau privée recommandée sur un cluster de serveurs.

  4. Sécurité : examinez les journaux des événements d'applications et de sécurité Windows.

  5. MSCS : examinez les journaux de cluster, des événements d'application et des événements système Windows.

  6. SQL Server : effectuez un dépannage normal après avoir vérifié qu'aucun problème n'affecte les paramètres fondamentaux du matériel, du système d'exploitation, du réseau, de la sécurité et de MSCS.

Récupération à partir d'une défaillance de cluster de basculement

Généralement, une défaillance de cluster de basculement est due à l'une des deux causes suivantes :

  • Défaillance matérielle dans un nœud d'un cluster composé de deux nœuds. Cette erreur peut être due à une défaillance de la carte SCSI ou du système d'exploitation.

    Pour effectuer une récupération à partir de cette défaillance, supprimez le nœud défaillant du cluster de basculement à l'aide du programme d'installation de SQL Server, mettez l'ordinateur hors connexion et résolvez la défaillance matérielle, puis réinstallez l'ordinateur et ajoutez le nœud réparé à l'instance de cluster de basculement.

    Pour plus d'informations, consultez Procédure : créer un cluster de basculement SQL Server (programme d'installation) et Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 1.

  • Échec du système d'exploitation. Dans ce cas, le nœud est hors ligne, mais il n'est pas rompu de manière irrémédiable.

    Pour effectuer une récupération à partir d'une défaillance du système d'exploitation, récupérez le nœud et testez le basculement. Si l'instance SQL Server ne bascule pas correctement, vous devez utiliser le programme d'installation de SQL Server pour supprimer SQL Server du cluster de basculement, effectuer les réparations nécessaires, réinstaller l'ordinateur, puis ajouter le nœud réparé à l'instance de cluster de basculement.

    Ce type de récupération à partir d'une défaillance du système d'exploitation peut prendre du temps. Si l'échec du système d'exploitation peut être facilement récupéré, évitez toutefois d'utiliser cette technique.

    Pour plus d'informations, consultez Procédure : créer un cluster de basculement SQL Server (programme d'installation) et Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 2.

Résolution des problèmes courants

La liste ci-dessous décrit les problèmes d'utilisation les plus courants et explique comment les résoudre.

Problème : utilisation incorrecte de la syntaxe d'invite de commandes pour installer SQL Server

Erreur 1 : Il est difficile de diagnostiquer les erreurs du programme d'installation lorsque vous utilisez le commutateur /qn à partir de l'invite de commandes, dans la mesure où /qncelui-ci supprime toutes les boîtes de dialogue et les messages d'erreur du programme d'installation. Si le commutateur /qn est spécifié, tous les messages d'installation, y compris les messages d'erreur, sont écrits dans les fichiers journaux de l'installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Solution 1 : utilisez le commutateur /qb à la place du commutateur /qn. Si vous utilisez le commutateur /qb, l'interface utilisateur de base s'affichera à chaque étape, ainsi que les messages d'erreur.

Problème : SQL Server ne peut pas se connecter au réseau après avoir fait l'objet d'une migration vers un autre nœud

Erreur 1 : les comptes de service SQL Server ne sont pas en mesure de contacter un contrôleur de domaine.

Solution 1 : dans les journaux d'événements, recherchez des signes indiquant l'existence de problèmes réseau, tels que des défaillances de carte ou des problèmes affectant le service DNS. Vérifiez que vous pouvez exécuter une commande ping sur le contrôleur de domaine.

Erreur 2 : les mots de passe des comptes de service SQL Server ne sont pas identiques sur tous les nœuds du cluster ou le nœud ne redémarre pas un service SQL Server qui a fait l'objet d'une migration depuis un nœud défaillant.

Solution 2 : modifiez les mots de passe des comptes de service SQL Server à l'aide du Gestionnaire de configuration SQL Server. Si vous n'effectuez pas cette opération et que vous modifiez les mots de passe des comptes de service SQL Server sur un nœud, vous devez également modifier les mots de passe sur tous les autres nœuds. Le Gestionnaire de configuration de SQL Server effectue cette opération automatiquement.

Problème : SQL Server ne peut pas accéder aux disques organisés en clusters

Erreur 1 : les microprogrammes ou les pilotes ne sont pas mis à jour sur tous les nœuds.

Solution 1 : vérifiez que tous les nœuds utilisent les versions adéquates des microprogrammes et les mêmes versions des pilotes.

Erreur 2 : un nœud ne peut pas récupérer des disques de clusters qui ont fait l'objet d'une migration depuis un nœud ayant échoué sur un disque de clusters partagés utilisant une lettre de lecteur différente.

Solution 2 : les lettres de lecteur de disque pour les disques de clusters doivent être identiques sur les deux serveurs. Si ce n'est pas le cas, examinez l'installation d'origine du système d'exploitation et MSCS (Microsoft Cluster Service).

Problème : la défaillance d'un service SQL Server provoque un basculement

Solution : pour empêcher que la défaillance de services spécifiques provoque le basculement du groupe SQL Server, configurez ces services à l'aide de l'Administrateur de cluster dans Windows, comme suit :

  • Désactivez la case à cocher Affecter le groupe sur l'onglet Avancé de la boîte de dialogue Propriétés de texte intégral. Cependant, si SQL Server provoque un basculement, le service de recherche en texte intégral redémarre.

Problème : SQL Server ne démarre pas automatiquement.

Solution : utilisez l'Administrateur de cluster dans MSCS. Le service SQL Server doit être paramétré de manière à démarrer manuellement ; l'Administrateur de cluster doit être configuré dans MSCS de façon à démarrer le service SQL Server.

Problème : le nom de réseau est hors ligne et vous ne pouvez pas vous connecter à SQL Server avec TCP/IP

Erreur 1 : le service DNS a échoué à cause d'une ressource cluster définie de façon à requérir ce service.

Solution 1 : remédiez aux problèmes DNS.

Erreur 2 : un nom en double existe sur le réseau.

Solution 2 : utilisez NBTSTAT pour rechercher le nom en double, puis résolvez le problème.

Erreur 3 : SQL Server ne se connecte pas à l'aide de canaux nommés.

Solution 3 : pour vous connecter à l'aide de canaux nommés, créez un alias avec le Gestionnaire de configuration de SQL Server pour vous connecter à l'ordinateur approprié. Par exemple, si vous disposez d'un cluster à deux nœuds (Node A et Node B) et d'une instance de cluster de basculement (Virtsql) avec une instance par défaut, vous pouvez vous connecter au serveur dont la ressource de nom réseau est hors connexion, en procédant comme suit :

  1. Déterminez le nœud sur lequel s'exécute le groupe contenant l'instance de SQL Server, à l'aide de l'Administrateur de cluster. Dans cet exemple, il s'agit de Node A.

  2. Démarrez le service SQL Server sur cet ordinateur à l'aide de net start. Pour plus d'informations sur l'utilisation de net start, consultez Démarrage manuel de SQL Server.

  3. Démarrez le Gestionnaire de configuration SQL Server SQL Server sur Node A. Examinez le nom du canal sur lequel le serveur est à l'écoute. Il doit être similaire à \\.\$$\VIRTSQL\canal\sql\query.

  4. Sur l'ordinateur client, démarrez le Gestionnaire de configuration SQL Server.

  5. Créez un alias SQLTEST1 pour vous connecter à ce nom de canal via les canaux nommés. Pour cela, entrez Node A comme nom de serveur et modifiez le nom du canal de la manière suivante : \\.\canal\$$\VIRTSQL\sql\query.

  6. Connectez-vous à cette instance à l'aide de l'alias SQLTEST1 comme nom de serveur.

Problème : le programme d'installation de SQL Server échoue sur un cluster avec l'erreur 11001

Erreur : une clé de Registre orpheline dans [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.X\Cluster]

Solution : assurez-vous que la ruche du Registre MSSQL.X n'est pas en cours d'utilisation, puis supprimez la clé de cluster.

Problème : erreur d'installation de cluster : « Le programme d'installation ne dispose pas des privilèges suffisants pour accéder au répertoire : <lecteur>\Microsoft SQL Server. Impossible de poursuivre l'installation. Ouvrez une session en tant qu'administrateur ou contactez votre administrateur système. »

Erreur : cette erreur est due à un lecteur partagé SCSI mal partitionné.

Solution : recréez une partition unique sur le disque partagé, comme suit :

  1. Supprimez la ressource disque du cluster.

  2. Supprimez toutes les partitions du disque.

  3. Dans les propriétés du disque, vérifiez que celui-ci est un disque de base.

  4. Créez une partition sur le disque partagé, formatez-le, puis affectez-lui une lettre de lecteur.

  5. Ajoutez le disque au cluster à l'aide de l'Administrateur de cluster (cluadmin).

  6. Exécutez le programme d'installation de SQL Server.

Problème : les applications ne parviennent pas à inscrire les ressources SQL Server dans une transaction distribuée

Erreur : comme Microsoft Distributed Transaction Coordinator (MS DTC) n'est pas complètement configuré dans Windows, les applications peuvent échouer dans leur tentative d'inscription des ressources SQL Server dans une transaction distribuée. Ce problème peut affecter les serveurs liés, les requêtes distribuées et les procédures stockées distantes qui utilisent des transactions distribuées.

Solution : pour éviter ce type de problème, vous devez activer intégralement les services MS DTC sur le serveur où SQL Server est installé.

Pour activer correctement MS DTC, procédez comme suit :

  1. Dans le Panneau de configuration, ouvrez Outils d'administration, puis Gestion de l'ordinateur.

  2. Dans le volet gauche de Gestion de l'ordinateur, développez Services et applications, puis cliquez sur Services.

  3. Dans le volet droit de Gestion de l'ordinateur, cliquez avec le bouton droit sur Distributed Transaction Coordinator, puis sélectionnez Propriétés.

  4. Dans la fenêtre Coordinateur de transactions distribuées, cliquez sur l'onglet Général, puis sur Arrêter pour arrêter le service.

  5. Dans la fenêtre Coordinateur de transactions distribuées, cliquez sur l'onglet Ouverture de session, puis définissez le compte d'ouverture de session NT AUTHORITY\NetworkService.

  6. Cliquez sur Appliquer, puis sur OK pour fermer la fenêtre Coordinateur de transactions distribuées. Fermez la fenêtre Gestion de l'ordinateur. Fermez la fenêtre Outils d'administration.

Remarque :
Dans le cas des installations de SQL Server sur des ordinateurs participant à un cluster de basculement, vous devez activer MS DTC complètement et l'organiser en clusters avant d'exécuter le programme d'installation. Si MS DTC n'est pas organisé en clusters, le programme d'installation échoue. Avant d'exécuter le programme d'installation, utilisez l'Administrateur de cluster de Microsoft pour vérifier que MS DTC a été organisé en clusters.

Utilisation de procédures stockées étendues et d'objets COM

Lorsque vous utilisez des procédures stockées étendues avec une configuration de clustering de basculement, toutes les procédures stockées étendues doivent être installées sur un disque de cluster dépendant de SQL Server. Ceci permet d'assurer que lors du basculement d'un nœud, les procédures stockées étendues peuvent toujours être utilisées.

Si les procédures stockées étendues utilisent des composants COM, l'administrateur doit enregistrer les composants COM sur chaque nœud du cluster. Les informations pour le chargement et l'exécution des composants COM doivent figurer dans le Registre du nœud actif, afin que les composants soient créés. Dans le cas contraire, les informations sont conservées dans le Registre de l'ordinateur sur lequel les composants COM ont été enregistrés en premier lieu.

Voir aussi

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server

Autres ressources

How Extended Stored Procedures Work
Execution Characteristics of Extended Stored Procedures


Procédures pour le clustering de basculement

Procédures pour le clustering de basculement |
 | Voir aussi
Planification d'une installation SQL Server > Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 >

Les rubriques Procédures de cette section contiennent des informations sur la création ou la gestion d'un cluster de basculement. Pour créer un cluster de basculement SQL Server, vous devez d'abord configurer les services MSCS (Microsoft Cluster Services) Microsoft à l'aide de l'Administrateur de clusters.

Voir aussi

Concepts

Mise en route avec le clustering de basculement de SQL Server 2008
Avant l'installation du clustering de basculement


Procédure : créer un cluster de basculement SQL Server (programme d'installation)

Procédure : créer un cluster de basculement SQL Server (programme d'installation) |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

L'Assistant Installation de SQL Server vous permet d'installer un cluster de basculement SQL Server sur un nœud unique.

Utilisez la procédure suivante pour créer une instance de cluster de basculement.

Pour ajouter ou supprimer des nœuds à une instance de cluster de basculement existante, consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Pour l'installation à distance, consultez Mises à niveau de la version et de l'édition.

Pour installer une instance autonome de SQL Server, consultez Procédure : installer SQL Server 2008 (programme d'installation).

Configuration requise

Avant de commencer, consultez les rubriques suivantes dans la documentation en ligne de SQL Server :

  • Planification d'une installation SQL Server

  • Avant l'installation du clustering de basculement

  • Considérations sur la sécurité pour une installation SQL Server

  • Vous devez absolument lire et suivre rigoureusement les instructions de l'article de la Base de connaissances Configuration de carte réseau privé recommandée sur un cluster de serveurs .

    Remarque :
    Souvenez-vous de l'emplacement du lecteur partagé dans l'Administrateur de cluster avant d'exécuter le programme d'installation de SQL Server. Vous aurez besoin de ces informations pour créer un cluster de basculement.

Pour installer SQL Server 2008

  1. Insérez le support d'installation SQL Server et, dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis redémarrez le programme d'installation de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation démarre le Centre d'installation SQL Server. Pour créer une installation de SQL Server 2008, cliquez sur Nouvelle installation ou ajouter des fonctionnalités à une installation existante.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. Dans la page Clé du produit, cliquez sur une case d'option pour indiquer si vous installez une édition gratuite de SQL Server ou si vous disposez d'une clé PID pour une version de production du produit. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008.

  7. Dans la page Termes de Licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour quitter le programme d'installation, cliquez sur Annuler.

  8. L'Assistant Installation installera les composants SQL Server requis s'ils ne sont pas déjà présents sur l'ordinateur. Cela comprend les éléments suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  9. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive. Lorsque la vérification est terminée, cliquez sur Suivant pour poursuivre.

  10. Dans la page Sélection de fonctionnalités, sélectionnez les composants que vous voulez installer. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Vous pouvez choisir n'importe quelle combinaison de cases à cocher, mais seuls Moteur de base de données et Analysis Services prennent en charge le clustering de basculement. Les autres composants s'exécutent sur un nœud de cluster de basculement unique.

    Vous pouvez spécifier un répertoire personnalisé pour les composants partagés en utilisant le champ situé au bas de cette page. Pour modifier le chemin d'installation des composants partagés, mettez à jour le nom du chemin d'accès dans le champ fourni en bas de la boîte de dialogue ou cliquez sur le bouton Parcourir pour accéder à un répertoire d'installation. Le chemin d'installation par défaut est C:\Program Files\Microsoft SQL Server\.

  11. Dans la page Configuration de l'instance, spécifiez s'il faut installer une instance par défaut ou une instance nommée. Pour plus d'informations, consultez Configuration d'une instance.

    Suffixe de l'ID d'instance — Par défaut, le nom de l'instance est utilisé comme suffixe de l'ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et le suffixe de l'ID d'instance seront MSSQLSERVER. Pour utiliser un suffixe d'ID d'instance non défini par défaut, activez la case à cocher Suffixe de l'ID d'instance et entrez une valeur.

    Remarque :
    Les instances autonomes classiques de SQL Server 2008, qu'il s'agisse d'instances par défaut ou d'instances nommées, n'utilisent pas de valeur non définie par défaut pour la case à cocher Suffixe de l'ID d'instance.

    Répertoire racine de l'instance — Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, utilisez le champ fourni ou cliquez sur Parcourir pour rechercher un dossier d'installation.

    Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

    Instances et fonctionnalités détectées - La grille affiche les instances de SQL Server qui se trouvent sur l'ordinateur où le programme d'installation s'exécute. Si une instance par défaut est déjà installée sur l'ordinateur, vous devez installer une instance nommée de SQL Server 2008. Pour continuer, cliquez sur Suivant.

  12. Utilisez la page Groupe de ressources de cluster pour spécifier le disque où les ressources du serveur virtuel SQL Server seront hébergées. Pour spécifier le nom du groupe de ressources de cluster SQL Server, vous avez le choix entre deux options :

    • Utilisez la zone de liste déroulante pour spécifier un groupe existant à utiliser.

    • Tapez le nom d'un groupe à créer. Notez que le nom « Stockage disponible » n'est pas un nom de groupe valide.

  13. Dans la page Sélection du disque du cluster, sélectionnez la ressource de disque de cluster partagée pour votre cluster de basculement SQL Server. Le disque de cluster est l'emplacement où les données SQL Server seront placées. Un seul disque peut être spécifié. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affiche. Il est recommandé de ne pas procéder à l'installation dans cette ressource. La grille des disques partagés disponibles affiche une liste de disques disponibles, indique si chacun d'eux est qualifié en tant que disque partagé et fournit une description de chaque ressource de disque. Pour continuer, cliquez sur Suivant.

  14. Dans la page Sélection du réseau du cluster, spécifiez les ressources réseau de votre instance de cluster de basculement :

    • Nom réseau du cluster de basculement SQL Server — Il s'agit du nom identifiant votre instance de cluster de basculement sur le réseau.

    • Paramètres réseau — Spécifiez le type IP et l'adresse IP de votre instance de cluster de basculement.

    Pour continuer, cliquez sur Suivant.

  15. Utilisez la page Stratégie de sécurité du cluster pour spécifier des groupes de domaines locaux ou globaux pour les services cluster. Toutes les autorisations de ressources sont gérées par des groupes au niveau du domaine qui incluent des comptes de service SQL Server en tant que membres de groupe. Pour plus d'informations sur les fonctionnalités des ID de sécurité (SID) d'un service sur Windows Server 2008, consultez Configuration des comptes de service Windows. Dans Windows Server 2003, spécifiez des groupes de domaines pour les services SQL Server. Pour continuer, cliquez sur Suivant.

  16. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez et compare cet espace à l'espace disque disponible sur l'ordinateur où le programme d'installation s'exécute. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  17. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  18. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

    Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte d'ouverture de session pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  19. Utilisez l'onglet Configuration du serveur - Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  20. Utilisez la page Configuration du Moteur de base de données — Mise en service du compte pour spécifier les éléments suivants :

    • Mode de sécurité - sélectionnez l'authentification Windows ou le mode d'authentification mixte pour votre instance de SQL Server. Si vous sélectionnez Mode d'authentification mixte, vous devez fournir un mot de passe fort pour le compte administrateur système SQL Server intégré.

      Lorsque la connexion d'un périphérique à SQL Server est établie, le mécanisme de sécurité est le même pour l'authentification Windows et le mode mixte. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    • Administrateurs SQL Server - Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  21. Utilisez la page Configuration du Moteur de base de données – Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration du moteur de base de données – Répertoires de données.

  22. Utilisez la page Configuration du Moteur de base de données - FILESTREAM pour activer FILESTREAM pour votre instance de SQL Server. Pour plus d'informations sur FILESTREAM, consultez Configuration du moteur de base de données - Filestream. Pour continuer, cliquez sur Suivant.

  23. Utilisez la page Configuration d'Analysis Services — Attribution de privilèges d'accès aux comptes pour spécifier les utilisateurs ou comptes qui ont les autorisations d'administrateur pour Analysis Services. Vous devez spécifier au moins un administrateur système pour Analysis Services. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour Analysis Services. Pour plus d'informations, consultez Configuration Analysis Services – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  24. Utilisez la page Configuration du Analysis Services — Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration de Analysis Services – Répertoires de données.

  25. Utilisez la page Configuration de Reporting Services pour spécifier le type d'installation de Reporting Services à créer. Vous pouvez choisir entre les options suivantes :

    • Configuration par défaut en mode Natif

    • Configuration par défaut en mode SharePoint

    • Installation de Reporting Services non configurée

    Pour plus d'informations sur les modes de configuration de Reporting Services, consultez Options d'installation du serveur de rapports.

  26. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  27. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  28. La page Prêt pour l'installation affichage une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  29. Au cours de l'installation, la page Progression de l'installation fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  30. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  31. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Configurer votre nouvelle installation SQL Server — Pour réduire la surface d'exposition attaquable d'un système, SQL Server sélectionne les services et les fonctionnalités clés à installer et à activer. Pour plus d'informations, consultez Présentation de la configuration de la surface d'exposition sur MSDN.

Pour plus d'informations sur l'emplacement des fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Voir aussi

Concepts

Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation)

Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation) |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Utilisez cette procédure pour gérer les nœuds d'une instance de cluster de basculement SQL Server existante.

Important :
Pour mettre à jour ou supprimer un cluster de basculement SQL Server, vous devez être un administrateur local autorisé à se connecter en tant que service sur tous les nœuds du cluster de basculement. Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Pour afficher les étapes de procédure pour ajouter ou supprimer des nœuds, sélectionnez une des opérations suivantes :

  • Ajouter un nœud à un cluster de basculement SQL Server 2008 existant

  • Supprimer un nœud d'un cluster de basculement SQL Server 2008 existant

Ajouter un nœud

Pour ajouter un nœud à un cluster de basculement SQL Server 2008 existant

  1. Insérez le support d'installation SQL Server et, dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis redémarrez le programme d'installation de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour ajouter un nœud à une instance de cluster de basculement existante, cliquez sur Installation dans le volet gauche. Sélectionnez ensuite Ajouter un nœud à un cluster de basculement SQL Server.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. Dans la page Clé de produit (Product Key), spécifiez la clé PID pour une version de production du produit. Notez que la clé de produit que vous entrez pour cette installation doit se rapporter à la même édition de SQL Server 2008 que celle installée sur le nœud actif.

  7. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour mettre fin au programme d'installation, cliquez sur Annuler.

  8. L'Assistant Installation installera les composants SQL Server requis s'ils ne sont pas déjà présents sur l'ordinateur. Cela comprend les éléments suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  9. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive. Lorsque la vérification est terminée, cliquez sur Suivant pour poursuivre.

  10. Dans la page Configuration du nœud de clusters, utilisez la zone de liste déroulante pour spécifier le nom de l'instance de cluster de basculement SQL Server 2008 qui sera modifiée pendant cette opération d'installation.

  11. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées. Pour les installations de cluster de basculement, les informations de nom de compte et de type de démarrage seront préremplies dans cette page, en fonction des paramètres indiqués pour le nœud actif. Vous devez fournir des mots de passe pour chaque compte. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  12. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez et compare cet espace à l'espace disque disponible sur l'ordinateur où le programme d'installation s'exécute. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  13. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  14. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  15. La page Prêt pour l'installation affichage une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation.

  16. Au cours de l'installation, la page Progression de l'installation fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  17. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  18. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Supprimer un nœud

Pour supprimer un nœud d'un cluster de basculement SQL Server 2008 existant

  1. Insérez le support d'installation SQL Server. Dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis redémarrez le programme d'installation de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour ajouter un nœud à une instance de cluster de basculement existante, cliquez sur Installation dans le volet gauche, puis sélectionnez Ajouter un nœud à un cluster de basculement SQL Server.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. L'Assistant Installation installera les composants requis SQL Server s'ils ne sont pas déjà présents sur l'ordinateur. Cela comprend les éléments suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  7. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive. Lorsque la vérification est terminée, cliquez sur Suivant pour poursuivre.

  8. Dans la page Configuration du nœud de clusters, utilisez la zone de liste déroulante pour spécifier le nom de l'instance de cluster de basculement SQL Server 2008 qui sera modifiée pendant cette opération d'installation. Le nœud qui sera supprimé sera répertorié dans le champ Nom de ce nœud.

  9. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  10. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  11. La page Prêt pour l'installation affiche une arborescence des options spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Supprimer.

  12. Pendant l'opération de suppression, la page Progression fournit des informations sur l'état.

  13. La page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer l'installation de SQL Server, cliquez sur Fermer. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Voir aussi

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : réparer une installation défectueuse de SQL Server 2008

Procédure : réparer une installation défectueuse de SQL Server 2008 |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Utilisez cette procédure pour réparer une installation de SQL Server 2008 endommagée.

Avant de continuer, pour les clusters de basculement SQL Server, consultez ces informations importantes :

  • La réparation doit être effectuée sur des nœuds de cluster individuels.

  • Pour réparer un nœud de cluster de basculement après une préparation ayant échoué, utilisez Supprimer un nœud et effectuez à nouveau la préparation. Consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Titre de procédure

  1. Lancez le programme d'installation de SQL Server (setup.exe) à partir du support d'installation SQL Server 2008.

  2. Après avoir vérifié les composants requis et le système, le programme d'installation affiche la page Centre d'installation SQL Server.

  3. Cliquez sur Maintenance dans la zone de navigation gauche, puis sur Réparer pour démarrer la réparation.

  4. La règle de support d'installation et les routines de fichiers sont exécutées pour garantir que les composants requis sont installés sur votre système et que les règles de validation du programme d'installation ont été correctement exécutées sur l'ordinateur. Cliquez sur OK ou sur Installer pour continuer.

  5. Dans la page Sélectionner une instance, sélectionnez l'instance à réparer, puis cliquez sur Suivant pour continuer.

  6. Les règles de réparation sont exécutées pour valider l'opération. Pour continuer, cliquez sur Suivant.

  7. La page Prêt à réparer indique que l'opération peut se poursuivre. Pour continuer, cliquez sur Réparer.

  8. La page Progression de la réparation indique l'état de l'opération de réparation. La page Terminé indique que l'opération est terminée.

Voir aussi

Concepts

Dépannage d'une installation de SQL Server
Dépannage de clusters de basculement
Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : supprimer une instance de cluster de basculement SQL Server (programme d'installation)

Procédure : supprimer une instance de cluster de basculement SQL Server (programme d'installation) |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Suivez cette procédure pour désinstaller une instance de cluster de basculement SQL Server.

Important :
Pour mettre à jour ou supprimer un cluster de basculement SQL Server, vous devez être un administrateur local autorisé à se connecter en tant que service sur tous les nœuds du cluster de basculement.

Avant de commencer

Prenez en compte les points importants suivants avant de désinstaller un cluster de basculement SQL Server :

  • Sur un ordinateur exécutant simultanément SQL Server 2008 et des versions antérieures de SQL Server, Enterprise Manager et d'autres programmes qui dépendent de SQL-DMO peuvent être désactivés, Cette situation peut se produire dans les cas suivants :

    • Installations côte à côte de SQL Server 2008, SQL Server 2000, et/ou de SQL Server 7.0, où l'une des versions est désinstallée.

    • Installations côte à côte de SQL Server 2000 avec SQL Server 2008, où SQL Server 2000 est installé après SQL Server 2008.

    Ce problème est dû à la suppression de l'inscription pour la bibliothèque SQL Server 2008 SQL-DMO COM. Pour réactiver SQL Server 2000 Enterprise Manager et d'autres programmes avec des liens de dépendance SQL-DMO, inscrivez SQL-DMO en exécutant « regsvr32.exe sqldmo.dll » à partir d'une invite de commandes.

  • Si SQL Server 2000 et SQL Server 2008 sont installés côte à côte dans un environnement en cluster, vous ne devez pas désinstaller SQL Server Native Client si vous désinstallez SQL Server 2008. La DLL de ressources SQL Server de SQL Server 2008 utilise toujours SQL Server Native Client pour se connecter à SQL Server. Lorsque SQL Server 2008 est installé, la DLL de ressource de cluster SQL Server est mise à niveau. Lors de la désinstallation de SQL Server 2008, la DLL de ressources SQL Server n'est pas remplacée par la version requise par SQL Server 2000. Si vous laissez SQL Server Native Client sur les nœuds du cluster, vous permettez à la DLL de ressources SQL Server de continuer à se connecter aux instances de SQL Server 2000.

  • Si SQL Server Native Client est désinstallé par accident, les ressources SQL Server ne pourront pas démarrer. Pour réinstaller SQL Server Native Client, exécutez le programme d'installation SQL Server pour installer les éléments requis de SQL Server.

  • Si vous avez désinstallé un cluster de basculement comportant plusieurs ressources de cluster IP SQL, vous devez supprimer les ressources IP SQL supplémentaires à l'aide de l'administrateur de clusters.

Pour plus d'informations sur la syntaxe de l'invite de commandes, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Pour désinstaller un cluster de basculement SQL Server

  1. Pour désinstaller un cluster de basculement SQL Server, utilisez la fonctionnalité Supprimer un nœud fournie par le programme d'installation de SQL Server pour supprimer chaque nœud individuellement. Pour plus d'informations, consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 1

Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 1 |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Dans ce scénario, la défaillance est due à une défaillance matérielle dans le nœud 1 d'un cluster à deux nœuds. Cette défaillance matérielle peut être provoquée, par exemple, par la défaillance d'un contrôleur de disque ou du système d'exploitation.

Pour effectuer une récupération suite à une défaillance matérielle dans un cluster de basculement

  1. Après la défaillance du nœud 1, le cluster de basculement de SQL Server bascule sur le nœud 2.

  2. Supprimez le nœud 1 du service MSCS (Microsoft Cluster Service) Microsoft. Pour supprimer un nœud de MSCS, à partir du nœud 2, ouvrez l'Administrateur de clusters, cliquez avec le bouton droit sur le nœud à supprimer, puis cliquez sur Supprimer le nœud.

  3. Assurez-vous que le Nœud 1 a été supprimé de la définition de cluster.

  4. Installez le nouveau matériel pour remplacer le matériel défaillant dans le nœud 1.

  5. Configurez Cluster Server (MSCS) Microsoft pour ajouter le nœud 1 au cluster existant à l'aide de l'Administrateur de clusters. Pour plus d'informations, consultez Avant l'installation du clustering de basculement.

  6. Vérifiez que les comptes administrateurs sont bien les mêmes sur tous les nœuds de clusters. Pour plus d'informations, consultez Procédure : créer un cluster de basculement SQL Server (programme d'installation).

  7. Exécutez le programme d'installation de SQL Server afin d'ajouter le nœud 1 au cluster de basculement. Pour plus d'informations, consultez Procédure : ajouter ou supprimer des nœuds dans un cluster de basculement SQL Server (programme d'installation).

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 2

Procédure : récupérer d'une défaillance de cluster de basculement dans le scénario 2 |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Dans le scénario 2, la défaillance est causée par le nœud 1, défectueux ou hors connexion, mais il n'est pas rompu de manière irrémédiable. Cela peut être dû à une défaillance du système d'exploitation ou du matériel.

Procédure

Pour récupérer à partir d'une défaillance de cluster de basculement

  1. Après la défaillance du nœud 1, le cluster de basculement de SQL Server bascule sur le nœud 2.

  2. Résolvez le problème du Nœud 1.

  3. Vérifiez que le cluster MSCS (Microsoft Cluster Service) fonctionne et que tous les nœuds sont en ligne.

  4. Tentez de faire basculer SQL Server vers le nœud récupéré. Si cette opération réussit, aucune autre action n'est nécessaire, à l'exception du test normal. Si SQL Server ne parvient pas à se connecter au nœud récupéré, consultez Dépannage de clusters de basculement.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Dépannage de clusters de basculement
Procédure : afficher les fichiers journaux d'installation de SQL Server

Autres ressources

How to: Rebuild the Master Database for SQL Server 2005
How to: Rebuild the Registry for SQL Server 2005


Procédure : activer l'authentification Kerberos sur un cluster de basculement SQL Server

Procédure : activer l'authentification Kerberos sur un cluster de basculement SQL Server |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Kerberos est un protocole d'authentification de réseau conçu pour fournir une authentification renforcée pour applications client/serveur. Kerberos fournit une base d'interopérabilité tout en améliorant la sécurité de l'authentification réseau à l'échelle de l'entreprise.

Autres ressources

Vous pouvez utiliser l'authentification Kerberos avec des instances autonomes de SQL Server ou avec des instances de cluster de basculement SQL Server. Pour plus d'informations sur l'activation de Kerberos, consultez l'article de la Base de connaissances « Comment faire pour utiliser l'authentification Kerberos dans SQL Server ».

Voir aussi

Concepts

Considérations sur la sécurité pour une installation SQL Server


Procédure : modification de l'adresse IP d'un cluster de basculement SQL Server

Procédure : modification de l'adresse IP d'un cluster de basculement SQL Server |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Pour gérer ou mettre à jour un cluster de basculement SQL Server, utilisez la fonction Ajout/suppression de programmes du Panneau de configuration. Pour plus d'informations sur la syntaxe de l'invite de commandes, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Avant de commencer, consultez la rubrique suivante dans la documentation en ligne de SQL Server : Avant l'installation du clustering de basculement.

Pour plus d'informations sur la modification de l'adresse IP des cartes réseau dans les nœuds d'un cluster, consultez cet article de la Base de connaissances Microsoft (en anglais).

Important :
Pour gérer ou mettre à jour un cluster de basculement SQL Server, vous devez être un administrateur local autorisé à ouvrir une session sous la forme d'un service sur tous les nœuds du cluster de basculement.

Pour modifier l'adresse IP d'un cluster de basculement SQL Server existant

  1. Dans le menu Démarrer, cliquez sur Exécuter, puis tapez cluadmin pour lancer l'Administrateur de cluster et vous connecter à l'instance locale.

  2. Dans le volet de gauche, développez le nœud Groupe et sélectionnez le groupe à mettre à jour.

  3. Dans le volet droit, cliquez avec le bouton droit sur l'adresse IP SQL 1 (nom d'instance du cluster de basculement), puis sélectionnez Propriétés.

  4. Cliquez sur l'onglet Paramètres, puis mettez à jour l'adresse IP SQL 1 (Nom SQL Server) dans le champ Adresse.

  5. Cliquez sur Appliquer pour appliquer la modification. Une boîte de dialogue d'avertissement peut indiquer :

    « Extension standard de l'Administrateur de cluster : Une erreur s’est produite lors de la définition des propriétés : Les propriétés étaient enregistrées mais toutes les modifications ne prendront effet qu'à la prochaine connexion de la ressource. ID d'erreur : 5024 (000013a0). »

  6. Cliquez sur OK pour effacer la boîte de dialogue Extension standard de l'Administrateur de cluster et revenir à l'Administrateur de cluster. Pour placer les ressources hors connexion, puis en ligne, procédez comme suit :

  7. Dans le volet droit, cliquez avec le bouton droit sur l'adresse IP SQL 1 (nom d'instance du cluster de basculement), puis sélectionnez Mettre hors ligne. Vous voyez l'adresse IP SQL 1 (nom d'instance du cluster de basculement), le nom de réseau SQL (nom d'instance du cluster de basculement), ainsi que SQL Server passant de l'état Connecté à l'état Déconnexion en cours, puis à l'état Déconnecté.

    Remarque :
    La propagation dans un réseau d'entreprise des modifications d'adresse IP peut prendre au moins 30 minutes. Vous devez tenter de mettre en ligne l'adresse IP SQL 1(nom d'instance du cluster de basculement) et le nom de réseau SQL (nom d'instance du cluster de basculement), puis exécuter une commande ping sur le nom d'instance du cluster de basculement, et attendre qu'il soit résolu par le DNS à la nouvelle adresse IP.

  8. Dans le volet droit, cliquez avec le bouton droit sur SQL Server, puis sélectionnez Mettre en ligne. Vous voyez l'adresse IP SQL 1 (nom d'instance du cluster de basculement), le nom de réseau SQL (nom d'instance du cluster de basculement), ainsi que SQL Server passant de l'état Déconnecté à l'état Connexion en cours, puis à l'état Connecté.

  9. Fermez l'Administrateur de cluster.

Voir aussi

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation)

Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation) |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Vous pouvez mettre à niveau un cluster de basculement SQL Server vers SQL Server 2008 à l'aide de l'Assistant Installation de SQL Server ou à partir de l'invite de commandes.

Pour avoir des informations sur la mise à niveau, consultez Mises à niveau de la version et de l'édition et Upgrading to SQL Server 2005.

Pour installer une instance autonome de SQL Server, consultez How to: Install SQL Server 2005 (Setup).

Pour avoir un exemple de syntaxe pour les installations à partir de l'invite de commandes, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Configuration requise

Avant de commencer, consultez ces informations importantes :

  • Avant l'installation du clustering de basculement

  • Consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

  • Upgrading the Database Engine

  • Article Configuration de carte réseau privé recommandée sur un cluster de serveurs dans la Base de connaissances Microsoft.

  • Dans le cas des installations locales, vous devez exécuter le programme d'installation de SQL Server en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

  • Pour procéder à la mise à niveau d'une instance de SQL Server vers un cluster de basculement SQL Server 2008, l'instance à mettre à niveau doit être un cluster de basculement. Pour mettre à niveau une instance autonome de SQL Server vers un cluster de basculement SQL Server 2008, installez un nouveau cluster de basculement SQL Server 2008, puis migrez les bases de données utilisateur depuis l'instance autonome à l'aide de l'Assistant Copie de base de données. Pour plus d'informations, consultez Utilisation de l'Assistant Copie de base de données.

  • Vous devez mettre à niveau un nœud de cluster de basculement à la fois. Pendant l'opération de mise à niveau, il y a plusieurs possibilités pour le basculement :

    • Déplacer le groupe de ressources vers un nœud qui a déjà été mis à niveau.

    • Déplacer le groupe de ressources vers un nœud qui n'a pas encore été mis à niveau.

    • Dans le cas d'un cluster de basculement à un seul nœud, le programme d'installation de SQL Server mettra le groupe de ressources SQL Server hors ligne.

  • Vous ne pouvez pas ajouter de fonctionnalités à un cluster de basculement existant.

  • La modification de l'édition d'un cluster de basculement est limitée à certains scénarios. Consultez Mises à niveau de la version et de l'édition.

  • Pour contrôler le comportement du basculement des nœuds de cluster pendant le processus de mise à niveau, exécutez l'opération de mise à niveau à partir de l'invite de commandes et utilisez le paramètre /FAILOVERCLUSTERROLLOWNERSHIP. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Pour mettre à niveau un cluster de basculement SQL Server

  1. Insérez le support d'installation SQL Server et, dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis réexécutez le programme d'installation de SQL Server 2008.

  4. Une fois que les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour mettre à niveau une instance existante de SQL Server 2008, cliquez sur Mise à niveau de SQL Server 2000 ou SQL Server 2005.

  5. Si les fichiers de support du programme d'installation sont requis, le programme d'installation de SQL Server les installera. Redémarrez votre ordinateur si vous êtes invité à le faire avant de continuer.

  6. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. À ce stade, des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  7. Dans la page Clé de produit (Product Key), cliquez sur une case d'option pour indiquer si vous effectuez une mise à niveau vers une édition gratuite de SQL Server ou si vous disposez d'une clé PID pour une version de production du produit. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008 et Mises à niveau de la version et de l'édition. Entrez votre clé PID dans la zone prévue à cet effet, puis cliquez sur Suivant pour continuer. Notez que la clé PID que vous utilisez pour une mise à niveau de cluster de basculement doit être cohérente sur tous les nœuds du cluster de basculement. Tous les nœuds de cluster de basculement d'une même instance de SQL Server doivent présenter la même édition de SQL Server.

  8. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour mettre fin au programme d'installation, cliquez sur Annuler.

  9. Dans la page Sélectionner une instance, spécifiez l'instance de SQL Server à mettre à niveau vers SQL Server 2008. Pour continuer, cliquez sur Suivant.

  10. Dans la page Sélection de composant, les fonctionnalités à mettre à niveau seront présélectionnées. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Notez que vous ne pouvez pas modifier les fonctionnalités à mettre à niveau, de même que vous ne pouvez pas ajouter de fonctionnalités pendant l'opération de mise à niveau. Pour ajouter des fonctionnalités à une instance mise à niveau de SQL Server 2008 une fois l'opération de mise à niveau terminée, consultez Procédure : ajouter des fonctionnalités à une instance de SQL Server 2008 (programme d'installation).

  11. Dans la page Configuration de l'instance, spécifiez s'il faut installer une instance par défaut ou une instance nommée. Pour plus d'informations, consultez Configuration d'une instance. Pour continuer, cliquez sur Suivant.

    Suffixe de l'ID d'instance - Par défaut, le nom de l'instance est utilisé comme suffixe de l'ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et le suffixe de l'ID d'instance seront MSSQLSERVER. Pour utiliser un suffixe d'ID d'instance non défini par défaut, activez la case à cocher Suffixe de l'ID d'instance et entrez une valeur.

    Remarque :
    Les instances autonomes classiques de SQL Server 2008, qu'il s'agisse d'instances par défaut ou d'instances nommées, n'utilisent pas de valeur non définie par défaut pour la case à cocher Suffixe de l'ID d'instance.

    Répertoire racine de l'instance - Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, utilisez le champ fourni ou cliquez sur Parcourir pour rechercher un dossier d'installation.

    Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

    Instances et fonctionnalités détectées - La grille affiche les instances de SQL Server qui se trouvent sur l'ordinateur où le programme d'installation s'exécute. Si une instance par défaut est déjà installée sur l'ordinateur, vous devez installer une instance nommée de SQL Server 2008. Pour continuer, cliquez sur Suivant.

  12. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez et compare cet espace à l'espace disque disponible sur l'ordinateur où le programme d'installation s'exécute. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  13. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  14. Dans la page Configuration du serveur – Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous mettez à niveau.

    Les informations d'authentification et de connexion seront transférées de l'instance antérieure de SQL Server. Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte d'ouverture de session pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  15. Utilisez l'onglet Configuration du serveur - Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  16. Dans la page des options de mise à niveau de recherche en texte intégral, spécifiez les options de mise à niveau pour les bases de données mises à niveau. Pour plus d'informations, consultez Options de mise à niveau de recherche en texte intégral.

  17. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  18. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées avant le début de l'opération de mise à niveau.

  19. Dans la page Rapport de mise à niveau de cluster, spécifiez le comportement du basculement lorsque le nœud est hors ligne pendant l'opération de mise à niveau. Vous pouvez choisir d'effectuer un basculement vers un nœud qui a déjà été mis à niveau ou vers un nœud présentant la version précédente. Utilisez la zone de liste déroulante Comportement du basculement pour faire votre sélection.

  20. La page Prêt pour la mise à niveau affiche une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  21. Au cours de l'installation, la page Progression fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  22. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  23. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Après la mise à niveau vers SQL Server 2008, effectuez les tâches suivantes :

  • Inscrire vos serveurs - La mise à niveau entraîne la suppression des paramètres du Registre pour l'instance antérieure de SQL Server. Après la mise à niveau, vous devez réinscrire vos serveurs.

  • Mettre à jour les statistiques - Afin d'optimiser les performances des requêtes, il est recommandé de mettre à jour les statistiques sur toutes les bases de données après une mise à niveau. Utilisez la procédure stockée sp_updatestats pour mettre à jour les statistiques des tables définies par l'utilisateur dans les bases de données SQL Server.

  • Mettre à jour les compteurs d'utilisation - Dans les versions antérieures de SQL Server, les valeurs des nombres de pages et de lignes d'index et de table peuvent s'avérer incorrectes. Pour corriger les éventuelles erreurs dans le nombre de lignes ou de pages, il est recommandé d'exécuter DBCC UPDATEUSAGE sur toutes les bases de données après une mise à niveau.

  • Configurer votre nouvelle installation SQL Server - Pour réduire la surface d'exposition attaquable d'un système, SQL Server sélectionne les services et les fonctionnalités clés à installer et à activer. Pour plus d'informations sur la configuration de la surface d'exposition, consultez le fichier Lisez-moi de cette version.

Voir aussi

Concepts

Procédure : installer SQL Server 2008 à partir de l'invite de commandes
Procédure : afficher les fichiers journaux d'installation de SQL Server

Autres ressources

How to: Verify a Successful Installation of SQL Server 2005 Services


Procédure : supprimer une instance de cluster de basculement SQL Server

Procédure : supprimer une instance de cluster de basculement SQL Server |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Lorsqu'une instance de SQL Server fait partie d'un cluster de basculement, le processus permettant de renommer un serveur virtuel diffère du processus permettant de renommer une instance autonome. Pour plus d'informations, consultez Procédure : renommer un ordinateur qui héberge une instance autonome de SQL Server.

Le nom du serveur virtuel est toujours identique au nom réseau SQL (le nom réseau du serveur virtuel SQL). Bien que vous puissiez modifier le nom du serveur virtuel, vous ne pouvez pas modifier le nom de l'instance. Par exemple, vous pouvez attribuer un autre nom à un serveur virtuel nommé VS1\instance1, tel que SQL35\instance1, mais la partie instance du nom (instance1) restera inchangée.

Avant de commencer

Avant de commencer le processus d'attribution d'un nouveau nom, examinez les éléments ci-dessous.

  • SQL Server ne prend pas en charge l'attribution d'un nouveau nom aux serveurs impliqués dans la réplication, sauf en cas d'utilisation de l'envoi de journaux avec la réplication. Le serveur secondaire dans l'envoi de journaux peut être renommé si le serveur principal est perdu de manière permanente. Pour plus d'informations, consultez Réplication et copie des journaux de transaction.

  • Lorsqu'un serveur configuré pour utiliser la mise en miroir de base de données doit être renommé, vous devez au préalable désactiver la mise en miroir de la base de données, puis la réactiver avec le nouveau nom du serveur virtuel. Les métadonnées pour la mise en miroir de la base de données ne seront pas mises à jour automatiquement de façon à refléter le nouveau nom du serveur virtuel.

Pour renommer un serveur virtuel

  1. À l'aide de l'Administrateur de cluster, modifiez le nom réseau SQL.

  2. Faites passer la ressource de nom réseau en mode hors connexion. La ressource SQL Server et les autres ressources dépendantes basculeront également en mode hors connexion.

  3. Faites repasser la ressource SQL Server en mode connecté.

Vérification de l'opération d'attribution d'un nom

Une fois qu'un serveur virtuel a été renommé, toute connexion qui utilisait l'ancien nom doit maintenant se connecter à l'aide du nouveau nom.

Pour vérifier que l'opération d'attribution d'un nom a réussi, sélectionnez des informations de @@servername ou sys.servers. La fonction @@servername retournera le nouveau nom du serveur virtuel et la table sys.servers affichera le nouveau nom du serveur virtuel. Pour vérifier que le processus de basculement fonctionne correctement avec le nouveau nom, l'utilisateur doit également essayer de faire basculer la ressource SQL Server vers les autres nœuds.

Pour les connexions établies à partir d'un nœud du cluster, le nouveau nom peut être utilisé presque immédiatement. Toutefois, pour les connexions utilisant le nouveau nom à partir d'un ordinateur client, le nouveau nom ne peut être utilisé pour se connecter au serveur qu'une fois qu'il est visible à cet ordinateur client. La durée nécessaire à la propagation du nouveau nom sur le réseau peut aller de quelques secondes à quelques minutes, selon la configuration du réseau ; il faudra peut-être davantage de temps avant que l'ancien nom du serveur virtuel ne soit plus visible sur le réseau.

Pour minimiser le délai de propagation réseau lorsque vous renommez un serveur virtuel, procédez comme suit :

Pour minimiser le délai de propagation réseau

  1. Exécutez les commandes suivantes à partir d'une invite de commandes sur le nœud du serveur :

    Copier le code
    ipconfig /flushdns
ipconfig /registerdns
nbtstat –RR

Voir aussi

Tâches

Procédure : renommer un ordinateur qui héberge une instance autonome de SQL Server


Procédure : ajouter des dépendances à une ressource SQL Server

Procédure : ajouter des dépendances à une ressource SQL Server |
 | Voir aussi
Vue d'ensemble des solutions à haute disponibilité > Mise en route avec le clustering de basculement de SQL Server 2008 > Procédures pour le clustering de basculement >

Si vous installez SQL Server dans un groupe de clusters Windows 2000 qui comporte plusieurs lecteurs de disques et choisissez de placer vos données sur un des lecteurs, la ressource SQL Server sera configurée uniquement pour ce lecteur. Pour placer les données ou les journaux sur un autre disque, vous devez d'abord ajouter une dépendance à la ressource SQL Server pour le disque supplémentaire.

Il est important de noter que si vous ajoutez d'autres ressources au groupe SQL Server, celles-ci doivent toujours avoir leurs propres ressources SQL uniques de noms sur le réseau et d'adresses IP.

N'utilisez pas de ressources SQL existantes de noms sur le réseau et d'adresses IP pour autre chose que SQL Server. Si les ressources SQL Server sont partagées avec d'autres ressources, les problèmes suivants peuvent se poser :

  • Des pannes inattendues peuvent se produire.

  • Les installations des Service Packs peuvent échouer.

  • Le programme d'installation de SQL Server peut échouer. Si ce problème se produit, vous ne pouvez pas installer d'autres instances SQL Server ou effectuer des opérations de maintenance régulière.

Tenez compte de ces problèmes supplémentaires :

  • FTP avec la réplication SQL Server : pour les instances de SQL Server qui utilisent FTP avec la réplication SQL Server, votre service FTP doit utiliser un des mêmes disques physiques que pour l'installation de SQL Server configurée pour utiliser le service FTP.

  • Dépendances de ressources SQL Server : si vous ajoutez une ressource à un groupe SQL Server et s'il existe une dépendance sur la ressource SQL Server pour garantir que SQL Server est disponible, Microsoft vous recommande d'ajouter une dépendance à la ressource de l'Agent SQL Server. N'ajoutez pas une dépendance à la ressource SQL Server. Pour garantir que l'ordinateur qui exécute SQL Server reste hautement SQL Serverdisponible, configurez la ressource de l'Agent SQL Server de façon à ce qu'elle n'affecte pas le groupe SQL Server en cas d'échec de cette dernière.

  • Ressources de partage de fichiers ou d'imprimantes : lorsque vous installez des ressources de partage de fichiers ou de clusters d'imprimantes, celles-ci ne doivent pas se trouver sur les mêmes ressources des disques physiques que l'ordinateur qui exécute SQL Server. Si elles se trouvent sur les ressources des disques physiques, vous pouvez constater une dégradation des performances et une perte des services sur l'ordinateur qui exécute SQL Server.

  • Considérations relatives à MS DTC : dès lors que vous avez installé le système d'exploitation et configuré votre cluster, vous devez configurer MS DTC pour qu'il fonctionne dans un cluster à l'aide de l'Administrateur de clusters. L'échec de la mise en cluster de MS DTC ne bloquera pas l'installation de SQL Server, mais les fonctionnalités des applications SQL Server peuvent être affectées si MS DTC n'est pas configuré correctement.

    Si vous installez Microsoft Distributed Transaction Coordinator (MS DTC) dans votre groupe SQL Server et si d'autres ressources dépendent de MS DTC, cette ressource ne sera pas disponible si ce groupe est hors connexion ou lors d'un basculement. Par défaut, SQL Server requiert que la ressource MS DTC soit mise dans un groupe SQL Server lorsque vous exécutez l'Assistant Basculement SQL Server sur les nouvelles installations. Microsoft vous recommande de placer MS DTC dans son propre groupe avec sa propre ressource de disque physique, si c'est possible.

Pour ajouter une dépendance à une ressource SQL Server

  1. Ouvrez l'Administrateur de clusters dans les Outils d'administration Windows.

  2. Recherchez le groupe qui contient la ressource SQL Server applicable que vous voulez rendre dépendante.

  3. Si la ressource du disque se trouve déjà dans ce groupe, passez à l'étape 4. Sinon, recherchez le groupe qui contient le disque. Si ce groupe et le groupe qui contient SQL Server n'appartiennent pas au même nœud, déplacez le groupe qui contient la ressource du disque vers le nœud propriétaire du groupe SQL Server.

  4. Mettez la ressource SQL Server hors connexion.

  5. Sélectionnez la ressource SQL Server, ouvrez la boîte de dialogue Propriétés et utilisez l'onglet Dépendances pour ajouter le disque au jeu de dépendances SQL Server.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Avant l'installation du clustering de basculement
Procédure : afficher les fichiers journaux d'installation de SQL Server


Rubriques consacrées aux procédures de préparation de SQL Server

Rubriques consacrées aux procédures de préparation de SQL Server |
 | Voir aussi
Planification d'une installation SQL Server >

Cette section contient des informations sur la façon de préparer SQL Server.

Dans cette section

  • Procédure : désactiver le protocole SMB

Voir aussi

Référence

Prise en charge d'Unicode et du classement
Configuration des comptes de service Windows


Procédure : désactiver le protocole SMB

Procédure : désactiver le protocole SMB |
 | Voir aussi
Planification d'une installation SQL Server > Rubriques consacrées aux procédures de préparation de SQL Server >

Les serveurs déployés dans le réseau de périmètre doivent avoir tous les protocoles inutilisés désactivés, y compris le protocole SMB (Server Message Block). Les serveurs Web et les serveurs DNS (Domain Name System) ne nécessitent pas SMB. Ce protocole doit être désactivé pour limiter le risque lié à l'énumération des utilisateurs.

Pour désactiver le protocole SMB

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Connexions réseau et accès à distance.

    Cliquez avec le bouton droit sur la connexion exposée à Internet, puis cliquez sur Propriétés.

  2. Activez la case à cocher Client pour les réseaux Microsoft, puis cliquez sur Désinstaller.

  3. Suivez les étapes de désinstallation.

  4. Sélectionnez Partage de fichiers et d'imprimantes pour les réseaux Microsoft, puis cliquez sur Désinstaller.

  5. Suivez les étapes de désinstallation.

Pour désactiver SMB sur les serveurs accessibles à partir d'Internet

  • Dans les propriétés de Connexion au réseau local, utilisez la boîte de dialogue Propriétés de Protocole Internet TCP/IP pour supprimer Partage de fichiers et d'imprimantes pour les réseaux Microsoft et Client pour les réseaux Microsoft.

Voir aussi

Concepts

Considérations sur la sécurité pour une installation SQL Server

Autres ressources

Rubriques consacrées aux procédures de préparation de SQL Server


Procédure : modifier les paramètres du système d'exploitation pour prendre en charge les versions localisées

Procédure : modifier les paramètres du système d'exploitation pour prendre en charge les versions localisées |
 | Voir aussi
Planification d'une installation SQL Server > Rubriques consacrées aux procédures de préparation de SQL Server >

Les versions localisées de SQL Server sont prises en charge dans les versions anglaises des systèmes d'exploitation pris en charge via l'utilisation des paramètres du Pack d'interface utilisateur multilingue de Microsoft Windows (MUI, Multilingual User Interface).

Vous devez toutefois vérifier certains paramètres de système d'exploitation avant d'installer une version localisée de SQL Server sur un serveur qui exécute un système d'exploitation en langue anglaise avec un paramétrage MUI non anglais. Vous devez vérifier que les paramètres de système d'exploitation suivants correspondent à la langue de la version localisée de SQL Server qui va être installée.

  • Le paramètre de l'interface utilisateur du système d'exploitation

  • Les paramètres régionaux utilisateur du système d'exploitation

  • Les paramètres régionaux système

Si les paramètres ne correspondent pas à la langue de la version localisée de SQL Server à installer, procédez comme suit pour définir correctement ces paramètres de système d'exploitation.

Attention :
Les installations de différentes versions linguistiques d'instances SQL Server sur le même ordinateur ne sont pas prises en charge.

Pour modifier le paramètre de l'interface utilisateur du système d'exploitation

  1. Si elle n'est pas déjà installée, installez l'interface utilisateur multilingue du système d'exploitation qui correspond à votre version localisée de SQL Server.

  2. Dans le Panneau de configuration, ouvrez Options régionales et linguistiques.

  3. Dans l'onglet Langues, pour Langue utilisée dans les menus et les dialogues, sélectionnez une valeur dans la liste.

    Ce paramètre affecte la langue de l'interface utilisateur de SQL Server qui doit correspondre à votre version localisée de SQL Server.

  4. Cliquez sur Appliquer pour confirmer la modification et sur OK pour fermer la fenêtre.

Pour modifier les paramètres régionaux utilisateur du système d'exploitation

  1. Si elle n'est pas déjà installée, installez l'interface utilisateur multilingue du système d'exploitation qui correspond à votre version localisée de SQL Server.

  2. Dans le Panneau de configuration, ouvrez Options régionales et linguistiques.

  3. Dans l'onglet Options régionales, pour Sélectionner un élément pour afficher ses paramètres, sélectionnez une valeur dans la liste.

    Ce paramètre affecte la mise en forme des données propre à une culture spécifique.

  4. Cliquez sur Appliquer pour confirmer la modification et sur OK pour fermer la fenêtre.

Pour modifier les paramètres régionaux système

  1. Si elle n'est pas déjà installée, installez l'interface utilisateur multilingue du système d'exploitation qui correspond à votre version localisée de SQL Server.

  2. Dans le Panneau de configuration, ouvrez Options régionales et linguistiques.

  3. Dans l'onglet Options avancées, pour Sélectionnez une langue qui corresponde à la version des programmes non Unicode que vous voulez utiliser, sélectionnez une valeur dans la liste.

    Ce paramètre permet au programme d'installation de SQL Server de choisir le meilleur classement par défaut pour votre installation de SQL Server.

  4. Cliquez sur Appliquer pour confirmer la modification et sur OK pour fermer la fenêtre.

Voir aussi

Référence

Prise en charge d'Unicode et du classement
Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Autres ressources

Rubriques consacrées aux procédures de préparation de SQL Server


Installation de SQL Server 2008

Installation de SQL Server 2008 |
 | Voir aussi

L'Assistant Installation de SQL Server est basé sur Windows Installer. Il fournit une arborescence de fonctionnalités unique pour installer tous les composants SQL Server :

  • Moteur de base de données SQL Server

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Outils d'administration

  • Documentation

Remarque SQL Server est disponible en éditions 32 bits et 64 bits. Les éditions 64 bits et 32 bits de SQL Server sont installées via l'Assistant Installation ou à l'invite de commandes. Pour plus d'informations sur les composants SQL Server, consultez Éditions et composants de SQL Server 2008 et Fonctionnalités prises en charge par les éditions de SQL Server 2008.

Par défaut, les exemples de bases de données et les exemples de code ne sont pas installés dans le cadre de l'installation de SQL Server. Pour installer les exemples de bases de données et de code pour les éditions autres que Express de SQL Server 2008, consultez le site Web CodePlex à l'adresse http://go.microsoft.com/fwlink/?LinkId=87843. Pour obtenir de l'aide sur les exemples de bases de données SQL Server et les exemples de code pour SQL Server Express, consultez la présentation des bases de données et des exemples à l'adresse http://go.microsoft.com/fwlink/?LinkId=110391.

Que vous utilisiez l'Assistant Installation de SQL Server ou l'invite de commandes pour installer SQL Server, le processus d'installation implique les étapes suivantes :

Dans cette section

Planification d'une installation SQL Server

Décrit comment préparer l'ordinateur pour SQL Server :

  • Vérifiez les configurations matérielle et logicielle requises.

  • Vérifiez les spécifications de l'outil d'analyse de configuration système et les problèmes bloquants.

  • Vérifiez les éléments de sécurité à prendre en compte pour une installation SQL Server.

Configuration de SQL Server 2008

Une fois le programme d'installation terminé, vous pouvez configurer SQL Server à l'aide d'utilitaires graphiques et d'invite de commandes.

Sections connexes

Considérations relatives à l'installation du moteur de base de données SQL Server

Explique comment installer et configurer le Moteur de base de données SQL Server.

Considérations sur l'installation d'Analysis Services

Explique comment installer et configurer Analysis Services.

Considérations sur l'installation de Reporting Services

Explique comment installer et configurer Reporting Services.

Considérations sur l'installation de SQL Server Integration Services

Explique comment installer et configurer Integration Services.

Considérations sur l'installation de la réplication SQL Server

Cette section explique comment installer et configurer la réplication SQL Server.

Directives pour l'installation des outils d'administration SQL Server

Cette section explique comment installer et configurer les outils d'administration SQL Server.

Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server

Cette section explique comment installer les exemples SQL Server AdventureWorks.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Autres ressources

Vue d'ensemble des solutions à haute disponibilité


Considérations relatives à l'installation du moteur de base de données SQL Server

Considérations relatives à l'installation du moteur de base de données SQL Server |
 | Voir aussi
Installation de SQL Server 2008 >

Le composant Moteur de base de données de SQL Server est le service de base pour le stockage, le traitement et la protection des données. Le Moteur de base de données fournit un accès contrôlé et un traitement transactionnel rapide qui répondent aux exigences des applications les plus gourmandes en termes de données dans votre entreprise.

SQL Server prend en charge jusqu'à 50 instances du Moteur de base de données sur un seul ordinateur. Pour créer une installation par défaut de SQL Server, consultez Procédure : installer SQL Server 2008 (programme d'installation).

Important Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Les fonctionnalités suivantes sont installées lorsque vous sélectionnez Moteur de base de données SQL Server dans la page Composants à installer de l'Assistant Installation de SQL Server :

  • Moteur de base de données

  • Réplication (composant facultatif)

  • Recherche en texte intégral (composant facultatif)

Les fonctionnalités supplémentaires suivantes sont des options pour un grand nombre de scénarios utilisateur classiques :

  • Integration Services

  • Composants de connectivité

  • Modèles de programmation

  • Outils d'administration

  • Management Studio

  • Documentation en ligne de SQL Server

Remarque :
Par défaut, les exemples de bases de données et les exemples de code ne sont pas installés dans le cadre de l'installation de SQL Server. Pour installer les exemples de bases de données et les exemples de code, consultez le site Web CodePlex.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Référence

Éditions et composants de SQL Server 2008

Concepts

Planification d'une installation SQL Server

Autres ressources

Vue d'ensemble des solutions à haute disponibilité


Considérations sur l'installation d'Analysis Services

Considérations sur l'installation d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 >

SQL Server fournit un programme d'installation unique pour installer tout ou une partie de ses composants, y compris Analysis Services. Le programme d'installation vous permet d'installer Analysis Services avec ou sans d'autres composants SQL Server sur un ordinateur unique.

Cette rubrique met en évidence des points importants dont vous devez être informé avant d'installer Analysis Services. Les informations dans cette rubrique vous aideront à évaluer les options d'installation afin que vous puissiez effectuer des sélections garantissant la réussite de l'installation.

Cette rubrique ne contient pas d'instructions relatives au démarrage du programme d'installation, à l'exécution du programme d'installation à partir de la ligne de commande ou à l'utilisation de l'Assistant Installation. Pour les instructions pas à pas sur le démarrage du programme d'installation et la sélection des composants à installer, consultez Installation de démarrage rapide de SQL Server 2008. Pour plus d'informations sur les options de ligne de commande pour l'installation de Analysis Services, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Préparation de l'installation de SQL Server Analysis Services

Avant d'installer Microsoft SQL Server Analysis Services, vérifiez les éléments requis suivants :

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Paramètres de l'outil d'analyse de configuration système

  • Considérations sur la sécurité pour une installation SQL Server

Sélection des composants à installer

Bien qu'il soit possible d'installer Analysis Services seul, notez que de nombreuses solutions d'entrepôt de données nécessitent l'installation d'autres composants SQL Server pour permettre le développement, le déploiement et l'administration de bases de données Analysis Services. Le tableau suivant décrit ces composants SQL Server supplémentaires.

Composant | Pour l'administrateur | Pour le développeur | Pour une utilisation facultative
Composants de connectivité Composants utilisés pour la communication entre les clients et les serveurs, y compris les bibliothèques réseau pour DB-Library, ODBC et OLE DB. | X | X |
Outils de gestion Outils interactifs pour gérer SQL Server, y compris le Gestionnaire de configuration SQL Server, SQL Server Management Studio, Générateur de profils SQL Server et le moniteur de réplication. | X |  |
Business Intelligence Development Studio Environnement de développement intégré pour les projets décisionnels. |  | X |
Kit de développement logiciel Logiciel qui assiste les développeurs dans la création de solutions personnalisées pour SQL Server. |  | X |
Services de base de données SQL Server. Le Moteur de base de données SQL Server et les outils permettant de gérer les données relationnelles et XML, la réplication et la recherche en texte intégral. |  |  | X
Reporting Services Un serveur de rapports pour gérer, exécuter, effectuer le rendu des rapports et les distribuer, et le Gestionnaire de rapports, une interface Web qui fournit l'accès aux composants SQL Server Reporting Services, notamment des outils d'administration et des rapports. |  |  | X
Integration Services SQL Server Integration Services, un ensemble d'objets graphiques et programmables permettant de déplacer, copier et transformer des données. |  |  | X
Documentation et exemples Documentation en ligne SQL Server, documents de référence de programmation et exemples pour tous les composants SQL Server. | X | X | X

Options d'installation d'Analysis Services

Vous pouvez installer Analysis Services dans les configurations suivantes :

  • Installez Analysis Services sur un ordinateur sans instance antérieure de SQL Server.

  • Installez SQL Server 2008 Analysis Services côte à côte avec une instance existante de SQL Server 2005 Analysis Services ou de SQL Server 2000 Analysis Services.

  • Mettez à niveau une instance existante de SQL Server 2005 Analysis Services ou de SQL Server 2000 Analysis Services pour SQL Server 2008 Analysis Services.

Installation de SQL Server Analysis Services

Après avoir pris connaissance de la configuration requise pour l'installation de SQL Server et vérifié que votre ordinateur répondait à ces critères, vous pouvez installer SQL Server Analysis Services.

Si vous utilisez l'Assistant Installation pour installer Analysis Services, vous utiliserez une série de pages pour spécifier les composants et les options. Le tableau suivant répertorie uniquement les pages de l'Assistant Installation où les options que vous sélectionnez affectent votre installation de Analysis Services :

Page Recommandations

Composants à installer

Sélectionnez Analysis Services pour installer le service Analysis Services.

Sélectionnez Composants de la station de travail, documentation en ligne et outils de développement pour installer les outils et la documentation.

Nom de l'instance

Vous pouvez indiquer un seul nom d'instance dans la page Nom de l'instance pour l'ensemble des composants SQL Server que vous avez sélectionnés pour être installés. Pour cette raison, vous ne pouvez pas par exemple installer une instance par défaut du Moteur de base de données SQL Server et une instance nommée de Analysis Services en même temps. Dans ce cas, vous devez exécuter le programme d'installation séparément pour chaque nom d'instance à utiliser.

Lorsque vous effectuez une installation côte à côte avec SQL Server 2000 Analysis Services, vous devez installer SQL Server 2008 Analysis Services comme instance nommée.

Lorsque vous effectuez une installation côte à côte avec SQL Server 2005 Analysis Services, vous devez installer SQL Server 2008 Analysis Services comme instance nommée de manière unique.

Compte de service

Analysis Services démarre et s'exécute en tant que service Microsoft Windows. Ce service figure dans la liste des services installés dans le Gestionnaire de configuration SQL Server et dans Services, le composant logiciel enfichable de la console MMC (Microsoft Management Console) qui permet l'administration des services Windows.

Chaque instance de Analysis Services est prise en charge par son propre service, et chaque instance peut utiliser des paramètres différents pour le classement et d'autres options du serveur. Les noms de service de chaque instance correspondent aux noms d'instance que vous avez spécifiés au cours de l'installation. Le nom de service de l'instance par défaut est MSSQLServerOLAPService. Le nom de service d'une instance nommée est MSOLAP$nom_instance, où nom_instance correspond au nom que vous avez spécifié pour l'instance au cours de l'installation.

Mode d'authentification

Cette page définit le fournisseur d'authentification pour le Moteur de base de données. SQL Server Analysis Services ne prend en charge que l'authentification Windows.

Paramètres de classement

Analysis Services utilise les mêmes indicateurs de classement et les mêmes paramètres de tri que le Moteur de base de données SQL Server. Si vous installez Analysis Services et le Moteur de base de données SQL Server sous le même nom d'instance, vous pouvez choisir d'utiliser les mêmes paramètres ou des paramètres différents pour les deux serveurs. Si vous choisissez d'utiliser des paramètres différents, vous pouvez configurer Analysis Services et le Moteur de base de données SQL Server séparément, comme le décrit la procédure suivante.

Pour utiliser des paramètres de classement différents pour Analysis Services et le moteur de base de données SQL Server

  1. Dans la page Paramètres de classement de l'Assistant Installation, activez la case à cocher Personnaliser pour chaque compte de service.

  2. En regard de Service, sélectionnez Analysis Services, puis configurez les options de classement pour Analysis Services.

    Remarque :
    L'option Classements SQL ne s'applique pas pour Analysis Services et n'est pas disponible lorsque vous configurez les options de classement de Analysis Services.

  3. En regard de Service, sélectionnez Moteur de base de données, puis configurez les options de classement pour le Moteur de base de données SQL Server.

Pour plus d'informations sur les options de classement de SQL Server, consultez Prise en charge d'Unicode et du classement.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Autres ressources

Vue d'ensemble des solutions à haute disponibilité


Rubriques de procédures pour l'installation d'Analysis Services

Rubriques de procédures pour l'installation d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services >

Cette section contient les procédures courantes suivantes pour installer Microsoft SQL Server Analysis Services.

Pour prendre connaissance des procédures courantes permettant de mettre à niveau des versions antérieures de Analysis Services et de migrer des packages Analysis Services, consultez Considérations sur l'installation d'Analysis Services.

Important :
Les rubriques de procédures pour l'installation d'Analysis Services fournies dans cette section traitent uniquement des options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Dans cette section

  • Procédure : installer Analysis Services en utilisant le programme d'installation

  • Procédure : installer plusieurs instances d'Analysis Services

  • Procédure : installer Analysis Services côte à côte avec une version antérieure

  • Procédure : renommer une instance d'Analysis Services

  • Procédure : ajouter ou supprimer des fonctionnalités pour une instance d'Analysis Services

  • Procédure : désinstaller une instance d'Analysis Services

Voir aussi

Concepts

Considérations sur l'installation d'Analysis Services


Procédure : installer Analysis Services en utilisant le programme d'installation

Procédure : installer Analysis Services en utilisant le programme d'installation |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Vous pouvez installer Microsoft SQL Server Analysis Services en utilisant l'Assistant Installation de SQL Server ou bien l'installer à partir de l'invite de commandes. L'Assistant Installation fournit une interface utilisateur graphique qui vous guide pour chaque décision relative à l'installation. Cette méthode d'installation est recommandée pour la plupart des utilisateurs. L'Assistant Installation fournit des instructions pour l'initialisation de SQL Server. Elles incluent la sélection de fonctionnalités, les règles d'attribution de nom des instances, la configuration des comptes de service, les directives de mots de passe forts et la sélection de classement.

Important :
Cette rubrique et les autres rubriques qui traitent des procédures d'installation de Analysis Services dans la présente section abordent uniquement les options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour installer Analysis Services en utilisant le programme d'installation

  1. Démarrez l'Assistant Installation de SQL Server.

  2. Consultez éventuellement la rubrique Procédure : installer SQL Server 2008 (programme d'installation) pour une description de l'Assistant Installation, tout particulièrement si vous installez d'autres composants SQL Server en plus de Analysis Services.

  3. Dans la page Composants à installer de l'Assistant Installation, sélectionnez Analysis Services. Consultez Considérations sur l'installation d'Analysis Services pour plus d'informations sur d'autres fonctionnalités SQL Server, telles que la documentation et les outils de développement, que vous pouvez souhaiter inclure dans votre installation.

  4. Dans la page Nom de l'instance, sélectionnez une instance nommée ou une instance par défaut pour votre installation. Si une instance par défaut existe déjà ou si une instance de SQL Server 2000 Analysis Services que vous ne souhaitez pas mettre à niveau est déjà installée sur l'ordinateur, vous ne pouvez sélectionner qu'une instance nommée.

  5. Dans la page Compte de service, spécifiez le nom d'utilisateur, le mot de passe et le nom de domaine des comptes de service Analysis Services et d'autres comptes de service SQL Server. Vous pouvez utiliser un seul compte pour l'ensemble des services.

  6. Dans la page Paramètres de classement, spécifiez le classement par défaut. Vous pouvez utiliser un classement pour Analysis Services et un autre classement pour le Moteur de base de données SQL Server, ou bien vous pouvez spécifier un seul et même classement pour l'ensemble des services.

  7. Terminez l'Assistant Installation. Les pages restantes de l'Assistant contiennent des options qui ne concernent pas Analysis Services.

Voir aussi

Concepts

Considérations sur l'installation d'Analysis Services

Autres ressources

Rubriques de procédures pour l'installation d'Analysis Services


Procédure : installer plusieurs instances d'Analysis Services

Procédure : installer plusieurs instances d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Vous pouvez exécuter plusieurs instances de Microsoft SQL Server Analysis Services sur le même ordinateur. Pour installer une instance supplémentaire, exécutez à nouveau le programme d'installation et spécifiez un nom unique pour la nouvelle instance.

Important :
Les rubriques de procédures pour l'installation d'Analysis Services fournies dans cette section traitent uniquement des options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour installer une autre instance d'Analysis Services

  1. Exécutez le programme d'installation en utilisant soit l'Assistant Installation de SQL Server, soit l'invite de commandes. Pour plus d'informations, consultez Considérations sur l'installation d'Analysis Services.

  2. Lorsque vous utilisez l'Assistant Installation de SQL Server, spécifiez un nom d'instance unique dans la page Nom de l'instance. Lorsque vous exécutez le programme d'installation à l'invite de commandes, utilisez l'option INSTANCE pour spécifier un nom d'instance unique.

Voir aussi

Autres ressources

Rubriques de procédures pour l'installation d'Analysis Services


Procédure : installer Analysis Services côte à côte avec une version antérieure

Procédure : installer Analysis Services côte à côte avec une version antérieure |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Vous pouvez installer SQL Server 2008 Analysis Services côte à côte avec une instance existante de SQL Server 2005 Analysis Services ou de SQL Server 2000 Analysis Services.

Lorsque vous effectuez une installation côte à côte avec SQL Server 2000 Analysis Services, vous devez installer SQL Server 2008 Analysis Services comme instance nommée car SQL Server 2000 Analysis Services ne prend pas en charge les instances nommées. Si vous supprimez ultérieurement l'instance par défaut de SQL Server 2000 Analysis Services, vous pouvez désigner une instance de SQL Server 2008 Analysis Services comme instance par défaut en utilisant l'outil de Modification du nom d'instance Analysis Services. Pour plus d'informations, consultez Procédure : renommer une instance d'Analysis Services.

Lorsque vous effectuez une installation côte à côte avec SQL Server 2005 Analysis Services, vous devez installer SQL Server 2008 Analysis Services comme instance nommée de manière unique.

Important :
Les rubriques de procédures pour l'installation d'Analysis Services fournies dans cette section traitent uniquement des options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour installer Analysis Services côte à côte avec une version antérieure

  1. Exécutez le programme d'installation en utilisant soit l'Assistant Installation de SQL Server, soit l'invite de commandes. Pour plus d'informations, consultez Considérations sur l'installation d'Analysis Services.

  2. Lorsque vous utilisez l'Assistant Installation de SQL Server, spécifiez un nom d'instance unique dans la page Nom de l'instance. Lorsque vous exécutez le programme d'installation à l'invite de commandes, utilisez l'option INSTANCE pour spécifier un nom d'instance unique.

Voir aussi

Autres ressources

Rubriques de procédures pour l'installation d'Analysis Services


Procédure : renommer une instance d'Analysis Services

Procédure : renommer une instance d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Vous pouvez renommer une instance existante de Microsoft Analysis Services à l'aide de la boîte de dialogue Renommer l'instance.

Important :
Cette rubrique et les autres rubriques qui traitent des procédures d'installation de Analysis Services dans la présente section abordent uniquement les options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Remarque :
Sur un ordinateur 64 bits, vous devez utiliser la version 64 bits de l'utilitaire Modification du nom d'instance.

Remarque :
L'utilitaire Modification du nom d'instance de Analysis Services n'est pas pris en charge pour une utilisation dans un environnement de cluster.

Pour renommer une instance d'Analysis Services

  1. Lancez l'outil Modification du nom d'instance, asinstancerename.exe, à partir de C:\Program Files\Microsoft SQL Server\10\Tools\Binn\VSShell\Common7\IDE.

  2. Dans la boîte de dialogue Renommer l'instance, sélectionnez dans la liste Instance à renommer l'instance que vous souhaitez renommer.

  3. Dans la zone Nouveau nom d'instance, entrez le nouveau nom de l'instance.

  4. Vérifiez que le nom d'utilisateur et le mot de passe sont corrects, puis cliquez sur Renommer.

Voir aussi

Autres ressources

Boîte de dialogue Renommer l'instance (Analysis Services)
Rubriques de procédures pour l'installation d'Analysis Services
Gestion des instances Analysis Services


Procédure : ajouter ou supprimer des fonctionnalités pour une instance d'Analysis Services

Procédure : ajouter ou supprimer des fonctionnalités pour une instance d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Dans Microsoft SQL Server, la maintenance des fonctionnalités est prise en charge uniquement via la fonction Ajouter ou supprimer des programmes du Panneau de configuration Microsoft Windows.

Important :
Cette rubrique et les autres rubriques qui traitent des procédures d'installation de Analysis Services dans la présente section abordent uniquement les options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour modifier des composants dans une instance existante de SQL Server Analysis Services

  1. Sur le Bureau Microsoft Windows, cliquez sur Démarrer, cliquez sur Panneau de configuration, puis double-cliquez sur Ajouter ou supprimer des programmes.

  2. Sous Programmes actuellement installés, sélectionnez Microsoft SQL Server, puis cliquez sur Modifier. L'Assistant Maintenance de Microsoft SQL Server démarre.

  3. Dans la page Sélection du composant, sous les instances SQL Server, sélectionnez l'instance qui inclut l'instance de Analysis Services que vous souhaitez modifier.

  4. Dans la page Maintenance des fonctionnalités, sélectionnez Analysis Services. L'Assistant Maintenance de Microsoft SQL Server lance ensuite l'Assistant Installation de Microsoft SQL Server.

  5. Dans la page Changer ou supprimer l'instance, cliquez sur Changer les composants installés.

  6. Cliquez sur Suivant et suivez les instructions qui s'affichent dans les pages successives de l'Assistant.

Voir aussi

Autres ressources

Rubriques de procédures pour l'installation d'Analysis Services


Procédure : désinstaller une instance d'Analysis Services

Procédure : désinstaller une instance d'Analysis Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation d'Analysis Services > Rubriques de procédures pour l'installation d'Analysis Services >

Suivez la procédure ci-dessous pour désinstaller une instance de Microsoft SQL Server Analysis Services.

Important :
Cette rubrique et les autres rubriques qui traitent des procédures d'installation de Analysis Services dans la présente section abordent uniquement les options d'installation spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour supprimer une instance de SQL Server Analysis Services

  1. Sur le Bureau Microsoft Windows, cliquez sur Démarrer, cliquez sur Panneau de configuration, puis double-cliquez sur Ajouter ou supprimer des programmes.

  2. Sous Programmes actuellement installés, sélectionnez Microsoft SQL Server, puis cliquez sur Modifier. L'Assistant Maintenance de Microsoft SQL Server démarre.
Remarque :
Si vous cliquez sur Supprimer au lieu de Modifier, vous ne pourrez pas désinstaller une instance de Analysis Services sans désinstaller le Moteur de base de données SQL Server et Reporting Services installés sous le même nom d'instance.

  1. Dans la page Sélection du composant, sous les instances SQL Server, sélectionnez l'instance qui inclut l'instance de Analysis Services que vous souhaitez supprimer.

  2. Dans la page Maintenance des fonctionnalités, sélectionnez Analysis Services. L'Assistant Maintenance de Microsoft SQL Server lance ensuite l'Assistant Installation de Microsoft SQL Server.

  3. Dans la page Modifier ou supprimer l'instance, cliquez sur Supprimer Microsoft SQL Server.

  4. Cliquez sur Suivant et suivez les instructions qui s'affichent dans les pages successives de l'Assistant.

Voir aussi

Autres ressources

Rubriques de procédures pour l'installation d'Analysis Services


Considérations sur l'installation de Reporting Services

Considérations sur l'installation de Reporting Services |
 | Voir aussi
Installation de SQL Server 2008 >

SQL Server fournit un programme d'installation unique qui installe tous les composants, y compris Reporting Services. Le programme d'installation vous permet d'installer Reporting Services avec ou sans d'autres composants SQL Server sur un ordinateur unique. Vous pouvez également sélectionner des fonctionnalités spécifiques dans Reporting Services si vous souhaitez installer séparément les applications client et serveur de Reporting Services.

Cette rubrique contient les informations et les recommandations pour :

  • Sélectionner les applications clientes et serveur à inclure dans une installation Reporting Services.

  • Sélectionner les services supplémentaires et les fonctionnalités pour prendre en charge les opérations de serveur de rapports.

  • Sélectionner un compte de service pour le service Report Server.

  • Sélectionner un mode d'installation pour que le programme d'installation configure de manière minimale ou intégrale l'instance que vous installez.

  • Installer plusieurs instances et versions de Reporting Services sur le même ordinateur.

préparation de l'installation de Reporting Services

Avant d'installer Reporting Services, consultez la configuration requise et la description des composants :

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Considérations sur la sécurité pour une installation SQL Server

  • Configuration des comptes de service Windows

Une fois que vous êtes familier de la configuration requise pour l'installation, vous pouvez exécuter le programme d'installation depuis la ligne de commande ou l'Assistant Installation :

  • Procédure : installer SQL Server 2008 (programme d'installation)

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes

Sélection des applications clientes et serveur

En plus des outils partagés fournis par SQL Server, Reporting Services inclut un ensemble complet d'outils et applications pour la création de rapport d'entreprise. La liste suivante explique quels outils et applications sont installés lorsque vous sélectionnez des fonctionnalités spécifiques dans l'Assistant Installation ou les arguments de ligne de commande :

Sélection de composant | Description
Reporting Services - ou - /FEATURES=RS | Installe les applications suivantes : Service Report Server (lequel inclut le service Web Report Server, application de traitement en arrière-plan, et le Gestionnaire de rapports), Générateur de rapports, Concepteur de rapports, outil de configuration de Reporting Services et les utilitaires de ligne de commande Reporting Services (rsconfig.exe, rskeymgmt.exe et rs.exe).
Outils clients - ou - /FEATURES=Tools | Installe SQL Server Management Studio utilisé pour configurer le serveur de rapports, gérer les travaux, gérer les planifications partagées et configurer les définitions de rôle.
Business Intelligence Development Studio - ou - /FEATURES=BIDS | Installe l'environnement de conception Visual Studio qui propose le Concepteur de rapports et le Générateur de modèles.

Sélection de composants et services supplémentaires

Un déploiement Reporting Services peut bénéficier de l'ajout d'autres services et technologies de composants SQL Server :

  • Sélectionnez Services Moteur de base de données dans la page Sélection de composant pour héberger les bases de données du serveur de rapports. Reporting Services nécessite une instance locale et distante de SQL Server 2005 ou SQL Server 2008 Moteur de base de données pour héberger les bases de données du serveur de rapports. Si vous installez une instance du Moteur de base de données en même temps que Reporting Services, vous pouvez éliminer une tâche de post-installation en installant la configuration par défaut, qui crée et configure automatiquement les bases de données du serveur de rapports. En plus d'héberger les bases de données du serveur de rapports, les bases de données relationnelles SQL Server peuvent également être une source de données pour les rapports et les modèles.

  • L'Agent SQL Server est obligatoire si vous voulez utiliser l'application du traitement en arrière-plan Reporting Services pour les abonnements et la création de rapports planifiée. L'Agent SQL Server doit s'exécuter dans l'instance du Moteur de base de données qui héberge la base de données du serveur de rapports. Vous pouvez spécifier l'Agent SQL Server dans la page Configuration du serveur lorsque vous installez le Moteur de base de données.

  • SQL Server Browser est obligatoire si vous installez une instance du Moteur de base de données qui sera utilisé pour héberger une base de données du serveur de rapports pour une instance de serveur de rapports située sur un autre ordinateur. Vous pouvez spécifier SQL Server Browser dans la page Configuration du serveur lorsque vous installez le Moteur de base de données.

  • Sélectionnez Analysis Services dans la page Sélection de composant si vous souhaitez utiliser SQL Server Analysis Services comme source de données pour les rapports et les modèles.

  • Sélectionnez Documentation en ligne de SQL Server dans la page Sélection de composant si vous souhaitez installer la documentation du produit pour Reporting Services.

  • Sélectionnez Integration Services dans la page Sélection de composant si vous souhaitez utiliser l'exemple de package SSIS, les scripts et les rapports pour interroger les données du journal de l'exécution de rapport. Vous devez avoir une installation d'Integration Services pour exécuter le package.

Sélection d'un compte de service

L'installation fournit une page Configuration du serveur dans l'Assistant Installation afin que vous puissiez configurer les services qui font partie de l'installation en cours. L'installation ne sélectionne pas de compte de service par défaut, donc vous devez spécifier explicitement le compte de service que vous souhaitez utiliser. Il est recommandé dans la plupart des cas que vous utilisiez un compte d'utilisateur de domaine ayant les privilèges les plus faibles avec les autorisations de connexion réseau. Si possible, spécifiez un compte utilisé exclusivement par le serveur de rapports afin que vous puissiez vérifier l'activité de connexion de ce compte.

Par la suite, si vous souhaitez modifier le compte de service Report Server ou mettre à jour le mot de passe, utilisez l'outil de configuration de Reporting Services pour effectuer les modifications. Pour plus d'informations sur les recommandations relatives aux comptes ou sur la mise à jour des paramètres du compte du service, consultez Configuration des comptes de service Windows et Configuration du compte de service Report Server.

Sélection d'une option d'installation

L'installation requiert que vous sélectionniez une option d'installation pour Reporting Services :

  • L'option Installer la configuration par défaut en mode natif demande au programme d'installation d'utiliser les valeurs par défaut lors de l'installation de Reporting Services préconfiguré. L'option d'installation par défaut est uniquement disponible si vous installez une instance locale du Moteur de base de données et une instance de Reporting Services en même temps, sinon vous ne pouvez pas sélectionner cette option d'installation. Cette option crée un serveur de rapports totalement déployé en mode natif et prêt à être utilisé une fois l'installation terminée, ce qui vous permet d'économiser du temps et des étapes. Pour plus d'informations, consultez Configuration par défaut pour une installation en mode natif (Reporting Services).

  • Installer la configuration par défaut du mode SharePoint demande au programme d'installation d'installer Reporting Services préconfiguré pour utiliser une base de données du serveur de rapports qui fonctionne avec le stockage de données SharePoint. Cette option d'installation par défaut est uniquement disponible si vous installez simultanément une instance locale du Moteur de base de données et une instance de Reporting Services. Vous devez uniquement sélectionner cette option si vous projetez de configurer l'intégration du serveur de rapports avec un déploiement SharePoint. Le serveur de rapports ne sera pas complètement fonctionnel tant que vous n'aurez pas procéder ainsi. Pour plus d'informations, consultez Configuration par défaut pour le mode intégré SharePoint (Reporting Services).

  • L'option Installer mais ne pas configurer le serveur demande au programme d'installation de copier les fichiers programme sur le disque, de configurer le service Report Server et d'enregistrer le fournisseur WMI (Windows Management Instrumentation) du serveur de rapports. Cette option d'installation porte également le nom d'installation de « fichiers uniquement » et correspond à l'option d'installation par défaut. La configuration à l'aide de l'outil de configuration de Reporting Services est nécessaire avant que le serveur de rapports ne puisse être utilisé. Sélectionnez cette option si vous souhaitez configurer séparément le serveur de rapports comme tâche de post-installation, utiliser les paramètres personnalisés, choisir une instance existante ou distante du Moteur de base de données pour héberger la base de données du serveur de rapports, ou installer Reporting Services comme instance nommée. Pour plus d'informations, consultez Installation de fichiers uniquement (Reporting Services).

L'installation n'installe pas de composants sur les ordinateurs distants. En outre, les scénarios de déploiement tels que le déploiement avec montée en puissance parallèle, le mode intégré SharePoint ou la configuration d'une base de données du serveur de rapports sur un cluster de basculement sont au delà de la portée du programme d'installation. Pour plus d'informations sur la prise en charge et la configuration de ces scénarios de déploiement, consultez Planification et architecture (Reporting Services) dans la documentation en ligne de SQL Server.

Comparaison des options d'installation

Le tableau suivant compare les paramètres utilisés dans une configuration par défaut à ceux utilisés dans une installation de fichiers uniquement.

Opération | Configuration par défaut | Installation de fichiers uniquement
Configure le nom de l'instance. | Requiert que vous installiez le Moteur de base de données et Reporting Services en même temps que la même instance. Utilise le nom d'instance SQL Server que vous spécifiez pour l'instance du Moteur de base de données qui héberge les bases de données du serveur de rapports. | Utilise le nom d'instance SQL Server. Une installation de fichiers uniquement peut être l'instance par défaut ou une instance nommée.
Crée les dossiers programme et copie les fichiers. | Oui | Oui
Enregistre le fournisseur WMI de Report Server. | Oui | Oui
Configure le compte de service et le type de démarrage. | Oui. Cette valeur doit être spécifiée pendant l'installation. | Oui. Cette valeur doit être spécifiée pendant l'installation.
Démarre le service Report Server. | Oui | Oui
Accorde les autorisations de dossier au compte de service Report Server. | Oui | Oui
Crée les bases de données reportserver et reportservertempdb. Crée le rsexecrole qui spécifie les autorisations relatives à la base de données. | Oui. Si la configuration par défaut est le mode intégré SharePoint, la propriété système IsSharePointEnabled du serveur de rapports est définie sur True. | Non
Configure une connexion de base de données. | Oui. Le compte de service Report Server bénéficie de droits sur la base de données via l'élément rsexecrole. | Non
Réserve les URL pour le serveur de rapports et le Gestionnaire de rapports (mode natif uniquement). | Oui | Non
Initialise le serveur de rapports. | Oui | Non
Configure la remise par courrier électronique. | Non | Non
Configure le compte d'exécution sans assistance. | Non | Non
Sauvegarde les clés de chiffrement. | Non | Non

configuration de Reporting Services

Après avoir installé Reporting Services, vous pouvez modifier l'installation pour reconfigurer le serveur ou sélectionner les paramètres personnalisés pour votre installation. Si vous avez effectué une installation de fichiers seulement, vous devez utiliser l'outil de configuration de Reporting Services pour configurer un serveur de rapports et le rendre opérationnel.

Pour exécuter l'outil de configuration de Reporting Services, cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, sur Outils de configuration, puis cliquez sur Configuration de Reporting Services. Pour plus d'informations, consultez Outil de configuration de Reporting Services et Rubriques d'aide à la configuration de Reporting Services.

vérification de votre installation de Reporting Services

Après l'installation et la configuration, vous devez vérifier que les composants de Reporting Services fonctionnent correctement. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services.

Installation de plusieurs instances et versions de Reporting Services

Le composant de serveur de rapports prend en charge les instances. Vous pouvez installer plusieurs instances de la même version, ou différentes versions de Reporting Services si vous souhaitez exécuter les versions SQL Server 2008, SQL Server 2005 ou SQL Server 2000 de Reporting Services côte à côte sur le même ordinateur.

SQL Server 2000 Reporting Services peut continuer à s'exécuter comme instance par défaut, côte à côte avec les instances nommées de SQL Server 2008 Reporting Services. Si vous exécutez SQL Server 2000 Reporting Services en même temps que d'autres versions, il doit s'agir d'une instance par défaut parce que SQL Server 2000 Reporting Services ne prend pas en charge les instances nommées. Par conséquent, lors d'une installation côte à côte sur un ordinateur qui exécute SQL Server 2000 Reporting Services, le programme d'installation SQL Server autorise uniquement l'installation d'instances nommées de SQL Server 2008 Reporting Services.

L'installation n'installe qu'une instance à la fois. Une instance unique de SQL Server peut contenir plusieurs composants, y compris Reporting Services. Vous pouvez installer plusieurs instances de Reporting Services sur le même ordinateur en exécutant plusieurs fois le programme d'installation.

Si vous installez plusieurs instances de Reporting Services qui s'exécutent comme instance par défaut et comme instances nommées, chaque instance sera identifiée à travers le nom de l'instance. SQL Server 2008 inclut également les informations de version. Par exemple, si vous avez installé une instance par défaut et une instance nommée de SQL Server 2005 et SQL Server 2008, vous visualiserez les fichiers programme et les services des quatre instances :

  • SQL Server 2005 Reporting Services (MSSQLSERVER)

  • SQL Server 2005 Reporting Services (MyInstanceName)

  • SQL Server 2008 Reporting Services (MSRS10.MSSQLSERVER)

  • SQL Server 2008 Reporting Services (MSRS10.MyInstanceName)

Par défaut, si vous installez Reporting Services comme instance nommée, le nom de l'instance servira à définir le répertoire virtuel du serveur de rapports et du Gestionnaire de rapports, et sera inclus dans l'URL pour un serveur de rapports et pour le Gestionnaire de rapports afin que chaque application soit nommée de façon unique par rapport aux autres instances de l'application qui s'exécutent sur le même ordinateur. Pour plus d'informations, consultez Configuration des URL de Report Server.

Fonctionnalités partagées

Vous ne pouvez pas installer plusieurs instances des fonctionnalités partagées, mais vous pouvez les exécuter côte à côte avec les versions antérieures (par exemple, exécuter SQL Server 2005 et SQL Server 2008 Business Intelligence Development Studio sur le même ordinateur).

Vous ne pouvez pas utiliser la création de rapports, la configuration du serveur ou les outils d'administration d'une version avec une autre version. Par exemple, vous ne pouvez pas utiliser l'outil de configuration de Reporting Services de SQL Server 2008 pour configurer une version antérieure d'un serveur de rapports. Soyez sûr d'installer tous les outils et applications dont vous avez besoin pour chaque version que vous installez.

Voir aussi

Concepts

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Autres ressources

Déploiement (Reporting Services)
Mise à niveau (Reporting Services)
Composants et outils de Reporting Services
Planification et architecture (Reporting Services)


Configuration par défaut pour une installation en mode natif (Reporting Services)

Configuration par défaut pour une installation en mode natif (Reporting Services) |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de Reporting Services >

La configuration par défaut pour le mode natif fait référence à une installation de Reporting Services où le programme d'installation installe et configure une instance de serveur de rapports. Une fois l'installation terminée, le serveur de rapports fonctionne et est opérationnel. Un serveur de rapports en mode natif s'exécute comme serveur d'applications autonome. Le mode natif est le mode par défaut.

Le programme d'installation installe les fonctionnalités Reporting Services suivantes lorsque vous sélectionnez la configuration par défaut pour l'option de mode natif : service Report Server (lequel inclut le service Web Report Server, application de traitement en arrière-plan et le Gestionnaire de rapports), Générateur de rapports, Aperçu du Concepteur de rapports, outil de configuration de Reporting Services et utilitaires en ligne de commande Reporting Services (rsconfig.exe, rskeymgmt.exe et rs.exe). Cette option ne s'applique pas aux fonctionnalités partagées telles que SQL Server Management Studio ou Business Intelligence Development Studio, qui doivent être spécifiées comme éléments séparés si vous souhaitez les installer.

L'installation configure les éléments suivants pour une installation de serveur de rapports en mode natif :

  • Compte de service pour le service Report Server.

  • URL du service Web Report Server.

  • URL du Gestionnaire de rapports.

  • Base de données du serveur de rapports.

  • Accès des comptes de service aux bases de données Report Server

  • Connexion DSN aux bases du serveur de rapports.

L'installation ne configure pas le compte d'exécution sans assistance, la messagerie électronique de serveur de rapports, la sauvegarde des clés de chiffrement ou le déploiement avec montée en puissance parallèle. Vous pouvez utiliser l'outil de configuration de Reporting Services pour configurer ces propriétés. Pour plus d'informations, consultez Outil de configuration de Reporting Services.

Quand installer la configuration par défaut pour le mode natif

Une configuration par défaut installe Reporting Services dans un état opérationnel afin que vous puissiez utiliser immédiatement le serveur de rapports une fois l'installation terminée. Spécifiez ce mode lorsque vous souhaitez économiser des étapes en éliminant toutes les tâches de configuration requises que vous devriez autrement exécuter dans l'outil de configuration de Reporting Services.

L'installation de la configuration par défaut ne garantit pas que le serveur de rapports fonctionnera après que l'installation est terminée. L'inscription des URL par défaut peut ne pas s'effectuer quand le service démarre. Testez toujours votre installation pour vérifier que le service démarre et s'exécute comme prévu.

Configuration requise

Cette option d'installation utilise les valeurs par défaut pour configurer les paramètres principaux requis pour rendre un serveur de rapports opérationnel. Elle comporte les impératifs suivants :

  • Reporting Services et SQL Server Moteur de base de données doivent être installés ensemble dans la même instance. L'instance du Moteur de base de données héberge la base de données de serveur de rapports que le programme d'installation crée et configure.

  • Le compte d'utilisateur utilisé pour exécuter le programme d'installation doit être membre du groupe local Administrateurs et avoir l'autorisation de créer des bases de données et d'y accéder sur l'instance de Moteur de base de données qui héberge les bases de données du serveur de rapports.

  • L'installation doit être en mesure d'utiliser les valeurs par défaut pour réserver les URL qui fournissent l'accès au serveur de rapports et au Gestionnaire de rapports. Ces valeurs sont le port 80, un caractère générique fort et les noms de répertoire virtuel aux formats ReportServer_<nom_instance> et Reports_<nom_instance>.

  • L'installation doit être en mesure d'utiliser les valeurs par défaut pour créer les bases de données du serveur de rapports. Ces valeurs sont ReportServer et ReportServerTempDB. Si vous avez des bases de données d'une précédente installation, le programme d'installation sera bloqué car il ne peut pas configurer le serveur de rapports dans la configuration par défaut pour le mode natif. Vous devez renommer, déplacer ou supprimer les bases de données pour débloquer le programlmle d'installation.

Si votre ordinateur ne satisfait pas à toutes les spécifications d'une installation par défaut, vous devez installer Reporting Services en mode fichiers uniquement, puis utiliser l'outil de configuration Reporting Services pour le configurer une fois l'installation terminée.

N'essayez pas de reconfigurer votre ordinateur uniquement pour autoriser une installation par défaut à se poursuivre. Un tel choix pourrait nécessiter plusieurs heures de travail, en éliminant concrètement l'avantage en termes de gain de temps que l'option d'installation fournit. La meilleure solution consiste à installer Reporting Services en mode fichiers uniquement, puis à configurer le serveur de rapports pour utiliser des valeurs spécifiques.

Réservations d'URL par défaut

Les réservations d'URL se composent d'un préfixe, d'un nom d'hôte, d'un port et d'un répertoire virtuel :

Élément | Description
Préfixe | Le préfixe par défaut est HTTP. Si vous avez préalablement installé un certificat SSL (Secure Sockets Layer), l'installation tente de créer des réservations d'URL qui utilisent le préfixe HTTPS.
Nom d'hôte | Le nom d'hôte par défaut est un caractère générique fort (+). Il spécifie que le serveur de rapports accepte toute requête HTTP sur le port désigné pour tout nom d'hôte qui se résout en l'ordinateur, y compris http://<nom_ordinateur>/serveur_de_rapports, http://localhost/serveur_de_rapports ou http://<adresse_IP>/serveur_de_rapports.
Port | Le port par défaut est 80. Si vous installez Reporting Services sur Windows XP SP2 32 bits, le port par défaut est 8080. Notez que si vous utilisez un port autre que le port 80, vous devez l'ajouter explicitement à l'URL lorsque vous ouvrez une application Web Reporting Services dans une fenêtre de navigateur.
Répertoire virtuel | Par défaut, les répertoires virtuels sont créés dans le format ReportServer_<nom_instance>pour le service Web Report Server et Reports_<nom_instance>pour le Gestionnaire de rapports. Pour le service Web Report Server, le répertoire virtuel par défaut est reportserver. Par défaut, le répertoire virtuel du Gestionnaire de rapports est reports.

Voici un exemple de chaîne URL complète :

  • http://+:80/reportserver, fournit l'accès au serveur de rapports.

  • http://+:80/reports, fournit l'accès au Gestionnaire de rapports.

Comment installer un serveur de rapports dans la configuration par défaut pour le mode natif

Vous pouvez spécifier une configuration par défaut en mode natif via la ligne de commande ou l'Assistant Installation. Les rubriques suivantes fournissent les instructions pas à pas :

  • Procédure : installer SQL Server 2008 (programme d'installation).

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Exemple de script de ligne de commande

L'exemple suivant inclut le service Moteur de base de données parce qu'il est requis pour une configuration par défaut.

Copier le code
setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultNativeMode"

Assistant Installation

Lorsque vous sélectionnez Reporting Services dans la page Sélection de fonctionnalités, le programme d'installation fournit une page de configuration de Reporting Services qui vous permet de spécifier le mode d'installation. Pour spécifier une installation en mode natif par défaut, sélectionnez l'option Installer la configuration par défaut en mode Natif sur la page de configuration de Reporting Services.

Voir aussi

Tâches

Procédure : vérifier une installation de Reporting Services

Référence

Configuration des comptes de service Windows

Concepts

Configuration du compte de service Report Server
Configuration des URL de Report Server
Configuration d'une connexion de base de données de serveur de rapports
Installation de fichiers uniquement (Reporting Services)
Configuration par défaut pour le mode intégré SharePoint (Reporting Services)
Considérations sur l'installation de Reporting Services
Initialisation d'un serveur de rapports
Configuration des URL de Report Server
Considérations sur l'installation de Reporting Services
Installation de démarrage rapide de SQL Server 2008

Autres ressources

Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer)
Planification d'un mode de déploiement


Configuration par défaut pour le mode intégré SharePoint (Reporting Services)

Configuration par défaut pour le mode intégré SharePoint (Reporting Services) |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de Reporting Services >

La configuration par défaut pour le mode intégré SharePoint fait référence à une installation Reporting Services où le programme d'installation installe et configure une instance de serveur de rapports, et crée la base de données du serveur de rapports dans un format qui prend en charge le stockage de contenu et l'adressage à partir d'un site SharePoint.

Le programme d'installation installe les fonctionnalités Reporting Services suivantes lorsque vous sélectionnez la configuration par défaut pour l'option mode intégré SharePoint : service Report Server, Générateur de rapports, Aperçu du Concepteur de rapports, outil de configuration de Reporting Services et les utilitaires de ligne de commande Reporting Services (rsconfig.exe, rskeymgmt.exe et rs.exe). Cette option ne s'applique pas aux fonctionnalités partagées telles que SQL Server Management Studio ou Business Intelligence Development Studio, qui doivent être spécifiées comme éléments séparés si vous souhaitez les installer.

Lorsque vous sélectionnez une option de configuration par défaut dans le programme d'installation, celui-ci configure le serveur de rapports en mode natif ou en mode intégré SharePoint. Pour un serveur de rapports en mode intégré SharePoint, le programme d'installation configure les éléments suivants :

  • Compte de service pour le service Report Server.

  • URL du service Web Report Server.

  • URL du Gestionnaire de rapports.

  • Base de données du serveur de rapports.

  • Accès des comptes de service aux bases de données Report Server

  • Connexion DSN aux bases de données du serveur de rapports.

L'installation ne configure pas le compte d'exécution sans assistance, la messagerie électronique de serveur de rapports, la sauvegarde des clés de chiffrement ou le déploiement avec montée en puissance parallèle. Vous pouvez utiliser l'outil de configuration de Reporting Services pour configurer ces propriétés. Pour plus d'informations, consultez Outil de configuration de Reporting Services.

Une fois l'installation terminée, il se peut que le serveur de rapports ne soit pas complètement opérationnel, car il n'est pas encore pleinement intégré à une batterie SharePoint. Vous devez encore installer un complément Reporting Services, configurer les paramètres d'intégration et, éventuellement, installer des logiciels supplémentaires si vous intégrez le serveur de rapports à une batterie de serveurs SharePoint qui couvre plusieurs serveurs. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Quand installer la configuration par défaut pour le mode intégré SharePoint

Cette option d'installation configure les paramètres de base du serveur de rapports qui permettent l'intégration du serveur de rapports à Windows SharePoint Services ou Microsoft Office SharePoint Server . Spécifiez ce mode lorsque :

  • vous souhaitez économiser des étapes en éliminant toutes les tâches de configuration requises que vous devriez autrement exécuter dans l'outil de configuration de Reporting Services. Les valeurs par défaut pour les URL Reporting Services, le nom de la base de données et les répertoires virtuels doivent être disponibles pour pouvoir être utilisées. Ces valeurs doivent être uniques. Si elles sont déjà utilisés par une autre installation sur l'ordinateur, le programme d'installation ne peut pas les utiliser pour configurer une installation par défaut.

  • Vous prévoyez d'installer immédiatement le complément Reporting Services et de configurer les paramètres d'intégration du serveur de rapports sur le site SharePoint. Si le serveur de rapports fournit la fonction de traitement des rapports à une batterie de serveurs SharePoint, vous devez également installer un SharePoint Web frontal sur le serveur de rapports afin de le joindre à la batterie. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Configuration requise

Cette option d'installation exige les éléments suivants :

  • Reporting Services et SQL Server Moteur de base de données doivent être installés ensemble dans la même instance. L'instance du Moteur de base de données héberge la base de données de serveur de rapports que le programme d'installation crée et configure.

  • Le compte d'utilisateur utilisé pour exécuter le programme d'installation doit être membre du groupe Administrateurs sur l'ordinateur local et avoir l'autorisation de créer des bases de données (et d'y accéder) utilisant l'instance de Moteur de base de données qui héberge les bases de données du serveur de rapports.

  • L'installation doit être en mesure d'utiliser les valeurs par défaut pour réserver les URL qui fournissent l'accès au serveur de rapports et au Gestionnaire de rapports. Ces valeurs sont le port 80, un caractère générique fort et les noms de répertoire virtuel aux formats ReportServer_<nom_instance> et Reports_<nom_instance>.

  • L'installation doit être en mesure d'utiliser les valeurs par défaut pour créer les bases de données du serveur de rapports. Pour une instance par défaut, ces valeurs sont ReportServer et ReportServerTempDB. Si vous avez des bases de données d'une installation précédente, le programme d'installation sera bloqué car il ne peut pas configurer le serveur de rapports. Vous devez renommer, déplacer ou supprimer les bases de données pour débloquer le programme d'installation.

L'installation ne vérifie pas l'installation d'un produit ou d'une technologie SharePoint sur l'ordinateur local ; elle n'installe pas non plus le complément Reporting Services ni ne configure de paramètres d'intégration dans l'Administration centrale de SharePoint. Vous devez installer et configurer ces applications séparément. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Si votre ordinateur ne satisfait pas à ces spécifications pour une installation par défaut, vous devez installer Reporting Services en mode fichiers uniquement, puis le configurer manuellement une fois l'installation terminée. Vous pouvez utiliser l'outil de configuration de Reporting Services pour configurer le Reporting Services.

N'essayez pas de reconfigurer votre ordinateur uniquement pour autoriser une installation par défaut à se poursuivre. Un tel choix pourrait nécessiter plusieurs heures de travail, en éliminant concrètement l'avantage en termes de gain de temps que l'option d'installation fournit. La meilleure solution consiste à installer Reporting Services en mode fichiers uniquement, puis à configurer le serveur de rapports pour utiliser des valeurs spécifiques.

Réservations d'URL par défaut

Les réservations d'URL se composent d'un préfixe, d'un nom d'hôte, d'un port et d'un répertoire virtuel :

Élément | Description
Préfixe | Le préfixe par défaut est HTTP. Si vous avez préalablement installé un certificat SSL (Secure Sockets Layer), l'installation tente de créer des réservations d'URL qui utilisent le préfixe HTTPS.
Nom d'hôte | Le nom d'hôte par défaut est un caractère générique fort (+). Il spécifie que le serveur de rapports accepte toute demande HTTP sur le port désigné pour tout nom d'hôte qui se résout en l'ordinateur, y compris http://<nom_ordinateur>/serveur_de_rapports, http://localhost/serveur_de_rapports ou http://<adresse_IP>/serveur_de_rapports.
Port | Le port par défaut est 80. Si vous installez Reporting Services sur Windows XP SP2 32 bits, le port par défaut est 8080. Notez que si vous utilisez un port autre que le port 80, vous devez l'ajouter explicitement à l'URL lorsque vous ouvrez une application Web Reporting Services dans une fenêtre de navigateur.
Répertoire virtuel | Par défaut, les répertoires virtuels sont créés dans le format ReportServer_<nom_instance>pour le service Web Report Server et Reports_<nom_instance>pour le Gestionnaire de rapports. Pour le service Web Report Server, le répertoire virtuel par défaut est reportserver. Par défaut, le répertoire virtuel du Gestionnaire de rapports est reports.

Voici un exemple de chaîne URL complète :

Exemple d'URL Description

http://+:80/reportserver

Fournit l'accès au serveur de rapports.

http://+:80/reports

Fournit l'accès au Gestionnaire de rapports.

Remarque :
En mode intégré à SharePoint, cette URL produit le message d'erreur rsOperationNotSupportedSharePointMode parce que le Gestionnaire de rapports n'est pas pris en charge dans ce mode. Dans ce mode, il est attendu que toute la gestion du contenu et l'accès aux rapports s'effectue via SharePoint et non pas le Gestionnaire de rapports.

Comment installer un serveur de rapports dans la configuration par défaut du mode intégré SharePoint

Vous pouvez spécifier une configuration par défaut en mode SharePoint via la ligne de commande ou l'Assistant Installation. Les rubriques suivantes fournissent les instructions pas à pas :

  • Procédure : installer SQL Server 2008 (programme d'installation).

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Exemple de script de ligne de commande

Cet exemple inclut le service Moteur de base de données parce qu'il est requis pour une configuration par défaut.

Copier le code
setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultSharePointMode"

Assistant Installation

Lorsque vous sélectionnez Reporting Services dans la page Sélection de fonctionnalités, le programme d'installation fournit une page de configuration de Reporting Services qui vous permet de spécifier le mode d'installation. Pour spécifier une installation en mode intégré SharePoint, sélectionnez Installer la configuration par défaut en mode intégré SharePoint sur la page de configuration de Reporting Services.

Voir aussi

Tâches

Procédure : vérifier une installation de Reporting Services

Concepts

Configuration du compte de service Report Server
Configuration des URL de Report Server
Configuration d'une connexion de base de données de serveur de rapports
Installation de fichiers uniquement (Reporting Services)
Configuration par défaut pour une installation en mode natif (Reporting Services)
Considérations sur l'installation de Reporting Services

Autres ressources

Déploiement (Reporting Services)
Planification d'un mode de déploiement
Planification d'une intégration SharePoint
Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint


Installation de fichiers uniquement (Reporting Services)

Installation de fichiers uniquement (Reporting Services) |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de Reporting Services >

L'installation de fichiers uniquement fait référence à une installation de Reporting Services dans laquelle le programme d'installation crée l'arborescence pour les fichiers programme Reporting Services, copie les fichiers sur disque, inscrit le service Report Server sur l'ordinateur local, configure le compte de service, accorde les autorisations de fichiers au compte de service et inscrit le fournisseur WMI Reporting Services.

Une installation de fichiers uniquement inclut les fonctionnalités Reporting Services suivantes : le service Report Server (qui héberge le service Web Report Server, l'application de traitement en arrière-plan et le Gestionnaire de rapports), le Générateur de rapports, l'Aperçu de Concepteur de rapports, l'outil de configuration de Reporting Services et les utilitaires de ligne de commande Reporting Services (rsconfig.exe, rskeymgmt.exe et rs.exe). Elle ne s'applique pas aux fonctionnalités partagées telles que SQL Server Management Studio ou Business Intelligence Development Studio, qui doivent être spécifiées comme éléments séparés si vous souhaitez les installer.

Par opposition avec d'autres modes d'installation, un serveur de rapports installé en mode fichiers uniquement n'est pas opérationnel lorsque l'installation est terminée. Une configuration supplémentaire sera requise pour placer le serveur de rapports en ligne à l'aide de l'Outil de configuration de Reporting Services.

Quand sélectionner le mode d'installation Fichiers uniquement

Une installation de fichiers uniquement doit être effectuée lorsque :

  • vous souhaitez connecter le serveur de rapports à une base de données de serveur de rapports distante ;

  • vous souhaitez installer le serveur de rapports en tant qu'instance nommée ;

  • vous devez respecter des spécifications de déploiement qui incluent l'utilisation de paramètres ou de fonctionnalités personnalisés et vous souhaitez disposer d'un contrôle total sur le moment et la manière dont le serveur est configuré.

  • Installation d'un cluster de basculement SQL Server qui inclut Reporting Services.

Comment effectuer une installation de fichiers uniquement

L'installation de fichiers uniquement est le mode d'installation par défaut pour Reporting Services.

Vous pouvez spécifier une installation de fichiers uniquement par le biais de la ligne de commande ou dans l'Assistant Installation. Les rubriques suivantes fournissent des instructions pas à pas :

  • Procédure : installer SQL Server 2008 (programme d'installation).

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Exemple de script de ligne de commande

Pour plus de clarté, l'exemple inclut /RSINSTALLMODE="FilesOnlyMode". Toutefois, le mode fichiers uniquement étant le mode par défaut, vous pouvez omettre ceci et obtenir tout de même une installation en mode fichiers uniquement.

Copier le code
setup /q /ACTION=install /FEATURES=RS /InstanceName=MSSQLSERVER /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSINSTALLMODE="FilesOnlyMode"

Assistant Installation

Lorsque vous sélectionnez Reporting Services dans la page Sélection de fonctionnalités, le programme d'installation fournit une page de configuration de Reporting Services qui vous permet de spécifier le mode d'installation. Pour spécifier une installation de fichiers uniquement, sélectionnez Installer mais ne pas configurer le serveur dans la page Configuration de Reporting Services.

Voir aussi

Tâches

Procédure : vérifier une installation de Reporting Services

Concepts

Configuration du compte de service Report Server
Configuration des URL de Report Server
Configuration d'une connexion de base de données de serveur de rapports
Configuration par défaut pour le mode intégré SharePoint (Reporting Services)
Configuration par défaut pour une installation en mode natif (Reporting Services)
Considérations sur l'installation de Reporting Services

Autres ressources

Déploiement (Reporting Services)
Mise à niveau (Reporting Services)
Composants et outils de Reporting Services


Procédure : vérifier une installation de Reporting Services

Procédure : vérifier une installation de Reporting Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de Reporting Services >

Lorsque vous installez un serveur de rapports en utilisant la configuration par défaut, le programme d'installation installe et déploie le serveur. Vous pouvez vérifier que le programme d'installation a déployé le serveur de rapports en réalisant quelques tests simples. Pour effectuer ces interventions, vous devez être un administrateur local. Pour permettre à d'autres utilisateurs de réaliser des tests, vous devez configurer leur accès au serveur de rapports. Pour plus d'informations sur la configuration de l'accès utilisateur, consultez Didacticiel : Définition des autorisations dans Reporting Services dans la documentation en ligne de SQL Server.

Remarque :
Les didacticiels de Reporting Services vous permettent d'acquérir rapidement des compétences essentielles. Il existe également un didacticiel qui présente chaque outil. Il explique comment démarrer l'outil et vous montre l'aspect de chaque outil lorsque vous l'ouvrez pour la première fois. Vous pouvez utiliser ce didacticiel pour confirmer que tous les outils été correctement installés. Pour plus d'informations, consultez Didacticiel : comment localiser et démarrer les outils Reporting Services dans la documentation en ligne de SQL Server.

Pour vérifier que le serveur de rapports est installé et s'exécute correctement

  • Exécutez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous venez d'installer. La page URL du service Web inclut un lien vers le service Web Report Server. Cliquez sur le lien pour vérifier que vous pouvez accéder au serveur. Si la base de données du serveur de rapports n'est pas configurée, configurez-la avant de cliquer sur le lien.

  • Ouvrez la fenêtre Services et vérifiez que le service Windows Report Server est en cours d'exécution. Pour afficher l'état du service Report Server, cliquez sur Démarrer, pointez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis double-cliquez sur Services. Lorsque la liste des services s'affiche, recherchez Report Server (MSSQLSERVER). L'état doit être Démarré.

  • Ouvrez un navigateur et entrez l'URL du serveur de rapports dans la barre d'adresses. L'adresse se compose du nom du serveur et de celui du répertoire virtuel spécifiés pour le serveur de rapports lors de l'installation. Par défaut, le répertoire virtuel du serveur de rapports est appelé ReportServer. Vous pouvez utiliser l'URL suivante pour vérifier l'installation du serveur de rapports : http://<nom_ordinateur>/ReportServer<_nom_instance>. L'URL sera différente si vous avez installé le serveur de rapports en tant qu'instance nommée. Pour plus d'informations sur le format des URL, consultez Configuration des URL de Report Server. Si vous êtes administrateur local sur Windows Vista ou Windows Server 2008, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

  • Exécutez les rapports pour tester le fonctionnement du serveur de rapports. Pour effectuer cette étape, vous pouvez installer et publier les exemples de rapports si vous n'avez pas de rapport à votre disposition. Pour les instructions sur l'installation des exemples de bases de données, des applications et des fichiers de données utilisés dans les didacticiels Reporting Services, consultez Installation initiale (Reporting Services) dans la documentation en ligne de SQL Server.

Pour vérifier que le Gestionnaire de rapports est installé et s'exécute correctement

  • Ouvrez un navigateur et entrez l'URL du Gestionnaire de rapports dans la barre d'adresses. L'adresse se compose du nom du serveur et de celui du répertoire virtuel spécifiés pour le Gestionnaire de rapports lors de l'installation ou dans la page URL du Gestionnaire de rapports de l'outil de configuration de Reporting Services. Par défaut, le répertoire virtuel du Gestionnaire de rapports est Reports. Vous pouvez utiliser l'URL suivante pour vérifier l'installation du Gestionnaire de rapports : http://<nom_ordinateur>/Reports<_nom_instance>.

  • Utilisez le Gestionnaire de rapports pour créer un dossier ou téléchargez un fichier pour vérifier si les définitions sont transmises à la base de données du serveur de rapports. Si ces opérations réussissent, cela signifie que la connexion fonctionne.

Pour vérifier que le Générateur de rapports est installé et s'exécute correctement

  • Ouvrez Business Intelligence Development Studioet créez un projet basé sur un type de projet Report Server. Pour plus d'informations sur l'utilisation de l'Assistant Projet Report Server, consultez Procédure : créer un projet Report Server (Reporting Services) dans la documentation en ligne de SQL Server.

  • Si vous avez installé des exemples de rapports, ouvrez les exemples de fichiers de projet de rapport et publiez les rapports sur un serveur de rapport. Pour plus d'informations, consultez Publication de modèles dans la documentation en ligne de SQL Server.

Voir aussi

Autres ressources

Dépannage des erreurs HTTP
Dépannage de problèmes liés aux erreurs de configuration
Dépannage des problèmes de connexion à un serveur et à une base de données
Cause et résolution des erreurs Reporting Services


Procédure : résoudre un problème d'installation de Reporting Services

Procédure : résoudre un problème d'installation de Reporting Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de Reporting Services >

Si vous ne parvenez pas à installer Reporting Services suite à des erreurs qui se produisent durant l'installation, utilisez les instructions fournies dans cette rubrique pour étudier les conditions les plus susceptibles de provoquer des erreurs d'installation. Pour obtenir des instructions sur la résolution des problèmes post-installation qui se produisent lors de la configuration d'un serveur de rapports, consultez Dépannage de problèmes liés aux erreurs de configuration.

Vérification des journaux d'installation

Les erreurs d'installation sont enregistrées dans des fichiers journaux dans le dossier Microsoft SQL Server\100\Setup Bootstrap\Log. Un sous-dossier est créé chaque fois que vous exécutez le programme d'installation. Le nom du sous-dossier est l'heure et la date d'exécution du programme d'installation. Les fichiers journaux incluent une collection de fichiers. Ouvrez le fichier *_summary.txt pour afficher des informations sur les produits, les composants et les instances. Ouvrez le fichier *_errorlog.txt pour afficher des informations sur les erreurs générées durant l'installation. Ouvrez le * _RS_*_ComponentUpdateSetup.log pour consulter les informations de l'installation de Reporting Services. Pour obtenir des instructions sur la manière d'afficher les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Vérification de la configuration requise

Le programme d'installation vérifie automatiquement les conditions préalables. Toutefois, si vous tentez de résoudre des problèmes d'installation, il est utile de connaître les vérifications effectuées par le programme d'installation.

  • Les spécifications relatives aux comptes pour l'exécution du programme d'installation incluent l'appartenance au groupe Administrateurs local. Le programme d'installation doit avoir l'autorisation d'ajouter des fichiers et des paramètres du Registre, de créer des groupes de sécurité locaux et de définir des autorisations. Si vous installez une configuration par défaut, le programme d'installation doit avoir l'autorisation de créer une base de données du serveur de rapports sur l'instance SQL Server sur laquelle vous effectuez l'installation.

  • Le système d'exploitation doit prendre en charge HTTP.SYS 1.1. Cela signifie que vous devez utiliser Windows XP Service Pack 2, (SP2) Windows Server 2003, Windows Vista ou Windows Server 2008.

  • Le service HTTP doit être activé et en cours d'exécution.

  • Le Coordinateur de transactions distribuées (DTC, Distributed Transaction Coordinator) doit s'exécuter si vous installez également le service SQL Server Agent.

  • Authz.dll doit être présent dans le dossier System32.

Le programme d'installation ne vérifie plus la présence des services Internet (IIS) ou de ASP.NET. Reporting Services requiert MDAC 2.0 et le Microsoft .NET Framework version 2.0 ; le programme d'installation installe ces composants s'ils ne sont pas déjà installés.

Résolution des problèmes liés à la configuration par défaut

Reporting Services prend en charge trois modes d'installation : configuration par défaut pour le mode natif, configuration par défaut pour le mode intégré SharePoint et mode fichiers uniquement. L'installation de Reporting Services dans la configuration par défaut présente davantage de conditions requises qui doivent être remplies pour que l'installation se poursuive. Si vous ne pouvez pas sélectionner cette option d'installation, vérifiez que le système satisfait toutes les spécifications décrites dans Configuration par défaut pour une installation en mode natif (Reporting Services).

Si vous ne pouvez pas résoudre le problème de conditions requises, effectuez une installation de fichiers uniquement et utilisez l'outil de configuration Reporting Services pour configurer le serveur. L'un des principaux avantages offerts par cet outil est que vous pouvez configurer chaque paramètre indépendamment et isoler les erreurs qui se produisent pendant la configuration. Pour plus d'informations, consultez Outil de configuration de Reporting Services.

Voir aussi

Concepts

Considérations sur l'installation de Reporting Services

Autres ressources

Concepts de dépannage (Reporting Services)


Considérations sur l'installation de SQL Server Integration Services

Considérations sur l'installation de SQL Server Integration Services |
 | Voir aussi
Installation de SQL Server 2008 >

SQL Server fournit un programme d'installation unique pour installer tout ou une partie de ses composants, y compris Integration Services. Le programme d'installation vous permet d'installer Integration Services avec ou sans d'autres composants SQL Server sur un ordinateur unique.

Cette rubrique met l'accent sur quelques facteurs importants qu'il convient de prendre en compte avant d'installer Integration Services. Les informations dans cette rubrique vous aideront à évaluer les options d'installation afin que vous puissiez effectuer des sélections garantissant la réussite de l'installation.

Cette rubrique ne contient pas d'instructions relatives au démarrage du programme d'installation, à l'utilisation de l'Assistant Installation ou à l'exécution du programme d'installation à partir de la ligne de commande. Pour les instructions pas à pas sur le démarrage du programme d'installation et la sélection des composants à installer, consultez Installation de démarrage rapide de SQL Server 2008. Pour plus d'informations sur les options de ligne de commande pour l'installation de Integration Services, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Préparation à l'installation d'Integration Services

Avant d'installer Microsoft SQL Server Integration Services, vérifiez les éléments requis suivants :

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Paramètres de l'outil d'analyse de configuration système

  • Considérations sur la sécurité pour une installation SQL Server

Sélection d'une configuration Integration Services

Vous pouvez installer SQL Server Integration Services dans les configurations suivantes :

  • Vous pouvez installer SQL Server Integration Services sur un ordinateur dépourvu d'instances antérieures de SQL Server.

  • Vous pouvez installer SQL Server 2008 Integration Services parallèlement à une instance existante de SQL Server 2005 Integration Services et/ou de SQL Server 2000 Data Transformation Services (DTS).

  • Vous pouvez mettre à niveau une instance existante de SQL Server 2005 Integration Services vers SQL Server 2008 Integration Services. Pour plus d'informations, consultez Considérations sur la mise à niveau de SQL Server Integration Services. Pour plus d'informations sur la compatibilité avec les versions antérieures de Integration Services, consultez Compatibilité descendante d'Integration Services.

  • Vous pouvez mettre à niveau une instance existante de SQL Server 2000 Data Transformation Services (DTS) vers SQL Server 2008 Integration Services. Pour plus d'informations, consultez Considérations sur la mise à niveau de Data Transformation Services. Pour plus d'informations sur la compatibilité descendante avec DTS, consultez Prise en charge de DTS dans SQL Server 2008.

Installation d'Integration Services

Après avoir pris connaissance de la configuration requise pour l'installation de SQL Server et vérifié que votre ordinateur répondait à ces critères, vous pouvez installer Integration Services.

Si vous utilisez l'Assistant Installation pour installer Integration Services, vous utiliserez une série de pages pour spécifier les composants et les options. Le tableau suivant répertorie uniquement les pages de l'Assistant Installation où les options que vous sélectionnez affectent votre installation de Integration Services :

Page Recommandations

Sélection de composant

Sélectionnez Integration Services pour installer le service Integration Services et pour exécuter des packages en dehors de l'environnement de conception.

Pour une installation complète d'Integration Services, qui inclue outils et la documentation relative au développement et à la gestion des packages, sélectionnez à la fois Integration Services et les Fonctionnalités partagéessuivantes :

  • Business Intelligence Development Studio pour installer les outils de conception des packages.

  • Outils d'administration - Complet pour installer SQL Server Management Studio afin de gérer les packages.

  • SQL Server Books Online pour installer la documentation.

  • Kit de développement logiciel (SDK) des outils clients pour installer des assemblys managés pour la programmation Integration Services.

Pour utiliser un serveur dédié pour les processus d'extraction, de transformation et de chargement (ETL), nous vous recommandons d'installer une instance locale du Moteur de base de données SQL Server lorsque vous installez Integration Services. Integration Services stocke habituellement les packages dans une instance du Moteur de base de données et s'appuie sur l'Agent SQL Server pour planifier ces packages. Si le serveur ETL ne dispose pas d'une instance du Moteur de base de données, vous devrez planifier ou exécuter les packages à partir d'un serveur qui possède une instance du Moteur de base de données. Cela signifie que les packages ne s'exécuteront pas sur le serveur ETL, mais sur le serveur à partir duquel ils ont été démarrés. En conséquence, les ressources du serveur ETL dédié ne sont pas utilisées comme prévu. De plus, les ressources d'autres serveurs peuvent être éprouvées par les processus ETL en cours d'exécution.

De nombreuses solutions de stockage de données requièrent également l'installation de composants SQL Server supplémentaires, tels que le Moteur de base de données SQL Server, SQL Server Analysis Services et SQL Server Reporting Services.

Remarque :
Parmi les composants SQL Server que vous pouvez sélectionner dans la page Sélection de composant de l'Assistant Installation, certains n'installent qu'un sous-ensemble partiel des composants Integration Services. Ces composants sont utiles pour des tâches spécifiques, mais les fonctionnalités de Integration Services s'en trouvent limitées. Par exemple, l'option Services Moteur de base de données installe les composants Integration Services requis pour l'Assistant Importation et Exportation SQL Server. L'option Business Intelligence Development Tools (BIDS) installe les composants Integration Services nécessaires à la conception d'un package, mais le service Integration Services n'est pas installé et vous ne pouvez pas exécuter de packages en-dehors de BI Development Studio. Pour garantir une installation complète de Integration Services, vous devez sélectionner Integration Services dans la page Sélection de composant.

Configuration de l'instance

Aucune sélection effectuée dans la page Configuration de l'instance n'affecte Integration Services ou le service Integration Services.

Vous pouvez installer une seule instance du service Integration Services sur un ordinateur. Vous vous connectez au service en utilisant le nom d'ordinateur.

Par défaut, le service Integration Services est configuré pour gérer les packages qui sont stockés dans la base de données msdb, dans l'instance du moteur de base de données qui est installée au même moment qu'Integration Services. Si une instance du moteur de base de données n'est pas installée au même moment qu'Integration Services, le service Integration Services est configuré pour gérer les packages dans la base de données msdb de l'instance locale par défaut du Moteur de base de données. Pour gérer des packages qui sont stockés dans une instance nommée ou dans une instance distante du Moteur de base de données, ou encore dans plusieurs instances du Moteur de base de données, vous devez modifier le fichier de configuration. Pour plus d'informations sur la façon de modifier ce fichier de configuration, consultez Configuration du service Integration Services.

Configuration du serveur

Passez en revue les paramètres du service Integration Services dans l'onglet Comptes de service de la page Configuration du serveur.

Par défaut, le service Integration Services est enregistré pour exécuter sous le compte Service Réseau intégré et le Type de démarrage est Automatique. Vous n'êtes pas tenu d'entrer un mot de passe pour le compte de service réseau intégré.

Fonctionnement du service Integration Services

Integration Services installe le service Integration Services, qui vous permet d'effectuer les tâches suivantes dans SQL Server Management Studio :

  • Gérer des packages et des dossiers Integration Services dans une vue hiérarchique. Les packages peuvent être stockés dans une instance du Moteur de base de données ou dans le système de fichiers.

  • Contrôler l'exécution des packages Integration Services en cours d'exécution sur un ordinateur.

Important :
Le service Integration Services n'est pas obligatoire pour créer, enregistrer et exécuter des packages Integration Services.

Le service Integration Services est installé lorsque vous sélectionnez l'option Integration Services dans la page Sélection de composant. Lorsque vous acceptez les paramètres par défaut de la page Configuration du serveur, le service Integration Services est activé et son Type de démarrage est Automatique.

Vous ne pouvez installer qu'une seule instance du service Integration Services sur un ordinateur. Le service n'est pas spécifique à une instance particulière du moteur de base de données. Vous vous connectez au service en utilisant le nom de l'ordinateur sur lequel le service s'exécute.

Pour gérer ce service, utilisez le Gestionnaire de configuration SQL Server ou le composant logiciel enfichable Services de la console MMC (Microsoft Management Console) en ouvrant les Outils d'administration à partir du Panneau de configuration. Pour plus d'informations, consultez Gestion du service Integration Services.

Par défaut, le service Integration Services est configuré pour gérer les packages qui sont stockés dans la base de données msdb, dans l'instance du moteur de base de données qui est installée au même moment qu'Integration Services. Si une instance du moteur de base de données n'est pas installée au même moment qu'Integration Services, le service Integration Services est configuré pour gérer les packages dans la base de données msdb de l'instance locale par défaut du Moteur de base de données. Pour gérer des packages qui sont stockés dans une instance nommée ou dans une instance distante du Moteur de base de données, ou encore dans plusieurs instances du Moteur de base de données, vous devez modifier le fichier de configuration. Pour plus d'informations sur la façon de modifier ce fichier de configuration, consultez Configuration du service Integration Services.

Par défaut, dans une nouvelle installation, Integration Services est configuré de façon à ne pas journaliser les événements en rapport avec l'exécution de packages dans le journal des événements des applications. Ce paramètre limite le nombre d'entrées de journal des événements lorsque vous utilisez la fonctionnalité du collecteur de données de SQL Server 2008. Les événements qui ne sont pas enregistrés incluent l'ID d'événement 12288, « le Package a démarré », et l'ID d'événement 12289, « le Package a fini avec succès ». Pour enregistrer ces événements dans le journal des événements des applications, ouvrez le Registre pour y apporter des modifications. Dans le Registre, recherchez le nœud HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\SSIS et modifiez la valeur DWORD du paramètre LogPackageExecutionToEventLog en remplaçant 0 par 1.

Installation d'Integration Services sur des ordinateurs 64 bits

Fonctionnalités d'Integration Services installées sur des ordinateurs 64 bits

L'installation installe différentes fonctionnalités Integration Services selon les options d'installation que vous sélectionnez :

  • Lorsque vous installez SQL Server et que vous sélectionnez Integration Services pour l'installation, l'ensemble des outils et des fonctionnalités Integration Services 64 bits sont installés.

  • Si vous avez besoin de fonctionnalités disponibles au moment de la conception Integration Services, vous devez également installer Business Intelligence Development Studio.

  • Si vous avez besoin des versions 32 bits des outils et du runtime Integration Services pour exécuter certains packages en mode 32 bits, vous devez également installer Business Intelligence Development Studio.

Les fonctionnalités 64 bits sont installées dans le répertoire Program Files et les fonctionnalités 32 bits sont installées séparément dans le répertoire Program Files (x86). (Ce comportement n'est pas spécifique à Integration Services ou SQL Server.)

Important :
Business Intelligence Development Studio (environnement de développement 32 bits des packages Integration Services) n'est pas pris en charge sur le système d'exploitation 64 bits Itanium et n'est pas installé sur les serveurs Itanium.

Pour plus d'informations, consultez Considérations 64 bits pour Integration Services.

Prise en charge des packages DTS (Data Transformation Services) sur des ordinateurs 64 bits

Aucune prise en charge au moment de la conception ou de l'exécution des packages DTS n'est proposée en mode 64 bits. Sur un ordinateur 64 bits, les packages DTS et les packages Integration Services qui exécutent des packages DTS ne peuvent s'exécuter qu'en mode 32 bits. Pour installer la version 32 bits de l'utilitaire dtexec (dtexec.exe), assurez-vous de sélectionner des outils clients ou Business Intelligence Development Studio pendant l'installation.

Il n'y a également aucune prise en charge 32 bits lors de la conception ou de l'exécution pour les packages DTS sur les systèmes d'exploitation Itanium. Par conséquent, vous ne pouvez pas créer, afficher, modifier ou exécuter des packages DTS sur les systèmes d'exploitation Itanium.

Installation de la prise en charge des packages DTS SQL Server 2000

SQL Server 2008 n'installe pas la prise en charge au moment de l'exécution des packages DTS. Vous devez installer cette prise en charge au moment de l'exécution avant de pouvoir exécuter et gérer des packages DTS. Pour plus d'informations sur la manière d'installer la prise en charge des DTS, consultez Procédure : installer la prise en charge des packages DTS.

Pour plus d'informations sur la prise en charge des DTS dans SQL Server 2008, consultez Prise en charge de DTS dans SQL Server 2008.

Voir aussi

Autres ressources

Configuration d'Integration Services dans un environnement cluster


Rubriques de procédures pour l'installation d'Integration Services

Rubriques de procédures pour l'installation d'Integration Services |
 | Voir aussi
Installation de SQL Server 2008 > Considérations sur l'installation de SQL Server Integration Services >

Cette section contient les procédures courantes suivantes pour installer Microsoft SQL Server Integration Services.

Pour prendre connaissance des procédures courantes de mise à niveau des services DTS (Data Transformation Services), consultez Rubriques de procédures sur la mise à niveau ou la migration de DTS (Data Transformation Services). Pour prendre connaissance des procédures courantes de migration des packages DTS, consultez Rubriques de procédures sur la migration des packages DTS (Data Transformation Services).

Important :
Les rubriques qui décrivent les procédures d'installation de Integration Services dans cette section décrivent uniquement les options d'installation spécifiques à Integration Services, mais contiennent des liens vers d'autres informations relatives à l'installation de SQL Server.

Dans cette section

  • Procédure : installer la prise en charge des packages DTS

Voir aussi

Concepts

Considérations sur l'installation de SQL Server Integration Services
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Procédure : installer la prise en charge des packages DTS

Procédure : installer la prise en charge des packages DTS
Installation de SQL Server 2008 > Considérations sur l'installation de SQL Server Integration Services > Rubriques de procédures pour l'installation d'Integration Services >

Les packages DTS (Data Transformation Services) peuvent continuer à s'exécuter parallèlement aux packages Integration Services sur le même ordinateur. Pour plus d'informations, consultez Prise en charge de DTS dans SQL Server 2008.

Pour utiliser des packages DTS avec des packages Integration Services, vous pouvez installer la prise en charge au moment de la conception et de l'exécution, comme décrit dans les sections suivantes.

Remarque :
Il n'existe également aucune prise en charge au moment de la conception ou de l'exécution pour les packages DTS sur les systèmes d'exploitation Itanium. Par conséquent, vous ne pouvez pas créer, afficher, modifier ou exécuter des packages DTS sur les systèmes d'exploitation Itanium.

Installation de la prise en charge des packages DTS

La prise en charge de DTS dans SQL Server 2008 comprend plusieurs composants, comme cela est décrit dans la rubrique Prise en charge de DTS dans SQL Server 2008. Bien que le programme d'installation puisse installer certains de ces composants, ces derniers ne sont pas entièrement tant que la prise en charge du runtime DTS n'est pas installée. Pour installer Integration Services avec toutes les fonctionnalités requises par la prise en charge de DTS, vous devez installer plusieurs éléments en procédant comme indiqué dans la procédure suivante.

Pour installer toutes les fonctionnalités qui prennent en charge DTS

  1. Au cours de l'installation, sur la page Sélection de composant, effectuez les sélections suivantes :

    1. Sélectionnez Integration Services.

      Cette option installe la tâche Script ActiveX et l'Assistant Migration de package DTS.

    2. Sélectionnez Compatibilité descendante des outils clients.

      Cette option installe la tâche d'exécution de package DTS 2000.

  2. Après l'exécution du programme d'installation, installez le runtime DTS comme décrit dans les sections « Installation de la prise en charge au moment de l'exécution pour les packages DTS sur un ordinateur 32 bits » et « Installation de la prise en charge au moment de l'exécution pour les packages DTS sur un ordinateur 32 bits », plus loin dans cette rubrique.

  3. (Facultatif) Après l'exécution du programme d'installation, installez le Concepteur DTS comme décrit dans la section « Installation de la prise en charge au moment du design des packages DTS », plus loin dans cette rubrique.

Installation de la prise en charge au moment de l'exécution pour les packages DTS sur un ordinateur 32 bits

SQL Server 2008 n'installe pas la prise en charge au moment de l'exécution des packages DTS. Avant de pouvoir exécuter et gérer des packages DTS, vous devez installer cette prise en charge au moment de l'exécution, comme décrit dans la procédure suivante.

Pour installer la prise en charge au moment de l'exécution des packages DTS (Data Transformation Services) sur un ordinateur 32 bits

  • Sur le support d'installation que vous avez utilisé pour installer SQL Server 2008, localisez et exécutez la version du package Windows Installer SQLServer2005_BC*.msi qui correspond au système d'exploitation.

    - ou -

  • Dans un navigateur Internet, ouvrez la page Microsoft SQL Server 2008 Feature Pack, puis téléchargez et installez les composants de compatibilité descendante Microsoft SQL Server 2005.

Installation de la prise en charge au moment de l'exécution pour les packages DTS sur un ordinateur 64 bits

Aucune prise en charge de l'exécution des packages DTS n'est proposée en mode 64 bits. Sur un ordinateur 64 bits, les packages DTS, et les packages Integration Services qui exécutent des packages DTS ne peuvent s'exécuter qu'en mode 32 bits. Pour exécuter des packages en mode 32 bits hors de BI Development Studio sur un ordinateur 64 bits, vous devez installer la version 32 bits du runtime et des utilitaires d'invite de commandes Integration Services.

Pour installer la version 32 bits du runtime et des utilitaires d'invite de commandes Integration Services sur un ordinateur 64 bits

  • Au cours de l'installation, sélectionnez Business Intelligence Development Studio pour installer la version 32 bits du runtime Integration Services, de l'utilitaire dtexec (dtexec.exe) et d'autres outils Integration Services.

Installation de la prise en charge au moment du design des packages DTS

SQL Server 2008 n'installe pas la prise en charge au moment de la conception des packages DTS. Avant de pouvoir utiliser les outils SQL Server 2008 pour ouvrir et consulter des packages DTS, vous devez télécharger et installer cette prise en charge au moment de la conception, comme décrit dans la procédure suivante.

Remarque :
Le concepteur de packages DTS que vous pouvez télécharger fonctionne avec les outils SQL Server 2008, mais les fonctionnalités du concepteur n'ont pas été mises à jour pour SQL Server 2008.

Pour installer la prise en charge au moment de la conception des packages DTS

  • Dans un navigateur Internet, ouvrez la page Web Feature Pack for Microsoft SQL Server 2005 puis téléchargez et installez les Composants du Concepteur DTS Microsoft SQL Server 2000.

Par défaut, les fichiers binaires pour SQL Server 2000 se trouvent dans le dossier %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn, alors que les fichiers binaires pour SQL Server 2008 se trouvent dans le dossier %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn. Du fait de ces emplacements par défaut, le chemin d'accès des fichiers binaires pour SQL Server 2000 peut apparaître dans la variable d'environnement PATH avant le chemin d'accès des fichiers binaires pour SQL Server 2008. Dans ce cas, un message d'erreur peut s'afficher lorsque vous essayez d'utiliser le Concepteur DTS. Pour résoudre cette erreur, copiez les fichiers requis par le concepteur vers un nouvel emplacement, comme décrit dans les procédures suivantes.

Pour vous assurer que le concepteur DTS peut être utilisé dans SQL Server Management Studio

  1. Copiez les fichiers SEMSFC.DLL, SQLGUI.DLL et SQLSVC.DLL du dossier %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn vers le dossier %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE.

  2. Copiez les fichiers SEMSFC.RLL, SQLGUI.RLL et SQLSVC.RLL du dossier %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn\Resources vers le dossier %ProgramFiles%\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Resources.

Pour garantir que le concepteur DTS peut être utilisé dans Business Intelligence Development Studio

  1. Copiez les fichiers SEMSFC.DLL, SQLGUI.DLL et SQLSVC.DLL du dossier %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn vers le dossier %ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE.

  2. Copiez les fichiers SEMSFC.RLL, SQLGUI.RLL et SQLSVC.RLL du dossier %ProgramFiles%\Microsoft SQL Server\80\Tools\Binn\Resources vers le dossier %ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\Resources.


Considérations sur l'installation de la réplication SQL Server

Considérations sur l'installation de la réplication SQL Server |
 | Voir aussi
Installation de SQL Server 2008 >

Les composants de réplication peuvent être installés à l'aide de l'Assistant Installation de SQL Server ou à l'invite de commandes. Installez la réplication lors de l'installation de SQL Server ou lors de la modification d'une instance existante.

Une fois que les composants de réplication sont installés, vous devez configurer le serveur avant de pouvoir utiliser la réplication. Pour plus d'informations, consultez Conception et implémentation (réplication) dans la documentation en ligne de SQL Server.

Important :
Si vous installez des composants de réplication lorsque vous modifiez une instance existante de SQL Server, vous devez arrêter et redémarrer l'Agent SQL Server une fois l'installation terminée. Cette action garantit que l'Agent SQL Server reconnaît les sous-systèmes de l'agent de réplication et peut appeler les agents de réplication à partir des étapes de travail.

Installation de la réplication à l'aide du programme d'installation

Pour installer la réplication lors de l'installation d'une nouvelle instance de SQL Server

  • Pour installer les composants de réplication, notamment les objets RMO (Replication Management Objects), sélectionnez Réplication SQL Server dans la page Sélection de composant de l'Assistant Installation.

Installation de la réplication à partir de l'invite de commandes

Pour installer la réplication lors de l'installation d'une nouvelle instance de SQL Server

  • Consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Voir aussi

Concepts

Installation de SQL Server 2008
Procédure : installer SQL Server 2008 à partir de l'invite de commandes
Fonctionnalités prises en charge par les éditions de SQL Server 2008


Directives pour l'installation des outils d'administration SQL Server

Directives pour l'installation des outils d'administration SQL Server |
 | Voir aussi
Installation de SQL Server 2008 >

Les outils d'administration SQL Server incluent les composants suivants :

  • SQL Server Management Studio

  • Générateur de profils SQL Server

  • Assistant Paramétrage de base de données SQL Server.

  • Outils d'invite de commandes, tels que sqlcmd.exe et osql.exe.

  • Compléments Business Intelligence Development Studio de Microsoft Visual Studio

Il est à noter que Business Intelligence Development Studio est une option séparée pendant l'installation de SQL Server.

Quel que soit le nombre d'instances de SQL Server, Analysis Services ou Reporting Services installées sur un ordinateur, une seule copie des outils d'administration SQL Server 2008 sera installée.

Les outils d'administration SQL Server 2008 peuvent s'exécuter côte à côte sur le même ordinateur avec d'anciennes versions d'outils d'administration SQL Server.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)
Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Référence

Éditions et composants de SQL Server 2008


Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server

Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server |
 | Voir aussi
Installation de SQL Server 2008 >

Les exemples de code et les exemples de bases de données pour SQL Server ne sont plus fournis avec le produit. Au lieu de cela, vous pouvez rechercher et télécharger les exemples de code et les exemples de bases de données à partir du site Web (en anglais) Microsoft SQL Server Samples and Community Projects à l'adresse http://www.codeplex.com/sqlserversamples. Dans les tableaux organisés par technologie, vous trouverez des liens hypertexte vers des exemples pour composants SQL Server et des exemples de bases de données SQL Server officiels. Ces tableaux fournissent également des liens vers les exemples et projets qui sont disponibles dans la communauté SQL Server.

Installation des exemples et des exemples de bases de données

Pour installer la totalité de l'ensemble d'exemples de produits, sur la page d'accueil des exemples et projets de communautés Microsoft SQL Server, cliquez sur l'onglet Versions. Notez que la version par défaut pour chaque projet est la version la plus récente. Il peut s'agir d'une version Community Technology Preview. Pour sélectionner une version antérieure, cliquez sur le nom de version dans le volet Version.

Sur CodePlex, vous pouvez localiser des projets spécifiques pour les exemples de produits pour un domaine technologique de SQL Server (Analysis Services, Moteur de base de données, Programmabilité des données, et ainsi de suite) en cliquant sur le lien de la technologie souhaitée dans la table des domaines technologiques de la page d'accueil Microsoft SQL Server Samples and Community Projects à l'adresse http://www.codeplex.com/sqlserversamples. Dans chaque projet spécifique, cliquez sur l'onglet Versions, puis cliquez sur le package Windows Installer pour télécharger l'ensemble d'exemples dans ce domaine technologique. Pour consulter le code des exemples dans ce domaine technologique, cliquez sur l'onglet Code source, puis cliquez sur l'icône de dossier dans la colonne Parcourir.

Remarque :
Si vous choisissez d'installer les exemples, par défaut les fichiers d'exemples sont installés à l'emplacement suivant : C:\Program Files\Microsoft SQL Server\100\Samples\<nom_technologie>.

Pour installer les exemples de base de données officiels pour SQL Server, accédez au site Web http://www.CodePlex.com/MSFTDBProdSamples. Autrement, sur la page d'accueil Microsoft SQL Server Samples and Community Projects, dans la section des exemples de base de données, cliquez sur le lien de téléchargement et sélectionnez les bases de données souhaitées.

Envoi de commentaires

Http://connect.microsoft.com et CodePlex fournissent un moyen direct de signaler des problèmes et de poser des questions sur les exemples de chaque domaine technologique. Pour signaler des problèmes et examiner l'état des problèmes que vous avez signalés, entrez un bogue à l'adresse : Http://connect.microsoft.com. Pour passer en revue différentes idées d'exemples, fournissez des commentaires à propos d'exemples existants ou posez des questions sur les exemples, cliquez sur l'onglet Discussions à Http://Connect.Microsoft.com/SqlServerSamples ou l'un des projets connexes. N'utilisez pas l'onglet Issues sur CodePlex pour signaler des défauts d'exemples.

Mise à jour de l'emplacement des exemples .NET Framework CLR.

Avant de compiler les exemples du CLR (Common Language Runtime) Microsoft .NET Framework pour SQL Server, vérifiez que le chemin d'accès de la version du compilateur .NET Framework correspond au premier répertoire Framework figurant dans la variable d'environnement PATH. L'emplacement du compilateur fourni avec cette version de SQL Server est C:\<Répertoire racine Windows>\Microsoft.NET\Framework\v2.0.x. Le lecteur C est le lecteur d'installation, <le répertoire racine Windows> est Windows ou WINNT, et x correspond à cinq chiffres.

Voir aussi

Concepts

Bases de données système et exemples de bases de données


Rubriques de procédures relatives à l'installation

Rubriques de procédures relatives à l'installation |
 | Voir aussi
Installation de SQL Server 2008 >

Utilisez les rubriques suivantes pour installer SQL Server 2008.

Dans cette section

Rubrique | Description
Procédure : installer SQL Server 2008 (programme d'installation) | Rubrique de procédure pour une installation SQL Server typique à l'aide de l'Assistant Installation.
Procédure : installer SQL Server 2008 à partir de l'invite de commandes | Rubrique de procédure qui fournit un exemple de syntaxe et de paramètres d'installation pour exécuter une installation sans assistance.
Procédure : ajouter des fonctionnalités à une instance de SQL Server 2008 (programme d'installation) | Rubrique de procédure pour mettre à jour une instance existante de SQL Server 2008.

Voir aussi

Concepts

Planification d'une installation SQL Server
Mise à niveau vers SQL Server 2008


Procédure : installer SQL Server 2008 (programme d'installation)

Procédure : installer SQL Server 2008 (programme d'installation) |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

L'Assistant Installation de SQL Server est basé sur Windows Installer. Il offre une arborescence unique de fonctionnalités pour installer tous les composants SQL Server et vous n'avez pas à installer les composants suivants un par un :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Outils de gestion

  • Composants de connectivité

  • Exemples de bases de données, exemples et documentation en ligne de SQL Server

Ces rubriques supplémentaires décrivent d'autres façons d'installer SQL Server 2008 :

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

  • Procédure : créer un cluster de basculement SQL Server (programme d'installation).

  • Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation).

Configuration requise

Avant d'installer SQL Server, consultez les rubriques dans Planification d'une installation SQL Server.

Remarque :
Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Pour installer SQL Server 2008

  1. Insérez le support d'installation SQL Server. Dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis redémarrez le programme d'installation de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation exécute le Centre d'installation SQL Server. Pour créer une installation de SQL Server 2008, cliquez sur Nouvelle installation ou ajouter des fonctionnalités à une installation existante.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. Dans la page Clé du produit, sélectionnez une case d'option pour indiquer si vous installez une édition gratuite de SQL Server ou une version de production du produit qui a une clé PID. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008.

  7. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions.

  8. L'Assistant Installation installera les composants SQL Server requis s'ils ne sont pas déjà présents sur l'ordinateur. Ces composants sont les suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  9. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive.

  10. Dans la page Sélection de fonctionnalités, sélectionnez les composants que vous voulez installer. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Vous pouvez choisir n'importe quelle combinaison de cases à cocher. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008.

    Vous pouvez également spécifier un répertoire personnalisé pour les composants partagés en utilisant le champ situé au bas de la page Sélection de fonctionnalités. Pour modifier le chemin d'installation des composants partagés, mettez à jour le nom du chemin d'accès dans le champ fourni en bas de la boîte de dialogue ou cliquez sur le bouton Parcourir pour accéder à un répertoire d'installation. Le chemin d'installation par défaut est C:\Program Files\Microsoft SQL Server\100\.

  11. Dans la page Configuration de l'instance, spécifiez s'il faut installer une instance par défaut ou une instance nommée. Pour plus d'informations, consultez Configuration d'une instance. Pour continuer, cliquez sur Suivant.

    Suffixe de l'ID d'instance — Par défaut, le nom de l'instance est utilisé comme suffixe de l'ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et le suffixe de l'ID d'instance seront MSSQLSERVER. Pour utiliser un suffixe d'ID d'instance non défini par défaut, activez la case à cocher Suffixe de l'ID d'instance et entrez une valeur.

    Remarque :
    Les instances autonomes typiques de SQL Server 2008, qu'il s'agisse d'instances par défaut ou d'instances nommées, n'utilisent pas de valeur non définie par défaut pour la case à cocher Suffixe de l'ID d'instance.

    Répertoire racine de l'instance — Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\100\. Pour spécifier un répertoire racine non défini par défaut, utilisez le champ fourni ou cliquez sur Parcourir pour rechercher un dossier d'installation.

    Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

    Instances et fonctionnalités détectées — La grille affiche les instances de SQL Server qui se trouvent sur l'ordinateur où le programme d'installation s'exécute. Si une instance par défaut est déjà installée sur l'ordinateur, vous devez installer une instance nommée de SQL Server 2008.

  12. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez. Elle compare ensuite cet espace à l'espace disque disponible. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  13. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  14. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

    Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte d'ouverture de session pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  15. Utilisez l'onglet Configuration du serveur — Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  16. Utilisez la page Configuration du Moteur de base de données – Mise en service du compte pour spécifier les éléments suivants :

    • Mode de sécurité — sélectionnez l'authentification Windows ou le mode d'authentification mixte pour votre instance de SQL Server. Si vous sélectionnez Mode d'authentification mixte, vous devez fournir un mot de passe fort pour le compte administrateur système SQL Server intégré.

      Lorsque la connexion d'un périphérique à SQL Server est établie, le mécanisme de sécurité est le même pour l'authentification Windows et le mode mixte. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    • Administrateurs SQL Server — Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou sur Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  17. Utilisez la page Configuration du Moteur de base de données – Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration du moteur de base de données – Répertoires de données.

  18. Utilisez la page Configuration du Moteur de base de données - FILESTREAM pour activer FILESTREAM pour votre instance de SQL Server. Pour plus d'informations, consultez Configuration du moteur de base de données - Filestream.

  19. Utilisez la page Configuration d'Analysis Services — Attribution de privilèges d'accès aux comptes pour spécifier les utilisateurs ou comptes qui ont les autorisations d'administrateur pour Analysis Services. Vous devez spécifier au moins un administrateur système pour Analysis Services. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour Analysis Services. Pour plus d'informations, consultez Configuration Analysis Services – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  20. Utilisez la page Configuration du Analysis Services — Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration de Analysis Services – Répertoires de données.

  21. Utilisez la page Configuration de Reporting Services pour spécifier le type d'installation de Reporting Services à créer. Vous pouvez choisir entre les options suivantes :

    • Configuration par défaut en mode Natif

    • Configuration par défaut en mode SharePoint

    • Installation de Reporting Services non configurée

    Pour plus d'informations sur les modes de configuration de Reporting Services, consultez Options d'installation du serveur de rapports.

  22. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  23. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  24. La page Prêt pour l'installation affiche une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  25. Au cours de l'installation, la page Progression de l'installation fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  26. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  27. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Configurer votre nouvelle installation de SQL Server

  • Pour réduire la surface d'exposition d'un système, SQL Server installe et active de façon sélective les services et les fonctionnalités clés. Pour plus d'informations, consultez Présentation de la configuration de la surface d'exposition sur MSDN.

  • Pour plus d'informations sur l'utilisation des outils graphiques et des utilitaires d'invite de commandes, consultez Configuration de SQL Server 2008.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Procédure : installer SQL Server 2008 à partir de l'invite de commandes

Procédure : installer SQL Server 2008 à partir de l'invite de commandes |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

Avant de démarrer le programme d'installation de SQL Server, lisez Planification d'une installation SQL Server.

L'installation d'une nouvelle instance de SQL Server à partir de l'invite de commandes vous permet de spécifier les composants à installer et la façon dont ils doivent être configurés. Vous pouvez également spécifier une interaction en mode silencieux, de base ou complète avec l'interface utilisateur du programme d'installation.

L'installation à partir de l'invite de commandes est prise en charge dans les scénarios suivants :

  • Installation, mise à niveau ou suppression d'une instance et des composants partagés de SQL Server 2008 sur un ordinateur local avec la syntaxe et les paramètres spécifiés à l'invite de commandes.

  • Installation, mise à niveau ou suppression d'une instance de cluster de basculement.

  • Mise à niveau à partir d'une édition de SQL Server 2008 vers une autre édition de SQL Server 2008.

  • Installation d'une instance de SQL Server 2008 sur un ordinateur local avec la syntaxe et les paramètres spécifiés dans un fichier de configuration. Vous pouvez utiliser cette méthode pour copier une configuration d'installation sur plusieurs ordinateurs ou bien pour installer plusieurs nœuds d'une installation de cluster de basculement.

Lorsque vous installez SQL Server à partir de l'invite de commandes, spécifiez des paramètres d'installation pour votre installation à l'invite de commandes dans le cadre de votre syntaxe d'installation.

Remarque :
Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant. Pour les installations de cluster de basculement, vous devez être un administrateur local autorisé à vous connecter en tant que service et à agir dans le cadre du système d'exploitation sur tous les nœuds du cluster de basculement.

Utilisation exacte des paramètres du programme d'installation

Utilisez les instructions suivantes pour développer des commandes d'installation ayant la syntaxe adéquate :

Copier le code
/PARAMETER
/PARAMETER=true/false

/FEATURES constitue une exception, car il s'agit d'un paramètre à valeurs multiples, mais son format est

  • /FEATURES=AS,RS,IS sans espace, avec une délimitation par des virgules

Notez l'utilisation des caractères d'échappement :

  • /INSTANCEDIR=c:\PathName est pris en charge.

  • /INSTANCEDIR=c:\PathName\ est pris en charge.

  • /INSTANCEDIR="c:\PathName\\" est pris en charge.

  • /INSTANCEDIR="c:\PathName\" n'est pas pris en charge.

Exemple de syntaxe

Utilisez les exemples de scripts suivants pour installer des composants SQL Server à l'invite de commandes. Ces scripts vous fournissent la syntaxe d'invite de commandes pour l'installation de SQL Server dans des scénarios utilisateur classiques. Testez et modifiez ces exemples selon les besoins de votre organisation.

Utilisation prise en charge des paramètres du programme d'installation

Utilisation des paramètres

Scénarios d'installation de base, y compris les services Moteur de base de données et les Outils d'administration

Scripts d'installation pour les scénarios d'installation de base

Scénarios d'installation de cluster de basculement

Scripts d'installation pour les scénarios d'installation de cluster de basculement

Scénarios d'installation d'Analysis Services

Scripts d'installation pour les scénarios d'installation d'Analysis Services

Scénarios d'installation de Reporting Services

Options et scripts d'installation pour Reporting Services

Scénarios d'installation d'Integration Services

Scripts d'installation pour les scénarios d'installation d'Analysis Services

Documentation de référence pour les paramètres d'installation

Paramètres d'installation

Comparaison des paramètres de programme d'installation entre les versions de SQL Server

Paramètres des versions précédentes de SQL Server

Scripts d'installation pour les scénarios d'installation de base

Testez et modifiez les scripts d'installation suivants selon les besoins de votre organisation.

Pour installer une nouvelle instance autonome avec tous les composants SQL Server

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=Install /FEATURES=SQL,AS,RS,IS,Tools,BIDS,BOL /INSTANCENAME=MSSQLSERVER /SECURITYMODE=SQL /SQLSYSADMINACCOUNTS="Builtin\Administrators" /SAPWD="StrongPassword" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="StrongPassword" /ASSYSADMINACCOUNTS="Builtin\Administrators" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="StrongPassword" /RSSVCACCOUNT="DomainName\UserName" /RSSVCPASSWORD="StrongPassword" /SQLBROWSERACCOUNT="DomainName\UserName" /SQLBROWSERPASSWORD="StrongPassword" /ISSVCACCOUNT="NT Authority\Network Service"
    Important :
    N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Remarque :
    Pour une instance par défaut, spécifiez « MSSQLSERVER » pour le paramètre /INSTANCENAME. Pour une instance nommée, spécifiez le nom de l'instance.

    Pour plus d'informations sur la configuration des comptes de service, consultez Configuration des comptes de service Windows. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.
Pour installer une nouvelle instance autonome avec les composants Moteur de base de données SQL Server, Réplication et Recherche en texte intégral

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=Install /FEATURES=SQL /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="DomainName\UserName" /AGTSVCACCOUNT="NT AUTHORITY\Network Service"

Important N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Remarque :
Pour une instance par défaut, spécifiez « MSSQLSERVER » pour le paramètre /INSTANCENAME. Pour une instance nommée, spécifiez le nom de l'instance.

 Pour installer les outils d'administration SQL Server uniquement

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /Action=Install /FEATURES=Tools
Pour installer SQL Server Express

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /FEATURES=SQL_Tools /INSTANCE=Express /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="BUILTIN\Administrators"
Use the /ENABLERANU parameter to enable RANU
Use the /ADDCURRENTUSERASSQLADMIN parameter to provision the user in the sysadmin role.
Pour mettre à niveau une instance existante ou un nœud de cluster de basculement existant à partir de SQL Server 2000 ou SQL Server 2005

  1. Avant de commencer, consultez la documentation relative à la mise à niveau dans Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau et Compatibilité ascendante. Il n'est pas nécessaire de spécifier les fonctionnalités à mettre à niveau.

  2. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  3. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=upgrade /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSUPGRADEDATABASEACCOUNT="<Provide a SQL Server logon account that can connect to the report server during upgrade>" /RSUPGRADEPASSWORD="<Provide a password for the report server upgrade account>"/ISSVCAccount="NT Authority\Network Service"

    Si vous mettez à niveau un nœud d'une instance de cluster de basculement, utilisez le paramètre /FAILOVERCLUSTERROLLOWNERSHIP pour contrôler le comportement du basculement avant que l'opération de mise à niveau ne mette le nœud hors ligne. L'utilisation de ce paramètre est la suivante :

    • /FAILOVERCLUSTERROLLOWNERSHIP=0 ne transfère pas la propriété du cluster aux nœuds mis à niveau et n'ajoute pas ce nœud à la liste des propriétaires possibles du cluster SQL Server au terme de la mise à niveau.

    • /FAILOVERCLUSTERROLLOWNERSHIP=1 transfère la propriété du cluster aux nœuds mis à niveau et ajoute ce nœud à la liste des propriétaires possibles du cluster SQL Server au terme de la mise à niveau.

    • /FAILOVERCLUSTERROLLOWNERSHIP=2 est le paramètre par défaut. Il sera utilisé si ce paramètre n'est pas spécifié. Ce paramètre indique que le programme d'installation de SQL Server gérera la propriété du cluster si nécessaire.

  4. Pour mettre à niveau les composants partagés uniquement, exécutez la commande suivante à une invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=upgrade

Important N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Remarque :
Pour une instance par défaut, spécifiez « MSSQLSERVER » pour le paramètre /INSTANCENAME. Pour une instance nommée, spécifiez le nom de l'instance.

 Pour mettre à niveau une instance existante de SQL Server 2008 vers une édition différente de SQL Server 2008

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=editionupgrade /INSTANCENAME=MSSQLSERVER /PID=<PID key for new edition>"

Important N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Remarque :
Pour une instance par défaut, spécifiez « MSSQLSERVER » pour le paramètre /INSTANCENAME. Pour une instance nommée, spécifiez le nom de l'instance. Si le nom de l'instance n'est pas spécifié, seuls les composants partagés seront mis à niveau.

 Pour installer SQL Server 2008 à l'aide d'un fichier de configuration

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=Install /Configurationfile=<path to ConfigurationFile.ini file>

    Après avoir exécuté le programme d'installation de SQL Server 2008, un fichier de configuration est généré et enregistré par défaut à l'emplacement suivant : <lecteur>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\<YYYYMMDD_HHMMSS\ConfigurationFile.ini. Ouvrez le fichier pour voir les descriptions des paramètres du programme d'installation et paramètres de l'installation qui a été effectuée. Vous pouvez utiliser le fichier de configuration pour reproduire des instances supplémentaires ou bien pour installer des nœuds supplémentaires d'une installation de cluster de basculement.

    Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Pour ajouter des composants à une instance existante de SQL Server

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=Install /INSTANCENAME=MSSQLSERVER /FEATURES=<Feature list>

    Remarque Pour ajouter des fonctionnalités à une instance nommée, utilisez le nom de l'instance au lieu de « MSSQLSERVER » dans l'exemple ci-dessus.
Pour désinstaller une instance existante de SQL Server

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. À une invite de commandes, naviguez jusqu'au répertoire suivant : %Program Files%\Microsoft SQL Server\100\Setup Bootstrap et tapez la commande suivante à l'invite de commandes :

    Copier le code
    Setup100.exe /Action=Uninstall /FEATURES=SQL,AS,RS,IS,Tools /INSTANCENAME=MSSQLSERVER

    Remarque Pour supprimer une instance nommée, utilisez le nom de l'instance au lieu de « MSSQLSERVER » dans l'exemple ci-dessus.

Scripts d'installation pour les scénarios d'installation de cluster de basculement

Il existe deux possibilités pour l'installation de cluster de basculement SQL Server :

  • L'installation intégrée installe et configure une instance de cluster de basculement à un seul nœud, en une seule étape.

  • L'installation avancée, également appelée installation entreprise, se compose de deux étapes : préparation d'une instance de cluster de basculement, puis exécution de l'installation pour créer une instance de cluster de basculement à un seul nœud.

Avant d'installer une instance de cluster de basculement SQL Server, consultez les rubriques suivantes :

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Considérations sur la sécurité pour une installation SQL Server

  • Avant l'installation du clustering de basculement

    Important :
    Toutes les commandes d'installation de cluster de basculement nécessitent un cluster Windows sous-jacent. Tous les nœuds qui feront partie d'un cluster de basculement SQL Server doivent faire partie du même cluster Windows.

Testez et modifiez les scripts d'installation de cluster de basculement suivants selon les besoins de votre organisation.

Pour installer un cluster de basculement SQL Server intégré à un seul nœud avec le moteur de base de données

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. À une invite de commandes, exécutez la commande suivante :

    Copier le code
    setup.exe /q /ACTION=InstallFailoverCluster /FEATURES=SQL /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /INSTANCEDIR="C:\Program Files\Microsoft SQL Server" /INSTALLSHAREDDIR="C:\Program Files\Microsoft SQL Server" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="XXXXXX" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="XXXXXX" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="CollationName"; default is SQL_Latin1_General_CP1_CS_AS" /FAILOVERCLUSTERGROUP="<Insert new Cluster Group name>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'" /FAILOVERCLUSTERIPADDRESSES="IPv4;XXX.XXX.XXX.XXX;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERNETWORKNAME="<Insert Failover Cluster Instance Name>" /SQLSYSADMINACCOUNTS=" DomainName\UserName " [/SECURITYMODE=SQL /SAPWD="StrongPassword"]
Pour installer un cluster de basculement SQL Server à un seul nœud avec Analysis Services

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=InstallFailoverCluster /FEATURES=AS /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /ASSYSADMINACCOUNTS="DomainName\UserName" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /ASDATADIR="<Drive>:\Data" /ASLOGDIR="<Drive>:\Log" /ASBACKUPDIR="<Drive>:\Backup" /ASCONFIGDIR="<Drive>:\Config" /ASTEMPDIR="<Drive>:\Temp" /FAILOVERCLUSTERGROUP="<Insert new Cluster Group name>" /FAILOVERCLUSTERDISKS="<Drive>:" /FAILOVERCLUSTERIPADDRESSES="IPv4; xxx.xxx.xxx.xxx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERNETWORKNAME="<Insert Failover Cluster Instance Name>" /INDICATEPROGRESS
Pour installer une instance de cluster de basculement SQL Server à un seul nœud avec le moteur de base de données et Analysis Services (instance par défaut)

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=InstallFailoverCluster /InstanceName=MSSQLSERVER /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - e.g., 'Disk S:'" /FAILOVERCLUSTERNETWORKNAME="<Insert Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="MSSQLSERVER" /Features=AS,SQL /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLSYSADMINACCOUNTS="DomainName\UserName
Pour installer une instance de cluster de basculement SQL Server à un seul nœud avec le moteur de base de données et Analysis Services (instance nommée)

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=InstallFailoverCluster /InstanceName=INSTANCE NAME /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Clister Disk Resource Name - e.g., 'Disk S:'" /FAILOVERCLUSTERNETWORKNAME="<Insert Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="NAMED_INSTANCE" /Features=AS,SQL /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /INSTALLSQLDATADIR="<Drive>:\<Path>\<INSTANCE NAME>\" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLSYSADMINACCOUNTS="DomainName\UserName"

Scénarios avancés pour l'installation de cluster de basculement :

Les deux exemples suivants créent une instance de cluster de basculement du Moteur de base de données en deux étapes : une étape pour préparer l'instance de cluster de basculement et l'autre pour exécuter le processus.

Testez et modifiez les scripts d'installation selon les besoins de votre organisation.

Pour effectuer l'étape « préparatoire » d'un scénario avancé d'installation d'un cluster de basculement pour le moteur de base de données (étape 1 sur 2)

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup.exe /q /ACTION=PrepareFailoverCluster /FEATURES=SQL /INSTANCENAME="<Insert Instance Name>" [/INSTANCEIDSUFFIX="<Insert InstanceID Suffix>"] /INSTANCEDIR="<Drive>:\Program Files\Microsoft SQL Server" /INSTALLSHAREDDIR="<Drive>:\Program Files\Microsoft SQL Server" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="XXXXXX" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="XXXXXX" /SQLDOMAINGROUP="DomainName\DomainGroup"
Pour effectuer l'étape « exécutoire » d'un scénario avancé d'installation d'un cluster de basculement pour le moteur de base de données (étape 2 sur 2). Exécutez la commande suivante sur l'ordinateur qui constituera le nœud actif dans le cluster de basculement pour le rendre utilisable. Vous devez exécuter l'action « CompleteFailoverCluster » sur le nœud qui possède le disque partagé dans le cluster de basculement SQL Server.

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=CompleteFailoverCluster /INSTANCENAME="<Insert Instance Name>" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Name>" /FAILOVERCLUSTERGROUP="Insert New Cluster Group>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - e.g., 'Disk S:'>" /FAILOVERCLUSTERIPADDRESSES="IPv4;XXX.XXX.XXX.XXX;Local Area Connection;xxx.xxx.xxx.x" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSYSADMINACCOUNTS="DomainName\UserName" [/SECURITYMODE=SQL /SAPWD="StrongPassword"]

Les deux exemples suivants créent une instance de cluster de basculement Analysis Services en deux étapes. Testez et modifiez les scripts d'installation selon les besoins de votre organisation.

Pour effectuer l'étape « préparatoire » d'un scénario avancé d'installation d'un cluster de basculement pour Analysis Services (étape 1 sur 2)

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=PrepareFailoverCluster /FEATURES=AS /InstanceName="<Insert Instance Name>" /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /INDICATEPROGRESS
Pour effectuer l'étape « exécutoire » d'un scénario avancé d'installation d'un cluster de basculement pour Analysis Services (étape 2 sur 2). Exécutez la commande suivante sur l'ordinateur qui constituera le nœud actif dans le cluster de basculement pour le rendre utilisable. Vous devez exécuter l'action « CompleteFailoverCluster » sur le nœud qui possède le disque partagé dans le cluster de basculement Analysis Services.

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=CompleteFailoverCluster /INSTANCENAME="<Insert Instance Name>" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Name>" /FAILOVERCLUSTERGROUP="<Insert New Cluster Group>" /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xxx.xxx.xxx.xxx;Local Area Connection;xxx.xxx.xxx.x" /ASSYSADMINACCOUNTS="DomainName\UserName" /ASDATADIR="<Drive>:\NEW_KATMAI\Data" /ASLOGDIR="<Drive>:\NEW_KATMAI\Log" /ASBACKUPDIR="Drive:\NEW_KATMAI\Backup" /ASCONFIGDIR="<Drive>:\NEW_KATMAI\Config" /ASTEMPDIR="<Drive>:\NEW_KATMAI\Temp" /INDICATEPROGRESS

Les deux exemples suivants créent une instance de cluster de basculement SQL Server avec le moteur de base de données et Analysis Services en deux étapes. Testez et modifiez les scripts d'installation selon les besoins de votre organisation.

Pour effectuer l'étape « préparatoire » d'un scénario avancé d'installation d'un cluster de basculement pour le moteur de base de données et Analysis Services (étape 1 sur 2)

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. À l'invite de commandes, exécutez la commande suivante pour préparer une instance par défaut :

    Copier le code
    setup.exe /q /ACTION=PrepareFailoverCluster /InstanceName=MSSQLSERVER /Features=AS,SQL /INDICATEPROGRESS /ASSVCACCOUNT="DomainName\UserName" /ASSVCPASSWORD="xxxxxxxxxxx" /ASDOMAINGROUP="DomainName\DomainGroup" /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="xxxxxxxxxxx" /SQLDOMAINGROUP="DomainName\DomainGroup" /AGTSVCACCOUNT="DomainName\UserName" /AGTSVCPASSWORD="xxxxxxxxxxx"

À l'invite de commandes, exécutez la commande suivante pour préparer une instance nommée :

 Pour effectuer l'étape « exécutoire » d'un scénario avancé d'installation d'un cluster de basculement pour le moteur de base de données et Analysis Services (étape 2 sur 2). Exécutez la commande suivante sur l'ordinateur qui constituera le nœud actif dans le cluster de basculement pour le rendre utilisable. Vous devez exécuter l'action « CompleteFailoverCluster » sur le nœud qui possède le disque partagé dans le cluster de basculement Analysis Services.

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. À l'invite de commandes, exécutez la commande suivante pour effectuer l'installation du cluster de basculement pour une instance par défaut :

    Copier le code
    setup.exe /q /ACTION=CompleteFailoverCluster /InstanceName=MSSQLSERVER /INDICATEPROGRESS /ASSYSADMINACCOUNTS="DomainName\Username" /ASDATADIR=<Drive>:\OLAP\Data /ASLOGDIR=<Drive>:\OLAP\Log /ASBACKUPDIR=<Drive>:\OLAP\Backup /ASCONFIGDIR=<Drive>:\OLAP\Config /ASTEMPDIR=<Drive>:\OLAP\Temp /FAILOVERCLUSTERDISKS="<Cluster Disk Resource Name - for example, 'Disk S:'>:" /FAILOVERCLUSTERNETWORKNAME="<Insert FOI Network Name>" /FAILOVERCLUSTERIPADDRESSES="IPv4;xx.xxx.xx.xx;Local Area Connection;xxx.xxx.xxx.x" /FAILOVERCLUSTERGROUP="MSSQLSERVER" /INSTALLSQLDATADIR="<Drive>:\<Path>\MSSQLSERVER" /SQLCOLLATION="SQL_Latin1_General_CP1_CS_AS" /SQLSYSADMINACCOUNTS="DomainName\UserName"

À l'invite de commandes, exécutez la commande suivante pour effectuer l'installation du cluster de basculement pour une instance nommée :

Scénarios d'ajout et de suppression de nœud :

Utilisez la syntaxe suivante pour ajouter des nœuds à une instance de cluster de basculement SQL Server existante ou en supprimer. L'action AddNode rassemble les informations relatives aux fonctionnalités et paramètres à partir du nœud actif, installe les composants nécessaires et joint le nouveau nœud au cluster de basculement SQL Server existant. L'action AddNode peut être utilisée pour les scénarios intégrés comme avancés.

Testez et modifiez les scripts d'installation selon les besoins de votre organisation.

Pour ajouter un nœud à une instance de cluster de basculement existante avec le moteur de base de données

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /SQLSVCACCOUNT="<SQL account used on other nodes>" /SQLSVCPASSWORD="<password for SQL account>" /AGTSVCACCOUNT="<SQL Server Agent account used on other nodes>", /AGTSVCPASSWORD="<SQL Server Agent account password>"
Pour ajouter un nœud à une instance de cluster de basculement existante avec Analysis Services

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /ASSVCACCOUNT="<AS account used on other nodes>" /ASSVCPASSWORD=”<password for AS account>” /INDICATEPROGRESS
Pour ajouter un nœud à une instance de cluster de basculement existante avec le moteur de base de données et Analysis Services

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=AddNode /INSTANCENAME="<Insert Instance Name>" /SQLSVCACCOUNT="<SQL account used on other nodes>" /SQLSVCPASSWORD="<password for SQL account>" /AGTSVCACCOUNT="<SQL Server Agent account used on other nodes>", /AGTSVCPASSWORD="<SQL Server Agent account password>" /ASSVCACCOUNT="<AS account used on other nodes>" /ASSVCPASSWORD=”<password for AS account>” /INDICATEPROGRESS

Pour supprimer complètement une instance de cluster de basculement SQL Server, utilisez l'action REMOVENODE sur chaque nœud du cluster de basculement. Testez et modifiez les scripts selon les besoins de votre organisation.

Pour supprimer un nœud d'une instance de cluster de basculement existante avec le moteur de base de données

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]
Pour supprimer un nœud d'une instance de cluster de basculement existante avec Analysis Services

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]
Pour supprimer un nœud d'une instance de cluster de basculement existante avec le moteur de base de données et Analysis Services

  1. Insérez le support d'installation de SQL Server 2008 dans le lecteur de disque et ouvrez le dossier racine.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=RemoveNode /INSTANCENAME="<Insert Instance Name>" [/INDICATEPROGRESS]

Scripts d'installation pour Analysis Services

Pour installer ou mettre à niveau Analysis Services à une invite de commandes, spécifiez « AS » comme l'une des valeurs pour l'option de ligne de commande FEATURES. Par exemple, pour installer Analysis Services, vous spécifieriez /FEATURES=AS sur la ligne de commande.

Le tableau suivant indique les paramètres requis pour installer une instance de Analysis Services.

Paramètre | Valeur par défaut | Description
ASBACKUPDIR | C:\Program Files\Microsoft SQL Server\<ID_instance>\OLAP\Backup Par exemple, l'ID d'instance peut revêtir la forme MSAS10.MSSQLSERVER. | Spécifie le dossier dans lequel les fichiers de sauvegarde de Analysis Services sont stockés.
ASCOLLATION | Latin1_General_CI_AS | Spécifie le paramètre de classement pour Analysis Services.
ASCONFIGDIR | C:\Program Files\Microsoft SQL Server\<ID_instance>\OLAP\Config | Spécifie le dossier dans lequel les fichiers de configuration de Analysis Services sont installés.
ASDATADIR | C:\Program Files\Microsoft SQL Server\<ID_instance>\OLAP\Data | Spécifie le dossier de génération des cubes d'Analysis Services.
ASLANGUAGE | 1033 | Spécifie l'identificateur de paramètres régionaux (LCID). La valeur 1033 représente Anglais (États-Unis).
ASLOGDIR | C:\Program Files\Microsoft SQL Server\<ID_instance>\OLAP\Log | Spécifie le dossier dans lequel les fichiers journaux Analysis Services sont stockés.
ASPROVIDERMSOLAP | 1 | Spécifie si le fournisseur MSOLAP peut s'exécuter in-process.
ASSVCACCOUNT | Compte système local | Définit le domaine de compte et le nom de connexion du service MSSQLServerOLAPService. Utilisez l'argument ASSVCPASSWORD pour définir le mot de passe correspondant au nom de connexion. Si vous ne spécifiez aucun argument, la valeur par défaut est utilisée.
ASSVCPASSWORD | vide | Spécifie le mot de passe du compte de service MSSQLServerOLAPService qui correspond au nom de connexion spécifié par l'argument ASSVCACCOUNT. La spécification d'un mot de passe vierge provoquera une erreur. Pour utiliser un mot de passe vierge, ne spécifiez pas ce paramètre.
ASSVCSTARTUPTYPE | Automatique | Spécifie si le service MSSQLServerOLAPService démarre automatiquement lors du redémarrage du système d'exploitation Windows. Les options sont Automatique, Désactivé, ou Manuel.
ASSYSADMINACCOUNTS | vide | Spécifie le mot de passe de compte d'administrateur MSSQLServerOLAPService.
ASTEMPDIR | C:\Program Files\Microsoft SQL Server\<ID_instance>\OLAP\Temp | Spécifie le dossier dans lequel les fichiers temporaires Analysis Services sont stockés.
ERRORREPORTING | 0 | Spécifie si le rapport d'erreurs est activé ou désactivé. Pour activer le rapport d'erreurs, spécifiez 1. Sinon, spécifiez 0.
SQMREPORTING | 0 | Spécifie si SQM (Software Quality Monitoring) est activé. Pour activer la création de rapports SQM, spécifiez 1. Sinon, spécifiez 0.

Testez et modifiez les scripts d'installation Analysis Services suivants selon les besoins de votre organisation.

Pour installer une nouvelle instance par défaut d'Analysis Services et des Outils d'administration.

  1. Insérez le support d'installation dans le lecteur de disque et ouvrez le dossier à l'emplacement <CD_ou_lecteur_DVD>:\SQLDev\Servers\, ou naviguez jusqu'au dossier de génération réseau \\..\SQLDev\Servers\.

  2. À une invite de commandes, exécutez la commande suivante :

    Copier le code
                    setup.exe /ACTION=install /FEATURES=AS,Tools /INSTANCENAME=MSSQLSERVER /ASSVCACCOUNT =<DomainName\UserName> /ASSVCPASSWORD =<StrongPassword>

    Important N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.
Pour mettre à niveau une instance existante de SQL Server 2000 Analysis Services ou SQL Server 2005 Analysis Services

  1. Insérez le support d'installation dans le lecteur de disque et ouvrez le dossier à l'emplacement <CD_ou_lecteur_DVD>:\SQLDev\Servers\, ou naviguez jusqu'au dossier de génération réseau \\..\SQLDev\Servers\..

  2. À une invite de commandes, exécutez la commande suivante :

    Copier le code
                    setup.exe /ACTION=upgrade /FEATURES=AS /INSTANCENAME=<InstanceName>
Pour réparer une installation SQL Server 2008 Analysis Services

  1. Insérez le support d'installation dans le lecteur de disque et ouvrez le dossier à l'emplacement <CD_ou_lecteur_DVD>:\SQLDev\Servers\, ou naviguez jusqu'au dossier de génération réseau \\..\SQLDev\Servers\..

  2. À une invite de commandes, exécutez la commande suivante :

    Copier le code
                    setup.exe /ACTION=repair /FEATURES=AS /INSTANCENAME=<InstanceName> /ASSVCACCOUNT =<DomainName\UserName> /ASSVCPASSWORD=<StrongPassword>
Pour désinstaller une instance d'Analysis Services

  1. Insérez le support d'installation dans le lecteur de disque et ouvrez le dossier à l'emplacement <CD_ou_lecteur_DVD>:\SQLDev\Servers\, ou naviguez jusqu'au dossier de génération réseau \\..\SQLDev\Servers\..

  2. À une invite de commandes, exécutez la commande suivante :

    Copier le code
                    setup.exe /ACTION=uninstall /FEATURES=AS /INSTANCENAME=<InstanceName>

Options et scripts d'installation pour Reporting Services

Pour installer ou mettre à niveau Reporting Services à partir de l'invite de commandes, spécifiez « RS » comme l'une des valeurs pour l'option de ligne de commande /FEATURES. Reporting Services reconnaît l'instance ; vous devez par conséquent spécifier le paramètre /INSTANCENAME. Utilisez les options suivantes pour configurer une installation de Reporting Services :

Option Valeurs valides Obligatoire Description

RSInstallMode

FilesOnlyMode

DefaultNativeMode

DefaultSharePointMode

Facultative

FilesOnlyMode installe les fichiers programme Reporting Services. FilesOnlyMode est la valeur par défaut. Si vous spécifiez ce mode, vous devez effectuer toutes les étapes de configuration à l'aide de l'outil de configuration de Reporting Services une fois l'installation terminée. Ce mode est requis si vous souhaitez installer Reporting Services en tant qu'instance nommée ou si vous souhaitez utiliser une instance du Moteur de base de données distante pour héberger la base de données du serveur de rapports.

DefaultNativeMode installe et configure le serveur de rapports en utilisant des valeurs par défaut pour le compte de service, la base de données et les URL.

DefaultSharePointMode installe et configure le serveur de rapports en utilisant des valeurs par défaut, à l'exception de la propriété système SharePointIntegratedMode, qui a la valeur True. Une fois l'installation terminée, le serveur de rapports ne sera pas opérationnel tant que vous n'aurez pas installé Windows SharePoint Services (WSS) 3.0 ou Microsoft Office SharePoint Server (MOSS) 2007. Vous devrez ensuite encore joindre le serveur de rapports à la batterie de serveurs SharePoint et configurer les paramètres d'intégration pour l'application Web SharePoint.

RSSVCACCOUNT

<domaine>\<utilisateur>

"NT AUTHORITY\NETWORK SERVICE"

"NT AUTHORITY\LOCAL SYSTEM"

"NT AUTHORITY\LOCAL SERVICE"

Oui

Spécifie le compte de service du service Report Server. Si vous spécifiez un compte d'utilisateur de domaine, le nom de domaine doit comporter moins de 254 caractères et le nom du compte d'utilisateur doit comporter moins de 20 caractères.

RSSVCPASSWORD

Si vous spécifiez un compte intégré, vous pouvez omettre cette valeur. Sinon, spécifiez le mot de passe du compte d'utilisateur de domaine.

Oui

Spécifiez un mot de passe fort pour le compte. Un mot de passe fort comporte au moins huit caractères et inclut une combinaison de signes alphanumériques minuscules et majuscules et au moins un caractère spécial.

RSSVCSTARTUPTYPE

Manuel

Automatique

Désactivé

Non

Spécifie le type de démarrage du service. La valeur par défaut est Automatique.

RSUPGRADEDATABASEACCOUNT

Connexion de base de données pour une base de données de serveur de rapports distante.

Requise si les informations d'identification que vous utilisez pour exécuter le programme d'installation ne disposent pas d'autorisations sysadmin ou de propriétaire de base de données sur la base de données du serveur de rapports.

Spécifie une connexion de base de données SQL Server utilisée de manière ponctuelle durant une opération de mise à niveau pour la connexion à l'instance du Moteur de base de données qui héberge la base de données du serveur de rapports. Le compte doit avoir l'autorisation de mettre à jour le schéma de base de données du serveur de rapports.

Cette valeur doit être spécifiée si vous mettez à niveau un serveur de rapports qui utilise une base de données de serveur de rapports distante pour stocker des données d'application et que les informations d'identification que vous avez utilisées pour exécuter le programme d'installation ne disposent pas d'autorisations suffisantes sur le serveur distant.

RSUPGRADEPASSWORD

Mot de passe pour la connexion ou une chaîne vide si la connexion n'a pas de mot de passe.

Cette valeur doit être spécifiée si l'option RSUPGRADEDATABASEACCOUNT est spécifiée.

Testez et modifiez les scripts d'installation suivants selon les besoins de votre organisation.

Pour installer des applications serveur Reporting Services en mode fichiers uniquement comme instance par défaut à l'aide de valeurs par défaut

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    Setup /q /ACTION=install /FEATURES=RS /INSTANCENAME=MSSQLSERVER /RSSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE"

Si vous prévoyez d'utiliser des valeurs par défaut, la ligne de commande peut inclure des arguments minimaux. Cet exemple installe un serveur de rapports non configuré en mode fichiers uniquement sans outils clients, où le compte de service s'exécute comme Service réseau. Notez que l'option /RSINSTALLMODE n'est pas spécifiée. Cela est dû au fait que le mode fichiers uniquement est le mode d'installation par défaut ; il est utilisé si aucun autre mode n'est spécifié.

Reporting Services requiert une instance du Moteur de base de données pour le stockage des données d'application. Si vous souhaitez utiliser une instance existante du Moteur de base de données pour les bases de données du serveur de rapports, vous devez installer Reporting Services en mode fichiers uniquement afin de pouvoir spécifier un serveur de base de données à utiliser une fois l'installation achevée. Pour plus d'informations sur le mode fichiers uniquement, consultez Installation de fichiers uniquement (Reporting Services).

 Pour installer Reporting Services, le service Moteur de base de données et les outils clients sur un ordinateur unique en mode natif dans la configuration par défaut

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup /q /ACTION=install /FEATURES=SQL,RS,TOOLS /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /RSSVCACCOUNT="Adventure-Works\RSUserAcct" /RSSVCPASSWORD="Som#Pas$w0rd" /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /AGTSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /RSSVCSTARTUPTYPE="Manual" /RSINSTALLMODE="DefaultNativeMode"

Ce script installe également le Concepteur de rapports dans Business Intelligence Development Studio et SQL Server Management Studio. Pour satisfaire les spécifications de la configuration par défaut, le Moteur de base de données est également installé dans la même instance que le serveur de rapports. Ce script inclut l'ensemble complet d'arguments de ligne de commande pour une installation du serveur de rapports, avec des valeurs autre que les valeurs par défaut et des informations d'identification fictives. Pour plus d'informations sur les modes de configuration par défaut, consultez Configuration par défaut pour une installation en mode natif (Reporting Services) et Configuration par défaut pour le mode intégré SharePoint (Reporting Services).

 Pour mettre à niveau un serveur de rapports SQL Server 2005 qui utilise une base de données de serveur de rapports distante

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup /q /ACTION=upgrade /INSTANCENAME=MSSQLSERVER /RSUPGRADEDATABASEACCOUNT="Adventure-Works\RSUserAcct" /RSUPGRADEPASSWORD ="Som#Pas$w0rd"

Les fonctionnalités et composants d'installation dans l'instance sont mis à niveau vers la nouvelle version ; vous ne pouvez pas mettre à niveau des fonctionnalités spécifiques dans la même instance.

Ce script nécessite que vous spécifiiez des informations d'identification pour connexion ponctuelle à l'instance de Moteur de base de données distante qui héberge la base de données du serveur de rapports. Vous pouvez omettre RSUPGRADEDATABASEACCOUNT si vous disposez d'autorisations sysadmin ou de mise à jour de base de données sur le serveur distant. Pour plus d'informations sur la mise à niveau d'un serveur de rapports, consultez Considérations sur la mise à niveau de Reporting Services.

 Pour désinstaller Reporting Services, le Moteur de base de données et les outils clients

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup /q /ACTION=uninstall /FEATURES=SQL,RS,Tools /INSTANCENAME=MSSQLSERVER

Scripts d'installation pour Integration Services

Integration Services est généralement installé ou mis à niveau en même temps qu'une instance du Moteur de base de données SQL Server. Bien que vous puissiez concevoir et exécuter des packages Integration Services sans instance du Moteur de base de données, vous ne pouvez pas stocker de packages SQL Server 2008 Integration Services dans SQL Server à moins qu'une instance du Moteur de base de données SQL Server 2008 ne soit disponible.

Pour installer ou mettre à niveau Integration Services à partir de l'invite de commandes, spécifiez « IS » comme l'une des valeurs pour l'option de ligne de commande FEATURES. Utilisez les options suivantes pour configurer le compte de service Integration Services :

Option | Obligatoire ? | Description
ISSVCAccount | Obligatoire | Compte qui exécutera le service Integration Services. Le compte recommandé est NT AUTHORITY\SERVICE RESEAU.
ISSVCPassword | Obligatoire | Mot de passe pour le compte spécifié comme ISSVCAccount. Lors de l'utilisation du compte Service réseau, spécifiez un mot de passe vide.
ISSVCStartupType | Facultative | Type de démarrage pour le service. Les valeurs valides sont Automatic, Manual ou Disabled. La valeur par défaut est Automatic.
Remarque :
Integration Services n'est pas spécifique à l'instance. Vous ne pouvez installer qu'une seule instance d'Integration Services sur un ordinateur. Vous vous connectez au service à partir des outils d'administration et des applications clientes en utilisant le nom du serveur sur lequel le service s'exécute.

Testez et modifiez les scripts d'installation suivants selon les besoins de votre organisation.

Pour installer Integration Services avec les paramètres par défaut avec une instance du Moteur de Base de données SQL Server et les outils clients

  1. Insérez le support d'installation de SQL Server dans le lecteur de disque.

  2. Exécutez la commande suivante à l'invite de commandes :

    Copier le code
    setup.exe /q /ACTION=install /FEATURES=SQL,IS,Tools /ISSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="DomainName\UserName" /SQLSVCPASSWORD="StrongPassword" /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /AGTACCOUNT="DomainName\UserName" /AGTPASSWORD="StrongPassword"

Important N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Remarque :
Pour l'instance par défaut du Moteur de base de données, spécifiez « MSSQLSERVER » pour <InstanceName>. Pour une instance nommée, spécifiez le nom de l'instance. Dans cet exemple, l'instance par défaut est spécifiée.

Paramètres pour l'installation de SQL Server

Utilisez les paramètres proposés dans le tableau ci-dessous pour développer des scripts d'installation à partir de l'invite de commandes.

Composants SQL Server | Nom du paramètre | Description | Valeurs acceptées
Analysis Services | /ASBACKUPDIR | Spécifie le répertoire pour les fichiers de sauvegarde Analysis Services. |
Analysis Services | /ASCOLLATION | Spécifie le paramètre de classement pour Analysis Services. |
Analysis Services | /ASCONFIGDIR | Spécifie le répertoire pour les fichiers de configuration Analysis Services. |
Analysis Services | /ASDATADIR | Spécifie le répertoire pour les fichiers de données Analysis Services. |
Analysis Services | /ASLANGUAGE | Spécifie les paramètres régionaux pour Analysis Services. |
Analysis Services | /ASLOGDIR | Spécifie le répertoire pour les fichiers journaux Analysis Services. |
Analysis Services | /ASSVCACCOUNT | Spécifie le compte pour le service Analysis Services. |
Analysis Services | /ASSVCPASSWORD | Spécifie le mot de passe pour le service Analysis Services. |
Analysis Services | /ASSVCSTARTUPTYPE | Spécifie le mode de démarrage pour le service Analysis Services. | 2=Automatique, 4=Désactivé, 3=Manuel
Analysis Services | /ASSYSADMINACCOUNTS | Spécifie les informations d'identification d'administrateur pour Analysis Services. |
Analysis Services | /ASTEMPDIR | Répertoire pour les fichiers temporaires Analysis Services. |
Analysis Services | /ASPROVIDERMSOLAP | Spécifie si le fournisseur MSOLAP peut s'exécuter in-process. | 1=activé, 0=désactivé
Moteur de base de données | /ENABLERANU | Active les informations d'identification Exécuter en tant que pour les installations SQL Server Express. |
Moteur de base de données | /INSTALLSQLDATADIR | Spécifie le répertoire de données pour les fichiers de données SQL Server. | 1=activé, 0=désactivé
Moteur de base de données | /REBUILDDATABASES |  |
Moteur de base de données | /SAPWD |  |
Moteur de base de données | /SECURITYMODE |  | /SECURITYMODE="SQL"
Moteur de base de données | /SQLBACKUPDIR |  |
Moteur de base de données | /SQLCOLLATION |  |
Moteur de base de données | /SQLSVCACCOUNT |  |
Moteur de base de données | /SQLSVCPASSWORD |  |
Moteur de base de données | /SQLSVCStartuptype | Spécifie le mode de démarrage pour le service SQL Server. | 2=Automatique, 4=Désactivé, 3=Manuel
Moteur de base de données | /SQLSYSADMINACCOUNTS | Utilisez ce paramètre pour configurer les utilisateurs dans SQL Server. |
Moteur de base de données | /SQLTEMPDBDIR |  |
Moteur de base de données | /SQLTEMPDBLOGDIR |  |
Moteur de base de données | /SQLUSERDBDIR |  |
Moteur de base de données | /SQLUSERDBLOGDIR |  |
Integration Services | /ISSVCAccount | Spécifie le compte pour Integration Services. | Nom_domaine\Nom_utilisateur ou Compte système
Integration Services | /ISSVCPassword | Spécifie le mot de passe Integration Services. | Obligatoire uniquement pour un compte de domaine.
Integration Services | /ISSVCStartupType | Spécifie le type de démarrage pour le service Integration Services. |
Extension NLRegS du DP | /NPENABLED |  |
Extension NLRegS du DP | /TCPENABLED |  |
Reporting Services | /RSInstallMode |  |
Reporting Services | /RSSVCACCOUNT |  |
Reporting Services | /RSSVCPASSWORD |  |
Reporting Services | /RSSVCStartupType |  |
Reporting Services | /RSUPGRADEDATABASEACCOUNT |  |
Reporting Services | /RSUPGRADEPASSWORD |  |
SQL Server Browser | /BROWSERSVCStartupType | Spécifie le mode de démarrage pour le service SQL Server Browser. | 2=Automatique, 4=Désactivé, 3=Manuel
Agent SQL Server | /AGTSVCACCOUNT | Spécifie le compte pour le service SQL Server. | Nom_domaine\Nom_utilisateur ou Compte système
Agent SQL Server | /AGTSVCPASSWORD | Spécifie le mot de passe SQL Server Agent. | Obligatoire uniquement pour un compte de domaine.
Agent SQL Server | /AGTSVCSTARTUPTYPE | Spécifie le mode de démarrage pour le service SQL Server Agent. | 2=Automatique, 4=Désactivé, 3=Manuel
Programme d'installation de SQL Server | /ACTION | Spécifie un flux de travail de programme d'installation. | Install, Uninstall ou Upgrade
Programme d'installation de SQL Server | /ERRORREPORTING | Rapport d'erreurs pour SQL Server. | 1=activé ; 0=désactivé
Programme d'installation de SQL Server | /FEATURES | Spécifie les composants à installer, désinstaller ou mettre à niveau. | SQL, SQLEngine, Replication, FullText, AS, RS, IS, TOOLS, BIDS, BOL
Programme d'installation de SQL Server | /HELP, H, ? | Affiche les options d'utilisation pour les paramètres d'installation. |
Programme d'installation de SQL Server | /INDICATEPROGRESS | Spécifie que le fichier journal d'installation en clair sera dirigé vers la console. |
Programme d'installation de SQL Server | /INSTALLSHAREDDIR | Spécifie un répertoire d'installation différent du répertoire par défaut pour les composants 64 bits. |
Programme d'installation de SQL Server | /INSTALLSHAREDWOWDIR | Spécifie un répertoire d'installation différent du répertoire par défaut pour les composants 32 bits. |
Programme d'installation de SQL Server | /INSTANCEDIR | Spécifie un répertoire d'installation différent du répertoire par défaut pour les composants partagés. |
Programme d'installation de SQL Server | /INSTANCEIDSUFFIX | Spécifie une valeur autre que la valeur par défaut pour un InstanceID. |
Programme d'installation de SQL Server | /INSTANCENAME | Spécifie un nom d'instance SQL Server autre que le nom par défaut. | /InstanceName=MSSQLServer ou /InstanceName=<Nom de l'instance nommée>
Programme d'installation de SQL Server | /Q | Spécifie que le programme d'installation s'exécute sans interface utilisateur. |
Programme d'installation de SQL Server | /SQMREPORTING | Spécifie la création de rapports d'utilisation de fonctionnalités pour SQL Server. | 1=activé ; 0=désactivé

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)
Procédure : lire un fichier journal d'installation de SQL Server


Procédure : ajouter des fonctionnalités à une instance de SQL Server 2008 (programme d'installation)

Procédure : ajouter des fonctionnalités à une instance de SQL Server 2008 (programme d'installation) |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

L'Assistant Installation de SQL Server fournit une arborescence de fonctionnalités unique pour l'installation de tous les composants SQL Server. Il n'est pas nécessaire d'installer chaque composant individuellement.

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Recherche en texte intégral

  • Outils d'administration

  • Composants de connectivité

  • Exemples de bases de données, exemples et documentation en ligne de SQL Server

Pour ajouter des fonctionnalités à une instance de SQL Server 2008 à partir de l'invite de commandes, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Composants requis

Avant de continuer, consultez les rubriques dans Planification d'une installation SQL Server.

Remarque :
Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Procédures

Pour installer SQL Server 2008

  1. Insérez le support d'installation SQL Server. Dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis redémarrez le programme d'installation de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour créer une installation de SQL Server 2008, cliquez sur Nouvelle installation ou ajouter des fonctionnalités à une installation existante.

  5. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  6. L'Assistant Installation installera les composants requis SQL Server s'ils ne sont pas déjà présents sur l'ordinateur. Cela comprend les éléments suivants :

    • .NET Framework 2.0

    • SQL Server Native Client

    • Fichiers de support d'installation de SQL Server

    Pour installer les composants requis, cliquez sur Installer.

  7. L'outil d'analyse de configuration système vérifiera l'état système de votre ordinateur avant que le programme d'installation ne se poursuive.

  8. Dans la page Type d'installation, indiquez l'instance à mettre à jour.

  9. Dans la page Sélection de fonctionnalités, sélectionnez les composants que vous voulez installer. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Vous pouvez choisir n'importe quelle combinaison de cases à cocher. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008. Chaque composant ne peut être installé qu'une seule fois sur une instance donnée de SQL Server. Pour installer plusieurs composants, vous devez installer une autre instance de SQL Server.

  10. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez et compare cet espace à l'espace disque disponible sur l'ordinateur où le programme d'installation s'exécute. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  11. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  12. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

    Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de fournir des privilèges moindres pour chaque service, où les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte de connexion pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  13. Utilisez l'onglet Configuration du serveur - Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  14. Utilisez la page Configuration du Moteur de base de données — Mise en service du compte pour spécifier les éléments suivants :

    • Mode de sécurité - sélectionnez l'authentification Windows ou le mode d'authentification mixte pour votre instance de SQL Server. Si vous sélectionnez Mode d'authentification mixte, vous devez fournir un mot de passe fort pour le compte administrateur système SQL Server intégré.

      Lorsque la connexion d'un périphérique à SQL Server est établie, le mécanisme de sécurité est le même pour l'authentification Windows et le mode mixte. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    • Administrateurs SQL Server — Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou sur Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server. Pour plus d'informations, consultez Configuration du moteur de base de données – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  15. Utilisez la page Configuration du Moteur de base de données — Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration du moteur de base de données – Répertoires de données.

  16. Utilisez la page Configuration du Moteur de base de données — FILESTREAM pour activer FILESTREAM pour votre instance de SQL Server. Pour plus d'informations sur FILESTREAM, consultez Configuration du moteur de base de données - Filestream. Pour continuer, cliquez sur Suivant.

  17. Utilisez la page Configuration d'Analysis Services — Attribution de privilèges d'accès aux comptes pour spécifier les utilisateurs ou comptes qui ont les autorisations d'administrateur pour Analysis Services. Vous devez spécifier au moins un administrateur système pour Analysis Services. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur Ajouter l'utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour Analysis Services. Pour plus d'informations, consultez Configuration Analysis Services – Mise en service de compte.

    Lorsque vous avez fini de modifier la liste, cliquez sur OK. Vérifiez la liste d'administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

  18. Utilisez la page Configuration du Analysis Services — Répertoires de données pour spécifier les répertoires d'installation non définis par défaut. Pour installer sur les répertoires par défaut, cliquez sur Suivant.

    Important :
    Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

    Pour plus d'informations, consultez Configuration de Analysis Services – Répertoires de données.

  19. Utilisez la page Configuration de Reporting Services pour spécifier le type d'installation de Reporting Services à créer. Vous pouvez choisir entre les options suivantes :

    • Configuration par défaut en mode Natif

    • Configuration par défaut en mode SharePoint

    • Installation de Reporting Services non configurée

    Pour plus d'informations sur les modes de configuration de Reporting Services, consultez Options d'installation du serveur de rapports.

  20. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  21. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées.

  22. La page Prêt pour l'installation affichage une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation.

  23. Au cours de l'installation, la page Progression de l'installation fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  24. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  25. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Configurer votre installation de SQL Server

  • Pour réduire la surface d'exposition d'un système, SQL Server installe et active de façon sélective les services et les fonctionnalités clés. Pour plus d'informations, consultez Présentation de la configuration de la surface d'exposition sur MSDN.

  • Pour plus d'informations sur l'utilisation des outils graphiques et des utilitaires d'invite de commandes, consultez Configuration de SQL Server 2008.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server
Procédure : installer SQL Server 2008 à partir de l'invite de commandes


Procédure : renommer un ordinateur qui héberge une instance autonome de SQL Server

Procédure : renommer un ordinateur qui héberge une instance autonome de SQL Server |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

Lorsque vous modifiez le nom de l'ordinateur qui exécute SQL Server, le nouveau nom est reconnu au démarrage de SQL Server. Vous n'avez pas besoin de réexécuter le programme d'installation pour réinitialiser le nom d'ordinateur. À la place, utilisez les étapes suivantes pour mettre à jour les métadonnées système qui sont stockées dans sys.servers et signalées par la fonction système @@SERVERNAME. Mettez à jour les métadonnées système pour refléter les modifications opérées dans les noms d'ordinateurs pour les connexions à distance et les applications qui utilisent @@SERVERNAME, ou qui interrogent le nom du serveur à partir de sys.servers.

Les procédures suivantes ne vous permettent pas de renommer une instance de SQL Server. Elles ne peuvent être utilisées que pour renommer la partie du nom de l'instance qui correspond au nom de l'ordinateur. Par exemple, vous pouvez remplacer le nom d'un ordinateur nommé MB1 qui héberge une instance de SQL Server nommée Instance1 par un autre nom, tel que MB2. Cependant, la partie d'instance du nom, Instance1, restera inchangée. Dans cet exemple, la partie \\Nom_ordinateur\Nom_instance nommée \\MB1\Instance1 sera remplacée par \\MB2\Instance1.

Avant de commencer

Avant d'entamer la procédure consistant à attribuer un nouveau nom, prenez connaissance des informations suivantes :

  • Lorsqu'une instance de SQL Server fait partie d'un cluster de basculement SQL Server, le processus permettant de renommer l'ordinateur diffère du processus permettant de renommer un ordinateur qui héberge une instance autonome.

  • SQL Server ne prend pas en charge la modification de nom des ordinateurs impliqués dans la réplication, excepté lorsque vous utilisez la copie des journaux de transaction avec la réplication. L'ordinateur secondaire pour la copie des journaux de transaction peut être renommé si l'ordinateur principal est définitivement perdu. Pour plus d'informations, consultez Réplication et copie des journaux de transaction.

  • Lorsque vous renommez un ordinateur configuré pour utiliser Reporting Services, Reporting Services peut ne pas être disponible après la modification du nom d'ordinateur. Pour plus d'informations, consultez Changement de nom d'un ordinateur serveur de rapports.

  • Lorsque vous renommez un ordinateur configuré pour utiliser la mise en miroir de bases de données, vous devez désactiver cette fonction avant de modifier le nom. Ensuite, vous devez la réactiver avec le nouveau nom de l'ordinateur. Les métadonnées de la mise en miroir de la base de données ne seront pas mises à jour automatiquement de façon à refléter le nouveau nom de l'ordinateur. Procédez comme suit pour mettre à jour les métadonnées système :

  • Les utilisateurs qui se connectent à SQL Server par le biais d'un groupe Windows utilisant une référence codée en dur au nom de l'ordinateur risquent de ne pas pouvoir se connecter à SQL Server. Cela peut se produire après l'attribution du nouveau nom si le groupe Windows spécifie l'ancien nom d'ordinateur. Pour vous assurer que ces groupes Windows bénéficient de la connectivité SQL Server après l'opération de changement de nom, mettez à jour le groupe Windows pour spécifier le nouveau nom de l'ordinateur.

Vous pouvez vous connecter à SQL Server à l'aide du nouveau nom d'ordinateur après avoir redémarré SQL Server. Pour vous assurer que @@SERVERNAME retourne le nom mis à jour de l'instance de serveur local, vous devez exécuter manuellement la procédure suivante qui s'applique à votre scénario. La procédure à utiliser varie selon que vous mettez à jour un ordinateur qui héberge une instance par défaut ou une instance nommée de SQL Server.

Pour renommer un ordinateur qui héberge une instance autonome de SQL Server

  • Dans le cas d'un ordinateur recommé qui héberge une instance par défaut de SQL Server, exécutez les procédures ci-dessous :

    Copier le code
    sp_dropserver <old_name>
GO
sp_addserver <new_name>, local
GO

    Redémarrez l'instance de SQL Server.

  • Dans le cas d'un ordinateur renommé qui héberge une instance nommée de SQL Server, exécutez les procédures ci-dessous :

    Copier le code
    sp_dropserver <old_name\instancename>
GO
sp_addserver <new_name\instancename>, local
GO

    Redémarrez l'instance de SQL Server.

Après l'opération d'attribution d'un nouveau nom

Une fois l'ordinateur redémarré, toutes les connexions qui utilisaient l'ancien nom d'ordinateur doivent se connecter à l'aide du nouveau nom.

Pour vérifier si la modification du nom s'est effectuée correctement

  • Sélectionnez des informations à partir de @@SERVERNAME ou sys.servers. La fonction @@SERVERNAME renvoie le nouveau nom et la table sys.servers affiche le nouveau nom. L'exemple suivant montre l'utilisation de @@SERVERNAME.

    Copier le code
    SELECT @@SERVERNAME AS 'Server Name'

Considérations supplémentaires

Ouvertures de sessions distantes - Si des sessions à distance sont ouvertes sur l'ordinateur, l'exécution de sp_dropserver risque de générer une erreur semblable à la suivante :

Copier le code
Server: Msg 15190, Level 16, State 1, Procedure sp_dropserver, Line 44
There are still remote logins for the server 'SERVER1'.

Pour résoudre l'erreur, vous devez supprimer les ouvertures de session à distance du serveur.

Pour supprimer les ouvertures de session à distance

  • Dans le cas d'une instance par défaut, suivez la procédure ci-dessous :

    Copier le code
    sp_dropremotelogin old_name
GO

  • Dans le cas d'une instance nommée, suivez la procédure ci-dessous :

    Copier le code
    sp_dropremotelogin old_name\instancename
GO

Configurations de serveur lié - Les configurations de serveur lié seront affectées par l'opération d'attribution d'un nouveau nom à l'ordinateur. Utilisez sp_addlinkedserver ou sp_setnetname pour mettre à jour les références de nom d'ordinateur. Pour plus d'informations, consultez la rubrique de la documentation en ligne sur MSDN sp_addlinkedserver (Transact-SQL) ou sp_setnetname (Transact-SQL) SQL Server.

Noms d'alias client - Les alias client qui utilisent des canaux nommés seront affectés par l'opération d'attribution d'un nouveau nom à l'ordinateur. Par exemple, si un alias « PROD_SRVR » a été créé pour désigner SRVR1 et utilise le protocole de canaux nommés, le nom de canal ressemblera à \\SRVR1\pipe\sql\query. Après avoir renommé l'ordinateur, le chemin d'accès du canal nommé ne sera plus valide. Pour plus d'informations sur les canaux nommés, consultez la rubrique consacrée à la création d'une chaîne de connexion valide à l'aide de canaux nommés SQL Server dans la documentation en ligne sur MSDN.

Voir aussi

Concepts

Installation de SQL Server 2008


Procédure : afficher les fichiers journaux d'installation de SQL Server

Procédure : afficher les fichiers journaux d'installation de SQL Server |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

La journalisation du programme d'installation de SQL Server a changé dans cette version. Le journal principal que vous devez consulter est l<lecteur>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\Summary.txt

Chaque exécution du programme d'installation générera un nouveau dossier de journal horodaté. Par exemple, si vous lancez la page Centre d'installation SQL Server, elle obtient son propre dossier de journal horodaté, et chaque action du programme d'installation appelée à partir de cette page obtient également le sien, ce qui fait que vous verrez probablement plusieurs dossiers de journaux horodatés dans ce répertoire. Le format du nom du dossier de journal horodaté est YYYMMDD_hhmmss.

Les journaux d'installation détaillés se trouvent à l'emplacement suivant :

<lecteur>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\.

Lorsque vous recherchez des erreurs dans le journal de détail, recherchez les expressions suivantes :

  • Compartiment Watson

  • Erreur :

  • L'exception a été

Une demande d'Installation typique passe par trois phases d'exécution :

  1. Contrôle de règles globales

  2. Mise à jour du composant

  3. Action demandée par l'utilisateur

Chacune de ces phases générera des journaux de synthèse et détaillés, avec des fichiers journaux supplémentaires qui sont générés si besoin est. Le programme d'installation est appelé au moins trois fois par action d'installation demandée par l'utilisateur.

Les fichiers journaux typiques générés seront :

  • Detail_GlobalRules.txt

  • Detail_ComponentUpdate.txt

  • Detail.txt

Le format du nom du fichier de journal résumé est Summary_ [nom de l'ordinateur] _timestamp_ [phase d'exécution]

Le journal résumé final est copié vers le dossier %Program Files%\Microsoft SQL Server\100\setup bootstrap\log et nommé Summary.txt à des fins de référence rapide.

Remarque : le programme d'installation ne convertira pas en CAB les fichiers journaux, sauf s'il y a une erreur.

Les actions MSI effectuées pendant l'installation génèrent leurs propres fichiers journaux au format suivant : [fonctionnalité du produit]_[cpu]_[LCID (facultatif)]_[tentative n°].log. Si une exécution MSI échoue, recherchez la « valeur de retour 3 » dans le journal MSI associé uniquement pour les versions ENU.

Les fichiers de banque de données contiennent une capture instantanée de l'état de tous les objets de configuration qui sont suivis par le processus d'installation et qui sont utiles pour réparer les erreurs de configuration. Des vidages de fichiers XML sont créés pour les objets de banque de données pour chaque phase d'exécution. Ils sont enregistrés dans leur propre sous-dossier de journal sous le dossier de journal horodaté, comme suit :

  • Datastore_GlobalRules

  • Datastore_ComponentUpdate

  • Datastore

Voir aussi

Concepts

Dépannage d'une installation de SQL Server


Procédure : lire un fichier journal d'installation de SQL Server

Procédure : lire un fichier journal d'installation de SQL Server |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

Le programme d'installation de SQL Server crée des fichiers journaux pour chaque composant SQL Server au cours de l'installation ; l'écriture commence dès que Setup.exe est lancé.

Pour lire un fichier journal d'installation de SQL Server

  1. Ouvrez l'Explorateur Windows et accédez à l'emplacement suivant :

    <lecteur>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG

  2. Ouvrez le fichier Summary.txt. Lisez les messages d'erreur.

  3. Si le fichier Summary.txt ne vous livre aucune information sur la cause de la défaillance, ouvrez le fichier SQLSetup[xxxx].cab dans le même répertoire racine.

  4. Si ce fichier .cab n'existe pas, ouvrez le fichier CORE à partir de :

    <lecteur>:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\LOG\Files

    Lisez le journal principal le plus récemment modifié : SQLSetup[xxxx]_[ComputerName]_Core.log.

  5. Si un message d'erreur s'est affiché dans l'interface utilisateur au cours de l'installation, recherchez ce journal : SQLSetup[xxxx][s]_[ComputerName]_WI.log.

  6. Lorsque vous analysez un fichier journal SQLSetup_[xxxx], recherchez 'UE 3'. Ceci est l'abréviation de 'Return Value 3'.

  7. Si un composant a échoué pendant l'installation, ouvrez le fichier journal SQLSetup[xxxx]_[ComputerName]_SQL.log et recherchez 'UE 3' pour analyser les erreurs.

Voir aussi

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Procédure : désinstaller une instance existante de SQL Server 2008 (Programme d'installation)

Procédure : désinstaller une instance existante de SQL Server 2008 (Programme d'installation) |
 | Voir aussi
Installation de SQL Server 2008 > Rubriques de procédures relatives à l'installation >

Cet article explique comment désinstaller manuellement une instance autonome de SQL Server. En suivant les étapes de cette rubrique, vous préparez également le système afin de pouvoir réinstaller SQL Server.

Important :
Pour maintenir ou mettre à jour une instance SQL Server, vous devez être administrateur local et disposer des autorisations requises pour vous connecter en tant que service.

Prenez en compte les points importants indiqués ci-après avant d'utiliser cette procédure pour désinstaller SQL Server :

  • Nous vous recommandons d'utiliser l'option Ajout/Suppression de programmes du Panneau de configuration pour désinstaller SQL Server.

  • Sur un ordinateur exécutant SQL Server ainsi que des versions antérieures de SQL Server, il est possible qu'Enterprise Manager et autres programmes reposant sur SQL-DMO soient désactivés. Cette situation peut se produire dans les cas suivants :

    • Installations côte à côte de n'importe quelle combinaison de SQL Server 2008, SQL Server 2000 et SQL Server 7.0 où une ou plusieurs de ces instances sont désinstallées.

    • Installations côte à côte de SQL Server 2000 avec SQL Server 2008, où SQL Server 2000 est installé après SQL Server 2008.

    Ce problème est dû à la suppression de l'inscription de la bibliothèque COM SQL-DMO SQL Server. Pour réactiver Enterprise Manager et les autres programmes ayant des dépendances SQL-DMO, inscrivez SQL-DMO en exécutant regsvr32.exe sqldmo.dll à partir de l'invite de commandes. Pour plus d'informations, consultez Dépannage d'une installation de SQL Server.

  • Avant de supprimer les composants SQL Server d'un ordinateur disposant de la quantité minimale de mémoire physique requise, vous devez vous assurer que la taille du fichier d'échange est suffisante. La taille du fichier d'échange doit être égale à deux fois la quantité de mémoire physique. Une mémoire virtuelle insuffisante peut entraîner la suppression incomplète de SQL Server.

  • Dans SQL Server 2005, le navigateur SQL Server était une installation intégrée au Moteur de base de données ou à Analysis Services. Dans SQL Server 2008, le navigateur SQL Server est une installation distincte, effectuée automatiquement avec le Moteur de base de données ou avec Analysis Services. Si vous avez plusieurs instances de SQL Server 2008, le navigateur SQL Server est automatiquement désinstallée lorsque la dernière instance de SQL Server 2008 est désinstallée.

    Si SQL Server 2005 existe sur le système avec une ou plusieurs instances de SQL Server 2008, le navigateur SQL Server 2008 ne sera pas supprimé automatiquement lors de la désinstallation de la dernière instance de SQL Server 2008. Le navigateur SQL Server installé avec SQL Server 2008 demeure sur le système pour faciliter les connexions à l'instance de SQL Server 2005. Vous pouvez conserver le navigateur SQL Server 2008 installé avec SQL Server 2005 ; il continuera à fonctionner correctement.

    Pour désinstaller tous les composants de SQL Server 2008, vous devez désinstaller manuellement le composant SQL Server Browser en utilisant Programmes et fonctionnalités dans le Panneau de configuration. Si vous supprimez le navigateur SQL Server 2008 quand une instance nommée de SQL Server 2005 est présente, la connectivité à SQL Server 2005 peut être interrompue. Dans ce cas, vous pouvez réinstaller SQL Server Browser de l'une des manières suivantes :

    • Réparez l'instance de SQL Server 2005 via Programmes et fonctionnalités dans le Panneau de configuration.

    • Installez une instance du moteur de base de données SQL Server 2005 ou Analysis Services.

Avant de supprimer SQL Server, procédez comme suit :

  • Sauvegardez vos données. Vous possédez peut-être des bases de données que vous voulez enregistrer dans leur état actuel. Peut-être souhaitez-vous également enregistrer les modifications qui ont été apportées aux bases de données système. Dans l'une de ces situations, veillez à sauvegarder les données avant de désinstaller SQL Server. Vous avez aussi la possibilité d'enregistrer une copie de tous les fichiers journaux et de données dans un dossier autre que le dossier MSSQL. Le dossier MSSQL est supprimé durant la désinstallation.

    Les fichiers que vous devez enregistrer incluent les fichiers de base de données suivants. Ces fichiers sont installés en même temps que SQL Server :

    • Distmdl.*

    • Master.*

    • Mastlog.*

    • Model.*

    • Modellog.*

    • Msdbdata.*

    • Msdblog.*

    • Mssqlsystemresource.*

    • Northwind.* (Cette base de données est une installation facultative.)

    • Pubs.*

    • Pubs_log.*

    • Tempdb.*

    • Templog.*

    • ReportServer[$InstanceName] (Il s'agit de la base de données par défaut de Reporting Services.)

    • ReportServer[$InstanceName]TempDB (Il s'agit de la base de données temporaire par défaut de Reporting Services.)

  • Supprimer les groupes de sécurité locaux . Avant de désinstaller SQL Server, supprimez les groupes de sécurité locaux des composants SQL Server.

  • Enregistrer ou renommer Reporting Services les dossiers Si vous utilisez l'installation de SQL Server avec Reporting Services, enregistrez ou renommez les dossiers et sous-dossiers suivants :

    • <lecteur>\Microsoft SQL Server\Reporting Services

    • <lecteur>\Microsoft SQL Server\MSSQL\Reporting Services

    • <lecteur>\Microsoft SQL Server\<nom de l'instance SQL Server>\Reporting Services

    • <lecteur>\Microsoft SQL Server\100\Tools\Report Designer

      Remarque :
      Si vous avez utilisé l'outil de configuration de SSRS pour configurer l'installation, les noms peuvent être différents de ceux figurant dans cette liste. Qui plus est, les bases de données peuvent être situées sur un ordinateur distant qui exécute SQL Server.

  • Supprimez les répertoires virtuels de Reporting Services. Utilisez le Gestionnaire IIS (Microsoft Internet Information Services) pour supprimer les répertoires virtuels suivants :

    • ReportServer[$InstanceName]

    • Reports[$InstanceName]

  • Supprimer le pool d'applications ReportServer Utilisez le Gestionnaire des services Internet pour supprimer le pool d'applications ReportServer.

  • Arrêter tous SQL Server les services Nous vous recommandons d'arrêter tous les services SQL Server avant de désinstaller les composants SQL Server. La désinstallation peut échouer s'il existe des connexions actives.

  • Utiliser un compte bénéficiant des autorisations appropriées Connectez-vous au serveur à l'aide du compte de service SQL Server ou à l'aide d'un compte doté d'autorisations équivalentes. Par exemple, vous pouvez vous connecter au serveur à l'aide d'un compte qui est membre du groupe Administrateurs local.

Pour désinstaller une instance de SQL Server 2008

  1. Pour commencer le processus de désinstallation, dans le menu Démarrer, cliquez sur Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.

  2. Sélectionnez le composant SQL Server à désinstaller, puis cliquez sur Modifier/Supprimer. L'Assistant Installation de SQL Server démarre.

  3. Les règles de support d'installation seront exécutées pour vérifier la configuration de votre ordinateur. Cliquez sur OK pour continuer.

  4. Dans la page Sélectionner une instance, utilisez la zone de liste déroulante pour spécifier une instance de SQL Server à supprimer ou l'option pour supprimer uniquement les fonctionnalités partagées et outils d'administration de SQL Server. Pour continuer, cliquez sur Suivant.

  5. Dans la page Sélectionner les fonctionnalités, spécifiez les fonctionnalités à supprimer de l'instance spécifiée de SQL Server. Pour continuer.

  6. Les règles de suppression seront exécutées pour vérifier que l'opération peut s'effectuer correctement.

  7. Dans la page Prêt pour la désinstallation, consultez la liste des composants et des fonctionnalités à désinstaller.

  8. Dans la page Progression de l'installation, l'état de l'installation s'affiche.

  9. Dans la page Fin de l'installation, cliquez sur Fermer pour quitter l'Assistant Installation.

  10. Répétez les étapes 2 à 9 jusqu'à ce que tous les composants SQL Server 2008 aient été supprimés.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Dépannage d'une installation de SQL Server

Dépannage d'une installation de SQL Server |
 | Voir aussi
Installation de SQL Server 2008 >

Pour consulter des informations de résolution des problèmes à propos de l'installation et des problèmes de mise à niveau, consultez le fichier Readme de SQL Server 2008.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Mise à niveau vers SQL Server 2008

Mise à niveau vers SQL Server 2008 |
 | Voir aussi

Vous pouvez mettre à niveau les instances de SQL Server 2000 ou SQL Server 2005 vers SQL Server 2008. Avant d'exécuter le programme d'installation de SQL Server pour procéder à la mise à niveau vers SQL Server 2008, examinez les rubriques suivantes à propos de la mise à niveau.

Dans cette section

Rubrique | Description
Planification d'une installation SQL Server | Documente les conditions requises pour l'installation, les contrôles de configuration du système exécutés par le programme d'installation de SQL Server et les considérations sur la sécurité pour une installation SQL Server.
Mises à niveau de la version et de l'édition | Documente les chemins d'accès de mise à niveau vers SQL Server 2008 pris en charge.
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau | Décrit le Conseiller de mise à niveau, outil qui analyse les instances SQL Server 2000 et SQL Server 2005 pour identifier les problèmes de mise à niveau connus.
Rubriques de procédures relatives à la mise en niveau | Fournit des liens vers des rubriques de procédures pour la mise à niveau vers SQL Server 2008.
Compatibilité ascendante | Répertorie les modifications importantes susceptibles d'affecter vos applications après que vous avez effectué une mise à niveau vers SQL Server 2008.

Voir aussi

Concepts

Considérations sur la mise à niveau du moteur de base de données
Considérations sur la mise à niveau d'Analysis Services
Considérations sur la mise à niveau de Reporting Services
Considérations sur la mise à niveau de Data Transformation Services
Considérations relatives à la mise à niveau de bases de données répliquées

Autres ressources

Considérations sur la mise à niveau de SQL Server Integration Services


Mises à niveau de la version et de l'édition

Mises à niveau de la version et de l'édition |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Les scénarios de mise à niveau suivants sont pris en charge dans cette version de SQL Server :

Mise à niveau à partir de | Mises à niveau prises en charge
SQL Server 2000 MSDE SP4 (32 bits)1 | SQL Server 2008 Express
SQL Server 2000 Standard SP4 (32 bits)1,4 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2000 Developer SP4 (32 bits) 1,4 | Aucune mise à niveau prise en charge.
SQL Server 2000 Enterprise SP4 (32 bits)1,4 | SQL Server 2008 Enterprise
SQL Server 2000 Enterprise Evaluation (32 bits, IA64, X64)4,5 | Aucune mise à niveau prise en charge.
SQL Server 2000 Developer IA64 SP4 (64 bits) 3,4,5 | SQL Server 2008 Developer IA64 (64 bits)
SQL Server 2000 Enterprise IA64 SP4 (64 bits)3,4,5 | SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2000 Personal SP4 (32 bits)2 | Aucune mise à niveau prise en charge.
SQL Server 2005 Express (32 bits) | SQL Server 2008 Express SQL Server 2008 Express Advanced
SQL Server 2005 Express Advanced (32 bits)1 | SQL Server 2008 Express Advanced
SQL Server 2005 Workgroup (32 bits)1 | Aucune mise à niveau prise en charge.
SQL Server 2005 Standard (32 bits)1 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2005 Developer (32 bits)1 | Aucune mise à niveau prise en charge.
SQL Server 2005 Enterprise (32 bits)1 | SQL Server 2008 Enterprise
SQL Server 2005 Enterprise Evaluation (32 bits, IA64, X64) | Aucune mise à niveau prise en charge.
SQL Server 2005 Developer IA64 (64 bits) | Aucune mise à niveau prise en charge.
SQL Server 2005 Standard IA64 (64 bits) | SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2005 Enterprise IA64 (64 bits) | SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2005 Developer X64 (64 bits) | SQL Server 2008 Developer X64 (64 bits)
SQL Server 2005 Standard X64 (64 bits) | SQL Server 2008 Standard X64 (64 bits) SQL Server 2008 Enterprise X64 (64 bits)
SQL Server 2005 Enterprise X64 (64 bits) | SQL Server 2008 Enterprise X64 (64 bits)
SQL Server 2008 Express1 | SQL Server 2008 Express SQL Server 2008 Express Advanced SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Express Advanced1 | SQL Server 2008 Express Advanced SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Express x64 (64 bits) | SQL Server 2008 Express x64 (64 bits) SQL Server 2008 Express Advanced x64 (64 bits)
SQL Server 2008 Express Advanced x64 (64 bits) | SQL Server 2008 Express Advanced x64 (64 bits) SQL Server 2008 Standard x64 (64 bits) SQL Server 2008 Enterprise x64 (64 bits)
SQL Server 2008 Workgroup1 | SQL Server 2008 Workgroup SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Web1 | SQL Server 2008 Web
SQL Server 2008 Standard1,2 | SQL Server 2008 Standard SQL Server 2008 Enterprise
SQL Server 2008 Developer1,2 | SQL Server 2008 Workgroup SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise
SQL Server 2008 Enterprise1,2 | SQL Server 2008 Enterprise
SQL Server 2008 Enterprise Evaluation2 | SQL Server 2008 Standard SQL Server 2008 Enterprise SQL Server 2008 Enterprise Evaluation
SQL Server 2008 Enterprise Evaluation IA64 (64 bits)2 | SQL Server 2008 Enterprise IA64 (64 bits) SQL Server 2008 Enterprise Evaluation IA64 (64 bits)
SQL Server 2008 Enterprise Evaluation x64 (64 bits)2 | SQL Server 2008 Standard x64 (64 bits) SQL Server 2008 Enterprise x64 (64 bits) SQL Server 2008 Enterprise Evaluation x64 (64 bits)
SQL Server 2008 Developer IA64 (64 bits) 2 | SQL Server 2008 Standard IA64 (64 bits) SQL Server 2008 Developer IA64 (64 bits) SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2008 Standard IA64 (64 bits)2 | SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2008 Standard x64 (64 bits)2 | SQL Server 2008 Standard IA64 (64 bits) SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2008 Enterprise IA64 (64 bits)2 | SQL Server 2008 Enterprise IA64 (64 bits)
SQL Server 2008 Enterprise x64 (64 bits)2 | SQL Server 2008 Enterprise x64 (64 bits)

1Cette édition de SQL Server peut être mise à niveau vers SQL Server 2008 dans le sous-système 32 bits (WOW64) d'un serveur 64 bits.

2La modification de l'édition d'un cluster de basculement SQL Server 2008 est limitée à certains scénarios. Les scénarios de mise à niveau vers une version antérieure d'édition suivants ne sont pas pris en charge pour les clusters de basculement SQL Server 2008 :

  • SQL Server 2008 Enterprise Edition vers SQL Server 2008 Developer, Standard ou Enterprise Evaluation.

  • SQL Server 2008 Developer Edition vers SQL Server 2008 Standard ou Enterprise Evaluation.

  • SQL Server 2008 Standard vers SQL Server 2008 Enterprise Evaluation.

  • SQL Server 2008 Enterprise Evaluation vers SQL Server 2008 Standard.

3La mise à niveau des clusters de basculement SQL Server 2000 IA64 (64 bits) n'est pas prise en charge.

4La mise à niveau de SQL Server 2000 Analysis Services vers SQL Server 2008 n'est pas prise en charge sur les clusters de basculement.

5 La mise à niveau de SQL Server 2000 (64 bits) n'installe pas les outils d'administration SQL Server 2008. Pour installer les outils d'administration, vous devez exécuter à nouveau le programme d'installation une fois la mise à niveau terminée.

Remarques sur les mises à niveau

  • Les instances inter-versions de SQL Server 2008 ne sont pas prises en charge. Les numéros de version des composants Moteur de base de données, Analysis Services et Reporting Services doivent être identiques dans une instance de SQL Server 2008.

  • Avant de mettre à niveau SQL Server, activez l'authentification Windows pour SQL Server Agent et vérifiez la configuration par défaut : le compte de service SQL Server Agent doit être membre du groupe sysadmin SQL Server.

  • Avant de mettre à niveau une édition de SQL Server 2008 vers une autre édition, vérifiez si les fonctionnalités que vous utilisez actuellement sont prises en charge dans l'édition vers laquelle vous allez effectuer la mise à niveau. Pour plus d'informations, consultez la section relative à vos composants dans Fonctionnalités prises en charge par les éditions de SQL Server 2008.

  • La mise à niveau interplateforme n'est pas prise en charge. Vous ne pouvez pas mettre à niveau une instance 32 bits de SQL Server vers une instance 64 bits native. Cependant, vous pouvez mettre à niveau une instance 32 bits de SQL Server vers WOW64, sous-système 32 bits d'un serveur 64 bits, comme décrit dans le tableau ci-dessus. Vous pouvez aussi sauvegarder ou détacher les bases de données d'une instance 32 bits de SQL Server, puis les restaurer ou les attacher à une instance de SQL Server (64 bits) si les bases de données ne sont pas publiées dans la réplication. Dans ce cas, vous devez aussi recréer toute connexion et autre objet utilisateur dans les bases de données système master, msdb et model.

  • Pour procéder à une mise à niveau vers SQL Server 2008, vous devez exécuter un système d'exploitation pris en charge. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

  • La mise à niveau sera bloquée s'il existe un redémarrage en attente.

  • La mise à niveau sera bloquée si le service Windows Installer ne s'exécute pas.

  • La mise à niveau sera bloquée si les compteurs de performance sont endommagés.

  • Pour procéder à une mise à niveau d'une instance de SQL Server vers un cluster de basculement SQL Server, l'instance à mettre à niveau doit être un cluster de basculement. Pour mettre à niveau une instance autonome de SQL Server vers un cluster de basculement SQL Server, installez un nouveau cluster de basculement SQL Server, puis migrez les bases de données utilisateur depuis l'instance autonome à l'aide de l'Assistant Copie de base de données. Pour plus d'informations sur la mise à niveau, consultez Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation). Pour plus d'informations sur la migration de bases de données, consultez Utilisation de l'Assistant Copie de base de données.

  • Pour mettre à niveau SQL Server 2005 vers SQL Server 2008 sur un ordinateur qui exécute Windows Server 2008, vous devez exécuter SQL Server 2005 SP2. SQL Server 2005 SP1 n'est pas un scénario de mise à niveau pris en charge.

Ajout de composants à une instance de SQL Server

Vous ne pouvez pas ajouter de composants à une installation existante de SQL Server au moment de la mise à niveau vers SQL Server 2008. Après la mise à niveau d'une instance de SQL Server vers SQL Server 2008, vous pouvez ajouter des fonctionnalités à l'aide de l'Assistant Installation de SQL Server 2008 : Setup.exe.

Prise en charge de langues différentes

  • La version anglaise de SQL Server est prise en charge sur toutes les versions traduites des systèmes d'exploitation pris en charge.

  • Les versions traduites de SQL Server sont prises en charge sur les systèmes d'exploitation traduits dans la même langue que la version traduite de SQL Server.

  • Les versions traduites de SQL Server peuvent être mises à niveau vers des versions traduites de SQL Server 2008 dans la même langue.

  • Les versions traduites de SQL Server ne peuvent pas être mises à niveau vers une version de SQL Server 2008 en anglais.

  • Les versions traduites de SQL Server ne peuvent pas être mises à niveau vers des versions traduites de SQL Server 2008 dans une autre langue.

  • Les versions traduites de SQL Server sont également prises en charge dans les versions anglaises des systèmes d'exploitation pris en charge grâce aux paramètres du Pack Windows d'interface utilisateur multilingue. Vous devez toutefois vérifier certains paramètres du système d'exploitation avant d'installer une version localisée de SQL Server sur un serveur qui exécute un système d'exploitation en langue anglaise avec un paramétrage MUI non anglais. Vous devez vous assurer que les paramètres suivants du système d'exploitation correspondent à la version traduite de SQL Server à installer :

    • Le paramètre de l'interface utilisateur du système d'exploitation

    • Les paramètres régionaux utilisateur du système d'exploitation

    • Les paramètres régionaux système

    Si les paramètres du système d'exploitation ne correspondent pas à la version traduite de SQL Server, vous devez alors les définir correctement avant d'installer SQL Server 2008.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Concepts

Planification d'une installation SQL Server
Mise à niveau vers SQL Server 2008
Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau


Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Le Conseiller de mise à niveau de SQL Server vous assiste lors de la préparation des mises à niveau vers SQL Server 2008. Le Conseiller de mise à niveau analyse les composants des versions antérieures de SQL Server, puis génère un rapport qui identifie les problèmes à résoudre avant ou après la mise à niveau.

Fonctionnement du Conseiller de mise à niveau

Lorsque vous exécutez le Conseiller de mise à niveau, la page d'accueil du Conseiller de mise à niveau s'affiche. À partir de la page d'accueil, vous pouvez exécuter les outils suivants :

  • Assistant Analyse du Conseiller de mise à niveau

  • Visionneuse de rapports du Conseiller de mise à niveau

  • Aide du Conseiller de mise à niveau

À la première utilisation du Conseiller de mise à niveau, exécutez l'Assistant Analyse du Conseiller de mise à niveau pour analyser les composants de SQL Server. Lorsque l'Assistant a terminé l'analyse, affichez les rapports obtenus dans la visionneuse de rapports du Conseiller de mise à niveau. Chaque rapport inclut des liens vers des informations de l'aide du Conseiller de mise à niveau qui vous permettront de corriger problèmes connus ou de minimiser leur incidence.

Analyse du Conseiller de mise à niveau

Le Conseiller de mise à niveau analyse les composants SQL Server suivants :

  • Moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Services DTS (Data Transformation Services)

    Remarque :
    Notification Services n'est pas inclus dans les analyses du Conseiller de mise à niveau car il a été supprimé de SQL Server 2008.

L'analyse examine les objets accessibles (tels que les scripts, les procédures stockées, les déclencheurs et les fichiers de trace). Le Conseiller de mise à niveau ne peut pas analyser les logiciels applicatifs ni les procédures stockées chiffrées.

La sortie se présente sous la forme d'un rapport XML. Pour afficher le rapport XML, utilisez la visionneuse de rapports du Conseiller de mise à niveau.

Remarque :
Les rapports peuvent contenir un élément « autres problèmes de mise à niveau ». Cet élément mène à une liste de problèmes qui ne sont pas détectés par le Conseiller de mise à niveau, mais qui peuvent exister sur votre serveur ou dans vos applications. Vous devez examiner la liste des problèmes non détectables et déterminer si vous devez modifier votre serveur ou vos applications en raison des problèmes non détectables.

Comment installer et exécuter le Conseiller de mise à niveau

L'emplacement d'installation du Conseiller de mise à niveau de SQL Server dépend des éléments que vous allez analyser. Le Conseiller de mise à niveau prend en charge l'analyse distance de tous les composants pris en charge, à l'exception de Reporting Services. Si vous n'analysez pas d'instances de Reporting Services, vous pouvez installer le Conseiller de mise à niveau sur n'importe quel ordinateur pouvant se connecter à votre instance de SQL Server et répondant à la configuration requise du Conseiller de mise à niveau. Pour plus d'informations, consultez Mises à niveau de la version et de l'édition. Si vous analysez des instances de Reporting Services, vous devez installer le Conseiller de mise à niveau sur le serveur de rapports.

Le Conseiller de mise à niveau est disponible dans le dossier Servers\redist\Upgrade Advisor du support d'installation SQL Server et à partir du Centre de téléchargement Microsoft.

La configuration requise pour l'installation et l'exécution du Conseiller de mise à niveau est la suivante :

  • Windows XP SP2 ou version ultérieure, Windows Vista, Windows Server 2003 SP1 ou version ultérieure ou Windows Server 2008.

  • Windows Installer 4.5 ou version ultérieure.

    .NET Framework 2.0 requiert Windows Installer 4.5. Vous pouvez installer Windows Installer à partir du site Web de Windows Installer.

  • Le .NET Framework 2.0 ou version ultérieure. Le .NET Framework 2.0 est disponible sur le support produit de SQL Server 2005 et sur le site Web de téléchargement des kits de développement logiciel (SDK), composants redistribuables et Service Packs.

    • Pour installer le .NET Framework 2.0 à partir du support de SQL Server 2005, recherchez la racine du lecteur de disque. Ensuite, double-cliquez sur le dossier redist, double-cliquez sur le dossier 2.0 et exécutez dotnetfx.exe (pour la version 32 bits) ou dotnetfx64.exe (pour la version 64 bits), selon votre système d'exploitation.

  • Les objets DSO (Decision Support Objects) SQL Server 2000 sont nécessaires pour analyser les problèmes de mise à niveau dans Analysis Services. Pour installer les objets DSO, insérez le support d'installation de SQL Server 2000 dans le lecteur de disque. Cela démarre le programme d'installation SQL Server 2000 Cliquez sur Installer les composants de SQL Server 2000. Cliquez sur Analysis Services pour démarrer le programme d'installation d'Analysis Services. Dans Sélectionner les composants, assurez-vous que le composant Decision Support Objects est bien sélectionné.

  • Les composants clients de SQL Server 2000 sont nécessaires pour analyser les packages DTS SQL Server 2000. Utilisez le disque d'installation de SQL Server 2000 pour installer les composants clients.

  • Les composants de compatibilité descendante SQL Server 2005 sont requis pour analyser les packages DTS SQL Server 2005 qui ont été migrés à partir de SQL Server 2000. Utilisez le disque d'installation de SQL Server 2005 pour installer les composants de compatibilité descendante.

Pour installer le Conseiller de mise à niveau à partir du Web, cliquez sur le bouton Télécharger figurant sur la page de téléchargement. Vous pouvez alors soit exécuter l'installation immédiatement, soit enregistrer le fichier SQLUA.msi afin de l'exécuter ultérieurement. Si vous procédez à l'installation à partir du disque du produit, exécutez le fichier SQLUA.msi directement à partir du disque du produit.

Après avoir installé le Conseiller de mise à niveau, vous pouvez l'ouvrir à partir du menu Démarrer :

  • Cliquez sur Démarrer, pointez sur Tous les programmes, pointez sur Microsoft SQL Server 2008, puis cliquez sur Conseiller de mise à niveau SQL Server 2008.

Pour plus d'informations, consultez la documentation relative au Conseiller de mise à niveau et le fichier Lisez-moi installé avec le Conseiller de mise à niveau.

Voir aussi

Référence

Mises à niveau de la version et de l'édition

Concepts

Utilisation de plusieurs versions et instances de SQL Server
Compatibilité ascendante


Considérations sur la mise à niveau du moteur de base de données

Considérations sur la mise à niveau du moteur de base de données |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Vous pouvez mettre à niveau le Moteur de base de données SQL Server vers SQL Server 2008. Pour plus d'informations sur les chemins de mise à niveau pris en charge, consultez Mises à niveau de la version et de l'édition.

Le programme d'installation de SQL Server peut mettre à niveau une version antérieure de SQL Server avec une intervention minimale de l'utilisateur. Toutefois, une préparation correcte et une bonne connaissance du processus de mise à niveau peuvent faciliter la prévention et la résolution des problèmes susceptibles de se produire.

Cette rubrique fournit les informations qui vous aideront à préparer et à comprendre le processus de mise à niveau :

  • Problèmes de mise à niveau connus

  • Tâches précédant la mise à niveau et observations

  • Liens vers les rubriques consacrées aux procédures de mise à niveau du Moteur de base de données.

  • Liens vers les rubriques consacrées aux procédures de migration des bases de données vers SQL Server

  • Remarques sur les clusters de basculement

  • Tâches postérieures à la mise à niveau et observations

Problèmes de mise à niveau connus

Avant d'effectuer la mise à niveau du Moteur de base de données, consultez Compatibilité descendante du moteur de base de données SQL Server. Pour plus d'informations sur les scénarios de mise à niveau pris en charge et sur les problèmes de mise à niveau connus, consultez Mises à niveau de la version et de l'édition. Pour plus d'informations sur la compatibilité descendante des autres composants de SQL Server, consultez Compatibilité ascendante.

Important :
Avant toute mise à niveau d'une édition de SQL Server vers une autre, vérifiez que la fonctionnalité en cours d'utilisation est prise en charge dans l'édition vers laquelle vous effectuez la mise à niveau.

Liste de contrôle préalable à la mise à niveau

La mise à niveau vers SQL Server à partir d'une version précédente est prise en charge par le programme d'installation de SQL Server. Vous pouvez également migrer les bases de données à partir de versions précédentes de SQL Server. La migration peut être effectuée à partir d'une instance SQL Server vers une autre instance située vers le même ordinateur ou à partir d'une instance SQL Server vers un autre ordinateur. Les options de migration incluent l'utilisation de l'Assistant Copie de base de données, de la fonctionnalité de sauvegarde et de restauration, ainsi que l'utilisation de l'Assistant Importation et exportation SQL Server Integration Services et des méthodes d'importation et d'exportation en bloc.

Avant d'effectuer la mise à niveau du Moteur de base de données, n'oubliez pas de respecter les consignes suivantes :

  • Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

  • Consultez Paramètres de l'outil d'analyse de configuration système.

  • Consultez Considérations sur la sécurité pour une installation SQL Server.

  • Consultez Mises à niveau de la version et de l'édition.

  • Consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

  • Consultez Compatibilité descendante du moteur de base de données SQL Server.

  • Consultez Migration de plans de requête.

Passez en revue les problèmes ci-dessous et apportez les modifications nécessaires, avant d'effectuer la mise à niveau de SQL Server :

  • Lorsque vous procédez à une mise à niveau à partir d'une version 64 bits de SQL Server vers une version 64 bits de SQL Server 2008, vous devez mettre à niveau Analysis Services avant de mettre à niveau le Moteur de base de données.

  • Sauvegardez tous les fichiers de base de données SQL Server de l'instance à mettre à niveau, afin de pouvoir les restaurer, si besoin est.

  • Exécutez les commandes DBCC (Database Console Commands) appropriées sur les bases de données à mettre à niveau afin de vérifier leur cohérence.

  • Estimez l'espace disque requis pour mettre à niveau les composants SQL Server, ainsi que les bases de données utilisateur. Pour connaître l'espace disque requis par les composants SQL Server, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

  • Vérifiez que les bases de données système de SQL Server - master, model, msdb et tempdb - sont configurées pour s'accroître automatiquement et vérifiez qu'elles disposent pour cela d'un espace disque suffisant.

  • Vérifiez que tous les serveurs de bases de données possèdent des informations d'ouverture de session dans la base de données master. Ce point est particulièrement important pour la restauration d'une base de données, car les informations d'ouverture de session système résident dans la base de données master.

  • Désactivez toutes les procédures stockées de démarrage, car le processus de mise à niveau arrête et démarre les services sur l'instance SQL Server en cours de mise à niveau. Les procédures stockées traitées au moment du démarrage pourraient bloquer le processus de mise à niveau.

  • Désactivez la réplication et vérifiez que le journal des réplications est vide.

  • La mise à niveau d'une instance du Moteur de base de données SQL Server 2000 conserve la valeur de configuration du Nombre maximal de threads de travail. Toutefois, nous vous recommandons de modifier la valeur Nombre maximal de threads de travail en spécifiant 0 avant d'effectuer la mise à niveau, afin de permettre au moteur de base de données de calculer le nombre optimal de threads. Pour plus d'informations, consultez Option max worker threads dans la documentation en ligne de SQL Server.

  • Quittez toutes les applications, y compris tous les services ayant des dépendances de SQL Server. La mise à niveau peut échouer si les applications locales sont connectées à l'instance en cours de mise à niveau.

  • Si vous utilisez la Mise en miroir de bases de données, consultez Procédure : réduire le temps d'indisponibilité des bases de données mises en miroir lors de la mise à niveau d'instances de serveur dans la Documentation en ligne SQL Server.

Mise à niveau du moteur de base de données

Vous pouvez remplacer une installation de SQL Server 2000 7.0 ou SQL Server 2005 par une mise à niveau de la version. Si une version précédente de SQL Server est détectée lorsque vous exécutez le programme d'installation de SQL Server, tous les fichiers programme de la version précédente de SQL Server sont mis à niveau et toutes les données stockées dans l'instance SQL Server précédente sont conservés. En outre, les versions précédentes de la documentation en ligne de SQL Server demeureront intactes sur l'ordinateur.

Attention :
Lorsque vous effectuerez une mise à niveau vers SQL Server, l'instance SQL Server précédente sera remplacée et n'existera plus sur votre ordinateur. Avant d'opérer la mise à niveau, sauvegardez les bases de données SQL Server et les autres objets associés à l'instance SQL Server précédente.

Vous pouvez mettre à niveau le Moteur de base de données en utilisant l'Assistant Installation de SQL Server.

Attention :
Si votre ordinateur possède les outils d'administration de SQL Server 2000 et une instance par défaut de SQL Server 2008, le programme d'installation de SQL Server vous permet d'installer une instance par défaut de SQL Server 2000. Toutefois, cette opération désactive l'instance installée de SQL Server 2008. Par conséquent, n'installez pas d'instance par défaut de SQL Server lorsque les outils d'administration de SQL Server 2000 et une instance par défaut de SQL Server 2008 existent déjà sur l'ordinateur.

Niveau de compatibilité des bases de données après une mise à niveau

Les niveaux de compatibilité des bases de données tempdb, model, msdb et Resource sont définies à 100 après la mise à niveau. La base de données système master conserve le niveau de compatibilité qu'elle avait avant la mise à niveau, sauf si ce niveau était inférieur à 80. Si le niveau de compatibilité de master était inférieur à 80 avant la mise à niveau, il est défini à 80 après la mise à niveau.

Si le niveau de compatibilité d'une base de données utilisateur était à 80 ou 90 avant la mise à niveau, il reste le même après la mise à niveau. Si le niveau de compatibilité était à 70 ou moins avant la mise à niveau, dans la base de données mise à niveau, le niveau de compatibilité est défini à 80, ce qui correspond au niveau de compatibilité le plus bas pris en charge dans SQL Server 2008.

Remarque :
Les nouvelles bases de données utilisateur héritent du niveau de compatibilité de la base de données model.

Migration des bases de données

Vous pouvez déplacer les bases de données utilisateur vers une instance de SQL Server à l'aide des fonctionnalités de sauvegarde et de restauration ou de détachement et d'attachement de SQL Server.

Important :
Une base de données dont le nom est identique sur les serveurs source et de destination ne peut pas être déplacée ni copiée. Dans ce cas, elle est signalée par « Existe déjà ».

Pour plus d'informations, consultez Utilisation de l'Assistant Copie de base de données ou Procédure : mettre à niveau SQL Server à l'aide de l'Assistant Copie de base de données.

Après la mise à niveau du moteur de base de données

Après la mise à niveau du Moteur de base de données, effectuez les tâches suivantes :

  • Réinscrivez vos serveurs. Pour plus d'informations sur l'inscription des serveurs, consultez la rubrique Inscription des serveurs dans la documentation en ligne de SQL Server.

  • Alimentez à nouveau les catalogues de texte intégral. Cette opération améliore la performance de votre installation SQL Server. Pour plus d'informations, consultez la rubrique sp_fulltext_catalog (Transact-SQL) dans la documentation en ligne de SQL Server.

  • Mettez à jour les statistiques sur toutes les bases de données à l'issue de la mise à niveau. Utilisez la procédure stockée sp_updatestats pour mettre à jour les statistiques des tables utilisateur dans les bases de données SQL Server.

  • Exécutez DBCC UPDATEUSAGE sur toutes les bases de données pour corriger les lignes ou les comptes de page incorrects.

  • Configurez l'installation de SQL Server. Pour réduire la surface d'exposition d'un système, SQL Server installe et active de façon sélective les services et les fonctions clés.

  • Validez ou supprimez les indicateurs USE PLAN générés par SQL Server 2005 et appliqués aux requêtes sur les tables partitionnées et les index.

    SQL Server 2008 modifie la manière dont sont traitées les requêtes sur les tables partitionnées et les index. Les requêtes sur les objets partitionnés qui utilisent l'indicateur USE PLAN pour un plan généré par SQL Server 2005 peuvent contenir un plan non utilisable dans SQL Server 2008. Nous recommandons les procédures suivantes après la mise à niveau vers SQL Server 2008.

    Lorsque l'indicateur USE PLAN conseil est spécifié directement dans une requête :

    1. Supprimez l'indicateur USE PLAN de la requête.

    2. Testez la requête.

    3. Si l'optimiseur ne sélectionne pas un plan approprié, réglez la requête, puis envisagez de spécifier l'indicateur USE PLAN avec le plan de requête désiré.

    Lorsque l'indicateur USE PLAN conseil est spécifié dans un repère de plan :

    1. Utilisez la fonction sys.fn_validate_plan_guide pour vérifier la validité du repère de plan. Vous pouvez aussi surveiller les repères de plan non valides en utilisant l'événement Plan Guide Unsuccessful dans Générateur de profils SQL Server.

    2. Si le repère de plan n'est pas valide, abandonnez-le. Si l'optimiseur ne sélectionne pas un plan approprié, réglez la requête, puis envisagez de spécifier l'indicateur USE PLAN avec le plan de requête désiré.

    Un repère de plan non valide n'entraîne pas l'échec d'une requête quand l'indicateur USE PLAN est spécifié dans un repère de plan. À la place, la requête est compilée sans utiliser l'indicateur USE PLAN. Pour plus d'informations sur le traitement des requêtes sur les objets partitionnés, consultez Améliorations du traitement des requêtes sur les tables et les index partitionnés.

Toutes les bases de données qui étaient marquées comme activées ou désactivées pour le texte intégral avant la mise à niveau conservent ce statut après la mise à niveau. Après la mise à niveau, les catalogues de texte intégral sont automatiquement reconstruits et alimentés pour toutes les bases de données activées pour le texte intégral. Cette opération peut s'avérer gourmande en termes de temps et de ressources. Vous pouvez suspendre temporairement l'opération d'indexation de texte intégral en exécutant l'instruction suivante :

Copier le code
EXEC sp_fulltext_service 'pause_indexing', 1

Pour reprendre l'alimentation de l'index de texte intégral, exécutez l'instruction suivante :

Copier le code
EXEC sp_fulltext_service 'pause_indexing', 0

Voir aussi

Concepts

Utilisation de plusieurs versions et instances de SQL Server
Compatibilité ascendante
Considérations relatives à la mise à niveau de bases de données répliquées


Procédure : mise à niveau d'une base de données avec Detach et Attach (Transact-SQL)

Procédure : mise à niveau d'une base de données avec Detach et Attach (Transact-SQL) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

Remarque relative à la sécurité :
Nous vous recommandons de ne pas attacher ou de restaurer des bases de données provenant de sources inconnues ou non approuvées. Ces bases de données peuvent contenir du code malveillant susceptible d'exécuter du code Transact-SQL indésirable ou de provoquer des erreurs en modifiant le schéma ou la structure physique des bases de données. Avant d'utiliser une base de données provenant d'une source inconnue ou non approuvée, exécutez DBCC CHECKDB sur la base de données sur un serveur qui n'est pas un serveur de production et examinez le code (par exemple les procédures stockées ou le code défini par l'utilisateur) dans la base de données.

Dans SQL Server 2008, vous pouvez utiliser les opérations de détachement et d'attachement pour mettre à niveau une base de données utilisateur à partir de SQL Server 2000 ou SQL Server 2005. Après avoir attaché une base de données SQL Server 2005 ou SQL Server 2000 dans SQL Server 2008, la base de données est immédiatement disponible et est ensuite automatiquement mise à niveau.

Cependant, les restrictions suivantes s'appliquent :

  • Les copies de la base de données master, model ou msdb créées à l'aide de SQL Server 2000 ou SQL Server 2005 ne peuvent pas être attachées.

  • Si vous attachez une base de données répliquée qui a été copiée et non pas détachée :

    • Si vous attachez la base de données à une version mise à niveau de la même instance de serveur, vous devez exécuter sp_vupgrade_replication pour mettre à niveau la réplication au terme de l'opération d'attachement. Pour plus d'informations, consultez sp_vupgrade_replication (Transact-SQL).

    • Si vous attachez la base de données à une instance de serveur différente (quelle que soit sa version), vous devez exécuter sp_removedbreplication pour supprimer la réplication au terme de l'opération d'attachement. Pour plus d'informations, consultez sp_removedbreplication (Transact-SQL).

  • Lors de l'utilisation des mots clés APPLY, PIVOT, TABLESAMPLE ou UNPIVOT sur des bases de données qui sont mises à niveau de SQL Server 2000 vers SQL Server 2008, le niveau de compatibilité de la base de données doit avoir la valeur 100. Pour définir le niveau de compatibilité de la base de données, consultez sp_dbcmptlevel (Transact-SQL).

    Important :
    Dans SQL Server 2000 Service Pack 3 (SP3) et les versions ultérieures de SQL Server, l'attachement et le détachement désactivent le chaînage des propriétés des bases de données croisées en affectant la valeur 0 à l'option cross db ownership chaining. Pour plus d'informations sur l'activation du chaînage, consultez Option cross db ownership chaining.

Options de mise à niveau d'index de recherche en texte intégral

Remarque :
Après avoir attaché une base de données SQL Server 2005 ou SQL Server 2000 dans SQL Server 2008, la base de données est immédiatement disponible et est ensuite automatiquement mise à niveau. Si la base de données comprend des index de recherche en texte intégral, la mise à niveau les importe, les réinitialise ou les reconstruit, selon le paramètre de la propriété de serveur upgrade_option. Si l'option de mise à niveau a la valeur Importer (upgrade_option = 2) ou Reconstruire (upgrade_option = 0), les index de recherche en texte intégral ne seront pas disponibles pendant la mise à niveau. Selon le volume de données indexé, l'importation peut prendre plusieurs heures et la reconstruction jusqu'à dix fois plus longtemps. Notez également que lorsque l'option de mise à niveau est Importer, les index de recherche en texte intégral associés sont reconstruits si aucun catalogue de texte intégral n'est disponible. Pour modifier le paramètre de la propriété de serveur upgrade_option, utilisez sp_fulltext_service.

Procédures

Pour mettre à niveau une base de données avec detach et attach

  1. Détachez la base de données de l'instance de SQL Server 7.0 ou SQL Server 2000 en utilisant la procédure stockée sp_detach_db.

    Pour plus d'informations, SQL Server onsultez la documentation en ligne de cette version de SQL Server.

    Remarque :
    Dans SQL Server 2005, cette procédure stockée a de nouvelles options. Pour plus d'informations, consultez sp_detach_db (Transact-SQL).

  2. Facultativement, déplacez le ou les fichiers de base de données détachés et le ou les fichiers journaux.

    Vous devez déplacer les fichiers journaux ainsi que les fichiers de données, même si vous souhaitez créer de nouveaux fichiers journaux. Dans certains cas, le rattachement d'une base de données nécessite ses fichiers journaux existants. Par conséquent, conservez toujours tous les fichiers journaux détachés jusqu'à ce que la base de données ait été attachée avec succès sans eux.

    Remarque :
    Si vous tentez d'attacher la base de données sans spécifier le fichier journal, l'opération attach recherche le fichier journal à son emplacement d'origine. Si la copie d'origine du journal figure toujours dans cet emplacement, la copie est attachée. Pour éviter d'utiliser le fichier journal d'origine, spécifiez le chemin d'accès du nouveau fichier journal ou supprimez la copie d'origine du fichier journal (après l'avoir copiée au nouvel emplacement).

  3. Attachez les fichiers copiés dans l'instance de SQL Server 2005 en utilisant l'instruction CREATE DATABASE avec l'option FOR ATTACH ou FOR ATTACH_REBUILD_LOG.

    Remarque :
    Pour plus d'informations sur l'attachement d'une base de données SQL Server 2005 à l'aide de l'Explorateur d'objets, consultez Procédure : attachement d'une base de données (SQL Server Management Studio).

  4. Nous vous recommandons d'exécuter DBCC UPDATEUSAGE sur la base de données mise à niveau.

    Dans les versions antérieures de SQL Server, les valeurs du nombre de lignes de table et d'index et du nombre de pages peuvent être incorrectes. Par conséquent, les bases de données créées avec des versions antérieures à SQL Server 2005 peuvent contenir des décomptes incorrects. Après la mise à niveau d'une base de données vers SQL Server 2005, nous vous recommandons d'exécuter DBCC UPDATEUSAGE pour corriger d'éventuels compteurs incorrects. Cette instruction DBCC corrige les compteurs de lignes, de pages utilisées, de pages réservées, de pages de feuilles et de pages de données pour chaque partition de table ou d'index. Pour plus d'informations, consultez DBCC UPDATEUSAGE (Transact-SQL).

  5. Facultativement, si vous effectuez une copie de la base de données (au lieu de la déplacer), vous pouvez rattacher la base de données d'origine sur l'instance de SQL Server 7.0 ou SQL Server 2000 en utilisant la procédure stockée sp_attach_db ou sp_attach_single_file_db.

    Pour plus d'informations, consultez la documentation en ligne de cette version de SQL Server.

Gestion des métadonnées sur l'instance de serveur mise à niveau

Lorsque vous attachez une base de données à une autre instance de serveur et si vous souhaitez offrir une expérience cohérente aux utilisateurs et aux applications, il est possible que vous deviez recréer une partie ou l'ensemble des métadonnées de la base de données, telles que les connexions, les travaux, et les autorisations sur cette autre instance de serveur. Pour plus d'informations, consultez Gestion des métadonnées lors de la mise à disposition d'une base de données sur une autre instance de serveur.

Exemple

Cet exemple met à niveau la base de données pubs SQL Server 2000 vers une base de données SQL Server 2005 en utilisant des instructions Transact-SQL pour détacher et attacher la base de données.

  1. Connectez l'Analyseur de requêtes SQL Server 2000 à une instance de serveur où la base de données pubs est attachée, puis détachez-la en utilisant la procédure stockée sp_detach_db.

    Copier le code
    USE master;
GO
EXEC sp_detach_db @dbname = N'pubs';
GO
  2. Pour cet exemple, en utilisant la méthode de votre choix, copiez les fichiers pubs (pubs.mdf et pubs_log.ldf) depuis C:\Program Files\Microsoft SQL Server\MSSQL\Data\ (emplacements par défaut de pubs dans SQL Server 2000) vers C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\ (répertoire de données de SQL Server 2005).

    Important :
    Pour une base de données de production, placez la base de données et le journal des transactions sur des disques séparés.

    Remarque :
    Pour copier des fichiers par le réseau sur un disque installé sur un ordinateur distant en utilisant le nom UNC (universal naming convention) de l'emplacement distant. Un nom UNC prend la forme \\Servername\Sharename\Path\Filename. Comme lors de l'écriture de fichiers sur le disque dur local, le compte d'utilisateur qu'utilise SQL Server doit avoir reçu les autorisations nécessaires à la lecture ou à l'écriture des fichiers sur le disque distant.

  3. Attachez la base de données pubs copiée et, en option, les fichiers journaux dans une instance de SQL Server 2005 (cet exemple utilise le même nom de base de données). Dans SQL Server Management Studio, ouvrez une nouvelle requête d'éditeur de requête et connectez-vous à l'instance de serveur à laquelle vous souhaitez attacher la base de données.

    Remarque :
    Pour plus d'informations, consultez Fenêtre Éditeur de requête du moteur de base de données SQL Server Management Studio.

    Exécutez l'instruction CREATE DATABASE suivante.

    Copier le code
    USE master;
GO
CREATE DATABASE pubs ON PRIMARY
   (FILENAME =
      'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\pubs.mdf')
   LOG ON (FILENAME =
      'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Data\pubs_log.ldf')
   FOR ATTACH;
GO
    Remarque :
    Dans SQL Server Management Studio, une base de données récemment attachée n'est pas immédiatement visible dans l'Explorateur d'objets. Pour afficher la base de données, cliquez sur la fenêtre Explorateur d'objets, puis sélectionnez Affichage > Actualiser. Lorsque le nœud Bases de données est développé, la base de données récemment attachée apparaît maintenant dans la liste des bases de données.

  4. Éventuellement, rattachez la base de données d'origine pubs à l'instance de SQL Server 2000 en utilisant la procédure stockée sp_attach_db. Dans l'Analyseur de requêtes, entrez :

    Copier le code
    USE master;
Go
EXEC sp_attach_db @dbname = N'pubs',
   @filename1 =
      N'c:\Program Files\Microsoft SQL Server\MSSQL\Data\pubs.mdf',
   @filename2 =
      N'c:\Program Files\Microsoft SQL Server\MSSQL\Data\pubs_log.ldf';
GO

Voir aussi

Concepts

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau

Autres ressources

Attachement et détachement des bases de données
CREATE DATABASE (Transact-SQL)
Procédure : attachement d'une base de données (SQL Server Management Studio)
Procédure : mettre à niveau SQL Server à l'aide de l'Assistant Copie de base de données
Sécurisation des fichiers de données et des fichiers journaux


Mise à niveau de la fonction de recherche en texte intégral

Mise à niveau de la fonction de recherche en texte intégral |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

La mise à niveau de recherche en texte intégral vers SQL Server 2008 est effectuée pendant l'installation et lorsque des fichiers de base de données et des catalogues de texte intégral d'une version précédente de SQL Server sont joints, sont restaurés ou sont copiés à l'aide de l'Assistant Copie de base de données.

Cette rubrique traite des aspects fondamentaux suivants de la mise à niveau de texte intégral :

  • Mise à niveau d'une instance de serveur

  • Options de mise à niveau de texte intégral

  • Considérations relatives au choix d'une option de mise à niveau de texte intégral

  • Migration d'index de recherche en texte intégral lors de la mise à niveau d'une base de données vers SQL Server 2008

  • Considérations relatives à la restauration d'un catalogue de texte intégral SQL Server 2005 vers SQL Server 2008

  • Attachement d'une base de données SQL Server 2005 à SQL Server 2008

Mise à niveau d'une instance de serveur

Pour une mise à niveau sur place, une instance de SQL Server 2008 est installée côte à côte avec l'ancienne version de SQL Server, et les données sont migrées. Si l'ancienne version de SQL Server intégrait la recherche en texte intégral, une nouvelle version de cette fonctionnalité est installée automatiquement. Une installation côte à côte signifie que chacun des composants suivants existe au niveau de l'instance de SQL Server.

Analyseurs lexicaux, générateurs de formes dérivées et filtres

Chaque instance utilise désormais son propre ensemble d'analyseurs lexicaux, de générateur de formes dérivées et de filtres, au lieu de s'appuyer sur la version de système d'exploitation de ces composants. Ces composants sont également plus faciles à inscrire et à configurer au niveau de l'instance. Pour plus d'informations, consultez Analyseurs lexicaux et générateurs de formes dérivées et Filtres de recherche en texte intégral.

Hôte de démon de filtre

Les hôtes de démons de filtre de texte intégral sont des processus qui se chargent en toute sécurité ; par ailleurs, ils gèrent l'exécution des composants extensibles tiers utilisés pour un index et une requête, par exemple les analyseurs lexicaux, les générateurs de formes dérivées et les filtres, sans altérer l'intégrité du moteur d'indexation et de recherche en texte intégral. Une instance de serveur utilise un processus multithread pour tous les filtres multithreads et un processus monothread pour tous les filtres monothreads.

Remarque :
SQL Server 2008 introduit un compte de service pour le service de lancement FDHOST (MSSQLFDLauncher). Ce service propage les informations sur le compte de services aux processus d'hôte de démon de filtre d'une instance spécifique de SQL Server. Pour plus d'informations sur la configuration de ce compte de service, consultez Procédure : définir le compte de service de lancement FDHOST (MSSQLFDLauncher) pour la recherche en texte intégral (Gestionnaire de configuration SQL Server).

Dans SQL Server 2005 et les versions antérieures, chaque index de recherche en texte intégral réside dans un catalogue de texte intégral qui appartient à un groupe de fichiers, a un chemin d'accès physique et est traité en tant que fichier de base de données. Dans SQL Server 2008, un catalogue de texte intégral est un concept logique – objet virtuel – qui renvoie à un groupe d'index de recherche en texte intégral. Par conséquent, un nouveau catalogue de texte intégral n'est pas traité en tant que fichier de base de données avec un chemin d'accès physique. Toutefois, un nouveau groupe de fichiers est créé sur le même disque pendant la mise à niveau de tout catalogue de texte intégral qui contient des fichiers de données. Cela maintient le comportement d'E/S de l'ancien disque après la mise à niveau. Tout index de recherche en texte intégral de ce catalogue est placé dans le nouveau groupe de fichiers si le chemin d'accès racine existe. Si l'ancien chemin de catalogue de texte intégral est non valide, la mise à niveau conserve l'index de recherche en texte intégral dans le même groupe de fichiers comme table de base ou, pour une table partitionnée, dans le groupe de fichiers principal.

Pour plus d'informations sur l'architecture de la recherche en texte intégral dans SQL Server 2008, consultez Architecture de la recherche en texte intégral.

Remarque :
Les instructions DDL Transact-SQL SQL Server 2005 qui spécifient des catalogues de texte intégral fonctionnent correctement.

Options de mise à niveau de texte intégral

Lors de la mise à niveau d'une instance de serveur vers SQL Server 2008, l'interface utilisateur vous permet de choisir l'une des options de mise à niveau de texte intégral suivantes.

Importer

Les catalogues de texte intégral sont importés. En général, l'importation est considérablement plus rapide que lors d'une reconstruction (rebuild). Par exemple, lorsque vous utilisez un seul processeur, l'importation s'exécute approximativement 10 fois plus vite que lors de la reconstruction. Toutefois, un catalogue de texte intégral importé n'utilise pas les analyseurs lexicaux nouveaux et améliorés introduits dans SQL Server 2008, ce qui fait que vous pouvez le cas échéant reconstruire vos catalogues de texte intégral au final.

Remarque :
Le processus de reconstruction peut s'exécuter en mode multithread, et si plus de 10 processeurs sont disponibles, la reconstruction peut s'effectuer plus vite que l'importation si vous la laissez utiliser tous les processeurs.

Si aucun catalogue de texte intégral n'est disponible, les index de recherche en texte intégral associés sont reconstruits. Cette option est disponible uniquement pour les bases de données SQL Server 2005.

Pour plus d'informations sur l'impact de l'importation de l'index de recherche en texte intégral, consultez « Considérations relatives au choix d'une option de mise à niveau de texte intégral », plus loin dans cette rubrique.

Reconstruire

Les catalogues de texte intégral sont reconstruits à l'aide des analyseurs lexicaux nouveaux et améliorés. La reconstruction des index peut prendre un moment, et une quantité importante de ressources en termes d'UC et de mémoire peut être requise après la mise à niveau.

Réinitialiser

Les catalogues de texte intégral sont réinitialisés. Les fichiers de catalogue de texte intégral SQL Server 2005 sont supprimés, mais les métadonnées pour les catalogues de texte intégral et les index de recherche en texte intégral sont conservées. Après leur mise à niveau, tous les index de recherche en texte intégral ont le suivi des modifications désactivé et aucune analyse n'est démarrée automatiquement. Le catalogue reste vide tant que vous n'avez pas procédé manuellement à une alimentation complète, au terme de la mise à niveau.

Considérations relatives au choix d'une option de mise à niveau de texte intégral

Au moment de choisir l'option de mise à niveau pour votre mise à niveau, tenez compte des éléments suivants :

  • Comment est-ce que vous utilisez les analyseurs lexicaux ?

    Le service de recherche en texte intégral SQL Server 2008 inclut de nouveaux analyseurs lexicaux et générateurs de formes dérivées. Ceux-ci peuvent modifier les résultats de requêtes de texte intégral de versions précédentes pour un modèle ou scénario de texte spécifique. Par conséquent, la manière dont vous utilisez les analyseurs lexicaux est importante lors du choix d'une option de mise à niveau appropriée :

    • Si les analyseurs lexicaux de la langue de texte intégral que vous utilisez n'ont pas changé dans SQL Server 2008, ou si l'exactitude de rappel n'est pas critique pour vous, l'importation est appropriée. Ultérieurement, si vous rencontrez des problèmes de rappel, vous pouvez effectuer une mise à niveau vers les nouveaux analyseurs lexicaux en reconstruisant vos catalogues de texte intégral. Pour plus d'informations, consultez « Analyseurs lexicaux et index de texte intégral importés », plus loin dans cette section.

    • Si vous tenez à l'exactitude de rappel et que vous utilisez l'un des analyseurs lexicaux améliorés dans SQL Server 2008, la reconstruction est appropriée.

  • Certains index de recherche en texte intégral ont-ils été construits sur la base de colonnes de clés de texte intégral de type Integer ?

    La reconstruction effectue, dans quelques cas, des optimisations internes qui améliorent les performances des requêtes de l'index de recherche en texte intégral mis à niveau. Spécifiquement, si vous avez des catalogues de texte intégral qui contiennent des index de recherche en texte intégral dont la colonne de clé de texte intégral de la table de base correspond à un type de données Integer, la reconstruction permet d'obtenir une performance idéale des requêtes de texte intégral après la mise à niveau. Nous vous recommandons vivement d'utiliser l'option Reconstruire dans ce cas.

    Remarque :
    Pour les index de recherche en texte intégral dans SQL Server 2008, nous recommandons que la colonne servant de clé de texte intégral corresponde à un type de données Integer. Pour plus d'informations, consultez Paramétrage et optimisation des performances (recherche en texte intégral).

  • Quelle est la priorité pour obtenir votre instance de serveur en ligne ?

    L'importation ou la reconstruction pendant la mise à niveau mobilise beaucoup de ressources processeur, ce qui retarde la mise à niveau et en ligne du reste de l'instance serveur. Si le fait d'avoir l'instance de serveur en ligne dès que possible est important et si vous êtes disposé à exécuter une alimentation manuelle après la mise à niveau, la réinitialisation est appropriée.

Utilisation de nouveaux analyseurs lexicaux après l'importation d'un index de recherche en texte intégral SQL Server 2005

Lors de l'importation d'un index de recherche en texte intégral SQL Server 2005, il est important de se rendre compte que SQL Server 2008 inclue de nouveaux analyseurs lexicaux pour beaucoup de langues qui existent dans SQL Server 2005. Seuls les analyseurs lexicaux pour l'anglais, le coréen, le thaï et le chinois (traditionnel et simplifié) restent inchangés. Pour d'autres langues, SQL Server 2008 présente une nouvelle génération d'analyseurs lexicaux, qui peuvent se comporter potentiellement légèrement différemment des analyseurs lexicaux SQL Server 2005 dans les index de recherche en texte intégral SQL Server 2005 importés.

Si un catalogue de texte intégral a été importé lorsqu'une base de données SQL Server 2005 a été mise à niveau vers SQL Server 2008, une ou plusieurs langues utilisées par les index de recherche en texte intégral dans le catalogue de texte intégral peuvent maintenant être associées aux nouveaux analyseurs lexicaux. Pour ces langues, quand une requête utilise les nouveaux analyseurs lexicaux, des discordances entre la requête et le contenu de l'index de recherche en texte intégral peuvent parfois se produire à la suite de légères différences dans le comportement des analyseurs lexicaux anciens et nouveaux. Dans ce cas, pour garantir une correspondance totale entre requêtes et contenu d'index de recherche en texte intégral, procédez à l'une des opérations suivantes :

  • reconstruisez le catalogue de texte intégral contenant l'index de recherche en texte intégral (ALTER FULLTEXT CATALOG catalog_name REBUILD) ;

  • publiez un FULL POPULATION sur l'index de recherche en texte intégral (ALTER FULLTEXT INDEX ON table_name START FULL POPULATION).

Important :
Si vos catalogues et index de recherche en texte intégral utilisent des analyseurs lexicaux inchangés, à l'instar des analyseurs lexicaux anglais, aucune incompatibilité ne peut avoir lieu. Les analyseurs lexicaux utilisés lors des requêtes seront ceux utilisés lorsque l'index a été créé lors de l'indexation et dans les futures requêtes.

Pour plus d'informations sur les analyseurs lexicaux, consultez Analyseurs lexicaux et générateurs de formes dérivées.

Mise à niveau des fichiers de mots parasites vers des listes de mots vides

Les mots parasites SQL Server 2005 ont été remplacés par les mots vides SQL Server 2008. Lorsqu'une base de données est mise à niveau vers SQL Server 2008 à partir d'une version précédente, les fichiers de mots parasites ne sont plus utilisés dans SQL Server 2008. Toutefois, les anciens fichiers de mots parasites sont stockés dans le dossier FTDATA\ FTNoiseThresaurusBak, et vous pouvez les utiliser ultérieurement lors de la mise à jour ou de la génération des listes de mots vides SQL Server 2008 correspondantes.

Après la mise à niveau :

  • Si vous n'avez jamais ajouté, modifié ou supprimé des fichiers de mots parasites de votre installation de SQL Server 2005, la liste de mots vides système doit correspondre à vos besoins.

  • Si vos fichiers de mots parasites ont été modifiés dans SQL Server 2005, ces changements sont perdus pendant la mise à niveau. Pour recréer ces mises à jour, vous devez recréer manuellement ces changements dans la liste de mots vides SQL Server 2008 correspondante. Pour plus d'informations, consultez ALTER FULLTEXT STOPLIST (Transact-SQL).

  • Si vous ne souhaitez pas appliquer de mots vides à vos index de recherche en texte intégral (par exemple, si vous avez supprimé ou effacé vos fichiers de mots parasites dans votre installation SQL Server 2005 ), vous devez désactiver la liste de mots vides pour chaque index de recherche en texte intégral mis à niveau. Exécutez l'instruction Transact-SQL suivante (en remplaçant database par le nom de la base de données mise à niveau et table par le nom de la table):

    Copier le code
    Use database;
ALTER FULLTEXT INDEX ON table
   SET STOPLIST OFF;
GO
    La clause STOPLIST OF supprime le filtrage par mot vide, et déclenche une alimentation de la table, sans filtrer les mots considérés comme des mots parasites.

Sauvegarde et catalogues de texte intégral importés

Pour les catalogues de texte intégral qui sont reconstruits ou réinitialisés pendant la mise à niveau (et pour les nouveaux catalogues de texte intégral), le catalogue de texte intégral est un concept logique et ne réside pas dans un groupe de fichiers. Par conséquent, pour sauvegarder un catalogue de texte intégral dans SQL Server 2008, vous devez identifier tous les groupes de fichiers contenant un index de recherche en texte intégral du catalogue et les sauvegarder un par un. Pour plus d'informations, consultez Sauvegarde et restauration d'un catalogue de texte intégral SQL Server 2008.

Pour les catalogues de texte intégral importés à partir de SQL Server 2005, le catalogue de texte intégral est encore un fichier de base de données dans son propre groupe de fichiers. Le processus de sauvegarde SQL Server 2005 pour les catalogues de texte intégral s'applique encore mais le service MSFTESQL n'existe pas dans SQL Server 2008. Pour plus d'informations sur le processus SQL Server 2005, consultez « Sauvegarde et restauration de catalogues de texte intégral » dans la documentation en ligne de SQL Server 2005.

Remarque :
Pour plus d'informations sur la sauvegarde et la restauration d'une base de données SQL Server 2008, consultez Sauvegarde et restauration d'un catalogue de texte intégral SQL Server 2008.

Migration d'index de recherche en texte intégral lors de la mise à niveau d'une base de données vers SQL Server 2008

Les fichiers de base de données et les catalogues de texte intégral d'une version précédente de SQL Server peuvent être mis à niveau vers une instance de serveur SQL Server 2008 existante en utilisant un attachement, une restauration ou l'Assistant Copie de base de données. Les index de recherche en texte intégral SQL Server 2005 sont, le cas échéant, importés, réinitialisés ou reconstruits. Dans SQL Server 2000, les index de recherche en texte intégral sont, le cas échéant, reconstruits ou réinitialisés. La propriété de serveur upgrade_option détermine l'option de mise à niveau de texte intégral que l'instance de serveur utilise pendant ces mises à niveau de base de données.

Après avoir attaché, restauré ou copié une éventuelle base de données SQL Server 2005 ou SQL Server 2000 dans SQL Server 2008, la base de données est immédiatement disponible et est ensuite automatiquement mise à niveau. Selon le volume de données indexé, l'importation peut prendre plusieurs heures et la reconstruction jusqu'à dix fois plus longtemps. Notez également que lorsque l'option de mise à niveau est Importer, si le catalogue de texte intégral n'est pas disponible, les index de recherche en texte intégral associés sont reconstruits.

Pour modifier le comportement de mise à niveau de texte intégral sur une instance de serveur

  • Transact-SQL: utilisez l'action upgrade_option de sp_fulltext_service

  • SQL Server Management Studio : utilisez l'option de mise à niveau de texte intégral de la boîte de dialogue Propriétés du serveur. Pour plus d'informations, consultez Procédure : afficher ou modifier les propriétés de serveur pour la recherche en texte intégral (SQL Server Management Studio).

Considérations relatives à la restauration d'un catalogue de texte intégral SQL Server 2005 vers SQL Server 2008

Une méthode de mise à niveau de données de texte intégral d'une base de données SQL Server 2005 vers SQL Server 2008 est de restaurer une sauvegarde de la base de données complète vers SQL Server 2008.

En important un catalogue, vous pouvez sauvegarder et restaurer la base de données et le fichier catalogue. Le comportement est identique à celui de SQL Server 2005 :

  • La sauvegarde de base de données complète inclut alors le catalogue de texte intégral. Pour faire référence au catalogue de texte intégral, utilisez son nom de fichier SQL Server 2005, sysft_+catalog-name.

  • Si le catalogue de texte intégral est hors connexion, la sauvegarde échouera.

Pour plus d'informations sur la sauvegarde et la restauration de catalogues de texte intégral SQL Server 2005, consultez Sauvegarde et restauration de catalogues de texte intégral et Restauration et sauvegarde de fichiers et catalogues de texte intégral dans la documentation en ligne de SQL Server 2005.

Lorsque la base de données est restaurée sur SQL Server 2008, un nouveau fichier de base de données est crée pour le catalogue de texte intégral. Le nom par défaut de ce fichier est ftrow_catalog-name.ndf. Par exemple, si nom-catalogue est cat1, le nom par défaut du fichier de base de données SQL Server 2008 serait ftrow_cat1.ndf. Mais si le nom par défaut est déjà utilisé dans le répertoire cible, le nouveau fichier de base de données serait nommé ftrow_catalog-name{GUID}.ndf, où GUID est l'identificateur global unique du nouveau fichier.

Après avoir importé les catalogues, les fichiers sys.database_files et sys.master_files sont mis à jour pour supprimer les entrées de catalogue et la colonne de chemin d'accès dans sys.fulltext_catalogs prend la valeur NULL.

Pour sauvegarder une base de données

  • Sauvegardes complètes de base de données

  • Création de sauvegardes des fichiers journaux de transactions (modèle de restauration complète)

Pour restaurer une sauvegarde de la base de données

  • Réalisation d'une restauration de base de données complète (mode de récupération simple)

  • Exécution d'une restauration de base de données complète (mode de restauration complète)

Remarque :
Pour plus d'informations sur la restauration des index de recherche en texte intégral SQL Server 2008, consultez Restauration fragmentaire et index de recherche en texte intégral.

Exemple

L'exemple suivant utilise la clause MOVE dans l'instruction RESTORE, afin de restaurer une base de données SQL Server 2005 nommée ftdb1. Les fichiers catalogue, le journal et la base de données SQL Server 2005 sont déplacés vers les nouveaux emplacements sur l'instance de serveur SQL Server 2008, comme suit :

  • Le fichier de base de données, ftdb1.mdf, est déplacé vers C:\Program Files\Microsoft SQL Server\MSSQL.1MSSQL10.MSSQLSERVER\MSSQL\DATA\ftdb1.mdf.

  • Le fichier journal, ftdb1_log.ldf, est déplacé vers un répertoire de journal sur votre lecteur de disque journal, log_drive:\log_directory\ftdb1_log.ldf.

  • Les fichiers catalogue qui correspondent au catalogue sysft_cat90 sont déplacés vers C:\temp. Après avoir importé les index de recherche en texte intégral, ceux-ci sont automatiquement placés dans un fichier de base de données, C:\ftrow_sysft_cat90.ndf, et C:\temp est supprimé.

Copier le code
RESTORE DATABASE [ftdb1] FROM  DISK = N'C:\temp\ftdb1.bak' WITH  FILE = 1,
   MOVE N'ftdb1' TO N'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\DATA\ftdb1.mdf',
    MOVE N'ftdb1_log' TO N'log_drive:\log_directory\ftdb1_log.ldf',
    MOVE N'sysft_cat90' TO N'C:\temp';

Attachement d'une base de données SQL Server 2005 à SQL Server 2008

Dans SQL Server 2008, un catalogue de texte intégral est un concept logique qui fait référence à un groupe d'index de recherche en texte intégral. Le catalogue de texte intégral est un objet virtuel qui n'appartient à aucun groupe de fichiers. Cependant, lorsque vous attachez une base de données SQL Server 2005 qui contient des fichiers catalogue de texte intégral à une instance de serveur SQL Server 2008, les fichiers catalogue sont attachés à partir de leur emplacement précédent avec les autres fichiers de base de données, les mêmes que dans SQL Server 2005.

L'état de chaque catalogue de texte intégral attaché sur SQL Server 2008 est le même que lors du détachement de la base de données de SQL Server 2005. Si le remplissage de l'index de recherche en texte intégral est interrompu par l'opération de détachement, le remplissage reprend sur SQL Server 2008, et l'index de recherche en texte intégral devient disponible pour la recherche en texte intégral.

Si SQL Server 2008 ne parvient pas à trouver un fichier catalogue de texte intégral ou si ce dernier a été déplacé durant l'opération d'attachement sans spécification du nouvel emplacement, le comportement dépend de l'option de mise à niveau de texte intégral sélectionnée. Si l'option de mise à niveau de texte intégral a la valeur Importer ou Reconstruire, le catalogue de texte intégral attaché est reconstruit. Si l'option de mise à niveau de texte intégral a la valeur Réinitialiser, le catalogue de texte intégral attaché est réinitialisé.

Pour plus d'informations sur le détachement et l'attachement d'une base de données, consultez Attachement et détachement des bases de données, CREATE DATABASE (Transact-SQL), sp_attach_db et sp_detach_db (Transact-SQL).

Voir aussi

Autres ressources

Mise en route avec la recherche en texte intégral
Moteur d'indexation et de recherche en texte intégral
Analyseurs lexicaux et générateurs de formes dérivées
Filtres de recherche en texte intégral


Migration de plans de requête

Migration de plans de requête |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

Dans la plupart des cas, la mise à niveau d'une base de données vers SQL Server 2008 améliore les performances des requêtes. Toutefois, si vous avez des requêtes critiques réglées avec soin pour la performance, vous pouvez conserver les plans de requête pour ces requêtes avant d'effectuer la mise à niveau en créant un repère de plan pour chaque requête. Si, après avoir effectué la mise à niveau, l'optimiseur de requête choisit un plan moins efficace pour l'une ou plusieurs des requêtes, vous pouvez activer les repères de plan et forcer l'optimiseur de requête à utiliser les plans de pré-mise à niveau.

Pour créer des repères de plan avant d'effectuer la mise à niveau, procédez comme suit :

  1. Enregistrez le plan actuel pour chaque requête critique en utilisant la procédure stockée sp_create_plan_guide et en spécifiant le plan de requête dans l'indicateur de requête USE PLAN.

  2. Vérifiez que le repère de plan est appliqué à la requête.

  3. Procédez à la mise à niveau de la base de données vers SQL Server 2008.

    Les plans sont conservés dans la base de données mise à niveau, dans les repères de plan et servent de secours en cas de régressions de plan après la mise à niveau.

    Nous vous recommandons de ne pas activer les repères de plan après la mise à niveau, car vous risquez de passer à côté d'opportunités de meilleurs plans dans la nouvelle version ou de recompilations bénéfiques en raison de statistiques mises à jour.

  4. Si des plans moins efficaces sont choisis après la mise à niveau, activez l'ensemble ou un sous-ensemble des repères de plan pour remplacer les nouveaux plans.

Exemple

L'exemple suivant indique comment enregistrer un plan de pré-mise à niveau pour une requête en créant un repère de plan.

Étape 1 : collecter le plan

Le plan de requête enregistré dans le repère de plan doit être au format XML. Les plans de requête XML peuvent être générés des manières suivantes :

  • SET SHOWPLAN_XML

  • SET STATISTICS XML

  • Interrogation de la colonne query_plan de la fonction de gestion dynamique sys.dm_exec_query_plan.

  • Classes d'événements Générateur de profils SQL Server Showplan XML, Showplan XML Statistics Profile et Showplan XML For Query Compile.

Pour plus d'informations sur la génération et l'analyse des plans de requête, consultez Analyse d'une requête.

L'exemple suivant collecte le plan de requête pour l'instruction SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC; en interrogeant des vues de gestion dynamique.

Copier le code
USE AdventureWorks;
GO
SELECT query_plan
    FROM sys.dm_exec_query_stats AS qs
    CROSS APPLY sys.dm_exec_sql_text(qs.sql_handle) AS st
    CROSS APPLY sys.dm_exec_text_query_plan(qs.plan_handle, DEFAULT, DEFAULT) AS qp
    WHERE st.text LIKE N'SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC;%';
GO

Étape 2 : créer le repère de plan nécessaire à l'application forcée du plan

À l'aide du plan de requête au format XML (obtenu à l'aide de n'importe laquelle des méthodes décrites précédemment) dans le repère de plan, copiez et collez le plan de requête en tant que littéral de chaîne à l'intérieur de l'indicateur de requête USE PLAN spécifié dans la clause OPTION de sp_create_plan_guide.

Dans le plan XML lui-même, échappez les guillemets (') qui apparaissent dans le plan en ajoutant un deuxième guillemet avant de créer le repère de plan. Par exemple, si un plan contient WHERE A.varchar = 'This is a string', vous devez utiliser un caractère d'échappement en modifiant le code par WHERE A.varchar = ''This is a string''.

L'exemple suivant crée un repère de plan pour le plan de requête collecté lors de l'étape 1 et insère le plan d'exécution XML pour la requête dans le paramètre @hints. Pour des raisons de concision, une partie seulement de la sortie du plan d'exécution est incluse dans cet exemple.

Copier le code
EXECUTE sp_create_plan_guide
@name = N'Guide1',
@stmt = N'SELECT City, StateProvinceID, PostalCode FROM Person.Address ORDER BY PostalCode DESC;',
@type = N'SQL',
@module_or_batch = NULL,
@params = NULL,
@hints = N'OPTION(USE PLAN N''<ShowPlanXML xmlns=''''http://schemas.microsoft.com/sqlserver/2004/07/showplan''''
    Version=''''0.5'''' Build=''''9.00.1116''''>
    <BatchSequence><Batch><Statements><StmtSimple>
    …
    </StmtSimple></Statements></Batch>
    </BatchSequence></ShowPlanXML>'')';
GO

Étape 3 : vérifier que le repère de plan est appliqué à la requête

Réexécutez la requête et examinez le plan de requête produit. Vous devez constater que le plan correspond à celui que vous avez spécifié dans le repère de plan.

Voir aussi

Autres ressources

sp_create_plan_guide (Transact-SQL)
Utilisation de l'indicateur de requête USE PLAN
Scénarios et exemples d'imposition de plan


Procédure : réduire le temps d'indisponibilité des bases de données mises en miroir lors de la mise à niveau d'instances de serveur

Procédure : réduire le temps d'indisponibilité des bases de données mises en miroir lors de la mise à niveau d'instances de serveur |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

Cette rubrique décrit comment réduire le temps mort pour les bases de données mises en miroir lorsque vous mettez à jour des instances de serveur Microsoft SQL Server 2005 vers Microsoft SQL Server 2008. Ce processus implique la mise à niveau séquentielle des instances de SQL Server 2005 qui participent à la mise en miroir de bases de données. Ce type de mise à niveau, appelé mise à niveau propagée, ne réduit le temps mort que pour un seul basculement. Notez que pour les sessions en mode hautes performances dans lesquelles le serveur miroir est géographiquement distant du serveur principal, une mise à niveau propagée peut être inappropriée.

Remarque :
Pour plus d'informations sur la façon d'effectuer une mise à niveau propagée pour installer un Service Pack ou un correctif logiciel, consultez Procédure : installer un Service Pack sur un système avec un temps mort minimal pour les bases de données mises en miroir.

Une mise à niveau propagée est un processus impliquant les différentes étapes suivantes :

  • Protégez vos données.

  • Si la session inclut un témoin, nous vous recommandons de le supprimer. Dans le cas contraire, lorsque l'instance de serveur miroir est mise à niveau, la disponibilité de la base de données dépend du témoin qui reste connecté à l'instance de serveur principal. Après avoir supprimé un témoin, vous pouvez le mettre à niveau à tout moment pendant le processus de mise à niveau propagée sans risquer un temps mort de la base de données.

    Remarque :
    Pour plus d'informations, consultez Quorum : effets d'un témoin sur la disponibilité de la base de données.

  • Si une session s'exécute en mode hautes performances, convertissez le mode d'opération en mode haute sécurité.

  • Mettez à niveau chaque instance de serveur impliquée dans la mise en miroir de bases de données. Une mise à niveau propagée implique la mise à niveau de l'instance de serveur qui est actuellement le serveur miroir, le basculement manuel de chacune de ses bases de données mises en miroir et la mise à niveau de l'instance de serveur qui était auparavant le serveur principal (et qui est désormais le nouveau serveur miroir). À ce stade, vous devrez reprendre la mise en miroir.

    Remarque :
    Avant de démarrer une mise à niveau propagée, nous vous recommandons d'effectuer un basculement manuel d'essai sur au moins une de vos sessions de mise en miroir.

  • Rétablissez si nécessaire le mode hautes performances.

  • Faites revenir le témoin dans la session de mise en miroir, si nécessaire.

Les procédures correspondant à ces étapes sont décrites ici.

Important :
Une instance de serveur peut remplir différents rôles de mise en miroir (serveur principal, serveur miroir ou témoin) dans des sessions de mise en miroir simultanées. Dans ce cas, vous devez adapter le processus de mise à niveau propagée de base en conséquence. Pour plus d'informations, consultez Sessions de mise en miroir de bases de données.

Pour protéger vos données avant une mise à niveau (meilleure pratique)

  1. Effectuez une sauvegarde complète de chaque base de données principale.

    Pour sauvegarder une base de données

    • Procédure : sauvegarder une base de données (SQL Server Management Studio).

    • Procédure : créer une sauvegarde complète de base de données (Transact-SQL)

  2. Exécutez la commande DBCC CHECKDB sur chaque base de données principale.

Pour supprimer un témoin d'une session

  1. Si une session de mise en miroir fait intervenir un témoin, nous vous recommandons de le supprimer avant d'effectuer une mise à niveau propagée.

    Pour supprimer le témoin

    • Procédure : supprimer le témoin d'une session de mise en miroir de bases de données (SQL Server Management Studio)

    • Procédure : Supprimer le témoin d'une session de mise en miroir de bases de données (Transact-SQL)

Pour faire passer une session du mode hautes performances en mode haute sécurité

  1. Si une session de mise en miroir s'exécute en mode hautes performances, avant d'effectuer une mise à niveau propagée, convertissez le mode d'opération en mode haute sécurité sans basculement automatique. Appliquez l'une des méthodes suivantes :

    • Dans SQL Server Management Studio : définissez l'option Mode d'opération sur Haute sécurité sans basculement automatique (synchrone) dans la page Mise en miroir de la boîte de dialogue Propriétés de la base de données. Pour plus d'informations sur la façon d'accéder à cette page, consultez Procédure : démarrer l'Assistant Configuration de la sécurité de mise en miroir de bases de données (SQL Server Management Studio).

    • Dans Transact-SQL : attribuez à la sécurité des transactions la valeur FULL. Pour plus d'informations, consultez Procédure : modification de la sécurité des transactions dans une session de mise en miroir de bases de données (Transact-SQL)

      Remarque :
      Pour plus d'informations, consultez Paramètres Transact-SQL et modes d'opération de mise en miroir de bases de données.

Pour effectuer la mise à niveau propagée

  1. Pour réduire le temps mort, nous vous recommandons d'appliquer la procédure suivante : démarrez la mise à niveau propagée en mettant à jour tout serveur partenaire de mise en miroir qui est actuellement le serveur miroir dans toutes ses sessions de mise en miroir. Vous pouvez être amené à mettre à jour plusieurs instances de serveur à ce stade.

    Remarque :
    Un témoin peut être mis à niveau à tout moment au cours du processus de mise à niveau propagée. Par exemple, si une instance de serveur est un serveur miroir dans la session 1 et un témoin dans la session 2, vous pouvez la mettre à niveau dès maintenant.

    L'instance de serveur à mettre à niveau en premier dépend de la configuration actuelle de vos sessions de mise en miroir, à savoir :

    • Si une instance de serveur est déjà le serveur miroir dans toutes ses sessions de mise en miroir, mettez-la à niveau vers la nouvelle version.

    • Si toutes vos instances de serveur correspondent actuellement au serveur principal dans toutes les sessions de mise en miroir, sélectionnez une instance de serveur à mettre à niveau en premier. Ensuite, basculez manuellement chacune de ses bases de données principales et mettez à niveau cette instance de serveur.

    Après sa mise à niveau, une instance de serveur réintègre automatiquement chacune de ses sessions de mise en miroir.

    Pour effectuer un basculement manuel

    • Procédure : basculement manuel d'une session de mise en miroir d'une base de données (SQL Server Management Studio)

    • Procédure : basculer manuellement une session de mise en miroir de bases de données (Transact-SQL).

    Pour plus d'informations sur le fonctionnement du basculement manuel, consultez Basculement manuel.

  2. Attendez la synchronisation de chaque session de mise en miroir dont l'instance de serveur miroir vient d'être mise à niveau. Ensuite, connectez-vous à l'instance du serveur principal et basculez manuellement la session. Lors du basculement, l'instance de serveur mise à niveau devient le serveur principal pour cette session, et l'ancien serveur principal devient le serveur miroir.

    Le but de cette étape est de permettre à une autre instance de serveur de devenir le serveur miroir dans chaque session de mise en miroir dans laquelle elle est un serveur partenaire.

    Restrictions après le basculement sur une instance de serveur mise à niveau.

    Après un basculement à partir d'une instance de serveur SQL Server 2005 vers une instance de serveur SQL Server 2008, la session de base de donnée est interrompue. Elle ne peut pas reprendre tant que l'autre serveur partenaire n'a pas été mis à niveau. Toutefois, le serveur principal accepte encore des connexions et autorise l'accès aux données et des modifications sur la base de données principale.

    Remarque :
    L'établissement d'une nouvelle session de mise en miroir requiert que toutes les instances de serveur exécutent la même version de SQL Server.

  3. Après avoir effectué le basculement, nous vous recommandons d'exécuter la commande DBCC CHECKDB sur la base de données principale.

  4. Mettez à niveau chaque instance de serveur qui est désormais le serveur miroir dans toutes les sessions de mise en miroir dans lesquelles elle est un serveur partenaire. Vous pourriez devoir mettre à jour plusieurs serveurs à ce stade.

    Important :
    Dans une configuration de mise en miroir complexe, certaines instances de serveur pourraient encore être le serveur principal d'origine dans une ou plusieurs sessions de mise en miroir. Répétez les étapes 2 à 4 pour ces instances de serveur jusqu'à ce que toutes les instances concernées soient mises à niveau.

  5. Reprenez la session de mise en miroir.

    Remarque :
    Le basculement automatique ne fonctionne pas tant que le témoin n'a pas été mis à niveau.

  6. Mettez à niveau toute instance de serveur restante qui est le témoin dans toutes ses sessions de mise en miroir. Une fois qu'un témoin mis à niveau a réintégré une session de mise en miroir, il est de nouveau possible d'effectuer un basculement automatique. Vous pouvez être amené à mettre à jour plusieurs serveurs à ce stade.

Pour rétablir le mode hautes performances d'une session

  1. Rétablissez éventuellement le mode hautes performances en appliquant l'une des méthodes suivantes :

    • Dans SQL Server Management Studio : définissez l'option Mode d'opération sur Haute performance (asynchrone) dans la page Mise en miroir de la boîte de dialogue Propriétés de la base de données.

    • Dans Transact-SQL : utilisez l'instruction ALTER DATABASE pour désactiver (OFF) la sécurité des transactions.

Pour réintégrer un témoin dans une session de mise en miroir

  1. En mode haute sécurité, rétablissez éventuellement le témoin sur chaque session de mise en miroir.

    Pour réintégrer un témoin

    • Procédure : ajouter ou remplacer un témoin de mise en miroir de base de données (SQL Server Management Studio)

    • Procédure : ajouter un témoin de mise en miroir de bases de données à l'aide de l'authentification Windows (Transact-SQL)

Voir aussi

Autres ressources

Mise en miroir de bases de données ALTER DATABASE (Transact-SQL)
BACKUP (Transact-SQL)
Procédure : afficher l'état d'une base de données mise en miroir (SQL Server Management Studio)
Présentation de la mise en miroir de bases de données
Mise en miroir synchrone de bases de données (mode Haute sécurité)
Procédure : installer un Service Pack sur un système avec un temps mort minimal pour les bases de données mises en miroir
Basculement de rôle durant une session de mise en miroir de bases de données
Sessions de mise en miroir de bases de données
Service forcé (avec possibilité de perte de données)
Procédure : démarrer le moniteur de mise en miroir de bases de données
Mise en miroir asynchrone de bases de données (mode hautes performances)


Mise à niveau de la copie des journaux de transaction SQL Server 2005 vers SQL Server 2008

Mise à niveau de la copie des journaux de transaction SQL Server 2005 vers SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

Il est possible de conserver les configurations de la copie des journaux de transaction lors d'une mise à niveau de SQL Server 2005 vers SQL Server 2008. Cette rubrique décrit les scénarios et les méthodes conseillées pour la mise à niveau d'une configuration de la copie des journaux de transaction.

Remarque :
La compression de la sauvegarde a été introduite dans SQL Server 2008 Enterprise Edition. Une configuration mise à niveau de la copie des journaux de transaction utilise l'option de configuration du niveau serveur de la compression de la sauvegarde par défaut pour contrôler si la compression de la sauvegarde est utilisée pour les fichiers de sauvegarde du journal des transactions. Le comportement de la compression de la sauvegarde des sauvegardes de journaux peut être spécifié pour chaque configuration de la copie des journaux de transaction. Pour plus d'informations, consultez Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

Protéger vos données avant la mise à niveau

Comme méthode conseillée, nous vous recommandons de protéger vos données avant une mise à niveau de la copie des journaux de transaction.

Pour protéger vos données

  1. Effectuez une sauvegarde complète de chaque base de données primaire.

    Pour plus d'informations, consultez :

    • Procédure : sauvegarder une base de données (SQL Server Management Studio).

    • Procédure : créer une sauvegarde complète de base de données (Transact-SQL)

    • BACKUP (Transact-SQL)

  2. Exécutez la commande DBCC CHECKDB sur chaque base de données primaire.

Mise à niveau d'une instance du serveur moniteur

L'instance du serveur moniteur, si elle existe, peut être mise à niveau à tout moment.

Pendant que le serveur moniteur est mis à niveau, la configuration de la copie des journaux de transaction continue à fonctionner, mais son état n'est pas enregistré dans les tables sur le moniteur. Les alertes qui ont été configurées ne sont pas déclenchées tant que le serveur moniteur est en cours de mise à niveau. Après la mise à niveau, vous pouvez mettre à jour les informations dans les tables du moniteur en exécutant la procédure stockée système sp_refresh_log_shipping_monitor (Transact-SQL).

Processus de mise à niveau pour les configurations avec un seul serveur secondaire

Le processus de mise à niveau décrit dans cette section présume une configuration composée du serveur principal et d'un seul serveur secondaire. La figure ci-après illustre cette configuration, avec une instance du serveur principal, A, et une seule instance du serveur secondaire, B.

Un serveur secondaire et aucun serveur moniteur

Pour plus d'informations sur la mise à niveau de plusieurs serveurs secondaires, consultez la rubrique « Éléments à prendre en compte pour la mise à niveau de plusieurs serveurs secondaires », plus bas dans cette rubrique.

Mise à niveau de l'instance du serveur secondaire

Le processus de mise à niveau implique la mise à niveau des instances de serveur secondaire d'une configuration SQL Server 2005 de la copie des journaux de transaction vers SQL Server 2008 avant la mise à niveau de l'instance du serveur principal. Mettez toujours à niveau l'instance du serveur secondaire en premier. Si le serveur principal a été mis à niveau avant un serveur secondaire, la copie des journaux de transaction échoue parce qu'une sauvegarde créée sur une version plus récente de SQL Server ne peut pas être restaurée sur une version antérieure de SQL Server.

La copie des journaux de transaction se poursuit durant le processus de mise à niveau parce que les serveurs secondaires mis à niveau continuent à restaurer les sauvegardes des journaux à partir du serveur principal SQL Server 2005. Le processus de mise à niveau des instances de serveur secondaire dépend en partie du fait que la configuration de la copie des journaux de transaction possède ou non plusieurs serveurs secondaires. Pour plus d'informations, consultez « Éléments à prendre en compte pour la mise à niveau de plusieurs instances de serveur secondaire », plus bas dans cette rubrique.

Pendant que l'instance de serveur secondaire est mise à niveau, les travaux de copie et de restauration de la copie des journaux de transaction ne s'exécutent pas, de telle sorte que les sauvegardes des journaux des transactions non restaurées s'accumulent. La quantité accumulée dépend de la fréquence de la sauvegarde planifiée sur le serveur principal. De même, si un serveur moniteur séparé a été configuré, il se peut que des alertes soient déclenchées et indiquent que les restaurations n'ont pas été effectuées sur une durée supérieure à l'intervalle configuré.

Une fois que le serveur secondaire a été mis à niveau, les travaux des agents de la copie des journaux de transaction reprennent et poursuivent la copie et la restauration des sauvegardes de journaux à partir de l'instance du serveur principal, le serveur A. La durée requise pour que le serveur secondaire mette la base de données secondaire à jour varie, selon le temps nécessaire pour mettre à niveau le serveur secondaire et la fréquence des sauvegardes sur le serveur principal.

Remarque :
Pendant la mise à niveau du serveur, la base de données secondaire n'est pas mise à niveau vers une base de données SQL Server 2008. Elle ne sera mise à niveau que si elle est placée en ligne.

Mise à niveau de l'instance du serveur principal

Lors de la planification d'une mise à niveau, un élément important à prendre en compte est la durée pendant laquelle votre base de données ne sera pas disponible. Le scénario de mise à niveau le plus simple est que la base de données ne soit pas disponible pendant que vous mettez à niveau le serveur principal (scénario 1, ci-après).

Au prix d'un processus de mise à niveau plus compliqué, vous pouvez augmenter la disponibilité de votre base de données en basculant le serveur principal SQL Server 2005 vers un serveur secondaire SQL Server 2008 avant de mettre à niveau le serveur principal d'origine (scénario 2, ci-après). Il existe deux variantes du scénario de basculement : vous pouvez revenir au serveur principal d'origine et sauvegarder la configuration de la copie des journaux de transaction originale. Autre solution, vous pouvez supprimer la configuration de la copie des journaux de transaction originale avant de mettre à niveau le serveur principal original, puis, ultérieurement, créer une configuration à l'aide du nouveau serveur principal. Cette rubrique décrit chacun de ces scénarios.

Important :
Veillez à mettre à niveau l'instance du serveur secondaire avant l'instance du serveur principal. Pour plus d'informations, consultez « Mise à niveau de l'instance du serveur secondaire », plus haut dans cette rubrique.

Scénario 1 : mettre à niveau l'instance de serveur principal sans basculement

C'est le scénario plus simple, mais il se traduit par un temps mort plus important que le basculement. L'instance de serveur principal est simplement mise à niveau et la base de données n'est pas disponible pendant cette mise à niveau.

Une fois que le serveur est mis à niveau, la base de données est automatiquement remise en ligne, ce qui entraîne sa mise à niveau. Après que la base de données a été mise à niveau, les travaux de la copie des journaux de transaction reprennent.

Scénario 2 : mettre à niveau l'instance de serveur principal avec basculement

Ce scénario optimise la disponibilité et réduit le temps mort. Il utilise un basculement contrôlé vers l'instance de serveur secondaire, ce qui maintient la base de données disponible pendant que vous mettez à niveau l'instance de serveur principal d'origine. Le temps mort est limité à la période de temps relativement courte nécessaire au basculement, et non à la durée requise pour mettre à niveau l'instance de serveur principal.

La mise à niveau de l'instance de serveur principal avec le basculement implique trois procédures générales : exécuter un basculement contrôlé sur le serveur secondaire, mettre à niveau l'instance de serveur principal d'origine vers SQL Server 2008 et installer la copie des journaux de transaction sur une instance de serveur principal SQL Server 2008. Ces procédures sont décrites dans la présente section.

Important :
Si vous prévoyez d'avoir l'instance de serveur secondaire comme nouvelle instance de serveur principal, vous devez supprimer la configuration de la copie des journaux de transaction. La copie des journaux de transaction doit être reconfigurée à partir du nouveau serveur principal vers le nouveau serveur secondaire, une fois que l'instance de serveur principal d'origine a été mise à niveau. Pour plus d'informations, consultez Suppression de la copie des journaux de transaction.

Procédure 1. Effectuer un basculement contrôlé vers le serveur secondaire

Basculement contrôlé vers le serveur secondaire :

  1. Exécutez manuellement une sauvegarde de fichier journal après défaillance du journal des transactions sur la base de données primaire en spécifiant WITH NORECOVERY. Cette sauvegarde capture les enregistrements de journal qui n'ont pas encore été sauvegardés et place la base de données hors connexion. Notez que pendant que la base de données est hors connexion, le travail de sauvegarde de la copie des journaux de transaction échoue.

    L'exemple suivant crée une sauvegarde de fichier journal après défaillance de la base de données AdventureWorks du serveur principal. Le fichier de sauvegarde est intitulé Failover_AdventureWorks_20080315.trn:

    Copier le code
    BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Failover_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
    Nous vous recommandons d'utiliser une convention d'affectation des noms de fichier distincte afin de différencier le fichier de sauvegarde créé manuellement des fichiers de sauvegarde créés par le travail de sauvegarde de la copie des journaux de transaction.

  2. Sur le serveur secondaire :

    1. Assurez-vous que toutes les sauvegardes effectuées automatiquement par les travaux de sauvegarde de la copie des journaux de transaction ont été appliquées. Pour vérifier les travaux de sauvegarde qui ont été appliqués, utilisez la procédure stockée système sp_help_log_shipping_monitor (Transact-SQL) sur le serveur moniteur ou sur les serveurs primaires et secondaires. Le même fichier doit être répertorié dans les colonnes last_backup_file, last_copied_file et last_restored_file. Si l'un des fichiers de sauvegarde n'a pas été copié et restauré, appelez manuellement les travaux de copie et de restauration de l'agent pour la configuration de la copie des journaux de transaction. Pour plus d'informations, consultez Procédure : démarrer un travail (SQL Server Management Studio) ou sp_start_job (Transact-SQL).

    2. Copiez le dernier fichier de sauvegarde de journal créé dans l'étape 1 à partir du partage de fichiers vers l'emplacement local utilisé par la copie des journaux de transaction sur le serveur secondaire.

    3. Restaurez la dernière sauvegarde de fichier journal en spécifiant WITH RECOVERY pour mettre la base de données en ligne. Dans le cadre de sa mise en ligne, la base de données est mise à niveau vers SQL Server 2008.

      L'exemple suivant restaure le fichier journal après défaillance de la base de données AdventureWorks sur la base de données secondaire. L'exemple utilise l'option WITH RECOVERY, qui place la base de données en ligne :

      Copier le code
      RESTORE LOG AdventureWorks
   FROM DISK = N'c:\log shipping\Failover_AdventureWorks_20080315.trn'
   WITH RECOVERY;
GO
      Remarque :
      Pour une configuration qui contient plusieurs serveurs secondaires, certains éléments supplémentaires sont à prendre en compte. Pour plus d'informations, consultez « Éléments à prendre en compte pour la mise à niveau de plusieurs instances de serveur secondaire », plus bas dans cette rubrique.

    4. Basculez la base de données en redirigeant les clients depuis le serveur principal original (serveur A) vers le serveur secondaire en ligne (serveur B).

    5. Veillez à ce que le journal des transactions de la base de données secondaire ne se remplisse pas pendant que la base de données est en ligne. Pour empêcher le journal des transactions de se remplir, vous pouvez avoir besoin de le sauvegarder. Si tel est le cas, nous vous recommandons de le sauvegarder dans un emplacement partagé, un partage de sauvegarde, pour que les sauvegardes soient disponibles pour être restaurées sur l'autre instance de serveur.

Procédure 2. Mettre à niveau l'instance de serveur principal d'origine vers SQL Server 2008

Après avoir mis à niveau l'instance de serveur principal d'origine vers SQL Server 2008, la base de données demeure hors connexion et au format SQL Server 2005.

Procédure 3. Installer la copie des journaux de transaction sur SQL Server 2008

Le reste du processus de mise à niveau dépend du fait que la copie des journaux de transaction est toujours configurée ou pas, comme suit :

  • Si vous avez conservé la configuration de la copie des journaux de transaction SQL Server 2005, revenez à l'instance de serveur principal d'origine. Pour plus d'informations, consultez « Pour revenir à l'instance de serveur principal d'origine », plus loin dans cette section.

  • Si vous avez supprimé la configuration de la copie des journaux de transaction avant le basculement, créez une nouvelle configuration de la copie des journaux de transaction dans laquelle l'instance de serveur secondaire d'origine est la nouvelle instance de serveur principal. Pour plus d'informations, consultez « Pour conserver l'ancienne instance de serveur secondaire comme nouvelle instance de serveur principal », plus loin dans cette section.
Pour revenir à l'instance de serveur principal d'origine
  1. Sur le serveur principal temporaire (serveur B), sauvegardez la fin du journal avec l'option WITH NORECOVERY pour créer une sauvegarde de fichier journal après défaillance et placer la base de données hors connexion. La sauvegarde de fichier journal après défaillance s'intitule Switchback_AdventureWorks_20080315.trn. Par exemple :

    Copier le code
    BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Switchback_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
  2. Si les sauvegardes des journaux des transactions ont eu lieu sur la base de données primaire temporaire, autres que la sauvegarde de fin créée à l'étape 1, restaurez ces sauvegardes de journaux à l'aide de WITH NORECOVERY sur la base de données hors connexion du serveur principal d'origine (serveur A). La base de données est mise à niveau au format SQL Server 2008 lorsque la première sauvegarde de journal est restaurée.

  3. Restaurez la sauvegarde de fichier journal après défaillance, Switchback_AdventureWorks_20080315.trn, sur la base de données primaire d'origine (sur le serveur A) à l'aide de l'option WITH RECOVERY pour mettre la base de données en ligne.

  4. Basculez à nouveau vers la base de données primaire d'origine (sur le serveur A) en redirigeant les clients vers le serveur secondaire en ligne à partir du serveur principal d'origine.

Après que la base de données a été placée en ligne, la configuration de la copie des journaux de transaction d'origine se poursuit.

Pour conserver l'ancienne instance de serveur secondaire comme nouvelle instance de serveur principal

Établissez une nouvelle configuration de la copie des journaux de transaction en utilisant l'ancienne instance de serveur secondaire, B, comme serveur principal et l'ancienne instance de serveur principal, A, comme nouveau serveur secondaire :

Important :
L'ancienne configuration de la copie des journaux de transaction doit avoir été supprimée du serveur principal d'origine au démarrage du processus avant d'effectuer la sauvegarde manuelle des journaux des transactions qui a placé la base de données hors connexion.

  1. Pour éviter d'effectuer une sauvegarde et une restauration complètes de la base de données sur le nouveau serveur secondaire (serveur A), appliquez les sauvegardes de journaux de la nouvelle base de données primaire vers la nouvelle base de données secondaire. Dans l'exemple de configuration, cela nécessite de restaurer les sauvegardes de journaux effectuées sur le serveur B vers la base de données du serveur A.

  2. Sauvegardez le journal à partir de la nouvelle base de données primaire (serveur B).

  3. Restaurez les sauvegardes des journaux vers la nouvelle instance de serveur secondaire (serveur A) à l'aide de WITH NORECOVERY. La première opération de restauration met à jour la base de données vers SQL Server 2008.

  4. Configurez la copie des journaux de transaction avec le précédent serveur secondaire (serveur B) comme instance de serveur principal.

    Important :
    Si vous utilisez SQL Server Management Studio, spécifiez que la base de données secondaire est déjà initialisée.

    Pour configurer la copie des journaux de transaction

    • Procédure : activer la copie des journaux de transaction (SQL Server Management Studio)

    • Procédure : activer la copie des journaux de transaction (Transact-SQL)

  5. Basculez la base de données en redirigeant les clients depuis le serveur principal original (serveur A) vers le serveur secondaire en ligne (serveur B).

    Important :
    Lorsque vous basculez vers une nouvelle base de données primaire, vous devez vous assurer que ses métadonnées sont cohérentes avec celles de la base de données principale d'origine. Pour plus d'informations, consultez Gestion des métadonnées lors de la mise à disposition d'une base de données sur une autre instance de serveur.

Éléments à prendre en compte pour la mise à niveau de plusieurs instances de serveur secondaire

La figure ci-après illustre cette configuration, avec une instance du serveur principal, A, et deux instances du serveur secondaire, B et C.

Deux serveurs secondaires et aucun serveur moniteur

Mettez toujours à niveau toutes les instances de serveur secondaires avant de mettre à niveau le serveur principal.

Mise à niveau avec basculement et retour au serveur principal d'origine

Lors de la mise à niveau de l'instance principale avec le basculement, le processus est plus complexe quand il y a plusieurs instances de serveur secondaire. Dans la procédure suivante, après que tous les serveurs secondaires ont été mis à niveau, le serveur principal est basculé vers l'une des bases de données secondaires mises à niveau. Le serveur principal d'origine est mis à niveau et la copie des journaux de transaction est basculée vers ce serveur.

  1. Mettez à niveau toutes les instances de serveur secondaire (serveur B et serveur C).

  2. Récupérez la fin du journal des transactions de la base de données primaire (sur le serveur A) et placez la base de données hors connexion, en sauvegardant le journal des transactions avec l'option WITH NORECOVERY.

  3. Sur le serveur secondaire vers lequel vous prévoyez de basculer (serveur B), mettez la base de données secondaire en ligne, en restaurant la sauvegarde du journal à l'aide de WITH RECOVERY.

  4. Sur chaque autre serveur secondaire (serveur C), laissez la base de données secondaire hors ligne en restaurant la sauvegarde de journal à l'aide de WITH NORECOVERY.

    Remarque :
    Les travaux de copie et de restauration de la copie des journaux de transaction s'exécutent sur les serveurs secondaires, mais les travaux demeurent inactifs parce que les nouveaux fichiers de sauvegarde des journaux ne sont pas placés sur le partage de sauvegarde.

  5. Basculez la base de données en redirigeant les clients depuis le serveur principal original (serveur A) vers le serveur secondaire en ligne (serveur B). La base de données en ligne devient un serveur principal temporaire, en conservant la base de données disponible pendant que le serveur principal d'origine est hors connexion (serveur A).

  6. Mettez à niveau le serveur principal d'origine (serveur A).

  7. Sur la base de données vers laquelle vous avez basculé – la base de données primaire temporaire (sur le serveur B), sauvegardez manuellement le journal des transactions avec l'option WITH NORECOVERY. La base de données est alors placée hors connexion.

  8. Restaurez toutes les sauvegardes des journaux des transactions que vous avez créées sur la base de données primaire temporaire (sur le serveur B) sur chaque autre base de données secondaire (sur le serveur C) à l'aide de WITH NORECOVERY. Cela permet à la copie des journaux de transaction de se poursuivre depuis la base de données primaire d'origine après sa mise à niveau, sans nécessiter une restauration de base de données complète sur chaque base de données secondaire.

  9. Restaurez le journal des transactions depuis le serveur principal temporaire (serveur B) vers la base de données primaire d'origine (sur le serveur A) à l'aide de l'option WITH RECOVERY.

Redéploiement de la copie des journaux de transaction

Si vous ne souhaitez pas migrer la configuration de la copie des journaux de transaction à l'aide de l'une des procédures indiquées ci-dessus, vous pouvez redéployer entièrement la copie des journaux de transaction en réinitialisant la base de données secondaire avec une sauvegarde et une restauration complètes de la base de données primaire. Cette option peut être souhaitable si vous avez une base de données peu volumineuse ou si une haute disponibilité n'est pas primordiale pendant la mise à niveau.

Pour plus d'informations sur l'activation de la copie des journaux de transaction à l'aide de SQL Server Management Studio, consultez Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

Pour plus d'informations sur l'activation de la copie des journaux de transaction à l'aide de Transact-SQL, consultez Procédure : activer la copie des journaux de transaction (Transact-SQL).

Voir aussi

Concepts

Migration d'une configuration de la copie des journaux de transaction SQL Server 2000 vers SQL Server 2008

Autres ressources

Utilisation des sauvegardes de journaux de transactions
Administration de la copie des journaux de transaction
Tables et procédures stockées liées à la copie des journaux de transaction


Migration d'une configuration de la copie des journaux de transaction SQL Server 2000 vers SQL Server 2008

Migration d'une configuration de la copie des journaux de transaction SQL Server 2000 vers SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau du moteur de base de données >

Il est impossible de mettre à niveau une configuration de la copie des journaux de transaction SQL Server 2000 vers SQL Server 2008. L'Assistant Plan de maintenance de base de données, qui faisait partie intégrante de la copie des journaux de transaction dans SQL Server 2000, n'est pas utilisé dans le cadre de la configuration de la copie des journaux de transaction dans SQL Server 2005. Par conséquent, la copie des journaux de transaction ne fonctionne plus lorsque vous mettez à niveau un serveur vers SQL Server 2008.

Vous pouvez migrer une configuration de la copie des journaux de transaction SQL Server 2000. Cette rubrique décrit les méthodes permettant d'effectuer cette opération :

  • La migration avec basculement vous permet de préserver la disponibilité de la base de données pendant la mise à niveau de chaque serveur dans la configuration de la copie des journaux de transaction. La base de données secondaire n'a pas besoin d'être réinitialisée.

  • La migration sans basculement est une procédure plus simple, qui n'impose pas le basculement vers le serveur secondaire. Si vous suivez cette procédure, votre base de données n'est pas disponible pendant la mise à niveau du serveur principal. La base de données secondaire n'a pas besoin d'être réinitialisée.

  • Redéployez complètement la copie des journaux de transaction, réinitialisation incluse de la base de données secondaire à partir d'une sauvegarde complète.

Une fois achevée la migration de votre configuration de la copie des journaux de transaction vers SQL Server 2008, vous pouvez supprimer les tables et les travaux de l'Agent SQL Server créés par la copie des journaux de transaction SQL Server 2000.

Remarque :
La compression de la sauvegarde a été introduite dans SQL Server 2008 Enterprise Edition. Une configuration mise à niveau de la copie des journaux de transaction utilise l'option de configuration du niveau serveur de la compression de la sauvegarde par défaut pour contrôler si la compression de la sauvegarde est utilisée pour les fichiers de sauvegarde du journal des transactions. Le comportement de la compression de la sauvegarde des sauvegardes de journaux peut être spécifié pour chaque configuration de la copie des journaux de transaction. Pour plus d'informations, consultez Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

Migration avec basculement

Une migration avec basculement implique que vous conserviez temporairement l'instance du serveur principal dans sa version d'origine de SQL Server, pendant que vous mettez à niveau l'instance du serveur secondaire. La mise à niveau d'une instance de serveur ne met à niveau que les bases de données connectées. Les bases de données hors connexion, comme une base de données secondaire de copie des journaux de transaction, demeurent dans la version d'origine de SQL Server. Aussi longtemps qu'une base de données demeure hors connexion, les sauvegardes de fichier journal de la version d'origine de SQL Server peuvent être restaurées.

Pour des raisons de clarté, cette procédure fait référence à l'instance de serveur principal de la copie des journaux de transaction SQL Server 2000 comme Serveur A et à l'instance de serveur secondaire de la copie des journaux de transaction SQL Server 2000 comme Serveur B. que Cette configuration est représentée dans l'illustration suivante, avec l'instance de serveur principal A et l'instance de serveur secondaire B.

Un serveur secondaire et aucun serveur moniteur
  1. Mettez à niveau l'instance du serveur secondaire, le serveur B, vers SQL Server 2008. Lorsque vous mettez à niveau le serveur B, la base de données de la copie des journaux de transaction demeure une base de données SQL Server 2000 car elle se trouve hors connexion. Cette base de données est mise à niveau à l'étape suivante. Les travaux de la copie des journaux de transaction SQL Server 2000 qui copient et restaurent les fichiers journaux ne fonctionneront plus.

    Remarque :
    À ce point, les utilisateurs peuvent continuer à accéder à la base de données primaire sur le serveur A.

  2. Basculez depuis l'instance de serveur principal (serveur A) vers l'instance de serveur secondaire (serveur B).

    1. Pour basculer, restaurez toutes les sauvegardes des journaux de transactions non appliquées à partir de la base de données primaire du serveur A vers le serveur B.

    2. Sauvegardez manuellement la fin du journal des transactions sur la base de données primaire en spécifiant WITH NORECOVERY. Cette sauvegarde capture les enregistrements de journal qui n'ont pas encore été sauvegardés et place la base de données hors connexion.

      L'exemple suivant sauvegarde la fin du fichier journal de la base de données AdventureWorks sur le serveur principal. Le fichier de sauvegarde est intitulé Failover_AdventureWorks_20080315.trn:

      Copier le code
      BACKUP LOG AdventureWorks
   TO DISK = N'\\FileServer\Log Shipping\AdventureWorks\Failover_AdventureWorks_20080315.trn'
   WITH NORECOVERY;
GO
    3. Placez la base de données secondaire en ligne sur le serveur B en restaurant la fin du journal des transactions avec WITH RECOVERY.

    Le processus de basculement place votre base de données secondaire en ligne, avant qu'elle ne soit mise à niveau automatiquement vers une base de données SQL Server 2008. Le processus de mise à niveau de base de données fait l'objet d'une journalisation complète.

    Remarque :
    Après avoir été mise à niveau, la base de données de copie des journaux située sur le serveur B est disponible pour les utilisateurs. Cependant, tant que la copie des journaux de transaction SQL Server 2008 n'est pas configurée sur le serveur B, les sauvegardes de fichier journal à partir de la base de données sur le serveur B ne peuvent pas être effectuées.

  3. Mettez à niveau le serveur A vers SQL Server 2008. La base de données de la copie des journaux de transaction demeure temporairement une base de données SQL Server 2000 car elle se trouve hors connexion.

  4. Sur le serveur B, configurez la copie des journaux de transaction de SQL Server 2008 en utilisant le serveur B comme serveur principal et le serveur A comme serveur secondaire. Lorsque vous commencez la copie des journaux de transactions vers le serveur A, la base de données de copie des journaux de transaction sur le serveur A est mise à niveau vers une base de données SQL Server 2008 dès l'application de la première sauvegarde de fichier journal.

    Important :
    Lorsque vous configurez la copie des journaux de transaction sur le serveur B, veillez à spécifier l'option Non, la base de données secondaire est initialisée dans l'onglet Initialiser la base de données secondaire de la boîte de dialogue Paramètres de base de données secondaire. Pour plus d'informations, consultez Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

  5. Si vous souhaitez que le serveur A soit de nouveau le serveur principal, vous pouvez effectuer un basculement vers ce serveur. Pour plus d'informations, consultez Changement des rôles entre les serveurs primaire et secondaire.

Migration sans basculement

Vous pouvez migrer la configuration de la copie des journaux de transaction de SQL Server 2000 vers SQL Server 2005 sans recourir au basculement. Cette procédure vous permet de mettre à niveau facilement les deux instances de serveur dans la configuration de la copie des journaux de transaction ; toutefois, la base de données primaire n'est pas disponible pendant la mise à niveau de l'instance du serveur principal vers SQL Server 2008.

  1. Mettez à niveau l'instance du serveur secondaire vers SQL Server 2008. Lorsque vous mettez à niveau l'instance du serveur secondaire, la base de données de la copie des journaux de transaction demeure une base de données SQL Server 2000 car elle se trouve dans un état hors ligne. Les travaux de la copie des journaux de transaction SQL Server 2000 qui copient et restaurent les fichiers journaux ne fonctionneront plus.

  2. Mettez à niveau le serveur principal vers SQL Server 2008. La base de données primaire n'est pas disponible pendant la mise à niveau.

  3. Configurez la copie des journaux de transaction depuis l'instance du serveur principal vers l'instance du serveur secondaire. Veillez à spécifier l'option Non, la base de données secondaire est initialisée dans l'onglet Initialiser la base de données secondaire de la base de données Paramètres de base de données secondaire. Pour plus d'informations, consultez Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

    Important :
    Spécifiez le même partage de sauvegarde que celui utilisé avec la configuration de la copie des journaux de transaction SQL Server 2000. Ainsi, toutes les sauvegardes de fichier journal sont correctement appliquées à la base de données secondaire lorsque vous activez la copie des journaux de transaction dans SQL Server 2008.

    Étant donné que le processus de mise à niveau de base de données fait l'objet d'une journalisation complète, votre base de données secondaire est mise à niveau vers une base de données SQL Server 2008 lorsque vous commencez à copier les journaux vers l'instance du serveur secondaire.

Redéploiement de la copie des journaux de transaction

Si vous ne souhaitez pas migrer la configuration de la copie des journaux de transaction, vous pouvez redéployer entièrement la copie des journaux de transaction en réinitialisant la base de données secondaire avec une sauvegarde et une restauration complètes de la base de données primaire. Cette option peut être souhaitable si vous avez une base de données peu volumineuse ou si une haute disponibilité n'est pas primordiale pendant la mise à niveau.

Pour activer la copie des journaux de transaction

  • Procédure : activer la copie des journaux de transaction (SQL Server Management Studio).

  • Procédure : activer la copie des journaux de transaction (Transact-SQL).

Suppression des travaux et des tables de copie des journaux de transaction SQL Server 2000

SQL Server 2008 ne recourt à aucune des tables de copie des journaux de transaction utilisées par SQL Server 2000. Par conséquent, vous pouvez supprimer ces tables après la mise à niveau du serveur vers SQL Server 2008. Ces tables sont les suivantes :

  • log_shipping_databases

  • log_shipping_monitor

  • log_shipping_plan_databases

  • log_shipping_plan_history

  • log_shipping_plans

  • log_shipping_primaries

  • log_shipping_secondaries

Vous pouvez également supprimer tous les travaux de l'Agent SQL Server de copie des journaux de transaction initialement créés pour la configuration de la copie des journaux de transaction par SQL Server 2000.

Voir aussi

Concepts

Mise à niveau de la copie des journaux de transaction SQL Server 2005 vers SQL Server 2008

Autres ressources

Utilisation des sauvegardes de journaux de transactions
Administration de la copie des journaux de transaction
Tables et procédures stockées liées à la copie des journaux de transaction


Considérations sur la mise à niveau d'Analysis Services

Considérations sur la mise à niveau d'Analysis Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

La mise à niveau est généralement effectuée par le programme d'installation de SQL Server. L'installation de SQL Server peut être utilisée pour mettre à niveau tout ou partie de ses composants, y compris Analysis Services.

Cette rubrique met en évidence des points importants dont vous devez être informé avant de mettre à niveau Analysis Services. Pour les instructions pas à pas sur le démarrage du programme d'installation et la sélection des composants à mettre à niveau, consultez Mise à niveau vers SQL Server 2008. Pour plus d'informations sur les options de ligne de commande pour la mise à niveau de Analysis Services, consultez Installing SQL Server from the Command Prompt.

Important :
Pour savoir quelles fonctionnalités Analysis Services ont été abandonnées, désapprouvées ou modifiées, consultez Compatibilité descendante de SQL Server Analysis Services.

Problèmes de mise à niveau connus

Avant d'effectuer une mise à niveau vers SQL Server 2008 Analysis Services, consultez Modifications avec rupture dans les fonctionnalités Analysis Services de SQL Server 2008. Il est également recommandé que vous exécutiez le Conseiller de mise à niveau comme décrit dans Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Liste de contrôle préalable à la mise à niveau

Avant de commencer à effectuer une mise à niveau vers SQL Server 2008 Analysis Services, prenez connaissance des éléments requis suivants :

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Paramètres de l'outil d'analyse de configuration système

  • Considérations sur la sécurité pour une installation SQL Server

  • Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau

Mise à niveau depuis SQL Server 2005 Analysis Services

Vous pouvez mettre à niveau une instance existante de SQL Server 2005 Analysis Services vers SQL Server 2008 Analysis Services et, dans le cadre du processus de mise à niveau, migrer automatiquement les bases de données existantes de l'instance précédente vers la nouvelle. Comme les métadonnées et les données binaires sont compatibles entre les deux versions, vous conserverez les données après la mise à niveau et vous n'avez pas à migrer les données manuellement. Pour mettre à niveau une instance existante de SQL Server 2005 Analysis Services, exécutez le programme d'installation et spécifiez le nom de l'instance existante comme nom de la nouvelle instance. Pour plus d'informations, consultez Procédure : mettre à niveau une instance d'Analysis Services.

Mise à niveau depuis SQL Server 2000 Analysis Services

Lorsque vous effectuez une mise à niveau de SQL Server 2000 Analysis Services vers SQL Server 2008 Analysis Services, en raison des modifications de l'architecture sous-jacente, il vaut mieux effectuer la mise à niveau en deux étapes. En premier lieu, installez côte à côte SQL Server 2008 Analysis Services et SQL Server 2000 Analysis Services. Puis, utilisez l'Assistant Migration d'Analysis Services pour migrer les bases de données SQL Server 2000 Analysis Services vers le format SQL Server 2008 Analysis Services. L'Assistant Migration d'Analysis Services migre les métadonnées des bases de données SQL Server 2000 Analysis Services vers SQL Server 2008 Analysis Services et recrée les structures de bases de données dans le format de base de données SQL Server 2008 Analysis Services tout en conservant intactes les bases de données d'origine. Pour plus d'informations, consultez Procédure : installer Analysis Services côte à côte avec une version antérieure et Migration de bases de données Analysis Services existantes.

Si vous supprimez l'instance par défaut de SQL Server 2000 Analysis Services après avoir migré ses bases de données, vous pouvez utiliser l'outil Modification du nom d'instance de Analysis Services pour désigner une instance nommée de SQL Server 2008 Analysis Services comme instance par défaut sur le serveur. Pour plus d'informations, consultez Procédure : renommer une instance d'Analysis Services.

Pour mettre à niveau SQL Server 2000 Analysis Services

  1. Installez une instance nommée de SQL Server 2008 Analysis Services en utilisant l'Assistant Installation de SQL Server ou une autre méthode d'installation. Pour plus d'informations, consultez Considerations for Installing Analysis Services ou Installing SQL Server from the Command Prompt.

  2. Utilisez l'Assistant Migration d'Analysis Services pour migrer les métadonnées de la base de données SQL Server 2000 Analysis Services vers SQL Server 2008 Analysis Services. Cette opération recrée les structures de la base de données dans le format SQL Server 2008 Analysis Services de la base de données tout en conservant intactes les bases de données d'origine. Pour plus d'informations, consultez Migration de bases de données Analysis Services existantes.

  3. Traitez les nouvelles bases de données SQL Server 2008 Analysis Services. Cette opération remplit de données les structures des nouvelles bases de données. Pour plus d'informations, consultez Traitement des objets Analysis Services.

  4. Vérifiez le traitement de la mise à niveau de la base de données. Vérifiez les bases de données mise à niveau dans SQL Server Management Studio et testez-les avec vos applications clientes.

  5. Désinstallez la version antérieure de Analysis Services si elle n'est plus nécessaire.

Voir aussi

Concepts

Considérations sur l'installation d'Analysis Services


Migration de bases de données Analysis Services existantes

Migration de bases de données Analysis Services existantes |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau d'Analysis Services >

Vous pouvez utiliser l'Assistant Migration Analysis Services pour mettre à niveau les bases de données Microsoft SQL Server 2000 Analysis Services vers Microsoft SQL Server 2008 Analysis Services. Lors de la migration, l'Assistant copie les objets de base de données SQL Server 2000 Analysis Services puis les recrée sur une instance de SQL Server 2008 Analysis Services. Les bases de données sources sont conservées intactes et ne sont pas modifiées. Après vous être assuré que les nouvelles bases de données étaient entièrement opérationnelles, vous pouvez supprimer les anciennes manuellement.

À titre de recommandation, migrez vos bases de données une par une, ou par petits lots. Cela permet de vérifier que chaque objet de base de données apparaît comme prévu sur le serveur de destination, avant de procéder à la migration d'objets supplémentaires. Lorsque vous utilisez l'Assistant Migration, le service MSSQLServerOLAPService doit fonctionner à la fois sur le serveur source et sur le serveur de destination. (Si vous migrez une instance nommée, le service MSOLAP$instancename doit fonctionner sur les deux serveurs.)

Après avoir migré vos bases de données, vous devez les traiter à partir de la source de données d'origine avant de pouvoir les interroger. Pour plus d'informations, consultez Traitement des objets Analysis Services.

Utilisation de l'Assistant Migration

Vous pouvez démarrer l'Assistant Migration à partir d'un nœud de serveur Analysis Services dans l'Explorateur d'objets de SQL Server Management Studio. Vous pouvez également lancer l'Assistant à partir de l'invite de commandes, en exécutant le programme MigrationWizard.exe.

Spécification d'une source et d'une destination

Après la page d'accueil de l'Assistant, la page Spécifier la source et la destination s'affiche. Dans cette page, vous pouvez spécifier le serveur source et le serveur de destination pour les bases de données que vous migrez. L'instance de destination d'Analysis Services peut être soit locale, soit distante. Si vous spécifiez un ordinateur de destination qui exécute plusieurs instances de SQL Server 2008 Analysis Services, utilisez le format nom_ordinateur\nom_instance.

Vous pouvez également choisir d'enregistrer le schéma de base de données dans un fichier de script et de terminer la migration ultérieurement en utilisant une tâche DDL d'exécution d'Analysis Services dans un package SQL Server 2008 Integration Services. Pour plus d'informations sur la tâche DDL d'exécution d'Analysis Services, consultez Tâche DDL d'exécution de SQL Server Analysis Services.

Sélection des bases de données à migrer

La page suivante de l'Assistant, Sélectionner les bases de données à migrer, affiche la liste de toutes les bases de données SQL Server 2000 Analysis Services et des bases de données SQL Server 2008 Analysis Services correspondantes à créer. Par défaut, toutes les bases de données sont sélectionnées, mais vous pouvez désactiver les cases à cocher en regard du nom des bases de données que vous ne souhaitez pas migrer.

Par défaut, une base de données source et sa base de données de destination correspondante ont le même nom. Toutefois, si une autre base de données avec le même nom existe déjà sur le serveur de destination, l'Assistant Migration affecte un nom unique à la nouvelle base de données. (Par exemple, une deuxième copie de la base AdventureWorks est nommée AdventureWorks 1.) Vous pouvez utiliser le nom fourni dans l'Assistant, taper un nouveau nom dans l'Assistant ou renommer la base de données à la fin de l'Assistant.

Pour plus d'informations sur la façon dont les objets SQL Server 2000 Analysis Services correspondent aux objets SQL Server 2008 Analysis Services, consultez Considérations relatives à la migration (Analysis Services).

Remarque :
L'Assistant Migration ne prend pas en charge la migration des bases de données Microsoft SQL Server 7.0 Analysis Services.

Validation des bases de données

Dans la page Validation des bases de données, l'Assistant Migration valide la structure des bases de données à migrer. L'Assistant génère un journal au fur et à mesure de la validation des bases de données. Pour afficher ce journal ou un sous-ensemble des entrées de ce journal, cliquez sur Afficher les journaux et choisissez l'une des options suivantes :

  • Afficher tout

  • Afficher les erreurs

  • Afficher les avertissements

  • Afficher les succès

La validation s'interrompt si une erreur se produit. Pour poursuivre le processus de migration, corrigez la base de données à l'origine de l'erreur, puis cliquez sur Redémarrer.

Vous pouvez arrêter le processus de validation à tout moment en cliquant sur Arrêter. L'Assistant affiche un message qui contient le nombre de bases de données n'ayant pas été validées.

Migration des bases de données

Dans la page Migration des bases de données, l'Assistant migre les objets SQL Server 2000 Analysis Services au format SQL Server 2008 Analysis Services. Vous pouvez arrêter le processus et annuler toute la transaction en cliquant sur Arrêter, puis sur Annuler.

Une fois la migration terminée, vous pouvez changer les sélections réalisées plus tôt en cliquant sur Précédente pour afficher les pages précédentes de l'Assistant. Toutefois, si vous faites cela, vous devez réexécuter le processus de migration. La réexécution du processus de migration entraîne la suppression des bases de données qui ont déjà été migrées.

Fin de l'Assistant

La page Fin de l'Assistant affiche un résumé des bases de données SQL Server 2008 Analysis Services qui ont été créées. Cliquez sur Terminer pour mettre fin à l'exécution de l'Assistant.

Après avoir migré une base de données, vous devez la traiter à partir de la source de données d'origine avant de pouvoir l'interroger. Pour plus d'informations, consultez Traitement des objets Analysis Services.

Voir aussi

Concepts

Considérations sur la mise à niveau d'Analysis Services


Considérations relatives à la migration (Analysis Services)

Considérations relatives à la migration (Analysis Services) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau d'Analysis Services >

Lorsque vous migrez à partir de versions antérieures de Microsoft SQL Server Analysis Services vers SQL Server 2008 Analysis Services, vous devez être conscient des modifications qui interviennent au niveau des fonctions, des fonctionnalités, de la structure et du comportement. Cette rubrique de présentation fournit des informations concernant les considérations courantes sur la migration qui ont trait à l'exploration de données et au moteur Analysis Services. Pour plus d'informations sur des points spécifiques des considérations relatives à la migration, consultez les rubriques suivantes :

  • Modifications avec rupture dans les fonctionnalités Analysis Services de SQL Server 2008

  • Migration de bases de données Analysis Services existantes

  • Fonctionnalités Analysis Services abandonnées dans SQL Server 2008

  • Fonctionnalités d'Analysis Services désapprouvées dans SQL Server 2008

Considérations relatives à la Migration de Analysis Services

Objets Analysis Services

Le tableau suivant décrit la correspondance entre les objets SQL Server 2000 Analysis Services et les objets SQL Server 2008 Analysis Services.

Objet SQL Server 2000 Analysis Services | Objet SQL Server 2008 Analysis Services | Informations complémentaires
Agrégation | Agrégation | Seules les agrégations pour HOLAP (hybrid OLAP) et MOLAP (multidimensional OLAP) sont migrées.
Base de données Analysis Services | Base de données Analysis Services | Aucune
Commande | Script MDX | Un script MDX (Multidimensional Expressions) est écrit pour l'objet qui contient la collection de commandes.
Cube | Cube | Une vue de source de données est également créée pour toutes les dimensions, dimensions virtuelles et cubes qui partagent la même source de données. Une vue de source de données est ensuite créée pour chaque modèle d'exploration et pour chaque dimension d'exploration de données.
Commandes des rôles de cubes et des rôles de bases de données | Non migrées | Aucune
Rôle de cube | Autorisation au niveau du cube | Les autorisations au niveau des dimensions et des cellules ne sont pas migrées.
Dimension d'exploration de données | Dimension d'exploration de données | Une vue de source de données est également créée pour chaque dimension d'exploration de données.
Source de données | Source de données | Aucune
Rôle de base de données | Autorisation sur les rôles de base de données et sur les bases de données | Aucune
Dimension | Dimension avec hiérarchie unique | Aucune
Dimensions partageant le même préfixe de nom (représentant des hiérarchies multiples) | Dimensions séparées, ayant chacune une hiérarchie unique. | Les expressions MDX qui font référence aux noms de hiérarchies d'origine ne fonctionnent plus.
Niveau dans une hiérarchie | Attribut dans la dimension et également un niveau dans une hiérarchie définie par l'utilisateur. | Aucune
Cubes liés | Non migrées | Aucune
Propriété de membre sur un niveau | Propriété de membre sur un niveau | Aucune
Modèle d'exploration de données | Modèle d'exploration de données | Une vue de source de données est créée pour chaque modèle d'exploration de données dans une base de données.
Rôle de modèle de modèle d'exploration de données | Migré sous forme de deux autorisations : une pour la structure d'exploration de données et une pour le modèle d'exploration de données. | Aucune
Hiérarchies parent-enfant multiples dans une dimension | Hiérarchie parent-enfant unique, qui est définie par des paramètres sur l'attribut parent. | Les expressions MDX qui font référence aux hiérarchies d'origine ne fonctionnent plus. Une dimension SQL Server 2008 Analysis Services ne peut avoir qu'une seule hiérarchie parent-enfant.
Partitions distantes | Non migrées. | Les partitions distantes ne sont pas disponibles tant que le serveur sur lequel elles se trouvent n'a pas été mis à niveau, ou tant que la base de données qui contient la partition distante n'a pas été migrée. Les bases de données qui contiennent les partitions distantes peuvent être migrées individuellement. La définition de la partition distante doit être actualisée pour identifier le nom de la nouvelle instance de serveur.
Référentiel | Fichiers ODL (Object Definition Language) au format XML | Aucune
Cube virtuel | Groupes de mesures liés | Aucune
Dimension virtuelle | Hiérarchie de la dimension source | Les dimensions parent-enfant virtuelles sont migrées sous forme de dimensions séparées, parce que les dimensions parent-enfant ne peuvent pas avoir plusieurs hiérarchies.

Formules de niveau personnalisées

Dans SQL Server 2005 Analysis Services (SSAS), les attributions remplaçaient les cellules calculées et les formules de niveau personnalisées. Les cellules calculées sont prises en charge dans SQL Server 2008 Analysis Services et sont migrées à partir de SQL Server 2000 Analysis Services sous la forme définie, mais les formules de niveau personnalisées sont migrées sous forme d'attributions.

Dans SQL Server 2008 Analysis Services, le test de calcul est automatiquement incrémenté à chaque passage. C'est pourquoi, si un cube contient des formules de niveau personnalisées, veillez à vérifier que les résultats sont bien ceux attendus.

Vues des sources de données

Les vues de sources de données constituaient une nouveauté de SQL Server 2005 Analysis Services (SSAS). Une vue de source de données diffère du schéma de cube de SQL Server 2000 Analysis Services, en ceci que la vue de source de données est une représentation logique de la source de données à partir de laquelle il est possible de définir plusieurs cubes, tandis que le schéma de cube de SQL Server 2000 Analysis Services est une représentation physique des relations entre les tables pour chaque cube.

Migration de dimensions à plusieurs hiérarchies

Le modèle des dimensions à plusieurs hiérarchies a changé entre SQL Server 2000 Analysis Services et SQL Server 2005 Analysis Services (SSAS). Autant que possible, ces hiérarchies sont migrées vers la même dimension mais, dans certaines circonstances, ce n'est pas possible. Dans ces cas, les calculs basés sur la hiérarchie de dimensions d'origine risquent d'échouer.

Syntaxe SQL

La façon d'exprimer des requêtes SQL a changé dans SQL Server 2005 Analysis Services (SSAS). La notation BNF (Backus-Naur Form) de la nouvelle syntaxe est utilisée dans la documentation en ligne.

Modifications des ensembles de lignes de schéma

Plusieurs ensembles de lignes de schéma ont été augmentés dans SQL Server 2005 Analysis Services (SSAS) pour fournir des informations complémentaires. Dans la plupart des cas, la position et la signification des ensembles de lignes et des colonnes existants restent les mêmes que dans SQL Server 2000 Analysis Services. Le tableau ci-dessous décrit les modifications des ensembles de lignes de schéma dans SQL Server 2005 Analysis Services (SSAS).

Schéma | Colonne | Changement
DBSCHEMA_TABLES_INFO | Toutes | Ce schéma n'est plus pris en charge.
MDSCHEMA_CELL_FORMULAS | Toutes | Ce schéma n'est plus pris en charge.
MDSCHEMA_DIMENSIONS | DIMENSION_CARDINALITY | Cette colonne renvoie le nombre de membres d'attributs de clé de la dimension.
MDSCHEMA_MEMBERS | LEVELS_LIST | Cette colonne de schéma contient la valeur NULL.
MDSCHEMA_MEMBERS | MEMBER_ORDINAL | Cette colonne a été abandonnée. La valeur 0 est renvoyée au lieu de l'ordinal du membre.

Noms uniques de membres

Dans SQL Server 2005 Analysis Services (SSAS), les noms de membre uniques ont été mis à jour et ils diffèrent maintenant de ceux de SQL Server 2000 Analysis Services. En raison de restrictions sur les noms de membre uniques, la récupération de résultats à partir du schéma des membres à l'aide du nom unique d'origine peut ne pas renvoyer les mêmes résultats que dans SQL Server 2000 Analysis Services.

Considérations sur la migration de l'exploration de données

L'Assistant Migration transfère tous les modèles d'exploration de données à partir de la base de données SQL Server 2000 Analysis Services vers la base de données de destination SQL Server 2008 Analysis Services. Pour chaque modèle d'exploration de données présent dans la base de données source, l'Assistant Migration crée une nouvelle structure d'exploration de données dans la base de données de destination. Cette structure d'exploration de données contient exactement un modèle, qui porte le même nom que le modèle d'exploration de données de la base de données source.

Pour faire migrer des modèles d'exploration de données individuels de SQL Server 2000 Analysis Services vers une instance de SQL Server 2008 Analysis Services, vous pouvez utiliser le langage PMML (Predictive Model Markup Language). L'exemple suivant montre comment récupérer la représentation PMML, sous forme d'un script XML, d'un modèle d'exploration de données SQL Server 2000 Analysis Services :

SELECT * FROM [Model_Name].PMML

Vous pouvez obtenir les mêmes informations en extrayant le schéma OLE DB, DMSCHEMA_MINING_MODEL_XML.

Vous pouvez utiliser le script PMML pour créer un nouveau modèle d'exploration de données dans une instance de SQL Server 2008 Analysis Services, à l'aide d'une instruction similaire à la suivante :

CREATE MINING MODEL [Model_Name] FROM PMML '<PMML script>'

Si vous utilisez l'Assistant Migration de Analysis Services pour migrer vos modèles d'exploration de données, sachez que cet Assistant ne prend en charge que la migration des métadonnées. Par conséquent, les modèles d'exploration de données migrés ne sont pas traités. Cependant, ces modèles contiennent encore les liaisons de données d'origine, et vous pouvez donc les traiter dans SQL Server 2008 Analysis Services après la migration. En revanche, si vous utilisez PMML pour faire migrer les modèles, les liaisons de données d'origine ne sont pas conservées. Par conséquent, vous ne pouvez plus traiter les modèles migrés. Cependant, les modèles sont prêts à l'emploi, car le PMML inclut les modèles et les tendances découverts par le modèle source.

Problèmes connus de migration de l'exploration de données :

  • Les modèles d'exploration de données qui possèdent plusieurs clés de niveau de cas avec des clés multiples dans une table imbriquée ne peuvent pas être migrés.

  • Les modèles d'exploration de données qui ont été créés à l'aide de fournisseurs d'exploration de données agrégées ne peuvent pas être migrés.

Voir aussi

Concepts

Considérations sur la mise à niveau d'Analysis Services


Rubriques de procédures de mise à niveau ou de migration d'Analysis Services

Rubriques de procédures de mise à niveau ou de migration d'Analysis Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau d'Analysis Services >

Cette section contient les procédures courantes suivantes pour mettre à niveau et migrer des bases de données vers Microsoft SQL Server 2008 Analysis Services.

Pour prendre connaissance des procédures courantes permettant d'installer Analysis Services, consultez Rubriques de procédures pour l'installation d'Analysis Services.

Important :
Les rubriques de procédures pour la mise à niveau et la migration d'Analysis Services fournies dans cette section traitent uniquement des options de mise à niveau et de migration spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Dans cette section

  • Procédure : mettre à niveau une instance d'Analysis Services

  • Procédure : migrer des bases de données Analysis Services

Voir aussi

Concepts

Considérations sur la mise à niveau d'Analysis Services


Procédure : mettre à niveau une instance d'Analysis Services

Procédure : mettre à niveau une instance d'Analysis Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau d'Analysis Services > Rubriques de procédures de mise à niveau ou de migration d'Analysis Services >

Vous pouvez mettre à niveau une instance existante de Microsoft SQL Server 2005 Analysis Services vers Microsoft SQL Server 2008 Analysis Services et, dans le cadre du processus de mise à niveau, migrer les bases de données existantes de l'instance antérieure vers la nouvelle. Pour procéder à la migration, exécutez le programme d'installation et spécifiez le nom de l'instance existante comme nom de la nouvelle instance.

Important :
Les rubriques de mise à niveau et de migration d'Analysis Services traitent uniquement des options de mise à niveau et de migration spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour mettre à niveau une instance d'Analysis Services

  1. Exécutez le programme d'installation en utilisant soit l'Assistant Installation de SQL Server, soit l'invite de commandes. Pour plus d'informations sur la façon d'exécuter le programme d'installation avec l'Assistant Installation de SQL Server, consultez Procédure : installer Analysis Services en utilisant le programme d'installation. Pour plus d'informations sur l'exécution du programme d'installation à partir de l'invite de commandes, consultez Installing SQL Server from the Command Prompt.

  2. Lorsque vous utilisez l'Assistant Installation de SQL Server, sélectionnez Instance par défaut dans la page Nom de l'instance. Pour confirmer la présence de l'instance de SQL Server 2000 Analysis Services, vous pouvez cliquer sur le bouton Instances installées. Lorsque vous exécutez le programme d'installation à partir de l'invite de commandes, utilisez l'option instancename pour indiquer le nom d'une instance existante de SQL Server 2000 Analysis Services. Étant donné que SQL Server 2000 Analysis Services ne prend pas en charge les instances nommées, le nom de l'instance existante est généralement celui du serveur.

Voir aussi

Tâches

Procédure : migrer des bases de données Analysis Services

Concepts

Considérations sur la mise à niveau d'Analysis Services


Procédure : migrer des bases de données Analysis Services

Procédure : migrer des bases de données Analysis Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau d'Analysis Services > Rubriques de procédures de mise à niveau ou de migration d'Analysis Services >

Vous pouvez migrer les bases de données Analysis Services existantes pendant l'installation, en mettant à niveau une instance existante de Analysis Services, ou après l'installation, en exécutant l'Assistant Migration.

Cette rubrique décrit le processus de migration de bases de données SQL Server 2000 Analysis Services existantes au moyen de l'Assistant Migration. Lorsque vous mettez à niveau une instance de SQL Server 2000 Analysis Services au cours de l'installation en utilisant l'Assistant Installation de SQL Server, il n'est pas nécessaire de spécifier des options supplémentaires pour la migration des bases de données.

Important :
Cette rubrique et les rubriques décrivant les procédures de mise à niveau et de migration d'Analysis Services qui l'accompagnent traitent uniquement des options de mise à niveau et de migration spécifiques à Analysis Services. Elles contiennent toutefois des liens vers d'autres rubriques dans lesquelles il est possible de trouver davantage d'informations sur l'installation de SQL Server.

Pour migrer des bases de données Analysis Services existantes au moyen de l'Assistant Migration

  1. Démarrez l'Assistant Migration à partir d'un nœud de serveur Analysis Services dans l'Explorateur d'objets de SQL Server Management Studio. Vous pouvez également lancer l'Assistant à partir de l'invite de commandes, en exécutant le programme MigrationWizard.exe.

  2. L'Assistant démarre et affiche la page Assistant Migration de Analysis Services. Lisez le message de présentation et cliquez sur Suivant pour continuer.

  3. Dans la page Spécifier la source et la destination, identifiez le serveur SQL Server 2000 Analysis Services source et le nom de l'instance, puis identifiez le serveur SQL Server 2008 Analysis Services de destination et le nom de l'instance. Au lieu de désigner un serveur de destination, vous pouvez également décider d'enregistrer le schéma de base de données dans un fichier de script et de compléter la migration ultérieurement. À cette fin, vous pouvez utiliser une tâche DDL d'exécution d'Analysis Services dans un package SQL Server 2008 Integration Services (SSIS). Pour plus d'informations sur la tâche DDL d'exécution d'Analysis Services, consultez Tâche DDL d'exécution de SQL Server Analysis Services.

  4. Dans la page Sélectionner les bases de données à migrer, activez les cases à cocher en regard des bases de données à migrer. Vous pouvez spécifier des noms différents pour les bases de données de destination si vous le souhaitez.

  5. Dans la page Validation des bases de données, l'Assistant analyse les bases de données à migrer et signale les problèmes qu'il découvre.

  6. Dans la page Migration des bases de données, l'Assistant affiche la progression de la migration des bases de données.

  7. Dans la page Fin de l'Assistant , l'Assistant affiche les résultats de la migration. Cliquez sur Terminer pour terminer l'Assistant.

  8. Après avoir migré une base de données, vous devez la traiter à partir de la source de données d'origine avant de pouvoir l'interroger. Pour plus d'informations, consultez Traitement des objets Analysis Services.

  9. Une fois la migration terminée, vous pouvez vous reporter à nouveau à la rubrique Considérations relatives à la migration (Analysis Services) pour bien comprendre les différences entre les versions des bases de données Analysis Services.

Voir aussi

Concepts

Migration de bases de données Analysis Services existantes
Considérations relatives à la migration (Analysis Services)


Considérations sur la mise à niveau de Reporting Services

Considérations sur la mise à niveau de Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

La mise à niveau est effectuée par le programme d'installation de SQL Server. Le programme d'installation SQL Server peut être utilisé pour mettre à niveau tout ou partie des composants SQL Server, y compris Reporting Services. Pour mettre à niveau une version antérieure de SQL Server, exécutez le programme d'installation de SQL Server 2008 sur un ordinateur ayant une version antérieure de SQL Server déjà installée. Le programme d'installation détecte les instances existantes et vous invite à procéder à la mise à niveau.

Lorsque vous exécutez le programme d'installation, vous pouvez sélectionner l'option de votre choix pour effectuer une mise à niveau de SQL Server 2000 ou SQL Server 2005, ou vous pouvez installer une nouvelle instance de SQL Server 2008 Reporting Services qui s'exécute côte à côte avec des installations existantes.

Cette rubrique met en évidence des points importants dont vous devez être informé avant de mettre à niveau Reporting Services.

Important :
Pour savoir quelles fonctionnalités Reporting Services ont été interrompues, désapprouvées ou modifiées, consultez Compatibilité descendante de Reporting Services.

Mise à niveau des éditions et des versions

Le programme d'installation de SQL Server 2008 fournit le support de mise à niveau pour les éditions antérieures suivantes de Reporting Services :

  • Installation de SQL Server 2000 Reporting Services avec le Service Pack 2 (SP2).

  • SQL Server 2005 Reporting Services.

La mise à niveau ou la migration vers une version antérieure d'une édition de SQL Server 2008 à partir d'une autre édition est prise en charge.

Problèmes de mise à niveau connus

Avant d'effectuer une mise à niveau vers SQL Server 2008 Reporting Services, consultez la documentation relative au Conseiller de mise à niveau et pour les informations les plus récentes sur les problèmes de mise à niveau. Pour obtenir la documentation relative au Conseiller de mise à niveau, installez celui-ci. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Les problèmes de mise à niveau connus incluent actuellement les éléments suivants :

  • Aucun support de mise à niveau pour un serveur de rapports qui utilise une instance SQL Server 2000 Moteur de base de données distante pour héberger la base de données du serveur de rapports.

  • Aucun support pour le service Web Report Server SQL Server 2000 dans SQL Server 2008. Ce point de terminaison est interrompu. Si vous avez créé ou installé des fonctionnalités personnalisées qui pointent sur le point de terminaison ReportServer2000, ces fonctionnalités personnalisées ne s'exécuteront plus. Pour plus d'informations sur les nouveaux points de terminaison, consultez Report Server Web Service Endpoints.

  • Aucun support pour les versions antérieures du fournisseur WMI de Reporting Services. Le fournisseur WMI de Reporting Services n'offre pas de compatibilité descendante avec les versions antérieures. Après la mise à niveau, vous ne pouvez pas utiliser le fournisseur WMI de SQL Server 2008 Reporting Services avec les versions antérieures de Reporting Services.

Pour plus d'informations sur les scénarios de mise à niveau pris en charge, consultez Mises à niveau de la version et de l'édition. Si vous ne pouvez pas exécuter le programme d'installation pour effectuer une mise à niveau sur place de votre installation existante, vous pouvez installer une nouvelle instance de SQL Server 2008 Reporting Services, puis effectuer une migration de votre base de données du serveur de rapports et des fichiers de configuration vers la nouvelle instance. Pour plus d'informations sur la migration de Reporting Services, consultez Procédure : migrer une installation Reporting Services.

Liste de contrôle préalable à la mise à niveau

Avant de commencer à effectuer une mise à niveau vers SQL Server 2008 Reporting Services, prenez connaissance des éléments requis suivants :

  • Passez en revue la configuration requise afin de déterminer si votre matériel et vos logiciels peuvent prendre en charge SQL Server 2008 Reporting Services. Pour plus d'informations, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

  • Utilisez l'outil d'analyse de configuration système (SCC, System Configuration Checker) pour analyser le serveur de rapports afin d'y déceler d'éventuels défauts pouvant empêcher une installation réussie de SQL Server 2008. Pour plus d'informations, consultez Paramètres de l'outil d'analyse de configuration système.

  • Prenez connaissance des meilleures pratiques recommandées et de l'aide pour SQL Server. Pour plus d'informations, consultez Considérations sur la sécurité pour une installation SQL Server.

  • Exécutez l'outil Conseiller de mise à niveau sur le serveur de rapports pour déterminer si des problèmes peuvent empêcher le succès de la mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

  • Sauvegardez votre clé symétrique. Pour plus d'informations, consultez Sauvegarde et restauration des clés de chiffrement.

  • Sauvegardez vos bases de données du serveur de rapports. Pour plus d'informations, consultez Déplacement des bases de données du serveur de rapports vers un autre ordinateur.

  • Sauvegardez les fichiers de configuration du serveur de rapports suivants : Rsreportserver.config, Rswebapplication.config, Rssvrpolicy.config, Rsmgrpolicy.config, Reportingservicesservice.exe.config, Web.config (pour à la fois les serveurs de rapports et les applications Gestionnaire de rapports ASP.NET) et Machine.config (pour ASP.NET si vous l'avez modifié pour les opérations de serveur de rapports).

  • Sauvegardez toutes les personnalisations effectuées dans les répertoires virtuels Reporting Services dans IIS.

Avant de mettre à niveau un environnement de production, veillez à toujours exécuter une mise à niveau de test dans un environnement de préproduction qui a la même configuration que votre environnement de production.

Comment mettre à niveau une version antérieure de Reporting Services

L'installation fournit des options de mise à niveau que vous pouvez spécifier comme argument de ligne de commande ou dans l'Assistant Installation. Choisissez parmi les rubriques suivantes les instructions sur la mise à niveau de votre installation.

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Explique comment procéder à une mise à niveau vers SQL Server 2008 à l'aide de l'Assistant Installation.

Procédure : installer SQL Server 2008 à partir de l'invite de commandes

Explique comment procéder à une mise à niveau vers SQL Server 2008 sous forme d'opération de ligne de commande.

Suppression des fichiers et des applications de l'installation précédente

La mise à niveau ne supprime pas les anciens fichiers journaux, le fichier RSWebApplication.config obsolète ou les paramètres de répertoire virtuel dans IIS. La mise à niveau ne supprime pas le Concepteur de rapports de SQL Server 2005, Management Studio ou autres outils clients. Si vous n'en avez plus besoin, veillez à supprimer ces fichiers et outils après la mise à niveau.

Mettre à niveau le flux de travail

Le processus de mise à niveau commence lorsque vous sélectionnez une instance de serveur de rapports existante à mettre à niveau.

  1. Si la base de données de serveur de rapports se trouve sur un ordinateur distant et que vous n'avez pas l'autorisation de mettre à jour cette base de données, le programme d'installation vous invite à fournir les informations d'identification pour mettre à jour la base de données de serveur de rapports distante. Soyez sûr de fournir les informations d'identification qui ont sysadmin ou les autorisations de mise à jour de la base de données.

  2. L'installation vérifie les conditions ou paramètres qui empêchent la mise à niveau et lit les paramètres de configuration. Les exemples incluent les extensions personnalisées déployées sur le serveur de rapports. Si la mise à niveau est bloquée, vous devez modifier votre installation afin que la mise à niveau ne soit plus bloquée, ou migrer vers une nouvelle instance de SQL Server 2008. Pour plus d'informations, consultez la documentation relative au Conseiller de mise à niveau.

  3. Si la mise à niveau peut se poursuivre, le programme d'installation vous invite à la continuer.

  4. Le programme d'installation crée de nouveaux dossiers pour les fichiers programme de SQL Server 2008. Les dossiers de programme pour une installation de Reporting Services incluent MSRS10.<nom_instance>.

  5. L'installation ajoute les fichiers programme du serveur de rapports SQL Server 2008, les outils de configuration et les utilitaires de ligne de commande qui font partie des fonctionnalités du serveur de rapports.

    1. Les fichiers programme de la version antérieure sont supprimés.

    2. Les utilitaires et les outils de configuration du serveur de rapports mis à niveau vers la nouvelle version incluent l'outil de configuration de Reporting Services, les utilitaires de ligne de commande et le Générateur de rapports. Les nouveaux outils installés avec SQL Server 2008 incluent le nouvel Aperçu du Concepteur de rapports.

    3. D'autres outils clients tels que Business Intelligence Development Studio, SQL Server Management Studio et la documentation en ligne ne sont pas mis à niveau. Pour obtenir des nouvelles versions des outils, vous pouvez les ajouter lorsque vous exécutez le programme d'installation. Les versions antérieures coexistent avec les versions de SQL Server 2008. Si vous avez installé les exemples, la version antérieure demeure. L'installation ne prend pas en charge la mise à niveau pour les exemples SQL Server.

  6. Le programme d'installation réutilise l'entrée de service du gestionnaire de services de contrôle pour le service Report Server de SQL Server 2008. Cette entrée de service inclut le compte de service Windows Report Server.

  7. L'installation réserve les nouvelles URL en fonction des paramètres de répertoire virtuel existants dans IIS. Comme le programme d'installation ne supprime pas toujours les répertoires virtuels dans IIS, veillez à les supprimer manuellement après la mise à niveau.

  8. L'installation met à niveau les bases de données du serveur de rapports vers le nouveau schéma et modifie le RSExecRole en ajoutant les autorisations du propriétaire de la base de données au rôle. Cette étape intervient seulement lorsque vous effectuez une mise à niveau à partir de SQL Server 2000 Reporting Services ou SQL Server 2005 Reporting Services avant le SP1.

  9. L'installation fusionne les paramètres dans les fichiers de configuration. En utilisant comme base les fichiers de configuration de l'installation actuelle, les nouvelles entrées sont ajoutées. Les entrées obsolètes ne sont pas supprimées, mais ne seront plus lues après la mise à niveau par le serveur de rapports.

Voir aussi

Concepts

Considérations sur l'installation de Reporting Services
Mise à niveau vers SQL Server 2008


Procédure : détecter les informations de version (Reporting Services)

Procédure : détecter les informations de version (Reporting Services) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Reporting Services >

Reporting Services consiste en plusieurs applications, outils et composants. Si vous installez ou mettez à niveau les composants en une seule opération, toutes les parties d'une installation seront de la même version. Toutefois, si vous exécutez plusieurs instances côte à côte, configurez les composants serveur pour qu'ils s'exécutent sur différents ordinateurs ou publiez les éléments sur un serveur central, vous pouvez rencontrer des erreurs de compatibilité de version si vous essayez d'utiliser les outils clients d'une version avec un serveur de rapports ayant une version différente. De telles erreurs sont susceptibles de se produire pendant des opérations de publication ou si vous essayez d'utiliser l'outil de configuration de Reporting Services pour vous connecter à un serveur de rapports d'une version précédente.

Cette rubrique peut vous aider à identifier les informations de version ou d'édition afin que vous puissiez déterminer s'il faut procéder à la mise à niveau d'un composant ou utiliser une installation différente d'un client ou d'une instance de serveur. Pour plus d'informations sur la mise à niveau, consultez Mise à niveau (Reporting Services).

Les erreurs de compatibilité de version ont peu de chances de se produire pour les connexions à la base de données du serveur de rapports. Le serveur de rapports peut automatiquement mettre à niveau une base de données du serveur de rapports à laquelle il est connecté, en éliminant de cette façon une cause majeure d'erreur d'incompatibilité de la version de base de données, qui se produisait parfois dans les versions antérieures. Toutefois, vous pouvez rencontrer une erreur dans un déploiement avec montée en puissance parallèle si vous n'avez pas mis à niveau tous les nœuds.

Les informations de version et d'édition du serveur de rapports s'affichent très aisément dans la page État de Report Server de l'outil de configuration de Reporting Services. Toutefois, si vous ne pouvez pas vous connecter au serveur de rapports à cause des erreurs d'incompatibilité de version, vous pouvez utiliser les autres étapes proposées plus loin dans cette rubrique.

Remarque :
Vous pouvez extraire les informations de version par programme. Pour extraire les informations de version du serveur, utilisez ServerInfoHeaderValue. Pour extraire la version de la base de donnée, utilisez GetDatabaseVersionDisplayName Method (WMI).

Pour rechercher les informations de version pour l'outil de configuration de Reporting Services

  • Démarrez l'outil de configuration de Reporting Services. Sur la page État de Report Server, consultez la valeur Version du produit et comparez-la au tableau Informations de version ci-dessous dans cette rubrique.

Pour rechercher les informations de version et d'édition pour une instance de serveur de rapports

  1. Ouvrez le fichier du journal de suivi du service Report Server dans un éditeur de texte. Le nom est ReportServerService_<timestamp>.log et le fichier se trouve dans le dossier \Reporting Services\ReportServer\logfiles.

  2. Les informations de version Report Server se trouvent dans <Product> en haut du fichier.

  3. Les informations d'édition du serveur de rapports se trouvent dans les instructions INFO plus bas dans le fichier :

    • Reporting Services starting SKU affiche l'édition de l'instance de serveur de rapports.

Une autre approche pour afficher les informations de version du serveur de rapports consiste à taper l'URL du serveur de rapports dans la barre d'adresses d'une fenêtre de navigateur. Les informations de version se trouvent en bas de page au format: <version >:<numéro_de_build>. S'il s'agit de la version 10, vous êtes connecté à une instance du serveur de rapports de SQL Server 2008.

Pour rechercher les informations d'édition de l'instance de base de données qui héberge les bases de données de serveur de rapports

  1. Ouvrez le fichier du journal de suivi du service Report Server dans un éditeur de texte. Le nom est ReportServerService_<timestamp>.log et le fichier se trouve dans le dossier \Reporting Services\ReportServer\logfiles.

  2. Les informations d'édition pour le serveur de base de données qui héberge la base de données du serveur de rapports se trouvent dans les instructions INFO plus bas dans le fichier :

    • Catalog SQL Server Edition affiche l'édition du serveur de base de données qui héberge la base de données du serveur de rapports.

Les informations de version ne sont pas disponibles dans les fichiers journaux, les outils et les interfaces de programmation. Utilisez le tableau à la fin de cette rubrique pour obtenir les informations de version de la base de données du serveur de rapports.

Pour rechercher la version du Concepteur de rapports et du Générateur de modèles

  1. Démarrez Business Intelligence Development Studio, cliquez sur Aide, puis cliquez sur À propos de Visual Studio.

  2. Dans la liste des produits installés, cliquez sur Reporting Services. Les informations de version apparaissent dans la section des détails du produit de la boîte de dialogue.

Pour rechercher la version du Gestionnaire de rapports ou du Générateur de rapports

  • Dans SQL Server 2008, le Gestionnaire de rapports s'exécute dans le service Report Server. Si vous connaissez la version du service Report Server, vous connaissez également celle du Gestionnaire de rapports. Toutefois, si vous pointez une instance du Gestionnaire de rapports vers une autre instance du service Report Server, il se peut que la version du Gestionnaire de rapports et celle du serveur de rapports ne soient pas synchronisées. Pour vérifier la version du Gestionnaire de rapports, cliquez avec le bouton droit sur une page Web dans le Gestionnaire de rapports et utilisez la commande Source pour consulter le code HTML. Les informations de version sont incorporées dans le code HTML sous-jacent.

  • Pour rechercher les informations de version pour le Générateur de rapports, démarrez le Générateur de rapports et cliquez sur À propos du Générateur de rapports dans le menu Aide.

Informations de version

Le tableau suivant fournit la liste des numéros de version du serveur de rapports et de la base de données du serveur de rapports :

Version | Serveur de rapports | Base de données du serveur de rapports
SQL Server 2008 | 10.n.nnnn.nn | n/a
SQL Server 2005 Reporting Services Service Pack 2 (SP2) | 9.0.3042.00 | C.0.8.45
SQL Server 2005 Express Edition with Advanced Services | 9.0.3042.00 | C.0.8.45
SQL Server 2005 Reporting Services Service Pack 1 (SP1) | 9.0.2049.00 | C.0.8.43
SQL Server 2005 Reporting Services | 9.0.1399.01 | C.0.8.40
SQL Server 2000 Reporting Services Service Pack 2 (SP2) | 8.00.1038 | C.0.6.54
SQL Server 2000 Reporting Services Service Pack 1 (SP1) | 8.00.0878 | C.0.6.51
SQL Server 2000 Reporting Services | 8.00.0743 | C.0.6.43

Voir aussi

Concepts

Mise à niveau d'une base de données du serveur de rapports

Autres ressources

Didacticiel : comment localiser et démarrer les outils Reporting Services
Mise à niveau (Reporting Services)
Composants et outils de Reporting Services


Mise à niveau d'une base de données du serveur de rapports

Mise à niveau d'une base de données du serveur de rapports |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Reporting Services >

La base de données du serveur de rapports offre un espace de stockage interne pour une ou plusieurs instances du serveur de rapports. Comme le schéma de base de données du serveur de rapports peut changer à chaque nouvelle version de Reporting Services, il est nécessaire que la version de la base de données corresponde à la version de l'instance du serveur de rapports que vous utilisez. Dans la plupart des cas, une base de données du serveur de rapports peut être mise à niveau automatiquement sans aucune intervention de votre part.

Remarque :
Vous pouvez mettre à niveau une base de données du serveur de rapports qui s'exécute sur une instance Moteur de base de données SQL Server 2005 sans devoir mettre à niveau le Moteur de base de données vers SQL Server 2008. Vous pouvez également utiliser une instance du Moteur de base de données SQL Server 2005 pour héberger une nouvelle base de données du serveur de rapports que vous créez pour une installation SQL Server 2008 Reporting Services.

Méthodes de mise à niveau de la base de données de serveur de rapports

La liste suivante identifie toutes les conditions selon lesquelles une base de données du serveur de rapports est mise à niveau :

  • L'installation met à niveau une instance unique d'un serveur de rapports. Puis, le schéma de base de données est mis à niveau automatiquement après le démarrage de service et le serveur de rapports détermine que la version du schéma de base de donnée ne correspond pas à la version du serveur.

  • Au démarrage du service, le serveur de rapports vérifie la version du schéma de base de donnée pour s'assurer qu'elle correspond à la version du serveur. Si la version du schéma de base de données est antérieure, elle est automatiquement mise à niveau vers la version du schéma requise par le serveur de rapports. La mise à niveau automatique est particulièrement utile si vous avez restauré ou joint une base de données du serveur de rapports plus ancienne. Un message est entré dans le fichier journal de suivi du serveur de rapports, indiquant que la version du schéma de base de données a été mise à niveau.

  • L'outil de configuration de Reporting Services met à niveau une base de données locale ou distante du serveur de rapports lorsque vous sélectionnez une version antérieure à utiliser avec une instance plus récente du serveur de rapports. Dans ce cas, vous devez confirmer l'action de mise à niveau avant qu'elle ne se produise.

    L'outil de configuration de Reporting Services ne fournit plus de bouton Mettre à niveau distinct ni de script de mise à niveau. Ces fonctionnalités sont obsolètes dans SQL Server 2008 en raison de la fonction de mise à niveau automatique du service Report Server.

Une fois le schéma mis à niveau, vous ne pouvez pas restaurer la mise à niveau dans une version antérieure. Pensez toujours à sauvegarder la base de données de serveur de rapports, au cas où vous devriez recréer une précédente installation.

Comment le schéma, les métadonnées et le serveur de rapports sont mis à jour

La mise à niveau de la base de données de serveur de rapports se déroule en trois étapes :

  1. Le schéma est mis à niveau automatiquement après l'installation et le démarrage du service, ou lorsque vous sélectionnez une base de données du serveur de rapports SQL Server 2005 ou 2000 dans l'outil de configuration de Reporting Services. De plus, le service Report Server vérifie la version de la base de donnée au démarrage. Si le serveur de rapports est connecté à une base de données qui est une version antérieure, il met à jour la base de données lors du démarrage.

  2. Les descripteurs de sécurité sont mis à niveau lors la première utilisation de la base de données de serveur de rapports après la mise à jour du schéma.

  3. Les rapports publiés et les captures instantanées de rapports compilées sont mis à jour lors de la première utilisation. Pour plus d'informations, consultez Mise à niveau de rapports.

Outre la base de données de serveur de rapports, un serveur de rapports utilise également une base de données temporaire. La base de données temporaire est mise à niveau automatiquement lors de la mise à niveau de la base de données de serveur de rapports.

Mise à niveau d'une base de données du serveur de rapports

Si vous mettez à niveau une installation de Reporting Services qui inclut une base de données du serveur de rapports, vous rencontrerez peut-être des problèmes lors de la mise à niveau du schéma de la base de données. Par défaut, le programme d'installation utilise le jeton de sécurité de l'utilisateur qui exécute le programme d'installation pour se connecter à l'instance SQL Server distante et mettre à jour le schéma. Si vous disposez d'autorisations sysadmin SQL Server sur la base de données serveur qui héberge les bases de données du serveur de rapports, la mise à niveau de la base de donnée aboutira. De même, si vous lancez le programme d'installation à partir de l'invite de commandes et spécifiez les arguments RSUPGRADEDATABASEACCOUNT et RSUPGRADEPASSWORD pour un compte qui possède l'autorisation sysadmin pour modifier le schéma sur l'ordinateur distant, la mise à niveau de la base de données s'effectuera sans problème.

En revanche, si vous ne bénéficiez pas d'autorisation sur la base de données de l'ordinateur distant, la connexion sera refusée et un message d'erreur s'affichera, indiquant que :

« Le programme d'installation n'a pas pu mettre à niveau le schéma de base de données de serveur de rapports. Vous devez mettre à jour ce schéma manuellement une fois l'installation terminée. Pour mettre à jour le schéma, exécutez l'outil de configuration de Reporting Services, ouvrez la page Installation de la base de données, resélectionnez la base de données, puis cliquez sur Appliquer. La base de données sera mise à niveau automatiquement.

À ce stade, les fichiers programme du serveur de rapports sont mis à niveau, mais la base de données du serveur de rapports reste au format de la version précédente. Le serveur de rapports n'est pas disponible tant que vous n'avez pas fini le processus de mise à niveau en mettant à niveau la base de données manuellement.

Pour mettre à niveau la base de données manuellement

Si le programme d'installation n'a pas mis à niveau la base de données de serveur de rapports automatiquement, l'installation de votre serveur de rapports n'est que partiellement mise à niveau. Pour mener à terme la mise à niveau, vous devez mettre à niveau la base de données de serveur de rapports manuellement en exécutant l'outil de configuration de Reporting Services une fois l'installation terminée.

  1. Exécutez l'outil de configuration de Reporting Services et connectez-vous au serveur de rapports que vous venez de mettre à niveau. Pour plus d'informations sur la manière de démarrer l'outil et de se connecter à un serveur, consultez Procédure : démarrer la configuration de Reporting Services.

  2. Ouvrez la page Installation de la base de données, puis cliquez sur Se connecter pour vous connecter à l'instance SQL Server hébergeant la base de données du serveur de rapports.

  3. Sélectionnez la base de données de serveur de rapports à mettre à niveau.

  4. Cliquez sur Appliquer pour mettre à jour le schéma de base de données.

Le serveur de rapports est disponible une fois ces étapes effectuées.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Concepts

Création d'une base de données de serveur de rapports
Considérations sur la mise à niveau de Reporting Services
Procédure : migrer une installation Reporting Services


Mise à niveau de rapports

Mise à niveau de rapports |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Reporting Services >

SQL Server 2008 présente les modifications apportées au langage RDL (Report Definition Language), au modèle objet de rapport et au modèle objet de rendu qui affecte les rapports créés dans les versions antérieures du logiciel. Lorsque vous mettez à niveau une installation SQL Server 2005 Reporting Services vers une installation SQL Server 2008 Reporting Services, les rapports et les captures instantanées existants téléchargés sur un serveur de rapports sont mis à niveau automatiquement avec le nouveau schéma la première fois où ils sont traités. Si un rapport ne peut pas être mis à niveau automatiquement, le rapport est traité à l'aide du mode de compatibilité ascendante.

Les fichiers de définition de rapport (.rdl) existants sont automatiquement mis à niveau lorsque vous les ouvrez dans le Concepteur de rapports de Business Intelligence Development Studio.

Remarque :
Pour plus d'informations sur les nouvelles fonctionnalités RDL, telles que la région de données Tablix ou le composant Chart modifié, consultez Nouveautés (Reporting Services).

Après la mise à niveau d'un rapport, vous pouvez noter la présence d'erreurs, d'avertissements et de messages. Cette présence est liée aux améliorations apportées au modèle objet de rapport interne et aux composants de traitement. En effet, des messages apparaissent lors de la détection de problèmes sous-jacents dans le rapport. Pour plus d'informations, consultez Compatibilité descendante de Reporting Services.

Versions prises en charge par la mise à niveau

Les rapports créés dans une version précédente de Reporting Services peuvent être mis à niveau. Les versions concernées sont les suivantes :

  • SQL Server 2000

  • SQL Server 2000 avec Service Pack 1

  • SQL Server 2000 avec Service Pack 2

  • SQL Server 2005

  • SQL Server 2005 avec Service Pack 1

  • SQL Server 2005 avec Service Pack 2

Fichiers de définition de rapport (.rdl) et Concepteur de rapports

Un fichier de définition de rapport comprend une référence à l'espace de noms RDL qui indique la version du schéma de définition de rapport utilisé pour valider le fichier rdl.

Lorsque vous ouvrez un fichier .rdl dans le Concepteur de rapports de Business Intelligence Development Studio, si le rapport a été créé pour un espace de noms antérieur, le Concepteur de rapports crée automatiquement un fichier de sauvegarde et met à niveau le rapport d'après l'espace de noms actuel. Si vous enregistrez la définition de rapport mise à niveau, vous enregistrez le fichier .rdl converti. Aussitôt le fichier enregistré, vous ne pouvez plus l'ouvrir dans les versions antérieures du Concepteur de rapports. Il s'agit de la seule façon dont vous pouvez mettre à niveau un fichier de définition de rapport.

Vous pouvez télécharger un fichier .rdl créé dans une version antérieure de Reporting Services sur un serveur de rapports SQL Server 2008 et il est automatiquement mis à niveau lors de la première utilisation. Le serveur de rapports stocke le fichier de définition de rapport dans le format d'origine. Le rapport est automatiquement mis à niveau la première fois où il est affiché, mais le fichier de définition de rapport stocké demeure inchangé.

Remarque :
Vous ne pouvez pas publier ou télécharger un rapport avec l'espace de noms de définition de rapport SQL Server 2008 sur un serveur de rapports SQL Server 2000 ou SQL Server 2005.

Pour identifier le schéma RDL actuel d'un rapport, d'un serveur de rapports ou du Concepteur de rapports, consultez Procédure : identifier la version du schéma d'un rapport.

Rapports publiés et captures instantanées de rapport

Lors de la première utilisation, le serveur de rapports essaie de mettre à niveau les rapports publiés et les captures instantanées de rapport existants vers le nouveau schéma de définition de rapport, en ne requérant aucune action spécifique de votre part. Lorsqu'un utilisateur affiche un rapport ou une capture instantanée de rapport, ou lorsque le serveur de rapports traite un abonnement, la mise à niveau s'effectue. La définition de rapport n'est pas remplacée, mais continue à être stocké sur le serveur de rapports SQL Server 2008 dans son schéma d'origine. Si un rapport ne peut pas être mis à niveau, le rapport s'exécute en mode compatibilité descendante.

Mode compatibilité descendante

Un rapport mis à niveau avec succès est traité par le processeur de rapports SQL Server 2008 Reporting Services. Un rapport qui ne peut pas être mis à niveau est traité par le processeur de rapports SQL Server 2005 Reporting Services en mode compatibilité descendante. Un rapport ne peut pas être traité par les deux processeurs de rapports.

Lors de la première utilisation, un rapport est mis à niveau avec succès ou marqué pour la compatibilité descendante.

Seul le processeur de rapports SQL Server 2008 Reporting Services prend en charge les nouvelles fonctionnalités, telles que la pagination à la demande, les régions de données Tablix et Jauge, et les régions des données de graphique améliorées. Si un rapport ne peut pas être mis à niveau, vous pouvez toujours consulter le rapport rendu, mais les nouvelles fonctionnalités ne sont pas disponibles. Pour tirer parti des nouvelles fonctionnalités, un rapport doit être mis à niveau avec succès.

Mise à niveau d'un rapport avec les sous-rapports

Quand un rapport contient des sous-rapports, l'un des quatre états suivants peut se produire pendant la mise à niveau :

  • Le rapport principal et tous les sous-rapports peuvent être mis à niveau avec succès. Ils sont traités par le processeur de rapports SQL Server 2008 Reporting Services.

  • Le rapport principal et tous les sous-états ne peuvent pas être mis à niveau. Ils sont traités par le processeur de rapports SQL Server 2005 Reporting Services.

  • Le rapport principal peut être mis à niveau, mais un ou plusieurs sous-rapports ne peuvent pas être mis à niveau. Le rapport principal est traité par le processeur de rapports SQL Server 2008 Reporting Services, mais le rapport rendu affiche le message « Erreur : le sous-rapport n'a pas pu être traité » à l'emplacement où le sous-rapport qui n'a pas pu être mis à niveau apparaîtrait.

  • Le rapport principal ne peut pas être mis à niveau, mais un ou plusieurs sous-rapports peuvent l'être. Le rapport principal est traité par le processeur de rapports SQL Server 2008 Reporting Services, mais le rapport rendu affiche le message « Erreur : le sous-rapport n'a pas pu être traité » à l'emplacement où le sous-rapport apparaîtrait.

Si le précédent message d'erreur apparaît, vous devez modifier la définition du rapport principal ou du sous-rapport afin que tous les rapports puissent être traités par la même version du processeur de rapports.

Les rapports d'extraction n'ont pas cette limitation parce qu'ils sont traités en tant que rapports indépendants.

Mise à niveau d'un rapport avec les éléments de rapport personnalisés

Les rapports SQL Server 2005 Reporting Services peuvent contenir les éléments de rapport personnalisés proposés par les fournisseurs de logiciels tiers et installés par l'administrateur système sur l'ordinateur de création de rapports et le serveur de rapports. Les rapports qui contiennent des éléments de rapport personnalisés peuvent être mis à niveau de différentes façons :

  • Un serveur de rapports SQL Server 2005 Reporting Services est mis à niveau vers un serveur de rapports SQL Server 2008 Reporting Services. Les rapports publiés sur le serveur de rapports sont automatiquement mis à niveau lors de la première utilisation.

  • Un serveur de rapports SQL Server 2005 Reporting Services est téléchargé sur un serveur de rapports SQL Server 2008 Reporting Services. Le rapport est automatiquement mis à niveau lors de la première utilisation.

  • Un serveur de rapports SQL Server 2005 Reporting Services est ouvert dans le Concepteur de rapports de Business Intelligence Development Studio. Une copie de sauvegarde du rapport original est créée. L'un des deux cas suivants se produit :

    1. Tous les éléments de rapport personnalisés du rapport n'ont pas de fonctionnalités non prises en charge. Les éléments de rapport personnalisés sont convertis en éléments de rapport dans le nouveau schéma de définition de rapport, de telle sorte que la totalité du rapport soit mise à niveau. Si vous enregistrez le fichier, il est enregistré dans l'espace de noms RDL courant.

    2. Un ou plusieurs éléments de rapport personnalisés du rapport ont des fonctionnalités non prises en charge. Une boîte de dialogue invite l'utilisateur à convertir les éléments de rapport personnalisés ou à les laisser inchangés.

    Pour plus d'informations, consultez Ouverture d'un rapport dans le Concepteur de rapports plus bas dans cette rubrique.

Pour plus d'informations sur l'identification de l'espace de noms RDL en cours d'un serveur de rapports, BI Development Studio ou un rapport, consultez Procédure : identifier la version du schéma d'un rapport.

Mise à niveau des rapports sur un serveur de rapports

La première fois où un rapport SQL Server 2005 Reporting Services s'exécute sur un serveur de rapports mis à niveau vers un serveur de rapports SQL Server 2008 Reporting Services, le rapport est automatiquement mis à niveau vers l'espace de noms de définition de rapport en cours et pris en charge par le serveur de rapports. Le rapport aurait pu exister sur le serveur de rapports avant la mise à niveau, être téléchargé via le Gestionnaire de rapports ou publié sur le serveur de rapports à partir du Concepteur de rapports de SQL Server 2005 BI Development Studio.

Le tableau suivant répertorie l'action de mise à niveau effectuée par le serveur de rapports pour les types spécifiques d'éléments de rapport personnalisés d'un rapport.

Type CRI | Action de mise à niveau du serveur de rapports
Éléments de rapport personnalisés tiers | Mise à niveau non effectuée. Traitement par le processeur de rapports SQL Server 2005 Reporting Services.
Éléments de rapport personnalisés Dundas 2005 Chart sans fonctionnalités non prises en charge | Mise à niveau vers le schéma RDL le plus récent. Tous les éléments de rapport personnalisés Dundas 2005 Chart sont convertis en régions de données graphiques de SQL Server 2008 Reporting Services. Traitement par le processeur de rapports SQL Server 2008 Reporting Services.
Éléments de rapport personnalisés Dundas 2005 Gauge sans fonctionnalités non prises en charge | Mise à niveau vers le schéma RDL le plus récent. Tous les éléments de rapport personnalisés Gauge Dundas 2005 sont convertis en régions de données de la jauge SQL Server 2008 Reporting Services. Traitement par le processeur de rapports SQL Server 2008 Reporting Services.
Éléments de rapport personnalisés Dundas 2005 Chart avec fonctionnalités non prises en charge | Mise à niveau non effectuée. Traitement par le processeur de rapports SQL Server 2005 Reporting Services.
Éléments de rapport personnalisés Dundas 2005 Gauge avec fonctionnalités non prises en charge | Mise à niveau non effectuée. Traitement par le processeur de rapports SQL Server 2005 Reporting Services.

Ouverture d'un rapport avec éléments de rapport personnalisés dans le Concepteur de rapports

Lorsque vous ouvrez un rapport SQL Server 2005 Reporting Services avec éléments de rapport personnalisés dans le Concepteur de rapports de SQL Server 2008 Business Intelligence Development Studio, le rapport est mis à niveau vers le nouveau schéma de définition de rapport. Selon les éléments de rapport personnalisés contenus dans le rapport, l'une des actions suivantes a lieu :

  • Éléments de rapport personnalisés tiers détectés. Si la version du CRI installé sur l'ordinateur de création de rapports n'est pas compatible avec le nouveau schéma RDL, l'aire de conception affiche une zone de texte avec une croix de couleur rouge. Vous devez contacter votre administrateur système pour installer les nouvelles versions des éléments de rapport personnalisés des fournisseurs tiers compatibles avec le nouveau schéma RDL.

  • Éléments de rapport personnalisés Dundas 2005 Chart ou Gauge détectés et toutes les instances contiennent les fonctionnalités prises en charge. Tous les éléments de rapport personnalisés Dundas 2005 Chart et Gauge sont convertis en éléments de rapport Reporting Services Chart et Gauge, que vous voyez sur la Boîte à outils. Ces éléments sont appelés éléments de rapport de la jauge et éléments de rapport graphiques natifs.

  • Les éléments de rapport personnalisés Dundas 2005 Chart ou Gauge sont détectés et une instance possède des fonctionnalités non prises en charge. Les fonctionnalités non prises en charge sont décrites après cette section. Vous pouvez choisir de convertir ou pas tous les éléments de rapport personnalisés en éléments de rapport natifs.

    • Si vous les convertissez, le rapport est mis à niveau vers le nouveau schéma RDL et les éléments de rapport personnalisés Dundas 2005 Chart et Gauge sont convertis en éléments de rapport Chart et Gauge natifs correspondants, mais les fonctionnalités non prises en charge sont supprimées. Dans le rapport rendu, vous pouvez voir les différences d'affichage des éléments de rapport personnalisés.

    • Si vous choisissez de ne les pas convertir, le rapport est mis à niveau vers le nouveau schéma RDL, mais les éléments de rapport personnalisés sont traités comme éléments de rapport personnalisés tiers. Vous devez travailler avec l'administrateur système et les fournisseurs tiers pour installer les nouveaux éléments de rapport personnalisés compatibles avec le nouveau schéma de rapport. Si les nouveaux éléments de rapport personnalisés ne sont pas disponibles, le rapport affiche une zone de texte avec une croix rouge dans le Concepteur de rapports.

L'enregistrement d'un rapport après qu'il a été mis à niveau dans l'environnement de création de rapports est la seule méthode pour mettre à niveau un rapport existant vers le nouveau schéma de définition de rapport.

Fonctionnalités des éléments de rapport personnalisées Dundas 2005 Chart non prises en charge

Les fonctionnalités des éléments de rapport personnalisées Dundas 2005 Chart non prises en charge sont les suivantes :

  • Annotations.

  • Éléments de légende personnalisés.

  • Attributs personnalisés avec les noms suivants :

    • CUSTOM_CODE_CS

    • Code personnalisé :

    • Assembly compilé.

      Par exemple, si votre fichier .rdl contient la section suivante, vous devrez la supprimer avant de procéder à la mise à niveau :

      Copier le code
      <CustomProperty>
 <Name>CUSTOM_CODE_CS</Name>
 <Value>dXNpWERwegfdfgiobxxl3bmc… </Value>
</CustomProperty>

Fonctionnalités des éléments de rapport personnalisées Dundas 2005 Gauge non prises en charge

Les fonctionnalités des éléments de rapport personnalisées Dundas 2005 Gauge non prises en charge sont les suivantes :

  • Indicateurs numériques.

  • Indicateur d'état.

  • Images personnalisées.

Voir aussi

Concepts

Considérations sur la mise à niveau de Reporting Services
Dernières modifications de SQL Server 2008 Reporting Services
Modifications du fonctionnement de SQL Server Reporting Services
Fonctionnalités supprimées dans SQL Server Reporting Services
Mise à niveau d'une base de données du serveur de rapports

Autres ressources

Boîte de dialogue de conversion des éléments de rapport personnalisés
Custom Report Items
Limitation des menaces et des risques de vulnérabilité (Reporting Services)


Considérations sur la mise à niveau de Data Transformation Services

Considérations sur la mise à niveau de Data Transformation Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Si SQL Server 2000 Data Transformation Services (DTS) est installé sur votre ordinateur, vous pouvez effectuer une mise à niveau vers SQL Server 2008 Integration Services sans conflit logiciel. Il n'y a pas de conflit logiciel car Integration Services est un produit complètement nouveau et non une mise à niveau de version de Data Transformation Services.

Remarque :
Si vous souhaitez effectuer une mise à niveau de SQL Server 2005 Integration Services vers SQL Server 2008 Integration Services, consultez Considérations sur la mise à niveau de SQL Server Integration Services.

Avant d'effectuer la mise à niveau des services DTS

Il est recommandé, avant de mettre à niveau Data Transformation Services vers Integration Services, de consulter la rubrique Prise en charge de DTS dans SQL Server 2008.

Nous recommandons également d'installer et d'exécuter le Conseiller de mise à niveau avant d'effectuer une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Mise à niveau des services DTS

Vous pouvez mettre à niveau une instance existante de SQL Server 2000 en appliquant l'une des méthodes suivantes :

  • Exécutez le programme d'installation de SQL Server 2008 et sélectionnez l'option Mise à niveau de SQL Server 2000 ou SQL Server 2005.

  • Exécutez setup.exe à l'invite de commandes et spécifiez l'option /ACTION=upgrade. Pour plus d'informations, consultez la section « Scripts d'installation de Integration Services » dans Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Il n'est pas possible d'utiliser le programme d'installation de SQL Server 2008 pour effectuer une mise à niveau directement à partir de SQL Server 6.5 ou 7.0 vers SQL Server 2008.

Lorsque vous effectuez une mise à niveau, vous pouvez mettre à niveau les services DTS et le Moteur de base de données, ou uniquement le Moteur de base de données. Si vous mettez à niveau uniquement les services DTS ou uniquement le Moteur de base de données, il existe certaines limitations :

  • Si vous mettez à niveau uniquement les services DTS, SQL Server 2008 Integration Services est complètement fonctionnel. Toutefois, Integration Services sera uniquement en mesure de stocker des packages dans le système de fichiers, à moins qu'une instance du Moteur de base de données SQL Server 2008 ne soit disponible sur un autre ordinateur. Si une instance du Moteur de base de données SQL Server 2008 est disponible, Integration Services sera en mesure de stocker des packages dans cette instance.

  • Si vous mettez à niveau uniquement le Moteur de base de données, les services DTS restent fonctionnels. Toutefois, vous n'aurez pas la fonctionnalité de Integration Services.

Mise à niveau de Data Transformation Services et du moteur de base de données vers SQL Server 2008

Cette section décrit les conséquences liées à l'exécution d'une mise à niveau qui obéit aux critères suivants :

  • Vous mettez à niveau les services DTS et une instance du Moteur de base de données vers SQL Server 2008.

  • Les services DTS et l'instance du Moteur de base de données à mettre à niveau se trouvent tous deux sur le même ordinateur.

Ce que fait le processus de mise à niveau

Le processus de mise à niveau effectue les tâches suivantes :

  • Mise à niveau de l'instance du Moteur de base de données vers SQL Server 2008.

  • Installation de SQL Server 2008 Integration Services.

  • Installation de la prise en charge de l'exécution mise à jour pour les packages DTS. Cette prise en charge inclut l'exécution DTS et l'énumération de package DTS dans SQL Server Management Studio. Les packages DTS peuvent continuer de s'exécuter avec les packages Integration Services sur le même ordinateur. Pour plus d'informations, consultez Procédure : installer la prise en charge des packages DTS.

  • Conservation des packages DTS existants intacts dans les tables système DTS existantes dans la base de données msdb.

Ce que ne fait pas le processus de mise à niveau

Le processus de mise à niveau n'effectue pas les tâches suivantes :

  • Il n'effectue pas la migration des packages DTS vers le format utilisé par les packages Integration Services. Après la mise à niveau, vous pouvez éventuellement utiliser l'Assistant Migration de package DTS pour migrer les packages DTS vers le format Integration Services. Au cours de la migration, l'Assistant copie les packages DTS, puis les recrée au format Integration Services. Les packages sources sont conservés intacts et ne sont pas modifiés.

    Lorsque vous installez Integration Services, l'Assistant Migration de package DTS est également installé.

    Remarque :
    L'Assistant Migration de package DTS est disponible dans les éditions Standard, Enterprise et Developer de SQL Server.

    Pour plus d'informations, consultez les rubriques suivantes :

    • Migration des packages DTS

    • Procédure : migrer des packages DTS (Data Transformation Services) vers Integration Services

    • Problèmes connus liés à la migration des packages DTS

  • N'installe pas la prise en charge facultative au moment du design, au moment de l'exécution ou de gestion pour les packages DTS. Pour plus d'informations, consultez Procédure : installer la prise en charge des packages DTS.

Ce que vous pouvez faire après la mise à niveau

Une fois la mise à niveau terminée, vous pouvez accomplir la tâche suivante :

  • Installer la prise en charge facultative au moment de l'exécution et de gestion pour DTS. Pour plus d'informations, consultez Procédure : installer la prise en charge des packages DTS.

Après avoir installé la prise en charge facultative au moment de l'exécution pour DTS, vous pouvez accomplir les tâches suivantes :

  • Pour afficher les packages DTS sous le nœud Management\Legacy\Data Transformation Services dans SQL Server Management Studio, connectez-vous à l'instance mise à niveau du Moteur de base de données. (Lorsque vous vous connectez au service Integration Services, vous ne pouvez afficher que les packages Integration Services.)

  • Pour exécuter des packages DTS dans un package Integration Services, utilisez la tâche d'exécution de package DTS 2000. Pour plus d'informations, consultez Tâche d'exécution de package DTS 2000.

  • Pour exécuter des packages DTS à l'invite de commandes, faites appel à l'utilitaire dtsrun.exe.

  • Pour exécuter des packages DTS à partir de travaux de l'agent SQL Server, appelez l'utilitaire dtsrun.exe depuis une étape de travail.

Pour plus d'informations sur la façon d'exécuter des packages, consultez Exécution de packages DTS (Data Transformation Services).

Voir aussi

Concepts

Prise en charge de DTS dans SQL Server 2008

Autres ressources

Interopérabilité et coexistence (Integration Services)


Rubriques de procédures sur la mise à niveau ou la migration de DTS (Data Transformation Services)

Rubriques de procédures sur la mise à niveau ou la migration de DTS (Data Transformation Services) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services >

Cette section contient les procédures courantes suivantes qui décrivent comment effectuer une mise à niveau de Microsoft SQL Server 2000 (Data Transformation Services) (DTS) vers SQL Server Integration Services :

  • Procédure : effectuer une mise à niveau de DTS (Data Transformation Services) vers Integration Services

Pour plus d'informations sur l'installation de Integration Services, consultez Considérations sur l'installation de SQL Server Integration Services.

Pour plus d'informations sur la façon de garantir le support pour DTS lorsque vous procédez à une mise à niveau vers Integration Services, consultez Procédure : installer la prise en charge des packages DTS.

Voir aussi

Concepts

Prise en charge de DTS dans SQL Server 2008

Autres ressources

Migration des packages DTS


Procédure : effectuer une mise à niveau de DTS (Data Transformation Services) vers Integration Services

Procédure : effectuer une mise à niveau de DTS (Data Transformation Services) vers Integration Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Rubriques de procédures sur la mise à niveau ou la migration de DTS (Data Transformation Services) >

La procédure suivante décrit comment utiliser le programme d'installation pour mettre à niveau une installation de SQL Server 2000 DTS (Data Transformation Services) vers Integration Services. Pour plus d'informations, consultez Considérations sur la mise à niveau de Data Transformation Services.

SQL Server 2008 n'installe pas la prise en charge au moment de l'exécution des packages DTS. Vous devez installer cette prise en charge au moment de l'exécution avant d'exécuter les packages DTS. Pour plus d'informations sur la manière d'installer la prise en charge des DTS, consultez Procédure : installer la prise en charge des packages DTS. Pour plus d'informations sur la prise en charge des DTS dans SQL Server 2008, consultez Prise en charge de DTS dans SQL Server 2008.

Après la mise à niveau, vous pouvez éventuellement utiliser l'Assistant Migration de package DTS pour migrer les packages DTS vers le format Integration Services. Au cours de la migration, l'Assistant copie les packages DTS, puis les recrée au format Integration Services. Les packages sources sont conservés intacts et ne sont pas modifiés. Pour plus d'informations, consultez Migration des packages DTS.

Remarque :
L'Assistant Migration de package DTS est disponible dans les éditions suivantes de SQL Server : Standard, Enterprise et Developer.

Pour plus d'informations sur l'exécution de la mise à niveau, consultez Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation).

Pour effectuer une mise à niveau de Data Transformation Services (DTS) vers Integration Services

  • Exécutez le programme d'installation de SQL Server 2008, puis sélectionnez Mise à niveau de SQL Server 2000 ou SQL Server 2005.

    - ou -

  • À l'invite de commande, exécutez setup.exe et spécifiez l'option /ACTION=upgrade.

    Pour plus d'informations sur l'installation à l'invite de commandes, consultez la section, « Scripts d'installation pour Integration Services », dans Procédure : installer SQL Server 2008 à partir de l'invite de commandes.

Voir aussi

Tâches

Procédure : installer la prise en charge des packages DTS

Concepts

Prise en charge de DTS dans SQL Server 2008


Migration des packages DTS

Migration des packages DTS |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services >

Integration Services fournit plusieurs options pour conserver les solutions créées avec les outils DTS et le modèle d'objet SQL Server 2000. Vous pouvez migrer les packages DTS vers le format Integration Services, continuer à les exécuter en utilisant le runtime DTS ou les intégrer aux solutions Integration Services en utilisant la tâche d'exécution de package DTS 2000.

Remarque :
Pour plus d'informations sur la mise à niveau des packages créés dans une version antérieure d'Integration Services, consultez Mise à niveau de packages Integration Services.

Lorsque vous migrez les packages DTS vers le format Integration Services, la structure du package migré et le degré d'aboutissement de la migration dépendent du contenu du package de départ. Les résultats de la migration d'un package peuvent être les suivants :

  • Les packages peuvent être migrés avec succès et intégralement, car ils ne contiennent que des tâches et n'utilisent que les fonctionnalités qui correspondent aux tâches et aux fonctionnalités Integration Services.

  • Les packages contiennent les tâches et les fonctionnalités DTS qui ne peuvent pas être migrées directement vers les tâches et les fonctionnalités Integration Services, mais la fonctionnalité du package est préservée grâce à l'utilisation de packages DTS encapsulés.

  • Dans certains cas, comme lorsque le nom du package contient des caractères non valides (/ \ : [ ] . =), ou lorsque le package contient des objets non enregistrés, l'Assistant Migration de package ne peut pas effectuer la migration avant la résolution de ces problèmes.

Remarque :
L'Assistant Migration de package conserve les packages DTS intacts et inchangés.

Si toutes les tâches du package peuvent être mappées à de nouvelles tâches dans Integration Services, la structure du package migré est très proche de la structure du package DTS. Inversement, si les tâches ne correspondent pas directement aux tâches Integration Services, la migration modifie la structure du package. Chaque tâche non migrée conserve son format DTS et est encapsulée dans une tâche d'exécution DTS 2000. Les tâches personnalisées dans les packages sont également migrées de cette façon. Pour plus d'informations, consultez Migration de tâches.

D'autres éléments de package tels que les contraintes de précédence, les connexions et les variables sont migrées vers l'élément équivalent dans Integration Services. Pour plus d'informations, consultez Migration des contraintes de précédence, Migration des connexions et Migration de variables.

Les mots de passe des packages ne sont pas migrés. Toutefois, Integration Services prend en charge les mots de passe de package DTS dans les packages DTS et dans la tâche d'exécution de package DTS 2000. Une tâche d'exécution de package DTS 2000 dans un package Integration Services peut passer le mot de passe du package à un package DTS. Pour plus d'informations, consultez Migration des mots de passe.

La tâche de script ActiveX dans Integration Services est souvent capable d'exécuter le code de script qui est migré à partir des scripts ActiveX dans des packages DTS sans modification supplémentaire. Toutefois, les références aux objets de package DTS ne sont pas prises en charge. Pour plus d'informations, consultez Migration de scripts.

Les annotations de texte entrées dans le Concepteur DTS, ainsi que les paramètres de journalisation de package et de gestion des erreurs, ne sont pas migrés.

Une fois les packages migrés, ils doivent être ouverts pour vérifier la présence éventuelle de problèmes et notamment les échecs de validation. Par exemple, certains packages dépendent de tâches précédentes dans le même package pour créer ou préparer les sources de données ou les destinations de données et, si ces objets sont introuvables, la validation peut échouer. Pour résoudre un problème de validation de ce type, affectez à la propriété DelayValidation la valeur true dans la tâche ou dans un autre objet conteneur, ou bien affectez à la propriété ValidateExternalMetadata la valeur false dans le composant de flux de données concerné.

Remarque :
Après avoir migré des packages à partir de Management Studio, connectez-vous à l'instance locale de Integration Services dans l'Explorateur d'objets pour observer les packages migrés. Si vous avez sélectionné SQL Server comme destination, les packages migrés sont visibles sous le nœud MSDB. Si vous avez sélectionné un dossier de système de fichiers comme destination, cliquez avec le bouton droit sur le nœud Système de fichiers, puis sélectionnez Importer un package pour afficher les packages migrés. Une fois que vous avez effectué la migration des packages à partir de BI Development Studio, les packages migrés sont enregistrés dans le dossier de système de fichiers que vous avez spécifié, puis ajoutés au projet ouvert sous le nœud Packages SSIS.

Il est impossible d'ouvrir ou de modifier directement les packages DTS dans BI Development Studio.

Pour obtenir des informations générales sur la prise en charge de DTS dans Integration Services, consultez Prise en charge de DTS dans SQL Server 2008.

Dans cette section

Utilisation de l'Assistant Migration de package DTS

Décrit le processus de migration que l'Assistant Migration de package fournit.

Problèmes connus liés à la migration des packages DTS

Donne la liste des problèmes connus liés à la migration des packages que l'Assistant Migration de package ou que le Conseiller de mise à niveau peut identifier.

Migration de tâches

Décrit comment l'Assistant Migration de package migre les tâches et explique les étapes que vous pouvez suivre après la migration pour réparer des tâches ou améliorer le fonctionnement de certaines tâches.

Migration des contraintes de précédence

Décrit comment l'Assistant Migration de package migre les contraintes de précédence et explique les étapes que vous pouvez suivre après la migration pour améliorer le fonctionnement des contraintes de précédence.

Migration de variables

Décrit comment l'Assistant Migration de package migre les variables et explique les étapes que vous pouvez suivre après la migration pour réparer ou améliorer le fonctionnement des variables.

Migration des connexions

Décrit comment l'Assistant Migration de package migre les connexions et explique les étapes que vous pouvez suivre après la migration pour modifier les propriétés des connexions.

Migration des mots de passe

Décrit comment l'Assistant Migration de package migre les mots de passe et présente d'autres étapes que vous pouvez suivre après la migration pour améliorer la sécurité.

Migration de scripts

Décrit comment l'Assistant Migration de package migre les scripts ActiveX.

Voir aussi

Tâches

Procédure : installer la prise en charge des packages DTS

Concepts

Compatibilité descendante d'Integration Services

Autres ressources

SQL Server Integration Services


Utilisation de l'Assistant Migration de package DTS

Utilisation de l'Assistant Migration de package DTS |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

Integration Services fournit l'Assistant Migration de package DTS pour la migration des packages DTS (Data Transformation Services) SQL Server 2000 créés avec les outils et le modèle objet DTS.

Remarque :
L'Assistant Migration de package est disponible dans les éditions Standard, Enterprise et Developer de SQL Server.

Remarque :
Pour plus d'informations sur la mise à niveau des packages créés dans une version antérieure d'Integration Services, consultez Mise à niveau de packages Integration Services.

Remarque :
Le Conseiller de mise à niveau ne peut pas analyser et l'Assistant Migration de package ne peut pas migrer les packages DTS enregistrés dans la base de données msdb d'une instance de SQL Server 7.0. Cependant, le Conseiller de mise à niveau peut analyser et l'Assistant Migration de package peut migrer les packages DTS SQL Server 7.0 enregistrés en tant que fichiers de stockage structurés ou dans la base de données msdb d'une instance de SQL Server 7.0 mise à niveau vers SQL Server 2005.

Certains packages ne peuvent pas être migrés en totalité. Par exemple, certaines tâches DTS ne correspondent pas à des tâches Integration Services, les tâches personnalisées ne peuvent pas être migrées et certains scripts dans les tâches ActiveX ou dans les transformations de données ne peuvent pas être migrés. Pour plus d'informations, consultez Migration de tâches et Problèmes connus liés à la migration des packages DTS.

Les packages au format DTS peuvent être utilisés dans les solutions Integration Services et peuvent continuer à fonctionner en tant que packages DTS autonomes.

De nombreux packages DTS sont protégés par des mots de passe. Si vous migrez ces packages, l'Assistant Migration de package vous invite à indiquer leurs mots de passe. Il est impossible de migrer un package protégé par mot de passe sans fournir le mot de passe correct.

SQL Server n'installe pas la prise en charge de Meta Data Services. L'Assistant Migration de package prend en charge les packages Meta Data Services (Référentiel) uniquement si SQL Server 2000, les outils SQL Server 2000 ou les fichiers redistribuables du référentiel sont installés sur l'ordinateur local. Quand les fichiers de référentiel sont présents, l'Assistant Migration de package peut migrer les packages DTS qui ont été enregistrés dans Meta Data Services. Si les fichiers de la base de données de référentiel ne sont pas présents, l'Assistant Migration de package peut migrer uniquement les packages DTS qui ont été enregistrés dans SQL Server ou dans des fichiers de stockage structuré.

Démarrage de l'Assistant Migration de package

Vous pouvez démarrer l'Assistant Migration de package à partir de trois emplacements.

  • Depuis SQL Server Management Studio. Connectez-vous à une instance du SQL Server Moteur de base de données, cliquez avec le bouton droit sur le nœud Data Transformation Services dans l'Explorateur d'objets sous Gestion\Existant et sélectionnez Assistant Migration.

  • À partir de Business Intelligence Development Studio. Créez ou ouvrez un projet Integration Services, cliquez avec le bouton droit sur le nœud Packages SSIS dans l'Explorateur de solutions et choisissez Migrer un package DTS 2000.

  • À partir d'une invite de commandes. Exécutez DTSMigrationWizard.exe à partir du dossier C:\Program Files\Microsoft SQL Server\100\DTS\Binn.

Sélection de la source du package

L'Assistant Migration de package peut migrer les packages DTS qui ont été enregistrés dans une base de données SQL Server msdb, dans des fichiers de stockage structuré ou dans Meta Data Services. Les packages qui ont été enregistrés dans des fichiers Visual Basic ne peuvent pas être migrés.

Important :
SQL Server n'installe pas la prise en charge de Meta Data Services. L'Assistant Migration de package ne peut accéder aux packages DTS enregistrés dans Meta Data Services que si SQL Server 2000, les outils SQL Server 2000 ou les fichiers redistribuables de la base de données de référentiel sont installés sur l'ordinateur.

Si un package est situé dans une base de données msdb ou dans Meta Data Services, l'utilisateur fournit un nom de serveur et l'Assistant Migration de package authentifie l'utilisateur en utilisant l'Authentification Windows ou l'Authentification SQL Server.

Si un package se trouve dans un fichier de stockage structuré, vous devez sélectionner le fichier à migrer. Un fichier de stockage structuré peut contenir les définitions de plusieurs packages et peut inclure plusieurs versions d'un même package. Vous pouvez migrer tout ou partie des packages et les versions de package dans le fichier.

Pour plus d'informations, consultez Choisir l'emplacement source (Assistant Migration de package DTS).

Sélection de la destination du package

L'Assistant Migration de package peut migrer des packages vers une base de données msdb dans une instance de SQL Server ou vers un fichier .dtsx. Le fichier .dtsx est une représentation XML de la définition de package enregistrée dans le système de fichiers.

Si la destination est SQL Server, l'utilisateur fournit un nom de serveur et l'Assistant Migration de package authentifie l'utilisateur au moyen de l'Authentification Windows ou de l'Authentification SQL Server.

Pour plus d'informations, consultez Choisir l'emplacement de destination (Assistant Migration de package DTS).

Remarque :
Après avoir migré des packages à partir de Management Studio, connectez-vous à l'instance locale de Integration Services dans l'Explorateur d'objets pour observer les packages migrés. Si vous avez sélectionné SQL Server comme destination, les packages migrés sont visibles sous le nœud MSDB. Si vous avez sélectionné un dossier de système de fichiers comme destination, cliquez avec le bouton droit sur le nœud Système de fichiers et sélectionnez Importer un package pour afficher les packages migrés. Les packages migrés depuis BI Development Studio sont enregistrés dans le dossier de système de fichiers que vous avez spécifié, puis ajoutés au projet ouvert sous le nœud Packages SSIS.

Il est impossible d'ouvrir ou de modifier les packages DTS dans BI Development Studio.

Sélection des packages à migrer

Une fois la source et la destination spécifiées, l'Assistant Migration de package affiche la liste des packages disponibles dans la base de données msdb, dans Meta Data Services ou dans le fichier de stockage structuré spécifié. Vous pouvez sélectionner les packages à migrer et mettre à jour les noms par défaut que l'Assistant Migration de package fournit pour les packages. Vous pouvez également mettre à jour les noms de package dans Business Intelligence Development Studio ou SQL Server Management Studio une fois les packages migrés.

Pour plus d'informations, consultez Liste des packages (Assistant Migration de package DTS).

Mots de passe des packages

Les packages développés avec les versions antérieures des outils SQL Server peuvent être protégés par des mots de passe. Vous devez fournir les mots de passe corrects pour que l'Assistant puisse accéder aux définitions de package pour effectuer leur migration. Si plusieurs packages partagent un même mot de passe, il n'est nécessaire d'indiquer le mot de passe qu'une seule fois. L'Assistant Migration de package ne peut pas continuer tant que vous n'avez pas fourni tous les mots de passe de tous les packages protégés par mot de passe. Si aucun package n'est protégé par mot de passe, l'Assistant passe cette étape.

Enregistrement des erreurs de migration

Vous pouvez demander à l'Assistant Migration de package d'enregistrer les erreurs qu'il rencontre au cours de la migration.

Pour plus d'informations, consultez Spécifiez un fichier journal (Assistant Migration de package DTS).

Affichage de la progression de la migration

L'Assistant Migration de package migre les packages sélectionnés un par un. Si l'Assistant ne parvient pas à migrer un package, il permet d'arrêter la migration des packages restants ou d'ignorer le package et de poursuivre la migration en passant au package suivant dans la liste. À chaque fois qu'un package est migré, l'état de la migration est mis à jour.

Pour plus d'informations, consultez Terminer l'Assistant (Assistant Migration de package DTS) et Migration des packages (Assistant Migration de package DTS).

Vérification des packages migrés

Une fois les packages migrés, ils doivent être ouverts dans Business Intelligence Development Studio pour vérifier la présence éventuelle de problèmes et notamment les échecs de validation. Par exemple, certains packages dépendent de tâches précédentes dans le même package pour créer ou préparer les sources de données ou les destinations de données et, si ces objets sont introuvables, la validation peut échouer. Pour résoudre un problème de validation de ce type, affectez à la propriété DelayValidation la valeur true dans la tâche ou dans un autre objet conteneur, ou bien affectez à la propriété ValidateExternalMetadata la valeur false dans le composant de flux de données concerné.

Remarque :
Après avoir migré des packages à partir de Management Studio, connectez-vous à l'instance locale de Integration Services dans l'Explorateur d'objets pour observer les packages migrés. Si vous avez sélectionné SQL Server comme destination, les packages migrés sont visibles sous le nœud MSDB. Si vous avez sélectionné un dossier de système de fichiers comme destination, cliquez avec le bouton droit sur le nœud Système de fichiers, puis sélectionnez Importer un package pour afficher les packages migrés. Une fois que vous avez effectué la migration des packages à partir de BI Development Studio, les packages migrés sont enregistrés dans le dossier de système de fichiers que vous avez spécifié, puis ajoutés au projet ouvert sous le nœud Packages SSIS.

Voir aussi

Tâches

Procédure : installer la prise en charge des packages DTS

Autres ressources

Migration des packages DTS


Problèmes connus liés à la migration des packages DTS

Problèmes connus liés à la migration des packages DTS |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

Cette section résume les problèmes que vous risquez de rencontrer lors de la migration des packages DTS Microsoft SQL Server 2000 vers le format Integration Services en utilisant l'Assistant Migration de package.

L'Assistant Migration de package migre certaines fonctionnalités DTS SQL Server 2000 qui n'ont pas d'équivalent direct dans Integration Services en les encapsulant dans une tâche d'exécution de package DTS 2000. Bien que dans de nombreux cas il soit possible d'exécuter des packages migrés sans rencontrer d'erreurs, vous serez peut-être néanmoins obligé de remplacer la fonctionnalité encapsulée dans la tâche d'exécution de package DTS 2000.

Une fois les packages migrés, ils doivent être ouverts pour vérifier la présence éventuelle de problèmes et notamment les échecs de validation. Par exemple, certains packages dépendent de tâches précédentes dans le même package pour créer ou préparer les sources de données ou les destinations de données, et la validation peut échouer si ces objets sont introuvables. Pour résoudre un problème de validation de ce type, affectez à la propriété DelayValidation la valeur true dans la tâche ou dans un autre objet conteneur, ou bien affectez à la propriété ValidateExternalMetadata la valeur false dans le composant de flux de données concerné.

Pour obtenir des informations générales sur la prise en charge de DTS dans Integration Services, consultez Prise en charge de DTS dans SQL Server 2008.

Problèmes connus détectés par le Conseiller de mise à niveau

La liste suivante présente les problèmes de migration, accompagnés d'une brève description, tels qu'ils sont signalés dans le rapport généré par le Conseiller de mise à niveau SQL Server. L'Assistant de Migration de package et le Conseiller de mise à niveau identifient et signalent les mêmes problèmes potentiels de migration de package.

Problème Description

Reconfiguration des paramètres de transaction après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les paramètres de transaction dans les packages DTS SQL Server 2000. Après la migration, vous devez modifier manuellement le package SSIS résultant pour restaurer les fonctionnalités du précédent package.

Action corrective : Après la migration, recréez les paramètres de transaction souhaités dans le package en définissant les propriétés de transaction appropriées pour le package et ses composants dans Business Intelligence Development Studio. Pour plus d'informations, consultez Incorporation des transactions dans les packages.

Remplacement de la fonction d'un script ActiveX associé à des étapes de package après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les scripts ActiveX associés aux étapes des packages DTS SQL Server 2000. Après la migration, vous devez modifier manuellement le package SSIS obtenu pour restaurer les fonctionnalités du précédent package.

Action corrective : Après la migration, remplacez le script manquant par une nouvelle tâche de script ou d'autres objets Integration Services si nécessaire. Pour plus d'informations, consultez Tâche de script.

Remplacement de la fonctionnalité de la tâche Analysis Services encapsulée dans une tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas la tâche Analysis Services dans les packages DTS SQL Server 2000. Le package migré contiendra une fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, convertissez la tâche d'exécution de package DTS 2000 qui encapsule la tâche Analysis Services en tâche de traitement Integration Services Analysis Services. Pour plus d'informations, consultez Tâche de traitement d'Analysis Services.

Remplacement de la fonctionnalité de la tâche de transformation de données complexe encapsulée dans une tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches de transformation de données complexe dans les packages DTS SQL Server 2000. Le package migré contiendra une fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, réécrivez la tâche de transformation de données complexe en utilisant des sources de flux de données, des transformations et des destinations Integration Services. Pour plus d'informations, consultez Création du flux de données d'un package et Composants des flux de données.

Remplacement de la fonctionnalité d'une tâche personnalisée encapsulée dans une tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches personnalisées dans les packages DTS SQL Server 2000. Le package migré contiendra une fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, recréez la logique de la tâche personnalisée en utilisant une tâche de script, un composant Script ou un composant personnalisé si la fonctionnalité voulue n'est pas disponible dans le composant Integration Services intégré ou dans la combinaison de composants. Pour plus d'informations sur les solutions de programmation, consultez Developer's Guide (Integration Services).

Remplacement de la fonctionnalité de la tâche de requête contrôlée par les données encapsulée dans une tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches de requête contrôlée par les données dans les packages DTS SQL Server 2000. Le package migré contiendra la fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, recréez la fonctionnalité de la tâche de requête contrôlée par les données en utilisant des composants de flux de données Integration Services. Prenez en compte les informations fournies dans les rubriques Transformation de dimension à variation lente, Transformation de fractionnement conditionnel ou Transformation de commande OLE DB lorsque vous remplacez les fonctionnalités des tâches Requête contrôlée par les données.

Remplacement de la fonctionnalité de la tâche de requête de prédiction de l'exploration de données encapsulée dans la tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches de requête de prédiction de l'exploration de données dans les packages DTS SQL Server 2000. Le package migré contiendra la fonctionnalité DTS encapsulée qui devra finalement être remplacée. SQL Server n'installe pas la prise en charge de la tâche de requête de prédiction de l'exploration de données SQL Server 2000. Par conséquent, le package migré ne pourra pas s'exécuter après une mise à niveau en l'absence de SQL Server 2000 Analysis Services.

Action corrective : Après la migration, convertissez la tâche d'exécution DTS 2000 qui encapsule la tâche de requête de prédiction de l'exploration de données en tâche de requête d'exploration de données Integration Services ou en tâche de transformation de requête d'exploration de données. Pour plus d'informations, consultez Tâche de requête d'exploration de données et Transformation de requête d'exploration de données.

Remplacement de la fonctionnalité de la tâche des propriétés dynamiques après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches des propriétés dynamiques dans les packages DTS SQL Server 2000. Après la migration, vous devez modifier manuellement le package SSIS résultant pour restaurer les fonctionnalités du précédent package.

Action corrective : Après la migration, recréez la fonctionnalité de la tâche des propriétés dynamiques en utilisant des fonctionnalités Integration Services telles que des variables, des expressions de propriété et des configurations de package. Pour plus d'informations, consultez Variables Integration Services et Utilisation de variables dans des packages ; Utilisation des expressions de propriété dans des packages ; et Configurations de package.

Remplacement de la fonctionnalité de la tâche d'exécution de package (avec le package Meta Data Services) encapsulée dans la tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches d'exécution de package qui chargent des packages Meta Data Services. Le package migré contiendra la fonctionnalité DTS encapsulée qui devra finalement être remplacée. SQL Server n'installe pas la prise en charge de Meta Data Services SQL Server 2000. Par conséquent, le package migré ne pourra pas s'exécuter après une mise à niveau en l'absence des Outils clients SQL Server 2000.

Action corrective : Après la migration, déplacez le package Meta Data Services vers un stockage SQL Server (dans la base de données msdb) ou vers un fichier de stockage structuré et convertissez la tâche d'exécution de package DTS 2000 qui encapsule la tâche d'exécution de package chargeant un package Meta Data Services en tâche d'exécution de package DTS 2000 chargeant un package à partir de SQL Server ou d'un fichier de stockage structuré. Pour plus d'informations, consultez Enregistrement des packages.

Remplacement de la fonctionnalité de la tâche de services Data Pump encapsulée dans une tâche d'exécution de package DTS 2000 après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas les tâches de services Data Pump dans les packages DTS SQL Server 2000. Le package migré contiendra une fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, recréez la fonctionnalité de la tâche de services Data Pump en utilisant des composants de flux de données Integration Services. Pour plus d'informations, consultez Création du flux de données d'un package et Composants des flux de données.

Remplacer la fonctionnalité de la connexion UDL encapsulée dans la tâche d'exécution de package DTS 2000 après la migration du package

L'Assistant Migration de package Integration Services ne migre pas les tâches qui obtiennent leurs informations de connexion à partir de fichiers Microsoft Data Link (.udl). Le package migré contiendra une fonctionnalité DTS encapsulée qui devra finalement être remplacée.

Action corrective : Après la migration, convertissez la tâche d'exécution de package DTS 2000 qui encapsule la connexion de fichier UDL en une tâche Integration Services équivalente utilisant un gestionnaire de connexions Integration Services. Pour plus d'informations, consultez Gestionnaires de connexions et Création de gestionnaires de connexions.

Réécriture du code d'un script ActiveX qui accède au modèle objet DTS après la migration d'un package

L'Assistant Migration de package Integration Services ne migre pas le code de script ActiveX qui accède au modèle d'objet DTS via la propriété Parent de la collection GlobalVariables dans les packages DTS (Data Transformation Services) SQL Server 2000. Après la migration, vous devez modifier manuellement le package SSIS obtenu pour restaurer les fonctionnalités du précédent package.

Action corrective : Après la migration, modifiez le code du script ou réécrivez la tâche de script ActiveX pour obtenir d'une autre façon les informations requises à partir du package : par exemple en utilisant des variables. Pour plus d'informations, consultez Variables Integration Services et Utilisation de variables dans des packages.

Problèmes connus non détectés par le Conseiller de mise à niveau

Les problèmes suivants ne sont pas détectés ou signalés par l'Assistant Migration de package ou le Conseiller de mise à niveau.

Problème | Description
Suppression et recréation des connexions ODBC après la migration du package | Les connexions ODBC génèrent une erreur si vous tentez de modifier la connexion après la migration. Action corrective : Si vous n'avez pas déjà migré le package, vous pouvez supprimer la connexion ODBC puis la recréer. Ce problème a été résolu dans SQL Server Service Pack 1. Installez le Service Pack 1 ou une version ultérieure pour éviter que ce problème ne se reproduise.

Voir aussi

Concepts

Compatibilité descendante d'Integration Services


Migration de tâches

Migration de tâches |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

De nombreuses tâches DTS (Data Transformation Services) SQL Server 2000 sont mappées directement à des tâches Integration Services et la migration d'un package vers Integration Services entraîne le remplacement de la version SQL Server 2000 d'une tâche par son équivalent Integration Services.

Le tableau suivant présente la liste des mappages directs entre les versions des tâches.

Tâche SQL Server 2000 | Tâche SQL Server 2005
Tâche Script ActiveX | Tâche de script ActiveX
Tâche d'insertion en bloc | Tâche d'insertion en bloc
Tâche Copie d'objets SQL Server | Tâche de transfert d'objets SQL Server
Tâche Prévision d'exploration de données | Tâche de requête d'exploration de données
Tâche d'exécution de package | Tâche d'exécution de package DTS 2000
Tâche d'exécution de processus | Tâche d'exécution de processus
Tâche d'exécution de requêtes SQL | Tache d'exécution de requêtes SQL
Tâche FTP | Tâche FTP
Tâche MSMQ | Tâche MSMQ
Tâche Envoyer un message | Tâche Envoyer un message
Tâches de transfert de bases de données, de transfert de messages d'erreur, de transfert de travaux, de transfert de connexions et de transfert de procédures stockées de master | Tâche de transfert d'objets SQL Server, Tâche de transfert de bases de données, Tâche de transfert de messages d'erreur, Tâche de transfert de travaux, Tâche de transfert de connexions et Tâche de transfert de procédures stockées de master
Remarque :
Les tâches de script ActiveX qui tentent d'accéder au modèle objet du package en utilisant la propriété Parent de la collection GlobalVariables échouent après la migration du package.

Certaines tâches SQL Server 2000 ne sont pas mappées directement aux tâches Integration Services :

  • La tâche Analysis Services (parce que la tâche Integration Services Analysis Services ne fonctionne pas avec une instance SQL Server 2000 de Analysis Services)

  • Tâche Requête contrôlée par les données

  • Tâche des propriétés dynamiques

  • Tâche de transformation de données

Dans SQL Server, certaines de ces tâches sont remplacées par des fonctionnalités qui ne sont pas des tâches. Le tableau suivant présente la liste des mappages entre les tâches SQL Server 2000 et les fonctionnalités SQL Server correspondantes qui ne sont pas des tâches.

Tâche SQL Server 2000 | Fonction SQL Server 2005
Propriétés dynamiques | Configurations et expressions des propriétés Pour plus d'informations, consultez Création de configurations de package.
Transformation de données | Tâche de flux de données et Composants des flux de données.
Requête contrôlée par les données | Prenez en compte les informations fournies dans les rubriques Transformation de dimension à variation lente, Transformation de fractionnement conditionnel et Transformation de commande OLE DB lorsque vous remplacez les fonctionnalités des tâches Requête contrôlée par les données.

Tâches personnalisées

Un package qui contient des tâches personnalisées est migré vers SQL Server selon une procédure particulière. Un package SQL Server 2000 est créé pour chaque tâche personnalisée, et une tâche d'exécution de package DTS 2000 qui appelle le package SQL Server 2000 est ajoutée au package migré. Les nouveaux packages SQL Server 2000, appelés des packages intermédiaires, sont incorporés au package migré et ne sont pas enregistrés séparément. Par exemple, un package SQL Server 2000 contenant trois tâches personnalisées est transformé en package SQL Server qui contient trois tâches d'exécution de package DTS 2000, où chaque tâche pointe vers un package SQL Server 2000 incorporé qui encapsule une tâche personnalisée.

Tâches Data Pump

Trois tâches SQL Server 2000 (Requête contrôlée par les données, Transformation de données et ParallelDataPump) sont basées sur le service DTS Data Pump SQL Server 2000. À l'exception des tâches de transformation de données simples, ces tâches sont migrées de la même façon que les tâches personnalisées. L'Assistant Migration de package crée un nouveau package SQL Server 2000 pour chaque tâche et ajoute une tâche d'exécution de package DTS 2000 pour chaque tâche Data Pump au nouveau package.

Tâche des propriétés dynamiques

Les tâches des propriétés dynamiques ne peuvent pas être migrées vers SQL Server. L'Assistant Migration de package émet un avertissement si vous tentez de migrer un package avec une tâche des propriétés dynamiques. Si vous choisissez de migrer le package, la tâche des propriétés dynamiques est remplacée par une tâche d'espace réservé dans le package migré. La tâche d'espace réservé est une tâche de script qui répertorie les paires propriété/valeur à partir de la tâche des propriétés dynamiques que vous pouvez éventuellement convertir en script dans la tâche de script. Ces informations sont écrites dans la tâche de script sous la forme de commentaires dans le script.

Dans SQL Server, les configurations remplacent et améliorent la fonctionnalité disponible dans la tâche des propriétés dynamiques. Pour plus d'informations, consultez Création de configurations de package.

Voir aussi

Autres ressources

Migration des packages DTS


Migration des contraintes de précédence

Migration des contraintes de précédence |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

Les contraintes de précédence dans un package DTS SQL Server 2000 migrent vers la collection PrecedenceConstraints du nouveau package.

Extension des fonctionnalités des contraintes de précédence

Une fois le package migré, vous pouvez étendre les contraintes de précédence en procédant comme suit :

  • Utilisez une expression avec le (ou à la place du) résultat d'exécution de l'exécutable précédent pour spécifier les conditions d'exécution de la tâche avec contrainte. Pour plus d'informations, consultez Ajout d'expressions aux contraintes de précédence.

  • Combinez plusieurs contraintes de précédence pour spécifier les conditions d'exécution de la tâche avec contrainte. Pour plus d'informations, consultez Application de plusieurs contraintes de précédence.

Voir aussi

Autres ressources

Migration des packages DTS
Contraintes de précédence


Migration de variables

Migration de variables |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

Dans Integration Services, une collection de variables est disponible dans tous les conteneurs : packages, structures de bouclage telles que le conteneur Foreach et le conteneur TaskHost qui encapsule chaque tâche. Lorsqu'un package est migré, les variables globales et les variables des tâches DTS SQL Server 2000 sont toutes migrées vers la collection de variables du package. Par exemple, les variables utilisées par une tâche d'exécution SQL Server 2000 sont ajoutées à la collection de variable du package migré.

Integration Services utilise des espaces de noms pour organiser les variables. Toutes les variables DTS sont migrées vers l'espace de noms User.

Extension des fonctionnalités des variables

Une fois le package migré, vous pouvez ajouter des fonctionnalités aux variables en procédant comme suit :

  • Créez d'autres espaces de noms et organisez les variables par espace de nom.

  • Utilisez des expressions pour affecter des valeurs aux variables.

  • Spécifiez si la mise à jour de la valeur d'une variable doit générer un événement.

Pour plus d'informations, consultez Variables Integration Services et Utilisation de variables dans des packages.

Voir aussi

Autres ressources

Migration des packages DTS


Migration des connexions

Migration des connexions |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

Les connexions dans les packages DTS SQL Server 2000 sont migrées vers SQL Server et converties en gestionnaires de connexions du type de connexion approprié.

Un gestionnaire de connexions est une représentation logique d'une connexion à une source de données. Le gestionnaire de connexions spécifie les attributs de la connexion physique que le moteur d'exécution crée lorsque le package est exécuté. Un package migré peut avoir plusieurs gestionnaires de connexions, tous du même type, mais configurés différemment. Pour plus d'informations, consultez Gestionnaires de connexions.

La seule tâche SQL Server 2000 qui utilise une connexion et qui peut être migrée vers SQL Server sans problème est la tâche d'exécution SQL. Ses connexions sont migrées en tant que gestionnaires de connexions OLE DB ou ODBC. Les propriétés des gestionnaires de connexions existants qui n'étaient pas définies, sont définies avec les valeurs par défaut dans le nouveau gestionnaire de connexions. Pour plus d'informations, consultez Gestionnaire de connexions OLE DB et Gestionnaire de connexions ODBC.

Remarque :
Dans certains cas, la tâche de transformation de données SQL Server 2000 peut être migrée avec ses connexions. La tâche de requête contrôlée par les données et la tâche de services Data Pump sont migrées vers des tâches d'exécution de package DTS 2000. Pour plus d'informations, consultez Migration de tâches et Problèmes connus liés à la migration des packages DTS.

Les connexions qui étaient utilisées dans les tâches SQL Server 2000 mais qui ne peuvent pas être migrées vers SQL Server sont conservées dans les packages SQL Server 2000 intermédiaires créés dans le cadre de la migration. Par exemple, une connexion dans la tâche de transformation de données SQL Server 2000 est conservée dans le package SQL Server 2000 intermédiaire qui encapsule la tâche de transformation de données.

Mise à jour des propriétés des gestionnaires de connexions

Les gestionnaires de connexions contiennent des propriétés qui sont définies avec des valeurs par défaut.

Le tableau suivant décrit ces propriétés.

Propriété | Description
DelayValidation | Valeur qui spécifie si la validation de la connexion est reportée jusqu'à l'exécution du package. L'Assistant Migration de package affecte la valeur False à cette propriété.
Description | Description du gestionnaire de connexions. L'Assistant Migration de package n'affecte aucune valeur à cette propriété.

Voir aussi

Autres ressources

Migration des packages DTS


Migration des mots de passe

Migration des mots de passe |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

SQL Server utilise uniquement des mots de passe pour les packages en rapport avec certaines options des niveaux de protection des packages. Par conséquent, les packages protégés par mot de passe qui sont entièrement migrés de SQL Server 2000 vers SQL Server ne conservent pas leurs mots de passe, bien que vous deviez fournir ces mots de passe au cours de la migration. Pour plus d'informations sur les niveaux de protection des packages dans SQL Server, consultez Définition du niveau de protection des packages.

Remarque :
Les packages protégés par mot de passe ne peuvent pas êtres migrés, sauf si vous fournissez les mots de passe appropriés.

Si le moteur de runtime DTS de SQL Server 2000 est installé, vous pouvez continuer à exécuter des packages SQL Server 2000. Vous pouvez également inclure ces packages dans des solutions de transformation de données SQL Server. SQL Server continue à prendre en charge les mots de passe des packages dans ce scénario. Par exemple, la tâche d'exécution de package DTS 2000 inclut une propriété de mot de passe pour passer un mot de passe à un package SQL Server 2000.

Ajout de fonctions de sécurité aux packages

Une fois un package migré, vous pouvez ajouter les fonctions de sécurité suivantes :

  • Définir le niveau de protection du package pour chiffrer toutes les valeurs de propriété ou uniquement les valeurs critiques lorsque le package est enregistré. Pour plus d'informations, consultez Packages Integration Services.

  • Signer numériquement le package et définir des propriétés pour s'assurer que la signature est contrôlée lorsque le package est chargé. For more information, see Utilisation de signatures numériques avec des packages.

    Important :
    Lorsqu'il est configuré pour vérifier la signature du package, Integration Services vérifie seulement si la signature numérique est présente, si elle est valide et si elle provient d'une source approuvée. Integration Services ne vérifie pas si le package a été modifié.

  • Chiffrer les points de terminaison des packages qui utilisent des points de terminaison. Pour plus d'informations, consultez Utilisation de points de contrôle dans les packages.

Pour plus d'informations sur la sécurisation du service Integration Services et des packages Integration Services, consultez Vue d'ensemble de la sécurité (Integration Services).

Voir aussi

Autres ressources

Migration des packages DTS


Migration de scripts

Migration de scripts |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Migration des packages DTS >

La version SQL Server 2000 de la tâche de script ActiveX peut être migrée vers la tâche de script ActiveX SQL Server. Cependant, la tâche de script ActiveX SQL Server est fournie dans le seul but d'assurer la compatibilité descendante. Après la migration, vous devez remplacer les tâches de script ActiveX par les fonctionnalités Integration Services.

Si vos scripts contiennent le code pour gérer le flux de contrôle dans les packages, vous pouvez être en mesure de remplacer les scripts par les nouvelles fonctionnalités de flux de contrôle dans Integration Services, telles que les conteneurs de boucle et des contraintes de précédence plus flexibles. Pour plus d'informations, consultez Conteneurs Integration Services et Contraintes de précédence.

Vous pouvez remplacer l'autre logique client de vos scripts par le code managé dans la tâche de script Integration Services. Pour plus d'informations sur la tâche de script Integration Services, consultez Tâche de script.

Les tâches de script ActiveX qui tentent d'accéder au modèle objet du package en utilisant la propriété Parent de la collection GlobalVariables échouent après la migration du package. L'ancienne fonctionnalité doit être remplacée au moyen d'un autre code de script ou de nouvelles fonctionnalités Integration Services.

Voir aussi

Autres ressources

Tâche de script ActiveX
Tâche de script
Migration des packages DTS


Rubriques de procédures sur la migration des packages DTS (Data Transformation Services)

Rubriques de procédures sur la migration des packages DTS (Data Transformation Services) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services >

Cette section contient les procédures courantes suivantes pour migrer des packages DTS SQL Server 2000 vers Microsoft Integration Services.

  • Procédure : migrer des packages DTS (Data Transformation Services) vers Integration Services

Pour prendre connaissance des procédures courantes permettant d'installer Integration Services, consultez Rubriques de procédures pour l'installation d'Integration Services.

Voir aussi

Concepts

Considérations sur la mise à niveau de Data Transformation Services
Compatibilité descendante d'Integration Services


Procédure : migrer des packages DTS (Data Transformation Services) vers Integration Services

Procédure : migrer des packages DTS (Data Transformation Services) vers Integration Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Considérations sur la mise à niveau de Data Transformation Services > Rubriques de procédures sur la migration des packages DTS (Data Transformation Services) >

Vous n'êtes pas obligé de migrer les packages DTS SQL Server 2000 vers le format de package Integration Services. Les packages DTS peuvent s'exécuter parallèlement aux packages Integration Services.

Remarque :
Pour plus d'informations sur la mise à niveau des packages créés dans une version antérieure d'Integration Services, consultez Mise à niveau de packages Integration Services.

Si vous souhaitez migrer vos packages DTS, SQL Server fournit l'Assistant Migration de package DTS pour vous aider dans cette tâche. L'Assistant conserve vos packages d'origine inchangés et vous pouvez donc toujours continuer à les utiliser si vous rencontrez des problèmes au moment de la migration.

L'Assistant Migration de package est installé lorsque Integration Services est installé. Pour plus d'informations, consultez Procédure : installer la prise en charge des packages DTS.

Remarque :
L'Assistant Migration de package est disponible dans les éditions Standard, Enterprise et Developer de SQL Server.

Pour plus d'informations sur la migration des packages DTS, consultez Migration des packages DTS.

Pour plus d'informations sur les options de mise à niveau et de migration disponibles pour les utilisateurs de Data Transformation Services, consultez Considérations sur la mise à niveau de Data Transformation Services.

Pour obtenir des informations générales sur la prise en charge de DTS dans Integration Services, consultez Prise en charge de DTS dans SQL Server 2008.

Pour migrer des packages DTS vers Integration Services

  1. Vous pouvez éventuellement exécuter le Conseiller de mise à niveau pour analyser vos packages existants et générer un rapport sur les problèmes de migration potentiels. Pour plus d'informations, consultez Problèmes connus liés à la migration des packages DTS.

  2. Exécutez l'Assistant Migration de package pour migrer vos packages.

  3. Reconfigurez les éléments du package qui doivent l'être manuellement, comme indiqué par le Conseiller de mise à niveau ou l'Assistant.

  4. Testez les packages migrés et corrigez les éventuelles erreurs.

Voir aussi

Tâches

Procédure : installer la prise en charge des packages DTS

Concepts

Compatibilité descendante d'Integration Services


Considérations relatives à la mise à niveau de bases de données répliquées

Considérations relatives à la mise à niveau de bases de données répliquées |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

SQL Server 2008 prend en charge la mise à niveau des bases de données répliquées à partir des versions précédentes de SQL Server ; il n'est pas nécessaire d'interrompre l'activité des autres nœuds lorsqu'un nœud est en cours de mise à niveau. Prenez soin de respecter les règles relatives aux versions qui sont prises en charge dans une topologie :

  • SQL Server 2000 Service Pack 3 (SP3) est la version minimale requise pour participer à une topologie de réplication avec SQL Server 2008. Aucune version minimale n'est requise si vous utilisez SQL Server 2005.

  • Toute version convient pour le serveur de distribution dès lors qu'elle est égale ou supérieure à celle du serveur de publication (en général, l'instance du serveur de distribution est la même que celle du serveur de publication).

  • Toute version convient pour le serveur de publication dès lors qu'elle est inférieure ou égale à celle du serveur de distribution.

  • La version de l'Abonné dépend du type de publication :

    • La version d'un Abonné à une publication transactionnelle peut être n'importe laquelle des deux versions du serveur de publication. Par exemple : un serveur de publication SQL Server 2000 peut avoir des Abonnés SQL Server 2008 et un serveur de publication SQL Server 2008 peut avoir des Abonnés SQL Server 2000.

    • La version d'un Abonné à une publication de fusion peut être toute version inférieure ou égale à celle du serveur de publication.

Remarque :
Cette rubrique est disponible dans la documentation d'aide du programme d'installation et dans la documentation en ligne de SQL Server. Les liens vers des rubriques qui s'affichent en gras dans la documentation d'aide du programme d'installation font référence à des rubriques qui sont exclusivement disponibles dans la documentation en ligne.

Exécuter l'Agent de lecture du journal pour la réplication transactionnelle avant la mise à niveau

Avant d'effectuer la mise à niveau vers SQL Server 2008, vous devez vous assurer que toutes les transactions validées de tables publiées ont été traitées par l'Agent de lecture du journal. Pour vous assurer que toutes les transactions ont été traitées, effectuez les étapes suivantes pour chaque base de données qui contient des publications transactionnelles :

  1. Assurez-vous que l'Agent de lecture du journal s'exécute pour la base de données. Par défaut, cet agent s'exécute en permanence.

  2. Arrêtez l'activité des utilisateurs sur les tables publiées.

  3. Laissez à l'Agent de lecture du journal le temps de copier des transactions vers la base de données de distribution, puis arrêtez-le.

  4. Exécutez sp_replcmds pour vérifier que toutes les transactions ont été traitées. Le jeu de résultats de cette procédure doit être vide.

  5. Exécutez sp_replflush pour fermer la connexion à partir de sp_replcmds.

  6. Effectuez la mise à niveau de serveur vers SQL Server 2008.

  7. Redémarrez l'Agent SQL Server et l'Agent de lecture du journal s'ils ne démarrent pas automatiquement après la mise à niveau.

Exécution des agents de réplication de fusion après la mise à niveau

Après la mise à niveau, exécutez l'Agent de capture instantanée pour chaque publication de fusion et l'Agent de fusion pour chaque abonnement afin de mettre à jour les métadonnées de réplication. Vous n'avez pas à appliquer la nouvelle capture instantanée, car elle n'est pas nécessaire pour réinitialiser les abonnements. Les métadonnées d'abonnement sont mises à jour lors de la première exécution de l'Agent de fusion après la mise à niveau. Ceci signifie que la base de données d'abonnement peut rester en ligne et active durant la mise à niveau du serveur de publication.

La réplication de fusion stocke les métadonnées de publication et d'abonnement dans un certain nombre de tables système des bases de données de publication et d'abonnement. L'exécution de l'Agent de capture instantanée met à jour les métadonnées d'abonnement et l'exécution de l'Agent de fusion met à jour les métadonnées d'abonnement. Il faut uniquement générer une capture instantanée de publication. Si une publication de fusion utilise des filtres paramétrés, chaque partition a également une capture instantanée. Il n'est pas nécessaire de mettre à jour ces captures instantanées partitionnées. (Dans SQL Server 2000, les filtres paramétrés étaient désignés comme des filtres dynamiques et les captures instantanées partitionnées étaient désignées comme des captures instantanées dynamiques.)

Exécutez les agents à partir de SQL Server Management Studio, du moniteur de réplication ou de la ligne de commande. Pour plus d'informations sur l'exécution de l'Agent de capture instantanée, consultez les rubriques suivantes :

  • Procédure : créer et appliquer la capture instantanée initiale (SQL Server Management Studio)

  • Procédure : démarrer et arrêter un Agent de réplication (SQL Server Management Studio)

  • Procédure : créer la capture instantanée initiale (programmation Transact-SQL de la réplication)

  • Replication Agent Executables Concepts

Pour plus d'informations sur l'exécution de l'Agent de fusion, consultez les rubriques suivantes :

  • Procédure : synchroniser un abonnement par extraction de données (SQL Server Management Studio)

  • Procédure : synchroniser un abonnement par envoi de données (SQL Server Management Studio)

  • Procédure : synchroniser un abonnement par extraction de données (pull) (Programmation de la réplication)

  • Procédure : synchroniser un abonnement par envoi de données (push) (Programmation de la réplication)

Après avoir mis à niveau SQL Server dans une topologie qui utilise la réplication de fusion, modifiez le niveau de compatibilité de toutes les publications si vous voulez utiliser les nouvelles fonctionnalités. Pour plus d'informations, consultez Utilisation de plusieurs versions de SQL Server dans une topologie de réplication.

Mise à niveau vers les éditions Standard, Workgroup ou Express

Avant toute mise à niveau d'une édition de SQL Server 2008 vers une autre, vérifiez que la fonctionnalité en cours d'utilisation est prise en charge dans l'édition vers laquelle vous effectuez la mise à niveau. Pour plus d'informations, consultez la section « Fonctionnalités de réplication SQL Server 2008 » dans la rubrique Fonctionnalités prises en charge par les éditions de SQL Server 2008.

Nouveau modèle de sécurité de l'Agent de réplication

Dans les versions de SQL Server antérieures à SQL Server 2005, les agents s'exécutaient par défaut sous le compte du service SQL Server Agent. SQL Server 2005 a permis de contrôler plus précisément chaque compte sous lequel les agents de réplication s'exécutent et établissent des connexions intégrées à Windows avec les bases de données et d'autres ressources ; un compte différent peut être spécifié pour chaque agent. Pour plus d'informations, consultez Sécurité et protection (réplication) et Modèle de sécurité de l'Agent de réplication.

Le nouveau modèle de sécurité a les implications suivantes dans la mise à niveau et l'exécution de SQL Server 2000 dans une topologie :

  • Les scripts de réplication créés dans SQL Server 2000 doivent être mis à niveau vers SQL Server 2008 pour pouvoir tirer parti des améliorations apportées à la sécurité. Pour plus d'informations, consultez Procédure : mettre à niveau les scripts de réplication (programmation Transact-SQL de la réplication).

  • Un serveur de distribution ou un Abonné mis à niveau à partir de SQL Server 2000 vers SQL Server 2008 continue d'être exécuté sous le compte de l'Agent SQL Server et a vraisemblablement plus de privilèges qu'il n'en nécessite. Après la mise à jour, nous vous recommandons de spécifier des comptes distincts pour les agents, avec les privilèges minimum appropriés. Pour spécifier des comptes distincts :

    1. Générez le script de la publication et des abonnements.

    2. Modifiez ces scripts. Pour plus d'informations, consultez Procédure : mettre à niveau les scripts de réplication (programmation Transact-SQL de la réplication).

    3. Supprimez la publication et les abonnements. Pour plus d'informations, consultez Publication de données et d'objets de base de données et Abonnement à des publications.

    4. Recréez-les à l'aide des scripts modifiés.

    Pour plus d'informations sur les privilèges requis par les agents, consultez Modèle de sécurité de l'Agent de réplication ; pour plus d'informations sur la gestion des connexions et des mots de passe, consultez Gestion des connexions et des mots de passe dans la réplication. Les nouvelles configurations de réplication créées après une mise à niveau requièrent une configuration de compte spécifique pour chaque agent de réplication.

    Remarque :
    Tous les agents configurés pour utiliser l'authentification SQL Server pour les connexions de bases de données locales sont modifiés pour utiliser l'authentification Windows. Les connexions locales sont les connexions effectuées par un agent à une instance SQL Server qui s'exécute sur le même ordinateur que l'agent. Par exemple, l'Agent de fusion pour un abonnement par extraction de données s'exécute chez l'Abonné, si bien que les connexions qu'il établit avec l'Abonné sont des connexions locales.

  • Les participants d'une topologie de réplication exécutant des versions précédentes de SQL Server gardent l'ancien modèle de sécurité de réplication tel quel. Par exemple :

    • Un abonnement par extraction de données vers un Abonné exécutant SQL Server 2000 n'utilise pas le nouveau modèle de sécurité, car l'Agent de fusion ou de distribution est créé sur l'Abonné.

    • Un abonnement par émission de données à partir d'un serveur de distribution exécutant SQL Server 2008 vers un Abonné exécutant SQL Server 2000 utilise le nouveau modèle de sécurité, car l'Agent de fusion ou de distribution est créé sur le serveur de distribution.

    • Un serveur de publication exécutant SQL Server 2000 avec un serveur de distribution exécutant SQL Server 2008 n'utilise pas le nouveau modèle de sécurité (pour l'Agent de capture instantanée, l'Agent de lecture de journal ou l'Agent de lecture de la file d'attente), car les agents sont créés dans le contexte de la base de données de publication.

  • SQL Server 2005 et SQL Server 2008 utilisent le même modèle de sécurité.

Synchronisation Web pour la réplication de fusion

L'option de synchronisation Web pour la réplication de fusion requiert la copie de l'Écouteur de réplication SQL Server (replisapi.dll) dans le répertoire virtuel sur le serveur IIS (Internet Information Services) utilisé pour la synchronisation. Lorsque vous configurez la synchronisation Web, le fichier est copié dans le répertoire virtuel par l'Assistant Configuration de la synchronisation Web. Si vous mettez à niveau les composants SQL Server installés sur le serveur IIS, vous devez manuellement copier replisapi.dll depuis le répertoire COM vers le répertoire virtuel sur le serveur IIS. Pour plus d'informations sur la configuration de la synchronisation Web, consultez Configuration de la synchronisation Web.

Restauration d'une base de données répliquée à partir d'une version antérieure

Pour vous assurer que les paramètres de réplication sont conservés lorsque vous restaurez la sauvegarde d'une base de données répliquée à partir d'une version précédente : effectuez la restauration vers un serveur et une base de données du même nom que le serveur et la base de données à l'origine de la sauvegarde.

Voir aussi

Référence

Mises à niveau de la version et de l'édition

Concepts

Compatibilité descendante de la réplication
Utilisation de plusieurs versions de SQL Server dans une topologie de réplication
Mise à niveau vers SQL Server 2008

Autres ressources

Administration (réplication)
Nouveautés (Réplication)


Directives pour la mise à niveau des outils d'administration SQL Server

Directives pour la mise à niveau des outils d'administration SQL Server |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

SQL Server 2008 prend en charge la mise à niveau depuis SQL Server 2000 ou SQL Server 2005. Cette rubrique documente la prise en charge et le fonctionnement de la mise à niveau des Outils d'administration de SQL Server et des composants de gestion tels que l'Agent SQL Server, la Messagerie de base de données, les Plans de Maintenance, XPStar et XPWeb.

Important :
Dans le cas d'une installation locale, vous devez exécuter le programme d'installation de SQL Server en qualité d'administrateur. Si vous exécutez le programme d'installation de SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine doté des autorisations de lecture et d'exécution sur le partage distant.

Problèmes de mise à niveau connus

Considérez les points suivants avant de procéder à une mise à niveau vers SQL Server 2008 :

Pour tous les scénarios de mise à niveau :

  • Tous les serveurs TSX doivent être mis à niveau avant que le serveur MSX ne le soit. Pour plus d'informations sur MSX/TSX dans SQL Server, consultez Automating Adminstration Across an Enterprise dans la documentation en ligne de SQL Server.

  • Tous les composants d'une instance de SQL Server doivent être mis à niveau simultanément. Les numéros de version des composants Moteur de base de données, Analysis Services et Reporting Services doivent être identiques dans une instance de SQL Server 2008.

  • Vous pouvez ajouter des composants à une installation existante de SQL Server en même temps que vous procédez à une mise à niveau vers SQL Server 2008. Pour plus d'informations, consultez Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation).

  • Les outils clients de SQL Server, tels que SQL Server Management Studio, Générateur de profils SQL Server, l'Assistant Paramétrage du Moteur de base de données, sqlcmd, osql et autres, ne sont pas mis à niveau vers SQL Server 2008. À la place, les Outils clients s'exécutent parallèlement avec les outils des précédentes versions SQL Server. SQL Server 2008 prend en charge les paramètres d'importation des versions antérieures des Outils clients pour SQL Server.

  • L'authentification depuis l'Agent SQL Server vers SQL Server est mise à jour depuis l'authentification SQL Server vers l'authentification Windows pendant la mise à niveau. L'authentification SQL Server n'est pas prise en charge dans SQL Server 2008.

  • Les données des travaux et des alertes sont conservées pendant la mise à niveau vers SQL Server 2008.

  • Si SQLMail est utilisé dans l'instance à mettre à niveau, les composants XPs associés sont pris en charge et activés après la mise à niveau. Sinon, ils sont désactivés.

  • La messagerie de base de données, également appelée SQLiMail, est mise à niveau avec le composant Moteur de base de données de SQL Server 2008. Par défaut, la messagerie sera désactivée après la mise à niveau. Toutes les mises à jour de schéma doivent être harmonisées avec un script de mise à jour après la mise à niveau.

Mise à niveau à partir de SQL Server 2000 :

  • Lors de la mise à niveau de SQL Server 2000 vers SQL Server 2008, tous les comptes proxy d'utilisateurs qui existaient avant la mise à niveau sont modifiés en compte proxy global temporaire UpgradedProxyAccount. Le compte UpgradedProxyAccount a uniquement accès aux sous-systèmes qui étaient explicitement utilisés et n'a pas accès à tous les sous-systèmes après la mise à niveau.

  • Bien que la substitution de jeton pour la syntaxe des travaux et des alertes de l'Agent SQL Server ait été modifiée depuis SQL Server 2000, les jetons ne sont pas automatiquement mis à jour pendant la mise à niveau vers SQL Server 2008.

Voir aussi

Tâches

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Référence

Mises à niveau de la version et de l'édition

Autres ressources

Backward Compatibility


Rubriques de procédures relatives à la mise en niveau

Rubriques de procédures relatives à la mise en niveau |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Les rubriques de cette section expliquent comment mettre à niveau une instance autonome de SQL Server.

Rubrique Description

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Rubrique procédurale pour mettre à niveau une instance autonome de SQL Server vers SQL Server 2008.
  • Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation)

Rubrique procédurale pour mettre à niveau une instance d'un cluster de basculement SQL Server vers SQL Server 2008.
  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes

Fournit des exemples de syntaxe d'invite de commandes pour installer SQL Server 2008.

Voir aussi

Référence

Mises à niveau de la version et de l'édition

Concepts

Compatibilité ascendante


Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation)

Procédure : effectuer une mise à niveau vers SQL Server 2008 (avec le programme d'installation) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Rubriques de procédures relatives à la mise en niveau >

L'Assistant Installation de SQL Server fournit une arborescence de fonctionnalités unique pour mettre à niveau les composants SQL Server. Vous pouvez également installer SQL Server 2008 côte à côte avec une version antérieure ou migrer les bases de données et les paramètres de configuration existants à partir d'une version antérieure de SQL Server et les appliquer à une instance de SQL Server 2008.

Pour plus d'informations, consultez ces rubriques :

  • Mises à niveau de la version et de l'édition

  • Pour plus d'informations sur la prise en charge des configurations côte à côte, consultez Utilisation de plusieurs versions et instances de SQL Server.

  • Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation)

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes

  • Utilisation de l'Assistant Copie de base de données

  • Procédure : mettre à niveau SQL Server à l'aide de l'Assistant Copie de base de données

Configuration requise

Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Avant de commencer à mettre à niveau le Moteur de base de données, consultez les rubriques suivantes :

  • Mise à niveau vers SQL Server 2008

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Paramètres de l'outil d'analyse de configuration système

  • Considérations sur la sécurité pour une installation SQL Server

  • Compatibilité descendante du moteur de base de données SQL Server

Procédure

Pour effectuer une mise à niveau vers SQL Server 2008

  1. Insérez le support d'installation SQL Server et, dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis réexécutez le programme d'installation (setup.exe) de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour mettre à niveau une instance existante de SQL Server 2008, cliquez sur Mise à niveau de SQL Server 2000 ou SQL Server 2005.

  5. Si les fichiers de support du programme d'installation sont requis, le programme d'installation de SQL Server les installera. Redémarrez votre ordinateur si vous êtes invité à le faire avant de continuer.

  6. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  7. Dans la page Clé de produit (Product Key), cliquez sur une case d'option pour indiquer si vous effectuez une mise à niveau vers une édition gratuite de SQL Server ou si vous disposez d'une clé PID pour une version de production du produit. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008 et Mises à niveau de la version et de l'édition.

  8. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour mettre fin au programme d'installation, cliquez sur Annuler.

  9. Dans la page Sélectionner une instance, spécifiez l'instance de SQL Server à mettre à niveau.

  10. Dans la page Sélection de composant, les fonctionnalités à mettre à niveau seront présélectionnées. Une description de chaque groupe de composants apparaît dans le volet droit après que vous avez sélectionné le nom de la fonctionnalité. Notez que vous ne pouvez pas modifier les fonctionnalités à mettre à niveau, de même que vous ne pouvez pas ajouter de fonctionnalités pendant l'opération de mise à niveau. Pour ajouter des fonctionnalités à une instance mise à niveau de SQL Server 2008 une fois l'opération de mise à niveau terminée, consultez Procédure : ajouter des fonctionnalités à une instance de SQL Server 2008 (programme d'installation).

  11. Dans la page Configuration de l'instance, spécifiez s'il faut installer une instance par défaut ou une instance nommée. Pour plus d'informations, consultez Configuration d'une instance.

    Suffixe de l'ID d'instance — Par défaut, le nom de l'instance est utilisé comme suffixe de l'ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et le suffixe de l'ID d'instance seront MSSQLSERVER. Pour utiliser un suffixe d'ID d'instance non défini par défaut, activez la case à cocher Suffixe de l'ID d'instance et entrez une valeur.

    Remarque :
    Les instances autonomes classiques de SQL Server 2008, qu'il s'agisse d'instances par défaut ou d'instances nommées, n'utilisent pas de valeur non définie par défaut pour la case à cocher Suffixe de l'ID d'instance.

    Répertoire racine de l'instance — Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, utilisez le champ fourni ou cliquez sur Parcourir pour rechercher un dossier d'installation.

    Tous les Service Packs et mises à niveau de SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

    Instances et fonctionnalités détectées — La grille affiche les instances de SQL Server qui se trouvent sur l'ordinateur où le programme d'installation s'exécute. Si une instance par défaut est déjà installée sur l'ordinateur, vous devez installer une instance nommée de SQL Server 2008. Pour continuer, cliquez sur Suivant.

  12. La page Espace disque requis calcule l'espace disque requis pour les fonctionnalités que vous spécifiez et compare cet espace à l'espace disque disponible sur l'ordinateur où le programme d'installation s'exécute. Pour plus d'informations, consultez Résumé sur l'espace nécessaire.

  13. Le flux de travail du reste de cette rubrique dépend des fonctionnalités que vous avez spécifiées pour votre installation. Il est possible que les pages ne soient pas toutes visibles, en fonction de vos sélections.

  14. Dans la page Configuration du serveur — Comptes de service, spécifiez les comptes de connexion des services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous mettez à niveau.

    Les informations d'authentification et de connexion seront transférées de l'instance antérieure de SQL Server. Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin que les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration de SQL Server - Comptes de service et Configuration des comptes de service Windows.

    Pour spécifier le même compte de connexion pour tous les comptes de service dans cette instance de SQL Server, fournissez les informations d'identification dans les champs en bas de page.

    Remarque relative à la sécurité N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

    Lorsque vous avez terminé de spécifier les informations de connexion pour les services SQL Server, cliquez sur Suivant.

  15. Utilisez l'onglet Configuration du serveur — Classement pour spécifier les classements non définis par défaut pour le Moteur de base de données et Analysis Services. Pour plus d'informations, consultez Configuration de SQL Server - Classement.

  16. Dans la page des options de mise à niveau de recherche en texte intégral, spécifiez les options de mise à niveau pour les bases de données mises à niveau. Pour plus d'informations, consultez Options de mise à niveau de recherche en texte intégral.

  17. Dans la page Création de rapports d'erreurs et d'utilisation, spécifiez les informations que vous souhaitez envoyer à Microsoft qui aideront à améliorer SQL Server. Par défaut, les options de rapports d'erreurs et d'utilisation des fonctionnalités sont activées. Pour plus d'informations, consultez Paramètres de rapports d'erreurs et d'utilisation.

  18. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avec les fonctionnalités SQL Server que vous avez spécifiées avant le début de l'opération de mise à niveau.

  19. La page Prêt pour la mise à niveau affiche une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  20. Au cours de l'installation, la page Progression fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  21. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  22. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

Étapes suivantes

Après la mise à niveau vers SQL Server 2008, effectuez les tâches suivantes :

  • Inscrire vos serveurs — La mise à niveau entraîne la suppression des paramètres du Registre pour l'instance antérieure de SQL Server. Après la mise à niveau, vous devez réinscrire vos serveurs.

  • Mettre à jour les statistiques — Afin d'optimiser les performances des requêtes, il est recommandé de mettre à jour les statistiques sur toutes les bases de données après une mise à niveau. Utilisez la procédure stockée sp_updatestats pour mettre à jour les statistiques des tables définies par l'utilisateur dans les bases de données SQL Server.

  • Mettre à jour les compteurs d'utilisation — Dans les versions antérieures de SQL Server, les valeurs des nombres de pages et de lignes d'index et de table peuvent s'avérer incorrectes. Pour corriger les nombres de lignes ou de pages non valides, il est recommandé d'exécuter DBCC UPDATEUSAGE sur toutes les bases de données après une mise à niveau.

  • Configurer votre nouvelle installation SQL Server — Pour réduire la surface d'exposition attaquable d'un système, SQL Server sélectionne les services et les fonctionnalités clés à installer et à activer. Pour plus d'informations sur la configuration de la surface d'exposition, consultez le fichier Lisez-moi de cette version.

Voir aussi

Concepts

Compatibilité ascendante

Autres ressources

Upgrading to SQL Server 2005


Procédure : effectuer une mise à niveau vers une autre édition de SQL Server 2008 (programme d'installation)

Procédure : effectuer une mise à niveau vers une autre édition de SQL Server 2008 (programme d'installation) |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Rubriques de procédures relatives à la mise en niveau >

L'Assistant Installation de SQL Server fournit une arborescence de fonctionnalités unique pour mettre à niveau les composants SQL Server. Vous pouvez également installer SQL Server 2008 côte à côte avec une version antérieure ou migrer les bases de données et les paramètres de configuration existants à partir d'une version antérieure de SQL Server et les appliquer à une instance de SQL Server 2008.

Pour plus d'informations, consultez ces rubriques :

  • Mises à niveau de la version et de l'édition

  • Utilisation de plusieurs versions et instances de SQL Server

  • Procédure : mettre à niveau une instance de cluster de basculement SQL Server (programme d'installation)

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes

  • Procédure : mettre à niveau SQL Server à l'aide de l'Assistant Copie de base de données

Configuration requise

Pour des installations locales, vous devez exécuter le programme d'installation en tant qu'administrateur. Si vous installez SQL Server à partir d'un partage distant, vous devez utiliser un compte de domaine qui dispose des autorisations de lecture et d'exécution sur le partage distant.

Avant de mettre à niveau le Moteur de base de données, consultez les rubriques suivantes :

  • Mise à niveau vers SQL Server 2008

  • Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

  • Paramètres de l'outil d'analyse de configuration système

  • Considérations sur la sécurité pour une installation SQL Server

  • Compatibilité descendante du moteur de base de données SQL Server

Important :
Pour activer la modification de l'édition de SQL Server, vous devez redémarrer les services SQL Server. L'application n'est ainsi pas disponible pendant que les services sont hors connexion.

Procédure

Pour effectuer une mise à niveau vers SQL Server 2008

  1. Insérez le support d'installation SQL Server. Dans le dossier racine, double-cliquez sur setup.exe. Pour effectuer l'installation à partir d'un partage réseau, recherchez le dossier racine sur le partage, puis double-cliquez sur setup.exe.

  2. Si la boîte de dialogue d'installation de Microsoft .NET Framework version 2.0 s'affiche, activez la case à cocher pour accepter le Contrat de licence de .NET Framework 2.0. Cliquez sur Suivant. Pour quitter l'installation de SQL Server 2008, cliquez sur Annuler. Une fois l'installation de .NET Framework 2.0 achevée, cliquez sur Terminer.

  3. Windows Installer 4.5 est également requis et peut être installé par l'Assistant Installation. Si vous êtes invité à redémarrer votre ordinateur, redémarrez-le, puis réexécutez le programme d'installation (setup.exe) de SQL Server 2008.

  4. Lorsque les composants requis sont installés, l'Assistant Installation lance le Centre d'installation SQL Server. Pour mettre à niveau une instance existante de SQL Server 2008 vers une autre édition, cliquez sur Avancé, puis sélectionnez Mise à niveau d'édition.

  5. Si les fichiers de support du programme d'installation sont requis, le programme d'installation de SQL Server les installera. Redémarrez votre ordinateur si vous êtes invité à le faire avant de continuer.

  6. L'outil d'analyse de configuration système effectuera une opération de découverte sur votre ordinateur. Cliquez sur OK pour continuer. Des fichiers journaux du programme d'installation ont été créés pour votre installation. Pour plus d'informations sur les fichiers journaux, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  7. Dans la page Clé de produit, sélectionnez une case d'option pour indiquer si vous effectuez une mise à niveau vers une édition gratuite de SQL Server ou si vous disposez d'une clé PID pour une version de production du produit. Pour plus d'informations, consultez Éditions et composants de SQL Server 2008 et Mises à niveau de la version et de l'édition.

  8. Dans la page Termes du contrat de licence, prenez connaissance du contrat de licence et activez la case à cocher indiquant que vous en acceptez les termes et conditions. Pour continuer, cliquez sur Suivant. Pour mettre fin au programme d'installation, cliquez sur Annuler.

  9. Dans la page Sélectionner une instance, spécifiez l'instance de SQL Server à mettre à niveau.

  10. L'outil d'analyse de configuration système exécutera un autre ensemble de règles pour valider la configuration de votre ordinateur avant le début de l'opération de mise à niveau d'édition.

  11. La page Prêt pour la mise à niveau affiche une arborescence des options d'installation spécifiées durant l'exécution du programme d'installation. Pour continuer, cliquez sur Installer.

  12. Au cours de l'installation, la page Progression fournit des informations sur l'état pour que vous puissiez contrôler la progression de l'installation au fil de l'avancement de l'exécution du programme d'installation.

  13. Après l'installation, la page Terminé fournit un lien vers le fichier journal résumé pour l'installation et d'autres remarques importantes. Pour terminer le processus d'installation de SQL Server, cliquez sur Fermer.

  14. Redémarrez l'ordinateur si vous êtes invité à le faire. Il est important de lire le message affiché par l'Assistant Installation à la fin de l'installation. Pour plus d'informations sur les fichiers journaux d'installation, consultez Procédure : afficher les fichiers journaux d'installation de SQL Server.

  15. Si vous avez effectué une mise à niveau à partir de SQL Server Express, vous devez exécuter des étapes supplémentaires avant de pouvoir utiliser votre instance mise à niveau de SQL Server:

    • Activez le service SQL Server Agent dans Windows GCL.

    • Configurez le compte du service de SQL Server Agent en utilisant le Gestionnaire de configuration SQL Server.

    • Les utilisateurs qui ont été configurés en tant qu'administrateurs système conservent leur configuration après la mise à niveau. En particulier, BUILTIN\Users conserve sa configuration. Désactivez, supprimez ou reconfigurez ces comptes, en fonction des besoins.

    • Les tailles et mode de récupération de TempDB et ModelDB restent inchangés après la mise à niveau. Reconfigurez ces paramètres en fonction des besoins.

    • Les bases de données modèles demeurent sur l'ordinateur après la mise à niveau. Supprimez-les ou reconfigurez-les en fonction des besoins.

Voir aussi

Concepts

Mise à niveau vers SQL Server 2008
Compatibilité ascendante


Compatibilité ascendante

Compatibilité ascendante |
 | Voir aussi
Mise à niveau vers SQL Server 2008 >

Les sections suivantes présentent des informations sur la compatibilité descendante pour les composants SQL Server. Ces informations concernent les fonctionnalités abandonnées, les fonctionnalités supprimées, les dernières modifications et les modifications de comportement.

Dans cette section

Rubrique | Description
Compatibilité descendante SQL Server | Contient des rubriques qui décrivent les modifications de SQL Server qui peuvent nécessiter que vous modifiiez vos applications. Les fonctionnalités incluses dans cette rubrique incluent la programmabilité des données, les outils de configuration de la surface d'exposition, le programme d'installation, les services SQL Server et autres modifications de fonctionnalités générales.
Compatibilité descendante du moteur de base de données SQL Server | Contient des rubriques qui décrivent les modifications du Moteur de base de données dans SQL Server qui peuvent nécessiter que vous modifiiez vos applications.
Compatibilité descendante de SQL Server Analysis Services | Contient des rubriques qui décrivent les modifications de Analysis Services dans SQL Server qui peuvent nécessiter que vous modifiiez vos applications.
Compatibilité descendante d'Integration Services | Décrit les modifications de Integration Services dans SQL Server qui peuvent nécessiter que vous modifiiez vos applications Data Transformation Services existantes.
Compatibilité descendante de Reporting Services | Contient des rubriques qui décrivent les modifications de SSRS dans SQL Server qui peuvent nécessiter que vous modifiiez vos solutions Reporting Services existantes.
Compatibilité descendante de la réplication | Contient des rubriques qui décrivent les modifications du Moteur de base de données dans SQL Server qui peuvent nécessiter que vous modifiiez vos solutions de réplication existantes.

Voir aussi

Concepts

Installation de SQL Server 2008
Mise à niveau vers SQL Server 2008
Migration vers SQL Server 2008


Compatibilité descendante SQL Server

Compatibilité descendante SQL Server
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Les rubriques de la section consacrée à la compatibilité descendante décrivent les changements de comportement SQL Server entre les différentes versions de SQL Server.

Les fonctionnalités incluses dans cette rubrique incluent la programmabilité des données, les outils de configuration de la surface d'exposition, le programme d'installation de SQL Server, les services SQL Server et autres modifications de fonctionnalités générales.

Rubrique | Description
Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 | Fonctionnalités SQL Server abandonnées dans cette version. Cette rubrique inclut couverture les fonctionnalités Programmabilité des données, les outils Configuration de la surface d'exposition et les fonctionnalités d'installation.
Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 | Fonctionnalité SQL Server abandonnée dans cette version. Cette rubrique inclut couverture les fonctionnalités Programmabilité des données, les outils Configuration de la surface d'exposition et les fonctionnalités d'installation.
Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 | Changements qui peuvent imposer des modifications dans les applications. Cette rubrique inclut couverture les fonctionnalités Programmabilité des données, les outils Configuration de la surface d'exposition et les fonctionnalités d'installation.
Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 | Autres changements intervenus par rapport aux fonctionnalités de base de données dans cette version. Cette rubrique inclut couverture les fonctionnalités Programmabilité des données, les outils Configuration de la surface d'exposition et les fonctionnalités d'installation.


Fonctionnalité SQL Server abandonnées dans SQL Server 2008

Fonctionnalité SQL Server abandonnées dans SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante SQL Server >

Cette rubrique décrit les fonctionnalités abandonnées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions abandonnées ne doivent pas être utilisées dans de nouvelles applications.

Fonctionnalités non prises en charge dans la prochaine version de SQL Server

Les fonctionnalités suivantes du Moteur de base de données SQL Server ne seront pas prises en charge dans la prochaine version de SQL Server. Évitez d'utiliser ces fonctionnalités dans vos nouveaux développements et modifiez dès que possible les applications qui y ont recours. La colonne Nom de la fonctionnalité apparaît dans les événements de suivi comme ObjectName, et dans les compteurs de performance et sys.dm_os_performance_counters comme nom_instance. L'ID de la fonctionnalité apparaît dans les événements de suivi comme ObjectId.

Catégorie | Fonctionnalité désapprouvée | Remplacement | Nom de la fonctionnalité | ID de la fonctionnalité
services SQL Server | Service ADHelper | Aucun | ADHelper |
Programmabilité des données | Points de terminaison SOAP/HTTP avec CREATE ENDPOINT (Transact-SQL) et ALTER ENDPOINT (Transact-SQL) | Windows Communications Foundation (WCF) ou ASP.NET | Services Web XML natifs | 21
Programmabilité des données | sys.soap_endpoints (Transact-SQL) | Windows Communications Foundation (WCF) ou ASP.NET | Services Web XML natifs | 22
Programmabilité des données | sys.endpoint_webmethods (Transact-SQL) | Windows Communications Foundation (WCF) ou ASP.NET | Services Web XML natifs | 23


Fonctionnalités SQL Server supprimées dans SQL Server 2008

Fonctionnalités SQL Server supprimées dans SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante SQL Server >

Cette rubrique décrit des fonctionnalités qui ne sont plus disponibles dans SQL Server 2008.

Outil Configuration de la surface d'exposition

L'outil Configuration de la surface d'exposition de SQL Server a été supprimé de SQL Server 2008. La fonctionnalité de remplacement de cette version est présentée ci-dessous.

Catégorie Fonctionnalité supprimée Remplacement

Outils

Outil Configuration de la surface d'exposition

L'outil Configuration de la surface d'exposition a été supprimé dans SQL Server 2008. Le tableau suivant indique ce que vous pouvez utiliser pour configurer les paramètres, options et fonctionnalités de composant dans la version CTP de février 2008.

Paramètres et fonctionnalités de composant | Comment configurer
Protocoles, connexion et options de démarrage | Utilisez le Gestionnaire de configuration SQL Server.
Fonctionnalités du Moteur de base de données | Utilisez la Gestion basée sur une stratégie, les paramètres de propriétés dans SQL Server Management Studio ou sp_Configure.
Fonctionnalités Analysis Services | Utilisez les paramètres de propriétés dans SQL Server Management Studio.
Reporting Services - Propriété EnableIntegratedSecurity | Utilisez les paramètres de propriétés dans SQL Server Management Studio.
Reporting Services - « Événements programmés et remise du rapport » et « Service Web et accès HTTP » | Modifiez le fichier de configuration RSReportServer.config.
Options de ligne de commande | Pas de prise en charge dans cette version.
Points de terminaison SOAP et Service Broker | Utilisez CREATE ENDPOINT et ALTER ENDPOINT.

Paramètres d'invite de commandes abandonnés pour l'installation de SQL Server

Le tableau suivant répertorie les paramètres d'invite de commandes d'installation des versions antérieures de SQL Server qui ne sont pas pris en charge dans SQL Server 2008.

Paramètre abandonné | Paramètre de remplacement
ADDLOCAL | /ACTION=Uninstall et /FEATURES
DISABLENETWORKPROTOCOLS | /TCPENABLED pour TCP/IP1
DISABLENETWORKPROTOCOLS | /NPENABLED pour les canaux nommés1
INSTALLSQLDATADIR | /SQLUSERDBDIR /SQLUSERDBLOGDIR /SQLBACKUPDIR /SQLTEMPDBDIR /SQLTEMPDBLOGDIR
REINSTALL | Pas de fonction équivalente dans cette version.
REINSTALLMODE | Pas de fonction équivalente dans cette version.
REMOVE | /ACTION=Uninstall et /FEATURES
SAMPLEDATABASE | Pas de fonction équivalente dans cette version.
SAVESYSDB | Pas de fonction équivalente dans cette version.
SKUUPGRADE | Pas de fonction équivalente dans cette version.
UPGRADE | /ACTION=Upgrade et /FEATURES
USESYSDB | Pas de fonction équivalente dans cette version.

1Ces paramètres sont valides uniquement pour l'installation.

Pour plus d'informations, consultez Procédure : installer SQL Server 2008 à partir de l'invite de commandes.


Modifications avec rupture dans les fonctionnalités SQL Server de SQL Server 2008

Modifications avec rupture dans les fonctionnalités SQL Server de SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante SQL Server >

Cette rubrique décrit les changements avec rupture apportés à SQL Server. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Sous-titre

Insérer le corps de la section ici.


Changements de comportement dans les fonctionnalités SQL Server de SQL Server 2008

Changements de comportement dans les fonctionnalités SQL Server de SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante SQL Server >

Cette rubrique décrit les changements de comportement dans SQL Server 2008. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Remarques

Insérer les notes ici.

Fonctionnalité | Informations supplémentaires
SQL Server Native Client | Updating an Application to SQL Server 2008 Native Client from SQL Server 2005 Native Client


Prise en charge des versions antérieures de SQL Server

Prise en charge des versions antérieures de SQL Server
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante SQL Server >

Les rubriques de cette section décrivent la prise en charge SQL Server des composants et fonctionnalités hérités suivants :

Reportez-vous à | Pour obtenir des informations sur…
DMO (Distributed Management Objects) | Prise en charge des objets DMO (Distributed Management Objects)


DMO (Distributed Management Objects)

DMO (Distributed Management Objects) |
 | Voir aussi
Compatibilité ascendante > Compatibilité descendante SQL Server > Prise en charge des versions antérieures de SQL Server >

La fonctionnalité DMO (Distributed Management Objects) est installée par SQL Server en tant que composant hérité. Pour installer la fonctionnalité Composants hérités, cliquez sur Avancé dans la page Composants à installer durant l'installation de SQL Server. Développez la fonction Composants clients, puis sélectionnez Composants hérités.

Voir aussi

Référence

Éditions et composants de SQL Server 2008


DTS (Data Transformation Services)

DTS (Data Transformation Services)
Compatibilité ascendante > Compatibilité descendante SQL Server > Prise en charge des versions antérieures de SQL Server >

DTS (Data Transformation Services) a été remplacé par SQL Server Integration Services.

SQL Server 2008 n'installe pas la prise en charge de DTS. Pour plus d'informations, consultez Prise en charge de DTS dans SQL Server 2008.

DTS (Data Transformation Services) est désapprouvé.

DTS (Data Transformation Services) est abandonné. Prévoyez de supprimer les dépendances à DTS avant la prochaine version de SQL Server. DTS demeure pris en charge dans SQL Server 2000, SQL Server 2005 et SQL Server 2008 conformément à notre engagement à fournir une prise en charge pour ces versions de SQL Server. Toutefois, la migration ou l'exécution des packages DTS peut ne pas être prise en charge dans la prochaine version.

Les fonctionnalités DTS qui seront abandonnées incluent le runtime DTS, l'API DTS, l'Assistant Migration de package permettant de migrer les packages DTS dans la prochaine version de Integration Services, la prise en charge de la maintenance des package DTS dans SQL Server Management Studio, ainsi que la tâche d'exécution de package DTS 2000.

Pour plus d'informations sur la façon d'effectuer une migration de packages DTS vers le format de package Integration Services, consultez Migration des packages DTS.


Compatibilité descendante du moteur de base de données SQL Server

Compatibilité descendante du moteur de base de données SQL Server
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Les rubriques de la section consacrée à la compatibilité descendante décrivent les changements de comportement entre les différentes versions de SQL Server.

Rubrique | Description
Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008 | Fonctionnalités Moteur de base de données désapprouvées dans cette version.
Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008 | Fonctionnalités Moteur de base de données abandonnées dans cette version.
Changements essentiels dans les fonctionnalités du moteur de base de données de SQL Server 2008 | Modifications des fonctionnalités Moteur de base de données qui peuvent imposer des modifications dans les applications.
Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 | Autres changements intervenus par rapport aux fonctionnalités de base de données dans cette version.


Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008

Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server >

Cette rubrique décrit les fonctionnalités Moteur de base de données SQL Server désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

Vous pouvez surveiller l'utilisation de fonctionnalités désapprouvées à l'aide du compteur de performance Objet SQL Server Fonctionnalités désapprouvées et des événements de suivi. Pour plus d'informations, consultez Utilisation d'objets SQL Server.

Fonctionnalités non prises en charge dans la prochaine version de SQL Server

Les fonctionnalités suivantes du Moteur de base de données SQL Server ne seront pas prises en charge dans la prochaine version de SQL Server. Évitez d'utiliser ces fonctionnalités dans vos nouveaux développements et modifiez dès que possible les applications qui y ont recours. La valeur Nom de la fonctionnalité apparaît dans les événements de suivi comme ObjectName et dans les compteurs de performance et sys.dm_os_performance_counters comme nom de l'instance. La valeur de l'ID de la fonctionnalité apparaît dans les événements de suivi comme ObjectId.

Catégorie | Fonctionnalité désapprouvée | Remplacement | Nom de la fonctionnalité | ID de la fonctionnalité
Sauvegarde et restauration | BACKUP { DATABASE | LOG } WITH PASSWORD | Aucune | BACKUP DATABASE ou LOG WITH PASSWORD | 104
Sauvegarde et restauration | BACKUP { DATABASE | LOG } WITH MEDIAPASSWORD | Aucune | BACKUP DATABASE ou LOG WITH MEDIAPASSWORD | 103
Sauvegarde et restauration | RESTORE { DATABASE | LOG } … WITH DBO_ONLY | RESTORE { DATABASE | LOG } … … WITH RESTRICTED_USER | RESTORE DATABASE ou LOG WITH DBO_ONLY | 101
Sauvegarde et restauration | RESTORE { DATABASE | LOG } WITH PASSWORD | Aucune | RESTORE DATABASE ou LOG WITH PASSWORD | 106
Sauvegarde et restauration | RESTORE { DATABASE | LOG } WITH MEDIAPASSWORD | Aucune | RESTORE DATABASE ou LOG WITH MEDIAPASSWORD | 105
Niveaux de compatibilité | niveau de compatibilité 80 et mise à niveau depuis la version 80 | Les niveaux de compatibilité sont uniquement disponibles pour les deux dernières versions. Pour plus d'informations sur les niveaux de compatibilité, consultez Niveau de compatibilité ALTER DATABASE (Transact-SQL). | Niveau de compatibilité 80 de la base de données | 107
Métadonnées | DATABASEPROPERTY | DATABASEPROPERTYEX | DATABASEPROPERTY | 38
Objets de base de données | Clause WITH APPEND sur les déclencheurs | Recréez la totalité du déclencheur. | CREATE TRIGGER WITH APPEND | 171
Options d'instance | Paramètre par défaut de l'option disallow results from triggers = 0 | Paramètre par défaut de l'option disallow results from triggers = 1 | sp_configure 'disallow results from triggers' | 172
Options de base de données | sp_dboption | ALTER DATABASE | sp_dboption | 77
Indicateurs de requête | Indicateur FASTFIRSTROW | OPTION (FAST n). | FASTFIRSTROW | 177
Serveurs distants | sp_addremotelogin sp_addserver sp_dropremotelogin sp_helpremotelogin sp_remoteoption | Remplacez les serveurs distants à l'aide de serveurs liés. | sp_addremotelogin sp_addserver sp_dropremotelogin sp_helpremotelogin sp_remoteoption | 70 69 71 72 73
Serveurs distants | @@remserver | Remplacez les serveurs distants à l'aide de serveurs liés. | Aucune | Aucune
Serveurs distants | SET REMOTE_PROC_TRANSACTIONS | Remplacez les serveurs distants à l'aide de serveurs liés. | SET REMOTE_PROC_TRANSACTIONS | 110
Sécurité | sp_dropalias | Remplacez les alias par une combinaison de comptes d'utilisateurs et de rôles de base de données. Utilisez sp_dropalias pour supprimer les alias dans les bases de données mises à niveau. | sp_dropalias | 68
SET, options | SET DISABLE_DEF_CNST_CHK | Aucune. L'option n'a pas d'effet. | SET DISABLE_DEF_CNST_CHK | 188
SET, options | SET ROWCOUNT pour les instructions INSERT, UPDATE et DELETE. | Mot clé TOP | SET ROWCOUNT | 109
Transact-SQL syntaxe | Utilisation de *= et =* | Utilisez la syntaxe de jointure ANSI. Pour plus d'informations, consultez FROM (Transact-SQL). | Opérateurs de jointure externe non ANSI (*= ou =*) | 178
Transact-SQL syntaxe | COMPUTE / COMPUTE BY | Utilisez ROLLUP. | COMPUTE [BY] | 180
Tables système | sys.database_principal_aliases | Utilisez les rôles à la place des alias. | database_principal_aliases | 150
Transact-SQL | La syntaxe RAISERROR (format : RAISERROR entier chaîne) est désapprouvée. | Réécrivez l'instruction en utilisant la syntaxe RAISERROR actuelle. | RAISEERROR (style précédent) | 164
Autres | DB-Library Embedded SQL for C | Bien que le Moteur de base de données prenne toujours en charge les connexions des applications existantes qui utilisent les API DB-Library et Embedded SQL, il n'inclut pas les fichiers ou la documentation nécessaires aux tâches de programmation dans les applications qui utilisent ces API. Une version future du Moteur de base de données SQL Server n'intègrera plus la prise en charge des connexions à partir des applications DB-Library ou Embedded SQL. N'utilisez pas DB-Library ni Embedded SQL pour développer de nouvelles applications. Supprimez toutes les dépendances à DB-Library ou à Embedded SQL lorsque vous modifiez les applications existantes. À la place de ces API, utilisez l'espace de noms SQLClient ou une API telle que OLE DB ou ODBC. SQL Server 2008 n'inclut pas la DLL DB-Library requise pour exécuter ces applications. Pour exécuter les applications DB-Library ou Embedded SQL, vous devez utiliser la DLL DB-Library à partir de SQL Server 6.5, SQL Server 7.0 ou SQL Server 2000. | Aucune | Aucune

Fonctionnalités non prises en charge dans une future version de SQL Server

Les fonctionnalités suivantes du Moteur de base de données SQL Server seront prises en charge dans la prochaine version de SQL Server, mais seront supprimées dans une version ultérieure. La version spécifique de SQL Server n'a pas été déterminée.

Catégorie Fonctionnalité désapprouvée Remplacement Nom de la fonctionnalité ID de la fonctionnalité

Niveaux de compatibilité

sp_dbcmptlevel

ALTER DATABASE … SET COMPATIBILITY_LEVEL. Pour plus d'informations, consultez Niveau de compatibilité ALTER DATABASE (Transact-SQL).

sp_dbcmptlevel

80

Niveaux de compatibilité

Niveau de compatibilité 90 de la base de données

Projetez de mettre à niveau la base de données et l'application avant la prochaine version.

Niveau de compatibilité 90 de la base de données

108

XML

Génération de schéma XDR en ligne

La directive XMLDATA de l'option FOR XML est désapprouvée. Utilisez la génération XSD en mode RAW et AUTO. Il n'existe aucune solution de remplacement pour la directive XMLDATA en mode EXPLICIT.

XMLDATA

181

Sauvegarde et restauration

BACKUP { DATABASE | LOG } TO TAPE

BACKUP { DATABASE | LOG } TO device_that_is_a_tape

BACKUP { DATABASE | LOG } TO DISK

BACKUP { DATABASE | LOG } TO device_that_is_a_disk

BACKUP DATABASE ou LOG TO TAPE

235

Sauvegarde et restauration

sp_addumpdevice 'tape'

sp_addumpdevice 'disk'

ADDING TAPE DEVICE

236

Sauvegarde et restauration

sp_helpdevice

sys.backup_devices

sp_helpdevice

100

Classements

Korean_Wansung_Unicode

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

Aucune Ces classements existent dans SQL Server 2005, mais ne sont pas visibles via fn_helpcollations.

Korean_Wansung_Unicode

Lithuanian_Classic

SQL_AltDiction_CP1253_CS_AS

191

192

194

Classements

Hindi

Macedonian

Ces classements existent dans SQL Server 2005 et versions ultérieures, mais ne sont pas visibles via fn_helpcollations. Utilisez à la place Macedonian_FYROM_90 et Indic_General_90.

Hindi

Macedonian

190

193

Classements

Azeri_Latin_90

Azeri_Cyrilllic_90

Azeri_Latin_100

Azeri_Cyrilllic_100

Azeri_Latin_90

Azeri_Cyrilllic_90

232

233

Configuration

SET ANSI_NULLS OFF et option de base de données ANSI_NULLS OFF

SET ANSI_PADDING OFF et option de base de données ANSI_PADDING OFF

SET CONCAT_NULL_YIELDS_NULL OFF et option de base de données CONCAT_NULL_YIELDS_NULL OFF

SET OFFSETS

Aucune.

ANSI_NULLS, ANSI_PADDING et CONCAT_NULLS_YIELDS_NULL sont toujours définies avec la valeur ON. SET OFFSETS ne sera pas disponible.

SET ANSI_NULLS OFF

SET ANSI_PADDING OFF

SET CONCAT_NULL_YIELDS_NULL OFF

SET OFFSETS

ALTER DATABASE SET ANSI_NULLS OFF

ALTER DATABASE SET ANSI_PADDING OFF

ALTER DATABASE SET CONCAT_NULL_YIELDS_NULL OFF

SET, options

Connexions

Le fournisseur SQLOLEDB n'est pas pris en charge.

Utilisez SQL Server Native Client pour les connexions ad hoc.

OLEDB pour les connexions ad hoc

32

Types de données

sp_addtype

sp_droptype

CREATE TYPE

DROP TYPE

sp_addtype

sp_droptype

62

63

Types de données

Syntaxe de timestamp pour le type de données rowversion

Syntaxe du type de données rowversion

TIMESTAMP

158

Type de données

Possibilité d'insérer des valeurs NULL dans les colonnes timestamp.

Utilisez DEFAULT à la place.

INSERT NULL dans les colonnes TIMESTAMP

179

Types de données

Option de table 'text in row'

Utilisez les types de données varchar(max), nvarchar(max) et varbinary(max). Pour plus d'informations, consultez sp_tableoption (Transact-SQL).

Option de table text in row

9

Types de données

Types de données :

  • text

  • ntext

  • image

Utilisez les types de données varchar(max), nvarchar(max), et varbinary(max).

Types de données : text, ntext ou image.

4

Gestion de base de données

sp_attach_db

sp_attach_single_file_db

Instruction CREATE DATABASE avec l'option FOR ATTACH. Pour recréer plusieurs fichiers journaux, lorsqu'un ou plusieurs d'entre eux possèdent un nouvel emplacement, utilisez FOR ATTACH_REBUILD_LOG.

sp_attach_db

sp_attach_single_file_db

81

82

Objets de base de données

CREATE DEFAULT

DROP DEFAULT

sp_bindefault

sp_unbindefault

Mot clé DEFAULT dans CREATE TABLE et ALTER TABLE

CREATE_DROP_DEFAULT

sp_bindefault

sp_unbindefault

162

64

65

Objets de base de données

CREATE RULE

DROP RULE

sp_bindrule

sp_unbindrule

Mot clé CHECK dans CREATE TABLE et ALTER TABLE

CREATE_DROP_RULE

sp_bindrule

sp_unbindrule

161

66

67

Objets de base de données

sp_change_users_login

Utilisez ALTER USER.

sp_change_users_login

Aucune

Objets de base de données

sp_depends

sys.dm_sql_referencing_entities et sys.dm_sql_referenced_entities

sp_depends

195

Objets de base de données

sp_renamedb

MODIFY NAME dans ALTER DATABASE.

sp_renamedb

79

Objets de base de données

sp_getbindtoken

Utilisez MARS ou les transactions distribuées.

sp_getbindtoken

98

Options de base de données

sp_bindsession

Utilisez MARS ou les transactions distribuées.

sp_bindsession

97

Options de base de données

sp_resetstatus

ALTER DATABASE SET { ONLINE | EMERGENCY }

sp_resetstatus

83

Options de base de données

Option TORN_PAGE_DETECTION de ALTER DATABASE

Option PAGE_VERIFY TORN_PAGE DETECTION de ALTER DATABASE

ALTER DATABASE WITH TORN_PAGE_DETECTION

102

DBCC

DBCC DBREINDEX

Option REBUILD de ALTER INDEX.

DBCC DBREINDEX

11

DBCC

DBCC INDEXDEFRAG

Option REORGANIZE de ALTER INDEX

DBCC INDEXDEFRAG

18

DBCC

DBCC SHOWCONTIG

sys.dm_db_index_physical_stats

DBCC SHOWCONTIG

10

DBCC

DBCC PINTABLE

DBCC UNPINTABLE

Cette option n'a aucun effet.

DBCC [UN]PINTABLE

189

Propriétés étendues

Level0type = 'type' et Level0type = 'USER' pour ajouter des propriétés étendues aux objets de type de niveau 1 ou 2.

Utilisez Level0type = 'USER' uniquement pour ajouter une propriété étendue directement à un utilisateur ou un rôle.

Utilisez Level0type = 'SCHEMA' pour ajouter une propriété étendue aux types level-1 comme TABLE ou VIEW ou aux types level-2 comme COLUMN ou TRIGGER. Pour plus d'informations, consultez sp_addextendedproperty (Transact-SQL).

EXTPROP_LEVEL0TYPE

EXTPROP_LEVEL0USER

13

14

Programmation des procédures stockées étendues

srv_alloc

srv_convert

srv_describe

srv_getbindtoken

srv_got_attention

srv_message_handler

srv_paramdata

srv_paraminfo

srv_paramlen

srv_parammaxlen

srv_paramname

srv_paramnumber

srv_paramset

srv_paramsetoutput

srv_paramstatus

srv_paramtype

srv_pfield

srv_pfieldex

srv_rpcdb

srv_rpcname

srv_rpcnumber

srv_rpcoptions

srv_rpcowner

srv_rpcparams

srv_senddone

srv_sendmsg

srv_sendrow

srv_setcoldata

srv_setcollen

srv_setutype

srv_willconvert

srv_wsendmsg

Utilisez l'intégration du CLR à la place.

XP_API

20

Programmation des procédures stockées étendues

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

Utilisez l'intégration du CLR à la place.

sp_addextendedproc

sp_dropextendedproc

sp_helpextendedproc

94

95

96

Procédures stockées étendues

xp_grantlogin

xp_revokelogin

xp_loginConfig

Utiliser CREATE_LOGIN

Utiliser l'argument DROP LOGIN IsIntegratedSecurityOnly de SERVERPROPERTY

xp_grantlogin

xp_revokelogin

xp_loginconfig

44

45

59

Fonctions

fn_get_sql

sys.dm_exec_sql_text

fn_get_sql

151

Options d'index

sp_indexoption

ALTER INDEX

sp_indexoption

78

Options d'index

Syntaxe CREATE TABLE, ALTER TABLE ou CREATE INDEX sans parenthèses autour des options.

Réécrivez l'instruction de manière à utiliser la syntaxe actuelle.

INDEX_OPTION

33

Objets de base de données

Possibilité de retourner les jeux de résultats à partir de déclencheurs

Aucune

Le déclencheur retourne des résultats

12

Options d'instance

option sp_configure 'allow updates'

Les tables système ne peuvent plus être mises à jour. La valeur n'a pas d'effet.

sp_configure allow updates'

173

Options d'instance

Options sp_configure :

  • 'locks'

  • 'open objects'

  • 'set working set size'

Désormais configuré automatiquement. La valeur n'a pas d'effet.

sp_configure 'locks'

sp_configure 'open objects'

sp_configure 'set working set size'

174

175

176

Options d'instance

Options sp_configure 'user instances enabled'

N'est plus nécessaire car SQL Server Compact 3.5 SP1 fournit la fonctionnalité nécessaire. La valeur n'a pas d'effet.

Aucune

Aucune

Options d'instance

Option sp_configure 'priority boost'

Les tables système ne peuvent plus être mises à jour. La valeur n'a pas d'effet.

sp_configure 'priority boost'

199

Options d'instance
  • Option sp_configure 'remote proc trans'

Les tables système ne peuvent plus être mises à jour. La valeur n'a pas d'effet.

sp_configure 'remote proc trans'

37

Serveurs liés

Un serveur lié utilise OLEDB.

Utilisation d'OLEDB pour les serveurs liés

19

Verrouillage

sp_lock

Interrogez sys.dm_tran_locks

sp_lock

99

Messagerie

SQL Mail

Messagerie de base de données

SQLMail

Messagerie

Métadonnées

FILE_ID

INDEXKEY_PROPERTY

FILE_IDEX

sys.index_columns

FILE_ID

INDEXKEY_PROPERTY

15

17

Services Web XML natifs

Instruction CREATE ENDPOINT ou ALTER ENDPOINT avec l'option FOR SOAP.

EXT_endpoint_webmethods

EXT_soap_endpoints

Utilisez à la place WFC (Windows Communications Foundation) ou ASP.NET.

EXT_CREATE_ALTER_SOAP_ENDPOINT

EXT_endpoint_webmethods

EXT_soap_endpoints

21

22

23

Programmabilité

(SQL-DMO SQL Server Database Management Objects)

SQL Server Management Objects (SMO)

SQL-DMO (SQL Server Database Management Objects) a été supprimé de SQL Server 2008 Express Edition et le sera dans les autres éditions.

Nous vous recommandons de modifier le plus tôt possible les applications qui utilisent actuellement cette fonction. Si vous devez assurer la prise en charge de SQL-DMO pour SQL Server Express, installez les composants de compatibilité descendante à partir du pack de fonctionnalités SQL Server 2005 du Centre de téléchargement Microsoft. N'utilisez pas SQL-DMO dans les nouveaux travaux de développement ; utilisez plutôt SMO (SQL Server Management Objects). Vous pouvez obtenir la documentation de SMO en installant la documentation en ligne de SQL Server 2005.

Aucune

Bases de données supprimables
  • sp_certify_removable

  • sp_create_removable

sp_detach_db

sp_certify_removable

sp_create_removable

74

75

Bases de données supprimables

sp_dbremove

DROP DATABASE

sp_dbremove

76

Sécurité

Syntaxe ALTER LOGIN WITH SET CREDENTIAL

Remplacée par la nouvelle syntaxe ALTER LOGIN ADD et DROP CREDENTIAL

ALTER LOGIN WITH SET CREDENTIAL

230

Sécurité

sp_addapprole

sp_dropapprole

CREATE APPLICATION ROLE

DROP APPLICATION ROLE

sp_addapprole

sp_dropapprole

53

54

Sécurité

sp_addlogin

sp_droplogin

CREATE LOGIN

DROP LOGIN

sp_addlogin

sp_droplogin

39

40

Sécurité

sp_adduser

sp_dropuser

CREATE USER

DROP USER

sp_adduser

sp_dropuser

49

50

Sécurité

sp_grantdbaccess

sp_revokedbaccess

CREATE USER

DROP USER

sp_grantdbaccess

sp_revokedbaccess

51

52

Sécurité

sp_addrole

sp_droprole

CREATE ROLE

DROP ROLE

sp_addrole

sp_droprole

56

57

Sécurité

sp_approlepassword

sp_password

ALTER APPLICATION ROLE

ALTER LOGIN

sp_approlepassword

sp_password

55

46

Sécurité

sp_changeobjectowner

ALTER SCHEMA ou ALTER AUTHORIZATION

sp_changeobjectowner

58

Sécurité

sp_defaultdb

sp_defaultlanguage

ALTER LOGIN

sp_defaultdb

sp_defaultlanguage

47

48

Sécurité

sp_denylogin

sp_grantlogin

sp_revokelogin

ALTER LOGIN DISABLE

CREATE LOGIN

DROP LOGIN

sp_denylogin

sp_grantlogin

sp_revokelogin

42

41

43

Sécurité

USER_ID

DATABASE_PRINCIPAL_ID

USER_ID

16

Sécurité

sp_srvrolepermission

sp_dbfixedrolepermission

Ces procédures stockées renvoient des informations qui étaient correctes dans SQL Server 2000. Le résultat ne reflète pas les modifications apportées aux hiérarchies d'autorisations implémentées dans SQL Server 2008. Pour plus d'informations, consultez Autorisations des rôles serveur fixes (moteur de base de données).

sp_srvrolepermission

sp_dbfixedrolepermission

61

60

Sécurité

GRANT ALL

DENY ALL

REVOKE ALL

Autorisations spécifiques GRANT, DENY et REVOKE.

Autorisation ALL

35

Sécurité

Fonction intrinsèque PERMISSIONS

Interrogez à la place sys.fn_my_permissions.

PERMISSIONS

170

Sécurité

SETUSER

EXECUTE AS

SETUSER

165

Classes SMO

Classe Microsoft.SQLServer.Management.Smo.Information

Classe Microsoft.SQLServer.Management.Smo.Settings

Classe Microsoft.SQLServer.Management.Smo.DatabaseOptions

Propriété Microsoft.SqlServer.Management.Smo.DatabaseDdlTrigger.NotForReplication

Classe Microsoft.SqlServer.Management.Smo.Server

Classe Microsoft.SqlServer.Management.Smo.Server

Classe Microsoft.SqlServer.Management.Smo.Database

Aucune

Aucune

Aucune

Agent SQL Server

Notification net send

Notification par radiomessagerie

Sous-système ActiveX

Notification par courrier électronique

Notification par courrier électronique

Scripts Command ou PowerShell

Aucune

Aucune

SQL Server Management Studio

Intégration de l'Explorateur de solutions dans SQL Server Management Studio

Intégration du contrôle de code source dans SQL Server Management Studio

Aucune

Aucune

Tables système

sysaltfiles

syscacheobjects

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

Vues de compatibilité. Pour plus d'informations, consultez Vues de compatibilité (Transact-SQL).

Important :
Les vues de compatibilité n'exposent pas les métadonnées des fonctionnalités introduites dans SQL Server 2005. Il est recommandé de mettre à niveau les applications pour pouvoir utiliser les affichages catalogue. Pour plus d'informations, consultez Affichages catalogue (Transact-SQL).

sysaltfiles

syscacheobjects

syscolumns

syscomments

sysconfigures

sysconstraints

syscurconfigs

sysdatabases

sysdepends

sysdevices

sysfilegroups

sysfiles

sysforeignkeys

sysfulltextcatalogs

sysindexes

sysindexkeys

syslockinfo

syslogins

sysmembers

sysmessages

sysobjects

sysoledbusers

sysopentapes

sysperfinfo

syspermissions

sysprocesses

sysprotects

sysreferences

sysremotelogins

sysservers

systypes

sysusers

141

152

Aucune

133

126

146

131

147

142

123

144

128

127

130

122

132

134

Aucune

143

140

119

137

125

139

145

157

121

153

120

129

138

136

135

124

Tables système

sys.numbered_procedures

sys.numbered_procedure_parameters

Aucune

numbered_procedures

numbered_procedure_parameters

148

149

Fonctions système

fn_virtualservernodes

fn_servershareddrives

SELECT FROM sys.dm_os_cluster_nodes

SELECT FROM sys.dm_io_cluster_shared_drives

fn_virtualservernodes

fn_servershareddrives

155

156

Vues système

sys.sql_dependencies

sys.sql_expression_dependencies

sys.sql_dependencies

196

Compression de table

Utilisation du format de stockage vardecimal.

Le format de stockage vardecimal est désapprouvé. La compression de données SQL Server 2008 compresse les valeurs décimales ainsi que d'autres types de données. Nous vous recommandons d'utiliser la compression de données au lieu du format de stockage vardecimal.

Format de stockage vardecimal

200

Compression de table

Utilisation de la procédure sp_db_vardecimal_storage_format.

Le format de stockage vardecimal est désapprouvé. La compression de données SQL Server 2008 compresse les valeurs décimales ainsi que d'autres types de données. Nous vous recommandons d'utiliser la compression de données au lieu du format de stockage vardecimal.

sp_db_vardecimal_storage_format

201

Compression de table

Utilisation de la procédure sp_estimated_rowsize_reduction_for_vardecimal.

Utilisez à la place la compression de données et la procédure sp_estimate_data_compression_savings.

sp_estimated_rowsize_reduction_for_vardecimal

202

Indicateurs de table

Spécification de NOLOCK ou READUNCOMMITTED dans la clause FROM d'une instruction UPDATE ou DELETE.

Supprimez les indicateurs de table NOLOCK ou READUNCOMMITTED de la clause FROM.

NOLOCK ou READUNCOMMITTED dans UPDATE ou DELETE

Aucune

Indicateurs de table

Spécification des indicateurs de table sans utilisation du mot clé WITH.

Utilisez WITH.

Indicateur de table sans WITH

8

Indicateurs de table

Indicateur de table HOLDLOCK sans parenthèses

167

Indicateurs de table

INSERT_HINTS

34

Pointeurs de texte

WRITETEXT

UPDATETEXT

READTEXT

Aucune

UPDATETEXT ou WRITETEXT

READTEXT

115

114

Pointeurs de texte

TEXTPTR()

TEXTVALID()

Aucune

TEXTPTR

TEXTVALID

5

6

Transact-SQL

Séquence d'appel de fonction ::

Remplacée par SELECT column_list FROM sys.<function_name>().

Par exemple, remplacez SELECT * FROM ::fn_virtualfilestats(2,1) par SELECT * FROM sys.fn_virtualfilestats(2,1).

Syntaxe d'appel de fonction '::'

166

Transact-SQL

Références de colonnes en 3 et 4 parties dans la liste SELECT

Noms en 2 parties dans le fonctionnement standard.

Nom de colonne à plus de deux parties

3

Transact-SQL

Une chaîne entre guillemets utilisée en tant qu'alias de colonne pour une expression dans une liste SELECT :

'string_alias' = expression

expression [AS] column_alias

expression [AS] [column_alias]

expression [AS] "column_alias"

expression [AS] 'column_alias'

column_alias = expression

Littéraux de chaîne comme alias de colonne

184

Transact-SQL

Procédures numérotées

Aucune. À ne pas utiliser.

ProcNums

160

Transact-SQL

Syntaxe table_name.index_name dans DROP INDEX

Syntaxe index_name ON table_name dans DROP INDEX.

DROP INDEX avec nom en deux parties

163

Transact-SQL

Pas d'instructions Transact-SQL se terminant avec un point-virgule.

Terminez les instructions Transact-SQL avec un point-virgule (;).

Aucune

Aucune

Transact-SQL

GROUP BY ALL

Utilisez la solution personnalisée cas par cas avec UNION ou une table dérivée.

GROUP BY ALL

169

Transact-SQL

ROWGUIDCOL comme nom de colonne dans les instructions DML.

Utilisez $rowguid.

ROWGUIDCOL

182

Transact-SQL

IDENTITYCOL comme nom de colonne dans les instructions DML.

Utilisez $identity.

IDENTITYCOL

183

Transact-SQL

Utilisation de #, ## comme table temporaire et noms de procédure stockée temporaires.

Utilisez au moins un caractère supplémentaire.

'#' et '##' comme nom des tables temporaires et procédures stockées

Aucune

Transact-SQL

Utilisation de @, @@ ou @@ comme identificateurs Transact-SQL.

N'utilisez pas @, @@ ou des noms commençant par @@ comme identificateurs.

'@' et noms commençant par '@@' comme identificateurs Transact-SQL

Aucune.

Transact-SQL

Utilisation du mot clé DEFAULT comme valeur par défaut.

N'utilisez pas le mot DEFAULT comme valeur par défaut.

Mot clé DEFAULT comme valeur par défaut

187

Transact-SQL

Utilisation d'un espace comme séparateur entre les indicateurs de table.

Utilisez une virgule pour séparer les indicateurs de table.

Indicateurs de table multiples sans virgule

168

Transact-SQL

La liste de sélection d'une vue indexée d'agrégation doit contenir COUNT_BIG (*) dans le mode de compatibilité 90.

Utilisez COUNT_BIG (*).

Liste de sélection de vue d'index sans COUNT_BIG (*)

2

Transact-SQL

Application indirecte des indicateurs de table à un appel d'une fonction table à plusieurs instructions via une vue.

Aucune

Indicateurs de fonctions table indirects

7

Transact-SQL

Syntaxe ALTER DATABASE :

MODIFY FILEGROUP READONLY

MODIFY FILEGROUP READWRITE

MODIFY FILEGROUP READ_ONLY

MODIFY FILEGROUP READ_WRITE

MODIFY FILEGROUP READONLY

MODIFY FILEGROUP READWRITE

195

196

Voir aussi

Référence

Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008


Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008

Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server >

Cette rubrique décrit les fonctionnalités du Moteur de base de données qui ne sont plus disponibles dans SQL Server 2008.

Catégorie | Fonctionnalité supprimée | Remplacement
Alias | sp_addalias | Remplacez les alias par une combinaison de comptes d'utilisateurs et de rôles de base de données. Pour plus d'informations, consultez CREATE USER (Transact-SQL) et CREATE ROLE (Transact-SQL). Supprimez les alias dans les bases de données mises à niveau à l'aide de sp_dropalias.
API | API de serveurs inscrits | Remplacée par une nouvelle API de serveurs inscrits qui prend en charge les nouvelles fonctionnalités de SQL Server 2008.
Sauvegarde et restauration | Instruction DUMP | BACKUP
Sauvegarde et restauration | Instruction LOAD | RESTORE
Sauvegarde et restauration | BACKUP LOG WITH NO_LOG | Aucune. Le journal des transactions est tronqué automatiquement si la base de données utilise le mode de récupération simple. Si vous devez supprimer la chaîne de sauvegarde de fichier journal d'une base de données, activez le mode de récupération simple.
Sauvegarde et restauration | BACKUP LOG WITH TRUNCATE_ONLY | Aucune. Le journal des transactions est tronqué automatiquement si la base de données utilise le mode de récupération simple. Si vous devez supprimer la chaîne de sauvegarde de fichier journal d'une base de données, activez le mode de récupération simple.
Sauvegarde et restauration | BACKUP TRANSACTION | BACKUP LOG
Niveau de compatibilité | Niveaux de compatibilité 60, 65 et 70 | Les bases de données doivent être définies au moins au niveau de compatibilité 80.
DBCC | DBCC CONCURRENCYVIOLATION | Aucune
Groupes | sp_addgroup | Utilisez des rôles.
Groupes | sp_changegroup | Utilisez des rôles.
Groupes | sp_dropgroup | Utilisez des rôles.
Groupes | sp_helpgroup | Utilisez des rôles.
Bases de données exemple | Northwind et pubs | Utilisez AdventureWorks. Northwind et pubs sont disponibles comme téléchargements ou peuvent être copiés à partir d'une installation précédente de SQL Server. Pour plus d'informations, consultez Exemples de bases de données AdventureWorks.
Outils | Outil Configuration de la surface d'exposition | L'outil Configuration de la surface d'exposition a été supprimé dans SQL Server 2008. Pour plus d'informations, consultez Compatibilité ascendante.
Assistant Web | sp_makewebtask sp_dropwebtask sp_runwebtask sp_enumcodepages | Nous vous recommandons d'utiliser à la place SQL Server Reporting Services.

Voir aussi

Référence

Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008


Changements essentiels dans les fonctionnalités du moteur de base de données de SQL Server 2008

Changements essentiels dans les fonctionnalités du moteur de base de données de SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server >

Cette rubrique décrit les changements importants apportés au Moteur de base de données. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Classements

Fonctionnalité Description

Nouveaux classements

SQL Server 2008 introduit de nouveaux classements qui sont en alignement complet avec les classements fournis par Windows Server 2008. Ces 80 nouveaux classements présentent une précision linguistique améliorée et sont dénotés par des références de version *_100. Si vous choisissez un nouveau classement pour votre serveur ou base de données, gardez à l'esprit que le classement peut ne pas être reconnu par les clients équipés de pilotes clients plus anciens. En raison des classements non reconnus, l'application peut retourner des erreurs et échouer. Envisagez les solutions suivantes :

  • Mettez à niveau le système d'exploitation du client afin de mettre aussi à jour les classements du système sous-jacent.

  • Si le client est équipé du logiciel client de base de données, envisagez de lui appliquer une mise à jour du service.

  • Choisissez un classement existant qui établit un mappage à une page de codes du client.

Pour plus d'informations, consultez Définition et modification des classements.

CLR (Common Language Runtime)

Fonctionnalité Description

Assemblys CLR

Lorsqu'une base de données est mise à niveau vers SQL Server 2008, l'assembly Microsoft.SqlServer.Types destiné à prendre en charge de nouveaux types de données est automatiquement installé. Les règles du Conseiller de mise à niveau détectent tout type d'utilisateur ou assembly avec des noms en conflit. Le Conseiller de mise à niveau recommandera de renommer tout assembly incompatible, et de renommer tout type en conflit ou d'utiliser des noms en deux parties dans le code pour faire référence à ce type d'utilisateur préexistant.

Si une mise à niveau de base de données détecte un assembly utilisateur avec un nom en conflit, elle renommera automatiquement cet assembly et placera la base de données en mode suspect.

Si un type d'utilisateur avec un nom en conflit existe pendant la mise à niveau, aucune étape spéciale n'est suivie. Après la mise à niveau, l'ancien type d'utilisateur et le nouveau type de système existeront tous deux. Le type d'utilisateur sera disponible uniquement en utilisant des noms en deux parties.

Assemblys CLR

SQL Server 2008 installe .NET Framework 3.5 SP1, qui met à jour les bibliothèques dans le GAC (Global Assembly Cache). Si des bibliothèques non prises en charge sont inscrites dans une base de données SQL Server, votre application SQL Server peut cesser de fonctionner après la mise à niveau vers SQL Server 2008. Cela est dû au fait que la maintenance ou la mise à niveau de bibliothèques dans le GAC ne met pas à jour les assemblys à l'intérieur de SQL Server. Si un assembly existe dans une base de données SQL Server et dans le GAC, les deux copies de l'assembly doivent être exactement les mêmes. Si ce n'est pas le cas, une erreur se produit lorsque l'assembly est utilisé par l'intégration du CLR SQL Server. Pour plus d'informations, consultez Supported .NET Framework Libraries.

Après la mise à niveau de votre base de données, effectuez la maintenance ou la mise à niveau de la copie de l'assembly à l'intérieur de vos bases de données SQL Server avec l'instruction ALTER ASSEMBLY. Pour plus d’informations, consultez l'article 949080 de la Base de connaissances.

Exécutez la requête suivante dans votre base de données pour détecter si vous utilisez une bibliothèque .NET Framework non prise en charge dans votre application.

Copier le code
SELECT name FROM sys.assemblies WHERE clr_name LIKE '%publickeytoken=b03f5f7f11d50a3a,%';

Vues de gestion dynamique

Vue | Description
sys.dm_os_sys_info | Suppression des colonnes cpu_ticks_in_ms et sqlserver_start_time_cpu_ticks.
sys.dm_exec_query_resource_semaphores sys.dm_exec_query_memory_grants | La colonne resource_semaphore_id n'est pas un ID unique dans SQL Server 2008. Cette modification peut affecter l'exécution de la requête de résolution des problèmes. Pour plus d'informations, consultez sys.dm_exec_query_resource_semaphores (Transact-SQL).

Erreurs et événements

Caractéristique | Description
Erreurs de connexion | Dans SQL Server 2005, l'erreur 18452 est retournée lorsqu'une connexion SQL est utilisée pour la connexion à un serveur configuré pour utiliser uniquement l'authentification Windows. Dans SQL Server 2008, l'erreur 18456 est retournée à la place.

Plan d'exécution de requêtes

Caractéristique Description

Schéma du plan d'exécution XML

Un nouvel élément SeekPredicateNew est ajouté au schéma du plan d'exécution XML et la séquence xsd englobante (SqlPredicatesType) est convertie en élément <xsd:choice>. À la place d'un ou de plusieurs éléments SeekPredicate, un ou plusieurs éléments SeekPredicateNew peuvent à présent s'afficher dans le plan d'exécution XML. Les deux éléments s'excluent mutuellement. L'élément SeekPredicate est conservé dans le schéma du plan d'exécution XML pour la compatibilité descendante ; toutefois, les plans de requêtes créés dans SQL Server 2008 peuvent contenir l'élément SeekPredicateNew. Les applications qui s'attendent à récupérer uniquement l'enfant SeekPredicate à partir du nœud ShowPlanXML/BatchSequence/Batch/Statements/StmtSimple/QueryPlan/RelOp/IndexScan/SeekPredicates peuvent échouer si l'élément SeekPredicate n'existe pas. Écrivez à nouveau l'application pour qu'elle attende l'élément SeekPredicate ou SeekPredicateNew dans ce nœud. Pour plus d'informations, consultez Améliorations du traitement des requêtes sur les tables et les index partitionnés.

Schéma du plan d'exécution XML

Un nouvel attribut IndexKind est ajouté au type complexe ObjectType dans le schéma du plan d'exécution XML. Les applications qui valident de façon stricte les plans SQL Server retournés par rapport au schéma SQL Server 2005 échouent.

Transact-SQL

Caractéristique Description

Événement DDL ALTER_AUTHORIZATION_DATABASE

Dans SQL Server 2005, lorsque l'événement DDL ALTER_AUTHORIZATION_DATABASE est déclenché, la valeur « object » est retournée dans l'élément ObjectType du fichier EVENTDATA xml pour cet événement lorsque le type d'entité de l'élément sécurisable dans l'opération de langage de définition de données (DDL) est un objet. Dans SQL Server 2008, le type réel (par exemple, « table » ou « function ») est retourné.

CONVERT

Si un style non valide est passé à la fonction CONVERT, une erreur est retournée lorsque la conversion est de type binaire à caractère ou caractère à binaire. Dans les versions antérieures de SQL Server, le style non valide est défini sur le style par défaut pour les conversions binaire à caractère et caractère à binaire.

GRANT/DENY/REVOKE EXECUTE sur les assemblys

L'autorisation EXECUTE ne peut pas être accordée, révoquée ou refusée sur les assemblys. Cette autorisation n'a aucun effet et provoque à présent une erreur. Accordez, refusez ou révoquez une autorisation EXECUTE sur les procédures stockées ou fonctions qui font plutôt référence à la méthode d'assembly.

Autorisations GRANT/DENY/REVOKE sur les types de systèmes

Les autorisations ne peuvent pas être accordées, révoquées ou refusées sur les types de systèmes. Dans les versions antérieures de SQL Server, ces instructions sont correctement exécutées, mais n'ont aucun effet. Dans SQL Server 2008, une erreur est retournée.

Clause OUTPUT

Pour empêcher tout comportement non déterministe, la clause OUTPUT ne peut pas référencer une colonne d'une vue ou fonction table lorsque cette colonne est définie par l'une des méthodes suivantes :

  • Une sous-requête.

  • Une fonction définie par l'utilisateur qui offre un accès à des données utilisateur ou système, ou qui est supposée permettre d'y accéder.

  • Une colonne calculée qui contient une fonction définie par l'utilisateur qui offre un accès aux données utilisateur ou système dans sa définition.

Lorsque SQL Server détecte une telle colonne dans la clause OUTPUT, l'erreur 4186 est générée. Pour plus d'informations, consultez MSSQLSERVER_4186.

Clause OUTPUT INTO

La table cible de la clause OUTPUT INTO ne peut pas comporter de déclencheurs activés.

Indicateur de table READPAST

L'indicateur de table READPAST ne peut pas être spécifié quand l'option de base de données READ_COMMITTED_SNAPSHOT a la valeur ON et que l'une ou l'autre des conditions suivantes a la valeur True :

  • Le niveau d'isolation de la transaction de la session est READ COMMITTED.

  • L'indicateur READCOMMITTED de la table est également spécifié dans la requête.

Pour spécifier l'indicateur READPAST dans ces cas, supprimez l'indicateur de table READCOMMITTED s'il est présent et incorporez l'indicateur de table READCOMMITTEDLOCK dans la requête.

sp_helpuser

Les noms de colonnes suivants qui sont retournés dans le jeu de résultats de la procédure stockée sp_helpuser ont changé.

Nom de colonne précédent | Nouveau nom de colonne
GroupName | RoleName
Group_name | Role_name
Group_id | Role_id
Users_in_group | Users_in_role

Chiffrement transparent des données

Le chiffrement transparent des données est effectué au niveau d'E/S : la structure de page est non chiffrée en mémoire et chiffrée uniquement lorsque la page est écrite sur disque. Les fichiers de bases de données et les fichiers journaux sont tous deux chiffrés. Les applications tierces qui ignorent le mécanisme SQL Server standard pour accéder aux pages (par exemple, en analysant directement les fichiers de données ou journaux) échouent lorsqu'une base de données utilise le chiffrement transparent des données, car les données sont chiffrées dans les fichiers. De telles applications peuvent exploiter l'API de chiffrement Windows pour développer une solution pour déchiffrer les données à l'extérieur de SQL Server.

XQuery

Caractéristique Description

Prise en charge de la date et de l'heure

Dans SQL Server 2005, les types de données xs:time, xs:date et xs:dateTime n'ont pas de prise en charge de fuseau horaire. Les données de fuseau horaire sont mappées au fuseau horaire UTC. SQL Server 2008 présente un comportement conforme standard qui a pour conséquence les modifications suivantes :

  • Les valeurs sans fuseau horaire sont validées.

  • Le fuseau horaire fourni ou l'absence de fuseau horaire est un paramètre conservé.

  • La représentation de stockage interne est modifiée.

  • La résolution des valeurs stockées est augmentée.

  • Les années négatives ne sont pas autorisées.

Modifiez les applications et expressions XQuery pour prendre en compte les nouvelles valeurs de type. Pour plus d'informations, consultez Utilisation de XML avec les types de données time, date, datetime2 et datetimeoffset.

Voir aussi

Référence

Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008
Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008
Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008

Autres ressources

Compatibilité descendante du moteur de base de données SQL Server
Niveau de compatibilité ALTER DATABASE (Transact-SQL)


Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008

Changements de comportement des fonctionnalités du moteur de base de données de SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server >

Cette rubrique décrit les changements de comportement dans le Moteur de base de données. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Architecture du processeur de requêtes

SQL Server 2008 modifie la manière dont sont traitées les requêtes sur les tables partitionnées et les index. Les requêtes sur des objets partitionnés qui utilisent l'indicateur USE PLAN pour un plan généré par SQL Server 2005 peuvent contenir un plan non valide. Pour plus d'informations, consultez Considérations sur la mise à niveau du moteur de base de données. Pour plus d'informations sur le traitement des requêtes sur les objets partitionnés, consultez Améliorations du traitement des requêtes sur les tables et les index partitionnés.

Serveurs liés

SQL Server 2008 modifie la sémantique de transaction des instructions INSERT...EXECUTE qui s'exécutent sur un serveur lié en boucle. Dans SQL Server 2005, ce scénario n'est pas pris en charge et provoque une erreur. Dans SQL Server 2008, une instruction INSERT...EXECUTE peut s'exécuter sur un serveur lié en boucle lorsque MARS (Multiple Active Result Set) n'est pas activé sur la connexion. Lorsque MARS est activé sur la connexion, le comportement est le même que dans SQL Server 2005.

Base de données tempdb

Dans les versions antérieures de SQL Server, l'option de base de données PAGE_VERIFY est définie à NONE pour la base de données tempdb et ne peut pas être modifiée. Dans SQL Server 2008, la valeur par défaut pour la base de données tempdb est CHECKSUM pour les nouvelles installations de SQL Server. Lorsque vous mettez à niveau une installation SQL Server, la valeur par défaut reste NONE. Impossible de modifier l'option. Nous vous recommandons d'utiliser CHECKSUM pour la base de données tempdb.

Repères de plan

Dans SQL Server 2008, si un repère de plan ne peut pas être honoré, la requête est compilée à l'aide d'un plan différent et aucune erreur n'est retournée. Dans SQL Server 2005, une erreur est levée et la requête échoue.

Les repères de plan créés dans SQL Server 2005 peuvent ne pas être valides après une mise à niveau vers SQL Server 2008. Les repères de plan non valides n'entraînent pas l'échec de l'application, mais le repère de plan n'est pas utilisé. Il est recommandé de réévaluer et de tester les définitions des repères de plan lorsque vous mettez à niveau votre application vers une nouvelle version de SQL Server. Les contraintes liées au paramétrage des performances et le comportement de la mise en correspondance des repères de plan peuvent changer. Même si un repère de plan non valide n'entraîne pas l'échec d'une requête, le plan est compilé sans utiliser le repère de plan. Après avoir mis à niveau une base de données vers SQL Server 2008, effectuez les tâches suivantes pour valider des repères de plan existants à l'aide de la fonction sys.fn_validate_plan_guide. Vous pouvez aussi surveiller les repères de plan non valides en utilisant l'événement Plan Guide Unsuccessful dans SQL Server Profiler.

Requêtes de table partitionnées utilisant l'indicateur USE PLAN

SQL Server 2008 modifie la manière dont sont traitées les requêtes sur les tables partitionnées et les index. Les requêtes sur des objets partitionnés qui utilisent l'indicateur USE PLAN peuvent contenir un plan non valide. Nous recommandons les procédures suivantes après la mise à niveau vers SQL Server 2008.

Lorsque l'indicateur USE PLAN est spécifié directement dans une requête :

  1. Supprimez l'indicateur USE PLAN de la requête.

  2. Testez la requête.

  3. Si l'optimiseur ne sélectionne pas un plan approprié, réglez la requête, puis spécifiez l'indicateur USE PLAN avec le plan de requête désiré.

Lorsque l'indicateur USE PLAN conseil est spécifié dans un repère de plan :

  1. Utilisez la fonction sys.fn_validate_plan_guide pour vérifier la validité du repère de plan. Vous pouvez aussi surveiller les repères de plan non valides en utilisant l'événement Plan Guide Unsuccessful dans Générateur de profils SQL Server.

  2. Si le repère de plan n'est pas valide, supprimez-le. Si l'optimiseur ne sélectionne pas un plan approprié, réglez la requête, puis spécifiez l'indicateur USE PLAN avec le plan de requête désiré.

Pour plus d'informations sur le traitement des requêtes sur les objets partitionnés, consultez Améliorations du traitement des requêtes sur les tables et les index partitionnés.

Fonction REPLACE

Dans SQL Server 2005, les espaces de fin spécifiés dans les paramètres d'entrée de la fonction REPLACE sont supprimés. Dans SQL Server 2008, les espaces de fin sont conservés. Pour les applications qui comptent sur le comportement précédent de la fonction, utilisez la fonction RTRIM lors de la spécification des paramètres d'entrée pour la fonction. Par exemple, la syntaxe suivante supprime les espaces de fin de chaque paramètre d'entrée de la fonction REPLACE : REPLACE(RTRIM(input_parameter), RTRIM(input_parameter), RTRIM(input_parameter)).

Voir aussi

Référence

Changements essentiels dans les fonctionnalités du moteur de base de données de SQL Server 2008
Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008
Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008

Autres ressources

Compatibilité descendante du moteur de base de données SQL Server
Niveau de compatibilité ALTER DATABASE (Transact-SQL)


Compatibilité descendante de la recherche en texte intégral

Compatibilité descendante de la recherche en texte intégral |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server >

Les rubriques de la section relative à la compatibilité descendante décrivent les changements de comportement de la recherche en texte intégral entre SQL Server 2005 et SQL Server 2008.

Voir... | Pour les rubriques concernant
Fonctionnalités de la recherche en texte intégral désapprouvées dans SQL Server 2008 | Fonctionnalités de la recherche en texte intégral désapprouvées dans cette version.
Fonctionnalités de la recherche en texte intégral abandonnées dans SQL Server 2008 | Fonctionnalités de la recherche en texte intégral supprimées dans cette version.
Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008 | Changements de la recherche en texte intégral qui pourraient nécessiter des modifications dans les applications.
Modifications du comportement de la recherche en texte intégral dans SQL Server 2008 | Autres changements de comportement de la recherche en texte intégral.

Voir aussi

Autres ressources

Compatibilité descendante du moteur de base de données SQL Server


Fonctionnalités de la recherche en texte intégral désapprouvées dans SQL Server 2008

Fonctionnalités de la recherche en texte intégral désapprouvées dans SQL Server 2008 |
 | Voir aussi
Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server > Compatibilité descendante de la recherche en texte intégral >

Cette rubrique décrit les fonctionnalités de la recherche en texte intégral désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

Vous pouvez surveiller l'utilisation de fonctionnalités désapprouvées à l'aide du compteur de performance SQL Server:Deprecated Features et des événements de suivi. Pour plus d'informations, consultez Utilisation des objets SQL Server (en anglais).

Fonctionnalités non prises en charge dans la prochaine version de SQL Server

Aucune fonctionnalité de recherche en texte intégral ne sera abandonnée dans la prochaine version de SQL Server.

Fonctionnalités non prises en charge dans une future version de SQL Server

Les fonctionnalités suivantes de recherche en texte intégral sont prises en charge dans la prochaine version de SQL Server, mais seront supprimées dans une version ultérieure. La version spécifique de SQL Server n'a pas été déterminée.

La valeur Nom de la fonctionnalité apparaît dans les événements de suivi comme ObjectName et dans les compteurs de performance et sys.dm_os_performance_counters comme nom de l'instance. La valeur de l'ID de la fonctionnalité apparaît dans les événements de suivi comme ObjectId.

Catégorie Fonctionnalité désapprouvée Remplacement Nom de la fonctionnalité ID de la fonctionnalité

Recherche en texte intégral

Option CREATE FULLTEXT CATALOG :

IN PATH 'rootpath'

ON FILEGROUP filegroup

Aucune.

CREATE FULLTEXT CATLOG IN PATH

Aucune.*

237

Aucune.*

Recherche en texte intégral

Propriété DATABASEPROPERTYEX: IsFullTextEnabled

Aucune.

DATABASEPROPERTYEX('IsFullTextEnabled')

202

Recherche en texte intégral

Propriété FULLTEXTCATALOGPROPERTY :

  • LogSize

  • PopulateStatus

Aucune.

FULLTEXTCATALOGPROPERTY('LogSize')

FULLTEXTCATALOGPROPERTY('PopulateStatus')

211

201

Recherche en texte intégral

Propriété FULLTEXTSERVICEPROPERTY :

  • ConnectTimeout

  • DataTimeout

  • ResourceUsage

Aucune

FULLTEXTSERVICEPROPERTY('ConnectTimeout')

FULLTEXTSERVICEPROPERTY('DataTimeout')

FULLTEXTSERVICEPROPERTY('ResourceUsage')

210

209

208

Recherche en texte intégral

Options sp_configure :

  • ft crawl bandwidth

  • ft notify bandwidth

Aucune.

sp_configure 'ft crawl bandwidth (max)'

sp_configure 'ft crawl bandwidth (min)'

sp_configure 'ft notify bandwidth (max)'

sp_configure 'ft notify bandwidth (min)'

204

205

206

207

Recherche en texte intégral

Option sp_detach_db :

[ @keepfulltextindexfile = ] 'KeepFulltextIndexFile'

Aucune.

sp_detach_db @keepfulltextindexfile

226

Recherche en texte intégral

sp_fulltext_catalog

CREATE FULL CATALOG

ALTER FULLTEXT CATALOG

DROP FULLTEXT CATALOG

sp_fulltext_catalog

84

Recherche en texte intégral

sp_fulltext_column

sp_fulltext_database

sp_fulltext_table

CREATE FULL INDEX

ALTER FULLTEXT INDEX

DROP FULLTEXT INDEX

sp_fulltext_column

sp_fulltext_database

sp_fulltext_table

86

87

85

Recherche en texte intégral

sp_help_fulltext_catalogs

sp_help_fulltext_catalog_components

sp_help_fulltext_catalogs_cursor

sp_help_fulltext_columns

sp_help_fulltext_columns_cursor

sp_help_fulltext_tables

sp_help_fulltext_tables_cursor

sys.fulltext_catalogs

sys.fulltext_index_columns

sys.fulltext_indexes

sp_help_fulltext_catalogs

sp_help_fulltext_catalog_components

sp_help_fulltext_catalogs_cursor

sp_help_fulltext_columns

sp_help_fulltext_columns_cursor

sp_help_fulltext_table

sp_help_fulltext_tables_cursor

88

203

90

92

93

91

89

Recherche en texte intégral

Valeurs d'action sp_fulltext_service :

  • clean_up, connect_timeout et data_timeout return zero

  • resource_usage n'a aucune fonction.

Aucune
  • sp_fulltext_service @action=clean_up

  • sp_fulltext_service @action=connect_timeout

  • sp_fulltext_service @action=data_timeout

  • sp_fulltext_service @action=resource_usage

116

117

118

200

Recherche en texte intégral

Colonnes sys.dm_fts_active_catalogs :

  • is_paused

  • previous_status

  • previous_status_description

  • row_count_in_thousands

  • status

  • status_description

  • worker_count

Aucune.

dm_fts_active_catalogs.is_paused

dm_fts_active_catalogs.previous_status

dm_fts_active_catalogs.previous_status_description

dm_fts_active_catalogs.row_count_in_thousands

dm_fts_active_catalogs.status

dm_fts_active_catalogs.status_description

dm_fts_active_catalogs.worker_count

218

221

222

224

219

220

223

Recherche en texte intégral

Colonne sys.dm_fts_memory_buffers :

  • row_count

Aucune.

dm_fts_memory_buffers.row_count

225

Recherche en texte intégral

Colonnes sys.fulltext_catalogs :

  • path

  • data_space_id

  • Colonnes file_id

Aucune.

fulltext_catalogs.path

fulltext_catalogs.data_space_id

fulltext_catalogs.file_id

215

216

217

* L'objet SQL Server:Deprecated Fonctionnalités ne surveille pas les occurrences de filegroup CREATE FULLTEXT CATLOG ON FILEGROUP.

Voir aussi

Référence

Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008

Concepts

Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008

Autres ressources

Objet SQL Server Fonctionnalités désapprouvées


Fonctionnalités de la recherche en texte intégral abandonnées dans SQL Server 2008

Fonctionnalités de la recherche en texte intégral abandonnées dans SQL Server 2008 |
 | Voir aussi
Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server > Compatibilité descendante de la recherche en texte intégral >

Aucune fonctionnalité de recherche en texte intégral n'est supprimée dans SQL Server 2008, même si certaines ont été désapprouvées. Pour plus d'informations, consultez Fonctionnalités de la recherche en texte intégral désapprouvées dans SQL Server 2008.

Voir aussi

Référence

Fonctionnalités du moteur de base de données supprimées dans SQL Server 2008

Concepts

Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008
Modifications du comportement de la recherche en texte intégral dans SQL Server 2008


Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008

Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008 |
 | Voir aussi
Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server > Compatibilité descendante de la recherche en texte intégral >

Cette rubrique décrit les modifications importantes apportées à la recherche en texte intégral. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Dernières modifications

Voici les modifications importantes qui ont été apportées à la recherche en texte intégral dans SQL Server 2008.

Fonctionnalité Scénario SQL Server 2005 SQL Server 2008

CONTAINSTABLE avec types définis par l'utilisateur

La clé de texte intégral est un type défini par l'utilisateur SQL Server, par exemple MyType = char(1).

La clé retournée est du type assigné au type défini par l'utilisateur.

Dans l'exemple, il s'agirait de char(1).

La clé retournée est du type défini par l'utilisateur. Dans l'exemple, il s'agirait de MyType.

Paramètre top_n_by_rank (des instructions CONTAINSTABLE et Transact-SQL FREETEXTTABLE)

Requêtes top_n_by_rank qui utilisent 0 comme paramètre.

Échec avec un message d'erreur qui signale que vous devez utiliser une valeur supérieure à zéro.

Réussite, retourne des lignes nulles.

CONTAINSTABLE et ItemCount

Suppression de lignes de table de base avant de pousser les modifications vers MSSearch.

CONTAINSTABLE retourne un enregistrement fantôme. ItemCount n'est pas modifié.

CONTAINSTABLE ne retourne pas d'enregistrements fantômes.

ItemCount

La table contient des documents ou des colonnes de type Null.

En plus des documents indexés, les documents qui sont Null ou qui ont des types Null sont comptés dans la valeur ItemCount.

Seuls les documents indexés sont comptés dans la valeur ItemCount.

Catalogue ItemCount

Colonne blob avec une extension NULL.

Comptée dans ItemCount du catalogue

Non comptée dans ItemCount du catalogue

UniqueKeyCount

Interrogation d'un nombre de clés uniques d'un catalogue, par exemple deux tables (table1 et table2) chacune avec trois mots : word1, word2 et word3. UniqueKeyCount = 9.

UniqueKeyCount = 9. Le tableau suivant résume comment cette valeur est atteinte :

table1 = 3

EOF pour l'index de recherche en texte intégral de table1 = 1

table2 = 3

EOF pour l'index de recherche en texte intégral de table2 = 1

catalogue de texte intégral = 1

Pour chaque table, UniqueKeyCount est le nombre de mots clés distincts + 1 (0xFF). Cela ne traite PAS les mêmes mots dans > 1 doc comme nouvelle clé unique.

Pour un catalogue, UniqueKeyCount est la somme de UniqueKeyCount de chacune des tables sous le catalogue. Les mots identiques de tables différentes sont traités comme des clés uniques. Dans ce cas, le nombre de clés uniques est 8.

sp_fulltext_pendingchanges lors de la mise à jour d'une colonne clé

Mise à jour de la colonne clé de texte intégral sur une ligne d'une table de 2 lignes et exécution de sp_fulltext_pendingchanges.

Les deux lignes apparaissent.

Une seule ligne apparaît.

Fonctions inline

Fonctions inline avec un opérateur de texte intégral

Retournent un message d'erreur.

Retournent les lignes pertinentes.

sp_fulltext_database

Activation ou désactivation de la recherche en texte intégral à l'aide de sp_fulltext_database.

Aucun résultat n'est retourné pour les requêtes de texte intégral. Si le texte intégral est désactivé pour la base de données, les opérations de texte intégral ne sont pas autorisées.

Retourne des résultats pour les requêtes de texte intégral et les opérations de texte intégral sont autorisées même si le texte intégral est désactivé pour la base de données.

Mots vides spécifiques aux paramètres régionaux

Requêtes dans des variantes d'un langage parent spécifiques aux paramètres régionaux, tel que le français de Belgique et le français du Canada.

Les requêtes dans des variantes spécifiques aux paramètres régionaux sont traitées par les composants (analyseurs lexicaux, générateurs de formes dérivées et mots vides) de leur langage parent. Par exemple, les composants Français (France) sont utilisés pour analyser le Français (Belgique).

Vous devez ajouter des mots vides de manière explicite pour chaque identificateur de paramètres régionaux (LCID). Par exemple, vous devriez spécifier un LCID pour la Belgique, le Canada et la France.

Processus d'indexation par radicaux du dictionnaire des synonymes

Utilisation du dictionnaire des synonymes et des formes flexionnelles (indexation par radicaux).

Un mot du dictionnaire des synonymes est ramené automatiquement à son radical après son expansion.

Si vous souhaitez que la forme radicale figure dans l'expansion, vous devez l'ajouter de manière explicite.

Chemin d'accès au catalogue de texte intégral et groupe de fichiers

Utilisation des catalogues de texte intégral.

Chaque catalogue de texte intégral a un chemin d'accès physique et appartient à un groupe de fichiers. Il est traité en tant que fichier de base de données.

Un catalogue de texte intégral est un objet virtuel qui n'appartient à aucun groupe de fichiers. Un catalogue de texte intégral est un concept logique qui fait référence à un groupe d'index de texte intégral.

Remarque :
SQL Server 2005 Les instructions DDL Transact-SQL qui spécifient des catalogues de texte intégral fonctionnent correctement.

sys.fulltext_catalogs

Utilisation du chemin d'accès, data_space_id et file_id de cet affichage catalogue.

Ces colonnes retournent une valeur spécifique.

Ces colonnes retournent NULL car le catalogue de texte intégral ne se trouve plus dans le système de fichiers.

sys.sysfulltextcatalogs

Utilisation de la colonne de chemin d'accès de cette table système désapprouvée.

Retourne le chemin d'accès de système de fichiers du catalogue de texte intégral.

Retourne NULL car le catalogue de texte intégral ne se trouve plus dans le système de fichiers.

sp_help_fulltext_catalogs

sp_help_fulltext_catalogs_cursor

Utilisation de la colonne PATH de ces procédures stockées désapprouvées.

Retourne le chemin d'accès de système de fichiers du catalogue de texte intégral.

Retourne NULL car le catalogue de texte intégral ne se trouve plus dans le système de fichiers.

sp_help_fulltext_catalog_components

Utilisation de sp_help_fulltext_catalog_components de cette procédure stockée.

Retourne une liste de tous les composants (filtres, analyseurs lexicaux et gestionnaires de protocoles) utilisés pour tous les catalogues de texte intégral dans la base de données active.

Retourne des lignes vides.

DATABASEPROPERTY et DATABASEPROPERTYEX

Utilisation de la propriété IsFullTextEnabled.

Le paramètre IsFullTextEnabled indique si la recherche en texte intégral est activée dans une base de données spécifique.

La valeur de cette colonne est sans effet. Les bases de données utilisateur sont toujours activées pour la recherche en texte intégral.

Voir aussi

Concepts

Modifications du comportement de la recherche en texte intégral dans SQL Server 2008

Autres ressources

Recherche en texte intégral
Obtention de valeurs de propriétés de texte intégral à l'aide de fonctions Transact-SQL


Modifications du comportement de la recherche en texte intégral dans SQL Server 2008

Modifications du comportement de la recherche en texte intégral dans SQL Server 2008 |
 | Voir aussi
Compatibilité ascendante > Compatibilité descendante du moteur de base de données SQL Server > Compatibilité descendante de la recherche en texte intégral >

Cette rubrique décrit les changements de comportement de la recherche en texte intégral. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Dans SQL Server 2008, le moteur d'indexation et de recherche en texte intégral est intégré en tant que service de base de données dans la base de données relationnelle dans le cadre de la requête de serveur et infrastructure de moteur de stockage. La nouvelle architecture de recherche en texte réalise les objectifs suivants :

  • Stockage et gestion intégrés — La recherche en texte intégral est maintenant intégrée directement avec les fonctions inhérentes de stockage et de gestion de SQL Server, et le service MSFTESQL n'existe plus.

    • Les index de recherche en texte intégral sont stockés dans les groupes de fichiers de la base de données, et non dans le système de fichiers. Les opérations d'administration sur une base de données, telles que la création d'une sauvegarde, affectent automatiquement les index de recherche en texte intégral.

    • Un catalogue de texte intégral est maintenant un objet virtuel qui n'appartient à aucun groupe de fichiers ; c'est un concept logique qui renvoie à un groupe d'index de recherche en texte intégral. Par conséquent, de nombreuses fonctionnalités de gestion de catalogue ont été abandonnées, et cet abandon a créé des modifications avec rupture pour quelques fonctionnalités. Pour plus d'informations, consultez Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008 et Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008.

      Remarque :
      Les instructions DDL Transact-SQL SQL Server 2005 qui spécifient des catalogues de texte intégral fonctionnent correctement.

  • Traitement de requêtes intégré — Le nouveau processeur de requêtes de recherche en texte intégral fait partie du moteur de base de données et est pleinement intégré avec le processeur de requêtes SQL Server. Cela signifie que l'optimiseur de requête reconnaît les prédicats de requête de texte intégral et les exécute automatiquement aussi efficacement que possible.

  • Administration et résolution des problèmes améliorées — La recherche en texte intégral intégrée fournit des outils pour vous aider à analyser des structures de recherche telles que l'index de recherche en texte intégral, le résultat d'un analyseur lexical donné, la configuration de mot vide, etc. Pour plus d'informations, consultez Dépannage de la recherche en texte intégral.

  • Les mots vides et les listes de mots vides ont remplacé les mots parasites et les fichiers de mots parasites. Une liste de mots vides est un objet de base de données qui facilite les tâches gestion des mots vides et améliore l'intégrité entre instances de serveur différentes et environnements. Pour plus d'informations, consultez Mots vides et listes de mots vides.

  • SQL Server 2008 contient de nouveaux analyseurs lexicaux pour un grand nombre des langues prises en charge par SQL Server 2005. Seuls les analyseurs lexicaux pour l'anglais, le coréen, le thaï et le chinois (traditionnel et simplifié) restent inchangés. Pour les autres langues, si un catalogue de texte intégral a été importé lorsqu'une base de données SQL Server 2005 a été mise à niveau vers SQL Server 2008, une ou plusieurs langues utilisées par les index de recherche en texte intégral dans le catalogue de texte intégral peuvent maintenant être associées aux nouveaux analyseurs lexicaux, lesquels peuvent se comporter un peu différemment des analyseurs lexicaux importés. Pour plus d'informations sur la façon de garantir une correspondance totale entre requêtes et contenu d'index de recherche en texte intégral, consultez Mise à niveau de la fonction de recherche en texte intégral.

  • Un nouveau service de lancement FDHOST (MSSQLFDLauncher) a été ajouté. Pour plus d'informations, consultez Mise en route avec la recherche en texte intégral.

  • L'indexation de texte intégral fonctionne avec une colonne FILESTREAM de la même façon qu'avec une colonne varbinary(max). La table FILESTREAM doit avoir une colonne qui contient l'extension de nom de fichier pour chaque objet blob FILESTREAM. Pour plus d'informations, consultez Exécution de requêtes sur des colonnes varbinary(max) et XML, Filtres de recherche en texte intégral, Processus d'indexation et d'interrogation en texte intégral et sys.fulltext_document_types (Transact-SQL).

    Le moteur de texte intégral indexe le contenu des objets blob FILESTREAM. L'indexation de fichiers tels que des images peut ne pas être utile. Lorsqu'un objet blob FILESTREAM est mis à jour, il est réindexé.

Important :
Pour des informations essentielles à propos de l'impact de la nouvelle architecture de recherche en texte intégral sur les applications existantes et les scripts, nous vous recommandons fortement de consulter Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008 et Modifications importantes apportées à la recherche en texte intégral dans SQL Server 2008.

Voir aussi

Concepts

Mise à niveau de la fonction de recherche en texte intégral

Autres ressources

Architecture de la recherche en texte intégral
Compatibilité descendante de la recherche en texte intégral
Principes de base de la recherche en texte intégral
Mise en route avec la recherche en texte intégral


Compatibilité descendante de SQL Server Analysis Services

Compatibilité descendante de SQL Server Analysis Services
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Les rubriques de cette section décrivent les changements de comportement entre les versions de Microsoft SQL Server Analysis Services.

Dans cette section

Rubriques | Description
Fonctionnalités Analysis Services abandonnées dans SQL Server 2008 | Décrit les fonctionnalités de réplication qui existaient dans les versions antérieures de SQL Server Analysis Services, mais ont été supprimées des versions ultérieures.
Fonctionnalités d'Analysis Services désapprouvées dans SQL Server 2008 | Décrit les fonctionnalités qui ont été conservées dans SQL Server Analysis Services pour des raisons de compatibilité descendante, mais qui seront supprimées dans une prochaine version de SQL Server.
Changements de comportement des fonctionnalités Analysis Services dans SQL Server 2008 | Décrit les fonctionnalités qui ont changé dans SQL Server Analysis Services.
Modifications avec rupture dans les fonctionnalités Analysis Services de SQL Server 2008 | Décrit les problèmes que vous pouvez rencontrer lors d'une mise à niveau de SQL Server Analysis Services.


Fonctionnalités d'Analysis Services désapprouvées dans SQL Server 2008

Fonctionnalités d'Analysis Services désapprouvées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de SQL Server Analysis Services >

Cette rubrique décrit les fonctionnalités Analysis Services désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

Fonctionnalités désapprouvées

Catégorie | Fonctionnalité désapprouvée | Commentaires
Propriétés des chaînes de connexion | InsertInto | Syntaxe d'origine de la chaîne de connexion pour le remplissage de cubes locaux.
Propriétés des chaînes de connexion | CreateCube | Syntaxe d'origine de la chaîne de connexion pour le remplissage de cubes locaux. Non pris en charge dans ADOMD.NET.
Fonctionnalités | SQL Server 2000 PMML | Cette fonctionnalité a été remplacée par le langage PMML (Predictive Model Markup Language) standard
Expressions multidimensionnelles (MDX, Multidimensional Expressions) | Create Action | La syntaxe étendue est prise en charge, mais les instructions en anglais ne peuvent pas créer de nouveaux types d'actions. Il est préférable d'utiliser DDL.
MDX | CalculationPassValue |
MDX | CalculationCurrentPass |
MDX | L'indicateur d'optimiseur de requête NON_EMPTY_BEHAVIOR a été activé par défaut | L'indicateur d'optimiseur de requête NON_EMPTY_BEHAVIOR sera désactivé par défaut dans une version ultérieure. Il s'agit d'un indicateur d'optimisation MDX qui peut générer des résultats incorrects lorsqu'il n'est pas utilisé correctement.
Autre | Propriété intrinsèque de cellule CELL_EVALUATION_LIST | Vide dans SQL Server Analysis Services.
Objets | Assemblys COM | Les assemblys COM peuvent poser un risque de sécurité.

Voir aussi

Autres ressources

Compatibilité descendante de SQL Server Analysis Services


Fonctionnalités Analysis Services abandonnées dans SQL Server 2008

Fonctionnalités Analysis Services abandonnées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de SQL Server Analysis Services >

Cette rubrique décrit les fonctionnalités de Analysis Services qui ne sont plus disponibles dans SQL Server 2008.

Fonctionnalités supprimées

Catégorie | Fonctionnalité supprimée | Commentaires
Propriétés des chaînes de connexion | Emplacement d'exécution de l'exploration de données | Accepté pour des raisons de compatibilité descendante, mais ignoré. L'exécution s'effectue toujours sur le serveur.
Propriétés des chaînes de connexion | Emplacement d'exploration de données |
Propriétés des chaînes de connexion | Fichier journal | La fonctionnalité de fichier journal est remplacée par la fonctionnalité de trace.
Propriétés des chaînes de connexion | Emplacement de l'exécution |
Propriétés des chaînes de connexion | Mesures distinctes par clé |
Propriétés des chaînes de connexion | Seuil de niveau large |
Fonctionnalités | Fournisseurs agrégés | Cette fonctionnalité est remplacée par des algorithmes de composant logiciel enfichable.
Fonctionnalités | Cubes liés | Cette fonctionnalité est remplacée par des groupes de mesures liés.
Fonctionnalités | Formules de niveau personnalisées | Cette fonctionnalité est remplacée par des scripts MDX (Multidimensional Expressions).
Fonctionnalités | Commandes de rôles de cubes et de rôles de bases de données | N'est plus pris en charge.
MDX | CreateVirtualDimension | Cette fonction MDX n'est plus prise en charge.
MDX | CreatePropertySet | Cette fonction MDX n'est plus prise en charge.
MDX | Ignore | Dans SQL Server 2000 Analysis Services, cette fonction était réservée à une utilisation ultérieure.
Autre | Enregistrement d'Active Directory |
Autre | Niveaux ignorés dans les hiérarchies parent-enfant | La propriété SkippedLevelsColumn, qui indique le nombre de niveaux à ignorer lors de la création d'un membre sous un parent dans une hiérarchie parent-enfant, n'est plus prise en charge.
Outils | Outil Configuration de la surface d'exposition | L'outil Configuration de la surface d'exposition a été supprimé dans SQL Server 2008. Pour plus d'informations, consultez Compatibilité ascendante.

Voir aussi

Autres ressources

Compatibilité descendante de SQL Server Analysis Services


Modifications avec rupture dans les fonctionnalités Analysis Services de SQL Server 2008

Modifications avec rupture dans les fonctionnalités Analysis Services de SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de SQL Server Analysis Services >

Cette rubrique décrit les changements avec rupture apportés à Analysis Services. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Modifications avec rupture dans Analysis Services de SQL Server 2008

Le tableau suivant présente la liste des problèmes que vous pouvez rencontrer au cours de la mise à niveau d'une base de données SQL Server 2005 Analysis Services (SSAS) Analysis Services vers SQL Server 2008.

Problème Description

La fonction shallow exists fonctionne différemment maintenant avec les jeux nommés qui contiennent des membres énumérés ou des jointures croisées d'enumsets.

Dans SQL Server 2005 Analysis Services (SSAS), la fonction shallow exists ne fonctionnait pas avec les jeux nommés qui contenant des membres énumérés ou des jointures croisées d'enumsets. Pour la compatibilité descendante avec la version Release d'origine et SP1 de SQL Server 2005 Analysis Services (SSAS), affectez à la la propriété de configuration « ConfigurationSettings\OLAP\Query\NamedSetShallowExistsMode » la valeur 1, ou pour la compatibilité descendante avec SQL Server 2005 Analysis Services (SSAS) SP2, affectez-lui la valeur 2.

Les fonctions VBA ne gèrent pas les valeurs NULL et vides comme elles étaient gérées dans SQL Server 2005 Analysis Services (SSAS) Analysis Services.

Dans SQL Server 2005 Analysis Services (SSAS), les fonctions VBA retournaient la valeur 0 ou une chaîne vide lorsque des valeurs NULL ou vides étaient utilisées comme arguments. Dans SQL Server 2008, elles retournent la valeur NULL.

L'Assistant Migration échouera parce que DSO n'est pas installé par défaut.

Par défaut, SQL Server 2008 n'installe pas le composant de compatibilité descendante DSO (Decision Support Objects). Le package de compatibilité descendante est installé par défaut mais le composant DSO du package sera désactivé. Dans la mesure où l'Assistant Migration SQL Server Analysis Services compte sur ce composant, il échouera à moins que le composant ne soit installé. Pour installer les composants DSO, procédez comme indiqué ci-dessous :

  1. Ouvrez le Panneau de configuration.

  2. Dans Windows XP ou Windows Server 2003, sélectionnez Ajout/Suppression de programmes. Dans Windows Vista et Windows Server 2008, sélectionnez Programmes et fonctionnalités.

  3. Cliquez avec le bouton droit sur Compatibilité descendante de Microsoft SQL Server 2005et sélectionnez Modifier.

  4. Dans l'Assistant Installation de compatibilité descendante, cliquez sur Suivant.

  5. Dans la page Maintenance du programme, sélectionnez Modifier, puis cliquez sur Suivant.

  6. Dans la page Sélection de composant, si DSO (Decision Support Objects) n'est pas disponible, cliquez sur la flèche bas et sélectionnez Ce composant sera installé sur le disque dur local. Cliquez sur Suivant.

  7. Dans la page Prêt à modifier le programme, cliquez sur Installer.

  8. Une fois l'installation terminée, cliquez sur Terminer.

Vous pouvez supprimer DSO après la migration en suivant les étapes précédentes, en remplaçant l'option de DSO par Ce composant ne sera pas disponible..

Si le package de compatibilité descendante n'est pas installé, vous pouvez l'installer à partir du support de distribution de SQL Server 2008. Notez qu'il existe des versions pour chaque architecture cible (x86, x64, ia64). Ces versions se trouvent aux emplacements suivants :

x86\Setup\x86\SQLServer2005_BC.msi

x64\Setup\x64\SQLServer2005_BC .msi

ia64\Setup\ia64\SQLServer2005_BC.msi

Il n'est pas recommandé de mettre l'emplacement de partition dans le dossier des données.

Le serveur gère le dossier des données et crée ou supprime des dossiers à mesure que les objets sont créés, supprimés et modifiés. Par conséquent, il est fortement déconseillé de spécifier un emplacement de stockage de partition à l'intérieur du dossier des données, surtout dans les sous-dossiers des bases de données, des cubes et des dimensions. Bien que le serveur vous permette d'effectuer cette action à l'aide de CREATE ou ALTER, il affichera un avertissement. Lorsque vous mettez à niveau des bases de données Analysis Services 2005 vers Analysis Services 2008 qui ont des emplacements de stockage de partition dans le dossier Data, la procédure fonctionnera. La restauration ou la synchronisation nécessitera le déplacement des emplacements de stockage de partition à l'extérieur du dossier Data.

Vous pouvez obtenir des résultats inattendus pour les requêtes qui utilisent le mot clé MDX « EXISTING » dans ProClarity Analytics Server et Microsoft Office PerformancePoint Server 2007.

ProClarity Analytics Server et Microsoft Office PerformancePoint Server 2007 utilisent le mot clé EXISTING de MDX incorrectement dans certains scénarios. En raison des mises à jour logicielles effectuées dans Analysis Services 2008, ces requêtes peuvent retourner des résultats inattendus. ProClarity Analytics Server et Microsoft Office PerformancePoint Server 2007 diffuseront une Service Release pour remédier à ce problème.

Modifications avec rupture dans Analysis Services de SQL Server 2005

Le tableau suivant présente la liste des problèmes que vous pouvez rencontrer au cours de la mise à niveau d'une base de données SQL Server 2000 Analysis Services vers SQL Server 2008.

Problème Description

Un objet dépendant d'un objet lié n'est pas migré

Les cubes liés et les dimensions liées ne sont pas migrés par le Conseiller de mise à niveau dans Microsoft SQL Server 2008 Analysis Services. Par conséquent, les objets qui font référence à un cube lié ou à une dimension liée ne peuvent pas être migrés, car l'objet lié sur lequel l'objet est basé ne peut pas faire l'objet d'une migration. Par exemple, un modèle d'exploration de données OLAP basé sur un cube lié ne peut pas être migré car le cube lié sur lequel le modèle d'exploration de données est basé ne peut pas être migré.

La fonction Autoexist peut générer des résultats de requête différents lorsque plusieurs hiérarchies font l'objet d'une migration vers la même dimension

Lorsque plusieurs hiérarchies ou dimensions virtuelles sont migrées vers la même dimension Microsoft SQL Server 2008 Analysis Services, l'interrogation des hiérarchies migrées contenues dans la dimension peut produire des résultats différents de ceux obtenus avec l'interrogation des mêmes hiérarchies lorsqu'elles étaient dans SQL Server 2000 Analysis Services, parce que la fonction Autoexist supprime automatiquement les tuples qui n'existent pas dans la dimension d'un cross join d'ensembles contenant les membres des hiérarchies migrées. Pour résoudre ce problème, vous devez vérifier les calculs qui impliquent plusieurs hiérarchies de la même dimension.

L'expérience de navigation est différente lorsque des niveaux désactivés sont utilisés

Depuis SQL Server 2005 Analysis Services, les niveaux masqués ou désactivés dans les hiérarchies ne sont plus pris en charge. Ces derniers sont migrés en tant que niveaux visibles ou activés. Les calculs concernant les hiérarchies contenant de tels niveaux risquent de renvoyer des résultats inattendus. Après la mise à niveau, examinez et vérifiez les calculs qui impliquent des hiérarchies qui contenaient précédemment des niveaux masqués ou désactivés.

La création de compartiments peut être différente pour les niveaux de regroupement

Depuis Microsoft SQL Server 2005 Analysis Services (SSAS), le regroupement automatique peut retourner un ensemble différent de groupes de membres. Les calculs qui reposent sur ces groupes de membres peuvent renvoyer des résultats inattendus. Après la mise à niveau, examinez et vérifiez les calculs qui reposent sur les groupes de membres.

La conversion d'une langue neutre vers une langue spécifique peut produire des résultats inattendus

Dans SQL Server 2000 Analysis Services et les versions antérieures, Analysis Services utilise uniquement des identificateurs de langue neutres, également connus sous le nom d'identificateurs de langue principaux, par exemple LANG_ENGLISH (0x09) pour l'anglais et LANG_CHINESE (0x04) pour le chinois.

Pour prendre en charge les options de traduction et de classement, Analysis Services utilise maintenant des identificateurs de langue spécifiques, qui sont une combinaison d'un identificateur de langue principal et d'un identificateur de sous-langue utilisé pour une culture spécifique. Par exemple, la combinaison de l'identificateur de langue principal LANG_ENGLISH (0x09) et de l'identificateur de sous-langue SUBLANG_ENGLISH_AUS (0x03) correspond à l'anglais australien.

La migration d'identificateurs de langue neutre vers des identificateurs de langue spécifique peut modifier le comportement attendu en matière de traduction et de classement, ce qui risque de produire des résultats inattendus. Après avoir mis à niveau, examinez et validez des objets tels que les dimensions, les hiérarchies et les membres pour lesquels l'identificateur de langue a changé.

Les commandes de rôle de cube ne sont pas prises en charge

Microsoft SQL Server 2008 Analysis Services ne prend pas en charge les objets de commande sur les rôles de cube et ne fait pas migrer les commandes des versions précédentes.

L'agrégation des formules de niveau personnalisées est différente

Si un cube contient une dimension avec des formules de niveau personnalisées ainsi que des dimensions avant et après avec des formules de membre personnalisées et/ou des opérateurs unaires, il se peut qu'il retourne des résultats différents de ceux des versions précédentes de Analysis Services. Cette situation se produit car le calcul des règles de précédence a changé.

Les formules de membre personnalisées et les formules de cumul personnalisé font l'objet d'une migration vers un script MDX

Dans les versions antérieures de Analysis Services, les propriétés suivantes sont prises en charge dans les dimensions et les niveaux : les formules de cumul personnalisé, les formules de membre personnalisées, les formules Tous les membres et les formules de niveau personnalisées. Dans SQL Server 2005 Analysis Services, ces propriétés ont été remplacées par les fonctionnalités prises en charge dans les scripts MDX (Multidimensional Expressions) et sont mises à niveau vers des scripts MDX lors de la migration.

Les agrégations personnalisées ne peuvent pas faire l'objet d'une migration

Les agrégations générées manuellement dans les versions antérieures d'Analysis Services ne font pas l'objet d'une migration vers Microsoft SQL Server 2008 Analysis Services. Seules les agrégations générées par l'Assistant Création de stockage sont migrées. Pour résoudre ce problème, créez manuellement les agrégations à l'aide de scripts XMLA.

Les membres de données existent toujours dans les dimensions de type parent-enfant

Les versions antérieures d'Analysis Services vous donnaient la possibilité de ne pas inclure les membres de données dans les dimensions de type parent-enfant. La propriété DataMembers d'une dimension dans les versions antérieures de Analysis Services a pris en charge trois options : Aucun, Masqué ou Visible. L'option Aucun n'est pas disponible dans Microsoft SQL Server 2008 Analysis Services. Les membres de données sont toujours inclus dans les attributs parents. Pour masquer les membres de données dans les dimensions parent-enfant, vous pouvez définir la propriété DataMembers d'une dimension avec la valeur Masqué. La propriété MembersWithData de l'attribut parent prend en charge uniquement deux options : NonLeafDataHidden ou NonLeafDataVisible.

Les commandes de rôle de base de données ne sont pas prises en charge

Microsoft SQL Server 2008 Analysis Services ne prend pas en charge les objets de commande sur les rôles de base de données et ne fait pas migrer les commandes des versions précédentes de Analysis Services.

DefaultMember est migré dans le script MDX

Dans les versions antérieures d'Analysis Services, le membre par défaut d'une dimension est spécifié par une expression MDX (Multidimensional Expressions) contenue dans la propriété DefaultMember de la dimension. Dans Microsoft SQL Server 2005 Analysis Services (SSAS), cette propriété a été remplacée par une fonctionnalité prise en charge dans les scripts MDX et est mise à niveau vers un script MDX lors de la migration.

Le changement du nom de dimension et de hiérarchie à la suite d'une migration peut générer des résultats de requête différents

Dans SQL Server 2000 Analysis Services, les hiérarchies de dimension sont représentées de manière interne en tant que dimensions distinctes et une convention d'affectation des noms permet de les identifier. La migration vers Microsoft SQL Server 2008 risque d'entraîner la création d'une dimension distincte avec un nouveau nom pour chaque hiérarchie de dimension au lieu d'associer les hiérarchies de dimension entre elles sous la dimension parente ; en effet, la création automatique donne lieu à des règles de sécurité différentes de celles appliquées dans les versions antérieures d'Analysis Services.

Les paramètres d'extraction ne sont pas migrés

Bien que l'extraction existe dans Microsoft SQL Server 2008 Analysis Services, les paramètres d'extraction ne sont pas migrés à partir des versions antérieures d'Analysis Services.

Les niveaux masqués sont visibles une fois la migration effectuée

Analysis Services ne prend plus en charge les niveaux cachés ou désactivés dans les hiérarchies. Ces derniers sont migrés en tant que niveaux visibles ou activés. Les calculs concernant les hiérarchies contenant de tels niveaux risquent de renvoyer des résultats inattendus.

Des objets non valides entraînent l'échec de la migration

La base de données contient des objets non valides. La migration ne peut pas aboutir lorsque la base de données contient des objets non valides.

Les cubes liés ne sont pas migrés

Les versions antérieures d'Analysis Services prenaient en charge les cubes liés. Dans Microsoft SQL Server 2005 Analysis Services (SSAS), cette fonctionnalité a été remplacée par des dimensions liées et des groupes de mesures liés.

Les noms uniques de membres risquent de changer durant la migration

Analysis Services tente de conserver les noms uniques des membres durant la migration ; toutefois, dans certaines circonstances, le nom unique d'un membre est modifié. Si tel est le cas, les applications clientes, les expressions MDX (Multidimensional Expressions) et les autres propriétés qui dépendent des noms uniques de membres risquent de produire des résultats inattendus.

Les sources de données ODBC ne sont pas prises en charge

Les versions précédentes d'Analysis Services permettaient d'utiliser les sources de données ODBC ; cependant, cette fonctionnalité n'est plus prise en charge.

Les partitions distantes ne sont pas migrées

Les partitions distantes ne sont pas migrées de Microsoft SQL Server 2000 Analysis Services vers Microsoft SQL Server 2008 Analysis Services. Mettez à niveau le serveur vers SQL Server 2008 Analysis Services, puis créez manuellement les partitions distantes.

Certains paramètres de l'algorithme de modèle d'exploration de données ne sont pas pris en charge

Les versions antérieures d'Analysis Services prennent en charge l'utilisation du paramètre MINIMUM_LEAF_CASES avec l'algorithme Microsoft Decision Trees et le paramètre MINIMUM_CLUSTER_CASES avec l'algorithme Microsoft Clustering. Depuis SQL Server 2005 Analysis Services, ces deux paramètres ont été renommés en MINIMUM_SUPPORT. Si ces paramètres ont été utilisés dans les modèles d'exploration de données créés à l'aide de la version antérieure de Analysis Services, les paramètres ne sont pas migrés.

Le comportement de certaines fonctions MDX a changé

En raison des améliorations et des modifications apportées au langage MDX (Multidimensional Expressions) de Microsoft SQL Server 2005 Analysis Services (SSAS), certaines fonctions MDX ne sont plus prises en charge ou n'ont pas le même comportement que dans les versions antérieures d'Analysis Services.

La commande CREATE KPI introduit un nouveau mot clé

Un nouveau mot clé, KPI, a été introduit pour la commande CREATE KPI. Si des objets existants ont le nom KPI, le nouveau mot clé sera en conflit avec eux.

La définition du niveau supérieur pour la sécurisation d'une dimension n'est pas prise en charge

Dans les versions antérieures d'Analysis Services, vous pouviez sécuriser une dimension de sorte que le niveau le plus élevé visible par un utilisateur ne soit pas le niveau le plus élevé de la hiérarchie. Les membres sécurisés via la définition du niveau supérieur seront visibles une fois la migration effectuée.

Les DLL des sources UDF ne sont ni migrées ni inscrites.

Les fonctions définies par l'utilisateur (UDF) inscrites dans les versions antérieures d'Analysis Services ne sont pas migrées.

Les opérateurs unaires ne sont pas complètement pris en charge dans les hiérarchies qui ne sont pas de type parent-enfant

Depuis Microsoft SQL Server 2005 Analysis Services (SSAS), l'utilisation d'opérateurs unaires dans les hiérarchies qui ne sont pas de type parent-enfant n'est pas prise en charge, sauf s'il existe une relation d'attribut entre les attributs des niveaux de la hiérarchie.

Les cubes virtuels ne sont pas pris en charge

Les versions antérieures d'Analysis Services prenaient en charge les cubes virtuels, c'est-à-dire une vue associant un sous-ensemble de mesures et de dimensions à partir d'un ou de plusieurs cubes standard ou liés. Dans Microsoft SQL Server 2005 Analysis Services (SSAS), cette fonctionnalité a été remplacée par des groupes de mesures liés. Lors la mise à niveau, les cubes virtuels sont migrés en tant que groupes de mesures liés.

Le contenu des tables d'écriture différée n'est pas migré

La structure des tables d'écriture différée créées par les versions antérieures d'Analysis Services a été mise à jour dans Microsoft SQL Server 2005 Analysis Services (SSAS). Les données des tables d'écriture différée créées par les versions antérieures d'Analysis Services ne peuvent pas être migrées vers la nouvelle structure de table d'écriture différée.

Voir aussi

Autres ressources

Compatibilité descendante de SQL Server Analysis Services


Changements de comportement des fonctionnalités Analysis Services dans SQL Server 2008

Changements de comportement des fonctionnalités Analysis Services dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de SQL Server Analysis Services >

Cette rubrique décrit les changements de comportement dans Analysis Services. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Modifications de comportement

Caractéristique Comportement de SQL Server 2000 Comportement de SQL Server

Navigation

Prend en charge les niveaux masqués ou désactivés dans les hiérarchies.

Les niveaux masqués ou désactivés sont migrés comme visibles et activés. Les calculs qui impliquent des hiérarchies contenant de tels niveaux peuvent renvoyer des résultats imprévus.

Dimension

Prend en charge l'option de ne pas inclure des membres de données dans les dimensions parent-enfant.

Il existe toujours des membres de données dans les dimensions parent-enfant ; les membres de données ne peuvent plus être exclus des dimensions parent-enfant.

Expressions multidimensionnelles (MDX, Multidimensional Expressions)

Fonction : CreateVirtualDimension

L'expression renvoie une erreur.

MDX

Fonction : CreatePropertySet

L'expression renvoie une erreur.

MDX

Instruction : With Cache

Syntaxe acceptée, mais aucune action.

MDX

Instruction : Create Cache

Syntaxe acceptée, mais aucune action.

MDX

Règles de priorité de calcul.

Les règles de priorité de calcul ont changé par rapport aux versions précédentes de Analysis Services.

En raison du cumul personnalisé ci-dessus, les expressions peuvent renvoyer des résultats différents de ceux des versions précédentes de Analysis Services.

Sécurité

Prend en charge l'option de spécification de la sécurité des dimensions, pour qu'un utilisateur puisse voir un niveau supérieur différent du niveau supérieur de la hiérarchie.

La définition du niveau supérieur n'est pas prise en charge pour la sécurité des dimensions. Les membres sécurisés à l'aide du niveau supérieur seront visibles après la migration.

Autre

AutoCommit et AutoRollback dans une mise à jour.

Les tentatives de validation d'une transaction inexistante échouent. Dans SQL Server 2000 Analysis Services, l'instruction Update créait sa propre transaction. Dans SQL Server Analysis Services, ce n'est pas le cas.

Voir aussi

Autres ressources

Compatibilité descendante de SQL Server Analysis Services


Compatibilité descendante de Reporting Services

Compatibilité descendante de Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Cette section décrit les modifications de comportement entre les versions de SQL Server Reporting Services. Elle traite des fonctionnalités qui ne sont plus disponibles ou destinées à être supprimées dans les versions futures. Elle décrit également les changements importants apportés au produit, connus pour empêcher le bon fonctionnement d'une application personnalisée incluant la fonctionnalité Reporting Services.

Dans cette section

  • Fonctions désapprouvées dans SQL Server Reporting Services

  • Fonctionnalités supprimées dans SQL Server Reporting Services

  • Dernières modifications de SQL Server 2008 Reporting Services

  • Modifications du fonctionnement de SQL Server Reporting Services

À propos de la création de rapports et de la publication dans SQL Server 2008

Dans cette version, les nouveaux rapports sont créés à l'aide d'une nouvelle version du schéma RDL (Report Definition Language). Les rapports utilisant le nouveau schéma doivent être créés dans la nouvelle application autonome Concepteur de rapports, et non dans le Concepteur de rapports intégré à SQL Server Business Intelligence Development Studio.

La nouvelle application autonome Concepteur de rapports offre le moyen de créer des rapports avec de nouvelles fonctionnalités, telles que les régions de données de tableau matriciel et les régions de données de graphique étendues. Les rapports qui utilisent le nouveau schéma ne peuvent pas être publiés sur les versions antérieures des serveurs de rapports Reporting Services. Pour afficher les rapports qui utilisent le nouveau schéma RDL, vous devez les déployer (à l'aide de l'application Concepteur de rapports) ou les télécharger (à l'aide du Gestionnaire de rapports) sur un serveur de rapports SQL Server 2008 Reporting Services.

Pour plus d'informations sur RDL, consultez Report Definition Language Reference. Pour plus d'informations sur la création de rapports, consultez Nouveautés de la création de rapports.
À propos du traitement et de la restitution des rapports dans SQL Server 2008

Dans cette version, le moteur de traitement des rapports a été refondu pour traiter et restituer les pages de rapport uniquement en cas d'affichage ou d'exportation. Pour plus d'informations, consultez Nouveautés dans le traitement des rapports et le rendu.

Dans cette version, le modèle objet de rendu de rapports a été remplacé. Pour plus d'informations, consultez Dernières modifications de SQL Server 2008 Reporting Services.

Voir aussi

Concepts

Compatibilité ascendante

Autres ressources

Mise à niveau (Reporting Services)


Fonctions désapprouvées dans SQL Server Reporting Services

Fonctions désapprouvées dans SQL Server Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de Reporting Services >

Cette rubrique décrit les fonctionnalités Reporting Services désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

Voir aussi

Concepts

Compatibilité ascendante

Autres ressources

Mise à niveau (Reporting Services)
Compatibilité descendante de Reporting Services


Fonctionnalités supprimées dans SQL Server Reporting Services

Fonctionnalités supprimées dans SQL Server Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de Reporting Services >

Cette rubrique décrit les fonctionnalités de Reporting Services qui ne sont plus disponibles dans SQL Server 2008. Elle n'inclut pas les annonces relatives à la cessation de la prise en charge pour des versions spécifiques du système d'exploitation ou de Microsoft Internet Information Services (IIS). Pour plus d'informations sur la configuration système requise, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

Mise à niveau manuelle de la base de données Report Server

À compter de SQL Server 2005 Service Pack 2, (SP2) le service Report Server est en mesure de détecter automatiquement la version de la base de données du serveur de rapports et de la mettre à niveau vers le schéma qui correspond à la version de l'instance de serveur de rapports actuelle. Lorsqu'une version antérieure de la base de données est détectée, vous êtes invité à la mettre à niveau. Si vous procédez à la mise à niveau, le schéma est mis à jour vers le nouveau format et vous ne pouvez pas le restaurer à un format précédent.

La fonctionnalité de mise à niveau automatique ayant été ajoutée, il n'est plus nécessaire de créer de script de mise à niveau de la base de données ni de disposer d'une option de mise à niveau manuelle dans l'outil de configuration de Reporting Services. Dans SQL Server 2008 Reporting Services (SSRS), les boutons permettant de créer le script et d'effectuer l'action de mise à niveau sont supprimés de la page Installation de la base de données dans l'outil de configuration de Reporting Services. Pour plus d'informations sur la prise en charge de la mise à niveau, consultez Mise à niveau d'une base de données du serveur de rapports.

Prise en charge d'Internet Explorer 5.5

La désapprobation de la prise en charge de Microsoft Internet Explorer 5.5 a été annoncée dans Reporting Services 2005 Service Pack 2. Cette version d'Internet Explorer n'est pas prise en charge dans la version SQL Server 2008 de Reporting Services.

Point de terminaison du service Web Report Server de SQL Server 2000

Le point de terminaison du service Web Report Server SQL Server 2000 a été supprimé dans cette version. Pour plus d'informations sur les points de terminaison actuels, consultez Report Server Web Service Endpoints dans la documentation en ligne de SQL Server.

Extension de rendu HTML OWC

L'extension de rendu HTML avec Office Web Components (OWC) a été supprimée dans cette version.

Extension de rendu HTML 3.2

Le format HTML 3.2 dans l'extension de rendu HTML a été supprimé dans cette version. L'extension de rendu n'est plus incluse dans une installation de Reporting Services.

Le Générateur de rapports s'exécute uniquement en mode de confiance totale

Pour Reporting Services en mode natif, l'exécution du Générateur de rapports en mode de confiance partielle est supprimée dans cette version. Reporting Services en mode natif ou en mode SharePoint prend en charge l'exécution du Générateur de rapports en mode de confiance totale uniquement.

Outil Configuration de la surface d'exposition

L'outil Configuration de la surface d'exposition a été supprimé dans SQL Server 2008. Pour plus d'informations, consultez Compatibilité ascendante.

Notification Services

Notification Services ont été supprimés de SQL Server 2008. Vous pouvez utiliser les fonctionnalités existantes de Reporting Services, telles que les abonnements pilotés par les données, pour obtenir certaines des fonctionnalités fournies par Notification Services dans les versions antérieures de SQL Server.

Voir aussi

Concepts

Compatibilité ascendante

Autres ressources

Mise à niveau (Reporting Services)
Compatibilité descendante de Reporting Services


Dernières modifications de SQL Server 2008 Reporting Services

Dernières modifications de SQL Server 2008 Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de Reporting Services >

Cette rubrique décrit les changements importants apportés à Reporting Services. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Vous pouvez rencontrer ces problèmes lorsque vous effectuez une mise à niveau, ou dans les scripts ou les rapports personnalisés. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Modifications importantes de Report Server

Modifications importantes du Générateur de rapports

Modifications importantes du traitement des rapports

Modifications importantes du rendu de rapport

Pour plus d'informations sur les nouvelles fonctionnalités, consultez Nouveautés (Reporting Services).

Modifications importantes de Report Server

Cette section décrit les modifications importantes apportées au serveur de rapport et aux outils de gestion.

Caractéristique Description

IIS et ASP.NET

Reporting Services ne dépend plus d'IIS pour fournir l'accès au point de terminaison SOAP. Les URL n'incluent plus les sites Web dans IIS. Reporting Services utilise directement HTTP.SYS pour écouter les demandes sur un port spécifique que vous définissez pour les URL du serveur de rapports.

Cette amélioration est une modification importante pour certains déploiements :

  • Si vous avez des scripts, des outils ou des processus de diagnostics qui incluent la révision des métadonnées ou des propriétés IIS, vous devez maintenant développer de nouvelles approches pour gérer le déploiement d'un serveur de rapports.

  • Si vous avez implémenté un filtre ISAPI pour la sécurité, vous devez déplacer le filtre ISAPI pour qu'il soit hébergé dans un serveur ISA ou créer un nouveau module HTTP qui effectue les mêmes opérations dans Reporting Services.

  • Si vous utilisez des paramètres de répertoire virtuel personnalisés, vous pouvez ne pas être en mesure de configurer des paramètres équivalents ou des URL dans la nouvelle implémentation du serveur de rapports. Dans certains cas, les opérations de mise à niveau ne peuvent pas créer des URL équivalentes pour le serveur de rapports ou le Gestionnaire de rapports.

Le Conseiller de mise à niveau détecte les modifications importantes en vérifiant les filtres ISAPI et les répertoires virtuels personnalisés. Le Conseiller de mise à niveau ne peut pas contrôler toutes les personnalisations possibles. Votre installation peut passer le contrôle du Conseiller de mise à niveau, mais continuer à s'interrompre ou à produire des erreurs inattendues.

Conflits de ports sous Windows XP

Sur les éditions prises en charge de Windows XP SP2 32 bits, IIS 5.1 et Reporting Services ne peuvent pas utiliser le même port. Vous ne pouvez pas configurer à la fois IIS 5.1 et un serveur de rapports pour qu'ils écoutent tous deux sur le port HTTP par défaut (port 80).

IIS 5.1 n'utilise pas HTTP.SYS pour les applications Web hébergées sur le serveur Web. Cela signifie qu'il n'existe aucune gestion de file d'attente commune pour les demandes qui aboutissent sur le même port et qu'il n'existe aucun référentiel commun des URL enregistrées et réservées.

Ce problème donne lieu au comportement suivant pour les mises à niveau de SQL Server 2008 Reporting Services sur Windows XP :

  • Sur les éditions 32 bits de Windows XP, si vous mettez à niveau une installation existante de SQL Server 2005 Reporting Services vers SQL Server 2008 Reporting Services, le serveur de rapports est configuré pour écouter sur le port 8080.

  • Sur les éditions 64 bits de Windows XP, si vous mettez à niveau une installation existante de SQL Server 2005 Reporting Services vers SQL Server 2008 Reporting Services, le serveur de rapports est configuré pour écouter sur le port 80.

  • Si vous effectuez une mise à niveau de génération à génération de SQL Server 2008, le serveur de rapports continue à écouter sur le même port été configuré avant la mise à niveau.

Après la mise à niveau complète, vous pouvez utiliser l'outil de configuration Reporting Services pour modifier le port sur lequel le serveur de rapports écoute, si vous souhaitez utiliser un port différent.

Pour plus d'informations sur les systèmes d'exploitation Windows pris en charge pour SQL Server 2008, consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.

Remarque :
IIS 5.0 n'est plus pris en charge. Les serveurs Windows 2000 ne sont pas pris en charge dans SQL Server 2008.

Fournisseur WMI (Windows Management Instrumentation) de Reporting Services

Le fournisseur WMI (Windows Management Instrumentation) de Reporting Services n'est pas compatible avec la version précédente. La nouvelle version inclut des méthodes supplémentaires pour prendre en charge l'inscription d'URL. Comme il ne peut y avoir qu'une seule version du fournisseur WMI Reporting Services pour une installation du serveur de rapports, cette version remplace la version précédente. Cette modification représente une modification importante pour certains déploiements. Si vous avez créé un script ou des outils qui appellent le fournisseur WMI, vous devez modifier votre code pour utiliser la nouvelle version. Pour plus d'informations, consultez Reporting Services WMI Provider.

Cette modification empêche également des utilisateurs de se connecter à une instance de SQL Server 2005 dans SQL Server Management Studio lorsque l'utilisateur spécifie le format <nom_serveur>\< nom_instance> pour se connecter. À la place, les utilisateurs doivent taper l'URL du serveur de rapports pour se connecter.

Consolidation des services et des applications

Le service Web Report Server, le Gestionnaire de rapports et l'application de traitement en arrière-plan sont consolidés en un seul service. Vous ne pouvez pas les démarrer ou les arrêter séparément.

Fichiers de configuration Reporting Services

Les fichiers de configuration Reporting Services sont également consolidés. Le fichier RSReportServer.config est le principal fichier de configuration du Gestionnaire de rapports et du service Web Report Server. Le fichier RSWebApplication.config est obsolète. Les paramètres RSWebApplication.config suivants ont été déplacés vers le fichier RSReportServer.config :

  • ReportServerUrl

  • ReportServerExternalUrl

  • ReportBuilderTrustLevel

  • Paramètres DeliveryUI des extensions de remise

  • DisplayErrorLink

Les paramètres suivants sont obsolètes et ne sont plus utilisés :

  • ReportServerVirtualDirectory

  • MaxActiveReqForOneUser

Si vous avez modifié le fichier RSWebApplication.config dans une installation précédente, le fichier n'est pas supprimé lorsque vous effectuez une mise à niveau vers SQL Server 2008. Vous devez supprimer le fichier manuellement ; tous les paramètres du fichier sont ignorés dans cette version.

Journaux de suivi Reporting Services

ReportServerService_<timestamp>.log est le principal journal de suivi pour toutes les applications qui s'exécutent dans le service. Les fichiers suivants sont obsolètes et ne sont plus créés dans SQL Server 2008 : ReportServerWebApp_<horodateur>.log, ReportServer_<horodateur>.log et ReportServerService_main_<horodateur>.log.

Outil de configuration de Reporting Services

L'outil de configuration de Reporting Services ne prend plus en charge les fonctionnalités de mise à niveau de la base de données ou de l'attribution de droits qui permettaient d'effectuer une mise à niveau ou d'accorder des autorisations en tant qu'opérations indépendantes ou de générer des modèles de script pour effectuer ces tâches. Dans cette version, la mise à niveau et les autorisations relatives à la base de données sont gérées comme opérations internes.

SQL Server Management Studio

Dans Management Studio, le dossier de base est supprimé de cette version. Vous ne pouvez pas afficher, gérer, distribuer ou sécuriser le contenu du serveur de rapports dans Management Studio.

Gestionnaire de rapports

Dans le Gestionnaire de rapports, les liens suivants sont supprimés des paramètres du site : Configurer les définitions de rôle au niveau élément, Configurer les définitions de rôle au niveau système, Gérer les travaux. Le Gestionnaire de rapports ne prend plus en charge la création, la modification ou la suppression des définitions de rôle. Vous devez utiliser Management Studio pour gérer les tâches qui sont dans des rôles spécifiques. De la même façon, la gestion des travaux a été déplacée du Gestionnaire de rapports vers Management Studio.

Abonnements par messagerie

Les abonnements par messagerie ne fonctionnent pas pour les alias de messagerie dans les champs Expéditeur, À, Cc, Cci et Répondre à lorsque le serveur de rapports ou le serveur SMTP distant est mis à niveau vers Windows Vista ou Windows Server 2008.

Ce problème se produit parce que Windows Server 2003 contient une fonctionnalité qui résout les alias en adresses de messagerie complètes. Reporting Services reposait sur cette fonctionnalité pour autoriser l'utilisation d'alias de messagerie au lieu d'adresses de messagerie complètes. Toutefois, pour aider à supprimer les fausses adresses de messagerie par filtrage, Windows Vista et Windows Server 2008 ne contiennent pas cette fonctionnalité. Pour contourner ce problème, vous devez configurer la propriété DefaultHostName dans la configuration. Pour plus d'informations sur la résolution de ce problème, consultez dans la Base de connaissances Microsoft l'article 945601 : « Abonnements SQL Server 2005 Reporting Services de messagerie ne fonctionnent pas dans Windows Vista et Windows Server 2008 si vous utilisez des alias comme des adresses de messagerie. »

Complément SQL Server 2008 Reporting Services pour les technologies SharePoint

Le complément SQL Server 2008 Reporting Services pour les technologies SharePoint propose des fonctions de rendu, de traitement et de gestion de rapport, ainsi que des abonnements pilotés par les données lorsque vous exécutez une instance du serveur de rapports SQL Server 2008 en mode intégré SharePoint. Le téléchargement du complément contient un composant WebPart Visionneuse de rapports, des pages d'application Web et la prise en charge de Windows SharePoint Services (WSS) ou de MOSS (Microsoft Office SharePoint Services).

Le complément SQL Server 2008 Reporting Services pour les technologies SharePoint nécessite une instance du serveur de rapports SQL Server 2008, car ce complément n'est pas pris en charge par les versions antérieures de SQL Server. Si votre serveur de rapports est antérieur à la version SQL Server 2008 et que vous installez ou mettez à niveau le complément SQL Server 2008 Reporting Services pour les technologies SharePoint, le serveur de rapports ne fonctionne pas comme prévu. Par exemple, vous ne pourrez pas configurer d'accès à la base de données avec la page Accorder l'accès à la base de données et rendre des rapports à l'aide d'un produit ou d'une technologie SharePoint. Pour résoudre ce problème, vous devez soit mettre à niveau votre instance du serveur de rapports vers SQL Server 2008, soit désinstaller le complément SQL Server 2008 Reporting Services pour les technologies SharePoint et réinstaller le complément SQL Server 2005 Reporting Services pour les technologies SharePoint.

Pour plus d'informations sur le complément SQL Server 2008 Reporting Services pour les technologies SharePoint, consultez le fichier Readme du complément Microsoft SQL Server 2008 Reporting Services.

Authentification de base

Dans SQL Server 2008 Reporting Services, seuls les types de connexion NETWORK et NETWORK_CLEARTEXT sont pris en charge avec l'authentification de base ; les types de connexion Interactive et BATCH ne sont pas pris en charge.

Modifications importantes du Générateur de rapports

Cette section décrit les modifications importantes apportées au Générateur de rapports.

Le Générateur de rapports s'exécute uniquement en mode de confiance totale

Dans les versions antérieures de Reporting Services exécutées en mode natif, le Générateur de rapports de SQL Server 2005 pouvait être démarré à l'aide des URL suivantes :

  • Confiance totale Par exemple, http://<nom_serveur>/reportserver/reportbuilder/reportbuilder.application

  • Confiance partielle Par exemple, http://<nom_serveur>/reportserver/reportbuilder/reportbuilderlocalintranet.application

Dans les deux URL, <nom_serveur> désigne l'ordinateur qui spécifie le serveur de rapports. De même, serveur_rapports y désigne l'instance du serveur de rapports.

Dans cette version, vous devez utiliser l'URL de confiance totale pour exécuter le Générateur de rapports. Lorsque vous utilisez l'URL de confiance totale pour la première fois, vous pouvez être invité à attribuer un niveau d'autorisations plus élevé à l'application.

Remarque :
Si le Générateur de rapports ne s'exécute pas, ou si vous obtenez une erreur, contactez l'administrateur système. Il se peut que vous n'ayez pas les autorisations nécessaires pour attribuer un niveau d'autorisations plus élevé à l'application.

Après avoir accordé ces autorisations une première fois, vous n'avez plus besoin de recommencer.

Dans cette version, si vous utilisez l'URL de confiance partielle, l'erreur suivante s'affiche lorsque vous ouvrez ou enregistrez un rapport, ou basculez d'un serveur de rapports à un autre :

« Échec. Une erreur s'est produite lors du traitement de votre demande. Enregistrez votre rapport et redémarrez l'application. »

Modifications importantes du traitement des rapports

L'architecture de traitement des rapports est modifiée de façon fondamentale dans cette version en fournissant un traitement des rapports à la demande. Le traitement des rapports à la demande réduit considérablement l'utilisation de la mémoire sur un serveur de rapports.

Importantes modifications de la mise à niveau RDL

Les éléments RDL suivants ne sont pas pris en charge lors de la mise à niveau d'un rapport existant :

  • Identificateurs d'objet dans RDL limités à 256 caractères

    La longueur des identificateurs d'objets dans RDL (par exemple, textboxID) n'était pas limitée dans les versions précédentes. Dans cette version, la longueur des identificateurs d'objet ne peut pas dépasser 256 caractères. Les identificateurs doivent toujours être conformes CLS.

Informations d'interactivité enregistrées uniquement pour la dernière demande

Dans les versions antérieures de Reporting Services, les captures instantanées enregistraient toutes les combinaisons possibles des choix interactifs, telles que les informations d'extraction et les choix de basculement. Vous pouviez afficher la page cinq d'un rapport, mais basculer par programme sur un élément de la première page en conservant l'ID correct pour l'opération de basculement.

Dans SQL Server 2008, les informations d'interactivité sont générées et enregistrées uniquement pour la dernière demande de rendu. Vous ne pouvez pas afficher une page et basculer par programme sur un élément d'une autre page. Vous pouvez basculer uniquement sur des éléments d'extraction de la page de rapport en cours.

Modification de l'espace de noms du modèle objet de rapport

Dans cette version, l'espace de noms du modèle objet de rapport a changé. Cet espace de noms fournit l'accès en lecture seule, tant au niveau du code personnalisé qu'au niveau des collections globales, par exemple Fields, Parameters et ReportItems. Si le code personnalisé existant utilise explicitement une référence complète à un espace de noms antérieur, il s'agit d'une modification avec rupture.

Il vous est recommandé de ne pas utiliser de références complètes pour accéder à des collections intégrées à partir de votre code. En ne spécifiant pas explicitement l'espace de noms, les références du code personnalisé correspondent à la version du modèle objet de rapport de Reporting Services actuellement installée.

Par exemple, dans SQL Server 2005 Reporting Services, les deux exemples suivants font ressortir la différence entre l'utilisation d'une référence complète à un paramètre (Microsoft.ReportingServices.ReportProcessing.ReportObjectModel.Parameter) et celle d'une référence par défaut à un paramètre (Parameter) pour passer un paramètre de rapport à une fonction personnalisée qui retourne l'étiquette de paramètre de rapport.

L'exemple suivant n'est pas recommandé. Il affiche la référence complète pour un paramètre de rapport. Le deuxième exemple est recommandé et illustre la référence de l'espace de noms par défaut pour un paramètre de rapport.

DO NOT USE FULLY QUALIFIED NAMESPACE REFERENCES FOR RUN-TIME COLLECTIONS

Public Function ShowParams(ByVal reportparameter As _

Microsoft.ReportingServices.ReportProcessing.ReportObjectModel.Parameter) _

As String

Return reportparameter.Label

End Function

La méthode recommandée pour accéder à une collection à l'exécution est affichée dans l'exemple suivant :

Public Function ShowParams(ByVal reportparameter As Parameter) _

As String

Return reportparameter.Label

End Function

Modifications importantes du rendu de rapport

L'architecture de rendu de rapport est modifiée de façon fondamentale dans cette version pour fournir un rendu plus cohérent pour la pagination et la mise en page entre les différents convertisseurs.

Nouveau modèle objet de rendu et pagination cohérente

Le modèle objet de rendu (ROM) a changé pour SQL Server 2008. Les versions antérieures du modèle objet de rendu ne sont plus prises en charge. L'accès au modèle objet de rendu à partir d'une extension de rendu multithread (et le basculement de contexte à partir de plusieurs threads) n'est pas pris en charge.

Le nouveau ROM rend les règles de restitution des pages plus cohérentes. Pour plus d'informations, consultez Présentation de la pagination dans Reporting Services.

Révision du rendu des données CSV

Dans les versions antérieures de Reporting Services, lorsque vous exportiez un rapport sous un format de fichier CSV, les données étaient mises en forme de manière à ce que leur apparence dans la page de rapport soit préservée. Pour les régions de données de matrice, le format de données obtenu se prêtait mal à l'importation dans d'autres applications en vue de continuer à utiliser les données.

Dans cette version, lorsque vous exportez un rapport vers un fichier CSV, vous pouvez choisir entre deux formats pris en charge : le mode Par défaut et le mode Conforme. Le mode Par défaut est optimisé pour Excel. Le mode conforme est optimisé pour les applications tierces. Pour plus d'informations, consultez Exportation vers un fichier CSV.

Le format antérieur des fichiers CSV n'est plus disponible. Toutefois, pour les rapports qui n'utilisent pas de régions de données de matrice, vous pouvez recourir au mode Conforme pour obtenir un format de fichier le plus proche du format de fichier CSV antérieur.

Agrégats avec visibilité conditionnelle dans les en-têtes et les pieds de page

Dans les versions antérieures de Reporting Services, différents convertisseurs utilisaient des règles variées pour déterminer les éléments avec une visibilité conditionnelle à inclure dans une page de rapport. Par exemple, des éléments masqués dans des rapports destinés à l'affichage dans un navigateur ou dans Excel pouvaient donner lieu à des calculs d'agrégats, ce qui n'était pas le cas pour les rapports destinés à l'impression.

Dans cette version, tous les convertisseurs utilisent le même jeu de règles pour déterminer les éléments à faire figurer dans une page.

Aucune prise en charge de formule dans Excel

Les versions antérieures de Reporting Services assuraient une prise en charge limitée de la conversion d'expressions RDL en formules Microsoft Excel. Dans cette version, lorsque vous exportez un rapport vers Excel, les expressions RDL ne sont pas converties en formules Excel.

Chevauchement d'éléments

Dans les versions antérieures de Reporting Services, si l'aire de conception d'un rapport comportait des éléments qui se chevauchaient, la publication du rapport générait un avertissement (« Le chevauchement des éléments de rapport n'est pas pris en charge dans tous les convertisseurs. »), mais les éléments de rapport demeuraient à leur emplacement d'origine sur l'aire de conception. Dans SQL Server 2008, les éléments de rapport peuvent être déplacés pour corriger le chevauchement des limites lorsqu'un rapport est affiché ou exporté dans un convertisseur qui ne prend pas en charge le chevauchement d'éléments. Pour plus d'informations, consultez Présentation des comportements de rendu.

Voir aussi

Concepts

Modifications du fonctionnement de SQL Server Reporting Services

Autres ressources

Mise à niveau (Reporting Services)
Compatibilité descendante de Reporting Services


Modifications du fonctionnement de SQL Server Reporting Services

Modifications du fonctionnement de SQL Server Reporting Services |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de Reporting Services >

Cette rubrique décrit les changements de comportement dans Reporting Services. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Configuration de Report Server et Outils d'administration

Création d'un rapport

Traitement d'un rapport

Génération d'un rapport

Modifications de comportement de la Configuration de Report Server et des Outils d'administration

Reporting Services contient plusieurs outils et applications qui permettent de configurer le serveur, ainsi que de gérer le contenu et les opérations. Dans cette version, chaque outil possède un objectif spécifique : configuration, administration et gestion du contenu. Pour favoriser la cohérence des outils et supprimer les fonctionnalités à double emploi, certaines tâches et fonctions ont, selon le cas, été ajoutées aux outils ou en ont été supprimées. Si vous étiez habitué à l'utilisation d'un outil pour effectuer une tâche donnée, il se peut que vous ayez à utiliser maintenant un autre outil pour accomplir la même tâche.

Fonctionnalité Description

Configuration de Reporting Services

Les icônes d'état à code de couleurs ont été supprimées. Les nouvelles pages de configuration d'URL remplacent les pages de création de répertoires virtuels. Le flux de travail pour créer et configurer une base de données du serveur de rapports a été modifié. Vous utilisez désormais un Assistant pour créer ou mettre à jour la connexion de base de données.

SQL Server Management Studio

Management Studio ne prend en charge que les tâches d'administration de serveur. Vous pouvez configurer un serveur de rapports qui s'exécute en mode natif ou en mode intégré SharePoint, et vous y connecter.

Gestionnaire de rapports

Le Gestionnaire de rapports permet d'afficher et de gérer le contenu du serveur de rapports. Cette version introduit la possibilité de gérer les modèles de rapport. Vous pouvez maintenant définir la sécurité de l'élément de modèle et associer les rapports générés interactifs aux entités d'un modèle.

Lors de l'affichage d'un rapport dans le Gestionnaire de rapports, en raison des modifications introduites par le traitement des rapports à la demande, la barre d'outils affiche une estimation de pages avec un point d'interrogation au lieu du nombre réel de pages du rapport. Vous pouvez toujours cliquer sur le bouton Dernière page et naviguer jusqu'à la fin du rapport.

Tâches prises en charge par les outils

Tâches | Configuration de Report Server | Management Studio | Gestionnaire de rapports | Utilitaires de ligne de commande
Réserver les URL | X |  |  | X
Définir le compte de service et le mot de passe | X |  |  | X
Créer la base de données du serveur de rapports ou modifier les informations de connexion | X |  |  | X
Configurer la montée en puissance parallèle du serveur de rapports | X |  |  | X
Sauvegarder, restaurer, modifier les clés ou supprimer les données chiffrées | X |  |  | X
Configurer le compte d'exécution sans assistance | X |  |  | X
Configurer la messagerie du serveur de rapports | X |  |  |
Activer Mes rapports |  | X |  |
Activer la journalisation de l'exécution des rapports |  | X |  |
Activer l'impression côté client |  | X |  |
Définir les valeurs par défaut du serveur pour l'historique de rapport |  | X |  |
Créer ou modifier les définitions de rôle |  | X |  |
Consulter l'état d'un processus de modèle ou d'un rapport en cours d'exécution et l'arrêter en cas de durée trop longue |  | X |  |
Attribuer les autorisations aux opérations et aux éléments du serveur de rapports en créant les attributions de rôle au niveau élément et au niveau système |  |  | X |
Définir et gérer l'arborescence des dossiers du serveur de rapports |  |  | X |
Afficher les rapports, les modèles de rapport, les sources de données partagées, les ressources et les dossiers |  |  | X |
Charger la définition de rapport (.rdl), le modèle de rapport (.smdl) et les fichiers de ressources |  |  | X |
Créer et gérer les planifications partagées |  | X | X |
Créer et gérer les rapports liés |  |  | X |
Créer et gérer l'historique de rapport |  |  | X |
Créer et gérer les sources de données partagées, ainsi que les propriétés de source de données définies dans un rapport individuel |  |  | X |
Planifier le moment où le traitement des données se produit pour un rapport ou configurer un rapport pour qu'il s'exécute comme capture instantanée d'exécution de rapport |  |  | X |
S'abonner aux remises de rapport, et créer et gérer les abonnements pilotés par les données |  |  | X |
Créer les abonnements pilotés par les données |  |  | X |
Utiliser le Générateur de rapports pour créer, modifier et enregistrer les rapports |  |  | X |
Générer des modèles, associer des rapports générés interactifs aux entités d'un modèle et définir la sécurité de l'élément de modèle |  |  | X |

Création d'un rapport

Dans les versions antérieures de Reporting Services, les quatre régions de données (Tableau, Matrice, Liste et Graphique) étaient des éléments de rapport distincts avec leur propre présentation et leurs propres propriétés. Dans cette version de Reporting Services, les régions de données Tableau, Matrice et Liste ont été remplacées par une nouvelle disposition en grille plus flexible, appelée région de données de tableau matriciel et utilisant des modèles prédéfinis pour créer les précédentes régions de données. La région de données de tableau matriciel permet de combiner les aspects des tableaux et des matrices dans des mises en page de rapport flexibles. La région de données de graphique demeure un élément de rapport séparé. Les nouveaux types de graphique, tels que polaire, radar et entonnoir, ont été ajoutés à la région de données de graphique. Pour plus d'informations sur les nouveaux types de graphique, consultez Utilisation de régions de données de graphique. Pour plus d'informations sur la région de données de tableau matriciel, consultez Utilisation de régions de données de tableau matriciel.

Conservation des espaces dans un corps de rapport ou un conteneur de rectangle

Les espaces superflus ne sont plus supprimés par défaut. Lorsque vous restituez un rapport qui possédait des espaces superflus sur le corps de rapport lors de l'affichage sur l'aire de conception du rapport, l'espace de fin après le dernier élément de rapport de la page est conservé. Il peut s'ensuivre un plus grand nombre de pages pour un rapport existant. Pour supprimer l'espace, définissez la propriété de rapport ConsumeContainerWhitespace avec la valeur true.

Pour plus d'informations, consultez Nouveautés de la création de rapports.

Traitement d'un rapport

Le traitement des rapports a été refondu dans SQL Server 2008. Le rapport est maintenant traité et restitué page après page, pendant que l'utilisateur du rapport le parcourt de façon interactive. La quantité de données sur chaque page influe sur la durée de restitution de chaque page. Le nombre total de pages est déterminé une fois le rapport restitué. Pour certains convertisseurs, le nombre de pages estimé s'affiche tant que toutes les pages du rapport n'ont pas été restituées.

Images

Les images ne sont plus extraites pendant la session initiale lorsqu'un rapport est restitué. Les images sont extraites lors du premier accès pendant un traitement à la demande.

Pour l'historique et les captures instantanées d'exécution, les images sont extraites au moment de la création de la capture instantanée.

Journal d'exécution : TimeDataRetrieval, TimeProcessing, TimeRendering

Les entrées du journal des rapports pour TimeDataRetrieval, TimeProcessing et TimeRendering sont enregistrées lors de la demande initiale adressée au processeur de rapports.

Détection d'erreurs à l'exportation

Dans les précédentes versions de Reporting Services, la totalité du rapport était traitée avant qu'une page ne soit affichée. Les erreurs dans les expressions de la propriété RDL Visibility.Hidden étaient détectées avant qu'un rapport ne puisse être exporté. Si vous pouviez consulter la première page d'un rapport, vous pouviez exporter la totalité du rapport sans erreur.

Dans cette version, les rapports sont traités page après page. Si des erreurs existent dans une expression de la propriété RDL Visibility.Hidden, l'erreur peut ne pas être détectée tant que la page sur laquelle l'erreur existe n'a pas été restituée pour l'exportation. Dans ce cas, l'ensemble de l'exportation échoue. Le fait de pouvoir consulter avec succès quelques pages d'un rapport ne garantit pas que vous puissiez exporter le rapport complet. Vous devez exporter le rapport et attendre que l'opération se soit achevée avec succès avant d'en déduire que l'exportation du rapport s'est déroulée sans erreur.

L'évaluation des expressions pour les opérations de regroupement, de tri et de filtre se déroule de la même façon que dans les versions précédentes de Reporting Services. Les erreurs dans ces expressions sont détectées par le composant de traitement des rapports et signalées comme erreurs critiques avant que la première page d'un rapport ne soit restituée.

Génération d'un rapport

La redéfinition de la génération des rapports a introduit les changements de comportement suivants lors de la génération d'un rapport existant.

Sauts de page

Dans les versions antérieures de Reporting Services, les convertisseurs de saut de page conditionnel géraient les éléments de rapport dans un conteneur (dans un rectangle ou dans le corps de rapport) de la façon suivante : les sauts de page des éléments de rapport supérieurs et inférieurs étaient appliqués au conteneur afin de réduire les pages vierges additionnelles. Dans le nouveau modèle objet de rendu, les sauts de page que vous définissez sur les éléments de rapport et appelés sauts de page logiques, provoquent toujours le rendu d'une nouvelle page. Il n'est procédé à aucune tentative pour éliminer les pages supplémentaires.

Pour plus d'informations, consultez Présentation de la pagination dans Reporting Services.

Éléments RepeatWith

Dans les versions antérieures de Reporting Services, les convertisseurs de saut de page conditionnel incluaient les éléments de rapport sur une page lorsque la propriété RepeatWith avait la valeur true. Ces éléments de rapport n'étaient pas comptabilisés lors du calcul de la taille de la page à cause de la nature flexible des tailles de page pour un convertisseur de saut de page conditionnel, ni lors de la définition de InteractiveHeight pour contrôler la quantité de données sur une page. Dans SQL Server 2008, ces éléments sont comptés dans la taille totale de la page. Il s'ensuit que les pages peuvent contenir moins de données, mais que la définition de la valeur pour InteractiveHeight a plus d'influence sur la taille de la page.

Pour plus d'informations, consultez Présentation des comportements de rendu.

Sous-états imbriqués et régions de données dans Excel

Dans les versions antérieures de Reporting Services, les régions de données imbriquées et les sous-rapports dans les cellules de tableau et de matrice n'étaient pas pris en charge lorsque vous exportiez un rapport vers Microsoft Office Excel. Dans SQL Server 2008, cette restriction a été supprimée. Vous pouvez concevoir des rapports qui utilisent des régions de données imbriquées et des sous-rapports dans une région de données, exporter le rapport vers le convertisseur Excel et consulter les éléments de rapport imbriqués.

Pour plus d'informations, consultez Exportation vers Microsoft Excel.

Voir aussi

Concepts

Compatibilité ascendante

Autres ressources

Nouveautés (Reporting Services)
Mise à niveau (Reporting Services)
Compatibilité descendante de Reporting Services


Compatibilité descendante d'Integration Services

Compatibilité descendante d'Integration Services
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Cette section décrit les modifications entre les versions de SQL Server Integration Services. Elle traite des fonctionnalités qui ne sont plus disponibles ou destinées à être supprimées dans les versions futures. Elle décrit également les changements importants apportés au produit, connus pour empêcher le bon fonctionnement ou pour modifier le comportement d'une application personnalisée incluant la fonctionnalité Integration Services.

Dans cette section

  • Fonctionnalités Integration Services désapprouvées dans SQL Server 2008

  • Fonctionnalités Integration Services abandonnées dans SQL Server 2008

  • Changements essentiels apportés aux fonctionnalités Integration Services de SQL Server 2008

  • Changements de comportement des fonctionnalités Integration Services dans SQL Server 2008

  • Prise en charge de DTS dans SQL Server 2008


Fonctionnalités Integration Services désapprouvées dans SQL Server 2008

Fonctionnalités Integration Services désapprouvées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante d'Integration Services >

Cette rubrique décrit les fonctionnalités Integration Services désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

DTS (Data Transformation Services)

DTS (Data Transformation Services) est abandonné. Prévoyez de supprimer les dépendances à DTS avant la prochaine version de SQL Server. DTS demeure pris en charge dans SQL Server 2000, SQL Server 2005 et SQL Server 2008 conformément à notre engagement à fournir une prise en charge pour ces versions de SQL Server. Toutefois, la migration ou l'exécution des packages DTS peut ne pas être prise en charge dans la prochaine version.

Les fonctionnalités DTS qui seront abandonnées incluent le runtime DTS, l'API DTS, l'Assistant Migration de package permettant de migrer les packages DTS dans la prochaine version de Integration Services, la prise en charge de la maintenance des package DTS dans SQL Server Management Studio, ainsi que la tâche d'exécution de package DTS 2000.

Pour plus d'informations sur la façon d'effectuer une migration de packages DTS vers le format de package Integration Services, consultez Migration des packages DTS.

Tâche de script ActiveX

La tâche de script ActiveX dans SQL Server 2008 est fournie exclusivement à des fins de compatibilité descendante avec DTS et sera supprimée dans la prochaine version de SQL Server. N'utilisez pas cette fonctionnalité pour le développement des nouveaux packages. Vous devez modifier le plus tôt possible les packages qui utilisent actuellement cette fonction. Vous pouvez recréer les fonctionnalités de vos scripts ActiveX à l'aide des nouveaux conteneurs de flux de contrôle et des contraintes de précédence plus flexibles qui sont disponibles dans Integration Services. Ou encore, vous pouvez réécrire vos scripts en utilisant la tâche de script Integration Services.

Pour plus d'informations sur la mise en œuvre d'une migration de scripts, consultez Migration de scripts.

Voir aussi

Concepts

Prise en charge de DTS dans SQL Server 2008


Fonctionnalités Integration Services abandonnées dans SQL Server 2008

Fonctionnalités Integration Services abandonnées dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante d'Integration Services >

Cette rubrique décrit les fonctionnalités de Integration Services qui ne sont plus disponibles dans SQL Server 2008.

Microsoft Visual Studio for Applications (VSA)

Dans SQL Server 2008, Visual Studio Tools for Applications (VSTA) a remplacé Visual Studio for Applications (VSA) comme environnement de script de la transformation de script et de la tâche de script. Même si cette modification ne requiert pas la réécriture des scripts, elle nécessite que les transformations et tâches de script qui contiennent des scripts VSA soient mises à niveau lorsque vous effectuez une migration de packages Integration Services existants vers SQL Server 2008.

Dans SQL Server 2008, les scripts VSA contenus dans les transformations ou les tâches de script seront convertis en scripts VSTA avant qu'Integration Services n'exécute les scripts.

Voir aussi

Concepts

Fonctionnalités Integration Services désapprouvées dans SQL Server 2008


Changements essentiels apportés aux fonctionnalités Integration Services de SQL Server 2008

Changements essentiels apportés aux fonctionnalités Integration Services de SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante d'Integration Services >

Cette rubrique décrit les changements importants apportés à Integration Services. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Dernières modifications

Le tableau suivant décrit les modifications avec rupture entre la version de Integration Services incluse avec SQL Server 2008 et la version de Integration Services incluse dans les versions antérieures.

Fonctionnalité | Description
Noms des fournisseurs dans les chaînes de connexion | Dans SQL Server 2008, les noms du fournisseur SQL Server Native Client et du fournisseur OLE DB pour Analysis Services ont changé et leurs chaînes de connexion utilisent une valeur différente. Pour mettre à jour automatiquement des chaînes de connexion qui utilisent ces noms de fournisseurs, utilisez l'Assistant Mise à niveau de packages SSIS pour mettre à niveau des packages SQL Server 2005. Vous pouvez également mettre à jour ces chaînes de connexion automatiquement ou manuellement dans BI Development Studio.
Composants tiers et personnalisés | Dans SQL Server 2008, Integration Services a modifié ses interfaces de programmation d'applications (API). Pour être compatibles avec ces nouvelles API, tous les composants tiers et personnalisés doivent être recompilés.


Changements de comportement des fonctionnalités Integration Services dans SQL Server 2008

Changements de comportement des fonctionnalités Integration Services dans SQL Server 2008
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante d'Integration Services >

Cette rubrique décrit les changements de comportement dans Integration Services. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Modifications de comportement

Le tableau suivant décrit les modifications de comportement entre la version de Integration Services incluse dans SQL Server 2008 et la version de Integration Services incluse dans les versions antérieures.

Élément Comportement de SQL Server 2005 Integration Services Comportement de SQL Server 2008 Integration Services

Renvoi d'une valeur NULL dans une variable de package à partir de la tâche Exécuter SQL

Renvoie la valeur au format 11/30/1999.

Renvoie la valeur au format 12/30/1899.

Développement de scripts dans la tâche Script et le composant Script

Utilise Visual Studio for Applications (VSA) comme environnement de script.

Utilise Visual Studio Tools for Applications (VSTA) comme environnement de script.

Pour migrer des packages qui contiennent des scripts, utilisez l'Assistant Mise à niveau de packages SSIS.

Utilisation de la transformation de recherche

Impossible de rendre la table de référence mise en cache persistante ou partager cette table entre plusieurs transformations de recherche.

Il est possible de rendre la table de référence mise en cache persistante ou partager cette table entre plusieurs transformations de recherche.

Pour utiliser les nouvelles fonctionnalités de transformation de recherche, pensez à revoir vos packages.


Prise en charge de DTS dans SQL Server 2008

Prise en charge de DTS dans SQL Server 2008 |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante d'Integration Services >

SQL Server 2008 assure une prise en charge au moment de la gestion 32 bits, de l'exécution et de la conception (facultatif) des packages DTS (Data Transformation Services) de SQL Server 2000 qui ont été créés à l'aide des outils et du modèle d'objet DTS.

Important :
Les fonctionnalités décrites dans cette rubrique, y compris la prise en charge au moment de l'exécution pour les packages DTS, requièrent l'installation manuelle de composants supplémentaires, facultatifs qui ne sont pas disponibles pendant l'installation. Pour plus d'informations, consultez les sections "Installation de la prise en charge au moment de l'exécution des packages DTS" et "Installation de la prise en charge au moment de la conception des packages DTS", plus loin dans cette rubrique.

La prise en charge DTS dans SQL Server 2008 inclut les fonctionnalités suivantes décrites plus loin de manière détaillée dans cette rubrique :

  • L'exécution DTS, le modèle d'objet qu'il expose, et l'utilitaire d'invite de commandes dtsrun.exe.

  • La tâche d'exécution de package DTS 2000 pour exécuter des packages DTS dans les packages Integration Services.

  • La tâche de script ActiveX pour des raisons de compatibilité descendante seulement.

  • L'Assistant Migration de package DTS pour la migration des packages DTS vers le format de package Integration Services.

  • Les règles de Conseiller de mise à niveau pour les packages DTS pour identifier des problèmes potentiels qui peuvent être rencontrés lors de la migration de packages.

SQL Server 2008 ne prend pas en charge les fonctionnalités DTS suivantes :

  • Aucune prise en charge au moment de la conception ou de l'exécution des packages DTS n'est proposée en mode 64 bits. Sur un ordinateur 64 bits, les packages DTS et les packages Integration Services qui exécutent des packages DTS ne peuvent s'exécuter qu'en mode 32 bits. Pour exécuter des packages en mode 32 bits, vous devez installer et utiliser la version 32 bits de l'utilitaire dtexec (dtexec.exe). Pour ce faire, sélectionnez Outils clients ou Business Intelligence Development Studio lors de l'installation.

  • Il n'y a également aucune prise en charge 32 bits lors de la conception ou de l'exécution pour les packages DTS sur les systèmes d'exploitation Itanium. Par conséquent, vous ne pouvez pas créer, afficher, modifier ou exécuter des packages DTS sur les systèmes d'exploitation Itanium.

Rubriques de cette section

Les liens suivants vous connectent aux différentes sections de cette rubrique :

Informations générales
  • Compatibilité générale entre DTS et SSIS

  • Gestion des packages DTS

Conception et exécution de packages DTS
  • Installation de la prise en charge au moment de l'exécution des packages DTS

  • Exécution de packages DTS à l'invite de commandes

  • Exécution des packages DTS à partir des travaux de l'Agent SQL Server

  • Exécution des packages DTS à partir des packages Integration Services

  • Installation de la prise en charge au moment de la conception des packages DTS

Migration des packages DTS
  • Migration des packages DTS

  • Migration des commandes dtsrun vers des commandes dtexec

Prise en charge limitée
  • Prise en charge des sources de données ODBC

  • Prise en charge des packages du référentiel

  • Prise en charge d'Integration Services dans SQL Server Express

Compatibilité générale entre DTS et Integration Services

DTS et Integration Services sont des produits complètement différents. Integration Services n'est pas une mise à niveau de version de DTS. Par conséquent, il n'existe pas de conflits logiciels entre DTS et Integration Services. Vous pouvez effectuer les procédures suivantes :

  • Installer DTS et Integration Services sur le même serveur.

  • Installer les packages DTS et les packages Integration Services sur le même serveur. Vous pouvez exécuter des packages SQL Server 2000 même lorsque les outils DTS ne sont pas présents, à l'aide d'une version mise à jour du runtime DTS qui est installé avec Integration Services.

  • Enregistrer les packages DTS dans la base de données msdb d'une instance de SQL Server 2000, ou une instance exécutant SQL Server 2005 ou une version ultérieure. Toutefois, vous pouvez enregistrer les packages SQL Server 2008 Integration Services que sur une instance qui exécute SQL Server 2008.

  • Utiliser un téléchargement facultatif du Concepteur DTS pour modifier les packages DTS même si les outils SQL Server 2000 ne sont pas présents sur l'ordinateur. Cependant, vous ne pouvez pas ouvrir ou modifier les packages DTS directement dans Business Intelligence Development Studio.

    Remarque :
    Pour plus d'informations sur le téléchargement de la version mise à jour du Concepteur DTS, consultez la section Installation au moment du design de la prise en charge des packages DTS SQL Server 2000.

Lorsque vous mettez à niveau une instance existante de SQL Server vers SQL Server 2008, les tables système (par exemple, sysdtspackages) que DTS utilise dans la base de données msdb restent intactes. Les packages DTS ne sont pas migrés automatiquement. Pour des informations sur la migration de packages, consultez la section Migration des packages DTS.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Gestion des packages DTS

Après avoir installé la prise en charge facultative au moment de l'exécution pour DTS comme décrit dans la section, "Installation de la prise en charge au moment de l'exécution des packages DTS", vous pouvez gérer des packages DTS à partir de SQL Server Management Studio. Ces packages DTS peuvent être stockés dans une instance de SQL Server 2000ou importés et stockés dans une instance qui exécute SQL Server 2005 ou version ultérieure.

Important :
Pour plus d'informations sur la sécurisation des packages DTS, consultez Sécurisation des packages DTS stockés dans SQL Server.

Pour afficher les packages DTS dans Management Studio, connectez-vous d'abord à une instance de SQL Server. (Ne vous connectez pas à une instance de Integration Services.) Puis, dans l'Explorateur d'objets, sous le nœud Management\Legacy\Data Transformation Services, vous pouvez effectuer les tâches suivantes :

  • Lorsque vous sélectionnez le nœud Data Transformation Services dans Management Studio, vous pouvez afficher et ouvrir les packages, les importer dans SQL Server à partir de fichiers de stockage structuré ou démarrer l'Assistant Migration de package DTS.

  • Lorsque vous sélectionnez un package DTS dans Management Studio, vous pouvez ouvrir le package pour le modifier, le migrer, l'exporter vers un fichier de stockage structuré ou le supprimer.

    Remarque :
    Pour ouvrir ou modifier les packages DTS, il convient d'effectuer un téléchargement distinct des composants du Concepteur DTS. Consultez la section Installation de la prise en charge au moment du design des packages DTS SQL Server 2000. Il est impossible d'ouvrir ou de modifier directement les packages DTS dans BI Development Studio.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Installation de la prise en charge au moment de l'exécution des packages DTS

Même si vous pouvez exécuter les packages DTS et les packages Integration Services sur le même ordinateur, SQL Server 2008 n'installe pas la prise en charge au moment de l'exécution des packages DTS. Vous devez installer cette prise en charge au moment de l'exécution avant de pouvoir exécuter et gérer des packages DTS. Pour plus d'informations sur la manière d'installer la prise en charge DTS au moment de l'exécution, consultez Procédure : installer la prise en charge des packages DTS.

Les fichiers de compatibilité descendante qui fournissent la prise en charge au moment de l'exécution pour les packages DTS incluent également la prise en charge au moment de l'exécution de la tâche de traitement SQL Server 2000 Analysis Services et ses dépendances, les objets DSO (Decision Support Objects). Cependant, les fichiers de compatibilité descendante n'incluent pas la prise en charge au moment du design de la modification des packages DTS qui contiennent la tâche de traitement de SQL Server 2000 Analysis Services. Vous pouvez modifier les packages qui contiennent cette tâche uniquement lorsque SQL Server 2000 Analysis Services est installé sur le même ordinateur.

Les fichiers de compatibilité descendante qui fournissent la prise en charge au moment de l'exécution pour les packages DTS n'incluent pas la prise en charge de la tâche de requête de prédiction de l'exploration de données SQL Server 2000.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Exécution de packages DTS à partir de l'invite de commandes

Vous pouvez exécuter les packages DTS à l'invite de commandes. Integration Services installe l'utilitaire dtsrun.exe lors de l'installation de la prise en charge à l'exécution des packages DTS.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Exécution des packages DTS à partir des travaux de l'Agent SQL Server

Pour exécuter un package DTS à partir d'un travail de l'Agent SQL Server, vous devez définir l'étape du travail sur Système d'exploitation (CmdExec) et faire appel à l'utilitaire dtsrun (dtsrun.exe) pour exécuter le package. Vous ne pouvez pas définir l'étape du travail sur Package SQL Server Integration Services. Pour plus d'informations, consultez Procédure : exécuter un package.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Exécution des packages DTS à partir des packages Integration Services

Vous pouvez aussi exécuter les packages DTS dans le cadre d'un package Integration Services. Integration Services fournit la tâche d'exécution de package DTS 2000 pour exécuter les packages DTS au sein d'un package Integration Services. Pour plus d'informations, consultez Tâche d'exécution de package DTS 2000.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Installation de la prise en charge au moment du design des packages DTS

Il est impossible d'ouvrir ou de modifier directement les packages DTS dans Business Intelligence Development Studio. De plus, ni SQL Server 2008, ni SQL Server 2005 n'installe le concepteur de packages DTS pour modifier les packages DTS. Cependant, vous pouvez télécharger et installer le concepteur de package DTS et l'utiliser pour modifier des packages DTS. Pour plus d'informations sur la manière d'installer la prise en charge au moment du design des packages DTS, consultez Procédure : installer la prise en charge des packages DTS. Après avoir installé ce téléchargement, vous pouvez afficher et modifier des packages DTS dans Management Studio ou dans l'Éditeur de tâche d'exécution de package DTS 2000 de Business Intelligence Development Studio.

Pour plus d'informations sur la gestion de certaines propriétés d'application DTS qui affectent l'environnement de conception DTS, consultez Définition des propriétés d'application DTS.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Migration des packages DTS

SQL Server fournit l'Assistant Migration de package DTS pour la migration des packages DTS vers le format de package Integration Services. Lorsque vous sélectionnez Integration Services pour l'installation, l'Assistant Migration de package DTS est également installé. Vous pouvez éventuellement utiliser cet Assistant pour mettre à niveau les packages DTS vers le format Integration Services. Lors de la migration, l'Assistant copie les packages DTS puis les recrée au format Integration Services. Les packages sources sont conservés intacts et ne sont pas modifiés.

Remarque :
L'Assistant Migration de package DTS est disponible dans SQL Server Standard, SQL Server Enterprise et SQL Server Developer.

De nombreux packages peuvent être entièrement migrés vers Integration Services, tout particulièrement les packages DTS qui utilisent des tâches, des connexions et d'autres objets qui ont des équivalents dans Integration Services. D'autres packages peuvent être migrés avec succès en encapsulant certaines tâches ou fonctionnalités qui ne peuvent pas être migrées dans une tâche d'exécution de package DTS 2000. Pour plus d'informations, consultez Migration des packages DTS.

Avant d'exécuter l'Assistant Migration de package DTS, vous pouvez installer et exécuter le Conseiller de mise à niveau pour analyser vos packages existants afin de rechercher les problèmes de migration. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Remarque :
Le Conseiller de mise à niveau ne peut pas analyser et l'Assistant Migration de package DTS ne peut pas migrer les packages DTS enregistrés dans la base de données msdb d'une instance de SQL Server 7.0. Cependant, le Conseiller de mise à niveau peut analyser, et l'Assistant Migration de package DTS peut migrer les packages DTS SQL Server 7.0 enregistrés comme fichiers de stockage structuré. De même, le Conseiller de mise à niveau peut analyser et l'Assistant Migration de package DTS peut migrer les packages DTS SQL Server 7.0 enregistrés dans la base de données msdb d'une instance de SQL Server 7.0 mise à niveau vers SQL Server 2005 ou version ultérieure.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Migration de lignes de commande pour l'exécution de packages

Pour comprendre comment les options de ligne de commande de l'utilitaire SQL Server 2000 DTS dtsrun (dtsrun.exe) sont mappées sur les options de l'utilitaire Integration Services dtexec (dtexec.exe), consultez Mappage des options dtsrun aux options dtexec.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Prise en charge des sources de données ODBC

Pour charger ou enregistrer des données sur une source de données ODBC, vous pouvez utiliser une source ou une destination ADO.NET, puis sélectionnez le fournisseur de données .NET Framework pour ODBC. Il est possible de créer une source ou une destination ODBC appropriée à utiliser dans un package unique à l'aide du composant Script. Pour plus d'informations, consultez Creating an ODBC Destination with the Script Component.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Prise en charge des packages Meta Data Services (Référentiel)

SQL Server 2000 Meta Data Services, généralement appelé « référentiel », est un composant qui n'est plus utilisé. SQL Server 2005 et les versions ultérieures n'installent pas et n'utilisent pas le référentiel.

Le concepteur DTS et l'utilitaire dtsrun continuent à prendre en charge les packages DTS enregistrés sur le référentiel.

Integration Services prend en charge le référentiel uniquement dans le Conseiller de mise à niveau et l'Assistant Migration de package DTS, et seulement si les fichiers redistribuables du référentiel sont installés sur l'ordinateur local. (Ces fichiers sont normalement présents lorsque l'ordinateur a SQL Server 2000 ou les outils SQL Server 2000 installés.) Quand les fichiers redistribuables du référentiel sont présents, le Conseiller de mise à niveau peut analyser les packages DTS qui ont été enregistrés dans le référentiel, et l'Assistant Migration de package DTS peut les migrer. Si les fichiers redistribuables du référentiel ne sont pas présents, le Conseiller de mise à niveau et l'Assistant Migration de package DTS sont réservés aux packages DTS qui ont été enregistrés dans SQL Server ou dans des fichiers de stockage structuré.

La tâche d'exécution de package DTS 2000 Integration Services ne peut pas exécuter un package DTS qui a été enregistré dans le référentiel. Toutefois, le runtime DTS SQL Server 2000 peut exécuter un tel package. Ainsi, pour qu'un package Integration Services exécute un package DTS stocké dans le référentiel, exécutez la procédure suivante :

  1. Assurez-vous que les fichiers du référentiel sont installés sur l'ordinateur qui exécute le package Integration Services. Pour installer les fichiers du référentiel, installez SQL Server 2000, les outils SQL Server 2000 ou les fichiers redistribuables du référentiel sur l'ordinateur local

  2. Créez un package DTS qui fait office de wrapper pour le package DTS stocké dans le référentiel. Dans ce package de wrapper DTS, utilisez la tâche d'exécution de package pour exécuter le package stocké dans le référentiel. Enregistrez ce package de wrapper dans SQL Server ou comme fichier de stockage structuré.

  3. Utilisez la tâche d'exécution de package DTS 2000 dans le package Integration Services pour exécuter le nouveau package de wrapper DTS.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Prise en charge des packages DTS dans SQL Server Express

SQL Server Express n'inclut pas Integration Services ni ne prend en charge les packages DTS. Toutefois, vous pouvez travailler avec les packages DTS sur un serveur qui exécute SQL Server Express en utilisant l'une des méthodes suivantes :

  • Pour exécuter les packages DTS existants sur un serveur qui exécute SQL Server Express, vous avez besoin du runtime DTS sur le serveur. Même si SQL Server Express n'inclut pas le runtime DTS, vous pouvez l'installer sur le serveur en installant les outils clients SQL Server 2000 ou les fichiers redistribuables DTS.

  • Pour modifier les packages DTS existants sur un serveur qui exécute SQL Server Express, vous pouvez utiliser les outils SQL Server 2000. Vous pouvez également modifier à distance les packages dans SQL Server Management Studio sur un serveur qui exécute une de ces versions de SQL Server : Workgroup, Standard, Enterprise ou Developer. SQL Server Express n'inclut pas SQL Server Management Studio.

  • Vous devez utiliser l'Assistant Migration de package DTS installé avec Integration Services pour migrer les packages DTS existants vers Integration Services. SQL Server Express n'inclut pas cet Assistant. Pour exécuter l'Assistant, vous pouvez utiliser une de ces versions de SQL Server : Standard, Enterprise ou Developer.

Icône de flèche utilisée avec le lien Retour en haut Retour en haut

Voir aussi

Concepts

Problèmes connus liés à la migration des packages DTS

Autres ressources

Mappage des options dtsrun aux options dtexec
Définition des propriétés d'application DTS
Considérations 64 bits pour Integration Services


Compatibilité descendante de la réplication

Compatibilité descendante de la réplication |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante >

Les rubriques de la section consacrée à la compatibilité descendante décrivent les changements de comportement entre les différentes versions de la réplication de Microsoft SQL Server. Il est important de comprendre la compatibilité descendante si vous effectuez une mise à niveau ou si vous avez plusieurs versions de SQL Server dans une topologie de réplication.

Rubrique | Description
Fonctionnalités désapprouvées dans la réplication SQL Server | Fonctionnalités de réplication qui ont été conservées dans Microsoft SQL Server 2008 pour permettre une compatibilité descendante, mais qui seront supprimées dans une version ultérieure de SQL Server.
Fonctionnalités abandonnées dans la réplication SQL Server | Fonctionnalités de réplication qui existaient dans des versions antérieures mais sont supprimées dans SQL Server 2005. Aucune fonctionnalité n'a été supprimée dans SQL Server 2008.
Modifications des comportements dans la réplication SQL Server | Fonctionnalités de réplication qui ont changé dans SQL Server 2008.
Dernières modifications dans la réplication SQL Server | Modifications des fonctionnalités de réplication qui peuvent imposer des modifications dans les applications.
Utilisation de plusieurs versions de SQL Server dans une topologie de réplication | Recommandations sur l'utilisation de plusieurs versions de SQL Server dans une topologie de réplication.

Voir aussi

Concepts

Considérations relatives à la mise à niveau de bases de données répliquées


Fonctionnalités désapprouvées dans la réplication SQL Server

Fonctionnalités désapprouvées dans la réplication SQL Server |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de la réplication >

Cette rubrique décrit les fonctionnalités de réplication désapprouvées qui sont toujours disponibles dans SQL Server 2008. Il est prévu que ces fonctionnalités soient supprimées dans une prochaine version de SQL Server. Les fonctions désapprouvées ne doivent pas être utilisées dans de nouvelles applications.

Fonctionnalités désapprouvées qui affectent tous les types de réplications

Les fonctionnalités suivantes, qui s'appliquent à tous les types de réplications, sont abandonnées dans SQL Server 2005 ou SQL Server 2008.

Fonctionnalité Description

Abonnements pouvant être attachés

Cette fonctionnalité peut être utilisée lors du déploiement d'un grand nombre d'abonnements par extraction de données, ce qui est relativement courant dans la réplication de fusion. Nous vous recommandons d'utiliser les méthodes suivantes plutôt que les abonnements pouvant être attachés :

  • Pour les publications de fusion qui sont partitionnées à l'aide de filtres paramétrés, nous vous recommandons d'utiliser des captures instantanées partitionnées, qui simplifient l'initialisation d'un grand nombre d'abonnements. Pour plus d'informations, consultez Captures instantanées des publications de fusion avec des filtres paramétrés.

  • Pour les publications non partitionnées, vous pouvez initialiser un abonnement avec une sauvegarde. Pour plus d'informations, consultez Initialisation d'une réplication de fusion sans capture instantanée et Initialisation d'un abonnement transactionnel sans capture instantanée.

Dans les deux cas, vous pouvez automatiser la création d'un grand nombre d'abonnements à l'aide de scripts : créez un abonnement unique, créez un script à partir de cet abonnement, modifiez le script pour chaque Abonné et appliquez-le à chaque Abonné pour créer un abonnement. Pour plus d'informations, consultez Création de scripts de réplication.

Inscription de l'Abonné

La procédure stockée de sp_addsubscriber est abandonnée. Il n'est plus requis d'inscrire explicitement un Abonné sur le serveur de publication.

Objets SQL-DMO (Distributed Management Objects)

Le code existant continue de fonctionner, mais SQL-DMO ne prend pas en charge les nouvelles fonctionnalités de SQL Server 2005 et SQL Server 2008. Utilisez plutôt Replication Management Objects (RMO). Pour plus d'informations, consultez Replication Management Objects Concepts.

Modifications du schéma à l'aide de sp_repladdcolumn et sp_repldropcolumn

Les procédures stockées sp_repladdcolumn et sp_repldropcolumn ont été abandonnées. Utilisez plutôt la réplication de modification du schéma. Pour plus d'informations, consultez Modification du schéma dans les bases de données de publication.

Les procédures stockées ne peuvent pas être utilisées pour ajouter ou supprimer des colonnes avec des types de données introduits dans SQL Server 2005 et versions ultérieures : types xml, varchar(max), nvarchar(max), varbinary(max) ou types définis par l'utilisateur (UDT), datetime2, time, datetimeoffset, hierarchyid, geometry et geography.

Validation de la somme de contrôle

La validation de somme de contrôle ne doit pas être utilisée. Utilisez la validation de somme de contrôle binaire. Vous pouvez également utiliser la validation du nombre de lignes pour tous les abonnés de SQL Server, y compris ceux qui s'abonnent aux publications des serveurs de publication Oracle. Pour plus d'informations, consultez Validation des données répliquées.

Ajout de publications à Active Directory

L'ajout d'une publication à l'annuaire Active Directory à l'aide du paramètre @add_to_active_directory de sp_addpublication ou sp_addmergepublication a été abandonné. L'abonnement à une publication en la localisant dans Active Directory a été désapprouvé.

Paramètre -UseInprocLoader

Ce paramètre de l'Agent de distribution et de l'Agent de fusion est désapprouvé parce qu'il n'est pas compatible avec le type de données XML. Si vous ne répliquez pas de données XML, ce paramètre peut être utilisé. Pour plus d'informations, consultez Agent de distribution de réplication et Agent de fusion de réplication.

Paramètres PublisherAddress, PublisherNetwork, DistributorNetworket DistributorAddress dans les Agents de fusion et de distribution¹

Ces paramètres sont utilisés pour spécifier l'adresse IP lors de la connexion au serveur de publication ou de distribution. Le sous-système de réplication utilisant des noms de serveurs pour vérifier la connexion, nous vous recommandons d'utiliser l'alias au niveau des protocoles clients pour mapper l'adresse IP au nom du serveur et d'utiliser le nom du serveur dans les agents.

¹ Abandonnés dans SQL Server 2008.

Fonctionnalités désapprouvées de la réplication transactionnelle

Les fonctionnalités de réplication transactionnelle suivantes ont été abandonnées dans SQL Server 2005 ou SQL Server 2008.

Fonctionnalité Description

Expiration des abonnements aux publications transactionnelles

La propriété @retention de sp_addpublication a été abandonné. Les abonnements restent marqués comme inactifs et doivent être réinitialisés s'ils n'ont pas été synchronisés durant la période de rétention de la distribution maximale (propriété @max_distretention de sp_adddistributiondb). Pour plus d'informations sur les périodes de rétention, consultez Expiration et désactivation des abonnements.

Abonnements « No sync » aux publications transactionnelles

Un abonnement est un abonnement « no sync » si la valeur none est affectée au paramètre @sync_type de sp_addsubscription ou sp_addpullsubscription. Si vous souhaitez spécifier que le schéma et les données nécessaires sont déjà présents dans la base de données d'abonnement, affectez plutôt la valeur Prise en charge de la réplication uniquement au paramètre. Pour plus d'informations, consultez Initialisation d'un abonnement transactionnel sans capture instantanée.

Abonnés ODBC

Utilisez plutôt OLE-DB pour les Abonnés non-SQL Server. Pour plus d'informations sur les Abonnés pris en charge, consultez Abonnés non-SQL Server.

Abonnements transformables

Cette fonctionnalité est disponible via l'interface des procédures stockées, mais elle n'est plus prise en charge dans l'interface utilisateur. L'utilisation de la fonctionnalité nécessite l'installation de DTS (Data Transformation Services) de SQL Server 2000. Pour plus d'informations, consultez Compatibilité descendante d'Integration Services.

Abonnements pouvant être mis à jour incluant les mises à jour immédiate et en attente avec des publications de captures instantanées et transactionnelles¹

Nous vous recommandons d'utiliser à la place la réplication transactionnelle d'égal à égal. Pour plus d'informations, consultez Réplication transactionnelle d'égal à égal.

Contrôle ActiveX de distribution

Ce contrôle vous permet d'incorporer l'Agent de distribution dans les applications. Utilisez plutôt RMO. Pour plus d'informations, consultez Procédure : synchroniser un abonnement par extraction de données (pull) (Programmation RMO) et Procédure : pour synchroniser un abonnement d'envoi de données (programmation RMO).

Interface de distribution de réplication

Dans SQL Server 2000, l'interface de distribution de réplication fournissait une interface permettant de stocker les transactions répliquées dans la base de données de distribution sur le serveur de distribution. Cette interface pouvait être utilisée pour activer la publication à partir d'une base de données non-SQL Server (une programmation personnalisée supplémentaire était requise pour suivre les modifications sur le serveur de publication). La prise en charge de cette fonctionnalité a été désapprouvée, mais le code existant continue de fonctionner sur un serveur mis à niveau à partir de SQL Server 2000. Pour plus d'informations, consultez « Replication Distributor Interface Reference » dans la documentation en ligne de SQL Server 2000.

SQL Server 2005 et SQL Server 2008 prennent en charge la publication à partir des bases de données Oracle sans programmation personnalisée. Pour plus d'informations, consultez Présentation de la publication Oracle.

Réplication sur des abonnés Oracle 8 et depuis des serveurs de publication Oracle 8¹

Pour plus d'informations sur les versions Oracle prises en charge, consultez Présentation de la publication Oracle et Abonnés Oracle.

¹ Abandonnés dans SQL Server 2008.

Fonctionnalités désapprouvées de la réplication de fusion

Les fonctionnalités de réplication de fusion suivantes ont été abandonnées dans SQL Server 2005 ou SQL Server 2008.

Fonctionnalité Description

Partenaires de synchronisation différents

La fonctionnalité de partenaires de synchronisation différents vous permet de spécifier un serveur de publication différent avec lequel un Abonné peut se synchroniser.

Dans SQL Server 2005 et SQL Server 2008, nous vous recommandons d'utiliser la réplication de fusion associée à la mise en miroir de bases de données, à la place des partenaires de synchronisation différents. Pour plus d'informations, consultez Réplication et mise en miroir des bases de données.

Abonnements « No sync » aux publications de fusion1

Un abonnement est un abonnement « no sync » si la valeur none est affectée au paramètre @sync_type de sp_addmergesubscription ou sp_addmergepullsubscription. Ce type d'abonnement n'est pas recommandé pour une réplication de fusion.

Contrôle ActiveX de fusion

Ce contrôle vous permet d'incorporer l'Agent de fusion dans les applications. Utilisez plutôt RMO. Pour plus d'informations, consultez Procédure : synchroniser un abonnement par extraction de données (pull) (Programmation RMO) ou Procédure : pour synchroniser un abonnement d'envoi de données (programmation RMO).

Option UPDATE multicolonne

Lorsque la réplication de fusion effectue une mise à jour, elle met à jour toutes les colonnes modifiées dans une seule instruction UPDATE et réaffecte aux colonnes non modifiées leur valeur d'origine. Elle peut également émettre plusieurs instructions UPDATE, avec une instruction UPDATE pour chaque colonne modifiée. L'instruction UPDATE multicolonne est généralement plus efficace.

Dans les versions de SQL Server antérieures à SQL Server 2005, nous recommandons de spécifier une valeur false pour l'option de l'article @fast_multicol_updateproc dans les cas où une mise à jour multicolonne (une instruction UPDATE unique) peut être moins efficace :

  • La plupart des mises à jour impliquent un nombre limité de colonnes.

  • La maintenance d'un index sur des colonnes non modifiées est lourde, car ces colonnes sont redéfinies à chaque mise à jour.

Grâce aux performances accrues de SQL Server, cette option n'est plus requise pour ces cas de figure.

Paramètre -ParallelUploadDownload¹

Ce paramètre de l'Agent de fusion est utilisé pour charger et télécharger simultanément les modifications dans une session de réplication de fusion. S'il permet des gains de performance, ceux-ci restent dépendants de la quantité de métadonnées à transférer sur le réseau.

propriété @allow_partition_realignment dans sp_addmergepublication¹

Ce paramètre est utilisé pour contrôler les opérations de suppression qui doivent être envoyées aux Abonnés lorsqu'une ligne est déplacée de la partition de l'Abonné.

Paramètre -ExchangeType¹

Ce paramètre est utilisé pour contrôler si l'Agent de fusion est en phase de chargement, de téléchargement, ou les deux à la fois. Sa valeur par défaut, 3, permet d'effectuer le chargement et le téléchargement. Nous déconseillons le chargement uniquement, car il ne permet pas de répliquer les modifications de schéma ou les processus d'initialisation. La fonctionnalité de téléchargement uniquement peut être obtenue en utilisant @subscriber_upload_options pour un article. Pour plus d'informations, consultez sp_addmergearticle (Transact-SQL).

Propriété @delete_tracking dans sp_addmergearticle¹

Cette propriété est utilisée pour arrêter le suivi des suppressions lorsque celles-ci doivent être envoyées au serveur de publication ou à l'Abonné. Cela peut être implémenté via DeleteHandler dans le BusinessLogicModule. Pour plus d'informations, consultez Exécution de la logique métier lors de la synchronisation de fusion.

Enregistrements logiques¹

Cette fonctionnalité est utilisée pour envoyer un ensemble de lignes connexes dans une transaction unique. Dans la plupart des cas, l'utilisation de cette fonctionnalité se traduit par une baisse importante des performances en matière de réplication. Pour plus d'informations, consultez Regroupements des modifications apportées à des lignes connexes à l'aide d'enregistrements logiques.

¹ Abandonnés dans SQL Server 2008.

Voir aussi

Concepts

Compatibilité descendante de la réplication


Fonctionnalités abandonnées dans la réplication SQL Server |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de la réplication >

Cette rubrique décrit les fonctionnalités de réplication qui ne sont plus disponibles dans SQL Server 2008.

Fonctionnalités abandonnées dans la réplication SQL Server

Cette section décrit les fonctionnalités de réplication abandonnées dans SQL Server 2005.

Fonctionnalités abandonnées qui affectent tous les types de réplication

Les fonctionnalités de réplication suivantes ont été abandonnées dans SQL Server.

Fonctionnalité Description

Création d'abonnements par envoi de données (push) sans connexion à l'Abonné dans l'Assistant Nouvel abonnement

La création d'abonnements par envoi de données (push) dans l'Assistant Nouvel abonnement requiert désormais une connexion active à l'Abonné durant la configuration. Pour plus d'informations sur l'utilisation de l'Assistant, consultez Procédure : créer un abonnement envoyé (SQL Server Management Studio).

Utilisation du protocole de transfert des fichiers (FTP, File Transfer Protocol) pour initialiser les Abonnés qui exécutent SQL Server version 7.0

Cette fonctionnalité est disponible pour les Abonnés qui exécutent SQL Server 2000 ou des versions ultérieures. Pour plus d'informations, consultez Transfert de captures instantanées via FTP.

Création d'abonnements dans le Gestionnaire de synchronisation Windows

Vous ne pouvez plus créer des abonnements dans le Gestionnaire de synchronisation, mais vous pouvez encore synchroniser les abonnements. Pour plus d'informations, consultez Gestionnaire de synchronisation Windows.

Abonnement à une publication en la localisant dans Active Directory

L'ajout d'une publication à l'annuaire Active Directory à l'aide du paramètre @add_to_active_directory de sp_addpublication ou sp_addmergepublication a été abandonné. L'abonnement à une publication en la recherchant dans Active Directory a été désapprouvé.

Contrôle ActiveX de la capture instantanée

Ce contrôle vous permet d'incorporer l'Agent de capture instantanée dans les applications. Utilisez plutôt le nouvel Agent de capture instantané managé. Pour plus d'informations, consultez SnapshotGenerationAgent et Procédure : créer la capture instantanée initiale (programmation RMO).

Activation de l'Agent distant

SQL Server 2000 prenait en charge l'exécution de l'Agent de distribution ou de l'Agent de fusion sur un autre ordinateur suivie de l'activation de cet agent à distance à l'aide du modèle DCOM. Cette prise en charge a été abandonnée pour les serveurs de distribution qui exécutent SQL Server 2005 et les versions ultérieures ; elle a également été abandonnée pour les serveurs de distribution qui exécutent des versions antérieures de SQL Server. Pour plus d'informations, consultez « Activation de l'Agent distant » dans la documentation en ligne de SQL Server 2000.

Abonnés à Microsoft Access (Jet 4.0)

Jet est la base de données sous-jacente utilisée par Access et la réplication prenait en charge les abonnements aux bases de données Jet dans SQL Server 2000. Ces abonnements ne sont plus pris en charge.

Nous vous conseillons d'utiliser SQL Server Express à la place. Access peut utiliser une base de données SQL Server comme arrière-plan et les bases de données SQL Server ne sont pas concernées par ce problème.

Fonctionnalités de réplication transactionnelle abandonnées

Les fonctionnalités de réplication transactionnelle suivantes ont été abandonnées.

Fonctionnalité Description

Option MSMQ (Message Queuing) pour les abonnements de mise à jour en attente

Avec les abonnements de mise à jour en attente, les modifications des Abonnés sont écrites dans une file d'attente ; elles sont ensuite lues dans cette file d'attente et remises au serveur de publication par l'Agent de lecture de la file d'attente. Dans SQL Server 2000, les abonnements pouvaient utiliser une file d'attente SQL Server ou bien l'option Message Queuing pour mettre les modifications en file d'attente. Le type de file d'attente était spécifié avec le paramètre @queue_type de sp_addpublication, qui autorisait les valeurs sql et msmq (Message Queuing). Dans SQL Server 2005, seule la valeur sql est autorisée. Les publications existantes qui utilisent l'option Message Queuing sont modifiées lors de la mise à niveau en vue de l'utilisation d'une file d'attente SQL Server. Si certaines de vos applications dépendent de la mise à jour en attente à l'aide de MSMQ, vous devrez les réécrire pour une file d'attente SQL Server. Pour plus d'informations sur les abonnements de mise à jour en attente, consultez Abonnements pouvant être mis à jour pour la réplication transactionnelle.

Fonctionnalités de réplication de fusion abandonnées

Les fonctionnalités de réplication de fusion suivantes ont été abandonnées.

Fonctionnalité Description

Publication à partir de SQL Server Express

MSDE SQL Server peut tenir lieu de serveur de publication pour les publications de fusion. SQL Server Express ne peut pas faire office de serveur de publication. Il peut s'abonner aux publications de fusion, aux publications transactionnelles et aux publications de capture instantanée. La réplication de fusion et la réplication transactionnelle avec des abonnements de mise à jour autorisent toutes les deux que les modifications soient retournées au serveur de publication à partir des Abonnés.

L'interface IVBCustomResolver.

Cette interface vous permettait de programmer des programmes de résolution de conflits personnalisés COM dans Visual Basic. Dans SQL Server 2005, nous vous conseillons d'utiliser des gestionnaires de logique métier à la place des programmes de résolution COM. Pour plus d'informations, consultez Exécution de la logique métier lors de la synchronisation de fusion.

Vous pouvez toujours programmer des programmes de résolution COM en C++. Pour plus d'informations, consultez Programmes de résolution personnalisés COM.

Voir aussi

Concepts

Compatibilité descendante de la réplication


Dernières modifications dans la réplication SQL Server

Dernières modifications dans la réplication SQL Server |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de la réplication >

Cette rubrique décrit les changements importants apportés à la réplication SQL Server. Ces modifications peuvent interrompre les applications, scripts ou fonctionnalités fondés sur les versions antérieures de SQL Server. Il se peut que vous rencontriez ces problèmes lors d'une mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Dernières modifications apportées dans SQL Server 2005

Cette section décrit les dernières modifications des fonctionnalités de réplication qui ont été apportées dans SQL Server 2005.

Dernières modifications qui affectent tous les types de réplication

Les modifications avec rupture décrites ci-dessous s'appliquent à tous les types de réplication.

Fonctionnalité Description

Modifications requises pour les scripts de réplication

Le modèle de sécurité de l'agent de réplication n'est plus celui de SQL Server 2000. Pour plus d'informations sur le modèle de sécurité, consultez Modèle de sécurité de l'Agent de réplication. Si vous êtes un membre du rôle serveur fixe sysadmin dans SQL Server 2005 et que vous exécutez des scripts de réplication créés à partir de SQL Server 2000 ou SQL Server 7.0, les scripts sont correctement exécutés. Si vous êtes un membre du rôle de base de données fixe dbo ou d'un autre rôle, les scripts échouent et doivent être mis à niveau. Pour plus d'informations sur la mise à niveau des scripts, consultez Procédure : mettre à niveau les scripts de réplication (programmation Transact-SQL de la réplication). Bien qu'il ne soit pas obligatoire de mettre à niveau les scripts qui sont exécutés par des membres du rôle sysadmin, il est recommandé de le faire afin de bénéficier des améliorations en termes de sécurité.

Connexions locales pour les agents de réplication

Lors de la mise à niveau vers SQL Server 2005, toutes les connexions locales qui utilisent l'authentification SQL Server sont modifiées pour utiliser l'authentification Windows. Les connexions locales sont les connexions effectuées par un agent vers une instance SQL Server qui s'exécute sur le même ordinateur. Par exemple, l'Agent de fusion pour un abonnement par extraction de données s'exécute chez l'Abonné, si bien que les connexions qu'il établit avec l'Abonné sont des connexions locales.

Dans les versions précédentes de SQL Server, les agents s'exécutaient par défaut sous le compte du service SQL Server Agent. Après la mise à niveau, les connexions locales sont établies sous ce compte. SQL Server 2005 permet de contrôler soigneusement chaque compte sous lequel les agents de réplication s'exécutent et établissent des connexions intégrées à Windows avec les bases de données et d'autres ressources ; un compte différent peut être spécifié pour chaque agent. Après la mise à niveau, il est recommandé de spécifier un compte différent par agent. Pour plus d'informations, consultez Considérations relatives à la mise à niveau de bases de données répliquées et Modèle de sécurité de l'Agent de réplication.

Contrôles ActiveX

Tous les contrôles ActiveX sont marqués comme non sûrs pour l'écriture de scripts et l'initialisation.

Le contrôle ActiveX de l'Agent de capture instantanée n'est pas disponible dans SQL Server 2005. Utilisez plutôt le nouvel Agent de capture instantané managé. Pour plus d'informations, consultez SnapshotGenerationAgent et Procédure : créer la capture instantanée initiale (programmation RMO).

Mot de passe pour le compte distributor_admin

Les connexions approuvées entre un serveur de publication et un serveur de distribution distant ne sont plus prises en charge, car elles ne requéraient pas un mot de passe (les connexions approuvées étaient utilisées par défaut dans les versions précédant SQL Server 2000 Service Pack 3). Si vous utilisez un serveur de distribution distant, avant d'effectuer la mise à niveau vers SQL Server 2005, convertissez les connexions approuvées en connexions non approuvées (cette observation ne concerne pas les serveurs de publication qui utilisent un serveur de distribution local). Pour plus d'informations sur le compte distributor_admin, consultez Protection du serveur de distribution.

Pour déterminer le type de connexion en cours d'utilisation

  • Sur le serveur de distribution, exécutez sp_helpdistpublisher. Si la valeur de la colonne trusted est 1, vous devez passer à une connexion non approuvée.

Pour passer à une connexion non approuvée

  1. Exécutez sp_changedistpublisher sur le serveur de distribution, en affectant la valeur 'trusted' au paramètre @property et la valeur 'False' au paramètre @value.

    Remarque :
    Certaines versions de la documentation en ligne de SQL Server 2000 ne répertorient pas 'trusted' comme valeur valide pour @property. Elle est pourtant valide pour toutes les versions de SQL Server 2000.

  2. Exécutez sp_changedistributor_password sur le serveur de publication et sur le serveur de distribution, en spécifiant un mot de passe fort pour le paramètre @password.

SQL Server Express n'inclut pas l'Agent SQL Server.

Si vous effectuez une mise à niveau vers SQL Server Express, vous devez reconfigurer la synchronisation de la réplication car SQL Server Express n'inclut pas l'Agent SQL Server.

Si vous souhaitez utiliser des abonnements par extraction de données, vous devez les synchroniser à l'aide des objets RMO (Replication Management Objects), du Gestionnaire de synchronisation Windows ou en exécutant l'agent de réplication à partir de la ligne de commande. Pour plus d'informations, consultez Réplication de données vers SQL Server Express.

Si vous voulez continuer à utiliser l'Agent SQL Server pour exécuter des travaux de l'agent de réplication, vous devez utiliser des abonnements par émission de données ou effectuer une mise à jour vers une version différente de SQL Server (toutes les versions à l'exception de SQL Server Express et de SQL Server Compact 3.5 SP1 incluent l'Agent SQL Server). Avec les abonnements par émission de données, l'Agent de distribution ou l'Agent de fusion s'exécutent au niveau du serveur de distribution, de sorte que l'Agent SQL Server est disponible (SQL Server Express ne peut pas être un serveur de distribution).

Abonnés à Microsoft Access (Jet 4.0)

Jet est la base de données sous-jacente utilisée par Access et la réplication prenait en charge les abonnements aux bases de données Jet dans SQL Server 2000. Ces abonnements ne sont plus pris en charge.

Il est recommandé d'utiliser plutôt SQL Server Express. Access peut utiliser une base de données SQL Server comme arrière-plan et les bases de données SQL Server ne sont pas concernées par ce problème. Pour plus d'informations, consultez Réplication de données vers SQL Server Express.

Dernières modifications pour la réplication transactionnelle

Les modifications avec rupture décrites ci-dessous s'appliquent à la réplication transactionnelle.

Fonctionnalité Description

Initialisation d'un abonnement transactionnel à partir d'une sauvegarde1

Pour initialiser un abonnement transactionnel à partir d'une sauvegarde dans SQL Server 2008, l'utilisateur doit être membre du rôle de serveur dbcreator. Dans SQL Server 2005, l'appartenance au rôle de base de données db_owner était suffisante.

Pour plus d'informations sur l'initialisation d'un abonnement à partir d'une sauvegarde, consultez Initialisation d'un abonnement transactionnel sans capture instantanée.

Option MSMQ (Message Queuing) pour l'abonnement de mise à jour en attente

Avec les abonnements de mise à jour en attente, les modifications des Abonnés sont écrites dans une file d'attente ; elles sont ensuite lues dans cette file d'attente et remises au serveur de publication par l'Agent de lecture de la file d'attente. Dans SQL Server 2000, les abonnements pouvaient utiliser une file d'attente SQL Server ou bien l'option Message Queuing pour mettre les modifications en file d'attente. Le type de file d'attente était spécifié avec le paramètre @queue_type de sp_addpublication, qui autorisait les valeurs sql et msmq (Message Queuing). Dans SQL Server 2005, seule la valeur sql est autorisée. Les publications existantes qui utilisent l'option Message Queuing sont modifiées lors de la mise à niveau en vue de l'utilisation d'une file d'attente SQL Server. Si certaines de vos applications dépendent de la mise à jour en attente à l'aide de Message Queuing, vous devrez les réécrire pour une file d'attente SQL Server. Pour plus d'informations sur les abonnements de mise à jour en attente, consultez Abonnements pouvant être mis à jour pour la réplication transactionnelle.

La mise à niveau de SQL Server supprime les files d'attente d'abonnement Message Queuing existantes si le service Message Queuing est parallèlement en cours d'exécution.

Important :
Dans Windows 2000 et Windows XP, le service MSDTC (Microsoft Distributed Transaction Coordinator) doit également être en cours d'exécution car Message Queuing requiert MSDTC sur ces plateformes.

Si le service Message Queuing n'est pas en cours d'exécution, supprimez les files d'attente manuellement une fois la mise à niveau achevée. Pour plus d'informations sur la suppression des files d'attente, consultez la documentation de Windows.

Changer pour appeler le format pour les abonnements avec mise à jour

Par défaut, un ensemble de procédures stockées est utilisé pour propager les modifications vers les Abonnés dans la réplication transactionnelle. Chaque procédure a un format d'appel. Ce format détermine la manière dont les paramètres sont passés à la procédure et la quantité de données qui est envoyée à l'Abonné. Dans SQL Server 2000, le format par défaut est CALL. Dans SQL Server 2005 et SQL Server 2008, le format par défaut est VCALL.

Cette modification affecte seulement les topologies dans lesquelles les procédures stockées ont été personnalisées. Après la mise à niveau, vous devez modifier la signature de la procédure personnalisée pour inclure des paramètres supplémentaires. Sinon, l'Agent de distribution échouera.

1 Ce problème affecte uniquement SQL Server 2008 et versions ultérieures.

Dernières modifications pour la réplication de fusion

Les dernières modifications décrites ci-dessous s'appliquent à la réplication de fusion.

Fonctionnalité Description

Publication à partir de SQL Server Express

MSDE SQL Server peut tenir lieu de serveur de publication pour les publications de fusion. SQL Server Express, qui remplace MSDE, ne peut pas tenir lieu de serveur de publication. Il peut s'abonner aux publications de fusion, aux publications transactionnelles et aux publications de capture instantanée. La réplication de fusion et la réplication transactionnelle avec des abonnements de mise à jour autorisent toutes deux que les modifications soient retournées au serveur de publication à partir des Abonnés. Pour plus d'informations sur la réplication sur SQL Server Express, consultez Réplication de données vers SQL Server Express.

Traitement des modifications

Dans les versions antérieures de SQL Server, les modifications apportées par l'Agent de fusion étaient réalisées ligne par ligne. Dans SQL Server 2005, les modifications sont regroupées, ce qui permet d'améliorer les performances ; par conséquent, une même instruction permet d'insérer, de mettre à jour ou de supprimer plusieurs lignes. Si, dans les bases de données de publication ou d'abonnement, des tables publiées possèdent des déclencheurs, vérifiez que ceux-ci peuvent gérer les insertions, les mises à jour et les suppressions portant sur plusieurs lignes. Pour plus d'informations, consultez Observations au sujet des lignes multiples pour les déclencheurs DML.

Recréation de tables de conflits

Lors de la mise à niveau de SQL Server 2005, les tables de conflits sont recréées et le propriétaire de la base de données (DBO, Database Owner) est leur propriétaire. Si d'autres propriétaires possédaient l'une des tables dans SQL Server 2000, votre application doit peut-être être modifiée.

La réplication de fusion crée une table de conflits pour chaque article associé à une publication, avec un nom qui a la forme conflict_PublicationName_ArticleName. Toutes les tables de métadonnées sont recréées lors de la mise à niveau et toutes les tables de conflits sont créées dans le schéma DBO.

Nouvelles plages d'identité attribuées

Pour les tables qui utilisent la gestion automatique des plages d'identité, la réplication peut attribuer de nouvelles plages d'identité au cours de la mise à niveau. Si certaines tables ont une plage d'identité attribuée à l'Abonné plus grande que celle du serveur de publication, la réplication attribue au serveur de publication une plage égale à celle de l'Abonné.

Pour déterminer les plages en cours d'utilisation pour chaque article, exécutez sp_helpmergearticle dans la base de données de publication et consultez les colonnes pub_identity_range et identity_range.

Voir aussi

Concepts

Compatibilité descendante de la réplication


Modifications des comportements dans la réplication SQL Server

Modifications des comportements dans la réplication SQL Server |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de la réplication >

Cette rubrique décrit les changements de comportement dans la réplication SQL Server. Les changements de comportement affectent le fonctionnement de certaines fonctionnalités ou interagissent dans SQL Server 2008 par rapport aux versions précédentes de SQL Server.

Modifications des comportements dans SQL Server 2005

Cette section décrit les modifications apportées au comportement des fonctionnalités de réplication dans SQL Server 2005.

Modifications des comportements qui affectent tous les types de réplication

Les modifications suivantes affectent tous les types de réplication.

Fonctionnalité | Description
Modèle de sécurité de l'agent de réplication | Dans les versions précédentes de SQL Server, les agents s'exécutaient par défaut sous le compte du service SQL Server Agent. SQL Server permet dorénavant de contrôler soigneusement chaque compte sous lequel les agents de réplication s'exécutent et établissent des connexions intégrées à Microsoft Windows avec les bases de données et d'autres ressources ; un compte différent peut être spécifié pour chaque agent. Pour plus d'informations, consultez Sécurité et protection (réplication) et Modèle de sécurité de l'Agent de réplication. Pour plus d'informations sur les effets de cette modification sur les mises à niveau, consultez la section « Nouveau modèle de sécurité de l'Agent de réplication » de Considérations relatives à la mise à niveau de bases de données répliquées et Dernières modifications dans la réplication SQL Server.
Gestionnaire de synchronisation Windows | Dans les versions de SQL Server antérieures à SQL Server 2005, la possibilité de synchroniser les abonnements avec le Gestionnaire de synchronisation était activée par défaut. Dans SQL Server 2005, vous devez explicitement activer cette option si vous souhaitez utiliser le Gestionnaire de synchronisation. Pour plus d'informations, consultez Procédure : synchroniser un abonnement à l'aide du Gestionnaire de synchronisation Windows (Windows Synchronization Manager).
Outil de résolution des conflits de réplication | Dans SQL Server 2000, l'outil de résolution des conflits de réplication était constitué en package en vue de sa redistribution. Dans SQL Server 2005, il n'est pas constitué en package séparément. Pour inclure l'outil de résolution des conflits de réplication dans une application, vous devez installer Microsoft .NET Framework 2.0 sur l'ordinateur sur lequel l'application est déployée et copier un nombre de fichiers sur l'ordinateur. Pour plus d'informations, consultez « Autres problèmes de mise à niveau de réplication » dans l'aide du Conseiller de mise à niveau. Pour plus d'informations sur le Conseiller de mise à niveau, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.
Modifications de l'option de schéma | Les options de schéma vous permettent de spécifier la manière dont les attributs et les objets associés aux tables, tels que les index et les contraintes, sont répliqués. Le comportement d'un nombre d'options de schéma a changé dans SQL Server 2005. La section suivante de cette rubrique fournit plus d'informations.

Modifications du comportement des options de schéma

Le tableau suivant résume les modifications des options de schéma dans SQL Server 2005.

Remarque :
Si l'option de schéma 0x8000 a été définie dans SQL Server 2000, elle a été désactivée au cours de la mise à niveau vers SQL Server 2005. Pour les options de schéma 0x10 ou 0x40, la réplication peut créer un plus grand nombre d'index dans SQL Server 2005 que dans SQL Server 2000.

Option | Comportement si l'option est définie dans SQL Server 2000 | Comportement si l'option est définie dans SQL Server 2005
0x80 | Crée une contrainte ou un index. Si l'option 0x8000 est aussi activée, la clé primaire est créée comme contrainte comportant un index. Si l'option 0x8000 n'est pas activée, seul l'index sur la colonne de la clé primaire est créé. | Crée une contrainte de clé primaire au niveau de l'Abonné. Tous les index liés à la contrainte sont également répliqués même si les options 0x10 et 0x40 ne sont pas activées (ces options contrôlent la création d'index pour d'autres cas).
0x4000 | Crée une contrainte ou un index. Si l'option 0x8000 est aussi activée, la contrainte unique est créée comme contrainte comportant un index. Si l'option 0x8000 n'est pas activée, seul l'index sur la colonne est créé. | Crée des contraintes uniques au niveau de l'Abonné. Tous les index liés à la contrainte sont également répliqués même si les options 0x10 et 0x40 ne sont pas activées (ces options contrôlent la création d'index pour d'autres cas).
0x8000 | Crée des contraintes de clé primaire et des contraintes uniques si les options 0x80 ou 0x4000 sont aussi spécifiées. Si aucune de ces options n'est spécifiée, l'option 0x8000 n'a aucun effet. | L'option n'a pas d'effet.

Modifications de comportement pour la réplication transactionnelle

Les modifications suivantes affectent la réplication transactionnelle.

Fonctionnalité Description

Appartenance de l'objet de l'Abonné

Lorsqu'il utilise l'Assistant Nouvelle publication SQL Server 2005 pour créer une publication, le propriétaire d'objets créés chez l'Abonné a par défaut la valeur du propriétaire de l'objet correspondant sur le serveur de publication. Dans les versions précédentes, le propriétaire n'était pas spécifié durant la création de l'objet chez l'Abonné ; il était par défaut le propriétaire associé au compte de l'Agent de distribution utilisé pour la connexion à l'Abonné. Le comportement n'est pas modifié pour la procédure stockée sp_addarticle (Transact-SQL).

Mode de sécurité des abonnements pouvant être mis à jour

Le paramètre @security_mode de sp_link_publication détermine comment les déclencheurs des abonnements de mise à jour immédiate exécutent des appels sur le serveur de publication. Dans SQL Server 2005, les options de ce paramètre sont les suivantes :

  • 0 : utilise l'authentification SQL Server avec la connexion spécifiée dans la procédure stockée en guise de nom d'utilisateur et de mot de passe.

  • 1 : utilise le contexte de sécurité (authentification SQL Server ou authentification intégrée de Windows) de l'utilisateur qui effectue la modification chez l'Abonné.

  • 2 : utilise la connexion de serveur lié existante, définie par l'utilisateur.

Dans les versions précédentes de SQL Server, l'option 0 était utilisée pour spécifier un appel de procédure distante dynamique (RPC, remote procedure call) de l'Abonné vers le serveur de publication plutôt qu'un serveur lié.

Modifications de comportement pour la réplication de fusion

Les modifications suivantes affectent la réplication de fusion.

Fonctionnalité Description

Niveau de compatibilité de la publication

Dans les versions précédentes de SQL Server, le niveau de compatibilité était automatiquement augmenté lorsque vous activiez une fonctionnalité à un niveau supérieur. Dans SQL Server 2005, vous devez manuellement affecter la valeur 90RTM au niveau de compatibilité avant d'activer la fonctionnalité qui requiert ce niveau de compatibilité. Pour plus d'informations, consultez la section « Niveau de compatibilité pour les publications de fusion » de Utilisation de plusieurs versions de SQL Server dans une topologie de réplication.

Mesures compensatoires

Dans les versions précédentes de SQL Server, des mesures compensatoires étaient prises si des erreurs (telles que des violations de contrainte) survenaient au cours de la synchronisation. Dans certains cas, ce comportement est souhaitable, mais dans d'autres cas, il peut poser problème ; par exemple, une configuration incorrecte de l'Abonné générant une erreur peut entraîner l'annulation des modifications sur le serveur de publication et tous les autres Abonnés.

Dans SQL Server 2005, le paramètre @compensate_for_errors de sp_addmergearticle vérifie si des mesures compensatoires sont prises. Lorsqu'il a la valeur False (valeur par défaut), les mesures compensatoires sont désactivées ; toutefois, les erreurs demeurent consignées et les fusions ultérieures continueront de tenter d'appliquer les modifications. Bien que les données des lignes affectées semblent non convergentes, dès que vous réparez l'erreur, la modification peut être appliquée et les données convergent. Lorsque ce paramètre a la valeur True, toute modification ne pouvant pas être appliquée à un nœud durant la synchronisation se traduit par des mesures compensatoires qui annulent la modification sur tous les autres nœuds.

Remarque :
Si la table source d'un article est déjà publiée dans une autre publication, la valeur de @compensate_for_errors doit être la même pour les deux articles. Pour les abonnements par extraction de données chez les Abonnés exécutant SQL Server 2000 version 8.00.858 et antérieures (qui incluent le Service Pack 3), les mesures compensatoires sont prises, même si @compensate_for_errors a la valeur False.

Tables de conflits

Dans les versions précédentes de SQL Server, la réplication de fusion créait une table de conflit unique pour chaque article de table inclus dans une publication, avec un nom au format conflict_<ArticleName>. Dans SQL Server 2005, les informations sont contenues dans deux tables : MSmerge_conflicts_info et une table portant un nom au format MSmerge_conflict_<PublicationName>_<ArticleName>.

Nettoyage des métadonnées par rétention

SQL Server 2005 utilise le nettoyage des métadonnées par rétention, qui a été introduit dans SQL Server 2000 Service Pack 1. Les métadonnées sont régulièrement supprimées des tables système suivantes :

  • MSmerge_contents

  • MSmerge_tombstone

  • MSmerge_genhistory

  • Toutes les tables avant image, s'il en existe. Les tables avant image existent si l'option d'optimisation de la synchronisation @keep_partition_changes est activée dans la publication (pour plus d'informations sur cette option, consultez la section suivante).

Paramètre @keep_partition_changes

Dans la version précédente de SQL Server, la valeur False était attribuée par défaut au paramètre@keep_partition_changes, car ceci permet de stocker davantage de données sur le serveur de publication. Le paramètre a maintenant la valeur True si le niveau de compatibilité de la publication est 90RTM ou supérieur et le paramètre @use_partition_groups a la valeur False. Pour plus d'informations sur ces options, consultez Filtres de lignes paramétrés.

Voir aussi

Concepts

Compatibilité descendante de la réplication


Utilisation de plusieurs versions de SQL Server dans une topologie de réplication

Utilisation de plusieurs versions de SQL Server dans une topologie de réplication |
 | Voir aussi
Mise à niveau vers SQL Server 2008 > Compatibilité ascendante > Compatibilité descendante de la réplication >

La réplication prend en charge la réplication de données vers différentes versions de SQL Server. Cette rubrique aborde les sujets suivants :

  • Versions de SQL Server prises en charge

  • Mappage des types de données de SQL Server 2008 pour les versions antérieures

  • Restauration d'une base de données répliquée à partir d'une version antérieure

  • Niveau de compatibilité pour les publications de fusion

Pour plus d'informations sur la façon de répliquer des données vers SQL Server Express et SQL Server Compact 3.5 SP1, consultez Réplication de données vers SQL Server Express et Réplication de données vers SQL Server Compact. Pour plus d'informations sur les fonctionnalités prises en charge par chaque édition de SQL Server, consultez Fonctionnalités prises en charge par les éditions de SQL Server 2008.

Versions de SQL Server prises en charge

SQL Server 2000 et SQL Server 2005 peuvent tous deux participer aux topologies de réplication avec SQL Server 2008. Pour SQL Server 2000 la version minimale est Service Pack 3 (SP3). Pour SQL Server 2005 la version minimale est Service Pack 2 (SP2).

Lorsque vous effectuez une réplication entre ou parmi des versions différentes de SQL Server, les fonctionnalités disponibles se limitent généralement à celles de la plus ancienne version utilisée. Par exemple, si vous mettez à niveau un serveur de distribution vers une instance de SQL Server 2008, mais que vous avez un serveur de publication qui exécute une instance de SQL Server 2005 et un Abonné qui exécute une instance de SQL Server 2000, vous êtes limité aux fonctionnalités générales et aux fonctionnalités de réplication de SQL Server 2000.

Remarque :
Le format de stockage sur disque de SQL Server étant le même dans les environnements 64 bits et 32 bits, une topologie de réplication peut combiner des instances de serveur qui s'exécutent dans un environnement 32 bits et des instances de serveur qui s'exécutent dans un environnement 64 bits.

Pour tous les types de réplication, la version du serveur de distribution ne doit pas être antérieure à la version du serveur de publication. (Dans la plupart des cas, les deux versions sont identiques.)

Pour la réplication transactionnelle, la version d'un Abonné à une publication transactionnelle peut être n'importe laquelle des deux versions du serveur de publication. Par exemple, un serveur de publication SQL Server 2000 peut avoir des Abonnés SQL Server 2008 et un serveur de publication SQL Server 2008 peut avoir des Abonnés SQL Server 2000.

Pour la réplication de fusion, un Abonné à une publication de fusion peut être n'importe quelle version antérieure à la version du serveur de publication. Pour plus d'informations sur la compatibilité des versions antérieures, consultez « Niveau de compatibilité pour les publications de fusion » plus loin dans cette rubrique. Pour plus d'informations sur les fonctionnalités de réplication prises en charge dans les différentes éditions de SQL Server, consultez Fonctionnalités prises en charge par les éditions de SQL Server 2008.

Utilisation d'un serveur de distribution SQL Server 2005 ou SQL Server 2008 avec un serveur de publication SQL Server 2000

SQL Server 2005 et SQL Server 2008 peuvent être utilisés comme serveur de distribution distant pour les serveurs de publication exécutant SQL Server 2000. Pour modifier les propriétés de l'agent dans ce cas de figure, exécutez les procédures stockées suivantes sur le serveur de distribution. Ces procédures vous permettent de modifier des propriétés introduites dans SQL Server 2005:

  • sp_MSchange_snapshot_agent_properties (Transact-SQL)

  • sp_MSchange_logreader_agent_properties (Transact-SQL)

  • sp_MSchange_distribution_agent_properties (Transact-SQL)

  • sp_MSchange_merge_agent_properties (Transact-SQL)

Si vous avez un serveur de publication et serveur de distribution qui exécutent SQL Server 2000, vous pouvez modifier les informations d'identification sous lesquelles les agents établissent des connexions à l'aide de sp_changedistpublisher et sp_changesubscriber. Toutefois, si vous mettez à niveau le serveur de distribution vers SQL Server 2008, ces procédures ne peuvent pas être utilisées pour modifier les informations d'identification utilisées dans les travaux d'agent existants. Les procédures affectent les travaux d'agent créés après que la procédure a été appelée. Pour modifier les informations d'identification des travaux d'agent existants, appelez l'une des quatre procédures répertoriées précédemment.

Mappage de nouveaux types de données pour les versions antérieures

SQL Server 2008 et SQL Server 2005 prennent en charge plusieurs nouveaux types de données. Comme illustré dans le tableau suivant, ces nouveaux types de données sont mappés vers des types de données compatibles chez l'Abonné si des abonnements par émission de données à partir d'un serveur de distribution de SQL Server 2005 ou SQL Server 2008 sont utilisés. Si les nouveaux types de données sont répliqués sur des Abonnés qui exécutent des versions antérieures de SQL Server, vous devez vérifier que les types de données sont mappés convenablement :

  • Le mappage est effectué par défaut pour les articles dans les publications de fusion, mais pas pour les articles dans les publications transactionnelles ou de capture instantanée. Pour les publications de fusion, la façon dont les types sont mappés est déterminée par le niveau de compatibilité de la publication. Par exemple, si une colonne est de type geography et que le niveau de compatibilité est 90RTM, le type est mappé avec varbinary(max). Si le niveau de compatibilité est 80RTM, le type est mappé avec image.

  • Le comportement de mappage est contrôlé par le paramètre @schema_option de sp_addarticle et sp_addmergearticle.

    Pour plus d'informations sur la façon de définir des options de schéma, consultez Procédure : spécifier des options de schéma (SQL Server Management Studio) et Procédure : spécifier des options de schéma (programmation Transact-SQL de la réplication).

Type de données de SQL Server 2008 | Type de données SQL Server 2005 | Type de données SQL Server 2000
Fonction CLR définie par l'utilisateur (UDT) : 8 000 octets ou moins | UDT | image
UDT : plus de 8 000 octets1 | varbinary(max) | image
date 2, 3 | nvarchar(10) | nvarchar(10)
datetime2 2, 3 | nvarchar(27) | nvarchar(27)
datetimeoffset 2, 3 | nvarchar(34) | nvarchar(34)
Attribut FILESTREAM 1, 4 | varbinary(max) | Non pris en charge
geography et geometry1, 3 | varbinary(max) | image
hierarchyid 1, 5 | varbinary(max) | image
nvarchar(max) | nvarchar(max) | ntext
time 2, 3 | nvarchar(16) | nvarchar(16)
varchar(max) | varchar(max) | text
varbinary(max) | varbinary(max) | image
xml | xml | ntext

1 Les mappages pour les types UDT, FILESTREAM, geography, geometry et hierarchyid ne sont pas pris en charge pour les publications transactionnelles avec les abonnements pouvant être mis à jour. Incluez uniquement ces types si tous les Abonnés de mise à jour exécutent SQL Server 2008 ou une version ultérieure.

2 La réplication ne vérifie pas le format des données insérées au niveau de l'Abonné. Par conséquent, votre application doit s'assurer que les données insérées sont du format correct pour les colonnes de type date, datetime2, datetimeoffset et time. Pour cela, on utilise en général une contrainte. Si les données ne sont pas du format correct, l'insertion au niveau du serveur de publication échoue.

3 Les Abonnés SQL Server Compact 3.5 convertissent ces types après qu'ils ont été répliqués sur l'Abonné. Pour plus d'informations sur les mappages des types de données pour SQL Server Compact 3.5, consultez la documentation SQL Server Compact 3.5.

Si vous mappez des colonnes de type geography ou geometry à varbinary(max) ou image, vous ne pouvez pas répliquer de contraintes par défaut pour ces colonnes. Les conséquences sont les suivantes :

  • Si vous avez déjà une contrainte par défaut sur le serveur de publication, supprimez la contrainte ou indiquez qu'elle ne doit pas être répliquée. Pour spécifier qu'elle ne doit pas être répliquée, utilisez l'option de schéma d'article pour les contraintes par défaut :

    • Sélectionnez une valeur False pour l'option Copier les spécifications de valeurs par défaut. Pour plus d'informations, consultez Procédure : spécifier des options de schéma (SQL Server Management Studio).

    • Désactivez l'option de schéma 0x800. Pour plus d'informations, consultez Procédure : spécifier des options de schéma (programmation Transact-SQL de la réplication).

  • Si vous souhaitez ajouter une contrainte par défaut sur le serveur de publication, spécifiez d'abord que les modifications de schéma ne doivent pas être répliquées. Pour plus d'informations, consultez Procédure : répliquer des modifications de schéma (SQL Server Management Studio) et Procédure : répliquer des modifications de schéma (programmation Transact-SQL de la réplication).

4 FILESTREAM est un attribut sur une colonne varbinary(max). Pour plus d'informations sur l'utilisation de colonnes FILESTREAM dans les tables répliquées, consultez la section « Replication » de Utilisation de FILESTREAM avec d'autres fonctionnalités SQL Server. Les colonnes ayant l'attribut FILESTREAM ne doivent pas être incluses dans les publications qui utilisent une capture instantanée de mode caractère.

5 La prise en charge des colonnes de type hierarchyid dépend du type de réplication et des versions de SQL Server utilisées. Pour plus d'informations, consultez la section « Utilisation de colonnes hierarchyid dans les tables répliquées » de la rubrique hierarchyid (Transact-SQL). Pour la réplication de fusion, hierarchyid est mappé avec image lorsque le niveau de compatibilité de la publication est 100RTM et qu'une capture instantanée de mode caractère est utilisée.

Réplication de types de données XML

Lors de la réplication de types de données XML vers SQL Server Compact 3.5 SP1, la réplication de fusion les mappe avec Ntext. Les données XML sur SQL Server 2008 ont des octets de préfixe pour le codage UTF-16. Ces octets sont conservés lors de la réplication de SQL Server vers SQL Server Compact 3.5 SP1 en utilisant la réplication de fusion. Ces octets de préfixe ne sont pas compris par SQL Server Management Studio lors de l'affichage de la colonne Ntext de la base de données SQL Server Compact 3.5 SP1. Par conséquent, ces octets sont affichés sous la forme de caractères incompréhensibles.

La collection de schémas XML dans SQL Server 2008 a été mise à jour. Cela a un effet lors de la réplication de colonnes XML liées à des schémas XML de SQL Server 2008 vers SQL Server 2005.

Les fuseaux horaires ne sont pas obligatoires pour les valeurs de schéma XML date, time et datetime dans SQL Server 2008. Cela signifie que si aucun fuseau horaire n'est spécifié sur la colonne XML du serveur de publication SQL Server 2008, la modification ne sera pas appliquée aux abonnés SQL Server 2005 car SQL Server 2005 exige qu'un fuseau horaire soit spécifié.

Les informations de fuseau horaire relatives aux valeurs typées de schéma XML date, time et datetime de serveur de publication SQL Server 2008 seront converties au fuseau horaire UTC-0 dans SQL Server 2005. Cela est représenté par l'indicateur de fuseau horaire Z.

Les types date, time et datetime du schéma XML SQL Server 2008 prennent en charge une précision plus élevée. Par conséquent, ces valeurs sont arrondies lors de la réplication vers SQL Server 2005.

Lors de la réplication de valeurs date ou datetime de schéma XML de SQL Server 2005 vers SQL Server 2008, les valeurs avec une année négative ne sont pas appliquées sur SQL Server 2008 car elles ne sont pas prises en charge sur SQL Server 2008.

Dans ces situations, les méthodes sp_table_validation et Validate sur les agents de réplication peuvent échouer. Pour plus d'informations, consultez la section « Mise à niveau de XML typé de SQL Server 2005 vers SQL Server 2008 » dans Comparaison du XML typé et du XML non typé.

Publication de données compressées

SQL Server 2008 prend en charge la compression de page et de ligne pour les tables et les index. Pour plus d'informations sur la prise en charge de la réplication pour les données compressées, consultez « Impact de la compression sur la réplication » dans Création de tables et d'index compressés.

Restauration d'une base de données répliquée à partir d'une version antérieure

Vous pouvez conserver les paramètres de réplication lors de la restauration d'une sauvegarde d'une base de données répliquée à partir d'une version antérieure. Si vous effectuez les restaurations vers un serveur et une base de données du même nom que le serveur et la base de données à l'origine de la sauvegarde ou si vous spécifiez l'option KEEP_REPLICATION, les paramètres de la réplication sont préservés. Pour plus d'informations, consultez RESTORE (Transact-SQL). Après avoir restauré la base de données, exécutez sp_vupgrade_replication pour mettre à niveau les données système et de schéma pour prendre en charge la réplication dans la version actuelle du produit.

Même s'il est possible de préserver la réplication après une restauration à partir d'une sauvegarde d'une version antérieure, celle-ci est rarement utilisée comme option de mise à niveau. Il est plus courant de mettre à niveau la base de données répliquée dans le cadre d'une mise à niveau du produit ou de recréer la base de données et la configuration de réplication à partir d'un jeu de scripts.

Niveau de compatibilité pour les publications de fusion

La réplication de fusion utilise le niveau de compatibilité de la publication pour déterminer les fonctionnalités qui peuvent être utilisées par les publications dans une base de données donnée. Les valeurs se situent dans la plage de 80RTM (SQL Server 2000 sans Service Pack installé) à 100RTM pour SQL Server 2008. Le niveau de compatibilité est spécifié par l'une des méthodes suivantes :

  • En utilisant le paramètre @publication_compatibility_level de sp_addmergepublication. Pour plus d'informations, consultez Procédure : définir le niveau de compatibilité des publications de fusion (programmation Transact-SQL de la réplication).

  • Dans la page Types d'abonnés de l'Assistant Nouvelle publication. Pour plus d'informations sur l'exécution de cet Assistant, consultez Procédure : créer une publication et définir des articles (SQL Server Management Studio).

  • Dans la page Général de la boîte de dialogue Propriétés de la publication - <Publication>. Pour plus d'informations, consultez Procédure : définir le niveau de compatibilité pour les publications de fusion (SQL Server Management Studio).

Les fonctionnalités suivantes nécessitent un niveau de compatibilité de 90RTM ou supérieur :

  • Enregistrements logiques. Pour plus d'informations, consultez Regroupements des modifications apportées à des lignes connexes à l'aide d'enregistrements logiques.

  • Options de téléchargement de l'Abonné. Pour plus d'informations, consultez Optimisation des performances de la réplication de fusion avec les articles en téléchargement seul.

  • Partitions qui ne se chevauchent pas. Pour plus d'informations, consultez Filtres de lignes paramétrés.

  • Gestionnaires de logique métier. Pour plus d'informations, consultez Exécution de la logique métier lors de la synchronisation de fusion.

  • Modifications de schéma qui utilisent des instructions ALTER <OBJECT>. Pour plus d'informations, consultez Modification du schéma dans les bases de données de publication.

Les fonctionnalités suivantes ne dépendent pas du niveau de compatibilité ; toutefois, ils nécessitent l'Agent de fusion fourni avec SQL Server 2005 et versions ultérieures. Les Abonnés qui exécutent des versions antérieures de SQL Server fonctionnent comme si la fonctionnalité n'était pas activée.

  • Partitions précalculées. Pour plus d'informations, consultez Optimisation des performances des filtres paramétrés avec des partitions précalculées.

  • Synchronisation Web. Pour plus d'informations, consultez Synchronisation Web pour la réplication de fusion.

  • Agents de phases parallèles (en spécifiant -ParallelUploadDownload pour l'Agent de fusion). Pour plus d'informations, consultez Agent de fusion de réplication.

  • Les fonctionnalités de capture instantanée pour les publications qui utilisent des filtres paramétrés. Ces fonctionnalités fournissent les capacités suivantes :

    • pour un Abonné de demander une capture instantanée s'il n'y en a pas de disponible pour sa partition ;

    • pour un administrateur de prégénérer et de planifier la génération de captures instantanéee ;

    • de livrer des captures instantanées paramétrées en utilisant FTP.

    Pour plus d'informations, consultez Captures instantanées des publications de fusion avec des filtres paramétrés et Transfert de captures instantanées via FTP.

  • Enregistrement de l'historique amélioré et statistiques de niveau article dans le Moniteur de réplication Pour plus d'informations, consultez Procédure : afficher des informations et effectuer des tâches relatives à un abonnement (moniteur de réplication).

Comportement du niveau de compatibilité de la publication dans SQL Server 2008

Voici quelques comportements importants du niveau de compatibilité de publication à considérer :

  • Le niveau de compatibilité de la publication n'est pas lié au niveau de compatibilité de la base de données.

  • Si vous créez une publication à l'aide de sp_addmergepublication ou via Replication Management Objects (RMO), le niveau de compatibilité de la publication est défini par défaut à 80RTM. Si vous créez une publication dans l'Assistant Nouvelle publication, le niveau de compatibilité de la publication est déterminé selon les options sélectionnées dans la page Types d'Abonnés de l'Assistant.

  • Dans les versions de SQL Server antérieures à SQL Server 2005, le niveau de compatibilité de la publication était automatiquement augmenté lorsque vous activiez une fonctionnalité à un niveau supérieur. À compter de SQL Server 2005, vous devez manuellement affecter la valeur 90RTM ou plus au niveau de compatibilité de la publication avant d'activer la fonctionnalité qui requiert ce niveau de compatibilité.

  • Le niveau de compatibilité de la publication peut uniquement être abaissé si l'Agent de capture instantanée n'a pas démarré et qu'il n'y a pas d'abonnement à la publication.

  • Toutes les publications de la même base de données doivent avoir le même niveau de compatibilité. Cette exigence entraîne les conséquences suivantes :

    • Si une base de données contient une publication qui a le niveau de compatibilité le plus bas (en l'occurrence, 80RTM) et que vous voulez ajouter une publication dans la base ayant le niveau 90RTM ou plus, vous devez augmenter manuellement le niveau de compatibilité de la première publication avant d'ajouter la nouvelle.

    • Si une base de données contient plusieurs publications avec des niveaux de compatibilité inférieurs et que vous souhaitez ajouter une autre publication dans la même base de données avec un niveau de 90RTM ou plus, vous devez supprimer toutes les publications existantes à l'exception d'une seule, augmenter le niveau de la publication restante vers 90RTM ou plus, recréer les publications supprimées au niveau 90RTM ou plus et créer la nouvelle publication avec un niveau de 90RTM ou plus.

Composants requis et niveaux de compatibilité pour la synchronisation Web

SQL Server 2008 prend en charge la synchronisation Web pour les Abonnés qui exécutent SQL Server 2005, SQL Server 2008 et SQL Server Compact 3.5 versions 3.0, 3.1 et 3.5. Le tableau suivant répertorie le niveau de compatibilité de publication et les composants serveur requis pour chaque type d'Abonné.

Version du serveur de publication | Version d'Abonné | Niveau de compatibilité de publication requis | Composants requis sur le serveur IIS
SQL Server 2008 | SQL Server 2008 | 100RTM | Composants IIS de SQL Server 2008
SQL Server 2008 | SQL Server Compact 3.5 3.0, 3.1 et 3.5 | 90RTM | Composants IIS SQL Server Compact 3.5 SP1 et composants IIS SQL Server 2008
SQL Server 2008 | SQL Server 2005 | 90RTM | Composants IIS de SQL Server 2008
SQL Server 2005 | SQL Server 2005 | 90RTM | Composants IIS de SQL Server 2005
SQL Server 2005 | SQL Server Compact 3.5 3.0, 3.1 et 3.5 | 90RTM | Composants IIS SQL Server Compact 3.5 SP1 et composants IIS SQL Server 2005
SQL Server 2005 | SQL Server 2008 | Non applicable1 | Non applicable1

1 Cette configuration n'est pas prise en charge car la version de serveur de publication doit être supérieure ou égale à la version d'Abonné.

Voir aussi

Concepts

Compatibilité descendante de la réplication
Considérations relatives à la mise à niveau de bases de données répliquées


Migration vers SQL Server 2008

Migration vers SQL Server 2008 |
 | Voir aussi

La migration d'une installation de SQL Server vers SQL Server 2008 est utile si vous êtes confronté à un blocage de la mise à niveau, si vos exigences incluent un déploiement à grande échelle ou un temps d'exécution spécifique, ou si vous modifiez le matériel ou la topologie de votre installation. Le processus de migration comprend des étapes manuelles et des étapes automatiques. Les rubriques suivantes décrivent le processus de migration :

Dans cette section

Rubrique | Description
Procédure : migrer une installation Reporting Services | Fournit des informations sur la migration de versions Reporting Services précédentes vers SQL Server 2008.
Mise à niveau de packages Integration Services | Fournit des informations sur la migration des packages Integration Services vers SQL Server 2008.
Migration des packages DTS | Fournit des informations sur la migration de packages DTS (Data Transformation Services) vers SQL Server 2008.

Voir aussi

Concepts

Compatibilité ascendante


Mise à niveau de packages Integration Services

Mise à niveau de packages Integration Services |
 | Voir aussi
Migration vers SQL Server 2008 >

Lorsque vous mettez à niveau une instance de SQL Server 2005 vers SQL Server 2008, vos packages SQL Server 2005 Integration Services (SSIS) existants ne sont pas automatiquement mis à niveau vers le format de package qu'utilise SQL Server 2008 Integration Services (SSIS). Vous devez choisir une méthode de mise à niveau et mettre à niveau vos packages SQL Server 2005 manuellement.

Lorsque vous mettez à niveau un package SQL Server 2005, Integration Services effectue une migration des scripts de toute tâche de script et de tout composant Script vers Microsoft Visual Studio Tools for Applications (VSTA). Dans SQL Server 2005, les scripts des tâches de script ou des composants Script utilisaient Microsoft Visual Studio for Applications (VSA). Pour plus d'informations sur les modifications que vous devrez peut-être effectuer avant la migration et sur l'échec de conversion de scripts, consultez Migration de scripts vers VSTA.

Choix d'une méthode de mise à niveau

Vous pouvez utiliser différentes méthodes pour mettre à niveau des packages SQL Server 2005. Pour certaines d'entre elles, la mise à niveau n'est que temporaire. Pour d'autres, elle est définitive. Le tableau suivant décrit chacune de ces méthodes et indique si la mise à niveau est temporaire ou définitive.

Méthode de mise à niveau Type de mise à niveau

Utiliser l'utilitaire dtexec (dtexec.exe) installé avec SQL Server 2008 pour exécuter un package SQL Server 2005.

Pour plus d'informations, consultez Utilitaire dtexec.

La mise à niveau de packages et la migration des scripts sont temporaires.

Les modifications ne peuvent pas être enregistrées.

Ajouter un package SQL Server 2005 à un projet existant ou ouvrir un package SQL Server 2005 dans SQL Server 2008 Integration Services.

La mise à niveau de packages est définitive si vous enregistrez le package, sinon, elle est temporaire.

La migration des scripts est permanente si vous ajoutez le package à un projet existant. Elle l'est également si vous ouvrez le package et enregistrez les modifications de conversion ; elle est temporaire si vous n'enregistrez pas les modifications de conversion.

Utiliser l'Assistant Mise à niveau de packages SSIS pour créer ou ouvrir un projet SQL Server 2005 Integration Services et mettre à niveau plusieurs packages du projet.

Pour plus d'informations, consultez Procédure : mettre à niveau des packages Integration Services à l'aide de l'Assistant Mise à niveau de packages SSIS et Aide sur l'Assistant Mise à niveau de packages SSIS via la touche F1.

La mise à niveau de packages et la migration des scripts sont définitives.

Présentation des résultats de mise à niveau de packages

Au cours de la mise à niveau de packages, la plupart des composants et fonctionnalités des packages SQL Server 2005 sont convertis de façon transparente en leurs équivalents SQL Server 2008. Il est toutefois certains composants pour lesquels aucune mise à niveau ne sera effectuée ou pour lesquels vous devez connaître les résultats. Le tableau suivant identifie ces composants et fonctionnalités.

Remarque :
Pour identifier les packages concernés par les points répertoriés dans le tableau, exécutez le Conseiller de mise à niveau. Pour plus d'informations, consultez Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau.

Composant ou fonctionnalité Résultats de la mise à niveau

Chaînes de connexion

Les noms de certains fournisseurs ont changé dans SQL Server 2008 et requièrent des valeurs différentes dans les chaînes de connexion.

Pour mettre à jour les chaînes de connexion, utilisez l'une des procédures suivantes :

  • Utilisez l'Assistant Mise à niveau de packages SSIS pour mettre à niveau le package et sélectionnez l'option Mettre à jour les chaînes de connexion pour l'utilisation des nouveaux noms de fournisseurs.

  • Dans Business Intelligence Development Studio, dans la boîte de dialogue Options, sélectionnez l'option Mettre à jour les chaînes de connexion pour l'utilisation des nouveaux noms de fournisseurs.

  • Dans Business Intelligence Development Studio, ouvrez le package et modifiez manuellement le texte de la propriété ConnectionString.

Transformation de recherche

Le processus de mise à niveau de packages effectue automatiquement une mise à niveau de la transformation de recherche vers la version SQL Server 2008. Toutefois, la version SQL Server 2008 de ce composant propose des fonctions supplémentaires dont vous souhaiterez peut-être tirer parti.

Pour plus d'informations, consultez Transformation de recherche.

Tâche de script et composant Script

Le processus de mise à niveau de packages effectue automatiquement une migration des scripts de la tâche de script et du composant Script de VSA vers VSTA.

Pour plus d'informations sur les modifications que vous devrez peut-être effectuer avant la migration et sur l'échec de conversion de scripts, consultez Migration de scripts vers VSTA.

Composants tiers et personnalisés

Ces composants ne seront pas mis à niveau. Pour qu'ils fonctionnent avec SQL Server 2008 Integration Services, vous devez les recompiler manuellement.

Voir aussi

Concepts

Migration vers SQL Server 2008


Migration de scripts vers VSTA

Migration de scripts vers VSTA |
 | Voir aussi
Migration vers SQL Server 2008 > Mise à niveau de packages Integration Services >

Lorsque vous mettez à niveau des packages SQL Server 2005 vers SQL Server 2008, Integration Services migre les scripts des tâches de script ou des composants Script vers Microsoft Visual Studio Tools for Applications (VSTA). VSTA est l'environnement de script que SQL Server 2008 Integration Services (SSIS) utilise. Dans SQL Server 2005, l'environnement de script pour Integration Services est Microsoft Visual Studio for Applications (VSA).

Si les scripts font référence à des interfaces ou utilisent des valeurs dont le type est défini par l'utilisateur, il peut être nécessaire de modifier ces scripts avant de mettre à niveau le package. Si vous ne le faites pas, et selon la méthode de mise à niveau choisie, vous pouvez être confronté à un échec de mise à niveau du package ou de validation du script. Le tableau ci-dessous décrit les modifications à apporter au code.

Tâche | Description
Modifier les références aux interfaces | Remplacez les références aux interfaces IDTSxxx90 par des références aux interfaces IDTSxxx100 correspondantes. Cette tâche s'applique aux tâches de script et aux composants Script.
Modifier les objets de type | Si, dans des variables d'exécution, des valeurs d'un type défini par l'utilisateur ne sont pas définies dans les assemblys mscorlib.dll ou Microsoft.SqlServer.VSTAScriptTaskPrx.dll, modifiez les types de sorte qu'ils héritent de System.MarshalByRefObject. Cette tâche s'applique uniquement aux tâches de script.

Pour plus d'informations sur la migration des scripts et la mise à niveau des packages, consultez Mise à niveau de packages Integration Services.

Présentation des échecs de migration

Lorsque vous migrez les scripts, la migration peut échouer pour l'une des raisons suivantes :

  • Le point d'entrée du script VSA a été renommé.

    Le point d'entrée spécifie dans la classe ScriptMain du projet VSTA la méthode que le runtime Integration Services utilise comme point d'entrée du code de tâche de script. La classe ScriptMain est celle que génèrent par défaut les modèles de script.

  • Le script VSA ne contient aucun point d'entrée ou en contient plusieurs.

  • Des références d'assemblys n'ont pas pu être ajoutées.

  • La classe ScriptMain a été modifiée de façon à hériter d'autres classes en plus de la classe ScriptObjectModelSSIS. Microsoft .NET Framework ne prend pas en charge l'héritage multiple.

Vous ne pouvez pas convertir un script VSA qui utilise Visual Basic 2005 en script VSTA qui utilise Microsoft Visual C# 2008. Toutefois, vous pouvez créer un script VSTA qui utilise Microsoft Visual C# 2008. Pour plus d'informations, consultez Coding and Debugging the Script Task et Coding and Debugging the Script Component.

Voir aussi

Autres ressources

Extending Packages with Scripting


Procédure : mettre à niveau des packages Integration Services à l'aide de l'Assistant Mise à niveau de packages SSIS

Procédure : mettre à niveau des packages Integration Services à l'aide de l'Assistant Mise à niveau de packages SSIS
Migration vers SQL Server 2008 > Mise à niveau de packages Integration Services >

Vous pouvez mettre à niveau des packages créés dans des versions antérieures de Integration Services vers le format Integration Services utilisé par SQL Server 2008. SQL Server fournit un Assistant Mise à niveau de packages SSIS à cet effet. Étant donné que vous pouvez configurer l'Assistant pour qu'il sauvegarde vos packages d'origine, vous pouvez continuer à les utiliser si vous rencontrez des problèmes de mise à niveau.

L'Assistant Mise à niveau de packages SSIS est installé lors de l'installation de Integration Services.

Remarque :
L'Assistant Mise à niveau de packages SSIS est disponible dans les éditions Standard, Enterprise et Developer de SQL Server.

Pour plus d'informations sur la mise à niveau des packages Integration Services, consultez Mise à niveau de packages Integration Services.

Remarque :
Pour plus d'informations sur la migration de packages créés dans SQL Server 2000 Data Transformation Services (DTS), consultez Migration des packages DTS.

Le reste de cette rubrique décrit comment exécuter l'Assistant et sauvegarder les packages d'origine.

Exécution de l'Assistant Mise à niveau de packages SSIS

Vous pouvez exécuter l'Assistant Mise à niveau de packages SSIS à partir de Business Intelligence Development Studio, de SQL Server Management Studio ou de l'invite de commandes.

Pour exécuter l'Assistant à partir de Business Intelligence Development Studio

  1. Dans Business Intelligence Development Studio, créez ou ouvrez un projet Integration Services.

  2. Dans l'Explorateur de solutions, cliquez avec le bouton droit sur le nœud Packages SSIS, puis cliquez sur Mettre à niveau tous les packages pour mettre à niveau tous les packages sous ce nœud.

    Remarque :
    Lorsque vous ouvrez un projet Integration Services qui contient des packages SQL Server 2005 Integration Services (SSIS), Integration Services ouvre automatiquement l'Assistant Mise à niveau de packages SSIS.

Pour exécuter l'Assistant à partir de SQL Server Management Studio

  • Dans SQL Server Management Studio, connectez-vous à Integration Services, développez le nœud Packages stockés, cliquez avec le bouton droit sur le nœud Système de fichiers ou MSDB, puis cliquez sur Mettre à niveau les packages.

Pour exécuter l'Assistant à l'invite de commandes

  • À l'invite de commandes, exécutez le fichier SSISUpgrade.exe à partir du dossier C:\Program Files\Microsoft SQL Server\100\DTS\Binn.

Sauvegarde des packages d'origine

Pour sauvegarder les packages d'origine, les packages d'origine et les packages mis à niveau doivent être stockés dans le même dossier du système de fichiers. Selon la façon dont vous exécutez l'Assistant, cet emplacement de stockage peut être sélectionné automatiquement :

  • Lorsque vous exécutez l'Assistant Mise à niveau de packages SSIS à partir de Business Intelligence Development Studio, l'Assistant stocke automatiquement à la fois les packages d'origine et les packages mis à niveau dans le même dossier dans le système de fichiers. Vous pouvez configurer l'Assistant pour sauvegarder les packages d'origine.

  • Lorsque vous exécutez l'Assistant Mise à niveau de packages SSIS à partir de SQL Server Management Studio ou de l'invite de commandes, vous pouvez spécifier différents emplacements de stockage pour les packages d'origine et les packages mis à niveau. Pour sauvegarder les packages d'origine, n'oubliez pas de spécifier que les packages d'origine et les packages mis à niveau sont stockés dans le même dossier du système de fichiers. Si vous spécifiez d'autres options de stockage, l'Assistant ne sera pas en mesure de sauvegarder les packages d'origine.

Lorsqu'il sauvegarde les packages d'origine, l'Assistant stocke une copie des packages d'origine dans un dossier SSISBackupFolder. Il crée le dossier SSISBackupFolder en tant que sous-dossier du dossier qui contient les packages d'origine et les packages mis à niveau.

Pour sauvegarder les packages d'origine dans SQL Server Management Studio ou à l'invite de commandes

  1. Enregistrez les packages d'origine à un emplacement du système de fichiers.

    Remarque :
    L'option de sauvegarde de l'Assistant fonctionne uniquement avec les packages stockés dans le système de fichiers.

  2. Dans SQL Server Management Studio ou à l'invite de commandes, exécutez l'Assistant Mise à niveau de packages SSIS.

  3. Dans la page Sélectionner l'emplacement source de l'Assistant, définissez la propriété Source du package à Système de fichiers.

  4. Dans la page Sélectionner l'emplacement de destination de l'Assistant, sélectionnez Enregistrer à l'emplacement source pour enregistrer les packages mis à niveau au même emplacement que kes packages d'origine.

    Remarque :
    L'option de sauvegarde de l'Assistant n'est disponible que lorsque les packages mis à niveau sont stockés dans le même dossier que les packages d'origine.

  5. Dans la page Sélectionner les options de gestion des packages de l'Assistant, sélectionnez l'option Sauvegarder les packages d'origine.

Pour sauvegarder les packages d'origine dans Business Intelligence Development Studio

  1. Enregistrez les packages d'origine à un emplacement du système de fichiers.

    Remarque :
    L'option de sauvegarde de l'Assistant fonctionne uniquement avec les packages stockés dans le système de fichiers.

  2. Dans Business Intelligence Development Studio, exécutez l'Assistant Mise à niveau de packages SSIS.

  3. Dans la page Sélectionner les options de gestion des packages de l'Assistant, sélectionnez l'option Sauvegarder les packages d'origine.


Procédure : migrer une installation Reporting Services

Procédure : migrer une installation Reporting Services |
 | Voir aussi
Migration vers SQL Server 2008 >

Cette rubrique fournit les instructions étape par étape qui vous permettront d'effectuer la migration d'un déploiement SQL Server 2000 ou SQL Server 2005 Reporting Services vers une nouvelle instance de SQL Server 2008 Reporting Services. La migration s'entend ici comme étant le déplacement de fichiers de données d'application vers une nouvelle instance de SQL Server 2008. Vous devez effectuer la migration de votre installation si vous êtes confronté à un blocage de la mise à niveau, si vos exigences incluent un déploiement à grande échelle ou un temps d'exécution spécifique, ou si vous modifiez le matériel ou la topologie de votre installation.

Le processus de migration pour Reporting Services comprend des étapes manuelles et des étapes automatiques. Les tâches suivantes sont inhérentes au processus de migration d'un serveur de rapports :

  • Sauvegardez les fichiers de base de données, de configuration et d'application.

  • Sauvegardez la clé de chiffrement.

  • Installez une nouvelle instance de SQL Server 2008. Si vous utilisez le même matériel, vous pouvez installer SQL Server 2008 côte à côte avec votre installation SQL Server 2000 ou 2005 existante. Sachez toutefois que si vous en décidez ainsi, vous devez installer SQL Server 2008 en tant qu'instance nommée.

  • Déplacez la base de données du serveur de rapports et les autres fichiers d'application de votre installation SQL Server 2000 ou 2005 vers votre nouvelle installation SQL Server 2008.

  • Déplacez tous les fichiers d'application personnalisés vers la nouvelle installation.

  • Configurez le serveur de rapports.

  • Modifiez RSReportServer.config pour y inclure tous les paramètres personnalisés de votre installation précédente.

  • Le cas échéant, configurez des listes de contrôle d’accès (ACL, Access Control List) personnalisées pour le nouveau groupe du service Windows Reporting Services.

  • Testez votre installation.

  • Supprimez les applications et outils inutiles après avoir vérifié que la nouvelle instance est complètement opérationnelle.

Si vous réutilisez une base de données de serveur de rapports existante créée au cours d'une installation précédente, notez que des restrictions s'appliquent pour les éditions de SQL Server que vous utilisez pour héberger la base de données du serveur de rapports. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports.

Avant de commencer

Même si vous effectuez une migration et non une mise à niveau de l'installation, pensez à exécuter le Conseiller de mise à niveau sur votre installation existante ; cela vous permettra d'identifier les problèmes susceptibles d'affecter la migration. Cette étape est particulièrement utile si vous migrez un serveur de rapports que vous n'avez pas installé ou configuré vous-même. En exécutant le Conseiller de mise à niveau, vous pouvez trouver des informations sur des paramètres personnalisés qui peuvent ne pas être pris en charge dans une nouvelle installation de SQL Server 2008.

Vous devez en outre prendre connaissance de plusieurs modifications importantes introduites dans SQL Server 2008 et décrites ci-dessous, qui affecteront la manière dont vous migrerez votre installation.

  • IIS n'est plus indispensable. Si vous effectuez une migration d'une installation du serveur de rapports vers un nouvel ordinateur, il n'est pas nécessaire d'ajouter le rôle de serveur Web. De plus, la procédure de configuration des URL et de l'authentification diffère par rapport à la précédente version, de même que les techniques et outils de diagnostic et de résolution des problèmes.

  • Le service Web Report Server, le Gestionnaire de rapports et le service Windows Report Server ont été regroupés en un seul service Report Server. Ces trois applications s'exécutent sous le même compte. Toutes les trois lisent les paramètres de configuration du fichier RSReportServer.config, ce qui rend obsolète le fichier RSWebApplication.config.

  • Le Gestionnaire de rapports et SQL Server Management Studio ont été repensés de manière à supprimer les fonctionnalités à double emploi. Chaque outil prend en charge un ensemble de tâches distinct ; les outils ne sont plus interchangeables.

  • Les filtres ISAPI ne sont pas pris en charge dans SQL Server 2008 Reporting Services. Si vous utilisez des filtres ISAPI, vous devez reconcevoir votre solution de création de rapports avant la migration.

  • Les restrictions d'adresse IP ne sont pas prises en charge dans SQL Server 2008 Reporting Services. Si vous utilisez des restrictions d'adresse IP, vous devez revoir votre solution de création de rapports avant la migration ou utiliser une technologie telle qu'un pare-feu, un routeur ou un traducteur d'adresses réseau (NAT, Network Address Translation) pour configurer des adresses restreintes pouvant accéder au serveur de rapports.

  • Les certificats SSL (Secure Sockets Layer) client ne sont pas prises en charge dans SQL Server 2008 Reporting Services. Si vous utilisez des certificats SSL clients, vous devez reconcevoir votre solution de création de rapports avant la migration.

  • Si vous utilisez un type d'authentification autre que l'authentification intégrée Windows, vous devez mettre à jour l'élément <AuthenticationTypes> dans le fichier RSReportServer.config avec un type d'authentification pris en charge. Les types d'authentification pris en charge sont NTLM, Kerberos, Negotiate et Basic. Les authentifications Digest, .NET Passport et anonyme ne sont pas prises en charge dans SQL Server 2008 Reporting Services.

  • Si vous utilisez des feuilles de style en cascade personnalisées dans votre environnement de création de rapports, elles ne seront pas migrées. Vous devez les déplacer manuellement après la migration.

Pour plus d'informations sur les changements effectués dans SQL Server 2008 Reporting Services, consultez la documentation relative au Conseiller de mise à niveau et Nouveautés (Reporting Services).

Sauvegarde des fichiers et des données

Avant d'installer une nouvelle instance de Reporting Services, assurez-vous de sauvegarder tous les fichiers de votre installation actuelle.

  1. Sauvegardez la clé de chiffrement de la base de données du serveur de rapports. Cette étape est cruciale pour le succès de la migration. En effet, à un stade plus avancé du processus de migration, vous devrez la restaurer pour rendre au serveur de rapports l'accès aux données chiffrées. Pour sauvegarder la clé, utilisez l'outil de configuration de Reporting Services (ou l'utilitaire rskeymgmt si vous effectuez la migration à partir de SQL Server 2000).

  2. Sauvegardez la base de données du serveur de rapports en utilisant l'une des méthodes prises en charge pour la sauvegarde d'une base de données SQL Server. Pour plus d'informations, consultez les instructions relatives à la sauvegarde de la base de données du serveur de rapports dans Déplacement des bases de données du serveur de rapports vers un autre ordinateur.

  3. Sauvegardez les fichiers de configuration du serveur de rapports. Les fichiers à sauvegarder sont les suivants :

    1. Rsreportserver.config

    2. Rswebapplication.config

    3. Rssvrpolicy.config

    4. Rsmgrpolicy.config

    5. Reportingservicesservice.exe.config

    6. Web.config pour les applications ASP.NET Report Server et Gestionnaire de rapports.

    7. Machine.config pour ASP.NET si vous l'avez modifié pour les opérations du serveur de rapports.

Installation de SQL Server 2008 Reporting Services

Installez une nouvelle instance du serveur de rapports en mode fichiers uniquement ; vous pourrez ainsi la configurer pour une utilisation de valeurs autres que celles définies par défaut. Pour une installation via la ligne de commande, utilisez l'argument FilesOnly. Dans l'Assistant Installation, sélectionnez l'option Installer mais ne pas configurer le serveur.

Cliquez sur l'un des liens suivants pour obtenir des instructions sur l'installation d'une nouvelle instance de Reporting Services :

  • Procédure : installer SQL Server 2008 (programme d'installation)

  • Procédure : installer SQL Server 2008 à partir de l'invite de commandes

Déplacement de la base de données du serveur de rapports

La base de données du serveur de rapports contient des rapports publiés, des modèles, des sources de données partagées, des planifications, des ressources, des abonnements et des dossiers. Elle contient également des propriétés système et d'élément, ainsi que les autorisations d'accès au contenu du serveur de rapports.

Si votre migration comprend l'utilisation d'une autre instance du Moteur de base de données, vous devez déplacer la base de données du serveur de rapports vers la nouvelle instance du Moteur de base de données. Si vous utilisez la même instance du Moteur de base de données, passez à « Configuration du serveur de rapports ».

Pour déplacer la base de données du serveur de rapports, procédez comme suit :

  1. Choisissez l'instance du Moteur de base de données à utiliser. SQL Server 2008 Reporting Services requiert l'utilisation de SQL Server 2005 ou 2008 pour l'hébergement de la base de données du serveur de rapports. SQL Server 2000 ne peut plus être utilisé pour héberger la base de données du serveur de rapports pour SQL Server 2008 Reporting Services. Si vous avez utilisé SQL Server 2000 ou SQL Server 2005 exécuté en mode de compatibilité 8.0, vous devez mettre à niveau le Moteur de base de données ou choisir une autre instance du Moteur de base de données.

  2. Démarrez SQL Server Management Studio et connectez-vous au Moteur de base de données.

  3. Créez le RSExecRole dans les bases de données système si le Moteur de base de données n'a jamais hébergé une base de données du serveur de rapports. Pour plus d'informations, consultez Procédure : créer le rôle RSExecRole.

  4. Suivez les instructions fournies dans Déplacement des bases de données du serveur de rapports vers un autre ordinateur.

N'oubliez pas que la base de données du serveur de rapports et la base de données temporaire dépendent l'une de l'autre et doivent être déplacées simultanément. Ne copiez pas les bases de données ; la copie ne transfère pas tous les paramètres de sécurité vers la nouvelle installation. Ne déplacez pas de travaux de l'Agent SQL Server pour les opérations planifiées du serveur de rapports. Le serveur de rapports recrée automatiquement ces travaux.

Déplacement des assemblys ou extensions personnalisés

Si votre installation comprend des éléments de rapport, des assemblys ou des extensions personnalisés, vous devez redéployer les composants personnalisés. Si vous n'êtes pas dans ce cas, passez à « Configuration du serveur de rapports ».

Pour redéployer les composants personnalisés, procédez comme suit :

  1. Déterminez si les assemblys sont pris en charge ou doivent être recompilés :

    • Les extensions d'authentification personnalisées créées pour la version SQL Server 2000 doivent être recompilées.

    • Les extensions de rendu personnalisées pour SQL Server 2008 Reporting Services doivent être réécrites à l'aide de ROM (Rendering Object Model).

    • Les convertisseurs HTML 3.2 et HTML OWC ne sont pas pris en charge dans SQL Server 2008 Reporting Services.

    • Les autres assemblys personnalisés ne devraient pas nécessiter de recompilation.

  2. Déplacez les assemblys vers le nouveau serveur de rapports et les dossiers \bin du Gestionnaire de rapports. Dans SQL Server 2008, les fichiers binaires du serveur de rapports se trouvent dans \Program files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\bin pour l'instance SQL Server 2008 Reporting Services par défaut.

  3. Modifiez les fichiers de configuration de façon à y ajouter des entrées pour votre composant personnalisé. Les entrées à ajouter dépendent du type d'assembly que vous utilisez. Pour obtenir des instructions sur l'endroit où placer des fichiers et ajouter des entrées de configuration, consultez les rubriques suivantes :

    1. Deploying a Custom Assembly

    2. How to: Deploy a Custom Report Item

    3. Deploying a Data Processing Extension

    4. Deploying a Delivery Extension

    5. Deploying a Rendering Extension

    6. Implementing a Security Extension

Configuration du serveur de rapports

Configurez les URL du service Web Report Server et du Gestionnaire de rapports, ainsi que la connexion à la base de données du serveur de rapports.

Si vous migrez un déploiement avec montée en puissance parallèle, mettez tous les nœuds du serveur de rapports hors connexion et migrez les serveurs un par un. Une fois que le premier serveur de rapports est migré et qu'il se connecte avec succès à la base de données du serveur de rapports, la version de la base de données du serveur de rapports est automatiquement mise à niveau vers la version de la base de donnée SQL Server 2008.

Remarque :
Si l'un des serveurs de rapports dans le déploiement avec montée en puissance parallèle est en ligne et n'a pas été migré, il peut rencontrer une exception rsInvalidReportServerDatabase parce qu'il utilise un schéma plus ancien lorsqu'il est connecté aux éléments mis à niveau.

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de Reporting Services que vous venez d'installer. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

  2. Configurez les URL du serveur de rapports et du Gestionnaire de rapports. Pour plus d'informations, consultez Procédure : configurer une URL (configuration de Reporting Services).

  3. Configurez la base de données du serveur de rapports, en sélectionnant la base de données du serveur de rapports de votre installation précédente. Une fois la configuration réussie, les services de serveur de rapports redémarreront, et une fois la connexion établie avec la base de données du serveur de rapports, la base de données sera mise à niveau automatiquement vers SQL Server 2008 Reporting Services. Pour plus d'informations sur l'exécution de l'Assistant Modification de base de données que vous utilisez pour créer ou sélectionner une base de données du serveur de rapports, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

  4. Restaurez les clés de chiffrement. Cette étape est indispensable pour activer le chiffrement réversible sur les chaînes de connexion préexistantes et les informations d'identification déjà présentes dans la base de données du serveur de rapports. Pour plus d'informations, consultez Sauvegarde et restauration des clés de chiffrement.

  5. Si vous avez installé le serveur de rapports sur un nouvel ordinateur et que vous utilisez le Pare-feu Windows, assurez-vous que le port TCP sur lequel le serveur de rapports est à l'écoute est ouvert. Par défaut, il s'agit du port 80. Pour plus d'informations, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

  6. Si vous avez installé le serveur de rapports sur Windows Vista ou Windows Server 2008, créez des attributions de rôles et ajoutez le site du serveur de rapports aux Sites de confiance pour en permettre une administration locale. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

Copie des paramètres de configuration personnalisés dans le fichier RSReportServer.config

Si vous avez modifié le fichier RSReportServer.config ou RSWebApplication.config dans l'installation précédente, vous devez apporter les mêmes modifications au nouveau fichier RSReportServer.config. La liste suivante résume certaines des raisons pour lesquelles vous avez pu modifier le fichier de configuration précédent et fournit des liens vers des informations supplémentaires sur la manière de configurer les mêmes paramètres dans SQL Server 2008.

Personnalisation | Informations
Remise du courrier électronique du serveur de rapports avec des paramètres personnalisés | Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)
Extensions pour le traitement des données | Configuration des extensions pour le traitement des données dans Reporting Services
Paramètres d'informations de périphérique | Personnalisation des paramètres d'extension de rendu dans RSReportServer.Config
Gestionnaire de rapports sur une instance distante | Procédure : configurer le Gestionnaire de rapports

Groupe de service Windows et ACL de sécurité

Dans SQL Server 2008 Reporting Services, il existe un groupe de service, le groupe de service Windows Reporting Services, utilisé pour créer des listes de contrôle d’accès (ACL) de sécurité pour toutes les clés de Registre, les fichiers et les dossiers installés avec SQL Server 2008 Reporting Services. Ce nom de groupe Windows apparaît dans le format SQLServerReportServerUser$<computer_name>$<instance_name>. Ce groupe prend la place des deux groupes de service Windows dans SQL Server 2005 Reporting Services. Si vous avez des listes de contrôle d’accès (ACL) personnalisées associées à l'un ou l'autre des groupes Windows SQL Server 2005 Reporting Services, vous devrez appliquer ces ACL au nouveau groupe pour votre nouvelle instance de serveur de rapports dans SQL Server 2008 Reporting Services.

Vérification de votre déploiement

  1. Testez les répertoires virtuels du serveur de rapports et du Gestionnaire de rapports en ouvrant un navigateur et en tapant une adresse URL dans le champ approprié. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services.

  2. Testez les rapports et assurez-vous qu'ils contiennent les données attendues. Passez en revue les informations de la source de données pour vérifier si ses informations de connexion sont toujours spécifiées. Le serveur de rapports utilise le modèle objet des rapports SQL Server 2008 lors du traitement et du rendu des rapports, mais il ne remplace pas les constructions SQL Server 2000 ou 2005 par de nouveaux éléments RDL (Report Definition Language). Pour en savoir plus sur l'exécution de rapports existants sur un serveur de rapports SQL Server 2008, consultez Mise à niveau de rapports.

Suppression des programmes et fichiers inutiles

Une fois que vous avez effectué avec succès une migration de votre serveur de rapports vers une instance SQL Server 2008 Reporting Services, vous pouvez éventuellement effectuer les étapes suivantes pour supprimer des programmes et des fichiers qui ne sont plus nécessaires.

  1. Désinstallez la version précédente de Reporting Services si elle n'est plus nécessaire. Cette étape ne supprime pas les éléments suivants, mais vous pouvez les supprimer manuellement si vous n'en avez plus besoin :

    • Ancienne base de données du serveur de rapports

    • Rôle RsExec

    • Comptes de service du serveur de rapports

    • Pool d'applications du service Web Report Server

    • Répertoires virtuels pour le serveur de rapports et le Gestionnaire de rapports

    • Fichiers journaux du serveur de rapports

  2. Supprimez IIS si vous n'en avez plus besoin sur cet ordinateur.

  3. Supprimez RSActivate.exe (des installations SQL Server 2000 uniquement).

Voir aussi

Concepts

Considérations sur la mise à niveau de Reporting Services

Autres ressources

Base de données de Report Server
Compatibilité descendante de Reporting Services
Outil de configuration de Reporting Services


Configuration de SQL Server 2008

Configuration de SQL Server 2008 |
 | Voir aussi

Une fois SQL Server installé, vous pouvez configurer davantage SQL Server à l'aide d'utilitaires graphiques et d'invite de commandes. Le tableau suivant décrit la prise en charge d'outils utilisés pour gérer une instance SQL Server :

Outil ou Utilitaire | Description
SQL Server Management Studio | SQL Server Management Studio est utilisé pour modifier et exécuter des requêtes et pour démarrer des tâches d'Assistant standard. Pour plus d'informations, consultez Présentation de SQL Server Management Studio.
Générateur de profils SQL Server | Générateur de profils SQL Server fournit une interface utilisateur graphique qui permet d'analyser une instance du Moteur de base de données SQL Server ou d'Analysis Services. Pour plus d'informations, consultez Présentation du Générateur de profils SQL Server.
Assistant Paramétrage du Moteur de base de données | L'Assistant Paramétrage du Moteur de base de données vous permet de créer des jeux d'index, des vues indexées et des partitions optimaux. Pour plus d'informations, consultez Utilisation de l'Assistant Paramétrage du moteur de base de données.
Business Intelligence Development Studio | Business Intelligence Development Studio est un environnement de développement intégré pour les solutions Analysis Services et Integration Services. Pour plus d'informations, consultez Présentation de Business Intelligence Development Studio.
Utilitaires d'invite de commandes | Vous pouvez gérer les objets SQL Server à partir de l'invite de commandes. Pour plus d'informations, consultez Utilitaires d'invite de commandes.
Gestionnaire de configuration SQL Server | Vous pouvez gérer les paramètres de configuration réseau du client et du serveur. Pour plus d'informations, consultez Gestionnaire de configuration SQL Server.
Importation et exportation de données | Integration Services propose des outils graphiques et des objets programmables permettant de déplacer, de copier et de transformer les données. Pour plus d'informations, consultez Vue d'ensemble (Integration Services).
Programme d'installation de SQL Server | Installer, mettre à niveau vers ou modifier les composants dans une instance de SQL Server. Pour plus d'informations, consultez Rubriques de procédures relatives à l'installation.

Voir aussi

Concepts

Configuration de Reporting Services

Autres ressources

Administration (moteur de base de données)


Validation d'une installation SQL Server

Validation d'une installation SQL Server |
 | Voir aussi
Configuration de SQL Server 2008 >

Pour vérifier une installation réussie de SQL Server 2008, assurez-vous que les services des composants que vous avez choisi d'installer sont en cours d'exécution sur votre ordinateur.

Utilisez la liste suivante de services pour vérifier que le service SQL Server est en cours d'exécution. Le tableau qui suit dresse la liste des noms complets des services, ainsi que des services qu'ils fournissent.

Remarque :
Les noms de service réels diffèrent légèrement de leurs noms complets. Pour les afficher, cliquez avec le bouton droit sur un service et sélectionnez Propriétés.

Si le service n'est pas en cours d'exécution, démarrez-le en cliquant dessus avec le bouton droit , puis en cliquant sur Démarrer. Si un service ne parvient pas à démarrer, recherchez le chemin d'accès au fichier .exe dans ses propriétés. Assurez-vous que le fichier .exe existe dans le chemin spécifié.

Nom | Service
SQL Server (MSSQLSERVER) | Instance par défaut du Moteur de base de données SQL Server.
SQL Server (nom_instance) | Instance nommée du Moteur de base de données SQL Server, où instance_nom désigne le nom de l'instance.
SQL Server Agent (MSSQLSERVER) | Instance par défaut de SQL Server Agent. SQL Server Agent exécute les travaux, surveille SQL Server, déclenche les alertes et permet d'automatiser certaines tâches administratives.
SQL Server Agent (nom_instance) | Instance nommée de SQL Server Agent, où instance_nom désigne le nom de l'instance. SQL Server Agent exécute les travaux, surveille SQL Server, déclenche les alertes et permet d'automatiser certaines tâches administratives.
Analysis Services (MSSQLSERVER) | Instance par défaut de Analysis Services.
Analysis Services (nom_instance) | Instance nommée d'Analysis Services, où nom_instance désigne le nom de l'instance.
Reporting Services | Instance par défaut de Reporting Services.
Reporting Services (nom_instance) | Instance nommée de Reporting Services, où nom_instance désigne le nom de l'instance.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Configuration de Reporting Services

Configuration de Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 >

Utilisez l'outil de configuration Reporting Services pour configurer une installation de SQL Server Reporting Services. Si vous avez installé un serveur de rapports à l'aide de l'option Fichiers uniquement, vous devez utiliser cet outil pour configurer le serveur et pouvoir vous en servir. Si vous avez installé un serveur de rapports avec l'option d'installation de configuration par défaut, vous pouvez utiliser cet outil pour vérifier ou modifier les paramètres spécifiés au cours de l'installation. Si vous procédez à une mise à niveau à partir d'une version antérieure, vous pouvez utiliser cet outil pour mettre à jour la base de données du serveur de rapports dans le nouveau format.

L'outil de configuration de Reporting Services peut servir à configurer une instance de serveur de rapports locale ou distante. Vous devez disposer des droits d'un administrateur local sur l'ordinateur hébergeant le serveur de rapports que vous configurez.

Dans cette section

Terme | Définition
Configuration du compte de service Report Server | Fournit des recommandations et des procédures pour la modification du compte de service et du mot de passe.
Configuration des URL de Report Server | Décrit comment configurer les URL qui servent à accéder au service Web Report Server et au Gestionnaire de rapports.
Création d'une base de données de serveur de rapports | Décrit comment créer une base de données de serveur de rapports en vue du stockage des métadonnées et des objets du serveur.
Configuration d'une connexion de base de données de serveur de rapports | Décrit comment modifier la chaîne de connexion qu'utilise le serveur de rapports pour se connecter à la base de données du serveur de rapports.
Configuration du compte d'exécution sans assistance | Décrit comment configurer un compte d'utilisateur de manière à traiter les rapports en mode sans assistance.
Configuration d'un Report Server pour la remise du courrier électronique | Décrit comment configurer un serveur de rapports pour la prise en charge de la distribution des rapports par messagerie.
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services | Fournit des informations sur la configuration de plusieurs instances du serveur de rapports pour utiliser une base de données partagée du serveur de rapports.
Configuration de Reporting Services pour l'intégration de SharePoint 3.0 | Fournit une vue d'ensemble des tâches et spécifications requises pour ajouter un serveur de rapports au déploiement existant d'un produit ou technologie SharePoint.
Configuration et gestion des clés de chiffrement | Explique comment utiliser et gérer les clés de chiffrement utilisées pour le stockage de données sensibles.
Rubriques d'aide à la configuration de Reporting Services | Fournit des instructions, étape par étape, pour les tâches les plus courantes.
Rubriques d'aide F1 sur la configuration de Reporting Services | Fournit des rubriques d'aide sur les pages de l'outil de configuration de Reporting Services.

Documentation en ligne de SQL Server

L'aide en ligne pour l'outil de configuration de Reporting Services est un sous-ensemble de la documentation du produit pour SQL Server Reporting Services. La documentation complète du produit est disponible dans la documentation en ligne de SQL Server.

Lorsque vous utilisez la documentation en ligne de SQL Server, vous avez accès à toutes les rubriques fournies dans le système d'aide en ligne, ainsi qu'à du contenu supplémentaire sur le déploiement, l'administration et la sécurisation de l'installation de Reporting Services. Pour plus d'informations, consultez Mise en route de la documentation en ligne de SQL Server.

Voir aussi

Concepts

Considérations sur l'installation de Reporting Services

Autres ressources

Nouvelle installation (Reporting Services)
Mise à niveau (Reporting Services)
Configuration d'une installation de serveur de rapports


Configuration du compte de service Report Server

Configuration du compte de service Report Server |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Reporting Services est implémenté en tant que service unique qui contient un service Web Report Server, le Gestionnaire de rapports et une application de traitement en arrière-plan utilisée pour le traitement des rapports planifié et la remise d'abonnement. Cette rubrique explique comment le compte de service est configuré initialement et comment modifier le compte ou le mot de passe à l'aide de l'outil de configuration de Reporting Services. Pour plus d'informations sur les applications qui exécutent le service, consultez Architecture du service (Reporting Services) dans la documentation en ligne de Microsoft SQL Server.

Configuration initiale

Le compte de service Report Server est défini pendant l'installation. Vous pouvez exécuter le service au moyen d'un compte d'utilisateur de domaine ou d'un compte intégré tel que NetworkService. Il n'y a aucun compte par défaut ; le compte que vous spécifiez dans la page Configuration de SQL Server - Comptes de service de l'Assistant Installation devient le compte initial du service Report Server.

Important :
Bien que le service Web Report Server et le Gestionnaire de rapports soient des applications ASP.NET, elles ne s'exécutent pas sous le compte ASP.NET. L'architecture de service unique exécute les deux applications ASP.NET dans la même identité de processus Report Server. Il s'agit d'une modification importante par rapport aux versions précédentes, dans lesquelles le service Web Report Server et le Gestionnaire de rapports s'exécutaient sous l'identité du processus de travail ASP.NET spécifiée dans les services Internet (IIS).

Modification du compte de service

Pour afficher et reconfigurer des informations sur le compte de service, utilisez toujours l'outil de configuration Reporting Services. Les informations sur l'identité du service sont stockées en interne dans plusieurs emplacements. L'utilisation de l'outil garantit que toutes les références sont mises à jour en conséquence chaque fois que vous modifiez le compte ou le mot de passe. L'outil de configuration Reporting Services exécute les étapes supplémentaires suivantes pour s'assurer que le serveur de rapports reste disponible :

  • Il ajoute automatiquement le nouveau compte au groupe de serveurs de rapports créés sur l'ordinateur local. Ce groupe est spécifié dans les listes de contrôle d'accès qui assurent la sécurité des fichiers de Reporting Services.

  • Il met à jour automatiquement les autorisations de connexion sur l'instance du Moteur de base de données SQL Server utilisée pour héberger la base de données du serveur de rapports. Le nouveau compte est ajouté au rôle RSExecRole.

    La connexion de base de données pour l'ancien compte n'est pas supprimée automatiquement. Assurez-vous de supprimer les comptes qui ne sont plus utilisés. Pour plus d'informations, consultez Administration d'une base de données du serveur de rapports.

    L'accord des autorisations de base de données au nouveau compte de service a lieu uniquement si vous avez configuré en premier lieu la connexion de base de données du serveur de rapports de façon à utiliser le compte de service. Si vous avez configuré la connexion de base de données du serveur de rapports de façon à utiliser un compte d'utilisateur de domaine ou une connexion de base de données SQL Server, les informations de connexion ne sont pas affectées par la mise à jour du compte de service.

  • Il met à jour automatiquement la clé de chiffrement pour inclure les informations de profil du nouveau compte.

    Remarque :
    Si le serveur de rapports est intégré au déploiement avec montée en puissance parallèle, seul le serveur de rapports en cours de mise à jour est affecté. Il n'y a aucune incidence sur les clés de chiffrement des autres serveurs de rapports de ce déploiement.

Pour obtenir des instructions sur la définition du compte, consultez Procédure : configurer un compte de service pour Reporting Services.

Choix d'un compte

Vous pouvez configurer le service Report Server pour qu'il s'exécute sous l'un des types de comptes suivants :

  • Compte d'utilisateur Windows le moins privilégié

  • NetworkService

  • LocalSystem

  • LocalService

Il n'existe pas d'approche optimale unique pour le choix d'un type de compte. Chaque compte présente des avantages et des inconvénients que vous devez prendre en compte. Si vous déployez Reporting Services sur un serveur de production, les meilleures pratiques suggèrent de configurer le service pour qu'il s'exécute sous un compte d'utilisateur de domaine, afin d'éviter tout dommage étendu en cas de détournement d'un compte partagé par un utilisateur malveillant. Cela simplifie également l'audit de l'activité d'ouverture de session pour ce compte. L'un des inconvénients liés à l'utilisation d'un compte d'utilisateur Windows est que si vous déployez Reporting Services dans un réseau qui utilise l'authentification Kerberos, vous devez inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom principal de service (SPN) pour Report Server.

Les instructions et les liens suivants de cette section peuvent vous aider à choisir l'approche la plus appropriée pour votre déploiement.

  • Compte de service (configuration de Reporting Services).

  • Configuration des comptes de service Windows dans la documentation en ligne de SQL Server.

  • Guide de planification de la sécurité des services et des comptes de service (en anglais) sur MSDN.

Mise à jour d'un mot de passe expiré

Si le service Report Server s'exécute sous un compte de domaine et que le mot de passe expire avant que vous puissiez le mettre à jour dans l'outil de configuration de Reporting Services, le service ne démarrera pas tant que vous n'aurez pas spécifié un nouveau mot de passe. Si le service ne peut pas être démarré, vous ne pouvez pas utiliser l'outil de configuration de Reporting Services pour vous connecter à ce serveur afin de mettre à jour le compte. Dans ce cas, vous devez utiliser une combinaison d'outils pour remettre le serveur en ligne.

Pour réinitialiser le mot de passe, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Panneau de configuration, sur Outils d'administration, puis cliquez sur Services.

  2. Cliquez avec le bouton droit sur SQL Server Reporting Services, puis sélectionnez Propriétés.

  3. Cliquez sur Ouvrir une session et entrez le nouveau mot de passe.

  4. Après avoir mis à jour le mot de passe, démarrez l'outil de configuration de Reporting Services et mettez à jour le mot de passe dans la page Compte de service. Cette étape supplémentaire est nécessaire pour mettre à jour les informations de compte stockées de manière interne par le serveur de rapports.

Si le mot de passe du compte de service pour le Moteur de base de données expire, l'erreur rsReportServerDatabaseUnavailable se produit si vous tentez de vous connecter au serveur de rapports. La réinitialisation du mot de passe résout cette erreur. Pour afficher le texte complet du message d'erreur, consultez Dépannage des problèmes de connexion à un serveur et à une base de données.

Configuration du service Report Server pour un serveur de rapports intégré à SharePoint

Si vous exécutez un serveur de rapports en mode intégré SharePoint, vous devez mettre à jour les informations de compte de service stockées dans la base de données de configuration SharePoint si l'une des conditions suivantes est remplie :

  • Modification du compte de service Reporting Services (par exemple, basculement de NetworkService vers un compte d'utilisateur de domaine).

  • Extension d'une batterie de serveurs SharePoint de façon à inclure une application Web SharePoint supplémentaire. Si la batterie de serveurs est configurée pour l'intégration au serveur de rapports et que l'application nouvellement ajoutée est configure pour s'exécuter sous un compte d'utilisateur différent de celui des autres applications de la batterie, vous devez mettre à jour les informations d'accès à la base de données.

Une fois les informations d'accès à la base de données réinitialisées, vous devez redémarrer le service Windows SharePoint Services pour vous assurer que l'ancienne connexion n'est plus utilisée.

  1. Dans Outils d'administration, cliquez sur Administration centrale de SharePoint 3.0.

  2. Cliquez sur Gestion des applications.

  3. Dans la section Reporting Services, cliquez sur Accorder l'accès à la base de données.

  4. Cliquez sur OK. La boîte de dialogue Entrer les informations d'identification s'affiche.

  5. Entrez les informations d'identification d'un utilisateur membre du groupe Administrateurs local sur l'ordinateur qui héberge le serveur de rapports. Ces informations seront utilisées pour une connexion ponctuelle à l'ordinateur du serveur de rapports afin de récupérer les informations du compte de service. Le nom de connexion de base de données créé pour chaque compte de service est mis à jour dans les bases de données SharePoint.

  6. Pour redémarrer le service, cliquez sur Opérations.

  7. Dans Topologie et services, cliquez sur Services sur le serveur.

  8. Pour Application Web de Windows SharePoint Services, cliquez sur Arrêter.

  9. Attendez que le service s'arrête.

  10. Cliquez sur Démarrer.

Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services
Procédure : démarrer la configuration de Reporting Services

Référence

Compte de service (configuration de Reporting Services)
Configuration des comptes de service Windows

Concepts

Configuration des URL de Report Server

Autres ressources

Déploiement (Reporting Services)
Planification des services, des comptes et des connexions
Démarrage et arrêt du service Report Server


Configuration des URL de Report Server

Configuration des URL de Report Server |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Dans Reporting Services, les URL permettent d'accéder au service Web Report Server et au Gestionnaire de rapports. Avant de pouvoir utiliser l'une et l'autre application, vous devez configurer au moins une URL pour le service Web et pour le Gestionnaire de rapports. Reporting Services fournit des valeurs par défaut pour les deux URL qui fonctionnent correctement dans la plupart des scénarios de déploiement, y compris les déploiements côte à côte avec les autres applications et services Web.

  • Si vous avez installé la configuration par défaut, les URL ont été créées automatiquement à l'aide des valeurs par défaut.

  • Si vous utilisez l'outil de configuration de Reporting Services pour créer ou modifier les URL, vous pouvez accepter les valeurs par défaut pour une URL ou spécifier des valeurs personnalisées. Un lien de test de l'URL apparaît sur la page lorsque vous définissez l'URL afin que vous puissiez confirmer immédiatement que les paramètres vous avez spécifiés résultent en une connexion valide. Pour les instructions pas à pas sur la configuration et le test d'une URL, consultez Procédure : configurer une URL (configuration de Reporting Services).

Définition d'une URL de serveur de rapports

L'URL identifie précisément l'emplacement d'une instance d'une application du serveur de rapports sur votre réseau. Lorsque vous créez une URL de serveur de rapports, vous devez spécifier les éléments suivants.

Élément | Description
Nom d'hôte | Un réseau TCP/IP utilise une adresse IP pour identifier de manière unique un périphérique sur le réseau. Il existe une adresse IP physique pour chaque carte réseau installée dans un ordinateur. Si l'adresse IP est résolue en en-tête d'hôte, vous pouvez spécifier l'en-tête de l'hôte. Si vous déployez le serveur de rapports sur un réseau d'entreprise, vous pouvez utiliser le nom réseau de l'ordinateur.
Port | Un port TCP est un point de terminaison sur le périphérique. Le serveur de rapports écoute les demandes sur un port désigné.
Répertoire virtuel | Un port est souvent partagé par plusieurs applications ou services Web. Pour cette raison, une URL de serveur de rapports inclut toujours un répertoire virtuel qui correspond à l'application obtenant la demande. Vous devez spécifier des noms de répertoire virtuel uniques pour chaque application Reporting Services qui écoute sur les mêmes port et adresse IP.
Paramètres SSL | Les URL de Reporting Services peuvent être configurées pour utiliser un certificat SSL existant que vous avez installé précédemment sur l'ordinateur. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer).

URL par défaut

Lorsque vous accédez à un serveur de rapports ou au Gestionnaire de rapports via son URL, celle-ci doit inclure le nom d'hôte et pas l'adresse IP. Sur un réseau TCP/IP, l'adresse IP se résout en un nom d'hôte (ou le nom de réseau de l'ordinateur). Si vous avez utilisé les valeurs par défaut pour configurer les URL, vous devez être en mesure d'accéder au service Web Report Server à l'aide d'URL qui spécifient le nom d'ordinateur ou localhost comme nom d'hôte :

  • http://<nom_ordinateur>/serveur_de_rapports

  • http://hôtelocal/serveurderapports

Les paramètres qui rendent cet URL disponibles apparaissent dans le tableau suivant. Ce tableau montre les valeurs par défaut qui activent une connexion de serveur de rapports via les URL incluant un nom d'hôte :

Élément | Valeur | Explication
Adresse IP | Assigné | Le service DNS (Domain Name Service) de votre réseau résout le nom d'hôte sur l'URL en adresse IP de l'ordinateur. Tant que l'adresse IP est spécifiée dans l'URL que vous définissez, une demande envoyée à un hôte spécifique atteint sa cible.
Port | 80 | Le port 80 est le port par défaut pour les connexions TCP/IP sur un ordinateur. Comme le serveur de rapports écoute sur le port 80, vous pouvez omettre le numéro de port de l'URL. Si vous spécifiez un autre port, vous devez le spécifier dans l'URL.
Répertoire virtuel | ReportServer | Remarquez que les deux exemples d'URL incluent le nom de répertoire virtuel. À moins que vous ne personnalisiez la définition d'URL, vous devez toujours spécifier le nom du répertoire virtuel de l'application dans l'URL.
Remarque :
Une réservation d'URL sous-jacente active tout nom d'hôte valide à utiliser dans une URL. L'outil de configuration de Reporting Services crée une réservation d'URL dans HTTP.SYS à l'aide de la syntaxe qui permet aux variations du nom d'hôte de se résoudre en une instance de serveur de rapports particulière. Pour plus d'informations sur les réservations d'URL, consultez À propos des réservations et de l'inscription d'URL (Reporting Services).

Autorisations côté serveur sur une URL de serveur de rapports

Les autorisations sur chaque point de terminaison d'une URL sont accordées exclusivement au compte de service Report Server. Seul ce compte possède les droits pour accepter les demandes dirigées vers les URL Reporting Services. Les listes de contrôle d'accès discrétionnaire (DACL) sont créées et maintenues pour le compte lorsque vous configurez l'identité de service à travers le programme d'installation ou l'outil de configuration de Reporting Services. Si vous modifiez le compte de service, l'outil de configuration de Reporting Services met à jour toutes les réservations d'URL que vous avez créées pour recueillir les nouvelles informations sur le compte. Pour plus d'informations, consultez Syntaxe de réservation d'URL (Reporting Services).

Authentification des demandes de clients envoyées à une URL de serveur de rapports

Par défaut, le type d'authentification pris en charge sur les points de terminaison d'URL est l'authentification Windows. Il s'agit de l'extension de sécurité par défaut. Si vous implémentez un fournisseur d'authentifications personnalisé ou par formulaire, vous devez modifier les paramètres d'authentification sur le serveur de rapports. Le cas échéant, vous pouvez aussi modifier les paramètres d'authentification Windows afin qu'ils correspondent au sous-système d'authentification utilisé dans votre réseau. Pour plus d'informations, consultez Configuration de l'authentification dans Reporting Services.

Dans cette section

Procédure : configurer une URL (configuration de Reporting Services)

Cette rubrique fournit des instructions pour définir et modifier une réservation d'URL dans l'outil de configuration de Reporting Services.

À propos des réservations et de l'inscription d'URL (Reporting Services)

Les URL sont utilisées pour accéder aux applications et aux rapports. Cette rubrique explique les URL d'application et les URL par défaut, ainsi que la façon dont l'inscription et les réservations d'URL fonctionnent dans Reporting Services.

Syntaxe de réservation d'URL (Reporting Services)

Les réservations d'URL par défaut que Reporting Services utilise sont valides pour la plupart des scénarios. Toutefois, si vous souhaitez restreindre l'accès ou étendre le déploiement pour activer l'accès Internet ou extranet, il se peut que vous ayez à personnaliser les paramètres pour qu'ils correspondent à vos impératifs. Cette rubrique décrit la syntaxe d'une réservation d'URL et fournit des recommandations pour créer des réservations personnalisées pour votre déploiement.

URL des fichiers de configuration (Reporting Services)

Le fichier RSReportServer.config contient plusieurs entrées pour les réservations d'URL et les URL utilisées par le Gestionnaire de rapports et la remise du courrier électronique du serveur de rapports. Cette rubrique résume les paramètres de configuration d'URL afin que vous puissiez apprendre à les comparer.

Réservations d'URL pour les déploiements de serveur de rapports multi-instance

Lorsque vous installez plusieurs instances de Reporting Services sur un même ordinateur, vous augmentez la probabilité de rencontrer une duplication d'URL lors de l'inscription. Pour éviter ces erreurs, suivez les recommandations de cette rubrique pour créer des réservations d'URL spécifiques à l'instance.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

URL du service Web (configuration de Reporting Services)

Autres ressources

Fichier de configuration RSReportServer
Consultation de rapports avec des composants WebPart de SharePoint 2.0
Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer)
Configuration d'une installation de serveur de rapports


À propos des réservations et de l'inscription d'URL (Reporting Services)

À propos des réservations et de l'inscription d'URL (Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration des URL de Report Server >

Les URL pour les applications Reporting Services sont définies en tant que réservations d'URL dans HTTP.SYS. Une réservation d'URL définit la syntaxe d'un point de terminaison URL à une application Web. Les réservations d'URL sont définies pour le service Web Report Server et pour le Gestionnaire de rapports lorsque vous configurez les applications sur le serveur de rapports. Les réservations d'URL sont créées automatiquement pour vous lors de la configuration d'URL par le biais du programme d'installation ou de l'outil de configuration Reporting Services :

  • Le programme d'installation crée des réservations d'URL à l'aide de valeurs par défaut. Si le programme d'installation installe la configuration par défaut, il réserve deux URL : une pour le service Web Report Server et une autre pour le Gestionnaire de rapports. Vous pouvez utiliser l'outil de configuration Reporting Services pour ajouter davantage d'URL ou modifier les URL par défaut créées par le programme d'installation.

  • L'outil de configuration Reporting Services crée une réservation d'URL basée sur l'URL que vous spécifiez dans les pages URL du service Web ou URL du Gestionnaire de rapports dans l'outil.

Le programme d'installation et l'outil assignent également des autorisations sur l'URL au service Report Server, vérifient s'il existe des instances en double et ajoutent la réservation d'URL à HTTP.SYS. Vous ne devez jamais créer ou modifier une réservation d'URL Reporting Services directement à l'aide de HttpCfg.exe ou d'un autre outil. Si vous ignorez une étape ou si vous avez défini une valeur non valide, vous rencontrerez des problèmes qui pourront être difficiles à diagnostiquer ou à résoudre.

Remarque :
HTTP.SYS est un composant du système d'exploitation qui écoute les demandes réseau et les transfère vers une file d'attente de demandes. Dans cette version de Reporting Services, HTTP.SYS établit et maintient la file d'attente de demandes pour le service Web Report Server et le Gestionnaire de rapports. Les services Internet (IIS) ne sont plus utilisés pour héberger ou accéder aux applications Reporting Services. Pour plus d'informations sur la fonctionnalité HTTP.SYS, consultez HTTP Server API sur MSDN.

Dans cette rubrique

Cette rubrique présente les URL, les réservations et l'inscription d'URL, les valeurs par défaut et des recommandations spécifiques au déploiement que vous devez suivre si vous créez ou modifiez des URL pour différentes configurations de serveur. Elle contient les sections suivantes :

  • URL dans Reporting Services

  • Réservation et inscription d'URL

  • URL par défaut

  • Authentification et identité de service pour les URL Reporting Services

  • URL pour l'administration locale

  • URL pour le déploiement avec montée en puissance parallèle

  • URL pour le mode intégré SharePoint

Pour plus d'informations sur la construction et l'utilisation des URL dans une installation Reporting Services ou sur la résolution des problèmes liés à la réservation ou à l'inscription, consultez Configuration des URL de Report Server et Dépannage de problèmes liés aux erreurs de configuration.

URL dans Reporting Services

Dans une installation Reporting Services, vous pouvez accéder aux outils, applications et éléments suivants par le biais d'URL :

  • Service Web Report Server

  • Gestionnaire de rapports

  • Générateur de rapports

  • Rapports ayant été publiés sur un serveur de rapports

Les autres éléments publiés adressables par URL, tels que les modèles et sources de données partagées, ne doivent pas être accédés par le biais d'URL en tant qu'éléments autonomes. Le serveur de rapports n'affiche pas ces éléments dans un format explicite lorsqu'ils sont affichés dans une fenêtre de navigateur.

Remarque :
Cette rubrique ne décrit pas l'accès par le biais d'URL au Générateur de rapports ou à des rapports spécifiques stockés sur le serveur de rapports. Pour plus d'informations sur l'accès à ces éléments de rapport par le biais d'URL, consultez Démarrage du Générateur de rapports et Using a URL to Access Report Server Items dans la documentation en ligne de SQL Server.

Réservation et inscription d'URL

Une réservation d'URL définit les URL qui peuvent être utilisées pour accéder à une application Reporting Services. Reporting Services réservera une ou plusieurs URL pour le service Web Report Server et le Gestionnaire de rapports dans HTTP.SYS, puis les inscrira lors du démarrage du service. Les URL du Générateur de rapport et des rapports sont basés sur la réservation d'URL du service Web Report Server. En ajoutant des paramètres à l'URL, vous pouvez ouvrir le Générateur de rapport ou des rapports par le biais du service Web. Les réservations et l'inscription sont fournies par HTTP.SYS. Pour plus d'informations, consultez Namespace Reservations, Registration, and Routing sur MSDN.

La réservation d'URL est un processus par lequel un point de terminaison URL à une application Web est créé et stocké dans HTTP.SYS. HTTP.SYS est la base de données de référentiel commune de toutes les réservations d'URL qui sont définies sur un ordinateur ; elle définit un jeu de règles communes qui garantissent des réservations d'URL uniques.

L'inscription d'URL se produit lorsque le service démarre. La file d'attente des demandes est créée et HTTP.SYS commence à transférer les demandes vers cette file d'attente. Un point de terminaison URL doit être inscrit pour que les demandes dirigées vers ce point de terminaison soient ajoutées à la file d'attente. Lorsque le service Report Server démarre, il enregistre toutes les URL qu'il a réservées pour toutes les applications actives. Cela signifie que le service Web doit être activé pour que l'inscription ait lieu. Si vous affectez à la propriété WebServiceAndHTTPAccessEnabled la valeur False dans la facette Configuration de la surface d'exposition pour Reporting Services de la gestion basée sur une stratégie, l'URL du service Web n'est pas inscrite au démarrage du service.

Les inscriptions des URL sont annulées si vous arrêtez le service ou si vous recyclez le service Web ou le domaine d'application du Gestionnaire de rapports. Si vous modifiez une réservation d'URL pendant que le service s'exécute, le serveur de rapports recycle immédiatement le domaine d'application afin que l'ancienne URL puisse être désinscrite et que la nouvelle puisse être utilisée.

Quelques exemples simples illustrent le concept de réservation d'URL et sa relation avec les adresses URL utilisées pour les applications Reporting Services. Un point clé à noter est que la réservation d'URL a une syntaxe différente de l'URL que vous utilisez pour accéder à l'application :

Réservation d'URL dans HTTP.SYS URL Explication

http://+:80/reportserver

http://<nom_ordinateur>/reportserver

http://<adresse_IP>/reportserver

http://localhost/reportserver

La réservation d'URL spécifie un caractère générique (+) sur le port 80. Cela met dans la file d'attente de serveur de rapports toute requête entrante qui spécifie un hôte résolu sur le serveur de rapports sur le port 80. Remarquez qu'avec cette réservation d'URL, une quantité quelconque d'URL peut être utilisée pour accéder au serveur de rapports.

Il s'agit de la réservation d'URL par défaut pour un serveur de rapports Reporting Services pour la plupart des systèmes d'exploitation.

http://123.45.67.0:80/reportserver

http://123.45.67.0/reportserver

Cette réservation d'URL spécifie une adresse IP ; elle est beaucoup plus restrictive que la réservation d'URL générique. Seules les URL qui incluent l'adresse IP peuvent être utilisées pour se connecter au serveur de rapports. Étant donné cette réservation d'URL, une demande à un serveur de rapports à http://<nom_ordinateur>/reportserver ou http://localhost/reportserver échouerait.

URL par défaut

Si vous installez Reporting Services dans la configuration par défaut, le programme d'installation réserve des URL pour le service Web Report Server et pour le Gestionnaire de rapports. Vous pouvez également accepter ces valeurs par défaut lorsque vous définissez des réservations d'URL dans l'outil de configuration Reporting Services. Les URL par défaut incluront un nom d'instance si vous installez SQL Server Express ou si vous installez Reporting Services en tant qu'instance nommée.

Important :
Le caractère d'instance est un trait de soulignement (_).

Les réservations d'URL incluent un numéro de port. Les systèmes d'exploitation suivants permettent à plusieurs applications Web de partager un port : Windows Server 2003, Windows Vista et Windows Server 2008. Si vous utilisez Windows XP, assurez-vous d'utiliser des ports uniques.

Type d'instance | Application | URL par défaut | Réservation d'URL réelle dans HTTP.SYS
Instance par défaut | Service Web Report Server | http://<nom_serveur>/reportserver | http://<nom_serveur>:80/reportserver
Instance par défaut | Gestionnaire de rapports | http://<nom_serveur>/reportserver | http://<nom_serveur>:80/reportserver
Instance nommée | Service Web Report Server | http://<nom_serveur>/reportserver_<nom_instance> | http://<nom_serveur>:80/reportserver_<nom_instance>
Instance nommée | Gestionnaire de rapports | http://<nom_serveur>/reports_<nom_instance> | http://<nom_serveur>:80/reports_<nom_instance>
SQL Server Express | Service Web Report Server | http://<nom_serveur>/reportserver_SQLExpress | http://<nom_serveur>:80/reportserver_SQLExpress
SQL Server Express | Gestionnaire de rapports | http://<nom_serveur>/reports_SQLExpress | http://<nom_serveur>:80/reports_SQLExpress

Authentification et identité de service pour les URL Reporting Services

Les réservations d'URL Reporting Services spécifient le compte de service du service Report Server. Le compte sous lequel le service s'exécute est utilisé pour toutes les URL créées pour les applications Reporting Services qui s'exécutent dans la même instance. L'identité de service de l'instance de serveur de rapports est stockée dans le fichier RSReportServer.config.

Le compte de service n'a aucune valeur par défaut. Toutefois, la spécification d'un compte de service est requise pendant l'installation et est spécifiée dans URLReservation dans RSReportServer.config même si vous installez le serveur en mode fichiers uniquement. Les valeurs valides pour le compte de service incluent un compte d'utilisateur de domaine, LocalSystem ou NetworkService.

L'accès anonyme est désactivé car la sécurité par défaut est RSWindowsNegotiate. Pour l'accès intranet, les URL de serveur de rapports utilisent des noms d'ordinateurs réseau. Si vous souhaitez configurer Reporting Services pour des connexions Internet, vous devez utiliser des paramètres différents. Pour plus d'informations, consultez Planification d'un déploiement extranet ou Internet. Pour plus d'informations sur l'authentification, consultez Configuration de l'authentification dans Reporting Services.

URL pour l'administration locale

Vous pouvez utiliser http://localhost/reportserver ou http://localhost/reports si vous avez spécifié un caractère générique fort ou faible pour la réservation d'URL.

L'URL http://localhost est interprétée comme http://127.0.0.1. Si vous avez lié la réservation d'URL à un nom d'ordinateur ou une adresse IP unique, vous ne pouvez pas utiliser localhost, à moins de créer une réservation supplémentaire pour 127.0.0.1 sur l'ordinateur local. De même, si localhost ou 127.0.0.1 est désactivé sur votre ordinateur, vous ne pouvez pas utiliser cette URL.

Windows Vista et Windows Server "Longhorn" incluent de nouvelles fonctionnalités de sécurité destinées à réduire le risque d'exécution accidentelle de programmes avec des privilèges élevés. Des étapes supplémentaires sont nécessaires pour activer l'administration locale sur ces systèmes d'exploitation. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

URL pour le déploiement avec montée en puissance parallèle

Informations pour cette section non disponibles dans cette version.

URL pour un serveur de rapports en mode intégré SharePoint

Si un serveur de rapports autonome est configuré pour s'exécuter au sein d'un déploiement plus vaste d'un produit ou d'une technologie SharePoint, la construction d'URL et de répertoires virtuels sera affectée de plusieurs manières :

  • Les URL pour les rapports et autres éléments sont adressées par le biais de l'URL d'application Web SharePoint. Pour l'accès URL à des rapports spécifiques, utilisez toujours une URL complète qui inclut le chemin d'accès au site, la bibliothèque de documents, le nom de l'article et une extension de nom de fichier (telle que .rdl pour un rapport). Vous devez spécifier des URL complètes lorsque vous faites référence à des sources de données partagées et à des modèles dans des rapports, et lorsque vous spécifiez un serveur et des dossiers cibles pour des opérations de publication sur un serveur de rapports.

  • L'extension de nom de fichier est utilisée pour distinguer entre différents types d'éléments de serveur de rapports. Les extensions valides incluent .rdl pour les définitions de rapport, .smdl pour les modèles d'état et .rsds pour les sources de données partagées créées pour un site SharePoint.

  • Bien que les produits et technologies SharePoint aient des réservations d'URL définies, vous pouvez ignorer la réservation lors de la publication sur le serveur. Pour les applications Web SharePoint, la réservation d'URL est une opération interne.

  • Pour les déploiements de serveur unique dans lesquels un serveur de rapports et une instance de technologie SharePoint intégrés sont installés sur le même ordinateur, vous ne pouvez pas utiliser http://localhost/reportserver. Si http://localhost est utilisé pour accéder à l'application Web SharePoint, vous devez utiliser un site Web différent du site par défaut ou une affectation de port unique pour accéder à un serveur de rapports. En outre, si le serveur de rapports est intégré à une batterie de serveurs SharePoint, l'accès localhost à un serveur de rapports n'est pas résolu pour les nœuds du déploiement installés sur des ordinateurs distants.

  • La réservation d'URL et le point de terminaison pour le Gestionnaire de rapports ne peuvent pas être configurés pour un serveur de rapports qui s'exécute en mode intégré SharePoint. Si vous les configurez, le gestionnaire ne fonctionnera plus après le déploiement d'un serveur de rapports en mode intégré SharePoint. Le Gestionnaire de rapports n'est pas pris en charge dans ce mode.

Si vous avez intégré un déploiement de serveur de rapports avec montée en puissance parallèle pour s'exécuter au sein d'un déploiement plus vaste d'un produit ou d'une technologie SharePoint, vous devez équilibrer la charge des nœuds du serveur de rapports et définir une URL de serveur virtuel unique pour le déploiement avec montée en puissance parallèle. Les paramètres d'intégration Report Server vous permettent uniquement de spécifier une URL de serveur de rapports unique. Dans le cas d'un déploiement avec montée en puissance parallèle, l'URL doit être le point d'accès pour les nœuds de serveur dans le déploiement avec montée en puissance parallèle.

Pour plus d'informations sur les modes de déploiement et les conditions requises en matière d'URL pour publier des éléments, consultez Planification d'un mode de déploiement et Déploiement de modèles et de sources de données partagées sur un site SharePoint.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Syntaxe de réservation d'URL (Reporting Services)
Configuration par défaut pour une installation en mode natif (Reporting Services)

Autres ressources

Fichier de configuration RSReportServer
Déploiement côte à côte de Reporting Services et des services IIS (Internet Information Services)


Syntaxe de réservation d'URL (Reporting Services)

Syntaxe de réservation d'URL (Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration des URL de Report Server >

Cette rubrique décrit les parties de la chaîne d'URL du service Web Report Server et du Gestionnaire de rapports. La chaîne d'URL stockée en interne possède une structure différente de celle d'une URL saisie dans la barre d'adresses d'une fenêtre de navigateur. La chaîne de réservation d'URL apparaît dans la fenêtre Résultats de l'outil de configuration de Reporting Services lorsque vous configurez une URL et dans le fichier RSReportServer.config. Il peut être utile de savoir comment la chaîne d'URL est définie si vous dépannez les problèmes de réservation d'URL ou interrogez HTTP.SYS pour afficher les réservations d'URL internes définies sur votre serveur.

Syntaxe d'URL

Une URL de serveur de rapports est stockée dans l'élément UrlString et l'élément VirtualDirectory. La raison de la séparation d'UrlString et de VirtualDirectory en éléments séparés est que vous pouvez avoir plusieurs chaînes d'URL, mais un seul nom de répertoire virtuel pour chaque application Reporting Services.

Dans HTTP.SYS, la réservation d'URL inclut les deux éléments UrlString et VirtualDirectory. La syntaxe d'une réservation d'URL comporte les parties suivantes :

<scheme>://<hostname>:<port>/<virtualdirectory>

Le tableau suivant décrit chaque propriété et les valeurs valides pour chacune d'elles.

Propriété Valeurs valides Description

Scheme

http ou https

Préfixes pour connexions SSL et connexions autres que SSL.

HostName

Caractère générique (+) fort, égal à la valeur (Assigné) pour l'adresse IP.

Caractère générique (*) faible, égal à la valeur (Non assigné) de l'adresse IP.

Nom de domaine complet

Nom de l'ordinateur

Adresse IP (IPV4)

Adresse IP (IPV6)

Identifie le serveur sur le réseau.

Le caractère générique fort (+) est la valeur par défaut. HTTP.SYS accepte toutes les demandes sur toutes les cartes réseau pour la combinaison d'un port donné et d'un répertoire virtuel. Le serveur de rapports accepte toute demande sur le port.

Caractère générique (*) faible. HTTP.SYS accepte toutes les demandes non gérées par les autres réservations d'URL sur toutes les cartes réseau pour la combinaison d'un port donné et d'un répertoire virtuel.

Le nom de l'ordinateur est le nom NETBIOS de l'ordinateur sur le réseau.

Le nom de domaine complet inclut l'adresse du domaine et le nom du serveur, tels qu'ils sont inscrits auprès d'un contrôleur de domaine ou d'un serveur de noms de domaine public.

L'adresse IP (IPV4) est l'adresse IP d'une carte réseau sur l'ordinateur au format IPV4 : nnn.nnn.nnn.nnn.

L'adresse IP (IPV6) est l'adresse IP d'une carte réseau sur l'ordinateur au format IPV6 : <en-tête>:<en-tête>:nnn.nnn.nnn.nnn.

Port

80

443

<personnalisés>

Le port 80 est le port standard pour les requêtes HTTP adressées depuis ou vers un serveur.

Le port 443 est le port standard pour les connexions SSL.

Vous pouvez utiliser n'importe quel port qui n'est pas déjà réservé par une autre application.

VirtualDirectory

ReportServer[_InstanceName]

Reports[_InstanceName]

<personnalisés>

Spécifie le nom de l'application. La valeur est une chaîne. Par défaut, Reporting Services utilise ReportServer et Reports comme noms d'applications pour les applications service Web Report Server et Gestionnaire de rapports. Vous pouvez utiliser d'autres noms, si vous le souhaitez.

Cette valeur est obligatoire. Elle identifie la publication.

Spécifiez un seul répertoire virtuel pour chaque instance d'application. Pour créer plusieurs URL pour la même application dans la même instance, créez plusieurs versions de l'élément UrlString. Pour créer des noms de répertoire virtuel uniques pour plusieurs instances d'application, pensez à ajouter le nom de l'instance dans le nom de répertoire virtuel à l'aide du trait de soulignement (_). La propriété InstanceName est facultative, mais recommandée si vous avez plusieurs instances sur le même ordinateur. Pour plus d'informations sur la définition des réservations d'URL pour les instances nommées, consultez Réservations d'URL pour les déploiements de serveur de rapports multi-instance.

La valeur du répertoire virtuel ne respecte pas la casse. Vous pouvez utiliser n'importe quelle chaîne tant qu'elle n'inclut pas les caractères de séparation d'URL ou le codage d'URL.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Autres ressources

Fichier de configuration RSReportServer


URL des fichiers de configuration (Reporting Services)

URL des fichiers de configuration (Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration des URL de Report Server >

Reporting Services stocke les paramètres d'application dans un fichier RSReportServer.config. Ce fichier contient des paramètres de configuration pour les URL et pour les réservations d'URL. Ces paramètres de configuration ont des règles de modification et des objectifs très différents. Si vous êtes habitué à la modification de fichiers de configuration pour régler un déploiement, cette rubrique peut vous aider à comprendre comment chaque paramètre URL est utilisé.

Paramètres d'URL du fichier RSReportServer.config

Reporting Services stocke les URL pour l'accès aux applications et aux rapports, et pour connecter les composants Web frontaux à un serveur de rapports principal.

URL d'accès aux applications

Les URL permettent d'accéder au service Web Report Server et au Gestionnaire de rapports. Pour configurer les URL, vous devez utiliser l'outil de configuration de Reporting Services. L'outil crée les réservations d'URL pour chaque application dans HTTP.SYS et ajoute des entrées pour les URL dans la section URLReservations de RSReportServer.config.

  • Pour consulter les descriptions de chaque élément dans la section URLReservations, consultez Fichier de configuration RSReportServer.

  • Pour plus d'informations sur la seule syntaxe de UrlString, consultez Syntaxe de réservation d'URL (Reporting Services).

  • Pour les instructions sur la configuration des URL pour l'accès aux applications, consultez Procédure : configurer une URL (configuration de Reporting Services).

URL d'accès aux rapports

Reporting Services inclut une extension de remise par messagerie de serveur de rapports que vous pouvez utiliser pour envoyer les liens de rapport ou les pièces jointes. Un lien de rapport est construit lorsque le rapport est remis. L'extension de remise par messagerie de serveur de rapports utilise le paramètre UrlRoot du fichier de configuration pour créer le lien. UrlRoot est également utilisé pour résoudre les liens d'un rapport rendu et généré via un traitement des rapports sans assistance.

UrlRoot est spécifié automatiquement dans le fichier RSReportServer.config lorsque vous configurez les URL pour l'accès aux applications. Si vous modifiez cette valeur dans le fichier de configuration, vous devez spécifier l'adresse URL valide d'un service Web Report Server connecté à une base de données de serveur de rapports qui contient les rapports que vous souhaitez remettre. Vous pouvez spécifier un seul élément UrlRoot pour une instance de serveur de rapports unique ; une seule entrée UrlRoot peut exister dans le fichier RSReportServer.config pour toute instance de serveur de rapports donnée. Si vous avez plusieurs URL réservées pour le service Web Report Server, vous devez choisir l'une des valeurs disponibles pour UrlRoot.

Dans la plupart des cas, vous n'avez pas besoin de modifier UrlRoot. Toutefois, si le serveur de rapports est accessible via une URL complète et que vous n'avez pas configuré une URL qui utilise l'en-tête de l'hôte sur le nom de site complet, vous devez modifier le fichier RSReportServer.config manuellement pour définir UrlRoot avec l'URL complète du serveur de rapports qui sera utilisée pour restituer le rapport (par exemple, https://www.adventure-works.com/mywebapp/reportserver).

URL connectant le Gestionnaire de rapports et les composants WebPart au service Web Report Server

Le Gestionnaire de rapports et les composants WebPart SharePoint 2.0 pour Reporting Services sont les composants Web frontaux qui se connectent à un serveur de rapports. Les URL utilisées pour se connecter à un serveur de rapports principal sont les suivantes :

  • ReportServerUrl (élément utilisé par le Gestionnaire de rapports)

  • ReportServerExternalUrl (élément utilisé par les composants WebPart)

Remarque :
Les versions antérieures de Reporting Services incluaient l'élément ReportServerVirtualDirectory. Cette valeur est obsolète dans SQL Server 2008. Si vous avez mis à niveau une installation existante et utilisez un fichier de configuration qui contient ce paramètre, le serveur de rapports ne lit plus cette valeur.

Le tableau suivant récapitule toutes les URL pouvant être spécifiées dans un fichier de configuration de Reporting Services.

Paramètre Utilisation Description

ReportServerUrl

Facultatif. Cet élément n'est pas inclus dans le fichier RSReportServer.config à moins que vous ne l'ajoutiez vous-même.

Définissez cet élément uniquement si vous configurez l'un des scénarios suivants :

  • Le Gestionnaire de rapports fournit un accès Web frontal à un service Web Report Server qui s'exécute sur un autre ordinateur ou sur une instance différente du même ordinateur.

  • Lorsque vous avez plusieurs URL vers un serveur de rapports et que vous souhaitez que le Gestionnaire de rapports utilise une URL spécifique.

  • Vous avez une URL du serveur de rapports spécifique que vous souhaitez voir utilisée par toutes les connexions du Gestionnaire de rapports.

    Par exemple, vous pouvez activer l'accès du Gestionnaire de rapports pour tous les ordinateurs du réseau, tout en requérant que le Gestionnaire de rapports se connecte au serveur de rapports à travers une connexion locale. Dans ce cas, vous pouvez configurer ReportServerUrl avec la valeur « http://localhost/reportserver ».

Pour les instructions sur l'implémentation de ces scénarios, consultez Procédure : configurer le Gestionnaire de rapports.

Cette valeur spécifie l'URL du service Web Report Server. Cette valeur est lue par l'application du Gestionnaire de rapports au démarrage. Si cette valeur est définie, le Gestionnaire de rapports se connecte au serveur de rapports spécifié dans l'URL.

Par défaut, le Gestionnaire de rapports fournit un accès Web frontal à un service Web Report Server qui s'exécute au sein de la même instance du serveur de rapports que le Gestionnaire de rapports. Toutefois, si vous souhaitez utiliser le Gestionnaire de rapports avec un service Web Report Server qui fait partie d'une autre instance ou s'exécute dans une instance d'un autre ordinateur, vous pouvez définir cette URL de façon à diriger le Gestionnaire de rapports pour qu'il se connecte au service Web Report Server externe.

Si un certificat SSL (Secure Sockets Layer) est installé sur le serveur de rapports auquel vous êtes connecté, la valeur de l'élément ReportServerUrl doit être le nom du serveur inscrit pour ce certificat. Si l'erreur « La connexion sous-jacente a été fermée. Impossible d'établir une relation de confiance pour le canal sécurisé SSL/TLS » s'affiche, définissez l'élément ReportServerUrl avec le nom de domaine complet du serveur pour lequel le certificat SSL a été émis. Par exemple, si le certificat est inscrit sur https://adventure-works.com.ventesenligne, l'URL du serveur de rapports sera https://adventure-works.com.ventesenligne/serveurderapports.

ReportServerExternalUrl

Facultatif. Cet élément n'est pas inclus dans le fichier RSReportServer.config à moins que vous ne l'ajoutiez vous-même.

Définissez cet élément uniquement si vous utilisez les composants WebPart de SharePoint 2.0 et que vous souhaitez que les utilisateurs soient en mesure d'extraire un rapport et de l'ouvrir dans une nouvelle fenêtre de navigateur.

Ajoutez l'élément <ReportServerExternalUrl> sous l'élément <ReportServerUrl>, puis définissez-le avec un nom de serveur de rapports complet qui se résout en une instance de serveur de rapports en cas d'accès dans une fenêtre de navigateur distincte. Ne supprimez pas <ReportServerUrl>.

L'exemple suivant illustre la syntaxe :

<ReportServerExternalUrl>http://myserver/reportserver</ReportServerExternalUrl>

Cette valeur est utilisée par les composants WebPart de SharePoint 2.0.

Dans les versions précédentes, il était recommandé que vous définissiez cette valeur pour déployer le Générateur de rapport sur un serveur de rapports Internet. Il s'agit d'un scénario de déploiement non testé. Si vous utilisiez ce paramètre par le passé pour gérer l'accès Internet au Générateur de rapports, vous devez prévoir une autre stratégie.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Autres ressources

Fichier de configuration RSReportServer
Procédure : modifier un fichier de configuration Reporting Services
Consultation de rapports avec des composants WebPart de SharePoint 2.0


Réservations d'URL pour les déploiements de serveur de rapports multi-instance

Réservations d'URL pour les déploiements de serveur de rapports multi-instance |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration des URL de Report Server >

Si vous installez plusieurs instances de Reporting Services sur le même ordinateur, vous devez considérer comment vous définirez les réservations d'URL pour chaque instance. Dans chaque instance, le service Web Report Server et le Gestionnaire de rapports doivent avoir au moins une réservation d'URL chacun. L'ensemble entier de réservations doit être unique dans HTTP.SYS.

Les URL en double sont détectées pendant l'inscription d'URL, qui se produit lorsque le service démarre. Si vous créez des réservations d'URL qui ne sont pas uniques, le conflit de nom peut ne pas être détecté avant le démarrage du service. Pour cette raison, assurez-vous de suivre les conventions ou les règles d'affectation de noms afin de vous assurer que toutes les valeurs sont uniques.

Conventions d'affectation de noms par défaut

Reporting Services peut être installé dans une instance nommée SQL Server. Lorsque vous installez ou configurez un serveur de rapports dans une instance nommée, le nom de l'instance est inclus automatiquement dans le répertoire virtuel dans la réservation d'URL par défaut que Reporting Services fournit. Le tableau suivant indique les réservations d'URL pour une instance par défaut et une instance nommée.

Instance SQL Server | Réservation d'URL par défaut
Par défaut (MSSQLSERVER) | http://+:80/reportserver
Nommée (MynamedInstance) | http://+:80/reportserver_MyNamedInstance

Pour l'instance nommée, le répertoire virtuel inclut le nom de l'instance. L'instance par défaut et l'instance nommée écoutent sur le même port, mais les noms de répertoires virtuels uniques déterminent quel serveur de rapports obtient la demande.

Il est recommandé d'utiliser le nom de répertoire virtuel afin de distinguer parmi l'instance de serveur de rapports. Il fournit une correspondance claire entre une URL et l'instance cible et garantit que les noms d'applications sont uniques dans tout le système.

Conventions d'affectation de noms personnalisées

Bien que l'utilisation du nom de l'instance soit recommandée, vous pouvez utiliser la syntaxe d'URL et vos propres conventions d'affectation de noms afin de satisfaire les contraintes de nom uniques pour les réservations d'URL. Les exemples suivants illustrent différentes approches permettant de créer des URL uniques pour chaque instance.

Instance par défaut du serveur de rapports (MSSQLSERVER) | ReportServer_MyNamedInstance | Unicité
http://+:80/reportserver | http://+:8888/reportserver | Chaque instance écoute sur un port différent.
http://www.contoso.com/reportserver | http://SRVR-46/reportserver | Chaque instance répond à différents noms de serveurs (nom de domaine complet et nom d'ordinateur).

Spécifications relatives à l'unicité

Les technologies sous-jacentes utilisées par Reporting Services imposent des spécifications relatives aux noms uniques. HTTP.SYS requiert que toutes les URL dans sa base de données de référentiel soient uniques. Vous pouvez varier le port, le nom d'hôte ou le nom de répertoire virtuel pour créer une URL unique. ASP.NET requiert que les identités d'application soient uniques dans le même processus. Cette spécification affecte les noms de répertoires virtuels. Elle spécifie que vous ne pouvez pas dupliquer de nom de répertoire virtuel dans la même instance de serveur de rapports.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server
Utilisation de plusieurs versions et instances de SQL Server


Création d'une base de données de serveur de rapports

Création d'une base de données de serveur de rapports |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Reporting Services utilise deux bases de données relationnelles SQL Server pour le stockage des objets et des métadonnées du serveur de rapports. Une base de données est utilisée pour le stockage principal et l'autre pour le stockage des données temporaires. Les bases de données sont créées ensemble et liées par le nom. Avec une instance par défaut de SQL Server, les bases de données sont nommées reportserver et reportservertempdb. Les deux bases de données sont collectivement appelées « base de données de serveur de rapports » ou « catalogue du serveur de rapports ».

Important :
N'écrivez pas d'applications qui exécutent des requêtes sur la base de données du serveur de rapports. La base de données du serveur de rapports n'est pas un schéma public. La structure des tables peut changer d'une version à la suivante. Si vous écrivez une application qui nécessite un accès à la base de données du serveur de rapports, utilisez toujours les API Reporting Services pour accéder à la base de données du serveur de rapports.

Méthodes pour créer la base de données de serveur de rapports

Vous pouvez créer la base de données du serveur de rapports des manières suivantes :

  • Automatiquement par le biais du programme d'installation, si vous choisissez l'option d'installation de la configuration par défaut. Dans l'Assistant Installation de Microsoft SQL Server, il s'agit de l'option Installer la configuration par défaut en mode Natif ou Installer la configuration par défaut en mode intégré SharePoint de la page Options d'installation du serveur de rapports. Si vous avez choisi l'option Installer mais ne pas configurer le serveur, vous devez utiliser l'outil de configuration de Reporting Services pour créer la base de données.

  • Manuellement, par le biais de l'outil de configuration de Reporting Services. Vous devez créer la base de données du serveur de rapports manuellement si vous utilisez un Moteur de base de données SQL Server distant pour héberger la base de données. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Conditions requises pour une version du serveur de bases de données

SQL Server est utilisé pour héberger les bases de données du serveur de rapports :

  • SQL Server 2005 ou SQL Server 2008 peut être utilisé pour héberger les bases de données. N'utilisez pas SQL Server 2000 ou versions antérieures de SQL Server.

  • L'instance du Moteur de base de données SQL Server peut être soit locale, soit distante.

Pour créer la base de données du serveur de rapports sur un ordinateur distant, vous devez configurer la connexion de manière à employer un compte d'utilisateur de domaine ou un compte de service pouvant accéder au réseau. Si vous décidez d'utiliser une instance SQL Server distante, réfléchissez avec soin aux informations d'identification que le serveur de rapports devra utiliser pour se connecter à l'instance SQL Server. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

Important :
Le serveur de rapports et l'instance SQL Server hébergeant la base de données du serveur de rapports peuvent appartenir à des domaines différents. Dans le cadre d'un déploiement Internet, il est courant d'utiliser un serveur situé derrière un pare-feu. Si vous configurez un serveur de rapports de manière à accéder à Internet, utilisez les informations d'identification SQL Server pour vous connecter à l'instance de SQL Server située derrière le pare-feu et recourez à IPSEC pour sécuriser la connexion.

Conditions requises pour une édition du serveur de bases de données

Lors de la création d'une base de données de serveur de rapports, soyez conscient que certaines éditions de SQL Server ne peuvent pas être utilisées pour héberger la base de données. Le tableau suivant répertorie les éditions du Moteur de base de données que vous pouvez utiliser pour les éditions spécifiques de Reporting Services.

Pour cette édition de SQL Server Reporting Services | Utilisez cette édition de l'instance du moteur de base de données pour héberger la base de données
SQL Server Express with Advanced Services | SQL Server Express with Advanced Services (local uniquement).
Web | Web Edition (locale uniquement)
Workgroup | Workgroup Edition (locale uniquement)
Evaluation | Éditions Standard, Evaluation, Enterprise (locales ou distantes)
Developer | Éditions Standard, Developer, Enterprise (locales ou distantes)
Standard | Éditions Standard, Enterprise (locales ou distantes)
Enterprise | Éditions Standard, Enterprise (locales ou distantes)

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Autres ressources

Base de données de Report Server
Administration d'une base de données du serveur de rapports
Developer's Guide (Reporting Services)


Configuration d'une connexion de base de données de serveur de rapports

Configuration d'une connexion de base de données de serveur de rapports |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Chaque instance de serveur de rapports requiert une connexion à la base de données de serveur de rapports qui stocke les rapports, les modèles de rapport, les sources de données partagées, les ressources et les métadonnées gérées par le serveur. La connexion initiale peut être créée lors de l'installation d'un serveur de rapports si vous installez la configuration par défaut. Dans la plupart des cas, vous utilisez l'outil de configuration de Reporting Services pour configurer la connexion une fois l'installation terminée. Vous pouvez modifier la connexion à tout moment afin de changer de type de compte ou de redéfinir les informations d'identification. Pour les instructions pas à pas sur la création de la base de données et la configuration de la connexion, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Vous devez configurer une connexion à la base de données du serveur de rapports dans les circonstances suivantes :

  • Configuration d'un serveur de rapports pour une première utilisation

  • Configuration d'un serveur de rapports de manière à utiliser une base de données de serveur de rapports différente

  • Modification du compte ou du mot de passe de l'utilisateur permettant d'établir la connexion à la base de données. Vous devez uniquement mettre à jour la connexion de base de données lorsque les informations du compte sont stockées dans le fichier RSReportServer.config. Si vous utilisez le compte de service pour la connexion (qui utilise la sécurité intégrée Windows comme type d'informations d'identification), le mot de passe n'est pas stocké, ce qui évite de mettre à jour les informations de connexion. Pour plus d'informations sur la modification des comptes, consultez Configuration du compte de service Report Server.

  • Configuration d'un déploiement avec montée en puissance parallèle de serveurs de rapports La configuration d'un déploiement avec montée en puissance parallèle nécessite la création de plusieurs connexions à une base de données de serveur de rapports. Pour plus d'informations sur cette opération en plusieurs étapes, consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services).

Comment Reporting Services se connecte au moteur de base de données

L'accès du serveur de rapports à une base de données de serveur de rapports dépend des informations d'identification et de connexion, ainsi que de la validité des clés de chiffrement de l'instance de serveur de rapports qui utilise cette base de données. Il est nécessaire de recourir à des clés de chiffrement valides pour stocker et extraire des données sensibles. Des clés de chiffrement sont créés automatiquement lors de la première configuration de la base de données. Une fois les clés créées, vous devez les mettre à jour si vous changez l'identité du service Report Server. Pour plus d'informations sur l'utilisation des clés de chiffrement, consultez Configuration et gestion des clés de chiffrement.

La base de données du serveur de rapports est un composant interne, accessible uniquement par le serveur de rapports. Les informations d'identification et de connexion que vous spécifiez pour la base de données du serveur de rapports sont utilisées exclusivement par le serveur de rapports. Les utilisateurs qui demandent des rapports n'ont pas besoin d'autorisations de base de données ou d'une connexion de base de données pour la base de données du serveur de rapports.

Reporting Services utilise System.Data.SqlClient pour se connecter au Moteur de base de données qui héberge la base de données de serveur de rapports. Si vous utilisez une instance locale du Moteur de base de données, le serveur de rapports établit la connexion à l'aide de la mémoire partagée. Si vous utilisez un serveur de base de données distant pour la base de données du serveur de rapports, il se peut que vous ayez à activer les connexions distantes selon l'édition que vous utilisez. Si vous utilisez l'édition Developer, les connexions distantes sont désactivées par défaut. Si vous utilisez l'édition Enterprise, les connexions distantes sont activées par défaut pour TCP/IP.

Pour vérifier que l'instance accepte les connexions à distance, cliquez successivement sur Démarrer, Tous les programmes, Microsoft SQL Server 2008, Outils de configuration, Gestionnaire de configuration SQL Server, puis vérifiez que le protocole TCP/IP est activé pour chaque service.

Lorsque vous activez les connexions à distance, les protocoles client et serveur sont également activés. Pour vérifier que les protocoles sont activés, cliquez successivement sur Démarrer, Tous les programmes, Microsoft SQL Server 2008, Outils de configuration, Gestionnaire de configuration SQL Server, Configuration du réseau SQL Server, puis cliquez sur Protocoles pour MSSQLSERVER. Pour plus d'informations, consultez Procédure : Activation ou désactivation d'un protocole réseau de serveur (Gestionnaire de configuration SQL Server).

Définition d'une connexion de base de données de serveur de rapports

Pour configurer la connexion, vous devez utiliser l'outil de configuration de Reporting Services ou l'utilitaire de ligne de commande rsconfig.exe. Un serveur de rapports requiert les informations de connexion suivantes :

  • Nom de l'instance du Moteur de base de données hébergeant la base de données du serveur de rapports. Vous pouvez utiliser une instance locale ou distante SQL Server 2005 ou SQL Server 2008.

  • Nom de la base de données de serveur de rapports Lorsque vous créez une connexion pour la première fois, vous pouvez créer une nouvelle base de données du serveur de rapports ou sélectionner une base de données existante. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports.

  • Type d'informations d'identification. Vous pouvez utiliser les comptes de service, un compte de domaine Windows ou une connexion de base de données SQL Server.

  • Nom d'utilisateur et mot de passe (requis seulement si vous utilisez un compte de domaine Windows ou une connexion SQL Server).

Les informations d'identification que vous fournissez doivent disposer de l'accès à la base de données du serveur de rapports. Si vous utilisez l'outil de configuration de Reporting Services, cette opération est effectuée automatiquement. Pour plus d'informations sur les autorisations requises pour accéder à la base de données, consultez la section « Autorisations de base de données » dans cette rubrique.

Stockage des informations de connexion à la base de données

Reporting Services stocke et chiffre les informations de connexion dans les paramètres RSreportserver.config suivants. Vous devez recourir à l'outil de configuration de Reporting Services ou à l'utilitaire rsconfig.exe pour créer des valeurs chiffrées pour ces paramètres.

Certaines valeurs ne sont pas définies pour tous les types de connexion. Si vous configurez la connexion à l'aide de valeurs par défaut (c'est-à-dire avec des comptes de service pour établir la connexion), <LogonUser>, <LogonDomain> et <LogonCred> apparaîtront vides comme suit :

Copier le code
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

Si vous configurez la connexion de manière à utiliser un compte Windows ou une connexion de base de données spécifique, vous devez mettre à jour les valeurs qui sont stockées si vous changez par la suite le compte ou l'ouverture de session.

Choix d'un type d'informations d'identification

Il existe trois types d'informations d'identification utilisables dans une connexion à une base de données de serveur de rapports :

  • Sécurité intégrée Windows avec utilisation du compte de service Report Server. Comme le serveur de rapports est implémenté comme service unique, seul le compte sous lequel le service s'exécute requiert l'accès à la base de données.

  • Un compte d'utilisateur Windows Si le serveur de rapports et la base de données du serveur de rapports sont installés sur le même ordinateur, vous pouvez utiliser un compte local. Sinon, vous devez utiliser un compte de domaine.

  • Connexion SQL Server.

Remarque :
Une extension d'authentification personnalisée ne peut pas être utilisée pour établir une connexion à une base de données de serveur de rapports. Les extensions d'authentification personnalisées servent uniquement à authentifier une entité de sécurité auprès d'un serveur de rapports. Elles n'affectent pas les connexions à la base de données du serveur de rapports ou aux sources de données externes qui fournissent un contenu aux rapports.

Si l'instance du Moteur de base de données est configurée pour l'authentification Windows et se trouve dans le même domaine ou un domaine approuvé avec le serveur de rapports, vous pouvez configurer la connexion pour utiliser le compte de service ou un compte d'utilisateur de domaine que vous gérez comme propriété de connexion à travers l'outil de configuration de Reporting Services. Si le serveur de base de données est dans un domaine différent ou si vous utilisez la sécurité de groupe de travail, vous devez configurer la connexion pour utiliser une connexion à une base de données SQL Server. Dans ce cas, veillez bien à chiffrer la connexion. Pour plus d'informations, consultez Chiffrement des connexions à SQL Server.
Utilisation de comptes de service et de la sécurité intégrée

Vous pouvez utiliser la sécurité intégrée Windows pour vous connecter via le compte de service Report Server. Le compte bénéficie des droits de connexion à la base de données du serveur de rapports. Il s'agit du type d'informations d'identification par défaut que choisit le programme d'installation si vous installez Reporting Services dans la configuration par défaut.

Le compte de service est un compte approuvé qui implique une faible maintenance de la gestion d'une connexion de base de données de serveur de rapports. Comme le compte de service utilise la sécurité intégrée Windows pour établir la connexion, il n'est pas nécessaire que les informations d'identification soient stockées. Toutefois, si vous modifiez par la suite l'identité ou le mot de passe du compte de service (par exemple, basculer d'un compte intégré vers un compte de domaine), veillez bien à utiliser l'outil de configuration de Reporting Services pour effectuer la modification. L'outil met automatiquement à jour les autorisations de base de données pour utiliser les informations modifiées sur le compte. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Si vous configurez la connexion de base de données pour qu'elle utilise le compte de service, le compte doit posséder les autorisations réseau si la base de données du serveur de rapports se trouve sur un ordinateur distant. N'utilisez pas le compte de service si la base de données du serveur de rapports se trouve dans un domaine différent, derrière un pare-feu ou si vous utilisez la sécurité des groupes de travail à la place de la sécurité des domaines. Utilisez un compte d'utilisateur de base de données SQL Server à la place.

Utilisation d'un compte d'utilisateur de domaine

Vous pouvez spécifier un compte d'utilisateur Windows pour la connexion à la base de données du serveur de rapports. Si vous utilisez un compte local ou un compte de domaine, vous devez mettre à jour la connexion à la base de données du serveur de rapports chaque fois que vous changez le mot de passe ou le compte. Utilisez toujours l'outil de configuration de Reporting Services pour mettre à jour la connexion.

Utilisation d'une connexion SQL Server

Vous pouvez spécifier une seule connexion SQL Server pour établir la connexion à la base de données du serveur de rapports. Si vous utilisez l'authentification SQL Server et si la base de données du serveur de rapports se trouve sur un ordinateur distant, utilisez IPSec pour sécuriser la transmission des données entre les serveurs. Si vous utilisez une connexion de base de données, vous devez mettre à jour la connexion à la base de données du serveur de rapports chaque fois que vous changez le mot de passe ou le compte.

Autorisations de base de données

Les rôles suivants sont attribués aux comptes utilisés pour la connexion à la base de données du serveur de rapports :

  • Rôles public et RSExecRole pour la base de données ReportServer.

  • Rôle RSExecRole pour les bases de données master, msdb et ReportServerTempDB.

Lorsque vous utilisez l'outil de configuration de Reporting Services pour créer ou modifier la connexion, ces autorisations sont automatiquement accordées. Si vous recourez à l'utilitaire rsconfig.exe et que vous spécifiez un autre compte pour la connexion, vous devez mettre à jour la connexion SQL Server pour ce nouveau compte. Dans l'outil de configuration de Reporting Services, vous pouvez créer les fichiers de script qui mettent à jour la connexion SQL Server pour le serveur de rapports.

Vérification du nom de la base de données

Utilisez l'outil de configuration de Reporting Services pour déterminer quelle est la base de données de serveur de rapports qu'utilise une instance de serveur de rapports particulière. Pour rechercher le nom, connectez-vous à l'instance de serveur de rapports puis ouvrez la page Installation de la base de données.

Utilisation d'une base de données de serveur de rapports différente ou déplacement d'une base de données de serveur de rapports

Vous pouvez configurer une instance de serveur de rapports de manière à utiliser une autre base de données de serveur de rapports en modifiant les informations de connexion. Il est courant de changer de base de données lors du déploiement d'un serveur de rapports de production. C'est généralement au passage d'une base de données de serveur de rapports de test à une base de données de serveur de rapports de production que les serveurs de production sont transférés. Par ailleurs, vous pouvez déplacer une base de données de serveur de rapports vers un autre ordinateur. Pour plus d'informations, consultez Déplacement des bases de données du serveur de rapports vers un autre ordinateur et Migration (Reporting Services).

Configuration de plusieurs serveurs de rapports de manière à utiliser la même base de données de serveur de rapports

Vous pouvez configurer plusieurs serveurs de rapports de manière à utiliser la même base de données de serveur de rapports. Cette configuration de déploiement est appelée déploiement avec montée en puissance parallèle. Cette configuration est une condition préalable requise si vous voulez exécuter plusieurs serveurs de rapports dans un cluster de serveurs. Toutefois, vous pouvez aussi utiliser cette configuration pour segmenter les applications de service ou pour tester l'installation et les paramètres d'une nouvelle instance de serveur de rapports afin de la comparer à l'installation existante d'un serveur de rapports. Pour plus d'informations, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

Voir aussi

Concepts

Création d'une base de données de serveur de rapports
Rubriques d'aide à la configuration de Reporting Services
Configuration du compte de service Report Server

Autres ressources

Connexion à une source de données (Reporting Services)
Configuration d'une installation de serveur de rapports
Fichier de configuration RSReportServer
Utilitaire rsconfig


Configuration d'un Report Server pour la remise du courrier électronique

Configuration d'un Report Server pour la remise du courrier électronique |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Reporting Services comprend une extension de la remise du courrier électronique que vous pouvez utiliser pour distribuer les rapports par courrier électronique. Selon la façon dont vous définissez l'abonnement de messagerie électronique, une remise peut consister en une notification, un lien, une pièce jointe ou un rapport incorporé. L'extension de remise de courrier électronique fonctionne avec votre technologie de serveur de messagerie existante. Le serveur de messagerie doit être un serveur SMTP ou redirecteur. Le serveur de rapports se connecte à un serveur SMTP par le biais de bibliothèques CDO (Collaboration Data Objects) (cdosys.dll) fournies par le système d'exploitation.

L'extension de remise par messagerie du serveur de rapports n'est pas configurée par défaut. Vous devez utiliser l'outil de configuration de Reporting Services pour opérer une configuration minimale de l'extension. Pour définir des propriétés avancées, vous devez modifier le fichier RSReportServer.config. Si vous ne pouvez pas configurer le serveur de rapports afin qu'il utilise cette extension, vous pouvez remettre les rapports dans un dossier partagé à la place. Pour plus d'informations, consultez Remise par partage de fichiers dans Reporting Services.

Configuration requise

  • La remise du courrier électronique pour Report Server est implémentée sur des objets de données de collaboration (CDO) et nécessite un serveur SMTP (Simple Mail Transfer Protocol) local ou distant, ou encore un redirecteur SMTP. Le protocole SMTP n'est pas pris en charge sur tous les systèmes d'exploitation Windows. Si vous utilisez l'édition Itanium de Windows Server 2008, le protocole SMTP n'est pas pris en charge. Pour plus d'informations sur les options de configuration fournies par le biais des objets CDO, consultez Configuration sur MSDN.

  • Le compte de service Report Server doit être autorisé à envoyer du courrier sur le serveur SMTP.

  • L'extension de remise du courrier électronique utilise le codage UTF-8 dans les pièces jointes électroniques. Vous ne pouvez pas modifier ce codage ; l'extension de rendu HTML prend en charge UTF-8 uniquement.

Remarque :
L'extension par défaut de la remise du courrier électronique ne prend pas en charge la signature numérique et le chiffrement des messages sortants.

Configuration d'un Report Server pour un service SMTP local ou distant

Vous pouvez utiliser un service SMTP local ou un serveur ou un redirecteur SMTP distant pour la prise en charge de la remise du courrier électronique. Si vous pouvez accéder à un serveur SMTP existant à distance, pensez à l'utiliser. Si aucun serveur SMTP n'est disponible ou si vous rencontrez par la suite des erreurs liées à la remise des rapports attribuables aux pannes de connexion de l'ordinateur, nous vous recommandons d'utiliser plutôt un service SMTP local. Cette rubrique couvre plus en détail le mode de configuration d'un serveur de rapports pour un service local ou distant.

Définition des options de configuration pour la remise du courrier électronique

Avant d'utiliser la remise du courrier électronique pour Report Server, vous devez définir les valeurs de configuration fournissant des informations sur le mode d'utilisation du serveur SMTP.

Pour configurer un serveur de rapports pour la remise par messagerie, procédez comme suit :

  • Utilisez l'outil de configuration de Reporting Services si vous spécifiez simplement un serveur SMTP et un compte d'utilisateur ayant l'autorisation d'envoyer des messages électroniques. Ce sont les paramètres minimum requis pour configurer l'extension de remise par messagerie de Report Server. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services).

  • (Facultatif) Utilisez un éditeur de texte pour spécifier les paramètres supplémentaires dans le fichier RSreportserver.config. Ce fichier contient tous les paramètres de configuration pour la remise de courrier électronique Report Server. La spécification de paramètres supplémentaires dans ces fichiers est obligatoire si vous utilisez un serveur SMTP local ou si vous limitez la remise par messagerie à des hôtes spécifiques. Pour plus d'informations sur la recherche et la modification de fichiers de configuration, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

Remarque :
Les paramètres du courrier électronique pour le serveur de rapports dépendent du CDO. Si vous souhaitez obtenir plus de détails sur des paramètres spécifiques, reportez-vous à la documentation de production CDO.

Configuration du courrier électronique pour Report Server

L'exemple suivant illustre les paramètres dans le fichier RSreportserver.config pour un serveur SMTP distant. Pour plus d'informations sur les descriptions et les valeurs valides de paramètres, consultez Fichier de configuration RSReportServer ou la documentation de produits CDO.

Copier le code
<RSEmailDPConfiguration>
     <SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
     <SMTPServerPort></SMTPServerPort>
     <SMTPAccountName></SMTPAccountName>
     <SMTPConnectionTimeout></SMTPConnectionTimeout>
     <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
     <SMTPUseSSL></SMTPUseSSL>
     <SendUsing>2</SendUsing>
     <SMTPAuthenticate></SMTPAuthenticate>
     <From>my-rs-email-account@Adventure-Works.com</From>
     <EmbeddedRenderFormats>
          <RenderingExtension>MHTML</RenderingExtension>
     </EmbeddedRenderFormats>
     <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
     <ExcludedRenderFormats>
          <RenderingExtension>HTMLOWC</RenderingExtension>
          <RenderingExtension>NULL</RenderingExtension>
     </ExcludedRenderFormats>
     <SendEmailToUserAlias>True</SendEmailToUserAlias>
     <DefaultHostName></DefaultHostName>
     <PermittedHosts>
          <HostName>Adventure-Works.com</HostName>
          <HostName>hotmail.com</HostName>
     </PermittedHosts>
</RSEmailDPConfiguration>

Options de configuration pour la définition du champ À : dans un message

Les abonnements définis par l'utilisateur qui sont créés en fonction des autorisations accordées par la tâche Gérer les abonnements individuels contiennent un nom d'utilisateur prédéfini qui repose sur le compte d'utilisateur de domaine. Lorsque l'utilisateur crée l'abonnement, le nom du destinataire dans le champ À :. est configuré automatiquement à l'adresse de la personne qui crée l'abonnement, au moyen du compte d'utilisateur de domaine.

Si vous utilisez un redirecteur ou un serveur SMTP qui utilise des comptes de messagerie différents du compte d'utilisateur de domaine, la remise des rapports échouera lorsque le serveur SMTP tentera de remettre le rapport à cet utilisateur.

Pour contourner ce problème, vous pouvez modifier les paramètres de configuration qui permettent aux utilisateurs d'entrer un nom dans le champ À :

  1. Ouvrez le fichier RSReportServer.config avec un éditeur de texte.

  2. Définissez SendEmailToUserAlias à False.

  3. Définissez DefaultHostName au nom DNS (Domain Name System) ou à l'adresse IP du redirecteur ou du serveur SMTP.

  4. Enregistrez le fichier.

Options de configuration pour le service SMTP distant

La connexion entre le serveur de rapports et le serveur ou redirecteur SMTP est déterminée par les paramètres de configuration suivants :

  • SendUsing spécifie une méthode pour l'envoi de messages. Vous pouvez choisir entre un service SMTP réseau ou un répertoire de collecte du service SMTP local. Pour utiliser un service SMTP distant, cette valeur doit être définie sur 2 dans le fichier RSReportServer.config.

  • SMTPServer spécifie le serveur ou le redirecteur SMTP distant. Cette valeur est obligatoire si vous utilisez un serveur ou un redirecteur SMTP distant.

  • De définit la valeur qui s'affiche dans De : objet d'un message électronique. Cette valeur est obligatoire si vous utilisez un serveur ou un redirecteur SMTP distant.

D'autres valeurs utilisées pour le service SMTP distant comprennent ce qui suit (notez que vous n'avez pas besoin de les spécifier à moins de vouloir remplacer les valeurs par défaut).

  • SMTPServerPort est configuré pour le port 25.

  • SMTPAuthenticate spécifie le mode de connexion du serveur de rapports au serveur SMTP distant. La valeur par défaut est 0 (ou aucune authentification). Dans ce cas, la connexion est effectuée par un accès anonyme. En fonction de la configuration de votre domaine, il est possible que le serveur de rapports et le serveur SMTP soient obligés d'être des membres du même domaine.

    Pour envoyer du courrier électronique aux listes de distribution limitée (par exemple, les listes de distribution qui acceptent des messages entrants uniquement à partir de comptes authentifiés), définissez SMTPAuthenticate sur la valeur 2.

Options de configuration pour le service SMTP local

La configuration d'un service SMTP local est pratique si vous testez ou dépannez la remise du courrier électronique pour le serveur de rapports. Par défaut, le service SMTP local n'est pas activé. Pour obtenir des instructions sur la manière de l'activer, consultez Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services).

La connexion entre le serveur de rapports et le serveur ou le redirecteur SMTP local est déterminée par les paramètres de configuration suivants :

  • SendUsing est défini sur 1.

  • SMTPServerPickupDirectory est défini sur un dossier de lecteur local.

    Remarque :
    Assurez-vous de ne pas définir SMTPServer si vous utilisez un serveur SMTP local.

  • De définit la valeur qui s'affiche dans De : objet d'un message électronique. Cette valeur est requise.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services
Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)

Autres ressources

Abonnement et remise (Reporting Services)
Remise par courrier électronique dans Reporting Services
Fichiers de configuration (Reporting Services)


Configuration du compte d'exécution sans assistance

Configuration du compte d'exécution sans assistance |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Reporting Services fournit un compte spécial utilisé pour le traitement de rapport sans surveillance et pour l'envoi de demandes de connexion par le biais du réseau. Le compte est utilisé des façons suivantes :

  • Envoyez les demandes de connexion sur le réseau pour les rapports qui utilisent l'authentification de base de données ou connectez-vous aux sources de données de rapport externes qui ne requièrent pas ou n'utilisent pas l'authentification. Pour plus d'informations, consultez la rubrique Spécification des informations d'identification et de connexion pour les sources de données de rapport dans la documentation en ligne de SQL Server.

  • Extraire des fichiers image externes qui sont utilisés dans un rapport. Si vous souhaitez utiliser un fichier image et que le fichier est inaccessible par le biais de l'accès Anonyme, vous pouvez configurer le compte de traitement de rapport sans surveillance et accorder au compte l'autorisation d'accéder au fichier. Pour plus d'informations sur le compte d'exécution sans surveillance utilisé pour extraire des images, consultez Ajout d'images à un rapport dans la documentation en ligne de SQL Server.

Le traitement sans surveillance des rapports désigne tout processus d'exécution de rapport déclenché par un événement, d'actualisation de données ou piloté par planification, plutôt que par une demande d'utilisateur. Le serveur de rapports utilise le compte de traitement sans surveillance des rapports pour se connecter à l'ordinateur qui héberge la source de données externe. Ce compte est nécessaire car les informations d'identification du compte de service Report Server ne sont jamais utilisées pour la connexion à d'autres ordinateurs.

Important :
La configuration de ce compte est facultative. Cependant, si vous ne le configurez pas, vous limitez vos options pour la connexion à certaines sources de données et vous risquez de ne pas pouvoir récupérer de fichiers image à partir d'ordinateurs distants. Si vous configurez le compte, vous devez le maintenir à jour. Plus spécifiquement, si vous laissez un mot de passe expirer ou si les informations de compte sont modifiées dans Active Directory, vous rencontrerez l'erreur suivante lors du prochain traitement de rapport : "Échec de l'ouverture de session (rsLogonFailed) Échec de connexion : nom d'utilisateur inconnu ou mot de passe incorrect ». Une maintenance correcte du compte de traitement de rapport sans surveillance est essentielle, même si vous ne récupérez jamais de fichiers image ou si vous n'envoyez jamais de demandes de connexion à des ordinateurs externes. Si vous configurez le compte et constatez ultérieurement que vous ne l'utilisez pas, vous pouvez le supprimer afin d'éliminer des tâches de maintenance de compte routinières.

Comment configurer le compte

Vous devez utiliser un compte utilisateur de domaine. Pour assumer son rôle prévu, ce compte doit être différent de celui utilisé pour exécuter le service Report Server. Veillez à utiliser un compte ayant les autorisations minimales (l'accès en lecture seule avec les autorisations de connexion réseau est suffisant) et un accès limité aux seuls ordinateurs qui fournissent des sources de données et des ressources au serveur de rapports. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Pour spécifier le compte, vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rsconfig.exe. La façon la plus simple de configurer le compte d'exécution sans surveillance consiste à exécuter l'outil de configuration de Reporting Services et à spécifier les informations d'identification dans la page Compte d'exécution.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer. Pour obtenir les instructions, consultez Procédure : démarrer la configuration de Reporting Services.

  2. Sur la page Compte d'exécution, activez l'option Spécifier un compte d'exécution.

  3. Tapez le compte et le mot de passe, tapez de nouveau le mot de passe, puis cliquez sur Appliquer.

Utilisation de l'utilitaire RSCONFIG.exe

Une autre méthode pour définir le compte consiste à recourir à l'utilitaire rsconfig.exe. Pour spécifier le compte, utilisez l'argument -e de l'utilitaire rsconfig.exe. La spécification de l'argument -e pour rsconfig.exe commande à l'utilitaire d'écrire les informations de compte dans le fichier de configuration. Il n'est pas nécessaire de spécifier un chemin d'accès au fichier RSreportserver.config. Suivez ces étapes pour configurer le compte.

  1. Créez ou sélectionnez un compte de domaine qui ne peut accéder qu'aux ordinateurs et aux serveurs qui fournissent des données ou des services à un serveur de rapports. Vous devez utiliser un compte bénéficiant d'autorisations réduites (telles que des autorisations de lecture seule).

  2. Ouvrez une invite de commandes. Dans le menu Démarrer, cliquez sur Exécuter, tapez cmd puis cliquez sur OK.

  3. Tapez la commande suivante pour configurer le compte sur une instance de serveur de rapports locale :

    rsconfig -e -u< domaine / nom_utilisateur > -p< mot_de_passe >

La commande rsconfig -e prend en charge des arguments supplémentaires. Pour obtenir plus d'informations sur la syntaxe et pour obtenir des exemples de commande, consultez Utilitaire rsconfig dans la documentation en ligne de SQL Server.

Comment les informations sur le compte sont stockées

Lorsque vous définissez le compte, les paramètres suivants sont spécifiés comme valeurs chiffrées dans le fichier RSreportserver.config sur une instance de serveur de rapports locale ou distante :

Copier le code
<UnattendedExecutionAccount>
     <UserName></UserName>
     <Password></Password>
     <Domain></Domain>
</UnattendedExecutionAccount>

Une fois que vous les avez définies, vous ne pouvez pas les déchiffrer pour les consulter sous la forme de texte brut. Si vous n'entrez pas les valeurs correctement ou que vous oubliez les valeurs que vous avez spécifiées, vous devez recommencer la procédure à l'aide de l'outil de configuration de Reporting Services ou de la commande rsconfig -e.

Comment utiliser le compte de traitement de rapport sans surveillance

Pour extraire les fichiers image, le serveur de rapports utilise automatiquement le compte et aucune action spécifique n'est requise de votre part. Pour utiliser le compte pour vous connecter aux sources de données externes qui fournissent les données aux rapports, vous devez spécifier une option Type d'informations d'identification dans la page de propriétés de source de données de la source de données du rapport ou de la source de données partagée :

  • Dans le Gestionnaire de rapports ou Management Studio, sélectionnez l'optionInformations d'identification non requises.

  • Sur un site SharePoint pour un serveur de rapports qui s'exécute en mode intégré SharePoint, sélectionnez l'option Compte de traitement de rapport sans assistance.

Le compte de traitement des rapports sans assistance est utilisé principalement pour se connecter aux serveurs externes, et non comme connexion aux serveurs de base de données. Si vous souhaitez utiliser les informations d'identification du compte pour vous connecter à une base de données, vous devez spécifier ces informations dans la chaîne de connexion. Vous pouvez spécifier Integrated Security=SSPI si le serveur de base de données prend en charge la sécurité intégrée Windows et si le compte utilisé pour le traitement de rapport sans assistance dispose de l'autorisation de lecture dans la base de données. Sinon, vous devez entrer le nom d'utilisateur et le mot de passe dans la chaîne de connexion, où ces informations apparaissent en texte en clair à tout utilisateur qui peut modifier les propriétés de la connexion à la source de données.

Bien que rien ne vous empêche d'utiliser le compte de traitement de rapport sans assistance pour récupérer les données une fois la connexion établie, il n'est pas recommandé de le faire. Ce compte est prévu pour des fonctions bien spécifiques. Si vous l'utilisez pour récupérer des données, vous allez à l'encontre de sa fonction première.

Comment maintenir le compte de traitement de rapport sans surveillance

Une fois que vous avez défini le compte, vous devez vous assurer que le compte et le mot de passe sont maintenus à jour. Vous pouvez utiliser l'outil de configuration de Reporting Services pour mettre à jour les paramètres de configuration qui stockent les informations relatives à ce compte.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer.

  2. Sur la page Compte d'exécution, vérifiez que l'option Spécifier un compte d'exécution est sélectionnée.

  3. Tapez le nouveau compte ou mot de passe, tapez de nouveau le mot de passe, puis cliquez sur Appliquer.

Comment supprimer le compte de traitement de rapport sans surveillance

Si vous n'utilisez pas le compte, vous pouvez le supprimer afin d'éliminer des tâches de maintenance de compte routinières.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer.

  2. Sur la page Compte d'exécution, désactivez l'option Spécifier un compte d'exécution.

  3. Cliquez sur Appliquer.

Les informations de compte sont supprimées du fichier RSReportServer.config.

Voir aussi

Autres ressources

Planification des services, des comptes et des connexions
Configuration d'une installation de serveur de rapports
Page des propriétés des sources de données (Gestionnaire de rapports)
Fichier de configuration RSReportServer
Utilitaire rsconfig
Spécification des informations d'identification et de connexion pour les sources de données de rapport


Configuration et gestion des clés de chiffrement

Configuration et gestion des clés de chiffrement |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Reporting Services Reporting Services utilise les clés de chiffrement pour protéger les informations de connexion et d'identification stockées dans la base de données du serveur de rapports. Dans Reporting Services, le chiffrement est pris en charge par la combinaison d'une clé publique, d'une clé privée et d'une clé symétrique, dont le but est de protéger les données sensibles. La clé symétrique est créée au cours de l'initialisation du serveur de rapports lorsque vous installez ou configurez le serveur de rapports. Elle est utilisée par le serveur de rapports pour chiffrer les données sensibles stockées sur le serveur de rapports. Les clés publiques et privées sont créées par le système d'exploitation et servent à protéger la clé symétrique. Une paire de clés privée et publique est créée pour chaque instance du serveur de rapports qui stocke des données sensibles dans une base de données de serveur de rapports.

La gestion des clés de chiffrement consiste à créer une copie de sauvegarde de la clé symétrique et à savoir quand et comment restaurer, supprimer ou modifier les clés. Si vous migrez une installation de serveur de rapports ou que vous configurez un déploiement avec montée en puissance parallèle, vous devez disposer d'une copie de sauvegarde de la clé symétrique pour pouvoir l'appliquer à la nouvelle installation.

Pour gérer les clés symétriques, utilisez au choix l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt. Les outils fournis dans Reporting Services servent à la gestion de la clé symétrique uniquement (les clés publique et privée sont gérées par le système d'exploitation). L'outil de configuration de Reporting Services et l'utilitaire rsconfig prennent en charge les tâches suivantes :

  • Sauvegarde d'un exemplaire de la clé symétrique pour permettre la récupération de l'installation d'un serveur de rapports ou pour servir dans le processus d'une migration planifiée.

  • Restauration dans une base de données de serveur de rapports d'une clé symétrique préalablement enregistrée afin de permettre à une nouvelle instance de serveur de rapports d'accéder à des données existantes qu'elle n'a pas chiffrées au départ.

  • Suppression des données chiffrées d'une base de données de serveur de rapports au cas improbable où l'accès à ces données chiffrées se révélerait impossible.

  • Recréation de clés symétriques et nouveau chiffrement des données au cas improbable où la sécurité de la clé symétrique serait compromise. La création périodique d'une nouvelle clé symétrique (tous les deux ou trois mois par exemple) est préconisée en tant que mesure de sécurité pour protéger la base de données d'un serveur de rapports contre les cyber-attaques qui tentent de déchiffrer la clé.

  • Ajout ou suppression d'une instance de serveur de rapports dans un déploiement évolutif où sont partagées par plusieurs serveurs de rapport une base de données unique et la clé symétrique assurant son chiffrement réversible.

Dans cette section

Rubrique | Description
Initialisation d'un serveur de rapports | Explique la procédure de création des clés de chiffrement.
Sauvegarde et restauration des clés de chiffrement | Explique la procédure de sauvegarde des clés de chiffrement et la façon de restaurer ces clés afin de récupérer l'installation d'un serveur de rapports ou de procéder à la migration de celui-ci.
Suppression et recréation des clés de chiffrement | Explique la procédure de remplacement d'une clé symétrique par une nouvelle version et, si la validation des clés symétriques est impossible, la procédure de chiffrement pour recommencer l'opération depuis le début.
Ajout et suppression de clés de chiffrement pour un déploiement évolutif | Explique la procédure de création et d'ajout des clés de chiffrement pour contrôler l'intégration des serveurs de rapports à un déploiement évolutif.

Voir aussi

Concepts

Stockage des données chiffrées du serveur de rapports

Autres ressources

Outil de configuration de Reporting Services
Utilitaire rskeymgmt
Administration d'une base de données du serveur de rapports


Initialisation d'un serveur de rapports

Initialisation d'un serveur de rapports |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Dans Reporting Services, un serveur initialisé est un serveur qui peut chiffrer et déchiffrer les données d'une base de données de serveur de rapports. L'initialisation est une condition obligatoire pour le fonctionnement d'un serveur de rapports. Cette opération s'effectue lorsque le service Report Server est démarré pour la première fois. Elle s'accomplit également lorsque vous intégrez le serveur de rapports au déploiement existant ou lorsque, manuellement, vous recréez les clés dans le cadre d'un processus de récupération. Pour plus d'informations sur l'utilisation des clés de chiffrement et sur leur intérêt, consultez Configuration et gestion des clés de chiffrement et Stockage des données chiffrées du serveur de rapports.

Les clés de chiffrement sont en partie basées sur les informations de profil du service Report Server. Si vous modifiez l'identité de l'utilisateur servant à exécuter le service Report Server, vous devez mettre à jour les clés en conséquence. Si vous utilisez l'outil de configuration de Reporting Services pour changer l'identité, cette opération s'effectue automatiquement.

Si l'initialisation échoue pour une raison quelconque, le serveur de rapports retourne une erreur RSReportServerNotActivated en réponse à l'utilisateur et aux demandes de service. Dans ce cas, le problème se situe peut-être au niveau de la configuration du serveur ou du système. Pour plus d'informations, consultez Correction des erreurs d'initialisation et de clé de chiffrement.

Vue d'ensemble du processus d'initialisation

Le processus d'initialisation crée et stocke une clé symétrique destinée au chiffrement. Cette clé symétrique est créée par les services de chiffrement de MicrosoftWindows, puis utilisée par le service Report Server pour chiffrer et déchiffrer des données. La clé symétrique est elle-même chiffrée avec une clé asymétrique.

La description du processus d'initialisation est détaillée comme suit :

  1. Au démarrage initial, le service Report Server lit le fichier RSReportServer.config pour récupérer l'identificateur d'installation et les informations de connexion à la base de données.

  2. Le service Report Server fait la demande d'une clé publique auprès des services de chiffrement. Windows crée une clé privée et une clé publique, puis envoie la clé publique au service Report Server.

  3. Le service Report Server se connecte à la base de données du serveur de rapports pour y stocker les valeurs de l'identificateur d'installation et de la clé publique.

  4. Le service Report Server rappelle les services de chiffrement, cette fois-ci pour demander une clé symétrique. Windows crée la clé symétrique requise.

  5. Le service Report Server se connecte à nouveau à la base de données du serveur de rapports et ajoute la clé symétrique aux valeurs de la clé publique et de l'identificateur d'installation stockées au cours de l'étape 3. Avant de la stocker, le service Report Server utilise sa clé publique pour chiffrer la clé symétrique. Une fois cette nouvelle clé stockée, le serveur de rapports est considéré comme initialisé et opérationnel.

Initialisation d'un serveur de rapports pour un déploiement évolutif

Reporting Services prend en charge le modèle de déploiement avec montée en puissance parallèle qui partage une seule base de données de serveur de rapports entre plusieurs instances de serveurs de rapports. Pour intégrer un déploiement évolutif, un serveur de rapports doit créer et stocker sa copie de la clé symétrique dans la base de données partagée. Bien qu'une seule clé symétrique soit utilisée par les serveurs utilisateurs de la base de données, chaque serveur de rapports possède un exemplaire de la clé. Chaque exemplaire est différent en soi puisqu'il est chiffré exclusivement à l'aide de la clé publique de son propriétaire.

Les premières étapes assurant l'initialisation d'un serveur de rapports en vue d'un déploiement évolutif sont identiques aux trois premières étapes de l'initialisation d'une combinaison base de données et serveur unique.

La seule différence réside dans la façon dont le serveur de rapports obtient la clé symétrique au cours du processus d'initialisation pour le déploiement évolutif. Lorsque le premier serveur est initialisé, il obtient la clé symétrique de Windows et Lorsque le deuxième serveur est initialisé durant la configuration du déploiement avec montée en puissance parallèle, il obtient sa clé symétrique du service Report Server déjà initialisé. L'instance du premier serveur de rapports utilise la clé publique de la deuxième instance pour créer un exemplaire chiffré de la clé symétrique pour l'instance du deuxième serveur de rapports. La clé symétrique n'est jamais exposée sous forme de texte brut à un seul stade de ce processus.

Initialisation d'un serveur de rapports

  • Pour initialiser un serveur de rapports, utilisez l'outil de configuration de Reporting Services. L'opération s'effectue automatiquement lorsque vous créez et configurez la base de données du serveur de rapports. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

  • Pour initialiser un serveur de rapports en vue de l'intégrer à un déploiement évolutif, utilisez la page d'initialisation de l'outil de configuration de Reporting Services ou l'utilitaire RSKeymgmt. Pour les instructions détaillées de cette procédure, consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services).

Remarque :
RSKeymgmt est une application console qui s'exécute à partir d'une ligne de commande sur un ordinateur hébergeant une instance de serveur de rapports déjà intégrée à un déploiement évolutif. Lorsque vous exécutez cet utilitaire, vous spécifiez des arguments pour sélectionner une instance de serveur de rapports distante à initialiser.

Un serveur de rapports n'est initialisé que dans la mesure où une correspondance entre l'identificateur d'installation et la clé publique existe. Si la correspondance est trouvée, une clé symétrique permettant le chiffrement réversible est créée. S'il n'existe aucune correspondance, le serveur de rapports est désactivé. Dans ce cas il peut s'avérer nécessaire d'appliquer une clé de sauvegarde ou de supprimer les données chiffrées si aucune clé de sauvegarde n'est disponible ou valide. Pour plus d'informations sur les clés de chiffrement utilisées par un serveur de rapports, consultez Configuration et gestion des clés de chiffrement.

Remarque :
Vous pouvez également utiliser le fournisseur WMI (Windows Management Instrumentation) de Reporting Services pour initialiser un serveur de rapports par programme. Pour plus d'informations, consultez Reporting Services WMI Provider.

Confirmation de l'initialisation d'un serveur de rapports

Pour confirmer l'initialisation d'un serveur de rapports, exécutez une commande ping pour le service Web Report Server en tapant http://<nomserveur>/serveurrapports dans la fenêtre de commande. Si l'erreur RSReportServerNotActivated se produit, l'initialisation a échoué.

Voir aussi

Concepts

Stockage des données chiffrées du serveur de rapports

Autres ressources

Opérations de sauvegarde et de restauration pour une installation Reporting Services
Correction des erreurs d'initialisation et de clé de chiffrement
Déploiement (Reporting Services)
Administration (Reporting Services)


Sauvegarde et restauration des clés de chiffrement

Sauvegarde et restauration des clés de chiffrement |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Une part importante de la configuration d'un serveur de rapports est réservée à la création d'une copie de sauvegarde de la clé symétrique utilisée pour le chiffrement d'informations confidentielles. Cet exemplaire de clé sauvegardée est nécessaire dans de nombreuses opérations courantes. Elle vous permet de réutiliser une base de données de serveur de rapports existante dans une nouvelle installation. La restauration de la copie de sauvegarde de la clé de chiffrement est indispensable lorsque l'un des événements suivants se produit :

  • Modification effectuée sur le nom du compte de service Windows Report Server ou réinitialisation du mot de passe. Lorsque vous utilisez l'outil de configuration de Reporting Services, la sauvegarde de la clé est intégrée à une opération de changement de nom du compte de service.

    Remarque :
    La réinitialisation et la modification d'un mot de passe sont deux opérations différentes. La réinitialisation d'un mot de passe requiert l'autorisation permettant de remplacer des informations de compte sur le contrôleur de domaine. Cette opération est effectuée par un administrateur système lorsqu'un utilisateur a oublié ou ne connaît pas un mot de passe particulier. Seule la réinitialisation d'un mot de passe nécessite la restauration de la clé symétrique. Le changement régulier d'un mot de passe de compte ne vous oblige pas à réinitialiser la clé symétrique.

  • Attribution d'un nouveau nom à l'ordinateur ou à l'instance qui héberge le serveur de rapports (une instance de serveur de rapports repose sur un nom d'instance SQL Server).

  • Migration d'une installation de serveur de rapports ou configuration d'un serveur de rapports afin d'utiliser une base de données de serveur de rapports différente.

  • Récupération d'une installation de serveur de rapports suite à une défaillance matérielle.

Une seule copie de sauvegarde de la clé symétrique est nécessaire. Il existe une correspondance unilatérale entre une base de données de serveur de rapports et une clé symétrique. Bien que vous n'ayez besoin que d'un seul exemplaire de clé sauvegardé, il peut s'avérer nécessaire de restaurer cette clé à plusieurs reprises si vous exécutez plusieurs serveurs de rapports dans un modèle de déploiement évolutif. En effet, chaque instance de serveur de rapports nécessite sa copie de la clé symétrique pour verrouiller et déverrouiller des données dans la base de données du serveur de rapports.

Sauvegarde des clés de chiffrement sur disque

La sauvegarde de la clé symétrique est un processus qui consiste à écrire la clé dans le fichier que vous spécifiez, puis à brouiller ces données à l'aide du mot de passe que vous fournissez. En aucun cas la clé symétrique ne peut être conservée sans être chiffrée, vous devez donc fournir un mot de passe afin de rendre la clé illisible au moment de son enregistrement sur un disque. Une fois le fichier créé, vous devez le stocker dans un endroit sécurisé et vous souvenir du mot de passe qui permet de déverrouiller le fichier. Pour sauvegarder la clé symétrique, utilisez soit l'outil de configuration de Reporting Services soit l'utilitaire rskeymgmt.

Procédure de sauvegarde des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports à configurer.

  2. Cliquez sur Clés de chiffrement, puis sur Sauvegarder.

  3. Tapez un mot de passe fort.

  4. Spécifiez un fichier pour contenir la clé stockée. Reporting Services ajoute une extension de fichier .snk au fichier. Prévoyez de conserver le fichier à part sur une disquette, pour qu'il soit indépendant du serveur de rapports.

  5. Cliquez sur OK.

Procédure de sauvegarde des clés de chiffrement (rskeymgmt)

  1. Insérez une disquette dans le lecteur approprié si vous voulez stocker le fichier protégé par mot de passe séparément du serveur de rapports.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Vous devez utiliser l'argument d'extraction -e pour copier la clé, fournir un nom de fichier et spécifier un mot de passe. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. Conservez la disquette en lieu sûr.

Restauration des clés de chiffrement

La restauration de la clé symétrique remplace la clé existante qui est stockée dans la base de données du serveur de rapports. Cette opération permet de remplacer une clé devenue inutilisable par son exemplaire précédemment enregistré sur disquette. La restauration des clés de chiffrement se traduit par les actions suivantes :

  • La clé symétrique est ouverte à l'aide du fichier de sauvegarde protégé par mot de passe.

  • La clé symétrique est chiffrée à l'aide de la clé publique du service Windows Report Server.

  • La clé symétrique chiffrée est stockée dans la base de données du serveur de rapports.

  • Les données de clé symétrique préalablement stockées (par exemple, des informations de clé déjà présentes dans la base de données du serveur de rapports en raison d'un précédent déploiement) sont supprimées.

Pour restaurer une clé de chiffrement, vous devez posséder un exemplaire de la clé de chiffrement dans un fichier et connaître le mot de passe permettant de déverrouiller l'exemplaire stocké. Si vous détenez la clé et le mot de passe, procédez à la restauration en exécutant l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt La clé symétrique doit être identique à l'exemplaire qui verrouille et déverrouille les données chiffrées stockées à ce moment-là dans la base de données du serveur de rapports. Si vous restaurez un exemplaire non valide, le serveur de rapports est incapable d'accéder à ces données. Vous serez amené à supprimer toutes les valeurs chiffrées si jamais la restauration d'une clé valide est impossible. Si, pour une raison quelconque, vous ne pouvez pas restaurer la clé de chiffrement (vous ne possédez pas de copie de sauvegarde par exemple), supprimez la clé et le contenu chiffré. Pour plus d'informations, consultez Suppression et recréation des clés de chiffrement. Pour plus d'informations sur la création des clés symétriques, consultez Initialisation d'un serveur de rapports.

Procédure de restauration des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports à configurer.

  2. Dans la page Clés de chiffrement, cliquez sur Restaurer.

  3. Sélectionnez le fichier .snk contenant la copie de sauvegarde.

  4. Tapez le mot de passe permettant de déverrouiller le fichier.

  5. Cliquez sur OK.

Procédure de restauration des clés de chiffrement (rskeymgmt)

  1. Insérez la disquette qui contient la copie de sauvegarde de la clé de chiffrement.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Utilisez l'argument -a pour restaurer les clés. Vous devez fournir un nom de fichier complet et spécifier un mot de passe. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement

Autres ressources

Outil de configuration de Reporting Services
Utilitaire rskeymgmt
Opérations de sauvegarde et de restauration pour une installation Reporting Services


Suppression et recréation des clés de chiffrement

Suppression et recréation des clés de chiffrement |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

La suppression et la recréation de clés de chiffrement sont des activités qui dépassent le cadre d'une simple opération de maintenance des clés de chiffrement. Vous effectuez ces tâches en réponse à une menace spécifique pesant sur votre serveur de rapports ou comme ultime recours si vous ne pouvez plus accéder à la base de données du serveur de rapports.

  • Recréez la clé symétrique lorsque vous estimez que la sécurité de la clé existante est compromise. Vous pouvez effectuer cette opération régulièrement en tant que mesure de sécurité.

  • Supprimez les clés de chiffrement existantes et le contenu chiffré inutilisable lorsqu'il vous est impossible de restaurer la clé symétrique.

Recréation des clés de chiffrement

Si vous avez la preuve que la clé symétrique est connue d'utilisateurs non autorisés ou si votre serveur de rapports a subi une attaque et que vous voulez, par mesure de précaution, réinitialiser la clé symétrique, procédez à une nouvelle création de clé. Cette opération implique un nouveau chiffrement de toutes les valeurs chiffrées à l'aide de la nouvelle valeur. Si vous exécutez plusieurs serveurs de rapports dans un déploiement évolutif, tous les exemplaires de la clé symétrique seront mis à jour avec cette nouvelle valeur. Le serveur de rapports utilise les clés publiques disponibles pour cette clé symétrique qu'il met à jour pour chaque serveur dans le déploiement.

La création d'une nouvelle clé symétrique n'est possible que si le serveur de rapports est en cours de fonctionnement. Cette opération, ainsi que le nouveau chiffrement de contenu, peuvent perturber les activités du serveur. Vous devez mettre le serveur en mode hors connexion tandis que vous procédez au nouveau chiffrement. Aucune demande ne doit être adressée au serveur de rapports durant cette opération.

Vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt pour réinitialiser la clé symétrique et les données chiffrées. Pour plus d'informations sur la création de la clé symétrique, consultez Initialisation d'un serveur de rapports.

Procédure de recréation des clés de chiffrement (outil de configuration de Reporting Services)

  1. Désactivez le service Web Report Server et l'accès HTTP en modifiant la propriété IsWebServiceEnabled dans le fichier rsreportserver.config. Cette étape arrête temporairement l'envoi des demandes d'authentification au serveur de rapports sans arrêter complètement le serveur. Vous devez avoir le service minimal afin de pouvoir recréer les clés.

    Si vous recréez des clés de chiffrement pour un déploiement évolutif de serveurs de rapports, désactivez cette propriété sur toutes les instances du déploiement.

    1. Ouvrez l'Explorateur Windows et naviguez jusqu'à lecteur:\Program Files\Microsoft SQL Server\instance_serveur_rapports\Reporting Services. Remplacez lecteur par votre lettre de lecteur et instance_serveur_rapports par le nom du dossier qui correspond à l'instance de serveur de rapports pour laquelle vous souhaitez désactiver le service Web et l'accès HTTP. Par exemple, C:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services.

    2. Ouvrez le fichier rsreportserver.config.

    3. Pour la propriété IsWebServiceEnabled, spécifiez False, puis enregistrez vos modifications.

  2. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports que vous voulez configurer.

  3. Dans la page Clés de chiffrement, cliquez sur Modifier. Cliquez sur OK.

  4. Redémarrez le service Windows Report Server. Si vous recréez des clés de chiffrement pour un déploiement évolutif, redémarrez le service sur toutes les instances.

  5. Réactivez le service Web et l'accès HTTP en modifiant la propriété IsWebServiceEnabled dans le fichier rsreportserver.config. Effectuez cette action pour toutes les instances si vous utilisez un déploiement évolutif.

Procédure de recréation des clés de chiffrement (rskeymgmt)

  1. Désactivez le service Web Report Server et l'accès HTTP. Suivez les instructions de la procédure précédente pour interrompre les opérations du service Web.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Utilisez l'argument -s pour réinitialiser la clé symétrique. Aucun autre argument n'est obligatoire :

    Copier le code
    rskeymgmt -s
  3. Redémarrez le service Windows et activez les opérations du service Web.

Suppression du contenu chiffré inutilisable

Si, pour une raison ou pour une autre, vous ne pouvez pas restaurer la clé de chiffrement, le serveur de rapports sera dans l'incapacité totale de déchiffrer les données chiffrées avec cette clé pour les utiliser. Pour que le serveur de rapports puisse fonctionner de nouveau, vous devez supprimer les valeurs chiffrées qui sont actuellement stockées dans la base de données du serveur de rapports et redéfinir manuellement les valeurs dont vous avez besoin.

La suppression des clés de chiffrement efface toutes les informations de clé symétrique de la base de données du serveur de rapports et supprime tout contenu chiffré. Les données non chiffrées sont intactes, seul le contenu chiffré est supprimé. Lorsque vous détruisez les clés de chiffrement, le serveur de rapports se réinitialise automatiquement en ajoutant une nouvelle clé symétrique. Les événements suivants se produisent lorsque vous supprimez des données chiffrées :

  • Les chaînes de connexion des sources de données partagées sont supprimées. Les utilisateurs qui exécutent des rapports reçoivent le message d'erreur suivant : « La propriété ConnectionString n'a pas été initialisée ».

  • Les informations d'identification sont supprimées. Les rapports et les sources de données partagées sont reconfigurées pour utiliser les informations d'identification qui sont demandées.

  • Les rapports basés sur des modèles (et qui font appel à des sources de données partagées configurées à l'aide d'informations d'identification stockées ou non) ne s'exécutent plus.

  • Les abonnements sont désactivés.

Le contenu chiffré qui est supprimé est irrémédiablement perdu. Vous devez spécifier à nouveau des chaînes de connexion et des informations d'identification stockées, puis activer les abonnements.

Vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt pour supprimer ces valeurs.

Procédure de suppression des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports que vous voulez configurer.

  2. Cliquez sur Clés de chiffrement, puis sur Supprimer. Cliquez sur OK.

  3. Redémarrez le service Windows Report Server. Pour un déploiement évolutif, effectuez cette opération sur toutes les instances de serveurs de rapports.

Procédure de suppression des clés de chiffrement (rskeymmgt)

  1. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Vous devez utiliser l'argument d'application -d. L'exemple suivant illustre l'argument que vous devez spécifier :

    Copier le code
    rskeymgmt -d
  2. Redémarrez le service Windows Report Server. Pour un déploiement évolutif, effectuez cette opération sur toutes les instances de serveurs de rapports.

Procédure de redéfinition des valeurs chiffrées

  1. Indiquez de nouveau la chaîne de connexion de chaque source de données partagée.

  2. Pour chaque rapport et chaque source de données partagée utilisant des informations d'identification stockées, vous devez retaper le nom d'utilisateur et le mot de passe, puis les enregistrer. Pour plus d'informations, consultez Spécification des informations d'identification et de connexion pour les sources de données de rapport.

  3. Pour les abonnements pilotés par les données, ouvrez chaque abonnement et retapez les informations d'identification dans la base de données d'abonnement.

  4. Pour les abonnements utilisant des données chiffrées (ce qui comprend l'extension de remise dans le partage de fichiers et toute extension de remise créées par d'autres développeurs qui utilisent le chiffrement), ouvrez chaque abonnement et retapez les informations d'identification. Les abonnements utilisant la remise par messagerie électronique du serveur de rapports n'ont pas recours aux données chiffrées, ils ne sont donc pas concernés par les modifications apportées à la clé.

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement
Stockage des données chiffrées du serveur de rapports

Autres ressources

Outil de configuration de Reporting Services
Utilitaire rskeymgmt


Ajout et suppression de clés de chiffrement pour un déploiement évolutif

Ajout et suppression de clés de chiffrement pour un déploiement évolutif |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Vous pouvez exécuter Reporting Services dans un modèle de déploiement avec montée en puissance parallèle si vous configurez plusieurs serveurs de rapports pour qu'ils utilisent une base de données de serveur de rapports partagée. L'appartenance d'un serveur de rapports au déploiement évolutif dépend si ce serveur a déposé ou non une clé de chiffrement dans la base de données de serveurs de rapports. Vous pouvez contrôler un déploiement évolutif en ajoutant et en supprimant des clés de chiffrement pour des instances de serveurs de rapports spécifiques. Si vous supprimez des nœuds du déploiement, vous pouvez les supprimer dans n'importe quel ordre. Si vous ajoutez des nœuds à un déploiement, vous devez joindre toutes les nouvelles instances à partir d'un serveur de rapports faisant déjà partie du déploiement.

Utilisation de l'outil de configuration de Reporting Services pour configurer un déploiement évolutif

Le moyen le plus simple de configurer un déploiement évolutif consiste à utiliser l'outil de configuration de Reporting Services. Pour plus d'informations et obtenir des instructions détaillées, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services et Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services).

Utilisation de l'outil Rskeymgmt pour configurer un déploiement évolutif

Initialisez une instance de serveur de rapports à l'aide de l'utilitaire rskeymgmt.exe pour qu'elle utilise une base de données de serveur de rapports partagée. L'ajout d'un serveur de rapports à un déploiement évolutif requiert l'initialisation du serveur de rapports. L'initialisation nécessite des autorisations d'administrateur. Vous devez disposer d'informations d'identification d'administrateur pour l'ordinateur distant qui héberge le serveur de rapports à intégrer au déploiement.

Procédure d'intégration d'un serveur de rapports à un déploiement évolutif (rskeymgmt)

  1. Exécutez rskeymgmt.exe localement sur l'ordinateur hébergeant un serveur de rapports déjà membre du déploiement évolutif.

  2. Utilisez l'argument -j pour rattacher un serveur de rapports à la base de données de serveur de rapports. Utilisez les arguments -m et -n pour spécifier l'instance de serveur de rapports distante à ajouter au déploiement. Utilisez les arguments -u et -v pour spécifier un compte d'administrateur sur l'ordinateur distant. Si vous créez un déploiement évolutif en utilisant plusieurs instances de serveur de rapports sur le même ordinateur, la syntaxe à utiliser est légèrement différente. Pour plus d'informations sur la syntaxe à utiliser, consultez Utilitaire rskeymgmt.

    L'exemple suivant illustre les arguments que vous devez spécifier si vous ajoutez un serveur de rapports distant à un déploiement évolutif (vous pouvez omettre les informations d'identification si vous avez des autorisations d'administrateur sur l'ordinateur distant) :

    Copier le code
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

Procédure de suppression d'un serveur de rapports intégré à un déploiement évolutif (rskeymgmt)

  1. Ouvrez le fichier rsreportserver.config du serveur de rapports que vous souhaitez supprimer et recherchez l'ID d'installation. Par défaut, ce fichier se trouve dans le répertoire Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer).

    Si vous installez une instance unique, il n'y aura qu'un seul fichier rsreportserver.config sur l'ordinateur. Si plusieurs instances de Reporting Services sont installées, utilisez la page État du serveur de l'outil de configuration de Reporting Services pour rechercher l'identificateur d'instance (par exemple, MSSQL.2) pour le serveur de rapports que vous souhaitez supprimer. Le nom du dossier où sont stockés les fichiers programmes de l'instance du serveur de rapports est basé sur l'identificateur de l'instance (par exemple, Program Files\Microsoft SQL Server\MSSQL.2).

  2. Exécutez rskeymgmt.exe. Vous pouvez exécuter cet utilitaire sur n'importe quel serveur de rapports intégré à un déploiement évolutif de serveurs de rapports.

  3. Utilisez l'argument -r pour séparer l'instance de serveur de rapports du déploiement évolutif. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -r <installation ID>

Ces étapes suppriment le serveur de rapports d'un déploiement avec montée en puissance parallèle, mais ne désinstallent pas l'instance Reporting Services sur le serveur de rapports. Après avoir supprimé le serveur de rapports du déploiement avec montée en puissance parallèle, vous pouvez désinstaller Reporting Services du serveur si vous n'avez plus besoin de Reporting Services sur ce serveur. Pour plus d'informations, consultez Procédure : désinstaller une instance existante de SQL Server 2008 (Programme d'installation).

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement
Initialisation d'un serveur de rapports

Autres ressources

Outil de configuration de Reporting Services
Utilitaire rskeymgmt


Stockage des données chiffrées du serveur de rapports

Stockage des données chiffrées du serveur de rapports |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Reporting Services stocke des valeurs chiffrées dans la base de données du serveur de rapports et dans les fichiers de configuration. La plupart des valeurs chiffrées sont des informations d'identification utilisées pour accéder à des sources de données externes fournissant des données aux rapports. Cette rubrique indique quelles valeurs sont chiffrées et décrit la fonctionnalité de chiffrement utilisée dans Reporting Services, ainsi que les autres types de données confidentielles stockées qu'il convient de connaître.

Valeurs chiffrées

La liste suivante décrit les valeurs qui sont stockées dans une installation Reporting Services.

  • Informations de connexion et informations d'identification utilisées par un serveur de rapports pour la connexion à une base de données de serveur de rapports qui stocke des données de serveur internes.

    Ces valeurs sont spécifiées et chiffrées au cours de l'installation ou de la configuration du serveur de rapports. Vous pouvez mettre à jour les informations de connexion à tout moment par le biais de l'outil de configuration de Reporting Services ou de l'utilitaire rsconfig. Le chiffrement des paramètres de configuration s'effectue à l'aide de la clé au niveau machine de l'ordinateur local qui est disponible pour tous les utilisateurs. Les informations chiffrées de connexion au serveur de rapports sont stockées dans le fichier rsreportserver.config (aucun autre fichier de configuration ne possède de paramètres chiffrés). Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

  • Informations d'identification stockées, utilisées par un serveur de rapports pour se connecter à des sources de données externes qui fournissent des données à un rapport.

    Ces valeurs sont définies lorsque vous configurez les informations d'une source de données pour un rapport, puis elles sont stockées sous la forme de valeurs chiffrées dans une base de données du serveur de rapports. Le serveur de rapports utilise une clé symétrique pour chiffrer et déchiffrer ces données. Pour plus d'informations sur les informations d'identification stockées, consultez Planification des services, des comptes et des connexions et Spécification des informations d'identification et de connexion pour les sources de données de rapport.

  • Un compte d'utilisateur sans assistance utilisé par le serveur de rapports pour se connecter à d'autres ordinateurs afin d'extraire des fichiers images externes ou des données externes utilisées dans un rapport.

    Ce compte est utilisé lorsqu'une connexion à un ordinateur distant est requise et qu'aucune autre information d'identification n'est disponible pour établir la connexion. Ce compte est principalement utilisé pour gérer le traitement de rapports sans assistance qui n'utilise pas d'informations d'identification pour accéder à une source de données. Si vous créez des rapports basés sur des sources de données qui ne nécessitent pas ou n'utilisent pas d'informations d'identification lors de l'accès aux données, vous devez configurer ce compte pour permettre son utilisation par le serveur de rapports.

    Ce compte se révèle indispensable dans certains cas et seul l'outil de configuration de Reporting Services ou l'utilitaire rsconfig peut créer un tel compte. Cette valeur est également stockée dans le fichier rsreportserver.config. Vous devez créer ce compte manuellement. Pour plus d'informations sur ce compte et son utilisation, consultez Configuration du compte d'exécution sans assistance.

  • Clé symétrique utilisée pour un chiffrement.

    Cette valeur est créée pendant l'installation ou la configuration du serveur, elle est ensuite stockée sous forme de valeur chiffrée dans la base de données du serveur de rapports. Le service Windows Report Server utilise cette clé pour chiffrer et déchiffrer des données stockées dans la base de données du serveur de rapports.

Fonctionnalité de chiffrement dans Reporting Services

Reporting Services utilise des fonctions de chiffrement qui font partie du système d'exploitation Windows. Des chiffrements symétriques et asymétriques sont utilisés.

Les données de la base de données du serveur de rapports sont chiffrées à l'aide d'une clé symétrique. Il existe une clé symétrique pour chaque base de données de serveur de rapports. Cette clé symétrique est elle-même chiffrée à l'aide de la clé publique d'une paire de clés asymétriques générée par Windows. La clé privée est détenue par le compte du service Report Server Windows.

Dans un déploiement évolutif de serveur de rapports où plusieurs instances de serveur de rapports partagent la même base de données de serveur de rapports, une clé symétrique unique est employée par tous les nœuds de serveur de rapports. Chaque nœud doit avoir une copie de la clé symétrique partagée. Une copie de la clé symétrique est créée automatiquement pour chaque nœud lorsque le déploiement évolutif est configuré. Chaque nœud chiffre sa copie de la clé symétrique à l'aide de la clé publique d'une paire de clés spécifiques de son compte de service Windows. Pour en savoir plus sur la création de la clé symétrique pour les déploiements à instance unique et évolutifs, consultez Initialisation d'un serveur de rapports.

Remarque :
Lorsque vous changez le compte du service Report Server Windows, les clés asymétriques peuvent devenir non valides, ce qui affecte les opérations du serveur. Pour éviter ce problème, utilisez toujours l'outil de configuration de Reporting Services pour modifier les paramètres de compte de service. Lorsque vous utilisez l'outil de configuration, les clés sont mises à jour automatiquement. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Autres sources de données confidentielles

Un serveur de rapports stocke d'autres données non chiffrées, mais qui contiennent des informations sensibles que vous voulez protéger. Plus particulièrement, les captures instantanées d'historique de rapport et d'exécution de rapport contiennent des résultats de requêtes pouvant inclure des données destinées exclusivement à des utilisateurs autorisés. Si vous utilisez la fonction de capture instantanée pour des rapports qui contiennent des données confidentielles, sachez que les utilisateurs capables d'ouvrir des tables dans une base de données du serveur de rapports peuvent être en mesure d'afficher des parties d'un rapport stocké en inspectant le contenu de la table.

Remarque :
Reporting Services ne prend pas en charge la mise en cache ou l'historique de rapport pour les rapports basés sur l'identité de sécurité de l'utilisateur.

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement

Autres ressources

Administration d'une base de données du serveur de rapports
Fichiers de configuration (Reporting Services)


Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Les déploiements avec montée en puissance parallèle sont utilisés pour augmenter l'évolutivité des serveurs de rapports afin de gérer davantage d'utilisateurs simultanés et de plus grandes charges d'exécution de rapport. Ils peuvent également être utilisés pour dédier des serveurs spécifiques à traiter des rapports interactifs ou planifiés. Les déploiements avec montée en puissance parallèle sont constitués de :

  • Plusieurs instances de serveurs de rapports qui partagent une base de données de serveur de rapports unique.

  • Éventuellement, un cluster à charge réseau équilibrée pour répartir la charge utilisateur interactive parmi les instances de serveurs de rapports.

Lorsque vous déployez Reporting Services sur un cluster à équilibrage de la charge réseau, vous devez vous assurer que le nom du serveur virtuel d'équilibrage de la charge réseau est utilisé dans la configuration des URL de serveurs de rapports et que les serveurs sont configurés pour partager le même état d'affichage.

Reporting Services ne participe pas aux clusters Microsoft Cluster Services. Toutefois, vous pouvez créer la base de données du serveur de rapports sur une instance de Moteur de base de données qui fait partie d'un cluster de basculement.

Pour planifier, installer et configurer un déploiement avec montée en puissance parallèle, suivez ces étapes :

  • Consultez Planification d'un déploiement avec montée en puissance parallèle pour obtenir des indications sur l'utilisation d'un déploiement avec montée en puissance parallèle.

  • Consultez Procédure : installer SQL Server 2008 (programme d'installation) pour obtenir des instructions relatives à l'installation des instances de serveurs de rapports.

  • Consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services) pour obtenir des instructions sur le partage d'une base de données du serveur de rapports et la jointure des serveurs de rapports avec montée en puissance parallèle.

  • Éventuellement, si vous configurez la montée en puissance parallèle pour une exécution sur un cluster à charge réseau équilibrée, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau pour obtenir des instructions sur la façon de configurer la validation de l'état d'affichage.

Voir aussi

Concepts

URL des fichiers de configuration (Reporting Services)
Considérations sur l'installation de Reporting Services

Autres ressources

Planification d'une topologie de déploiement
Hébergement d'une base de données du serveur de rapports dans un cluster de basculement SQL Server
Fichiers de configuration (Reporting Services)
Composants et outils de Reporting Services


Configuration de Reporting Services pour l'intégration de SharePoint 3.0

Configuration de Reporting Services pour l'intégration de SharePoint 3.0 |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Vous pouvez configurer un déploiement de SQL Server Reporting Services pour fonctionner avec un déploiement de Microsoft Windows SharePoint Services 3.0 ou Microsoft Office SharePoint Server 2007. Vous devez effectuer des étapes de configuration sur un serveur de rapports et un déploiement de produit ou de technologie SharePoint pour que les utilisateurs puissent publier des documents de création de rapports dans les bibliothèques SharePoint et obtenir des services de gestion et d'affichage de rapports sur les sites SharePoint. La procédure de configuration établit des informations de connexion au serveur ; par conséquent, il est important d'effectuer les étapes dans l'ordre.

Cette rubrique fournit une vue d'ensemble des étapes de configuration pour chaque serveur. Elle contient les sections suivantes :

  • Vue d'ensemble des étapes de configuration sur un serveur de rapports

  • Vue d'ensemble des étapes de configuration sur un serveur SharePoint

  • Configuration du compte de service

  • Procédure de configuration de l'intégration de serveur

Pour plus d'informations sur les différentes topologies de serveur, consultez Topologies de déploiement pour Reporting Services en mode intégré SharePoint. Pour une liste complète de rubriques relatives à l'intégration SharePoint dans la documentation en ligne, consultez Comment en savoir plus sur le mode intégré SharePoint.

Vue d'ensemble des étapes de configuration sur un serveur de rapports

Pour configurer un serveur de rapports pour l'intégration SharePoint, vous devez disposer d'un serveur de rapports autonome existant ou d'un déploiement évolutif. Vous devez effectuer les tâches suivantes sur le serveur de rapports :

  1. Créez une base de données de serveur de rapports en mode intégré SharePoint.

    Cela permet de définir des propriétés de serveur sur le serveur de rapports et d'activer un nouveau point de terminaison de gestion du serveur de rapports SOAP qui est utilisé pour le fonctionnement en mode intégré. Utilisez l'outil de configuration de Reporting Services pour créer la base de données.

  2. Pour les déploiements qui incluent une batterie de serveurs SharePoint, installez un serveur Web frontal Windows SharePoint Services sur le serveur de rapports. Le serveur Web frontal joint le serveur de rapports à une batterie de serveurs SharePoint. L'installation du serveur Web frontal sur le serveur de rapports est nécessaire uniquement si vous déployez le serveur de rapports et l'instance de technologie SharePoint sur des ordinateurs distincts.

  3. Pour les déploiements qui incluent le placement des bases de données SharePoint sur le même ordinateur que le serveur de rapports, configurez le service Report Server pour s'exécuter sous un compte de domaine. Cette étape est nécessaire uniquement si les serveur de rapports et les bases de données d'application sont un même ordinateur et que l'application Web SharePoint se trouve sur un autre ordinateur.

À propos de la base de données du serveur de rapports

Une base de données de serveur de rapports offre un espace de stockage interne pour une ou plusieurs instances du serveur de rapports. Une base de données du serveur de rapports peut prendre en charge les opérations en mode natif ou en mode d'intégration SharePoint, mais pas les deux. Le contenu de la base de données dépend du mode et n'est pas interchangeable d'un mode de serveur à l'autre. Si vous créez une base de données de serveur de rapports pour prendre en charge le mode intégré SharePoint, vous ne pouvez convertir ni migrer automatiquement la base de données pour qu'elle s'exécute ultérieurement avec une instance du serveur de rapports en mode natif. Une base de données de serveur de rapports est utilisée de plusieurs manières, selon le mode de serveur :

  • Lorsqu'elle est créée pour un fonctionnement en mode natif, la base de données du serveur de rapports est le seul référentiel pour les données persistantes utilisées par le serveur de rapports.

  • Lorsqu'elle est créée en mode intégré SharePoint, la base de données du serveur de rapports contient les propriétés du serveur, des captures instantanées d'exécution de rapport, un historique des rapports, des définitions d'abonnement et des planifications. Elle contient une copie secondaire des rapports, des modèles de rapports, des sources de données partagées et des ressources afin d'améliorer les performances de traitement sur le serveur. Le stockage principal pour les documents de rapports se trouve dans les bases de données de contenu SharePoint. Pour plus d'informations, consultez Stockage et synchronisation de contenu de serveur de rapports avec des bases de données SharePoint.

La création d'une base de données de serveur de rapports pour le mode intégré SharePoint est une première étape importante de la configuration du serveur de rapports pour l'intégration SharePoint. Vous pouvez utiliser l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports et configurer la connexion au serveur de rapports. Seul le serveur de rapports se connecte à la base de données du serveur de rapports. L'instance de Windows SharePoint Services ou de Office SharePoint Server ne se connecte jamais à la base de données du serveur de rapports et n'extrait jamais de données de cette dernière.

À propos du déploiement de serveur de rapports avec montée en puissance parallèle et du mode intégré SharePoint

Si vous intégrez un déploiement avec montée en puissance parallèle de serveur de rapports à une batterie de serveurs SharePoint, toutes les instances de serveur de rapports qui font partie du déploiement doivent s'exécuter en mode intégré SharePoint. Vous ne pouvez pas avoir une combinaison de modes de serveur dans le même déploiement évolutif. En outre, vous devez créer un point unique d'entrée au déploiement avec montée en puissance parallèle (autrement dit, une URL résolue à une adresse IP virtuelle pour un cluster à équilibrage de charge réseau sur lequel les instances de serveur de rapports sont installées).

À propos des instances de serveur de rapports multiples et du mode intégré SharePoint

Si vous installez plusieurs instances de Reporting Services sur un ordinateur unique, mais que vous configurez uniquement l'une de ces instances pour le mode intégré SharePoint, assurez-vous d'effectuer les opérations suivantes :

  • Assurez-vous que toutes les instances de Reporting Services sont la même version. SQL Server 2008 Reporting Services (SSRS) introduit une version mise à jour du fournisseur Reporting Services Windows Management Instrumentation (WMI). Vous ne pouvez pas avoir SQL Server 2008 Reporting Services (SSRS) et des versions antérieures à SQL Server 2008 Reporting Services (SSRS) sur le même ordinateur. Par conséquent, il est nécessaire que toutes les instances de serveur de rapports exécutent SQL Server 2008 Reporting Services (SSRS) ou version ultérieure, même si vous n'avez pas besoin de fonctionnalités SQL Server 2008 Reporting Services (SSRS) pour toutes les instances.

  • Si vous exécutez le programme d'installation de SQL Server 2008 pour chaque instance de serveur de rapports à différents moments, redémarrez le service WMI après avoir installé la deuxième instance de SQL Server 2008 Reporting Services (SSRS).

Vue d'ensemble des étapes de configuration sur un serveur SharePoint

Pour configurer l'intégration sur le serveur qui exécute le produit ou la technologie SharePoint, vous devez effectuer les opérations suivantes :

  1. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

    Le complément installe des fichiers programme et des pages d'application, y compris les pages que vous ouvrez dans l'administration centrale pour définir l'URL du serveur de rapports et d'autres paramètres d'intégration. Vous pouvez spécifier des paramètres d'intégration du serveur de rapports pour une batterie de serveurs SharePoint ou une application Web SharePoint indépendante.

  2. Activez la fonctionnalité de serveur de rapports si vous n'avez pas installé le complément sur une collection de site racine.

  3. Utilisez l'Administration centrale de SharePoint pour configurer l'intégration du serveur de rapports. Les paramètres de configuration incluent la spécification d'une URL de serveur de rapports unique, la définition d'un type d'authentification sur les demandes dirigées vers le serveur de rapports et l'accord des autorisations d'accès aux bases de données au compte de service Report Server.

  4. Éventuellement, dans l'Administration centrale de SharePoint, vous pouvez définir des valeurs par défaut de serveur de rapports qui activent l'enregistrement, la création de rapports ad hoc et des limites pour l'historique de rapport et les valeurs de délai d'attente.

Les produits et technologies SharePoint peuvent être déployés sous la forme d'une batterie de serveurs ou d'un serveur autonome. Une batterie de serveurs contient un ou plusieurs serveurs virtuels où chaque serveur virtuel est une application Web SharePoint. Un serveur de rapports s'intègre au niveau de la batterie de serveurs. De la perspective de l'intégration de l'espace de stockage, il peut exister une seule base de données de serveur de rapports pour une batterie de serveurs. Vous pouvez utiliser l'administration centrale de SharePoint pour gérer les paramètres d'intégration pour tous les serveurs de la batterie de serveurs.

Chaque application Web SharePoint dans une batterie de serveurs peut être configurée pour utiliser des fournisseurs d'authentification différents. Cela n'affecte en aucune manière l'intégration du serveur de rapports. Le déploiement du serveur de rapports traitera les demandes pour chaque serveur de la batterie de serveurs, quel que soit le fournisseur d'authentification qu'il utilise.

Chaque application Web possède un site de niveau supérieur par défaut. Vous pouvez définir des autorisations de manière différente sur chaque site de niveau supérieur pour modifier la disponibilité des éléments et des opérations du serveur de rapports entre tous les serveurs d'une batterie de serveurs.

Configuration du compte de service

Un serveur de rapports est implémenté comme service Windows unique qui s'exécute sous un compte intégré ou un compte local ou d'utilisateur Windows de domaine. En mode intégré SharePoint, le service doit se connecter aux bases de données de contenu SharePoint avec des autorisations d'écriture et d'exécution. Étant donné que le service se connecte aux bases de données de contenu SharePoint, le compte que vous utilisez pour exécuter le service aura des spécifications différentes selon que des connexions distantes sont utilisées et que la connexion du point de terminaison proxy de l'URL du serveur de rapports utilise la sécurité intégrée de Windows ou le mode Compte approuvé.

Le tableau suivant fournit des recommandations de compte de service pour différents scénarios de déploiement.

Scénario de déploiement Services Bases de données SharePoint Recommandation de compte pour le service Report Server

Serveur unique

Tous les services sont installés sur le même ordinateur

Sur le même ordinateur

N'importe lequel (NetworkService, utilisateur de domaine, utilisateur local, LocalSystem).

Étant donné que les applications se connectent à l'aide d'une connexion de base de données locale, vous pouvez configurer le service pour s'exécuter sous tout type de compte.

Déploiement distribué sur plusieurs ordinateurs

Application Web SharePoint et serveur de rapports installés sur des ordinateurs différents

Sur un troisième ordinateur

-- ou --

Ordinateur serveur SharePoint

Compte d'utilisateur de domaine

-- ou --

NetworkService, mais uniquement si vous ajoutez NT_AUTHORITY\NetworkService au groupe Windows WSS_WPG sur le serveur de rapports. Pour plus d'informations, consultez Dépannage de problèmes liés aux erreurs de configuration.

Déploiement distribué sur plusieurs ordinateurs

Application Web SharePoint et serveur de rapports installés sur des ordinateurs différents

Sur l'ordinateur serveur de rapports

Le compte d'utilisateur de domaine est requis, indépendamment de la façon dont le point de terminaison proxy d'URL du serveur de rapports est configuré.

Lorsque les bases de données SharePoint s'exécutent sur un ordinateur distant, l'application Web SharePoint refuse explicitement l'accès aux bases de données des comptes d'ordinateur d'un ordinateur distant. Si le serveur de rapports se trouve sur le même ordinateur que les bases de données SharePoint et si l'un des services s'exécute sous un compte intégré, l'accès lui sera refusé en conséquence. La configuration du service pour qu'il s'exécute en tant que compte d'utilisateur de domaine garantit que le serveur de rapports ne se verra pas refuser l'accès aux bases de données car il s'exécute sous un compte interdit.
Remarque :
La base de données du serveur de rapports n'est pas incluse dans la discussion des spécifications de compte de service pour les connexions de base de données. Cela est dû au fait que seul le serveur de rapports se connecte à la base de données du serveur de rapports.

À propos des configurations de compte de service SharePoint

Les recommandations de compte de service pour Windows SharePoint Services et Office SharePoint Server stipulent que pour un déploiement de batterie de serveurs, vous devez exécuter le processus de pool d'applications comme compte d'utilisateur de domaine, et non comme Service réseau. Bien qu'un compte d'utilisateur de domaine soit recommandé, il n'est pas requis. Toutefois, il est important de savoir que si vous configurez une application Web SharePoint pour s'exécuter comme Service réseau et que le serveur de rapports est sur un ordinateur distant, vous rencontrerez des erreurs lors de l'accès aux rapports et aux fonctionnalités de serveur de rapports d'un site SharePoint si le point de terminaison proxy d'URL du serveur de rapports se connecte en mode Compte approuvé. Pour plus d'informations sur les erreurs de serveur qui se produisent lorsque vous déployez cette configuration, consultez Dépannage de problèmes liés aux erreurs de configuration.

Pour plus d'informations sur la connexion des comptes de service à une instance de technologie SharePoint, consultez Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint. Pour plus d'informations sur les recommandations relatives aux comptes de service pour un déploiement SharePoint, consultez Planification des comptes administratifs et comptes de service dans la documentation produit de Windows SharePoint Services.

Procédure de configuration de l'intégration de serveur

La configuration des serveurs pour un fonctionnement intégré requiert plusieurs outils et étapes. Cliquez sur les liens suivants pour lire les instructions relatives à la configuration de l'intégration de serveur dans des scénarios de déploiement spécifiques :

  • Procédure : configurer l'intégration à SharePoint sur un serveur autonome

  • Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Voir aussi

Tâches

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint
Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Référence

Configuration des comptes de service Windows

Concepts

Sauvegarde et restauration des clés de chiffrement
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services)

Autres ressources

Fichier de configuration RSReportDesigner
Planification d'un mode de déploiement
Topologies de déploiement pour Reporting Services en mode intégré SharePoint
Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint
Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint
Déploiement de modèles et de sources de données partagées sur un site SharePoint


Rubriques d'aide à la configuration de Reporting Services

Rubriques d'aide à la configuration de Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Cette section contient des procédures qui indiquent comment configurer une instance de serveur de rapports à l'aide de l'outil de configuration de Reporting Services.

Dans cette section

Les rubriques de cette section sont organisées en catégories afin que vous puissiez rechercher plus aisément les instructions que vous souhaitez. La première section contient les rubriques pour les tâches de configuration de base pour un serveur de rapports en mode natif. La deuxième section contient les rubriques de configuration avancées. La troisième section contient les rubriques pour configurer un serveur de rapports afin qu'il s'exécute en mode intégré SharePoint.

Configuration de base

Rubrique | Description
Procédure : démarrer la configuration de Reporting Services | Indique la procédure à suivre pour démarrer l'outil de configuration de Reporting Services.
Procédure : configurer un compte de service pour Reporting Services | Explique comment spécifier des informations de compte et de mot de passe pour le service Web Report Server.
Procédure : inscrire un nom principal de service (SPN) pour Report Server | Explique comment enregistrer manuellement un SPN pour un serveur de rapports qui s'exécute sous un compte d'utilisateur de domaine sur un réseau qui utilise l'authentification Kerberos.
Procédure : configurer une URL (configuration de Reporting Services) | Explique comment établir une ou plusieurs URL utilisées pour accéder au service Web Report Server et au Gestionnaire de rapports.
Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) | Indique la procédure à suivre pour créer une base de données du serveur de rapports. Cette étape est nécessaire pour déployer une installation de Reporting Services.

Configuration avancée ou facultative

Rubrique | Description
Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services) | Indique la procédure à suivre pour configurer plusieurs serveurs de rapports afin qu'ils partagent une base de données du serveur de rapports.
Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services) | Fournit des instructions de configuration d'un serveur de rapports pour la distribution par messagerie.
Procédure : configurer un pare-feu pour accéder à Report Server | Explique comment ouvrir les ports utilisés pour les demandes entrantes et les réponses sortantes d'un serveur de rapports.
Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008 | Décrit les étapes supplémentaires requises pour se connecter au Gestionnaire de rapports ou à un serveur de rapports en utilisant http://localhost.
Procédure : configurer un serveur de rapports pour l'administration à distance | Explique comment configurer une instance de serveur de rapports distante afin que vous puissiez vous y connecter et le configurer à partir d'un autre ordinateur.
Procédure : activer ou désactiver les fonctionnalités Reporting Services | Explique comment supprimer les fonctionnalités inutilisées dans une installation Reporting Services.
Procédure : activer les erreurs distantes (Configuration Reporting Services) | Explique comment définir des propriétés de serveur sur un serveur de rapports de façon à retourner des informations supplémentaires concernant les conditions d'erreur qui se produisent sur des serveurs distants.

Intégration SharePoint

Rubrique | Description
Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports. | Explique comment ajouter des fichiers programme SharePoint utilisés pour joindre un serveur de rapports à une batterie de serveurs SharePoint.
Procédure : installer ou désinstaller le complément Reporting Services | Explique comment installer les pages d'application du serveur de rapports, les pages de configuration et l'URL sur un serveur SharePoint.
Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint | Explique comment activer manuellement la fonctionnalité de serveur de rapports pour une collection de sites si la collection de sites racine n'est pas activée.
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services) | Explique comment créer une base de données de serveur de rapports pour un serveur de rapports qui s'exécute en mode intégré SharePoint.
Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint | Fournit des instructions pour configurer l'intégration dans l'administration centrale de SharePoint.
Procédure : configurer l'intégration à SharePoint sur un serveur autonome | Fournit les instructions pas à pas pour installer tous les composants serveur et bases de données d'application sur un ordinateur unique.
Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs | Fournit les instructions pas à pas pour installer les composants serveur sur plusieurs ordinateurs dans un déploiement de serveurs distribué.
Procédure : basculer entre les modes serveur (configuration de Reporting Services) | Explique comment supprimer une instance de serveur de rapports d'un déploiement d'une technologie ou d'une instance SharePoint afin de pouvoir l'exécuter en tant que serveur de rapports en mode natif.
Comment en savoir plus sur le mode intégré SharePoint | Fournit une liste de rubriques spécifiques au complément Reporting Services pour SharePoint Technologies.

Voir aussi

Tâches

Procédure : détecter les informations de version (Reporting Services)

Concepts

Procédure : migrer une installation Reporting Services

Autres ressources

Conception de rapports ad hoc : rubriques de procédures
Configuration d'une installation de serveur de rapports
Outil de configuration de Reporting Services


Procédure : démarrer la configuration de Reporting Services

Procédure : démarrer la configuration de Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

L'outil de configuration Reporting Services est utilisé pour configurer une installation Reporting Services. Vous pouvez configurer une instance de serveur de rapports locale ou distante tant que vous êtes membre du groupe d'administrateurs local sur le serveur de rapports. Pour pouvoir configurer une instance de serveur de rapports distante et vous y connecter, vous devez permettre aux appels WMI (Windows Management Instrumentation) distants de traverser le Pare-feu Windows. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration à distance dans la documentation en ligne de SQL Server.

L'outil de configuration Reporting Services est spécifique à la version. L'outil de configuration Reporting Services installé avec SQL Server 2008 ne peut pas être utilisé pour configurer une version antérieure de Reporting Services. Si vous exécutez des versions anciennes et récentes de Reporting Services côte à côte sur le même ordinateur, vous devez utiliser l'outil de configuration Reporting Services fourni avec chaque version pour configurer chaque instance.

Pour lancer la configuration de Reporting Services

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, puis sur Outils de configuration.

    Si vous souhaitez configurer une instance de serveur de rapports à partir d'une version antérieure de SQL Server, ouvrez le dossier de programme pour cette version. Par exemple, pointez sur Microsoft SQL Server 2005 au lieu de Microsoft SQL Server 2008 pour ouvrir les outils de configuration pour les composants serveur SQL Server 2005.

  2. Cliquez sur Configuration de Reporting Services. La boîte de dialogue Se connecter à une instance du serveur de rapports s'affiche pour que vous spécifiiez l'instance de serveur de rapports à configurer.

  3. Dans Nom du serveur, spécifiez le nom de l'ordinateur sur lequel est installée l'instance de serveur de rapports. Le nom de l'ordinateur local apparaît par défaut, mais vous pouvez taper le nom d'une instance SQL Server distante si vous souhaitez vous connecter à un serveur de rapports installé sur un ordinateur distant.

  4. Si vous spécifiez un ordinateur distant, cliquez sur Rechercher pour établir une connexion.

  5. Dans Instance du serveur de rapports, sélectionnez l'instance SQL Server Reporting Services que vous souhaitez configurer. Seules les instances de serveur de rapports SQL Server 2008 figurent dans la liste. Vous ne pouvez pas configurer d'instances de versions antérieures de Reporting Services.

  6. Cliquez sur Connexion.

Voir aussi

Concepts

Rubriques d'aide à la configuration de Reporting Services

Autres ressources

Configuration d'une installation de serveur de rapports
Outil de configuration de Reporting Services


Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint

Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Les paramètres d'intégration de serveur de rapports sont configurés dans l'Administration centrale SharePoint une fois que vous avez installé le complément Microsoft SQL Server 2008 Reporting Services pour technologies SharePoint. Pour configurer l'intégration de serveur de rapports, utilisez les pages Reporting Services sous l'onglet Gestion des applications d'Administration centrale.

Si la section Reporting Services n'est pas visible dans Gestion des applications, le complément Reporting Services n'est pas installé ou les paramètres d'intégration de serveur de rapports ne sont pas activés.

Pour vérifier l'installation, consultez la liste des applications installées dans Ajout/Suppression de programmes. Si le complément Reporting Services est installé, suivez les instructions dans cette rubrique pour activer la fonctionnalité.

Par défaut, le complément Reporting Services est activé pour la collection de sites racine de l'application Web SharePoint locale. Si le site racine n'est pas activé ou si vous n'avez pas de collection de sites définie lorsque le complément Reporting Services est installé, vous devez activer les paramètres d'intégration de serveur de rapports manuellement.

Pour activer l'intégration Reporting Services sur une collection de sites

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 3.0.

  2. Cliquez sur Actions du site.

  3. Cliquez sur Paramètres du site.

  4. Cliquez sur Fonctionnalités de la collection de sites.

  5. Recherchez Fonctionnalité d'intégration Report Server dans la liste.

  6. Cliquez sur Activer.

Étapes suivantes

Une fois la fonctionnalité activée, vous pouvez continuer l'intégration de serveur. Pour obtenir des instructions, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Voir aussi

Concepts

Procédure : installer ou désinstaller le complément Reporting Services
Procédure : installer ou désinstaller le complément Reporting Services
Configuration de Reporting Services pour l'intégration de SharePoint 3.0

Autres ressources

Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint
Planification d'un mode de déploiement


Procédure : configurer un pare-feu pour accéder à Report Server

Procédure : configurer un pare-feu pour accéder à Report Server |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Les applications du serveur de rapports et les rapports publiés sont accessibles via les URL qui spécifient une adresse IP, un port et un répertoire virtuel. Si le Pare-feu Windows est activé, le port que le serveur de rapports est configuré pour utiliser est très probablement fermé. La présence d'une page Web vierge après la demande d'un rapport ou l'affichage d'une page vierge lorsque vous tentez d'ouvrir le Gestionnaire de rapports à partir d'un ordinateur client distant constituent une indication qu'un port peut être fermé.

Pour ouvrir un port, vous devez utiliser le Pare-feu Windows sur le serveur de rapports. Reporting Services n'ouvrent pas de ports automatiquement ; vous devez effectuer cette étape manuellement.

Par défaut, le serveur de rapports écoute les requêtes HTTP sur le port 80. De ce fait, les instructions suivantes incluent les étapes qui spécifient ce port. Si vous avez configuré les URL du serveur de rapports pour utiliser un autre port, vous devez spécifier ce numéro de port lors des instructions ci-après.

Si vous accédez à des bases de données relationnelles SQL Server sur des ordinateurs externes, ou si la base de données du serveur de rapports se trouve sur une instance SQL Server externe, vous devez ouvrir les ports 1433 et 1434 sur l'ordinateur externe. Pour plus d'informations, consultez Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données. Pour plus d'informations sur le paramètres par défaut du Pare-feu Windows et obtenir une description des ports TCP qui affectent le Moteur de base de données, Analysis Services, Reporting Services et Integration Services, consultez Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server.

Configuration requise

Ces instructions supposent que vous avez déjà configuré le compte de service, créé la base de données du serveur de rapports et configuré les URLS du service Web Report Server et du Gestionnaire de rapports. Pour plus d'informations, consultez Rubriques d'aide à la configuration de Reporting Services.

Vous devez aussi avoir vérifié que le serveur de rapports est accessible via une connexion locale du navigateur Web à l'instance locale du serveur de rapports. Cette étape établit que votre installation est en état de marche. Vous devez vérifier que l'installation est configurée correctement avant de commencer à ouvrir les ports. Pour compléter cette étape sur Windows Vista ou Windows Server 2008, vous devez également avoir ajouté le site du serveur de rapports aux Sites de confiance. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

Ouverture des ports dans le Pare-feu Windows

Il existe des instructions distinctes selon les différentes versions du Pare-feu Windows. Si vous utilisez Windows Vista ou Windows Server 2008, recourez aux instructions à la fin de cette rubrique.

Pour ouvrir le port 80 sur Windows Server 2003 SP2 ou Windows XP SP2

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration, puis sur Pare-feu Windows.

  2. Sous l'onglet Exceptions, cliquez sur Ajouter un port.

  3. Dans la zone Nom, tapez ReportServer (TCP sur le port 80).

  4. Dans la zone Numéro de port, tapez 80.

  5. Vérifiez que le protocole TCP est sélectionné.

  6. Cliquez sur Modifier l'étendue.

  7. Cliquez sur Uniquement mon réseau (ou sous-réseau),, puis cliquez sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue.

  9. Redémarrez l'ordinateur.

Pour ouvrir le port 80 sur Windows Vista

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration, cliquez sur Sécurité, puis sur Pare-feu Windows.

  2. Cliquez sur Autoriser un programme via le Pare-feu Windows.

  3. Cliquez sur Continuer.

  4. Sous l'onglet Exceptions, cliquez sur Ajouter un port.

  5. Dans la zone Nom, tapez ReportServer (TCP sur le port 80).

  6. Dans la zone Numéro de port, tapez 80.

  7. Vérifiez que le protocole TCP est sélectionné.

  8. Cliquez sur Modifier l'étendue.

  9. Cliquez sur Uniquement mon réseau (ou sous-réseau),, puis cliquez sur OK.

  10. Cliquez sur OK pour fermer la boîte de dialogue.

  11. Redémarrez l'ordinateur.

Étapes suivantes

Après avoir ouvert le port et avant de confirmer si les utilisateurs distants peuvent accéder au serveur de rapports sur le port que vous ouvrez, vous devez accorder l'accès utilisateur au serveur de rapports à travers les attributions de rôle sur la page d'Accueil et au niveau du site. Vous pouvez ouvrir un port correctement et que les connexions du serveur de rapports échouent si les utilisateurs n'ont pas les autorisations suffisantes. Pour plus d'informations, consultez Procédure : accorder à un utilisateur l'accès à un serveur de rapports (Gestionnaire de rapports).

Vous pouvez également vérifier que le port est ouvert correctement en démarrant le Gestionnaire de rapports sur un autre ordinateur. Pour plus d'informations, consultez Procédure : démarrer le Gestionnaire de rapports.

Voir aussi

Tâches

Procédure : vérifier une installation de Reporting Services

Concepts

Configuration du compte de service Report Server
Configuration des URL de Report Server
Création d'une base de données de serveur de rapports
Configuration du compte de service Report Server
Rubriques d'aide à la configuration de Reporting Services


Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)

Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Reporting Services fournit une extension de remise du courrier électronique qui permet aux utilisateurs de s'abonner aux rapports remis par la suite aux boîtes aux lettres électroniques. L'extension de remise du courrier électronique de Report Server doit être configurée avant de pouvoir être utilisée. Pour configurer un serveur de rapports pour la remise du courrier électronique, procédez comme suit :

  • Passerelle ou serveur de protocole SMTP (Simple Mail Transfer Protocol).

  • Compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP. Selon les stratégies de sécurité en vigueur dans votre organisation, vous devrez peut-être demander une autorisation préalable pour envoyer du courrier électronique à partir d'un serveur SMTP d'entreprise. Pour plus d'informations, contactez votre administrateur système ou réseau.

  • Le service Report Server doit avoir les autorisations Send As sur le serveur SMTP.

Pour configurer la messagerie électronique du serveur de rapports, vous pouvez utiliser l'outil de configuration de Reporting Services ou modifier les fichiers de configuration. L'outil de configuration de Reporting Services fournit les paramètres minimaux requis par le serveur de rapports. Si vous souhaitez utiliser le service SMTP local ou spécifier des paramètres avancés, modifiez plutôt les fichiers de configuration.

Si vous souhaitez évaluer la fonctionnalité de messagerie électronique du serveur de rapports ou résoudre un problème d'abonnement ou de remise, vous pouvez configurer la messagerie électronique du serveur de rapports de façon à utiliser un service SMTP local qui remet les rapports à un dossier local. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique.

Si vous ne configurez pas un serveur de rapports pour une remise par messagerie ou si vous n'avez pas accès à un serveur SMTP, vous pouvez utiliser l'extension de remise par partage de fichiers pour distribuer les rapports dans des dossiers partagés accessibles par le biais des connexions réseau.

Pour configurer la messagerie électronique du serveur de rapports à l'aide de l'outil de configuration de Reporting Services

  1. Vérifiez que le service Report Server Windows a des autorisations Send As sur le serveur SMTP.

  2. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports.

  3. Sur la page Paramètres de messagerie, entrez le nom du serveur SMTP. Il peut s'agir d'une adresse IP, du nom UNC d'un ordinateur sur l'intranet de votre entreprise ou d'un nom de domaine complet.

  4. Dans Adresse de l'expéditeur, tapez le nom d'un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  5. Cliquez sur Appliquer.

Pour configurer un service SMTP distant pour le serveur de rapports

  1. Vérifiez que le service Report Server Windows a des autorisations Send As sur le serveur SMTP.

  2. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  3. Vérifiez que <UrlRoot> est paramétré à l'adresse URL du serveur de rapports. Cette valeur est définie lorsque vous configurez le serveur de rapports et elle devrait normalement être déjà définie. Si elle n'est pas définie, tapez l'adresse URL du serveur de rapports.

  4. Dans la section Remise, recherchez <ReportServerEmail>.

  5. Dans <SMTPServer>, tapez le nom du serveur SMTP. Il peut s'agir d'une adresse IP, du nom UNC d'un ordinateur sur l'intranet de votre entreprise ou d'un nom de domaine complet.

  6. Vérifiez que <SendUsing> a la valeur 2. S'il a une autre valeur, le serveur de rapports n'est pas configuré pour utiliser un service SMTP distant.

  7. Dans <From>, tapez le nom d'un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  8. Enregistrez le fichier.

    Le serveur de rapports utilise automatiquement les nouveaux paramètres ; il n'est pas nécessaire de redémarrer le service. Vous pouvez spécifier des paramètres SMTP supplémentaires pour configurer comment le serveur SMTP est utilisé pour la remise par messagerie du serveur de rapports. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique et Fichier de configuration RSReportServer.

Pour configurer un service SMTP local pour le serveur de rapports

  1. Dans le Panneau de configuration, cliquez sur Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows pour démarrer l'Assistant Composants Windows.

  3. Sélectionnez Serveur d'applications et cliquez sur Détails.

  4. Sélectionnez Services Internet (IIS), puis cliquez sur Détails.

  5. Activez la case à cocher Service SMTP, puis cliquez sur OK.

  6. Dans l'Assistant Composants Windows, cliquez sur Suivant. Cliquez sur Terminer.

  7. Vérifiez que le service s'exécute dans la console Services.

  8. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  9. Vérifiez que <UrlRoot> est paramétré à l'adresse URL du serveur de rapports. Cette valeur est définie lorsque vous configurez le serveur de rapports et elle devrait normalement être déjà définie. Si elle n'est pas définie, tapez l'adresse URL du serveur de rapports.

  10. Dans la section Remise, recherchez <ReportServerEmail>.

  11. Dans <SMTPServer>, effacez les valeurs pour ce paramètre, mais ne supprimez pas les balises.

  12. Affectez la valeur 1 à <SendUsing>. S'il a une autre valeur, le serveur de rapports n'est pas configuré pour utiliser un service SMTP local.

  13. Définissez <SMTPServerPickupDirectory> sur un dossier de lecteur local.

  14. Définissez <From> sur un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  15. Enregistrez le fichier.

Voir aussi

Concepts

Configuration d'un Report Server pour la remise du courrier électronique

Autres ressources

Procédure : définir l'extension de remise par défaut du Gestionnaire de rapports
Remise par partage de fichiers dans Reporting Services
Remise par courrier électronique dans Reporting Services
Outil de configuration de Reporting Services
Abonnement et remise (Reporting Services)


Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008

Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008 |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Le déploiement de Reporting Services sur Windows Vista et de Windows Server 2008 nécessite des étapes de configuration supplémentaires si vous souhaitez administrer une instance de serveur de rapports localement. Windows Vista et Windows Server 2008 restreignent tous deux l'emploi excessif d'autorisations élevées en supprimant les autorisations d'administrateur lors de l'accès aux applications. Comme le système d'exploitation supprime les autorisations, les membres du groupe Administrateurs local exécutent la plupart des applications comme s'ils utilisaient le compte Utilisateur standard.

Même si cette solution améliore la sécurité globale de votre système, elle vous empêche d'utiliser les attributions de rôle prédéfinies et intégrées que Reporting Services crée pour les administrateurs locaux. Toutefois, avec une configuration supplémentaire de votre part, vous pouvez gérer efficacement le contenu du serveur de rapports et les opérations utilisant les autorisations d'utilisateur standard en procédant comme suit :

  • Ajoutez les URL Reporting Services aux sites approuvés. Par défaut, Internet Explorer 7.0 sur Windows Vista et Windows Server 2008 s'exécute en mode protégé, fonctionnalité qui empêche les demandes du navigateur d'atteindre les processus globaux qui s'exécutent sur le même ordinateur. Vous pouvez désactiver le mode protégé pour les applications du serveur de rapports en les ajoutant comme Sites de confiance.

  • Créez les attributions de rôle qui vous accordent en tant qu'administrateur du serveur de rapports l'autorisation de gérer le contenu et les opérations sans devoir utiliser la fonctionnalité Exécuter en tant qu'administrateur sur Internet Explorer. En créant les attributions de rôle pour votre compte d'utilisateur Windows, vous accédez à un serveur de rapports avec les autorisations Gestionnaire de contenu et Administrateur système via les attributions de rôle explicites qui remplacent les attributions de rôle prédéfinies et intégrées que Reporting Services crée pour les administrateurs locaux.

Cette rubrique explique comment configurer le serveur de rapports pour l'administration locale à l'issue de l'installation et de la configuration des composants du serveur de rapports. Si vous n'avez pas encore installé ou configuré le serveur de rapports, consultez Procédure : installer SQL Server 2008 (programme d'installation) et Rubriques d'aide à la configuration de Reporting Services. Pour plus d'informations sur les fonctionnalités du Contrôle de compte d'utilisateur (UAC) et sur la façon de se connecter au moteur de base de données avec les autorisations d'administrateur, consultez Procédure : Se connecter à SQL Server depuis Windows Vista.

Remarque :
Si vous déployez Reporting Services sur Windows Vista ou Windows Server 2008, veillez bien à ouvrir le port 80 dans le Pare-feu Windows pour autoriser l'accès au serveur de rapports. Pour obtenir des instructions, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

Pour configurer l'administration locale d'un serveur de rapports sur Windows Vista et Windows Server 2008

  1. Ouvrez une fenêtre du navigateur avec les autorisations Exécuter en tant qu'administrateur. Dans le menu Démarrer, cliquez sur Tous les programmes, cliquez avec le bouton droit sur Internet Explorer et sélectionnez Exécuter en tant qu'administrateur.

  2. Cliquez sur Autoriser pour continuer.

  3. Dans l'adresse URL, entrez l'URL du Gestionnaire de rapports. Pour obtenir des instructions, consultez Procédure : démarrer le Gestionnaire de rapports.

  4. Cliquez sur Outils.

  5. Cliquez sur Options Internet.

  6. Cliquez sur Sécurité.

  7. Cliquez sur Sites de confiance.

  8. Cliquez sur Sites.

  9. Ajoutez http://<nom_serveur>.

  10. Désactivez la case à cocher Nécessite la certification du serveur (https:) pour tous les sites dans cette zone si vous n'utilisez pas HTTPS pour le site par défaut.

  11. Cliquez sur Ajouter.

  12. Cliquez sur OK.

  13. Dans le Gestionnaire de rapports, sur la page d'accueil, cliquez sur Propriétés.

  14. Cliquez sur Nouvelle attribution de rôle.

  15. Tapez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

  16. Sélectionnez Gestionnaire de contenu.

  17. Cliquez sur OK.

  18. Cliquez sur Paramètres du site dans l'angle supérieur de la page d'accueil.

  19. Cliquez sur Configurer la sécurité au niveau du site.

  20. Cliquez sur Nouvelle attribution de rôle.

  21. Tapez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

  22. Sélectionnez Administrateur système.

  23. Cliquez sur OK.

  24. Fermez le Gestionnaire de rapports.

  25. Ouvrez à nouveau le Gestionnaire de rapports dans Internet Explorer, sans utiliser Exécuter en tant qu'administrateur.

Utilisation de Business Intelligence Development Studio sur Windows Vista et Windows Server 2008

Si vous avez installé Business Intelligence Development Studio sur Windows Vista ou Windows Server 2008, vous rencontrerez des problèmes de compatibilité avec l'environnement Visual Studio lors de l'utilisation des outils de conception. Si vous souhaitez ouvrir une solution ou un projet existant, ou publiez des éléments du Concepteur de rapports ou du Générateur de modèles sur un serveur de rapports, vous devez ouvrir Business Intelligence Development Studio avec les autorisations élevées :

  1. Dans le menu Démarrer, cliquez sur Tous les programmes, sur SQL Server 2008, cliquez avec le bouton droit sur Business Intelligence Development Studio, puis cliquez sur Exécuter en tant qu'administrateur.

  2. Cliquez sur Continuer.

  3. Cliquez sur Exécuter le programme.

Vous devez maintenant être en mesure de déployer les rapports et autres éléments sur un serveur de rapports. Si vous n'avez pas les autorisations suffisantes, vous rencontrerez des erreurs telles que celles-ci :

  • Accès refusé lorsque vous essayez d'ouvrir un projet existant.

  • Échec de connexion lorsque vous configurez une connexion de la source de données à une source de données partagée.

  • Lors de l'utilisation de l'Assistant Serveur de rapports pour créer un rapport, vous obtenez une erreur d'échec de connexion lorsque l'Assistant tente de se connecter à la source de données externe qui fournit les données au rapport.

SQL Server Les utilisateurs Management Studio doivent utiliser les autorisations Exécuter en tant qu'administrateur pour créer les connexions des utilisateurs qui administrent les bases de données sur le serveur. Pour plus d'informations sur les conditions requises pour les autorisations élevées de Management Studio, consultez Procédure : Se connecter à SQL Server depuis Windows Vista.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008

Concepts

Rubriques d'aide à la configuration de Reporting Services


Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services)

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

La fonctionnalité Reporting Services prend en charge un modèle de déploiement avec montée en puissance parallèle qui vous permet d'exécuter plusieurs instances de serveur de rapports partageant une base de données de serveur de rapports unique.

Pour créer un déploiement avec montée en puissance parallèle, vous devez utiliser le programme d'installation et l'outil de configuration de Reporting Services.

  • Utilisez le programme d'installation pour installer chaque instance de serveur de rapports qui sera jointe au déploiement avec montée en puissance parallèle.

  • Utilisez l'outil de configuration de Reporting Services pour connecter chaque serveur de rapports à la base de données partagée. Vous ne pouvez connecter et configurer qu'un seul serveur de rapports à la fois.

  • Utilisez l'outil de configuration de Reporting Services pour procéder au déploiement avec montée en puissance parallèle en joignant de nouvelles instances de serveur de rapports à la première instance déjà connectée à la base de données de serveur de rapports.

Pour éviter des erreurs de compatibilité de base de données lorsque vous connectez les instances du serveur à la base de données partagée, assurez-vous que toutes les instances soient de la même version. Par exemple, si vous créez la base de données du serveur de rapports à l'aide d'une instance du serveur de rapports SQL Server 2008, l'édition de toutes les autres instances du même déploiement doit également être SQL Server 2008. Pour plus d'informations, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

Les instructions suivantes expliquent comment configurer un déploiement avec montée en puissance parallèle de serveur de rapports à deux nœuds. Répétez les étapes décrites dans cette rubrique pour ajouter des nœuds de serveur de rapports supplémentaires au déploiement.

Si vous prévoyez d'héberger le déploiement avec montée en puissance parallèle sur un cluster à charge réseau équilibrée, vous devez configurer le cluster avant de configurer le déploiement avec montée en puissance parallèle. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau.

Pour installer une instance de SQL Server en vue d'héberger les bases de données du serveur de rapports

  1. Installez une instance de SQL Server sur un ordinateur qui hébergera les bases de données du serveur de rapports. Au minimum, installez Moteur de base de données SQL Server et Reporting Services.

  2. Si nécessaire, activez le serveur de rapports pour les connexions distantes. Certaines versions de SQL Server n'autorisent pas les connexions TCP/IP et Canaux nommés distantes par défaut. Pour déterminer si les connexions distantes sont autorisées ou non, utilisez l'outil Gestionnaire de configuration SQL Server et vérifiez les paramètres de configuration réseau de l'instance cible. Si l'instance distante est également une instance nommée, vérifiez que le service SQL Server Browser est activé et en cours d'exécution sur le serveur cible. SQL Server Browser fournit le numéro de port utilisé pour se connecter à l'instance nommée.

Pour installer la première instance du serveur de rapports

  1. Installez la première instance du serveur de rapports faisant partie du déploiement. Lorsque vous installez Reporting Services, choisissez l'option Installer mais ne pas configurer le serveur dans la page Options d'installation du serveur de rapports.

  2. Démarrez l'outil de configuration de Reporting Services.

  3. Configurez l'URL de service Web Report Server, l'URL du Gestionnaire de rapports et la base de données du serveur de rapports. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports.

  4. Vérifiez le fonctionnement du serveur de rapports. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services.

Pour installer et configurer la deuxième instance du serveur de rapports

  1. Exécutez le programme d'installation pour installer une deuxième instance de Reporting Services sur un ordinateur différent ou comme instance nommée sur le même ordinateur. Lorsque vous installez Reporting Services, choisissez l'option Installer mais ne pas configurer le serveur dans la page Options d'installation du serveur de rapports.

  2. Démarrez l'outil de configuration de Reporting Services et connectez-vous à la nouvelle instance que vous venez d'installer.

  3. Connectez le serveur de rapports à la même base de données que celle utilisée pour la première instance de serveur de rapports.

    1. Cliquez sur Base de données pour ouvrir la page Base de données.

    2. Cliquez sur Modifier la base de données.

    3. Cliquez sur Choisir une base de données de serveur de rapports existante.

    4. Tapez le nom de serveur de l'instance du Moteur de base de données SQL Server SQL Server qui héberge la base de données du serveur de rapports que vous voulez utiliser. Vous devez spécifier le serveur auquel vous vous êtes connecté lors de la procédure précédente.

    5. Cliquez sur Tester la connexion, puis cliquez sur Suivant.

    6. Dans la Base de données du serveur de rapports, sélectionnez la base de données que vous avez créée pour le premier serveur de rapports, puis cliquez sur Suivant. Le nom par défaut est ReportServer. Ne sélectionnez pas ReportServerTempDB ; il est utilisé uniquement pour stocker les données temporaires lors du traitement des rapports. Si la liste de bases de données est vide, répétez les quatre étapes précédentes pour établir une connexion au serveur.

    7. Dans la page Informations d'identification, sélectionnez le type de compte et les informations d'identification que le serveur de rapports utilisera pour se connecter à la base de données du serveur de rapports. Vous pouvez utiliser les mêmes informations d'identification que la première instance du serveur de rapports, ou des informations d'identification différentes. Cliquez sur Suivant.

    8. Cliquez sur Résumé et cliquez sur Terminer.

  4. Configurez l'URL du service Web Report Server. Ne testez pas encore l'URL. Elle ne sera pas résolue tant que le serveur de rapports est joint au déploiement avec montée en puissance parallèle.

  5. Configurez l'URL du Gestionnaire de rapports. Ne testez pas encore l'URL ou essayez de vérifier le déploiement. Le serveur de rapports ne sera pas disponible tant que le serveur de rapports n'est pas joint au déploiement avec montée en puissance parallèle.

Pour joindre la deuxième instance de serveur de rapports au déploiement avec montée en puissance parallèle

  1. Ouvrez l'outil de configuration de Reporting Services, puis reconnectez-vous à la première instance du serveur de rapports. Le premier serveur de rapports étant déjà initialisé pour les opérations de chiffrement réversible ; il est utilisé pour joindre de nouvelles instances du serveur de rapports au déploiement avec montée en puissance parallèle.

  2. Cliquez sur Déploiement avec montée en puissance parallèle pour ouvrir la page Déploiement avec montée en puissance parallèle. Vous devez voir deux entrées, l'une pour chaque instance de serveur de rapports connectée à la base de données du serveur de rapports. La première instance de serveur de rapports doit être jointe. Le deuxième serveur de rapports doit être en attente de rattachement. Si vous ne voyez pas de telles entrées pour votre déploiement, vérifiez que vous êtes connecté au premier serveur de rapports qui est déjà configuré et initialisé pour utiliser la base de données du serveur de rapports.

    Capture d'écran partielle de la page de déploiement avec montée en puissance parallèle

  3. Dans la page Déploiement avec montée en puissance parallèle, sélectionnez l'instance de serveur de rapports qui attend pour joindre le déploiement et cliquez sur Ajouter le serveur.

  4. Vous devez maintenant être en mesure de vérifier que les deux instances de serveur de rapports sont opérationnelles. Pour vérifier la deuxième instance, vous pouvez utiliser l'outil de configuration de Reporting Services pour vous connecter au serveur de rapports et cliquer sur l'URL du service Web ou l'URL du Gestionnaire de rapports.

Si vous envisagez d'exécuter les serveurs de rapports dans un cluster de serveurs avec équilibrage de charge, une configuration supplémentaire est requise. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)
Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)
Procédure : démarrer la configuration de Reporting Services

Concepts

Configuration des URL de Report Server
Configuration d'une connexion de base de données de serveur de rapports
Ajout et suppression de clés de chiffrement pour un déploiement évolutif
Rubriques d'aide à la configuration de Reporting Services

Autres ressources

Planification d'un déploiement avec montée en puissance parallèle


Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau

Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez la montée en puissance parallèle du serveur de rapports en vue de son exécution sur un cluster avec équilibrage de la charge réseau (NLB, Network Load Balancing), vous devez effectuer les opérations suivantes :

  • S'assurer que le cluster avec équilibrage de la charge réseau est accessible via un nom de serveur virtuel mappé avec l'adresse IP du serveur virtuel. Un nom de serveur virtuel est nécessaire pour configurer un point d'entrée unique au cluster avec équilibrage de la charge réseau. Lorsque vous configurerez une URL pour chaque instance du serveur de rapports, vous spécifierez le nom du serveur virtuel en tant qu'hôte.

  • Configurez la validation de l'état d'affichage pour prendre en charge la consultation des rapports interactifs. Les rapports interactifs sont en général restitués à plusieurs reprises au cours d'une session mono-utilisateur afin de permettre la visualisation de données nouvelles ou différentes en réponse aux actions de l'utilisateur. Configurer la validation de l'état d'affichage assure la continuité au cours de la session utilisateur quel que soit le serveur de rapports qui répond à la demande réelle.

Reporting Services ne fournit pas de fonctionnalités pour l'équilibrage de charge d'un déploiement avec montée en puissance parallèle ou pour définir un point unique d'accès via une URL partagée. Vous devez implémenter une solution logicielle ou matérielle distincte pour la solution de cluster avec équilibrage de la charge réseau afin de prendre en charge un déploiement avec montée en puissance parallèle de Reporting Services.

Vous pouvez installer Reporting Services sur les nœuds qui font déjà partie d'un cluster avec équilibrage de la charge réseau ou configurer d'abord un déploiement avec montée en puissance parallèle, puis installer le logiciel de cluster.

Étapes pour le déploiement du serveur de rapports sur un cluster avec équilibrage de la charge réseau

Appuyez-vous sur les indications suivantes pour installer et configurer votre déploiement :

Étape Description Informations complémentaires

1

Avant d'installer Reporting Services sur les nœuds de serveurs d'un cluster avec équilibrage de la charge réseau, vérifiez les spécifications du déploiement avec montée en puissance parallèle.

Planification d'un déploiement avec montée en puissance parallèle

2

Configurez le cluster avec équilibrage de la charge réseau et vérifiez son bon fonctionnement.

Veillez à mapper un nom d'en-tête de l'hôte à l'adresse IP du serveur virtuel du cluster avec équilibrage de la charge réseau. Le nom d'en-tête de l'hôte est utilisé dans l'URL du serveur de rapports et présente l'avantage d'être plus facile à retenir et à taper qu'une adresse IP.

Pour plus d'informations, consultez la documentation Windows Server correspondant à la version du système d'exploitation Windows que vous exécutez.

4

Installer Reporting Services en mode fichiers uniquement sur les nœuds qui font déjà partie d'un cluster avec équilibrage de la charge réseau et configurer les instances du serveur de rapports pour un déploiement avec montée en puissance parallèle.

La montée en puissance parallèle que vous configurez ne répond pas aux demandes adressées à l'IP du serveur virtuel. La configuration de la montée en puissance parallèle pour l'utilisation de l'IP du serveur virtuel intervient à un stade ultérieur, après la configuration de la validation de l'état d'affichage.

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services)

5

Configurez la validation de l'état d'affichage.

Pour de meilleurs résultats, effectuez cette étape après avoir configuré le déploiement avec montée en puissance parallèle et avant de configurer les instances du serveur de rapports pour l'utilisation de l'IP du serveur virtuel. En configurant d'abord la validation de l'état d'affichage, vous pouvez éviter les exceptions sur l'échec de la validation de l'état quand les utilisateurs tentent d'accéder aux rapports interactifs.

Comment configurer la validation de l'état d'affichage dans cette rubrique.

6

Configurer HostName et UrlRoot pour l'utilisation de l'IP du serveur virtuel du cluster avec équilibrage de la charge réseau.

Comment configurer HostName et UrlRoot dans cette rubrique.

7

Vérifiez que les serveurs sont accessibles via le nom d'hôte que vous avez spécifié.

Vérifiez l'accès au serveur de rapports dans cette rubrique.

Comment configurer la validation de l'état d'affichage

Pour exécuter un déploiement avec montée en puissance parallèle sur un cluster avec équilibrage de la charge réseau, vous devez configurer la validation de l'état d'affichage afin que les utilisateurs puissent consulter les rapports HTML interactifs. Vous devez accomplir ces tâches pour le serveur de rapports et pour le Gestionnaire de rapports.

La validation de l'état d'affichage est contrôlée par ASP.NET. Par défaut, la validation de l'état d'affichage est activée et utilise l'identité du service Web pour effectuer la validation. Toutefois, dans un scénario de cluster avec équilibrage de la charge réseau, il existe plusieurs instances de services et plusieurs identités de services Web qui s'exécutent sur différents ordinateurs. L'identité de service étant différente pour chaque nœud, vous ne pouvez pas vous appuyer sur une seule identité de processus pour effectuer la validation.

Pour contourner ce problème, vous pouvez générer une clé de validation arbitraire pour prendre en charge la validation de l'état d'affichage, puis configurer manuellement chaque nœud de serveur de rapports de manière à ce qu'il utilise la même clé. Vous pouvez utiliser n'importe quelle séquence hexadécimale générée de façon aléatoire. L'algorithme de validation (tel que SHA1) détermine la longueur que doit avoir la séquence hexadécimale.

  1. Générez une clé de validation et clé de déchiffrement en utilisant les fonctionnalités de création automatique fourni par le .NET Framework. À la fin, vous devez avoir une entrée <machineKey> unique que vous pouvez coller dans le fichier Web.config pour chaque instance du Gestionnaire de rapports dans le déploiement avec montée en puissance parallèle.

    L'exemple suivant illustre la valeur que vous devez obtenir. Ne copiez pas cet exemple dans vos fichiers de configuration ; les valeurs de clé ne sont pas valides.

    Copier le code
    <machineKey validationKey="123455555" decryptionKey="678999999" validation="SHA1" decryption="AES"/>
  2. Ouvrez le fichier Web.config du Gestionnaire de rapports, puis, dans la section <system.web>, collez l'élément <machineKey> que vous avez généré. Par défaut, le fichier Web.config du Gestionnaire de rapports se trouve dans \Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportManager\Web.config.

  3. Enregistrez le fichier.

  4. Répétez l'étape précédente pour chaque serveur de rapports impliqué dans le déploiement avec montée en puissance parallèle.

  5. Vérifiez que tous les fichiers Web.Config des dossiers \Reporting Services\ReportManager contiennent des éléments <machineKey> identiques dans la section <system.web>.

Comment configurer HostName et UrlRoot

Pour configurer un déploiement avec montée en puissance parallèle du serveur de rapports sur un cluster avec équilibrage de la charge réseau, vous devez définir un seul nom de serveur virtuel qui fournit un point d'accès unique au cluster de serveurs. Puis, inscrivez le nom du serveur virtuel auprès du serveur de noms de domaine de votre environnement.

Après avoir défini le nom du serveur virtuel, vous pouvez configurer les propriétés HostName et UrlRoot du fichier RSReportServer.config de façon à inclure le nom du serveur virtuel dans l'URL du serveur de rapports.

Configurez la propriété HostName lorsque vous utilisez des réservations d'URL génériques dans votre environnement de création de rapports. Lorsque vous spécifiez la propriété HostName comme nom du serveur virtuel du serveur avec équilibrage de la charge réseau (NLB), le trafic réseau de l'environnement de création de rapports est dirigé vers le serveur NLB. Le serveur NLB distribue ensuite les demandes parmi les nœuds du serveur de rapports.

En outre, configurez la propriété UrlRoot afin que les liens du rapport fonctionnent dans les rapports exportés vers des rapports statiques, tels que ceux au format Excel ou PDF, ou dans les rapports créés par abonnements, tels que les abonnements de messagerie électronique.

Si vous intégrez Reporting Services à Windows SharePoint Services 3.0 ou Office SharePoint Server 2007, ou que vous hébergez vos rapports dans une application Web personnalisée, il se peut que vous ayez uniquement besoin de configurer la propriété UrlRoot. Dans ce cas, configurez la propriété UrlRoot comme URL du site SharePoint ou de l'application Web. Le trafic réseau de l'environnement de création de rapports est alors dirigé vers l'application qui gère les rapports, et non vers le serveur de rapports ou le cluster avec équilibrage de la charge réseau (NLB, Network Load Balancing).

Ne modifiez pas ReportServerUrl. Si vous modifiez cette URL, un aller-retour supplémentaire au serveur virtuel sera nécessaire pour chaque demande interne à gérer. Pour plus d'informations, consultez URL des fichiers de configuration (Reporting Services). Pour plus d'informations sur la modification du fichier de configuration, consultez Procédure : modifier un fichier de configuration Reporting Services.

  1. Ouvrez RSReportServer.config dans un éditeur de texte.

  2. Recherchez la section <services>, et ajoutez les informations suivantes au fichier de configuration, en remplaçant la valeur HostName par le nom de serveur virtuel de votre serveur NLB :

    Copier le code
    <HostName>virtual_server</HostName>
  3. Recherchez UrlRoot. L'élément n'est pas spécifié dans le fichier de configuration, mais la valeur par défaut utilisée est une URL au format http:// ou https://<nom_ordinateur>/<serveur_rapports>, où <serveur_rapports> est le nom du répertoire virtuel du service Web Report Server.

  4. Tapez une valeur pour UrlRoot qui inclut le nom virtuel du cluster au format http:// ou https://<serveur_virtuel>/<reportserver>.

  5. Enregistrez le fichier.

  6. Répétez ces étapes dans chaque fichier RSReportServer.config de chaque serveur de rapports impliqué dans le déploiement par montée en puissance parallèle.

Vérifier l'accès au serveur de rapports

Vérifiez que vous pouvez accéder au déploiement avec montée en puissance parallèle via le nom du serveur virtuel (par exemple, https://MyVirtualServerName/reportserver et https://MyVirtualServerName/reports).

Vous pouvez vérifier quel nœud traite effectivement les rapports en examinant les fichiers journaux du serveur de rapports ou en vérifiant le journal d'exécution Reporting Services (la table du journal d'exécution contient une colonne InstanceName qui indique quelle instance a traité une demande particulière). Pour plus d'informations, consultez Fichiers journaux de Reporting Services.

Si vous ne pouvez pas vous connecter au serveur de rapports, vérifiez l'équilibrage de la charge réseau pour contrôler que les demandes sont envoyées au serveur de rapports et affichez le journal HTTP du serveur de rapports pour être certain que le serveur reçoit les demandes.

Dépannage des demandes ayant échoué

Si les demandes n'atteignent pas les instances du serveur de rapports, consultez le fichier RSReportServer.config pour vérifier que le nom du serveur virtuel est spécifié comme nom d'hôte pour les URL du serveur de rapports :

  1. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  2. Recherchez <HostName>, <ReportServerUrl> et <UrlRoot>, puis vérifiez le nom d'hôte pour chaque paramètre. Si la valeur n'est pas le nom d'hôte attendu, remplacez-le par le nom d'hôte approprié.

Si vous démarrez l'outil de configuration de Reporting Services après avoir effectué ces modifications, l'outil peut remplacer les paramètres <ReportServerUrl> par la valeur par défaut. Conservez toujours une copie de sauvegarde des fichiers de configuration au cas où vous auriez besoin de les remplacer par la version qui contient les paramètres à utiliser.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)
Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services)

Concepts

Rubriques d'aide à la configuration de Reporting Services

Autres ressources

Planification d'un déploiement avec montée en puissance parallèle
Fichier de configuration RSReportServer


Procédure : configurer un serveur de rapports pour l'administration à distance

Procédure : configurer un serveur de rapports pour l'administration à distance |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Dans Reporting Services, vous pouvez configurer des instances de serveur de rapports localement ou à distance. Pour configurer une instance de serveur de rapports à distance, vous pouvez faire appel à l'outil de configuration de Reporting Services ou bien écrire un code personnalisé qui utilise le fournisseur WMI (Windows Management Instrumentation) de Reporting Services. L'outil de configuration de Reporting Services offre une interface graphique avec le fournisseur WMI pour vous permettre de configurer un serveur de rapports sans avoir à écrire du code. Lorsque vous démarrez l'outil, vous pouvez spécifier un serveur distant auquel vous connecter.

Avant de pouvoir utiliser l'outil pour configurer un serveur de rapports distant, vous devez suivre les instructions de cette rubrique pour activer les ports du Pare-feu Windows, les connexions à distance et les demandes WMI distantes.

Une configuration appropriée vous aide à éviter l'erreur suivante :

The machine could not be found.

"The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)".

Configuration requise

Pour cela, vous devez ouvrir une session localement et être membre du groupe Administrateurs local. Vous ne pouvez pas modifier les paramètres du pare-feu Windows d'un ordinateur distant sur une connexion distante.

Si vous souhaitez activer l'administration à distance pour un utilisateur non-administrateur, vous devez accorder des autorisations d'activation à distance DCOM (Distributed Component Object Model) au compte. Les instructions de configuration du serveur pour un accès non-administrateur sont fournies dans cette rubrique.

Certaines organisations disposent de stratégies de groupe qui empêchent l'administration serveur à distance pour certains systèmes d'exploitation ou certains utilisateurs. Avant de commencer à modifier les paramètres du pare-feu, vérifiez auprès de votre administrateur réseau si des restrictions s'appliquent dans le cadre de l'administration à distance.

Pour plus d'informations, consultez Connecting Through Windows Firewall dans la documentation du kit de développement Platform SDK sur MSDN.

Tâches

Les tâches qui activent la configuration de serveur de rapports à distance incluent les éléments suivants :

  • Activer les ports du Pare-feu Windows afin d'autoriser les demandes sur les ports utilisés par le serveur de rapports et par l'instance du moteur de base de données SQL Server.

  • Autoriser les connexions distantes à l'instance du moteur de base de données qui héberge la base de données du serveur de rapports. Une connexion distante est nécessaire pour la configuration de la connexion à la base de données du serveur de rapports et la gestion des clés de chiffrement.

  • Activer les demandes WMI distantes pour franchir le Pare-feu Microsoft Windows.

  • Si vous configurez un serveur de rapports distant pour l'administration par un utilisateur non-administrateur, vous devez définir les autorisations DCOM pour activer l'accès WMI distant à un compte d'utilisateur Windows standard. Du fait que WMI utilise DCOM en tant que moyen de transport pour les appels distants, vous devez définir les autorisations DCOM afin que les utilisateurs non connectés en tant qu'administrateur local puissent configurer le serveur.

  • Si vous configurez un serveur de rapports distant pour l'administration par un utilisateur non-administrateur, vous devez également définir les autorisations WMI sur l'espace de noms WMI du serveur de rapports. Par défaut, tous les membres du groupe Administrateurs local ont accès à l'espace de noms WMI du serveur de rapports. Pour accorder un droit d'accès aux personnes qui ne sont pas administrateurs, vous devez définir des autorisations.

Les instructions relatives à l'exécution de ces tâches sont fournies dans cette rubrique.

Pour ouvrir les ports du Pare-feu Windows

  1. Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données.

  2. Procédure : configurer un pare-feu pour accéder à Report Server.

Pour configurer les connexions distantes à la base de données du serveur de rapports

  1. Cliquez sur Démarrer, pointez sur Programmes, sur Microsoft SQL Server 2008 et sur Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.

  2. Dans le volet gauche, développez Configuration du réseau SQL Server, puis cliquez sur Protocoles pour l'instance de SQL Server.

  3. Dans le volet d'informations, activez les protocoles TCP/IP et Canaux nommés, puis redémarrez le service SQL Server.

Pour activer l'administration à distance dans le pare-feu Windows

  1. Ouvrez une session en tant qu'administrateur local sur l'ordinateur où vous souhaitez activer l'administration à distance.

  2. Si le serveur de rapports s'exécute sur Windows Vista, cliquez avec le bouton droit sur Invite de commandes et sélectionnez Exécuter en tant qu'administrateur. Pour d'autres systèmes d'exploitation, ouvrez une fenêtre d'invite de commandes.

  3. Exécutez la commande suivante :

    Copier le code
    netsh.exe firewall set service type=REMOTEADMIN mode=ENABLE scope=ALL

    Vous pouvez spécifier différentes options pour l'étendue. Pour plus d'informations, consultez la documentation produit du pare-feu Windows.

  4. Vérifiez que l'administration à distance est activée. Vous pouvez exécuter la commande suivante pour afficher l'état :

    Copier le code
    netsh.exe firewall show state

  5. Redémarrez l'ordinateur.

Pour définir les autorisations DCOM en vue d'activer l'accès WMI à distance pour les non-administrateurs

  1. Dans le menu Démarrer, pointez sur Outils d'administration, puis cliquez sur Services de composants.

    Pour Windows Vista, dans le menu Démarrer, cliquez sur Tous les programmes, cliquez sur Exécuter, puis entrez mmc comexp.msc.

  2. Ouvrez le dossier Services de composants.

  3. Ouvrez le dossier Ordinateurs.

  4. Sélectionnez Poste de travail.

  5. Dans le menu Action, sélectionnez Propriétés.

  6. Cliquez sur Sécurité COM.

  7. Sous Autorisations d'exécution et d'activation, cliquez sur Modifier les limites.

  8. Si votre nom n'apparaît pas dans la boîte de dialogue Autorisation d'exécution, cliquez sur Ajouter.

  9. Tapez le nom de votre compte d'utilisateur, puis cliquez sur OK.

  10. Dans la zone Autorisation pour <Utilisateur ou groupe>, dans la colonne Autoriser, sélectionnez Exécution à distance et Activation à distance, puis cliquez sur OK.

Pour définir les autorisations sur l'espace de noms WMI du rapport de serveurs pour les non-administrateurs

  1. Dans le menu Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.

  2. Ouvrez le dossier Services et applications.

  3. Cliquez avec le bouton droit sur Contrôle WMI, puis sélectionnez Propriétés.

  4. Cliquez sur Sécurité.

  5. Ouvrez le dossier Root.

  6. Ouvrez le dossier Microsoft.

  7. Ouvrez le dossier SQLServer.

  8. Ouvrez le dossier ReportServer.

  9. Ouvrez le dossier de l'instance. Si vous avez installé l'instance par défaut, le dossier est MSSQLSERVER.

  10. Ouvrez le dossier v10.

  11. Sélectionnez le dossier Admin, puis cliquez sur Sécurité.

  12. Cliquez sur Ajouter, puis tapez le compte d'utilisateur que vous utiliserez pour gérer le serveur.

  13. Dans la colonne Autoriser, sélectionnez Activer le compte, Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Autres ressources

Outil de configuration de Reporting Services
Reporting Services WMI Provider
Configuration d'une installation de serveur de rapports


Procédure : configurer un compte de service pour Reporting Services

Procédure : configurer un compte de service pour Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Dans une installation Reporting Services, le service Web Report Server, le Gestionnaire de rapports et l'application de traitement en arrière-plan s'exécutent au sein d'un même service. Le compte sous lequel le service s'exécute est défini pendant l'installation lorsque vous spécifiez le compte dans la page Identité du service, mais vous pouvez utiliser l'outil de configuration de Reporting Services si vous souhaitez utiliser un autre compte ou mettre à jour le mot de passe.

Si vous disposez d'un serveur de rapports configuré pour utiliser le mode intégré SharePoint et que vous modifiez le compte de service à l'aide de l'outil de configuration Reporting Services, vous devez également ouvrir l'Administration centrale de SharePoint et vous servir de la page Accorder l'accès à la base de données de Reporting Services pour réappliquer les paramètres du serveur de rapports et de l'instance. Cette étape accordera aux bases de données SharePoint le nouvel accès au compte de service, requis pour intégrer Reporting Services à Windows SharePoint Services (WSS) ou Microsoft Office SharePoint Server (MOSS). Pour plus d'informations sur la manière d'accorder l'accès à la base de données dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Utilisez toujours l'outil de configuration de Reporting Services pour mettre à jour le compte de service afin que les autres paramètres qui dépendent de l'identité de service puissent être mis à jour simultanément.

Pour configurer le compte de service Report Server

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous au serveur de rapports.

  2. Dans la page Compte de service, sélectionnez l'option qui décrit le type de compte vous souhaitez utiliser. Pour obtenir des recommandations sur le type de compte à spécifier, consultez Configuration du compte de service Report Server.

  3. Si vous avez sélectionné un compte d'utilisateur Windows, spécifiez le nouveau compte et le nouveau mot de passe. La longueur du nom du compte ne peut pas excéder 20 caractères.

    Si le serveur de rapports est déployé dans un réseau qui prend en charge l'authentification Kerberos, vous devez inscrire le nom principal de service (SPN) du serveur de rapports avec le compte d'utilisateur de domaine que vous venez de spécifier. Pour plus d'informations, consultez Procédure : inscrire un nom principal de service (SPN) pour Report Server.

  4. Cliquez sur Appliquer.

  5. Lorsque vous êtes invité à sauvegarder la clé symétrique, tapez un nom de fichier et un emplacement pour la sauvegarde de la clé symétrique, entrez un mot de passe pour verrouiller et déverrouiller le fichier, puis cliquez sur OK.

  6. Si le serveur de rapports utilise le compte de service pour se connecter à la base de données du serveur de rapports, les informations de connexion seront mises à jour pour utiliser le nouveau compte ou mot de passe. La mise à jour des informations de connexion nécessite que vous vous connectiez à la base de données. Si la boîte de dialogue Connexion de la base de données SQL Server apparaît, entrez les informations d'identification habilitées à se connecter à la base de données, puis cliquez sur OK.

  7. Lorsque vous êtes invité à restaurer la clé symétrique, tapez le mot de passe spécifié à l'étape 5, puis cliquez sur OK.

  8. Examinez les messages d'état dans le volet Résultats pour vérifier que toutes les tâches se sont terminées avec succès.

Dépannage des erreurs de mise à jour de l'identité du service

La modification de l'identité du service initialise une série d'événements qui incluent le redémarrage du service, la mise à jour de la clé de chiffrement protégée par mot de passe, la mise à jour des réservations d'URL et la mise à jour des informations de connexion à la base de données du serveur de rapports si vous utilisez le compte de service pour vous connecter à la base de données du serveur de rapports. Vous pouvez surveiller l'état de ces événements en consultant les notifications dans le volet Résultats en bas de page. Si des erreurs se produisent pendant ce processus, vous pouvez essayer de les résoudre à l'aide des techniques suivantes :

  • Si la clé symétrique ne peut pas être restaurée, vous pouvez essayer de la restaurer manuellement en utilisant Restaurer dans la page Clés de chiffrement. Si cette technique ne fonctionne pas, envisagez de supprimer le contenu chiffré. Vous devrez recréer les abonnements et les informations de connexion à la source de données, mais le reste du contenu demeurera disponible. Pour plus d'informations, consultez Sauvegarde et restauration des clés de chiffrement.

  • Si le service ne démarre pas, redémarrez-le manuellement en utilisant l'application console Services dans les Outils d'administrateur.

  • Les erreurs de réservation d'URL peuvent se produire lorsque vous mettez à jour le compte de service. Chaque réservation d'URL comporte un descripteur de sécurité incluant une liste de contrôle d'accès discrétionnaire (DACL) qui accorde l'autorisation au compte de service d'accepter les demandes sur l'URL. Lorsque vous mettez à jour le compte, l'URL doit être recréée pour mettre à jour la liste DACL avec les nouvelles informations de compte. Si la réservation d'URL ne peut pas être recréée et que vous savez que le compte est valide, essayez de redémarrer l'ordinateur. Si l'erreur persiste, essayez d'utiliser un autre compte.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Référence

Compte de service (configuration de Reporting Services)

Concepts

Configuration du compte de service Report Server
Configuration d'une connexion de base de données de serveur de rapports
Configuration et gestion des clés de chiffrement

Autres ressources

Architecture du service (Reporting Services)


Procédure : configurer une URL (configuration de Reporting Services)

Procédure : configurer une URL (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Avant de pouvoir utiliser le Gestionnaire de rapports ou le service Web Report Server, vous devez configurer au moins une URL pour chaque application. La configuration des URL est obligatoire si vous avez installé Reporting Services en mode « fichiers uniquement »(autrement dit, en sélectionnant l'option Installer mais ne pas configurer le serveur sur la page Options d'installation du serveur de rapports dans l'Assistant Installation). Si vous avez installé Reporting Services dans la configuration par défaut, les URL sont déjà configurées pour chaque application. Si vous disposez d'un serveur de rapports configuré pour s'exécuter en mode intégré SharePoint et que vous mettez à jour l'URL du service Web Report Server à l'aide de l'outil de configuration Reporting Services, vous devez également mettre à jour l'URL dans l'Administration centrale de SharePoint.

Utilisez l'outil de configuration de Reporting Services pour configurer les URL. Toutes les parties de l'URL sont définies dans cet outil. Contrairement aux versions précédentes, les sites Web IIS (Internet Information Services) ne fournissent plus l'accès aux applications Reporting Services dans SQL Server 2008.

Reporting Services fournit les valeurs par défaut qui fonctionnent bien dans la plupart des scénarios de déploiement, y compris les déploiements côte à côte avec les autres applications et services Web. Les URL par défaut incorporent les noms d'instance, réduisant le risque de conflits d'URL si vous exécutez plusieurs instances de serveur de rapports sur le même ordinateur.

Cette rubrique fournit des instructions relatives aux tâches suivantes :

  • Créer une URL pour le service Web Report Server.

  • Créer une URL pour le Gestionnaire de rapports.

  • Définir les propriétés URL avancées pour définir des URL supplémentaires.

Pour plus d'informations sur la façon dont les URL sont stockées et maintenues ou sur les problèmes d'interopérabilité, consultez À propos des réservations et de l'inscription d'URL (Reporting Services) et Déploiement côte à côte de Reporting Services et des services IIS (Internet Information Services). Pour obtenir des exemples d'URL souvent utilisées dans une installation Reporting Services, consultez Exemples d'URL dans cette rubrique.

Configuration requise

Avant de créer ou de modifier une URL, souvenez-vous des points suivants :

  • Vous devez être membre du groupe Administrateurs local sur le serveur de rapports.

  • Si IIS 6.0 ou 7.0 sont installés sur le même ordinateur, vérifiez les noms des répertoires virtuels sur les sites Web qui utilisent le port 80. Si vous consultez les répertoires virtuels qui utilisent les noms de répertoire virtuel Reporting Services par défaut (autrement dit, Reports et ReportServer), choisissez des noms de répertoire virtuel différents pour les URL Reporting Services que vous configurez.

  • Vous devez utiliser l'outil de configuration de Reporting Services pour configurer l'URL : N'utilisez pas d'utilitaire système. Ne modifiez jamais directement les réservations d'URL dans la section URLReservations du fichier RSReportServer.config. L'utilisation de l'outil de configuration de Reporting Services est nécessaire pour mettre à jour la réservation d'URL sous-jacente stockée en interne et pour synchroniser les paramètres URL stockés dans le fichier RSReportServer.config.

  • Choisissez une heure qui présente une activité de rapport basse. À chaque modification de la réservation d'URL, vous pouvez vous attendre à ce que les domaines d'application pour le service Web Report Server et le Gestionnaire de rapports soient recyclés.

  • Pour une vue d'ensemble de la construction et de l'utilisation des URL dans Reporting Services, consultez Configuration des URL de Report Server.

Pour configurer une URL pour le service Web Report Server

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports locale.

  2. Cliquez sur URL du service Web.

  3. Spécifiez le répertoire virtuel. Le nom de répertoire virtuel identifie l'application qui reçoit la demande. Comme une adresse IP et un port peuvent être partagés par plusieurs applications, le nom de répertoire virtuel spécifie quelle application reçoit la demande.

    Cette valeur doit être unique pour garantir que la demande atteint sa destination prévue. Cette valeur est obligatoire. Elle ne respecte pas la casse. Il existe une correspondance univoque entre un nom de répertoire virtuel et une instance d'une application Reporting Services. Si vous créez plusieurs URL vers la même instance d'application, vous devez utiliser le même nom de répertoire virtuel dans toutes les URL que vous définissez pour cette instance d'application.

    Pour le service Web Report Server, le nom du répertoire virtuel par défaut est ReportServer.

  4. Spécifiez l'adresse IP qui identifie de façon unique le serveur de rapports sur le réseau. Si vous souhaitez spécifier un en-tête de l'hôte ou définir des URL supplémentaires pour la même instance d'application, vous devez cliquer sur Avancé. Pour obtenir des instructions sur la façon de définir les propriétés avancées sur l'URL, consultez les instructions plus loin dans cette rubrique. Sinon, utilisez la page URL du service Web pour effectuer une sélection parmi les valeurs suivantes :

    • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

    • Non assigné spécifie que le serveur de rapports reçoit une demande qui n'a pas été gérée par une autre application. Il est recommandé d'éviter cette option. Si vous sélectionnez cette option, il devient possible pour une autre application qui possède une réservation d'URL plus forte d'intercepter les demandes prévues pour le serveur de rapports.

    • 127.0.0.1 est l'adresse IPv4 utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

    • ::1 désigne l'adresse de bouclage au format IPv6.

    • Les adresses IP spécifiques apparaissent également dans cette liste. Les adresses IP peuvent être aux formats IPv4 et IPv6. Nnn.nnn.nnn.nnn est l'adresse IPv4 32 bits d'une carte réseau sur votre ordinateur. Les adresses IPv6 sont de 128 bits, avec huit champs de 4 octets séparés par le signe deux-points : <préfixe>:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn

      Si vous avez plusieurs cartes ou si votre réseau prend en charge les adresses IPv4 et les adresses IPv6, vous visualisez plusieurs adresses IP. Si vous sélectionnez une seule adresse IP, elle limitera l'accès de l'application à la seule adresse IP (et à tout nom d'hôte qu'un serveur de noms de domaine mappe sur cette adresse). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports. En général, si vous sélectionnez cette valeur, c'est parce que vous configurez plusieurs réservations d'URL qui spécifient aussi des adresses IP explicites ou des noms d'hôte (par exemple, un premier pour une carte réseau utilisée pour les connexions intranet et un second utilisé pour les connexions extranet).

  5. Spécifiez le port. Le port 80 est le port par défaut pour Reporting Services sur Windows Server 2003, Windows Vistaet Windows Server 2008, parce qu'il peut être partagé avec d'autres applications. Si vous utilisez Windows XP SP2 32 bits, le port par défaut est 8080. Si vous souhaitez utiliser un numéro de port personnalisé, souvenez-vous que vous devrez toujours le spécifier dans l'URL utilisée pour accéder au serveur de rapports. Vous pouvez utiliser les techniques suivantes pour rechercher un port disponible :

    • À partir d'une invite de commandes, tapez la commande suivante pour retourner la liste des ports TCP utilisés :

      netstat –a –n -p tcp

    • Lisez l'article (en anglais) du support Microsoft Information about TCP/IP port assignments pour comprendre les attributions de port TCP et les différences entre les ports bien identifiés (0 à 1023), les ports inscrits (1024 à 49151) et les ports dynamiques ou privés (49152 à 65535).

    • Si vous utilisez le Pare-feu Windows, vous devez ouvrir le port. Pour obtenir des instructions, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

  6. Si vous ne l'avez pas déjà fait, vérifiez qu'IIS (s'il est installé) n'a pas de répertoire virtuel ayant le même nom que celui que vous projetez d'utiliser.

  7. Si vous avez installé un certificat SSL, vous pouvez le sélectionner pour lier l'URL au certificat SSL installé sur votre ordinateur.

  8. Le cas échéant, si vous sélectionnez un certificat SSL, vous pouvez spécifier un port personnalisé. La valeur par défaut est 443 mais vous pouvez utiliser tout port disponible.

  9. Cliquez sur Appliquer pour créer l'URL.

  10. Testez l'URL en cliquant sur le lien dans la section URL de la page. Notez que la base de données du serveur de rapports doit être créée et configurée avant que vous puissiez tester l'URL. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

  11. De plus, si votre serveur de rapports est configuré pour utiliser le mode intégré SharePoint, configurez l'URL du service Web Report Server dans l'Administration centrale de SharePoint. Pour plus d'informations sur la mise à jour de l'URL du service Web Report Server dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Pour créer une réservation d'URL pour le Gestionnaire de rapports

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports.

  2. Cliquez sur URL du Gestionnaire de rapports.

  3. Spécifiez le répertoire virtuel. Le Gestionnaire de rapports écoute sur la même adresse IP et le même port que le service Web Report Server. Si vous avez configuré le Gestionnaire de rapports pour pointer sur un service Web Report Server différent, vous devez modifier les paramètres d'URL du Gestionnaire de rapports dans le fichier RSReportServer.config. Pour obtenir des instructions, consultez Procédure : configurer le Gestionnaire de rapports.

  4. Si vous avez installé un certificat SSL, vous pouvez le sélectionner pour exiger que toutes les demandes adressées au Gestionnaire de rapports soient acheminées via le protocole HTTPS.

    Le cas échéant, si vous sélectionnez un certificat SSL, vous pouvez spécifier un port personnalisé. La valeur par défaut est 443, mais vous pouvez utiliser tout port disponible.

  5. Cliquez sur Appliquer pour créer l'URL.

  6. Testez l'URL en cliquant sur le lien dans la section URL de la page.

Définition de propriétés avancées pour spécifier les URL supplémentaires

Vous pouvez réserver plusieurs URL pour le service Web Report Server ou le Gestionnaire de rapports en spécifiant des ports ou des noms d'hôte différents (une adresse IP ou un nom d'en-tête de l'hôte qu'un serveur de noms de domaine peut résoudre en une adresse IP assignée à l'ordinateur). En créant plusieurs URL, vous pouvez définir différents chemins d'accès à la même instance de serveur de rapports. Par exemple, pour activer l'accès intranet et extranet à un serveur de rapports, vous pouvez utiliser l'URL par défaut pour l'accès intranet et un nom d'hôte complet supplémentaire pour l'accès extranet :

  • http://myserver01/reportserver

  • http://www.adventure-works.com/reportserver

Vous ne pouvez pas définir plusieurs noms de répertoire virtuel pour la même instance d'application. Chaque instance d'application de Reporting Services est mappée sur un nom de répertoire virtuel unique. Si vous avez plusieurs instances de Reporting Services sur le même ordinateur, le nom de répertoire virtuel d'une application doit inclure le nom de l'instance pour garantir que chaque demande atteint sa cible prévue.

Pour définir les propriétés avancées sur une URL

  1. Dans l'URL du service Web ou sur la page URL du Gestionnaire de rapports, cliquez sur Avancé.

  2. Cliquez sur Ajouter.

  3. Cliquez sur l'adresse IP ou le nom d'en-tête de l'hôte. Si vous spécifiez un en-tête de l'hôte, veillez bien à spécifier un nom que le service DNS peut résoudre. Si vous spécifiez un nom de domaine disponible publiquement, incluez la totalité de l'URL, y compris http://www.

  4. Spécifiez le port. Si vous spécifiez un port personnalisé, l'URL de l'application doit toujours inclure le numéro de port.

  5. Cliquez sur OK.

  6. Testez l'URL en ouvrant une fenêtre de navigateur et en entrant l'URL.

URL de plusieurs instances de Report Server sur le même ordinateur

Si vous réservez les URL pour plusieurs instances de Reporting Services, vous devez suivre les conventions d'affectation de noms afin d'éviter les conflits de noms. Pour plus d'informations, consultez Réservations d'URL pour les déploiements de serveur de rapports multi-instance.

Exemples de configurations d'URL

La liste suivante présente quelques exemples d'URL de serveur de rapports :

  • http://localhost/serveurderapports

  • http://localhost/serveurderapports_SQLEXPRESS

  • http://ventes01/serveurderapports

  • http://ventes01:8080/serveurderapports

  • https://ventes.adventure-works.com/serveurderapports

  • https://www.adventure-works.com:8080/serveurderapports01

Les URL que vous utilisez pour accéder au Gestionnaire de rapports partagent le même format et sont généralement créées sous le site Web qui héberge le serveur de rapports. La seule différence est le nom du répertoire virtuel (dans ce cas, le nom est rapports, mais vous pouvez configurer le répertoire virtuel pour qu'il utilise le nom de votre choix) :

  • http://localhost/rapports

  • http://localhost/rapports_SQLEXPRESS

  • http://ventes01/rapports

  • http://ventes01:8080/rapports

  • https://ventes.adventure-works.com/rapports

  • https://www.adventure-works.com:8080/rapports

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Concepts

Configuration des URL de Report Server

Autres ressources

Configuration de l'authentification dans Reporting Services


Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez un serveur de rapports pour une exécution dans un déploiement d'un produit ou d'une technologie SharePoint, vous devez spécifier des paramètres d'intégration qui déterminent la connexion entre l'instance de technologie SharePoint et un serveur de rapports Reporting Services:

  • Vous devez être administrateur sur le site ou la batterie SharePoint pour configurer l'intégration du serveur de rapports :

  • Vous devez avoir installé le Complément Reporting Services qui fournit les pages de configuration.

  • Vous devez également avoir un serveur de rapports cible qui est déjà connecté à une base de données du serveur de rapports créée pour le mode d'opérations intégré SharePoint.

  • Si vous configurez Reporting Services pour s'exécuter dans une batterie de serveurs SharePoint, un serveur Web frontal SharePoint doit également être installé sur le serveur de rapports.

Les paramètres que vous spécifiez sont stockés dans la base de données de configuration. Si vous configurez l'intégration pour une batterie qui inclut plusieurs serveurs virtuels, les paramètres seront utilisés par tous les serveurs Web frontaux qui sont activés dans une batterie de serveurs SharePoint et qui ont une installation du Complément Reporting Services.

Si vous modifiez ultérieurement les comptes de service Report Server ou que vous étendez une batterie de serveurs SharePoint pour inclure des applications supplémentaires, vous devez réexécuter la commande d'accord d'accès à la base de données afin de mettre à jour les droits d'accès dans la base de données de configuration SharePoint. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Pour plus d'informations sur l'ensemble des tâches à effectuer, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Remarque :
Une fois que vous avez défini une URL de serveur de rapports, vous devez être très prudent lors de sa modification. Toute modification d'une URL de serveur de rapports perturbe la connexion entre les serveurs, ce qui affecte les rapports et les modèles en cours de traitement. Si vous modifiez l'URL de serveur de rapports sur un serveur de production, assurez-vous de respecter les procédures de temps d'arrêt planifié établies pour votre organisation.

Pour spécifier les paramètres d'intégration de serveur de rapports dans l'administration centrale

  1. Dans Outils d'administration, cliquez sur Administration centrale SharePoint 3.0.

  2. Cliquez sur l'onglet Gestion des applications.

    Dans la section Reporting Services, vous devez voir les liens suivants : Gérer les paramètres d'intégration, Accorder l'accès à la base de données, Définir des paramètres par défaut serveur. Si vous ne voyez pas la section ou les liens, le Complément Reporting Services n'est pas installé sur l'ordinateur ou la fonctionnalité n'est pas activée. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

  3. Cliquez sur Gérer les paramètres d'intégration.

  4. Dans URL du service Web Report Server, spécifiez le site de serveur de rapports que vous souhaitez utiliser avec le site ou la batterie SharePoint actuel. L'URL peut pointer vers une seule instance de serveur de rapports ou il peut s'agir du nom de serveur virtuel d'un ensemble de serveurs de rapports à équilibrage de charge qui s'exécutent dans un déploiement avec montée en puissance parallèle.

    Pour obtenir l'URL, ouvrez l'outil de configuration de Reporting Services, connectez-vous au serveur de rapports et cliquez sur URL du service Web. Cliquez sur l'URL pour vérifier qu'elle fonctionne. Copiez l'URL et collez-la dans URL du service Web Report Server.

    L'URL du serveur de rapports inclut un nom de serveur et un répertoire virtuel que vous avez spécifiés dans l'outil de configuration Reporting Services. Les exemples suivants illustrent comment une URL du serveur de rapports peut être construite :

    • http://nom-serveur/reportserver (cet exemple peut être utilisé si le serveur de rapports se trouve sur un autre ordinateur).

    • http://nom_votre_serveur:8080/reportserver (cet exemple peut être utilisé si le serveur de rapports s'exécute sur Microsoft Windows XP SP2).

    • https://nom_votre_serveur:443/reportserver.

    Ne spécifiez pas http://localhost pour l'URL d'un serveur de rapports utilisé dans une batterie SharePoint. Une adresse URL qui spécifie http://localhost n'est pas valide pour les applications Web SharePoint installées sur des serveurs distants.

    Si vous avez installé côte à côte le serveur de rapports et l'instance de technologie SharePoint, vérifiez qu'il n'y a pas de conflits de nom de répertoire virtuel. Pour plus d'informations sur les problèmes d'interopérabilité, consultez Déploiement côte à côte de Reporting Services et des services IIS (Internet Information Services).

  5. Dans Mode d'authentification, sélectionnez Authentification Windows ou Authentification approuvée pour spécifier si le point de terminaison de serveur de rapports installé sur le serveur SharePoint envoie un en-tête avec un jeton de sécurité pour une connexion avec emprunt d'identité sur le serveur de rapports.

    Toutes les demandes issues d'une action utilisateur sur une page d'application Reporting Services sont transférées par le point de terminaison de serveur de rapports sur l'application Web SharePoint vers un serveur de rapports à des fins de traitement. Selon le mode d'authentification, la demande peut inclure ou non un jeton d'identité d'utilisateur SharePoint dans l'en-tête.

    Si l'application Web SharePoint est configurée pour l'authentification Windows et que le protocole Kerberos est activé, vous pouvez sélectionner Authentification Windows pour vous connecter par le biais de la sécurité intégrée Windows. Dans ce cas, aucun jeton d'identité d'utilisateur n'est envoyé. Éventuellement, vous pouvez sélectionner Authentification approuvée pour emprunter l'identité du compte approuvé et passer les informations utilisateur SharePoint dans l'en-tête de demande au serveur de rapports.

    Si l'application Web SharePoint est configurée pour l'authentification par formulaires, l'en-tête de demande inclura toujours l'identité utilisateur SharePoint ; par ailleurs, toute valeur que vous spécifiez pour le mode d'authentification est ignorée. Pour plus d'informations sur les connexions serveur, consultez Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint.

  6. Cliquez sur OK.

  7. Dans la section Reporting Services, cliquez sur Ajouter des comptes approuvés. Au cours de cette opération, les informations du compte de service sont récupérées à partir de l'instance du serveur de rapports. Une connexion de base de données et des autorisations sont créées pour chaque compte de service Report Server. L'intégration d'un serveur de rapports Reporting Services avec une application Web SharePoint exige que le serveur de rapports soit capable d'accéder aux bases de données de configuration et de contenu SharePoint. Le service Web Report Server doit être en mesure de se connecter en tant qu'utilisateurs approuvés avec des autorisations de lecture et d'écriture.

  8. Spécifiez le nom du serveur de rapports. Par défaut, il s'agit du nom de l'ordinateur.

  9. Spécifiez si l'instance est l'instance par défaut ou une instance nommée. Si vous avez des doutes, démarrez l'outil de configuration de Reporting Services et connectez-vous au serveur de rapports. Dans la boîte de dialogue Se connecter à une instance du serveur de rapports, développez Nom de l'instance pour afficher une liste des instances installées sur le serveur. MSSQLSERVER est le nom de l'instance par défaut. Toutes les autres instances sont des instances nommées.

  10. Cliquez sur OK.

    La boîte de dialogue Entrer les informations d'identification s'ouvre.

  11. Dans la boîte de dialogue Entrer les informations d'identification, spécifiez le nom d'utilisateur et le mot de passe pour se connecter au serveur de rapports afin de récupérer les informations du compte de service. Assurez-vous d'entrer les informations d'identification d'un compte membre du groupe local Administrateurs sur l'ordinateur serveur de rapports.

  12. Dans la section Reporting Services, cliquez sur Définir des paramètres par défaut serveur.

  13. Dans Paramètre par défaut de l'historique de rapport, spécifiez une valeur par défaut à l'échelle du site pour déterminer le nombre de copies d'historique de rapport à conserver. La valeur par défaut fournit un paramètre initial qui établit le nombre de captures instantanées qui peuvent être stockées pour chaque rapport. Vous pouvez spécifier des limites différentes dans les pages de propriétés de rapports particuliers.

  14. Dans Délai de traitement des rapports, spécifiez si le délai de traitement d'un rapport expire sur le serveur de rapports après un certain nombre de secondes. Cette valeur s'applique au traitement du rapport sur le serveur de rapports. Elle n'a aucune incidence sur le traitement des données sur le serveur de base de données qui fournit les données pour le rapport. La minuterie du traitement du rapport commence lorsque le rapport est sélectionné et s'arrête lors de l'ouverture du rapport. La valeur que vous spécifiez doit être suffisante pour terminer le traitement des données et du rapport.

  15. Dans Journal de traitement des rapports, spécifiez si le serveur de rapports génère des journaux de traces et le nombre de jours pendant lesquels ces journaux sont conservés. Vous pouvez spécifier si le serveur de rapports génère des journaux de traces et le nombre de jours pendant lesquels ces journaux sont conservés. Les journaux sont stockés sur l'ordinateur serveur de rapports dans le dossier \Microsoft SQL Server\MSSQL.n\ReportServer\Log. Un nouveau fichier journal est démarré chaque fois que le service est démarré. Pour plus d'informations sur les fichiers journaux, consultez Journal des traces du service Report Server.

  16. Dans Activer la sécurité intégrée de Windows, spécifiez si une connexion à une source de données de rapport peut être établie à l'aide du jeton de sécurité Windows de l'utilisateur qui a demandé le rapport.

  17. Dans Activer la création de rapports appropriés, spécifiez si les utilisateurs peuvent exécuter des requêtes ad hoc à partir d'un rapport du Générateur de rapports. Le paramétrage de cette option permet de définir la propriété EnableLoadReportDefinition sur le serveur de rapports. Si vous désactivez cette option, le serveur de rapports ne générera pas de rapports consultables à l'aide de clics pour les rapports qui utilisent un modèle de rapport comme source de données.

  18. Cliquez sur OK.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur un serveur autonome
Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs
Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Concepts

Procédure : installer ou désinstaller le complément Reporting Services
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services)

Autres ressources

Intégration de Reporting Services et de la technologie SharePoint
Gestion de l'historique de rapport
Affichage et gestion d'éléments de serveur de rapports à partir d'un site SharePoint
Définition des valeurs de délai d'attente pour le traitement d'un rapport


Procédure : configurer l'intégration à SharePoint sur un serveur autonome

Procédure : configurer l'intégration à SharePoint sur un serveur autonome |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

L'un des scénarios de déploiement pour exécuter Reporting Services en mode intégré SharePoint consiste à installer tous les composants serveur et bases de données d'application sur un serveur autonome unique. Cette configuration est utile si vous souhaitez en savoir davantage sur l'interaction entre les technologies ou si vous développez une application personnalisée et que vous souhaitez tirer parti de la simplicité liée à la présence de tous les services sur un ordinateur unique. L'illustration suivante montre les composants que vous devez installer.

Reporting Services et SharePoint sur un ordinateur

Configuration requise

Avant de commencer à installer des composants, assurez-vous d'effectuer les opérations suivantes :

  • Étudiez l'introduction aux configurations de déploiement afin de vous familiariser avec les composants que vous allez installer. Pour plus d'informations, consultez Topologies de déploiement pour Reporting Services en mode intégré SharePoint.

  • Étudiez la rubrique de vue d'ensemble de configuration afin d'en savoir plus sur les recommandations relatives à la configuration des comptes de service et sur les étapes de configuration. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

  • Examinez les configurations matérielle et logicielle requises qui s'appliquent à tous les scénarios de déploiement qui incluent Reporting Services en mode intégré SharePoint. Pour plus d'informations, consultez Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint.

  • Examinez les sections restantes dans cette rubrique afin d'en savoir plus sur les spécifications supplémentaires qui s'appliquent à une configuration de serveur autonome.

Considérations relatives à la base de données pour la configuration du serveur autonome

Reporting Services et les produits et technologies SharePoint utilisent des bases de données relationnelles SQL Server pour stocker des données d'application. Reporting Services requiert une instance du Moteur de base de données dans une édition compatible. Les produits et technologies SharePoint peuvent utiliser un serveur de base de données existant si vous en fournissez un. Dans le cas contraire, le programme d'installation installe SQL Server Embedded Edition en tant que composant interne et l'utilise pour les bases de données d'application. Étant donné que vous installez déjà le Moteur de base de données pour Reporting Services, vous pouvez envisager d'utiliser cette même instance pour les bases de données d'application SharePoint.

Toutefois, si vous laissez le programme d'installation installer et utiliser SQL Server Embedded Edition, vous pouvez réduire considérablement le nombre d'étapes d'installation et de configuration. Si vous disposez d'un espace disque suffisant, vous devez utiliser l'édition Embedded fournie par SharePoint.

Si vous ne souhaitez pas avoir plusieurs instances de SQL Server sur votre ordinateur, vous pouvez utiliser le Moteur de base de données pour les bases de données de configuration et de contenu SharePoint. Pour cela, vous devez choisir l'option d'installation Avancée lorsque vous installez un produit ou une technologie SharePoint.

Remarque :
L'instance de serveur de rapports ne peut pas utiliser l'édition Embedded pour sa base de données. Toutefois, l'instance Embedded Edition installée par le produit ou la technologie SharePoint peut exister côte à côte avec d'autres éditions du Moteur de base de données que vous pouvez installer également. Pour plus d'informations sur l'édition requise pour la base de données du serveur de rapports, consultez Création d'une base de données de serveur de rapports.

Ordre d'installation

Vous pouvez installer les technologies de composants dans n'importe quel ordre, mais pour de meilleurs résultats vous devez installer en premier Reporting Services et vérifier que vous avez une installation valide avant d'installer le produit ou la technologie SharePoint.

Pour réduire le nombre d'étapes nécessaires, vous devez installer Reporting Services et le Moteur de base de données simultanément Étant donné que vous installez le Moteur de base de données et Reporting Services ensemble, vous aurez très probablement l'option d'installer Reporting Services dans la configuration par défaut, où les répertoires virtuels, le compte de service et les bases de données du serveur de rapports sont configurés automatiquement pendant l'installation.

La liste ci-dessous résume les tâches de déploiement à exécuter :

  1. Installez Reporting Services et le Moteur de base de données. Si possible, choisissez l'option Installer la configuration par défaut en mode SharePoint lors de l'installation de Reporting Services. Sinon, vous pouvez sélectionner l'option du Installer mais ne pas configurer le serveur et configurer le serveur comme tâche de post-installation.

  2. Configurez le serveur de rapports s'il n'est pas déjà configuré et vérifiez que vous avez une installation valide.

  3. Téléchargez et installez le package redistribuable Microsoft .NET Framework 3.0 .

  4. Installez Windows SharePoint Services ou Office SharePoint Server 2007. Choisissez l'option d'installation Basique.

  5. Exécutez l'Assistant Configuration des produits et technologies SharePoint, puis ouvrez le site SharePoint pour vérifier que vous avez une installation valide.

  6. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

  7. Configurez les fonctionnalités d'intégration du serveur de rapports dans l'Administration centrale.

Pour installer Reporting Services et le moteur de base de données

  • Installer Reporting Services et le Moteur de base de données sur le même ordinateur. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 (programme d'installation).

  • Configurez le serveur de rapports, mais lorsque vous créez la base de données du serveur de rapports, sélectionnez l'option pour le mode intégré SharePoint. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports.

Une fois l'installation terminée, vous pouvez vérifier qu'elle a réussi en vous connectant au serveur de rapports. Vous pouvez tester la connexion en entrant http://localhost/reportserver dans l'adresse d'URL d'une fenêtre de navigateur.

Pour télécharger et installer le package redistribuable du .NET Framework 3.0

  1. Téléchargez le package redistributable du .NET Framework 3.0 à partir du Centre de téléchargement Microsoft.

  2. Exécutez le programme d'installation. Le programme d'installation s'exécute en arrière-plan et son exécution peut prendre un certain temps. Pour vérifier sa progression, cliquez sur l'icône d'installation de Microsoft .NET Framework 3.0 dans la zone de notification de la barre des tâches.

Pour installer et configurer Windows SharePoint Services ou Office SharePoint Server

  1. Exécutez Setup.exe à partir du support d'installation.

  2. Entrez la clé de produit de 25 caractères.

  3. Acceptez le contrat de license de logiciel.

  4. Cliquez sur Basique.

    Cette option fournit le moins d'étapes d'installation. Elle installe immédiatement le logiciel en utilisant toutes les valeurs par défaut. Elle automatise également les étapes de configuration pour la configuration de l'Administration centrale et du site SharePoint par défaut.

    Si vous souhaitez utiliser une instance Moteur de base de données existante, vous devez plutôt cliquer sur Avancée. Lorsque vous choisissez cette option, le programme d'installation fournit l'option d'installation Complète, que vous pouvez utiliser pour spécifier le serveur de base de données à utiliser. Sachez que le fait de choisir l'option d'installation Avancée augmente la complexité des étapes de configuration que vous devez effectuer ultérieurement. Pour plus d'informations sur la façon de spécifier et de configurer une installation Avancée, suivez la procédure « Pour installer un produit ou une technologie SharePoint » dans Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs. Lorsque vous avez terminé l'installation Avancée et les étapes de configuration dans la rubrique de déploiement multi-serveur, retournez à cette rubrique, modifiez l'affectation des ports et continuez les tâches restantes.

  5. Dans la page Terminé, vérifiez que la case à cocher est activée pour Exécuter l'Assistant Configuration des produits et technologies SharePoint.

  6. Cliquez sur Fermer.

    Une fois le programme d'installation fermé, l'Assistant Configuration des produits et technologies SharePoint s'exécute. Lorsque vous sélectionnez l'option d'installation Basique, les tâches de configuration s'exécutent en arrière-plan et vous pouvez cliquer sur Terminer lorsque les tâches de configuration sont terminées.

  7. Vérifiez que l'installation a réussi. Par défaut, un site SharePoint s'ouvre dans une fenêtre de navigateur une fois les tâches de configuration terminées. Cette étape vérifie le processus d'installation et de configuration.

Par défaut, l'Assistant Configuration des produits et technologies SharePoint assigne le port 80 à l'application Web SharePoint, ce qui rend le serveur de rapports indisponible. En conséquence, vous devez maintenant modifier les paramètres de configuration du serveur de rapports de façon à utiliser un port différent et vous devez démarrer le site Web par défaut.

Vérifier que la base de données du serveur de rapports est configurée pour le mode intégré SharePoint

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour obtenir des instructions, consultez Procédure : démarrer la configuration de Reporting Services.

  2. Dans la page État de Report Server, vérifiez que Mode du serveur de rapports a la valeur Intégré à SharePoint.

  3. Si le serveur de rapports n'est pas configuré pour le mode intégré SharePoint, cliquez sur Base de données et créez la base de données du serveur de rapports pour le mode intégré SharePoint. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) et Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services).

Si vous utilisez une nouvelle installation de Reporting Services, vous devez également configurer le compte de traitement de rapport sans assistance si vous voulez prendre en charge l'exécution de rapport sans assistance. En option, configurez le serveur de rapports pour la remise de courrier électronique. Pour plus d'informations, consultez Configuration du compte d'exécution sans assistance et Configuration d'un Report Server pour la remise du courrier électronique.

Pour télécharger et installer le Complément Reporting Services pour SharePoint Technologies

  1. Cliquez sur Microsoft SQL Server pour ouvrir la page de téléchargement sur le site Web Microsoft.

    Important :
    Vous devez être administrateur de batterie de serveurs Web SharePoint et administrateur de collection de site pour installer le Complément Reporting Services.

  2. Choisissez la langue d'installation.

  3. Dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour installer la version 32 bits ou 64 bits du Complément Reporting Services.

  4. Cliquez sur Enregistrer pour enregistrer le fichier dans un emplacement sur votre ordinateur.

  5. Ouvrez l'Explorateur Windows et recherchez le dossier où le fichier se trouve.

  6. Double-cliquez sur SharePointRS.msi pour commencer l'installation. Pour plus d'informations, consultez Procédure : installer ou désinstaller le complément Reporting Services.

  7. Obtenez la version la plus récente du fichier lisez-moi pour le Complément Reporting Services afin d'examiner les modifications de dernière minute et les problèmes connus. Dans la page de téléchargement sur le site Web Microsoft, dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour ouvrir le fichier readme_rsaddin.htm, puis enregistrez le fichier sur votre ordinateur.

Pour configurer l'intégration du serveur de rapports

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 3.0.

    Important :
    Pour effectuer les étapes suivantes, vous devez être membre du groupe Administrateur de batterie de serveurs SharePoint et un administrateur de la collection de sites.

  2. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Si vous ne voyez pas cette section, vous devez activer la fonctionnalité d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

    Au minimum, vous devez définir l'URL du serveur de rapports, sélectionner un mode d'authentification et accorder l'accès au serveur de rapports aux bases de données SharePoint. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

  3. Fermez l'Administration centrale.

Étapes suivantes

Vérifiez l'intégration en démarrant l'outil de configuration de Reporting Services et en ouvrant la page Intégration SharePoint pour afficher l'état du serveur. Vous devez voir un lien sur lequel vous pouvez cliquer pour démarrer l'Administration centrale de SharePoint.

Vous pouvez également vérifier une installation en ouvrant une fenêtre du navigateur sur le serveur de rapports. L'URL doit ressembler à http://nom-serveur-exemple:8080/serveurderapports. Cette URL pointe sur le point de terminaison de proxy. Après avoir ajouté des éléments de serveur de rapports dans une bibliothèque SharePoint, vous pouvez ouvrir une fenêtre du navigateur sur cette URL pour afficher les éléments sur le site.

Pour finir, vous devez être en mesure d'ouvrir l'application Web SharePoint et de télécharger des rapports et d'autres documents vers une bibliothèque SharePoint.

Après avoir installé tous les composants et configuré les paramètres pour connecter des composants serveur, vous devez assigner des autorisations, ajouter des types de contenu et ajouter des éléments de serveur de rapports à une bibliothèque SharePoint.
Pour finir les tâches de déploiement pour l'intégration de serveur
  1. Ouvrez l'application Web SharePoint. Par défaut, l'URL est http://<votre-nom-serveur>.

  2. Définissez des autorisations pour accorder à l'utilisateur l'accès au site SharePoint. La sécurité est requise, mais si vous voulez hériter des autorisations existantes, vous n'êtes pas tenu de définir des autorisations sur des éléments spécifiques. Pour plus d'informations, consultez Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint ou Procédure : définir les autorisations sur les éléments de serveur de rapports sur un site SharePoint (Reporting Services en mode intégré SharePoint).

  3. Ajoutez les types de contenu Reporting Services si vous voulez créer de nouvelles sources de données partagées, des modèles de rapport et des rapports du Générateur de rapports. Pour plus d'informations, consultez Procédure : ajouter des types de contenu de serveur de rapports à une bibliothèque (Reporting Services en mode intégré SharePoint).

  4. Créez des sources de données partagées à utiliser avec les rapports et les modèles. Pour plus d'informations, consultez Procédure : créer et gérer des sources de données partagées (Reporting Services en mode intégré SharePoint).

  5. Créez des planifications partagées à utiliser avec les abonnements ou le traitement de rapport sans assistance. Pour plus d'informations, consultez Procédure : créer et gérer des planifications partagées (Reporting Services en mode intégré SharePoint).

  6. Publiez des fichiers de définition de rapport (.rdl), des fichiers de source de données (.rds) et des fichiers de modèle de rapport (.smdl) dans une bibliothèque SharePoint. Vous pouvez également utiliser la commande Télécharger dans une bibliothèque SharePoint pour télécharger des fichiers .rdl et .smdl, mais pas des fichiers .rds. Selon vos autorisations, vous pouvez également créer des rapports dans le Générateur de rapports et les enregistrer dans une bibliothèque. Si les rapports incluent des références à des sources de données partagées ou à des fichiers externes, vous devez mettre à jour ces références. Pour plus d'informations, consultez Déploiement de modèles et de sources de données partagées sur un site SharePoint et Procédure : Télécharger des documents vers une bibliothèque SharePoint (Reporting Services en mode intégré SharePoint).

Lorsque vous téléchargez des rapports, assurez-vous que les propriétés de source de données du rapport sont correctes. La source de données doit avoir une chaîne de connexion valide à une source de données externe. Le type d'informations d'identification doit être valide pour votre topologie réseau. En particulier, si l'authentification Kerberos n'est pas activée pour votre domaine, vous ne pouvez pas utiliser le type d'informations d'identification de sécurité intégrée de Windows. À la place, vous devez spécifier des informations d'identification stockées. Après avoir vérifié que les propriétés de source de données sont correctes, vous pouvez cliquer sur le nom du rapport pour ouvrir le rapport. Le rapport s'ouvre automatiquement dans le composant WebPart de visionneuse de rapports.

Si le rapport ne s'ouvre pas, vérifiez les autorisations sur le rapport et les propriétés de source de données qui définissent une connexion à la source de données externe. Sur un site ou dans une batterie de serveurs, les autorisations SharePoint permettent de contrôler l'accès aux rapports, aux modèles de rapport, aux sources de données partagées et à l'outil Générateur de rapports utilisé pour créer des rapports appropriés. Si ces éléments ne sont pas visibles pour les utilisateurs, vous devez vérifier que les autorisations sont définies correctement.

Un serveur de rapports qui s'exécute en mode intégré SharePoint ne peut pas être géré par le biais du Gestionnaire de rapports ou de SQL Server Management Studio. Pour obtenir la liste complète des fonctionnalités prises en charge et non prises en charge, consultez Fonctionnalités prises en charge par Reporting Services en mode intégré SharePoint.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 3.0

Autres ressources

Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint
Topologies de déploiement pour Reporting Services en mode intégré SharePoint
Planification d'un mode de déploiement
Intégration de Reporting Services et de la technologie SharePoint


Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Cette rubrique fournit des instructions étape par étape pour l'installation et la configuration de Reporting Services en mode intégré SharePoint dans une topologie de déploiement sur plusieurs serveurs. Cette configuration est recommandée si de nombreux utilisateurs accèdent aux rapports à partir d'un site SharePoint. L'illustration suivante montre les composants que vous devez installer.

Reporting Services et SharePoint séparément

Configuration requise

Avant de commencer à installer des composants, assurez-vous d'effectuer les opérations suivantes :

  • Étudiez l'introduction aux configurations de déploiement afin de vous familiariser avec les composants que vous allez installer. Pour plus d'informations, consultez Topologies de déploiement pour Reporting Services en mode intégré SharePoint.

  • Étudiez la rubrique de vue d'ensemble de configuration afin d'en savoir plus sur les recommandations relatives à la configuration des comptes de service et sur les étapes de configuration. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

  • Étudiez les configurations matérielle et logicielle requises qui s'appliquent à tous les scénarios de déploiement qui incluent Reporting Services en mode intégré SharePoint. Pour plus d'informations, consultez Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint.

  • Étudiez les éléments restants dans cette section afin d'en savoir plus sur les spécifications supplémentaires qui s'appliquent à une configuration de serveur autonome.
Configuration requise pour les serveurs dans un déploiement sur plusieurs serveurs

Vous devez disposer d'au moins deux ou trois serveurs. L'hébergement des bases de données d'application sur un troisième serveur utilisé exclusivement par le Moteur de base de données est une technique courante pour améliorer les performances si vous vous attendez à un nombre d'utilisateurs relativement important.

Si vous utilisez deux serveurs, chacun doit disposer des composants suivants :

  • Sur l'un des serveurs, installez SQL Server 2008 Reporting Services (SSRS) et le Moteur de base de données. Ce serveur sera utilisé pour héberger le serveur de rapports avec les bases de données du serveur de rapports et les bases de données d'application SharePoint.

  • Sur le deuxième serveur, installez le package redistribuable Microsoft .NET Framework 3.0, une instance d'un produit ou d'une technologie SharePoint et le complément Reporting Services. Ce serveur constituera le serveur principal de la batterie. L'administration centrale sera installée sur ce serveur. Les utilisateurs accéderont au contenu du serveur de rapports à partir de la collection de sites de cet ordinateur.

Configuration requise pour les comptes dans un déploiement sur plusieurs serveurs

Vous devez disposer d'un compte d'utilisateur de domaine pour connecter l'instance du produit ou de la technologie SharePoint à la base de données SharePoint_config. Les batteries de serveurs requièrent l'utilisation de comptes de domaine pour les services et les connexions de bases de données. Si possible, créez un compte pouvant être utilisé exclusivement pour cette application. Évitez d'utiliser vos propres informations d'identification ou celles d'un utilisateur qui accédera à un site SharePoint en tant qu'utilisateur normal (sous peine de recevoir des erreurs de type « accès refusé »).

Vous devez créer une connexion de base de données SQL Server pour le compte de domaine. La connexion a besoin d'autorisations DBCreator sur le serveur.

Vous devez configurer le compte de processus du pool d'applications SharePoint pour qu'il s'exécute en tant que compte d'utilisateur de domaine.

Vous devez configurer le service Report Server pour qu'il s'exécute en tant que compte d'utilisateur de domaine.

Important :
Pour les déploiements de serveur distribués où le serveur de rapports, l'application Web SharePoint et les bases de données du serveur se trouvent sur trois ordinateurs distincts, vous pouvez utiliser les paramètres par défaut qui incluent le site Web et les affectations de port par défaut. Si vous installez l'application Web SharePoint et le serveur de rapports sur des ordinateurs distincts, tout en plaçant les bases de données SharePoint sur l'ordinateur serveur de rapports, vous rencontrerez des erreurs de connexion, à moins que vous ne suiviez les consignes de configuration des comptes de service décrites dans la section précédente. Pour plus d'informations, consultez Procédure : configurer un compte de service pour Reporting Services.

Des informations d'identification d'administrateur sont requises pour exécuter tous les programmes d'installation, pour accorder des autorisations pour l'administration de collection de sites principale et pour accorder l'accès aux bases de données lorsque vous configurez l'intégration du serveur de rapports.

Ordre d'installation

Vous pouvez installer les technologies de composants dans n'importe quel ordre. Pour de meilleurs résultats, vérifiez que chaque produit ou technologie serveur est correctement installé avant de l'intégrer.

La liste suivante fournit un résumé des tâches de déploiement :

  1. Installez Reporting Services et le moteur de base de données. Si vous installez le logiciel serveur sur un serveur de production ou si vous utilisez une configuration de déploiement à trois serveurs, choisissez l'option Installer mais ne pas configurer le serveur, ce qui vous permettra de contrôler quand et comment configurer le serveur de rapports.

  2. Configurez le serveur de rapports et vérifiez la validité de l'installation.

  3. Téléchargez et installez le package redistribuable .NET Framework 3.0.

  4. Installez Windows SharePoint Services ou Office SharePoint Server 2007. Choisissez l'option d'installation Avancée, ce qui vous permettra de spécifier un serveur de base de données distant pendant la configuration.

  5. Exécutez l'Assistant Configuration des produits et technologies SharePoint et sélectionnez le serveur de base de données.

  6. Configurez les fonctionnalités de collection de sites dans l'Administration centrale et ouvrez le site SharePoint pour vérifier la validité de l'installation.

  7. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

  8. Configurez les fonctionnalités d'intégration du serveur de rapports dans l'Administration centrale.

Pour installer Reporting Services et le moteur de base de données

  • Installez Reporting Services et le Moteur de base de données sur le même ordinateur ou sur des ordinateurs distincts. Pour plus d'informations, consultez Considérations sur l'installation de Reporting Services.

Lorsque le programme d'installation a terminé, configurez le serveur de rapports pour un fonctionnement en mode natif afin de vérifier que l'installation a réussi. Cette façon de procéder vous permet d'utiliser le Gestionnaire de rapports pour vérifier l'installation.

Pour obtenir des instructions sur le démarrage de l'outil de configuration de Reporting Services et la configuration du serveur de rapports pour sa mise en exploitation, consultez Rubriques d'aide à la configuration de Reporting Services.

Pour télécharger et installer le package redistribuable .NET Framework 3.0

  1. Sur un serveur différent de celui que vous utiliserez pour l'instance du produit ou de la technologie SharePoint, téléchargez le package redistribuable .NET Framework 3.0 à partir du Centre de téléchargement Microsoft.

  2. Exécutez le programme d'installation. Le programme d'installation s'exécute en arrière-plan et son exécution peut prendre un certain temps. Pour vérifier sa progression, cliquez sur l'icône d'installation de Microsoft .NET Framework 3.0 dans la zone de notification de la barre des tâches.

Pour installer un produit ou une technologie SharePoint

  1. Exécutez Setup.exe à partir du support d'installation de Windows SharePoint Services 3.0 ou Microsoft Office SharePoint Server .

  2. Entrez la clé de produit de 25 caractères.

  3. Acceptez le contrat de licence du logiciel.

  4. Cliquez sur Avancé.

    1. Dans Type de serveur, cliquez sur Web frontal.

    2. L'onglet Emplacement des données spécifie l'emplacement des fichiers d'index de recherche. Sous Emplacement des données, utilisez la valeur par défaut ou sélectionnez un ordinateur qui possède un espace disque supplémentaire.

    3. Cliquez sur Installer maintenant.

  5. Configurez le produit ou la technologie SharePoint. L'Assistant Configuration des produits et technologies SharePoint doit démarrer après que l'installation est terminée. Si tel n'est pas le cas, démarrez-le à partir des Outils d'administration.

    1. Dans l'écran de bienvenue, cliquez sur Suivant.

    2. Cliquez sur Oui pour redémarrer les services si besoin est.

    3. Dans la page Se connecter à une batterie de serveurs, cliquez sur Non, je veux créer une batterie de serveurs, puis cliquez sur Suivant.

    4. Dans la page Spécifier les paramètres de la base de données de configuration, entrez le nom du serveur de base de données. Si vous avez installé le Moteur de base de données en tant qu'instance par défaut, le nom du serveur de base de données est celui de l'ordinateur.

    5. Dans Nom d'utilisateur et Mot de passe, tapez les informations d'identification d'un compte d'utilisateur de domaine autorisé à se connecter à l'ordinateur et disposant d'une connexion de base de données SQL Server, ainsi que d'autorisations DBCreator sur le serveur. Si possible, spécifiez un compte utilisé uniquement pour exécuter cette application. Ne tapez pas les informations d'identification d'un utilisateur qui accédera ultérieurement au site SharePoint ; cet utilisateur peut en effet recevoir des erreurs de type « accès refusé » ultérieurement, lors de l'accès au contenu du site. Cliquez sur Suivant.

    6. Dans la page Configurer l'application Web Administration centrale de SharePoint, cliquez sur Suivant pour accepter toutes les valeurs par défaut. Si vous savez que les fonctionnalités d'emprunt d'identité et de délégation sont activées pour l'authentification Windows dans votre domaine, vous pouvez sélectionner à la place Négocier (Kerberos). Sinon, sélectionnez la valeur par défaut et cliquez sur Suivant.

    7. Dans Fin de l'Assistant Configuration des produits et technologies SharePoint, cliquez sur Suivant pour commencer la configuration à l'aide des paramètres que vous avez spécifiés.

    8. Cliquez sur Terminer.

Pour configurer l'application Web SharePoint

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 3.0. Suivez la liste de vérification qui s'affiche dans Tâches d'administration. Pour plus d'informations sur chaque tâche, cliquez sur le lien Lire le Guide de démarrage rapide. Les tâches des étapes suivantes sont obligatoires.

  2. Créez une application Web :

    1. Cliquez sur Créer des sites SharePoint.

    2. Cliquez sur Créer une application Web.

    3. Sélectionnez Créer un nouveau site Web IIS (SharePoint - 80) en utilisant les valeurs par défaut. Ces valeurs incluent l'utilisation du port 80, aucun en-tête d'hôte, le chemin d'accès par défaut, NTLM et pas d'accès anonyme. Veillez à spécifier le compte du processus du pool d'applications. Choisissez un compte d'utilisateur de domaine.

    4. Cliquez sur OK.

  3. Dans la page Application créée, cliquez sur Créer une collection de sites.

    1. Entrez un titre.

    2. Utilisez les valeurs par défaut. Lorsque vous spécifiez l'Administrateur principal de la collection de sites, spécifiez un compte disposant d'autorisations d'administrateur local.

    3. Cliquez sur OK.

  4. Ouvrez une fenêtre d'invite de commandes et tapez iisrest /noforce.

  5. Cliquez sur l'URL pour vérifier le site.

  6. (Facultatif) Dans Administration Centrale, activez la journalisation des diagnostics.

Pour configurer le serveur de rapports pour le mode intégré SharePoint

  1. installez et configurez un serveur Web SharePoint frontal sur l'ordinateur serveur de rapports. Pour obtenir des instructions, consultez Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports..

    1. Une fenêtre de navigateur s'ouvre sur l'Administration Centrale du serveur principal et vous permet de vérifier que la configuration de la batterie de serveurs a réussi.

  2. Configurez le serveur de rapports en vue de l'intégration :

    1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour obtenir des instructions, consultez Procédure : démarrer la configuration de Reporting Services.

    2. Dans le volet de navigation, cliquez sur Compte de service. Vérifiez qu'il utilise un compte d'utilisateur de domaine. Si ce n'est pas le cas, configurez-le de sorte qu'il en utilise un.

    3. Dans le volet de navigation, cliquez sur Base de données.

      Remarque :
      Si vous utilisez une instance distante du Moteur de base de données, consultez Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services) pour plus d'informations.

    4. Cliquez sur Modifier la base de données.

    5. Sélectionnez Créer une nouvelle base de données.

    6. Cliquez sur Suivant.

    7. Spécifiez l'instance du Moteur de base de données qui hébergera la base de données.

    8. Cliquez sur Tester la connexion pour vérifier que vous pouvez vous y connecter.

    9. Cliquez sur Suivant.

    10. Dans Nom de la base de données, tapez un nom pour la nouvelle base de données (par exemple, serveur_rapportsModeSharepoint).

    11. Sélectionnez Mode intégré à SharePoint.

    12. Cliquez sur Suivant.

    13. Spécifiez les informations d'identification que le serveur de rapports utilise pour se connecter à la base de données du serveur de rapports.

    14. Cliquez sur Suivant.

    15. Cliquez sur Suivant.

    16. Cliquez sur Terminer.

    17. Configurez le compte d'exécution sans assistance et tous les autres paramètres que vous souhaitez modifier. Les valeurs du répertoire virtuel Serveur de rapports doivent toujours être valides. Toutefois, le Gestionnaire de rapports n'est plus disponible à présent que vous avez configuré le serveur de rapports pour l'utilisation d'une base de données en mode intégré SharePoint (l'onglet du répertoire virtuel Gestionnaire de rapports doit être grisé).

Pour télécharger et installer le complément Reporting Services

  1. Cliquez sur Microsoft SQL Server 200 pour ouvrir la page de téléchargement sur le site Web Microsoft.

    Important :
    Vous devez être administrateur de batterie de serveurs Web SharePoint et administrateur de collection de site pour installer le Complément Reporting Services.

  2. Choisissez la langue d'installation.

  3. Dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour installer la version 32 bits ou 64 bits du Complément Reporting Services.

  4. Cliquez sur Enregistrer pour enregistrer le fichier dans un emplacement sur votre ordinateur.

  5. Ouvrez l'Explorateur Windows et recherchez le dossier où le fichier se trouve.

  6. Double-cliquez sur SharePointRS.msi pour commencer l'installation. Pour obtenir des instructions, consultez Procédure : installer ou désinstaller le complément Reporting Services.

  7. Procurez-vous la version la plus récente du fichier lisez-moi pour le complément Reporting Services afin d'examiner les modifications de dernière minute et les problèmes connus. Dans la page de téléchargement sur le site Web de Microsoft, dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour ouvrir le fichier readme_rsaddin.htm, puis enregistrez le fichier sur votre ordinateur.

Pour configurer l'intégration du serveur dans l'Administration centrale

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 3.0.

    Important :
    Pour effectuer les étapes suivantes, vous devez être membre du groupe Administrateur de batterie de serveurs SharePoint et un administrateur de la collection de sites.

  2. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Si vous ne voyez pas cette section, vous devez activer la fonctionnalité d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

    Au minimum, vous devez définir l'URL du serveur de rapports, sélectionner un mode d'authentification et accorder l'accès au serveur de rapports aux bases de données SharePoint. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

  3. Fermez l'Administration centrale.

Une erreur s'affiche si les services Reporting Services s'exécutent sous des comptes intégrés. Si vous avez déjà configuré les services pour l'utilisation de comptes d'utilisateurs de domaine, redémarrez-les pour effacer les anciennes informations de connexion (à supposer qu'il existe des connexions dans la session active). Pour plus d'informations sur la configuration des comptes de service, consultez Configuration du compte de service Report Server.

Étapes suivantes

Après avoir installé tous les composants et configuré les paramètres pour connecter des composants serveur, vous devez assigner des autorisations, ajouter des types de contenu et ajouter des éléments de serveur de rapports à une bibliothèque SharePoint.

Pour finir les tâches de déploiement pour l'intégration de serveur

  1. Ouvrez l'application Web SharePoint. Par défaut, l'URL est http://<votre-nom-serveur>.

  2. Définissez des autorisations pour accorder à l'utilisateur l'accès au site SharePoint. La sécurité est requise, mais si vous voulez hériter des autorisations existantes, vous n'êtes pas tenu de définir des autorisations sur des éléments spécifiques. Pour plus d'informations, consultez Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint ou Procédure : définir les autorisations sur les éléments de serveur de rapports sur un site SharePoint (Reporting Services en mode intégré SharePoint).

  3. Ajoutez les types de contenu Reporting Services si vous voulez créer de nouvelles sources de données partagées, des modèles de rapport et des rapports du Générateur de rapports. Pour plus d'informations, consultez Procédure : ajouter des types de contenu de serveur de rapports à une bibliothèque (Reporting Services en mode intégré SharePoint).

  4. Créez des sources de données partagées à utiliser avec les rapports et les modèles. Pour plus d'informations, consultez Procédure : créer et gérer des sources de données partagées (Reporting Services en mode intégré SharePoint).

  5. Créez des planifications partagées à utiliser avec les abonnements ou le traitement de rapport sans assistance. Pour plus d'informations, consultez Procédure : créer et gérer des planifications partagées (Reporting Services en mode intégré SharePoint).

  6. Publiez des fichiers de définition de rapport (.rdl), des fichiers de source de données (.rds) et des fichiers de modèle de rapport (.smdl) dans une bibliothèque SharePoint. Vous pouvez également utiliser la commande Télécharger dans une bibliothèque SharePoint pour télécharger des fichiers .rdl et .smdl, mais pas des fichiers .rds. Selon vos autorisations, vous pouvez également créer des rapports dans le Générateur de rapports et les enregistrer dans une bibliothèque. Si les rapports incluent des références à des sources de données partagées ou à des fichiers externes, vous devez mettre à jour ces références. Pour plus d'informations, consultez Déploiement de modèles et de sources de données partagées sur un site SharePoint et Procédure : Télécharger des documents vers une bibliothèque SharePoint (Reporting Services en mode intégré SharePoint).

Lorsque vous téléchargez des rapports, assurez-vous que les propriétés de source de données du rapport sont correctes. La source de données doit avoir une chaîne de connexion valide vers une source de données externe. Le type d'informations d'identification doit être valide pour votre topologie de réseau. En particulier, si l'authentification Kerberos n'est pas activée pour votre domaine, vous ne pouvez pas utiliser le type d'informations d'identification de sécurité intégrée de Windows. À la place, vous devez spécifier des informations d'identification stockées. Après avoir vérifié que les propriétés de source de données sont correctes, vous pouvez cliquer sur le nom du rapport pour ouvrir le rapport. Le rapport s'ouvre automatiquement dans le composant WebPart de visionneuse de rapports.

Si le rapport ne s'ouvre pas, vérifiez les autorisations sur le rapport et les propriétés de source de données qui définissent une connexion à la source de données externe. Sur un site ou dans une batterie de serveurs, les autorisations SharePoint permettent de contrôler l'accès aux rapports, aux modèles de rapport, aux sources de données partagées et à l'outil Générateur de rapports utilisé pour créer des rapports appropriés. Si ces éléments ne sont pas visibles pour les utilisateurs, vous devez vérifier que les autorisations sont définies correctement.

Un serveur de rapports qui s'exécute en mode intégré SharePoint ne peut pas être géré par le biais du Gestionnaire de rapports. Pour obtenir la liste complète des fonctionnalités prises en charge et non prises en charge, consultez Fonctionnalités prises en charge par Reporting Services en mode intégré SharePoint.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur un serveur autonome

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 3.0
Considérations sur l'installation de Reporting Services
Configuration du compte d'exécution sans assistance
Configuration d'un Report Server pour la remise du courrier électronique

Autres ressources

Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint
Topologies de déploiement pour Reporting Services en mode intégré SharePoint
Planification d'un mode de déploiement
Intégration de Reporting Services et de la technologie SharePoint


Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Reporting Services utilise une base de données SQL Server pour le stockage interne. La base de données est un composant nécessaire ; elle permet de stocker les rapports publiés, les modèles, les sources de données partagées, les données de session, les ressources et les métadonnées du serveur.

Pour créer une base de données du serveur de rapports ou modifier la chaîne de connexion ou les informations d'identification, utilisez les options de la page Base de données de l'outil de configuration de Reporting Services.

Quand créer ou configurer les bases de données de serveur de rapports

Vous devez créer et configurer la base de données du serveur de rapports si vous avez installé le serveur de rapports en mode fichiers uniquement.

Si vous avez installé Reporting Services dans la configuration par défaut pour le mode natif ou le mode intégré SharePoint, la base de données du serveur de rapports a été créée et configurée automatiquement lorsque l'instance du serveur de rapports a été installée. Vous pouvez utiliser l'outil de configuration de Reporting Services pour afficher ou modifier les paramètres que le programme d'installation a configurés automatiquement.

Avant de commencer

La création ou la configuration d'une base de données de serveur de rapports est un processus comportant plusieurs étapes. Avant de créer la base de données du serveur de rapports, pensez à la façon dont vous souhaitez spécifier les éléments suivants :

Sélectionner un serveur de base de données

Reporting Services requiert une instance du Moteur de base de données SQL Server 2005 ou 2008 pour héberger la base de données du serveur de rapports. Vous pouvez utiliser un serveur local ou distant.

Vérifier les spécifications d'édition

Vérifiez que l'édition du Moteur de base de données est compatible avec l'édition du serveur de rapports que vous utilisez. Pour plus d'informations sur la compatibilité des éditions, consultez Création d'une base de données de serveur de rapports.

Activer les connexions TCP/IP

Activez les connexions TCP/IP pour le Moteur de base de données. Certaines éditions du Moteur de base de données n'activent pas TCP/IP par défaut. Les instructions sont fournies dans cette rubrique.

Ouvrir le port pour SQL Server

Pour un serveur distant, si vous utilisez le logiciel de pare-feu, vous devez ouvrir le port sur lequel le Moteur de base de données écoute.

Choisir un mode

Une base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Mode natif est la valeur par défaut. Utilisez ce mode lorsque vous souhaitez déployer Reporting Services comme serveur d'applications autonome.

Mode intégré SharePoint est utilisé lorsque vous projetez de déployer le serveur de rapports avec une instance d'un produit ou d'une technologie SharePoint. La base de données est créée lorsque vous exécutez l'Assistant, mais vous n'êtes pas en mesure d'ajouter un contenu ou d'afficher des éléments tant que vous n'avez pas ajouté le serveur de rapports à une batterie de serveurs SharePoint. Pour plus d'informations, consultez Planification d'un mode de déploiement.

Choisir les informations d'identification du serveur de rapports

Décidez comment le serveur de rapports se connectera aux bases de données de serveur de rapports. Les types d'informations d'identification incluent le compte d'utilisateur de domaine, le compte d'utilisateur de la base de données SQL Server ou le compte de service Report Server.

Ces informations d'identification sont chiffrées et stockées dans le fichier RSReportServer.config. Le serveur de rapports utilise ces informations d'identification pour les connexions continues à la base de données du serveur de rapports. Si vous souhaitez utiliser un compte d'utilisateur Windows ou un compte d'utilisateur de base de données, veillez bien à en spécifier un qui existe déjà. Bien que l'outil de configuration de Reporting Services crée une connexion et définisse les autorisations nécessaires, il ne crée pas de compte automatiquement. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

Choisir une langue du serveur de rapports

Choisissez une langue à spécifier pour le serveur de rapports. Les noms de rôle prédéfinis, les descriptions et les dossiers Mes rapports n'apparaissent pas en différentes langues lorsque les utilisateurs se connectent au serveur à l'aide de différentes versions linguistiques d'un navigateur. Pour plus d'informations sur la façon dont les ressources de langue sont utilisées dans un déploiement de serveur de rapports, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services).

Vérifier les informations d'identification pour créer et mettre en service la base de données

Vérifiez que les informations d'identification de votre compte ont l'autorisation de créer des bases de données sur l'instance du Moteur de base de données. Ces informations d'identification sont utilisées pour une connexion unique afin de créer la base de données du serveur de rapports et RSExecRole. Si une connexion n'existe pas déjà, une connexion d'utilisateur de la base de données est créée pour le compte utilisé par le serveur de rapports pour se connecter à la base de données. Vous pouvez vous connecter sous le compte Microsoft Windows avec lequel vous êtes connecté ou vous pouvez entrer une connexion de base de données SQL Server.

Pour activer l'accès à une base de données distante du serveur de rapports

  1. Si vous utilisez une instance distante du Moteur de base de données, ouvrez une session sur le serveur de base de données pour vérifier ou activer les connexions TCP/IP.

  2. Dans le menu Démarrer, pointez successivement sur Tous les programmes, Microsoft SQL Server et Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.

  3. Ouvrez Configuration du réseau SQL Server.

  4. Sélectionnez l'instance.

  5. Cliquez avec le bouton droit sur TCP/IP, puis cliquez sur Activé.

  6. Redémarrez le service.

  7. Ouvrez votre logiciel de pare-feu, ainsi que le port sur lequel SQL Server écoute. Pour l'instance par défaut, il s'agit généralement du port 1433 pour les connexions TCP/IP. Pour plus d'informations, consultez Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données.

Pour créer une base de données locale du serveur de rapports

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports pour laquelle vous créez la base de données. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

  2. Dans la page Base de données, cliquez sur Modifier la base de données.

  3. Cliquez sur Créer une base de données, puis cliquez sur Suivant.

  4. Connectez-vous à l'instance du Moteur de base de données que vous allez utiliser pour créer et héberger la base de données du serveur de rapports :

    1. Tapez l'instance du Moteur de base de données SQL Server que vous souhaitez utiliser. L'Assistant affiche un Moteur de base de données local qui s'exécute comme instance par défaut en cas de disponibilité. Sinon, vous devez entrer le serveur et l'instance à utiliser. Les instances nommées sont spécifiées dans le format suivant : <nom_ serveur>\<nom_instance>.

    2. Entrez les informations d'identification utilisées pour une connexion unique au Moteur de base de données en vue de créer les bases de données du serveur de rapports. Pour plus d'informations sur la façon dont ces informations d'identification sont utilisées, consultez Avant de commencer dans cette rubrique.

    3. Pour valider la connexion au serveur, cliquez sur Tester la connexion.

    4. Cliquez sur Suivant.

  5. Spécifiez les propriétés utilisées pour créer la base de données. Pour plus d'informations sur la façon dont ces propriétés sont utilisées, consultez Avant de commencer dans cette rubrique :

    1. Tapez le nom de la base de données du serveur de rapports. Une base de données temporaire est créée parallèlement à la base de données primaire. Pensez à utiliser un nom descriptif qui vous aidera à vous rappeler comment la base de données est utilisée. Notez que le nom que vous spécifiez sera utilisé pendant toute la durée de vie de la base de données. Vous ne pouvez pas renommer une base de données du serveur de rapports après sa création.

    2. Sélectionnez la langue dans laquelle vous souhaitez que les définitions de rôle et Mes rapports apparaissent.

    3. Sélectionnez le mode serveur. Sélectionnez toujours Mode natif à moins que vous ne projetiez de déployer le serveur de rapports avec un produit ou une technologie SharePoint.

    4. Cliquez sur Suivant.

  6. Spécifiez les informations d'identification que le serveur de rapports doit utiliser pour se connecter à la base de données du serveur de rapports.

    1. Spécifiez le type d'authentification :

      Sélectionnez Informations d'identification de la base de données pour vous connecter à l'aide d'une connexion de base de données SQL Server déjà définie. L'utilisation d'informations d'identification de base de données est recommandée si le serveur de rapports se trouve sur un ordinateur qui est dans un domaine différent, un domaine non approuvé ou derrière un pare-feu.

      Sélectionnez Informations d'identification Windows si vous avez un compte d'utilisateur de domaine avec les privilèges les plus faibles qui a l'autorisation de se connecter à l'ordinateur et au serveur de base de données.

      Sélectionnez Informations d'identification du service si vous souhaitez que le serveur de rapports se connecte à l'aide de son compte de service. Avec cette option, le serveur se connecte en utilisant la sécurité intégrée ; les informations d'identification ne sont pas chiffrées ou stockées.

    2. Cliquez sur Suivant.

  7. Examinez les informations sur la page Résumé pour vérifier que les paramètres sont corrects, puis cliquez sur Suivant.

  8. Vérifiez la connexion en cliquant sur une URL de la page URL de Report Server ou de la page URL du Gestionnaire de rapports. Les URL doivent être définies dans l'ordre pour que ce test fonctionne. Si la connexion à la base de données du serveur de rapports est valide, vous pouvez voir l'arborescence des dossiers du serveur de rapports ou le Gestionnaire de rapports dans une fenêtre de navigateur. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Référence

Configuration des comptes de service Windows
Base de données (configuration de Reporting Services)

Concepts

Configuration d'une connexion de base de données de serveur de rapports
Rubriques d'aide à la configuration de Reporting Services

Autres ressources

Administration d'une base de données du serveur de rapports
Base de données de Report Server
Configuration d'une installation de serveur de rapports
Outil de configuration de Reporting Services


Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services)

Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Utilisez l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports en mode intégré SharePoint et configurer la connexion du serveur de rapports à la base de données du serveur de rapports. Seul le serveur de rapports se connecte à la base de données du serveur de rapports. L'instance de Windows SharePoint Services ou de Office SharePoint Server que vous intégrez au serveur de rapports ne se connecte jamais à la base de données du serveur de rapports ou n'en extrait jamais directement de données.

Une base de données du serveur de rapports peut prendre en charge les opérations en mode natif ou en mode d'intégration SharePoint, mais pas les deux. Si vous créez une base de données du serveur de rapports pour prendre en charge le mode intégré SharePoint, vous ne pouvez ni convertir ni migrer la base de données pour qu'elle s'exécute ultérieurement avec une instance du serveur de rapports en mode natif. La base de données du serveur de rapports contient des métadonnées spécifiques au mode (plus spécifiquement, des informations relatives aux emplacements des éléments et aux autorisations).

Lorsqu'elle est créée en mode intégré SharePoint, la base de données du serveur de rapports contient les propriétés du serveur, des captures instantanées d'exécution de rapport, un historique des rapports, des définitions d'abonnement et des planifications. Elle contient une copie secondaire des rapports, des modèles de rapports, des sources de données partagées et des ressources afin d'améliorer les performances de traitement sur le serveur. Le stockage principal pour les documents de rapports se trouve dans les bases de données de contenu SharePoint. Pour plus d'informations, consultez Stockage et synchronisation de contenu de serveur de rapports avec des bases de données SharePoint.

Voici les principaux points à se souvenir à propos d'une base de données du serveur de rapports prenant en charge les intégrations SharePoint :

  • Utilisez l'Assistant Modification de base de données de la page Base de données de l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports en mode intégré SharePoint. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

  • Utilisez l'outil de configuration de Reporting Services pour maintenir ou mettre à jour les informations de connexion à la base de données du serveur de rapports.

  • Utilisez SQL Server Management Studio et les outils SQL Server pour sauvegarder et administrer une base de données du serveur de rapports. Les fonctionnalités de sauvegarde de base dans Administration Centrale de SharePoint 3.0 ne s'appliquent pas à une base de données du serveur de rapports.

  • La création de la base de données du serveur de rapports ne constitue qu'une étape dans un processus à plusieurs étapes qui configure un serveur de rapports pour les opérations d'intégration. Après avoir créé la base de données, effectuez les étapes d'intégration en démarrant l'administration centrale SharePoint 3.0 et en spécifiant les paramètres d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Voir aussi

Tâches

Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 3.0
Configuration d'une connexion de base de données de serveur de rapports

Autres ressources

Planification d'un mode de déploiement
Administration d'une base de données du serveur de rapports


Procédure : activer les erreurs distantes (Configuration Reporting Services)

Procédure : activer les erreurs distantes (Configuration Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Vous pouvez définir des propriétés de serveur sur un serveur de rapports de façon à retourner des informations supplémentaires concernant les conditions d'erreur qui se produisent sur des serveurs distants. Si un message d'erreur contient le texte « Pour obtenir plus d'informations sur cette erreur, accédez au serveur de rapports sur le serveur local ou activez les erreurs distantes », vous pouvez définir la propriété EnableRemoteErrors de façon à accéder à des informations supplémentaires qui peuvent vous aider à résoudre le problème.

Remarque :
Vous pouvez modifier la table ConfigurationInfo dans la base de données du serveur de rapports afin d'affecter la valeur True à EnableRemoteErrors, mais si le serveur de rapports est utilisé de manière active, vous devez utiliser SQL Server Management Studio ou un script pour modifier les paramètres.

Activer les erreurs distantes à travers SQL Server Management Studio

  1. Démarrez Management Studio et connectez-vous à une instance du serveur de rapports.

  2. Cliquez avec le bouton droit sur le nœud du serveur de rapports et sélectionnez Propriétés.

  3. Cliquez sur Avancé pour ouvrir la page de propriétés.

  4. Dans EnableRemoteErrors, sélectionnez True.

  5. Cliquez sur OK.

Activation d'erreur distantes par le biais d'un script

  1. Créez un fichier texte et copiez-y le script suivant.

    Copier le code
    Public Sub Main()
  Dim P As New [Property]()
  P.Name = "EnableRemoteErrors"
  P.Value = True
  Dim Properties(0) As [Property]
  Properties(0) = P
  Try
    rs.SetSystemProperties(Properties)
    Console.WriteLine("Remote errors enabled.")
  Catch SE As SoapException
    Console.WriteLine(SE.Detail.OuterXml)
  End Try
End Sub

  2. Enregistrez le fichier sous le nom EnableRemoteErrors.rss.

  3. Cliquez sur Démarrer, pointez sur xécuter, tapez cmd et cliquez sur OK pour ouvrir une fenêtre d'invite de commandes.

  4. Accédez au répertoire qui contient le fichier .rss que vous venez de créer.

  5. Tapez la ligne de commande suivante, en remplaçant servername par le nom de votre serveur.

    Copier le code
    rs -i EnableRemoteErrors.rss -s http://servername/ReportServer

Voir aussi

Autres ressources

Report Server System Properties
Procédure : se connecter à un serveur de rapports dans Management Studio
Report Server System Properties
Propriétés du serveur (page Avancé) - Reporting Services


Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports. |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez un serveur de rapports pour qu'il s'exécute en mode intégré SharePoint dans une batterie de serveurs SharePoint qui consiste en plusieurs serveurs, vous devez installer l'application Web frontale d'un produit ou d'une technologie SharePoint sur le serveur de rapports afin de pouvoir joindre le serveur de rapports à la batterie.

Une batterie de serveurs SharePoint consiste en plusieurs serveurs qui utilisent tous la même version du produit ou de la technologie SharePoint. Si la batterie de serveurs utilise Windows SharePoint Services 3.0, vous devez installer Windows SharePoint Services 3.0 sur le serveur de rapports. Si la batterie de serveurs utilise la batterie MicrosoftOfficeSharePoint Portal Server, vous devez installer un SharePoint Portal ServerOffice.

Pour installer le frontal Web, vous devez être un administrateur d'une batterie de serveurs SharePoint. Vous devez également connaître le nom du serveur de base de données et la base de données de configuration utilisée par la batterie de serveurs.

Les étapes suivantes ne sont requises que si vous déployez un serveur de rapports dans une batterie de serveurs SharePoint. Si toutes les applications serveur s'exécutent sur un seul ordinateur, l'installation du Web frontal sur le serveur de rapports n'est pas nécessaire.

Après avoir installé le Web frontal et joint le serveur de rapports à la batterie, vous pouvez utiliser l'administration centrale de SharePoint 3.0 pour désactiver les fonctionnalités du Web frontal dont vous n'avez pas besoin.

Pour installer le Web frontal

  1. Sur le serveur qui exécute Reporting Services, exécutez le programme d'installation pour le produit ou la technologie SharePoint utilisé pour la batterie.

  2. Dans Types d'installation, cliquez sur Avancée.

  3. Dans Type de serveur, sélectionnez Frontal Web.

  4. L'onglet Emplacement des données spécifie l'emplacement des fichiers d'index de recherche. Sur Emplacement des données, utilisez la valeur par défaut ou choisissez un ordinateur qui possède un espace disque supplémentaire.

  5. Cliquez sur Installer maintenant.

Après avoir fini l'Installation, vous devez configurer le Web frontal pour le joindre à la batterie de serveurs.

Pour configurer le Web frontal

  1. Exécutez l'Assistant Configuration des produits et technologies SharePoint pour joindre le frontal Web à la batterie de serveurs SharePoint distante. L'Assistant Configuration d'un produit ou d'une technologie SharePoint doit démarrer après que l'installation est terminée. Si tel n'est pas le cas, démarrez-le à partir des Outils d'administration.

  2. Dans l'écran de bienvenue, cliquez sur Suivant.

  3. Cliquez Oui pour redémarrer les services si besoin est.

  4. Dans la page Se connecter à une batterie de serveurs, sélectionnez Oui pour vous connecter à une batterie de serveurs existante. Cliquez sur Suivant.

  5. Dans la page Spécifier les paramètres de la base de données de configuration, spécifiez l'instance SQL Server Moteur de base de données qui héberge la base de données de configuration. Si vous ne connaissez pas le nom de la base de données de configuration, cliquez sur Récupérer les noms de bases de données, puis sélectionnez la base de données de configuration.

  6. Entrez un nom d'utilisateur et un mot de passe que le frontal Web utilisera pour se connecter à la base de données de configuration. Cliquez sur Suivant.

  7. Dans la page Fin de l'Assistant Configuration des produits et technologies SharePoint, cliquez sur Paramètres avancés.

  8. Dans Paramètres avancés, vérifiez que l'option Ne pas utiliser cet ordinateur pour héberger le site Web est sélectionnée.

  9. Cliquez sur OK, sur Suivant, puis terminez l'Assistant.

L'installation du frontal Web n'est qu'une étape dans le processus global de configuration. Pour plus d'informations sur la procédure complète, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Pour plus d'informations sur la configuration d'un déploiement multi-serveur qui intègre Reporting Services et les produits et technologies SharePoint, consultez Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Concepts

Procédure : installer ou désinstaller le complément Reporting Services
Configuration de Reporting Services pour l'intégration de SharePoint 3.0

Autres ressources

Intégration de Reporting Services et de la technologie SharePoint
Planification d'un mode de déploiement
Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint


Procédure : installer ou désinstaller le complément Reporting Services

Procédure : installer ou désinstaller le complément Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Le Complément Microsoft SQL Server 2008 Reporting Services pour Microsoft SharePoint Technologies correspond à un téléchargement Web que vous pouvez installer sur un serveur doté d'une instance d'un produit ou d'une technologie SharePoint. Il fournit un ensemble de fonctionnalités qui vous permettent d'exécuter un serveur de rapports au sein d'un déploiement plus étendu de Microsoft Windows SharePoint Services 3.0 ou Microsoft Office SharePoint Server 2007. Ces fonctionnalités incluent un composant WebPart visionneuse de rapports, un point de terminaison de proxy d'URL et des pages d'application qui vous permettent de créer, d'afficher et de gérer des rapports, des modèles de rapport et tout autre contenu du serveur de rapports sur un site SharePoint. Le complément Reporting Services pour SharePoint Technologies est un composant requis pour un serveur de rapports qui s'exécute en mode intégré SharePoint.

Un déploiement de Reporting Services est intégré dans un déploiement d'un produit ou d'une technologie SharePoint au niveau de la batterie de serveurs. Si vous possédez plusieurs applications Web SharePoint dans une configuration de batterie de serveurs, vous devez installer le complément Reporting Services sur chaque ordinateur qui possède un frontal Web. Après avoir installé le complément sur chaque ordinateur, démarrez l'administration centrale pour configurer l'intégration du serveur de rapports pour tous les serveurs de la batterie de serveurs.

Préparation de l'installation

L'installation du complément Reporting Services est l'une des nombreuses étapes nécessaires pour intégrer un serveur de rapports avec une instance d'un produit ou d'une technologie SharePoint. Pour plus d'informations sur la procédure complète, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0. L'ordre des étapes de configuration des serveurs est important. Pour obtenir les meilleurs résultats possibles, prenez soin de les exécuter dans l'ordre.

Pour préparer l'installation du complément Reporting Services :

  1. Ouvrez une session en tant qu'administrateur d'une batterie de serveurs SharePoint pour installer le complément Reporting Services.

  2. Vérifiez que vous disposez de deux installations de serveur – un serveur de rapports et un serveur SharePoint – qui répondent aux conditions requises pour le fonctionnement intégré. Pour plus d'informations, consultez Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint.

  3. Téléchargez le complément Reporting Services sur un serveur doté d'une instance du produit ou de la technologie SharePoint.

    1. Accédez à la page Complément SQL Server 2005 Reporting Services pour SharePoint Technologies du Centre de téléchargement Microsoft.

    2. Sélectionnez la version linguistique à installer. Le composant WebPart visionneuse de rapports (ReportViewer.dwp) sera disponible uniquement dans la langue que vous choisissez. Les pages et messages d'application seront disponibles dans toutes les langues prises en charge, quelle que soit la langue que vous sélectionnez dans la page Téléchargement. Pour plus d'informations sur les langues prises en charge, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services).

    3. Dans la section Fichiers composant ce téléchargement, cliquez sur Télécharger pour installer le fichier SharepointRS.msi.

  4. Si vous intégrez Reporting Services à une batterie de serveurs SharePoint qui possède plusieurs applications Web frontales, copiez ou téléchargez le fichier SharepointRS.msi sur chaque ordinateur de la batterie de serveurs qui possède un serveur Web frontal. Effectuez cette opération uniquement pour les serveurs Web frontaux qui seront utilisés pour accéder à du contenu de serveur de rapports.

Procédure d'installation du complément Reporting Services à l'aide de l'Assistant Installation

Exécutez SharepointRS.msi sur un ordinateur qui possède le frontal Web pour un déploiement du produit ou de la technologie SharePoint pour lequel vous souhaitez configurer l'intégration du serveur de rapports. Vous pouvez utiliser l'Assistant Installation pour installer le complément Reporting Services ou exécuter le programme d'installation à partir de la ligne de commande et spécifier des arguments de ligne de commande pour une installation en mode fichiers uniquement.

Le programme d'installation ne configure pas le serveur pour l'intégration avec Reporting Services. Vous devez configurer l'intégration une fois l'installation terminée. Le programme d'installation utilise l'arborescence existante du déploiement actuel et crée un dossier pour les fichiers d'application du complément Reporting Services.

  1. Naviguez jusqu'au dossier qui contient SharePointRS.msi.

  2. Double-cliquez sur SharePointRS.msi pour exécuter l'Assistant Installation. L'Assistant affiche une page d'accueil, le contrat de licence et une page d'information relative à l'inscription.

  3. Cliquez sur Installer pour exécuter le programme d'installation.

  4. Une fois l'installation terminée, accédez aux outils d'administration et cliquez sur Administration centrale de SharePoint 3.0.

  5. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Pour obtenir des instructions sur la spécification de ces paramètres, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Procédure d'installation du complément Reporting Services en mode fichiers uniquement

Vous pouvez installer le complément Reporting Services en mode fichiers uniquement si vous avez rencontré des erreurs pendant une installation normale. En mode fichiers uniquement, le programme d'installation exécute l'Assistant Installation pour copier les fichiers d'application sur votre ordinateur. Une fois les fichiers copiés, vous devez exécuter des actions personnalisées pour achever l'installation.

  1. Exécutez SharePointRS.msi SKIPCA=1.

  2. Recherchez le fichier rsCustomAction.exe dans le système de fichiers. Ce fichier est copié sur votre ordinateur par le programme d'installation. Il se trouve dans le répertoire %Temp%.

    Pour obtenir les informations relatives au chemin d'accès à ce fichier, cliquez sur Démarrer, sur Exécuter, puis tapez %temp%. Le fichier doit se trouver dans \Documents and Settings\<votre_nom>\LOCALS~1\Temp.

  3. Ouvrez une fenêtre d'invite de commandes. Pour cela, cliquez sur Démarrer, sur Exécuter, puis tapez cmd.

  4. Naviguez jusqu'au dossier contenant l'exécutable rsCustomAction.

  5. Entrez la commande suivante :

    Copier le code
    rsCustomAction.exe /i
    Cette étape de configuration nécessitera plusieurs minutes. Le service W3SVC sera redémarré pendant ce processus.

  6. Une fois l'installation terminée, accédez aux outils d'administration et cliquez sur Administration centrale de SharePoint 3.0.

  7. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Pour obtenir des instructions sur la spécification de ces paramètres, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Procédure de suppression du complément Reporting Services

Vous pouvez désinstaller le complément Reporting Services pour SharePoint Technologies en exécutant le programme d'installation (SharepointRS.msi) en mode de désinstallation. La désinstallation du complément entraîne la suppression des fonctionnalités d'intégration utilisées pour traiter les rapports et les modèles sur un serveur de rapports.

Pour désinstaller le complément Reporting Services, une installation Windows SharePoint Services ou Office SharePoint Server 2007 doit être en cours d'exécution. Si vous désinstallez d'abord les produits ou technologies SharePoint, vous devez les réinstaller pour pouvoir désinstaller le complément Reporting Services.

  1. Sur le site SharePoint, supprimez tous les rapports et autres éléments de serveur de rapports que vous n'utilisez plus. Ils ne s'exécuteront plus une fois le complément Reporting Services supprimé.

  2. Dans le Panneau de configuration, dans Ajout/Suppression de programmes, sélectionnez Complément Microsoft SQL Server 2005 Reporting Services pour Microsoft SharePoint Technologies.

Cliquez sur Supprimer.

Les étapes de désinstallation du complément sont identiques pour les serveurs autonomes et les batteries de serveurs. Le programme d'installation supprimera les fichiers de programme et tous les paramètres de configuration qui ont été ajoutés durant l'installation.

Les éléments suivants ne seront pas supprimés :

  • Les comptes de connexion créés pour le compte de service Report Server qui étaient utilisés pour accéder aux bases de données de contenu et de configuration SharePoint. Vous devez supprimer les comptes de connexion pour le compte de service Report Server à partir de l'instance du Moteur de base de données SQL Server utilisée pour héberger les bases de données SharePoint.

  • Autorisations ou groupes créées pour les utilisateurs de rapports. Si vous avez créé des groupes SharePoint ou des niveaux d'autorisation personnalisés pour accorder l'accès aux fonctionnalités du serveur de rapports, vous devez révoquer toutes les autorisations qui ne sont plus nécessaires.

  • Fichiers de données que vous avez téléchargés vers une bibliothèque SharePoint, y compris les fichiers de définition de rapport (.rdl), de modèle de rapport (.smdl) et de source de données partagée (.rsds). Ces fichiers ne seront pas supprimés mais ils ne s'exécuteront plus. Vous devez les supprimer manuellement.

  • Le programme d'installation ne supprimera pas la base de données du serveur de rapports et ne modifiera pas l'instance du serveur de rapports utilisée pour les opérations intégrées. Après avoir désinstallé le complément, vous pouvez exécuter le serveur de rapports en mode natif si vous souhaitez utiliser l'instance comme application de création de rapports autonome.

Procédure d'exécution de SharePointRS.msi à partir de la ligne de commande

Vous pouvez exécuter le programme d'installation à partir de la ligne de commande pour réparer ou désinstaller le complément Reporting Services.

  • Exécutez SharePointRS.msi -r pour réparer une installation existante.

  • Exécutez SharePointRS.msi -u pour désinstaller une installation existante du complément.

Fichiers journaux d'installation

Lors de son exécution, le programme d'installation enregistre des informations dans un fichier journal, dans le dossier %temp% de l'utilisateur qui installe le complément Reporting Services. Le nom de ce fichier est RS_SP_<numéro>.log. Chaque erreur consignée dans ce journal commence par la chaîne « SSRSCustomActionError ».

Voir aussi

Tâches

Procédure : basculer entre les modes serveur (configuration de Reporting Services)
Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 3.0

Autres ressources

Affichage et gestion d'éléments de serveur de rapports à partir d'un site SharePoint
Planification d'un mode de déploiement
Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint
Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint
Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint


Procédure : inscrire un nom principal de service (SPN) pour Report Server

Procédure : inscrire un nom principal de service (SPN) pour Report Server |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous déployez Reporting Services dans un réseau qui utilise le protocole Kerberos pour l'authentification mutuelle, vous devez créer un nom principal de service (SPN) pour le service Report Server si vous le configurez pour s'exécuter en tant que compte d'utilisateur de domaine. De plus, lorsque vous configurez un utilisateur de domaine en tant que compte de service, le serveur de rapports doit être configuré de manière à utiliser l'authentification NTLM.

À propos des noms principaux de service

Un nom principal de service est un identificateur unique pour un service sur un réseau qui utilise l'authentification Kerberos. Il est composé d'une classe de service, d'un nom d'hôte et d'un port. Sur un réseau qui utilise l'authentification Kerberos, un nom principal de service pour le serveur doit être inscrit sous un compte d'ordinateur prédéfini (tel que NetworkService ou LocalSystem) ou un compte d'utilisateur. Les noms principaux de service sont enregistrés automatiquement pour les comptes intégrés. Toutefois, lorsque vous exécutez un service sous un compte d'utilisateur de domaine, vous devez inscrire manuellement le nom principal de service pour le compte que vous souhaitez utiliser.

Pour créer un nom principal de service, vous pouvez utiliser l'utilitaire de ligne de commande SetSPN. Pour plus d'informations, consultez Setspn sur Microsoft Windows Server TechCenter.

Vous devez être administrateur de domaine pour exécuter l'utilitaire sur le contrôleur de domaine.

Syntaxe

La syntaxe de commande pour utiliser l'utilitaire SetSPN en vue de créer un SPN pour le serveur de rapports ressemble à ce qui suit :

Copier le code
Setspn -a http/<computername>.<domainname>:<port> <domain-user-account>

SetSPN est disponible avec le pack d'outils de support Windows Server 2003 Service Pack 1, que vous devez télécharger séparément. L'argument -a est utilisé pour inscrire un nom principal de service auprès d'un compte particulier.

HTTP est la classe de service. Le service Web Report Server s'exécute dans HTTP.SYS. L'une des conséquences de la création d'un nom principal de service pour HTTP est que des tickets seront accordés à toutes les applications Web sur le même ordinateur qui s'exécutent dans HTTP.SYS (y compris les applications hébergées dans les services Internet (IIS)) en fonction du compte d'utilisateur de domaine. Si ces services s'exécutent sous un compte différent, les demandes d'authentification échouent. Pour éviter ce problème, assurez-vous de configurer toutes les applications HTTP pour qu'elles s'exécutent sous le même compte ou envisagez la création d'en-têtes d'hôtes pour chaque application puis la création de noms principaux de service distincts pour chaque en-tête d'hôte. Lorsque vous configurez des en-tête de l'hôte, les modifications de DNS sont requises indépendamment de la configuration Reporting Services.

Les valeurs que vous spécifiez pour <nom_ordinateur>, <nom_domaine> et <port> identifient l'adresse réseau unique de l'ordinateur qui héberge le serveur de rapports. Ce peut être un nom d'hôte local ou un nom de domaine complet (FQDN). Si vous n'avez qu'un seul domaine et que vous utilisez le port 80, vous pouvez omettre <nom_domaine> et <port> de votre ligne de commande. <compte_utilisateur_domaine> est le compte d'utilisateur qu'exécute le service Report Server et pour lequel le nom principal de service (SPN) est inscrit.

Inscrire un nom principal de service pour un compte d'utilisateur de domaine

Pour inscrire un nom principal de service pour un service Report Server qui s'exécute en tant qu'utilisateur de domaine

  1. Installez Reporting Services et configurez le service Report Server pour qu'il s'exécute en tant que compte d'utilisateur de domaine. Notez que les utilisateurs ne seront pas en mesure de se connecter au serveur de rapports tant que vous n'aurez pas terminé les étapes suivantes.

  2. Téléchargez et installez les Outils de support de Windows Server 2003 Service Pack 1 à partir du Centre de téléchargement.

  3. Ouvrez une session sur le contrôleur de domaine en tant qu'administrateur de domaine.

  4. Ouvrez une fenêtre d'invite de commandes.

  5. Copiez la commande suivante, en remplaçant les valeurs d'espaces réservés par des valeurs réelles valides pour votre réseau :

    Copier le code
    Setspn -a http/<computer-name>.<domain-name>:<port> <domain-user-account>

  6. Exécutez la commande.

  7. Ouvrez le fichier RsReportServer.config et recherchez la section <AuthenticationTypes>. Ajoutez <RSWindowsNegotiate/> comme première entrée de cette section pour activer NTLM.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services

Concepts

Configuration du compte de service Report Server
Rubriques d'aide à la configuration de Reporting Services
Considérations sur l'installation de Reporting Services

Autres ressources

Planification des services, des comptes et des connexions


Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Procédure : basculer entre les modes serveur (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous avez configuré un serveur de rapports pour qu'il s'exécute en mode intégré SharePoint, vous pouvez détacher le serveur de rapports d'un déploiement d'une instance de technologie SharePoint en basculant le serveur en mode natif.

Pour basculer entre les modes, vous devez pointer le serveur sur une base de données de serveur de rapports en mode natif. Il n'est pas nécessaire de réinstaller le serveur de rapports pour passer d'un mode à l'autre.

Bien que vous puissiez changer de mode pour le serveur de rapports, vous ne pouvez pas changer de mode pour la base de données du serveur de rapports. Une base de données de serveur de rapports contient des données spécifiques au mode qui ne sont pas utilisables dans un contexte différent. Si vous avez créé une base de données de serveur de rapports en mode intégré SharePoint, vous ne pouvez pas l'utiliser avec un serveur de rapports en mode natif.

Trois méthodes permettent de passer du mode intégré SharePoint au mode natif. Dans l'outil de configuration de Reporting Services, dans la page Installation de la base de données, effectuez l'une des opérations suivantes :

  • Cliquez sur Modifier et créez une nouvelle base de données.

  • Dans la liste des bases de données existantes, sélectionnez une base de données de serveur de rapports existante qui s'exécute déjà en mode natif, spécifiez les informations d'identification et cliquez sur Appliquer.

  • Cliquez sur Nouveau et créez une nouvelle base de données. Assurez-vous de désactiver la case à cocher Utiliser le schéma qui prend en charge le mode intégré SharePoint.

Cette rubrique fournit la procédure correspondant à la première approche. Pour plus d'informations sur la manière de configurer un serveur de rapports en mode natif pour qu'il s'exécute en mode intégré à SharePoint, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

Pour passer au mode natif

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, puis sur Outils de configuration.

  2. Cliquez sur Configuration de Reporting Services. La boîte de dialogue Sélection de l'instance d'installation de Report Server s'affiche pour que vous puissiez spécifier l'instance de serveur de rapports à configurer.

  3. Dans Nom de l'ordinateur, spécifiez le nom de l'ordinateur sur lequel est installée l'instance de serveur de rapports. Le nom de l'ordinateur local est spécifié par défaut, mais vous pouvez également taper le nom d'une instance de SQL Server distante.

  4. Dans Nom de l'instance, choisissez l'instance de SQL Server Reporting Services que vous souhaitez configurer.

  5. Cliquez sur Connexion.

  6. Cliquez sur Installation de la base de données pour afficher la page Installation de la base de données. Cette page contient des informations sur la base de données actuellement utilisée. Mode serveur doit avoir la valeur Intégré à SharePoint.

  7. Cliquez sur Modifier.

  8. Cliquez sur OK pour confirmer la création d'une nouvelle base de données.

  9. Dans la boîte de dialogue Connexion SQL Server, entrez un nom pour la nouvelle base de données.

  10. Vérifiez que la case à cocher Créez la base de données de serveur de rapports en mode intégré à SharePoint est désactivée.

  11. Cliquez sur OK.

  12. Dans la page Installation de la base de données, spécifiez les informations d'identification utilisées pour la connexion à la base de données du serveur de rapports.

    1. Choisissez Informations d'identification du service pour utiliser le compte de service Windows et le compte de service Web pour vous connecter par le biais de la sécurité intégrée.

    2. Choisissez Informations d'identification Windows pour spécifier un compte d'utilisateur de domaine. Un compte d'utilisateur de domaine doit être spécifié sous la forme <domaine>\<utilisateur>.

    3. Choisissez Informations d'identification SQL Server pour spécifier un compte de connexion SQL Server.

  13. Cliquez sur Appliquer.

Lorsque vous basculez d'un serveur de rapports en mode intégré SharePoint vers le mode natif, l'emplacement du contenu et les autorisations utilisées pour contrôler l'accès au contenu sont redéfinis. Le contenu doit être republié sur le serveur de rapports, vous devez attribuer des rôles sur le serveur de rapports qui accorde l'accès aux éléments et aux opérations, et vous devez redéfinir les abonnements et les opérations planifiées. L'historique de rapport que vous avez créé sur le serveur de rapports qui s'exécutait en mode intégré SharePoint ne peut pas être recréé sur un serveur de rapports en mode natif.

Voir aussi

Tâches

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 3.0
Procédure : installer ou désinstaller le complément Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services)

Autres ressources

Planification d'un mode de déploiement


Procédure : activer ou désactiver les fonctionnalités Reporting Services

Procédure : activer ou désactiver les fonctionnalités Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Vous pouvez désactiver les fonctionnalités de serveur de rapports que vous n'utilisez pas dans le cadre d'une stratégie de verrouillage pour réduire l'exposition aux attaques d'un serveur de rapports de production. Dans la plupart des cas, vous préférerez exécuter les fonctionnalités de Reporting Services conjointement afin de bénéficier de toutes les fonctionnalités offertes dans Reporting Services. Toutefois, vous pouvez désactiver les fonctionnalités dont vous n'avez pas besoin, selon votre modèle de déploiement. Par exemple, vous pouvez activer le traitement en arrière-plan uniquement si le traitement de tous les rapports a été planifié. De même, vous pouvez exécuter simplement le service Web Report Server si vous souhaitez disposer uniquement de rapports interactifs à la demande.

Les procédures passées en revue dans cette rubrique vous indiquent comment désactiver des fonctionnalités Reporting Services. Les fonctionnalités peuvent être configurées de différentes façons, par exemple en modifiant directement le fichier RsReportServer.config ou en utilisant la facette Configuration de la surface d'exposition pour Reporting Services de Gestion basée sur des stratégies dans SQL Server Management Studio. Utilisez les liens pour localiser les procédures qui expliquent comment activer ou désactiver une fonctionnalité :

  • Service Web Report Server

  • Traitement et événements planifiés

  • Gestionnaire de rapports

  • Générateur de rapports

  • Sécurité intégrée de Windows pour les sources de données de rapports

Service Web Report Server

Pour activer le service Web Report Server en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour plus d'informations, consultez Procédure : modifier un fichier de configuration Reporting Services.

  2. Pour activer le service Web Report Server, affectez à IsWebServiceEnabled la valeur true :

    Copier le code
    <IsWebServiceEnabled>true</IsWebServiceEnabled>

  3. Pour désactiver le service Web Report Server, affectez à IsWebServiceEnabled la valeur false :

    Copier le code
    <IsWebServiceEnabled>false</IsWebServiceEnabled>

  4. Enregistrez vos modifications et fermez le fichier.

Pour activer ou désactiver le service Web Report Server en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer le service Web Report Server, affectez à WebServiceAndHTTPAccessEnabled la valeur True.

    • Pour désactiver le service Web Report Server, affectez à WebServiceAndHTTPAccessEnabled la valeur False.

  5. Cliquez sur OK.

Événements planifiés et remise

Pour activer ou désactiver les événements planifiés et la remise en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour plus d'informations, consultez Procédure : modifier un fichier de configuration Reporting Services.

  2. Pour activer le traitement et la remise des rapports planifiés, affectez à IsSchedulingService, IsNotificationService et IsEventService la valeur true :

    Copier le code
    <IsSchedulingService>true<\IsSchedulingService>
<IsNotificationService>true<\IsNotificationService>
<IsEventService>true<\IsEventService>

  3. Pour désactiver le traitement et la remise des rapports planifiés, affectez la à IsSchedulingService, IsNotificationService et IsEventService la valeur false :

    Copier le code
    <IsSchedulingService>false<\IsSchedulingService>
<IsNotificationService>false<\IsNotificationService>
<IsEventService>false<\IsEventService>

  4. Enregistrez vos modifications et fermez le fichier.
Remarque :
Vous ne pouvez pas désactiver complètement le traitement en arrière-plan car il fournit des fonctionnalités de maintenance de base de données requises pour les opérations de serveur.

Pour activer ou désactiver les événements planifiés et leur remise en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer les événements planifiés et leur remise, affectez à ScheduleEventsAndReportDeliveryEnabled la valeur True.

    • Pour désactiver les événements planifiés et leur remise, affectez à ScheduleEventsAndReportDeliveryEnabled la valeur False.

  5. Cliquez sur OK.

Remarque :
Vous ne pouvez pas désactiver complètement le traitement en arrière-plan car il fournit des fonctionnalités de maintenance de base de données requises pour les opérations de serveur.

Gestionnaire de rapports

Pour activer ou désactiver le Gestionnaire de rapports en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour obtenir des instructions, consultez Procédure : modifier un fichier de configuration Reporting Services.

  2. Pour activer le Gestionnaire de rapports, affectez à IsReportManagerEnabled la valeur true:

    Copier le code
    <IsReportManagerEnabled>true<\IsReportManagerEnabled>

  3. Pour désactiver le Gestionnaire de rapports, affectez à IsReportManagerEnabled la valeur false:

    Copier le code
    <IsReportManagerEnabled>false<\IsReportManagerEnabled>

  4. Enregistrez vos modifications et fermez le fichier.

Pour activer ou désactiver le Gestionnaire de rapports en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer le Gestionnaire de rapports, affectez à ReportManagerEnabled la valeur True.

    • Pour désactiver le Gestionnaire de rapports, affectez à ReportManagerEnabled la valeur False.

  5. Cliquez sur OK.

Générateur de rapports

Pour activer ou désactiver le Générateur de rapports en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés du serveur, sous Sélectionner une page, cliquez sur Sécurité.

    • Pour activer le Générateur de rapports, sélectionnez l'option Activer les exécutions de rapports ad hoc.

    • Pour désactiver le Générateur de rapports, désélectionnez l'option Activer les exécutions de rapports ad hoc.

  4. Cliquez sur OK.

Sécurité intégrée de Windows

Pour activer ou désactiver la sécurité intégrée de Windows en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés du serveur, sous Sélectionner une page, cliquez sur Sécurité.

    • Pour activer la sécurité intégrée de Windows, sélectionnez l'option Activer la sécurité intégrée Windows pour les sources de données de rapport.

    • Pour désactiver la sécurité intégrée de Windows, désélectionnez l'option Activer la sécurité intégrée Windows pour les sources de données de rapport.

  4. Cliquez sur OK.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Autres ressources

Fichier de configuration RSReportServer
Architecture des composants
Composants et outils de Reporting Services
Architecture du service (Reporting Services)
Présentation de SQL Server Management Studio
Administration de serveurs à l'aide de la Gestion basée sur des stratégies


Rubriques d'aide F1 sur la configuration de Reporting Services

Rubriques d'aide F1 sur la configuration de Reporting Services |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services >

Cette section décrit l'aide accessible par la touche F1 de l'outil Configuration de Reporting Services.

Dans cette section

  • Se connecter à un serveur de rapports

  • État de Report Server

  • Compte de service

  • URL du service Web

  • Configuration avancée de plusieurs sites Web

  • Base de données

  • Assistant Modification de base de données

  • Assistant Modifier les informations d'identification

  • URL du Gestionnaire de rapports

  • Paramètres de messagerie

  • Compte d'exécution

  • Clés de chiffrement

  • Sauvegarder la clé de chiffrement

  • Restaurer la clé de chiffrement

  • Déploiement avec montée en puissance parallèle

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Autres ressources

Outil de configuration de Reporting Services
Configuration d'une installation de serveur de rapports


Se connecter à un serveur de rapports (outil de configuration de Reporting Services)

Se connecter à un serveur de rapports (outil de configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette boîte de dialogue pour vous connecter à une instance du serveur de rapports SQL Server 2008 Reporting Services locale ou distante. Vous ne pouvez pas utiliser cet outil pour vous connecter aux versions antérieures de serveurs de rapports Reporting Services. Vous ne pouvez vous connecter qu'à une instance à la fois.

  • Pour vous connecter à une instance locale du serveur de rapports, utilisez les valeurs par défaut et cliquez sur Se connecter. L'outil de configuration de Reporting Services fournit le nom du serveur local et détecte l'instance par défaut. Dans la plupart des cas, vous pouvez cliquer sur Se connecter sans avoir à modifier les valeurs. Si vous avez installé plusieurs instances, vous devez sélectionner celle que vous souhaitez utiliser.

  • Pour vous connecter à une instance de serveur de rapports distante, tapez le nom du serveur, cliquez sur Rechercher, sélectionnez l'instance, puis cliquez sur Se connecter.

Pour ouvrir cette boîte de dialogue, démarrez l'outil de configuration de Reporting Services. Cette boîte de dialogue apparaît immédiatement lorsque vous démarrez l'outil. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Nom du serveur

Entrez le nom de réseau de l'ordinateur sur lequel SQL Server 2008 Reporting Services est installé. Tapez simplement le nom de l'ordinateur, sans inclure de préfixe ou de barre oblique.

Rechercher

Recherchez l'ordinateur spécifié dans Nom du serveur.

Instance du serveur de rapports

Sélectionnez l'instance à laquelle se connecter si plusieurs instances de serveur de rapports sont installées. Seules les instances valides sont disponibles pour la sélection. Si vous exécutez côte à côte des versions antérieures de Reporting Services et une instance SQL Server, ces instances n'apparaîtront pas dans la liste.

Se connecter

Connectez-vous au serveur et à l'instance que vous avez spécifiés.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Concepts

Utilisation de plusieurs versions et instances de SQL Server

Autres ressources

Outil de configuration de Reporting Services


État de Report Server (configuration de Reporting Services)

État de Report Server (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour afficher les informations sur l'instance du serveur de rapports à laquelle vous êtes connecté. Cette page est la page de démarrage pour la configuration du serveur de rapports. Des pages supplémentaires sont disponibles pour configurer les URL, le compte de service, la base de données du serveur de rapports, la remise des messages électroniques du serveur de rapports, le déploiement avec montée en puissance parallèle et les clés de chiffrement.

Pour ouvrir la page, démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Si vous vous connectez au serveur de rapports et que tous les liens de page sont grisés, vérifiez que le service Report Server est démarré. Vous pouvez utiliser l'application de console Services dans les Outils d'administration pour vérifier l'état du service.

Options

Instance SQL Server

Affiche les informations sur l'instance du serveur de rapports à laquelle vous êtes connecté. Les noms des instances du serveur de rapports sont basés sur les instances nommées de SQL Server. L'instance par défaut est MSSQLSERVER. Une instance nommée correspond à une valeur que vous avez spécifiée pendant l'installation. Pour plus d'informations sur les instances, consultez Utilisation de plusieurs versions et instances de SQL Server.

Remarque :
Dans SQL Server Express with Advanced Services, l'instance par défaut est SQLExpress.

ID de l'instance

Correspond à un dossier sur le système de fichiers contenant les fichiers programme de l'instance SQL Server à laquelle vous êtes connecté. La valeur ID d'instance est affectée par le programme d'installation au format composant.instance, où composant est une valeur qui représente un composant SQL Server et instance un nom d'instance. MSSQLSERVER est le nom de l'instance par défaut. Par exemple, si vous installez des instances par défaut des composants Moteur de base de données, Analysis Services et Reporting Services, les noms de dossiers correspondants sont MSSQL10.MSSQLSERVER, MSAS10.MSSQLSERVER et MSRS10.MSSQLSERVER, respectivement. Si vous installez une deuxième instance d'un composant que vous avez déjà installé, tel que le Moteur de base de données, et que vous nommez l'instance Contoso, l'ID d'instance est MSSQL10.Contoso.

Édition

Affiche les informations sur l'édition. Reporting Services est disponible dans les éditions Workgroup, Developer, Evaluation, Standard et Enterprise de SQL Server Express with Advanced Services.

Version du produit

Affiche la version de Reporting Services que vous avez installée.

Base de données du serveur de rapports

Affiche le nom de la base de données du serveur de rapports qui stocke les données d'application pour l'instance du serveur de rapports en cours.

Mode du serveur de rapports

Indique si le serveur de rapports est déployé en mode natif ou en mode intégré SharePoint. Cette valeur est définie sur Mode intégré SharePoint si la base de données du serveur de rapports a été créée à l'aide d'un schéma qui prend en charge ce mode d'opération. Pour plus d'informations sur les modes de déploiement, consultez Planification d'un mode de déploiement. Pour plus d'informations sur toutes les étapes requises pour configurer des opérations intégrées, consultez Configuration de Reporting Services pour l'intégration de SharePoint 3.0.

État de serveur

Indique si le service Report Server est en cours d'exécution.

Démarrer

Démarre le service Report Server. Le redémarrage du service est nécessaire après certains changements de configuration (par exemple, lors de la reconfiguration d'un serveur de rapports après un changement du nom de l'ordinateur). Si vous reconfigurez les réservations d'URL, le service redémarrera automatiquement. Le redémarrage est nécessaire pour prendre en compte les modifications.

Arrêter

Arrête le service Report Server. L'arrêt du service provoque l'arrêt du serveur de rapports. Pour plus d'informations, consultez Démarrage et arrêt du service Report Server.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Initialisation d'un serveur de rapports

Autres ressources

Architecture du service (Reporting Services)
Configuration d'une installation de serveur de rapports
Démarrage et arrêt du service Report Server


Compte de service (configuration de Reporting Services)

Compte de service (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Compte de service pour spécifier le compte sous lequel le service Report Server est exécuté. Ce compte est au départ configuré pendant l'installation. Vous pouvez le modifier si vous souhaitez modifier le compte ou le mot de passe. Le service Web Report Server, le Gestionnaire de rapports et l'application de traitement en arrière-plan s'exécutent tous sous l'identité du service que vous spécifiez dans cette page.

Le compte que vous spécifiez pour le service Report Server requiert une autorisation pour accéder au Registre, aux fichiers programme de serveur de rapports et à la base de données du serveur de rapports. Toutes les autorisations sont configurées automatiquement pour le compte lorsque vous utilisez l'outil de configuration de Reporting Services pour définir le compte. Si vous utilisez le compte de service pour vous connecter à la base de données du serveur de rapports, l'outil crée une connexion de base de données pour le compte et configure des autorisations de base de données en assignant le compte au RSExecRole sur l'instance SQL Server qui héberge la base de données du serveur de rapports. La base de données du serveur de rapports est le seul magasin de données dans lequel un serveur de rapports écrit. Le compte de service ne requiert pas d'autorisations à d'autres magasins de données.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez le lien dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Important :
Lorsque vous devez mettre à jour le compte ou le mot de passe, il est vivement recommandé d'utiliser l'outil de configuration de Reporting Services. L'utilisation de cet outil pour mettre à jour le compte garantit que les autres paramètres internes qui dépendent de l'identité de service sont mis à jour automatiquement en même temps.

Options

Utiliser un compte intégré

Sélectionnez Service réseau, Système Local ou Service local dans la liste. Seul Service réseau est recommandé ; toutefois, vous pouvez configurer le compte de façon à utiliser tout compte disponible.

Utiliser un autre compte

Sélectionnez cette option pour spécifier un compte d'utilisateur Windows. Vous pouvez entrer un compte d'utilisateur Windows local ou un compte d'utilisateur de domaine. Spécifiez le compte de domaine dans ce format : <domaine>\<utilisateur>. Spécifiez un compte d'utilisateur Windows local sous la forme suivante : <nom_ordinateur>\<utilisateur>. Vous pouvez sélectionner uniquement un compte existant ; vous ne pouvez pas créer de nouveaux comptes dans l'outil Configuration de Reporting Services.

Le nom du compte ne doit pas comporter plus de 20 caractères.

Si votre réseau utilise l'authentification Kerberos et que vous configurez le serveur de rapports pour s'exécuter sous un compte d'utilisateur de domaine, vous devez inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom principal de service (SPN) pour Report Server.

Si vous changez de type de compte (par exemple, en remplaçant un compte Windows par un autre ou en remplaçant un compte intégré par un compte de domaine Windows), vous serez invité à créer une copie de sauvegarde de la clé de chiffrement. La copie de sauvegarde sera restaurée automatiquement lorsque vous sélectionnerez le nouveau compte.

Remarque :
L'outil Configuration de Reporting Services vous invite à sauvegarder et à restaurer la clé de chiffrement à chaque modification du compte de service. Ces étapes sont nécessaires pour garantir que les données chiffrées restent disponibles pour le serveur de rapports. Pour plus d'informations sur ces actions, consultez Clés de chiffrement (Configuration de Reporting Services)..

De plus, si vous disposez d'un serveur de rapports configuré pour s'exécuter en mode intégré SharePoint et que vous modifiez le compte de service à l'aide de l'outil de configuration Reporting Services, vous devez également ouvrir l'Administration centrale de SharePoint et vous servir de la page Accorder l'accès à la base de données de Reporting Services pour réappliquer les paramètres du serveur de rapport et de l'instance. Cette étape accordera aux bases de données SharePoint le nouvel accès au compte de service, requis pour intégrer Reporting Services à Windows SharePoint Services (WSS) ou Microsoft Office SharePoint Server (MOSS). Pour plus d'informations sur la manière d'accorder l'accès à la base de données dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Choix d'un compte

Pour de meilleurs résultats, spécifiez un compte qui a des autorisations de connexion réseau, avec un accès aux contrôleurs de domaine réseau et aux passerelles ou serveurs SMTP d'entreprise. Le tableau suivant fournit une synthèse des comptes et des recommandations pour leur utilisation.

Compte Explication

Comptes d'utilisateurs de domaine

Si vous avez un compte d'utilisateur de domaine Windows qui possède les autorisations minimales requises pour les opérations de serveur de rapports, vous devez l'utiliser.

Un compte d'utilisateur de domaine est recommandé car il isole le service Report Server des autres applications. L'exécution de plusieurs applications sous un compte partagé, tel que Service réseau, accroît le risque qu'un utilisateur malveillant prenne le contrôle du serveur de rapports car une violation de la sécurité pour l'une des applications peut facilement s'étendre à toutes les applications qui s'exécutent sous le même compte.

Un compte d'utilisateur de domaine est requis si vous configurez le serveur de rapports pour la délégation contrainte ou pour une configuration spécifique en mode intégré SharePoint où le serveur de rapports, la base de données du serveur de rapports et la configuration et les bases de données de contenu SharePoint sont sur un ordinateur et l'application Web SharePoint est sur un deuxième ordinateur.

Notez que si vous utilisez un compte d'utilisateur de domaine, vous devrez modifier périodiquement le mot de passe si votre organisation met en vigueur une stratégie d'expiration des mots de passe. Vous devrez peut-être également inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom principal de service (SPN) pour Report Server.

Évitez d'utiliser un compte d'utilisateur Windows local. En général, les comptes locaux ne disposent pas des autorisations suffisantes pour accéder aux ressources sur d'autres ordinateurs. Pour plus d'informations sur la manière dont l'utilisation d'un compte local limite la fonctionnalité du serveur de rapports, consultez Considérations relatives à l'utilisation des comptes locaux dans cette rubrique.

Service réseau

Service réseau est un compte intégré doté des privilèges minimaux, qui possède les autorisations d'ouverture de session sur le réseau. Ce compte est recommandé si vous n'avez pas de compte d'utilisateur de domaine disponible ou si vous souhaitez éviter toute interruption de service qui peut se produire à cause des stratégies d'expiration de mot de passe.

Si vous sélectionnez Service réseau, essayez de réduire le nombre d'autres services qui s'exécutent sous le même compte. Une violation de la sécurité pour l'une des applications compromettra la sécurité de toutes les autres applications qui s'exécutent sous le même compte.

Service local

Service local est un compte prédéfini qui s'apparente à un compte d'utilisateur Windows local authentifié. Les services qui s'exécutent au moyen du compte Service local accèdent aux ressources réseau dans le cadre d'une session nulle, sans informations d'identification. Ce compte ne convient pas aux scénarios de déploiement intranet où le serveur de rapports doit se connecter à une base de données de serveur de rapports distante ou à un contrôleur de domaine réseau afin d'authentifier un utilisateur avant d'ouvrir un rapport ou de traiter un abonnement.

Système local

Système local est un compte doté de privilèges élevés qui n'est pas obligatoire pour l'exécution d'un serveur de rapports. Évitez ce compte pour les installations de serveur de rapports. Choisissez un compte de domaine ou Service réseau à la place.

Considérations relatives à l'utilisation des comptes locaux

La principale considération liée à l'utilisation des comptes locaux concerne l'obligation, pour le serveur de rapports, de pouvoir accéder aux serveurs de base de données, serveurs de messagerie et contrôleurs de domaine distants. Si vous configurez le serveur de rapports pour s'exécuter en tant que compte d'utilisateur Windows local, Service local ou Système Local, vous introduisez des considérations qui doivent être prises en compte lors de la définition d'autres paramètres de configuration et de la création et remise d'abonnement :

  • L'exécution du service sous un compte local limitera ultérieurement vos options si vous configurez une connexion à une base de données de serveur de rapports distante. En particulier, si vous utilisez une base de données de serveur de rapports distante, vous devez configurer la connexion afin d'utiliser un compte d'utilisateur de domaine ou un utilisateur de base de données SQL Server qui dispose de l'autorisation d'ouverture de session sur l'instance SQL Server distante.

  • L'exécution du service sous un compte local introduira de nouvelles conditions requises en matière de création d'abonnement. Le serveur de rapports stocke des informations sur l'utilisateur qui crée l'abonnement. Si l'utilisateur crée l'abonnement alors qu'il est connecté sous un compte de domaine, le service Report Server essaie de se connecter à un contrôleur de domaine pour authentifier l'utilisateur lors du traitement de l'abonnement. Si le service s'exécute sous un compte local, la demande d'authentification échoue lorsque le serveur de rapports essaie d'envoyer la demande à un contrôleur de domaine distant. Pour contourner cette limitation, vous pouvez utiliser une extension personnalisée d'authentification basée sur les formulaires ou faire en sorte que tous les utilisateurs se connectent à un serveur de rapports sous un compte d'utilisateur local.

  • L'exécution du service sous un compte local introduira de nouvelles conditions requises en matière de remise des abonnements. Certaines extensions de remise ont les informations du compte d'utilisateur dans la définition de l'abonnement. Si vous envoyez des rapports à des adresses de messagerie basées sur des comptes d'utilisateur de domaine et que vous exécutez le service Report Server sous un compte local, il ne peut pas accéder à un contrôleur de domaine distant pour résoudre le compte de messagerie cible.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services

Concepts

Configuration du compte de service Report Server
Rubriques d'aide F1 sur la configuration de Reporting Services

Autres ressources

Serveur de rapports
Démarrage et arrêt du service Report Server


URL du service Web (configuration de Reporting Services)

URL du service Web (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page URL du service Web pour configurer ou modifier l'URL permettant d'accéder au serveur de rapports. Une réservation d'URL est créée en fonction de l'URL que vous spécifiez. La réservation d'URL définit la syntaxe et les règles de toutes les URL qui peuvent être utilisées par la suite pour accéder au service Web Report Server. Elle spécifie le préfixe, l'hôte, le port et le répertoire virtuel pour le service Web Report Server. Selon la façon dont vous spécifiez l'hôte, plusieurs URL peuvent être possibles pour une réservation unique. La valeur par défaut pour l'hôte spécifie un caractère générique fort. Un caractère générique fort vous permet de spécifier dans une URL un nom d'hôte qui peut être résolu sur l'ordinateur qui héberge le serveur de rapports. Pour plus d'informations sur la configuration et les réservations d'URL, consultez Procédure : configurer une URL (configuration de Reporting Services) et Configuration des URL de Report Server.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur URL du service Web dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Cette page fournit les valeurs utilisées communément dans les URL de serveurs de rapports. Si vous souhaitez créer des URL supplémentaires, utiliser les en-têtes de l'hôte ou spécifier l'adresse IP dans un format particulier, cliquez sur Avancé.

Un lien vers le service Web apparaît sur cette page après que vous avez cliqué sur Appliquer. Si vous cliquez sur ce lien avant que la base de données du serveur de rapports ne soit créée, vous pouvez vous attendre à voir l'erreur « Page introuvable ». Cette erreur n'apparaît plus une fois la base de données configurée. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Si vous avez réinstallé Reporting Services et constatez que vous obtenez une erreur lors de la tentative d'utiliser la valeur d'adresse IP par défaut « Assigné » et le port 80, vous pouvez généralement résoudre l'erreur en recréant l'URL après avoir redémarré le service. Pour obtenir des instructions, consultez Dépannage de problèmes liés aux erreurs de configuration.

Options

Répertoire virtuel

Spécifie le nom de répertoire virtuel pour le service Web Report Server. Vous ne pouvez avoir qu'un nom virtuel pour chaque instance du service Web Report Server sur le même ordinateur.

Adresse IP

Identifie le serveur de rapports sur un réseau TCP/IP. Les valeurs valides sont les suivantes :

  • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

  • Non assigné spécifie que le serveur de rapports accepte toute demande qui n'a pas de correspondance exacte pour l'adresse IP ou le nom d'hôte. N'utilisez pas cette valeur si une autre application Web l'utilise déjà. Sinon, vous interromprez le service pour l'autre application.

  • 127.0.0.1 est utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

  • Nnn.nnn.nnn.nnn est l'adresse IPv4 d'une carte réseau sur votre ordinateur. Si votre réseau utilise l'adressage IPv6, l'adresse IP est une valeur 128 bits de 8 champs de 4 octets semblable au format suivant : <en-tête>:nnnn:nnnn:nnnn:nnnn.

    Si vous avez plusieurs cartes, une adresse IP apparaît pour chacune d'elles. Si vous sélectionnez uniquement cette valeur, elle limite l'accès de l'application à la seule adresse IP (et à tout nom d'hôte mappé sur cette adresse par un serveur de noms de domaine). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports.

Port TCP

Spécifie le port que le serveur de rapports surveille pour les requêtes HTTP pour les URL qui incluent le nom de répertoire virtuel de serveur de rapports.

Certificat SSL

Lie un certificat à l'adresse IP que vous avez spécifiée. Le certificat doit être installé et configuré sur le serveur. Reporting Services ne fournit pas de fonctionnalités pour gérer des certificats. Le certificat doit être émis sur un nom d'hôte ou un nom d'ordinateur qui se résout en une adresse IP. Par exemple, pour utiliser un certificat délivré à http://salesreports, l'adresse IP que vous avez spécifiée doit être résolue en un serveur intitulé salesreports.

Si vous utilisez un certificat, vous devez également modifier le paramètre de configuration UrlRoot dans le fichier RSReportServer.config, afin qu'il spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Port SSL

Spécifie le port pour les connexions SSL.

URL

Affiche les URL définies pour l'instance en cours du serveur de rapports.

Avancé

Cliquez pour créer des URL supplémentaires pour l'instance d'application en cours.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration des URL de Report Server

Autres ressources

Déploiement côte à côte de Reporting Services et des services IIS (Internet Information Services)
Planification d'un déploiement extranet ou Internet


Configuration avancée de plusieurs sites Web (configuration de Reporting Services)

Configuration avancée de plusieurs sites Web (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > URL du service Web (configuration de Reporting Services) >

Utilisez cette boîte de dialogue pour créer et gérer les URL permettant d'accéder à un serveur de rapports ou au Gestionnaire de rapports. La boîte de dialogue Configuration de site Web multiple avancée est utilisée pour créer des URL supplémentaires, des URL personnalisées qui incluent un nom d'en-tête de l'hôte ou spécifier une adresse IP au format IPv4 ou IPv6.

La création de plusieurs URLS est utile si vous souhaitez configurer les différents moyens d'accéder à un serveur de rapports. Par exemple, l'accès au serveur de rapports via une connexion intranet et extranet requiert en général que vous ayez une URL différente pour chaque type de connexion.

Pour ouvrir la boîte de dialogue Configuration de site Web multiple avancée, cliquez sur Avancé dans l'URL du service Web ou sur la page URL du Gestionnaire de rapports dans l'outil de configuration de Reporting Services. Une fois la boîte de dialogue Configuration de site Web multiple avancée ouverte, vous pouvez cliquer sur Ajoutez ou sur Modifier pour définir de nouvelles URL ou modifier ou supprimer les URL existantes.

Cliquez sur OK pour enregistrer vos modifications. Si vous ajoutez ou supprimez des URL, mais en revanche fermez la boîte de dialogue sans cliquer d'abord sur OK, vos modifications seront perdues.

Options

Adresse IP

Identifie le serveur de rapports sur un réseau TCP/IP. Les valeurs valides sont les suivantes :

  • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

  • Non assigné spécifie que le serveur de rapports accepte toute demande qui n'a pas de correspondance exacte pour l'adresse IP ou le nom d'hôte. N'utilisez pas cette valeur si une autre application Web l'utilise déjà. Sinon, vous interromprez le service pour l'autre application.

  • 127.0.0.1 est utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

  • Nnn.nnn.nnn.nnn est l'adresse IPv4 d'une carte réseau sur votre ordinateur. Si votre réseau utilise l'adressage IPv6, l'adresse IP est une valeur 128 bits de 8 champs de 4 octets semblable au format suivant : <en-tête>:nnnn:nnnn:nnnn:nnnn.

    Si vous avez plusieurs cartes, une adresse IP apparaît pour chacune d'elles. Si vous sélectionnez uniquement cette valeur, elle limite l'accès de l'application à la seule adresse IP (et à tout nom d'hôte mappé sur cette adresse par un serveur de noms de domaine). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports.

Port

Spécifie le port que surveille le serveur de rapports pour les demandes. Le port par défaut est le port 80. Si vous utilisez le port 80, vous n'avez pas à l'inclure dans l'URL. Si vous utilisez un autre numéro de port, vous devez toujours l'inclure dans l'URL (par exemple, http://localhost:8181/reports).

En-tête de l'hôte

Si vous avez déjà un en-tête de l'hôte défini sur un serveur de noms de domaine qui se résout sur votre ordinateur, vous pouvez spécifier cet en-tête de l'hôte dans une URL que vous configurez pour l'accès au serveur de rapports.

Un en-tête de l'hôte est un nom unique qui permet à plusieurs sites Web de partager une même adresse IP et un même port. Les noms d'en-tête de l'hôte sont plus faciles à mémoriser et à taper que les adresses IP et les numéros de port. Un exemple de nom d'en-tête de l'hôte peut être www.adventure-works.com.

Port SSL

Spécifie le port pour les connexions SSL. Le numéro de port SSL par défaut est 443.

Certificat SSL

Spécifie le nom de certificat d'un certificat SSL que vous avez installé sur cet ordinateur. Si le certificat est mappé sur un caractère générique, vous pouvez l'utiliser pour une connexion de serveur de rapports.

Spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Le nom que vous spécifiez doit être identique au nom pour lequel le certificat est enregistré.

Un certificat doit être installé pour utiliser cette option. Vous devez également modifier le paramètre de configuration UrlRoot dans le fichier RSReportServer.config, afin qu'il spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Délivré à

Nom de l'ordinateur sur lequel le certificat a été créé.

Ajouter

Définissez une URL supplémentaire.

Modifier

Modifiez une partie de la syntaxe d'URL.

Supprimer

Supprimez une entrée URL de la liste.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server


Base de données (configuration de Reporting Services)

Base de données (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Base de données pour créer et configurer les bases de données du serveur de rapports qui fournissent le stockage interne pour une ou plusieurs instances du serveur de rapports. Si vous configurez un serveur de rapports pour utiliser une base de données de serveur de rapports, vous devez utiliser l'outil de configuration de Reporting Services pour créer la base de données.

La création d'une base de données de serveur de rapports et la configuration de la connexion est un processus comportant plusieurs étapes. Pour vous guider à travers les étapes, cette page propose un Assistant pour chaque type de tâche. Les autorisations et les connexions sont créées ou mises à jour automatiquement. Vous pouvez surveiller l'état de chaque étape dans la page Progression. Si une erreur se produit, vous pouvez cliquer sur l'erreur pour obtenir plus d'informations sur sa résolution.

Une base de données de serveur de rapports doit prendre en charge un mode serveur spécifique. Le mode par défaut est le mode natif, mais vous pouvez également créer une base de données de serveur de rapports en mode intégré SharePoint si vous exécutez un serveur de rapports dans un déploiement plus vaste d'un produit ou d'une technologie SharePoint. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) et Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (outil de configuration de Reporting Services).

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur Base de données dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Nom du serveur SQL Server

Dans la base de données en cours du serveur de rapports, Nom du serveur SQL Server spécifie le nom du serveur SQL Server 2005 ou du Moteur de base de données SQL Server 2008 qui exécute la base de données du serveur de rapports. Vous pouvez utiliser une instance par défaut ou nommée sur un ordinateur local ou distant.

Nom de la base de données

Spécifie le nom de la base de données du serveur de rapports qui stocke les données du serveur.

Mode du serveur de rapports

Indique si la base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Pour plus d'informations, consultez Planification d'un mode de déploiement.

Modifier la base de données

Démarrez un Assistant qui vous guide à travers toutes les étapes requises pour créer ou sélectionner une base de données de serveur de rapports.

Type d'informations d'identification

Détermine les informations d'identification utilisées par le serveur de rapports pour la connexion à la base de données du serveur de rapports. Les types d'informations d'identification que vous pouvez spécifier incluent le compte de service, un utilisateur de domaine Windows, un utilisateur local Windows ou une connexion à une base de données SQL Server. Pour plus d'informations sur la sélection des informations d'identification, consultez Configuration d'une connexion de base de données de serveur de rapports.

Nom d'utilisateur

Spécifie un compte d'utilisateur du domaine si vous utilisez les informations d'identification Windows ou une connexion SQL Server si vous utilisez les informations d'identification SQL Server. Si vous utilisez les informations d'identification Windows, indiquez-les dans le format suivant : <domaine>\<compte>.

Mot de passe

Spécifie le mot de passe du compte.

Modifier les informations d'identification

Démarrez un Assistant qui vous guide à travers toutes les étapes requises pour sélectionner un autre compte ou mettre à jour le mot de passe du compte utilisé pour se connecter à la base de données du serveur de rapports.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Création d'une base de données de serveur de rapports
Mise à niveau d'une base de données du serveur de rapports
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Autres ressources

Base de données de Report Server
Administration d'une base de données du serveur de rapports


Assistant Modification de base de données (configuration de Reporting Services)

Assistant Modification de base de données (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Base de données (configuration de Reporting Services) >

L'outil de configuration de Reporting Services propose l'Assistant Modification de la base de données pour vous guider à travers les différentes étapes de la création d'une base de données du serveur de rapports ou de la sélection d'une base de données existante du serveur de rapports en vue de l'utiliser avec l'instance en cours du serveur de rapports.

Si vous sélectionnez une base de données du serveur de rapports d'une version antérieure, elle sera mise à niveau pour correspondre à la version de l'instance du serveur de rapports à laquelle elle est connectée. Lorsque le service démarre, il vérifie automatiquement la version de la base de données et la met automatiquement à niveau avec le schéma en cours.

Pour démarrer l'Assistant, cliquez sur Modifier la base de données dans la page Base de données de l'outil de configuration de Reporting Services. Pour plus d'instructions sur le démarrage de l'outil de configuration de Reporting Services, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Action

Sélectionnez la tâche à exécuter. Vous pouvez créer une base de données en mode natif ou en mode intégré SharePoint. Ou, vous pouvez sélectionner une base de données existante du serveur de rapports afin de l'utiliser avec l'instance en cours du serveur de rapports.

Serveur de base de données

Spécifiez le nom de l'instance SQL Server Moteur de base de données qui héberge la base de données du serveur de rapports. Vous pouvez utiliser une instance SQL Server 2005 ou SQL Server 2008. Vous pouvez utiliser une instance par défaut ou une instance nommée sur un ordinateur local ou distant. Si vous vous connectez à une instance nommée, entrez le nom du serveur sous la forme <serveur>\<instance>.

Pour vous connecter à l'instance du Moteur de base de données, vous devez utiliser les informations d'identification qui ont l'autorisation de se connecter au serveur et de mettre à jour les informations de la base de données. L'outil de configuration de Reporting Services utilise vos informations d'identification Windows courantes, mais si vous n'avez pas de connexion ou d'autorisations sur la base de données, vous devez spécifier une connexion à une base de données SQL Server. Vous ne pouvez pas spécifier d'autres informations d'identification Windows. Si vous souhaitez vous connecter en tant qu'utilisateur Windows différent, connectez-vous comme cet utilisateur et démarrez l'outil de configuration de Reporting Services.

La connexion à une instance distante nécessite que vous activiez au préalable cette instance pour les connexions distantes. Certaines versions et éditions de SQL Server n'autorisent pas les connexions distantes par défaut. Pour vérifier si les connexions distantes sont autorisées, utilisez l'outil Gestionnaire de configuration SQL Server et confirmez que les protocoles TCP/IP et des canaux nommés sont activés. Si l'instance distante est également une instance nommée, vérifiez que le service SQL Server Browser est activé et en cours d'exécution sur le serveur cible. SQL Server Browser fournit le numéro de port utilisé par l'instance nommée à l'outil de configuration de Reporting Services.

Base de données

Spécifie le nom de la base de données du serveur de rapports qui stocke les données du serveur. Vous pouvez spécifier une base de données existante ou en créer une.

Les propriétés utilisées pour créer une base de données apparaissent dans l'Assistant lorsque vous sélectionnez Créer une nouvelle base de données sur la page Actions. L'outil de configuration de Reporting Services crée deux bases de données liées par le nom : une base de données pour contenir les données statiques et une base de données temporaire pour stocker les données de session et les données de travail. Pour plus d'informations, consultez Base de données de Report Server.

Vous pouvez également choisir une base de données existante du serveur de rapports. L'outil de configuration de Reporting Services ne filtre pas les bases de données non valides. Les bases de données valides sont basées sur le schéma de base de données du serveur de rapports (vous ne pouvez pas sélectionner une base de données où manquent les tables, les vues ou les procédures stockées nécessaires). Si vous choisissez une base de données créée à partir d'une version antérieure de Reporting Services, la base de données sera mise à niveau au format actuel.

Langue

Cette valeur est définie uniquement lorsque vous créez une nouvelle base de données du serveur de rapports.

Avec cette valeur, vous spécifiez la langue dans laquelle les définitions de rôle et les descriptions sont créées. Reporting Services fournit un modèle d'autorisation à base de rôles qui inclut un ensemble de rôles prédéfinis. Ces rôles sont créés une fois dans la langue spécifiée. Les noms des rôles et les descriptions n'apparaissent jamais dans d'autres langues, même si vous vous connectez au serveur de rapports à l'aide d'un navigateur dont les paramètres de culture ou de langue sont pris en charge par le serveur. La langue que vous spécifiez détermine aussi celle utilisée pour créer le nom du dossier Mes rapports et les dossiers Utilisateurs qui font partie de la fonctionnalité Mes rapports. Pour plus d'informations sur la prise en charge de la langue dans Reporting Services, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services).

Mode serveur

Une base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Les modes s'excluent mutuellement.

Si vous créez une base de données du serveur de rapports, vous devez spécifier un mode. Le mode que vous sélectionnez détermine la structure de la base de données du serveur de rapports et attribue à la propriété système SharePointIntegrated du serveur de rapports la valeur true ou false.

Si vous sélectionnez une autre base de données du serveur de rapports, le mode de la base de données courante s'affiche afin que vous sachiez comment celle-ci est utilisée. Vous pouvez sélectionner une base de données créée pour un mode différent. Ce choix entraîne une bascule du mode serveur de l'instance en cours du serveur de rapports. Pour plus d'informations sur les modes, consultez Planification d'un mode de déploiement.

Informations d'identification

Spécifie le compte utilisé par le serveur de rapports pour se connecter à la base de données du serveur de rapports. Les valeurs valides incluent le compte de service du service Web Report Server, la connexion à une base de données SQL Server définie sur l'instance du Moteur de base de données que vous utilisez pour héberger le serveur de rapports, ou un compte Windows. Si vous utilisez un compte Windows, vous pouvez spécifier un compte local (<nom_ordinateur>\<nom_utilisateur>) si le serveur de rapports et la base de données sont sur le même ordinateur, ou un compte d'utilisateur de domaine (<domaine>\<nom_utilisateur>) s'ils sont sur des ordinateurs différents du même domaine.

Le serveur de rapports crée alors une connexion de base de données et attribue les autorisations de base de données au compte que vous spécifiez.

Le serveur de rapports ne crée pas le compte lui-même. Le compte que vous spécifiez doit déjà exister et doit être valide pour votre configuration de déploiement. Plus particulièrement, si la base de données se trouve sur un ordinateur distant et que vous souhaitez utiliser un compte Windows, vous devez spécifier un compte qui a les autorisations de connexion sur cet ordinateur.

Si l'ordinateur se trouve dans un domaine différent ou non approuvé, pensez à utiliser la connexion à une base de données SQL Server. Pour plus d'informations sur le choix d'un compte, consultez Configuration d'une connexion de base de données de serveur de rapports.

Résumé

Vérifiez les paramètres avant que le programme d'installation ne configure la connexion.

État d'avancement et fin

Surveillez la progression de chaque tâche.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Référence

Base de données (configuration de Reporting Services)
Assistant Modification des informations d'identification (configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Autres ressources

Planification d'un mode de déploiement
Base de données de Report Server
Administration d'une base de données du serveur de rapports


Assistant Modification des informations d'identification (configuration de Reporting Services)

Assistant Modification des informations d'identification (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Base de données (configuration de Reporting Services) >

L'outil de configuration de Reporting Services fournit l'Assistant Modification des informations d'identification pour vous guider à travers les étapes de reconfiguration du compte que le serveur de rapports utilise pour se connecter à la base de données du serveur de rapports. Lorsque vous modifiez les informations d'identification, l'outil met à jour toutes les autorisations et informations de connexion de base de données sur le serveur de base de données pour la base de données du serveur de rapports en cours d'utilisation par le serveur de rapports.

Pour démarrer l'Assistant, cliquez sur Modifier les informations d'identification dans la page Base de données de l'outil de configuration de Reporting Services. Pour plus d'instructions sur le démarrage de l'outil de configuration de Reporting Services, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Serveur de base de données

Spécifiez le nom de l'instance SQL Server Moteur de base de données qui exécute la base de données du serveur de rapports.

Pour vous connecter à l'instance du Moteur de base de données, vous devez utiliser les informations d'identification qui ont l'autorisation de se connecter au serveur et de mettre à jour les informations de la base de données. L'outil de configuration de Reporting Services utilise vos informations d'identification Windows courantes, mais si vous n'avez pas de connexion ou d'autorisations sur la base de données, vous pouvez spécifier une connexion à une base de données SQL Server.

Vous ne pouvez pas spécifier d'autres informations d'identification Windows. Si vous souhaitez vous connecter en tant qu'utilisateur Windows différent, connectez-vous comme cet utilisateur et démarrez l'outil de configuration de Reporting Services.

Informations d'identification

Spécifie le compte utilisé par le serveur de rapports pour se connecter à la base de données du serveur de rapports. Les valeurs valides incluent le compte de service du service Web Report Server, la connexion à une base de données SQL Server définie sur l'instance du Moteur de base de données que vous utilisez pour héberger le serveur de rapports, ou un compte Windows. Si vous utilisez un compte Windows, vous pouvez spécifier un compte local (<nom_ordinateur>\<nom_utilisateur>) si le serveur de rapports et la base de données sont sur le même ordinateur, ou un compte d'utilisateur de domaine (<domaine>\<nom_utilisateur>) s'ils sont sur des ordinateurs différents du même domaine.

Le serveur de rapports crée alors une connexion de base de données et attribue les autorisations de base de données au compte que vous spécifiez.

Le serveur de rapports ne crée pas le compte lui-même. Le compte que vous spécifiez doit déjà exister et doit être valide pour votre configuration de déploiement. Plus particulièrement, si la base de données se trouve sur un ordinateur distant et que vous souhaitez utiliser un compte Windows, vous devez spécifier un compte qui a les autorisations de connexion sur cet ordinateur.

Si l'ordinateur se trouve dans un domaine différent ou non approuvé, pensez à utiliser la connexion à une base de données SQL Server. Pour plus d'informations sur le choix d'un compte, consultez Configuration d'une connexion de base de données de serveur de rapports.

Résumé

Vérifiez les paramètres avant l'Assistant ne s'exécute.

État d'avancement et fin

Surveillez la progression de chaque tâche.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Référence

Base de données (configuration de Reporting Services)
Assistant Modification de base de données (configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Autres ressources

Base de données de Report Server
Administration d'une base de données du serveur de rapports


URL du Gestionnaire de rapports (configuration de Reporting Services)

URL du Gestionnaire de rapports (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page URL du Gestionnaire de rapports pour configurer ou modifier l'URL permettant d'accéder au Gestionnaire de rapports. Par défaut, l'URL du Gestionnaire de rapports hérite du préfixe, de l'adresse IP et du port de l'URL du service Web Report Server URL. La raison en est que le Gestionnaire de rapports fournit l'accès frontal au service Web qui s'exécute au sein du même service Report Server. Si vous isolez les applications de service et utilisez le Gestionnaire de rapports pour accéder à un service Web Report Server sur un autre ordinateur, vous devez modifier le fichier RSReportServer.config pour pointer le Gestionnaire de rapports sur une instance différente. Pour plus d'informations sur la configuration d'une connexion du Gestionnaire de rapports avec un serveur de rapports distant, consultez Procédure : configurer le Gestionnaire de rapports.

Si vous êtes en train de configurer le serveur de rapports pour qu'il s'exécute en mode intégré SharePoint, ne créez pas l'URL du Gestionnaire de rapports. Le Gestionnaire de rapports n'est pas pris en charge sur un serveur de rapports exécuté en mode intégré SharePoint. Si une URL existe déjà pour le Gestionnaire de rapports, elle devient indisponible après que vous avez configuré le serveur de rapports pour qu'il s'exécute en mode intégré SharePoint.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur URL du Gestionnaire de rapports dans le volet de navigation. Pour plus d'informations sur le démarrage de l'outil, consultez Procédure : démarrer la configuration de Reporting Services.

Remarque :
Si le Gestionnaire de rapports n'est pas activé, vous ne pouvez pas définir d'options sur cette page. Pour plus d'informations sur l'activation du Gestionnaire de rapports, consultez Procédure : activer ou désactiver les fonctionnalités Reporting Services.

Options

Répertoire virtuel

Spécifie le nom de répertoire virtuel pour le Gestionnaire de rapports. Vous ne pouvez avoir qu'un seul nom de répertoire virtuel pour chaque instance du Gestionnaire de rapports sur le même ordinateur.

URL

Affiche l'URL définie pour l'instance en cours du Gestionnaire de rapports.

Avancé

Ajoutez une URL supplémentaire pour l'instance en cours du Gestionnaire de rapports.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

URL des fichiers de configuration (Reporting Services)
Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration des URL de Report Server

Autres ressources

Architecture du service (Reporting Services)
Fichier de configuration RSReportServer
Planification d'un mode de déploiement
Gestionnaire de rapports


Paramètres de messagerie (Configuration de Reporting Services)

Paramètres de messagerie (Configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour spécifier les paramètres du protocole SMTP (Simple Mail Transfer Protocol) qui activent la remise du courrier électronique à partir du serveur de rapports. Vous pouvez utiliser l'extension de remise du courrier électronique Report Server pour distribuer des rapports ou des notifications de traitement de rapport par le biais d'abonnements à la messagerie. L'extension de remise par messagerie Report Server nécessite un serveur SMTP et une adresse de messagerie à utiliser dans le champ De :.

Des paramètres de configuration supplémentaires peuvent être utilisés pour personnaliser davantage les abonnements à la messagerie, notamment les paramètres qui limitent les hôtes de serveur de messagerie et la disponibilité de l'extension de rendu. Vous ne pouvez pas spécifier ces paramètres dans l'outil de configuration de Reporting Services. Pour configurer les paramètres supplémentaires, vous devez modifier manuellement le fichier RSReportServer.config. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique et Fichiers de configuration (Reporting Services).

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur Paramètres de messagerie dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Adresse de l'expéditeur

Spécifie l'adresse de messagerie à utiliser dans le champ De : d'un message généré. Vous devez spécifier un compte d'utilisateur qui a l'autorisation d'envoyer du courrier depuis le serveur SMTP.

Méthode actuelle de remise SMTP

Spécifie que le message du serveur de rapports est acheminé par le biais d'un serveur SMTP. Il s'agit du seul mode de remise que vous pouvez spécifier dans l'outil Configuration de Reporting Services.

Un autre mode de remise consiste à utiliser un répertoire de collecte local du service SMTP. Vous pouvez utiliser ce mode de remise si aucun service réseau SMTP n'est disponible. Pour spécifier un répertoire de collecte local du service SMTP, vous devez modifier le fichier RSReportServer.config. Si vous éditez le fichier de configuration pour qu'il utilise un répertoire de collecte local du service SMTP, l'outil Configuration de Reporting Services définit l'option Mode de remise sur Personnalisé pour indiquer que le mode de remise est spécifié dans le fichier de configuration.

Dans le fichier de configuration, le mode de remise est défini par le biais du paramètre de configuration SendUsing. Pour plus d'informations sur la spécification du paramètre SendUsing, consultez Configuration d'un Report Server pour la remise du courrier électronique.

Serveur SMTP

Spécifiez le serveur ou la passerelle SMTP à utiliser. Vous pouvez utiliser un serveur local ou un serveur SMTP sur votre réseau.

Voir aussi

Concepts

Configuration d'un Report Server pour la remise du courrier électronique
Rubriques d'aide F1 sur la configuration de Reporting Services


Compte d'exécution (configuration de Reporting Services)

Compte d'exécution (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour configurer un compte à utiliser pour le traitement sans assistance. Ce compte est utilisé dans des circonstances particulières lorsque d'autres sources d'informations d'identification ne sont pas disponibles :

  • lorsque le serveur de rapports se connecte à une source de données qui n'exige pas d'informations d'identification ; les documents XML et certaines applications de base de données côté client sont des exemples de sources de données qui n'ont pas nécessairement besoin d'informations d'identification.

  • lorsque le serveur de rapports se connecte à un autre serveur pour extraire des fichiers image externes ou d'autres ressources référencées dans un rapport.

La définition de ce compte est facultative, mais si vous ne définissez pas le compte, l'utilisation des images externes et des connexions à certaines sources de données est limitée. Lorsque vous récupérez des fichiers image externes, le serveur de rapports vérifie si une connexion anonyme peut être établie. Si la connexion est protégée par mot de passe, le serveur de rapports utilise le compte de traitement sans assistance pour se connecter au serveur de rapports. Lors de l'extraction des données pour un rapport, le serveur de rapports emprunte l'identité de l'utilisateur actuel, invite l'utilisateur à fournir des informations d'identification, utilise des d'informations d'identification stockées ou utilise le compte de traitement sans assistance si la connexion de la source de données spécifie Aucun comme type d'informations d'identification. Le serveur de rapports n'autorise pas la délégation ou l'emprunt d'identité des informations d'identification de son compte de service lors de la connexion à d'autres ordinateurs. Par conséquent, il doit utiliser le compte de traitement sans assistance si aucune information d'identification n'est disponible.

Le compte que vous spécifiez doit être différent de celui utilisé pour exécuter le compte de service. Si vous configurez ce compte, il est stocké dans le fichier RSReportServer.config sous forme de valeur chiffrée. Si vous exécutez le serveur de rapports dans un déploiement avec montée en puissance parallèle, vous devez configurer ce compte de la même façon sur chaque serveur de rapports.

Vous pouvez utiliser n'importe quel compte d'utilisateur Windows. Pour optimiser les résultats, choisissez un compte possédant des autorisations en lecture et des autorisations de connexion réseau afin de prendre en charge les connexions à d'autres ordinateurs. Il doit posséder des autorisations en lecture sur un fichier de données ou image externe que vous voulez utiliser dans un rapport. Ne spécifiez pas un compte local sauf si toutes les images externes et les sources de données de rapport sont stockées sur l'ordinateur du serveur de rapports. Utilisez le compte uniquement pour le traitement sans assistance des rapports.

Remarque :
Si vous utilisez SQL Server 2008 Express Edition with Advanced Services, vous devez simplement configurer ce compte si vous faites référence à des images externes dans un rapport et qu'une autorisation est requise pour accéder au fichier image. SQL Server Express ne prend pas en charge une connexion de source de données à un serveur distant.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez Compte d'exécution dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Spécifier un compte d'exécution

Sélectionnez un compte.

Compte

Entrez un compte d'utilisateur de domaine Windows. Utilisez ce format : <domaine>\<compte d'utilisateur>.

Mot de passe

Tapez le mot de passe.

Confirmer le mot de passe

Tapez de nouveau le mot de passe.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Stockage des données chiffrées du serveur de rapports
Configuration du compte d'exécution sans assistance

Autres ressources

Fichier de configuration RSReportServer


Clés de chiffrement (Configuration de Reporting Services).

Clés de chiffrement (Configuration de Reporting Services). |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Clés de chiffrement pour gérer la clé symétrique utilisée pour chiffrer et déchiffrer les données dans un serveur de rapports. La gestion des clés de chiffrement représente une partie importante de la configuration du serveur de rapports. Bien que la clé symétrique soit créée et appliquée automatiquement lors de la création de la base de données du serveur de rapports, vous devez créer une copie de sauvegarde de la clé symétrique de façon à pouvoir exécuter les opérations de maintenance de routine. Les tâches de maintenance suivantes nécessitent une copie valide de la clé symétrique :

  • Modification du compte du service Report Server

  • Migration d'une installation de Reporting Services vers un autre ordinateur

  • Configuration d'une nouvelle instance de serveur de rapports pour partager ou utiliser une base de données existante du serveur de rapports

La restauration de la clé symétrique est nécessaire si vous avez mis à jour le compte d'utilisateur du service Report Server (et si vous avez utilisé un outil autre que l'outil de configuration de Reporting Services pour modifier le compte) ou si vous effectuez la migration d'une installation de serveur de rapports vers un nouveau serveur.

Pour protéger la clé symétrique de tout accès non autorisé, cette clé est chiffrée à l'aide de la clé privée du service Report Server. Seul le service Report Server est capable de déverrouiller et d'utiliser la clé symétrique dans le but de stocker des données sensibles dans la base de données du serveur de rapports. Si vous modifiez l'identité du service Report Server ou si vous effectuez la migration du serveur de rapports vers un nouvel ordinateur, la clé privée du service Report Server ne sera plus capable de déverrouiller la clé symétrique. Pour restaurer l'accès à la clé symétrique, celle-ci doit être chiffrée une nouvelle fois à l'aide de la clé privée de la nouvelle identité du service Report Server. La restauration de la clé symétrique est le processus qui conduit au nouveau chiffrement.

Vous devez restaurer une clé symétrique seulement s'il s'agit de la même clé actuellement utilisée pour chiffrer et déchiffrer les données dans la base de données du serveur de rapports. Si vous restaurez une clé symétrique non valide, vous ne serez plus en mesure d'accéder aux données sensibles. Dans ce cas, vous devez supprimer et recréer la clé.

Important :
La suppression de la clé symétrique et la création d'une nouvelle clé correspondent à une action irréversible qui peut avoir d'importantes conséquences sur votre installation actuelle. Si vous supprimez la clé, toute donnée existante chiffrée par la clé symétrique sera supprimée avec la clé. Les données supprimées incluent les chaînes de connexion aux sources de données de rapport externes, les chaînes de connexion stockées et certaines informations d'abonnement.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez le lien dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Sauvegarde

Copie la clé symétrique dans un fichier que vous spécifiez. La clé symétrique n'est jamais stockée en texte clair. Vous devez taper un mot de passe pour protéger le fichier.

Restaurer

Applique une copie de la clé symétrique enregistrée précédemment à la base de données du serveur de rapports. Vous devez fournir un mot de passe pour déverrouiller le fichier.

La copie précédente de la clé symétrique de l'instance du serveur de rapports à laquelle vous est actuellement connecté est remplacée par la version restaurée. Après avoir restauré la clé symétrique, vous devez initialiser tous les serveurs de rapports qui utilisent la base de données du serveur de rapports. Pour plus d'informations sur l'initialisation des serveurs de rapports, consultez Initialisation d'un serveur de rapports.

Modifier

Recrée la clé symétrique et rechiffre toutes les valeurs chiffrées de la base de données du serveur de rapports. Veillez à arrêter le service Report Server avant de recréer la clé symétrique.

Dans un déploiement avec montée en puissance parallèle, toutes les copies de la clé symétrique sont remplacées par les versions plus récentes. Avant de remplacer la clé symétrique, veillez à passer en revue la liste des serveurs joints au déploiement avec montée en puissance parallèle pour vérifier que seules les instances valides du serveur de rapports obtiennent un accès à la nouvelle clé. Les serveurs qui font partie d'un déploiement avec montée en puissance parallèle sont répertoriés dans la page Déploiement avec montée en puissance parallèle. Arrêtez le service sur chaque serveur de rapports du déploiement avant de recréer la clé.

Notez que la régénération de la clé symétrique peut prendre du temps s'il existe un grand nombre de sources de données et d'abonnements.

Supprimer

Supprime la clé symétrique de la totalité du contenu chiffré, notamment les chaînes de connexion et les informations d'identification stockées. Vous devez supprimer uniquement la clé symétrique si vous ne pouvez pas la restaurer.

Une fois la clé symétrique supprimée, vous devez réentrer les chaînes de connexion et les informations d'identification stockées manquantes dans les rapports et les sources de données partagées qui ne contiennent plus ces valeurs Vous devez également mettre à jour tous les abonnements dont les extensions de remise stockent des données chiffrées. Il s'agit notamment de l'extension de remise de partage de fichiers et des éventuelles extensions de remise tierces qui utilisent les valeurs chiffrées.

Il n'existe pas de méthode automatique de mise à jour de ces informations. Les rapports, les abonnements et les sources de données partagées qui utilisent des informations d'identification stockées et des chaînes de connexion doivent être mis à jour l'un après l'autre.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Autres ressources

Correction des erreurs d'initialisation et de clé de chiffrement


Sauvegarder la clé de chiffrement (configuration de Reporting Services)

Sauvegarder la clé de chiffrement (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Clés de chiffrement (Configuration de Reporting Services). >

Reporting Services utilise une clé de chiffrement pour sécuriser les données sensibles stockées dans la base de données du serveur de rapports. La possession d'une sauvegarde de cette clé est essentielle pour garantir l'accès continu aux chaînes de connexion et aux informations d'identification chiffrées.

Vous devez avoir une copie de sauvegarde de cette clé si vous déplacez la base de données du serveur de rapports vers un autre ordinateur ou si vous modifiez le nom d'utilisateur ou le mot de passe du compte de service Report Server. Ces deux opérations nécessitent la restauration de la clé à partir d'une copie de sauvegarde que vous avez créée précédemment.

Pour ouvrir la boîte de dialogue Clé de chiffrement de sauvegarde, cliquez sur Clés de chiffrement dans le volet de navigation de l'outil Configuration de Reporting Services, puis cliquez sur Sauvegarder. La boîte de dialogue apparaît également lorsque vous mettez à jour le compte de service à l'aide de la page Compte de service de l'outil Configuration de Reporting Services.

Options

Emplacement du fichier

Spécifiez un nom et un emplacement de fichier pour la clé symétrique Reporting Services. La clé symétrique n'est jamais stockée en texte clair. Vous devez taper un mot de passe pour protéger le fichier.

Mot de passe

Entrez un mot de passe qui protège le fichier contre tout accès non autorisé. Seuls les utilisateurs qui connaissent le mot de passe seront en mesure de restaurer la clé verrouillée à l'intérieur du fichier. Reporting Services met en vigueur une stratégie de mot de passe forte. Le mot de passe doit comporter au moins 8 caractères et inclure une combinaison de caractères alphanumériques majuscules et minuscules, ainsi qu'au moins un caractère symbole.

Confirmer le mot de passe

Retapez le mot de passe que vous avez entré.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Référence

Clés de chiffrement (Configuration de Reporting Services).

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Autres ressources

Correction des erreurs d'initialisation et de clé de chiffrement


Restaurer la clé de chiffrement (configuration de Reporting Services)

Restaurer la clé de chiffrement (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Clés de chiffrement (Configuration de Reporting Services). >

Reporting Services utilise une clé de chiffrement pour sécuriser les données sensibles stockées dans la base de données du serveur de rapports. Pour garantir un accès ininterrompu aux données chiffrées, il importe que vous créiez une sauvegarde de la clé de chiffrement au cas où vous devriez la restaurer ultérieurement en raison de modifications dans le compte de service ou dans le cadre d'une migration planifiée.

Pour restaurer la clé, vous devez avoir enregistré préalablement une copie de sauvegarde de la clé sur un fichier protégé par mot de passe. Pendant la restauration de la clé, le serveur de rapports remplace la clé existante par la clé trouvée dans le fichier protégé par mot de passe. La clé qui est à l'intérieur du fichier doit être identique à celle utilisée pour chiffrer et déchiffrer les données.

Pour vérifier que vous avez restauré une clé valide, utilisez le Gestionnaire de rapports pour consulter les abonnements ou un rapport ayant une source de données qui utilise des informations d'identification stockées. Si vous recevez une erreur selon laquelle « Le serveur de rapports ne peut pas accéder aux données chiffrées » lors de la tentative d'ouverture d'une page de la définition de l'abonnement, ou si vous êtes invité à entrer les informations d'identification lorsque vous ouvrez un rapport qui utilisait précédemment les informations d'identification stockées pour la source de données du rapport, vous avez restauré une clé non valide.

Si vous restaurez une clé non valide différente de celle utilisée pour chiffrer les données, il est impossible de déchiffrer les données actuellement stockées dans la base de données du serveur de rapports. Si vous restaurez une clé non valide, vous devez restaurer immédiatement une copie de sauvegarde de la clé correcte, si elle est disponible. Si vous ne disposez pas de la copie de sauvegarde de la clé utilisée pour chiffrer les données, vous devez supprimer toutes les données chiffrées. À cette fin, cliquez sur le bouton Supprimer de la page Clés de chiffrement. Après avoir supprimé le contenu chiffré, vous devez mettre à jour tous les abonnements manuellement et spécifier à nouveau toutes les informations d'identification stockées définies pour les rapports et les abonnements pilotés par les données sur le serveur de rapports.

Pour ouvrir la boîte de dialogue Restaurer la clé de chiffrement, cliquez sur Clés de chiffrement dans le volet de navigation de l'outil de configuration de Reporting Services, puis cliquez sur Restaurer. La boîte de dialogue apparaît également lorsque vous mettez à jour le compte de service à l'aide de la page Compte de service de l'outil de configuration de Reporting Services.

Options

Emplacement du fichier

Sélectionnez le fichier protégé par mot de passe qui contient une copie de la clé symétrique. L'extension de fichier par défaut est .snk.

Mot de passe

Entrez le mot de passe permettant de déverrouiller le fichier. Seuls les utilisateurs qui connaissent le mot de passe peuvent restaurer la clé. Reporting Services applique une stratégie de mot de passe fort. Le mot de passe doit contenir au moins 8 caractères et inclure une combinaison de caractères alphanumériques majuscules et minuscules, ainsi qu'au moins un caractère symbole.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services

Référence

Clés de chiffrement (Configuration de Reporting Services).

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Autres ressources

Correction des erreurs d'initialisation et de clé de chiffrement


Déploiement avec montée en puissance parallèle (configuration de Reporting Services)

Déploiement avec montée en puissance parallèle (configuration de Reporting Services) |
 | Voir aussi
Configuration de SQL Server 2008 > Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour afficher l'état d'initialisation d'un déploiement avec montée en puissance parallèle ou pour joindre un serveur de rapports à un déploiement avec montée en puissance parallèle.

Un serveur de rapports initialisé décrit un serveur qui peut chiffrer et déchiffrer les données sensibles stockées dans une base de données de serveur de rapports (par exemple, les informations d'identification et les chaînes de connexion). L'initialisation d'un serveur de rapports est nécessaire à son fonctionnement.

Un déploiement avec montée en puissance fait référence à deux ou plusieurs instances de serveurs de rapports qui partagent une même base de données de serveur de rapports. Cette configuration est utilisée dans les scénarios suivants :

  • Comme condition préalable pour l'équilibrage de charge de plusieurs serveurs de rapports dans un cluster de serveurs. Avant de pouvoir soumettre plusieurs serveurs de rapports à l'équilibrage de charge, vous devez les configurer pour qu'ils partagent la même base de données de serveur de rapports.

  • Pour segmenter les applications du serveur de rapports sur différents ordinateurs, en utilisant un serveur pour le traitement interactif des rapports et un autre serveur pour le traitement planifié des rapports. Dans ce scénario, chaque instance de serveur traite les différents types de demandes pour le même contenu de serveur de rapports stocké dans la base de données partagée du serveur de rapports.

Pour configurer un déploiement avec montée en puissance parallèle, commencez par deux instances de serveurs de rapports ou plus qui sont toutes connectées à la même base de données de serveur de rapports. Après que toutes les instances ont été installées, vous vous connectez au premier serveur de rapports, puis utilisez la page Déploiement avec montée en puissance parallèle pour attacher chaque instance supplémentaire. Seul un serveur de rapports déjà initialisé pour utiliser une base de données peut initialiser des nœuds supplémentaires.

Pour ouvrir la page, démarrez l'outil de configuration Reporting Services et sélectionnez Déploiement avec montée en puissance parallèle dans le volet de navigation. Pour plus d'informations, consultez Procédure : démarrer la configuration de Reporting Services.

Options

Nom du serveur SQL Server

Spécifiez le nom de l'instance SQL Server Moteur de base de données qui héberge la base de données du serveur de rapports.

Nom de la base de données

Spécifie le nom de la base de données à laquelle l'instance de serveur de rapports est connectée.

Mode serveur

Affiche le mode du serveur et de la base de données. Le mode du serveur est le mode natif ou le mode intégré SharePoint. Les déploiements avec montée en puissance parallèle sont pris en charge pour les deux modes.

Serveur

Affiche le nom du serveur de rapports. Dans la plupart des cas, il s'agit du nom de l'ordinateur sur lequel le serveur de rapports est installé.

Instance

Affiche le nom de l'instance du serveur de rapports. Les instances de serveur de rapports sont basées sur les instances SQL Server.

État

Indique si le serveur de rapports est initialisé ou en attente de rejoindre un déploiement avec montée en puissance parallèle :

  • Pour un serveur de rapports qui ne fait pas partie d'un déploiement avec montée en puissance parallèle, cette page montre que l'instance du serveur de rapports est initialisée par rapport à sa base de données de serveur de rapports dédiée. L'état est défini sur Joint.

  • Pour un serveur de rapports en attente de joindre un déploiement avec montée en puissance parallèle, cette page contient les valeurs vides de Serveur, Instance et État. Un serveur de rapports attend de joindre un déploiement avec montée en puissance parallèle si vous avez sélectionné une base de données existante du serveur de rapports déjà utilisée par une autre instance de serveur de rapports. Un message de cette page vous demande de vous connecter à un serveur de rapports déjà joint à la batterie de serveurs. Pour compléter cette demande, cliquez sur Se connecter, sélectionnez un serveur de rapports déjà initialisé pour utiliser la base de données du serveur de rapports, cliquez sur Déploiement avec montée en puissance parallèle, sélectionnez l'instance de serveur de rapports En attente de joindre, puis cliquez sur Initialiser.

  • Pour un serveur de rapports qui fait actuellement partie d'un déploiement avec montée en puissance parallèle, cette page indique l'état d'initialisation de toutes les instances de serveur de rapports qui partagent la même base de données de serveur de rapports. Lors de l'affichage de l'état d'un déploiement avec montée en puissance parallèle, peu importe le serveur auquel vous êtes connecté. Les informations d'état sont signalées de manière identique pour tous les nœuds du déploiement avec montée en puissance parallèle.

    Pour un serveur de rapports qui fait déjà partie d'un déploiement avec montée en puissance parallèle, vous pouvez utiliser cette page pour ajouter ou supprimer des nœuds.

Initialiser

Cliquez sur Initialiser pour ajouter un serveur de rapports au déploiement avec montée en puissance parallèle. Cette étape configure un serveur de rapports de telle sorte qu'il utilise une clé symétrique dans une base de données de serveur de rapports partagée. Vous pouvez utiliser Initialiser pour ajouter une instance de serveur de rapports à un déploiement avec montée en puissance parallèle ou pour résoudre un problème de migration ou d'installation.

Une instance de serveur de rapports est disponible uniquement si vous avez précédemment configuré une connexion à une base de données de serveur de rapports partagée. De plus, vous devez effectuer l'initialisation à partir d'un serveur de rapports qui est déjà initialisé pour utiliser la base de données du serveur de rapports.

Supprimer

Cliquez sur Supprimer pour supprimer de la base de données du serveur de rapports les clés de chiffrement de l'instance sélectionnée du serveur de rapports. Vous pouvez supprimer des clés pour retirer un serveur de rapports d'un déploiement avec montée en puissance parallèle ou pour résoudre un problème de migration ou d'installation. Avec cette option, seules les clés de chiffrement de l'instance spécifiée du serveur de rapports sont supprimées. Les données chiffrées dans la base de données du serveur de rapports ne sont pas concernées.

Par précaution, veillez à créer une copie de sauvegarde de la clé symétrique avant de la supprimer. Après avoir supprimé de la liste les clés de chiffrement du dernier serveur de rapports, vous introduisez de nouvelles conditions sur toutes les initialisations ultérieures de serveur de rapports pour cette base de données. En effet, après avoir initialisé un serveur de rapports, vous devez restaurer une copie de sauvegarde de la clé symétrique. La restauration de la clé symétrique est nécessaire pour pouvoir accéder aux données chiffrées actuellement présentes dans la base de données du serveur de rapports.

Si vous n'avez plus besoin des données chiffrées ou si vous ne possédez pas de copie de sauvegarde de la clé, vous devez supprimer les données chiffrées. Pour plus d'informations, consultez Clés de chiffrement (Configuration de Reporting Services)..

Voir aussi

Tâches

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (Configuration de Reporting Services)

Concepts

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services
Initialisation d'un serveur de rapports
Configuration et gestion des clés de chiffrement

Autres ressources

Planification d'un mode de déploiement
Utilitaire rskeymgmt


Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server

Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server |
 | Voir aussi
Configuration de SQL Server 2008 >

Les systèmes de pare-feu empêchent les accès non autorisés aux ressources de l'ordinateur. Si un pare-feu est activé alors qu'il n'est pas configuré correctement, les tentatives de connexion à SQL Server peuvent être bloquées.

Pour accéder à une instance du SQL Server par le biais d'un pare-feu, vous devez configurer le pare-feu sur l'ordinateur exécutant SQL Server pour autoriser l'accès. Le pare-feu est un composant de Microsoft Windows. Vous pouvez également installer un pare-feu d'une autre société. Cette rubrique explique comment configurer le Pare-feu Windows, mais les principes de base s'appliquent à d'autres programmes de pare-feu.

Remarque :
Cette rubrique fournit une vue d'ensemble de la configuration du pare-feu et résume les informations présentant un intérêt pour un administrateur SQL Server. Pour plus d'informations sur le pare-feu et pour des informations rigoureuses sur le pare-feu, consultez la documentation de pare-feu, par exemple Pare-feu Windows avec fonctions avancées de sécurité et IPsec et Pare-feu Windows avec fonctions avancées de sécurité - Plan du contenu.

Les utilisateurs familiarisés avec l'élément Pare-feu Windows dans le Panneau de configuration et avec le composant logiciel enfichable MMC (Microsoft Management Console) du Pare-feu Windows avec fonctions avancées de sécurité et qui savent quels paramètres de pare-feu ils veulent configurer peuvent passer directement aux rubriques de la liste suivante :

  • Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données

  • Procédure : configurer le pare-feu Windows pour accéder à Analysis Services

  • Procédure : configurer un pare-feu pour accéder à Report Server

  • Procédure : configurer un pare-feu Windows pour Integration Services

Dans cette rubrique

Cette rubrique contient les sections suivantes :

Informations de base sur le pare-feu

Paramètres du pare-feu par défaut

Programmes pour configurer le pare-feu

Ports utilisés par le moteur de base de données

Ports utilisés par Analysis Services

Ports utilisés par Reporting Services

Ports utilisés par Integration Services

Ports et services supplémentaires

Interaction avec d'autres règles de pare-feu

Vue d'ensemble des profils de pare-feu

Paramètres supplémentaires du pare-feu

Utilisation du composant logiciel enfichable Pare-feu Windows avec fonctions avancées de sécurité

Résolution des problèmes liés aux paramètres du pare-feu

Informations de base sur le pare-feu

Les pare-feu fonctionnent en examinant les paquets entrants, et en les comparant à un jeu de règles. Si les règles autorisent le paquet, le pare-feu passe le paquet au protocole TCP/IP pour traitement supplémentaire. Si les règles n'autorisent pas le paquet, le pare-feu ignore le paquet et, si la journalisation est activée, crée une entrée dans le fichier journal du pare-feu.

La liste du trafic autorisé est remplie de l'une des façons suivantes :

  • Lorsque l'ordinateur dont le pare-feu est activé lance la communication, le pare-feu crée une entrée dans la liste afin que la réponse soit autorisée. La réponse entrante est considérée comme étant un trafic sollicité et vous n'avez pas à configurer cet élément.

  • Un administrateur configure les exceptions du pare-feu. Cela permet l'accès à des programmes spécifiés qui s'exécutent sur votre ordinateur, ou l'accès aux ports de connexion spécifiés sur votre ordinateur. Dans ce cas, l'ordinateur accepte le trafic entrant non sollicité lorsqu'il joue le rôle de serveur, d'écouteur ou d'homologue. C'est le type de configuration qui doit être complétée pour se connecter à SQL Server.

Le choix d'une stratégie de pare-feu est plus complexe que le fait de déterminer si un port donné doit être ouvert ou fermé. Lors de la conception d'une stratégie de pare-feu pour votre entreprise, veillez à prendre en considération toutes les règles et les options de configuration disponibles. Cette rubrique n'examine pas toutes les options de pare-feu possibles. Nous vous recommandons de consulter les documents suivants :

Mise en route avec le Pare-feu Windows avec fonctions avancées de sécurité dans Windows Vista et Windows Server 2008

Guide de conception du Pare-feu Windows avec fonctions avancées de sécurité (éventuellement en anglais)

Introduction au serveur et domaine (éventuellement en anglais)

Paramètres du pare-feu par défaut

Pour planifier votre configuration de pare-feu, la première étape est de déterminer l'état en cours du pare-feu de votre système d'exploitation. Si le système d'exploitation a été mis à niveau à partir d'une version précédente, les anciens paramètres du pare-feu ont pu être conservés. De même, les paramètres du pare-feu ont peut-être été modifiés par un autre administrateur ou par une Stratégie de groupe dans votre domaine. Cependant, les paramètres de sécurité par défaut sont les suivants :

  • Windows Server 2008

    Le pare-feu est activé et bloque les connexions distantes.

  • Windows Server 2003

    Le pare-feu est désactivé. Les administrateurs doivent penser à activer le pare-feu.

  • Windows Vista

    Le pare-feu est activé et bloque les connexions distantes.

  • Windows XP, Service Pack 2 ou version ultérieure

    Le pare-feu est activé et bloque les connexions distantes.

  • Window XP, Service Pack 1 ou version précédente

    Le pare-feu est désactivé et doit être activé.

Remarque :
L'activation du pare-feu affectera d'autres programmes qui accèdent à cet ordinateur, comme le partage de fichiers et d'imprimantes, ainsi que les connexions Bureau à distance. Les administrateurs doivent tenir compte de toutes les applications qui s'exécutent sur l'ordinateur avant de définir les paramètres du pare-feu.

Programmes pour configurer le pare-feu

Il existe trois façons de configurer les paramètres du Pare-feu Windows.

  • Élément du Pare-feu Windows dans le Panneau de configuration

    Le composant Pare-feu Windows peut être ouvert à partir du Panneau de configuration.

    Important :
    Les modifications effectuées dans le Pare-feu Windows dans le Panneau de configuration affectent seulement le profil actuel. Les appareils mobiles, par exemple un ordinateur portable, ne doivent pas utiliser le Pare-feu Windows dans le Panneau de configuration car le profil peut changer lorsqu'il est connecté dans une configuration différente. Le profil configuré précédemment ne sera alors pas appliqué. Pour plus d'informations sur les profils, consultez Mise en route du Pare-feu Windows avec fonctions avancées de sécurité dans Windows Vista et Windows Server 2008.

    L'élément Pare-feu Windows dans le Panneau de configuration vous permet de configurer des options de base. Ces options en question sont les suivantes :

    • Activation ou désactivation du Pare-feu Windows dans le Panneau de configuration

    • Règles d'activation et de désactivation

    • Octroi d'exceptions pour les ports et les programmes

    • Définition de restrictions d'étendue

    L'option Pare-feu Windows du Panneau de configuration est très appropriée pour les utilisateurs qui ne sont pas familiarisés avec la configuration du pare-feu, et qui configurent les options de base du pare-feu de base pour les ordinateurs qui ne sont pas mobiles. Vous pouvez également ouvrir le Pare-feu Windows dans le Panneau de configuration à partir de la commande run en utilisant la procédure suivante :

    Pour ouvrir le Pare-feu Windows

    1. Dans le menu Démarrer, cliquez sur Exécuter, puis tapez firewall.cpl.

    2. Cliquez sur OK.

  • Microsoft Management Console (MMC)

    Le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité vous permet de configurer des paramètres du pare-feu plus avancés. Ce composant logiciel enfichable est uniquement disponible pour Microsoft Vista et Windows Server 2008 ; toutefois, il présente la plupart des options de pare-feu de façon simple et expose tous les profils de pare-feu. Pour plus d'informations, consultez Utilisation du composant logiciel Pare-feu Windows avec fonctions avancées de sécurité, plus loin dans cette rubrique.

  • netsh

    L'outil netsh.exe peut être utilisé par un administrateur pour configurer et surveiller des ordinateurs Windows à partir d'une invite de commandes. En utilisant l'outil netsh, vous pouvez diriger les commandes de contexte que vous entrez dans l'application d'assistance appropriée, et celle-ci exécute ensuite la commande. Une application d'assistance est un fichier de bibliothèque de liens dynamiques (.dll, Dynamic Link Library) qui étend les fonctionnalités de l'outil netsh en fournissant la configuration, l'analyse et la prise en charge d'un ou plusieurs services, utilitaires ou protocoles. Tous les systèmes d'exploitation qui prennent en charge SQL Server ont une application d'assistance de pare-feu. Microsoft Windows Vista et Windows Server 2008 ont également une application d'assistance de pare-feu avancée, appelée advfirewall. La façon d'utiliser netsh n'est pas décrite dans cette rubrique. Toutefois, un grand nombre des options de configuration décrites peuvent être configurées via netsh. Pour les scripts permettant de configurer SQL Server à l'aide de netsh, consultez Comment utiliser un script pour ouvrir par programme des ports SQL Server à utiliser sur les systèmes qui exécutent Windows XP Service Pack 2. Pour plus d'informations sur netsh, consultez les liens suivants :

    • Comment utiliser l'outil Netsh.exe et les commutateurs de ligne de commande

    • Comment utiliser le contexte « pare-feu netsh advfirewall » à la place du contexte « pare-feu netsh » pour contrôler le comportement de Pare-feu Windows dans Windows Server 2008 et Windows Vista

    • La commande de « netsh firewall » avec le paramètre « profile=all » ne configure pas le profil public sur un ordinateur Windows Vista

    • Résolution des problèmes liés aux paramètres du Pare-feu Windows dans Windows XP Service Pack 2 pour les utilisateurs expérimentés

Ports utilisés par SQL Server

Les tableaux suivants peuvent vous aider à identifier les ports utilisés par SQL Server.

Ports utilisés par le moteur de base de données

Le tableau suivant répertorie les ports qui sont fréquemment utilisés par le Moteur de base de données.

Scénario Port Commentaires

L'instance SQL Server par défaut qui s'exécute via TCP

Le port 1433 TCP

C'est le port le plus commun autorisé via le pare-feu. Il s'applique aux connexions de routine de l'installation par défaut du Moteur de base de données, ou une instance nommée qui est la seule instance qui s'exécute sur l'ordinateur. (Les instances nommées ont des considérations spéciales. Consultez ultérieurement Ports dynamiques dans cette rubrique.)

Instances nommées de SQL Server dans la configuration par défaut

Le port TCP est un port dynamique déterminé au moment des démarrages du Moteur de base de données.

Consultez l'exposé ci-dessous dans la section Ports dynamiques. Le port UDP 1434 peut être requis pour le service SQL Server Browser lorsque vous utilisez des instances nommées.

Les instances nommées de SQL Server lorsqu'elles sont configurées pour utiliser un port fixe

Le numéro de port configuré par l'administrateur.

Consultez l'exposé ci-dessous dans la section Ports dynamiques.

Connexion administrateur dédiée

Le port TCP 1434

Par défaut, les connexions distantes à la connexion administrateur dédiée (DAC) ne sont pas activées. Pour activer une DAC distante, utilisez la facette Configuration de la surface d'exposition. Pour plus d'informations, consultez Présentation de la configuration de la surface d'exposition.

Service SQL Server Browser

Port UDP 1434

Le service SQL Server Browser est à l'écoute des connexions entrantes vers une instance nommée et fournit au client le numéro de port TCP qui correspond à cette instance nommée. Normalement le service SQL Server Browser est démarré toutes les fois que les instances nommées du Moteur de base de données sont utilisées. Il n'est pas nécessaire que le service SQL Server soit démarré si le client est configuré pour se connecter au port spécifique de l'instance nommée.

Instance par défaut de SQL Server qui s'exécute sur un point de terminaison HTT.

Port TCP 80

Utilisé pour une connexion HTTP via une URL.

Instance par défaut de SQL Server qui s'exécute sur un point de terminaison HTTPS.

Port TCP 443

Utilisé pour une connexion HTTPS via une URL. HTTPS est une connexion HTTP qui utilise SSL (Secure Sockets Layer).

Service Broker

Port TCP 4022

Il n'y a aucun port par défaut pour SQL Server Service Broker, mais c'est la configuration classique.

Mise en miroir de bases de données

Port choisi par l'administrateur. Pour déterminer le port, exécutez la requête suivante :

SELECT name, protocol_desc, port, state_desc FROM sys.tcp_endpoints

WHERE type_desc = 'DATABASE_MIRRORING'

Il n'existe aucun port par défaut pour la mise en miroir de bases de données, mais c'est la configuration classique. Il est très important d'éviter d'interrompre un point de terminaison de mise en miroir en cours d'utilisation, surtout en mode haute sécurité avec basculement automatique. Votre configuration du pare-feu doit éviter de rompre le quorum. Pour plus d'informations, consultez Spécification d'une adresse réseau de serveur (mise en miroir de base de données).

Réplication

Les connexions de réplication à SQL Server utilisent les ports standard type du Moteur de base de données (port TCP 1433, etc.)

La synchronisation Web et l'accès de FTP/UNC pour la capture instantanée de réplication requièrent l'ouverture de ports supplémentaires sur le pare-feu. Pour transférer des données initiales et le schéma d'un emplacement à un autre, la réplication peut utiliser FTP (port TCP 21), ou la synchronisation via HTTP (port TCP 80) ou le partage de fichiers et d'imprimantes (port TCP 137,138 ou 139).

Pour la synchronisation via HTTP, la réplication utilise le point de terminaison IIS (dont les ports sont configurables mais qui a par défaut le port 80), mais le processus IIS se connecte au système principal SQL Server via les ports standard (1433 pour l'instance par défaut.

Pendant la synchronisation Web via FTP, le transfert FTP s'effectue entre IIS et le serveur de publication SQL Server, pas entre l'abonné et IIS.

Pour plus d'informations, consultez qui Configuration de Microsoft Internet Security and Acceleration Server pour la réplication Microsoft SQL Server 2000 sur Internet.

Débogueur Transact-SQL

Port TCP 135

Consultez Considérations spéciales relatives au port 135

L'exception IPsec peut également être requise.

Si vous utilisez Visual Studio, sur l'ordinateur hôte Visual Studio, vous devez également ajouter Devenv.exe à la liste Exceptions et ouvrir le port TCP 135.

Si vous utilisez Management Studio, sur l'ordinateur hôte Management Studio, vous devez également ajouter ssms.exe à la liste Exceptions et ouvrir le port TCP 135. Pour plus d'informations, consultez Configuration et démarrage du débogueur Transact-SQL.

Pour obtenir des instructions détaillées sur la manière de configurer le Pare-feu Windows pour le Moteur de base de données, consultez la rubrique Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données.

Ports dynamiques

Les instances nommées (y compris SQL Server Express) utilisent des ports dynamiques. Cela signifie que chaque fois que le Moteur de base de données démarre, il identifie un port disponible et utilise ce numéro de port. Si l'instance nommée est la seule instance du Moteur de base de données installée, elle utilisera probablement le port TCP 1433. Si d'autres instances du Moteur de base de données sont installées, le port utilisé sera probablement un port TCP différent. Dans la mesure où le port sélectionné peut changer chaque fois que le Moteur de base de données est démarré, il est difficile de configurer le pare-feu pour qu'il active l'accès au numéro de port correct. Par conséquent, si un pare-feu est démarré, nous recommandons de reconfigurer le Moteur de base de données pour qu'il utilise le même numéro de port à chaque fois. Cela s'appelle port fixe ou port statique. Pour plus d'informations, consultez Configuration d'un port fixe.

L'alternative à la configuration d'une instance nommée pour l'écoute sur un port fixe est de créer une exception dans le pare-feu pour un programme SQL Server, tel que sqlservr.exe (pour le Moteur de base de données). Cette approche peut être pratique, mais le numéro de port n'apparaîtra pas dans la colonne Port local de la page Règles de trafic entrant lorsque vous utilisez le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité. Cela peut rendre plus difficile le fait d'auditer quels ports sont ouverts. Une autre considération est qu'un Service Pack ou mise à jour cumulative peut modifier le chemin d'accès vers le fichier exécutable SQL Server, ce qui risque d'invalider la règle de pare-feu.

Remarque :
La procédure suivante utilise l'élément Pare-feu Windows dans le Panneau de configuration. Le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité peut configurer une règle plus complexe. Cela inclut la configuration d'une exception de service qui peut être utile pour assurer une défense en profondeur. Consultez ci-dessous Utilisation du composant logiciel enfichable Pare-feu Windows avec fonctions avancées de sécurité.

Pour ajouter une exception de programme au pare-feu à l'aide de l'élément Pare-feu Windows du Panneau de configuration.

  1. Sous l'onglet Exceptions de l'élément du Pare-feu Windows dans Panneau de configuration, cliquez sur Ajouter un programme.

  2. Accédez à l'emplacement de l'instance de SQL Server que vous souhaitez autoriser via le pare-feu, par exemple C:\Program Files\Microsoft SQL Server\MSSQL10.<nom_instance>\MSSQL\Binn, sélectionnez sqlservr.exe, puis cliquez sur Ouvrir.

  3. Cliquez sur OK.

Pour plus d'informations sur les points de terminaison, consultez Protocoles réseau et points de terminaison TDS et Affichages catalogue des points de terminaison (Transact-SQL).

Ports utilisés par Analysis Services

Le tableau suivant répertorie les ports qui sont fréquemment utilisés par Analysis Services.

Fonctionnalité | Port | Commentaires
Analysis Services | Port TCP 238 pour l'instance par défaut | Port standard pour l'instance par défaut de Analysis Services.
Service SQL Server Browser | Port TCP 2382 uniquement exigé pour une instance nommée Analysis Services | Les demandes de connexion des clients à une instance nommée de Analysis Services qui ne définissent pas un numéro de port sont dirigées vers le port 2382, qui est le port écouté par SQL Server Browser. SQL Server Browser redirige ensuite la demande vers le port utilisé par l'instance nommée.
Analysis Services configuré pour une utilisation via IIS/HTTP (Le service PivotTable® utilise HTTP ou HTTPS) | Port TCP 80 | Utilisé pour une connexion HTTP via une URL.
Analysis Services configuré pour une utilisation via IIS/HTTPS (Le service PivotTable® utilise HTTP ou HTTPS) | Port TCP 443 | Utilisé pour une connexion HTTPS via une URL. HTTPS est une connexion HTTP qui utilise SSL (Secure Sockets Layer).

Si des utilisateurs accèdent à Analysis Services via IIS et Internet, vous devez ouvrir le port sur lequel IIS écoute et spécifier ce port dans la chaîne de connexion cliente. Dans ce cas, aucun port ne doit être ouvert pour l'accès direct à Analysis Services. Le port par défaut 2389 et le port 2382, ainsi que tous les ports qui ne sont pas nécessaires, doivent être soumis à des restrictions.

Pour obtenir des instructions détaillées sur la manière de configurer le Pare-feu Windows pour Analysis Services, consultez Procédure : configurer le pare-feu Windows pour accéder à Analysis Services.

Ports utilisés par Reporting Services

Le tableau suivant répertorie les ports qui sont fréquemment utilisés par Reporting Services.

Fonctionnalité | Port | Commentaires
Services Web Reporting Services | Port TCP 80 | Utilisé pour une connexion HTTP à Reporting Services via une URL. Nous vous recommandons de ne pas utiliser la règle préconfigurée Services World Wide Web (HTTP). Pour plus d'informations, consultez ci-dessous la section Interaction avec d'autres règles de pare-feu.
Reporting Services configuré pour une utilisation via HTTPS | Port TCP 443 | Utilisé pour une connexion HTTPS via une URL. HTTPS est une connexion HTTP qui utilise SSL (Secure Sockets Layer). Nous vous recommandons de ne pas utiliser la règle préconfigurée Services World Wide Web sécurisés (HTTPS). Pour plus d'informations, consultez ci-dessous la section Interaction avec d'autres règles de pare-feu.

Lorsque Reporting Services se connecte à une instance du Moteur de base de données ou Analysis Services, vous devez également ouvrir les ports appropriés pour ces services. Pour obtenir des instructions détaillées sur la manière de configurer le Pare-feu Windows pour Reporting Services, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

Ports utilisés par Integration Services

Le tableau suivant répertorie les ports qui sont utilisés par le service Integration Services.

Fonctionnalité Port Commentaires

Appels de procédure distante Microsoft (MS RPC)

Utilisé par le runtime Integration Services.

Port TCP 135

Consultez Considérations spéciales relatives au port 135

Le service Integration Services utilise DCOM sur le port 135. Le Gestionnaire de contrôle des services utilise le port 135 pour effectuer des tâches telles que le démarrage et l'arrêt du service Integration Services ainsi que la transmission des demandes de contrôle au service en exécution. Le numéro de port ne peut pas être modifié.

Ce port ne doit être ouvert que si vous vous connectez à une instance distante du service Integration Services à partir de Management Studio ou d'une application personnalisée.

Pour obtenir des instructions détaillées sur la manière de configurer le Pare-feu Windows pour Integration Services, consultez Configuration d'un pare-feu Windows pour accéder à Integration Services et Procédure : configurer un pare-feu Windows pour Integration Services.

Ports et services supplémentaires

Le tableau suivant répertorie les ports et services dont SQL Server peut dépendre.

Scénario Port Commentaires

Windows Management Instrumentation

Pour plus d'informations sur WMI, consultez WMI Provider for Configuration Management Concepts.

WMI s'exécute dans le cadre d'un hôte de service partagé avec les ports attribués via DCOM. WMI peut utiliser le port TCP 135.

Consultez Considérations spéciales relatives au port 135

Le Gestionnaire de configurations SQL Server utilise WMI pour lister et gérer des services. Nous vous recommandons d'utiliser la règle préconfigurée Windows Management Instrumentation (WMI). Pour plus d'informations, consultez ci-dessous la section Interaction avec d'autres règles de pare-feu.

Microsoft Distributed Transaction Coordinator (MS DTC)

Port TCP 135

Consultez Considérations spéciales relatives au port 135

Si votre application utilise des transactions distribuées, vous devez éventuellement configurer le pare-feu pour autoriser le trafic MS DTC (Microsoft Distributed Transaction Coordinator) entre des instances MS DTC distinctes, et entre MS DTC et les gestionnaires de ressources tels que SQL Server. Nous vous recommandons d'utiliser le groupe de règles préconfigurées Distributed Transaction Coordinator.

Le bouton Parcourir dans Management Studio utilise UDP pour se connecter au service SQL Server Browser. Pour plus d'informations, consultez Service SQL Server Browser.

Port UDP 1434

UDP est un protocole sans connexion.

Le pare-feu a un paramètre, nommé Propriété UnicastResponsesToMulticastBroadcastDisabled de l'interface INetFwProfile, qui contrôle le comportement du pare-feu par rapport aux réponses monodiffusion (unicast) à une demande UDP multidiffusion (ou multicast). Il a deux comportements :

  • Si le paramètre est TRUE, aucune réponse de monodiffusion à une diffusion n'est autorisée. L'énumération des services échouera.

  • Si le paramètre est FALSE (valeur par défaut), les réponses de monodiffusion sont autorisées pendant 3 secondes. La durée n'est pas configurable. Dans un réseau encombré ou à latence élevée, ou pour les serveurs très chargés, toute tenative d'énumération des instances de SQL Server peut retourner une liste partielle, qui peut induire les utilisateurs en erreur.

Trafic IPsec

Port UDP 500 et port UDP 4500

Si la stratégie de domaine exige que les communications réseau s'effectuent par le biais du protocole IPsec, vous devez également ajouter les ports UDP 4500 et UDP 500 à la liste des exceptions. IPsec est une option de l'Assistant Nouvelle règle de trafic entrant dans le composant logiciel enfichable Pare-feu Windows. Pour plus d'informations, consultez ci-dessous Utilisation du composant logiciel enfichable Pare-feu Windows avec fonctions avancées de sécurité.

Utilisation de l'authentification Windows avec les domaines approuvés

Les pare-feu doivent être configurés pour autoriser des demandes d'authentification.

Pour plus d'informations, consultez Comment faire pour configurer un pare-feu pour les domaines et les approbations.

SQL Server et le clustering Windows

Le clustering requiert des ports supplémentaires qui ne sont pas directement en rapport avec SQL Server.

Pour plus d'informations, consultez Activer un réseau pour une utilisation du cluster.

Des espaces de noms réservés de l'URL dans l'API HTTP Server (HTTP.SYS)

Probablement le port TCP 80, mais la configuration d'autres ports est possible. Pour les informations générales, consultez Configuration de HTTP et HTTPS.

Pour informations spécifiques à SQL Server en ce qui concerne la réservation d'un point de terminaison HTTP.SYS à l'aide de HttpCfg.exe, consultez Reserving URL Namespaces by Using Http.sys.

Considérations spéciales relatives au port 135

Lorsque vous utilisez RPC avec TCP/IP ou avec UDP/IP comme transport, les ports entrants sont fréquemment attribués de manière dynamique aux services système en fonction des besoins ; les ports TCP/IP et UDP/IP qui sont supérieurs au port 1024 sont utilisés. Ces ports sont souvent appelés de façon informelle « ports RPC aléatoires ». Dans ces cas, les clients RPC comptent sur le mappeur de points de terminaison RPC pour leur indiquer quels ports dynamiques ont été attribués au serveur. Pour certains services basés sur RPC, vous pouvez configurer un port spécifique au lieu de laisser RPC en attribuer un dynamiquement. Vous pouvez également limiter la plage de ports que RPC attribue dynamiquement, indépendamment du service. Pour plus d'informations sur cette rubrique, activez les liens suivants :

  • Vue d'ensemble des services et exigences de ports réseau pour le système Windows Server

  • Comment faire pour corriger les erreurs du mappeur de points de terminaison RPC à l'aide d'outils de support Windows Server 2003 disponibles sur le CD-ROM du produit

  • Utilisation de DCOM avec les pare-feu

  • Appel de procédure distante (RPC)

  • Comment faire pour configurer l'allocation de port dynamique RPC avec un pare-feu

  • Démarrage de Windows 2000 et analyse du trafic d'ouverture de session

Interaction avec d'autres règles de pare-feu

Le Pare-feu Windows utilise des règles et des groupes de règles pour établir sa configuration. Chaque règle ou groupe de règles est généralement associé à un programme ou service particulier, et ce programme ou service peut modifier ou supprimer qui règle à votre insu. Par exemple, les groupes de règles Services World Wide Web (HTTP) et Services World Wide Web (HTTPS) sont associés à IIS. L'activation de ces règles ouvrira les ports 80 et 443, et les fonctionnalités de SQL Server qui dépendent des ports 80 et 443 fonctionneront si ces règles sont activées. Toutefois, les administrateurs qui configurent IIS peuvent modifier ou désactiver ces règles. Par conséquent, si vous utilisez le port 80 ou le port 443 pour SQL Server, vous devez créer votre propre règle ou groupe de règles qui conserve votre configuration de port souhaitée indépendamment des autres règles IIS.

Le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité autorise tout trafic qui correspond aux règles d'autorisation applicables. S'il existe deux règles qui s'appliquent toutes deux au port 80 (avec des paramètres différents), le trafic qui correspond à l'une ou l'autre règle sera autorisé. Si une règle autorise le trafic sur le port 80 du sous-réseau local et l'autre règle autorise le trafic à partir de n'importe quelle adresse, le résultat fait que tout le trafic vers le port 80 est autorisé indépendamment de la source. Pour gérer efficacement l'accès à SQL Server, les administrateurs doivent périodiquement examiner toutes les règles de pare-feu activées sur le serveur.

Vue d'ensemble des profils de pare-feu

Les profils de pare-feu sont examinés dans Mise en route du Pare-feu Windows avec fonctions avancées de sécurité dans Windows Vista et Windows Server 2008 de la section Pare-feu d'hôte prenant en charge l'emplacement réseau. Pour résumer, Windows Vista et Windows Server 2008 identifient et gardent en mémoire chacun des réseaux auxquels ils se connectent (connectivité, connexions et catégorie).

Il existe trois types d'emplacements réseau dans le Pare-feu Windows avec fonctions avancées de sécurité :

  • Domaine. Windows peut authentifier l'accès au contrôleur de domaine pour le domaine auquel l'ordinateur est joint.

  • Public. En dehors des réseaux de domaine, tous les réseaux sont catégorisés initialement en tant que publics. Les réseaux qui représentent des connexions directes à l'Internet ou qui se trouvent à emplacements publics, tels que les aéroports et les cafés, doivent rester publics.

  • Privé. Réseau identifié par un utilisateur ou une application comme privé. Seuls les réseaux de confiance doivent être identifiés en tant que réseaux privés. Les utilisateurs identifient généralement comme privés les réseaux domestiques ou les réseaux pour petites entreprises.

L'administrateur peut créer un profil pour chaque type d'emplacement réseau, chaque profil contenant des stratégies de pare-feu différentes. Un seul profil est appliqué à la fois. L'ordre des profils est appliqué comme suit :

  1. Si toutes les interfaces sont authentifiées au contrôleur de domaine pour le domaine dans lequel l'ordinateur est membre, le profil de domaine est appliqué.

  2. Si toutes les interfaces sont authentifiées au contrôleur de domaine ou sont connectées à des réseaux classifiés comme emplacements de réseau privés, le profil privé est appliqué.

  3. Autrement, le profil public est appliqué.

Utilisez le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité pour afficher et configurer tous les profils de pare-feu. L'élément du Pare-feu Windows dans le Panneau de configuration configure seulement le profil actuel.

Paramètres de pare-feu supplémentaires utilisant l'élément Pare-feu Windows dans le Panneau de configuration

Les exceptions que vous ajoutez au pare-feu peuvent restreindre l'ouverture du port aux connexions entrantes à partir d'ordinateurs spécifiques ou du sous-réseau local. Cette restriction de la portée d'ouverture de port peut réduire la surface d'exposition de votre ordinateur aux utilisateurs malveillants, et elle est recommandée.

Remarque :
L'utilisation de l'élément Pare-feu Windows dans le Panneau de configuration configure seulement le profil de pare-feu actuel.

Pour modifier l'étendue d'une exception de pare-feu à l'aide de l'élément Pare-feu Windows dans le Panneau de configuration

  1. Dans Pare-feu Windows du Panneau de configuration, sélectionnez un programme ou un port sous l'onglet Exceptions, puis cliquez sur Propriétés ou Modifier.

  2. Dans la boîte de dialogue Modifier un programme ou Modifier un port, cliquez sur Modifier l'étendue.

  3. Choisissez l'une des options suivantes :

    • N'importe quel ordinateur (y compris ceux présents sur Internet)

      Option non recommandée. Cela autorisera tout ordinateur qui peut adresser votre ordinateur à se connecter au programme ou port spécifié. Ce paramètre peut être nécessaire pour autoriser la présentation d'informations à des utilisateurs anonymes sur Internet, mais augmente votre exposition aux utilisateurs malveillants. Votre exposition peut être accrue encore plus si vous activez ce paramètre et également autorisez la traversée NAT (Network Address Translation), comme l'option Autoriser la traversée latérale.

    • Uniquement mon réseau (ou sous-réseau)

      Ce paramètre plus sécurisé que N'importe quel ordinateur. Seuls les ordinateurs présents sur le sous-réseau local de votre réseau peuvent se connecter au programme ou port.

    • Liste personnalisée :

    Seuls les ordinateurs qui correspondent aux adresses IP de votre liste peuvent se connecter. Ce paramètre peut être plus sécurisé que l'option Uniquement mon réseau (ou sous-réseau) ; toutefois, les ordinateurs clients utilisant DHCP peuvent parfois modifier leur adresse IP. L'ordinateur prévu ne sera alors pas en mesure de se connecter. Un autre ordinateur, que vous n'aviez pas projeté d'autoriser, peut accepter l'adresse IP répertoriée puis être en mesure de se connecter. L'option Liste personnalisée peut être appropriée pour lister des autres serveurs qui sont configurés pour utiliser une adresse IP fixe ; toutefois, les adresses IP peuvent être usurpées par un intrus. Les règles de pare-feu restrictives ne sont fortes que si votre infrastructure réseau l'est aussi.

Utilisation du composant logiciel enfichable Pare-feu Windows avec fonctions avancées de sécurité

Sur les ordinateurs qui exécutent Vista ou Windows Server 2008, des paramètres de pare-feu avancés supplémentaires peuvent être configurés en utilisant le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité. Le composant logiciel enfichable inclut un Assistant Règle et expose des paramètres supplémentaires qui ne sont pas disponibles dans l'élément Pare-feu Windows du Panneau de configuration. Ces paramètres sont les suivants :

  • Paramètres de chiffrement

  • Restrictions de services

  • Restriction des connexions pour les ordinateurs par nom

  • Restriction des connexions à des utilisateurs ou profils spécifiques

  • Traversée latérale autorisant le trafic de contourner les routeurs NAT (Network Address Translation)

  • Configuration de règles de trafic sortant

  • Configuration de règles de sécurité

  • Présence nécessaire d'IPsec pour les connexions entrantes

Pour créer une règle de pare-feu à l'aide de l'Assistant Nouvelle règle

  1. Dans le menu Démarrer, cliquez sur Exécuter, tapez WF.msc, puis cliquez sur OK.

  2. Dans le Pare-feu Windows avec fonctions avancées de sécurité, dans le volet gauche, cliquez avec le bouton droit sur Règles de trafic entrant, puis cliquez sur Nouvelle règle.

  3. Exécutez l'Assistant Nouvelle règle de trafic entrant à l'aide des paramètres que vous souhaitez.

Résolution des problèmes liés aux paramètres du pare-feu

Les outils et techniques suivants peuvent être utiles pour résoudre les problèmes liés au pare-feu :

  • L'état effectif du port repose sur l'union de toutes les règles en rapport avec le port. Lors de la tentative de bloquer l'accès via un port, il peut être utile d'examiner toutes les règles qui citent le numéro de port. Pour cela, utilisez le composant logiciel enfichable MMC du Pare-feu Windows avec fonctions avancées de sécurité et triez les règles du trafic entrant et sortant par numéro de port.

  • Examinez les ports qui sont actifs sur l'ordinateur sur lequel SQL Server s'exécute. Ce processus de vérification inclut l'identification des ports TCP/IP qui écoutent, ainsi que de l'état des ports.

    Pour vérifier les ports qui écoutent, utilisez l'utilitaire de ligne de commande netstat. L'utilitaire netstat affiche non seulement les connexions IP actives, mais également diverses statistiques et informations IP.

    Pour lister les ports TCP/IP qui sont à l'écoute

    1. Ouvrez la fenêtre d'invite de commandes.

    2. À l'invite de commandes, tapez netstat -n -a.

      Le commutateur -n indique à netstat d'afficher l'adresse numérique et le numéro de port des connexions TCP actives. Le commutateur -a indique à netstat d'afficher les ports TCP et UPD écoutés par l'ordinateur.
  • L'utilitaire PortQry peut être utilisé pour signaler l'état des ports TCP/IP comme à l'écoute, pas à l'écoute ou filtré. (Lorsque l'état est filtré, le port peut être à l'écoute ou non ; cet état indique que l'utilitaire n'a pas reçu de réponse du port.) L'utilitaire PortQry peut être téléchargé à partir du Centre de téléchargement Microsoft.

Pour des rubriques supplémentaires sur la résolution des problèmes, consultez :

  • Résolution des problèmes liés aux paramètres du Pare-feu Windows avec fonctions avancées de sécurité dans Windows Vista et Windows Server 2008 - Diagnostics et outils

  • Dépannage (moteur de base de données)

  • Dépannage (Analysis Services - Exploration de données)

  • Dépannage (Reporting Services)

  • Dépannage (Integration Services)

Voir aussi

Concepts

Avant l'installation du clustering de basculement

Autres ressources

Vue d'ensemble des services et exigences de ports réseau pour le système Windows Server


Bases de données système et exemples de bases de données

Bases de données système et exemples de bases de données |
 | Voir aussi
Configuration de SQL Server 2008 >

Lorsque SQL Server est installé, le programme d'installation crée les fichiers de base de données et les fichiers journaux présentés dans le tableau suivant.

Base de données | Fichier de base de données | Fichier journal
master | Master.mdf | mastlog.ldf
model | Model.mdf | Modellog.ldf
msdb | Msdbdata.mdf | Msdblog.ldf
tempdb | Tempdb.mdf | Templog.ldf
mssqlsystemresource | Mssqlsystemresource.mdf | Mssqlsystemresource.ldf

Les bases de données système sont master, model, msdb, mssqlsystemresource et tempdb.

Remarque :
L'emplacement par défaut des fichiers de base de données et des fichiers journaux est Program Files\Microsoft SQL Server\MSQL10.<nom_instance>\MSSQL\. Il peut s'agir d'un autre emplacement si le répertoire par défaut a été modifié pendant l'installation de SQL Server.

Exemples de bases de données AdventureWorks

Par défaut, les exemples de bases de données ne sont pas installés dans cette version de SQL Server. Pour plus d'informations sur l'installation des exemples de bases de données et des exemples de code, consultez le site Web de CodePlex.

Les informations supplémentaires sur les exemples sont disponibles après que SQL Server 2008 a été installé. Dans le menu Démarrer, cliquez sur Programmes, sur Microsoft SQL Server 2008, sur Documentation et didacticiels, puis sur Vue d'ensemble des exemples pour Microsoft SQL Server.

Voir aussi

Tâches

Considérations relatives à l'installation d'exemples de bases de données et d'exemples de code SQL Server

Concepts

Installation de SQL Server 2008
Mise à niveau vers SQL Server 2008

Autres ressources

Getting Started with SQL Server Projects and Administration


Guide de référence de l'interface utilisateur du programme d'installation de SQL Server

Guide de référence de l'interface utilisateur du programme d'installation de SQL Server |
 | Voir aussi

Cette section décrit les options d'installation proposées par l'Assistant Installation de SQL Server.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Accepter les termes du contrat de licence

Accepter les termes du contrat de licence |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Accepter les termes du contrat de licence de l'Assistant Installation de SQL Server pour accepter les termes du contrat de licence de cette version de SQL Server.

Options

Vous pouvez imprimer le contrat de licence ou le copier dans le Presse-papiers. Pour continuer, acceptez le contrat de licence, puis cliquez sur Suivant. Pour quitter l'installation, cliquez sur Annuler.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

À propos des termes du contrat de licence SQL Server


Ajouter un nœud de cluster de basculement SQL Server

Ajouter un nœud de cluster de basculement SQL Server |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système


Configuration Analysis Services – Mise en service de compte

Configuration Analysis Services – Mise en service de compte |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Déjà amorcées dans SQL Server 2005, des modifications significatives ont été implémentées pour garantir que SQL Server était plus sécurisé que les versions antérieures. Les modifications incluaient une stratégie que l'on pourrait appeler « stratégie de sécurisation par conception, de sécurisation par défaut et de sécurisation dans le déploiement » et destinée à protéger le serveur et ses bases de données des attaques contre la sécurité.

SQL Server 2008 poursuit le processus de renforcement de la sécurité en apportant de nouvelles modifications aux composants du serveur et des bases de données. SQL Server 2008 utilise des fonctionnalités, telles que le Contrôle de compte d'utilisateur (UAC), disponibles dans Windows Vista et Windows Server 2008.

Les modifications introduites dans SQL Server 2008 aident à réduire la surface et les zones d'attaque du serveur et de ses bases de données en instituant la stratégie dite de l'« autorité la moins privilégiée ». Cette stratégie signifie que les comptes internes sont protégés et séparés en fonctions du système d'exploitation et en fonctions SQL Server. Les mesures adoptées sont les suivantes :

  • Possibilité de mettre en service une ou plusieurs entités de sécurité Windows dans le rôle serveur de Sysadmin au sein de SQL Server. Cette option est disponible pendant l'installation de SQL Server.

  • L'outil Configuration de la surface d'exposition (SAC) a été supprimé. Il a été remplacé par la gestion basée sur des stratégies, et des modifications ont été apportées au Gestionnaire de configuration.

Ces modifications affectent votre plan de sécurité pour SQL Server et vous aident à créer un profil de sécurité plus complet pour votre système.

Considérations relatives à l'exécution de SQL Server 2008 dans Windows Vista

Dans les versions Windows antérieures à Windows Vista, les membres du groupe local Administrateurs n'ont pas besoin de leurs propres connexions SQL Server et il n'est pas nécessaire de leur accorder des droits d'administration dans SQL Server. Ils se connectent à SQL Server en tant qu'entité de sécurité de serveur intégrée BUILTIN\Administrateurs et disposent de droits d'administration au sein de SQL Server, car BUILTIN\Administrateurs est membre du rôle serveur fixe sysadmin.

Dans Windows Vista, ces mécanismes sont disponibles seulement pour les utilisateurs administratifs qui disposent d'autorisations Windows élevées, ce qui n'est pas recommandé. Par défaut, les administrateurs effectuent la plupart des actions en tant qu'utilisateur standard sur les systèmes d'exploitation Windows Vista et Windows Server 2008. Par conséquent, vous devez créer une connexion SQL Server pour chaque utilisateur administrateur et ajouter ce nom de connexion au rôle serveur fixe sysadmin. Vous devez procéder de même pour les comptes Windows utilisés pour exécuter les travaux de l'Agent SQL Server. Ceux-ci incluent les travaux de l'agent de réplication.

Vous devez tenir compte des points suivants lors de l'installation et de l'exécution de SQL Server 2008 dans Windows Vista.

Problèmes dus au contrôle de compte d'utilisateur dans Windows Vista

Windows Vista inclut une nouvelle fonctionnalité, le Contrôle de compte d'utilisateur, qui permet aux administrateurs de gérer les autorisations élevées qu'ils utilisent. Par défaut, dans Windows Vista, les administrateurs n'utilisent pas leurs droits d'administration. À la place, ils effectuent la plupart des actions en tant qu'utilisateurs standard (non administratifs), n'assumant temporairement leurs droits d'administration que lorsque cela est nécessaire.

Le Contrôle de compte d'utilisateur entraîne certains problèmes connus. Pour plus d'informations, consultez les pages Web suivantes sur TechNet :

Windows Vista : Contrôle de compte d'utilisateur

Options

Spécifiez les administrateurs SQL Server - Vous devez spécifier au moins un administrateur système pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur le bouton Utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server.

Lorsque vous avez terminé de modifier la liste, cliquez sur OK, puis vérifiez la liste des administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

Voir aussi

Référence

Configuration des comptes de service Windows


Configuration de Analysis Services – Répertoires de données

Configuration de Analysis Services – Répertoires de données |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les répertoires par défaut indiqués dans le tableau suivant sont configurables par l'utilisateur pendant l'installation de SQL Server.

Description | Répertoire par défaut | Recommandations
Répertoire de données racine | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_Instance>\OLAP\Data\ | Assurez-vous que le dossier \Program files\Microsoft SQL Server\ est protégé avec des autorisations limitées. Le fonctionnement de Analysis Services dépend, dans de nombreuses configurations, de la performance de l'emplacement de stockage sur lequel le répertoire de données se trouve. Placez ce répertoire sur l'emplacement de stockage le plus performant raccordé au système. Pour les installations de cluster de basculement, vérifiez que les répertoires de données sont placés sur le disque partagé.
Répertoire de fichiers journaux | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_instance>\OLAP\Log\ | C'est le répertoire des fichiers journaux Analysis Services ; il inclut le journal FlightRecorder. Si vous augmentez la durée de la boîte noire, assurez-vous que le répertoire de journal dispose de l'espace adéquat.
Répertoire Temp | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_Instance>\OLAP\Temp\ | Placez le répertoire Temp sur le sous-système de stockage le plus performant.
Répertoire de sauvegarde | C:\Program Files\Microsoft SQL Server\MSAS10.<ID_Instance>\OLAP\Backup\ | Il s'agit du répertoire pour les fichiers de sauvegarde par défaut Analysis Services. Vérifiez que des autorisations appropriées sont définies pour empêcher la perte de données et vérifiez que le groupe d'utilisateurs pour le service Analysis Services a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

Remarques

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont uniques à cette instance de SQL Server. Aucun des répertoires dans cette boîte de dialogue ne doit être partagé avec des répertoires d'autres instances de SQL Server.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur des lecteurs partagés sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server


Sélection du disque du cluster

Sélection du disque du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection du disque du cluster de l'Assistant Installation de SQL Server pour sélectionner la ressource de disque de cluster partagée pour votre cluster de basculement SQL Server. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Options

Disques partagés

Sélectionnez un disque dans la liste. Le disque de cluster est l'emplacement où les données SQL Server seront placées.

Un seul disque peut être spécifié. Si vous sélectionnez le groupe contenant la ressource quorum du cluster, un avertissement s'affiche. Il est recommandé de ne pas procéder à l'installation dans cette ressource.

Disques partagés disponibles

Affiche une liste de disques disponibles, indique si chacun d'eux est qualifié en tant que disque partagé et fournit une description de chaque ressource de disque.


Sélection du réseau du cluster

Sélection du réseau du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection du réseau du cluster pour spécifier les ressources réseau de votre instance de cluster de basculement.

Options

Nom réseau du cluster de basculement SQL Server - Il s'agit du nom identifiant votre instance de cluster de basculement sur le réseau.

Paramètres réseau - Spécifiez le type IP et l'adresse IP de votre instance de cluster de basculement.


Configuration du nœud de clusters

Configuration du nœud de clusters
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du nœud de clusters pour ajouter ou supprimer des nœuds d'une instance de cluster de basculement.

Options

Nom de l'instance SQL Server - Utilisez la liste déroulante pour sélectionner l'instance de cluster de basculement SQL Server à modifier.

Nom de ce nœud - Ce champ contiendra le nom de l'ordinateur qui exécute le programme d'installation de SQL Server. Il s'agit du nœud de cluster de basculement qui sera ajouté ou supprimé de l'instance de cluster de basculement SQL Server.


Configuration du nœud de clusters (Complète)

Configuration du nœud de clusters (Complète) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du nœud de clusters (Complète) pour spécifier une instance existante de SQL Server préparée pour le clustering.

Options

Dans les zones de liste déroulante :

  • Nom de l'instance SQL Server — Sélectionnez le nom de l'instance pour le cluster de basculement SQL Server.

  • Nom de ce nœud — Ce champ sera prérempli avec le nom de l'ordinateur où le programme d'installation de SQL Server s'exécute.

  • Nom réseau du cluster de basculement SQL Server— Ce champ n'est pas prérempli. Indiquez le nom réseau de la nouvelle instance de cluster de basculement SQL Server. Il s'agit du nom qui identifie l'instance de cluster de basculement sur le réseau.

Voir aussi

Tâches

Procédure : créer un cluster de basculement SQL Server (programme d'installation)


Groupe de ressources de cluster

Groupe de ressources de cluster |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Groupe de ressources de cluster pour spécifier le disque où les ressources du serveur virtuel SQL Server seront hébergées.

Options

Spécifiez le nom du groupe de ressources de cluster SQL Server. Vous avez le choix entre deux options :

  • Utilisez la zone de liste déroulante pour spécifier un groupe existant à utiliser.

  • Tapez le nom d'un groupe à créer. Notez que le nom « Stockage disponible » n'est pas un nom de groupe valide.

Voir aussi

Tâches

Procédure : créer un cluster de basculement SQL Server (programme d'installation)


Stratégie de sécurité du cluster

Stratégie de sécurité du cluster
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Stratégie de sécurité du cluster pour configurer la stratégie de sécurité pour votre instance de cluster de basculement.

Options

Spécifiez des groupes de domaines locaux ou globaux pour les services cluster. Toutes les autorisations de ressources sont gérées par des groupes au niveau du domaine qui incluent des comptes de service SQL Server en tant que membres de groupe. Pour plus d'informations sur les fonctionnalités des ID de sécurité (SID) d'un service sur Windows Server 2008, consultez Configuration des comptes de service Windows.


Complète (Mise à niveau)

Complète (Mise à niveau) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Complète (Mise à niveau) pour vérifier que la mise à niveau est terminée.

Options

Cette boîte de dialogue comprend un lien vers le fichier journal d'installation pour cette opération. Pour continuer, cliquez sur Fermer.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Informations d'identification pour la mise à niveau de base de données distante

Informations d'identification pour la mise à niveau de base de données distante |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Informations d'identification pour la mise à niveau de base de données distante de l'Assistant Installation de Microsoft SQL Server pour spécifier une connexion à une base de données à une base de données de serveur de rapports distante.

Si vous mettez à niveau une base de données de serveur de rapports sur une instance SQL Server Moteur de base de données distante et que vous exécutez le programme d'installation sous des informations d'identification qui n'ont pas d'autorisations de mise à jour de base de données sur une instance distante, vous devez entrer des informations d'identification que le programme d'installation peut utiliser pour se connecter à la base de données du serveur de rapports et la modifier.

Options

Nom d'utilisateur

Spécifie une connexion de base de données SQL Server utilisée de manière ponctuelle durant une opération de mise à niveau pour la connexion à l'instance du Moteur de base de données qui héberge la base de données du serveur de rapports. Le compte doit avoir l'autorisation de mettre à jour le schéma de base de données du serveur de rapports.

Requise si les informations d'identification que vous utilisez pour exécuter le programme d'installation ne disposent pas d'autorisations sysadmin ou de propriétaire de base de données sur la base de données du serveur de rapports.

Cette valeur doit être spécifiée si vous mettez à niveau un serveur de rapports qui utilise une base de données de serveur de rapports distante pour stocker des données d'application et que les informations d'identification que vous avez utilisées pour exécuter le programme d'installation ne disposent pas d'autorisations suffisantes sur le serveur distant.

Mot de passe

Mot de passe pour la connexion ou une chaîne vide si la connexion n'a pas de mot de passe.

Voir aussi

Concepts

Considérations sur la mise à niveau de Reporting Services
Considérations sur l'installation de Reporting Services


Configuration du moteur de base de données – Mise en service de compte

Configuration du moteur de base de données – Mise en service de compte |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Amorcées dans SQL Server 2005, des modifications significatives ont été implémentées pour garantir que SQL Server était plus sécurisé que les versions antérieures. Les modifications incluaient une stratégie que l'on pourrait appeler « stratégie de sécurisation par conception, de sécurisation par défaut et de sécurisation dans le déploiement » et destinée à protéger l'instance du serveur et ses bases de données des attaques contre la sécurité.

SQL Server 2008 poursuit le processus de renforcement de la sécurité en apportant de nouvelles modifications aux composants du serveur et des bases de données. SQL Server 2008 exploite le Contrôle de compte d'utilisateur (UAC) disponible dans Windows Vista et Windows Server 2008.

Les modifications introduites dans SQL Server 2008 réduisent la surface et les zones d'attaque du serveur et de ses bases de données en instituant la stratégie dite de l'« autorité la moins privilégiée ». Cette stratégie signifie que les comptes internes sont protégés et séparés en fonctions du système d'exploitation et en fonctions SQL Server. Ces mesures sont les suivantes :

  • Possibilité de mettre en service une ou plusieurs entités Windows dans le rôle serveur de Sysadmin à l'intérieur de SQL Server. Cette option est disponible pendant l'installation de SQL Server.

  • L'outil Configuration de la surface d'exposition a été supprimé et remplacé par la gestion basée sur des stratégies et les modifications de l'outil Gestionnaire de configuration.

Ces modifications affectent votre plan de sécurité pour SQL Server et vous aident à créer un profil de sécurité plus complet pour votre système.

Considérations relatives à l'exécution de SQL Server 2008 sous Windows Vista

Dans les versions antérieures à Windows Vista, les membres du groupe local Administrateurs n'ont pas besoin de leurs propres connexions SQL Server et il n'est pas nécessaire de leur accorder des droits d'administration dans SQL Server. Ils se connectent à SQL Server en tant qu'entité de sécurité de serveur intégrée BUILTIN\Administrators et disposent de droits d'administration au sein de SQL Server, car BUILTIN\Administrators est membre du rôle de serveur fixe sysadmin.

Sous Windows Vista, ces mécanismes sont disponibles seulement pour les utilisateurs administratifs qui disposent d'autorisations Windows élevées, ce qui n'est pas recommandé. Par défaut, les administrateurs effectuent la plupart des actions en tant qu'utilisateur standard sur Windows Vista et les systèmes d'exploitation Windows Server 2008. Par conséquent, vous devez créer une connexion SQL Server pour chaque utilisateur administrateur et ajouter ce nom de connexion au rôle de serveur fixe sysadmin. Vous devez procéder de même pour les comptes Windows utilisés pour exécuter les travaux de l'Agent SQL Server. Ceux-ci incluent les travaux de l'agent de réplication.

Vous devez tenir compte des points suivants lors de l'installation et de l'exécution de SQL Server 2008 sous Windows Vista.

Problèmes dus au contrôle de compte d'utilisateur dans Windows Vista

Windows Vista inclut une nouvelle fonctionnalité, le Contrôle de compte d'utilisateur, qui permet aux administrateurs de gérer les autorisations élevées qu'ils utilisent. Par défaut, sous Windows Vista, les administrateurs n'utilisent pas leurs droits d'administration. À la place, ils effectuent la plupart des actions en tant qu'utilisateurs standard, n'assumant temporairement leurs droits d'administration que lorsque cela est nécessaire.

Le Contrôle de compte d'utilisateur entraîne certains problèmes connus. Pour plus d'informations, consultez les pages Web suivantes sur TechNet :

Windows Vista : Contrôle de compte d'utilisateur

Options

Mode de sécurité - Sélectionnez l'authentification Windows ou l'authentification de mode mixte pour votre installation.

Mise en service de l'entité de sécurité Windows - Dans les versions antérieures de SQL Server, le groupe local de Windows Builtin\Administrator a été placé dans le rôle serveur sysadmin de SQL Server, en accordant aux administrateurs Windows l'accès à l'instance de SQL Server.

Important :
Si le code ou les processus de votre organisation dépendent de l'accès au groupe local Windows Builtin\Administrator, vous devez accorder explicitement le droit d'ouverture de session sur SQL Server. L'installation ne vous permet pas de continuer tant que cette étape n'a pas été effectuée.

Spécifiez les administrateurs SQL Server - Vous devez spécifier au moins une entité de sécurité Windows pour l'instance de SQL Server. Pour ajouter le compte sous lequel le programme d'installation de SQL Server s'exécute, cliquez sur le bouton Utilisateur actuel. Pour ajouter ou supprimer des comptes dans la liste des administrateurs système, cliquez sur Ajouter ou Supprimer, puis modifiez la liste des utilisateurs, groupes ou ordinateurs qui disposeront des privilèges d'administrateur pour l'instance de SQL Server.

Lorsque vous avez terminé de modifier la liste, cliquez sur OK, puis vérifiez la liste des administrateurs dans la boîte de dialogue de configuration. Une fois la liste complète, cliquez sur Suivant.

Si vous sélectionnez l'authentification de mode mixte, vous devez fournir les informations d'identification de session pour le compte de l'administrateur système (SA) SQL Server intégré.

Remarque relative à la sécurité :
N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort.

Mode d'authentification Windows

Quand un utilisateur se connecte par le biais d'un compte d'utilisateur Windows, SQL Server valide le nom et le mot de passe du compte à l'aide du jeton de l'entité de sécurité Windows du système d'exploitation. Il s'agit du mode d'authentification par défaut et il est plus fiable que le mode mixte. L'authentification Windows utilise le protocole de sécurité Kerberos, met en œuvre les stratégies de mot de passe en termes de validation de la complexité des mots de passe forts et prend en charge le verrouillage des comptes et l'expiration des mots de passe.

Remarque relative à la sécurité :
Lorsque c'est possible, utilisez l'authentification Windows.

Important :
N'utilisez pas de mot de passe vide. Utilisez un mot de passe fort. Ne définissez jamais un mot de passe sa vide ou faible.

Mode mixte (authentification Windows ou authentification SQL Server)

Permet aux utilisateurs de se connecter en utilisant l'authentification Windows ou l'authentification SQL Server. Les utilisateurs qui se connectent via un compte d'utilisateur Windows peuvent utiliser des connexions approuvées qui sont validées par Windows.

Si vous devez choisir l'authentification en mode mixte et utiliser des connexions SQL pour vous adapter à des applications héritées, définissez des mots de passe forts pour tous les comptes SQL Server.

Remarque :
L'authentification SQL Server est fournie uniquement dans un souci de compatibilité descendante. Lorsque c'est possible, utilisez l'authentification Windows.

Entrer le mot de passe

Entrez et confirmez la connexion d'administrateur système (sa). Les mots de passe constituant la première ligne de défense contre les intrus, le choix de mots de passe forts est essentiel à la sécurité de votre système. Ne définissez jamais un mot de passe sa vide ou faible.

Remarque :
Les mots de passe SQL Server peuvent contenir de 1 à 128 caractères, notamment des lettres, des symboles et des chiffres. Si vous choisissez l'authentification en mode mixte, vous devez d'abord entrer un mot de passe sa fort avant de passer à la page suivante de l'Assistant Installation.

Instructions sur les mots de passe forts

Les mots de passe forts ne peuvent pas être aisément devinés par une personne et ils ne sont pas aisément piratés par un programme informatique. Les mots de passe forts ne peuvent pas utiliser des conditions ou des termes interdits, notamment :

  • Une condition vide ou NULL

  • "Password"

  • "Admin"

  • "Administrator"

  • "sa"

  • "sysadmin"

Un mot de passe fort ne peut pas se composer des termes suivants associés à l'ordinateur d'installation :

  • Le nom de l'utilisateur qui a ouvert la session sur l'ordinateur.

  • Nom de l'ordinateur.

Un mot de passe fort doit contenir plus de 8 caractères et satisfaire au moins trois des quatre critères suivants :

  • Il doit contenir des lettres majuscules.

  • Il doit contenir des lettres minuscules.

  • Il doit contenir des chiffres.

  • Il doit contenir des caractères non alphanumériques, comme #, % ou ^.

Les mots de passe entrés sur cette page doivent répondre aux exigences des stratégies de mots de passe forts. Si vous avez un processus automatisé qui utilise l'authentification SQL Server, assurez-vous que le mot de passe répond aux exigences des stratégies de mots de passe forts.

Voir aussi

Référence

Configuration des comptes de service Windows


Configuration du moteur de base de données – Répertoires de données

Configuration du moteur de base de données – Répertoires de données |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le tableau suivant affiche les répertoires par défaut qui sont configurables par l'utilisateur pendant l'installation de SQL Server :

Description | Répertoire par défaut | Recommandations
Répertoire de données racine | C:\Program Files\Microsoft SQL Server\ | Le programme d'installation de SQL Server configurera les listes de contrôle d'accès pour les répertoires SQL Server et rompra l'héritage dans le cadre de la configuration.
Répertoire de base de données utilisateur | C:\Program Files\Microsoft SQL Server\MSSQL10.<IDInstance>\Data | Les meilleures pratiques pour les répertoires de données utilisateur dépendent de la charge de travail et des exigences en matière de performances. Pour les installations de cluster de basculement, vérifiez que les répertoires de données sont placés sur le disque partagé.
Répertoire du journal de la base de données utilisateur | C:\Program Files\Microsoft SQL Server\MSSQL10.<IDInstance>\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire Temp de base de données | C:\Program Files\Microsoft SQL Server\MSSQL10.<IDInstance>\Data | Les meilleures pratiques pour le répertoire Temp dépendent de la charge de travail et des exigences en matière de performances.
Répertoire Temp du journal de base de données | C:\Program Files\Microsoft SQL Server\MSSQL10.<IDInstance>\Data | Assurez-vous que le répertoire du journal a un espace adéquat.
Répertoire de sauvegarde | C:\Program Files\Microsoft SQL Server\MSSQL10.<IDInstance>\Backup | Définissez les autorisations appropriées pour empêcher la perte de données et vérifiez que le groupe d'utilisateurs pour le service SQL Server a les autorisations adéquates pour écrire dans le répertoire de sauvegarde. L'utilisation d'un lecteur mappé pour les répertoires de sauvegarde n'est pas prise en charge.

Remarques

  • Lors de l'ajout de fonctionnalités à une installation existante, vous ne pouvez ni modifier l'emplacement d'une fonctionnalité précédemment installée, ni spécifier l'emplacement d'une nouvelle fonctionnalité.

  • Si vous spécifiez des répertoires d'installation autres que les répertoires par défaut, assurez-vous que les dossiers d'installation sont propres à cette instance de SQL Server. Aucun répertoire de cette boîte de dialogue ne doit être partagé avec les répertoires d'autres instances de SQL Server.

  • Les fichiers programmes et les fichiers de données ne peuvent pas être installés aux emplacements suivants :

    • sur un lecteur de disque amovible ;

    • dans un système de fichiers utilisant la compression ;

    • dans un répertoire où figurent des fichiers système ;

    • sur des lecteurs partagés sur une instance de cluster de basculement.

Voir aussi

Concepts

Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server


Configuration du moteur de base de données - Filestream

Configuration du moteur de base de données - Filestream |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez cette page pour activer FILESTREAM pour cette installation de SQL Server 2008.

Activer FILESTREAM pour l'accès Transact-SQL

Sélectionnez cette option pour activer FILESTREAM pour l'accès Transact-SQL. Ce contrôle doit être activé pour que les autres options de contrôle soient disponibles.

Activer FILESTREAM pour l'accès en continu des E/S de fichier

Sélectionnez cette option pour activer l'accès en continu Win32 pour FILESTREAM.

Nom du partage Windows

Utilisez ce contrôle pour entrer le nom du partage Windows dans lequel les données FILESTREAM doivent être stockées.

Permettre aux clients distants d'avoir un accès en continu aux données FILESTREAM

Sélectionnez ce contrôle pour permettre aux clients distants d'accéder à ces données FILESTREAM sur ce serveur.

Voir aussi

Autres ressources

Mise en route du stockage FILESTREAM
sp_configure (Transact-SQL)


Configuration du moteur de base de données – Instance utilisateur

Configuration du moteur de base de données – Instance utilisateur
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Instance utilisateur permet de générer une instance distincte du Moteur de base de données pour les utilisateurs sans autorisations d'administrateur et d'ajouter des utilisateurs dans le rôle d'administrateur.

Option

Activer les instances utilisateur

Par défaut, cette option est activée. Pour désactiver la fonction qui active les instances utilisateur, désactivez cette case à cocher.

L'instance utilisateur, également désignée comme instance enfant ou client, est une instance de SQL Server qui est générée par l'instance parent (l'instance principale exécutée en tant que service, telle que SQLExpress) pour le compte d'un utilisateur. L'instance utilisateur s'exécute en tant que processus utilisateur dans le contexte de sécurité de cet utilisateur. L'instance utilisateur est isolée de l'instance parent et de toutes les autres instances utilisateur exécutées sur l'ordinateur. La fonction d'instance utilisateur est également appelée RANU (« Run As Normal User », exécution en tant qu'utilisateur normal).

Ajouter l'utilisateur au rôle Administrateur SQL Server

Par défaut, cette option est désactivée. Pour ajouter l'utilisateur du programme d'installation en cours au rôle Administrateur SQL Server, activez la case à cocher.

Les utilisateurs Windows Vista qui sont membres de BUILTIN\Administrateurs ne sont pas ajoutés automatiquement au rôle serveur fixe sysadmin lorsqu'ils se connectent à SQL Server Express. Seuls les utilisateurs Windows Vista qui ont été ajoutés explicitement à un rôle d'administrateur de niveau serveur peuvent administrer SQL Server Express. Tous les membres du groupe Built-In\Users peuvent se connecter à l'instance de SQL Server Express, mais ils auront des autorisations limitées pour effectuer les tâches de base de données. Pour cette raison, les utilisateurs dont les privilèges SQL Server Express sont hérités de BUILTIN\Administrateurs et de Built-In\Utilisateurs dans les versions précédentes de Windows doivent bénéficier explicitement des privilèges d'administrateur dans les instances de SQL Server Express qui s'exécutent sur Windows Vista.

Pour apporter des modifications quelconques aux rôles d'utilisateur une fois le programme d'installation terminé, utilisez l'outil Configuration de la surface d'exposition SQL Server 2005 (SQLSAC.exe). Pour mettre à jour la liste des utilisateurs dans le rôle SQL Server Administrateur système, cliquez sur le lien Ajouter un nouvel administrateur.

Assurez-vous que le champ Utilisateur à mettre en service contient les paramètres DomainName\UserName de l'utilisateur dont les autorisations doivent être mises à jour. Sélectionnez le rôle à mettre à jour dans la liste des instances de SQL Server dans le volet Privilèges disponibles, puis cliquez sur la flèche droite. Pour ajouter l'utilisateur à tous les rôles disponibles pour toutes les instances disponibles de SQL Server et tous les rôles disponibles, cliquez sur la double flèche vers la droite.

Pour implémenter les modifications une fois votre sélection terminée, cliquez sur OK. Pour quitter l'outil sans apporter de modification, cliquez sur Annuler.


Résumé sur l'espace nécessaire

Résumé sur l'espace nécessaire |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Résumé sur l'espace nécessaire pour examiner l'espace disque requis pour les fonctionnalités SQL Server 2008 sélectionnées pour votre installation.

Options

Si la quantité d'espace disque requis est trop élevée, envisagez les options suivantes :

  • Remplacez les répertoires d'installation par un lecteur disposant de davantage d'espace disque.

  • Modifiez les fonctionnalités SQL Server pour votre installation.

  • Créez davantage d'espace libre sur le lecteur spécifié en déplaçant d'autres fichiers ou applications.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008


Règles de mise à niveau de l'édition

Règles de mise à niveau de l'édition |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
Engine_OnlySupportedFeaturesUsedCheckSystem | Vérifie les bases de données système pour les fonctionnalités qui ne sont pas prises en charge dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau. | Désactivez les fonctionnalités utilisées dans les bases de données système qui ne sont pas disponibles dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau.
Engine_OnlySupportedFeaturesUsedCheckUser | Vérifie toutes les bases de données utilisateur pour les fonctionnalités qui ne sont pas prises en charge par l'édition SQL Server. | Désactivez les fonctionnalités utilisées dans les bases de données système qui ne sont pas disponibles dans l'édition SQL Server vers laquelle vous effectuez la mise à niveau.
Engine_SqlEngineRestartCheck | Vérifie si le service SQL Server peut être redémarré. | Identifiez et corrigez le problème qui empêche la mise en ligne du service SQL Server.
Engine_SqlServerServiceDisabled_Id | Vérifie que le service SQL Server n'a pas la valeur Désactivé. | Définissez le type de démarrage manuel ou automatique pour le service SQL Server.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
EditionUpgradeMatrixCheck | Vérifie si l'instance sélectionnée de SQL Server répond aux besoins de la matrice de mise à niveau. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Consultez Mises à niveau de la version et de l'édition.
AS_ValidateEditionUpgrade | Vérifie si Analysis Services est mis à niveau vers une édition valide. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Consultez Mises à niveau de la version et de l'édition.
Cluster_EditionDownGradeCheck | Vérifie si l'édition de l'instance sélectionnée de SQL Server est prise en charge dans ce scénario. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Consultez Mises à niveau de la version et de l'édition.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Certains scénarios de mise à niveau multiplateformes ne sont pas pris en charge. Consultez Mises à niveau de la version et de l'édition.
EditionDownGradeCheck | Vérifie si l'édition de l'instance sélectionnée de SQL Server est prise en charge dans ce scénario. | Certains scénarios de mise à niveau d'édition ne sont pas pris en charge. Consultez Mises à niveau de la version et de l'édition.

Voir aussi

Référence

Paramètres de l'outil d'analyse de configuration système


Paramètres de rapports d'erreurs et d'utilisation

Paramètres de rapports d'erreurs et d'utilisation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Paramètres de rapports d'erreurs et d'utilisation de l'Assistant Installation de SQL Server pour activer la fonctionnalité de rapport d'erreurs et d'utilisation dans SQL Server.

Options

Par défaut, les fonctionnalités de collecte de données Utilisation de fonctionnalités et de rapports d'erreurs sont activées par défaut pour SQL Server et ses composants dans les versions préliminaires de SQL Server 2008. Vous pouvez toutefois désactiver l'une de ces options ou les deux en désactivant les cases à cocher correspondantes.

Rapport d'erreurs

Si vous activez la fonctionnalité Rapport d'erreurs, SQL Server est configuré pour envoyer automatiquement un rapport à Microsoft si une erreur irrécupérable se produit dans l'un des composants SQL Server suivants :

  • Le Moteur de base de données moteur de base de données

  • Agent SQL Server

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

Microsoft utilise les rapports d'erreurs pour améliorer le fonctionnement de SQL Server. Ces informations sont traitées en toute confidentialité.

Des informations sur les erreurs sont envoyées à Microsoft par le biais d'une connexion sécurisée (https) et elles sont stockées avec un accès limité. Des rapports d'erreurs peuvent également être envoyés sur votre propre serveur de rapports d'erreurs d'entreprise.

Les rapports d'erreurs comprennent les informations suivantes :

  • la condition de SQL Server lorsque le problème s'est produit ;

  • des informations sur la version du système d'exploitation et le matériel ;

  • votre ID de produit numérique, qui n'est pas utilisé pour identifier votre licence ;

  • l'adresse IP réseau de votre ordinateur ou de votre serveur proxy ;

  • des informations provenant de la mémoire ou des fichiers du processus à l'origine de l'erreur.

Microsoft ne regroupe pas de manière intentionnelle vos fichiers, nom, adresse, adresse électronique ou tout autre forme d'informations personnelles. Le rapport d'erreurs peut toutefois contenir des informations personnelles qui proviennent de la mémoire ou des fichiers du processus à l'origine de l'erreur. Bien que ces informations permettent à priori de déterminer votre identité, Microsoft ne les exploite pas à cette fin.

Pour obtenir des informations sur la politique de confidentialité et la procédure de collecte de données de Microsoft SQL Server, consultez cette page Web Microsoft SQL Server Privacy Statement.

Si vous activez les rapports d'erreurs et qu'une erreur irrémédiable se produit, vous pouvez voir une réponse de Microsoft dans le journal des événements Windows, qui pointe sur un article de la Base de connaissances Microsoft traitant cette erreur.

Pour désactiver la fonction de rapport d'erreurs et d'utilisation de fonctionnalités pour toutes les instances de SQL Server et leurs composants une fois l'installation terminée, accédez à la boîte de dialogue Paramètres de rapports d'erreurs et d'utilisation et désactivez les cases à cocher pour Utilisation de fonctionnalités. Si l'option Rapport d'erreurs est activée pour plusieurs composants SQL Server (le Moteur de base de données SQL Server, Analysis Services, Reporting Services et les composants partagés), vous pouvez la désactiver individuellement pour l'instance de chaque composant, ainsi que pour les composants partagés répertoriés comme Autres.

Utilisation de fonctionnalités

Si vous activez Utilisation de fonctionnalités, SQL Server est configuré pour envoyer régulièrement un rapport à Microsoft. Ces rapports incluent des informations sur votre configuration matérielle et sur la façon dont vous utilisez les logiciels et les services SQL Server. Microsoft utilise les données d'utilisation des fonctionnalités pour améliorer SQL Server. Les composants suivants font partie des composants SQL Server analysés :

  • Le Moteur de base de données moteur de base de données

  • Analysis Services

  • Reporting Services

  • Integration Services

  • Réplication

  • Business Intelligence Development Studio

Les informations sur l'utilisation des fonctionnalités sont envoyées à Microsoft, puis stockées avec un accès limité.

Pour désactiver les rapports d'utilisation des fonctionnalités une fois l'installation terminée, utilisez l'outil Rapports d'erreurs et d'utilisation SQL Server dans le menu Outils de configuration de SQL Server.

Les informations sont collectées quotidiennement pour toutes les instances SQL Server activées. Par défaut, la collecte est effectuée à minuit afin de réduire la charge sur le serveur. Si vous souhaitez changer l'heure de la collecte, vous pouvez modifier manuellement la clé du Registre concernée. Chaque instance de SQL Server possède sa propre clé de Registre :

HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL10\CPE\TimeofReporting

La valeur de cette clé de Registre inclut l'heure de la collecte ainsi que le nombre de minutes qui s'écoulent à partir de 00:00 (minuit). Par exemple, la valeur 60 fixe l'exécution de la collecte à 1:00 a.m., la valeur 1200 fixe l'exécution de la collecte à 8:00 p.m., et ainsi de suite.

Voir aussi

Autres ressources

Configuring a SQL Server Installation


Rapport sur le cluster de basculement

Rapport sur le cluster de basculement |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Rapport sur le cluster de basculement pour afficher les résultats du rapport de l'analyse du système du programme d'installation pour cette opération.

Options

Pour afficher un rapport détaillé pour l'analyse, cliquez sur le lien de rapport.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Règles d'installation des fonctionnalités

Règles d'installation des fonctionnalités |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Le programme d'installation de SQL Server 2008 valide la configuration de votre ordinateur avant la fin de l'opération d'installation. Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Le système d'exploitation doit être conforme à la configuration minimale requise pour ce produit. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Le service WMI doit être en cours d'exécution.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est installé. Windows PowerShell est un composant requis de SQL Server 2008 Express Edition with Advanced Services. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Permet de déterminer si le programme d'installation est pris en charge sur la plate-forme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.
BlockCrossLanguageInstall | Vérifie si la langue d'installation est la même que la langue des fonctionnalités SQL Server existantes. | Vous devez mettre à niveau SQL Server en utilisant la même version linguistique que l'instance existante de SQL Server.
BlockMixedArchitectureInstall | Vérifie si les fonctionnalités d'installation sont la même architecture de processeur que l'instance spécifiée. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
RS_DoesCatalogExist | Vérifie si le fichier de base de données de catalogue existe. | Renommez, déplacez ou supprimez les fichiers.
RS_DoesCatalogTempDBExist | Vérifie si le fichier de base de données temporaire de catalogue existe. | Renommez, déplacez ou supprimez les fichiers.
StandaloneInstall_HasClusteredOrPreparedInstanceCheck | Vérifie si le nom d'instance sélectionné est déjà utilisé par une instance préparée par cluster ou en cluster existante sur tout nœud de cluster. | Vous ne pouvez pas utiliser le nom d'instance sélectionné, car il est déjà utilisé. Indiquez un autre nom d'instance pour SQL Server.

Voir aussi

Référence

Paramètres de l'outil d'analyse de configuration système


Sélection de fonctionnalités

Sélection de fonctionnalités |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez les cases à cocher de la page Sélection de fonctionnalités de l'Assistant Installation de SQL Server pour sélectionner les composants de votre installation de SQL Server.

Options

Une description de chaque groupe de composants s'affiche dans le volet Description en cas de sélection. Vous pouvez activer n'importe quelle combinaison de cases à cocher. Pour continuer, vous devez faire une sélection.

Les composants Moteur de base de données et Analysis Services sont les seules fonctionnalités SQL Server 2008 qui prennent en charge le clustering de basculement. Vous pouvez installer d'autres composants, tels que Reporting Services ou Integration Services, sur un nœud de cluster de basculement, mais ils ne prennent pas en charge les clusters et leurs services ne basculent pas si le nœud est placé hors connexion. Pour plus d'informations, consultez Mise en route avec le clustering de basculement de SQL Server 2008.

Sélectionnez ce groupe de composants. Pour installer ces composants et ces fonctionnalités

Services du Moteur de base de données

Le Moteur de base de données SQL Server inclut les composants suivants :

  • Le Moteur de base de données est le service central qui permet de stocker, de traiter et de sécuriser les données.

  • Facultatif : La réplication est un ensemble de technologies qui permettent de copier et de distribuer des données et des objets d'une base de données vers une autre, puis de synchroniser les bases de données afin de préserver leur cohérence.

  • Facultatif : La recherche en texte intégral fournit les fonctionnalités nécessaires à l'émission de requêtes de texte intégral sur les données de caractères en texte brut des tables SQL Server.

  • Outils de gestion de données relationnelles et XML.

Analysis Services

Analysis Services inclut les outils de création et de gestion d'applications de traitement analytique en ligne (OLAP, OnLine Analytical Processing) et de Data Mining.

Reporting Services 2,3

Reporting Services inclut les composants serveur et clients à l'aide desquels vous pouvez créer, gérer et déployer des rapports tabulaires, matriciels, graphiques et libres. Reporting Services est également une plateforme évolutive que vous pouvez utiliser pour développer des applications de création de rapports.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Fonctionnalités partagées :

  • Outils clients

  • Documentation en ligne de SQL Server

  • Business Intelligence Development Studio 4,5

  • Integration Services

Les outils clients incluent les composants permettant la communication entre les clients et les serveurs, notamment les bibliothèques réseau pour DB-Library, OLEDB pour OLAP, ODBC, ADODB et ADOMD+, ainsi que les outils d'administration SQL Server suivants :

  • SQL Server Management Studio (SSMS) est un environnement intégré d'accès, de configuration, de gestion, d'administration et de développement de tous les composants de SQL Server. SSMS réunit les fonctionnalités d'Enterprise Manager, de l'Analyseur de requêtes et d'Analysis Manager, inclus dans les versions précédentes de SQL Server, dans un environnement unique qui fournit l'accès de SQL Server aux développeurs et aux administrateurs de tous les niveaux de compétence.

  • Le Gestionnaire de configuration SQL Server permet de gérer la configuration de base des services SQL Server, des protocoles serveur et clients et des alias clients.

  • Générateur de profils SQL Server fournit une interface utilisateur graphique qui permet d'analyser une instance du Moteur de base de données ou une instance Analysis Services.

  • L'Assistant Paramétrage du Moteur de base de données permet de créer des ensembles d'index, des vues indexées et des partitions optimaux.

  • Le Moniteur de réplication permet de suivre l'état et les performances des publications et des abonnements dans une topologie de réplication.

  • Fonctionnalités clientes SQLXML

  • La documentation en ligne de SQL Server est fournie avec la documentation principale de SQL Server.

Business Intelligence Development Studio est un environnement de développement intégré pour les solutions Analysis Services, Reporting Services et Integration Services.

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

1Le programme d'installation ne configure pas l'équilibrage de charge et l'adressage par URL unique pour les nœuds multiples d'un déploiement avec montée en puissance parallèle de Reporting Services. Pour effectuer un déploiement avec montée en puissance parallèle, vous devez utiliser Windows Server, Microsoft Application Center ou un logiciel tiers de gestion de clusters. Pour plus d'informations sur la configuration du déploiement d'une batterie de serveurs Web, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

2 Microsoft Internet Explorer 6.0 SP 1 est requis pour le composant Concepteur de rapports de Reporting Services.

3 Reporting Services n'est pas pris en charge simultanément dans les configurations côte à côte sur la plateforme 64 bits et sur le sous-système 32 bits (WOW64) d'un serveur 64 bits.

4Internet Explorer 6.0 SP1 est requis pour les installations de SQL Server Management Studio.

5Internet Explorer 6.0 SP1 est requis pour les installations de Business Intelligence Development Studio.

Répertoire de composants partagé

Les fonctionnalités partagées par toutes les instances de SQL Server sur un même ordinateur sont installées dans un répertoire unique. Elles incluent les éléments suivants :

  • Outils clients

  • Documentation en ligne de SQL Server

  • Business Intelligence Development Studio

  • Integration Services

Par défaut, ces composants partagés sont installés dans %Program Files%Microsoft SQL Server\. Pour modifier le chemin d'installation, cliquez sur le bouton Parcourir. La modification du chemin d'installation d'un composant partagé affecte également les autres composants partagés. En effet, les installations ultérieures placeront les composants partagés dans le même emplacement que celui de l'installation d'origine.

Sur les systèmes d'exploitation x64, vous pouvez spécifier où les composants 64 bits doivent être installés et où les composants 32 bits doivent l'être sur le sous-système WOW64.

Installation des exemples de bases de données AdventureWorks

Par défaut, les exemples de bases de données et les exemples de code ne sont pas installés dans le cadre de l'installation de SQL Server. Pour installer les exemples de bases de données et les exemples de code, consultez le site Web CodePlex.

Les informations supplémentaires sur les exemples sont disponibles après que SQL Server 2008 a été installé. Dans le menu Démarrer, cliquez sur Programmes, sur Microsoft SQL Server 2008, sur Documentation et didacticiels, puis sur Vue d'ensemble des exemples pour Microsoft SQL Server.

Voir aussi

Référence

Éditions et composants de SQL Server 2008


Sélection de composant (Désinstaller)

Sélection de composant (Désinstaller) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection de composant — Désinstaller pour sélectionner les fonctionnalités à supprimer de l'instance spécifiée de SQL Server.

Options

Vous pouvez choisir n'importe quelle combinaison de fonctionnalités.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Fonctionnalités à mettre à niveau

Fonctionnalités à mettre à niveau |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Fonctionnalités à mettre à niveau de l'Assistant Installation SQL Server 2008 pour spécifier les fonctionnalités à mettre à niveau vers SQL Server 2008.

Options

  • Il n'est pas possible de modifier les fonctionnalités à mettre à niveau dans cette version.

Voir aussi

Référence

Mises à niveau de la version et de l'édition

Concepts

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions et instances de SQL Server


Options de mise à niveau de recherche en texte intégral

Options de mise à niveau de recherche en texte intégral |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page des options de mise à niveau de recherche en texte intégral de l'Assistant Installation SQL Server pour sélectionner l'option de mise à niveau de recherche en texte intégral à utiliser pour les bases de données que vous mettez à niveau cette fois.

Dans SQL Server 2005 et les versions antérieures, chaque index de texte intégral réside dans un catalogue de texte intégral qui appartient à un groupe de fichiers, a un chemin d'accès physique et est traité en tant que fichier de base de données. Dans SQL Server 2008, un catalogue de texte intégral est un concept logique – objet virtuel – qui renvoie à un groupe d'index de texte intégral. Par conséquent, un nouveau catalogue de texte intégral n'est pas traité en tant que fichier de base de données avec un chemin d'accès physique. Toutefois, un nouveau groupe de fichiers est créé sur le même disque pendant la mise à niveau de tout catalogue de texte intégral qui contient des fichiers de données. Cela maintient le comportement d'E/S de l'ancien disque après la mise à niveau. Tout index de texte intégral de ce catalogue est placé dans le nouveau groupe de fichiers si le chemin d'accès racine existe. Si l'ancien chemin de catalogue de texte intégral est non valide, la mise à niveau conserve l'index de texte intégral dans le même groupe de fichiers comme table de base ou, pour une table partitionnée, dans le groupe de fichiers principal.

Options

Lorsque vous effectuez une mise à niveau vers SQL Server 2008, choisissez l'une des options de mise à niveau de texte intégral ci-dessous.

Importer

Les catalogues de texte intégral sont importés. En général, l'importation est considérablement plus rapide que lors d'une reconstruction (rebuild). Par exemple, lorsque vous utilisez un seul processeur, l'importation s'exécute approximativement 10 fois plus vite que lors de la reconstruction. Toutefois, un catalogue de texte intégral importé n'utilise pas les analyseurs lexicaux nouveaux et améliorés introduits dans SQL Server 2008, ce qui fait que vous pouvez le cas échéant reconstruire vos catalogues de texte intégral au final.

Remarque :
Le processus de reconstruction peut s'exécuter en mode multithread, et si plus de 10 processeurs sont disponibles, la reconstruction peut s'effectuer plus vite que l'importation si vous la laissez utiliser tous les processeurs.

Si aucun catalogue de texte intégral n'est disponible, les index de recherche en texte intégral associés sont reconstruits. Cette option est disponible uniquement pour les bases de données SQL Server 2005.

Pour plus d'informations sur l'impact de l'importation de l'index de texte intégral, consultez « Considérations relatives au choix d'une option de mise à niveau », plus loin dans cette rubrique.

Reconstruire

Les catalogues de texte intégral sont reconstruits à l'aide des analyseurs lexicaux nouveaux et améliorés. La reconstruction des index peut prendre un moment, et une quantité importante de ressources en termes d'UC et de mémoire peut être requise après la mise à niveau.

Réinitialiser

Les catalogues de texte intégral sont réinitialisés. Les fichiers de catalogue de texte intégral SQL Server 2005 sont supprimés, mais les métadonnées pour les catalogues de texte intégral et les index de texte intégral sont conservés. Après leur mise à niveau, tous les index de recherche en texte intégral ont le suivi des modifications désactivé et aucune analyse n'est démarrée automatiquement. Le catalogue reste vide tant que vous n'avez pas procédé manuellement à une alimentation complète, au terme de la mise à niveau.

Toutes ces options de mise à niveau garantissent que les bases de données mises à niveau bénéficient pleinement des améliorations en termes de performances du texte intégral de SQL Server 2008.

Important :
Pour plus d'informations sur l'utilisation des nouveaux analyseurs lexicaux et la mise à niveau des fichiers de mots parasites vers les liste de mots vides après avoir importé un index de texte intégral SQL Server 2005, consultez Mise à niveau de la fonction de recherche en texte intégral.

Considérations relatives au choix d'une option de mise à niveau de texte intégral

Au moment de choisir l'option de mise à niveau pour votre mise à niveau, tenez compte des éléments suivants :

  • Comment est-ce que vous utilisez les analyseurs lexicaux ?

    Le service de recherche en texte intégral SQL Server 2008 inclut de nouveaux analyseurs lexicaux et générateurs de formes dérivées. Ceux-ci peuvent modifier les résultats de requêtes de texte intégral de versions précédentes pour un modèle ou scénario de texte spécifique. Par conséquent, la manière dont vous utilisez les analyseurs lexicaux est importante lors du choix d'une option de mise à niveau appropriée :

    • Si les analyseurs lexicaux de la langue de texte intégral que vous utilisez n'ont pas changé dans SQL Server 2008, ou si l'exactitude de rappel n'est pas critique pour vous, l'importation est appropriée. Ultérieurement, si vous rencontrez des problèmes de rappel, vous pouvez effectuer une mise à niveau vers les nouveaux analyseurs lexicaux en reconstruisant vos catalogues de texte intégral. Pour plus d'informations, consultez Mise à niveau de la fonction de recherche en texte intégral.

    • Si vous tenez à l'exactitude de rappel et que vous utilisez l'un des analyseurs lexicaux améliorés dans SQL Server 2008, la reconstruction est appropriée.

  • Certains index de texte intégral ont-ils été construits sur la base de colonnes de clés de texte intégral de type Integer ?

    La reconstruction effectue, dans quelques cas, des optimisations internes qui améliorent les performances des requêtes de l'index de texte intégral mis à niveau. Spécifiquement, si vous avez des catalogues de texte intégral qui contiennent des index de texte intégral dont la colonne de clé de texte intégral de la table de base correspond à un type de données Integer, la reconstruction permet d'obtenir une performance idéale des requêtes de texte intégral après la mise à niveau. Nous recommandons vivement que vous utilisiez l'option Reconstruire dans ce cas.

    Remarque :
    Pour les index de texte intégral dans SQL Server 2008, nous recommandons que la colonne servant de clé de texte intégral corresponde à un type de données Integer. Pour plus d'informations, consultez Paramétrage et optimisation des performances (recherche en texte intégral).

  • Quelle est la priorité pour obtenir votre instance de serveur en ligne ?

    L'importation ou la reconstruction pendant la mise à niveau mobilise beaucoup de ressources processeur, ce qui retarde la mise à niveau et en ligne du reste de l'instance serveur. Si le fait d'avoir l'instance de serveur en ligne dès que possible est important et si vous êtes disposé à exécuter une alimentation manuelle après la mise à niveau, la réinitialisation est appropriée.

Ressources supplémentaires

Modifications importantes de la recherche en texte intégral dans SQL Server 2008

Modifications du comportement de la recherche en texte intégral dans SQL Server 2008

Fonctionnalités du moteur de base de données abandonnées dans SQL Server 2008

Recherche de la colonne clé de texte intégral

Analyseurs lexicaux et générateurs de formes dérivées

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


L'installation est terminée

L'installation est terminée |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Cliquez sur Fermer pour terminer l'installation.

Voir aussi

Référence

Éditions et composants de SQL Server 2008

Concepts

Validation d'une installation SQL Server
Configuration de SQL Server 2008


Conditions préalables d'installation

Conditions préalables d'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Pour que SQL Server soit correctement installé, les composants logiciels suivants sont requis sur l'ordinateur d'installation. Ils sont installés par le programme d'installation de SQL Server :

  • .NET Framework version 3.5 pour SQL Server Express et SQL Server Express Advanced

  • .NET Framework version 2.0 SP1 pour SQL Server 2008 sur Windows Server 2003 (64 bits) IA64 SP1

  • .NET Framework version 3.5 pour toutes les autres éditions de SQL Server 2008

  • Fichiers de support d'installation de SQL Server

  • SQL Server Native Client

Remarque :
En cas d'échec ou d'annulation de l'installation, ces composants ne sont pas supprimés. Pour les supprimer, utilisez Ajout/Suppression de programmes dans le Panneau de configuration.

Options

Pour installer les fichiers requis, cliquez sur Installer. Pour quitter l'installation, cliquez sur Annuler.

Voir aussi

Référence

Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008


progression de l'installation

progression de l'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Installation en cours de l'Assistant Installation de SQL Server pour vérifier l'état du programme d'installation de SQL Server.

Voir aussi

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Type d'installation

Type d'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Type d'installation de l'Assistant Installation de SQL Server pour spécifier s'il convient d'installer une nouvelle instance de SQL Server 2008 ou d'ajouter des fonctionnalités à une instance existante.

Options

Sélectionnez la case d'option qui correspond à votre choix :

  • Effectuer une nouvelle installation de SQL Server 2008

  • Ajouter des fonctionnalités à une instance existante de SQL Server 2008

    Si vous choisissez d'ajouter des fonctionnalités à une instance existante, utilisez la liste déroulante pour sélectionner l'instance de SQL Server à mettre à jour.

    Remarque :
    Vous ne pouvez pas ajouter des fonctionnalités à une instance de cluster de basculement après son installation. Pour ajouter des fonctionnalités SQL Server à un cluster de basculement existant, vous devez effectuer une nouvelle installation pour installer une instance séparée de SQL Server.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Configuration d'une instance

Configuration d'une instance |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration d'une instance de l'Assistant Installation de SQL Server pour spécifier s'il faut créer une instance par défaut ou une instance nommée de SQL Server. Si une instance de SQL Server n'est pas déjà installée, une instance par défaut sera créée à moins que vous ne spécifiiez une instance nommée.

Chaque instance de SQL Server consiste en un ensemble distinct de services qui ont des paramètres spécifiques pour les classements et autres options. La structure du répertoire, la structure de Registre et les noms des services reflètent tous le nom de l'instance et un ID d'instance spécifique créé pendant le programme d'installation de SQL Server.

Une instance est soit l'instance par défaut, soit une instance nommée. Le nom par défaut de l'instance est MSSQLSERVER ; SQLExpress pour SQL Server Express. Il n'est pas nécessaire qu'un client spécifie le nom de l'instance pour établir une connexion. Une instance nommée est déterminée par l'utilisateur au cours de l'installation. Vous pouvez installer SQL Server comme instance nommée sans installer d'abord l'instance par défaut. L'instance par défaut peut être une installation de SQL Server 2000, SQL Server 2005 ou SQL Server 2008. Une seule installation de SQL Server, indépendamment de la version, peut être à un instant donné l'instance par défaut.

Instances multiples

SQL Server prend en charge plusieurs instances de SQL Server sur un seul serveur ou processeur, mais une seule instance peut être l'instance par défaut. Toutes les autres instances doivent être des instances nommées. Un ordinateur peut exécuter simultanément plusieurs instances SQL Server et chaque instance s'exécute indépendamment des autres.

Pour plus d'informations, consultez Spécifications des capacités maximales pour SQL Server.

Options

Instances de cluster de basculement uniquement — Indiquez le nom réseau du cluster de basculement SQL Server. Ce nom identifie l'instance de cluster de basculement sur le réseau.

Instance par défaut ou instance nommée — Prenez ces informations en compte lorsque vous décidez d'installer une instance par défaut ou une instance nommée de SQL Server :

  • Si vous envisagez d'installer une seule instance de SQL Server sur un serveur de bases de données, ce doit être une instance par défaut.

  • Utilisez une instance nommée lorsque vous envisagez plusieurs instances sur le même ordinateur. Un serveur ne peut héberger qu'une seule instance par défaut.

  • Toute application qui installe SQL Server Express doit l'installer en tant qu'instance nommée. Ce procédé réduit au minimum les conflits liés à l'installation de plusieurs applications sur le même ordinateur.

Instance par défaut

Choisissez cette option pour installer une instance par défaut de SQL Server. Un ordinateur ne peut héberger qu'une instance par défaut ; toutes les autres instances doivent être nommées. Toutefois, si vous avez une instance par défaut de SQL Server installée, vous pouvez ajouter une instance par défaut de Analysis Services sur le même ordinateur.

Instance nommée

Sélectionnez cette option pour créer une nouvelle instance nommée. Prenez en compte les points suivants lorsque vous nommez une instance de SQL Server :

  • Les noms d'instance ne respectent pas la casse.

  • Les noms d'instance ne peuvent pas contenir le terme « Default » ou autres mots clés réservés. Si un mot clé réservé est utilisé dans le nom d'une instance, une erreur d'installation se produit. Pour plus d'informations, consultez Mots clés réservés (programme d'installation).

  • Si vous spécifiez MSSQLServer comme nom d'instance, une instance par défaut est créée. Pour SQL Server Express, si vous spécifiez SQLExpress comme nom d'instance, une instance par défaut est créée.

  • Les noms d'instance sont limités à 16 caractères.

  • Le premier caractère d'un nom d'instance doit être une lettre. Les lettres acceptables sont celles définies par la norme Unicode 2.0. Elles incluent les caractères latins a-z, A-Z et les caractères littéraux des autres langues.

  • Les autres caractères d'un nom d'instance peuvent être des lettres définies par le standard Unicode 2.0, des nombres décimaux provenant de scripts de latin de base ou nationaux, le symbole dollar ($) ou le trait de soulignement (_).

  • Les espaces incorporés ou autres caractères spéciaux ne sont pas autorisés dans les noms d'instance. La barre oblique inverse (\), la virgule (), les deux-points (:), le point-virgule (;), le guillemet simple ('), l'esperluette (&) et l'arobase (@) ne sont pas autorisés non plus.

    Remarque :
    Seuls les caractères valides dans la page de codes Windows en cours sont autorisés dans les noms d'instance SQL Server. En cas d'utilisation d'un caractère Unicode non pris en charge, une erreur d'installation se produit.

Instances et fonctionnalités détectées

Consultez la liste des instances et des composants de SQL Server installés sur l'ordinateur sur lequel le programme d'installation de SQL Server est en cours d'exécution.

ID d'instance - Par défaut, le nom de l'instance est utilisé comme ID d'instance. Il permet d'identifier les répertoires d'installation et les clés de Registre de votre instance SQL Server. Tel est le cas pour les instances par défaut et les instances nommées. Pour une instance par défaut, le nom de l'instance et l'ID d'instance seront MSSQLSERVER. Pour utiliser un ID d'instance non défini par défaut, spécifiez-le dans le champ ID d'instance.

Remarque :
Les ID d'instance qui commencent avec un trait de soulignement (_) ou qui contiennent le signe dièse (#) ou le symbole dollar ($) ne sont pas pris en charge.

Pour plus d'informations sur les répertoires, les emplacements de fichiers et la dénomination d'ID d'instance, consultez Emplacements des fichiers pour les instances par défaut et les instances nommées de SQL Server.

Répertoire racine de l'instance - Par défaut, le répertoire racine de l'instance est C:\Program Files\Microsoft SQL Server\. Pour spécifier un répertoire racine non défini par défaut, cliquez sur le bouton Parcourir ou fournissez un nom de chemin d'accès.

Tous les composants d'une instance donnée de SQL Server sont gérés comme une unité. Tous les Service Packs et mises à niveau SQL Server s'appliqueront à chaque composant d'une instance de SQL Server.

Tous les composants de SQL Server qui partagent le même nom d'instance doivent remplir les critères suivants :

  • Même version

  • Même édition

  • Mêmes paramètres de langue

  • Même état cluster

    Remarque :
    Reporting Services n'est pas sensible aux clusters.

  • Même système d'exploitation

Voir aussi

Autres ressources

How to: Install SQL Server 2005


Sélection de l'instance (Désinstaller)

Sélection de l'instance (Désinstaller) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Dans la page Sélection de l'instance — Désinstaller, utilisez la zone de liste déroulante pour spécifier l'instance de SQL Server à désinstaller.

Options

Vous pouvez spécifier une instance entière de SQL Server ou bien indiquer que seuls les fonctionnalités partagées et les outils d'administration doivent être désinstallés.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Sélection de l'instance (Mise à niveau)

Sélection de l'instance (Mise à niveau) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélection de l'instance (Mise à niveau) pour spécifier l'instance de SQL Server à mettre à niveau.

Options

Tous les composants d'une instance doivent être mis à niveau simultanément. Vous ne pouvez ajouter ni supprimer des fonctionnalités au cours de la mise à niveau.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Minimiser la surface d'exposition de SQL Server 2008

Minimiser la surface d'exposition de SQL Server 2008 |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La réduction de la surface d'exposition est une mesure de sécurité qui implique l'arrêt ou la désactivation de composants inutilisés. La réduction de la surface d'exposition permet de renforcer la sécurité car les risques d'attaque à l'encontre d'un système sont minimisés.

Pour les nouvelles installations de SQL Server 2008, certains services, certaines fonctionnalités et connexions sont désactivés ou arrêtés pour réduire la surface d'exposition de SQL Server. Dans le cas d'installations mises à niveau, tous les services, fonctionnalités et connexions demeurent dans l'état préalable à la mise à niveau.

  • Utilisez le Gestionnaire de configuration de SQL Server pour activer, désactiver, démarrer ou arrêter des services et configurer la connectivité distante de votre Moteur de base de données.

  • Utilisez la Gestion basée sur des stratégies pour activer et désactiver des fonctionnalités facultatives.

Utilisation du Gestionnaire de configuration SQL Server

Le Gestionnaire de configuration SQL Server est installé avec toutes les éditions de SQL Server.

Pour ouvrir le Gestionnaire de configuration SQL Server

  1. Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008 et sur Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.
Pour configurer un service de façon à ce qu'il démarre automatiquement

  1. Dans le Gestionnaire de configuration SQL Server, développez Services SQL Server.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur l'un des services SQL Server, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, définissez le Mode de démarrage à Automatique.
Pour configurer le moteur de base de données de façon à accepter les connexions distantes

  1. Dans le Gestionnaire de configuration SQL Server, développez Configuration du réseau SQL Server, puis cliquez sur Protocoles pour <nom_instance>.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur l'un des protocoles disponibles, puis cliquez sur Propriétés.

    Remarque :
    Le protocole de mémoire partagée ne peut pas être activé pour les connexions distantes.

  3. Pour activer un protocole pour les connexions distantes, affectez la valeur Oui à la zone Active.

Pour obtenir de l'assistance concernant le Gestionnaire de configuration SQL Server, consultez le fichier d'aide du Gestionnaire de configuration SQL Server ou la documentation en ligne de SQL Server. Pour configurer les points de terminaison SOAP et Service Broker, utilisez CREATE ENDPOINT et ALTER ENDPOINT.

Utilisation de la Gestion basée sur des stratégies

La configuration de la Gestion basée sur des stratégies s'effectue à l'aide de SQL Server Management Studio. Si Management Studio n'est pas installé, exécutez le programme d'installation et installez les outils clients. Management Studio ne fait pas partie de l'installation de SQL Server Express. Téléchargez Management Studio Express à partir de Microsoft.com. Les fonctionnalités de la Gestion basée sur des stratégies sont décrites dans la documentation en ligne de SQL Server.

Pour ouvrir SQL Server Management Studio

  1. Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, puis cliquez sur SQL Server Management Studio.
Pour configurer la Gestion basée sur des stratégies

  1. Dans Management Studio, connectez-vous à une instance du Moteur de base de données, développez Gestion, puis Gestion de la stratégie.

  2. Configurez la Gestion basée sur des stratégies en utilisant les trois facettes suivantes :

    • Configuration de la surface d'exposition

    • Configuration de la surface d'exposition pour Analysis Services

    • Configuration de la surface d'exposition pour Reporting Services

    Les fonctionnalités de configuration de la surface d'exposition désactivées par défaut ne doivent pas être activées, sauf si les besoins spécifiques de l'entreprise l'exigent.

Paramètres recommandés :

  • Paramètres recommandés pour le Moteur de base de données

    Définissez toutes les propriétés de la facette Configuration de la surface d'exposition avec la valeur « faux ».

  • Paramètres recommandés pour Analysis Services

    Définissez toutes les propriétés de la facette Configuration de la surface d'exposition pour Analysis Services avec la valeur « faux ».

  • Paramètres recommandés pour Reporting Services

    Utilisez la Configuration de la surface d'exposition pour Reporting Services afin de désactiver les fonctionnalités Reporting Services dont vous n'avez pas besoin.

Voir aussi

Autres ressources

Présentation de la configuration de la surface d'exposition


Post-désinstallation

Post-désinstallation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Post-désinstallation pour vérifier que l'opération a été correctement effectuée.

Options

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Clé du produit

Clé du produit |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Clé du produit pour valider votre instance de SQL Server 2008 ou indiquer l'édition gratuite de SQL Server 2008 à installer.

Options

Pour indiquer une édition gratuite de SQL Server 2008, sélectionnez la case d'option qui correspond aux installations gratuites, puis utilisez la zone de liste déroulante pour identifier l'édition à installer.

Pour valider une édition payante de SQL Server 2008, sélectionnez la case d'option qui correspond à la clé du produit, puis indiquez votre clé dans l'espace fourni.

Pour les installations de cluster de basculement, utilisez la même clé de produit pour chaque nœud de cluster de basculement. Si la clé du produit provient d'une autre édition de SQL Server, une erreur se produit.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Progression (Désinstaller)

Progression (Désinstaller) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Progression (Désinstaller) pour contrôler la progression du programme l'installation.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Prêt pour l'installation

Prêt pour l'installation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Prêt pour l'installation fournit un résumé des fonctionnalités à installer ou à modifier par le programme d'installation de SQL Server.

Options

La page affiche les options suivantes :

  • Pour continuer l'installation, cliquez sur Installer.

  • Pour modifier vos paramètres d'installation, cliquez sur Précédent.

  • Pour quitter le programme d'installation, cliquez sur Annuler.

Voir aussi

Tâches

Procédure : lire un fichier journal d'installation de SQL Server

Concepts

Procédure : afficher les fichiers journaux d'installation de SQL Server


Méthode de récupération

Méthode de récupération
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Faites une sélection, puis cliquez sur Suivant pour continuer.


Supprimer un nœud de cluster de basculement SQL Server

Supprimer un nœud de cluster de basculement SQL Server |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Supprimer un nœud de cluster de basculement pour identifier l'ordinateur à supprimer en tant que nœud de cluster de basculement SQL Server 2008.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Options d'installation du serveur de rapports

Options d'installation du serveur de rapports |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Options d'installation du serveur de rapports de l'Assistant Installation de Microsoft SQL Server pour spécifier les options qui déterminent le mode d'installation de l'instance d'un serveur de rapports. La disponibilité d'une option d'installation dépend du fait que vous installez également ou non une instance locale du Moteur de base de données SQL Server lors de l'installation du serveur de rapports ; cette disponibilité dépend également de l'existence ou non d'autres valeurs par défaut.

Si le programme d'installation ne peut pas configurer le serveur de rapports par défaut, car une ou plusieurs conditions requises ne sont pas respectées, l'Assistant Installation n'autorise que l'option d'installation minimale ; les fichiers dont vous avez besoin sont copiés mais vous êtes obligé d'utiliser l'outil de configuration de Reporting Services pour configurer le serveur de rapports à la fin de l'installation.

Dans certains cas, si un certificat SSL (Secure Sockets Layer) est installé sur l'ordinateur et lié à un caractère générique fort, le programme d'installation crée les URL Reporting Services à l'aide du préfixe HTTPS. Pour plus d'informations sur la façon dont les certificats sont mappés aux URL Reporting Services, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Remarque :
Un fichier de base de données de serveur de rapports existant peut entraîner l'échec de l'installation si vous choisissez l'une des options d'installation par défaut. Lorsque vous choisissez une option d'installation par défaut, le programme d'installation tente de créer une base de données de serveur de rapports à l'aide du nom par défaut. Si une base de données existe déjà sous ce nom, le programme d'installation échoue et vous devez annuler l'installation. Pour éviter ce problème, vous pouvez renommer la base de données existante avant d'exécuter le programme d'installation ou choisir l'option Installer mais ne pas configurer le serveur afin de pouvoir spécifier des paramètres de base de données personnalisés une fois l'installation terminée.

Options

Installer la configuration par défaut en mode natif

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. Lorsque vous choisissez cette option, l'instance du serveur de rapports est prête à être utilisée à la fin de l'installation. Le programme d'installation crée la base de données du serveur de rapports à l'aide d'une instance locale de Moteur de base de données, puis configure un serveur de rapports pour l'utilisation des valeurs par défaut.

Cette option n'est disponible que si les valeurs par défaut utilisées dans l'installation d'un serveur de rapports sont valides pour votre système. Cette option est recommandée pour les développeurs qui souhaitent installer tous les composants localement, ainsi que pour les utilisateurs qui évaluent le logiciel.

Pour afficher les informations relatives aux paramètres par défaut utilisés par le programme d'installation ou pour déterminer la raison pour laquelle la configuration par défaut ne peut pas être installée, cliquez sur Détails. Pour plus d'informations sur la configuration par défaut pour un serveur de rapports en mode natif, consultez Configuration par défaut pour une installation en mode natif (Reporting Services).

Installer la configuration par défaut en mode intégré SharePoint

Installe une instance de serveur de rapports en utilisant les valeurs par défaut pour les bases de données, le compte de service et les réservations d'URL du serveur de rapports. La base de données du serveur de rapports est créée dans un format qui prend en charge le stockage et l'adressage de contenu à partir d'un site SharePoint.

Pour plus d'informations sur cette option d'installation, consultez Configuration par défaut pour le mode intégré SharePoint (Reporting Services).

Installer mais ne pas configurer le serveur

Installe les fichiers programme du serveur de rapports, crée le compte de service Report Server et inscrit le fournisseur WMI (Windows Management Instrumentation) du serveur de rapports. Cette option d'installation porte également le nom d'installation de « fichiers uniquement ». Sélectionnez cette option si vous ne souhaitez pas utiliser la configuration par défaut. Si la configuration par défaut ne peut pas être installée, ou si vous installez un cluster de basculement SQL Server qui inclut Reporting Services, cette option est la seule disponible. Pour plus d'informations sur l'installation de fichiers uniquement, consultez Installation de fichiers uniquement (Reporting Services).

Une fois l'installation terminée, vous devez créer la base de données du serveur de rapports et configurer le serveur de rapports de sorte qu'il puisse être utilisé. Pour configurer un serveur de rapports et créer la base de données correspondante, utilisez l'outil de configuration de Reporting Services. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports et Configuration d'une connexion de base de données de serveur de rapports.

Installation du complément Reporting Services pour SharePoint Technologies

Pour installer le complément Reporting Services pour SharePoint Technologies, cliquez sur le fichier rsSharePoint.msi dans le dossier d'installation sur le média d'installation SQL Server 2008 après avoir complété l'installation de SQL Server.

Voir aussi

Tâches

Procédure : démarrer la configuration de Reporting Services
Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Concepts

Considérations sur l'installation de Reporting Services
Configuration par défaut pour une installation en mode natif (Reporting Services)


Mots clés réservés (programme d'installation)

Mots clés réservés (programme d'installation) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

SQL Server utilise des mots clés réservés pour définir, manipuler et ajouter des bases de données. Les mots clés réservés font partie de la grammaire Transact-SQL, qui est utilisée par SQL Server pour analyser et comprendre les instructions et les lots Transact-SQL.

Les noms des instances SQL Server ne peuvent pas correspondre à un mot clé réservé. Aidez-vous du tableau suivant pour vous assurer que les mots clés réservés ne sont pas utilisés dans les noms des instances SQL Server.

ADD | EXCEPT | PERCENT
ALL | EXEC | PLAN
ALTER | EXECUTE | PRECISION
AND | EXISTS | PRIMARY
ANY | EXIT | PRINT
AS | FETCH | PROC
ASC | FILE | PROCEDURE
AUTHORIZATION | FILLFACTOR | PUBLIC
BACKUP | FOR | RAISERROR
BEGIN | FOREIGN | READ
BETWEEN | FREETEXT | READTEXT
BREAK | FREETEXTTABLE | RECONFIGURE
BROWSE | FROM | REFERENCES
BULK | FULL | REPLICATION
BY | FUNCTION | RESTORE
CASCADE | GOTO | RESTRICT
CASE | GRANT | RETURN
CHECK | GROUP | REVOKE
CHECKPOINT | HAVING | RIGHT
CLOSE | HOLDLOCK | ROLLBACK
CLUSTERED | IDENTITY | ROWCOUNT
COALESCE | IDENTITY_INSERT | ROWGUIDCOL
COLLATE | IDENTITYCOL | RULE
COLUMN | IF | SAVE
COMMIT | IN | SCHEMA
COMPUTE | INDEX | SELECT
CONSTRAINT | INNER | SESSION_USER
CONTAINS | INSERT | SET
CONTAINSTABLE | INTERSECT | SETUSER
CONTINUE | INTO | SHUTDOWN
CONVERT | IS | SOME
CREATE | JOIN | STATISTICS
CROSS | KEY | SYSTEM_USER
CURRENT | KILL | TABLE
CURRENT_DATE | LEFT | TEXTSIZE
CURRENT_TIME | LIKE | THEN
CURRENT_TIMESTAMP | LINENO | TO
CURRENT_USER | LOAD | TOP
CURSOR | NATIONAL | TRAN
DATABASE | NOCHECK | TRANSACTION
DBCC | NONCLUSTERED | TRIGGER
DEALLOCATE | NOT | TRUNCATE
DECLARE | NULL | TSEQUAL
DEFAULT | NULLIF | UNION
DELETE | OF | UNIQUE
DENY | OFF | UPDATE
DESC | OFFSETS | UPDATETEXT
DISK | ON | USE
DISTINCT | OPEN | USER
DISTRIBUTED | OPENDATASOURCE | VALUES
DOUBLE | OPENQUERY | VARYING
DROP | OPENROWSET | VIEW
DUMMY | OPENXML | WAITFOR
DUMP | OPTION | WHEN
ELSE | OR | WHERE
END | ORDER | WHILE
ERRLVL | OUTER | WITH
ESCAPE | OVER | WRITETEXT

De plus, la norme ISO définit une liste de mots clés réservés. Évitez d'utiliser les mots clés réservés ISO pour les identificateurs et les noms d'objets. La liste des mots clés réservés ODBC figurant dans le tableau ci-dessous est identique à celle des mots clés réservés ISO.

Remarque :
La liste des mots clés réservés ISO peut être parfois plus restrictive ou moins restrictive que la liste SQL Server. Par exemple, la liste des mots clés réservés ISO contient INT. SQL Server ne traite pas INT comme mot clé réservé.

Mots clés réservés ODBC

Les mots suivants sont réservés et utilisés dans les appels de fonctions ODBC. Ces mots ne limitent pas la grammaire SQL minimale. Cependant, pour garantir la compatibilité avec les pilotes qui gèrent la grammaire SQL de base, il est préférable de ne pas utiliser ces mots clés dans les noms d'instance SQL Server.

ABSOLUTE | EXEC | OVERLAPS
ACTION | EXECUTE | PAD
ADA | EXISTS | PARTIAL
ADD | EXTERNAL | PASCAL
ALL | EXTRACT | POSITION
ALLOCATE | FALSE | PRECISION
ALTER | FETCH | PREPARE
AND | FIRST | PRESERVE
ANY | FLOAT | PRIMARY
ARE | FOR | PRIOR
AS | FOREIGN | PRIVILEGES
ASC | FORTRAN | PROCEDURE
ASSERTION | FOUND | PUBLIC
AT | FROM | READ
AUTHORIZATION | FULL | REAL
AVG | GET | REFERENCES
BEGIN | GLOBAL | RELATIVE
BETWEEN | GO | RESTRICT
BIT | GOTO | REVOKE
BIT_LENGTH | GRANT | RIGHT
BOTH | GROUP | ROLLBACK
BY | HAVING | ROWS
CASCADE | HOUR | SCHEMA
CASCADED | IDENTITY | SCROLL
CASE | IMMEDIATE | SECOND
CAST | IN | SECTION
CATALOG | INCLUDE | SELECT
CHAR | INDEX | SESSION
CHAR_LENGTH | INDICATOR | SESSION_USER
CHARACTER | INITIALLY | SET
CHARACTER_LENGTH | INNER | SIZE
CHECK | INPUT | SMALLINT
CLOSE | INSENSITIVE | SOME
COALESCE | INSERT | SPACE
COLLATE | INT | SQL
COLLATION | INTEGER | SQLCA
COLUMN | INTERSECT | SQLCODE
COMMIT | INTERVAL | SQLERROR
CONNECT | INTO | SQLSTATE
CONNECTION | IS | SQLWARNING
CONSTRAINT | ISOLATION | SUBSTRING
CONSTRAINTS | JOIN | SUM
CONTINUE | KEY | SYSTEM_USER
CONVERT | LANGUAGE | TABLE
CORRESPONDING | LAST | TEMPORARY
COUNT | LEADING | THEN
CREATE | LEFT | TIME
CROSS | LEVEL | TIMESTAMP
CURRENT | LIKE | TIMEZONE_HOUR
CURRENT_DATE | LOCAL | TIMEZONE_MINUTE
CURRENT_TIME | LOWER | TO
CURRENT_TIMESTAMP | MATCH | TRAILING
CURRENT_USER | MAX | TRANSACTION
CURSOR | MIN | TRANSLATE
DATE | MINUTE | TRANSLATION
DAY | MODULE | TRIM
DEALLOCATE | MONTH | TRUE
DEC | NAMES | UNION
DECIMAL | NATIONAL | UNIQUE
DECLARE | NATURAL | UNKNOWN
DEFAULT | NCHAR | UPDATE
DEFERRABLE | NEXT | UPPER
DEFERRED | NO | USAGE
DELETE | NONE | USER
DESC | NOT | USING
DESCRIBE | NULL | VALUE
DESCRIPTOR | NULLIF | VALUES
DIAGNOSTICS | NUMERIC | VARCHAR
DISCONNECT | OCTET_LENGTH | VARYING
DISTINCT | OF | VIEW
DOMAIN | ON | WHEN
DOUBLE | ONLY | WHENEVER
DROP | OPEN | WHERE
ELSE | OPTION | WITH
END | OR | WORK
END-EXEC | ORDER | WRITE
ESCAPE | OUTER | YEAR
EXCEPT | OUTPUT | ZONE
EXCEPTION |  |

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Sélectionner une instance

Sélectionner une instance |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Sélectionner une instance de l'Assistant Installation de SQL Server pour spécifier l'instance de SQL Server pour cette opération.

Options

Utilisez les cases d'option pour spécifier s'il faut mettre à niveau l'instance de SQL Server et ses composants partagés, ou uniquement les composants partagés. Les composants partagés dans cette version de SQL Server sont les suivants :

  • Integration Services

  • SQL Server Browser

  • SQL Server Active Directory Helper

  • SQL Writer

Pour plus d'informations sur les scénarios de mise à niveau pris en charge et sur les problèmes de mise à niveau connus, consultez Mises à niveau de la version et de l'édition.

Voir aussi

Concepts

Utilisation du Conseiller de mise à niveau pour la préparation des mises à niveau
Utilisation de plusieurs versions et instances de SQL Server


Configuration de SQL Server - Classement

Configuration de SQL Server - Classement |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Dans la page Configuration du serveur - Classement de l'Assistant Installation de SQL Server, vous pouvez modifier les paramètres de classement utilisés par le Moteur de base de données et Analysis Services pour le tri. Sélectionnez l'option pour correspondre aux paramètres de classement de différentes installations de SQL Server ou d'un autre ordinateur.

Options

Personnaliser pour SQL Server et Analysis Services

SQL Server fournit deux groupes de classements : les classements Windows et les classements SQL Server. Vous pouvez spécifier des paramètres de classement distincts pour le Moteur de base de données et pour Analysis Services ou spécifier le même classement pour tous les deux.

Par défaut, un classement SQL Server est sélectionné pour les paramètres régionaux système de langue anglaise (US). Le classement par défaut pour les versions localisées de SQL Server est la valeur des paramètres régionaux système Windows pour votre ordinateur. Pour plus d'informations, consultez Utilisation des classements SQL Server.

Les paramètres par défaut ne doivent être modifiés que si le paramètre de classement de cette installation de SQL Server doit se conformer aux paramètres de classement utilisés par une autre instance de SQL Server ou aux paramètres régionaux système Windows d'un autre ordinateur.

Remarque Analysis Services utilise uniquement les classements Windows. Si vous prévoyez d'installer Analysis Services, sélectionnez un classement Windows pendant l'exécution du programme d'installation de SQL Server afin de garantir des résultats cohérents entre le Moteur de base de données SQL Server et Analysis Services.

Pour plus d'informations, consultez Paramètres de classement du programme d'installation.

Meilleures pratiques

Pour obtenir la table des paramètres régionaux système de Windows et de leurs classements par défaut correspondants utilisés par le programme d'installation de SQL Server, consultez Paramètres de classement du programme d'installation.

Dans la mesure du possible, choisissez un classement unique pour votre organisation. De cette manière, vous n'avez pas à spécifier explicitement le classement pour chaque base de données, colonne, expression ou identificateur. Si vous devez utiliser plusieurs classements et paramètres de page de codes, codez vos requêtes conformément aux règles de priorité des classements. Pour plus d'informations, consultez la rubrique Priorité de classement (Transact-SQL) dans la documentation en ligne.

Lorsque vous sélectionnez un classement pour SQL Server, considérez les recommandations suivantes :

  • Sélectionnez un classement binaire si cette option est acceptable.

  • Si vos applications utilisent des types de données nchar/nvarchar et char/varchar et peuvent les mélanger dans une comparaison, sélectionnez un classement Windows pour une comparaison cohérente entre les types de données.

  • Si vos applications utilisent exclusivement des types de données char/varchar et que vous utilisez Analysis Services, sélectionnez un classement Windows.

  • Si vos applications utilisent uniquement des types de données char/varchar et que toutes les conditions suivantes sont également remplies, sélectionnez un classement SQL Server :

    • Vous vous souciez des performances de comparaison de chaînes/LIKE.

    • Vous ne vous souciez pas de la sémantique de comparaison linguistique dans les classements Windows.

    • Vous souhaitez l'ordre de tri de dictionnaire dans les classements SQL Server.

    • Vous ne vous souciez pas de la cohérence de tri avec le système d'exploitation ou avec d'autres applications.

Voir aussi

Référence

Prise en charge d'Unicode et du classement
Paramètres de classement du programme d'installation


Configuration de SQL Server - Comptes de service

Configuration de SQL Server - Comptes de service |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Configuration du serveur de l'Assistant Installation de SQL Server pour attribuer des comptes de connexion aux services SQL Server. Les services réels configurés dans cette page dépendent des fonctionnalités que vous avez sélectionnées.

Options

Vous pouvez attribuer le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service individuellement. Vous pouvez également spécifier si les services démarrent automatiquement, sont démarrés manuellement ou sont désactivés. Microsoft vous recommande de configurer les comptes de service individuellement afin de vous assurer que les services SQL Server disposent des autorisations minimales requises pour effectuer leurs tâches. Pour plus d'informations, consultez Configuration des comptes de service Windows.

Configurer les comptes de service SQL Server individuellement (recommandé)

Utilisez la grille pour attribuer à chaque service SQL Server un nom d'utilisateur et un mot de passe d'ouverture de session et définir le type de démarrage pour le service. Vous pouvez utiliser des comptes système intégrés, un compte local, un groupe local, un groupe de domaine ou des comptes d'utilisateurs de domaine pour les services SQL Server.

Pour les installations de cluster de basculement, les informations de nom de compte et de type de démarrage seront préremplies dans cette page, en fonction des paramètres indiqués pour le nœud actif. Vous devez fournir des mots de passe pour chaque compte.

Sélectionnez l'un des services suivants pour en personnaliser les paramètres.

Sélectionnez ce service Pour configurer les paramètres d'authentification pour

SQL Server Agent

Service qui exécute les travaux, analyse SQL Server et autorise l'automatisation de certaines tâches administratives.

Il n'existe aucun compte de connexion par défaut pour ce service.

Le type de démarrage par défaut est Manuel.

SQL Server

Le Moteur de base de données SQL Server.

Il n'existe aucun compte de connexion par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

SQL Server Browser

SQL Server Browser est le service de résolution des noms qui fournit des informations de connexion SQL Server aux ordinateurs clients. Ce service est partagé entre plusieurs instances de SQL Server et Integration Services.

Le compte de connexion par défaut est NT Authority\Service local ; il ne peut pas être modifié.

Le type de démarrage par défaut est Automatique.

Analysis Services

Analysis Services.

Il n'existe aucun compte de connexion par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

Reporting Services

Reporting Services.

Les comptes de service sont utilisés pour configurer une connexion à la base de données du serveur de rapports. Choisissez le service réseau intégré si vous souhaitez utiliser les paramètres d'authentification par défaut. Si vous spécifiez un compte d'utilisateur de domaine, assurez-vous d'inscrire un nom principal de service (SPN) pour ce compte si vous utilisez l'authentification Windows sur le serveur de rapports. Pour plus d'informations, consultez Procédure : configurer l'authentification Windows dans Reporting Services.

Important :
Microsoft vous recommande de ne pas utiliser le compte Service réseau pour les services SQL Server ou SQL Server Agent si un compte disposant de privilèges moindres est disponible, car Service réseau est un compte partageable. Service réseau convient uniquement à une utilisation comme compte de service SQL Server si vous pouvez garantir qu'aucun autre service qui utilise le compte n'est installé sur l'ordinateur. Les comptes Utilisateur local ou Utilisateur de domaine qui ne sont pas administrateurs Windows sont plus appropriés pour les services SQL Server.

Il n'existe aucun compte de connexion par défaut pour ce service.

Le type de démarrage par défaut est Automatique.

Integration Services

Integration Services propose un ensemble d'outils graphiques et d'objets programmables permettant de déplacer, de copier et de transformer les données.

Le compte de connexion par défaut pour ce service est NT Authority\Service réseau.

Le type de démarrage par défaut est Automatique.

Lanceur de démon de filtre de texte intégral SQL

Service qui crée les processus fdhost.exe. Ce service est obligatoire pour héberger les analyseurs lexicaux et filtres qui traitent les données textuelles pour l'indexation de texte intégral.

Fournissez un compte dans lequel exécuter le service du lanceur FDHOST. Nous vous recommandons vivement d'utiliser un compte à faibles privilèges. Ce compte doit être différent de celui que vous utilisez pour le service SQL Server. Sur Windows Vista et Windows Server 2008, le compte du service du lanceur FDHOST prend pour valeur par défaut SERVICE LOCAL.

Pour des raisons de sécurité, sur des versions de Windows antérieures à Windows Vista et Windows Server 2008, nous vous recommandons d'utiliser un compte UTILISATEUR LOCAL créé spécialement comme compte du service du lanceur FDHOST. L'utilisation d'un compte SYSTÈME LOCAL, SERVICE LOCAL ou SERVICE RÉSEAU risque de fournir accidentellement des privilèges accrus pour le service et de réduire ainsi la sécurité de votre installation de SQL Server.

Le service du lanceur FDHOST est démarré automatiquement sauf si le compte de service n'est pas valide ou que vous n'en spécifiez pas (sur Windows Server 2003 ou Windows XP).

Voir aussi

Référence

Configuration des comptes de service Windows

Concepts

Considérations sur la sécurité pour une installation SQL Server


Assistant Cluster de basculement SQL Server - Terminé

Assistant Cluster de basculement SQL Server - Terminé |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système


Assistant Cluster de basculement SQL Server - Installer

Assistant Cluster de basculement SQL Server - Installer |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système


Assistant Cluster de basculement SQL Server - Préparer

Assistant Cluster de basculement SQL Server - Préparer |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est requis avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système


Résumé (Mise à niveau)

Résumé (Mise à niveau) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Utilisez la page Résumé pour afficher les options spécifiées pour cette mise à niveau.

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)


Analyse de la configuration système (SCC, System Configuration Check)

Analyse de la configuration système (SCC, System Configuration Check) |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Analyse de la configuration système de l'Assistant Installation de SQL Server indique la progression de l'outil de validation du système. Les routines de l'Analyse de la configuration système recherchent sur l'ordinateur où SQL Server sera installé les conditions susceptibles de bloquer le programme d'installation.

Options

Le bouton Suivant est uniquement disponible si tous les résultats d'analyse sont positifs ou si les échecs d'analyse ne bloquent pas le programme d'installation.

Utilisez le bouton Afficher les détails pour afficher le résumé des règles et des résultats d'analyse. La colonne État à droite des résultats de l'analyse affiche l'état de chaque élément. Cliquez sur l'état d'un élément pour consulter les détails.

Le tableau suivant décrit les paramètres de contrôle pour le SCC, les spécifications et la résolution des problèmes bloquants.

Élément d'analyse | Description | Action de l'utilisateur
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Vérifiez que la version du système d'exploitation est conforme à la configuration minimale requise pour ce produit. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des droits d'administrateur sur l'ordinateur. | Vérifiez que le compte qui exécute le programme d'installation de SQL Server a des droits d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Vérifiez que le service WMI (Windows Management Instrumentation) est en cours d'exécution.
SSMS_IsInternetConnected | Vérifie si l'ordinateur est connecté à Internet. Les outils d'administration SQL Server basés sur la technologie .NET Framework doivent vérifier la liste de révocation de certificats au démarrage. | Vérifiez que l'ordinateur est connecté à Internet.
FacetDomainControllerCheck | Vérifie si l'ordinateur est contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est installé. Windows PowerShell est un composant requis de SQL Server 2008 Express Edition with Advanced Services. | Pour les installations de Microsoft SQL Server 2008 Express with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Permet de déterminer si le programme d'installation est pris en charge sur la plate-forme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Rubriques supplémentaires relatives aux règles

Consultez les rubriques suivantes pour des règles d'installation spécifiques au scénario :

  • Règles d'installation des fonctionnalités

  • Contrôle des règles de mise à niveau et de réparation

  • Règles de mise à niveau de l'édition

  • Règles de désinstallation

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système
Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008


Règles de désinstallation

Règles de désinstallation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

La page Règles de désinstallation exécute un ensemble de règles pour garantir le succès de l'installation.

Options

Le tableau suivant décrit les paramètres de contrôle pour l'outil d'analyse de configuration système, les spécifications et la résolution des problèmes bloquants :

Élément d'analyse | Description | Action de l'utilisateur
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
OsVersionCheck | Vérifie si l'ordinateur répond à la configuration minimale requise en termes de version du système d'exploitation. | Vérifiez que la version du système d'exploitation est conforme à la configuration minimale requise pour ce produit.
RebootRequiredCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
ThreadHasAdminPrivilegeCheck | Vérifie si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur. | Vérifiez si le compte qui exécute le programme d'installation de SQL Server a des privilèges d'administrateur sur l'ordinateur.
WmiServiceStateCheck | Vérifie si le service WMI est démarré et s'exécute sur l'ordinateur. | Vérifiez que le service WMI fonctionne.
BlockMismatchedArchitectureUninstall | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de supprimer est différente de celle de ce programme d'installation. | L'architecture du programme d'installation doit être identique à celle de l'instance de SQL Server que vous désinstallez.

Rubriques supplémentaires relatives aux règles

Consultez les rubriques suivantes pour des règles d'installation spécifiques au scénario :

  • Règles d'installation des fonctionnalités

  • Contrôle des règles de mise à niveau et de réparation

  • Règles de mise à niveau de l'édition

  • Règles de désinstallation

Voir aussi

Tâches

Procédure : installer SQL Server 2008 (programme d'installation)

Référence

Paramètres de l'outil d'analyse de configuration système
Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008


Contrôle des règles de mise à niveau et de réparation

Contrôle des règles de mise à niveau et de réparation |
 | Voir aussi
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Les règles suivantes sont utilisées par le programme d'installation de SQL Server pour valider la configuration de votre ordinateur avant la fin de l'opération d'installation.

Élément d'analyse | Description | Action de l'utilisateur
SSMS_IsInternetConnected | Vérifie que l'ordinateur est connecté à Internet. Lorsqu'une application .NET Framework comme Microsoft Management Studio démarre, il peut y avoir un court délai le temps que le contrôle de sécurité .NET Framework valide un certificat. | Vérifiez que l'ordinateur est connecté à Internet.
AclPermissionsFacet | Vérifie si les clés de Registre SQL Server sont cohérentes. | Les clés de Registre SQL Server doivent être cohérentes pour prendre en charge l'installation ou la mise à niveau de SQL Server.
BlockMixedArchitectureUpgrade | Vérifie si l'architecture de processeur des fonctionnalités que vous essayez de mettre à niveau est différente de celle de ce programme d'installation. | Vous devez effectuer l'installation ou la mise à niveau à l'aide d'un support d'installation SQL Server correspondant à l'architecture de l'instance de SQL Server que vous modifiez.
Cluster_IsOnlineIfClustered | Vérifie que l'ordinateur n'est pas en cluster ou que l'ordinateur est en cluster et que le service de cluster est en ligne. | L'ordinateur ne doit pas être en cluster ou le cluster doit être opérationnel et en ligne.
FacetDomainControllerCheck | Vérifie si l'ordinateur est ou non un contrôleur de domaine. L'installation de SQL Server 2008 sur un contrôleur de domaine n'est pas recommandée. | Vérifiez que cet ordinateur n'est pas un contrôleur de domaine. Consultez Considérations sur la sécurité pour une installation SQL Server.
FacetPowerShellCheck | Vérifie si Windows PowerShell est ou non installé. Windows PowerShell est un composant requis pour certaines éditions de SQL Server 2008. | Pour les installations de SQL Server 2008 Express Edition with Advanced Services, vérifiez que Windows PowerShell est installé.
FacetWOW64PlatformCheck | Détermine si le programme d'installation de SQL Server est ou non pris en charge sur cette plateforme de système d'exploitation. | Cette règle bloquera les installations non prises en charge sur la plateforme 64 bits. Consultez Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008.
FusionRebootCheck | Vérifie si un redémarrage de l'ordinateur en attente est nécessaire. Un redémarrage en attente peut provoquer l'échec du programme d'installation. | Un redémarrage de l'ordinateur est nécessaire. Vous devez redémarrer cet ordinateur avant d'installer SQL Server.
PerfMonCounterNotCorruptedCheck | Vérifie si la ruche du Registre du compteur de performance existante est cohérente. | Vérifiez que la ruche du Registre du compteur de performance est cohérente.
SqlUnsupportedProductBlocker | Vérifie si SQL Server 7.0 ou SQL Server 7.0 OLAP Services est installé. SQL Server 2008 n'est pas pris en charge côte à côte avec SQL Server 7.0. | Supprimez SQL Server 7.0 ou installez SQL Server 2008 sur un autre ordinateur.

Voir aussi

Référence

Paramètres de l'outil d'analyse de configuration système


Vérifier les options de désinstallation

Vérifier les options de désinstallation
Guide de référence de l'interface utilisateur du programme d'installation de SQL Server >

Vérifiez votre sélection, puis cliquez sur Suivant pour continuer.


La rubrique que vous recherchez n'est pas disponible tant que le programme d'installation n'a pas terminé l'installation de la documentation en ligne.

La rubrique que vous recherchez n'est pas disponible tant que le programme d'installation n'a pas terminé l'installation de la documentation en ligne.

Une fois le programme d'installation terminé, vous pouvez consulter la documentation de SQL Server en cliquant sur Aide, en appuyant sur la touche F1 dans les boîtes de dialogue ou les éléments d'interface, ou (à partir du menu Démarrer) en pointant sur Tous les programmes, sur Microsoft SQL Server 2005, sur Documentation et didacticiels, puis en cliquant sur Documentation en ligne de SQL Server.