À propos d'Access Web Datasheet

Access Web Datasheet fournit un environnement comparable à celui d'Excel pour l'affichage et la modification de données. Il affiche le contenu d'une liste ou d'une bibliothèque de documents dans une grille constituée de lignes et de colonnes. Les éléments et les colonnes de la liste apparaissent sous forme de lignes et de colonnes dans Access Web Datasheet. Vous pouvez ajouter et modifier des lignes et des colonnes, appliquer des filtres et des ordres de tri, afficher des valeurs calculées et des totaux ou effectuer encore d'autres opérations.

L'illustration suivante montre la Liste des employés dans Access Web Datasheet :

Liste des employés dans Access Web Datasheet

Légende 1 Une ligne correspond à un élément de la liste.

Légende 2 Une colonne correspond à un champ de la liste.

Légende 3 La flèche de liste déroulante dans l'en-tête de colonne permet de filtrer et trier les données.

Légende 4 La ligne des totaux est utilisée pour afficher des valeurs de regroupement pour chaque colonne.

Haut de la page

Afficher une liste dans Access Web Datasheet

La plupart des types de listes peuvent être affichés dans Access Web Datasheet. Il existe deux façons d'afficher une liste dans Access Web Datasheet :

  • En ouvrant une liste en mode Affichage standard, puis en passant au mode Feuille de données en cliquant sur Modifier dans la feuille de données sous l’onglet Liste du ruban.

    Remarque Si un mode Affichage standard ne prend pas en charge la modification en mode Feuille de données, la commande Modifier dans la feuille de données n’est pas disponible. Par exemple, le mode Explorateur d’une bibliothèque de documents ne prend pas en charge la modification en mode Feuille de données.

  • En créant un affichage en mode Feuille de données. Notez que vous pouvez définir le mode Feuille de données comme affichage par défaut pour une liste.

Un affichage Feuille de données est indépendant de tous les autres affichages d'une liste. Si vous ajoutez ou si vous supprimez une colonne d'un affichage en mode standard, la modification n'affecte pas l'affichage en mode Feuille de données.

Les types de listes qui ne prennent pas en charge le mode Feuille de données sont les suivants :

  • Forum de discussion
  • Enquête
  • Bibliothèque d'images
  • Catalogue de modèles Web
  • Catalogue de composants WebPart
  • Sources de données
  • Boîte de réception

Haut de la page

Parties de liste dans Access Web Datasheet

Lignes Un affichage Access Web Datasheet contient une ou plusieurs lignes. Chaque ligne stocke des informations sur un élément de la liste. Par exemple, une ligne de la Liste des employés stocke des informations sur un employé.

Vous pouvez ajouter une ligne en vous plaçant à la fin de la liste et en entrant des données dans la ligne marquée d'un astérisque (*). Vous pouvez également modifier ou supprimer une ligne. Vos modifications sont envoyées au serveur lorsque vous quittez la ligne et elles sont validées de façon asynchrone. Vous pouvez continuer à apporter des modifications à différentes lignes : l'affichage valide alors vos modifications en tâche de fond. Si vos modifications aboutissent à un conflit ou à une erreur, l'affichage est mis à jour avec des informations nécessaires pour résoudre le conflit ou l'erreur.

Vous pouvez changer la hauteur des lignes, trier les lignes à partir d'une ou plusieurs colonnes et masquer des lignes en appliquant des filtres.

Colonnes Un affichage contient une ou plusieurs colonnes. Chaque colonne stocke un type particulier d'informations pour chaque élément de l'affichage. Par exemple, la colonne Nom de la liste Employés stocke le nom des employés.

Vous pouvez ajouter une colonne à une liste en mode Feuille de données ou en mode Affichage standard. Une colonne doit avoir un nom et un type de données spécifique. Vous pouvez indiquer qu’une colonne est obligatoire pour éviter que l’utilisateur ignore la colonne en entrant ses données. Vous pouvez également spécifier d’autres paramètres pour les colonnes, comme une valeur par défaut et une longueur maximale. Pour plus d’informations sur l’ajout d’une colonne à une liste, consultez l’Aide de Microsoft SharePoint Foundation 2010. Pour afficher l’Aide de Microsoft SharePoint Foundation 2010, cliquez sur Aide ( Icône Aide).

Vous pouvez modifier une colonne existante ou supprimer une colonne. Vous pouvez personnaliser l'apparence des colonnes en les affichant ou en les masquant, en les réorganisant, en ajustant la largeur et en filtrant et en triant les lignes sur la base des valeurs contenues dans les colonnes. Vous pouvez également ajouter des colonnes calculées à la liste.

Groupe Feuilles de données Le groupe Feuille de données situé dans le ruban, sous l’onglet Liste, propose des commandes permettant d’effectuer des tâches courantes en mode Feuille de données, comme l’affichage du volet Office ou l’ajout d’une nouvelle ligne.

Barre d'état La barre d'état située dans le bas de l'affichage donne des informations utiles, telles que :

  • des messages d'erreur ou d'avertissement
  • des informations spécifiques à la sélection active, par exemple « Lecture seule ».
  • l'état de communication des serveurs

Volet Office Le volet Office permet un accès facile et contextuel à certaines actions, sans qu'il soit nécessaire de sortir de l'affichage en mode Feuille de données.

L'illustration suivante montre le volet Office pour un exemple de liste :

Légende 1 La barre d'outils se trouve en haut du volet. Elle affiche des boutons pour des commandes courantes, comme Couper, Copier, Coller, Trier et Aide.

Légende 2 Le fait de cliquer sur la barre d'affichage .NET masque ou affiche le volet Office. Vous pouvez faire glisser la barre pour redimensionner le volet.

Légende 3 Pointez au dessus de la barre de défilement pour faire défiler le volet verticalement.

Légende 4 L'intérieur du volet affiche différentes commandes.

Haut de la page

Configuration logicielle requise pour l'utilisation d'Access Web Datasheet

Votre ordinateur doit avoir une configuration logicielle requise pour vous permettre d'afficher une liste dans Access Web Datasheet.

Haut de la page


Configuration logicielle requise pour Access Web Datasheet

Pour ouvrir une liste dans Access Web Datasheet, vous devez disposer de la configuration logicielle suivante :

  • Installez une version 32 bits de Microsoft Office 2010 sur votre ordinateur.
  • Installez le composant Microsoft Office Access Web Datasheet qui fait partie d’Office 2010 sur votre ordinateur.

    Remarque Ce composant est installé par défaut lorsque vous installez Office 2010.

  • Utilisez Microsoft Internet Explorer 6.0 ou version ultérieure pour ouvrir la liste.
  • Vérifiez que les paramètres de sécurité du navigateur prennent en charge les contrôles Microsoft ActiveX.

Si un ou plusieurs de ces éléments ne sont pas installé, un message vous indique que la liste sera affichée en mode standard. Les paramètres que vous avez spécifiés pour le mode Feuille de données, comme l'ordre des colonnes, le tri et le filtre ainsi que les paramètres de la ligne des totaux, vont être appliqués à l'affichage en mode standard avant l'affichage de la liste. Cependant, des paramètres comme la hauteur des lignes, la largeur des colonnes et les colonnes masquées sont ignorés.

Notez que même si votre configuration ne correspond que partiellement à la configuration requise, vous pourrez apporter des modifications à l'affichage en mode Feuille de données. Ces modifications seront enregistrées et vous pourrez les voir lorsque vous utiliserez un ordinateur répondant à la configuration requise.


Affichage des informations sur le produit et sur l'ordinateur

Vous pouvez afficher la version du composant Microsoft Office Access Web Datasheet qui est installé sur votre ordinateur, le numéro d'identification du produit, des informations système, ainsi que d'autres informations qui s'y rapportent en ouvrant la boîte de dialogue À propos de.

  • Cliquez avec le bouton droit dans le coin supérieur gauche de la liste, puis cliquez sur À propos de.


Obtention d'aide dans Access Web Datasheet

  • Pour obtenir de l'aide sur Access Web Datasheet, cliquez avec le bouton droit sur l'une des cellules de la feuille de données, puis cliquez sur Aide.

    Important Les rubriques d’aide d’Access Web Datasheet traitent des fonctionnalités qui sont disponibles. Pour obtenir une aide générale sur les listes SharePoint, cliquez sur Aide ( Icône Aide).

  • Pour obtenir de l’aide sur la page de SharePoint contenant la feuille de données, cliquez sur Aide ( Icône Aide).
  • Pour obtenir de l'aide lorsqu'un composant WebPart d'affichage de liste est affiché en mode Feuille de données, cliquez sur le menu du composant WebPart, puis sur Aide. Les rubriques d'aide traitent des pages, des propriétés et des connexions de composants WebPart.

Remarques

  • Plusieurs boîtes de dialogue et messages de la barre d'état comprennent des liens vers des informations d'aide contextuelles. Vous pouvez également cliquer sur Aide ( Icône Aide) dans la barre d'outils du volet Office.
  • Si la feuille de données est activée, une pression sur la touche F1 affiche l'aide sur le mode Feuille de données. Dans le cas contraire, c'est l'aide d'Internet Explorer qui s'affiche.


Résolution des problèmes dans Access Web Datasheet

Je ne parviens pas à ouvrir une liste dans Access Web Datasheet ou la liste s’ouvre en mode standard

Aucune donnée n’est visible ou seules certaines données sont visibles dans l’affichage

Affichage du message « La liste/l’affichage n’existe pas »

Affichage du message « Vous ne disposez pas des autorisations nécessaires »

Affichage du message « Impossible d’afficher ou d’ajouter des pièces jointes »

Affichage du message « Impossible d’actualiser la liste »

Affichage du message « Des champs requis sont manquants dans l’affichage »

L’affichage ou une partie de celui-ci est en lecture seule

Je ne parviens pas à ouvrir une liste dans Access Web Datasheet ou la liste s’ouvre en mode standard

Ce problème peut être dû à l'une des raisons suivantes :

  • La configuration de votre ordinateur ne répond pas aux conditions requises pour afficher Access Web Datasheet.
    • Un composant de feuille de données compatible avec SharePoint Foundation 2010 n’est pas installé.
    • Votre navigateur ne prend pas en charge les contrôles ActiveX.
    • Le mode Feuille de données n’est pas pris en charge sur les installations 64 bits de Microsoft Office.
    • La prise en charge des contrôles ActiveX est désactivée.
  • Si la liste ou l’affichage actuel ne prend pas en charge le mode Feuille de données, l’option Mode Feuille de données du Ruban est estompée. Par exemple, l’affichage d’une bibliothèque de diapositives en mode Feuille de données n’est pas pris en charge.
  • Une erreur s'est produite lors de l'accès aux informations sur la structure de la liste ou la définition de l'affichage. Essayez d'actualiser l'affichage.

Haut de la page

Aucune donnée n’est visible ou seules certaines données sont visibles dans l’affichage

Si vous ne voyez aucune donnée dans l'affichage, ce peut être parce que le serveur est occupé ou non trouvé ou bien parce qu'une autre erreur s'est produite. Fermez la liste et essayez de l'afficher ultérieurement.

Certaines lignes ou colonnes peuvent ne pas être visibles pour une ou plusieurs des raisons suivantes :

  • Vous avez appliqué un filtre ou bien un filtre fait partie de la définition de l'affichage.

    Pour savoir si des filtres sont appliqués à l'affichage, vérifiez si la flèche pointant vers le bas dans les en-têtes de colonne ont une apparence normale. Si une colonne est filtrée, la flèche apparaît dans une couleur différente. La différence de couleur peu être difficilement visible sur certains moniteurs.

    Pour vérifier qu’un filtre est bien spécifié comme faisant partie de la définition d’un affichage, dans le Ruban, sous l’onglet Liste, cliquez sur Modifier cet affichage. Dans la page Modifier l’affichage, regardez dans la section Filtre si un filtre a été appliqué.

  • La colonne est masquée ou la colonne n'est pas incluse dans la définition de l'affichage.

    Pour afficher toutes les colonnes masquées, cliquez avec le bouton droit sur la cellule supérieure gauche de l'affichage et cliquez sur Afficher.

    Pour vérifier qu’une colonne est incluse dans l’affichage, dans le Ruban, sous l’onglet Liste, cliquez sur Modifier cet affichage. Dans la page Modifier l’affichage, dans la section Colonnes, vérifiez si la case à cocher Afficher n’est pas activée. Activez-la pour inclure la colonne dans l’affichage.

  • La liste requiert l'approbation de contenu et tous les éléments ou certains d'entre-eux sont toujours en attente ou ont été rejetés.

    Pour vérifier le statut d'approbation de vos éléments, dans la liste déroulante Affichage, cliquez sur Mes soumissions. Consultez les colonnes Statut d'approbation et Commentaires. Si un élément a été rejeté, modifiez l'élément. L'élément est alors placé en attente et sera à nouveau envoyé pour approbation.

Haut de la page

Affichage du message « La liste/l’affichage n’existe pas »

La liste ou l'affichage en mode Feuille de données n'existe pas. Il est possible qu'elle ait été supprimée par un autre utilisateur. Vérifiez que la liste et l'affichage existent, puis réessayez.

Haut de la page

Affichage du message « Vous ne disposez pas des autorisations nécessaires »

Ce peut être dû à une des raisons suivantes :

  • Vous ne disposez pas des autorisations nécessaires pour effectuer la modification.
  • Vous avez été empêché d'ajouter du contenu au site.
  • Vous avez dépassé vos limites de stockage sur le site.
Pour éviter ces erreurs, contactez votre administrateur système.

Haut de la page

Affichage du message « Impossible d’afficher ou d’ajouter des pièces jointes »

Ceci peut être dû à une erreur qui s'est produite sur le serveur. Essayez d'ajouter ou d'afficher vos pièces jointes ultérieurement.

Haut de la page

Affichage du message « Impossible d’actualiser la liste »

À cause d'une erreur du serveur, l'affichage ne peut pas être actualisé. Cliquez sur Oui pour réessayer. Si l'erreur se produit à nouveau, cliquez sur Non et réessayez ultérieurement.

Haut de la page

Affichage du message « Des champs requis sont manquants dans l’affichage »

L'affichage ne comprend pas une ou plusieurs colonnes dont les données sont requises. Une ligne doit avoir des valeurs non vides dans les colonnes dont le paramètre Requise a été activé, avant d'être envoyée au serveur.

Étant donné que l'affichage ne comprend pas une ou plusieurs des colonnes où des données sont requises, vous ne pouvez pas effectuer les opérations suivantes :

  • Ajouter de nouvelles lignes.
  • Modifier une ligne si elle a une valeur vide dans une de ses colonnes où les données sont requises.

    Remarque Une colonne dont le paramètre Requise est activé ne va pas accepter de valeurs vides. Cependant, une colonne dont le paramètre Requise n'était pas activé mais qui a été activé par la suite, peut contenir des valeurs vides. Aussi, lorsque vous changez le paramétrage d'une colonne de Non requis en Requis, éditez la liste en mode Feuille de données pour vérifier que la colonne a bien des valeurs non vides pour chacune de ses lignes.

Pour éviter ce message, ajoutez les champs requis à l'affichage ou contactez l'auteur de la liste.

Haut de la page

L’affichage ou une partie de celui-ci est en lecture seule

Cela peut être dû à une parmi plusieurs raisons. Pour plus d'informations, cliquez sur le lien Lecture seule dans la barre d'état.

Haut de la page


Définir un affichage de feuille de données comme affichage par défaut

Lorsque vous créez une liste, un nouvel affichage « standard » lui est appliqué par défaut. Pour passer en mode Feuille de données, dans le Ruban, sous Outils de liste, cliquez sur Liste, puis sur Mode Feuille de données. Toutefois, si vous souhaitez définir le mode Feuille de données comme affichage par défaut d’une liste, vous devez tout d’abord créer un nouvel affichage de feuille de données pour la liste et ensuite en faire l’affichage par défaut.

Pour créer un nouvel affichage Feuille de données pour une liste et le définir comme affichage par défaut :
  1. Dans le Ruban, cliquez sur l’onglet Liste, puis cliquez sur Créer un affichage.
  2. Dans la page Créer un affichage, sous Choisir un format d’affichage, cliquez sur Mode Feuille de données.
  3. Dans la page Créer un mode Feuille de données, tapez le nom de l’affichage. Vous pouvez inclure le mot « Feuille de données » pour indiquer qu’il s’agit d’un affichage de ce type.
  4. Activez la case à cocher Définir cet affichage comme affichage par défaut.
  5. Vérifiez que l’option Créer un affichage public est activée afin que les autres visiteurs puissent voir cet affichage.
  6. En bas de la page, cliquez sur OK.
Pour définir le mode Feuille de données comme affichage par défaut :
  1. Dans le Ruban, cliquez sur l’onglet Liste, puis cliquez sur Paramètres de la liste.
  2. Dans la page Paramètres de la liste, sous Affichages, cliquez sur le nom de l’affichage dont vous voulez faire l’affichage par défaut.
  3. Dans la page Modifier l’affichage, dans la section Nom, activez la case à cocher Définir cet affichage comme affichage par défaut.

    Remarque Si l'affichage est déjà défini comme affichage par défaut, ou s'il est défini comme affichage personnalisé, la case à cocher n'est pas affichée.


Afficher, masquer ou redimensionner le volet Office

  • Pour afficher ou masquer le volet Office, sur le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  • Pour redimensionner le volet Office, placez le curseur sur la barre d'affichage .NET à gauche du volet. Lorsque le curseur se transforme en curseur de redimensionnement, cliquez et faites glisser le curseur vers la gauche ou vers la droite.


Raccourcis clavier

Vous pouvez utiliser des touches de raccourci pour accéder rapidement aux commandes ou aux opérations fréquemment utilisées. Les sections suivantes présentent les touches de raccourcis disponibles dans Access Web Datasheet. Vous pouvez également utiliser des touches d'accès rapide pour activer différentes parties de l'affichage sans l'aide de la souris.

Sélection d'éléments de l'affichage

Exécution de commandes

Édition des données

Formatage d'une cellule qui prend en charge le texte HTML enrichi

Tri et filtrage des données

Sélection d'éléments de l'affichage

Pour | Appuyez sur
Déplacer la sélection de la gauche vers la droite, puis vers le bas. Si plusieurs cellules sont sélectionnées, activer la cellule suivante de la sélection. | TAB
Déplacer la sélection de haut en bas, puis vers la droite. Si plusieurs cellules sont sélectionnées, activer la cellule suivante de la sélection. | ENTRÉE
Déplacer la sélection de droite à gauche. Si la cellule active est la cellule la plus à gauche, MAJ+TAB sélectionne la dernière cellule de la ligne précédente. | MAJ+TAB
Sélectionner la cellule au-dessus de la cellule active. Si la cellule active est la cellule la plus haute, MAJ+ENTRÉE sélectionne la dernière cellule de la colonne précédente. | MAJ+ENTRÉE
Déplacer la sélection dans la direction correspondant à la touche de direction. | Touches de direction
Étendre ou réduire la sélection dans la direction correspondant à la touche de direction. | MAJ+Touche de direction
Déplacer la sélection vers la dernière cellule dans la direction correspondant à la touche de direction. S'il y a des cellules vides dans cette direction, déplacer vers la dernière cellule précédant la première cellule vide. | CTRL+Touche de direction
Étendre la sélection vers la dernière cellule dans la direction correspondant à la touche de direction. S'il y a des cellules vides dans cette direction, étendre la sélection vers la dernière cellule précédant la première cellule vide. | CTRL+MAJ+Touche de direction
Sélectionner la première cellule de la ligne active. | Début
Sélectionner la première cellule de la première ligne. | CTRL+Début
Sélectionner la dernière cellule de la dernière ligne. | CTRL+Fin
Étendre la sélection vers le début de la ligne active. | MAJ+Début
Étendre la sélection vers la fin de la ligne active. | MAJ+Fin
Étendre la sélection vers le début de la liste. | CTRL+MAJ+Début
Étendre la sélection vers la fin de la liste. | CTRL+MAJ+Fin
Étendre la sélection à la colonne entière. Si le texte d'une cellule est sélectionné et que la colonne prend en charge le formatage HTML enrichi, supprimer le formatage. | CTRL+Barre d'espace
Étendre la sélection à la ligne entière. | MAJ+Barre d'espace
Sélectionner la totalité de la liste. | CTRL+A
Afficher la page suivante de la liste. | PG. SUIV
Afficher la page précédente de la liste. | PG. PRÉC
Étendre une sélection d'une page vers le bas. | MAJ+PG. SUIV
Étendre une sélection d'une page vers le haut. | MAJ+PG. PRÉC
Faire défiler pour afficher la cellule active. | CTRL+RETOUR ARRIERE

Haut de la page

Exécution de commandes

Pour | Appuyez sur
Afficher le menu contextuel pour la sélection active. | MAJ+F10
Exécuter la commande du menu contextuel contenant la lettre soulignée. | Lettre soulignée dans un menu contextuel
Annuler les modifications apportées aux lignes et qui n'ont pas encore été validées. Si un menu contextuel est visible, fermer le menu contextuel sans exécuter de commande. En mode Modification, annuler ce mode et ignore vos modifications. | ÉCHAP
Si l'affichage en mode Feuille de données est activé et qu'il n'est pas en mode Modification, afficher l'aide du mode Feuille de données. Sinon, afficher l'aide de Internet Explorer. | F1
Entrer en mode Modification. | F2
Effacer la cellule active. | Suppr
Afficher le volet Office | F8
Masquer le volet Office | MAJ+F8
Copier la sélection vers le Presse-papiers. | CTRL+C
Coller le contenu du Presse-papiers. | CTRL+V
Déplacer la sélection vers le Presse-papiers. | CTRL+X
Afficher la boîte de dialogue Résoudre les conflits et les erreurs. | F7
Fermer la fenêtre du navigateur. | ALT+F4

Haut de la page

Édition des données

Pour | Appuyez sur
Annuler les modifications apportées à la cellule active. | CTRL+Z
Insérer un trait d'union insécable. | CTRL+MAJ+-
Dans une ligne des totaux, afficher la liste des fonctions de regroupement disponibles pour la cellule active. Dans les colonnes de type Une seule ligne de texte, afficher la liste des valeurs existantes de la colonne. | ALT+Bas

Haut de la page

Formatage d'une cellule qui prend en charge le texte HTML enrichi

Pour | Appuyez sur
Activer la liste des polices. | CTRL+MAJ+F
Activer la liste des tailles de polices. | CTRL+MAJ+P
Appliquer le style Gras à la sélection. | CTRL+B
Souligner la sélection. | CTRL+U
Placer la sélection en italique. | CTRL+I
Justifier la sélection à gauche. | CTRL+L
Justifier la sélection au centre. | CTRL+E
Justifier la sélection à droite. | CTRL+R
Ajouter des puces à la sélection. | CTRL+MAJ+L
Augmenter l'indentation. | CTRL+M
Diminuer l'indentation. | CTRL+MAJ+M
Supprimer le formatage en texte HTML enrichi dans la cellule active. | CTRL+Barre d'espace

Haut de la page

Tri et filtrage des données

Pour | Appuyez sur
Afficher la liste déroulante de filtrage pour la colonne sélectionnée. | ALT+MAJ+Bas
Fermer la liste déroulante de filtrage. | ALT+MAJ+Haut
Passer à l'élément précédent dans la liste déroulante de filtrage, lorsque la liste est affichée. | Haut
Passer à l'élément suivant dans la liste déroulante de filtrage, lorsque la liste est affichée. | Bas
Passer au premier élément dans la liste déroulante de filtrage, lorsque la liste est affichée. | Début
Passer au dernier élément dans la liste déroulante de filtrage, lorsque la liste est affichée. | Fin
Passer une page plus haut ou une page plus bas dans la liste déroulante de filtrage, lorsque la liste est affichée. | PG. PRÉC, PG. SUIV
Exécuter l'élément sélectionné dans la liste déroulante de filtrage, lorsque la liste est affichée. | ENTRÉE

Haut de la page


Extraction et mise à jour des données par Access Web Datasheet

L'édition des données dans Access Web Datasheet est plus rapide qu'en mode standard.

En mode standard, vous ne pouvez modifier qu’un seul élément à la fois. Après avoir été modifié, un élément doit être validé sur le serveur pour que vous puissiez modifier l’élément suivant.

Dans Access Web Datasheet, vous pouvez apporter des modifications à une ligne, puis vous placer dans la ligne suivante et y modifier des cellules. Cet affichage gère l'envoi de vos modifications au serveur et vous communique l'état en retour, sans interrompre votre travail.

Mises à jour asynchrones

Extraction de données asynchrones

Mises à jour asynchrones

Lorsque vous ajoutez ou modifiez une ligne, Access Web Datasheet envoie la modification au serveur, marque la ligne comme étant en attente et affiche l'icône En attente ( Icône En attente ) dans l'en-tête de la ligne. Lorsqu'une ligne comporte des modifications en attente, vous ne pouvez pas la modifier tant que les modifications ne sont pas validées. Par contre, vous pouvez continuer à modifier d'autres lignes pendant que le dernier groupe de modifications est envoyé au serveur.

Lorsque l'affichage obtient une réponse du serveur, il met à jour les données en conséquence. Si la modification a entraîné un conflit ou une erreur, l'en-tête de ligne affiche l'icône Conflit ( Icône Conflit ) ou l'icône Erreur ( Icône Erreur ). Si la modification a été validée, l'icône En attente disparaît et la ligne est à nouveau disponible pour des modifications.

Les modifications apportées à l'affichage, comme la modification de l'ordre des colonnes ou le masquage de la ligne des totaux, sont également envoyées de façon asynchrone au serveur. Vous ne pouvez cependant pas effectuer des modifications structurelles ni modifier une colonne calculée lorsque des modifications sont en attente. Vous devez attendre que toutes les modifications soient validées ou résoudre tout conflit ou toute erreur avant de changer la structure ou de modifier une colonne calculée.

Si vous tentez d'actualiser ou de quitter l'affichage lorsque des modifications sont en attente, vous êtes invité à attendre que vos modifications soient validées. Selon la réponse du serveur, vous pouvez ensuite résoudre les conflits ou les erreurs éventuelles.

Haut de la page

Extraction de données asynchrone

Lorsque vous ouvrez une liste dans Access Web Datasheet, il extrait les 100 premières lignes, puis les lignes restantes de façon asynchrone. La barre d'état affiche Récupération des données tant que Access Web Datasheet récupère des données du serveur. Si vous essayez de filtrer ou de trier des données, vous devez attendre que la liste termine l'extraction de toutes les données nécessaires sur le serveur pour afficher le résultat du filtrage ou du tri.

Si le serveur est occupé, s'il est introuvable ou si toute autre erreur se produit, empêchant ainsi l'affichage d'extraire les lignes nécessaires, l'affichage affiche une erreur.

Haut de la page


Sélectionner une cellule, une ligne, une colonne ou une liste

Sélection d'une seule cellule

  • Cliquez sur la cellule ou appuyez sur les touches de direction pour vous déplacer jusqu'à la cellule.

    Remarque Si vous cliquez sur cellule qui contient un lien hypertexte, vous allez à l’adresse Web correspondante. Pour sélectionner une cellule contenant un lien hypertexte, utilisez un des raccourcis clavier.

Sélection du contenu d'une cellule

  • Sélectionnez la cellule, cliquez à l'intérieur de la cellule et sélectionnez le texte de la cellule.

Sélection d'une plage de cellules

  • Cliquez sur la première cellule de la plage, puis faites glisser le curseur jusqu'à la dernière cellule. Vous pouvez également cliquer sur la première cellule de la plage, puis maintenir la touche MAJ enfoncée et cliquer sur la dernière cellule de la plage.

Remarque Vous pouvez faire défiler la liste pour que la dernière cellule soit visible.

Sélection d'une ligne ou d'une colonne

  • Cliquez sur l'en-tête de la ligne ou de la colonne.

Sélection de plusieurs lignes ou de plusieurs colonnes

  • Cliquez sur l'en-tête de la ligne ou de la colonne et faites glisser le curseur jusqu'à la dernière ligne ou la dernière colonne. Vous pouvez également sélectionner la première ligne ou la première colonne et, en maintenant la touche MAJ enfoncée, cliquer sur la dernière ligne ou la dernière colonne.


Ajouter une colonne de choix à valeurs multiples

Vous pouvez utiliser une colonne de choix à valeurs multiples pour sélectionner simultanément plusieurs éléments dans la liste de choix. Vous pouvez, par exemple, affecter plusieurs personnes à chaque tâche dans une liste de suivi de tâches. Vous entrez les choix possibles lorsque vous ajoutez la colonne à votre liste.

Ajouter une colonne de choix à valeurs multiples

  1. Cliquez avec le bouton droit sur n'importe quel en-tête de colonne ou cellule de la liste puis cliquez sur Ajouter une colonne.
  2. Sous Nom et type, entrez le nom de la colonne puis cliquez sur Choix.
  3. Sous Paramètres de colonne supplémentaires, tapez les choix qui doivent apparaître dans la colonne puis cliquez sur Cases à cocher (autoriser plusieurs sélections).
  4. Définissez les autres options de votre choix puis cliquez sur OK.

Pour utiliser une colonne de choix à valeurs multiples tout en affichant la feuille de données, cliquez sur la flèche de déroulement dans la cellule, puis activez ou désactivez la case à cocher en regard de chaque valeur à ajouter ou à supprimer de la cellule.

Modifier la liste de choix dans une colonne de choix à valeurs multiples

Pour ajouter, modifier ou supprimer des éléments d'une colonne de choix à valeurs multiples, procédez comme suit :

  1. Cliquez avec le bouton droit sur l'en-tête de colonne ou une cellule quelconque de la colonne que vous voulez modifier, puis cliquez sur Modifier/Supprimer une colonne.
  2. Sous Paramètres de colonne supplémentaires, modifiez la liste de choix.
  3. Définissez les autres options de votre choix puis cliquez sur OK.

Utiliser une colonne de choix à valeurs multiples

Pour utiliser une colonne de choix à valeurs multiples, procédez comme suit :

  1. Cliquez sur la flèche de déroulement dans la cellule à modifier.
  2. Activez ou désactivez la case à cocher en regard de chaque élément à ajouter ou à supprimer de la cellule.
  3. Cliquez sur OK.

Les choix sélectionnés apparaissent dans la cellule, séparés par des points-virgules (;).


Ajouter une colonne de recherche à valeurs multiples

Vous pouvez utiliser une colonne de recherche à valeurs multiples pour sélectionner simultanément plusieurs éléments dans la liste de choix. Vous pouvez, par exemple, affecter plusieurs personnes à chaque tâche dans une liste de suivi de tâches. Les valeurs figurant dans la colonne de recherche proviennent d'une colonne existante de la liste active ou d'une autre liste.

Ajouter une colonne de recherche à valeurs multiples

  1. Cliquez avec le bouton droit sur n'importe quel en-tête de colonne ou cellule de la liste puis cliquez sur Ajouter une colonne.
  2. Sous Nom et type, entrez le nom de la colonne puis cliquez sur Recherche (informations déjà sur ce site).
  3. Sous Paramètres de colonne supplémentaires, sélectionnez la liste contenant les valeurs à ajouter à votre colonne de recherche dans la liste déroulante Obtenir des informations à partir de.
  4. Sélectionnez la colonne qui contient les valeurs dans la liste déroulante Dans cette colonne.
  5. Sélectionnez Autoriser plusieurs valeurs.
  6. Définissez les autres options de votre choix puis cliquez sur OK.

Pour utiliser une colonne de recherche à valeurs multiples tout en affichant la feuille de données, cliquez sur la flèche de déroulement dans la cellule, puis activez ou désactivez la case à cocher en regard de chaque valeur à ajouter ou à supprimer de la cellule.

Modifier la liste de choix dans une colonne de recherche à valeurs multiples

Dans la mesure où les éléments d'une colonne de recherche à valeurs multiples proviennent d'une autre colonne de la liste active ou d'une colonne d'une autre liste, vous devez modifier la liste sur laquelle est basée la colonne de recherche. Ainsi, si la colonne de recherche est basée sur les valeurs de la colonne Titre de la liste Tâches, vous devez modifier la liste Tâches afin de modifier les valeurs de la colonne de recherche.

Utiliser une colonne de recherche à valeurs multiples

Pour utiliser une colonne de recherche à valeurs multiples, procédez comme suit :

  1. Cliquez sur la flèche de déroulement dans la cellule à modifier.
  2. Activez ou désactivez la case à cocher en regard de chaque élément à ajouter ou à supprimer de la cellule.
  3. Cliquez sur OK.

Les choix sélectionnés apparaissent dans la cellule, séparés par des points-virgules (;).


Ajout d'une ligne ou d'une colonne

Ajout d'une ligne

Par défaut, la ligne (*) - une ligne vide marquée d'un astérisque (*) dans son en-tête de ligne est affichée après la dernière ligne d'une liste. Vous pouvez l'utiliser pour ajouter un nouvel élément à la liste.

Remarque Vous ne pouvez pas insérer une ligne vide entre deux lignes existantes. Si l'affichage est en lecture seule, la ligne marquée d'un astérisque n'apparaît pas.

Pour ajouter une ligne, effectuez l’une des étapes suivantes :

  • Si la ligne vide n’est pas visible, cliquez avec le bouton droit sur n’importe quelle cellule, puis cliquez sur Ajouter une ligne
  • Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Nouvelle ligne.

Ajout d'une colonne

  1. Cliquez avec le bouton droit sur une cellule de la liste.
  2. Cliquez sur Ajouter une colonne.
  3. Dans la page Créer une colonne, spécifiez les informations de la colonne, puis cliquez sur OK.

    La nouvelle colonne sera ajoutée à droite des colonnes existantes. Pour déplacer la colonne vers son nouvel emplacement, faites glisser son en-tête vers l'emplacement de votre choix.


Modification de la largeur d'une colonne

  1. Cliquez avec le bouton droit sur l'en-tête de la colonne, puis cliquez sur Largeur de colonne.
  2. Dans la boîte de dialogue Largeur de colonne, tapez un nombre compris entre 1 et 255.

Remarques

  • Si vous spécifiez la valeur 0, la colonne apparaît masquée.
  • Vous pouvez également faire glisser la ligne de la limite du côté droit de l'en-tête de la colonne, jusqu'à ce que la colonne ait la largeur souhaitée. Pour dimensionner une colonne de façon à ce que chaque cellule tienne sur une seule ligne, déplacez le curseur vers la limite droite de l'en-tête de la colonne. Lorsque le curseur de redimensionnement apparaît, double-cliquez sur la ligne de limite.


Modification de la hauteur d'une ligne

  1. Cliquez avec le bouton droit sur l'en-tête d'une ligne, puis cliquez sur Hauteur de ligne.
  2. Dans la boîte de dialogue Hauteur de ligne, tapez un nombre compris entre 1 et 409.

Remarques

  • La modification de la hauteur d'une ligne entraîne la modification de celle de toutes les lignes de la liste.
  • Vous pouvez également faire glisser la limite supérieure ou inférieure de l'en-tête de ligne jusqu'à ce que la ligne ait la hauteur souhaitée. Pour redimensionner une ligne de sorte que son contenu soit entièrement visible, placez le curseur sur la limite supérieure de l'en-tête de ligne. Lorsque le curseur de redimensionnement apparaît, double-cliquez sur la ligne de la limite.


Suppression d'une ligne ou d'une colonne

Suppression d'une ligne

  1. Cliquez sur l'en-tête de ligne de la ligne que vous voulez supprimer.

    Remarque Pour supprimer plusieurs lignes, cliquez sur le premier en-tête de ligne et faites glisser le curseur jusqu'à la dernière ligne. Vous pouvez également sélectionner la première ligne, maintenir la touche MAJ enfoncée et sélectionner la dernière ligne.

  2. Cliquez avec le bouton droit sur la sélection, puis cliquez sur Supprimer les lignes.

Les lignes supprimées sont placées dans la Corbeille du site et peuvent être restaurées dans la liste en cas de besoin. Pour plus d’informations sur le fonctionnement de la Corbeille, ouvrez l’aide dans Microsoft SharePoint Foundation 2010 en cliquant sur Aide ( Icône Aide).

Suppression d'une colonne

  1. Cliquez avec le bouton droit sur l'en-tête de colonne de la colonne que vous voulez supprimer, puis cliquez sur Modifier/Supprimer une colonne.
  2. Dans la page Modifier la colonne, cliquez sur Supprimer.

Remarques

  • Les colonnes sélectionnées ne sont pas placées dans la Corbeille du site. Elles sont définitivement supprimées.
  • Vous pouvez supprimer une seule colonne à la fois. Si des cellules sont sélectionnées dans plusieurs colonnes, la colonne contenant la cellule active est retenue comme colonne sélectionnée.
  • Si une colonne est en lecture seule, vous ne pouvez pas la supprimer. De même, vous ne pouvez pas supprimer certaines colonnes dans des listes d'un certain type parce que ces colonnes sont requises pour que la liste fonctionne correctement.


Modification d'une colonne

Vous pouvez modifier le nom d'une colonne, sa description et son type de données, ainsi que les paramètres liés à son type de données.

  1. Cliquez avec le bouton droit sur une cellule de la colonne que vous voulez modifier, puis cliquez sur Modifier/Supprimer une colonne.
  2. Dans la page Modifier la colonne, apportez vos modifications, puis cliquez sur OK.

Remarques

  • Vous ne pouvez modifier qu'une seule colonne à la fois. Si des cellules dans plusieurs colonnes sont sélectionnées, c'est la colonne qui contient la cellule active qui est sélectionnée.
  • Si une colonne est en lecture seule, vous ne pouvez pas la modifier.


Réorganisation des colonnes

Le mode Feuille de données offre un moyen rapide et facile pour changer l'ordre des colonnes.

  1. Pour déplacer une colonne, placez le pointeur de la souris sur l'en-tête de la colonne que vous voulez déplacer, jusqu'à ce qu'il se transforme en pointeur de déplacement ( Pointeur de déplacement ).

    Pour déplacer une série de colonnes, cliquez sur l'en-tête de la première colonne, appuyez sur la touche MAJ et, tout en la maintenant enfoncée, cliquez sur la dernière colonne de la série. Placez le pointeur sur un des côtés du rectangle qui englobe les colonnes sélectionnées pour afficher le pointeur de déplacement.

  2. Cliquez et faites glisser les colonnes sélectionnées vers le nouvel emplacement.

Lorsque vous déplacez une colonne, la définition de l'affichage est automatiquement mise à jour.

Remarque Vous ne pouvez pas déplacer des lignes. Vous pouvez réorganiser les lignes en les triant.


Afficher ou masquer une colonne

Affichage d'une colonne masquée

Une ligne verticale plus épaisse à droite d'un en-tête de colonne indique que la colonne voisine est masquée.

  • Pour afficher une colonne masquée, sélectionnez les colonnes visibles qui se trouvent de part et d'autre de la colonne masquée, cliquez avec le bouton droit sur la sélection, puis cliquez sur Afficher.
  • Pour afficher toutes les colonnes masquées de la liste, cliquez avec le bouton droit sur le coin supérieur gauche de la liste, puis cliquez sur Afficher.

Masquage d'une colonne

  • Pour masquer une colonne, cliquez avec le bouton droit sur l’en-tête de la colonne que vous voulez masquer, puis cliquez sur Masquer.


Afficher les entrées précédentes dans une colonne Plusieurs lignes de texte

Vous pouvez configurer une colonne Plusieurs lignes de texte de sorte que les entrées précédentes soient conservées et non remplacées lorsque vous modifiez les données de la colonne. Cette fonctionnalité vous permet de conserver un enregistrement des entrées précédentes de la colonne, de la date de leur modification et de l'auteur de celle-ci.

Créer une nouvelle colonne pour ajout uniquement

  1. Cliquez avec le bouton droit sur n'importe quelle cellule de la liste puis cliquez sur Ajouter une colonne.
  2. Tapez un nom de colonne dans la zone Nom de colonne puis cliquez sur Plusieurs lignes de texte.
  3. Sous Paramètres de colonne supplémentaires, sous Ajouter des modifications à un texte existant, cliquez sur Oui.
  4. Apportez toutes les autres modifications requises puis cliquez sur OK.

    La nouvelle colonne est ajoutée à la droite des colonnes existantes. Pour déplacer la colonne vers un nouvel emplacement, faites glisser son en-tête jusqu'à l'emplacement souhaité.

Modifier une colonne existante en colonne pour ajout uniquement

  1. Cliquez avec le bouton droit sur l'en-tête de colonne de la colonne à modifier, puis cliquez sur Modifier/Supprimer une colonne.
  2. Si le type de données de la colonne n’est pas encore « Plusieurs lignes de texte », cliquez sur Plusieurs lignes de texte. Si l’option n’est pas disponible, cela signifie que le type de données de cette colonne ne peut pas être modifié et que vous devez créer une nouvelle colonne pour utiliser l’option Ajouter des modifications.
  3. Sous Paramètres de colonne supplémentaires, sous Ajouter des modifications à un texte existant, cliquez sur Oui.
  4. Apportez toutes les autres modifications requises puis cliquez sur OK.

Afficher les entrées précédente dans une colonne pour ajout uniquement

Seule l'entrée la plus récente dans une colonne pour ajout uniquement est affichée dans la cellule Access Web Datasheet. Pour consulter les entrées précédentes, procédez comme suit :

  • Cliquez avec le bouton droit sur la cellule dont vous souhaitez afficher les entrées précédentes puis cliquez sur Afficher les entrées.

    Microsoft SharePoint Foundation 2010 affiche toutes les données de l'élément, y compris les entrées précédentes dans la colonne pour ajout uniquement.


Types de données

Pour obtenir de l'aide sur les types de données, consultez l'aide de Microsoft SharePoint Foundation 2010.

Pour afficher l’Aide de Microsoft SharePoint Foundation 2010, dans la page SharePoint, cliquez sur Aide ( Icône Aide).


Spécification d'une valeur par défaut pour une colonne

Vous pouvez spécifier une valeur par défaut pour des colonnes de type texte simple, choix, nombre, monnaie ou date et heure. La valeur par défaut est affichée automatiquement dans la colonne pour toutes les nouvelles lignes. Vous pouvez laisser la valeur par défaut dans la cellule, ou bien la modifier à tout moment.

  1. Cliquez avec le bouton droit sur une colonne, et cliquez sur Modifier/Supprimer une colonne.
  2. En dessous de Valeur par défaut, sélectionnez un des éléments suivants :
    • Texte Si le type de la colonne est Une seule ligne de texte, spécifiez une chaîne comme valeur par défaut.
    • Choix Si le type de la colonne est Choix, spécifiez un des choix de la liste de choix spécifiés plus haut.
    • Nombre Si le type de la colonne est Nombre, spécifiez une valeur numérique.
    • Monétaire Si le type de la colonne est Monétaire, spécifiez une valeur monétaire.
    • Date du jour Si le type de la colonne est Date et heure et que vous voulez la date du jour comme valeur par défaut, choisissez cette option.
    • Une date quelconque Si le type de la colonne est Date et heure et que vous voulez spécifier une date spécifique, sélectionnez le bouton de la dernière option et entrez une date au format JJ/MM/AAAA.
    • Oui dans la case à cocher Valeur par défaut Si le type de la colonne est Oui/Non (case à cocher) et que vous voulez que la case à cocher apparaisse activée par défaut, sélectionnez Oui.
    • Calculé Si vous voulez utiliser une valeur calculée comme valeur par défaut, entrez une formule. Notez que la formule ne peut pas référencer d'autres colonnes de la liste.


Résolution des problèmes liés aux types de données

Pour obtenir de l'aide sur la résolution des problèmes liés aux types de données, consultez l'aide de Microsoft SharePoint Foundation 2010.

Pour afficher l’aide de Microsoft SharePoint Foundation 2010, cliquez sur Aide ( Icône Aide).


Ajout, modification ou suppression du contenu d'une cellule

Modification d'une cellule à la fois

Vous pouvez ajouter, modifier ou supprimer le contenu d'une cellule en mode Modification.

  1. Si la cellule que vous voulez modifier n'est pas sélectionnée, cliquez sur celle-ci.

    Remarque Si la cellule contient un lien hypertexte, vous allez accéder à l'adresse Web correspondante.

  2. Cliquez de nouveau sur la cellule pour passer au mode Modification, puis apportez vos modifications à la cellule.

    Remarque Vous pouvez également appuyer sur F2 pour passer au mode Modification.

  3. Appuyez sur TAB ou ENTRÉE lorsque vous avez terminé.

Remarque Appuyez sur Ctrl+Z pour annuler la dernière modification que vous avez apportée à la cellule. Appuyez sur Échap pour annuler les modifications que vous avez apportées à la cellule et quitter le mode Modification.

Modification de cellules en bloc

Vous pouvez modifier en bloc des cellules, des lignes ou des colonnes de l'une des façons suivantes :

  • En copiant et en collant des données.
  • En faisant glisser la poignée de recopie.


Modification d'un lien hypertexte

Cette commande est disponible uniquement si la cellule sélectionnée contient un lien hypertexte.

  1. Cliquez avec le bouton droit sur la cellule qui contient un lien hypertexte, pointez sur Lien hypertexte, puis cliquez sur Modifier le lien hypertexte.
  2. Dans la boîte de dialogue Modifier le lien hypertexte, tapez une adresse URL valide dans la zone de texte Entrez l’adresse Web. Une adresse URL valide doit commencer par un protocole, tel que http:// ou ftp://, et ne doit pas dépasser 255 caractères.
  3. Tapez le texte à afficher dans la zone de texte Entrez la description.


Saisir des données dans une cellule en les sélectionnant dans une liste de valeurs

Lorsque vous entrez des données dans une colonne comportant une seule ligne de cellules de texte, vous pouvez sélectionner une valeur pour la cellule de deux manières.

  • Cliquez sur la cellule dans laquelle vous voulez entrer les données. Si une flèche vers le bas s’affiche en regard de la cellule, cliquez sur la flèche, puis sur la valeur que vous souhaitez sélectionner pour cette cellule.

    Sélection à partir d’une liste

  • Commencez à taper les données dans la cellule. Les données entrées ailleurs dans la colonne sont utilisées pour correspondre à ce que vous avez déjà tapé, et le résultat le plus proche s’affiche dans la cellule. Lorsque la valeur appropriée s’affiche, appuyez sur Entrée pour la sélectionner.

    Saisie à partir d’une liste


Réception d'une notification lorsque le contenu d'une liste est modifié

Afficher Réception d'une notification lorsque l'un des éléments suivants est modifié : ligne, document ou cellule

  1. Cliquez avec le bouton droit sur l'en-tête de la ligne ou sur la cellule pour laquelle vous voulez activer la notification, puis cliquez sur M'avertir.
  2. Dans la page Nouvelle alerte, spécifiez comment et quand vous voulez recevoir la notification.

Afficher Réception d'une notification si une quelconque modification est apportée à la liste ou à la bibliothèque de documents

  1. Cliquez avec le bouton droit sur le coin supérieur gauche de la liste ou de la bibliothèque, puis cliquez sur M'avertir.
  2. Dans la page Nouvelle alerte, spécifiez comment et quand vous voulez recevoir la notification.


Annuler des modifications

Vous pouvez annuler des modifications qui n'ont pas encore été enregistrées dans la liste. En mode Modification, vous pouvez annuler des modifications apportées à la cellule active.

  • Cliquez sur Annuler dans la barre d'outils du volet Office ou utilisez la combinaison de touches CTRL+Z.

Remarques

  • Pour les cellules qui prennent en charge la mise en forme HTML enrichi, chaque commande de mise en forme est considérée comme une modification.
  • La commande Annuler est différente de celle qui permet d'annuler le mode Modification en appuyant sur la touche Échap.
  • Vous ne pouvez pas annuler les modifications apportées à la liste après avoir ajouté ou supprimé une pièce jointe d'un enregistrement. Vous ne pouvez pas annuler les modifications apportées à une ligne après que la ligne ait été enregistrée.


Validation des données

Pour obtenir de l'aide sur la validation des données, consultez l'aide de Microsoft SharePoint Foundation 2010.

Pour afficher l’aide de SharePoint Foundation 2010, cliquez sur Aide ( Icône Aide).


Mise en forme des données

Vous pouvez mettre en forme le contenu d'une colonne si elle prend en charge plusieurs lignes de texte et le texte enrichi (RTF).

Pour activer la prise en charge du texte enrichi pour une colonne :

  1. Cliquez avec le bouton droit dans la colonne pour laquelle vous souhaitez autoriser le texte enrichi et cliquez sur Modifier/Supprimer une colonne.
  2. Sous Nom et type, sélectionnez Plusieurs lignes de texte si cela n'est pas déjà fait.
  3. Sous Paramètres supplémentaires de colonne, sélectionnez Texte enrichi (gras, italique, alignement de texte).
  4. Cliquez sur OK.

Une fois les paramètres définis, vous pouvez mettre en forme le texte d'une ou plusieurs cellules, ou seulement une partie de texte dans une cellule :

  1. Sélectionnez les cellules ou le texte à mettre en forme.
  2. Si le volet Office n’est pas ouvert, dans le ruban, cliquez sur l’onglet Liste, puis sur Afficher le Volet Office.
  3. Appliquez le format de votre choix. Vous pouvez changer les paramètres de la police, la couleur du texte et la couleur d'arrière-plan, ainsi que l'indentation et l'alignement. Vous pouvez également organiser le texte en liste d'éléments numérotés ou en liste à puces.

Remarques

  • Pour supprimer la mise en forme en texte enrichi, sélectionnez le texte, puis appuyez sur CTRL+Espace. Cette combinaison de touches ne supprime toutefois pas le paramètre d'alignement.
  • Vous ne pouvez pas mettre en forme des cellules en lecture seule ni la ligne des totaux.
  • Le formatage ne s'applique pas aux lignes masquées parce qu'un filtre a été appliqué.


Activer ou désactiver le renvoi à la ligne du texte dans une colonne

Si le renvoi à la ligne du texte est activé pour une colonne, le contenu de la cellule est affiché sur plusieurs lignes. Dans le cas contraire, chaque cellule affiche uniquement le contenu qui tient sur une seule ligne. Par défaut, le renvoi à la ligne est activé pour toutes les colonnes.

Le renvoi à la ligne du texte s'applique aux types de données suivants : Une seule ligne de texte, Plusieurs lignes de texte, Choix, Personne ou groupe, Lien hypertexte ou Image, Calculé.

  • Cliquez avec le bouton droit sur l'en-tête de la colonne pour laquelle vous souhaitez changer le paramètre, puis cliquez sur Désactiver le renvoi à la ligne ou sur Activer le renvoi à la ligne.


Résolution des problèmes liés à la mise en forme des données

Les boutons de mise en forme ne sont pas affichés dans le volet Office.

La mise en forme ne s’applique pas à toutes les lignes de la colonne.

J’ai copié du texte dans une colonne de type Plusieurs lignes de texte, mais la mise en forme n’a pas été appliquée.

Un message indique qu’une cellule dépasse sa taille maximale.

Les boutons de mise en forme ne sont pas affichés dans le volet Office.

Pour activer la mise en forme du texte, la colonne doit prendre en charge plusieurs lignes de texte ainsi que le texte enrichi.

Pour activer la prise en charge du texte enrichi dans une colonne :

  1. Cliquez avec le bouton droit dans la colonne pour laquelle vous souhaitez autoriser le texte enrichi et cliquez sur Modifier/Supprimer une colonne.
  2. Sur la page Modifier les colonnes, dans la section Nom et type, sélectionnez l’option Plusieurs lignes de texte si elle n’est pas déjà définie comme type de colonne.
  3. Dans la section Paramètres de colonne supplémentaires, sélectionnez Texte enrichi (gras, italique, alignement de texte).
  4. Cliquez sur OK.

Une fois ces paramètres modifiés, vous pouvez mettre en forme le texte d’une ou plusieurs cellules, ou seulement une partie de texte dans une cellule :

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Sélectionnez les cellules ou le texte à mettre en forme.
  3. Dans le volet Office, utilisez les outils de texte enrichi pour appliquer le format de votre choix. Vous pouvez modifier les paramètres de police, de couleur du texte et de couleur d’arrière-plan, d’indentation et d’alignement. Vous pouvez également organiser le texte en liste numérotée ou en liste à puces.

Haut de la page

La mise en forme ne s'applique pas à toutes les lignes de la colonne.

Lorsque vous sélectionnez une colonne entière et que vous appliquez la mise en forme, la ligne des totaux et les lignes masquées en raison d'un filtre ne sont pas mises en forme.

Haut de la page

J'ai copié du texte dans une colonne de type Plusieurs lignes de texte, mais la mise en forme n'a pas été appliquée.

Il est possible que la mise en forme du texte source ne soit pas intégralement reconnue par la liste. Vérifiez que le texte source ne contient pas des formats qui ne sont pas pris en charge par la liste.

Pour déterminer les formats pris en charge, sélectionnez une cellule dans une colonne qui prend en charge le texte enrichi et utilisez les boutons sous la barre du volet Office pour les examiner.

Haut de la page

Un message indique qu'une cellule dépasse sa taille maximale.

Une cellule mise en forme contient du texte et des informations sur la mise en forme. Si les données et les informations de mise en forme dépassent la taille maximale de la cellule, ce message apparaît. Essayez de réduire le texte ou le nombre de formats appliqués au texte.

Haut de la page


Filtrage des données en mode

Le filtrage est un processus consistant à extraire et à afficher uniquement les éléments de liste qui remplissent certaines conditions. Appliquer plusieurs filtres à une liste vous permet de trouver rapidement des entrées de liste spécifiques.

Par exemple, l'affichage Cadres de la liste Employés est créé en filtrant les employés dont la colonne Cadre est définie sur Oui. Vous pouvez filtrer davantage cette liste pour afficher les cadres dont la colonne Pays/Région est définie sur France et la colonne Département sur Loire. L'illustration suivante présente la liste des cadres travaillant dans la Loire.

Affichage Cadres de la liste Employés

Notez l'apparence de la flèche pointant vers le bas dans l'en-tête des colonnes Département et Pays/Région.

Lorsque vous passez à d'autres affichages ou que vous fermez l'affichage Cadres, les filtres Pays/Région et Département ne sont pas enregistrés. La prochaine fois que ouvrirez la liste dans l'affichage Cadres, elle affichera tous les cadres.

Vous pouvez appliquer un filtre à une liste de deux manières :

  • Un filtre peut être appliqué à une liste en mode Feuille de données. Le filtre est réinitialisé lorsque vous accédez à une autre page et doit être appliqué à nouveau la prochaine fois que vous souhaitez afficher les mêmes résultats.
  • Lorsque vous spécifiez un filtre comme faisant partie de la définition de l’affichage, les critères de filtre sont enregistrés et sont appliqués chaque fois que vous ouvrez la liste dans l’affichage spécifié.

Les colonnes du type Plusieurs lignes de texte et Lien hypertexte ou Image ne prennent pas en charge le filtrage. Pour les colonnes de type Pièce jointe, vous pouvez filtrer sur les valeurs Oui et Non. Pour les colonnes de type Choix (multiples), les cellules qui contiennent la valeur choisie vont être retenues.


Application d'un filtre

  1. Cliquez sur la flèche pointant vers le bas dans l'en-tête de colonne.

    Remarque Si une colonne ne prend pas en charge le filtrage, les commande de filtrage sont désactivées.

  2. Dans la liste, effectuez l'une des opérations suivantes :
    • Cliquez sur une valeur de cellule pour filtrer les enregistrements qui ont une valeur correspondante. Pour les colonnes à choix multiples, les enregistrements qui contiennent la valeur sélectionnée seront sélectionnés.
    • Cliquez sur (Vides) pour filtrer les enregistrements qui ne contiennent aucune valeur.
    • Cliquez sur (Non vide) pour filtrer les enregistrements qui contiennent une valeur.
    • Cliquez sur Filtre personnalisé pour définir des critères de filtre personnalisés. Dans la boîte de dialogue Filtre personnalisé, spécifiez les opérateurs et les valeurs de comparaison. Par exemple, pour rechercher les noms commençant par « A » ou « B », sélectionnez commence par dans la liste supérieure gauche et tapez A dans la liste supérieure droite. Sélectionnez commence par dans la liste gauche du milieu, et B dans la liste droite du milieu. Sélectionnez le premier opérateur Ou pour lier les deux critères, puis cliquez sur OK.
  3. Cliquez sur (Afficher tout) pour supprimer les filtres de cette colonne.

Remarque Vous pouvez filtrer et trier plusieurs colonnes dans un affichage.


Supprimer un filtre ou un ordre de tri

Pour déterminer si une colonne est filtrée, cliquez sur la flèche pointant vers le bas dans l'en-tête de la colonne. Si un filtre est appliqué à une colonne, une autre entrée que Afficher tout est sélectionnée dans la liste déroulante.

Afficher Pour supprimer un filtre d'une colonne

  1. Cliquez sur la flèche pointant vers le bas dans l'en-tête de la colonne.
  2. Cliquez sur Afficher tout dans la liste.

Afficher Pour supprimer tous les filtres et les ordres de tri

  • Dans la barre d'outils du volet Office, cliquez sur Afficher tous les enregistrements.


Trier des lignes

Le tri permet de organiser les éléments d’une liste dans un ordre souhaité. Cela peut être utile lorsque vous recherchez des entrées spécifiques ou que vous identifiez des groupements spécifiques d’entrées.

Une liste peut être triée de deux manières

  • Une liste peut être triée lorsqu’elle se trouve en mode Feuille de données. Le tri est réinitialisé lorsque vous accédez à une autre page et doit être appliqué à nouveau la prochaine fois que vous souhaitez afficher les mêmes résultats.
  • Lorsque vous spécifiez le tri dans le cadre de la définition de l’affichage, les critères de tri sont enregistrés et sont appliqués chaque fois que vous ouvrez la liste dans l’affichage spécifié.

Pour trier sur une seule colonne

  1. Cliquez sur la flèche pointant vers le bas dans l'en-tête de la colonne.
  2. Cliquez sur Tri croissant ou sur Tri décroissant.
  3. Vous pouvez répéter cette procédure sur les autres colonnes pour organiser la liste avec plus de précision.

Pour trier sur plusieurs colonnes à la fois

Lorsque vous triez sur plusieurs colonnes, l’ordre dans lequel vous triez les colonnes détermine la manière avec laquelle les données sont organisées. En règle générale, vous devez commencer par trier les informations les plus importantes. Par exemple, pour trier les employés par ordre alphabétique dans chaque service, il est essentiel que chacun soit groupé par service. Par conséquent, vous devez commencer par trier la colonne Service, puis trier la colonne Employés.

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Trier.
  3. Dans la boîte de dialogue Tri personnalisé, sous Trier sur, sélectionnez la colonne de tri la plus externe et cliquez sur Croissant ou sur Décroissant.
  4. Répétez l’étape ci-dessus pour deux autres colonnes, en terminant par le critère de tri le moins important.
  5. Cliquez sur OK.

Remarques

  • Vous pouvez appliquer un ou plusieurs filtres sur un affichage trié.
  • Les colonnes de type Plusieurs lignes de texte, Choix à valeurs multiples et Liste de choix à valeurs multiples ne prennent pas en charge le tri. Si une colonne ne prend pas en charge le tri, les commandes de tri sont désactivées pour cette colonne.
  • L'ordre des lignes après le tri dépend du type de données des colonnes utilisées pour le tri.

    Ordres de tri par défaut pour les différents types de données

    Lors d'un tri dans l'ordre croissant, l'affichage en mode Feuille de données utilise l'ordre suivant. Lors d'un tri dans l'ordre décroissant, cet ordre de tri est inversé, sauf pour les cellules vides, qui sont toujours placées en dernier.

    Type de données | Ordre de tri
    Nombres | Triés du plus petit nombre négatif au plus grand nombre positif
    Alphanumériques Triés de gauche à droite, caractère par caractère. Par exemple, si une cellule contint le texte « A100 », elle est placée après une cellule qui contient l'entrée « A1 » et avant une cellule qui contient l'entrée « A11 ».

    Le texte et le texte qui comprend des nombres sont triés dans l'ordre suivant : 0 1 2 3 4 5 6 7 8 9 (espace) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Les apostrophes (') et les traits d'union (-) sont ignorés, avec cette exception : lorsque deux chaînes de texte ne se différencient que par la présence d'un trait d'union, la chaîne qui renferme celui-ci est classée en dernier.
    Valeurs logiques | Non est placé avant Oui.
    Valeurs d'erreur | Toutes les valeurs d'erreur sont traitées de la même façon dans les opérations de tri.


Résolution des problèmes liés au tri et au filtrage

Je ne parviens pas à enregistrer l’ordre de tri ou les critères de filtre dans l’affichage

Les commandes de tri et de filtrage ne sont pas disponibles

Certains des opérateurs sont manquants dans la boîte de dialogue Filtre personnalisé

Je ne parviens pas à afficher la colonne dans laquelle je souhaite trier des lignes ou filtrer des données

L’ordre de tri ne correspond pas aux paramètres de l’ordinateur

J’ai appliqué un filtre ou un tri, mais l’affichage n’apparaît pas filtré ou trié

Je ne parviens pas à enregistrer l’ordre de tri ou les critères de filtre dans l’affichage

Aucun tri ou filtrage appliqué à une liste après son ouverture en mode Feuille de données n'est enregistré. Lorsque vous fermez l'affichage ou que vous basculez vers un autre affichage, ces paramètres sont perdus. Pour enregistrer un ordre de tri ou des critères de filtre, spécifiez-les dans la définition de l'affichage.

Haut de la page

Les commandes de tri et de filtrage ne sont pas disponibles

Si une colonne ne prend pas en charge le tri ou le filtrage, les commandes ne sont pas affichées lorsque vous cliquez sur l'en-tête de la colonne.

Haut de la page

Certains des opérateurs sont manquants dans la boîte de dialogue Filtre personnalisé

La liste des opérateurs affichée dans la boîte de dialogue Filtre personnalisé varie selon le type de données de la colonne sélectionnée. Par exemple, Commence par et Contient ne sont pas disponibles pour des colonnes numériques.

Haut de la page

Je ne parviens pas à afficher la colonne dans laquelle je souhaite trier des lignes ou filtrer des données

Vérifiez que la colonne n'est pas masquée en mode Feuille de données. Cliquez avec le bouton droit dans le coin supérieur gauche de la liste, puis cliquez sur Afficher. Si la commande Afficher est désactivée, vérifiez la définition de l'affichage pour vous assurer que la colonne est incluse dans l'affichage.

Haut de la page

L’ordre de tri ne correspond pas aux paramètres de l’ordinateur

Ce problème peut être lié aux paramètres régionaux de votre serveur SharePoint. Pour plus d’informations, consultez l’aide de Microsoft SharePoint Foundation 2010. Pour afficher l’aide de Microsoft SharePoint Foundation 2010, cliquez sur Aide ( [image]).

Haut de la page

J’ai appliqué un filtre ou un tri, mais l’affichage n’apparaît pas filtré ou trié

Lorsque vous ajoutez ou que vous modifiez des données après avoir appliqué un filtre ou un tri, l'affichage n'actualise pas automatiquement les données. Essayez d'actualiser l'affichage ou appliquez de nouveau le filtre ou l'ordre de tri.

Haut de la page


Déplacement, copie et collage du contenu des cellules

Vous pouvez déplacer ou copier les parties d'une liste dans un autre endroit de la liste ou dans un autre document. Lorsque vous déplacez une sélection, celle-ci est supprimée de la liste et est déplacée vers le Presse-papiers. Lorsque vous copiez une sélection, celle-ci reste dans la liste et une copie est placée dans le Presse-papiers. Le collage du contenu du Presse-papiers entraîne son transfert vers la destination.

Déplacement ou copie des parties d'une liste

Collage du contenu du Presse-papiers dans une liste

Déplacement ou copie des parties d'une liste

Si la plage sélectionnée comprend des cellules qui ne peuvent pas être vides ou qui sont en lecture seule, l'opération de déplacement va échouer. Les colonnes ayant les types de données suivants ne peuvent pas être vides et elles ne peuvent pas être effacées à la suite d'une opération de déplacement : Case à cocher et Calculé.

Le tableau suivant indique le contenu du Presse-papiers après une opération de déplacement ou de copie.

Déplacement ou copie de... | Contenu du Presse-papiers
Données ou une ou plusieurs cellules (la sélection ne comprend pas de lignes entières ou une colonne) | Le contenu des cellules va être effacé ou copié dans le Presse-papiers.
Une ou plusieurs lignes | Les lignes sélectionnées vont être effacées ou copiées et placées dans le Presse-papiers.
Une colonne (peut seulement être copiée, ne peut pas être déplacée) | La sélection va être placée dans le Presse-papiers.
Ligne des totaux | Si elle est déplacée, l'expression pour les cellules de la ligne des totaux est définie à Aucun. La ligne des totaux n'est pas affectée par une opération de copie. Les valeurs de regroupement sont placées dans le Presse-papiers.
Cellule de type Case à cocher | N'est pas effacée lors d'une opération de déplacement. Oui ou Non est placé dans le Presse-papiers.
Colonne de type Calculé | N'est pas effacée lors d'une opération de déplacement. Les valeurs calculées sont placées dans le Presse-papiers.

Haut de la page

Collage du contenu du Presse-papiers dans une liste

Lorsque vous collez le contenu du Presse-papiers, de nouvelles lignes vont être ajoutées au bas de la feuille de données, si nécessaire. Cependant, si l'affichage ne contient pas suffisamment de colonnes, l'opération de collage va échouer. Une opération de collage va également échouer dans les situations suivantes :

  • Certaines des cellules de destination ou toutes ces cellules sont en lecture seule
  • Le collage du contenu dans les cellules sélectionnées va provoquer un échec des règles de validation qui s'y appliquent
  • Tentative de coller des données qui ne correspondent pas au type de données des cellules de destination
  • Tentative de coller des données dans une colonne calculée

Lorsque vous tentez de coller des données d'un certain type dans une colonne d'un type différent, la liste va tenter de convertir les données source pour les faire correspondre au type de données de la colonne de destination. Par exemple, si les données sources sont numériques et que les cellules de destination acceptent du texte, les données source vont être converties en texte puis placées dans les cellules de destination. Si les données source ne peuvent pas être converties pour les faire correspondre au type de données des cellules de destination, l'opération de collage va échouer.

Le tableau suivant indique les résultats de différentes opérations de collage :

Contenu du Presse-papiers | Tentative de coller du contenu dans... | Résultat de l'opération de collage
Une seule cellule | Une plage de cellules | Le contenu est copié dans chaque cellule de la plage sélectionnée.
Une plage de cellules | Une seule cellule | La plage de destination s'étend pour correspondre à la totalité du contenu du Presse-papiers, où la cellule sélectionnée devient la cellule supérieure gauche de la plage de destination.
Une ou plusieurs lignes ou colonnes | La première cellule d'une ligne ou d'une colonne. | La plage de destination s'étend pour correspondre à la totalité du contenu du Presse-papiers, où la cellule sélectionnée devient la cellule supérieure gauche de la plage de destination.
Une ou plusieurs lignes | Une cellule autre que la première cellule d'une ligne | L'opération de collage échoue.
Une ou plusieurs colonnes | Une cellule autre que la première cellule d'une colonne | L'opération de collage réussit, sauf si la plage de destination s'étend au-delà de la dernière ligne de l'affichage, et que l'affichage comprend des colonnes requises. Comme les colonnes requises vont être vides dans les nouvelles lignes, les nouvelles lignes ne sont pas ajoutées et un message vous indique que certaines lignes ont été ignorées.
Une plage de cellules | Une plage de cellules | Si les dimensions correspondent, l'opération de collage réussit ; dans le cas contraire, elle échoue.
Cellules de la ligne des totaux | Ligne des totaux | L'expression contenue dans les cellules source va être placée dans les cellules de destination.
Cellules de la ligne des totaux | Partout ailleurs que sur la ligne des totaux | Les valeurs de regroupement vont être placées dans les cellules de destination.

Haut de la page


Remplissage automatique des cellules avec des données

Vous pouvez remplir une série de données avec une valeur spécifique, avec une plage de valeurs ou avec des valeurs linéairement croissantes.

Copie du contenu d'une cellule dans d'autres cellules de la colonne

Copie d'une série de valeurs dans d'autres cellules de la colonne

Valeurs linéairement croissantes pour une plage de cellules de la colonne

Copie du contenu d'une cellule vers d'autres cellules de la colonne

Par exemple, la colonne Année de la ligne 1 contient la valeur 1980 et vous voulez la copier vers les lignes 2, 3, 4 et 5.

  1. Sélectionnez la cellule dont vous voulez copier le contenu.
  2. Positionnez le pointeur de la souris sur la poignée de recopie dans le coin inférieur droit de la cellule.

    Pointeur de la souris sur la poignée de recopie

  3. Lorsque le curseur de glisser-déposer (+) apparaît, faites-le glisser jusqu'à englober toutes les cellules de destination. Vous pouvez le faire glisser à partir de la cellule sélectionnée, vers le haut ou vers le bas.

    Cellules de destination sélectionnées avec la poignée de recopie

  4. Lorsque vous relâchez le bouton de la souris, le contenu de la première cellule est copié dans les cellules de destination.

    Cellules de destination remplies avec les données de la cellule source

Haut de la page

Copie d'une série de valeur vers d'autres cellules de la colonne

Par exemple, vous voulez remplir la colonne Trimestre avec les valeurs 1, 2, 3, 4, 1, 2, 3, 4, etc.

  1. Tapez 1 dans la première ligne, 2 dans la seconde, 3 dans la troisième et 4 dans la quatrième.
  2. Sélectionnez ces quatre cellules.
  3. Positionnez le pointeur de la souris sur la poignée de recopie dans le coin inférieur droit de la sélection.
  4. Lorsque le curseur de glisser-déposer (+) apparaît, maintenez la touche CTRL enfoncée et faites-le glisser jusqu'à englober toutes les cellules de destination. Vous pouvez le faire glisser à partir de la cellule sélectionnée, vers le haut ou vers le bas.

Haut de la page

Valeurs linéairement croissantes pour une plage de cellules de la colonne

Les cellules de certaines colonnes de texte et de nombres peuvent être remplies avec une série de valeurs linéairement croissantes qui s'incrémentent depuis la ou les cellules sources. Les types de colonnes qui n'acceptent pas cette opération sont répertoriées dans les remarques ci-après.

Par exemple, vous voulez remplir les cellules de la colonne Année avec les valeurs 1910, 1920, 1930, etc.

  1. Tapez 1910 dans la première ligne et 1920 dans la deuxième.
  2. Sélectionnez la cellule Année de la première et de la deuxième ligne.
  3. Positionnez le pointeur de la souris sur la poignée de recopie dans le coin inférieur droit de la sélection.
  4. Lorsque le curseur de glisser-déposer (+) apparaît, faites-le glisser jusqu'à englober toutes les cellules de destination. Vous pouvez le faire glisser à partir de la cellule sélectionnée, vers le haut ou vers le bas.

Remarque Si la série initiale contient une seule valeur, vous devez maintenir la touche CTRL enfoncée tout en faisant glisser la poignée de recopie pour générer une série.

Exemples de valeurs linéairement croissantes

Le tableau suivant présente quelques séries qui peuvent être générées en faisant glisser la poignée de recopie.

Valeurs initiales | Série résultante
1, 2, 3 | 4, 5, 6...
Lun | Mar, Mer, Jeu...
Lundi | Mardi, Mercredi, Jeudi...
jan | fév, mar, avr...
jan, avr | juil, oct, jan...
01/01/2005 | 01/02/2005, 01/03/2005...
15/01/2005, 15/03/2005 | 15/05/2005, 15/07/2005...
1999, 2000 | 2001, 2002, 2003...
Trim3 | Trim4, Trim1, Trim2,...
T3 | T4, T1, T2
texte1, texteA | texte2, texteA, texte3, texteA...
1ère période | 2ème période, 3ème période...
Produit 1 | Produit 2, Produit 3...

Remarques

  • Vous pouvez remplir automatiquement plusieurs colonnes en une seule opération. Les cellules sélectionnées dans chaque colonne vont être utilisées pour remplir les cellules de destination.
  • Les colonnes ayant les types de données suivants ne peuvent pas être remplies avec des valeurs linéairement croissantes :
    • Plusieurs lignes de texte
    • Choix
    • Recherche
    • Oui/Non (case à cocher)
    • Personne ou Groupe
    • Lien hypertexte ou Image
    • Calculées
  • Si vous tentez de remplir une cellule qui est en lecture seule ou de remplir une cellule avec une valeur non valide, l'opération de remplissage va échouer pour cette cellule.

Haut de la page


Résolution des problèmes liés au remplissage automatique des cellules avec des données

J'obtiens le message « Des cellules de la zone de destination sont en lecture seule. ».

Vous faites glisser la poignée de recopie pour inclure des cellules qui sont en lecture seule.

J'obtiens le message « Des lignes ont été ignorées parce que des nouvelles lignes contiennent des valeurs non valides dans des zones requises. ».

Vous faites glisser la poignée de recopie pour inclure des lignes qui ne contiennent pas de valeur pour une ou plusieurs colonnes où des informations sont requises.

J'obtiens le message « Impossible d'effectuer cette opération sur une colonne calculée. ».

Vous ne pouvez pas copier des valeurs dans une colonne calculée en faisant glisser la poignée de recopie. Une colonne calculée obtient ses valeurs en évaluant une formule. Pour afficher ou modifier la formule d'une colonne calculée, cliquez sur une cellule de la colonne, puis cliquez de nouveau.

J'obtiens le message « Tentative de saisie des cellules ou des lignes avec des valeurs non valides. ».

Vous tentez de remplir des cellules avec des valeurs qui ne satisfont pas aux règles de validation de la cellule ou de la ligne.

J'obtiens le message « Des données ont été tronquées. ».

Vous tentez de remplir des cellules avec des valeurs dont la longueur excède la longueur maximale autorisée dans les cellules de destination.


Résolution des problèmes liés au déplacement, à la copie et au collage du contenu des cellules

Impossible de coller des données dans une colonne ou affichage du message « Collage de n cellules impossible »

J’obtiens le message « Des données ont été tronquées. »

Affichage du message « Des cellules de la zone sont requises et leur contenu ne peut pas être effacé »

Affichage du message « Des cellules/lignes de la zone sont en lecture seule »

Affichage du message « Ces informations ne peuvent pas être collées car la zone copiée n’est pas totalement visible dans la liste »

Affichage du message « Impossible de coller les informations car la zone coupée ou copiée et la zone de collage ne sont pas de la même taille »

Affichage du message « Certaines lignes ont été ignorées »

Impossible de coller des données dans une colonne ou affichage du message « Collage de n cellules impossible »

Effectuez une des actions suivantes :

  • Vérifiez que la colonne n'est pas une colonne calculée.
  • Vérifiez que le type des données que vous essayez de coller correspond au type des cellules de destination.
  • Vérifiez que les règles de validation définies pour une cellule ou pour une ligne sont respectées par l'opération de collage.

Haut de la page

J’obtiens le message « Des données ont été tronquées. »

Vous essayez de coller davantage de caractères que ce qui est autorisé dans une ou plusieurs cellules de destination. Par exemple, si vous tentez de coller plus de 255 caractères dans une cellule de type Une seule ligne de texte, les caractères en trop vont être tronqués.

Haut de la page

Affichage du message « Des cellules de la zone sont requises et leur contenu ne peut pas être effacé »

Vous essayez de déplacer une ou plusieurs cellules d'une colonne où les informations sont requises. Une colonne requise ne peut pas être laissée vide ; au lieu d'essayer de déplacer les données, copiez les données vers la destination, puis supprimez les lignes non souhaitées.

Haut de la page

Affichage du message « Des cellules/lignes de la zone sont en lecture seule »

Vous tentez de déplacer les données d'une ou de plusieurs cellules ou lignes qui sont en lecture seule, ou bien de coller des données dans des cellules ou des lignes qui sont en lecture seule. Vous ne pouvez pas modifier le contenu de cellules ou de lignes qui sont en lecture seule.

Haut de la page

Affichage du message « Ces informations ne peuvent pas être collées car la zone copiée n’est pas totalement visible dans la liste »

Ce peut être dû à une des raisons suivantes :

  • Vous tentez de coller une ou plusieurs lignes dans une cellule autre que la première cellule d'une ligne.
  • Vous tentez de coller une plage de cellules dans une cellule, mais l'affichage ne contient pas le nombre de lignes et de colonnes à droite et sous la cellule de destination.

Haut de la page

Affichage du message « Impossible de coller les informations car la zone coupée ou copiée et la zone de collage ne sont pas de la même taille »

Vous tentez de coller une plage de cellules dans une plage de destination, mais leurs dimensions ne correspondent pas. Assurez-vous de sélectionner le même nombre de lignes et de colonnes dans la plage de destination et dans la plage source.

Haut de la page

Affichage du message « Certaines lignes ont été ignorées »

Ce peut être dû à une des raisons suivantes :

  • Vous tentez de copier une ou plusieurs colonnes dans une cellule autre que la première cellule de la colonne de destination.
  • Vous tentez de coller des données dans la ligne marquée d'un astérisque (*), mais l'opération n'ajoute pas de données à toutes les colonnes requises de l'affichage.

Toute opération nécessitant l'ajout de nouvelles lignes mais qui laisse vides des colonnes requises va échouer. L'opération de collage réussit seulement sur des lignes existantes, les autres lignes étant ignorées.

Haut de la page


Approbation ou rejet d'éléments en attente

Si une liste est configurée pour exiger l’approbation de contenu, les utilisateurs dotés des droits de gestion de liste appropriés peuvent consulter les articles que d’autres utilisateurs ont ajoutés à la liste, puis les approuver ou les refuser avant que les informations soient affichées publiquement. Seuls les éléments approuvés sont affichés à destination des utilisateurs du site.

  1. En mode Feuille de données, vérifiez la colonne État de l’approbation pour vérifier si des éléments sont en attente d’approbation.
  2. Passez en mode Approuver/Rejeter les éléments :
    1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Affichage actuel, cliquez sur Approuver/rejeter les éléments dans le menu déroulant Affichage actuel.
    2. Vérifiez que vous êtes toujours en mode Feuille de données. Cliquez sur Mode Feuille de données, si nécessaire.
  3. Si vous le souhaitez, vous pouvez filtrer la liste de sorte d’afficher uniquement les éléments en attente. Cliquez sur la flèche pointant vers le bas dans l’en-tête de la colonne Statut d’approbation, puis sur En attente.
  4. Pour approuver ou rejeter une seule ligne, cliquez sur l’état actuel de l’élément dans la colonne État de l’approbation, cliquez sur la flèche vers le bas, puis cliquez sur Approuvé ou Rejeté dans le menu déroulant.

    Pour mettre à jour des lignes adjacentes avec le même état ou le même commentaire, entrez la valeur pour la première ligne et faites glisser la poignée de recopie pour inclure les lignes désirées. Vous pouvez également copier et coller des valeurs dans les colonnes.

  5. Tapez vos commentaires dans la colonne Commentaires de l’approbateur.

Remarque Vous pouvez également redéfinir comme étant en attente un élément approuvé ou rejeté. Cela annule la publication de l’élément de sorte qu’il n’apparaisse plus aux utilisateurs visitant le site.


Envoi de modifications de données à un gestionnaire de liste pour approbation

Si vous ajoutez ou modifiez des données dans une liste à approbation de contenu, vos modifications ne sont pas visibles aux autres utilisateurs tant qu’elles n’ont pas été approuvées par un utilisateur disposant des droits d’approbation voulus.

Remarque Si vous disposez de droits d’approbation de contenu sur la liste, toute modification que vous apportez est automatiquement approuvée.

Créer un nouvel élément de liste et l’envoyer pour révision

  1. Dans le Ruban, cliquez sur l’onglet Élément puis, dans le groupe Nouveau, cliquez sur Nouvel élément.
  2. Dans la page Nouvel élément, entrez les informations sur le nouvel élément, puis cliquez sur OK.

    En mode Feuille de données, le nouvel élément apparaît dans la liste avec le statut d’approbation En attente. Un utilisateur disposant de droits d’approbation sur le contenu doit passer en revue et approuver l’élément avant que celui-ci soit visible aux visiteurs du site.

Modifier un élément qui a déjà été approuvé

  1. Passez en mode Mes envois.
    1. Dans le Ruban, cliquez sur l’onglet Liste, puis dans le groupe Affichages personnalisés, cliquez sur Mes envois dans le menu déroulant Affichage actuel.
    2. Vérifiez que vous êtes toujours en mode Feuille de données. Cliquez sur Mode Feuille de données, si nécessaire.

    Cet affichage affiche tous les éléments que vous avez ajoutés à la liste, y compris les éléments rejetés. L’affichage affiche les colonnes Statut d’approbation et Commentaires en plus de toutes les colonnes de la liste. Cependant, les colonnes Statut d’approbation, Commentaires, Modifié et Modifié par sont en lecture seule. Lorsqu’un élément a été approuvé, il peut être uniquement modifié par la personne qui en est à l’origine.

  2. Dans la ligne de l’élément que vous souhaitez modifier, apportez les modifications souhaitées.

    En mode Feuille de données, le statut d’approbation de l’élément que vous avez modifié passe automatiquement à En attente . Lorsqu’une ligne est modifiée, elle doit passer par le processus d’approbation comme s’il s’agissait d’une nouvelle entrée.


Utilisation des bibliothèques de documents

Le mode Feuille de données offre le même niveau de prise en charge pour les bibliothèques de documents que pour les listes. Vous pouvez ouvrir une bibliothèque de documents en mode Feuille de données pour afficher le contenu d'une bibliothèque, ajouter et supprimer des dossiers et des documents, ainsi que pour modifier des documents et changer leurs propriétés.

Utilisation de documents en mode Feuille de données

Gestion de documents et de dossiers en mode Feuille de données

Utilisation de documents en mode Feuille de données

Bibliothèque en mode Feuille de données

Vous pouvez utiliser une bibliothèque de documents en mode Feuille de données de deux façons.

  • Dans le ruban, sous l’onglet Bibliothèque, cliquez sur Mode Feuille de données.
  • Créez un ou plusieurs affichages personnalisés pour la bibliothèque à l’aide du mode Feuille de données. Procédez comme suit :
    1. Dans le ruban, sous l’onglet Bibliothèque, cliquez sur Créer un affichage.
    2. Dans la page Créer un affichage, dans la section Choisir un format d’affichage, cliquez sur Mode Feuille de données.
    3. Dans la zone Nom de l'affichage, tapez un nom. Vous pouvez inclure l'expression « Feuille de données » dans le nom de l'affichage pour mieux l'identifier ultérieurement.
    4. Définissez les autres propriétés de l’affichage.
    5. Cliquez sur OK.
    6. Ce nouvel affichage apparaît dans la liste déroulante Affichage actuel.

      Remarque Si le paramétrage pour les dossiers de l'affichage est défini sur Afficher les éléments dans les dossiers, seuls les documents et les dossiers du plus haut niveau sont affichés lorsque vous ouvrez la bibliothèque. Si le paramétrage pour les dossiers est défini sur Afficher tous les éléments sans dossiers, alors tous les documents, notamment ceux qui se trouvent sous des dossiers différents, sont affichés sous forme de lignes lorsque vous ouvrez la bibliothèque.

Pour modifier les paramètres d’un mode Feuille de données existant :

  1. Dans le ruban, sous l’onglet Bibliothèque, cliquez sur Modifier cet affichage.
  2. Dans la page Modifier l’affichage, sélectionnez ou modifiez les propriétés de l’affichage.
  3. Cliquez sur OK.

Haut de la page

Gestion de documents et de dossiers en mode Feuille de données

  • Vous pouvez ajouter et télécharger des documents dans la bibliothèque de la même façon que lorsque vous ajoutez ou que vous téléchargez des documents dans l'affichage Tous les documents ou dans n'importe quel autre mode standard.
  • Si le paramétrage pour les dossiers de l'affichage est défini sur Afficher les documents à l'intérieur de dossiers, vous pouvez ajouter de nouveaux dossiers et vous déplacer dans les différents dossiers de la bibliothèque.
  • Vous pouvez ouvrir, modifier et archiver ou extraire un document.
  • Vous pouvez supprimer des documents et des dossiers en mode Feuille de données. Lorsque vous supprimez un dossier, le contenu de ce dossier, notamment ses sous-dossiers, est supprimé de la bibliothèque.
  • Vous pouvez ajouter des colonnes ou supprimer et modifier une colonne que vous ou un autre utilisateur avez ajouté à l'affichage. Vous pouvez également entrer et modifier les données stockées dans de telles colonnes, sur des lignes contenant des documents. Les lignes correspondant aux dossiers ne peuvent pas être modifiées. Notez que des colonnes comme Type et Modifié par sont en lecture seule. Vous ne pouvez pas les modifier ou les supprimer, ni entrer ou modifier le contenu de ces colonnes.
  • Vous pouvez afficher ou masquer la ligne des totaux.
  • Vous pouvez trier et filtrer la bibliothèque sur la base de différentes colonnes, dont la colonne Type.
  • Le mode Feuille de données n'affiche pas la ligne marquée d'un astérisque (*) pour une bibliothèque de documents.
  • Vous ne pouvez pas entrer une valeur dans la colonne Nom en faisant glisser la poignée de recopie, ni en sélectionnant une valeur dans la liste déroulante de la cellule.

Haut de la page


Ajout, affichage ou suppression de documents attachés à une ligne

Vous pouvez attacher un ou plusieurs documents à une ligne dans certains types de listes. Les pièces jointes s’affichent sous forme de trombones dans la colonne Pièces jointes d’une ligne. Si aucun des éléments d’une liste ne possède de pièces jointes, la colonne Pièces jointes n’apparaît pas.

Ajouter une pièce jointe à un nouvel élément

  1. Dans le Ruban, cliquez sur l’onglet Élément puis, dans le groupe Nouveau, cliquez sur Nouvel élément.
  2. Dans la page Nouvel élément, tapez un nom pour l’élément et spécifiez les autres propriétés de l’élément.
  3. Cliquez sur Joindre un fichier .
  4. Choisissez ensuite le ou les fichiers que vous voulez attacher au nouvel élément, puis cliquez sur Ouvrir.
  5. Cliquez sur OK.
  6. Cliquez sur OK.

Ajouter une pièce jointe à un élément existant

  1. En mode Feuille de données, cliquez avec le bouton droit sur la colonne Pièces jointes d’une ligne, puis cliquez sur Modifier une pièce jointe.

    Remarque Vous ne pouvez pas ajouter de pièces jointes à une ligne qui n'a pas encore été validée.

  2. Dans la boîte de dialogue Pièces jointes aux éléments de liste :
    • Pour ajouter une pièce jointe, cliquez sur Ajouter. Choisissez le ou les fichiers que vous souhaitez attacher à la ligne, puis cliquez sur Ouvrir.

      Pour afficher l’aperçu d’un fichier avant de l’insérer en tant que pièce jointe, double-cliquez dessus dans la boîte de dialogue Pièces jointes aux éléments de liste.

    • Pour supprimer une pièce jointe, sélectionnez-la et cliquez sur Supprimer.
  3. Après avoir spécifié toutes les pièces jointes désirées dans la boîte de dialogue Pièces jointes aux éléments de liste, cliquez sur OK pour les attacher à la ligne. Une icône en forme de trombone apparaîtra dans la colonne Pièces jointes pour indiquer que la ligne contient un ou plusieurs fichiers joints.


Archivage ou extraction d'un document

Pour archiver un document qui a été extrait pour vous mais qui n'est pas ouvert

  1. Cliquez avec le bouton droit sur l'en-tête ou sur l'une des cellules de la ligne correspondant au document que vous voulez archiver, pointez sur Document, puis cliquez sur Archiver le document.
  2. Dans la page Archiver, indiquez si vous souhaitez conserver le document extrait pour vous après l’avoir archivé sur le serveur ou libérer afin que d’autres puissent travailler dessus.
  3. Éventuellement, dans la zone Commentaires, vous pouvez décrire les modifications que vous avez apportées au document.
  4. Cliquez sur OK.

Pour extraire un document

  • Cliquez avec le bouton droit sur l'en-tête de la ligne ou sur une des cellules de la ligne correspondant au document que vous voulez extraire, pointez sur Document, puis cliquez sur Extraire le Document.

Remarque Vous ne pouvez pas extraire un document qui est actuellement extrait par un autre utilisateur.


Suppression d'un dossier ou d'un document

La suppression d'un dossier entraîne celle de son contenu, notamment ses sous-dossiers.

  1. Cliquez avec le bouton droit sur l'en-tête ou sur l'une des cellules de la ligne correspondant au dossier ou au document que vous voulez supprimer, puis cliquez sur Supprimer le dossier ou sur Supprimer le document.
  2. Pour confirmer, cliquez sur Oui.

Remarque Vous ne pouvez supprimer qu'un seul dossier à la fois.


Modification d'un document

Lorsque vous ouvrez un document pour le modifier, Microsoft SharePoint Foundation 2010 peut effectuer plusieurs tâches requises automatiquement, telles que l’extraction du fichier, son téléchargement sur votre ordinateur et son ouverture dans le programme approprié.

  • Cliquez avec le bouton droit sur l'en-tête ou sur l'une des cellules de la ligne correspondant au document que vous voulez extraire, pointez sur Document, puis cliquez sur Modifier le document.

    Si l’extraction du document est requise avant sa modification, Microsoft SharePoint Foundation 2010 vous avertit que vous vous apprêtez à extraire et à modifier le document. Cliquez sur OK pour continuer.

Le document est ouvert à l’aide de l’application Office appropriée. Vous pouvez modifier le document et le réenregistrer dans la bibliothèque ou à un autre emplacement. Lorsque vous fermez un document extrait, vous avez la possibilité de le réarchiver ou de le mettre à jour sur le serveur pendant son extraction.

Remarque Vous ne pouvez pas modifier un document qui a été extrait par un autre utilisateur. Vous ne pouvez pas non plus modifier les colonnes de la ligne correspondant au document avant qu'il soit de nouveau archivé.


Établir des autorisations au niveau de l'élément

Vous pouvez empêcher certains utilisateurs d'afficher ou de modifier des éléments d'une liste en établissant des autorisations au niveau de l'élément. Vous pouvez, par exemple, définir des autorisations pour la liste de telle sorte que les utilisateurs puissent uniquement afficher leurs propres éléments ou qu'ils puissent afficher tous les éléments mais uniquement modifier les leurs. Lorsque vous créez une nouvelle liste, les autorisations initialement définies permettent à tous les utilisateurs d'afficher et de modifier tous les éléments, qu'ils les aient créés ou non.

Limiter l'accès en lecture des utilisateurs sur les éléments d'autres utilisateurs

Définissez des autorisations d'accès en lecture en procédant comme suit :

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Paramètres, cliquez sur Paramètres de la liste.
  2. Dans la page Paramètres de la liste, cliquez sur Paramètres avancés.
  3. Dans la page Paramètres avancés, sous Autorisations au niveau de l’élément, cliquez sur l’une des options Accès en lecture suivantes :
    • Cliquez sur Lire tous les éléments pour permettre à tous les utilisateurs de lire tous les éléments de la liste.
    • Cliquez sur Lire les éléments créés par l’utilisateur pour permettre aux utilisateurs de lire uniquement les éléments qu’ils ont créés.
  4. Cliquez sur OK.

Limiter l'accès en écriture des utilisateurs sur les éléments

Définissez des autorisations d'accès en modification en procédant comme suit :

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Paramètres, cliquez sur Paramètres de la liste.
  2. Dans la page Paramètres de la liste, cliquez sur Paramètres avancés.
  3. Dans la page Paramètres avancés, sous Autorisations au niveau de l’élément, cliquez sur l’une des options Accès en modification suivantes :
    • Cliquez sur Créer et modifier tous les éléments pour permettre à tous les utilisateurs de modifier tous les éléments de la liste.
    • Cliquez sur Créer des éléments et modifier les éléments créés par l’utilisateur pour permettre aux utilisateurs de modifier uniquement les éléments qu’ils ont créés.
    • Cliquez sur Aucun pour empêcher tous les utilisateurs de modifier les éléments.
  4. Cliquez sur OK.


Mise à disposition d'un document pour des discussions

  • Cliquez avec le bouton droit sur l'en-tête ou sur l'une des cellules de la ligne correspondant au document que vous voulez rendre disponible pour des discussions, puis cliquez sur Discuter.

Le document s'ouvre dans Internet Explorer. La fenêtre du navigateur affiche la barre d'outils Discussions.


Ouverture d'un dossier ou d'un document

  • Pour atteindre un dossier ou ouvrir un document, cliquez sur l'icône dans la colonne Type du dossier ou du fichier.

    Si le document a été créé dans Microsoft Office, il est ouvert à l'aide de l'application Office appropriée. Tous les autres documents sont ouverts dans Internet Explorer.


Effectuer un suivi et afficher des informations de version relatives à des éléments de liste

Vous pouvez stocker des informations sur les modifications apportées à des éléments individuels d'une liste. Vous pouvez ensuite vérifier quel type de modification a été apportée à chaque élément, la date de la modification et l'auteur de celle-ci.

Activer le suivi de version pour des éléments d'une liste

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Paramètres, cliquez sur Paramètres de la liste.
  2. Dans la page Paramètres de la liste, cliquez sur Paramètres de contrôle de version.
  3. Dans la page Paramètres de contrôle de version, dans la section Historique des versions, cliquez sur Oui pour créer une version chaque fois que vous modifiez un élément.
  4. Pour limiter le nombre de versions conservées, activez la case à cocher Conserver le nombre de versions suivant et spécifiez un nombre maximal de versions à conserver.
  5. Cliquez sur OK.

Afficher les versions d'un élément d'une liste

  1. Cliquez avec le bouton droit sur l'en-tête de ligne ou une cellule quelconque de la ligne correspondant à l'élément dont vous souhaitez afficher les informations de version.
  2. Pointez sur Élément puis cliquez sur Versions.

    Les informations de version sont affichées.


Afficher les versions d'un document

Si le paramètre de versions des documents d'une bibliothèque de documents est activé pour stocker les versions des documents, vous pouvez afficher des informations sur les différentes versions de chaque document de la bibliothèque.

Afficher les versions du document

  • Cliquez avec le bouton droit sur l'en-tête de la ligne ou sur une des cellules de la ligne correspondant au document dont vous voulez afficher les versions, pointez sur Document, puis cliquez sur Versions du document.

Modifier les paramètres de version du document

  1. Dans le Ruban, cliquez sur l’onglet Bibliothèque puis, dans le groupe Paramètres, cliquez sur Paramètres de la bibliothèque.
  2. Dans la page Paramètres de la liste, sous Paramètres généraux, cliquez sur Paramètres de contrôle de version.
  3. Dans la page Paramètres de contrôle de version de la bibliothèque de documents, sous Historique des versions du document, sélectionnez le schéma de contrôle de version de votre choix, puis cliquez sur OK.


Résolution des modifications en conflit

Un conflit survient lorsque deux utilisateurs effectuent une modification sur la même partie des données ou de la structure d'une liste. L'utilisateur qui soumet une modification en premier va réussir à valider ses modifications, mais le second va être averti de l'existence d'un conflit.

Par exemple, un utilisateur A modifie la colonne Ville de la troisième ligne de Dallas en Seattle et, au même moment, vous changez la cellule en y indiquant Houston au lieu de Dallas. Les modifications de l'utilisateur A sont soumises en premier au serveur, suivies par vos modifications. Le serveur vous informe d'un conflit et vous laisse résoudre le conflit.

Remarque Un conflit va survenir même si les utilisateurs modifient des cellules différentes dans la même ligne.

L'illustration suivante montre la liste avec l'icône Conflit affichée dans l'en-tête de la troisième ligne.

Une ligne avec un conflit

Vous ne pouvez pas apporter de modifications à une ligne où il y a un conflit avant de résoudre ce conflit.

Le fait de cliquer sur l'icône Conflit affiche la boîte de dialogue Résolution des conflits.

Remarque Si vous tentez de supprimer une ligne qui a été mise à jour par un autre utilisateur, un conflit va survenir, mais l'icône Conflit ne va pas apparaître parce que la ligne a déjà été mise à jour. Dans ce cas, cliquez sur Résoudre dans la barre d'état pour ouvrir la boîte de dialogue Résolution des conflits.

Boîte de dialogue Résolution des conflits

La grille des détails affiche toutes les colonnes de l'affichage actuel. Pour la ligne concernée, elle montre la modification que vous avez effectuée ainsi que celle effectuée par l'autre utilisateur. Les colonnes modifiées apparaissent en surbrillance. Notez que vous ne pouvez pas modifier les valeurs affichées dans la grille des détails. Dans le haut de la boîte de dialogue, vous pouvez voir le nom de l'utilisateur qui a effectué la modification, ainsi que la date et l'heure à laquelle elle a été faite.

Lorsque deux utilisateurs ou plus effectuent une série de modifications, il est possible qu'il y ait plusieurs conflits. Un nouveau conflit survient lorsque vous tentez de résoudre un conflit existant. S'il y a plusieurs conflits, la boîte de dialogue Résolution des conflits vous permet de voir les détails de chaque conflit en cliquant sur les boutons Précédent et Suivant en haut à droite de la boîte de dialogue. Les conflits sont classés sur la base des numéros de ligne. En d'autres termes, le conflit de la troisième ligne apparaît avant celui de la quatrième ligne. Lorsque vous faites défiler les conflits, la ligne affectée est activée dans la feuille de données. Vous pouvez également afficher les détails d'un conflit spécifique en cliquant sur l'icône Conflit de la ligne concernée. La boîte de dialogue va automatiquement se positionner sur le conflit sélectionné, mais vous pouvez afficher des détails sur d'autres conflits en cliquant sur les boutons Précédent ou Suivant.

Remarque S'il y a une ou plusieurs erreurs dans l'affichage en plus des conflits, la boîte de dialogue Résolution des conflits va contenir des informations détaillées sur les erreurs et vous permettre de les résoudre.

À partir des informations de la grille des détails, vous pouvez ignorer les modifications que vous avez apportées ou bien essayer de les appliquer à nouveau. Si les modifications ont été apportées à différentes colonnes dans une ligne, le fait de réappliquer vos modifications va fusionner vos modifications avec celles de l'utilisateur A. Si les modifications ont été apportées à la même cellule, vos modifications vont remplacer celles de l'utilisateur A. Lorsqu'il existe plusieurs conflits, vous pouvez entreprendre une action individuelle pour chaque conflit ou bien une seule action pour tous les conflits. Pour ignorer ou essayer d'appliquer à nouveau toutes vos modifications, cliquez sur Ignorer toutes mes modifications ou sur Réessayer d'appliquer toutes mes modifications.

Vous pouvez fermer la boîte de dialogue sans entreprendre d'action, mais vous ne pouvez pas quitter ou actualiser la liste ni apporter des modifications à une colonne calculée tant que vous n'avez pas résolu le conflit.

Afficher Scénarios spécifiques de la boîte de dialogue Résolution des conflits

Voici les cas particuliers où la boîte de dialogue Résolution des conflits peut présenter les informations différemment.
  • Vous mettez à jour une ligne qui a été supprimée par un autre utilisateur. Dans ce cas, la boîte de dialogue n'affiche pas le nom de l'utilisateur ni la date et l'heure de la modification. Dans la grille des détails, la ligne qui correspond à l'autre utilisateur affiche simplement la mention Ligne supprimée. La seule option disponible consiste à annuler vos modifications. Vous ne pouvez pas réessayer d'appliquer vos modifications.
  • L'utilisateur A met à jour une colonne qui ne fait pas partie de votre affichage en cours. Dans ce cas, la grille des détails ne va pas comprendre la colonne qui a été modifiée par l'utilisateur A. Le fait de réessayer d'appliquer vos modifications ne vas pas remplacer les modifications que l'utilisateur A a effectuées sur les colonnes qui ne font pas partie de votre affichage.
  • L'utilisateur A modifie une colonne, puis la modifie à nouveau de façon à ce que la cellule reprenne sa valeur d'origine. Dans ce cas, la boîte de dialogue va seulement montrer la dernière modification.
  • Si le filtre actuel masque une ligne avec un conflit, la boîte de dialogue va temporairement supprimer le filtre pour afficher la ligne de la feuille de données. Dès que la boîte de dialogue est fermée, le filtre est automatiquement réappliqué.
  • Si l'utilisateur A ajoute ou supprime une pièce jointe avec le navigateur et que vous mettez à jour une ligne, vous recevez une information indiquant qu'il y a conflit. Cependant, la boîte de dialogue va mettre en surbrillance la colonne de la ligne Modifications de l'autre utilisateur seulement si l'utilisateur ajoute la première pièce jointe ou supprime la dernière pièce jointe. La colonne de la grille des détails va afficher Oui s'il y a une ou plusieurs pièces jointes, et Non s'il n'y en a pas.
  • Si la cellule affectée est un lien hypertexte, la grille des détails va afficher l'adresse URL si le nom complet n'est pas disponible. Pour une image, la grille va afficher le chemin d'accès. Si la colonne affectée comprend du formatage en texte enrichi, la grille va afficher le texte sans le formatage. Cependant, la colonne va apparaître en surbrillance si le formatage a changé.

Haut de la page

Résolution de conflits structurels

Il est également possible qu'un conflit structurel survienne lorsque deux utilisateurs ou plus modifient différentes parties d'une liste. Un conflit structurel survient lorsque la résolution des modifications est impossible. Par exemple, l'utilisateur A supprime une colonne et l'utilisateur B tente de la mettre à jour, ou bien l'utilisateur A change le type de données d'une colonne et l'utilisateur B entre des données qui ne sont pas compatibles avec le nouveau type de données. Dans ces situations, l'utilisateur B va être invité à actualiser la liste. L'actualisation de la liste va extraire la dernière version de la liste, mais les modifications de l'utilisateur B vont être annulées.

Haut de la page

La résolution d'un conflit peut provoquer un nouveau conflit ou une nouvelle erreur

La résolution d'un conflit peut provoquer un ou plusieurs nouveaux conflits ou erreurs. Par exemple, un troisième utilisateur, l'utilisateur C, effectue une série de modifications génératrices de conflits pendant que vous êtes occupé à résoudre des conflits dus aux modifications de l'utilisateur A. Si le fait de réessayer d'appliquer vos modifications provoque un nouveau conflit, celui-ci va être ajouté à la liste des conflits existants et la boîte de dialogue va être mise à jour.

Haut de la page


À propos de la résolution des erreurs

Vous pouvez rencontrer une ou plusieurs erreurs lorsque vous utilisez le mode Feuille de données. Certaines erreurs peuvent être résolues en répétant simplement l'action ou en actualisant l'affichage, tandis que d'autres nécessitent plus de travail. Selon l'erreur, l'affichage vous fournit les informations appropriées pour vous permettre de la corriger.

Causes des erreurs

Types d’erreurs

Résolution des erreurs

Causes des erreurs

Des erreurs peuvent se produire dans les situations suivantes :
  • Ouverture d'une feuille de données. Par exemple, l'affichage peut ne pas se charger ou ne pas afficher de données.
  • Affichage ou modification de données dans l'affichage. Par exemple, la validation des modifications que vous avez apportées aux données peut échouer si le serveur ne peut pas être trouvé.
  • Affichage ou modification de la structure de la liste. Par exemple, la suppression d'une colonne peut provoquer une erreur due à l'absence des autorisations nécessaires.
  • Affichage ou modification de la définition de l'affichage. Par exemple, la réorganisation de colonnes peut échouer à cause d'un dépassement de délai du serveur.

Haut de la page

Types d'erreurs

Il y a deux types d'erreurs : celles que vous pouvez résoudre en effectuant à nouveau vos modifications et celles que vous pouvez résoudre en ignorant vos modifications.

Erreurs que vous pouvez résoudre en effectuant à nouveau vos modifications :

  • Pas de réponse du serveur. Ce peut être à cause d'un dépassement de délai du serveur.
  • Le serveur est occupé ou ne peut être trouvé.
  • La réponse du serveur n'est pas lisible.
  • Toute autre erreur inattendue.

Les erreurs que vous pouvez résoudre en ignorant vos modifications :

  • Vous ne disposez pas des autorisations nécessaires pour effectuer la modification.
  • Vous avez été empêché d'ajouter du contenu au site.
  • Vous avez dépassé vos limites de stockage sur le site.
Pour éviter ces erreurs, contactez votre administrateur système.

Haut de la page

Résolution des erreurs

Lorsqu'une erreur se produit, l'affichage affiche l'icône Erreur ( Icône Erreur ) dans la ligne correspondante ainsi que dans la barre d'état. Vous voyez également le texte Cliquez pour résoudre les erreurs dans la barre d'état. S'il y a des conflits et des erreurs, vous voyez le texte Cliquez pour résoudre les conflits de données et les erreurs.

L'illustration suivante montre la boîte de dialogue Résoudre les erreurs.

Boîte de dialogue Résoudre les erreurs

Les grille des détails affiche les colonnes de votre affichage actuel. Pour les lignes concernées, elle affiche les modifications que vous avez effectuées. Notez que vous ne pouvez pas modifier les valeurs affichées dans la grille des détails. Dans le haut de la boîte de dialogue, vous pouvez voir la description de l'erreur.

S'il y a plusieurs erreurs, vous pouvez voir des informations détaillées pour chaque erreur en cliquant sur les boutons Précédent et Suivant dans la partie supérieure droite de la boîte de dialogue.

Sur la base des informations sur l'erreur dans la grille des détails, vous pouvez ignorer les modifications que vous avez effectuées ou réappliquer vos modifications. Lorsqu' il existe plusieurs erreurs, vous pouvez appliquer des actions individuellement pour chaque cellule ou bien appliquer une même action pour toutes les erreurs. Pour ignorer ou réappliquer toutes vos erreurs, cliquez sur Ignorer toutes mes modifications ou Tenter à nouveau d'appliquer toutes mes modifications.

Notez que toutes les actions que vous entreprenez pour résoudre une erreur peut aboutir à une nouvelle erreur. Dans ce cas, la boîte de dialogue est mise à jour pour afficher des informations détaillées sur la nouvelle erreur.

Vous pouvez fermer la boîte de dialogue sans effectuer aucune action, mais vous ne pourrez pas quitter ou actualiser la liste, ni apporter des modifications à une colonne calculée tant que l'erreur n'est pas résolue.

Haut de la page


Résoudre des modifications et des erreurs conflictuelles

  1. Cliquez sur Résoudre dans la barre d'état pour afficher la boîte de dialogue Résoudre les conflits et les erreurs.

  2. Effectuez une des actions suivantes :

    • Pour résoudre le conflit ou l'erreur actuellement affichée en ignorant les modifications apportées à la ligne, cliquez sur Ignorer mes modifications. Vos modifications sont alors perdues.
    • Pour résoudre tous les conflits et toutes les erreurs en attente en ignorant toutes les modifications que vous avez apportées à la liste, cliquez sur Ignorer toutes mes modifications.
    • Pour résoudre le conflit ou l'erreur actuellement affiché en réappliquant vos modifications, cliquez sur Tenter à nouveau d'appliquer mes modifications. Dans le cas d'un conflit, si vous-même et l'autre utilisateur avez modifié la même colonne, vos modifications vont remplacer les modifications de l'autre utilisateur. Si vous modifiez d'autres colonnes, vos modifications seront fusionnées avec les modifications de l'autre utilisateur.
    • Pour résoudre tous les conflits et toutes les erreurs en attente en réappliquant vos modifications, cliquez sur Tenter à nouveau d'appliquer toutes mes modifications.
    • Pour afficher les informations détaillées sur le conflit ou l'erreur suivante, cliquez sur Suivant dans le coin supérieur droit de la boîte de dialogue.
    • Pour afficher les informations détaillées du conflit ou de l'erreur précédente, cliquez sur le bouton Précédent dans le coin supérieur droit de la boîte de dialogue.
    • Pour résoudre ultérieurement les conflits et les erreurs, cliquez sur Fermer dans la barre de titre de la boîte de dialogue.

Remarques

  • La grille des détails affiche toutes les colonnes de votre affichage actuel. Si les colonnes ne sont pas visibles, utilisez la barre de défilement horizontale pour vous déplacer, ou bien faites glisser le bord droit de la boîte de dialogue pour accroître la largeur de la grille des détails.

    Pour effectuer un zoom sur le contenu d'une colonne, cliquez sur la colonne dans la grille des détails. Vos modifications et celles de l'autre utilisateur sont affichées dans la boîte de dialogue Détails du champ. La boîte de dialogue est également utile pour afficher les modifications du formatage de texte enrichi.

  • La grille des détails affiche Ligne supprimée à la place d'une ligne de données, si vous-même ou l'autre utilisateur supprimez une ligne. Si l'autre utilisateur supprime la ligne, la boîte de dialogue n'affiche pas le nom de l'utilisateur ni la date et l'heure de la suppression. De même, vous ne pouvez pas réappliquer vos modifications.


Apparition de conflits

Un conflit survient lorsque deux utilisateurs effectuent une modification sur la même partie des données ou de la structure d'une liste. L'utilisateur qui soumet une modification en premier va réussir à valider ses modifications, mais le second va être averti de l'existence d'un conflit.

Types de modifications possibles sur une liste

Scénarios aboutissant à un conflit

Scénarios n'aboutissant pas à un conflit

Scénarios aboutissant à un conflit structurel

Scénarios n'aboutissant pas à un message d'erreur ou à un conflit

Types de modifications possibles sur une liste

Vous pouvez apporter trois types de modifications à une liste. Le tableau suivant présente chacun des types, avec quelques exemples :

Type de modification | Exemples
Modification des données d'une liste | Ajouter, modifier ou supprimer une ligne Coller le contenu du Presse-papiers Ajouter des données à des cellules en faisant glisser la poignée de recopie Ajouter ou supprimer des pièces jointes Formater le contenu d'une ou plusieurs cellules
Modification de la structure d'une liste | Ajouter ou supprimer une colonne Modifier les paramètres d'une colonne Apporter des modifications à une colonne calculée Modifier les paramètres d'une liste
Modification de la définition d'un affichage | Appliquer un filtre ou un ordre de tri Changer la largeur de colonne ou la hauteur de ligne Changer l'ordre des colonnes Afficher ou masquer la ligne des totaux

Haut de la page

Scénarios aboutissant à un conflit

Le tableau suivant résume les scénarios où un conflit survient :

Utilisateur A | Utilisateur B
Supprime une ligne | Met à jour la même ligne
Met à jour une ligne | Met à jour ou supprime la même ligne Remarque Dans une bibliothèque de documents, si l'utilisateur A met à jour une ligne ou un document, et que l'utilisateur B supprime la même ligne ou le même document, il n'y a pas de conflit.
Ajoute ou supprime une pièce jointe avec le navigateur | Met à jour ou supprime la même ligne
Supprime un document | Met à jour la même ligne
Modifie, renomme ou enregistre un document | Met à jour la même ligne
Met à jour une ligne sans modifier de document | Met à jour la même ligne
Change le formatage du texte enrichi | Met à jour ou supprime la même ligne

Dans une bibliothèque de documents, si l'utilisateur A ouvre un document et que l'utilisateur B modifie le document ou change ses paramètres, l'utilisateur B va recevoir un message d'erreur indiquant que le document est verrouillé.

Haut de la page

Scénarios n'aboutissant pas à un conflit

Le tableau suivant résume les scénarios où il n'y pas de conflit :

Utilisateur A | Utilisateur B | Exemple
Modifie des données | Modifie la définition de l'affichage | L'utilisateur A ajoute une ligne et l'utilisateur B applique un ordre de tri à l'affichage
Modifie la structure | Modifie la définition de l'affichage | L'utilisateur A ajoute une colonne et l'utilisateur B applique un ordre de tri à l'affichage
Modifie la définition de l'affichage | Modifie des données | L'utilisateur A applique un ordre de tri et l'utilisateur B ajoute une ligne
Modifie la définition de l'affichage | Modifie la structure | L'utilisateur A applique un ordre de tri et l'utilisateur B ajoute une colonne
Modifie la définition de l'affichage | Modifie la définition de l'affichage | L'utilisateur A applique un ordre de tri, après quoi l'utilisateur B applique un ordre de tri différent Remarque Parce que la dernière modification subsiste, la modification de l'utilisateur B va remplacer la modification de l'utilisateur A

Remarque Dans une bibliothèque de documents, si les utilisateurs A et B ouvrent un document en mode Lecture seule, et s'ils décident ensuite de modifier et d'enregistrer le document en remplaçant la version existante, l'utilisateur qui enregistre en second va écraser les modifications apportées par l'autre utilisateur.

Haut de la page

Scénarios aboutissant à un conflit structurel

Le tableau suivant résume les scénarios où un message d'erreur va être affiché. L'utilisateur B va être invité à actualiser la liste et ses modifications vont être annulées.

Utilisateur A | Utilisateur B
Supprime une colonne | Met à jour des données dans la même colonne
Modifie le type de données d'une colonne | Ajoute ou met à jour des données d'un type incompatible
Ajoute, renomme ou supprime une colonne, modifie le type de données d'une colonne ou d'autres propriétés | Modifie une colonne calculée
Effectue des modifications au niveau de la liste, comme renommer la liste, changer sa description ou ses paramètres de sécurité, réorganiser les colonnes, activer ou désactiver les pièces jointes ou ajouter la liste à la Barre de lancement rapide | Modifie une colonne calculée
Modifie une colonne calculée | Ajoute, renomme ou supprime une colonne, modifie le type de données d'une colonne ou d'autres propriétés. Remarque L'utilisateur B doit être sur la page Ajouter une colonne ou Modifier la colonne avant que l'utilisateur A commence à modifier la colonne calculée.
Modifie une colonne calculée | Effectue des modifications au niveau de la liste, comme renommer la liste, changer sa description ou ses paramètres de sécurité, réorganiser les colonnes, activer ou désactiver les pièces jointes ou ajouter la liste à la Barre de lancement rapide Remarque L'utilisateur B doit être sur la page Paramètres de la liste avant que l'utilisateur A commence à modifier la colonne calculée.

Haut de la page

Scénarios n'aboutissant pas à un message d'erreur ou à un conflit

Le tableau suivant résume les scénarios n'aboutissant ni à une erreur ni à un conflit :

Utilisateur A | Utilisateur B
Supprime une colonne | Supprime la même colonne
Supprime une pièce jointe | Supprime la même pièce jointe
Supprime un document | Supprime le même document ou la même ligne
Supprime une ligne | Supprime la même ligne

Haut de la page


Exportation d'une feuille de données

Vous pouvez exporter à partir de Microsoft SharePoint Foundation 2010 vers Microsoft Access 2010 ou vers Microsoft Excel 2010. Pour Access 2010, vous pouvez exporter vers une table statique ou liée dans une base de données nouvelle ou existante. Pour Excel 2010, vous pouvez créer une requête en mode Feuille de données, dans une feuille de calcul nouvelle ou existante, ou dans un nouveau classeur.

Exportation vers Access

Lorsque vous exportez de Microsoft SharePoint Foundation 2010 vers Access 2010, vous créez une table de base de données statique avec des données en mode Feuille de données. Cette table de base de données statique n’est pas liée au mode Feuille de données et n’est pas mise à jour lorsque des modifications sont apportées aux données dans Microsoft SharePoint Foundation 2010.

Suivi d'une liste dans Access

Lorsque vous choisissez Assurer un suivi de cette liste dans Access dans le volet Office, vous créez une table dans Access qui est liée de manière dynamique à Microsoft SharePoint Foundation 2010. Si vous modifiez les données en mode Feuille de données, ces modifications sont automatiquement mises à jour dans la table Access. De la même façon, si vous modifiez les données dans la table Access, ces modifications sont automatiquement reflétées en mode Feuille de données.

Remarque Dans certains types de listes, il y a des colonnes qui peuvent être modifiées en mode Feuille de données dans Microsoft SharePoint Foundation 2010, mais pas dans les tables Access liées.

Interrogation d'une liste avec Excel

Lorsque vous effectuez une requête de mode Feuille de données avec Excel, vous créez une requête dans Excel qui extrait des données en mode Feuille de données. Lorsque des données en mode Feuille de données ont été exportées vers Excel 2010, toute modification apportée aux données en mode Feuille de données sont automatiquement mises à jour dans la feuille de calcul Excel. Toutefois, les modifications apportées à la feuille de calcul Excel ne sont pas retransmises à Microsoft SharePoint Foundation 2010.


Interrogation d'une liste avec Excel

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Interroger la liste avec Excel.

Microsoft Excel exporte la feuille de données sous la forme d’un fichier de requête Web.

Si Excel est en cours d’exécution lorsque vous cliquez sur Inclure dans le graphique avec Excel, vous avez la possibilité d’importer les données du fichier de requête Web dans une feuille de calcul existante, dans une nouvelle feuille de calcul ou dans un nouveau classeur. Autrement, Excel ouvre et importe les données dans un nouveau classeur. Les données importées sont affichées sous forme de liste dans une feuille de calcul et lient les données aux informations contenues dans Microsoft SharePoint Foundation 2010.

Mise à jour d'une feuille de calcul avec les modifications d'une feuille de données

Une fois que vous apportez des modifications aux données de Microsoft SharePoint Foundation 2010, vous pouvez mettre à jour la feuille de calcul dans Excel à l’aide de la fonctionnalité d’actualisation des données externes. Pour plus d’informations sur les requêtes, consultez l’aide de Microsoft Excel.


Exportation d'informations de contacts ou d'événements

Exportation d'informations de contacts

Dans l’affichage en mode standard et en mode Feuille de données d’une liste de contacts, vous pouvez exporter la totalité d’une liste de contacts ou un contact individuel vers Microsoft Outlook.

Exportation d'une liste de contacts

  1. Dans le ruban, cliquez sur l’onglet Liste puis, dans le groupe Se connecter et exporter, cliquez sur Se connecter à Outlook.
  2. Outlook vous invite à confirmer la connexion à la liste de contacts Outlook. Cliquez sur Oui.

Une fois que vous avez exporté une liste de contacts vers Outlook, toutes les modifications apportées à la liste de contacts sur Microsoft SharePoint Foundation 2010 seront automatiquement transférées et mises à jour dans la liste des contacts dans Outlook. Ces modifications sont affichées au rechargement suivant de la liste de contacts dans Outlook.

Exportation d'un contact individuel

  1. Effectuez une des actions suivantes :
    • En mode standard, cliquez sur la flèche de liste déroulante dans la cellule Nom du contact que vous souhaitez exporter, puis cliquez sur Exporter un contact.
    • Dans l'affichage en mode Feuille de données, cliquez avec le bouton droit sur le contact à exporter. Cliquez sur Exporter un contact.
  2. Vous êtes invité à confirmer le téléchargement d'un fichier de cartes de visite virtuelles (avec l'extension vcf). Cliquez sur Ouvrir.

Cette action exporte le contact vers la liste de contacts par défaut Contacts de Outlook. Vous pouvez ensuite décider d'enregistrer le contact dans Contacts ou bien dans une autre liste de contacts.

Haut de la page

Exportation d'informations d'événements

Vous pouvez exporter une liste d’événements entière ou un événement individuel à partir d’une liste d’événements vers Outlook. Pour afficher un calendrier sous forme d’une liste d’événements, dans le Ruban, sous Outils de liste, cliquez sur Liste, puis cliquez sur Tous les événements dans la liste déroulante Affichage actuel.

Exportation d'une liste d'événements

  1. Dans le ruban, cliquez sur l’onglet Liste puis, dans le groupe Se connecter et exporter, cliquez sur Se connecter à Outlook.
  2. Outlook vous invite à confirmer la connexion du calendrier de Microsoft SharePoint Foundation 2010 à Outlook. Cliquez sur Oui.

Une fois que vous avez exporté une liste d’événements vers Outlook, toutes les modifications apportées à la liste d’événements sur Microsoft SharePoint Foundation 2010 seront automatiquement transférées et mises à jour dans le calendrier Outlook. Ces modifications sont affichées au rechargement suivant du calendrier dans Outlook.

Exportation d'un événement individuel

  1. Effectuez une des actions suivantes :
    • En mode Feuille de données, cliquez avec le bouton droit sur la ligne correspondant à l'événement que vous voulez exporter, puis cliquez sur Exporter un événement.
    • En mode standard, sélectionnez l’événement que vous voulez exporter, puis, dans l’onglet Commandes personnalisées, cliquez sur Exporter un événement.
  2. Vous êtes invité à confirmer le téléchargement d'un fichier calendrier Internet (avec l'extension ics). Cliquez sur Ouvrir.

Cette action exporte l'événement vers le calendrier Outlook par défaut Calendrier. Vous pouvez ensuite décider d'enregistrer l'événement dans Calendrier ou bien dans un autre calendrier.

Haut de la page


Exportation ou liaison d'une feuille de données à Access

Exportation d'une feuille de données dans Access

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Exporter vers Access.
  3. Choisissez d'exporter la feuille de données vers une base de données existante ou vers une nouvelle base de données et cliquez sur OK.

Microsoft Access vous invite à spécifier l'emplacement de la base de données et ouvre une table avec les données exportées.

Suivi d'une liste dans Access

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Assurer un suivi de cette liste dans Access.
  3. Choisissez d'exporter la feuille de données vers une base de données existante ou vers une nouvelle base de données, puis cliquez sur OK.

Access vous invite à spécifier l’emplacement de la base de données et crée une table liée qui établit un lien avec les données de Microsoft SharePoint Foundation 2010.

Mise à jour de la feuille de données à partir des modifications apportées dans la table liée

  1. Modifiez la table liée dans Access.
  2. En mode Feuille de données, dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Actualiser les données.

Mise à jour d’une table attachée à partir de modifications dans SharePoint

  • Pour intégrer dans votre table liée les modifications apportées aux données dans Microsoft SharePoint Foundation 2010, dans Access, utilisez la commande Actualiser.


Création d'un état Access

Lorsque vous créez un état dans Microsoft Access à partir d'une feuille de données, vous créez une table liée aux données de la feuille de données et vous générez un état basé sur ces données.

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Cliquez sur Générer un état avec Access.
  3. Choisissez d'exporter la feuille de données dans une base de données existante ou dans une nouvelle base de données et cliquez sur OK.

Access vous invite à spécifier l’emplacement de la base de données et crée une table liée qui établit un lien aux données Microsoft SharePoint Foundation 2010. Il génère ensuite un état simple qui affiche tous les champs et tous les enregistrements de la table liée. Pour plus d’informations sur les rapports dans Access, voir « Créer un état » dans l’aide d’Access.


Création d'un graphique Excel

Lorsque vous créez un graphique Microsoft Excel avec un mode Feuille de données, Excel crée une requête des données en mode Feuille de données, puis crée un graphique basé sur les données faisant l’objet d’une requête.

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Inclure dans le graphique avec Excel.

Excel exporte la feuille de données sous la forme d’un fichier de requête Web.

Si Excel est en cours d’exécution, lorsque vous cliquez sur Inclure dans le graphique avec Excel, vous avez la possibilité d’importer les données du fichier de requête Web dans une feuille de calcul existante, une nouvelle feuille de calcul ou un nouveau classeur. Sinon, Excel ouvre et importe les données dans un nouveau classeur. Les données importées sont affichées sous forme de liste dans un classeur ; elles lient les données aux informations de Microsoft SharePoint Foundation 2010. Vous êtes ensuite invité à créer un graphique à l’aide de l’Assistant graphique.


Création d'un tableau croisé dynamique Excel

Lorsque vous créez un tableau croisé dynamique Microsoft Excel, Excel crée une requête en mode Feuille de données, puis crée un tableau croisé dynamique à partir des données interrogées.

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Créer un tableau croisé dynamique Excel (PivotTable).

Excel exporte la feuille de données sous la forme d’un fichier de requête Web.

Si Excel est en cours d’exécution lorsque vous cliquez sur Créer un tableau croisé dynamique Excel (PivotTable), vous avez la possibilité d’importer les données du fichier de requête Web dans une feuille de calcul existante, dans une nouvelle feuille de calcul ou dans un nouveau classeur. Autrement, Excel ouvre et importe la feuille de données dans un nouveau classeur. Les données importées sont affichées sous forme de liste dans une feuille de calcul et lient les données aux informations contenues dans Microsoft SharePoint Foundation 2010. Excel affiche la liste des champs du tableau croisé dynamique et la barre d’outils Tableau croisé dynamique, et vous invite à créer un tableau croisé dynamique.


Impression d'une feuille de données avec Excel

Lorsque vous imprimez des données en mode Feuille de données avec Microsoft Excel, Excel crée une requête des données en mode Feuille de données, puis imprime les données renvoyées par la requête.

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher le Volet Office.
  2. Dans le volet Office, cliquez sur Imprimer avec Excel.

Excel exporte la feuille de données sous la forme d’un fichier de requête Web.

Si Excel est en cours d’exécution, lorsque vous cliquez sur Imprimer avec Excel, vous avez la possibilité d’importer les données du fichier de requête Web dans une feuille de calcul existante, une nouvelle feuille de calcul ou un nouveau classeur. Sinon, Excel ouvre et importe les données la feuille de données dans un nouveau classeur. Les données importées sont affichées sous forme de liste dans un classeur et lient les données aux informations de Microsoft SharePoint Foundation 2010. Vous êtes ensuite invité à imprimer la liste Excel.


Opérateurs de calcul

Les opérateurs spécifient le type de calcul que vous voulez effectuer sur les éléments d'une formule. Les listes prennent en charge trois différents types d'opérateurs de calcul : arithmétique, comparaison et texte.

Types d'opérateurs

Ordre dans lequel une liste effectue les opérations dans une formule

Important Les formules peuvent uniquement être utilisées dans des colonnes du type de données Calculé. Vous ne pouvez pas changer le type de données d’une colonne en Calculé.

Types d'opérateurs

Opérateurs arithmétiques Pour effectuer des opérations mathématiques de base comme l'addition, la soustraction ou la multiplication, pour combiner des nombres et produire des résultats numériques, utilisez les opérateurs arithmétiques suivants.

Opérateur arithmétique | Signification (exemple)
+ (signe Plus) | Addition (3+3)
– (signe Moins) | Soustraction (3–1) Négation (–1)
* (astérisque) | Multiplication (3*3)
/ (barre oblique) | Division (3/3)
% (signe Pour cent) | Pour cent (20%)
^ (signe d'insertion) | Exponentiation (3^2)

Opérateurs de comparaison Vous pouvez comparer deux valeurs avec les opérateurs suivants. Lorsque deux valeurs sont comparées au moyen de ces opérateurs, le résultat est une valeur logique, Oui ou Non.

Opérateur de comparaison | Signification (exemple)
= (signe Égal) | Égal à (A=B)
> (signe Supérieur à) | Supérieur à (A>B)
< (signe Inférieur à) | Inférieur à (A<B)
>= (signe Supérieur ou égal à) | Supérieur ou égal à (A>=B)
<= (signe Inférieur ou égal à) | Inférieur ou égal à (A<=B)
<> (signe Différent de) | Différent de (A<>B)

Opérateur de concaténation de texte Utilisez le « et » commercial (&) pour joindre ou concaténer une ou plusieurs chaînes de texte pour produire un seul élément de texte.

Opérateur texte | Signification (exemple)
& (et commercial) | Connecte ou concatène deux valeurs pour produire une seule valeur texte continue ("Les"&"Comptoirs")

Haut de la page

Ordre dans lequel une liste effectue les opérations dans une formule

Les formules calculent les valeurs dans un ordre spécifique. Une formule de liste va commencer par un signe Égal (=). Après cela se trouvent les éléments à calculer (les opérandes), qui sont séparés par des opérateurs de calcul. Les listes calculent la formule de gauche à droite, selon un ordre spécifique pour chaque opérateur de la formule.

Priorité des opérateurs

Si vous combinez plusieurs opérateurs dans une même formule, les listes effectuent les opérations dans l'ordre indiqué par le tableau suivant. Si une formule contient des opérateurs de même priorité, par exemple si une formule contient à la fois un opérateur de multiplication et un opérateur de division, les listes évaluent les opérateurs de gauche à droite.

Opérateur | Description
– | Négation (comme dans –1)
% | Pour cent
^ | Exponentiation
* et / | Multiplication et division
+ et – | Addition et soustraction
& | Connecte deux chaînes de texte (concaténation)
= < > <= >= <> | Comparaison

Utilisation de parenthèses

Pour changer l'ordre d'évaluation, placez entre parenthèses la partie de la formule qui doit être calculée en premier. Par exemple, le formule suivante produit 11, parce qu'une liste calcule la multiplication avant l'addition. La formule multiplie 2 par 3, puis ajoute 5 au résultat.

=5+2*3

Par contre, si vous utiliser des parenthèses pour modifier la syntaxe, la liste ajoute 5 à 2, puis multiplie le résultat par 3 pour produire 21.

=(5+2)*3

Dans l'exemple ci-dessous, les parenthèses autour de la première partie de la formule forcent la liste à calculer d'abord [Coût]+25, puis à diviser le résultat par la somme des valeurs des colonnes EC1 et EC2.

=([Coût]+25)/SOMME([EC1]+[EC2])

Haut de la page


Références à des colonnes dans une formule

Une référence identifie une cellule de la ligne sélectionnée dans une feuille de données et indique à la liste où se trouvent les valeurs ou les données que vous voulez utiliser dans une formule. Par exemple, [Coût] référence la valeur de la colonne Coût dans la ligne sélectionnée. Si la colonne Coût contient la valeur 100 pour cette ligne, alors =[Coût]*3 va renvoyer 300.

Important Les formules peuvent uniquement être utilisées dans des colonnes du type de données Calculé. Vous ne pouvez pas changer le type de données d’une colonne en Calculé.

Avec les références, vous pouvez utiliser dans une ou plusieurs formules des données contenues dans différentes colonnes d'une liste. Les colonnes ayant les types de données suivants peuvent être référencées dans une formule : une seule ligne de texte, nombre, monnaie, date et heure, choix, oui/non et calculé.

Vous utilisez le nom complet de la colonne pour la référencer dans une formule. Si le nom comprend un espace ou un caractère spécial, vous devez placer le nom entre crochets ([ ]). Les références ne font pas de distinction entre les majuscules et les minuscules. Par exemple, vous pouvez référencer la colonne Prix Unitaire sous la forme [Prix Unitaire] ou [prix unitaire].

Remarque Vous ne pouvez pas référencer une valeur d'une ligne autre que la ligne en cours. Vous ne pouvez pas non plus inclure des références de colonne dans une formule qui est spécifiée comme valeur par défaut pour une colonne.


Constantes dans les formules

Une constante est une valeur qui n'est pas calculée. Par exemple, la date 10/9/2008, le nombre 210 et le texte « Bénéfices trimestriels » sont tous des constantes. Les types de données possibles pour les constantes sont les suivants :

  • Chaîne (Exemple: =[Nom] = "Dupont")

    Les constantes de type chaîne sont placées entre des guillemets doubles et peuvent comporter jusqu'à 255 caractères.

  • Nombre (Exemple: =[Coût] >= 29,99)

    Les constantes numériques peuvent comporter des décimales et peuvent être positives ou négatives.

  • Date (Exemple: =[Date] <> 7/7/2002)

    Les constantes de type date ne nécessitent pas de délimiteurs.

  • Booléen (Exemple: =SI([Coût]>[Bénéfice], "Perte", "Pas de perte")

    Oui et Non sont des constantes booléennes. Vous pouvez les utiliser dans des expressions conditionnelles. Dans l'exemple précédent, si Coût est supérieur à Bénéfice, la fonction SI renvoie Oui, et la formule renvoie la chaîne « Perte ». Si Coût est inférieur ou égal à Bénéfice, la fonction renvoie Non, et la formule renvoie la chaîne « Pas de perte ».


À propos de l'affichage des totaux et des valeurs calculées

Vous pouvez effectuer différents types de calcul dans une liste dans Access Web Datasheet. Vous pouvez afficher des valeurs de regroupement, telles qu'une somme et une moyenne, pour une colonne de la liste. Vous pouvez ajouter des colonnes calculées qui utilisent une formule pour calculer des valeurs pour chaque ligne de la liste. Vous pouvez également utiliser des formules pour spécifier la valeur par défaut d'une colonne.

L'illustration suivante montre la liste des salaires dans Access Web Datasheet. La liste affiche les valeurs de regroupement dans la ligne des totaux au bas de la liste, ainsi qu'une colonne calculée appelée Salaire net.

Feuille de données avec calcul et totaux

La ligne des totaux affiche le nombre de lignes dans la colonne Personne et la somme des valeurs dans la colonne Salaire net. La colonne Salaire net utilise la formule qui est affichée dans l'info-bulle pour calculer les valeurs pour chaque ligne.

Affichage des valeurs de regroupement

Affichage des valeurs calculées dans une colonne

Utilisation d'une formule pour calculer des valeurs par défaut pour une colonne

Affichage des valeurs de regroupement

En mode Feuille de données, vous pouvez afficher ou masquer la ligne des totaux en cliquant sur Afficher les totaux, sous l’onglet Liste du ruban. Initialement, la ligne des totaux affiche la somme de chacune des colonnes numériques de la liste. S’il n’y a pas de colonnes numériques dans la liste, c’est un comptage des éléments qui est affiché dans la dernière colonne de la liste. Vous ne pouvez pas modifier les valeurs affichées dans la ligne des totaux.

Après avoir activé la ligne des totaux, vous pouvez afficher ou masquer les valeurs de regroupement pour une colonne spécifique. Vous pouvez également modifier la fonction de regroupement qui est utilisée par une colonne en sélectionnant simplement une autre fonction dans la liste déroulante de la ligne des totaux. L'info-bulle qui apparaît lorsque vous passez le pointeur sur une valeur de regroupement indique la fonction de regroupement qui est utilisée par la colonne.

Vous ne pouvez pas filtrer les données d'une liste sur la base de valeurs de regroupement. Cependant, si une liste est filtrée, les valeurs de regroupement sont calculées à partir des seuls éléments qui figurent dans l'ensemble qui est renvoyé. La ligne des totaux n'est pas prise en compte dans les tris effectués sur les autres lignes de la liste.

Le tableau suivant indique les fonctions de regroupement qui sont prises en charge dans une liste, ainsi que les types de données qui prennent en charge chacune des fonctions.

Nom de la fonction | Description | Types de données qui prennent en charge cette fonction
Moyenne | Renvoie la moyenne des valeurs de la colonne à agréger. | Numérique, Monétaire, DateHeure
Compte | Compte le nombre de valeurs. Pour les colonnes de type Booléen, Pièce jointe et Icône doc, seules les valeurs Oui sont comptées. | Numérique, Monétaire, DateHeure, Booléen, Pièce jointe, Icône doc, Texte (une seule ligne), Texte (plusieurs lignes), Choix (unique), Choix (multiples), Recherche, Lien hypertexte
Maximum | Renvoie la plus grande valeur de la colonne à agréger. | Numérique, Monétaire, DateHeure
Minimum | Renvoie la plus petite valeur de la colonne à agréger. | Numérique, Monétaire, DateHeure
Somme | Calcule la somme des valeurs d'une colonne. | Numérique, Monétaire
Écart-type | Renvoie l'écart-type des valeurs de la colonne à agréger, en supposant que les valeurs représentent un échantillon d'une population plus importante. | Numérique, Monétaire
Variance | Renvoie la variance des valeurs de la colonne à agréger, en supposant que les valeurs représentent un échantillon d'une population plus importante. | Numérique, Monétaire

Lorsque vous cliquez sur la flèche pointant vers le bas dans une cellule de la ligne des totaux, Aucune est affichée dans la liste, en même temps que d'autres fonctions de regroupement. Sélectionnez Aucune pour une colonne où vous ne voulez pas de regroupement.

Vous pouvez regrouper des valeurs dans une colonne calculée. La liste des fonctions disponibles pour la colonne dépend du type de données de la valeur résultant du calcul.

Haut de la page

Affichage des valeurs calculées dans une colonne

Vous pouvez ajouter une colonne calculée à une liste pour calculer des valeurs à l'aide d'une formule. Une formule peut référencer seulement des valeurs d'autres colonnes au sein de la même ligne. Vous ne pouvez pas désigner une cellule spécifique ou une plage de cellules dans une formule.

Les valeurs calculées sont stockées dans la colonne, mais vous ne pouvez pas modifier les valeurs. Lorsque les valeurs référencées par la formule changent, la liste recalcule automatiquement la valeur pour la colonne calculée.

L'info-bulle qui apparaît lorsque vous laissez le pointeur de votre souris sur une valeur calculée indique la formule utilisée par la colonne. Vous pouvez modifier une formule en sélectionnant une cellule qui utilise la formule et en passant au mode Modification. Lorsque vous avez terminé la modification de la formule et quitté le mode Modification, les nouvelles valeurs sont automatiquement calculées et affichées dans la colonne.

Vous pouvez trier et filtrer des valeurs dans une colonne calculée.

Haut de la page

Utilisation d'une formule pour calculer des valeurs par défaut pour une colonne

Lorsque vous ajoutez à une liste une colonne de type Une seule ligne, Choix, Numérique, Monétaire ou DateHeure, vous pouvez spécifier une formule à la place d'une constante comme valeur par défaut. Lorsque vous ajoutez une nouvelle ligne, la liste va évaluer la formule et afficher le résultat comme valeur par défaut de la colonne.

Lorsque vous spécifiez une formule comme valeur par défaut, vous pouvez appeler toutes les fonctions prises en charge, mais la formule ne peut pas référencer d'autres colonnes. Comme la formule va être évaluée avant l'entrée de données dans les autres colonnes, les références de colonnes ne sont pas autorisées.

Haut de la page


Formules

Les formules sont des équations qui effectuent des calculs sur des valeurs d'une liste. Une formule commence par un signe Égal (=). Par exemple, la formule suivante multiplie 2 par 3, puis ajoute 5 au résultat.

=5+2*3

Vous pouvez utiliser une formule dans une colonne calculée et pour calculer des valeurs par défaut pour une colonne.

Important Les formules peuvent uniquement être utilisées dans des colonnes du type de données Calculé. Vous ne pouvez pas changer le type de données d’une colonne en Calculé.

Une formule peut également contenir un ou plusieurs des éléments suivants : fonctions, références à des colonnes, opérateurs et constantes.

Composants d'une formule
=PI()*[Résultat]^2

Fonctions La fonction PI() renvoie la valeur de pi : 3,142...

Références (ou noms de colonnes) [Résultat] représente la valeur de la colonne Résultat pour la ligne courante.

Constantes Nombres ou valeurs texte entrées directement dans une formule, comme 2.

Opérateurs L'opérateur ^ (exponentiation) élève un nombre à une puissance, et l'opérateur * (astérisque) multiplie.

Exemples

Une formule peut utiliser un ou plusieurs des éléments ci-dessus. Voici quelques exemples de formules (par ordre croissant de complexité).

  • Formules simples (comme =128+345)

    Les formules suivantes contiennent des valeurs littérales et des opérateurs.

    Exemple | Description
    =128+345 | Additionne 128 et 345
    =5^2 | Élève 5 au carré
  • Formules contenant des références à des colonnes (comme =[Bénéfice] – [Coût])

    Les formules suivantes référencent d'autres colonnes de la même liste.

    Exemple | Description
    =[Bénéfice] | Utilise la valeur de la colonne Bénéfice
    =[Bénéfice]*10/100 | 10% de la valeur de la colonne Bénéfice
    =[Bénéfice] > [Coût] | Renvoie Oui si la valeur de la colonne Bénéfice est supérieure à la valeur de la colonne Coût
  • Formules appelant des fonctions (comme =AVG(1, 2, 3, 4, 5))

    Les formules suivantes appellent des fonctions intégrées.

    Exemple | Description
    =MAX(T1, T2, T3, T4) | Renvoie la valeur la plus élevée d'un ensemble de valeurs
    =SI(Coût>Bénéfice, "Perte", "Pas de perte") | Renvoie Perte si le coût est supérieur au bénéfice. Sinon, renvoie Pas de perte.
    =JOUR("15-Avr-2008") | Renvoie la partie Jour d'une date. Cette formule renvoie le nombre 15.
  • Formules avec des fonctions imbriquées (comme =SOMME(ARRONDI([Coût],2),[Bénéfice])

    Les formules suivantes spécifient une ou plusieurs fonctions comme arguments d'une autre fonction.

    Exemple Description
    =SOMME(SI(A>B, A-B, 10), C) Le fonction SI renvoie la différence entre les valeurs des colonnes A et B, ou bien 10.

    La fonction SOMME additionne la valeur renvoyée par la fonction SI et la valeur de la colonne C.

    =DEGRES(PI()) La fonction PI renvoie le nombre 3,14159265358979.

    La fonction DEGRES convertit une valeur spécifiée en radians en degrés. Cette formule renvoie la valeur 180.
    =ESTNUM(TROUVE("BD",Colonne1)) La fonction TROUVE recherche la chaîne BD dans Colonne1 et renvoie la position du début de cette chaîne. Elle renvoie une valeur d'erreur si la chaîne n'est pas trouvée.

    La fonction ESTNUM renvoie Oui si la fonction TROUVE renvoie une valeur numérique. Sinon, elle renvoie Non.


Modification d'une formule

  1. Cliquez sur une des cellules de la colonne calculée.
  2. Cliquez à nouveau sur la cellule pour afficher la formule actuelle.
  3. Modifiez la formule et appuyez sur Entrée.

    Remarque Après avoir tapé le signe Égal (=) dans une colonne calculée, vous pouvez coller une référence de colonne simplement en cliquant sur la cellule de cette colonne qui appartient à la ligne en cours. Cependant, si la colonne est d'un type de données qui ne prend pas en charge les calculs, si vous tentez de sélectionner une cellule dans une autre ligne ou si vous sélectionnez plusieurs cellules, la liste ne va pas coller la référence de colonne dans la formule.

  4. Cliquez sur Continuer pour confirmer vos modifications.
  5. Si la liste comporte des conflits, des erreurs ou des modifications en attente, vous serez invité à valider ou à ignorer vos modifications. La modification d'une formule provoque un changement de la structure de la liste et la nouvelle formule peut être effective seulement après que toutes les modifications aient été envoyées au serveur ou ignorées, et que tous les conflits et toutes les erreurs aient été éliminés de la liste.

    Cliquez sur OK pour valider les modifications et résoudre les conflits et les erreurs.

  6. La liste va envoyer les modifications en attente au serveur. S'il y a des conflits et des erreurs, la boîte de dialogue Résoudre les conflits et les erreurs va apparaître. Acceptez ou ignorez vos modifications.

Important Les formules peuvent uniquement être utilisées dans des colonnes du type de données Calculé. Vous ne pouvez pas changer le type de données d’une colonne en Calculé.


Exemples de formules courantes

Vous pouvez utiliser les exemples ci-après dans des colonnes calculées. Les exemples qui ne contiennent pas de références à des colonnes peuvent être utilisés pour spécifier la valeur par défaut d'une colonne.

Important Les formules peuvent uniquement être utilisées dans des colonnes du type de données Calculé. Vous ne pouvez pas changer le type de données d’une colonne en Calculé.

Formules conditionnelles

Afficher Vérifier si un nombre est supérieur ou inférieur à un autre nombre

Utilisez la fonction SI pour effectuer cette opération.

Colonne1 | Colonne2 | Formule | Description
15 000 | 9 000 | =Colonne1>Colonne2 | Colonne1 est-il supérieur à Colonne2 ? (0ui)
15 000 | 9 000 | =SI(Colonne1<=Colonne2; "Oui"; "Non") | Colonne1 est-il inférieur ou égal à Colonne2? (Non)

Afficher Renvoyer une valeur logique après la comparaison du contenu de colonnes

Pour un résultat qui est une valeur logique (0ui ou Non), utilisez les fonctions ET, OU et NON.
Colonne1 | Colonne2 | Colonne3 | Formule | Description
15 | 9 | 8 | =ET(Colonne1>Colonne2; Colonne1<Colonne3) | 15 est-il supérieur à 9 et inférieur à 8 ? (Non)
15 | 9 | 8 | =OU(Colonne1>Colonne2; Colonne1<Colonne3) | 15 est-il supérieur à 9 ou inférieur à 8 ? (Oui)
15 | 9 | 8 | =NON(Colonne1+Colonne2=24) | 15 plus 9 est-il égal à 24 ? (Non)

Pour un résultat qui est un autre calcul ou pour toute autre valeur que Oui ou Non, utilisez les fonctions SI, ET et OU.

Colonne1 | Colonne2 | Colonne3 | Formule | Description
15 | 9 | 8 | =SI(Colonne1=15; "Oui"; "Non") | Si la valeur de Colonne1 égale 15, alors renvoyer "Oui". (Oui)
15 | 9 | 8 | =SI(ET(Colonne1>Colonne2; Colonne1<Colonne3); "Oui"; "Non") | Si 15 est supérieur à 9 et inférieur à 8, alors renvoyer "Oui". (Non)
15 | 9 | 8 | =SI(OU(Colonne1>Colonne2; Colonne1<Colonne3); "Oui"; "Non") | Si 15 est supérieur à 9 ou inférieur à 8, alors renvoyer "Oui". (Oui)

Afficher Afficher des zéros sous forme d'espaces blancs ou de tirets

Utilisez la fonction SI pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
10 | 10 | =Colonne1-Colonne2 | Second nombre soustrait du premier (0)
10 | 10 | =SI(Colonne1-Colonne2;"";Colonne1-Colonne2) | Renvoie null lorsque la valeur est zéro (colonne vide)
15 | 9 | =SI(Colonne1-Colonne2;"-";Colonne1-Colonne2) | Renvoie un tiret lorsque la valeur est zéro (-)

Formules avec le type Date et heure

Afficher Additionner des dates

Pour ajouter un nombre de jour à une date, utilisez l'opérateur d'addition (+). Notez que lors de la manipulation de dates, le type de la colonne calculée doit être défini à Date et heure.
Colonne1 | Colonne2 | Formule | Description
9/6/2007 | 3 | =Colonne1+Colonne2 | Ajouter 3 jours à 9/6/2007 (12/6/2007)
10/12/2008 | 54 | =Colonne1+Colonne2 | Ajouter 54 jours à 10/12/2008 (2/2/2009)

Pour ajouter un nombre de mois à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1 | Colonne2 | Formule | Description
9/6/2007 | 3 | =DATE(ANNEE(Colonne1);MOIS(Colonne1)+Colonne2;JOUR(Colonne1)) | Ajouter 3 mois à 9/6/2007 (9/9/2007)
10/12/2008 | 25 | =DATE(ANNEE(Colonne1);MOIS(Colonne1)+Colonne2;JOUR(Colonne1)) | Ajouter 25 mois à 10/12/2008 (10/1/2011)

Pour ajouter un nombre d'années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1 | Colonne2 | Formule | Description
9/6/2007 | 3 | =DATE(ANNEE(Colonne1)+Colonne2;MOIS(Colonne1);JOUR(Colonne1)) | Ajoute 3 années à 9/6/2007 (9/6/2010)
10/12/2008 | 25 | =DATE(ANNEE(Colonne1)+Colonne2;MOIS(Colonne1);JOUR(Colonne1)) | Ajoute 25 années à 10/12/2008 (10/12/2033)

Pour ajouter une combinaison de jours, de mois et d'années à une date, utilisez les fonctions DATE, ANNEE, MOIS et JOUR.

Colonne1 | Formule | Description
9/6/2007 | =DATE(ANNEE(Colonne1)+3;MOIS(Colonne1)+1;JOUR(Colonne1)+5) | Ajoute 3 années, 1 mois et 5 jours à 9/6/2007 (14/7/2010)
10/12/2008 | =DATE(ANNEE(Colonne1)+1;MOIS(Colonne1)+7;JOUR(Colonne1)+5) | Ajouter 1 année, 7 mois et 5 jours à 9/6/2007 (14/1/2009)

Afficher Calculer la différence entre deux dates

Utilisez la fonction DATEDIF pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
01-Janv-1995 | 15-Juin-1999 | =DATEDIF(Colonne1; Colonne2;"j") | Renvoyer le nombre de jours entre les deux dates (1 626)
01-Janv-1995 | 15-Juin-1999 | =DATEDIF(Colonne1; Colonne2;"am") | Renvoyer le nombre de mois entre les dates, en ignorant la partie Années (5)
01-Janv-1995 | 15-Juin-1999 | =DATEDIF(Colonne1; Colonne2;"aj") | Renvoyer le nombre de jours entre les dates, en ignorant la partie Années (165)

Afficher Calculer la différence entre deux heures

Pour présenter le résultat au format d'heure standard (heures:minutes:secondes), utilisez l'opérateur de soustraction (-) et la fonction TEXTE.

Pour ce mode calcul, les heures ne doivent pas dépasser 24, et les minutes et les secondes ne doivent pas dépasser 60.

Colonne1 | Colonne2 | Formule | Description
09/06/2007 10:35 | 09/06/2007 15:30 | =TEXTE(Colonne2-Colonne1;"h") | Heures entre deux heures (4)
09/06/2007 10 h 35 | 09/06/2007 15:30 | =TEXTE(Colonne2-Colonne1;"h:mm") | Heures et minutes entre deux heures (4:55)
09/06/2007 10:35 | 09/06/2007 15:30 | =TEXTE(Colonne2-Colonne1;"h:mm:ss") | Heures, minutes et secondes entre deux heures (4:55:00)

Pour présenter le résultat dans un total basé sur une seule unité de temps, utilisez la fonction ENT, ou les fonctions HEURE, MINUTE et SECONDE.

Colonne1 | Colonne2 | Formule | Description
09/06/2007 10:35 | 10/06/2007 15:30 | =ENT((Colonne2-Colonne1)*24) | Nombre total d'heures entre deux heures (28)
09/06/2007 10:35 | 10/06/2007 15:30 | =ENT((Colonne2-Colonne1)*1440) | Nombre total de minutes entre deux heures (1 735)
09/06/2007 10:35 | 10/06/2007 15:30 | =ENT((Colonne2-Colonne1)*86400) | Nombre total de secondes entre deux heures (104 100)
09/06/2007 10:35 | 10/06/2007 15:30 | =HEURE(Colonne2-Colonne1) | Nombre d'heures entre deux heures, lorsque la différence n'excède pas 24. (4)
09/06/2007 10:35 | 10/06/2007 15:30 | =MINUTE(Colonne2-Colonne1) | Nombre de minutes entre deux heures, lorsque la différence n'excède pas 60. (55)
09/06/2007 10:35 | 10/06/2007 15:30 | =SECONDE(Colonne2-Colonne1) | Nombre de secondes entre deux heures, lorsque la différence n'excède pas 60. (0)

Afficher Convertir des heures

Pour convertir des heures au format d'heure standard en nombre décimal, utilisez la fonction ENT.
Colonne1 | Formule | Description
10:35 | =(Colonne1-ENT(Colonne1))*24 | Nombre d'heures depuis 00:00 (10,583333)
12:15 | =(Colonne1-ENT(Colonne1))*24 | Nombre d'heures depuis 00:00 (12,25)

Pour convertir des heures au format décimal en format d'heure standard (heures:minutes:secondes), utilisez l'opérateur de division et la fonction TEXTE.

Colonne1 | Formule | Description
10,5833 | =TEXTE(Colonne1/24; "h:mm") | Heures depuis 00:00 (10:35)
12:25 | =TEXTE(Colonne1/24; "h:mm") | Heures depuis 00:00 (12:15)

Afficher Insérer des dates juliennes

L'expression « date julienne » est parfois utilisée pour désigner un format de date qui est une combinaison de l'année en cours et du nombre de jours depuis le début de l'année. Par exemple, le 1er janvier 2007 est représenté par 2007001 et le 31 décembre 2007 est représenté par 2003356.

Il existe également une date julienne couramment utilisée en astronomie, qui est un système de date séquentiel démarrant le 1er janvier 4713 avant J.C.

Remarque Ce format n'est pas basé sur le calendrier julien.

Pour convertir une date en date julienne, utilisez les fonctions TEXTE et DATEVAL.

Colonne1 | Formule | Description
23/6/2007 | =TEXTE(Colonne1;"aa")&TEXTE((Colonne1-DATEVAL("1/1/"& TEXTE(Colonne1;"aa"))+1);"000") | Date en format julien, avec une année sur deux chiffres (07174)
23/6/2007 | =TEXTE(Colonne1;"aaaa")&TEXTE((Colonne1-DATEVAL("1/1/"&TEXTE(Colonne1;"aa"))+1);"000") | Date en format julien, avec une année sur quatre chiffres (2007174)

Pour convertir une date en date julienne utilisée en astronomie, utilisez la constante 2415018,50.

Cette formule vaut seulement pour les dates postérieures au 1/3/1901 et si vous utilisez le système de date 1900.

Colonne1 | Formule | Description
23/6/2007 | =Colonne1+2415018,50 | Date au format « Julien », utilisée en astronomie (2454274,50)

Afficher Afficher des dates sous la forme d'un jour de la semaine

Pour convertir des dates en texte indiquant le jour de la semaine, utilisez les fonctions TEXTE et JOURSEM.
Colonne1 | Formule | Description
19-Févr-2007 | =TEXTE(JOURSEM(Colonne1); "jjjj") | Calcule le jour de la semaine pour la date et renvoie le nom complet du jour (Lundi)
3-Janv-2008 | =TEXTE(JOURSEM(Colonne1); "jjj") | Calcule le jour de la semaine pour la date et renvoie le nom abrégé du jour (Jeu)

Formules mathématiques

Afficher Additionner des nombres

Pour additionner des nombres figurant dans deux colonnes ou plus d'une même ligne, utilisez l'opérateur d'addition ou la fonction SOMME.

Colonne1 | Colonne2 | Colonne3 | Formule | Description
6 | 5 | 4 | =Colonne1+Colonne2+Colonne3 | Additionne les valeurs des trois premières colonnes (15)
6 | 5 | 4 | =SOMME(Colonne1;Colonne2;Colonne3) | Additionne les valeurs des trois premières colonnes (15)
6 | 5 | 4 | =SOMME(SI(Colonne1>Colonne2; Colonne1-Colonne2; 10); Colonne3) | Si Colonne1 est supérieur à Colonne2, additionner la différence avec Colonne3. Sinon, additionner 10 avec Colonne3. (5)

Afficher Soustraire des nombres

Utilisez l'opérateur de soustraction (-) pour effectuer cette opération.
Colonne1 | Colonne2 | Colonne3 | Formule | Description
15 000 | 9 000 | -8 000 | =Colonne1-Colonne2 | Soustraire 9 000 de 15 000 (6 000)
15 000 | 9 000 | -8 000 | =SOMME(Colonne1; Colonne2; Colonne3) | Additionner les nombres des trois premières colonnes, y compris les valeurs négatives (16 000)

Afficher Calculer la différence entre deux nombres, exprimée en pourcentage

Utilisez les opérateurs de soustraction (-) et de division (/), ainsi que la fonction ABS.
Colonne1 | Colonne2 | Formule | Description
2 342 | 2 500 | =(Colonne2-Colonne1)/ABS(Colonne1) | Pourcentage de différence (6,75% ou 0,06746)

Afficher Multiplier des nombres

Utilisez l'opérateur de multiplication (*) ou la fonction PRODUIT pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
5 | 2 | =Colonne1*Colonne2 | Multiplie entre eux les nombres des deux premières colonnes (10)
5 | 2 | =PRODUIT(Colonne1; Colonne2) | Multiplie entre eux les nombres des deux premières colonnes (10)
5 | 2 | =PRODUIT(Colonne1;Colonne2;2) | Multiplie entre eux les nombres des deux premières colonnes et le nombre 2 (20)

Afficher Diviser des nombres

Utilisez l'opérateur de division (/) pour effectuer cette opération.

Colonne1 | Colonne2 | Formule | Description
15 000 | 12 | =Colonne1/Colonne2 | Divise 15 000 par 12 (1 250)
15 000 | 12 | =(Colonne1+9000)/Colonne2 | Additionne 15 000 et 9 000, puis divise le total par 12 (2 000)

Afficher Calculer la moyenne de nombres

La moyenne est également appelée moyenne arithmétique. Pour calculer la moyenne de nombres figurant dans deux colonnes ou plus d'une même ligne, utilisez la fonction MOYENNE.

Colonne1 | Colonne2 | Colonne3 | Formule | Description
6 | 5 | 4 | =MOYENNE(Colonne1;Colonne2;Colonne3) | Moyenne des nombres des trois premières colonnes (5)
6 | 5 | 4 | =MOYENNE(SI(Colonne1>Colonne2; Colonne1-Colonne2; 10); Colonne3) | Si Colonne1 est supérieur à Colonne2, calculer la moyenne de la différence entre ces deux nombres et de Colonne3. Sinon calculer la moyenne de la valeur 10 et de Colonne3. (2,5)

Afficher Calculer la médiane de nombres

La médiane est la valeur qui se trouve au milieu d'une série ordonnée de nombres. Utilisez la fonction MEDIANE pour calculer la médiane d'un groupe de nombres.
A | B | C | D | E | F | Formule | Description
10 | 7 | 9 | 27 | 0 | 4 | =MEDIANE(A; B; C; D; E; F) | Médiane des nombres contenus dans les six premières colonnes (8)

Afficher Calculer le plus petit ou le plus grand nombre dans une série

Pour calculer le plus petit ou le plus grand nombre de deux colonnes ou plus d'une même ligne, utilisez les fonctions MIN et MAX.
Colonne1 | Colonne2 | Colonne3 | Formule | Description
10 | 7 | 9 | =MIN(Colonne1; Colonne2; Colonne3) | Plus petit nombre (7)
10 | 7 | 9 | =MAX(Colonne1; Colonne2; Colonne3) | Plus grand nombre (10)

Afficher Compter des valeurs

Pour compter des valeurs numériques, utilisez la fonction NB.
Colonne1 | Colonne2 | Colonne3 | Formule | Description
Pomme |  | 12/12/2007 | =NB(Colonne1; Colonne2; Colonne3) | Compte le nombre de colonnes contenant des valeurs numériques, y compris des valeurs de type date et heure. Exclut le texte et les valeurs null. (1)
12€ | #DIV/0! | 1,01 | =NB(Colonne1; Colonne2; Colonne3) | Compte le nombre de colonnes contenant des valeurs numériques, mais exclut les valeurs de type erreur et logique (2)

Afficher Augmenter ou diminuer un nombre d'un certain pourcentage

Utilisez l'opérateur Pourcentage (%) pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
23 | 3% | =Colonne1*(1+5%) | Augmente le nombre dans Column1 de 5% (24,15)
23 | 3% | =Colonne1*(1+Colonne2) | Augmente le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3% (23,69)
23 | 3% | =Colonne1*(1-Colonne2) | Diminue le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3% (22,31)

Afficher Élever un nombre à une puissance

Utilisez l'opérateur Exposant (^) ou la fonction PUISSANCE pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
5 | 2 | =Colonne1^Colonne2 | Calcule 5 au carré (25)
5 | 3 | =PUISSANCE(Colonne1; Colonne2) | Calcule 5 au cube (125)

Afficher Arrondir un nombre

Pour arrondir un nombre vers le haut, utilisez les fonctions ARRONDI.SUP, IMPAIR et PAIR.

Colonne1 | Formule | Description
20,3 | =ARRONDI.SUP(Colonne1;0) | Arrondit 20,3 vers le haut, à l'entier le plus proche (21)
-5,9 | =ARRONDI.SUP(Colonne1;0) | Arrondit -5,9 vers le haut (-6)
12,5493 | =ARRONDI.SUP(Colonne1;2) | Arrondit 12,5493 vers le haut, au centième le plus proche, avec deux décimales (12,55)
20,3 | =PAIR(Colonne1) | Arrondit 20,3 vers le haut, au nombre pair le plus proche (22)
20,3 | =IMPAIR(Colonne1) | Arrondit 20,3 vers le haut, au nombre impair le plus proche (21)

Pour arrondir un nombre vers le bas, utilisez la fonction ARRONDI.INF.

Colonne1 | Formule | Description
20,3 | =ARRONDI.INF(Colonne1;0) | Arrondit 20,3 vers le bas, à l'entier le plus proche (20)
-5,9 | =ARRONDI.INF(Colonne1;0) | Arrondit -5,9 vers le bas (-5)
12,5493 | =ARRONDI.INF(Colonne1;2) | Arrondit 12,5493 vers le bas, au centième le plus proche, avec deux décimales (12,54)

Pour arrondir un nombre vers le nombre ou la fraction décimale la plus proche, utilisez la fonction ARRONDI.

Colonne1 | Formule | Description
20,3 | =ARRONDI(Colonne1;0) | Arrondit 20,3 vers le bas, parce que la fraction décimale est inférieure à 0,5 (20)
5,9 | =ARRONDI(Colonne1;0) | Arrondit 5,9 vers le haut, parce que la fraction décimale est supérieure à 0,5 (6)
-5,9 | =ARRONDI(Colonne1;0) | Arrondit -5,9 vers le bas, parce que la fraction décimale est inférieure à 0,5 (-6)
1,25 | =ARRONDI(Colonne1; 1) | Arrondit le nombre au dixième le plus proche (une décimale). Comme la partie à arrondir est supérieure ou égale à 0,05, le nombre est arrondi vers le haut (résultat : 1,3)
30,452 | =ARRONDI(Colonne1; 2) | Arrondit le nombre au centième le plus proche (deux décimales). Comme la partie à arrondir, 0,002, est inférieure à 0,005, le nombre est arrondi vers le bas (résultat : 30,45)

Pour arrondir un nombre au chiffre significatif au dessus de 0, utilisez les fonctions ARRONDI, ARRONDI.SUP, ARRONDI.INF, ENT et NBCAR.

Colonne1 | Formule | Description
5 492 820 | =ARRONDI(Colonne1;3-NBCAR(ENT(Colonne1))) | Arrondit le nombre à trois chiffres significatifs (5 490 000)
22 230 | =ARRONDI.INF(Colonne1;3-NBCAR(ENT(Colonne1))) | Arrondit le nombre vers le bas, à trois chiffres significatifs (22 200)
5 492 820 | =ARRONDI.SUP(Colonne1; 5-NBCAR(ENT(Colonne1))) | Arrondit le nombre vers le haut à 5 chiffres significatifs (5 492 900)

Formules avec du texte

Afficher Changer la casse du texte

Utilisez les fonctions MAJUSCULE, MINUSCULE ou NOMPROPRE pour effectuer cette opération.
Colonne1 | Formule | Description
nancy Davolio | =MAJUSCULE(Colonne1) | Change le texte en majuscules (NANCY DAVOLIO)
nancy Davolio | =MINUSCULE(Colonne1) | Change le texte en minuscules (nancy davolio)
nancy Davolio | =NOMPROPRE(Colonne1) | Change le texte avec la 1ère lettre des mots en majuscule (Nancy Davolio)

Afficher Combiner le prénom et le nom

Utilisez l'opérateur « et commercial »(&) ou la fonction CONCATENER pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
Nancy | Fuller | =Colonne1&Colonne2 | Combine les deux chaînes (NancyFuller)
Nancy | Fuller | =Colonne1&" "&Colonne2 | Combine les deux chaînes, séparées par un espace (Nancy Fuller)
Nancy | Fuller | =Colonne2&","&Colonne1 | Combine les deux chaînes, séparées par une virgule (Fuller,Nancy)
Nancy | Fuller | =CONCATENER(Colonne2; ","; Colonne1) | Combine les deux chaînes, séparées par une virgule (Fuller,Nancy)

Afficher Combiner du texte et des nombres provenant de différentes colonnes

Utilisez les fonctions CONCATENER et TEXTE, et l'opérateur « et commercial » (&) pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
Dupont | 28 | =Colonne1&" vend "&Colonne2&" unités." | Combine le contenu de ces deux colonnes en une phrase (Dupont vend 28 unités.)
Durant | 40% | =Colonne1&" vend "&TEXTE(Colonne2;"0%")&" des ventes totales." | Combine le contenu de ces deux colonnes en une phrase (Durand vend 40% des ventes totales.). Remarque La fonction TEXTE ajoute la valeur formatée de Colonne2 au lieu de la valeur sous-jacente, qui est 0,4.
Dupont | 28 | =CONCATENER(Colonne1;" vend ";Colonne2;" unités.") | Combine le contenu de ces deux colonnes en une phrase (Dupont vend 28 unités.)

Afficher Combiner du texte avec une date ou une heure

Utilisez la fonction TEXTE et l'opérateur « et commercial » (&) pour effectuer cette opération.
Colonne1 | Colonne2 | Formule | Description
Date de facturation | 5-Juin-2007 | ="Date de facture : "&TEXTE(Colonne2; "j-mmm-aaaa") | Combine du texte avec une date (Date de facture : 5-Juin-2007)
Date de facturation | 5-Juin-2007 | =Colonne1&" "&TEXTE(Colonne2; "jj-mmm-aaaa") | Combiner du texte avec une date provenant d'une autre colonne en une seule colonne (Date de facturation 05-jun-2007)

Afficher Comparer le contenu de colonnes

Pour comparer une colonne à une autre colonne ou à une liste de valeurs, utilisez les fonctions EXACT et OU.
Colonne1 | Colonne2 | Formule | Description
BD122 | BD123 | =EXACT(Colonne1;Colonne2) | Comparer le contenu des deux premières colonnes (Non)
BD122 | BD123 | =EXACT(Colonne1; "BD122") | Comparer le contenu de Colonne1 avec la chaîne « BD122 » (Oui)
BD122 | BD123 | =OU(EXACT("BD121"; Colonne1; Colonne2) | Comparer la chaîne « BD121 » avec le contenu des deux premières colonnes (Non)

Afficher Vérifier si la valeur d'une colonne ou une partie de celle-ci correspond à du texte spécifique

Pour vérifier si la valeur d'une colonne ou une partie de celle-ci correspond à du texte spécifique, utilisez SI, TROUVE, CHERCHE et ESTNUM.

Colonne1 | Formule | Description
Davolio | =SI(Colonne1="Davolio"; "Oui"; "Non") | Vérifie si le contenu de Colonne1 est Davolio (Oui)
Davolio | =SI(ESTNUM(TROUVE("v";Colonne1)); "Oui"; "Non") | Vérifie si Colonne1 contient la lettre v (Oui)
BD123 | =ESTNUM(TROUVE("BD";Colonne1)) | Vérifie si Colonne1 contient BD (Oui)

Afficher Compter les colonnes non vides

Utilisez la fonction NBVAL pour effectuer cette opération.
Colonne1 | Colonne2 | Colonne3 | Formule | Description
Ventes | 19 |  | =NBVAL(Colonne1; Colonne2) | Compte le nombre de colonnes non vides (2)
Ventes | 19 |  | =NBVAL(Colonne1; Colonne2; Colonne3) | Compte le nombre de colonnes non vides (2)

Afficher Supprimer des caractères dans du texte

Utilisez les fonctions NBCAR, GAUCHE et DROITE pour effectuer cette opération.
Colonne1 | Formule | Description
Vitamine A | =GAUCHE(Colonne1;NBCAR(Colonne1)-2) | Renvoie 8 (10-2) caractères à partir de la gauche (Vitamine)
Vitamine B1 | =DROITE(Colonne1; NBCAR(Colonne1)-9) | Renvoie 2 (11-9) caractères à partir de la droite (B1)

Afficher Supprimer des espaces du début et de la fin d'une colonne

Utilisez la fonction SUPPRESPACE pour effectuer cette opération.
Colonne1 | Formule | Description
Bonjour ! | =SUPPRESPACE(Colonne1) | Supprimer les espaces du début et de la fin (Bonjour !)

Afficher Répéter un caractère dans une colonne

Utilisez la fonction REPT pour effectuer cette opération.
Formule | Description
=REPT(".";3) | Répète un point 3 fois (...)
=REPT("-";10) | Répète un tiret 10 fois (----------)

Autres formules

Afficher Masquer des valeurs d'erreur dans des colonnes

Pour afficher un tiret, #N/A ou NA à la place d'une valeur d'erreur, utilisez la fonction ESTERREUR.
Colonne1 | Colonne2 | Formule | Description
10 | 0 | =Colonne1/Colonne2 | Génère une erreur (#DIV/0)
10 | 0 | =SI(ESTERREUR(Colonne1/Colonne2);"NA";Colonne1/Colonne2) | Renvoie NA lorsque la valeur est une erreur
10 | 0 | =SI(ESTERREUR(Colonne1/Colonne2);"-";Colonne1/Colonne2) | Renvoie un tiret lorsque la valeur est une erreur


Afficher ou masquer des valeurs de regroupement

  • Pour afficher ou masquer des valeurs agrégées de toutes les colonnes de la liste, cliquez sur l’onglet Liste puis, dans le groupe Feuille de données, cliquez sur Afficher les totaux.

    La ligne Total apparaît au bas de la liste. Elle affiche la somme des valeurs pour les colonnes numériques ; si la liste ne contient pas de colonnes numériques, elle affiche le nombre de lignes non vides dans la dernière colonne de la liste. Si la ligne est visible au moment où vous cliquez sur Afficher les totaux, cette ligne devient alors masquée.

  • Pour afficher ou masquer des valeurs de regroupement pour une ou plusieurs colonnes de la liste, procédez comme suit :
    1. Cliquez sur une cellule dans la ligne Total.
    2. Cliquez sur la flèche vers le bas qui s’affiche dans la cellule.
    3. Dans la liste déroulante des fonctions de regroupement, sélectionnez Aucune pour masquer la valeur totale. Sélectionnez une fonction autre que Aucune pour afficher une valeur totale.


Résolution des problèmes liés aux totaux et aux valeurs calculées

Affichage d’un message indiquant que les résultats de la formule vont être envoyés au serveur

Erreur de syntaxe

La cellule affiche la formule au lieu de son résultat

Affichage d’un message indiquant des modifications en attente lors de la modification d’une colonne calculée

Erreur de délai d’expiration ou erreur inattendue

Affichage d’un message indiquant que la structure de la liste a changé

Affichage d’un message d’erreur indiquant l’absence d’autorisation pour modifier des colonnes calculées dans la liste

Modification impossible d’une formule parce que une ou plusieurs autres colonnes requièrent des valeurs

Message d’erreur indiquant qu’une ou plusieurs références de colonnes ne sont pas autorisées

Message d’erreur indiquant qu’une colonne n’existe pas

Impossible de sélectionner une colonne spécifique lors de la modification d’une colonne calculée

Les cellules d’une colonne calculée affichent « #NOM? »

Les cellules d’une colonne calculée affichent « #CIRC! »

Les cellules d’une colonne calculée affichent « #VALEUR! »

Les cellules d’une colonne calculée affichent « #NOMBRE! »

Les cellules d’une colonne calculée affichent « #DIV/0! »

Les cellules d’une colonne calculée affichent « #NUL! »

Les cellules d’une colonne calculée affichent « #N/A! »

Affichage d’un message indiquant que les résultats de la formule vont être envoyés au serveur

Vous avez édité la formule, et la liste tente d'envoyer les nouveaux résultats au serveur. Effectuez une des actions suivantes :

  • Cliquez sur Continuer pour mettre fin à l'opération de modification. S'il y a des modifications, des conflits ou des erreurs en attente, la liste vous invite à effectuer les actions appropriées.
  • Cliquez sur Annuler pour revenir à la cellule contenant la formule.

Haut de la page

Erreur de syntaxe

Ce peut être à cause d'une ou plusieurs des raisons suivantes :

  • Les parenthèses utilisées dans la formule sont en nombre impair. Vérifiez qu'à chaque parenthèse ouvrante correspond une parenthèse fermante.
  • La formule comprend un caractère spécial autre que le signe Égal (=) et les opérateurs de calcul.
  • La formule appelle une ou plusieurs fonctions, mais vous avez spécifié un nombre d'arguments incorrect pour une ou plusieurs de ces fonctions.
  • La formule utilise une fonction qui n'est pas prise en charge par une liste. En particulier, les listes ne prennent pas en charge les fonctions ALEA et MAINTENANT. Vous ne pouvez pas utiliser les fonctions AUJOURDHUI et MOI dans une colonne calculée, mais vous pouvez les utiliser pour spécifier la valeur par défaut d'une colonne.

Haut de la page

La cellule affiche la formule au lieu de son résultat

Vérifiez que la cellule qui contient la formule fait bien partie d'une colonne calculée. Si vous entrez une formule dans une colonne autre qu'une colonne calculée, comme une colonne de type Une seule ligne de texte, la liste va traiter la formule comme une chaîne de texte et l'afficher telle quelle.

Haut de la page

Affichage d’un message indiquant des modifications en attente lors de la modification d’une colonne calculée

Toute modification apportée à une colonne calculée se traduit par une modification de structure de la liste. Vous pouvez apporter des modifications structurelles à une liste seulement s'il n'y a pas de modifications, de conflits ou d'erreurs en attente. S'il y en a, vous êtes invité à attendre que toutes les modifications soient envoyées au serveur, et à résoudre tous les conflits ou erreurs avant de pouvoir ajouter ou modifier une colonne.

Haut de la page

Erreur de délai d'expiration ou erreur inattendue.

Actualisez la liste et refaites la modification que vous avez apportée à la colonne calculée.

Haut de la page

Affichage d’un message indiquant que la structure de la liste a changé

La modification d'une colonne calculée se traduit par une modification de structure de la liste. Si la liste fait l'objet d'un conflit entre votre modification et un changement de structure effectué par un autre utilisateur, vous êtes invité à actualiser la liste. L'actualisation de la liste met à jour votre affichage, mais ignore les modifications que vous avez apportées à la colonne calculée. Essayez de recommencer votre modification.

Haut de la page

Affichage d’un message d’erreur indiquant l’absence d’autorisation pour modifier des colonnes calculées dans la liste

La modification d'une colonne calculée se traduit par une modification de structure de la liste. Si vous ne disposez pas des autorisations nécessaires pour modifier la structure d'une liste, vous ne pouvez pas modifier des colonnes calculées dans la liste.

Haut de la page

Modification impossible d’une formule parce que une ou plusieurs autres colonnes requièrent des valeurs

La liste doit valider toutes vos modifications avant de permettre la modification d'une formule. Une ligne ne peut pas être validée si une de ses colonnes définie comme colonne requise est laissée vide. Entrez des valeurs valides dans toutes les colonnes requises, puis essayez à nouveau de modifier une formule.

Haut de la page

Message d’erreur indiquant qu’une ou plusieurs références de colonnes ne sont pas autorisées

La formule comprend une référence à une colonne dont le type de données ne prend pas en charge les calculs. Modifiez la formule pour y supprimer les références aux colonnes non prises en charge.

Haut de la page

Message d’erreur indiquant qu’une colonne n’existe pas

Vous avez spécifié une chaîne comme opérande, mais la liste n'a pas pu trouver une colonne dont le nom correspond à la chaîne. Effectuez une des actions suivantes :

  • Vérifiez que les colonnes référencées dans la formule existent.
  • Vérifiez que les noms des colonnes sont placés entre crochets ([]) s'ils comprennent des espaces ou des caractères spéciaux.
  • Vérifiez que les libellés des références de colonnes sont corrects.

Haut de la page

Impossible de sélectionner une colonne spécifique lors de la modification d’une colonne calculée

Après avoir tapé le signe Égal (=) dans une colonne calculée, vous pouvez coller une référence de colonne simplement en cliquant sur la cellule de cette colonne qui appartient à la ligne courante. Cependant, si la colonne est d'un type de données qui ne prend pas en charge les calculs, ou bien si vous tentez de sélectionner une cellule d'une autre ligne ou de sélectionner plusieurs cellules, la liste ne va pas coller la référence de colonne dans la formule.

Haut de la page

Les cellules d’une colonne calculée affichent « #NOM? »

Une colonne référencée dans une formule n'existe plus. Ajoutez la colonne à la liste ou bien modifiez la formule pour y supprimer la référence.

Haut de la page

Les cellules d’une colonne calculée affichent « #CIRC! »

L'erreur est provoquée par une ou plusieurs références circulaires. Une référence circulaire se produit dans les situations suivantes :

  • La formule utilisée dans la colonne comprend une référence à elle-même. Par exemple, la formule utilisée pour calculer la colonne Revenu imposable contient une référence à la colonne Revenu imposable.
  • Deux colonnes ou plus se référencent mutuellement. Par exemple, la colonne Calcul1 utilise la formule =[Calcul2]+2 et la colonne Calcul2 utilise la formule =[Calcul1]-1.
Pour supprimer une référence circulaire, effectuez une ou plusieurs des actions suivantes :
  • Vérifiez que la formule ne référence pas la colonne qui contient la formule.
  • Si la formule référence une autre colonne, vérifiez que la formule de la colonne référencée ne référence pas la première colonne.
  • Vérifiez que les libellés des références de colonnes sont corrects.

Haut de la page

Les cellules d’une colonne calculée affichent « #VALEUR! »

Cette erreur peut se produire dans l'une des deux situations suivantes :

  • Un type d'opérande incorrect est utilisé dans la formule.
  • Un type d'argument incorrect est spécifié pour une fonction qui est utilisée dans la formule.
Vérifiez le type de données des opérandes et des arguments.

Haut de la page

Les cellules d’une colonne calculée affichent « #NOMBRE! »

Cette erreur se produit lorsque la formule comprend des valeurs numériques non valides, comme dans les cas suivants :

  • La valeur renvoyée par la formule est trop grande pour être représentée dans une liste.
  • La formule a rencontré une valeur de date qui est antérieure au 1/1/1900.
  • Une fonction utilisée dans la formule attend un argument numérique, mais vous avez spécifié un argument non numérique. Un type d'argument incorrect est spécifié pour une fonction qui est utilisée dans la formule.

Haut de la page

Les cellules d’une colonne calculée affichent « #DIV/0! »

Cette erreur se produit lorsqu'un nombre est divisé par zéro (0), comme dans les cas suivants :

  • Spécification explicite d'une division par zéro (0), comme =133/0.
  • La formule comprend des références de colonnes et, au moment de l'évaluation, les valeurs des colonnes référencées provoquent une division par zéro (0). Par exemple, les colonnes [Compte1] et [Compte2] ont les mêmes valeurs dans les mêmes lignes : la formule =[Qté]/[Compte1]-[Compte2] provoque donc une erreur pour ces lignes.

Haut de la page

Les cellules d’une colonne calculée affichent « #NUL! »

Cette erreur se produit lorsqu'un argument ou une opérande spécifiés dans une formule ont une valeur Null. Si un seul élément d'une formule a une valeur Null, c'est toute la formule qui aboutit à une valeur Null. Pour éviter cette erreur, vérifiez que les valeurs Null sont remplacées par zéro (0). Vous pouvez également changer le paramétrage des colonnes référencées en Requise, pour que toutes les lignes aient une valeur différente de Null.

Haut de la page

Les cellules d’une colonne calculée affichent « #N/A! »

Cette erreur se produit lorsqu'une valeur est manquante dans une fonction. Vérifiez que vous avez spécifié tous les paramètres requis par la fonction.

Haut de la page


Fonctions

Les fonctions sont des formules prédéfinies qui effectuent des calculs en utilisant des valeurs spécifiques, appelées arguments, dans un ordre particulier, ou structure. Les fonctions peuvent être utilisées pour effectuer des calculs simples ou complexes. Par exemple, la fonction ARRONDI arrondit un nombre de la colonne Coût.

=ARRONDI(Coût, 2)

Principaux problèmes liés à l'utilisation d'une fonction :

  • Structure La structure d'une fonction commence par un signe Égal (=), suivi du nom de la fonction, d'une parenthèse ouvrante, des arguments de la fonction séparés par des virgules et d'une parenthèse fermante.
  • Nom de la fonction Nom d'une fonction qui est prise en charge par les listes. Chaque fonction prend un nombre déterminé d'arguments, les traite et renvoie une valeur.
  • Arguments Les arguments peuvent être des nombres, du texte, des valeurs logiques comme Vrai ou Faux ou bien des références de colonnes. L'argument que vous indiquez doit produire une valeur valide pour cet argument. Les arguments peuvent également être des constantes, des formules ou d'autres fonctions.
  • Info-bulle d'argument Une info-bulle avec la syntaxe et les arguments apparaît lorsque vous tapez la fonction. Par exemple, tapez =ARRONDI( et l'info-bulle apparaît. Les info-bulles apparaissent seulement pour les fonctions prédéfinies.

Remarque Les listes ne prennent pas en charge les fonctions ALEA et MAINTENANT. Les fonctions AUJOURDHUI et MOI ne sont pas prises en charge dans des colonnes calculées, mais elles peuvent être utilisées dans la définition d'une valeur par défaut pour une colonne.

Haut de la page

Fonctions imbriquées

Dans certains cas, vous pouvez être amené à utiliser une fonction comme argument d'une autre fonction. Par exemple, la formule suivante utilise la fonction MOYENNE et compare le résultat avec la somme des valeurs de deux colonnes.

=MOYENNE([Coût1], SOMME([Coût2]+[Remise]))

Renvois valides Lorsqu'une fonction est utilisée comme argument, elle doit renvoyer une valeur du même type que celui utilisé par l'argument. Par exemple, si l'argument utilise Oui ou Non, la fonction imbriquée doit renvoyer Oui ou Non. Si ce n'est pas le cas, la liste affiche une valeur d'erreur #VALEUR!.

Limites des niveaux d'imbrication Une formule peut contenir jusqu'à huit niveaux de fonctions imbriquées. Lorsque la Fonction B est utilisée comme argument dans la Fonction A, la Fonction B est une fonction de deuxième niveau. Par exemple, la fonction SOMME est une fonction de deuxième niveau puisqu'elle est un argument de la fonction MOYENNE. Une fonction imbriquée dans la fonction SOMME serait alors une fonction de troisième niveau, etc.

Haut de la page


Ajout ou modification d'une colonne calculée

Vous pouvez ajouter une colonne qui calcule des valeurs pour chaque ligne en fonction d'autres valeurs de la même ligne.

Ajout d'une colonne calculée

  1. Dans le Ruban, cliquez sur l’onglet Liste puis, dans le groupe Paramètres, cliquez sur Créer une colonne.
  2. Dans la page Créer une colonne, spécifiez le nom de la colonne.
  3. Sélectionnez Calculé comme type d'information à stocker dans la colonne.
  4. Dans la zone de texte Formule, tapez une nouvelle formule. Pour insérer des références à des colonnes, sélectionnez une colonne dans la liste Insérer une colonne, puis cliquez sur Ajouter à la formule.
  5. Spécifiez le format de la valeur que va renvoyer la formule ainsi que d'autres paramètres qui s'y rapportent.

Modification d'une colonne calculée

  1. Cliquez avec le bouton droit sur la colonne, puis cliquez sur Modifier/Supprimer une colonne.
  2. Dans la zone de texte Formule, modifiez la formule existante. Pour insérer des références à des colonnes, sélectionnez une colonne dans la liste Insérer une colonne, puis cliquez sur Ajouter à la formule.
  3. Spécifiez le format de la valeur que va renvoyer la formule ainsi que d'autres paramètres qui s'y rapportent.

Remarques

  • L'ajout ou la modification d'une colonne entraîne une modification de la structure de la liste. Vous pouvez apporter des modifications structurelles à une liste s'il n'existe aucune modification, aucun conflit ou aucune erreur en attente. S'il en existe, vous êtes invité à attendre que toutes les modifications soient soumises au serveur, et à résoudre tous les conflits ou erreurs avant de pouvoir ajouter ou modifier une colonne.
  • Vous ne pouvez pas changer le type de données d'une colonne en Calculé. Pour utiliser une formule dans une colonne non calculée, vous devez supprimer la colonne puis ajouter une colonne calculée.


Modifier le type de la valeur de total affichée dans une colonne

  1. Cliquez sur la ligne des totaux de la colonne pour laquelle vous voulez modifier le type de total.
  2. Cliquez sur la flèche pointant vers le bas et sélectionnez la fonction de votre choix dans la liste.

    Modifier les totaux

Remarque La sélection de l'option Aucune dans la liste pour une colonne entraîne la désactivation de la valeur de total pour cette colonne.


DATE

Renvoie le numéro de série séquentiel qui représente une date donnée.

Syntaxe

DATE(année;mois;jour)

année L'argument représentant l'année peut comprendre de 1 à 4 chiffres.

  • Si année est compris entre 0 (zéro) et 1899 (incluse), la valeur est ajoutée à 1900 pour calculer l'année. Par exemple,

    DATE(108,1,2)
    renvoie 2 janvier 2008 (1900+108).

  • Si année est compris entre 1900 et 9999 (incluse), la valeur est utilisée telle quelle. Par exemple,

    DATE(2008,1,2)
    renvoie 2 janvier 2008.

mois est un nombre représentant le mois de l'année. Si mois est supérieur à 12, ce nombre de mois est ajouté au premier mois de l'année spécifiée. Par exemple,

DATE(2008,14,2)
renvoie le numéro de série représentant le 2 février 2009.

jour est un nombre représentant le jour du mois. Si jour est supérieur au nombre de jours dans le mois spécifié, ce nombre de jours est ajouté au premier jour du mois. Par exemple,

DATE(2008,1,35)
renvoie le numéro de série représentant le 4 février 2008.

Remarques

  • Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.
  • La fonction DATE est principalement utilisée dans des formules où année, mois et jour sont des formules et pas des constantes.

Exemple

année | mois | jour | Formule | Description (résultat)
2008 | 1 | 1 | =DATE([année];[mois];[jour]) | Date sous forme de numéro de série pour la date (1/1/2008 ou 39448)


DATEDIF

Calcule le nombre de jours, de mois ou d'années entre deux dates. Cette fonction est fournie pour des raisons de compatibilité avec Lotus 1-2-3.

Syntaxe

DATEDIF(date_début;date_fin;unité)

date_début Une date qui représente la première date, ou date de début, de la période. Les dates peuvent être entrées comme des chaînes de texte entre guillemets (par exemple "2001/1/30"), comme des numéros de série (par exemple 36 921, qui représente le 30 janvier 2001, si vous utilisez le système de date 1900), ou comme le résultat d'autres formules ou fonctions (par exemple, DATEVAL("2001/1/30")).

date_fin Une date qui représente la dernière date, ou date de fin, de la période.

unité Le type d'information que vous voulez obtenir :

unité | renvoie
"A" | Le nombre d'années entières dans la période.
"M" | Le nombre de mois entiers dans la période.
"J" | Le nombre de jours dans la période.
"MJ" | La différence entre les jours dans date_début et date_fin. Les mois et les années des dates sont ignorés.
"AM" | La différence entre les mois dans date_début et date_fin. Les jours et les années des dates sont ignorés.
"AJ" | La différence entre les jours de date_début et de date_fin. Les années des dates sont ignorées.

Remarques

  • Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.
  • La fonction DATEDIF est utilisée dans des formules où il faut calculer un âge.

Exemple

date_début | date_fin | Formule | Description (résultat)
1/1/2001 | 1/1/2003 | DATEDIF(date_début;date_fin;"A") | Deux années entières dans la période (2)
1/6/2001 | 15/8/2002 | DATEDIF(date_début;date_fin;"J") | 440 jours entre le 1er juin 2001 et le 15 août 2002 (440)
01/06/2001 | 15/8/2002 | DATEDIF(date_début;date_fin;"AJ") | 75 jours entre le 1er juin et le 15 août, en ignorant les années des dates (75)
01/06/2001 | 15/8/2002 | DATEDIF(date_début;date_fin;"MJ") | La différence entre 1 et 15 - le jour de Date_début et le jour de Date_fin - en ignorant les mois et les années des dates (14)


DATEHEURE

La fonction DATEHEURE est une combinaison des fonctions DATE et TEMPS.

DATE Renvoie le numéro de série séquentiel qui représente une date donnée.

TEMPS renvoie la représentation décimale de l’heure avec une valeur comprise entre 0 (zéro) et 0,99999999, qui représente l’heure, de 0:00:00 (12:00:00 AM) à 23:59:59 (11:59:59 PM).

Syntaxe

DATEHEURE(année,mois,jour,heure,minute,seconde)

Année L’argument Année peut comporter un à quatre chiffres. Vous ne pouvez pas utiliser une année antérieure à 1900. Si l’argument Année est compris entre 0 (zéro) et 1899, la valeur est ajoutée à 1900 pour calculer l’année. Par exemple, DATEHEURE(108,1,2,n,n,n) renvoie la date comme 39.449 ; qui est le numéro de série représentant le 2 janvier 2008 (1900 + 108). Si l’argument Année est compris entre 1900 et 9999, la valeur est considérée comme celle de l’année. Par exemple, DATEHEURE(2008,1,2,n,n,n) renvoie également la date comme 39.449.

Mois est un nombre représentant le mois de l’année. Si mois est supérieur à 12, ce nombre de mois est ajouté au premier mois de l’année spécifiée. Par exemple, DATEHEURE(2008,14,2,n,n,n) renvoie le numéro de série représentant le 2 février 2009.

Jour est un nombre représentant le jour du mois. Si jour est supérieur au nombre de jours dans le mois spécifié, ce nombre de jours est ajouté au premier jour du mois. Par exemple, DATE(2008,1,35) renvoie le numéro de série représentant le 4 février 2008.

Heure représente un nombre compris entre 0 (zéro) et 32767 indiquant l’heure. Toute valeur supérieure à 23 sera divisée par 24 et le reste sera traité comme la valeur horaire. Par exemple, DATEHEURE(n,n,n ,27,0,0) renvoie l’heure comme .125 ou 03:00 (03:00 AM).

Minute représente un nombre compris entre 0 et 32767 indiquant les minutes. Toute valeur supérieure à 59 sera convertie en heures et en minutes. Par exemple, DATEHEURE(n,n,n ,0,750,0) renvoie l’heure sous la forme .520833 ou 12:30 (12:30 PM).

Seconde représente un nombre compris entre 0 et 32767 indiquant les secondes. Toute valeur supérieure à 59 sera convertie en heures, en minutes et en secondes. Par exemple, DATEHEURE(n,n,n 0,0,2000) renvoie l’heure sous la forme .023148 ou 12:33:20 (12:33:20 PM).

Notes

Les dates sont stockées sous forme de numéros de série séquentiels afin de pouvoir être utilisées dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se trouve 39 448 jours après le 1er janvier 1900.

Exemple

Année | Mois | Jour | Heure | Minute | Seconde | Formule | Description
2006 | 12 | 1 | 12 | 45 | 25 | =DATEHEURE([Année],[Mois],[Jour],[Heure],[Minute],[Seconde]) | Numéro de série pour la date et la représentation décimale de l’heure du jour (39,052.5315393519)

Haut de la page


DATEVAL

Renvoie le numéro de série d'une date représentée par date_texte. Utilisez DATEVAL pour convertir une date représentée par du texte en un numéro de série.

Syntaxe

DATEVAL(date_texte)

date_texte est un texte qui représente une date au format date. Par exemple, "30/1/2008" ou "30-Jan-2008" sont des chaînes de texte entre guillemets qui représentent des dates.

Si la partie Année de date_texte est omise, DATEVAL utilise l'année en cours provenant de l'horloge de votre serveur. Les informations relatives à l'heure dans date_texte sont ignorées.

Remarques

  • Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.
  • La plupart des fonctions convertissent automatiquement les valeurs de type date en numéros de série.

Exemple

Formule | Description (résultat)
=DATEVAL("22/8/2008") | Numéro de série de la date texte (39 682)
=DATEVAL("22-AOU-2008") | Numéro de série de la date texte (39 682)
=DATEVAL("2008/02/23") | Numéro de série de la date texte (39 501)
=DATEVAL("5-JUL") | Numéro de série de la date texte, dans le cas où l'horloge de l'ordinateur est définie à 2000 (37 807)


JOUR

Renvoie le jour d'une date, représentée par un numéro de série. Le jour est représenté par un entier compris entre 1 et 31.

Syntaxe

JOUR(numéro_série)

numéro_série représente la date du jour que vous recherchez.

Remarques

  • Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.
  • Les valeurs renvoyées par les fonctions ANNEE, MOIS et JOUR sont des valeurs grégoriennes, quel que soit le format d'affichage de la valeur date donnée en argument. Par exemple, si le format d'affichage de la date donnée en argument est Hijri (calendrier islamique), les valeurs renvoyées pour les fonctions ANNEE, MOIS et JOUR sont des valeurs associées à la date grégorienne équivalente.

Exemple

Formule | Description (résultat)
=JOUR("15-Avr-2008") | Jour de la date (15)


JOURS360

Renvoie le nombre de jours entre deux dates sur la base d'une année de 360 jours (douze mois de 30 jours), qui est utilisée dans certains calculs comptables. Utilisez cette fonction pour faciliter les paiements informatisés, si votre système comptable est basé sur douze mois de 30 jours.

Syntaxe

JOURS360(date_début;date_fin;méthode)

date_début et date_fin sont deux dates dont vous voulez connaître le nombre de jours qui les séparent. Si date_début est postérieure à date_fin, JOURS360 renvoie un nombre négatif.

méthode est une valeur logique qui spécifie s'il faut utiliser la méthode US ou européenne dans le calcul.

Méthode | Définie
FAUX ou omise | Méthode U.S. (NASD). Si la date de début est le 31 d'un mois, cette date devient égale au 30 du même mois. Si la date de fin est le 31 d'un mois et que la date de début est antérieure au 30 d'un mois, la date de fin devient égale au 1er du mois suivant ; sinon, la date de fin devient égale au 30 du même mois.
VRAI | Méthode européenne. Les dates de début et les dates de fin qui sont un 31 d'un mois deviennent égales au 30 du même mois.

Remarque

Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.

Exemple

Col1 | Col2 | Formule | Description (résultat)
30/01/2008 | 01/02/2008 | =JOURS360([Col1];[Col2]) | Nombre de jours entre les deux dates, sur la base d'une année de 360 jours (1)


HEURE

Renvoie l'heure d'une valeur de type heure. L'heure est donnée sous la forme d'un nombre entier, entre 0 (00:00) et 23 (23:00).

Syntaxe

HEURE(numéro_de_série)

numéro_de_série représente l'heure qui contient la partie heure que vous recherchez. Les heures peuvent être entrées sous forme de chaînes de texte entre guillemets (par exemple, "18:45"), de nombres décimaux (par exemple, 0,78125, qui représente 18:45) ou de résultats d'autres formules ou d'autres fonctions (par exemple, TEMPSVAL("18:45")).

Remarque

Les valeurs heure constituent une partie d'une valeur de type date et sont représentées par un nombre décimal (par exemple, 12:00 est représenté par 0,5 parce que c'est la moitié d'une journée).

Exemple

Formule | Description (résultat)
=HEURE("3:30:30") | Partie heure de l'heure (3)
=HEURE("15:30:30") | Partie heure de l'heure (15)
=HEURE("15:30") | Partie heure de l'heure (15)


MINUTE

Renvoie les minutes d'une valeur de type heure. La minute est donnée sous la forme d'un entier, entre 0 et 59.

Syntaxe

MINUTE(numéro_de_série)

numéro_de_série est l'heure qui contient la partie minute que vous recherchez. Les heures peuvent être entrées sous forme de chaînes de texte entre guillemets (par exemple, "18:45"), de nombres décimaux (par exemple, 0,78125, qui représente 18:45) ou de résultats d'autres formules ou d'autres fonctions (par exemple, TEMPSVAL("18:45")).

Remarques

Les valeurs heure constituent une partie d'une valeur de type date et sont représentées par un nombre décimal (par exemple, 12:00 est représenté par 0,5 parce que c'est la moitié d'une journée).

Exemple

Formule | Description (résultat)
=MINUTE("16:48:00") | Minutes de l'heure (48)


MOIS

Renvoie le mois d'une date, représentée par un numéro de série. Le mois est représenté par un entier compris entre 1 (janvier) et 12 (décembre).

Syntaxe

MOIS(numéro_de_série)

numéro_de_série est la date du mois que vous recherchez.

Remarques

Les dates sont stockées comme des numéros de série séquentiels, ce qui permet de les utiliser dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se situe 39 448 jours après le 1er janvier 1900.

Les valeurs renvoyées par les fonctions ANNEE, MOIS et JOUR sont des valeurs grégoriennes, quel que soit le format d'affichage de la valeur date donnée en argument. Par exemple, si le format d'affichage de la date donnée en argument est Hijri (calendrier islamique), les valeurs renvoyées pour les fonctions ANNEE, MOIS et JOUR sont des valeurs associées à la date grégorienne équivalente.

Exemple

Formule | Description (résultat)
=MOIS("15-Avr-2008") | Mois de la date (4)


MAINTENANT.HEURE

Renvoie la représentation décimale de l’heure courante. Le nombre décimal renvoyé par MAINTENANT.HEURE est une valeur comprise entre 0 (zéro) et 0,99999999, représentant les heures comprises entre 0:00:00 (12:00:00 AM) et 23:59:59 (11:59:59 P.M.).

Remarque MAINTENANT.HEURE renvoie uniquement l’heure actuelle. Pour utiliser une fonction pour une heure précise, utilisez la fonction TEMPS. Pour plus d’informations, consultez la rubrique Fonction TEMPS.

Syntaxe

MAINTENANT.HEURE()

Note

La syntaxe de la fonction MAINTENANT.HEURE ne comporte aucun argument. Vous devez joindre les parenthèses vides au nom de la fonction. Sans cela, Microsoft SharePoint Foundation 2010 ne la reconnaîtra pas en tant que fonction.


SECONDE

Renvoie les secondes d'une valeur de temps. Les secondes sont représentées par un nombre entier compris entre 0 (zéro) et 59.

Syntaxe

SECONDE(numéro_de_série)

numéro_de_série est la valeur de l'heure dont vous voulez trouver les secondes. Les valeurs d'heure peuvent être entrées sous la forme de chaînes de texte entre guillemets (par exemple, "18:45"), de caractères décimaux (par exemple, 0,78125, qui représente 18:45) ou de résultats d'autres formules ou fonctions (par exemple, TEMPSVAL("18:45")).

Remarque

Une valeur d'heure est une partie d'une valeur de date représentée par un nombre décimal (par exemple, 12:00 est représenté par 0,5 car il s'agit du milieu de la journée).

Exemple

Formule | Description
=SECONDE("16:48:18") | Secondes dans l'heure (18)
=SECONDE("16:48") | Secondes dans l'heure (0)


TEMPS

Renvoie le nombre décimal correspondant à une certaine heure. Le nombre décimal renvoyé par la fonction TEMPS est une valeur comprise entre 0 (zéro) et 0,99999999, représentant les heures comprises entre 0:00:00 (12:00:00 AM) et 23:59:59 (11:59:59 P.M.).

Syntaxe

TEMPS(heure;minute;seconde)

heure représente un nombre compris entre 0 (zéro) et 32 767 indiquant l'heure. Toute valeur supérieure à 23 est divisée par 24 et le reste est traité comme la valeur horaire. Par exemple, TEMPS(27;0;0) = TEMPS(3;0;0) = 0,125 ou 03:00 (03:00 AM).

minute représente un nombre compris entre 0 et 32 767 indiquant les minutes. Toute valeur supérieure à 59 est convertie en heures et en minutes. Par exemple, TEMPS(0;750;0) = TEMPS (12;30;0) = 0,520833 ou 12:30 (12:30 PM).

seconde représente un nombre compris entre 0 et 32 767 indiquant les secondes. Toute valeur supérieure à 59 est convertie en heures, minutes et secondes. Par exemple, TEMPS(0;0;2000) = TEMPS(0;33;22) = 0,023148 ou 00:33:20 (12:33:20 AM)

Remarque

Une valeur d'heure est une partie d'une valeur de date représentée par un nombre décimal (par exemple, 12:00 est représenté par 0,5 car il s'agit du milieu de la journée).

Exemple

Heure | Minute | Seconde | Formule | Description (résultat)
12 | 0 | 0 | =TEMPS([Heure];[Minute];[Seconde]) | Représentation décimale de l'heure du jour, pour l'heure spécifiée (0,5)
16 | 48 | 10 | =TEMPS([Heure];[Minute];[Seconde]) | Représentation décimale de l'heure du jour, pour l'heure spécifiée (0,700115741)


TEMPSVAL

Renvoie le nombre décimal de l'heure représentée par une chaîne de texte. Ce nombre décimal est une valeur comprise entre 0 (zéro) et 0,99999999, qui représente l'heure, de 0:00:00 (12:00:00 AM) à 23:59:59 (11:59:59 PM).

Syntaxe

TEMPSVAL(heure_texte)

heure_texte est une chaîne de texte qui représente une heure dans n'importe quel format d'heure de la feuille de calcul ; par exemple, des chaînes de texte "6:45 PM" et "18:45" entre guillemets qui représentent l'heure.

Remarque

  • Les informations de date figurant dans l'argument heure_texte ne sont pas prises en compte.

Exemple

Formule | Description (résultat)
=TEMPSVAL("2:24") | Partie décimale d'un jour, pour l'heure spécifiée (0,1)
=TEMPSVAL("22-Aoû-2008 6:35") | Partie décimale d'un jour, pour l'heure spécifiée (0,274305556)


AUJOURDHUI

Renvoie le numéro de série de la date du jour. Le numéro de série est le code de date et d'heure utilisé pour les calculs de date et d'heure.

Remarque Vous pouvez utiliser la fonction AUJOURDHUI seulement pour spécifier une valeur par défaut. Vous ne pouvez pas l'utiliser dans une colonne calculée.

Syntaxe

AUJOURDHUI

Remarque

Les dates sont stockées sous forme de numéros de série séquentiels afin de pouvoir être utilisées dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se trouve 39 448 jours après le 1er janvier 1900.


JOURSEM

Renvoie le jour de la semaine correspondant à une date. Par défaut, le jour est donné sous forme d'un nombre entier compris entre 0 et 7.

Syntaxe

JOURSEM(numéro_de_série;type_retour)

numéro_de_série est un numéro séquentiel représentant la date du jour que vous cherchez.

type_retour est le chiffre qui détermine le type de la valeur renvoyée.

Argument type_retour | Numéro renvoyé
1 ou omis | Numéros de 1 (dimanche) à 7 (samedi).
2 | Numéros de 1 (lundi) à 7 (dimanche).
3 | Numéros de 0 (lundi) à 6 (dimanche).

Note

Les dates sont stockées sous forme de numéros de série séquentiels afin de pouvoir être utilisées dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se trouve 39 448 jours après le 1er janvier 1900.

Exemple

Formule | Description (résultat)
=JOURSEM("14/2/2008") | Jour de la semaine, avec des numéros de 1 (dimanche) à 7 (samedi) (5)
=JOURSEM("14/2/2008";2) | Jour de la semaine, avec des numéros de 1 (lundi) à 7 (dimanche) (4)
=JOURSEM("14/2/2008";3) | Jour de la semaine, avec des numéros de 0 (lundi) à 6 (dimanche) (3)

Remarque Le 14/2/2008 est un mardi.


ANNEE

Renvoie l'année correspondant à une date.

Syntaxe

ANNEE(numéro_de_série)

numéro_de_série représente la date de l'année que vous souhaitez rechercher.

Remarque

Les dates sont stockées sous forme de numéros de série séquentiels afin de pouvoir être utilisées dans des calculs. Par défaut, le 31 décembre 1899 a le numéro de série 1 et le 1er janvier 2008 a le numéro de série 39 448 parce que cette date se trouve 39 448 jours après le 1er janvier 1900.

Les valeurs renvoyées par les fonctions ANNEE, MOIS et JOUR sont des valeurs grégoriennes, quel que soit le format d'affichage pour la valeur de date indiquée. Par exemple, si le format d'affichage de la date indiquée est Hijri, les valeurs renvoyées pour les fonctions ANNEE, MOIS et JOUR sont associées aux dates grégoriennes équivalentes.

Exemple

Formule | Description (résultat)
=ANNEE("7/5/2008") | Année de la première date (2008)
=ANNEE("7/5/10") | Année de la deuxième date (2010)


DDB

Renvoie l'amortissement d'un bien durant une période spécifiée suivant la méthode de l'amortissement dégressif à taux double ou selon un coefficient à spécifier.

Syntaxe

DDB(coût;valeur_résiduelle;durée;période;facteur)

coût représente le coût initial du bien.

valeur_résiduelle représente la valeur à la fin de l'amortissement (parfois appelée valeur résiduelle du bien).

durée représente le nombre de périodes sur lesquelles le bien est amorti (parfois appelée durée de vie utile du bien).

période représente la période pour laquelle vous voulez calculer l'amortissement. La période doit utiliser les mêmes unités que la durée.

facteur représente le taux d'amortissement. Si facteur est omis, la valeur 2 lui est attribuée (la méthode d'amortissement dégressif à taux double).

Les cinq arguments doivent être des nombres positifs.

Remarques

  • La méthode d'amortissement dégressif à taux double calcule l'amortissement à un taux accéléré. L'amortissement est plus élevé pour la première période et décroît au cours des périodes successives. La fonction DDB utilise la formule suivante pour calculer l'amortissement pour une période :

    ((coût-valeur_résiduelle) - amortissement total sur les périodes précédentes) * (facteur/durée)

  • Modifiez le facteur si vous ne voulez pas utiliser la méthode d'amortissement dégressif à taux double.

Exemple

coût | valeur_résiduelle | durée | Formule | Description (résultat)
2400 | 300 | 10 | =DDB([coût];[valeur_résiduelle];[durée]*365;1) | Amortissement du premier jour. La valeur 2 est automatiquement attribuée à Facteur. (1,32)
2400 | 300 | 10 | =DDB([coût];[valeur_résiduelle];[durée]*12;1;2) | Amortissement du premier mois (40,00)
2400 | 300 | 10 | =DDB([coût];[valeur_résiduelle];[durée];1;2) | Amortissement de la première année (480,00)
2400 | 300 | 10 | =DDB([coût];[valeur_résiduelle];[durée];2;1,5) | Amortissement de la deuxième année, avec un facteur de 1,5 au lieu de la méthode d'amortissement à taux double (306,00)
2400 | 300 | 10 | =DDB([coût];[valeur_résiduelle];[durée];10) | Amortissement de la dixième année. La valeur 2 est automatiquement attribuée à Facteur. (22,12)

Remarque Les résultats sont arrondis à deux décimales.


VC

Renvoie la valeur capitalisée d'un investissement sur la base de versements périodiques et constants et d'un taux d'intérêt constant.

Syntaxe

VC(taux;npm;vpm;va;type)

Pour une description plus complète des arguments de VC et pour plus d'informations sur les fonctions d'annuité, voir la fonction VA.

taux représente le taux d'intérêt par période.

npm représente le nombre total de périodes de remboursement au cours de l'opération.

vpm représente le montant du remboursement pour chaque période. Ce montant est fixe pendant toute la durée de l'opération. En principe, vpm comprend le capital et les intérêts, mais exclut toute autre charge ou impôt. Si vous omettez l'argument vpm, vous devez inclure l'argument va.

va représente la valeur actuelle ou la somme forfaitaire représentant aujourd'hui une série de remboursements futurs. Si va est omis, la valeur prise en compte par défaut est 0 (zéro) et vous devez inclure l'argument vpm.

type peut prendre les valeurs 0 ou 1 et indique l'échéance des paiements. Si type est omis, la valeur par défaut est 0.

Définissez Type à | Si les versements sont dus
0 | En fin de période
1 | En début de période

Remarques
  • Veillez à utiliser la même unité pour les arguments taux et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour l'argument taux et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour l'argument taux et 4 pour l'argument npm.
  • Quel que soit l'argument, les décaissements, tels que les dépôts sur un compte d'épargne, sont représentés par un nombre négatif alors que les encaissements, tels que les paiements de dividendes, sont représentés par un nombre positif.

Exemple 1

taux | npm | pmt | va | type | Formule | Description (résultat)
6% | 10 | -200 | -500 | 1 | =VC(taux/12;npm;pmt;va;type) | Valeur capitalisée d'un investissement avec les arguments spécifiés (2581,40)

Remarque Le taux d'intérêt annuel est divisé par 12 parce qu'il est composé mensuellement.

Exemple 2

taux | npm | pmt | Formule | Description (résultat)
12% | 12 | -1000 | =VC([taux]/12;[npm];[pmt]) | Valeur capitalisée d'un investissement avec les arguments spécifiés (12 682,50)

Remarque Le taux d'intérêt annuel est divisé par 12 parce qu'il est composé mensuellement.


INTPER

Renvoie le montant des intérêts pour une période donnée, pour un investissement basé sur des versements périodiques et constants et sur un taux d'intérêt constant. Pour une description plus complète des arguments de INTPER et pour plus d'informations sur les fonctions d'annuité, voir la fonction VA.

Syntaxe

INTPER(taux;pér;npm;va;vc;type)

taux représente le taux d'intérêt par période.

pér représente la période pour laquelle vous souhaitez calculer les intérêts. La valeur spécifiée doit être comprise entre 1 et npm.

npm représente le nombre total de périodes de remboursement au cours de l'opération.

va représente la valeur actuelle ou la somme forfaitaire représentant aujourd'hui une série de remboursements futurs.

vc représente la valeur future (valeur capitalisée), c'est-à-dire le montant que vous souhaitez obtenir après le dernier remboursement. Si vous ne spécifiez pas l'argument vc, la valeur par défaut est 0 (par exemple, la valeur future d'un emprunt est égale à 0).

type peut prendre les valeurs 0 ou 1 et indique l'échéance des paiements. Si type est omis, sa valeur par défaut est 0.

Affectez à l'argument type la valeur | Si les paiements doivent être effectués
0 | En fin de période
1 | En début de période

Remarques
  • Veillez à utiliser la même unité pour les arguments taux et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour l'argument taux et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour l'argument taux et 4 pour l'argument npm.
  • Quel que soit l'argument, les décaissements, tels que les dépôts sur un compte d'épargne, sont représentés par un nombre négatif alors que les encaissements, tels que les paiements de dividendes, sont représentés par un nombre positif.

Exemple

taux | pér | npm | va | Formule | Description (résultat)
10% | 1 | 3 | 8 000 | =INTPER([taux]/12; [pér]*3; [npm]; [va]) | Intérêts dus au cours du premier mois, pour un emprunt avec les arguments spécifiés (-22,41)
10% | 1 | 3 | 8 000 | =INTPER([taux]; 3; npm; [va]) | Intérêts dus au cours de la dernière année pour un emprunt avec les arguments spécifiés, où les versements sont effectués annuellement (-292,45)

Remarque Le taux d'intérêt est divisé par 12 pour obtenir un taux mensuel. Les années où les versements sont effectués sont multipliées par 12 pour obtenir le nombre de paiements.


ISPMT

Calcule le montant des intérêts d'un investissement pour une période donnée.

Syntaxe

ISPMT(taux;pér;npm;va)

taux représente le taux d'intérêt de l'investissement.

pér représente la période pour laquelle vous voulez calculer les intérêts ; il doit être compris entre 1 et Nombre_périodes.

npm représente le nombre total de périodes de remboursement pour l'investissement.

va représente la valeur actuelle d'un investissement. Pour un emprunt, va est le montant du prêt.

Remarques

  • Veillez à être cohérent dans la définition des unités des arguments taux et npm. Si vous remboursez mensuellement un emprunt d'une durée de quatre ans au taux d'intérêt annuel de 12 %, utilisez 12 %/12 pour l'argument taux et 4*12 pour l'argument npm. Si, pour le même emprunt, vos remboursements sont effectués annuellement, utilisez 12 % pour l'argument taux et 4 pour l'argument npm.
  • Pour tous les arguments, les décaissements, tels que les dépôts sur un compte d'épargne ou tout autre retrait, sont représentés par un nombre négatif alors que les encaissements, tels que les chèques de dividendes et autres dépôts, sont représentés par un nombre positif.
  • Pour plus d'informations sur les fonctions financières, voir la fonction VA.

Exemple

taux | pér | npm | va | Formule | Description (résultat)
10% | 1 | 3 | 8 000 000 | =ISPMT([taux]/12;[pér];[npm]*12;[va]) | Intérêts payés pour le premier paiement mensuel d'un prêt avec les arguments spécifiés (-64 814,8)
10% | 1 | 3 | 8 000 000 | =ISPMT([taux];1;[npm];[va]) | Intérêts payés pour la première année d'un prêt avec les arguments spécifiés (-533,333)

Remarque Le taux d'intérêt est divisé par 12 pour obtenir un taux mensuel. Les années où les versements sont effectués sont multipliées par 12 pour obtenir le nombre de paiements.


NPM

Renvoie le nombre de périodes d'un investissement sur la base de versements périodiques et constants et d'un taux d'intérêt constant.

Syntaxe

NPM(taux;vpm;va;vc;type)

Pour une description plus complète des arguments de NPM et pour plus d'informations sur les fonctions d'annuité, voir la fonction VA.

taux représente le taux d'intérêt par période.

vpm représente le montant d'un versement périodique ; celui-ci reste constant pendant toute la durée de l'opération. En règle générale, vpm comprend le principal et les intérêts, mais aucune autre charge ni impôt.

va représente la valeur actuelle ou la somme forfaitaire représentant aujourd'hui une série de remboursements futurs.

vc représente la valeur future (valeur capitalisée), c'est-à-dire le montant que vous souhaitez obtenir après le dernier remboursement. Si vous ne spécifiez pas l'argument vc, sa valeur par défaut est 0 (par exemple, la valeur future d'un emprunt est égale à 0).

type peut prendre les valeurs 0 ou 1 et indique l'échéance des paiements.

Définissez type à | Si les paiements doivent être effectués
0 ou omis | En fin de période
1 | En début de période

Exemple
taux | pmt | va | vc | type | Formule | Description (résultat)
12% | -100 | -1 000 | 10 000 | 1 | =NPM([taux]/12; [pmt]; [va]; [vc]; 1) | Périodes pour l'investissement avec les arguments spécifiés (60)
12% | -100 | -1 000 | 10 000 | 1 | =NPM([taux]/12; [pmt]; [va]; [vc]) | Périodes pour l'investissement avec les arguments spécifiés, mais avec des paiements effectués au début de la période (60)
12% | -100 | -1 000 | 10 000 | 1 | =NPM([taux]/12; [pmt]; [va]) | Périodes pour l'investissement avec les arguments spécifiés, mais avec une valeur future de 0 (-9,578)


VAN

Calcule la valeur actuelle nette d'un investissement en utilisant un taux d'escompte ainsi qu'une série de décaissements (valeurs négatives) et d'encaissements (valeurs positives) futurs.

Syntaxe

VAN(taux;valeur1;valeur2; ...)

taux est le taux d'escompte pour une période.

valeur1;valeur2; ... sont 1 à 29 arguments représentant les décaissements et les encaissements.

  • valeur1;valeur2; ... doivent être également répartis dans le temps et se produire à la fin de chaque période.
  • VAN utilise l'ordre de valeur1; valeur2; ... pour interpréter l'ordre des flux financiers. Assurez-vous d'entrer les décaissements et les encaissements dans la séquence correcte.
  • Les arguments qui sont des nombres, des arguments vides, des valeurs logiques ou des représentations de nombres sous forme de texte sont comptés ; les arguments qui sont des valeurs d'erreur ou du texte qui ne peut pas être converti en nombre sont ignorés.

Remarques

  • L'investissement VAN commence par une période précédant le flux financier valeur1 et se termine avec le dernier flux financier de la liste. Le calcul de VAN est basé sur des flux financiers futurs. Si votre premier flux financier se produit au début de la première période, la première valeur doit être ajoutée au résultat de VAN et non pas incluse dans les arguments de valeur. Pour plus d'informations, consultez les exemples ci-dessous.
  • Si n est le nombre de flux financiers de la liste des valeurs, la formule pour VAN est :

  • VAN est similaire à la fonction VA (valeur actuelle). La principale différence entre VA et VAN est que VA permet que les flux financiers commencent à la fin ou au début de la période. Au contraire des valeurs de flux financiers variables de VAN, les flux financiers de VA doivent être constants tout au long de l'investissement. Pour plus d'informations sur les fonctions d'annuités et financières, voir VA.
  • VAN est également lié à la fonction TRI (taux de rentabilité interne). TRI est le taux pour lequel VAN est égal à zéro : VAN(TRI(...); ...) = 0.

Exemple 1

Dans l'exemple suivant :

  • taux est le taux d'escompte annuel.
  • valeur1 est le coût initial de l'investissement après une année à partir de la date actuelle.
  • valeur2 est le rapport de la première année.
  • valeur3 est le rapport de la deuxième année.
  • valeur4 est le rapport de la troisième année.
taux | valeur1 | valeur2 | valeur3 | valeur4 | Formule | Description (résultat)
10% | -10 000 | 3 000 | 4 200 | 6 800 | =VAN([taux]; [valeur1]; [valeur2]; [valeur3]; [valeur4]) | Valeur actuelle nette de cet investissement (1 188,44)

Dans l'exemple précédent, vous incluez le coût initial de 10 000 € en le faisant figurer comme une des valeurs, parce que le paiement est effectué à la fin de la première période.

Exemple 2

Dans l'exemple suivant :

  • taux est le taux d'escompte annuel. Il peut représenter le taux d'inflation ou le taux d'intérêt d'un investissement compétitif.
  • valeur1 est le coût initial de l'investissement une année à partir de la date actuelle.
  • valeur2 est le rapport de la première année.
  • valeur3 est le rapport de la deuxième année.
  • valeur4 est le rapport de la troisième année.
  • valeur5 est le rapport de la quatrième année.
  • valeur6 est le rapport de la cinquième année.
taux | valeur1 | valeur2 | valeur3 | valeur4 | valeur5 | valeur6 | Formule | Description (résultat)
8% | 40 000 | 8 000 | 9 200 | 10 000 | 12 000 | 14 500 | =VAN(taux; [valeur2]; [valeur3]; [valeur4]; [valeur5]; [valeur6])+[valeur1] | Valeur actuelle nette de cet investissement (1 922,06)
8% | 40 000 | 8 000 | 9 200 | 10 000 | 12 000 | 14 500 | =VAN(taux; [valeur2]; [valeur3]; [valeur4]; [valeur5]; [valeur6]; -9000)+[valeur1] | Valeur actuelle nette de cet investissement, avec une perte de 9000 pour la sixième année (-3 749,47)

Dans l'exemple précédent, vous n'incluez pas le coût initial de 40 000 € en le faisant figurer comme une des valeurs, parce que le paiement est effectué au début de la première période.


VPM

Calcule le remboursement d'un emprunt sur la base de remboursements et d'un taux d'intérêt constants.

Syntaxe

VPM(taux;npm;va;vc;type)

Pour une description plus complète des arguments de VPM, reportez-vous à la fonction VA.

taux représente le taux d'intérêt de l'emprunt.

npm représente le nombre de remboursements pour l'emprunt.

va représente la valeur actuelle ou la valeur que représente à la date d'aujourd'hui une série de remboursements futurs ; il s'agit du principal de l'emprunt.

vc représente la valeur capitalisée, c'est-à-dire le montant que vous souhaitez obtenir après le dernier paiement. Si vc est omis, la valeur par défaut est 0 (zéro), c'est-à-dire que la valeur capitalisée d'un emprunt est égale à 0.

type représente le nombre 0 (zéro) ou 1 et indique quand les paiements doivent être effectués.

Affectez à l'argument type la valeur | Si les paiements doivent être effectués
0 ou omis | En fin de période
1 | En début de période

Notes
  • La valeur du paiement renvoyée par VPM comprend le principal et les intérêts mais pas les charges, versements de garantie et autres impôts parfois associés aux emprunts.
  • Veillez à utiliser la même unité pour les arguments taux et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour l'argument taux et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour l'argument taux et 4 pour l'argument npm.

Afficher Conseil

Pour connaître le montant total payé sur toute la durée de l'emprunt, multipliez la valeur renvoyée par VPM par npm.

Exemple 1

Dans l'exemple suivant :

  • taux représente le taux d'intérêt annuel
  • npm représente le nombre de mois de remboursements
  • va représente le montant de l'emprunt
taux | npm | va | Formule | Description (résultat)
8% | 10 | 10 000 | =VPM([taux]/12; [npm]; [va]) | Valeur du remboursement mensuel d'un emprunt défini par les arguments spécifiés (-1 037,03)
8% | 10 | 10 000 | =VPM([taux]/12; [npm]; [va]; 0, 1) | Valeur du remboursement mensuel d'un emprunt défini par les arguments spécifiés, excepté que les paiements doivent être effectués au début de la période (-1 030,16)

Exemple 2

Vous pouvez utiliser la fonction VPM afin de déterminer les paiements pour des annuités autres que des emprunts.

Dans l'exemple suivant :

  • taux représente le taux d'intérêt annuel.
  • npm représente les années que vous prévoyez d'économiser.
  • va représente la somme que vous voulez avoir épargnée en 18 ans.
taux | npm | va | Formule | Description (résultat)
6% | 18 | 50 000 | =VPM([taux]/12; [npm]*12; 0; [va]) | Montant à épargner chaque mois pour disposer de 50 000 € au bout de 18 ans (-129,08)

Remarque Pour obtenir un taux mensuel, le taux d'intérêt est divisé par 12. Pour obtenir le nombre de remboursements, le taux d'intérêt annuel du marché est multiplié par 12.


PRINCPER

Calcule, pour une période donnée, la part de remboursement du principal d'un investissement sur la base de remboursements périodiques et d'un taux d'intérêt constants.

Syntaxe

PRINCPER(taux;pér;npm;va;vc;type)

Pour une description plus complète des arguments de PRINCPER, reportez-vous à la fonction VA.

taux représente le taux d'intérêt par période.

pér indique la période et doit être compris entre 1 et npm.

npm représente le nombre total de périodes de remboursement au cours de l'opération.

va représente la valeur actuelle, c'est-à-dire la valeur que représente à la date d'aujourd'hui une série de remboursements futurs.

vc représente la valeur capitalisée, c'est-à-dire le montant que vous souhaitez obtenir après le dernier paiement. Si vc est omis, la valeur par défaut est 0 (zéro), c'est-à-dire que la valeur capitalisée d'un emprunt est égale à 0.

type représente le nombre 0 ou 1 et indique quand les paiements doivent être effectués.

Affectez à l'argument type la valeur | Si les paiements doivent être effectués
0 ou omis | En fin de période
1 | En début de période

Note

Veillez à utiliser la même unité pour les arguments taux et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour l'argument taux et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour l'argument taux et 4 pour l'argument npm.

Exemple 1

taux | npm | va | Formule | Description (résultat)
10% | 2 | 2 000 | =PRINCPER([taux]/12; 1; [npm]*12; [va]) | Part de remboursement du principal pour le premier mois de l'emprunt (-75,62)

Remarque Pour obtenir un taux mensuel, le taux d'intérêt est divisé par 12. Pour obtenir le nombre de remboursements, le taux d'intérêt annuel du marché est multiplié par 12.

Exemple 2

taux | pér | va | Formule | Description (résultat)
8% | 10 | 200 000 | =PRINCPER([taux]; [pér]; 10; [va]) | Part de remboursement du principal pour la dernière année de l'emprunt avec les arguments spécifiés (-27 598,05)


VA

Calcule la valeur actuelle d'un investissement. La valeur actuelle correspond à la somme que représente aujourd'hui un ensemble de remboursements futurs. Par exemple, lorsque vous faites un emprunt, le montant de l'emprunt représente la valeur actuelle pour le prêteur.

Syntaxe

VA(taux;npm;vpm;vc;type)

taux représente le taux d'intérêt par période. Par exemple, si vous obtenez un emprunt pour l'achat d'une voiture à un taux d'intérêt annuel de 10% et que vos remboursements sont mensuels, le taux d'intérêt mensuel sera de 10%/12, soit 0,83%. Le chiffre entré dans la formule en tant que taux peut être 10%/12, 0,83% ou 0,0083.

npm représente le nombre total de périodes de paiement au cours de l'opération. Si, pour l'achat d'une voiture, vous obtenez un emprunt sur quatre ans, remboursable mensuellement, cet emprunt s'étend sur 4*12 (ou 48) périodes. Le chiffre tapé dans la formule en tant qu'argument npm sera 48.

vpm représente le montant du remboursement pour chaque période. Ce montant est identique pendant toute la durée de l'opération. En règle générale, vpm comprend le principal et les intérêts, mais exclut toutes les autres charges ou impôts. Par exemple, le remboursement mensuel d'un emprunt de 100 000 € sur quatre ans à 12% pour l'achat d'une voiture est de 2 333,30 €. Le chiffre tapé dans la formule en tant qu'argument vpm sera 2 333,30. Si l'argument vpm est omis, vous devez inclure l'argument vc.

vc représente la valeur capitalisée, c'est-à-dire le montant que vous souhaitez obtenir après le dernier paiement. Si vc est omis, la valeur par défaut est 0 (par exemple, la valeur capitalisée d'un emprunt est égale à 0). Ainsi, si vous souhaitez économiser 500 000 € pour financer un projet précis dans 18 ans, 500 000 € est la valeur capitalisée à atteindre. Vous pouvez faire une estimation du taux d'intérêt et déterminer le montant que vous devez épargner chaque mois. Si l'argument vc est omis, vous devez inclure l'argument vpm.

type représente le nombre 0 ou 1 et indique quand les paiements doivent être effectués.

Affectez à l'argument type la valeur | Si les paiements doivent être effectués
0 ou omis | En fin de période
1 | En début de période

Notes
  • Veillez à utiliser la même unité pour les arguments taux et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour l'argument taux et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour l'argument taux et 4 pour l'argument npm.
  • Les différentes fonctions qui s'appliquent aux annuités sont les suivantes :
    • INTPER
    • PRINCPER
    • TAUX
    • VA
    • VC
    • VPM
    Une annuité est une série de remboursements constants pendant une période ininterrompue. Par exemple, le remboursement d'un emprunt pour l'achat d'une voiture ou d'un bien immobilier constitue une annuité. Pour plus d'informations, reportez-vous à la description de chaque fonction d'annuité.
  • Dans les fonctions d'annuité, les décaissements, tels que les dépôts sur un compte d'épargne, sont représentés par un nombre négatif. Les encaissements, tels que les chèques de dividendes, sont représentés par un nombre positif. Par exemple, une somme de 1 000 € déposée dans une banque est représentée par l'argument –1 000 si vous êtes le déposant, et par l'argument 1 000 si vous représentez la banque.
  • Un argument financier est résolu par rapport aux autres. Si l'argument taux est différent de 0 :

    Si l'argument taux est égal à 0 :

    (vpm * npm) + va + vc = 0

Exemples

Dans l'exemple suivant :

  • pmt représente la somme remboursée à la fin de chaque mois pour une annuité d'assurance.
  • taux représente le taux d'intérêt acquis sur la somme payée.
  • nper représente les années au cours desquelles la somme sera payée.
pmt | taux | npm | Formule | Description (résultat)
500 | 8% | 20 | =VA([taux]/12; 12*[nper]; [pmt]; ; 0) | Valeur actuelle d'une annuité avec les arguments spécifiés (-59 777,15).

Le résultat est négatif car il représente un décaissement, ce que vous devriez payer. Si vous devez effectuer un décaissement de 60 000 € pour cet investissement, il n'est pas intéressant d'y souscrire car la valeur actuelle de la suite d'annuités (59 777,15 €) est inférieure à ce que vous devez payer.

Remarque Pour obtenir un taux mensuel, le taux d'intérêt est divisé par 12. Pour obtenir le nombre de remboursements, le taux d'intérêt annuel du marché est multiplié par 12.


TAUX

Calcule le taux d'intérêt par période d'un investissement donné. La fonction TAUX est calculée par itération et peut n'avoir aucune solution ou en avoir plusieurs. La fonction renvoie la valeur d'erreur #NOMBRE! si, après 20 itérations, les résultats ne convergent pas à 0,0000001 près.

Syntaxe

TAUX(npm;vpm;va;vc;type;estimation)

Pour une description complète des arguments npm, vpm, va, vc et type, reportez-vous à la fonction VA.

npm représente le nombre total de périodes de remboursement au cours de l'opération.

vpm représente le montant du remboursement pour chaque période et reste constant pendant toute la durée de l'opération. En règle générale, vpm comprend le principal et les intérêts mais exclut toute autre charge ou impôt. Si l'argument vpm est omis, vous devez inclure l'argument vc.

va représente la valeur actuelle, c'est-à-dire la valeur que représente à la date d'aujourd'hui une série de remboursements futurs.

vc représente la valeur future (valeur capitalisée), c'est-à-dire le montant que vous souhaitez obtenir après le dernier remboursement. Si vous ne spécifiez pas l'argument vc, la valeur par défaut est 0 (par exemple, la valeur future d'un emprunt est égale à 0).

type représente le nombre 0 ou 1 et indique quand les paiements doivent être effectués.

Affectez à l'argument type la valeur | Si les paiements doivent être effectués
0 ou omis | En fin de période
1 | En début de période

estimation représente votre estimation de la valeur du taux.

  • Si l'argument estimation est omis, la valeur par défaut est 10%.
  • Si les résultats de la fonction TAUX ne convergent pas, essayez différentes valeurs pour l'argument estimation. Normalement, les résultats de TAUX convergent si l'argument estimation est compris entre 0 et 1.

Remarque

Veillez à utiliser la même unité pour les arguments estimation et npm. Si vous effectuez des remboursements mensuels pour un emprunt sur quatre ans à un taux d'intérêt annuel de 12%, utilisez 12%/12 pour estimation et 4*12 pour l'argument npm. Si vous effectuez des remboursements annuels pour le même emprunt, utilisez 12% pour estimation et 4 pour l'argument npm.

Exemples

npm | pmt | va | Formule | Description (résultat)
4 | -200 | 8 000 | =TAUX([npm]*12; [pmt]; [va]) | Taux mensuel de l'emprunt défini par les arguments spécifiés (1%)
4 | -200 | 8 000 | =TAUX([npm]*12; [pmt]; [va])*12 | Taux d'intérêt annuel de l'emprunt défini par les arguments spécifiés (0,09241767 ou 9,24 %)

Remarque Le nombre d'années nécessaire au remboursement de l'emprunt est multiplié par 12 pour obtenir le nombre de mois.


AMORLIN

Calcule l'amortissement linéaire d'un bien pour une période donnée.

Syntaxe

AMORLIN(coût;valeur_rés;durée)

coût représente le coût initial du bien.

valeur_rés représente la valeur du bien au terme de l'amortissement (aussi appelée valeur résiduelle du bien).

durée représente le nombre de périodes pendant lesquelles le bien est amorti (parfois appelée durée de vie utile du bien).

Exemple

coût | valeur_rés | durée | Formule | Description (résultat)
30 000 | 7 500 | 10 | =AMORLIN([coût]; [valeur_rés]; [durée]) | Amortissement annuel du bien (2 250)


SYD

Calcule l'amortissement d'un bien pour une période donnée sur la base de la méthode américaine Sum-of-Years Digits (amortissement dégressif à taux décroissant appliqué à une valeur constante).

Syntaxe

SYD(coût;valeur_rés;durée;période)

coût représente le coût initial du bien.

valeur_rés représente la valeur du bien au terme de l'amortissement (également appelée valeur résiduelle du bien).

durée représente le nombre de périodes pendant lesquelles le bien est amorti (parfois appelée durée de vie utile du bien).

période est la période et doit être exprimée dans la même unité que la durée.

Remarque

  • La fonction SYD se calcule comme suit :

Exemple

coût | valeur_rés | durée | Formule | Description (résultat)
30 000 | 7 500 | 10 | =SYD([coût];[valeur_rés];[durée];1) | Première annuité (4 090,91)
30 000 | 7 500 | 10 | =SYD([coût];[valeur_rés];[durée];10) | Dixième annuité (409,09)


EST

Cette section décrit les neuf fonctions utilisées pour tester le type d’une valeur ou d’une référence de colonne.

Chacune de ces fonctions, regroupées sous le nom de fonctions EST, vérifie le type de valeur et renvoie VRAI ou FAUX selon le résultat. Par exemple, la fonction ESTVIDE renvoie la valeur logique VRAI si la valeur est une référence de colonne qui est vide ; sinon, elle renvoie FAUX.

Syntaxe

ESTVIDE(valeur)
ESTERR(valeur)
ESTERREUR(valeur)
ESTLOGIQUE(valeur)
ESTNA(valeur)
ESTNONTEXTE(valeur)
ESTNUL(valeur)
ESTNUM(valeur)
ESTTEXTE(valeur)

valeur est la valeur que vous voulez tester. La valeur peut être une valeur vide, d’erreur, logique, de texte, de nombre ou une référence de colonne.

Fonction | Renvoie VRAI si
ESTERR | La valeur correspond à toute valeur d'erreur sauf #N/A.
ESTERREUR | La valeur correspond à toute valeur d'erreur (#N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? ou #NUL!).
ESTLOGIQUE | La valeur correspond à une valeur logique.
ESTNA | La valeur correspond à la valeur d'erreur #N/A (valeur non disponible).
ESTNONTEXTE | La valeur correspond à tout élément qui n'est pas du texte. (Notez que cette fonction renvoie VRAI si la valeur correspond à une référence de colonne vide.)
ESTNUL | La valeur fait référence à la valeur #NUL!.
ESTNUM | La valeur correspond à un nombre.
ESTTEXTE | La valeur correspond à du texte.
ESTVIDE | La valeur correspond à une référence de colonne vide.

Remarques
  • Les arguments de valeurs des fonctions EST ne sont pas convertis. Par exemple, dans la plupart des fonctions où un nombre est requis, la valeur texte « 19 » est convertie en nombre 19. Cependant, dans la formule ESTNUM("19"), « 19 » n'est pas converti à partir d'une valeur texte et la fonction ESTNUM renvoie FAUX.
  • Les fonctions EST sont utilisées dans des formules pour tester le résultat d'un calcul. Lorsqu'elles sont combinées avec la fonction SI, elles constituent une méthode pour identifier des erreurs dans des formules (voir les exemples suivants).

Exemple 1

Formule | Description (résultat)
=ESTLOGIQUE(VRAI) | Vérifie si VRAI est une valeur logique (VRAI)
=ESTLOGIQUE("VRAI") | Vérifie si « VRAI » est une valeur logique (FAUX)
=ESTNUM(4) | Vérifie si 4 est un nombre (VRAI)

Exemple 2

Col1 | Formule | Description (résultat)
Or | =ESTVIDE([Col1]) | Vérifie si la valeur de Col1 est vide (FAUX)
#REF! | =ESTERREUR([Col1]) | Vérifie si la valeur de Col1 est une erreur (VRAI)
#REF! | =ESTNA([Col1]) | Vérifie si la valeur de Col1 est l'erreur #N/A (FAUX)
#N/A | =ESTNA([Col1]) | Vérifie si la valeur de Col1 est l'erreur #N/A (VRAI)
#N/A | =ESTERR([Col1]) | Vérifie si la valeur de Col1 est une erreur (FAUX)
#NUL! | =ESTNUL([Col1]) | Vérifie si la valeur de Col1 est #NUL! (Oui)
330,92 | =ESTNUM([Col1]) | Vérifie si la valeur de Col1 est un nombre (VRAI)
Région1 | =ESTTEXTE([Col1]) | Vérifie si la valeur de Col1 est du texte (VRAI)


Moi

Renvoie le nom de l'utilisateur courant.

Syntaxe

Moi

Remarques

  • La fonction Moi peut être utilisée seulement avec des valeurs par défaut ; vous ne pouvez pas utiliser cette fonction dans une colonne calculée.


ET

Renvoie la valeur logique VRAI ou Oui si tous les arguments ont pour résultat la valeur VRAI ; renvoie FAUX ou Non si au moins l’un des arguments a pour résultat la valeur FAUX.

Syntaxe

ET(valeur_logique1;valeur_logique2;...)

valeur_logique1;valeur_logique2; ... représentent les 1 à 30 conditions que vous souhaitez tester et qui peuvent être soit VRAI, soit FAUX.

Remarques

  • Les arguments doivent s'évaluer en valeurs logiques comme VRAI ou FAUX, ou bien les arguments doivent être des références de colonnes contenant des valeurs logiques.
  • Si un argument qui est une référence de colonne contient du texte, ET renvoie la valeur d'erreur #VALEUR! ; si la colonne est vide, ET renvoie FAUX.
  • Si les arguments ne contiennent pas de valeurs logiques, ET renvoie la valeur d'erreur #VALEUR!.
  • Si un ou plusieurs arguments contiennent #NUL!, ET renvoie la valeur #NUL!.

Exemple 1

Formule | Description (résultat)
=ET(VRAI;VRAI) | Tous les arguments sont VRAIS (VRAI)
=ET(VRAI;FAUX) | Un des arguments est FAUX (FAUX)
=ET(2+2=4;2+3=5) | Tous les arguments s'évaluent à VRAI (VRAI)
=ET(VRAI;#NUL!) | Le premier argument prend la valeur VRAI et un argument contient #NUL! (#NUL!)

Exemple 2

Col1 | Col2 | Formule | Description (résultat)
50 | 104 | =ET(1<[Col1];[Col1]<100) | Parce que 50 est entre 1 et 100 (VRAI)
50 | 104 | =SI(ET(1<[Col2];[Col2]<100);[Col2];"La valeur est hors limites.") | Affiche le second nombre s'il est compris entre 1 et 100, sinon affiche un message (La valeur est hors limites.)
50 | 104 | =SI(ET(1<[Col1];[Col1]<100);[Col1];"La valeur est hors limites.") | Affiche le premier nombre s'il est compris entre 1 et 100, sinon affiche un message (50)


CHOISIR

Utilise un numéro d'index pour renvoyer une valeur de la liste des arguments. Utilisez CHOISIR pour sélectionner une parmi jusqu'à 29 valeurs sur la base du numéro d'index. Par exemple, si valeur1 à valeur7 contiennent les jours de la semaine, CHOISIR renvoie un de ces jours lorsqu'un nombre compris entre 1 et 7 est utilisé comme numéro d'index.

Syntaxe

CHOISIR(numéro_index;valeur1;valeur2;...)

numéro_index spécifie quel argument de valeur est sélectionné. numéro_index doit être un nombre compris entre 1 et 29, ou bien une formule ou une référence de formule contenant un nombre entre 1 et 29.

  • Si numéro_index est 1, CHOISIR renvoie valeur1 ; s'il vaut 2, CHOISIR renvoie valeur2, etc.

  • Si numéro_index est inférieur à 1 ou supérieur au numéro de la dernière valeur de la liste, CHOISIR renvoie la valeur d'erreur #VALEUR!.

  • Si numéro_index est une fraction, il est tronqué à l'entier inférieur le plus proche avant d'être utilisé.

valeur1;valeur2;... représentent 1 à 29 arguments de valeur dans lesquels CHOISIR sélectionne une valeur ou une action à effectuer sur la base de numéro_index. Les arguments peuvent être des nombres, des références de colonnes, des formules, des fonctions ou du texte.

Remarques

Exemple 1

Col1 | Col2 | Col3 | Col4 | Formule | Description (résultat)
1er | 2ème | 3ème | Terminé | =CHOISIR(2;[Col1];[Col2];[Col3];[Col4]) | Valeur du deuxième argument Col2 (2ème)
Clous | Vis | Écrous | Boulons | =CHOISIR(4;[Col1];[Col2];[Col3];[Col4]) | Valeur du quatrième argument Col4 (Boulons)

Exemple 2

Col1 | Col2 | Col3 | Col4 | Formule | Description (résultat)
23 | 45 | 12 | 10 | =SOMME([Col1]; CHOISIR(2;[Col2];[Col3];[Col4])) | Additionne les deux arguments Col1 et le résultat de la fonction CHOISIR (35)


FAUX

Renvoie la valeur logique FAUX.

Syntaxe

FAUX( )

Remarque

Vous pouvez également taper le mot FAUX directement dans la formule : il est alors interprété comme la valeur logique FAUX.


SI

Renvoie une certaine valeur si une condition que vous spécifiez est évaluée à VRAI, et une autre valeur si elle est évaluée à FAUX.

Utilisez SI pour effectuer des tests conditionnels sur des valeurs et des formules.

Syntaxe

SI(test_logique;valeur_si_vrai;valeur_si_faux)

test_logique est toute valeur ou expression qui peut être évaluée à VRAI ou à FAUX. Par exemple, [Trimestre1]=100 est une expression logique ; si la valeur dans une ligne de la colonne [Trimestre1] est égale à 100, l'expression est évaluée à VRAI. Sinon, l'expression est évaluée à FAUX. Cet argument peut utiliser tout opérateur de calcul de comparaison.

valeur_si_vrai est la valeur qui est renvoyée si test_logique est VRAI. Par exemple, si cet argument est la chaîne de texte « Budgété » et que l'argument test_logique est évalué à VRAI, alors la fonction SI affiche le texte « Budgété ». Si test_logique est VRAI et que valeur_si_vrai est vide, cet argument renvoie 0 (zéro). Pour afficher le mot VRAI, utilisez la valeur logique VRAI pour cet argument. valeur_si_vrai peut être une autre formule.

valeur_si_faux est la valeur qui est renvoyée si test_logique est évalué à FAUX. Par exemple, si cet argument est la chaîne « Hors budget » et que l'argument test_logique est évalué à FAUX, alors la fonction SI affiche le texte « Hors budget ». Si test_logique est FAUX et que valeur_si_faux est omis, (c'est-à-dire s'il n'y a pas de point-virgule après valeur_si_vrai), alors la valeur logique FAUX est renvoyée. Si test_logique est FAUX et que valeur_si_faux est vide (c'est-à-dire si après valeur_si_vrai, il y a un point-virgule suivi par les parenthèses fermantes), alors la valeur 0 (zéro) est renvoyée. valeur_si_faux peut être une autre formule.

Remarques

  • Jusqu'à sept fonctions SI peuvent être imbriquées comme arguments valeur_si_vrai et valeur_si_faux pour construire des tests plus élaborés. Voir le dernier des exemples qui suivent.
  • Lorsque les arguments valeur_si_vrai et valeur_si_faux sont évalués, SI renvoie la valeur renvoyée par ces instructions.
  • Si des arguments de SI sont des matrices, chaque élément de la matrice est évalué lorsque l'instruction SI est traitée.

Exemple 1

Col1 | Col2 | Col3 | dépense | Formule | Description (résultat)
 |  |  | 50 | =SI([dépense]<=100;"Budgété";"Hors budget") | Si le nombre est inférieur ou égal à 100, la formule affiche « Budgété ». Sinon, la fonction affiche « Hors budget ». (Budgété)
23 | 45 | 89 | 50 | =SI([dépense]=100;SOMME([Col1];[Col2];[Col3]);"") | Si le nombre est 100, les trois valeurs sont additionnées. Sinon, du texte vide est ("") est renvoyé. ()

Exemple 2

dépenses_réelles | dépenses_prévues | Formule | Description (résultat)
1500 | 900 | =SI([dépenses_réelles]>[dépenses_prévues];"Hors budget";"OK") | Vérifie si la première ligne est hors budget (Hors budget)
500 | 900 | =SI([dépenses_réelles]>[dépenses_prévues];"Hors budget";"OK") | Vérifie si la deuxième ligne est hors budget (OK)

Exemple 3

score | Formule | Description (résultat)
45 | =SI([score]>89,"A";SI([score]>79;"B"; SI([score]>69;"C";SI([score]>59;"D";"F")))) | Attribue une note d'évaluation sous forme de lettre au premier score (F)
90 | =SI([score]>89;"A";SI([score]>79;"B"; SI([score]>69;"C";SI([score]>59;"D";"F")))) | Attribue une note d'évaluation sous forme de lettre au deuxième score (A)
78 | =SI([score]>89;"A";SI([score]>79;"B"; SI([score]>69;"C";SI([score]>59;"D";"F")))) | Attribue une note d'évaluation sous forme de lettre au troisième score (C)

Dans l'exemple précédent, la seconde instruction SI est également l'argument valeur_si_faux de la première instruction SI. De la même façon, la troisième instruction SI est l'argument valeur_si_faux de la deuxième instruction SI. Par exemple, si le premier test_logique ([score]>89) est VRAI, « A » est renvoyé. Si le premier test_logique est FAUX, la deuxième instruction SI est évaluée, etc.

Les lettres de notation sont attribuées aux nombres selon les règles suivantes (en supposant que seuls des entiers sont utilisés).

Si score est | l'expression renvoie
supérieur à 89 | A
entre 80 et 89 | B
entre 70 et 79 | C
entre 60 et 69 | D
inférieur à 60 | F


NON

Inverse la valeur de son argument. Utilisez NON lorsque vous voulez vérifier qu'une valeur n'est pas égale à une valeur particulière.

Syntaxe

NON(logique)

valeur_logique représente une valeur ou expression qui peut prendre la valeur VRAI ou FAUX.

Remarque

Si logique est FAUX, NON renvoie VRAI ; si logique est VRAI, NON renvoie FAUX.

Exemple

Formule | Description (résultat)
=NON(FAUX) | Inverse FAUX (VRAI)
=NON(1+1=2) | Inverse une équation qui est évaluée à VRAI (FAUX)


OU

Renvoie la valeur VRAI si un argument est VRAI et FAUX si tous les arguments sont FAUX.

Syntaxe

OU(valeur_logique1;valeur_logique2;...)

valeur_logique1;valeur_logique2; ... représentent les 1 à 30 conditions que vous souhaitez tester et qui peuvent être soit VRAI, soit FAUX.

Remarques

  • Les arguments doivent être évalués à des valeurs logiques, telles que VRAI ou FAUX, ou doivent être des matrices ou des références contenant des valeurs logiques.
  • Si un argument référence de colonne contient du texte ou est vide, ces valeurs sont ignorées.
  • Si la plage spécifiée ne contient aucune valeur logique, la fonction OU renvoie la valeur d'erreur #VALEUR!.
  • Si un ou plusieurs arguments contiennent #NUL!, OU renvoie la valeur #NUL!.

Exemples

Formule | Description (résultat)
=OU(VRAI) | Un argument est VRAI (VRAI)
=OU(1+1=1;2+2=5) | Tous les arguments ont pour résultat FAUX (FAUX)
=OU(VRAI;FAUX;VRAI) | Au moins un argument est VRAI (VRAI)
=OU(#NUL!,#NUL!) | Les deux arguments contiennent #NUL!(#NUL!)
=OU(1+1=1,#NUL!) | Le premier argument a pour résultat FAUX et #NUL! est l’autre argument (#NUL!)


VRAI

Renvoie la valeur logique VRAI.

Syntaxe

VRAI( )

Remarque

Vous pouvez entrer directement la valeur VRAI sans utiliser cette fonction. La fonction VRAI permet avant tout d'assurer la compatibilité avec d'autres programmes.


ABS

Renvoie la valeur absolue d'un nombre. La valeur absolue d'un nombre est le nombre sans son signe.

Syntaxe

ABS(nombre)

nombre représente le nombre réel dont vous voulez obtenir la valeur absolue.

Exemples

Col1 | Formule | Description (résultat)
-4 | =ABS([Col1]) | Valeur absolue de -4 (4)


ACOS

Renvoie l'arccosinus, ou cosinus inverse, d'un nombre. L'arccosinus est l'angle dont le cosinus est nombre. L'angle renvoyé est exprimé en radians, dans une plage allant de 0 (zéro) à pi.

Syntaxe

ACOS(nombre)

nombre représente le cosinus de l'angle de votre choix et doit être compris entre -1 et 1.

Remarque

Si vous voulez convertir le résultat de radians en degrés, multipliez-le par 180/PI() ou bien utilisez la fonction DEGRES.

Exemple

Formule | Description (résultat)
=ACOS(-0,5) | Arccosinus de -0,5 en radians, 2*pi/3 (2,094395)
=ACOS(-0,5)*180/PI() | Arccosinus de -0,5 en degrés (120)
=DEGRES(ACOS(-0,5)) | Arccosinus de -0,5 en degrés (120)


ACOSH

Renvoie le cosinus hyperbolique inverse d'un nombre. Ce nombre doit être supérieur ou égal à 1. Le cosinus hyperbolique inverse est la valeur dont le cosinus hyperbolique est nombre ; ACOSH(COSH(nombre)) est donc égal à nombre.

Syntaxe

ACOSH(nombre)

nombre représente tout nombre réel égal ou supérieur à 1.

Exemple

Formule | Description (résultat)
=ACOSH(1) | Cosinus hyperbolique inverse de 1 (0)
=ACOSH(10) | Cosinus hyperbolique inverse de 10 (2,993223)


ASIN

Renvoie l'arcsinus, ou sinus inverse, d'un nombre. L'arcsinus est l'angle dont le sinus est nombre. L'angle renvoyé est exprimé en radians, dans une plage allant de -pi/2 à pi/2.

Syntaxe

ASIN(nombre)

nombre représente le sinus de l'angle de votre choix et doit être compris entre -1 et 1.

Remarque

Pour exprimer l'arcsinus en degrés, multipliez le résultat par 180/PI() ou bien utilisez la fonction DEGRES.

Formule | Description (résultat)
=ASIN(-0,5) | Arcsinus de -0,5 en radians, -pi/6 (-0,5236)
=ASIN(-0,5)*180/PI() | Arcsinus de -0,5 en degrés (-30)
=DEGRES(ASIN(-0,5)) | Arcsinus de -0,5 en degrés (-30)


ASINH

Renvoie le sinus hyperbolique inverse d'un nombre. Le sinus hyperbolique inverse est la valeur dont le sinus hyperbolique est nombre ; ASINH(SINH(nombre)) est donc égal à nombre.

Syntaxe

ASINH(nombre)

nombre représente un nombre réel quelconque.

Exemple

Formule | Description (résultat)
=ASINH(-2,5) | Sinus hyperbolique inverse de -2,5 (-1,64723)
=ASINH(10) | Sinus hyperbolique inverse de 10 (2,998223)


ATAN

Renvoie l'arctangente, ou tangente inverse, d'un nombre. L'arctangente est l'angle dont la tangente est ce nombre. L'angle renvoyé est exprimé en radians, dans une plage allant de -pi/2 à pi/2.

Syntaxe

ATAN (nombre)

nombre représente la tangente de l'angle de votre choix.

Remarque

Pour exprimer l'arctangente en degrés, multipliez le résultat par 180/PI() ou bien utilisez la fonction DEGRES.

Exemple

Formule | Description (résultat)
=ATAN(1) | Arctangente de 1 en radians, pi/4 (0,785398)
=ATAN(1)*180/PI() | Arctangente de 1 en degrés (45)
=DEGRES(ATAN(1)) | Arctangente de 1 en degrés (45)


ATAN2

Renvoie l'arctangente, ou tangente inverse, des coordonnées x et y spécifiées. L'arctangente est l'angle entre l'axe des x et une ligne allant de l'origine (0, 0) à un point dont les coordonnées sont (nombre_x, nombre_y). L'angle est exprimé en radians entre -pi et pi, à l'exclusion de -pi.

Syntaxe

ATAN2(nombre_x;nombre_y)

nombre_X représente la coordonnée x (abscisse) du point.

nombre_Y représente la coordonnée y (ordonnée) du point.

Remarques

  • Un résultat positif représente un angle dans le sens inverse des aiguilles d'une montre à partir de l'axe des x ; un résultat négatif représente un angle dans le sens des aiguilles d'une montre.
  • ATAN2(a;b) égale ATAN(b/a), excepté que a peut être égal à 0 dans ATAN2.
  • Si nombre_x et nombre_y sont tous deux égaux à 0, ATAN2 renvoie la valeur d'erreur #DIV/0!.
  • Pour exprimer l'arctangente en degrés, multipliez le résultat par 180/PI() ou bien utilisez la fonction DEGRES.

Exemple

Formule | Description (résultat)
=ATAN2(1;1) | Arctangente du point 1,1 en radians, pi/4 (0,785398)
=ATAN2(-1;-1) | Arctangente du point -1,-1 en radians, -3*pi/4 (-2,35619)
=ATAN2(-1;-1)*180/PI() | Arctangente du point 1,1 en degrés (-135)
=DEGRES(ATAN2(-1;-1)) | Arctangente du point 1,1 en degrés (-135)


ATANH

Renvoie la tangente hyperbolique inverse d'un nombre. Ce nombre doit être compris entre -1 et 1. La tangente hyperbolique inverse est la valeur dont la tangente hyperbolique est nombre ; ATANH(TANH(nombre)) est égal à nombre.

Syntaxe

ATANH(nombre)

nombre représente tout nombre réel compris entre 1 et -1.

Exemple

Formule | Description (résultat)
=ATANH(0,76159416) | Tangente hyperbolique inverse de 0,76159416 (1, approximativement)
=ATANH(-0,1) | Tangente hyperbolique inverse de -0,1 (-0,10034)


PLAFOND

Renvoie un nombre arrondi vers le haut, au multiple de l'argument précision. Par exemple, si vous voulez éviter l'utilisation de centimes à l'unité dans vos prix et que votre produit est tarifé à 4,42€, utilisez la formule =PLAFOND(4,42;0,05) pour arrondir le prix vers le haut, au multiple de 5 centimes le plus proche.

Syntaxe

PLAFOND(nombre;précision)

nombre est la valeur que vous voulez arrondir.

précision représente le multiple auquel vous souhaitez arrondir.

Remarques

  • Si un des arguments n'est pas numérique, PLAFOND renvoie la valeur d'erreur #VALEUR!.
  • Quel que soit le signe de nombre, la valeur est arrondie en s'éloignant de zéro. Si nombre est un multiple exact de l'argument précision, aucun arrondi n'est effectué.
  • Si nombre et précision sont de signes opposés, PLAFOND renvoie la valeur d'erreur #NOMBRE!

Exemple

Formule | Description (résultat)
=PLAFOND(2,5;1) | Arrondit 2,5 vers le haut, au multiple de 1 le plus proche (3)
=PLAFOND(-2,5;-2) | Arrondit -2,5 vers le haut, au multiple de -2 le plus proche (-4)
=PLAFOND(-2,5;2) | Renvoie une erreur parce que -2,5 et 2 sont de signe différent (#NOMBRE!)
=PLAFOND(1,5;0,1) | Arrondit 1,5 vers le haut, au multiple de 0,1 le plus proche (1,5)
=PLAFOND(0,234;0,01) | Arrondit 0,234 vers le haut, au multiple de 0,01 le plus proche (0,24)


COS

Renvoie le cosinus de l'angle donné.

Syntaxe

COS(nombre)

nombre représente l'angle, exprimé en radians, dont vous voulez obtenir le cosinus.

Remarque

Si l'angle est exprimé en degrés, multipliez-le par PI()/180 ou bien utilisez la fonction RADIANS pour le convertir en radians.

Exemple

Formule | Description (résultat)
=COS(1,047) | Cosinus de 1,047 radians (0,500171)
=COS(60*PI()/180) | Cosinus de 60 degrés (0,5)
=COS(RADIANS(60)) | Cosinus de 60 degrés (0,5)


COSH

Renvoie le cosinus hyperbolique d'un nombre.

Syntaxe

COSH(nombre)

nombre est n'importe quel nombre réel dont vous voulez le cosinus hyperbolique.

Remarque

La formule du cosinus hyperbolique est :

Exemple

Formule | Description (résultat)
=COSH(4) | Cosinus hyperbolique de 4 (27,30823)
=COSH(EXP(1)) | Cosinus hyperbolique de la base du logarithme népérien (7,610125)


DEGRES

Convertit des radians en degrés.

Syntaxe

DEGRES(angle)

angle représente l'angle en radians que vous voulez convertir.

Exemple

Formule | Description (résultat)
=DEGRES(PI()) | Degrés de pi radians (180)


PAIR

Renvoie l'argument nombre après l'avoir arrondi au nombre entier pair le plus proche. Vous pouvez utiliser cette fonction pour traiter des éléments qui vont par paires. Prenons, par exemple, le cas d'une caisse d'emballage pouvant contenir des rangées d'un ou deux articles : la caisse est pleine lorsque le nombre d'articles, arrondi au nombre entier pair le plus proche, correspond à la capacité de la caisse.

Syntaxe

PAIR(nombre)

nombre représente la valeur à arrondir.

Remarques

  • Si nombre n'est pas numérique, PAIR renvoie la valeur d'erreur #VALEUR!
  • Quel que soit le signe du nombre, une valeur est arrondie vers le haut, sa valeur étant déterminée en l'éloignant de zéro. Si le nombre est un entier pair, il n'y a pas d'opération d'arrondi.

Exemple

Formule | Description (résultat)
=PAIR(1,5) | Arrondit 1,5 vers le haut, à l'entier pair le plus proche (2)
=PAIR(3) | Arrondit 3 vers le haut, à l'entier pair le plus proche (4)
=PAIR(2) | Arrondit 2 vers le haut, à l'entier pair le plus proche (2)
=PAIR(-1) | Arrondit -1 vers le haut, à l'entier pair le plus proche (-2)


EXP

Renvoie e élevé à la puissance d'un nombre. La constante e est égale à 2,71828182845904, la base du logarithme népérien (naturel).

Syntaxe

EXP(nombre)

nombre représente l'exposant appliqué à la base e.

Remarques

  • Pour calculer les puissances pour d'autres bases, utilisez l'opérateur d'exponentiation (^).
  • EXP est l'inverse de LN, le logarithme népérien (naturel) d'un nombre.

Exemple

Formule | Description (résultat)
=EXP(1) | Valeur approximative de e (2,718282)
=EXP(2) | Base du logarithme népérien e élevée à la puissance 2 (7,389056)


FACT

Renvoie la factorielle d'un nombre. La factorielle d'un nombre est égale à 1*2*3*...* nombre.

Syntaxe

FACT(nombre)

nombre représente le nombre non négatif dont vous voulez obtenir la factorielle. Si nombre n'est pas un entier, il est tronqué.

Exemple

Formule | Description (résultat)
=FACT(5) | Factorielle de 5, ou 1*2*3*4*5 (120)
=FACT(1,9) | Factorielle de la partie entière de 1,9 (1)
=FACT(0) | Factorielle de 0 (1)
=FACT(-1) | Les nombres négatifs provoquent une valeur d'erreur (#NOMBRE!)
=FACT(1) | Factorielle de 1 (1)


PLANCHER

Arrondit un nombre à l'entier ou au multiple le plus proche de l'argument précision en tendant vers zéro.

Syntaxe

PLANCHER(nombre;précision)

nombre représente la valeur numérique à arrondir.

précision représente le multiple auquel vous souhaitez arrondir.

Remarques

  • Si un des arguments n'est pas numérique, PLANCHER renvoie la valeur d'erreur #VALEUR!.
  • Si nombre et précision sont de signe différent, PLANCHER renvoie la valeur d'erreur #NOMBRE!.
  • Quel que soit le signe du nombre, une valeur est arrondie vers le bas, sa valeur étant déterminée en l'éloignant de zéro. Si le nombre est un multiple exact de précision, il n'y a pas d'opération d'arrondi.

Exemple

Formule | Description (résultat)
=PLANCHER(2,5;1) | Arrondit 2,5 vers le bas, au multiple de 1 le plus proche (2)
=PLANCHER(-2,5;-2) | Arrondit -2,5 vers le bas, au multiple de -2 le plus proche (-2)
=PLANCHER(-2,5;2) | Renvoie une erreur parce que -2,5 et 2 sont de signe différent (#NOMBRE!)
=PLANCHER(1,5;0,1) | Arrondit 1,5 vers le bas, au multiple de 0,1 le plus proche (1,5)
=PLANCHER(0,234;0,01) | Arrondit 0,234 vers le bas, au multiple de 0,01 le plus proche (0,23)


ENT

Arrondit un nombre vers le bas, à l'entier le plus proche.

Syntaxe

ENT(nombre)

nombre représente le nombre réel que vous souhaitez arrondir au nombre entier immédiatement inférieur.

Exemple 1

Formule | Description (résultat)
=ENT(8,9) | Arrondit 8,9 vers le bas (8)
=ENT(-8,9) | Arrondit -8,9 vers le bas (-9)

Exemple 2

Col1 | Formule | Description (résultat)
19,5 | =[Col1]-ENT([Col1]) | Renvoie la partie décimale d'un nombre réel positif dans Col1 (0,5)


LN

Renvoie le logarithme népérien (naturel) d'un nombre. Les logarithmes népériens sont basés sur la constante e (2,71828182845904).

Syntaxe

LN(nombre)

nombre représente le nombre réel positif dont vous souhaitez obtenir le logarithme népérien.

Remarque

LN est l'inverse de la fonction EXP.

Exemple

Formule | Description (résultat)
=LN(86) | Logarithme népérien de 86 (4,454347)
=LN(2,7182818) | Logarithme népérien de la valeur de la constante e (1)
=LN(EXP(3)) | Logarithme népérien de e élevé à la puissance 3 (3)


LOG

Renvoie le logarithme d'un nombre pour la base que vous spécifiez.

Syntaxe

LOG(nombre;base)

nombre représente le nombre réel positif dont vous souhaitez obtenir le logarithme.

base est la base du logarithme. Si base est omis, la valeur 10 lui est attribuée.

Exemple

Formule | Description (résultat)
=LOG(10) | Logarithme de 10 (1)
=LOG(8;2) | Logarithme de 8 en base 2 (3)
=LOG(86;2,7182818) | Logarithme de 86 en base e (4,454347)


LOG10

Renvoie le logarithme en base 10 d'un nombre.

Syntaxe

LOG10(nombre)

nombre représente le nombre réel positif dont vous souhaitez obtenir le logarithme en base 10.

Exemple

Formule | Description (résultat)
=LOG10(86) | Logarithme en base 10 de 86 (1,934498451)
=LOG10(10) | Logarithme en base 10 de 10 (1)
=LOG10(1E5) | Logarithme en base 10 de 1E5 (5)
=LOG10(10^5) | Logarithme en base 10 de 10^5 (5)


MOD

Renvoie le reste de la division d'un nombre par un diviseur. Le résultat a le même signe que le diviseur.

Syntaxe

MOD(nombre;diviseur)

nombre représente le nombre à diviser pour obtenir le reste.

diviseur représente le nombre par lequel vous souhaitez diviser nombre.

Remarques

  • Si diviseur est égal à 0, MOD renvoie la valeur d'erreur #DIV/0!.

  • La fonction MOD peut être exprimée à l'aide de la fonction INT :

    MOD(n, d) = n - d*INT(n/d)

Exemple

Formule | Description (résultat)
=MOD(3; 2) | Reste de 3/2. (1)
=MOD(-3; 2) | Reste de -3/2. Le signe est le même que celui du diviseur. (1)
=MOD(3; -2) | Reste de 3/-2. Le signe est le même que celui du diviseur. (-1)
=MOD(-3; -2) | Reste de -3/-2. Le signe est le même que celui du diviseur. (-1)


IMPAIR

Renvoie le nombre, arrondi à la valeur du nombre entier impair le plus proche en s'éloignant de zéro.

Syntaxe

IMPAIR(nombre)

nombre représente la valeur à arrondir.

Remarques

  • Si l'argument nombre n'est pas numérique, IMPAIR renvoie la valeur d'erreur #VALEUR!.
  • Quel que soit le signe de nombre, la valeur est arrondie en s'éloignant de zéro. Si nombre est déjà un nombre entier impair, il n'est pas arrondi.

Exemples

Formule | Description (résultat)
=IMPAIR(1,5) | Arrondit 1,5 au nombre entier impair le plus proche, en s'éloignant de zéro (3)
=IMPAIR(3) | Arrondit 3 au nombre entier impair le plus proche, en s'éloignant de zéro (3)
=IMPAIR(2) | Arrondit 2 au nombre entier impair le plus proche, en s'éloignant de zéro (3)
=IMPAIR(-1) | Arrondit -1 au nombre entier impair le plus proche, en s'éloignant de zéro (-1)
=IMPAIR(-2) | Arrondit -2 au nombre entier impair le plus proche, en s'éloignant de zéro (-3)


PI

Renvoie la valeur 3,14159265358979, la constante mathématique pi, avec une précision de 15 décimales.

Syntaxe

PI( )

Exemples

Formule | Description (résultat)
=PI() | Pi (3,14159265358979)
=PI()/2 | Pi/2 (1,570796327)
=PI()*(3^2) | Aire d'un cercle avec le rayon (28,27433388)


PUISSANCE

Renvoie la valeur du nombre élevé à une puissance.

Syntaxe

PUISSANCE(nombre;puissance)

nombre représente le nombre de base, un nombre réel quelconque.

puissance représente l'exposant auquel le nombre de base est élevé.

Note

L'opérateur « ^ » peut être utilisé à la place de la fonction PUISSANCE pour indiquer la puissance à laquelle le nombre de base doit être élevé, par exemple 5^2.

Exemples

Formule | Description (résultat)
=PUISSANCE(5;2) | 5 au carré (25)
=PUISSANCE(98,6;3,2) | 98,6 élevé à la puissance de 3,2 (2401077)
=PUISSANCE(4;5/4) | 4 élevé à la puissance de 5/4 (5,656854)


PRODUIT

Renvoie le produit de tous les nombres donnés comme arguments.

Syntaxe

PRODUIT(nombre1;nombre2;...)

nombre1;nombre2; ... représentent de 1 à 30 nombres que vous voulez multiplier.

Remarques

  • Les arguments qui sont des nombres, des valeurs logiques ou des représentations textuelles de nombres sont pris en compte. Les arguments qui correspondent à des valeurs d'erreur ou à du texte qui ne peut pas être converti en nombre génèrent des erreurs.
  • Si un argument est une référence de colonne, seuls les nombres sont comptés. Les arguments vides, les valeurs logiques, le texte ou les valeurs d'erreur sont ignorées.

Exemples

Col1 | Col2 | Col3 | Formule | Description (résultat)
5 | 15 | 30 | =PRODUIT([Col1]; [Col2]; [Col3]) | Multiplie les nombres (2 250)
5 | 15 | 30 | =PRODUIT([Col1]; [Col2]; [Col3];2) | Multiplie les nombres entre eux, puis par 2 (4 500)


RADIANS

Convertit des degrés en radians.

Syntaxe

RADIANS(angle)

angle désigne l'angle en degrés que vous souhaitez convertir.

Exemples

Formule | Description (résultat)
=RADIANS(270) | 270 degrés exprimés en radians (4,712389 ou 3pi/2 radians)


ROMAIN

Convertit un nombre arabe en nombre romain, sous forme de texte.

Syntaxe

ROMAIN(nombre;type)

Nombre est le chiffre arabe que vous souhaitez convertir.

type est un argument déterminant le type de chiffres romains que vous souhaitez obtenir. Le style peut être classique ou simplifié, c'est-à-dire devenir plus concis si les valeurs augmentent. Reportez-vous à l'exemple

ROMAN(499,0)
ci-dessous.

Type | Style
0 ou omis | Classique.
1 | Plus concis, consultez l'exemple plus bas.
2 | Plus concis, consultez l'exemple plus bas.
3 | Plus concis, consultez l'exemple plus bas.
4 | Simplifié.
VRAI | Classique.
FAUX | Simplifié.

Remarques

  • Si l'argument nombre est négatif, la fonction renvoie la valeur d'erreur #VALEUR!.
  • Si nombre est supérieur à 3999, la fonction renvoie la valeur d'erreur #VALEUR!.

Exemples

Formule | Description (résultat)
=ROMAIN(499;0) | Style de chiffres romains classiques pour 499 (CDXCIX)
=ROMAIN(499;1) | Version plus concise pour 499 (LDVLIV)
=ROMAIN(499;2) | Version plus concise pour 499 (XDIX)
=ROMAIN(499;3) | Version plus concise pour 499 (VDIV)
=ROMAIN(499;4) | Version plus concise pour 499 (ID)
=ROMAIN(2013;0) | Style de chiffres romains classiques pour 2013 (MMXIII)


ARRONDI

Le contenu de cette rubrique n'est peut-être pas applicable à certaines langues.

Arrondit un nombre au nombre de chiffres indiqué.

Syntaxe

ARRONDI(nombre;no_chiffres)

nombre représente le nombre à arrondir.

no_chiffres spécifie le nombre de chiffres auquel vous voulez arrondir le nombre.

Remarques

  • Si no_chiffres est supérieur à 0 (zéro), nombre est arrondi au nombre de décimales indiqué.
  • Si no_chiffres est égal à 0, nombre est arrondi au nombre entier le plus proche.
  • Si no_chiffres est inférieur à 0, nombre est arrondi à gauche de la virgule.

Exemple

Formule | Description (résultat)
=ARRONDI(2,15;1) | Arrondit 2,15 à une décimale (2,2)
=ARRONDI(2,149;1) | Arrondit 2,149 à une décimale (2,1)
=ARRONDI(-1,475;2) | Arrondit -1,475 à deux décimales (-1,48)
=ARRONDI(21,5;-1) | Arrondit 21,5 à une décimale à gauche du séparateur décimal (20)


ARRONDI.INF

Arrondit un nombre en tendant vers 0 (zéro).

Syntaxe

ARRONDI.INF(nombre;no_chiffres)

nombre représente un nombre réel quelconque à arrondir en tendant vers zéro.

no_chiffres représente le nombre de chiffres à prendre en compte pour arrondir le nombre.

Remarques

  • La fonction ARRONDI.INF est similaire à la fonction ARRONDI, excepté qu'elle arrondit toujours le nombre en tendant vers zéro.
  • Si l'argument no_chiffres est supérieur à 0 (zéro), le nombre est arrondi à la valeur entière immédiatement inférieure (ou supérieure pour les nombres négatifs) et comporte le nombre de décimales spécifié.
  • Si l'argument no_chiffres est égal à 0, le nombre est arrondi au nombre entier immédiatement inférieur.
  • Si l'argument no_chiffres est inférieur à 0, le nombre est arrondi à la valeur immédiatement inférieure (ou supérieure si négative) par incrémentations de 10, 100, etc., en fonction de la valeur de no_chiffres.

Exemple

Formule | Description (résultat)
=ARRONDI.INF(3,2;0) | Arrondit 3,2 à la valeur entière immédiatement inférieure (3)
=ARRONDI.INF(76,9;0) | Arrondit 76,9 à la valeur entière immédiatement inférieure (76)
=ARRONDI.INF(3,14159;3) | Arrondit 3,14159 à la valeur inférieure comportant trois décimales (3,141)
=ARRONDI.INF(-3,14159;1) | Arrondit -3,14159 à la valeur inférieure comportant une décimale (-3,1)
=ARRONDI.INF(31415,92654;-2) | Arrondit 31415,92654 à gauche du séparateur décimal, à la centaine immédiatement inférieure (31400)


ARRONDI.SUP

Arrondit un nombre en s'éloignant de 0 (zéro).

Syntaxe

ARRONDI.SUP(nombre;no_chiffres)

nombre représente un nombre réel quelconque à arrondir en s'éloignant de zéro.

no_chiffres représente le nombre de chiffres à prendre en compte pour arrondir le nombre.

Remarques

  • La fonction ARRONDI.SUP est similaire à la fonction ARRONDI, excepté qu'elle arrondit toujours le nombre en s'éloignant de zéro.

  • Si l'argument no_chiffres est supérieur à 0 (zéro), le nombre est arrondi à la valeur immédiatement supérieure (ou inférieure pour les nombres négatifs) et comporte le nombre de décimales spécifié.

  • Si l'argument no_chiffres est égal à 0 ou omis, le nombre est arrondi au nombre entier immédiatement supérieur.

  • Si l'argument no_chiffres est inférieur à 0, le nombre est arrondi à la valeur immédiatement supérieure (ou inférieure si négative) par incrémentations de 10, 100, etc., en fonction de la valeur de no_chiffres.

Exemple

Formule | Description (résultat)
=ARRONDI.SUP(3,2;0) | Arrondit 3,2 à la valeur entière immédiatement supérieure (4)
=ARRONDI.SUP(76,9;0) | Arrondit 76,9 à la valeur entière immédiatement supérieure (77)
=ARRONDI.SUP(3,14159;3) | Arrondit 3,14159 à la valeur supérieure comportant trois décimales (3,142)
=ARRONDI.SUP(-3,14159;0,1) | Arrondit -3,14159 à la valeur supérieure comportant une décimale (-3,2)
=ARRONDI.SUP(31415,92654;-2) | Arrondit 31415,92654 à gauche du séparateur décimal, à la centaine immédiatement supérieure (31 500)


SIGNE

Détermine le signe d'un nombre. Renvoie 1 si le nombre est positif, zéro (0) si le nombre est égal à 0 et -1 si le nombre est négatif.

Syntaxe

SIGNE(nombre)

nombre représente n'importe quel nombre réel.

Exemple

Formule | Description (résultat)
=SIGNE(10) | Signe d'un nombre positif (1)
=SIGNE(4-4) | Signe de zéro (0)
=SIGNE(-0,00001) | Signe d'un nombre négatif (-1)


SIN

Renvoie le sinus d'un nombre.

Syntaxe

SIN(nombre)

nombre représente l'angle exprimé en radians dont vous voulez obtenir le sinus.

Remarque

Si l'argument est exprimé en degrés, multipliez-le par PI()/180 ou utilisez la fonction RADIANS pour le convertir en radians.

Exemple

Formule | Description (résultat)
=SIN(PI()) | Sinus de pi radians (0, approximativement)
=SIN(PI()/2) | Sinus de pi/2 radians (1)
=SIN(30*PI()/180) | Sinus de 30 degrés (0,5)
=SIN(RADIANS(30)) | Sinus de 30 degrés (0,5)


SINH

Renvoie le sinus hyperbolique d'un nombre.

Syntaxe

SINH(nombre)

nombre représente n'importe quel nombre réel.

Remarque

La formule du sinus hyperbolique est la suivante :

Exemple 1

Formule | Description (résultat)
=SINH(1) | Sinus hyperbolique de 1 (1,175201194)
=SINH(-1) | Sinus hyperbolique de -1 (-1,175201194)

Exemple 2

Vous pouvez utiliser la fonction de sinus hyperbolique pour obtenir une approximation de courbe de répartition des probabilités. Par exemple, une valeur de test de laboratoire varie entre 0 et 10 secondes. L'analyse empirique des données issues des expérimentations montre que la probabilité d'obtenir un résultat x inférieur à t secondes est estimée à l'aide de l'équation suivante :

P(x<t) = 2,868 * SINH(0,0342 * t), où 0<t<10

Pour calculer la probabilité d'obtenir un résultat inférieur à 1,03 secondes, remplacez la variable t par 1,03.

Formule | Description (résultat)
=2,868*SINH(0,0342*1,03) | Probabilité d'obtenir un résultat inférieur à 1,03 secondes (0,101049063)

La probabilité d'obtention de ce résultat est donc d'environ 101 pour 1000 expérimentations.


RACINE

Donne la racine carrée d'un nombre.

Syntaxe

RACINE(nombre)

nombre représente le nombre dont vous voulez obtenir la racine carrée.

Remarque

Si nombre est négatif, la fonction RACINE renvoie la valeur d'erreur #NOMBRE!.

Exemple

Formule | Description (résultat)
=RACINE(16) | Racine carrée de 16 (4)
=RACINE(-16) | Racine carrée de -16. Ce nombre étant négatif, une erreur est renvoyée (#NOMBRE!).
=RACINE(ABS(-16)) | Racine carrée de la valeur absolue du nombre (4)


SOMME

Additionne tous les nombres figurant dans les arguments spécifiés.

Syntaxe

SOMME(nombre1;nombre2;...)

nombre1;nombre2; ... représentent de 1 à 30 arguments dont vous voulez calculer la valeur totale ou somme.

Remarques

  • Les nombres, les valeurs logiques et les représentations de nombres sous forme de texte directement tapés dans la liste des arguments sont pris en compte. Reportez-vous aux deux premiers exemples ci-dessous.
  • Les arguments génèrent des erreurs s'ils correspondent à des valeurs d'erreur ou à qui ne peut pas être converti en nombre.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
-5 | 15 | 30 |  | VRAI | =SOMME(3;2) | Additionne 3 et 2 (5)
-5 | 15 | 30 |  | VRAI | =SOMME("5";15;VRAI) | Additionne 5, 15 et 1, parce que les valeurs de texte sont converties en nombres et la valeur logique VRAI est convertie en 1 (21)
-5 | 15 | 30 |  | VRAI | =SOMME([Col1];[Col2];[Col3]) | Additionne les nombres des trois premières colonnes (50)
-5 | 15 | 30 |  | VRAI | =SOMME([Col1];[Col2];[Col3];15) | Additionne les nombres des trois premières colonnes et 15 (65)
-5 | 15 | 30 |  | VRAI | =SOMME([Col4];[Col5];2) | Additionne les valeurs des deux dernières colonnes et 2 (2)


SOMME.CARRES

Renvoie la somme des carrés des arguments.

Syntaxe

SOMME.CARRES(nombre1;nombre2;...)

nombre1;nombre2; ... représentent de 1 à 30 arguments pour lesquels vous voulez obtenir la somme des carrés.

Exemple

Formule | Description (résultat)
=SOMME.CARRES(3;4) | Somme des carrés de 3 et 4 (25)


TAN

Renvoie la tangente de l'angle donné.

Syntaxe

TAN(nombre)

nombre représente l'angle exprimé en radians dont vous voulez calculer la tangente.

Remarque

Si l'argument est exprimé en degrés, multipliez-le par PI()/180 ou utilisez la fonction RADIANS pour le convertir en radians.

Exemple

Formule | Description (résultat)
=TAN(0,785) | Tangente de 0,785 radians (0,99920)
=TAN(45*PI()/180) | Tangente de 45 degrés (1)
=TAN(RADIANS(45)) | Tangente de 45 degrés (1)


TANH

Donne la tangente hyperbolique d'un nombre.

Syntaxe

TANH(nombre)

nombre représente n'importe quel nombre réel.

Remarque

La formule de la tangente hyperbolique est la suivante :

Exemple

Formule | Description (résultat)
=TANH(-2) | Tangente hyperbolique de -2 (-0,96403)
=TANH(0) | Tangente hyperbolique de 0 (0)
=TANH(0,5) | Tangente hyperbolique de 0,5 (0,462117)


TRONQUE

Tronque un nombre en supprimant la partie décimale de ce nombre de sorte que la valeur renvoyée par défaut soit un nombre entier.

Syntaxe

TRONQUE(nombre;no_chiffres)

nombre représente le nombre à tronquer.

no_chiffres représente le nombre de décimales apparaissant à droite de la virgule après que le chiffre a été tronqué. La valeur par défaut de no_chiffres est 0 (zéro).

Remarque

Les fonctions TRONQUE et ENT sont similaires en ce sens qu'elles renvoient toutes deux des nombres entiers. La fonction TRONQUE supprime la partie décimale d'un nombre. La fonction ENT arrondit les nombres à l'entier immédiatement inférieur en fonction de la valeur de la partie décimale de ces nombres. Les fonctions ENT et TRONQUE diffèrent uniquement lorsqu'il s'agit de nombres négatifs. En effet,

TRUNC(-4.3)
renvoie -4, mais
INT(-4.3)
renvoie -5, parce que -5 est le nombre entier immédiatement inférieur.

Exemple

Formule | Description (résultat)
=TRONQUE(8,9) | Partie entière de 8,9 (8)
=TRONQUE(-8,9) | Partie entière de -8,9 (-8)
=TRONQUE(PI()) | Partie entière de pi (3)


ECART.MOYEN

Renvoie la moyenne des écarts absolus de points de données par rapport à leur moyenne. ECART.MOYEN est une mesure de la variabilité dans un ensemble de données.

Syntaxe

ECART.MOYEN(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments pour lesquels vous voulez la moyenne des écarts absolus.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou qui est vide, ces valeurs sont ignorées ou renvoient la valeur d'erreur #VALEUR! ; la valeur zéro est cependant prise en compte.
  • L'équation pour l'écart moyen est :

ECART.MOYEN est influencé par l'unité de mesure des données en entrée.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
4 | 5 | 6 | 7 | 5 | 4 | 3 | =ECART.MOYEN([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Moyenne des écarts absolus des nombres par rapport à leur moyenne (1,020408)


MOYENNE

Renvoie la moyenne (moyenne arithmétique) des arguments.

Syntaxe

MOYENNE(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments numériques dont vous voulez la moyenne.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un groupe d'arguments ou une référence de colonne contient du texte, des valeurs logiques ou est vide, ces valeurs sont ignorées ou renvoient la valeur d'erreur #VALEUR! ; la valeur zéro est cependant prise en compte.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
10 | 7 | 9 | 27 | 2 | =MOYENNE([Col1];[Col2];[Col3];[Col4];[Col5]) | Moyenne des nombres des colonnes (11)
10 | 7 | 9 | 27 | 2 | =MOYENNE([Col1];[Col2];[Col3];[Col4];[Col5];5) | Moyenne des nombres des colonnes et de 5 (10)


AVERAGEA

Calcule la moyenne (moyenne arithmétique) des valeurs de la liste des arguments. Contrairement à la fonction MOYENNE, les valeurs texte et logiques comme VRAI et FAUX sont incluses dans le calcul.

Syntaxe

AVERAGEA(valeur1;valeur2; ...)

valeur1;valeur2;... représentent 1 à 30 arguments dont vous voulez obtenir la moyenne.

Remarques

  • Les arguments contenant du texte sont évalués à 0 (zéro). Le texte vide ("") est évalué à 0 (zéro). Si le calcul ne doit pas prendre en compte les valeurs texte dans la moyenne, utilisez la fonction MOYENNE.
  • Les arguments qui contiennent VRAI sont évalués à 1 ; les arguments qui contiennent FAUX sont évalués à 0 (zéro).

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Formule | Description (résultat)
10 | 7 | 9 | 2 | 0 |  | =AVERAGEA([Col1];[Col2];[Col3];[Col4];[Col5]) | Moyenne des nombres (5,6).
10 | 10 | 9 | 2 | 1 |  | =AVERAGEA([Col1];[Col2];[Col3];[Col4];[Col6]) | Moyenne des nombres et de l'argument vide (7,75).


LOI.BETA

Renvoie la fonction de densité de probabilité bêta cumulée. Cette fonction est généralement utilisée pour étudier la variation du pourcentage d'un élément présent dans des échantillonnages, par exemple, la durée journalière pendant laquelle les gens regardent la télévision.

Syntaxe

LOI.BETA(x;alpha;bêta;A;B)

x représente la valeur entre A et B à laquelle la fonction doit être évaluée.

alpha représente un paramètre de la distribution.

bêta représente un paramètre de la distribution.

A représente une limite inférieure facultative de l'intervalle des x.

B représente une limite supérieure facultative de l'intervalle des x.

Remarques

  • Si un des arguments n'est pas numérique, LOI.BETA renvoie la valeur d'erreur #VALEUR!.
  • Si alpha = 0 ou bêta = 0, LOI.BETA renvoie la valeur d'erreur #NOMBRE!.
  • Si x < A, x > B ou A = B, LOI.BETA renvoie la valeur d'erreur #NOMBRE!.
  • Si vous ne spécifiez pas les valeurs de A et B, la fonction LOI.BETA utilise la distribution bêta cumulée standard (A = 0 et B = 1).

Exemple

x | alpha | bêta | A | B | Formule | Description (résultat)
2 | 8 | 10 | 1 | 3 | =LOI.BETA([x];[alpha];[bêta];[A];[B]) | Fonction de densité de probabilité bêta cumulée pour les paramètres (0,685470581)


BETA.INVERSE

Renvoie l'inverse de la fonction de distribution des probabilités d'une variable aléatoire selon une loi bêta. En d'autres termes, si probabilité = LOI.BETA(x,...), alors BETA.INVERSE(probabilité,...) = x. La distribution de variable aléatoire selon une loi bêta peut être utilisée dans la planification de projets, pour modéliser les délais d'exécution probables en fonction d'un délai d'exécution attendu et d'une variabilité.

Syntaxe

BETA.INVERSE(probabilité;alpha;bêta;A;B)

probabilité représente une probabilité associée à la distribution bêta.

alpha représente un paramètre de la distribution.

bêta représente un paramètre de la distribution.

A représente une limite inférieure facultative de l'intervalle des x.

B représente une limite supérieure facultative de l'intervalle des x.

Remarques

  • Si un des arguments n'est pas numérique, BETA.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si alpha = 0 ou bêta = 0, BETA.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si probabilité = 0 ou probabilité > 1, BETA.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si vous omettez les valeurs de A et B, BETA.INVERSE utilise la distribution de variable aléatoire selon la loi bêta standard : dans ce cas, A = 0 et B = 1.

BETA.INVERSE utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, BETA.INVERSE fonctionne par itérations jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10-7. Si BETA.INVERSE n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

probabilité | alpha | bêta | A | B | Formule | Description (résultat)
0,685470581 | 8 | 10 | 1 | 3 | =BETA.INVERSE([probabilité];[alpha];[bêta];[A];[B]) | Inverse de la fonction de densité des probabilités d'une variable aléatoire selon une loi bêta pour ces paramètres (2)


LOI.BINOMIALE

Renvoie la probabilité d'une variable aléatoire discrète suivant la loi binomiale. Utilisez LOI.BINOMIALE dans des problèmes avec un nombre fixe de tests ou d'essais, lorsque les résultats des tirages sont seulement des succès ou des échecs, lorsque les essais sont indépendants et que la probabilité de succès est constante tout au long de l'expérimentation. Par exemple, LOI.BINOMIALE peut calculer la probabilité que deux des trois bébés suivants soient des garçons.

Syntaxe

LOI.BINOMIALE(nombre_s;essais;probabilité_s;cumulée)

nombre_s représente le nombre d'essais réussis.

essais représente le nombre d'essais indépendants.

probabilité_s représente la probabilité de succès de chaque essai.

Cumulative représente une valeur logique déterminant le mode de calcul de la fonction : cumulatif ou non. Si cumulative est VRAI, alors LOI.BINOMIALE renvoie la fonction de distribution cumulative, qui est la probabilité qu'il y ait au plus nombre_s succès ; si cumulative est FAUX, elle renvoie la fonction de probabilité de masse, qui est la probabilité qu'il y ait exactement nombre_s succès.

Remarques

  • nombre_s et essais sont tronqués à leur partie entière.
  • Si nombre_s, essais ou probabilité_s ne sont pas des valeurs numériques, LOI.BINOMIALE renvoie la valeur d'erreur #VALEUR!.
  • Si nombre_s < 0 ou nombre_s > essais, LOI.BINOMIALE renvoie la valeur d'erreur #NOMBRE!.
  • Si probabilité_s < 0 ou probabilité_s > 1, LOI.BINOMIALE renvoie la valeur d'erreur #NOMBRE!.
  • La fonction de probabilité de masse binomiale est :

    où :

    est COMBIN(n,x).

    Remarque La fonction COMBIN est utilisée ici pour illustrer la formule mathématique utilisée par la fonction LOI.BINOMIALE. Ce n'est pas une fonction que vous pouvez utiliser dans une liste.

    La distribution binomiale cumulative est :

Exemple

nombre_s | essais | probabilité_s | Formule | Description (résultat)
6 | 10 | 0,5 | =LOI.BINOMIALE([nombre_s];[essais];[probabilité_s];FAUX) | Probabilité que exactement 6 essais sur 10 soient des succès (0,205078)


LOI.KHIDEUX

Renvoie la probabilité d'une variable aléatoire continue suivant une loi unilatérale du Khi-deux. La distribution ?2 est associée à un test ?2. Utilisez le test ?2 pour comparer des valeurs observées et attendues. Par exemple, une expérience de génétique peut être fondée sur l'hypothèse que la génération suivante de plantes va comporter un certain jeu de couleurs. En comparant les résultats observés avec les résultats attendus, vous pouvez décider si votre hypothèse d'origine était valide.

Syntaxe

LOI.KHIDEUX(x;degrés_liberté)

x représente la valeur à laquelle vous voulez évaluer la distribution

degrés_liberté représente le nombre de degrés de liberté.

Remarques

  • Si un des arguments n'est pas numérique, LOI.KHIDEUX renvoie la valeur d'erreur #VALEUR!.
  • Si x est négatif, LOI.KHIDEUX renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté n'est pas un entier, il est tronqué.
  • Si degrés_liberté < 1 ou degrés_liberté = 10^10, LOI.KHIDEUX renvoie une valeur d'erreur #NOMBRE!.
  • LOI.KHIDEUX est calculé comme LOI.KHIDEUX = P(X>x), où X est une variable aléatoire ?2.

Exemple

x | degrés_liberté | Formule | Description (résultat)
18,307 | 10 | =LOI.KHIDEUX([x];[degrés_liberté]) | Probabilité d'une variable aléatoire continue suivant une loi unilatérale du Khi-deux, pour les arguments spécifiés (0,050001)


KHIDEUX.INVERSE

Renvoie l'inverse de la probabilité d'une variable aléatoire continue suivant une loi unilatérale du Khi-deux. Si probabilité = LOI.KHIDEUX(x,...), alors KHIDEUX.INVERSE(probabilité,...) = x. Utilisez cette fonction pour comparer des résultats observés à des résultats attendus pour décider si votre hypothèse d'origine était valide.

Syntaxe

KHIDEUX.INVERSE(probabilité;degrés_liberté)

probabilité représente une probabilité associée à la distribution khi-deux.

degrés_liberté représente le nombre de degrés de liberté.

Remarques

  • Si un des arguments n'est pas numérique, KHIDEUX.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou probabilité > 1, KHIDEUX.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté n'est pas un entier, il est tronqué.
  • Si degrés_liberté < 1 ou degrés_liberté = 10^10, KHIDEUX.INVERSE renvoie la valeur d'erreur #NOMBRE!.

KHIDEUX.INVERSE utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, KHIDEUX.INVERSE fonctionne par itération jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10^-7. Si KHIDEUX.INVERSE n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

probabilité | degrés_liberté | Formule | Description (résultat)
0,05 | 10 | =KHIDEUX.INVERSE([probabilité];[degrés_liberté]) | Inverse de la probabilité d'une variable aléatoire continue suivant une loi unilatérale du Khi-deux (18,30703)


INTERVALLE.CONFIANCE

Renvoie l'intervalle de confiance pour une moyenne de population avec une distribution normale. L'intervalle de confiance est une plage de chaque côté d'une moyenne échantillonnée. Par exemple, si vous commandez un produit par courrier, vous pouvez déterminer, avec un niveau spécifique de confiance, la date au plus tôt et la date au plus tard à laquelle le produit va arriver.

Syntaxe

INTERVALLE.CONFIANCE(alpha;écart-type;taille)

alpha représente le niveau critique utilisé pour calculer le niveau de confiance. Celui-ci est égal à 100*(1 - alpha) % ; en d'autres termes, un alpha de 0,05 indique un niveau de confiance de 95 %.

écart-type représente l'écart-type de la population pour la plage de données ; il est supposé connu.

taille représente la taille de l'échantillon.

Remarques

  • Si un des arguments n'est pas numérique, INTERVALLE.CONFIANCE renvoie la valeur d'erreur #VALEUR!.
  • Si alpha = 0 ou alpha = 1, INTERVALLE.CONFIANCE renvoie la valeur d'erreur #NOMBRE!.
  • Si écart-type = 0, INTERVALLE.CONFIANCE renvoie la valeur d'erreur #NOMBRE!.
  • Si taille n'est pas un entier, il est tronqué.
  • Si taille < 1, INTERVALLE.CONFIANCE renvoie la valeur d'erreur #NOMBRE!.
  • En supposant une valeur alpha égale à 0,05, il faut calculer la zone sous la courbe normale standard qui est égale à (1 - alpha), c'est-à-dire à 95 pour cent. Cette valeur est ± 1,96. Le niveau de confiance est donc :

Exemple

Supposons que, sur un échantillon de 50 voyageurs, la durée moyenne du trajet vers le lieu de travail est de 30 minutes avec un écart-type de population de 2,5. On peut alors être sûr à 95 % que la moyenne de la population se trouve dans l'intervalle :

alpha | écart-type | taille | Formule | Description (résultat)
0,05 | 0,5 | 50 | =INTERVALLE.CONFIANCE([alpha];[écart-type];[taille]) | Intervalle de confiance pour une moyenne de population. En d'autres termes, la durée moyenne du trajet vers le lieu de travail est égale à 30 ± 0,692951 minutes, ou 29,3 à 30,7 minutes. (0,692951)


NB

Compte le nombre d'arguments qui contiennent des nombres.

Syntaxe

NB(valeur1;valeur2; ...)

valeur1; valeur2; ... représentent 1 à 30 arguments qui peuvent contenir ou référencer différents types de données, seuls les nombres étant comptés.

Remarques

  • Les arguments qui sont des nombres, des dates ou des représentations de nombres sous forme de texte sont comptés ; les arguments qui sont des valeurs d'erreur ou du texte qui ne peut pas être converti en nombre sont ignorés.
  • Si vous devez compter des valeurs logiques, du texte ou des valeurs d'erreur, utilisez la fonction NBVAL.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
Ventes | 12/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | =NB([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Compte le nombre d'arguments de la liste qui contiennent des nombres (3)
 |  |  | 19 | 22,24 | VRAI | #DIV/0! | =NB([Col4];[Col5];[Col6];[Col7]) | Compte le nombre d'arguments qui contiennent des nombres dans les 4 dernières lignes de la liste (2)
Ventes | 2/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | NB([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7];2) | Compte le nombre d'arguments de la liste qui contiennent des nombres, ainsi que la valeur 2 (4)


NBVAL

Compte le nombre d'arguments qui ne sont pas vides.

Syntaxe

NBVAL(valeur1;valeur2; ...)

valeur1; valeur2; ... représentent 1 à 30 arguments correspondant aux valeurs à compter. Dans ce cas, une valeur est tout type d'information, y compris du texte vide (""), mais à l'exclusion des arguments vides. Si vous ne devez pas compter des valeurs logiques, du texte ou des valeurs d'erreur, utilisez la fonction NB.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
Ventes | 12/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | =NBVAL([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Compte le nombre d'arguments non vides dans la liste (6)
Ventes | 12/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | =NBVAL([Col4];[Col5];[Col6];[Col7])) | Compte le nombre d'arguments non vides dans les 4 dernières lignes de la liste (4)
Ventes | 12/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | =NBVAL([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7];2) | Compte le nombre d'arguments non vides de la liste, ainsi que la valeur 2 (7)
Ventes | 12/8/2008 |  | 19 | 22,24 | VRAI | #DIV/0! | =NBVAL([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7];"Deux") | Compte le nombre d'arguments non vides de la liste, ainsi que la valeur « Deux » (7)


CRITERE.LOI.BINOMIALE

Renvoie la plus petite valeur pour laquelle la distribution binomiale cumulée est supérieure ou égale à une valeur critère. Utilisez cette fonction pour les applications d'assurance qualité. Par exemple, utilisez CRITERE.LOI.BINOMIALE pour déterminer le nombre le plus élevé de pièces défectueuses qui peut être accepté sur une ligne d'assemblage sans que la totalité du lot soit rejetée.

Syntaxe

CRITERE.LOI.BINOMIALE(tirages;probabilité_s;alpha)

tirages représente le nombre de tirages de Bernoulli.

probabilité_s représente la probabilité d'un succès pour chaque tirage.

alpha représente la valeur critère.

Remarques

  • Si un des arguments n'est pas numérique, CRITERE.LOI.BINOMIALE renvoie la valeur d'erreur #VALEUR!.
  • Si tirages n'est pas un entier, il est tronqué.
  • Si tirages < 0, CRITERE.LOI.BINOMIALE renvoie la valeur d'erreur #NOMBRE!.
  • Si probabilité_s est < 0 ou probabilité_s > 1, CRITERE.LOI.BINOMIALE renvoie la valeur d'erreur #NOMBRE!.
  • Si alpha < 0 ou alpha > 1, CRITERE.LOI.BINOMIALE renvoie la valeur d'erreur #NOMBRE!.

Exemple

tirages | probabilité_s | alpha | Formule | Description (résultat)
6 | 0,5 | 0,75 | =CRITERE.LOI.BINOMIALE([tirages],[probabilité_s],[alpha]) | Plus petite valeur pour laquelle la distribution binomiale cumulée est supérieure ou égale à une valeur critère (4)


SOMME.CARRES.ECARTS

Renvoie la somme des carrés des écarts de points de données par rapport à la moyenne de leur échantillon.

Syntaxe

SOMME.CARRES.ECARTS(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments pour lesquels vous voulez calculer la somme des écarts au carré.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si l'argument contient du texte, des valeurs logiques ou s'il est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.
  • L'équation pour la somme des écarts au carré est :

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =SOMME.CARRES.ECARTS([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Somme des carrés des écarts des données par rapport à la moyenne de leur échantillon (48)


LOI.EXPONENTIELLE

Renvoie la distribution exponentielle. Utilisez LOI.EXPONENTIELLE pour modéliser le temps entre deux événements, par exemple le temps nécessaire à un distributeur automatique de billets pour délivrer de l'argent. Par exemple, vous pouvez utiliser LOI.EXPONENTIELLE pour déterminer la probabilité que le processus prenne au plus 1 minute.

Syntaxe

LOI.EXPONENTIELLE(x;lambda;cumulative)

x représente la valeur de la fonction.

lambda représente la valeur du paramètre.

cumulative représente une valeur logique indiquant le mode de calcul de la fonction exponentielle. Si l'argument cumulative est VRAI, la fonction LOI.EXPONENTIELLE renvoie la fonction de distribution cumulée. Si l'argument cumulative est FAUX, elle renvoie la fonction de densité de probabilité.

Remarques

  • Si x ou lambda n'est pas numérique, LOI.EXPONENTIELLE renvoie la valeur d'erreur #VALEUR!.
  • Si x < 0, LOI.EXPONENTIELLE renvoie la valeur d'erreur #NOMBRE!.
  • Si lambda = 0, LOI.EXPONENTIELLE renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la fonction de densité de probabilité est :

  • L'équation pour la fonction de distribution cumulée est :

Exemple 1

Formule | Description (résultat)
=LOI.EXPONENTIELLE(0,2;10;FAUX) | Fonction de distribution exponentielle de probabilité (1,353353)

Exemple 2

x | lambda | Formule | Description (résultat)
0,2 | 10 | =LOI.EXPONENTIELLE([x];[lambda];VRAI) | Fonction de distribution exponentielle cumulée (0,864665)


LOI.F

Renvoie la probabilité d'une variable aléatoire suivant une loi F. Vous pouvez utiliser cette fonction pour déterminer si deux séries de données ont des degrés de diversité différents. Par exemple, vous pouvez examiner les résultats de tests proposés à des hommes et à des femmes entrant à l'université et déterminer si la dispersion est différente chez les hommes et chez les femmes.

Syntaxe

LOI.F(x;degrés_liberté1;degrés_liberté2)

x représente la variable avec laquelle la fonction doit être calculée.

degrés_liberté1 représente le nombre de degrés de liberté du numérateur.

degrés_liberté2 représente le nombre de degrés de liberté du dénominateur.

Remarques

  • Si un des arguments n'est pas numérique, LOI.F renvoie la valeur d'erreur #VALEUR!.
  • Si x est négatif, LOI.F renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté1 ou degrés_liberté2 n'est pas un entier, il est tronqué.
  • Si degrés_liberté1 < 1 ou degrés_liberté1 = 10^10, LOI.F renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté2 < 1 ou degrés_liberté2 = 10^10, LOI.F renvoie la valeur d'erreur #NOMBRE!.
  • LOI.F est calculé comme LOI.F=P( F<x ), où F est une variable aléatoire qui a une distribution F.

Exemple

x | degrés1 | degrés2 | Formule | Description (résultat)
15,20675 | 6 | 4 | =LOI.F([x];[degrés1];[degrés2]) | Probabilité d'une variable aléatoire suivant une loi F pour les arguments spécifiés (0,01)


INVERSE.LOI.F

Renvoie l'inverse de la distribution de probabilité suivant une loi F. Si p = LOI.F(x,...), alors INVERSE.LOI.F(p,...) = x.

La distribution suivant une loi F peut être utilisée dans un test F qui compare le degré de variabilité de deux séries de données. Par exemple, vous pouvez analyser la distribution des revenus aux États-Unis et au Canada pour déterminer si les deux pays ont un degré similaire de diversité.

Syntaxe

INVERSE.LOI.F(probabilité;degrés_liberté1;degrés_liberté2)

probabilité représente une probabilité associée à la distribution cumulée F.

degrés_liberté1 représente le nombre de degrés de liberté du numérateur.

degrés_liberté2 est le nombre de degrés de liberté du dénominateur.

Remarques

  • Si un des arguments n'est pas numérique, INVERSE.LOI.F renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou probabilité > 1, INVERSE.LOI.F renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté1 ou degrés_liberté2 n'est pas un entier, il est tronqué.
  • Si degrés_liberté1 < 1 ou degrés_liberté1 = 10^10, INVERSE.LOI.F renvoie la valeur d'erreur #NOMBRE!.
  • Si degrés_liberté2 < 1 ou degrés_liberté2 = 10^10, INVERSE.LOI.F renvoie la valeur d'erreur #NOMBRE!.

INVERSE.LOI.F peut être utilisé pour renvoyer des valeurs critiques de la distribution F. Par exemple, le résultat d'un calcul ANALYSE DE VARIANCE comprend souvent des données pour les statistiques de F, la probabilité de F et la valeur critique de F au niveau d'importance 0,05. Pour renvoyer la valeur critique de F, utilisez le niveau d'importance comme argument probabilité avec INVERSE.LOI.F.

INVERSE.LOI.F utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, INVERSE.LOI.F fonction par itération jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10^-7. Si INVERSE.LOI.F n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

probabilité | degrés1 | degrés2 | Formule | Description (résultat)
0,01 | 6 | 4 | =INVERSE.LOI.F([probabilité];[degrés1];[degrés2]) | Inverse de la distribution de probabilité suivant une loi F pour les arguments spécifiés (15,20675)


FISHER

Renvoie la transformation de Fisher à x. Cette transformation produit une fonction qui est approximativement normalement distribuée au lieu d'être asymétrique. Utilisez cette fonction pour effectuer des tests d'hypothèses sur le coefficient de corrélation.

Syntaxe

FISHER(x)

x représente une valeur numérique pour laquelle vous voulez réaliser la transformation.

Remarques

  • Si x n'est pas numérique, FISHER renvoie la valeur d'erreur #VALEUR!.
  • Si x = -1 ou si x = 1, FISHER renvoie la valeur d'erreur #NOMBRE!.

  • L'équation pour la transformation de Fisher est :

Exemple

Formule | Description (résultat)
=FISHER(0,75) | Transformation de Fisher à 0,75 (0,972955)


FISHER.INVERSE

Renvoie l'inverse de la transformation de Fisher. Utilisez cette transformation lors de l'analyse de corrélations entre des séries ou des tableaux de données. Si y = FISHER(x), alors FISHER.INVERSE(y) = x.

Syntaxe

FISHER.INVERSE(y)

y représente la valeur pour laquelle vous voulez réaliser l'inverse de la transformation.

Remarques

  • Si y n'est pas numérique, FISHER.INVERSE renvoie la valeur d'erreur #VALEUR!.

  • L'équation pour l'inverse de la transformation de Fisher est :

Exemple

Formule | Description (résultat)
=FISHER.INVERSE(0,972955) | Inverse de la transformation de Fisher à 0,972955 (0,75)


LOI.GAMMA

Renvoie la probabilité d'une variable aléatoire suivant une loi Gamma. Vous pouvez utiliser cette fonction pour étudier des variables dont la distribution est susceptible d'être asymétrique. La loi gamma est couramment utilisée dans l'étude de files d'attente.

Syntaxe

LOI.GAMMA(x; alpha;bêta;cumulative)

x représente la valeur à laquelle vous voulez évaluer la distribution

alpha représente un paramètre de la distribution.

bêta représente un paramètre de la distribution. Si bêta vaut 1, cette fonction renvoie la probabilité d'une variable aléatoire suivant une loi Gamma centrée réduite.

Cumulative représente une valeur logique déterminant le mode de calcul de la fonction : cumulatif ou non. Si l'argument cumulative est VRAI, la fonction LOI.GAMMA renvoie la fonction de distribution cumulée ; si l'argument cumulative est FAUX, la fonction renvoie la fonction de probabilité de masse.

Remarques

  • Si x, alpha ou bêta n'est pas numérique, LOI.GAMMA renvoie la valeur d'erreur #VALEUR!.
  • Si x < 0, LOI.GAMMA renvoie la valeur d'erreur #NOMBRE!.
  • Si alpha = 0 ou si bêta = 0, LOI.GAMMA renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la distribution gamma est :

    La distribution gamma standard est :

  • Lorsque alpha = 1, LOI.GAMMA renvoie la distribution exponentielle avec :

  • Pour un entier positif n, lorsque alpha = n/2, bêta = 2 et cumulative = VRAI, LOI.GAMMA renvoie (1 - LOI.KHIDEUX(x)) avec n degrés de liberté.
  • Lorsque alpha est un entier positif, LOI.GAMMA est également appelé distribution d'Erlang.

Exemple

x | alpha | bêta | Formule | Description (résultat)
10 | 9 | 2 | =LOI.GAMMA([x];[alpha];[bêta];FAUX) | Distribution gamma des probabilités pour les arguments spécifiés (0,032639)
10 | 9 | 2 | =LOI.GAMMA([x];[alpha];[bêta];VRAI) | Distribution gamma cumulée pour les arguments spécifiés (0,068094)


LOI.GAMMA.INVERSE

Renvoie l'inverse de la distribution gamma cumulée. Si p = LOI.GAMMA(x,...), alors LOI.GAMMA.INVERSE(p,...) = x.

Vous pouvez utiliser cette fonction pour étudier une variable dont la distribution est susceptible d'être asymétrique.

Syntaxe

LOI.GAMMA.INVERSE(probabilité;alpha;bêta)

probabilité représente la probabilité associée à la loi Gamma.

alpha représente un paramètre de la distribution.

bêta représente un paramètre de la distribution. Si bêta vaut 1, cette fonction renvoie la loi gamma standard.

Remarques

  • Si un des arguments n'est pas numérique, LOI.GAMMA.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou probabilité > 1, LOI.GAMMA.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si alpha = 0 ou si bêta = 0, LOI.GAMMA.INVERSE renvoie la valeur d'erreur #NOMBRE!.

LOI.GAMMA.INVERSE utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, LOI.GAMMA.INVERSE fonctionne par itération jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10^-7. Si LOI.GAMMA.INVERSE n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

probabilité | alpha | bêta | Formule | Description (résultat)
0,068094 | 9 | 2 | =LOI.GAMMA.INVERSE([probabilité];[alpha];[bêta]) | Inverse de la distribution cumulée gamma pour les arguments spécifiés (10)


LNGAMMA

Renvoie le logarithme népérien de la fonction gamma, G(x).

Syntaxe

LNGAMMA(x)

x représente la valeur pour laquelle vous souhaitez calculer LNGAMMA.

Remarques

  • Si x n'est pas numérique, LNGAMMA renvoie la valeur d'erreur #VALEUR!.
  • Si x = 0, LNGAMMA renvoie la valeur d'erreur #NOMBRE!.
  • Le nombre e élevé à la puissance LNGAMMA(i), où i est un entier, renvoie le même résultat que (i - 1)!.
  • LNGAMMA est calculé comme suit :

    où :

Exemple

Formule | Description (résultat)
=LNGAMMA(4) | Logarithme népérien de la fonction gamma à 4 (1,791759)


MOYENNE.GEOMETRIQUE

Renvoie la moyenne géométrique de données positives. Par exemple, vous pouvez utiliser la fonction MOYENNE.GEOMETRIQUE pour calculer un taux de croissance moyen à partir d'un intérêt composé à taux variables.

Syntaxe

MOYENNE.GEOMETRIQUE(nombre1;nombre2; ...)

nombre1;nombre2;... représentent 1 à 30 arguments dont vous souhaitez calculer la moyenne.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou si elle est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.
  • Si des points de données sont = 0, MOYENNE.GEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la moyenne géométrique est :

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =MOYENNE.GEOMETRIQUE([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Moyenne géométrique des données (5,476987)


MOYENNE.HARMONIQUE

Renvoie la moyenne harmonique d'une série de données. La moyenne harmonique est la réciproque de la moyenne arithmétique des réciproques.

Syntaxe

MOYENNE.HARMONIQUE(nombre1;nombre2;...)

nombre1;nombre2;... représentent 1 à 30 arguments dont vous souhaitez calculer la moyenne.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou si elle est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.
  • Si des points de données sont = 0, MOYENNE.HARMONIQUE renvoie la valeur d'erreur #NOMBRE!.
  • La moyenne harmonique est toujours inférieure à la moyenne géométrique, qui est toujours inférieure à la moyenne arithmétique.
  • L'équation pour la moyenne harmonique est :

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Formule | Description (résultat)
4 | 5 | 8 | 7 | 11 | 4 | 3 | =MOYENNE.HARMONIQUE([Col1];[Col2];[Col3];[Col4];[Col5];[Col6];[Col7]) | Moyenne harmonique des données (5,028376)


LOI.HYPERGEOMETRIQUE

Renvoie la probabilité d'une variable aléatoire discrète suivant une loi hypergéométrique. LOI.HYPERGEOMETRIQUE renvoie la probabilité d'un nombre donné de succès d'un échantillon, étant donnés la taille de l'échantillon, les succès de la population et la taille de la population. Utilisez LOI.HYPERGEOMETRIQUE pour des problèmes de population finie, où chaque observation est soit un succès soit un échec, et où chaque sous-ensemble d'une taille donnée est choisi avec une probabilité égale.

Syntaxe

LOI.HYPERGEOMETRIQUE(succès_échantillon;nombre_échantillon;succès_population;nombre_population)

succès_échantillon représente le nombre de succès de l'échantillon.

nombre_échantillon représente la taille de l'échantillon.

succès_population représente le nombre de succès de la population.

nombre_population représente la taille de la population.

Remarques

  • Tous les arguments sont tronqués à des entiers.
  • Si un des arguments n'est pas numérique, LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #VALEUR!.
  • Si succès_échantillon < 0 ou si succès_échantillon est supérieur au plus petit des deux arguments nombre_échantillon et succès_population, LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • Si succès_échantillon est inférieur à la valeur la plus grande de 0 ou de (nombre_échantillon - nombre_population + succès_population), LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • Si nombre_échantillon < 0 ou si nombre_échantillon > nombre_population, LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • Si succès_population < 0 ou si succès_population > nombre_population, LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • Si nombre_population < 0, LOI.HYPERGEOMETRIQUE renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la distribution hypergéométrique est :

    où :

    x = succès_échantillon

    n = nombre_échantillon

    M = succès_population

    N = nombre_population

    LOI.HYPERGEOMETRIQUE est utilisée dans l'échantillonnage sans substitution à partir d'une population finie.

Exemple

Un échantillon de chocolats contient 20 pièces. Huit pièces sont au caramel et les douze autres sont aux noisettes. Si une personne choisit 4 pièces au hasard, la fonction suivante renvoie la probabilité que exactement une pièce soit au caramel.

succès_échantillon | nombre_échantillon | succès_population | nombre_population | Formule | Description (résultat)
1 | 4 | 8 | 20 | =LOI.HYPERGEOMETRIQUE([succès_échantillon];[nombre_échantillon];[succès_population];[nombre_population]) | Distribution hypergéométrique pour l'échantillon et la population (0,363261)


KURTOSIS

Renvoie le kurtosis d'une série de données. Pour une distribution comparée avec la distribution normale, le kurtosis caractérise le fait que la distribution présente des pics ou est monotone. Un kurtosis positif indique une distribution avec des pics relatifs. Un kurtosis négatif indique une distribution relativement monotone.

Syntaxe

KURTOSIS(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments pour lesquels vous voulez calculer le kurtosis.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou si elle est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.
  • S'il y a moins de quatre points de données ou si l'écart-type de l'échantillon est égal à zéro, KURTOSIS renvoie la valeur d'erreur #DIV/0!.
  • Le kurtosis est défini comme suit :

    où :

    s est l'écart-type de l'échantillon.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Col8 | Col9 | Col10 | Formule | Description (résultat)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =KURTOSIS([Col1]; [Col2]; [Col3]; [Col4]; [Col5]; [Col6];[Col7];[Col8];[Col9];[Col10]) | Kurtosis de la série de données (-0,1518)


LOI.LOGNORMALE.INVERSE

Renvoie l'inverse de la fonction de distribution de x suivant une loi lognormale cumulée, où ln(x) est normalement distribué avec les paramètres espérance et écart_type. Si p = LOI.LOGNORMALE(x,...), alors LOI.LOGNORMALE.INVERSE(p,...) = x.

Utilisez la distribution lognormale pour analyser des données transformées de façon logarithmique.

Syntaxe

LOI.LOGNORMALE.INVERSE(probabilité;espérance;écart_type)

probabilité est la probabilité associée à la distribution lognormale.

espérance est l'espérance mathématique de ln(x).

écart_type est l'écart-type de ln(x).

Remarques

  • Si un des arguments n'est pas numérique, LOI.LOGNORMALE.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou probabilité > 1, LOI.LOGNORMALE.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si écart_type <= 0, LOI.LOGNORMALE.INVERSE renvoie la valeur d'erreur #NOMBRE!.

  • L'inverse de la fonction de distribution lognormale est :

Exemple

probabilité | espérance | écart_type | Formule | Description (résultat)
0,039084 | 3,5 | 1,2 | =LOI.LOGNORMALE.INVERSE([probabilité];[espérance];[écart-type]) | Inverse de la fonction de distribution cumulée lognormale pour les arguments spécifiés (4,000028)


LOI.LOGNORMALE

Renvoie la distribution de x suivant une loi lognormale cumulée, où ln(x) est normalement distribué avec les paramètres Espérance et Écart_type. Utilisez cette fonction pour analyser des données qui ont été transformées de façon logarithmique.

Syntaxe

LOI.LOGNORMALE(x;espérance;écart_type)

x représente la variable avec laquelle la fonction doit être calculée.

espérance est l'espérance mathématique de ln(x).

écart_type est l'écart-type de ln(x).

Remarques

  • Si un des arguments n'est pas numérique, LOI.LOGNORMALE renvoie la valeur d'erreur #VALEUR!.
  • If x = 0 ou si écart-type = 0, LOI.LOGNORMALE renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la fonction de distribution lognormale cumulée est :

Exemple

x | espérance | écart_type | Formule | Description (résultat)
4 | 3,5 | 1,2 | =LOI.LOGNORMALE([x];[espérance];[écart_type]) | Distribution lognormale cumulée à 4, avec les arguments spécifiés (0,039084)


MAX

Renvoie la valeur la plus élevée d'un ensemble de valeurs.

Syntaxe

MAX(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 nombres pour lesquels vous souhaitez trouver la valeur maximale.

Remarques

  • Vous pouvez spécifier des arguments qui sont des nombres, des arguments vides, des valeurs logiques ou des représentations de nombres sous forme de texte. Les arguments qui sont des valeurs d'erreur ou du texte qui ne peut pas être traduit en nombre provoquent des erreurs.
  • Si les valeurs logiques et le texte ne doivent pas être ignorés, utilisez MAXA.
  • Si les arguments ne contiennent pas de nombres, MAX renvoie 0 (zéro).

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
10 | 7 | 9 | 27 | 2 | =MAX([Col1];[Col2];[Col3];[Col4];[Col5]) | Valeur la plus élevée des nombres (27)
10 | 7 | 9 | 27 | 2 | =MAX([Col1];[Col2];[Col3];[Col4];[Col5];30) | Valeur la plus élevée des nombres et de 30 (30)


MAXA

Renvoie la valeur la plus élevée d'une liste d'arguments. Les valeurs texte et logiques comme VRAI et FAUX sont comparées au même titre que les nombres.

MAXA est similaire à MINA. Pour plus d'informations, voir les exemples donnés pour MINA.

Syntaxe

MAXA(valeur1;valeur2; ...)

valeur1; valeur2; ... représentent 1 à 30 valeurs pour lesquelles vous souhaitez trouver la valeur la plus élevée.

Remarques

  • Vous pouvez spécifier des arguments qui sont des nombres, des arguments vides, des valeurs logiques ou des représentations de nombres sous forme de texte. Les arguments qui sont des valeurs d'erreur provoquent des erreurs. Si le calcul ne doit pas porter sur des valeurs texte ou logiques, utilisez la fonction MAX.
  • Les arguments qui contiennent VRAI sont évalués à 1 ; les arguments qui contiennent du texte ou FAUX sont évalués à 0 (zéro).
  • Si les arguments ne contiennent pas de valeurs, MAXA renvoie 0 (zéro).

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
0 | 0,2 | 0,5 | 0,4 | VRAI | =MAXA([Col1];[Col2];[Col3];[Col4];[Col5]) | Valeur la plus élevée des nombres. VRAI est évalué à 1 (1)


MEDIANE

Renvoie la médiane des nombres donnés. La médiane est le nombre qui est au milieu d'une série de nombres ; en d'autres termes, une moitié des nombres a des valeurs qui sont supérieures à la médiane et l'autre moitié a des valeurs qui lui sont inférieures.

Syntaxe

MEDIANE(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent les 1 à 30 nombres dont vous souhaitez obtenir la médiane.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou si elle est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.

  • Sil les nombres de la série sont en nombre pair, MEDIANE calcule la moyenne des deux nombres du milieu. Voir le deuxième exemple ci-dessous.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Formule | Description (résultat)
1 | 2 | 3 | 4 | 5 | 6 | =MEDIANE([Col1];[Col2];[Col3];[Col4];[Col5]) | Médiane des 5 premiers nombres de la liste (3)
1 | 2 | 3 | 4 | 5 | 6 | =MEDIANE([Col1];[Col2];[Col3];[Col4];[Col5];[Col6]) | Médiane de tous les nombres, ou moyenne de 3 et de 4 (3,5)


MIN

Renvoie la valeur la moins élevée d'un ensemble de valeurs.

Syntaxe

MIN(nombre1;nombre2, ...)

nombre1;nombre2; ... représentent les 1 à 30 nombres parmi lesquels vous souhaitez trouver la valeur minimale.

Remarques

  • Vous pouvez spécifier des arguments qui sont des nombres, des arguments vides, des valeurs logiques ou des représentations de nombres sous forme de texte. Les arguments qui sont des valeurs d'erreur ou du texte qui ne peuvent pas être traduit en nombre provoquent des erreurs.
  • Si un argument est une référence de colonne, seuls les nombres sont utilisés. Si les valeurs logiques et le texte ne doivent pas être ignorés, utilisez MINA.
  • Si les arguments ne contiennent pas de nombres, MIN renvoie 0.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
10 | 7 | 9 | 27 | 2 | =MIN([Col1];[Col2];[Col3];[Col4];[Col5]) | Valeur la moins élevée des nombres (2)
10 | 7 | 9 | 27 | 2 | =MIN([Col1];[Col2];[Col3];[Col4];[Col5];0) | Valeur la moins élevée des nombres et de 0 (0)


MINA

Renvoie la valeur la moins élevée d'une liste d'arguments. Les valeurs texte et logiques comme VRAI et FAUX sont comparées au même titre que les nombres.

Syntaxe

MINA(valeur1;valeur2; ...)

valeur1;valeur2;... représentent 1 à 30 valeurs parmi lesquelles vous voulez rechercher la plus petite valeur.

Remarques

  • Vous pouvez spécifier des arguments qui sont des nombres, des arguments vides, des valeurs logiques ou des représentations de nombres sous forme de texte. Les arguments qui sont des valeurs d'erreur provoquent des erreurs. Si le calcul ne doit pas porter sur des valeurs texte ou logiques, utilisez la fonction MIN.
  • Les arguments qui contiennent VRAI sont évalués à 1 ; les arguments qui contiennent du texte ou FAUX sont évalués à 0 (zéro).
  • Si les arguments ne contiennent pas de nombres, MINA renvoie 0.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Formule | Description (résultat)
FAUX | 0,2 | 0,5 | 0,4 | 0,8 | =MINA([Col1];[Col2];[Col3];[Col4];[Col5]) | Valeur la moins élevée des nombres. FAUX est évalué à 0 (0)


MODE

Renvoie la valeur la plus fréquente ou la plus répétitive dans la liste des arguments. Comme MEDIANE, MODE est une mesure de positionnement.

Syntaxe

MODE(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent les 1 à 30 arguments dont vous souhaitez déterminer le mode.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si un argument est une référence de colonne qui contient du texte, des valeurs logiques ou si elle est vide, ces valeurs sont ignorées ; par contre, les arguments ayant la valeur zéro sont pris en compte.
  • Si la série de données ne contient pas de points de données en doublon, MODE renvoie la valeur d'erreur #N/A.

Dans une série de valeurs, le mode est la valeur qui revient le plus fréquemment ; la médiane est la valeur centrale et la moyenne est la valeur moyenne. Aucune mesure de tendance centrale ne fournit une image complète des données. Supposons des données groupées en trois zones, une moitié autour d'une même valeur basse et une moitié autour de deux valeurs élevées. MOYENNE et MEDIANE peuvent renvoyer une valeur du milieu - relativement vide en données -, et MODE peut renvoyer la valeur basse correspondant à la majorité des données.

Exemple

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Formule | Description (résultat)
5,6 | 4 | 4 | 3 | 2 | 4 | =MODE([Col1];[Col2];[Col3];[Col4];[Col5];[Col6]) | Mode, ou valeur la plus fréquemment présente (4)


LOI.BINOMIALE.NEG

Renvoie la distribution binomiale négative. LOI.BINOMIALE.NEG renvoie la probabilité qu'il y ait nombre_échecs échecs avant le succès N° nombre_succès, lorsque la probabilité constante d'un succès est probabilité_succès. Cette fonction est similaire à la distribution binomiale, excepté que le nombre de succès est fixé et que le nombre d'essais est variable. Comme dans la distribution binomiale, il est supposé que les essais sont indépendants.

Par exemple, vous devez trouver 10 personnes ayant des excellents réflexes, et vous savez que la probabilité qu'un candidat ait ces qualifications est de 0,3. LOI.BINOMIALE.NEG calcule la probabilité que vous ayez à interviewer un certain nombre de candidats non qualifiés avant de trouver 10 candidats qualifiés.

Syntaxe

LOI.BINOMIALE.NEG(nombre_échecs;nombre_succès;probabilité_succès)

nombre_échecs représente le nombre d'échecs.

nombre_succès représente le nombre de succès à obtenir.

probabilité_succès représente la probabilité d'obtenir un succès.

Remarques

  • nombre_échecs et nombre_succès doivent être >= 0.
  • nombre_échecs et nombre_succès sont tronqués à leur partie entière.
  • Si un des arguments n'est pas numérique, LOI.BINOMIALE.NEG renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité_succès < 0 ou si probabilité_succès > 1, LOI.BINOMIALE.NEG renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la distribution binomiale négative est :

    où :

    x est nombre_échecs, r est nombre_succès et p est probabilité_succès.

Exemple

nombre_échecs | nombre_succès | probabilité_succès | Formule | Description (résultat)
10 | 5 | 0,25 | =LOI.BINOMIALE.NEG([nombre_échecs];[nombre_succès];[probabilité_succès]) | Distribution binomiale négative pour les arguments spécifiés (0,055049)


LOI.NORMALE

Renvoie la distribution normale pour l'espérance mathématique et l'écart-type spécifiés. Cette fonction a de nombreuses applications en statistique, dont les tests d'hypothèses.

Syntaxe

LOI.NORMALE(x;espérance;écart_type;cumulative)

x représente la valeur dont vous recherchez la distribution

moyenne représente l'espérance mathématique de la distribution.

écart_type représente l'écart type de la distribution.

cumulative représente une valeur logique déterminant le mode de calcul de la fonction : cumulatif ou non. Si l'argument cumulative est VRAI, la fonction LOI.NORMALE renvoie la fonction de distribution cumulée ; si l'argument cumulative est FAUX, elle renvoie la fonction de probabilité de masse.

Remarques

  • Si les arguments espérance ou écart_type ne sont pas numériques, la fonction LOI.NORMALE renvoie la valeur d'erreur #VALEUR!
  • Si écart_type = 0, LOI.NORMALE renvoie la valeur d'erreur #NOMBRE!.
  • Si espérance = 0, écart_type = 1 et cumulative = VRAI, LOI.NORMALE renvoie la distribution normale standard.
  • L'équation pour la fonction de densité normale (cumulative = FAUX) est :

  • Lorsque cumulative = VRAI, la formule est l'intégrale de moins l'infini à x de la formule donnée.

Exemple

x | espérance | écart_type | Formule | Description (résultat)
42 | 40 | 1,5 | =LOI.NORMALE([x];[espérance];[écart_type];VRAI) | Fonction de distribution cumulée pour les arguments spécifiés (0,908789)
42 | 40 | 1,5 | =LOI.NORMALE([x];[espérance];[écart_type];FAUX) | Fonction de probabilité de masse pour les arguments spécifiés (0,10934005)


LOI.NORMALE.INVERSE

Renvoie l'inverse de la distribution cumulée normale pour l'espérance mathématique et l'écart-type spécifiés.

Syntaxe

LOI.NORMALE.INVERSE(probabilité;espérance;écart_type)

probabilité représente une probabilité correspondant à la distribution normale.

espérance représente l'espérance mathématique de la distribution.

écart_type représente l'écart type de la distribution.

Remarques

  • Si un des arguments n'est pas numérique, LOI.NORMALE.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou si probabilité > 1, LOI.NORMALE.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si écart_type = 0, LOI.NORMALE.INVERSE renvoie la valeur d'erreur #NOMBRE!.

  • Si espérance = 0 et écart_type = 1, LOI.NORMALE.INVERSE utilise la distribution normale standard (voir LOI.NORMALE.STANDARD.INVERSE).

LOI.NORMALE.INVERSE utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, LOI.NORMALE.INVERSE fonctionne par itération jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10^-7. Si LOI.NORMALE.INVERSE n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

probabilité | espérance | écart_type | Formule | Description (résultat)
0,908789 | 40 | 1,5 | =LOI.NORMALE.INVERSE([probabilité];[espérance];[écart_type]) | Inverse de la distribution cumulée normale pour les arguments spécifiés (42)


LOI.NORMALE.STANDARD

Renvoie la fonction de distribution cumulée normale standard. Cette distribution a une moyenne égale à 0 (zéro) et un écart-type égal à 1. Utilisez cette fonction à la place de la table donnant la valeur des aires comprises sous une courbe normale standard.

Syntaxe

LOI.NORMALE.STANDARD(z)

z est la valeur pour laquelle vous voulez la distribution.

Remarques

  • Si z n'est pas numérique, LOI.NORMALE.STANDARD renvoie la valeur d'erreur #VALEUR!.
  • L'équation pour la fonction de densité normale standard est :

Exemple

Formule | Description (résultat)
=LOI.NORMALE.STANDARD(1,333333) | Fonction de distribution cumulée normale à 1,333333 (0,908789)


LOI.NORMALE.STANDARD.INVERSE

Renvoie l'inverse de la distribution cumulée normale standard. La distribution a une moyenne de zéro et un écart-type de 1.

Syntaxe

LOI.NORMALE.STANDARD.INVERSE(probabilité)

probabilité représente une probabilité correspondant à la distribution normale.

Remarques

  • Si probabilité n'est pas numérique, LOI.NORMALE.STANDARD.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si probabilité < 0 ou si probabilité > 1, LOI.NORMALE.STANDARD.INVERSE renvoie la valeur d'erreur #NOMBRE!.

LOI.NORMALE.STANDARD.INVERSE utilise une technique itérative pour calculer la fonction. À partir d'une valeur de probabilité donnée, LOI.NORMALE.STANDARD.INVERSE fonctionne par itération jusqu'à ce que le résultat atteigne une précision de l'ordre de ±3x10^-7. Si LOI.NORMALE.STANDARD.INVERSE n'obtient pas de convergence au bout de 100 itérations, la fonction renvoie la valeur d'erreur #N/A.

Exemple

Formule | Description (résultat)
=LOI.NORMALE.STANDARD.INVERSE(0,908789) | Inverse de la distribution cumulée normale standard, avec une probabilité de 0,908789 (1,3333)


LOI.POISSON

Renvoie la probabilité d'une variable aléatoire suivant une loi de Poisson. Une application courante de la loi de Poisson est la prédiction du nombre d'événements susceptibles de se produire sur une période de temps déterminée, par exemple, le nombre de voitures qui se présentent à un poste de péage en l'espace d'une minute.

Syntaxe

LOI.POISSON(x;moyenne;cumulative)

x représente le nombre d'événements.

moyenne représente l'espérance mathématique.

Cumulative représente une valeur logique déterminant le mode de calcul de la fonction : cumulatif ou non. Si l'argument cumulative est VRAI, la fonction LOI.POISSON renvoie la probabilité de Poisson pour qu'un événement aléatoire se reproduise un nombre de fois inférieur ou égal à x. Si l'argument cumulative est FAUX, la fonction renvoie la probabilité de masse de Poisson pour qu'un événement se reproduise x fois exactement.

Remarques

  • Si l'argument x n'est pas un nombre entier, il est ramené à sa valeur entière par troncature.
  • Si les arguments x ou moyenne ne sont pas numériques, la fonction LOI.POISSON renvoie la valeur d'erreur #VALEUR!.
  • Si l'argument x < 0, la fonction LOI.POISSON renvoie la valeur d'erreur #NOMBRE!.
  • Si l'argument moyenne < 0, la fonction LOI.POISSON renvoie la valeur d'erreur #NOMBRE!.
  • La fonction LOI.POISSON se calcule comme suit :

    Si l'argument cumulative = FAUX :

    Si l'argument cumulative = VRAI :

Exemples

x | moyenne | Formule | Description (résultat)
2 | 5 | =LOI.POISSON([x];[moyenne];VRAI) | Probabilité de Poisson cumulée selon les arguments spécifiés (0,124652)
2 | 5 | =LOI.POISSON([x];[moyenne];FAUX) | Fonction de probabilité de masse de Poisson selon les arguments spécifiés (0,084224)


COEFFICIENT.ASYMETRIE

Renvoie l'asymétrie d'une distribution. Cette fonction caractérise le degré d'asymétrie d'une distribution par rapport à sa moyenne. Une asymétrie positive indique une distribution unilatérale décalée vers les valeurs les plus positives. Une asymétrie négative indique une distribution unilatérale décalée vers les valeurs les plus négatives.

Syntaxe

COEFFICIENT.ASYMETRIE(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent les 1 à 30 arguments dont vous souhaitez déterminer l'asymétrie.

Remarques

  • Les arguments doivent être des nombres ou des références de colonnes contenant des nombres.
  • Si une référence de colonne utilisée comme argument contient du texte, des valeurs logiques ou est vide, ces valeurs sont ignorées. En revanche, les arguments contenant la valeur 0 sont pris en compte.
  • Si le nombre d'observations est inférieur à trois ou que l'écart type de l'échantillon est nul, la fonction COEFFICIENT.ASYMETRIE renvoie la valeur d'erreur #DIV/0!.
  • L'équation d'asymétrie se définit comme suit :

Exemple

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | Formule | Description (résultat)
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =COEFFICIENT.ASYMETRIE([D1]; [D2]; [D3]; [D4]; [D5]; [D6]; [D7]; [D8]; [D9]; [D10]) | Asymétrie d'une distribution de la série de données (0,359543)


CENTREE.REDUITE

Renvoie une valeur centrée réduite d'une distribution caractérisée par les arguments moyenne et écart_type.

Syntaxe

CENTREE.REDUITE(x;moyenne;écart_type)

x représente la valeur à centrer et à réduire.

moyenne représente l'espérance mathématique de la distribution.

écart_type représente l'écart type de la distribution.

Remarques

  • Si l'argument écart_type = 0, la fonction CENTREE.REDUITE renvoie la valeur d'erreur #NOMBRE!.
  • L'équation de la valeur normalisée est la suivante :

Exemple

x | moyenne | Ecartype | Formule | Description (résultat)
42 | 40 | 1,5 | =CENTREE.REDUITE([x];[moyenne];[Ecartype]) | Valeur centrée réduite de 42 pour les arguments spécifiés (1,333333)


ECARTYPE

Evalue l'écart type d'une population en se basant sur un échantillon de cette population. L'écart type est une mesure de la dispersion des valeurs par rapport à la moyenne (valeur moyenne).

Syntaxe

ECARTYPE(nombre1;nombre2;...)

nombre1;nombre2; ... représentent de 1 à 30 arguments numériques correspondant à un échantillon de population.

Remarques

  • Les valeurs logiques, telles que VRAI et FAUX, et le texte sont ignorés. Si les valeurs logiques et le texte doivent être pris en compte, utilisez la fonction STDEVA.
  • La fonction ECARTYPE part de l'hypothèse que les arguments ne représentent qu'un échantillon de la population. Si vos données représentent l'ensemble de la population, utilisez la fonction ECARTYPEP pour en calculer l'écart type.
  • L'écart type est calculé à l'aide de la méthode « non biaisé » ou « n-1 ».
  • La fonction ECARTYPE utilise la formule suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire de 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =ECARTYPE([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Écart type de la résistance à la rupture (27,46391572)


STDEVA

Calcule l'écart type sur la base d'un échantillon. L'écart type mesure la dispersion des valeurs par rapport à la moyenne (valeur moyenne). Outre des nombres, le calcul peut comprendre du texte ou des valeurs logiques telles que VRAI et FAUX.

Syntaxe

STDEVA(valeur1;valeur2; ...)

valeur1;valeur2; ... représentent 1 à 30 valeurs correspondant à un échantillon d'une population.

Remarques

  • La fonction STDEVA part de l'hypothèse que les arguments ne représentent qu'un échantillon de la population. Si vos données représentent l'ensemble de la population, calculez l'écart type à l'aide de la fonction STDEVPA.
  • Les arguments contenant la valeur VRAI ont la valeur 1 ; les arguments contenant du texte ou la valeur FAUX ont la valeur 0. Si le calcul ne doit inclure ni texte ni valeur logique, utilisez plutôt la fonction de feuille de calcul ECARTYPE.
  • L'écart type est calculé à l'aide de la méthode « non biaisé » ou « n-1 ».
  • La fonction STDEVA utilise la formule suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire de 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1 299 | =STDEVA([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Écart type de la résistance à la rupture de l'ensemble des outils produits (27,46391572)


ECARTYPEP

Calcule l'écart type d'une population à partir de la population entière telle que la déterminent les arguments. L'écart type est une mesure de la dispersion des valeurs par rapport à la moyenne (valeur moyenne).

Syntaxe

ECARTYPEP(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments correspondant à une population.

Remarques

  • Les valeurs logiques, telles que VRAI et FAUX, et le texte sont ignorés. Si les valeurs logiques et le texte ne doivent pas être ignorés, utilisez plutôt la fonction de feuille de calcul STDEVPA.
  • La fonction ECARTYPEP part de l'hypothèse que les arguments représentent l'ensemble de la population. Si vos données ne représentent qu'un échantillon de cette population, utilisez la fonction ECARTYPE pour en calculer l'écart type.
  • Sur des échantillons de grande taille, les fonctions ECARTYPE et ECARTYPEP renvoient approximativement la même valeur.
  • L'écart type est calculé à l'aide de la méthode « non biaisé » ou « n-1 ».
  • La fonction ECARTYPEP utilise la formule suivante :

Exemple

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =ECARTYPEP([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Écart type de la résistance à la rupture, en supposant que seulement 10 outils sont produits (26,05455814)


STDEVPA

Calcule l'écart type d'une population en prenant en compte toute la population et en utilisant les arguments spécifiés, y compris le texte et les valeurs logiques. L'écart type mesure la dispersion des valeurs par rapport à la moyenne (valeur moyenne).

Syntaxe

STDEVPA(valeur1;valeur2; ...)

valeur1;valeur2; ... représentent 1 à 30 valeurs correspondant à une population.

Remarques

  • La fonction STDEVPA part de l'hypothèse que les arguments représentent l'ensemble de la population. Si vos données ne représentent qu'un échantillon de cette population, calculez l'écart type à l'aide de la fonction STDEVA.
  • Les arguments contenant la valeur VRAI ont la valeur 1 ; les arguments contenant du texte ou la valeur FAUX ont la valeur 0. Si le calcul ne doit inclure ni texte ni valeur logique, utilisez plutôt la fonction de feuille de calcul ECARTYPEP.
  • S'il s'agit d'échantillons de taille importante, les fonctions STDEVA et STDEVPA renvoient à peu près les mêmes valeurs.
  • L'écart type est calculé à l'aide de la méthode « avec biais » ou « n-1 ».
  • La fonction STDEVPA utilise la formule suivante :

Exemple

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =STDEVPA([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Écart type de la résistance à la rupture, en supposant que seulement 10 outils sont produits (26,05455814)


LOI.STUDENT

Renvoie la probabilité d'une variable aléatoire suivant la loi de t de Student, dans laquelle une valeur numérique (x) est une valeur calculée de t dont il faut calculer la probabilité. La loi de t est utilisée pour les tests d'hypothèse sur des échantillons de petite taille. Utilisez cette fonction au lieu d'une table des valeurs critiques de la loi de t.

Syntaxe

LOI.STUDENT(x;degrés_liberté;uni/bilatéral)

x représente la valeur numérique à laquelle la distribution doit être évaluée.

degrés_liberté représente un nombre entier indiquant le nombre de degrés de liberté.

uni/bilatéral indique le type de distribution à renvoyer : unilatérale ou bilatérale. Si l'argument uni/bilatéral = 1, la fonction LOI.STUDENT renvoie la distribution unilatérale. Si l'argument uni/bilatéral = 2, la fonction LOI.STUDENT renvoie la distribution bilatérale.

Remarques

  • Si l'un des arguments n'est pas numérique, la fonction LOI.STUDENT renvoie la valeur d'erreur #VALEUR!.
  • Si l'argument degrés_liberté < 1, la fonction LOI.STUDENT renvoie la valeur d'erreur #NOMBRE!.
  • Les arguments degrés_liberté et uni/bilatéral sont tronqués de façon à être convertis en nombres entiers.
  • Si l'argument uni/bilatéral est différent de 1 ou de 2, la fonction LOI.STUDENT renvoie la valeur d'erreur #NOMBRE!.
  • La fonction LOI.STUDENT est calculée sous la forme LOI.STUDENT = p(x<abs(X)), où X est une variable aléatoire qui suit la loi de t.

Exemple

x | degrés | Formule | Description (résultat)
1,96 | 60 | =LOI.STUDENT([x];[degrés];2) | Distribution bilatérale (0,054644927 ou 5,46 pour cent)
1,96 | 60 | =LOI.STUDENT([x];[degrés];1) | Distribution unilatérale (0,027322463 ou 2,73 pour cent)


LOI.STUDENT.INVERSE

Renvoie la valeur d'une variable aléatoire suivant la loi de t de Student, en fonction de la probabilité et du nombre de degrés de liberté.

Syntaxe

LOI.STUDENT.INVERSE(probabilité;degrés_liberté)

probabilité représente la probabilité associée à la loi bilatérale t de Student.

degrés_liberté représente le nombre de degrés de liberté caractérisant la distribution.

Remarque

  • Si l'un des arguments n'est pas numérique, la fonction LOI.STUDENT.INVERSE renvoie la valeur d'erreur #VALEUR!.
  • Si l'argument probabilité < 0 ou si l'argument probabilité > 1, la fonction LOI.STUDENT.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • Si l'argument degrés_liberté n'est pas un nombre entier, l'argument est tronqué.
  • Si l'argument degrés_liberté < 1, la fonction LOI.STUDENT.INVERSE renvoie la valeur d'erreur #NOMBRE!.
  • La fonction LOI.STUDENT.INVERSE est calculée sous la forme LOI.STUDENT.INVERSE = p(t<X), où X est une variable aléatoire qui suit la loi de t.
  • Une valeur t unilatérale peut être renvoyée en remplaçant l'argument probabilité par l'argument 2*probabilité. Pour une probabilité de 0,05 et des degrés de liberté au nombre de 10, la valeur bilatérale est calculée avec LOI.STUDENT.INVERSE(0,05;10), qui renvoie 2,28139. La valeur unilatérale pour la même probabilité et les mêmes degrés de liberté peut être calculée avec LOI.STUDENT.INVERSE(2*0,05;10), qui renvoie 1,812462.

    Remarque Dans certaines tables, la probabilité est décrite comme (1-p).

La fonction LOI.STUDENT.INVERSE est calculée à l'aide d'une méthode par itération. À partir d'une valeur donnée de l'argument probabilité, la fonction LOI.STUDENT.INVERSE travaille par itération jusqu'à ce que la précision du résultat obtenu soit de ± 3x10^-7. Si la fonction LOI.STUDENT.INVERSE ne converge pas après 100 itérations, elle renvoie la valeur d'erreur #N/A.

Exemple

probabilité | degrés | Formule | Description (résultat)
0,054645 | 60 | =LOI.STUDENT.INVERSE([probabilité];[degrés]) | Valeur d'une variable aléatoire suivant la loi de t de Student pour les arguments spécifiés (1,959997462)


VAR

Calcule la variance sur la base d'un échantillon.

Syntaxe

VAR(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments correspondant à un échantillon d'une population.

Remarque

  • La fonction VAR part de l'hypothèse que les arguments ne représentent qu'un échantillon de la population. Si vos données représentent l'ensemble de la population, utilisez la fonction VAR.P pour en calculer la variance.
  • Les valeurs logiques, telles que VRAI et FAUX, et le texte sont ignorés. Si les valeurs logiques et le texte doivent être pris en compte, utilisez la fonction VARA.
  • La fonction VAR utilise la formule suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire de 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =VAR([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Variance de la résistance à la rupture des outils (754,2666667)


VARA

Calcule la variance sur la base d'un échantillon. Outre des nombres, le calcul peut comprendre du texte ou des valeurs logiques telles que VRAI et FAUX.

Syntaxe

VARA(valeur1;valeur2; ...)

valeur1;valeur2; ... représentent 1 à 30 arguments correspondant à un échantillon d'une population.

Remarque

  • La fonction VARA part de l'hypothèse que les arguments ne représentent qu'un échantillon de la population. Si vos données représentent l'ensemble de la population, calculez la variance à l'aide de la fonction VARPA.
  • Les arguments contenant la valeur VRAI ont la valeur 1 ; les arguments contenant du texte ou la valeur FAUX ont la valeur 0. Si le calcul ne doit inclure ni texte ni valeur logique, utilisez plutôt la fonction VAR.
  • La fonction VARA utilise la formule suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire de 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =VARA([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Calcule la variance de la résistance à la rupture des outils (754,2666667)


VAR.P

Calcule la variance sur la base de l'ensemble de la population.

Syntaxe

VAR.P(nombre1;nombre2; ...)

nombre1;nombre2; ... représentent 1 à 30 arguments correspondant à une population.

  • Les valeurs logiques, telles que VRAI et FAUX, et le texte sont ignorés. Si les valeurs logiques et le texte doivent être pris en compte, utilisez la fonction VARPA.

Remarque

  • La fonction VAR.P part de l'hypothèse que les arguments représentent l'ensemble de la population. Si vos données ne représentent qu'un échantillon de la population, utilisez la fonction VAR pour en calculer la variance.
  • L'équation de la fonction VAR.P est la suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire des 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =VAR.P([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Variance des résistances à la rupture pour tous les outils, en supposant que seulement 10 outils sont produits (678,84)


VARPA

Calcule la variance sur la base de l'ensemble de la population. Outre des nombres, le calcul peut comprendre du texte et des valeurs logiques telles que VRAI et FAUX.

Syntaxe

VARPA(valeur1;valeur2; ...)

valeur1;valeur2;... représentent 1 à 30 arguments correspondant à une population.

Remarque

  • La fonction VARPA part de l'hypothèse que les arguments représentent l'ensemble de la population. Si vos données ne représentent qu'un échantillon de cette population, calculez la variance à l'aide de la fonction VARA.
  • Les arguments contenant la valeur VRAI ont la valeur 1 ; les arguments contenant du texte ou la valeur FAUX ont la valeur 0. Si le calcul ne doit inclure ni texte ni valeur logique, utilisez la fonction VAR.P.
  • La fonction VARPA utilise la formule suivante :

Exemple

Supposons que l'on constitue un échantillon aléatoire des 10 outils estampés par la même machine pendant un cycle de production et que l'on en mesure la résistance à la rupture.

O1 | O2 | O3 | O4 | O5 | O6 | O7 | O8 | O9 | O10 | Formule | Description (résultat)
1 345 | 1 301 | 1 368 | 1 322 | 1 310 | 1 370 | 1 318 | 1 350 | 1 303 | 1 299 | =VARPA([O1]; [O2]; [O3]; [O4]; [O5]; [O6]; [O7]; [O8]; [O9]; [O10]) | Variance des résistances à la rupture pour tous les outils, en supposant que seulement 10 outils sont produits (678,84)


LOI.WEIBULL

Renvoie la probabilité d'une variable aléatoire suivant une loi Weibull. Utilisez cette distribution dans une analyse de fiabilité telle que le calcul du temps moyen de fonctionnement sans panne d'un appareil.

Syntaxe

LOI.WEIBULL(x;alpha;bêta;cumulée)

x représente la variable avec laquelle la fonction doit être calculée.

alpha représente un paramètre de la distribution.

bêta représente un paramètre de la distribution.

cumulée détermine la forme de la fonction.

Remarque

  • Si les arguments x, alpha ou bêta ne sont pas numériques, la fonction LOI.WEIBULL renvoie la valeur d'erreur #VALEUR!.
  • Si x < 0, la fonction LOI.WEIBULL renvoie la valeur d'erreur #NOMBRE!.
  • Si alpha = 0 ou si bêta = 0, la fonction LOI.WEIBULL renvoie la valeur d'erreur #NOMBRE!.
  • L'équation pour la fonction de distribution cumulée de la loi Weibull est la suivante :

  • L'équation pour la fonction de densité de probabilité de la loi Weibull est la suivante :

  • Lorsque alpha = 1, LOI.WEIBULL renvoie la distribution exponentielle avec :

Exemple

x | alpha | bêta | Formule | Description (résultat)
105 | 20 | 100 | =LOI.WEIBULL([x];[alpha];[bêta];VRAI) | Fonction de distribution cumulée selon la loi de Weibull pour les arguments spécifiés (0,929581)
105 | 20 | 100 | =LOI.WEIBULL([x];[alpha];[bêta];FAUX) | Fonction de densité de probabilité de la loi Weibull pour les arguments spécifiés (0,035589)


ASC

Pour les langues dont le jeu de caractères est codé sur deux octets (DBCS), change les caractères en pleine chasse (codés sur deux octets) en caractères en demi-chasse (codés sur un octet).

Syntaxe

ASC(texte)

texte représente le texte ou une référence de colonne contenant le texte que vous voulez changer. Si le texte ne contient aucune lettre en pleine chasse, le texte n'est pas modifié.

Exemples

=ASC("EXCEL")
égale « EXCEL »

=ASC("
Excel Excel Excel Excel
")
égale « Excel Excel Excel Excel »


CAR

Renvoie le caractère spécifié par un nombre. Utilisez CAR pour traduire en caractères des numéros de code de page que vous pouvez trouver dans des fichiers provenant d'autres types d'ordinateurs.

Syntaxe

CAR(nombre)

nombre représente un nombre compris entre 1 et 255, indiquant le caractère recherché. Ce caractère provient du jeu de caractères utilisé par votre ordinateur.

Exemple

Formule | Description (résultat)
=CAR(65) | Affiche le caractère 65 du jeu (A)
=CAR(33) | Affiche le caractère 33 du jeu (!)


EPURAGE

Supprime tous les caractères non imprimables du texte. Utilisez EPURAGE sur du texte importé d'autres applications qui contient des caractères qui peuvent ne pas s'imprimer avec votre système d'exploitation. Par exemple, vous pouvez utiliser EPURAGE pour supprimer du code informatique de bas niveau qui se trouve souvent au début et à la fin des fichiers de données et qui ne peut pas être imprimé.

Syntaxe

EPURAGE(texte)

texte représente toute information dont vous voulez supprimer les caractères non imprimables.

Exemple

Col1 | Formule | Description (résultat)
CAR(7)&"texte"&CAR(7) | =EPURAGE([Col1]) | Supprime le caractère non imprimable CAR(7) de la chaîne (texte).


CODE

Renvoie un code numérique pour le premier caractère d'une chaîne de texte. Le code renvoyé correspond au jeu de caractères utilisé par votre ordinateur.

Syntaxe

CODE(texte)

texte est le texte dont vous voulez obtenir le code du premier caractère.

Exemple

Formule | Description (résultat)
=CODE("A") | Affiche le code numérique de A (65)
=CODE("!") | Affiche le code numérique de ! (33)


CONCATENER

Assemble plusieurs chaînes de caractères de façon à n'en former qu'une seule.

Syntaxe

CONCATENER (texte1;texte2;...)

texte1;texte2; ... représentent 1 à 30 éléments de texte à assembler en un seul élément de texte. Les éléments de texte peuvent être des chaînes de texte, des nombres ou des références de colonnes.

Remarques

L'opérateur « & » peut être utilisé à la place de CONCATENER pour assembler des éléments de texte.

Exemple

Col1 | Col2 | Col3 | Formule | Description
les espèces | de truites de rivière | 32 | =CONCATENER("La population moyenne pour";[Col1];" ";[Col2];" est de ";[Col3];"/kilomètre") | Concatène une phrase à partir des données (La population moyenne pour les espèces de truites de rivière est de 32/kilomètre)


EURO

Convertit un nombre en texte avec un format monétaire, les décimales étant arrondies à l'emplacement spécifié. Le format utilisé est #.##0,00_€);(#.##0,00€).

Syntaxe

EURO(nombre;décimales)

nombre représente un nombre, une référence de colonne contenant un nombre ou une formule dont l'évaluation donne un nombre.

décimales représente le nombre de chiffres à droite de la virgule. Si l'argument décimales est négatif, nombre est arrondi à gauche de la virgule. Si vous omettez l'argument décimales, les paramètres régionaux système seront utilisés pour déterminer le nombre de décimales.

Remarque

La fonction EURO utilise la devise définie sur votre ordinateur. Si vous voulez toujours afficher la devise américaine, utilisez alors la fonction USDOLLAR.

Exemple

Col1 | Formule | Description (résultat)
1234,567 | =EURO([Col1];2) | Affiche le premier nombre en format monétaire, 2 chiffres à droite du séparateur décimal (1 234,57€)
1234,567 | =EURO([Col1];-2) | Affiche le premier nombre en format monétaire, 2 chiffres à gauche du séparateur décimal (1 200€)
-1234,567 | =EURO([Col1];-2) | Affiche le deuxième nombre en format monétaire, 2 chiffres à gauche du séparateur décimal ((1 200€))
-0,123 | =EURO([Col1];4) | Affiche le troisième nombre en format monétaire, 4 chiffres à droite du séparateur décimal ((0,1230€))
99,888 | =EURO([Col1]) | Affiche le quatrième nombre en format monétaire, 2 chiffres à gauche du séparateur décimal (99,89€)


EXACT

Compare deux chaînes de texte et renvoie VRAI si elles sont exactement les mêmes et FAUX dans le cas contraire. EXACT fait la distinction entre les majuscules et les minuscules. Utilisez EXACT pour tester du texte entré dans un document.

Syntaxe

EXACT(texte1;texte2)

texte1 représente la première chaîne de texte.

texte2 représente la seconde chaîne de texte.

Exemple

Col1 | Col2 | Formule | Description (résultat)
mot | mot | =EXACT([Col1];[Col2]) | Vérifie si les chaînes correspondent (VRAI)
Mot | mot | =EXACT([Col1];[Col2] | Vérifie si les chaînes correspondent (FAUX)
m ot | mot | =EXACT([Col1];[Col2]) | Vérifie si les chaînes correspondent (FAUX)


TROUVE

Recherche une chaîne de texte (texte_à_trouver) dans une autre chaîne de texte (texte_où_chercher), et renvoie le numéro de la position de début de texte_à_trouver, à partir du premier caractère de texte_où_chercher. Vous pouvez également utiliser CHERCHE pour rechercher une chaîne de texte dans une autre chaîne ; cependant, au contraire de CHERCHE, TROUVE fait la distinction entre les majuscules et les minuscules et n'autorise pas l'emploi de caractères génériques.

Syntaxe

TROUVE(texte_à_trouver;texte_où_chercher;position_démarrage)

texte_à_trouver représente le texte que vous voulez trouver.

texte_où_chercher représente le texte contenant le texte que vous voulez rechercher.

position_démarrage spécifie le caractère à partir duquel la recherche doit commencer. Le premier caractère de texte_où_chercher est le caractère numéro 1. Si vous omettez position_démarrage, la valeur 1 lui est attribuée automatiquement.

Afficher Conseil

Utilisez position_démarrage pour ignorer un nombre spécifié de caractères. Par exemple, vous voulez faire une recherche dans la chaîne de texte « AHF0093.HabillementJeunesHommes ». Pour trouver le numéro du premier « H » dans la partie descriptive de la chaîne de texte, définissez position_démarrage à 8 pour ne pas faire de recherche dans la partie du texte qui est le numéro de série. TROUVE commence au caractère 8, trouve texte_à_trouver au caractère suivant et renvoi le nombre 9. TROUVE renvoie toujours le nombre de caractères à partir du début de texte_où_chercher, en comptant les caractères que vous passez si position_démarrage est supérieur à 1.

Remarques

  • Si texte_à_trouver est "" (texte vide), TROUVE trouve une correspondance dès le premier caractère de la chaîne où chercher (c'est-à-dire le caractère correspondant à position_démarrage ou à 1).
  • Texte_à_trouver ne peut pas contenir de caractères génériques.
  • Si texte_à_trouver ne figure pas dans texte_où_chercher, TROUVE renvoie la valeur d'erreur #VALEUR!.
  • Si position_démarrage n'est pas supérieur à zéro, TROUVE renvoie la valeur d'erreur #VALEUR!.
  • Si position_démarrage est supérieur à la longueur de texte_où_chercher, TROUVE renvoie la valeur d'erreur #VALEUR!.

Exemple 1

Formule | Description (résultat)
=TROUVE("M";"Miriam McGovern") | Position du premier « M » dans la chaîne (1)
=TROUVE("m";"Miriam McGovern") | Position du premier « m » dans la chaîne (6)
=TROUVE("M";"Miriam McGovern";3) | Position du premier « M » dans la chaîne, en commençant au troisième caractère (8)

Exemple 2

Col1 | Formule | Description (résultat)
Isolateurs céramique #124-TD45-87 | =STXT([Col1];1;TROUVE(" #";[Col1];1)-1) | Extrait le texte de la position 1 à la position de « # » dans la chaîne (Isolateurs céramique)
Bobines cuivre #12-671-6772 | =STXT([Col1];1;TROUVE(" #";[Col1];1)-1) | Extrait le texte de la position 1 à la position de « # » dans la chaîne (Bobines cuivre)
Résistances variables #116010 | =STXT([Col1];1;TROUVE(" #";[Col1];1)-1) | Extrait le texte de la position 1 à la position de « # » dans la chaîne (Résistances variables)


CTXT

Arrondit un nombre au nombre de décimales spécifié, formate le nombre au format décimal avec une virgule et des points et renvoie le résultat sous forme de texte.

Syntaxe

CTXT(nombre;décimales;pas_de_points)

nombre représente le nombre que vous voulez arrondir et convertir en texte.

décimales représente le nombre de chiffres à droite du séparateur décimal.

pas_de_points représente une valeur logique qui, si elle vaut VRAI, empêche CTXT d'insérer des points dans le texte renvoyé.

Remarques

  • Si décimales est négatif, le nombre est arrondi à gauche du séparateur décimal.
  • Si vous omettez des décimales, les paramètres régionaux système seront utilisés pour déterminer le nombre de décimales.
  • Si pas_de_points est égal à FAUX ou est omis, le texte renvoyé comprend des points comme séparateur de milliers.

Exemple

Formule | Description (résultat)
=CTXT(1234,567;1) | Arrondit le premier nombre à 1 chiffre à droite du séparateur décimal (1.234,6)
=CTXT(1234,567;-1) | Arrondit le premier nombre à 1 chiffre à gauche du séparateur décimal (1.230)
=CTXT(-1234,567;-1;VRAI) | Arrondit le deuxième nombre à 1 chiffre à gauche du séparateur décimal, sans séparateur de milliers (-1230)
=CTXT(44,332) | Arrondit le troisième nombre à 2 chiffres à gauche du séparateur décimal (44,33)


GAUCHE

GAUCHE renvoie le premier caractère ou les premiers caractères d'une chaîne de texte, sur la base du nombre de caractères que vous spécifiez.

Syntaxe

GAUCHE(texte;nombre_caractères)

texte représente la chaîne de texte contenant les caractères à extraire.

nombre_caractères spécifie le nombre de caractères que GAUCHE doit extraire.

  • nombre_caractères doit être supérieur ou égal à zéro.

  • Si nombre_caractères est supérieur à la longueur du texte, GAUCHE renvoie tout le texte.

  • Si nombre_caractères est omis, la valeur 1 lui est attribuée.

Exemple

Col1 | Formule | Description (résultat)
Prix de vente | =GAUCHE([Col1];4) | Les quatre premier caractères de la chaîne (Prix)
Suède | =GAUCHE([Col1]) | Le premier caractère de la chaîne (S)


NBCAR

NBCAR renvoie le nombre de caractères dans une chaîne de texte.

Syntaxe

NBCAR(texte)

texte représente le texte dont vous voulez trouver la longueur. Les espaces sont comptés comme des caractères.

Exemple

Col1 | Formule | Description (résultat)
Paris, France | =NBCAR([Col1]) | Longueur de la chaîne (13)
 | =NBCAR([Col1]) | Longueur de la chaîne (0)
A Une | =NBCAR([Col1]) | Longueur de la chaîne, qui comprend 5 espaces (8)


MINUSCULE

Convertit toutes les lettres majuscules d'une chaîne de texte en minuscules.

Syntaxe

MINUSCULE(texte)

texte représente le texte que vous voulez convertir en minuscules. MINUSCULE ne modifie pas les caractères du texte qui ne sont pas des lettres.

Exemple

Col1 | Formule | Description (résultat)
E. E. Cummings | =MINUSCULE([Col1]) | Chaîne de texte en minuscules (e. e. cummings)
Apt. 2B | =MINUSCULE([Col1]) | Chaîne de texte en minuscules (apt. 2b)


STXT

STXT renvoie une nombre spécifique de caractères dans une chaîne de texte, à partir d'une position que vous spécifiez, sur la base d'un nombre de caractères que vous spécifiez.

Syntaxe

STXT(texte;position_début;nombre_caractères)

texte représente la chaîne de texte qui contient les caractères que vous voulez extraire.

position_début représente la position du premier caractère que vous voulez extraire du texte. Le premier caractère du texte correspond à une position_début égale à 1, etc.

nombre_caractères spécifie le nombre de caractères du texte que STXT doit renvoyer.

Remarques

  • Si position_début est supérieur à la longueur du texte, STXT renvoie "" (chaîne de texte vide).
  • Si position_début est inférieur à la longueur du texte mais que Position_début plus Nombre_caractères est supérieur à la longueur du texte, STXT renvoie les caractères jusqu'à la fin du texte.
  • Si position_début est inférieur à 1, STXT renvoie la valeur d'erreur #VALEUR!.

  • Si nombre_caractères est négatif, STXT renvoie la valeur d'erreur #VALEUR!.

Exemple

Formule | Description (résultat)
=STXT("Flux de fluide";1;4) | Quatre caractères de la chaîne, à partir du premier caractère (Flux)
=STXT("Flux de fluide";9;20) | Vingt caractères de la chaîne, à partir du neuvième (fluide)
=STXT("Flux de fluide";20;5) | La position de début étant supérieure à la longueur de la chaîne, un texte vide est renvoyé ()


NULL

Renvoie la valeur #NUL!. Utilisez la fonction NULL pour indiquer les valeurs vides dans une colonne calculée.

La fonction NULL vous permet d’éviter d’inclure involontairement des valeurs vides dans vos calculs. Lorsqu’une formule fait référence à une cellule contenant #NUL!, la formule renvoie #NUL!.

Syntaxe

NULL()

Note

La syntaxe de la fonction NULL ne comporte aucun argument. Vous devez joindre les parenthèses vides au nom de la fonction. Sans cela, Microsoft SharePoint Foundation 2010 ne la reconnaîtra pas en tant que fonction.


NZ

Vérifie si la valeur est #NUL!. Si l’argument a la valeur VRAI, la fonction renvoie la valeur de remplacement, sinon elle renvoie la valeur.

Syntaxe

NZ(valeur, remplacement)

Argument | Description
valeur | Peut être une référence de colonne. Si valeur est #NUL!, la fonction renvoie la valeur de remplacement. Sinon, elle renvoie la valeur.
remplacement | Peut être des nombres, du texte ou des références de colonne. La valeur de remplacement est renvoyée si la valeur #NUL!.

Exemple

Col1 | Col2 | Formule | Description (résultat)
#NUL! | 200 | =NZ([Col 1],[Col2]) | Vérifie si la valeur de Col1 est l’erreur #NUL! et renvoie la valeur de remplacement (200).
400 | 450 | =NZ([Col 1],[Col2]) | Vérifie si la valeur de Col1 est l’erreur #NUL! et renvoie la valeur de remplacement (400).


NOMPROPRE

Met en majuscule la première lettre et toutes les autres lettres d'un texte qui suivent un caractère non alphabétique dans une chaîne de texte. Toutes les autres lettres de la chaîne sont converties en lettres minuscules.

Syntaxe

NOMPROPRE(texte)

texte est un texte entouré de guillemets, une formule qui renvoie du texte ou une référence de colonne contenant un texte dont vous voulez que certaines lettres soient en majuscules.

Exemples

Formule | Description (résultat)
=NOMPROPRE("ceci est un TITRE") | Mise en majuscule de la première lettre des mots de la chaîne (Ceci Est Un Titre)
=NOMPROPRE("vaison-la-romaine") | Mise en majuscule de la première lettre des mots de la chaîne (Vaison-La-Romaine)
=NOMPROPRE("76BudGet") | Mise en majuscule de la première lettre de la chaîne (76Budget)


REMPLACER

REMPLACER remplace une chaîne de caractères par une autre, en fonction du nombre de caractères spécifiés.

Syntaxe

REMPLACER(ancien_texte;no_départ;no_car;nouveau_texte)

ancien_texte représente le texte dont vous voulez remplacer un nombre donné de caractères.

no_départ représente la place du premier caractère de la chaîne ancien_texte où le remplacement par nouveau_texte doit commencer.

no_car représente le nombre de caractères d'ancien_texte que nouveau_texte doit remplacer à l'aide de REMPLACER.

nouveau_texte représente le texte qui doit remplacer les caractères d'ancien_texte.

Exemples

Formule | Description (résultat)
=REMPLACER("abcdefghijk";6;5;"*") | Remplace cinq caractères, en commençant au sixième caractère (abcde*k)
=REMPLACER("2009";3;2;"10") | Remplace les deux derniers chiffres de 2009 par 10 (2010)
=REMPLACER("123456";1;3;"@") | Remplace les trois premiers caractères par @ (@456)


REPT

Répète un texte un certain nombre de fois. Utilisez la fonction REPT pour ajouter un nombre déterminé d'instances d'une chaîne de texte.

Syntaxe

REPT(texte;no_fois)

texte représente le texte à répéter.

no_fois représente un nombre positif indiquant le nombre de fois que le texte doit être répété.

Remarques

  • Si no_fois est égal à 0 (zéro), la fonction REPT renvoie un texte vide ("").

  • Si no_fois n'est pas un nombre entier, il est tronqué.

  • Le résultat de la fonction REPT ne peut pas dépasser 2 000 caractères, sinon la fonction REPT renvoie #VALEUR!.

Exemples

Formule | Description (résultat)
=REPT("*-"; 3) | Affiche la chaîne 3 fois (*-*-*-)
=REPT("-"0,10) | Affiche un tiret 10 fois (----------)


DROITE

La fonction DROITE renvoie les derniers caractères d'une chaîne de texte, en fonction du nombre de caractères spécifiés.

Syntaxe

DROITE(texte;no_car)

texte représente la chaîne de texte contenant les caractères à extraire.

no_car indique le nombre de caractères à extraire à l'aide de la fonction DROITE.

Remarques

  • L'argument no_car doit être supérieur ou égal à zéro.
  • Si l'argument no_car est supérieur à la longueur du texte, la fonction DROITE renvoie l'intégralité du texte.
  • Si vous ne spécifiez pas l'argument no_car, sa valeur par défaut est 1.

Exemples

Formule | Description (résultat)
=DROITE("Prix de vente";5) | Les 5 derniers caractères de la chaîne (vente)
=DROITE("Nombre en stock") | Le dernier caractère de la chaîne (k)


CHERCHE

La fonction CHERCHE renvoie le numéro du caractère au niveau duquel un caractère spécifique ou une chaîne de texte est initialement reconnu(e) à partir du no_départ. Utilisez la fonction CHERCHE pour déterminer la position d'un caractère ou d'une chaîne de texte dans une autre chaîne de texte de façon à pouvoir utiliser ensuite les fonctions STXT ou REMPLACER pour modifier le texte.

Syntaxe

CHERCHE(texte_cherché;texte;no_départ)

texte_cherché est le texte que vous voulez trouver. Vous pouvez utiliser les caractères génériques [le point d'interrogation (?) et l'astérisque (*)] dans l'argument texte_cherché. Le point d'interrogation correspond à un caractère quelconque et l'astérisque correspond à une séquence de caractères quelconque. Si vous voulez trouver réellement un point d'interrogation ou un astérisque, tapez un tilde (~) devant ce caractère.

texte est le texte comprenant la chaîne de texte que vous voulez trouver.

no_départ indique le numéro du caractère dans l'argument texte à partir duquel la recherche doit débuter.

Afficher Conseil

Utilisez l'argument no_départ pour ignorer un nombre spécifié de caractères. Par exemple, supposons que vous utilisiez la chaîne de texte « AVF0093.VêtementsJeunesGens ». Pour trouver le numéro du premier « V » dans la partie descriptive de la chaîne de texte, affectez la valeur 8 à l'argument no_départ pour que la recherche ne s'opère pas dans la partie du numéro de série. La fonction CHERCHE commence sa recherche au caractère numéro 8, trouve l'argument texte_cherché au caractère suivant et renvoie le numéro 9. Elle renvoie toujours le numéro des caractères à partir du début du texte, en prenant en compte les caractères ignorés si no_départ est supérieur à 1.

Remarques

  • La fonction CHERCHE ne fait pas de distinction entre les majuscules et les minuscules lors de la recherche de texte.
  • La fonction CHERCHE est similaire à la fonction TROUVE, à l'exception du fait que la fonction TROUVE respecte les majuscules et les minuscules.
  • Si l'argument texte_cherché est introuvable, la fonction renvoie la valeur d'erreur #VALEUR!.
  • Si l'argument no_départ est omis, sa valeur par défaut est 1.
  • Si la valeur de l'argument no_départ n'est pas supérieure à 0 (zéro) ou est supérieure à la longueur de l'argument texte, la fonction renvoie la valeur d'erreur #VALEUR!.

Exemple

Col1 | Col2 | Col3 | Formule | Description (résultat)
Instructions | Pertes et profits | profits | =CHERCHE("i";[Col1];6) | Position du premier « i » dans la chaîne, en commençant à la sixième position (9)
Instructions | Pertes et profits | profits | =CHERCHE([Col2];[Col3]) | Position de « profits » dans « Pertes et profits » (11)
Instructions | Pertes et profits | profits | =REMPLACE([Col3];CHERCHE([Col3];[Col2]);6;"bénéfices") | Remplace « profits » par « bénéfices » (Pertes et bénéfices)


T

Renvoie le texte auquel l'argument valeur fait référence.

Syntaxe

T(valeur)

valeur représente la valeur à tester.

Remarques

  • Si l'argument valeur est ou fait référence à du texte, la fonction T renvoie l'argument. Si l'argument valeur ne fait pas référence à du texte, la fonction T renvoie du texte vide "".

  • Vous n'avez généralement pas besoin d'utiliser la fonction T dans une formule, car les valeurs sont généralement converties si nécessaire.

Exemple

Formule | Description (résultat)
=T("Pluie") | La valeur étant du texte, le texte est renvoyé (Pluie)
=T(19) | La valeur étant un nombre, du texte vide est renvoyé ()
=T(VRAI) | La valeur étant une valeur logique, du texte vide est renvoyé ()


TEXTE

Convertit une valeur en texte selon un format de nombre spécifique.

Syntaxe

TEXTE(valeur;format_texte)

valeur représente une valeur numérique, une formule dont le résultat est une valeur numérique ou une référence de colonne contenant une valeur numérique.

format_texte représente un format de nombre en format texte.

Remarque

  • La fonction TEXTE convertit une valeur en texte mis en forme et son résultat n'est plus calculé en tant que nombre.

Exemple

Vendeur | Ventes | Formule | Description (résultat)
Beaune | 2 800 | =[Vendeur]&" a vendu pour "&TEXT([Ventes]; "0,00 €;(0,00 €)";)&" d'articles." | Combine les éléments pour constituer une phrase (Beaune a vendu pour 2 800,00 € d'articles.)
Dodsworth | 0,4 | =[Vendeur]&" a vendu "&TEXT([Ventes];"0,00%")&" du total des ventes." | Combine les éléments pour constituer une phrase (Dodsworth a vendu 40,00 % du total des ventes.)


SUPPRESPACE

Supprime tous les espaces dans un texte, à l'exception des espaces simples entre les mots. Exécutez la fonction SUPPRESPACE sur le texte provenant d'autres applications et dont l'espacement peut être irrégulier.

Syntaxe

SUPPRESPACE(texte)

texte représente le texte dont vous voulez supprimer les espaces.

Exemple

Formule | Description (résultat)
=SUPPRESPACE(" Revenus premier trimestre ") | Supprime les espaces à gauche et à droite du texte spécifié dans la formule (Revenus premier trimestre)


TRIMENDS

Supprime les espaces de début et de fin, tels que des espaces blancs ou insécables avant et après le texte. Utilisez TRIMENDS sur les chaînes de texte que vous avez reçues d’une autre application et qui sont susceptibles d’avoir de contenir un espace supplémentaire avant et après.

Remarque TRIMENDS conserve l’espacement au sein de la chaîne de texte. Pour modifier l’espacement à l’intérieur de la chaîne de texte, utilisez la fonction TRIMENDS. Pour plus d’informations, consultez la rubrique d’aide concernant la fonction SUPPRESPACE.

Syntaxe

TRIMENDS(texte)

Texte Chaîne dont vous voulez supprimer les espaces.

Exemple

Formule | Description (résultat)
=TRIMENDS (“ Enregistrer les ventes ”) | Supprime les espaces de début et de fin dans le texte de la formule (Enregistrer les ventes)


MAJUSCULE

Convertit un texte en majuscules.

Syntaxe

MAJUSCULE(texte)

texte est le texte que vous voulez convertir en caractères majuscules. L'argument texte peut être une référence de colonne ou une chaîne de caractères.

Exemple

Formule | Description (résultat)
=MAJUSCULE("total") | Chaîne convertie en majuscules (TOTAL)
=MAJUSCULE("Total") | Chaîne convertie en majuscules (TOTAL)


USDOLLAR

Convertit un nombre en texte utilisant un format monétaire et l'arrondit au nombre de décimales spécifié. Le format utilisé est $#,##0.00_);($#,##0.00).

Syntaxe

USDOLLAR(nombre;décimales)

nombre représente un nombre, une référence de colonne contenant un nombre ou une formule qui renvoie un nombre.

décimales représente le nombre de chiffres à droite de la virgule. Si l'argument décimales est négatif, nombre est arrondi à gauche de la virgule. Si vous omettez l'argument décimales, les paramètres régionaux système seront utilisés pour déterminer le nombre de décimales.

Remarque

La fonction USDOLLAR affiche toujours la devise des États-Unis. Si vous voulez afficher la devise définie sur votre ordinateur, utilisez la fonction DOLLAR.

Exemple

Col1 | Formule | Description (résultat)
1234,567 | =USDOLLAR([Col1];2) | Affiche le premier nombre dans un format monétaire, 2 chiffres après la virgule ($1 234,57)
1234,567 | =USDOLLAR([Col1];-2) | Affiche le premier nombre dans un format monétaire, 2 chiffres avant la virgule ($1 200)
-1234,567 | =USDOLLAR([Col1];-2) | Affiche le deuxième nombre dans un format monétaire, 2 chiffres avant la virgule (($1 200))
-0,123 | =USDOLLAR([Col1];4) | Affiche le troisième nombre dans un format monétaire, 4 chiffres après la virgule (($0,1230))
99,888 | =USDOLLAR([Col1]) | Affiche le quatrième nombre dans un format monétaire, 2 chiffres avant la virgule ($99,89)


CNUM

Convertit en nombre une chaîne de caractères représentant un nombre.

Syntaxe

CNUM(texte)

texte représente le texte placé entre guillemets ou une référence de colonne contenant le texte que vous voulez convertir.

Remarque

  • L'argument texte peut avoir l'un des formats constants (numérique, de date ou d'heure). Si l'argument texte ne correspond à aucun de ces formats, CNUM renvoie la valeur d'erreur #VALEUR!.

Exemple

Formule | Description (résultat)
=CNUM("1 000 €") | Nombre équivalent à la chaîne (1 000)
=CNUM("16:48:00")-CNUM("12:00:00") | Numéro de série équivalent à 4 heures et 48 minutes, c'est-à-dire "16:48:00"-"12:00:00" (0,2 ou 4:48)


Amélioration des performances d'Access Web Datasheet

Les performances d'un affichage en mode Feuille de données dépendent de nombreux facteurs, comme la taille de la liste, les performances et la configuration du serveur, ainsi que des conditions de trafic sur le réseau. Cette section présente quelques indications permettant d'améliorer les performances du mode Feuille de données.

Les opérations suivantes mettre un certain temps à s'exécuter et il est donc conseillé de réduire leur utilisation au minimum :

  • Actualiser un affichage contenant une grande quantité de données.
  • Déplacer ou copier de grands ensembles de données.
  • Remplir un grand nombre de cellules en faisant glisser la poignée de recopie.
  • Changer la formule dans une colonne calculée.
  • Attacher de gros documents.
  • Exportation de et liaison vers Microsoft Excel 2010.
  • Résoudre un nombre important d'erreurs.

Effectuez les actions suivantes pour améliorer les performances d'un affichage :

  • Supprimez les colonnes qui ne sont pas nécessaires dans l'affichage. Dans la page Modifier le mode Feuille de données, désactivez la case à cocher Afficher pour les colonnes qui ne sont pas nécessaires dans l'affichage. Par contre, ne supprimez pas les colonnes qui sont indiquées comme Requise. Vous ne pourrez plus ajouter de données si l'affichage ne comprend pas toutes les colonnes requises.
  • Appliquez un ou plusieurs filtres pour supprimer les lignes qui ne sont pas nécessaires. Par exemple, vous pouvez éditer la définition de l'affichage Cadres pour y inclure un filtre qui masque les lignes correspondant aux employés qui ne sont pas cadres.

    En plus des filtres enregistrés, vous pouvez appliquer des filtres au cours de la session de travail, de façon à réduire davantage la quantité de données dans l'affichage. Par exemple, si vous mettez à jour les lignes correspondant aux cadres de la région de Washington, masquez les lignes des cadres des autres états.

  • Configurez le serveur SharePoint pour optimiser ses performances. Pour plus d’informations sur l’amélioration des performances d’un serveur, consultez l’aide de Microsoft SharePoint Foundation 2010. Pour afficher l’aide de Microsoft SharePoint Foundation 2010, cliquez sur Aide ( Icône Aide).


Affichage du message « La structure de la liste a changé »

Lorsque deux utilisateurs modifient la structure d'une liste au même moment, l'utilisateur qui envoie une modification en premier va réussir à valider cette modification, mais le second utilisateur est informé d'une modification de la structure de la liste.

Le tableau suivant présente une synthèse des scénarios où vous êtes informé d'une modification de la structure d'une liste.

Utilisateur A | Utilisateur B
Supprime une colonne | Met à jour des données dans la même colonne
Modifie le type de données d'une colonne | Ajoute ou met à jour des données d'un type incorrect
Ajoute, renomme ou supprime une colonne, modifie le type de données d'une colonne ou d'autres propriétés | Modifie une colonne calculée
Effectue des modifications au niveau de la liste, comme renommer la liste, modifier sa description ou ses paramètres de sécurité ou bien ajouter la liste à la Barre de lancement rapide | Modifie une colonne calculée
Modifie une colonne calculée | Ajoute, renomme ou supprime une colonne, modifie le type de données d'une colonne ou d'autres propriétés Remarque L'utilisateur B doit être sur la page Ajouter une colonne ou Modifier la colonne avant que l'utilisateur A commence à modifier la colonne calculée.
Modifie une colonne calculée | Effectue des modifications au niveau de la liste, comme renommer la liste, modifier sa description ou ses paramètres de sécurité ou bien ajouter la liste à la Barre de lancement rapide Remarque L'utilisateur B doit être sur la page Paramètres de la liste avant que l'utilisateur A commence à modifier la colonne calculée.

Vous pouvez résoudre un conflit de structure en actualisant la liste. Lorsque la liste est actualisée, vos modifications sont ignorées et votre affichage est mis à jour avec la dernière version de la liste. Après avoir actualisé la liste, répétez à nouveau vos modifications.


Affichage du message « Arrêt de l'envoi des modifications »

Vous tentez d'arrêter le processus d'envoi de vos modifications au serveur avant de procéder à une actualisation, d'effectuer une navigation en dehors de la liste ou d'apporter des modifications à une colonne calculée. Effectuez une des actions suivantes :

  • Cliquez sur Oui pour arrêter l'envoi par la liste des modifications au serveur. Vous allez perdre les modifications qui n'ont pas encore été enregistrées par le serveur. Vous ne pourrez pas non plus résoudre les conflits ou les erreurs provenant des modifications qui ont déjà été envoyées au serveur.
  • Cliquez sur Non pour continuer à envoyer les modifications. Vous allez pouvoir résoudre les conflits et les erreurs, et renvoyer vos modifications au serveur.


Affichage du message « Envoi des modifications en attente »

La liste tente d'envoyer vos modifications au serveur avant de traiter votre demande d'actualisation, de navigation en dehors de la liste ou de modification d'une colonne calculée. Effectuez l'une des actions suivantes :

  • Attendez que toutes les modifications soient envoyées au serveur. Cela vous permet de résoudre les conflits et les erreurs, et de renvoyer si nécessaire vos modifications au serveur.
  • Ignorez vos modifications en cliquant sur Annuler. Si vous cliquez sur Annuler, l'application vous demande de confirmer que vous voulez arrêter l'envoi des modifications au serveur. Si vous cliquez sur Oui, vous allez perdre les modifications qui n'ont pas encore été enregistrées par le serveur. Vous ne pourrez pas non plus résoudre les conflits ou les erreurs provenant des modifications qui ont déjà été envoyées au serveur.


J’obtiens le message « Des modifications sont en attente ou des conflits et des erreurs ne sont pas résolus ».

Vous tentez d'actualiser ou de quitter la liste ou d'apporter des modifications à une colonne calculée. Certaines modifications que vous avez apportées à la liste n'ont pas été envoyées au serveur.

Vous pouvez effectuer l'une des opérations suivantes :

  • Cliquez sur Oui pour patienter pendant l'envoi des modifications au serveur. En cas de conflits ou d'erreurs suite à l'envoi des modifications, vous serez en mesure de les résoudre et de réessayer l'opération.
  • Cliquez sur Non pour continuer immédiatement votre dernière action. Vous perdrez quelques modifications ou toutes les modifications qui n'ont pas été encore envoyées au serveur. Vous ne serez également pas en mesure de résoudre les conflits ou les erreurs liées aux modifications déjà envoyées au serveur.


La barre d'état affiche « Modifications en attente »

Lorsque vous modifiez le contenu d'une liste, vous n'êtes pas obligé d'attendre que vos modifications précédentes soient envoyées au serveur pour en apporter d'autres. Pendant que vous apportez des modifications, la liste continue d'envoyer en arrière-plan vos modifications au serveur. Si vous avez modifié en bloc plusieurs cellules (vous avez rempli plusieurs lignes en faisant glisser la poignée de recopie, par exemple), la liste peut prendre plusieurs secondes pour envoyer toutes les modifications au serveur. Dans ce cas, elle affiche le lien Modifications en attente dans la barre d'état.

L'affichage de ce lien ne signifie pas que vous devez différer l'ajout ou la modification de données jusqu'à ce que les précédentes modifications soient envoyées. Toutefois, si vous tentez de modifier la formule d'une colonne calculée ou d'actualiser ou de fermer l'affichage, vous recevez un message vous indiquant que vous devez patienter jusqu'à ce que vos modifications soient envoyées au serveur.


La barre d'état affiche « Lecture seule » ou « Cet affichage est en lecture seule »

La cellule, la colonne, la ligne sélectionnée ou l'affichage entier est en lecture seule. Vous ne pouvez pas modifier une cellule, une colonne ou une ligne qui est marquée en lecture seule. Si l'affichage entier est en lecture seule, vous ne pouvez pas modifier une partie de celui-ci.

La totalité ou certaines parties d'un affichage peuvent être en lecture seule pour une ou plusieurs des raisons suivantes :

  • Certaines colonnes, telles que Créé par et Modifié, sont toujours en lecture seule. Les valeurs de ces colonnes sont entrées automatiquement.
  • Les modifications que vous apportez à la ligne ou à la colonne sélectionnée ont été envoyées au serveur. S'il n'existe aucun conflit ou aucune erreur, vous pouvez modifier la ligne ou la colonne après l'enregistrement des modifications.
  • La ligne ou la colonne sélectionnée contient une erreur ou un conflit non résolu. Résolvez le conflit ou l'erreur avant de tenter de modifier la ligne ou la colonne sélectionnée.
  • La liste est configurée de telle façon qu'elle requiert l'approbation du contenu et vous l'affichez en mode Tous les éléments.
  • Dans l’affichage Mes envois d’une liste qui requiert l’approbation de contenu, les colonnes Statut d’approbation et Commentaires sont en lecture seule. Seul un utilisateur disposant du droit d’approbation peut modifier ces deux colonnes.
  • Les pièces jointes sont en lecture seule dans une liste qui requiert l'approbation du contenu. Vous ne pouvez pas afficher ou modifier les pièces jointes dans aucun des affichages.
  • Le document de la ligne active a été extrait par un utilisateur. Vous ne pouvez pas modifier les colonnes de la ligne tant que l'utilisateur n'a pas archivé le document.
  • Vous n'êtes pas autorisé à modifier la colonne ou la ligne. Contactez l'auteur de la liste pour plus d'informations.


La barre d'état affiche « Récupération des données »

La liste récupère des données par lots de lignes. Elle tente d’extraire le lot suivant. Cela peut prendre quelques instants si le serveur est occupé.

Si le serveur rencontre un problème lors de la récupération des données, un message apparaît. Dans ce cas, fermez la liste et réessayez ultérieurement.


Prise en charge internationale

Des informations détaillées sur la prise en charge internationale des listes figurent dans l'aide de Microsoft SharePoint Foundation 2010.

Pour afficher l’aide de Microsoft SharePoint Foundation 2010, cliquez sur Aide ( Icône Aide).


Reconversion d'une chaîne de caractère déterminée

Remarque Cette commande est disponible uniquement si la prise en charge de l'éditeur de méthode d'entrée en japonais, en chinois simplifié ou en chinois traditionnel est activée sur votre système d'exploitation ou via les paramètres de langue Microsoft Office.

Vous pouvez reconvertir une chaîne de caractère qui a déjà été entrée et convertie.

  1. Placez le point d'insertion au début ou parmi les caractères que vous voulez reconvertir.
  2. Cliquez avec le bouton droit sur la cellule, puis cliquez sur Reconvertir dans le menu contextuel.
  3. Cliquez sur le caractère souhaité, puis appuyez deux fois sur ENTRÉE.