Bienvenue dans le système d’aide de l’Assistant Configuration des produits SharePoint

Table des matières :

  • Bienvenue dans l’Assistant Configuration des produits SharePoint
  • Mise à niveau visuelle
  • Se connecter à une batterie de serveurs
  • Spécifier les paramètres de la base de données de configuration
  • Spécifier les paramètres de sécurité de la batterie de serveurs
  • Configurer l’application Web Administration centrale de SharePoint
  • Vérifier les paramètres
  • Paramètres avancés
  • Configuration des produits SharePoint
  • Configuration terminée
  • Supprimer le site Web Administration centrale de SharePoint
  • Modifier les paramètres d’une batterie de serveurs
  • Remplacer le site SharePoint par défaut
  • Procédure : configurer le serveur proxy
  • Procédure : réparer les produits SharePoint
  • Applets de commande Windows PowerShell pour l’Assistant Configuration des produits SharePoint


Configurer l’application Web Administration centrale de SharePoint

Vous pouvez configurer l’application Web Administration centrale de SharePoint et les paramètres de sécurité.

Numéro de port

L’application Web Administration centrale de SharePoint vous permet de gérer les paramètres de configuration de votre batterie de serveurs SharePoint. Le premier serveur que vous ajoutez à la batterie de serveurs héberge ce site Web. Si vous devez spécifier un numéro de port, vous pouvez utiliser n’importe quel numéro compris entre 1 et 65535 bien qu’il soit recommandé d’éviter les numéros de la plage de ports connus.

Les numéros de port appartiennent aux trois plages suivantes :

  • Les ports connus sont compris entre 0 et 1023.
  • Les ports enregistrés sont compris entre 1024 et 49151.
  • Les ports dynamiques ou privés font partie de la plage comprise entre 49152 et 65535.

Si vous devez changer ultérieurement le numéro de port, vous devrez réexécuter l’Assistant Configuration des produits SharePoint. L’Assistant Configuration mettra à jour le numéro de port dans la base de données de configuration et créera un travail pour mettre à jour le numéro de port dans chaque application Web Administration centrale de SharePoint sur les autres serveurs de la batterie.

Remarque La modification manuelle du numéro de port de l’application Web Administration centrale de SharePoint dans le Gestionnaire des services Internet (IIS) n’est pas prise en charge. Vous devez réexécuter l’Assistant Configuration.

Paramètres de sécurité

Les protocoles d’authentification NTLM et Kerberos sont pris en charge.

NTLM

Le paramètre par défaut, à savoir le protocole NTLM, est basé sur un mécanisme de stimulation/réponse pour authentifier le client. Le protocole NTLM est disponible dans les produits SharePoint pour communiquer avec les systèmes qui ne peuvent utiliser que l’authentification NTLM.

Négocier (Kerberos)

Le protocole Kerberos version 5 est le principal protocole de sécurité pour l’authentification au sein d’un domaine. L’authentification Kerberos utilise un système de tickets de service qui vérifie l’identité de l’utilisateur et des services réseau. Cette double vérification porte le nom d’authentification mutuelle. Le système tente d’abord de négocier l’authentification via le protocole Kerberos, mais si cette tentative échoue, il utilise le protocole NTLM.

Pour activer l’authentification Kerberos, vous devez effectuer une configuration supplémentaire. Pour plus d’informations, voir Kerberos.


Supprimer le site Web Administration centrale de SharePoint

Le site Web Administration centrale de SharePoint vous permet d’effectuer des tâches administratives localement ou à distance.Il doit y avoir au moins un site Web Administration centrale de SharePoint dans chaque batterie de serveurs.

Vous pouvez utiliser les options de cette page pour modifier le site Web Administration centrale de SharePoint.


Configuration terminée

Dès que l’Assistant Configuration des produits SharePoint a terminé toutes les tâches de configuration requises, vous pouvez accéder à l’Administration centrale de SharePoint pour configurer votre site Web.

Configuration réussie

Si vous effectuez une installation autonome, une fois les tâches de configuration nécessaires accomplies, vous pouvez cliquer sur Terminer pour fermer l’Assistant Configuration. La page d’accueil du site Web par défaut s’ouvre.

Si vous effectuez une installation ou une mise à niveau sur une batterie de serveurs, dès que les paramètres de configuration que vous avez entrés s’affichent, vous pouvez cliquer sur Terminer pour fermer l’Assistant Configuration. Le site Administration centrale de SharePoint s’affiche dans votre navigateur Web.

Si vous effectuez une réparation, cliquez sur Fermer pour quitter l’Assistant Configuration.

Remarque Si vous utilisez Microsoft Internet Explorer et n’avez pas modifié les paramètres par défaut, la sécurité renforcée est activée. Lorsque l’Assistant Configuration lance Internet Explorer, un message contextuel vous invite à ajouter le site à la liste des sites de confiance.

Échec de configuration

Si des erreurs se sont produites lors de la réalisation d’une ou de plusieurs tâches, les événements sont écrits dans le journal d’événements et dans le journal d’installation. Pour vous permettre d’effectuer un diagnostic du problème, vous voyez s’afficher des informations détaillées sur la tâche de configuration en cours d’exécution au moment de l’échec de l’Assistant Configuration, ainsi que les messages d’erreur correspondants et un lien vers le fichier journal.


Modifier les paramètres d’une batterie de serveurs

Vous pouvez utiliser les options de cette page pour modifier les paramètres d’une batterie de serveurs. Le nom du serveur qui héberge la base de données de configuration et le nom de cette base de données s’affichent.

Si vous souhaitez déconnecter cet ordinateur de cette batterie de serveurs, sélectionnez Se déconnecter de cette batterie de serveurs, puis cliquez sur Suivant. Une fois la configuration terminée, cet ordinateur n’hébergera plus le site Web Administration centrale de SharePoint et sera automatiquement supprimé de la batterie de serveurs SharePoint.

Vous pourrez ensuite exécuter l’Assistant Configuration si vous souhaitez connecter l’ordinateur à une autre batterie de serveurs.


Configuration des produits SharePoint

L’Assistant Configuration des produits SharePoint effectue les tâches de configuration suivantes :

  • Il configure l’accès aux bases de données et crée les bases de données de contenu de configuration et d’administration. Dans une installation autonome, SQL Server Express 2008 est installé et configuré.
  • Il installe et configure les fonctionnalités et les services.
  • Il configure la sécurité.
  • Il crée un exemple de données.

Remarque Le délai nécessaire à l’exécution de chaque tâche de configuration est variable.

Si l’Assistant Configuration rencontre une erreur lors de l’exécution d’une tâche, il interrompt la configuration. La page Configuration terminée s’affiche avec un message annonçant l’échec de la configuration et un lien vers le fichier journal à utiliser pour résoudre le problème qui a provoqué cet échec.

Si vous annulez l’Assistant Configuration, les tâches de configuration déjà effectuées ne sont pas annulées ; pour terminer le déploiement du serveur, il faut effectuer les tâches de configuration restantes. Pour cela, vous devez exécuter à nouveau l’Assistant de configuration.

Exécution de l’outil de vérification de mise à niveau

Si vous effectuez une mise à niveau, il est recommandé d’utiliser d’abord l’outil de vérification de mise à niveau pour analyser vos sites. L’outil de vérification de mise à niveau doit être exécuté sur chaque ordinateur de la batterie de serveurs où est installé SharePoint.

Remarque Pour pouvoir exécuter cet outil, vous devez être membre du groupe Administrateurs sur l’ordinateur local.

Sur une ligne de commande, accédez au dossier suivant de votre disque dur : %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\bin, puis exécutez la commande suivante pour analyser un serveur de votre batterie de serveurs :

stsadm.exe -o preupgradecheck

Vous devez exécuter cet outil sur chaque serveur de votre batterie de serveurs. L’exécution de l’outil peut prendre de quelques minutes à quelques heures selon la taille du contenu de votre environnement.

Une fois l’analyse terminée, vous pouvez afficher un fichier de résultat qui liste tous les problèmes détectés et qui décrit leur mode de résolution. Le fichier se trouve dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\LOGS. Les fichiers journaux sont nommés selon le format suivant : PreUpgradeCheck_AAAAMMJJ-HHMMSS-SSS-nombre-aléatoire.log, où AAAAMMJJ représente la date et HHMMSS-SSS représente l’heure (au format 24 heures avec minutes, secondes et millisecondes). Le nombre aléatoire sert à différencier les éventuelles tentatives simultanées d’exécution de la commande de pré-mise à niveau.

Mise à niveau d’une batterie de serveurs

Si vous procédez à la mise à niveau d’une batterie de serveurs, suivez la procédure ci-après :

  1. Exécutez le programme d’installation, puis exécutez l’Assistant Configuration des produits SharePoint sur le serveur qui exécute l’Administration centrale de SharePoint dans votre batterie de serveurs.
  2. Lorsqu’un message s’affiche, vous invitant à exécuter le programme d’installation sur les autres serveurs de la batterie, vous devez faire de même et exécuter le programme d’installation, puis l’Assistant Configuration des produits SharePoint sur les autres serveurs.
  3. Une fois que tous les serveurs de la batterie affichent le message, revenez au premier serveur Web et cliquez sur OK pour poursuivre le processus de mise à niveau sur celui-ci.
  4. À l’issue de l’exécution de l’Assistant sur le premier serveur, procédez à la configuration des autres serveurs.

Spécifications des comptes de sécurité

Pour déployer les produits SharePoint au sein d’un environnement comportant une batterie de serveurs, vous devez utiliser un compte d’utilisateur permettant à la fois d’installer le produit et d’exécuter l’Assistant Configuration des produits SharePoint. Ce compte doit être un compte d’utilisateur de domaine unique, pouvant être désigné en tant que compte de service. Ce compte d’utilisateur sert à accéder à votre base de données de configuration. Il est utilisé tant pour la configuration initiale des bases de données que pour assurer la connexion des serveurs de la batterie aux bases de données.

Important Veillez à ce que votre domaine ne mette pas en œuvre une stratégie de groupe qui interdise au compte choisi comme compte d’accès aux bases de données de s’exécuter en tant que service.

Ce compte agit aussi en tant qu’identité du pool d’applications pour le pool d’applications de l’Administration centrale de SharePoint. Le service Minuteur de SharePoint 2010 s’exécute sous l’égide de ce compte. Nous vous conseillons d’appliquer le principe des privilèges minimum et de n’intégrer ce compte d’utilisateur à aucun groupe de sécurité, que ce soit sur vos serveurs Web ou sur vos serveurs de bases de données.


Procédure : réparer les produits SharePoint

Utilisez cette procédure pour démarrer l’Assistant Configuration des produits SharePoint en mode réparation.

  1. Cliquez sur Démarrer, sur Panneau de configuration, puis sur Ajout/Suppression de programmes.
  2. Sélectionnez l’installation de produit ou technologie SharePoint que vous souhaitez réparer et cliquez sur Modifier.
  3. Dans l’Assistant Installation, sélectionnez Réparer, puis cliquez sur Continuer. Une validation des fichiers binaires est effectuée.
  4. Sur l’écran final de l’Assistant Installation, sélectionnez Exécuter l’Assistant Configuration des produits SharePoint, puis cliquez sur Fermer.
  5. L’Assistant Configuration des produits SharePoint est automatiquement appelé en mode réparation ; il détecte les composants manquants, puis détermine le mode d’installation sélectionné à l’origine.
  6. En cas d’un déploiement multiserveur, vous êtes invité à entrer vos informations de connexion au pool d’applications.
  7. Donnez les informations de connexion du compte Exécuter en tant que pour le pool d’applications.
  8. L’Assistant de configuration vérifie les conditions préalables et exécute les tâches requises pour réparer la configuration.


Bienvenue dans l’Assistant Configuration des produits SharePoint

L’Assistant Configuration des produits SharePoint effectue, presque sans l’intervention de l’utilisateur, des tâches de base indispensables au démarrage de l’Administration centrale de SharePoint ou qui ne peuvent pas être exécutées ailleurs.

Outre la configuration initiale, l’Assistant de configuration permet de réaliser les tâches suivantes à n’importe quel moment :

  • Identifier les composants manquants.
  • Valider votre configuration.
  • Identifier, réparer ou redéfinir les paramètres de sécurité et de configuration de bas niveau.

L’Assistant Configuration devra peut-être démarrer, interrompre ou réinitialiser le service d’administration SharePoint, le service du minuteur SharePoint, les services Internet (IIS) et les services d’autres applications qui dépendent de Microsoft SharePoint Foundation et sont correctement inscrits.

Si vous ne voulez pas interrompre les opérations serveur, cliquez sur Non pour quitter l’Assistant de configuration.

Remarque Vous devez exécuter entièrement l’Assistant Configuration pour terminer le déploiement serveur, accéder à l’Administration centrale de SharePoint et configurer votre site.

Une fois la configuration terminée dans l’Assistant, les services nécessaires à l’exécution de l’Administration centrale sont activés. Vous devez alors configurer votre site à l’aide de l’Administration centrale.

Configuration logicielle requise

Pour pouvoir installer, configurer ou faire fonctionner le serveur, les conditions suivantes doivent être remplies :

  • Édition 64 bits d’un système d’exploitation Windows Server 2008 pris en charge.
  • Microsoft SQL Server Express (pour les installations autonomes) ou une version prise en charge de Microsoft SQL Server 2005 ou SQL Server 2008.
  • Informations d’identification pour les serveurs sur lesquels vous effectuez l’installation et un compte de domaine à utiliser comme compte de service.

Pour plus d’informations sur ces conditions et pour consulter la documentation la plus à jour et la plus complète concernant ce produit, voir le TechCenter des produits Microsoft SharePoint 2010.

Autonome

Le déploiement des produits SharePoint dans un environnement autonome consiste à installer tous les composants et fonctionnalités sur un seul ordinateur autonome en utilisant les paramètres par défaut. L’Assistant Configuration ne vous invite pas à définir les paramètres de configuration, ni les informations d’identification. Il utilise les valeurs par défaut pour créer l’application Web, les services principaux et les groupes de sécurité standard nécessaires au démarrage de l’Administration centrale.

L’Assistant de configuration utilise les paramètres par défaut si vous sélectionnez l’une des options suivantes dans l’Assistant Installation :

  • Autonome
  • Batterie de serveurs, puis Autonome

Batterie de serveurs

Lorsque vous sélectionnez l’option Batterie de serveurs dans l’Assistant Configuration, ce dernier vous permet d’effectuer l’installation sur une batterie de serveurs, d’utiliser une base de données existante, de déployer une nouvelle batterie de serveurs ou de vous connecter à une batterie existante. Vous pouvez créer des bases de données ou utiliser celles qui existent déjà. Dans votre batterie de serveurs, vous pouvez utiliser un ou plusieurs ordinateurs comme serveurs Web. En outre, un ou plusieurs ordinateurs peuvent fournir des services de base de données à partir de Microsoft SQL Server.

L’Assistant de configuration vous demandera de fournir les informations d’identification requises pour créer les éléments principaux comme l’application Web de l’Administration centrale et la nouvelle base de données de configuration.

Réparation

Vous pouvez utiliser l’option Réparer pour remplacer les fichiers modifiés ou endommagés et les paramètres du Registre.

Par exemple, vous pouvez utiliser l’option Réparer lorsque vous voulez restaurer le paramètre par défaut d’une entrée de Registre qui a été remplacée.

Lorsque vous réparez une installation, les fichiers déjà installés sont vérifiés, les composants manquants sont détectés et la configuration est réparée.

Pour plus d’informations, voir Procédure : réparer les produits SharePoint.

Mise à niveau

Vous pouvez effectuer la mise à niveau vers la dernière version des produits SharePoint.

Exécution de l’outil de vérification de mise à niveau

Si vous effectuez une mise à niveau, vous devez d’abord utiliser l’outil de vérification de mise à niveau pour analyser vos sites.

Remarque Pour pouvoir exécuter cet outil, vous devez être membre du groupe Administrateurs sur l’ordinateur local.

Sur une ligne de commande, accédez au dossier suivant de votre disque dur : %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\bin, puis exécutez la commande suivante pour analyser un serveur de votre batterie de serveurs :

stsadm.exe -o preupgradecheck

Vous devez exécuter l’outil sur chaque serveur de votre batterie de serveurs. L’exécution de l’outil peut prendre de quelques minutes à quelques heures selon la taille du contenu de votre environnement.

Une fois l’analyse terminée, vous pouvez afficher un fichier de résultat qui liste tous les problèmes détectés et qui décrit leur mode de résolution. Le fichier se trouve dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\12\LOGS. Les fichiers journaux sont nommés selon le format suivant : PreUpgradeCheck_AAAAMMJJ-HHMMSS-SSS-nombre-aléatoire.log, où AAAAMMJJ représente la date et HHMMSS-SSS représente l’heure (au format 24 heures avec minutes, secondes et millisecondes). Le nombre aléatoire sert à différencier les éventuelles tentatives simultanées d’exécution de la commande de pré-mise à niveau.

Mise à niveau d’une batterie de serveurs

Si vous procédez à la mise à niveau d’une batterie de serveurs, suivez la procédure ci-après :

  1. Exécutez le programme d’installation, puis exécutez l’Assistant Configuration des produits SharePoint sur le serveur qui exécute l’Administration centrale de SharePoint dans votre batterie de serveurs.
  2. Lorsqu’un message s’affiche, vous invitant à exécuter le programme d’installation sur les autres serveurs de la batterie, vous devez faire de même et exécuter le programme d’installation, puis l’Assistant Configuration des produits SharePoint sur les autres serveurs.
  3. Une fois que tous les serveurs de la batterie affichent le message, revenez au premier serveur Web et cliquez sur OK pour poursuivre le processus de mise à niveau sur celui-ci.
  4. À l’issue de l’exécution de l’Assistant sur le premier serveur, procédez à la configuration des autres serveurs.

Application de mises à jour à une batterie de serveurs

Après avoir appliqué une mise à jour, par exemple un Service Pack ou une mise à jour cumulative, vous devez exécuter l’Assistant Configuration des produits SharePoint pour mettre à niveau la batterie de serveurs vers la nouvelle version. Tous les serveurs de la batterie de serveurs doivent être mis à jour vers la même version ; en outre, les mêmes produits et modules linguistiques doivent être installés sur ces serveurs pour permettre l’exécution de l’Assistant Configuration. Si l’un des serveurs de votre batterie de serveurs n’est pas mis à jour, la page État des produits et des correctifs de la batterie de serveurs s’affiche, en répertoriant l’état actuel de chaque serveur de la batterie de serveurs. Dans cette page, vous pouvez déterminer quels sont les serveurs à mettre à jour. Pour mettre à jour vos serveurs, quittez l’Assistant Configuration des produits SharePoint, exécutez la mise à jour sur les serveurs où elle est nécessaire, puis réexécutez l’Assistant Configuration.


Se connecter à une batterie de serveurs

Vous pouvez créer une batterie de serveurs ou gérer la connexion à une batterie de serveurs SharePoint existante. Vous devez fournir le nom du serveur de base de données, le nom de la base de données, ainsi que les informations d’identification d’un compte d’utilisateur servant à accéder à la base de données. Si vous vous connectez à une batterie de serveurs existante, vous devez également spécifier une phrase secrète à utiliser pour la connexion à la batterie de serveurs. Pour plus d’informations, voir Spécifier les paramètres de sécurité de la batterie de serveurs.

Tous les serveurs de la batterie doivent utiliser la même base de données de configuration. Si la base de données n’existe pas, une nouvelle base de données est créée. Si le nom de la base de données est identique à celui d’une base de données existante, la base de données ne doit contenir aucune table, procédure stockée ou autre objet.

Entrez les informations d’identification du compte d’utilisateur utilisé par les produits SharePoint pour la connexion à la base de données. Si la base de données de configuration est hébergée sur un autre ordinateur, le compte doit être un compte de domaine.

Vous pouvez sélectionner l’une des options suivantes :

  • Ne pas modifier ces paramètres
  • Créer une nouvelle batterie de serveurs
  • Se connecter à une batterie de serveurs existante
  • Se déconnecter de cette batterie de serveurs

Remarque Il se peut que toutes les options n’apparaissent pas dans votre installation. Les options affichées dépendent de la configuration et l’état de votre batterie de serveurs.

L’Assistant Configuration vérifie s’il existe une connexion à une base de données de configuration. Si ce n’est pas le cas, une nouvelle batterie de serveurs est créée. Si une connexion existe, les paramètres ne sont pas modifiés.

Lorsque vous gérez la connexion de base de données à une batterie de serveurs existante, l’Assistant Configuration vérifie qu’il existe une ou plusieurs applications Web Administration centrale de SharePoint dans la batterie de serveurs enregistrées dans la base de données de configuration. Vous évitez ainsi d’être confronté au cas où il existe une batterie de serveurs mais où aucune application Web Administration centrale de SharePoint n’est installée pour gérer l’installation.

Si vous sélectionnez l’option Se déconnecter de cette batterie de serveurs, l’Assistant Configuration supprime le serveur de la batterie puis met à jour l’Administration centrale de SharePoint pour la batterie.

Si l’ordinateur déconnecté dispose d’une application Web Administration centrale de SharePoint, celle-ci est supprimée ainsi que l’entrée dans la base de données de configuration.


Procédure : configurer les paramètres du serveur proxy

Cette procédure permet de configurer le serveur proxy réseau.

  1. Cliquez sur Démarrer, sur Panneau de configuration, sur Centre Réseau et partage, puis sous Voir aussi, cliquez sur Options Internet.
  2. Dans la boîte de dialogue Propriétés d’Internet, cliquez sur l’onglet Connexions.
  3. Cliquez sur Paramètres réseau.
  4. Dans la boîte de dialogue Paramètres du réseau local, section Configuration automatique, vérifiez que les deux cases à cocher sont désactivées.
  5. Dans la section Serveur proxy, procédez comme suit :
    1. Activez la case à cocher Utiliser un serveur proxy pour votre réseau local.
    2. Dans la zone Adresse, tapez le nom de votre serveur proxy.
    3. Dans la zone Port, tapez le numéro de port de votre serveur proxy.
    4. Activez la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.
  6. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du réseau local.
  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés d’Internet.


Applets de commande Windows PowerShell pour l’Assistant Configuration des produits SharePoint

Dans la version 2010 des produits SharePoint, vous pouvez utiliser les applets de commande Windows PowerShell comme interface pour effectuer différentes opérations de configuration des produits SharePoint. Pour pouvoir réaliser ces opérations, vous devez être membre du groupe Administrateurs sur l’ordinateur local.

Vous exécutez les applets de commande Windows PowerShell à partir de la fenêtre de la console de gestion SharePoint 2010. Pour accéder à la fenêtre de la console de gestion SharePoint 2010, cliquez sur Démarrer, pointez sur Tous les programmes, sur Outils d’administration, puis cliquez sur Console de gestion SharePoint 2010.

Les applets de commande doivent être exécutées dans un ordre spécifique pour pouvoir fonctionner correctement. Si vous utilisez l’Assistant Configuration des produits SharePoint pour configurer votre installation, il appelle automatiquement les commandes (également appelées tâches de configuration) dans l’ordre approprié. Cependant, si vous utilisez des applets de commande, assurez-vous d’effectuer les tâches dans l’ordre requis. Les applets de commande Windows PowerShell doivent être exécutées dans l’ordre suivant :

  1. New-SPConfigurationDatabase
  2. Install-SPHelpCollection
  3. Initialize-SPResourceSecurity
  4. Install-SPService
  5. Install-SPFeature
  6. New-SPCentralAdministration
  7. Install-SPApplicationContent


Spécifier les paramètres de la base de données de configuration

La base de données de configuration sert à stocker les informations de configuration et de mappage du site pour votre batterie de serveurs. Que celle-ci soit composée d’un seul ordinateur entièrement équipé ou de plusieurs ordinateurs, elle doit disposer d’une base de données de configuration.

Paramètres de la base de données

Vous devez fournir les paramètres de connectivité à un serveur de base de données existant via un compte d’utilisateur existant.

Serveur de base de données

Vous devez taper le nom de l’ordinateur exécutant une version prise en charge de Microsoft SQL Server 2005 ou Microsoft SQL Server 2008. Vous pouvez taper le nom de l’ordinateur qui exécute SQL Server sous la forme serveur ou serveur\instance.

Nom de la base de données

Si vous créez une base de données de configuration, vous pouvez taper son nom pour que l’Assistant Configuration la crée ; sinon, vous pouvez taper le nom d’une base de données configurée à l’avance. Pour utiliser une base de données existante, vous devez exécuter Psconfig.exe à partir de la ligne de commande afin de vous connecter à cette base de données. En outre, elle ne doit pas contenir de tables, de procédures stockées ou d’autres objets.

Si vous vous connectez à une base de données de configuration existante, vous pouvez cliquer sur Récupérer les noms de bases de données. Cela permet d’extraire les bases de données de configuration enregistrées sur l’ordinateur exécutant SQL Server et de choisir celle qui convient.

Compte d’accès à la base de données

Vous devez entrer les informations d’identification d’un compte d’utilisateur existant. Ce dernier sera toujours utilisé pour la connexion à la base de données. Si la base de données de configuration est hébergée sur un autre ordinateur, vous devez fournir les informations d’identification d’un compte de domaine.

Bien que vous puissiez entrer un compte local ou un compte de domaine dans les installations utilisant SQL Server, le compte local fonctionne uniquement pour les déploiements à un seul serveur. Pour plus de flexibilité, il est recommandé d’utiliser un compte de domaine si vous envisagez d’ajouter ultérieurement d’autres ordinateurs à la batterie de serveurs.

Pour déployer les produits SharePoint au sein d’un environnement comportant une batterie de serveurs, vous devez utiliser un compte d’utilisateur de domaine unique pouvant être désigné en tant que compte de service SharePoint. Ce compte d’utilisateur sert à accéder à la base de données de configuration. Il est utilisé tant pour la configuration initiale des bases de données que pour assurer la connexion des serveurs de la batterie aux bases de données.

Important Veillez à ce que votre domaine ne mette pas en œuvre une stratégie de groupe qui interdise au compte choisi comme compte d’accès aux bases de données de s’exécuter en tant que service.

Ce compte agit aussi en tant qu’identité du pool d’applications pour le pool d’applications de l’Administration centrale de SharePoint. Le service Minuteur de SharePoint 2010 s’exécute sous l’égide de ce compte. L’Assistant Configuration des produits SharePoint ajoute ce compte aux noms d’utilisateurs SQL Server ainsi qu’aux rôles de serveur Créateur de base de données SQL Server et Administrateur de sécurité SQL Server. Nous vous conseillons d’appliquer le principe des privilèges minimum et de n’intégrer ce compte d’utilisateur à aucun groupe de sécurité, que ce soit sur vos serveurs Web ou sur vos serveurs de bases de données.

Le compte d’accès à la base de données doit posséder les autorisations suivantes : administrateur de sécurité, créateur de base de données et propriétaire de base de données pour toutes les bases de données SharePoint. Si vous exécutez Psconfig.exe à partir de la ligne de commande pour installer et spécifier le compte à l’aide de l’authentification SQL, les autorisations relatives à ce compte doivent être configurées dans SQL Server ; l’Assistant Configuration n’effectue pas cette configuration lorsque vous exécutez Psconfig.exe à partir de la ligne de commande avec l’option d’authentification SQL.

Le compte spécifié pour l’accès à la base de données doit posséder au minimum les autorisations suivantes :

  • capacité de lire et d’écrire dans la base de données de configuration ;
  • autorisations serveur (administrateur de sécurité) dans SQL Server ;
  • pour la création et l’ajout d’un schéma, autorisations d’un propriétaire de base de données.

De plus, si l’Assistant de configuration crée une nouvelle base de données de configuration, le compte d’accès à la base de données doit bénéficier des autorisations suivantes :

  • création de base de données ;
  • création de procédure.

Tâches

Pour créer la base de données de configuration, l’Assistant Configuration effectue les tâches suivantes :

  1. Vérifier que SQL Server satisfait aux conditions minimales.
  2. Créer une base de données ou se connecter à une base de données existante vide.
  3. Ajouter un schéma de base de données à la nouvelle base de données de configuration.
  4. Ajouter le serveur actif à la topologie.
  5. Ajouter à la base de données de configuration les informations d’identification du compte d’accès à la base de données.
  6. Écrire la chaîne de connexion à la base de données dans le Registre de l’ordinateur local.

Pour se déconnecter d’une base de données de configuration, l’Assistant Configuration effectue les tâches suivantes :

  1. Supprimer la chaîne de connexion de la base de données de configuration.
  2. Interrompre sur l’ordinateur local l’exécution du service NT de planification des tâches.
  3. Supprimer les données spécifiques à l’ordinateur de l’ancienne base de données de configuration.


Paramètres avancés

Pour créer automatiquement des comptes d’utilisateurs uniques à l’aide des services de domaine Active Directory (AD DS), vous devez activer le mode de création de compte Active Directory.

Étant donné qu’au moins une application Web Administration centrale est requise pour chaque batterie de serveurs, dans le premier serveur de la batterie, l’application Web Administration centrale est automatiquement installée et seul un ensemble de champs est présenté pour le domaine Active Directory et l’unité d’organisation Active Directory. Lorsque vous exécutez l’Assistant de configuration sur les autres serveurs de la batterie, une option s’affiche sur cet écran pour créer l’application Web Administration centrale.

Si vous souhaitez créer une URL d’équilibrage de charge pour l’Administration centrale, ou assurer une redondance, vous pouvez créer plusieurs sites Web Administration centrale. Toutefois, ceci n’est pas nécessaire dans la plupart des installations.

Pour activer le mode de création de compte Active Directory
  1. Sur la page Paramètres avancés, sélectionnez Activer le mode de création de compte Active Directory.
  2. Sous Domaine Active Directory, tapez le nom de votre domaine.
  3. Sous Unité d’organisation Active Directory, tapez votre unité d’organisation SharePoint.
  4. Pour retourner à la page Fin de l’Assistant Configuration des produits SharePoint, cliquez sur OK.

Avertissement Si vous activez cette option, vous risquez de ne pas pouvoir effectuer la mise à niveau de Microsoft SharePoint Foundation vers d’autres produits basés sur les produits et technologies SharePoint. Si vous rencontrez des difficultés lors de l’installation de produits SharePoint sur cet ordinateur, exécutez de nouveau l’Assistant Configuration des produits SharePoint pour désactiver cette option.


Vérifier les paramètres

Utilisez la page Fin de l’Assistant Configuration des produits SharePoint pour vérifier les paramètres de la base de données et de l’application Web Administration centrale définis.

Vérifiez que les paramètres sont corrects, puis cliquez sur Suivant pour continuer.

Cliquez sur Paramètres avancés pour activer le mode de création de compte Active Directory. Pour plus d’informations, voir Paramètres avancés.


Remplacer le site SharePoint par défaut

Lorsque vous exécutez une installation autonome ou une mise à niveau et qu’un produit SharePoint existant est déjà installé, il est possible qu’un site SharePoint soit déjà défini par défaut sur le port 80.

Si vous êtes sûr que ce site n’est pas nécessaire, vous pouvez le désactiver et en créer un autre que vous hébergerez au port 80 ou sur un autre port.


Spécifier les paramètres de sécurité de la batterie de serveurs

Tapez une phrase secrète pour contribuer à sécuriser les données de configuration de la batterie de serveurs, puis cliquez sur Suivant.

Bien qu’une phrase secrète soit similaire à un mot de passe, elle est généralement plus longue que ce dernier afin d’accroître la sécurité. Elle sert à chiffrer les informations d’identification des comptes inscrits dans les produits SharePoint, par exemple, le compte système spécifié lors de l’exécution de l’Assistant Configuration des produits SharePoint. Veillez à ne pas oublier la phrase secrète, car vous devez l’utiliser chaque fois que vous ajoutez un serveur à la batterie de serveurs.

Assurez-vous que la phrase secrète répond aux critères suivants :

  • Huit caractères de longueur au minimum
  • Contient au moins trois des quatre groupes de caractères suivants :
    • caractères majuscules (de A à Z) ;
    • caractères minuscules (de a à z) ;
    • chiffres (de 0 à 9) ;
    • caractères non alphabétiques (par exemple !, $, #, %).

Vous pouvez modifier la phrase secrète après la configuration de la batterie de serveurs en exécutant l’applet de commande Set-SPPassphrase dans Windows PowerShell. Par défaut, la nouvelle phrase secrète est déployée sur tous les serveurs de la batterie. Cependant, si un problème se pose lors du déploiement de la nouvelle phrase secrète, vous devez mettre à jour manuellement la phrase secrète sur le serveur où le déploiement a échoué. Exécutez l’applet de commande Set-SPPassphrase - LocalServerOnly dans Windows PowerShell pour mettre à jour manuellement la phrase secrète.

Remarque La page Spécifier les paramètres de sécurité de la batterie de serveurs ne s’affiche pas lorsque vous effectuez une mise à niveau.


Mise à niveau visuelle

La mise à niveau visuelle permet aux utilisateurs de conserver l’aspect existant des sites SharePoint après une mise à niveau vers une nouvelle version. Cela réduit l’impact de la mise à niveau sur les utilisateurs ainsi que les problèmes liés aux pages personnalisées, aux composants WebPart, aux contrôles Web et aux affichages.

Les propriétaires de sites peuvent décider s’il convient de mettre à niveau l’apparence de leurs sites vers la nouvelle version, et à quel moment effectuer cette mise à niveau. Par défaut, les sites créés après la mise à niveau utilisent la nouvelle interface utilisateur.

  • Modifier les sites SharePoint existants pour profiter des derniers progrès réalisés dans le confort d’utilisation

    • Sélectionnez cette option si vous souhaitez modifier les sites SharePoint existants afin qu’ils utilisent la nouvelle interface utilisateur, notamment la mise en page, l’organisation des commandes et le style. Si vous sélectionnez cette option, vous devez également sélectionner l’une des options suivantes :

    • Conserver les pages personnalisées, mais mettre à jour le modèle et les pages d’application pour utiliser la nouvelle interface utilisateur

      • Sélectionnez cette option si vous souhaitez modifier les sites SharePoint existants afin qu’ils utilisent la nouvelle interface utilisateur, tout en conservant l’ensemble des modifications personnalisées effectuées.

    • Restaurer toutes les pages personnalisées en fonction de leurs modèles d’origine

      • Sélectionnez cette option si vous souhaitez modifier les sites SharePoint existants afin qu’ils utilisent la nouvelle interface utilisateur et si vous souhaitez remplacer l’ensemble des modifications personnalisées effectuées.

  • Conserver l’aspect des sites SharePoint existants et permettre aux utilisateurs de profiter des derniers progrès réalisés dans le confort d’utilisation de leur site

    • Sélectionnez cette option si vous souhaitez conserver l’interface utilisateur existante, notamment la mise en page, l’organisation des commandes et le style. L’ensemble des données et des paramètres du site d’origine sont conservés.

    Après la mise à niveau d’une batterie de serveurs, les administrateurs de batterie de serveurs, les administrateurs de collections de sites et les propriétaires de sites peuvent mettre à jour leurs sites vers l’interface utilisateur la plus récente.

    Lorsque le site utilise l’interface utilisateur antérieure, certaines des nouvelles fonctionnalités ne sont pas disponibles. Ces fonctionnalités incluent l’interface utilisateur du Ruban, la modification sur place des pages Wiki, les calendriers interactifs et les relations de liste. Lorsque le site est mis à jour vers la toute dernière interface utilisateur, les nouvelles fonctionnalités deviennent automatiquement disponibles.

    Quel que soit le type de mise à niveau sélectionné pour la batterie de serveurs, les administrateurs peuvent tirer parti de tous les avantages liés à la mise à niveau, notamment une meilleure fiabilité, évolutivité et simplicité de gestion.

    La conservation de l’interface utilisateur précédente réduit le risque que le contenu personnalisé cesse de fonctionner. Par conséquent, les administrateurs, les développeurs et les utilisateurs finaux ont la certitude de pouvoir continuer à utiliser le site SharePoint jusqu’à la fin de l’ensemble de la mise à niveau.