Configuration de Reporting Services

Aide du Gestionnaire de configuration de SQL Server 2008 R2 Reporting Services
Configuration de Reporting Services

Utilisez l'outil de configuration Reporting Services pour configurer une installation de SQL Server Reporting Services. Si vous avez installé un serveur de rapports à l'aide de l'option Fichiers uniquement, vous devez utiliser cet outil pour configurer le serveur et pouvoir vous en servir. Si vous avez installé un serveur de rapports avec l'option d'installation de configuration par défaut, vous pouvez utiliser cet outil pour vérifier ou modifier les paramètres spécifiés au cours de l'installation. Si vous procédez à une mise à niveau à partir d'une version antérieure, vous pouvez utiliser cet outil pour mettre à jour la base de données du serveur de rapports dans le nouveau format. Pour plus d'informations sur les options et considérations relatives au déploiement pour la configuration de Reporting Services, consultez les sections Déploiement (Reporting Services en mode natif) et Déploiement (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

L'outil de configuration de Reporting Services peut servir à configurer une instance de serveur de rapports locale ou distante. Vous devez disposer des droits d'un administrateur local sur l'ordinateur hébergeant le serveur de rapports que vous configurez.

Dans cette section

Configuration du compte de service Report Server

Fournit des recommandations et des procédures pour la modification du compte de service et du mot de passe.

Configuration des URL de Report Server

Décrit comment configurer les URL qui servent à accéder au service Web Report Server et au Gestionnaire de rapports.

Création d'une base de données de serveur de rapports

Décrit comment créer une base de données de serveur de rapports en vue du stockage des métadonnées et des objets du serveur.

Configuration d'une connexion de base de données de serveur de rapports

Décrit comment modifier la chaîne de connexion qu'utilise le serveur de rapports pour se connecter à la base de données du serveur de rapports.

Configuration du compte d'exécution sans assistance

Décrit comment configurer un compte d'utilisateur de manière à traiter les rapports en mode sans assistance.

Configuration d'un Report Server pour la remise du courrier électronique

Décrit comment configurer un serveur de rapports pour la prise en charge de la distribution des rapports par messagerie.

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Fournit des informations sur la configuration de plusieurs instances du serveur de rapports pour utiliser une base de données partagée du serveur de rapports.

Configuration de Reporting Services pour l'intégration de SharePoint 2010

Fournit une vue d'ensemble des tâches et spécifications requises pour ajouter un serveur de rapports au déploiement existant d'un produit ou technologie SharePoint.

Configuration et gestion des clés de chiffrement

Explique comment utiliser et gérer les clés de chiffrement utilisées pour le stockage de données sensibles.

Rubriques d'aide à la configuration de Reporting Services

Fournit des instructions, étape par étape, pour les tâches les plus courantes.

Rubriques d'aide F1 sur la configuration de Reporting Services

Fournit des rubriques d'aide sur les pages de l'outil de configuration de Reporting Services.

Documentation en ligne de SQL Server

L'aide en ligne pour l'outil de configuration de Reporting Services est un sous-ensemble de la documentation du produit pour SQL Server Reporting Services. La documentation complète du produit est disponible dans la documentation en ligne de SQL Server.

Lorsque vous utilisez la documentation en ligne de SQL Server, vous avez accès à toutes les rubriques fournies dans le système d'aide en ligne, ainsi qu'à du contenu supplémentaire sur le déploiement, l'administration et la sécurisation de l'installation de Reporting Services. Pour plus d'informations, consultez la rubrique Mise en route de la documentation en ligne de SQL Server dans la documentation en ligne de SQL Server.


Configuration du compte de service Report Server

Configuration du compte de service Report Server |
 | Voir aussi
Configuration de Reporting Services >

Reporting Services est implémenté en tant que service unique qui contient un service Web Report Server, le Gestionnaire de rapports et une application de traitement en arrière-plan utilisée pour le traitement des rapports planifié et la remise d'abonnement. Cette rubrique explique comment le compte de service est configuré initialement et comment modifier le compte ou le mot de passe à l'aide de l'outil de configuration de Reporting Services. Pour plus d'informations sur les applications qui exécutent le service, consultez Architecture du service (Reporting Services) dans la documentation en ligne de Microsoft SQL Server.

Configuration initiale

Le compte de service Report Server est défini pendant l'installation. Vous pouvez exécuter le service au moyen d'un compte d'utilisateur de domaine ou d'un compte intégré tel que NetworkService. Il n'y a aucun compte par défaut ; le compte que vous spécifiez dans la page Configuration du serveur - Comptes de service de l'Assistant Installation devient le compte initial du service Report Server.

Important :
Bien que le service Web Report Server et le Gestionnaire de rapports soient des applications ASP.NET, elles ne s'exécutent pas sous le compte ASP.NET. L'architecture de service unique exécute les deux applications ASP.NET dans la même identité de processus Report Server. Il s'agit d'une modification importante par rapport aux versions précédentes, dans lesquelles le service Web Report Server et le Gestionnaire de rapports s'exécutaient sous l'identité du processus de travail ASP.NET spécifiée dans les services Internet (IIS).

Modification du compte de service

Pour afficher et reconfigurer des informations sur le compte de service, utilisez toujours l'outil de configuration Reporting Services. Les informations sur l'identité du service sont stockées en interne dans plusieurs emplacements. L'utilisation de l'outil garantit que toutes les références sont mises à jour en conséquence chaque fois que vous modifiez le compte ou le mot de passe. L'outil de configuration Reporting Services exécute les étapes supplémentaires suivantes pour s'assurer que le serveur de rapports reste disponible :

  • Il ajoute automatiquement le nouveau compte au groupe de serveurs de rapports créés sur l'ordinateur local. Ce groupe est spécifié dans les listes de contrôle d'accès qui assurent la sécurité des fichiers de Reporting Services.

  • Il met à jour automatiquement les autorisations de connexion sur l'instance du moteur de base de données SQL Server utilisée pour héberger la base de données du serveur de rapports. Le nouveau compte est ajouté au rôle RSExecRole.

    La connexion de base de données pour l'ancien compte n'est pas supprimée automatiquement. Assurez-vous de supprimer les comptes qui ne sont plus utilisés. Pour plus d'informations, consultez Administration d'une base de données du serveur de rapports dans la documentation en ligne de SQL Server.

    L'accord des autorisations de base de données au nouveau compte de service a lieu uniquement si vous avez configuré en premier lieu la connexion de base de données du serveur de rapports de façon à utiliser le compte de service. Si vous avez configuré la connexion de base de données du serveur de rapports de façon à utiliser un compte d'utilisateur de domaine ou une connexion de base de données SQL Server, les informations de connexion ne sont pas affectées par la mise à jour du compte de service.

  • Il met à jour automatiquement la clé de chiffrement pour inclure les informations de profil du nouveau compte.

    Remarque :
    Si le serveur de rapports est intégré au déploiement avec montée en puissance parallèle, seul le serveur de rapports en cours de mise à jour est affecté. Il n'y a aucune incidence sur les clés de chiffrement des autres serveurs de rapports de ce déploiement.

Pour obtenir des instructions sur la définition du compte, consultez Procédure : configurer un compte de service pour Reporting Services.

Choix d'un compte

Vous pouvez configurer le service Report Server pour qu'il s'exécute sous l'un des types de comptes suivants :

  • Compte d'utilisateur Windows le moins privilégié

  • NetworkService

  • LocalSystem

  • LocalService

Il n'existe pas d'approche optimale unique pour le choix d'un type de compte. Chaque compte présente des avantages et des inconvénients que vous devez prendre en compte. Si vous déployez Reporting Services sur un serveur de production, les meilleures pratiques suggèrent de configurer le service pour qu'il s'exécute sous un compte d'utilisateur de domaine, afin d'éviter tout dommage étendu en cas de détournement d'un compte partagé par un utilisateur malveillant. Cela simplifie également l'audit de l'activité d'ouverture de session pour ce compte. L'un des inconvénients liés à l'utilisation d'un compte d'utilisateur Windows est que si vous déployez Reporting Services dans un réseau qui utilise l'authentification Kerberos, vous devez inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom de principal du service (SPN) pour Report Server.

Les instructions et les liens suivants de cette section peuvent vous aider à choisir l'approche la plus appropriée pour votre déploiement.

  • Compte de service (configuration de Reporting Services).

  • Configuration des comptes de service Windows dans la documentation en ligne de SQL Server.

  • Guide de planification de la sécurité des services et des comptes de service (en anglais) sur MSDN.

Mise à jour d'un mot de passe expiré

Si le service Report Server s'exécute sous un compte de domaine et que le mot de passe expire avant que vous puissiez le mettre à jour dans l'outil de configuration de Reporting Services, le service ne démarrera pas tant que vous n'aurez pas spécifié un nouveau mot de passe. Si le service ne peut pas être démarré, vous ne pouvez pas utiliser l'outil de configuration de Reporting Services pour vous connecter à ce serveur afin de mettre à jour le compte. Dans ce cas, vous devez utiliser une combinaison d'outils pour remettre le serveur en ligne.

Pour réinitialiser le mot de passe, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Panneau de configuration, sur Outils d'administration, puis cliquez sur Services.

  2. Cliquez avec le bouton droit sur SQL Server Reporting Services, puis sélectionnez Propriétés.

  3. Cliquez sur Ouvrir une session et entrez le nouveau mot de passe.

  4. Après avoir mis à jour le mot de passe, démarrez l'outil de configuration de Reporting Services et mettez à jour le mot de passe dans la page Compte de service. Cette étape supplémentaire est nécessaire pour mettre à jour les informations de compte stockées de manière interne par le serveur de rapports.

Si le mot de passe du compte de service pour le moteur de base de données expire, l'erreur rsReportServerDatabaseUnavailable se produit si vous tentez de vous connecter au serveur de rapports. La réinitialisation du mot de passe résout cette erreur. Pour afficher le texte complet du message d'erreur, consultez Dépannage des problèmes de connexion à un serveur et à une base de données dans la documentation en ligne de SQL Server.

Configuration du service Report Server pour un serveur de rapports intégré à SharePoint

Si vous exécutez un serveur de rapports en mode intégré SharePoint, vous devez mettre à jour les informations de compte de service stockées dans la base de données de configuration SharePoint si l'une des conditions suivantes est remplie :

  • Modification du compte de service Reporting Services (par exemple, basculement de NetworkService vers un compte d'utilisateur de domaine).

  • Extension d'une batterie de serveurs SharePoint de façon à inclure une application Web SharePoint supplémentaire. Si la batterie de serveurs est configurée pour l'intégration au serveur de rapports et que l'application nouvellement ajoutée est configure pour s'exécuter sous un compte d'utilisateur différent de celui des autres applications de la batterie, vous devez mettre à jour les informations d'accès à la base de données.

Une fois les informations d'accès à la base de données réinitialisées, vous devez redémarrer le service Windows SharePoint Services pour vous assurer que l'ancienne connexion n'est plus utilisée.

  1. Dans Outils d'administration, cliquez sur Administration centrale de SharePoint 2010.

  2. Cliquez sur Gestion des applications.

  3. Dans la section Reporting Services, cliquez sur Accorder l'accès à la base de données.

  4. Cliquez sur OK. La boîte de dialogue Entrer les informations d'identification s'affiche.

  5. Entrez les informations d'identification d'un utilisateur membre du groupe Administrateurs local sur l'ordinateur qui héberge le serveur de rapports. Ces informations seront utilisées pour une connexion ponctuelle à l'ordinateur du serveur de rapports afin de récupérer les informations du compte de service. Le nom de connexion de base de données créé pour chaque compte de service est mis à jour dans les bases de données SharePoint.

  6. Pour redémarrer le service, cliquez sur Opérations.

  7. Dans Topologie et services, cliquez sur Services sur le serveur.

  8. Pour Application Web de Windows SharePoint Services, cliquez sur Arrêter.

  9. Attendez que le service s'arrête.

  10. Cliquez sur Démarrer.

Remarque :
Les produits et technologies SharePoint 2010 requièrent des comptes de domaine pour la configuration du service comme l'intégration des Reporting Services SharePoint.

Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services
Procédure : lancer la configuration de Reporting Services

Référence

Compte de service (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration des URL de Report Server

Configuration des URL de Report Server |
 | Voir aussi
Configuration de Reporting Services >

Dans Reporting Services, les URL permettent d'accéder au service Web Report Server et au Gestionnaire de rapports. Avant de pouvoir utiliser l'une et l'autre application, vous devez configurer au moins une URL pour le service Web et pour le Gestionnaire de rapports. Reporting Services fournit des valeurs par défaut pour les deux URL qui fonctionnent correctement dans la plupart des scénarios de déploiement, y compris les déploiements côte à côte avec les autres applications et services Web.

  • Si vous avez installé la configuration par défaut, les URL ont été créées automatiquement à l'aide des valeurs par défaut.

  • Si vous utilisez l'outil de configuration de Reporting Services pour créer ou modifier les URL, vous pouvez accepter les valeurs par défaut pour une URL ou spécifier des valeurs personnalisées. Un lien de test de l'URL apparaît sur la page lorsque vous définissez l'URL afin que vous puissiez confirmer immédiatement que les paramètres vous avez spécifiés résultent en une connexion valide. Pour les instructions pas à pas sur la configuration et le test d'une URL, consultez Procédure : configurer une URL (configuration de Reporting Services).

Définition d'une URL de serveur de rapports

L'URL identifie précisément l'emplacement d'une instance d'une application du serveur de rapports sur votre réseau. Lorsque vous créez une URL de serveur de rapports, vous devez spécifier les éléments suivants.

Élément | Description
Nom d'hôte | Un réseau TCP/IP utilise une adresse IP pour identifier de manière unique un périphérique sur le réseau. Il existe une adresse IP physique pour chaque carte réseau installée dans un ordinateur. Si l'adresse IP est résolue en en-tête d'hôte, vous pouvez spécifier l'en-tête de l'hôte. Si vous déployez le serveur de rapports sur un réseau d'entreprise, vous pouvez utiliser le nom réseau de l'ordinateur.
Port | Un port TCP est un point de terminaison sur le périphérique. Le serveur de rapports écoute les demandes sur un port désigné.
Répertoire virtuel | Un port est souvent partagé par plusieurs applications ou services Web. Pour cette raison, une URL de serveur de rapports inclut toujours un répertoire virtuel qui correspond à l'application obtenant la demande. Vous devez spécifier des noms de répertoire virtuel uniques pour chaque application Reporting Services qui écoute sur les mêmes port et adresse IP.
Paramètres SSL | Les URL de Reporting Services peuvent être configurées pour utiliser un certificat SSL existant que vous avez installé précédemment sur l'ordinateur. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

URL par défaut

Lorsque vous accédez à un serveur de rapports ou au Gestionnaire de rapports via son URL, celle-ci doit inclure le nom d'hôte et pas l'adresse IP. Sur un réseau TCP/IP, l'adresse IP se résout en un nom d'hôte (ou le nom de réseau de l'ordinateur). Si vous avez utilisé les valeurs par défaut pour configurer les URL, vous devez être en mesure d'accéder au service Web Report Server à l'aide d'URL qui spécifient le nom d'ordinateur ou localhost comme nom d'hôte :

  • http://<nom_ordinateur>/serveur_de_rapports

  • http://hôtelocal/serveurderapports

Les paramètres qui rendent cet URL disponibles apparaissent dans le tableau suivant. Ce tableau montre les valeurs par défaut qui activent une connexion de serveur de rapports via les URL incluant un nom d'hôte :

Élément | Valeur | Explication
Adresse IP | Assigné | Le service DNS (Domain Name Service) de votre réseau résout le nom d'hôte sur l'URL en adresse IP de l'ordinateur. Tant que l'adresse IP est spécifiée dans l'URL que vous définissez, une demande envoyée à un hôte spécifique atteint sa cible.
Port | 80 | Le port 80 est le port par défaut pour les connexions TCP/IP sur un ordinateur. Comme le serveur de rapports écoute sur le port 80, vous pouvez omettre le numéro de port de l'URL. Si vous spécifiez un autre port, vous devez le spécifier dans l'URL.
Répertoire virtuel | ReportServer | Remarquez que les deux exemples d'URL incluent le nom de répertoire virtuel. À moins que vous ne personnalisiez la définition d'URL, vous devez toujours spécifier le nom du répertoire virtuel de l'application dans l'URL.
Remarque :
Une réservation d'URL sous-jacente active tout nom d'hôte valide à utiliser dans une URL. L'outil de configuration de Reporting Services crée une réservation d'URL dans HTTP.SYS à l'aide de la syntaxe qui permet aux variations du nom d'hôte de se résoudre en une instance de serveur de rapports particulière. Pour plus d'informations sur les réservations d'URL, consultez À propos des réservations et de l'inscription d'URL (Reporting Services).

Autorisations côté serveur sur une URL de serveur de rapports

Les autorisations sur chaque point de terminaison d'une URL sont accordées exclusivement au compte de service Report Server. Seul ce compte possède les droits pour accepter les demandes dirigées vers les URL Reporting Services. Les listes de contrôle d'accès discrétionnaire (DACL) sont créées et maintenues pour le compte lorsque vous configurez l'identité de service à travers le programme d'installation ou l'outil de configuration de Reporting Services. Si vous modifiez le compte de service, l'outil de configuration de Reporting Services met à jour toutes les réservations d'URL que vous avez créées pour recueillir les nouvelles informations sur le compte. Pour plus d'informations, consultez Syntaxe de réservation d'URL (Reporting Services).

Authentification des demandes de clients envoyées à une URL de serveur de rapports

Par défaut, le type d'authentification pris en charge sur les points de terminaison d'URL est l'authentification Windows. Il s'agit de l'extension de sécurité par défaut. Si vous implémentez un fournisseur d'authentifications personnalisé ou par formulaire, vous devez modifier les paramètres d'authentification sur le serveur de rapports. Le cas échéant, vous pouvez aussi modifier les paramètres d'authentification Windows afin qu'ils correspondent au sous-système d'authentification utilisé dans votre réseau. Pour plus d'informations, consultez Configuration de l'authentification dans Reporting Services dans la documentation en ligne de SQL Server.

Dans cette section

Procédure : configurer une URL (configuration de Reporting Services)

Cette rubrique fournit des instructions pour définir et modifier une réservation d'URL dans l'outil de configuration de Reporting Services.

À propos des réservations et de l'inscription d'URL (Reporting Services)

Les URL sont utilisées pour accéder aux applications et aux rapports. Cette rubrique explique les URL d'application et les URL par défaut, ainsi que la façon dont l'inscription et les réservations d'URL fonctionnent dans Reporting Services.

Syntaxe de réservation d'URL (Reporting Services)

Les réservations d'URL par défaut que Reporting Services utilise sont valides pour la plupart des scénarios. Toutefois, si vous souhaitez restreindre l'accès ou étendre le déploiement pour activer l'accès Internet ou extranet, il se peut que vous ayez à personnaliser les paramètres pour qu'ils correspondent à vos impératifs. Cette rubrique décrit la syntaxe d'une réservation d'URL et fournit des recommandations pour créer des réservations personnalisées pour votre déploiement.

URL des fichiers de configuration (Reporting Services)

Le fichier RSReportServer.config contient plusieurs entrées pour les réservations d'URL et les URL utilisées par le Gestionnaire de rapports et la remise du courrier électronique du serveur de rapports. Cette rubrique résume les paramètres de configuration d'URL afin que vous puissiez apprendre à les comparer.

Réservations d'URL pour les déploiements de serveur de rapports multi-instance

Lorsque vous installez plusieurs instances de Reporting Services sur un même ordinateur, vous augmentez la probabilité de rencontrer une duplication d'URL lors de l'inscription. Pour éviter ces erreurs, suivez les recommandations de cette rubrique pour créer des réservations d'URL spécifiques à l'instance.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

URL du service Web (configuration de Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


À propos des réservations et de l'inscription d'URL (Reporting Services)

À propos des réservations et de l'inscription d'URL (Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Configuration des URL de Report Server >

Les URL pour les applications Reporting Services sont définies en tant que réservations d'URL dans HTTP.SYS. Une réservation d'URL définit la syntaxe d'un point de terminaison URL à une application Web. Les réservations d'URL sont définies pour le service Web Report Server et pour le Gestionnaire de rapports lorsque vous configurez les applications sur le serveur de rapports. Les réservations d'URL sont créées automatiquement pour vous lors de la configuration d'URL par le biais du programme d'installation ou de l'outil de configuration Reporting Services :

  • Le programme d'installation crée des réservations d'URL à l'aide de valeurs par défaut. Si le programme d'installation installe la configuration par défaut, il réserve deux URL : une pour le service Web Report Server et une autre pour le Gestionnaire de rapports. Vous pouvez utiliser l'outil de configuration Reporting Services pour ajouter davantage d'URL ou modifier les URL par défaut créées par le programme d'installation.

  • L'outil de configuration Reporting Services crée une réservation d'URL basée sur l'URL que vous spécifiez dans les pages URL du service Web ou URL du Gestionnaire de rapports dans l'outil.

Le programme d'installation et l'outil assignent également des autorisations sur l'URL au service Report Server, vérifient s'il existe des instances en double et ajoutent la réservation d'URL à HTTP.SYS. Vous ne devez jamais créer ou modifier une réservation d'URL Reporting Services directement à l'aide de HttpCfg.exe ou d'un autre outil. Si vous ignorez une étape ou si vous avez défini une valeur non valide, vous rencontrerez des problèmes qui pourront être difficiles à diagnostiquer ou à résoudre.

Remarque :
HTTP.SYS est un composant du système d'exploitation qui écoute les demandes réseau et les transfère vers une file d'attente de demandes. Dans cette version de Reporting Services, HTTP.SYS établit et maintient la file d'attente de demandes pour le service Web Report Server et le Gestionnaire de rapports. Les services Internet (IIS) ne sont plus utilisés pour héberger ou accéder aux applications Reporting Services. Pour plus d'informations sur la fonctionnalité HTTP.SYS, consultez HTTP Server API sur MSDN.

Dans cette rubrique

Cette rubrique présente les URL, les réservations et l'inscription d'URL, les valeurs par défaut et des recommandations spécifiques au déploiement que vous devez suivre si vous créez ou modifiez des URL pour différentes configurations de serveur. Elle contient les sections suivantes :

  • URL dans Reporting Services

  • Réservation et inscription d'URL

  • URL par défaut

  • Authentification et identité de service pour les URL Reporting Services

  • URL pour l'administration locale

  • URL pour le déploiement avec montée en puissance parallèle

  • URL pour le mode intégré SharePoint

Pour plus d'informations sur la construction et l'utilisation des URL dans une installation Reporting Services ou sur la résolution des problèmes liés à la réservation ou à l'inscription, consultez Configuration des URL de Report Server et Dépannage de problèmes de configuration dans la documentation en ligne de SQL Server.

URL dans Reporting Services

Dans une installation Reporting Services, vous pouvez accéder aux outils, applications et éléments suivants par le biais d'URL :

  • Service Web Report Server

  • Gestionnaire de rapports

  • Générateur de rapports

  • Rapports ayant été publiés sur un serveur de rapports

Les autres éléments publiés adressables par URL, tels que les modèles et sources de données partagées, ne doivent pas être accédés par le biais d'URL en tant qu'éléments autonomes. Le serveur de rapports n'affiche pas ces éléments dans un format explicite lorsqu'ils sont affichés dans une fenêtre de navigateur.

Remarque :
Cette rubrique ne décrit pas l'accès par le biais d'URL au Générateur de rapports ou à des rapports spécifiques stockés sur le serveur de rapports. Pour plus d'informations sur l'accès à ces éléments de rapport par le biais d'une URL, consultez Utilisation d'une URL pour accéder à des éléments de serveur de rapports dans la documentation en ligne de SQL Server.

Réservation et inscription d'URL

Une réservation d'URL définit les URL qui peuvent être utilisées pour accéder à une application Reporting Services. Reporting Services réservera une ou plusieurs URL pour le service Web Report Server et le Gestionnaire de rapports dans HTTP.SYS, puis les inscrira lors du démarrage du service. Les URL du Générateur de rapport et des rapports sont basés sur la réservation d'URL du service Web Report Server. En ajoutant des paramètres à l'URL, vous pouvez ouvrir le Générateur de rapport ou des rapports par le biais du service Web. Les réservations et l'inscription sont fournies par HTTP.SYS. Pour plus d'informations, consultez Namespace Reservations, Registration, and Routing sur MSDN.

La réservation d'URL est un processus par lequel un point de terminaison URL à une application Web est créé et stocké dans HTTP.SYS. HTTP.SYS est la base de données de référentiel commune de toutes les réservations d'URL qui sont définies sur un ordinateur ; elle définit un jeu de règles communes qui garantissent des réservations d'URL uniques.

L'inscription d'URL se produit lorsque le service démarre. La file d'attente des demandes est créée et HTTP.SYS commence à transférer les demandes vers cette file d'attente. Un point de terminaison URL doit être inscrit pour que les demandes dirigées vers ce point de terminaison soient ajoutées à la file d'attente. Lorsque le service Report Server démarre, il enregistre toutes les URL qu'il a réservées pour toutes les applications actives. Cela signifie que le service Web doit être activé pour que l'inscription ait lieu. Si vous affectez à la propriété WebServiceAndHTTPAccessEnabled la valeur False dans la facette Configuration de la surface d'exposition pour Reporting Services de la gestion basée sur une stratégie, l'URL du service Web n'est pas inscrite au démarrage du service.

Les inscriptions des URL sont annulées si vous arrêtez le service ou si vous recyclez le service Web ou le domaine d'application du Gestionnaire de rapports. Si vous modifiez une réservation d'URL pendant que le service s'exécute, le serveur de rapports recycle immédiatement le domaine d'application afin que l'ancienne URL puisse être désinscrite et que la nouvelle puisse être utilisée.

Quelques exemples simples illustrent le concept de réservation d'URL et sa relation avec les adresses URL utilisées pour les applications Reporting Services. Un point clé à noter est que la réservation d'URL a une syntaxe différente de l'URL que vous utilisez pour accéder à l'application :

Réservation d'URL dans HTTP.SYS URL Explication

http://+:80/reportserver

http://<nom_ordinateur>/reportserver

http://<adresse_IP>/reportserver

http://localhost/reportserver

La réservation d'URL spécifie un caractère générique (+) sur le port 80. Cela met dans la file d'attente de serveur de rapports toute requête entrante qui spécifie un hôte résolu sur le serveur de rapports sur le port 80. Remarquez qu'avec cette réservation d'URL, une quantité quelconque d'URL peut être utilisée pour accéder au serveur de rapports.

Il s'agit de la réservation d'URL par défaut pour un serveur de rapports Reporting Services pour la plupart des systèmes d'exploitation.

http://123.45.67.0:80/reportserver

http://123.45.67.0/reportserver

Cette réservation d'URL spécifie une adresse IP ; elle est beaucoup plus restrictive que la réservation d'URL générique. Seules les URL qui incluent l'adresse IP peuvent être utilisées pour se connecter au serveur de rapports. Étant donné cette réservation d'URL, une demande à un serveur de rapports à http://<nom_ordinateur>/reportserver ou http://localhost/reportserver échouerait.

URL par défaut

Si vous installez Reporting Services dans la configuration par défaut, le programme d'installation réserve des URL pour le service Web Report Server et pour le Gestionnaire de rapports. Vous pouvez également accepter ces valeurs par défaut lorsque vous définissez des réservations d'URL dans l'outil de configuration Reporting Services. Les URL par défaut incluront un nom d'instance si vous installez SQL Server Express ou si vous installez Reporting Services en tant qu'instance nommée.

Important :
Le caractère d'instance est un trait de soulignement (_).

Les réservations d'URL incluent un numéro de port. Les systèmes d'exploitation suivants permettent à plusieurs applications Web de partager un port : Windows Server 2003, Windows Vista et Windows Server 2008. Si vous utilisez Windows XP, assurez-vous d'utiliser des ports uniques.

Type d'instance | Application | URL par défaut | Réservation d'URL réelle dans HTTP.SYS
Instance par défaut | Service Web Report Server | http://<nom_serveur>/reportserver | http://<nom_serveur>:80/reportserver
Instance par défaut | Gestionnaire de rapports | http://<nom_serveur>/reportserver | http://<nom_serveur>:80/reportserver
Instance nommée | Service Web Report Server | http://<nom_serveur>/reportserver_<nom_instance> | http://<nom_serveur>:80/reportserver_<nom_instance>
Instance nommée | Gestionnaire de rapports | http://<nom_serveur>/reports_<nom_instance> | http://<nom_serveur>:80/reports_<nom_instance>
SQL Server Express | Service Web Report Server | http://<nom_serveur>/reportserver_SQLExpress | http://<nom_serveur>:80/reportserver_SQLExpress
SQL Server Express | Gestionnaire de rapports | http://<nom_serveur>/reports_SQLExpress | http://<nom_serveur>:80/reports_SQLExpress

Authentification et identité de service pour les URL Reporting Services

Les réservations d'URL Reporting Services spécifient le compte de service du service Report Server. Le compte sous lequel le service s'exécute est utilisé pour toutes les URL créées pour les applications Reporting Services qui s'exécutent dans la même instance. L'identité de service de l'instance de serveur de rapports est stockée dans le fichier RSReportServer.config.

Le compte de service n'a aucune valeur par défaut. Toutefois, la spécification d'un compte de service est requise pendant l'installation et est spécifiée dans URLReservation dans RSReportServer.config même si vous installez le serveur en mode fichiers uniquement. Les valeurs valides pour le compte de service incluent un compte d'utilisateur de domaine, LocalSystem ou NetworkService.

L'accès anonyme est désactivé car la sécurité par défaut est RSWindowsNegotiate. Pour l'accès intranet, les URL de serveur de rapports utilisent des noms d'ordinateurs réseau. Si vous souhaitez configurer Reporting Services pour des connexions Internet, vous devez utiliser des paramètres différents. Pour plus d'informations, consultez Planification d'un déploiement extranet ou Internet dans la documentation en ligne de SQL Server. Pour plus d'informations sur l'authentification, consultez Configuration de l'authentification dans Reporting Services dans la documentation en ligne de SQL Server.

URL pour l'administration locale

Vous pouvez utiliser http://localhost/reportserver ou http://localhost/reports si vous avez spécifié un caractère générique fort ou faible pour la réservation d'URL.

L'URL http://localhost est interprétée comme http://127.0.0.1. Si vous avez lié la réservation d'URL à un nom d'ordinateur ou une adresse IP unique, vous ne pouvez pas utiliser localhost, à moins de créer une réservation supplémentaire pour 127.0.0.1 sur l'ordinateur local. De même, si localhost ou 127.0.0.1 est désactivé sur votre ordinateur, vous ne pouvez pas utiliser cette URL.

Windows Vista et Windows Server "Longhorn" incluent de nouvelles fonctionnalités de sécurité destinées à réduire le risque d'exécution accidentelle de programmes avec des privilèges élevés. Des étapes supplémentaires sont nécessaires pour activer l'administration locale sur ces systèmes d'exploitation. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

URL pour le déploiement avec montée en puissance parallèle

Informations pour cette section non disponibles dans cette version.

URL pour un serveur de rapports en mode intégré SharePoint

Si un serveur de rapports autonome est configuré pour s'exécuter au sein d'un déploiement plus vaste d'un produit ou d'une technologie SharePoint, la construction d'URL et de répertoires virtuels sera affectée de plusieurs manières :

  • Les URL pour les rapports et autres éléments sont adressées par le biais de l'URL d'application Web SharePoint. Pour l'accès URL à des rapports spécifiques, utilisez toujours une URL complète qui inclut le chemin d'accès au site, la bibliothèque de documents, le nom de l'article et une extension de nom de fichier (telle que .rdl pour un rapport). Vous devez spécifier des URL complètes lorsque vous faites référence à des sources de données partagées et à des modèles dans des rapports, et lorsque vous spécifiez un serveur et des dossiers cibles pour des opérations de publication sur un serveur de rapports.

  • L'extension de nom de fichier est utilisée pour distinguer entre différents types d'éléments de serveur de rapports. Les extensions valides incluent .rdl pour les définitions de rapport, .smdl pour les modèles d'état et .rsds pour les sources de données partagées créées pour un site SharePoint.

  • Bien que les produits et technologies SharePoint aient des réservations d'URL définies, vous pouvez ignorer la réservation lors de la publication sur le serveur. Pour les applications Web SharePoint, la réservation d'URL est une opération interne.

  • Pour les déploiements de serveur unique dans lesquels un serveur de rapports et une instance de technologie SharePoint intégrés sont installés sur le même ordinateur, vous ne pouvez pas utiliser http://localhost/reportserver. Si http://localhost est utilisé pour accéder à l'application Web SharePoint, vous devez utiliser un site Web différent du site par défaut ou une affectation de port unique pour accéder à un serveur de rapports. En outre, si le serveur de rapports est intégré à une batterie de serveurs SharePoint, l'accès localhost à un serveur de rapports n'est pas résolu pour les nœuds du déploiement installés sur des ordinateurs distants.

  • La réservation d'URL et le point de terminaison pour le Gestionnaire de rapports ne peuvent pas être configurés pour un serveur de rapports qui s'exécute en mode intégré SharePoint. Si vous les configurez, le gestionnaire ne fonctionnera plus après le déploiement d'un serveur de rapports en mode intégré SharePoint. Le Gestionnaire de rapports n'est pas pris en charge dans ce mode.

Si vous avez intégré un déploiement de serveur de rapports avec montée en puissance parallèle pour s'exécuter au sein d'un déploiement plus vaste d'un produit ou d'une technologie SharePoint, vous devez équilibrer la charge des nœuds du serveur de rapports et définir une URL de serveur virtuel unique pour le déploiement avec montée en puissance parallèle. Les paramètres d'intégration Report Server vous permettent uniquement de spécifier une URL de serveur de rapports unique. Dans le cas d'un déploiement avec montée en puissance parallèle, l'URL doit être le point d'accès pour les nœuds de serveur dans le déploiement avec montée en puissance parallèle.

Pour plus d'informations sur les modes de déploiement et les conditions requises en matière d'URL pour publier des éléments, consultez Planification d'un mode de déploiement et Déploiement de modèles et de sources de données partagées sur un site SharePoint dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Syntaxe de réservation d'URL (Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Syntaxe de réservation d'URL (Reporting Services)

Syntaxe de réservation d'URL (Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Configuration des URL de Report Server >

Cette rubrique décrit les parties de la chaîne d'URL du service Web Report Server et du Gestionnaire de rapports. La chaîne d'URL stockée en interne possède une structure différente de celle d'une URL saisie dans la barre d'adresses d'une fenêtre de navigateur. La chaîne de réservation d'URL apparaît dans la fenêtre Résultats de l'outil de configuration de Reporting Services lorsque vous configurez une URL et dans le fichier RSReportServer.config. Il peut être utile de savoir comment la chaîne d'URL est définie si vous dépannez les problèmes de réservation d'URL ou interrogez HTTP.SYS pour afficher les réservations d'URL internes définies sur votre serveur.

Syntaxe d'URL

Une URL de serveur de rapports est stockée dans l'élément UrlString et l'élément VirtualDirectory. La raison de la séparation d'UrlString et de VirtualDirectory en éléments séparés est que vous pouvez avoir plusieurs chaînes d'URL, mais un seul nom de répertoire virtuel pour chaque application Reporting Services.

Dans HTTP.SYS, la réservation d'URL inclut les deux éléments UrlString et VirtualDirectory. La syntaxe d'une réservation d'URL comporte les parties suivantes :

<scheme>://<hostname>:<port>/<virtualdirectory>

Le tableau suivant décrit chaque propriété et les valeurs valides pour chacune d'elles.

Propriété Valeurs valides Description

Scheme

http ou https

Préfixes pour connexions SSL et connexions autres que SSL.

HostName

Caractère générique (+) fort, égal à la valeur (Assigné) pour l'adresse IP.

Caractère générique (*) faible, égal à la valeur (Non assigné) de l'adresse IP.

Nom de domaine complet

Nom de l'ordinateur

Adresse IP (IPV4)

Adresse IP (IPV6)

Identifie le serveur sur le réseau.

Le caractère générique fort (+) est la valeur par défaut. HTTP.SYS accepte toutes les demandes sur toutes les cartes réseau pour la combinaison d'un port donné et d'un répertoire virtuel. Le serveur de rapports accepte toute demande sur le port.

Caractère générique (*) faible. HTTP.SYS accepte toutes les demandes non gérées par les autres réservations d'URL sur toutes les cartes réseau pour la combinaison d'un port donné et d'un répertoire virtuel.

Le nom de l'ordinateur est le nom NETBIOS de l'ordinateur sur le réseau.

Le nom de domaine complet inclut l'adresse du domaine et le nom du serveur, tels qu'ils sont inscrits auprès d'un contrôleur de domaine ou d'un serveur de noms de domaine public.

L'adresse IP (IPV4) est l'adresse IP d'une carte réseau sur l'ordinateur au format IPV4 : nnn.nnn.nnn.nnn.

L'adresse IP (IPV6) est l'adresse IP d'une carte réseau sur l'ordinateur au format IPV6 : <en-tête>:<en-tête>:nnn.nnn.nnn.nnn.

Port

80

443

<personnalisés>

Le port 80 est le port standard pour les requêtes HTTP adressées depuis ou vers un serveur.

Le port 443 est le port standard pour les connexions SSL.

Vous pouvez utiliser n'importe quel port qui n'est pas déjà réservé par une autre application.

VirtualDirectory

ReportServer[_InstanceName]

Reports[_InstanceName]

<personnalisés>

Spécifie le nom de l'application. La valeur est une chaîne. Par défaut, Reporting Services utilise ReportServer et Reports comme noms d'applications pour les applications service Web Report Server et Gestionnaire de rapports. Vous pouvez utiliser d'autres noms, si vous le souhaitez.

Cette valeur est obligatoire. Elle identifie la publication.

Spécifiez un seul répertoire virtuel pour chaque instance d'application. Pour créer plusieurs URL pour la même application dans la même instance, créez plusieurs versions de l'élément UrlString. Pour créer des noms de répertoire virtuel uniques pour plusieurs instances d'application, pensez à ajouter le nom de l'instance dans le nom de répertoire virtuel à l'aide du trait de soulignement (_). La propriété InstanceName est facultative, mais recommandée si vous avez plusieurs instances sur le même ordinateur. Pour plus d'informations sur la définition des réservations d'URL pour les instances nommées, consultez Réservations d'URL pour les déploiements de serveur de rapports multi-instance.

La valeur du répertoire virtuel ne respecte pas la casse. Vous pouvez utiliser n'importe quelle chaîne tant qu'elle n'inclut pas les caractères de séparation d'URL ou l'encodage d'URL.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


URL des fichiers de configuration (Reporting Services)

URL des fichiers de configuration (Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Configuration des URL de Report Server >

Reporting Services stocke les paramètres d'application dans un fichier RSReportServer.config. Ce fichier contient des paramètres de configuration pour les URL et pour les réservations d'URL. Ces paramètres de configuration ont des règles de modification et des objectifs très différents. Si vous êtes habitué à la modification de fichiers de configuration pour régler un déploiement, cette rubrique peut vous aider à comprendre comment chaque paramètre URL est utilisé.

Paramètres d'URL du fichier RSReportServer.config

Reporting Services stocke les URL pour l'accès aux applications et aux rapports, et pour connecter les composants Web frontaux à un serveur de rapports principal.

URL d'accès aux applications

Les URL permettent d'accéder au service Web Report Server et au Gestionnaire de rapports. Pour configurer les URL, vous devez utiliser l'outil de configuration de Reporting Services. L'outil crée les réservations d'URL pour chaque application dans HTTP.SYS et ajoute des entrées pour les URL dans la section URLReservations de RSReportServer.config.

  • Pour consulter les descriptions de chaque élément dans la section URLReservations, consultez Fichier de configuration RSReportServer dans la documentation en ligne de SQL Server.

  • Pour plus d'informations sur la seule syntaxe de UrlString, consultez Syntaxe de réservation d'URL (Reporting Services).

  • Pour les instructions sur la configuration des URL pour l'accès aux applications, consultez Procédure : configurer une URL (configuration de Reporting Services).

URL d'accès aux rapports

Reporting Services inclut une extension de remise par messagerie de serveur de rapports que vous pouvez utiliser pour envoyer les liens de rapport ou les pièces jointes. Un lien de rapport est construit lorsque le rapport est remis. L'extension de remise par messagerie de serveur de rapports utilise le paramètre UrlRoot du fichier de configuration pour créer le lien. UrlRoot est également utilisé pour résoudre les liens d'un rapport rendu et généré via un traitement des rapports sans assistance.

UrlRoot est spécifié automatiquement dans le fichier RSReportServer.config lorsque vous configurez les URL pour l'accès aux applications. Si vous modifiez cette valeur dans le fichier de configuration, vous devez spécifier l'adresse URL valide d'un service Web Report Server connecté à une base de données de serveur de rapports qui contient les rapports que vous souhaitez remettre. Vous pouvez spécifier un seul élément UrlRoot pour une instance de serveur de rapports unique ; une seule entrée UrlRoot peut exister dans le fichier RSReportServer.config pour toute instance de serveur de rapports donnée. Si vous avez plusieurs URL réservées pour le service Web Report Server, vous devez choisir l'une des valeurs disponibles pour UrlRoot.

Dans la plupart des cas, vous n'avez pas besoin de modifier UrlRoot. Toutefois, si le serveur de rapports est accessible via une URL complète et que vous n'avez pas configuré une URL qui utilise l'en-tête de l'hôte sur le nom de site complet, vous devez modifier le fichier RSReportServer.config manuellement pour définir UrlRoot avec l'URL complète du serveur de rapports qui sera utilisée pour restituer le rapport (par exemple, https://www.adventure-works.com/mywebapp/reportserver).

URL connectant le Gestionnaire de rapports et les composants WebPart au service Web Report Server

Le Gestionnaire de rapports et les composants WebPart SharePoint 2.0 pour Reporting Services sont les composants Web frontaux qui se connectent à un serveur de rapports. Les URL utilisées pour se connecter à un serveur de rapports principal sont les suivantes :

  • ReportServerUrl (élément utilisé par le Gestionnaire de rapports)

  • ReportServerExternalUrl (élément utilisé par les composants WebPart)

Remarque :
Les versions antérieures de Reporting Services incluaient l'élément ReportServerVirtualDirectory. Cette valeur est obsolète dans SQL Server 2008. Si vous avez mis à niveau une installation existante et utilisez un fichier de configuration qui contient ce paramètre, le serveur de rapports ne lit plus cette valeur.

Le tableau suivant récapitule toutes les URL pouvant être spécifiées dans un fichier de configuration de Reporting Services.

Paramètre Utilisation Description

ReportServerUrl

Facultatif. Cet élément n'est pas inclus dans le fichier RSReportServer.config à moins que vous ne l'ajoutiez vous-même.

Définissez cet élément uniquement si vous configurez l'un des scénarios suivants :

  • Le Gestionnaire de rapports fournit un accès Web frontal à un service Web Report Server qui s'exécute sur un autre ordinateur ou sur une instance différente du même ordinateur.

  • Lorsque vous avez plusieurs URL vers un serveur de rapports et que vous souhaitez que le Gestionnaire de rapports utilise une URL spécifique.

  • Vous avez une URL du serveur de rapports spécifique que vous souhaitez voir utilisée par toutes les connexions du Gestionnaire de rapports.

    Par exemple, vous pouvez activer l'accès du Gestionnaire de rapports pour tous les ordinateurs du réseau, tout en requérant que le Gestionnaire de rapports se connecte au serveur de rapports à travers une connexion locale. Dans ce cas, vous pouvez configurer ReportServerUrl avec la valeur « http://localhost/reportserver ».

Pour obtenir des instructions sur l'implémentation de ces scénarios, consultez Procédure : configurer le Gestionnaire de rapports dans la documentation en ligne de SQL Server.

Cette valeur spécifie l'URL du service Web Report Server. Cette valeur est lue par l'application du Gestionnaire de rapports au démarrage. Si cette valeur est définie, le Gestionnaire de rapports se connecte au serveur de rapports spécifié dans l'URL.

Par défaut, le Gestionnaire de rapports fournit un accès Web frontal à un service Web Report Server qui s'exécute au sein de la même instance du serveur de rapports que le Gestionnaire de rapports. Toutefois, si vous souhaitez utiliser le Gestionnaire de rapports avec un service Web Report Server qui fait partie d'une autre instance ou s'exécute dans une instance d'un autre ordinateur, vous pouvez définir cette URL de façon à diriger le Gestionnaire de rapports pour qu'il se connecte au service Web Report Server externe.

Si un certificat SSL (Secure Sockets Layer) est installé sur le serveur de rapports auquel vous êtes connecté, la valeur de l'élément ReportServerUrl doit être le nom du serveur inscrit pour ce certificat. Si l'erreur « La connexion sous-jacente a été fermée. Impossible d'établir une relation de confiance pour le canal sécurisé SSL/TLS » s'affiche, définissez l'élément ReportServerUrl avec le nom de domaine complet du serveur pour lequel le certificat SSL a été émis. Par exemple, si le certificat est inscrit sur https://adventure-works.com.ventesenligne, l'URL du serveur de rapports sera https://adventure-works.com.ventesenligne/serveurderapports.

ReportServerExternalUrl

Facultatif. Cet élément n'est pas inclus dans le fichier RSReportServer.config à moins que vous ne l'ajoutiez vous-même.

Définissez cet élément uniquement si vous utilisez les composants WebPart de SharePoint 2.0 et que vous souhaitez que les utilisateurs soient en mesure d'extraire un rapport et de l'ouvrir dans une nouvelle fenêtre de navigateur.

Ajoutez l'élément <ReportServerExternalUrl> sous l'élément <ReportServerUrl>, puis définissez-le avec un nom de serveur de rapports complet qui se résout en une instance de serveur de rapports en cas d'accès dans une fenêtre de navigateur distincte. Ne supprimez pas <ReportServerUrl>.

L'exemple suivant illustre la syntaxe :

<ReportServerExternalUrl>http://myserver/reportserver</ReportServerExternalUrl>

Cette valeur est utilisée par les composants WebPart de SharePoint 2.0.

Dans les versions précédentes, il était recommandé que vous définissiez cette valeur pour déployer le Générateur de rapport sur un serveur de rapports Internet. Il s'agit d'un scénario de déploiement non testé. Si vous utilisiez ce paramètre par le passé pour gérer l'accès Internet au Générateur de rapports, vous devez prévoir une autre stratégie.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Réservations d'URL pour les déploiements de serveur de rapports multi-instance

Réservations d'URL pour les déploiements de serveur de rapports multi-instance |
 | Voir aussi
Configuration de Reporting Services > Configuration des URL de Report Server >

Si vous installez plusieurs instances de Reporting Services sur le même ordinateur, vous devez considérer comment vous définirez les réservations d'URL pour chaque instance. Dans chaque instance, le service Web Report Server et le Gestionnaire de rapports doivent avoir au moins une réservation d'URL chacun. L'ensemble entier de réservations doit être unique dans HTTP.SYS.

Les URL en double sont détectées pendant l'inscription d'URL, qui se produit lorsque le service démarre. Si vous créez des réservations d'URL qui ne sont pas uniques, le conflit de nom peut ne pas être détecté avant le démarrage du service. Pour cette raison, assurez-vous de suivre les conventions ou les règles d'affectation de noms afin de vous assurer que toutes les valeurs sont uniques.

Conventions d'affectation de noms par défaut

Reporting Services peut être installé dans une instance nommée SQL Server. Lorsque vous installez ou configurez un serveur de rapports dans une instance nommée, le nom de l'instance est inclus automatiquement dans le répertoire virtuel dans la réservation d'URL par défaut que Reporting Services fournit. Le tableau suivant indique les réservations d'URL pour une instance par défaut et une instance nommée.

Instance SQL Server | Réservation d'URL par défaut
Par défaut (MSSQLSERVER) | http://+:80/reportserver
Nommée (MynamedInstance) | http://+:80/reportserver_MyNamedInstance

Pour l'instance nommée, le répertoire virtuel inclut le nom de l'instance. L'instance par défaut et l'instance nommée écoutent sur le même port, mais les noms de répertoires virtuels uniques déterminent quel serveur de rapports obtient la demande.

Il est recommandé d'utiliser le nom de répertoire virtuel afin de distinguer parmi l'instance de serveur de rapports. Il fournit une correspondance claire entre une URL et l'instance cible et garantit que les noms d'applications sont uniques dans tout le système.

Conventions d'affectation de noms personnalisées

Bien que l'utilisation du nom de l'instance soit recommandée, vous pouvez utiliser la syntaxe d'URL et vos propres conventions d'affectation de noms afin de satisfaire les contraintes de nom uniques pour les réservations d'URL. Les exemples suivants illustrent différentes approches permettant de créer des URL uniques pour chaque instance.

Instance par défaut du serveur de rapports (MSSQLSERVER) | ReportServer_MyNamedInstance | Unicité
http://+:80/reportserver | http://+:8888/reportserver | Chaque instance écoute sur un port différent.
http://www.contoso.com/reportserver | http://SRVR-46/reportserver | Chaque instance répond à différents noms de serveurs (nom de domaine complet et nom d'ordinateur).

Spécifications relatives à l'unicité

Les technologies sous-jacentes utilisées par Reporting Services imposent des spécifications relatives aux noms uniques. HTTP.SYS requiert que toutes les URL dans sa base de données de référentiel soient uniques. Vous pouvez varier le port, le nom d'hôte ou le nom de répertoire virtuel pour créer une URL unique. ASP.NET requiert que les identités d'application soient uniques dans le même processus. Cette spécification affecte les noms de répertoires virtuels. Elle spécifie que vous ne pouvez pas dupliquer de nom de répertoire virtuel dans la même instance de serveur de rapports.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Création d'une base de données de serveur de rapports

Création d'une base de données de serveur de rapports |
 | Voir aussi
Configuration de Reporting Services >

Remarque :
Pour SQL Server 2008 R2, il n'y a pas eu de modifications au contenu répertorié dans cette rubrique.

Reporting Services utilise deux bases de données relationnelles SQL Server pour le stockage des objets et des métadonnées du serveur de rapports. Une base de données est utilisée pour le stockage principal et l'autre pour le stockage des données temporaires. Les bases de données sont créées ensemble et liées par le nom. Avec une instance par défaut de SQL Server, les bases de données sont nommées reportserver et reportservertempdb. Les deux bases de données sont collectivement appelées « base de données de serveur de rapports » ou « catalogue du serveur de rapports ».

Important :
N'écrivez pas d'applications qui exécutent des requêtes sur la base de données du serveur de rapports. La base de données du serveur de rapports n'est pas un schéma public. La structure des tables peut changer d'une version à la suivante. Si vous écrivez une application qui nécessite un accès à la base de données du serveur de rapports, utilisez toujours les API Reporting Services pour accéder à la base de données du serveur de rapports.

Méthodes pour créer la base de données de serveur de rapports

Vous pouvez créer la base de données du serveur de rapports des manières suivantes :

  • Automatiquement par le biais du programme d'installation, si vous choisissez l'option d'installation de la configuration par défaut. Dans l'Assistant Installation de Microsoft SQL Server, il s'agit de l'option Installer la configuration par défaut en mode Natif ou Installer la configuration par défaut en mode intégré SharePoint de la page Options d'installation du serveur de rapports. Si vous avez choisi l'option Installer mais ne pas configurer le serveur, vous devez utiliser l'outil de configuration de Reporting Services pour créer la base de données.

  • Manuellement, par le biais de l'outil de configuration de Reporting Services. Vous devez créer la base de données du serveur de rapports manuellement si vous utilisez un moteur de base de données SQL Server distant pour héberger la base de données. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Conditions requises pour une version du serveur de bases de données

SQL Server est utilisé pour héberger les bases de données du serveur de rapports :

  • SQL Server 2005 ou SQL Server 2008 peut être utilisé pour héberger les bases de données. N'utilisez pas SQL Server 2000 ou versions antérieures de SQL Server.

  • L'instance du moteur de base de données SQL Server peut être soit locale, soit distante.

Pour créer la base de données du serveur de rapports sur un ordinateur distant, vous devez configurer la connexion de manière à employer un compte d'utilisateur de domaine ou un compte de service pouvant accéder au réseau. Si vous décidez d'utiliser une instance SQL Server distante, réfléchissez avec soin aux informations d'identification que le serveur de rapports devra utiliser pour se connecter à l'instance SQL Server. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

Important :
Le serveur de rapports et l'instance SQL Server hébergeant la base de données du serveur de rapports peuvent appartenir à des domaines différents. Dans le cadre d'un déploiement Internet, il est courant d'utiliser un serveur situé derrière un pare-feu. Si vous configurez un serveur de rapports de manière à accéder à Internet, utilisez les informations d'identification SQL Server pour vous connecter à l'instance de SQL Server située derrière le pare-feu et recourez à IPSEC pour sécuriser la connexion.

Conditions requises pour une édition du serveur de bases de données

Lors de la création d'une base de données de serveur de rapports, soyez conscient que certaines éditions de SQL Server ne peuvent pas être utilisées pour héberger la base de données. Le tableau suivant répertorie les éditions du moteur de base de données que vous pouvez utiliser pour les éditions spécifiques de Reporting Services.

Pour cette édition de SQL Server Reporting Services | Utilisez cette édition de l'instance du moteur de base de données pour héberger la base de données
SQL Server Express with Advanced Services | SQL Server Express with Advanced Services (local uniquement).
Web | Web Edition (locale uniquement)
Workgroup | Workgroup Edition (locale uniquement)
Evaluation | Evaluation
Developer | Éditions Standard, Developer, Enterprise (locales ou distantes)
Standard | Éditions Standard, Enterprise (locales ou distantes)
Enterprise | Éditions Standard, Enterprise (locales ou distantes)

Voir aussi

Concepts

Configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration d'une connexion de base de données de serveur de rapports

Configuration d'une connexion de base de données de serveur de rapports |
 | Voir aussi
Configuration de Reporting Services >

Chaque instance de serveur de rapports requiert une connexion à la base de données de serveur de rapports qui stocke les rapports, les modèles de rapport, les sources de données partagées, les ressources et les métadonnées gérées par le serveur. La connexion initiale peut être créée lors de l'installation d'un serveur de rapports si vous installez la configuration par défaut. Dans la plupart des cas, vous utilisez l'outil de configuration de Reporting Services pour configurer la connexion une fois l'installation terminée. Vous pouvez modifier la connexion à tout moment afin de changer de type de compte ou de redéfinir les informations d'identification. Pour les instructions pas à pas sur la création de la base de données et la configuration de la connexion, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Vous devez configurer une connexion à la base de données du serveur de rapports dans les circonstances suivantes :

  • Configuration d'un serveur de rapports pour une première utilisation

  • Configuration d'un serveur de rapports de manière à utiliser une base de données de serveur de rapports différente

  • Modification du compte ou du mot de passe de l'utilisateur permettant d'établir la connexion à la base de données. Vous devez uniquement mettre à jour la connexion de base de données lorsque les informations du compte sont stockées dans le fichier RSReportServer.config. Si vous utilisez le compte de service pour la connexion (qui utilise la sécurité intégrée de Windows comme type d'informations d'identification), le mot de passe n'est pas stocké, ce qui évite de mettre à jour les informations de connexion. Pour plus d'informations sur la modification des comptes, consultez Configuration du compte de service Report Server.

  • Configuration d'un déploiement avec montée en puissance parallèle de serveurs de rapports La configuration d'un déploiement avec montée en puissance parallèle nécessite la création de plusieurs connexions à une base de données de serveur de rapports. Pour plus d'informations sur cette opération en plusieurs étapes, consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services).

Comment Reporting Services se connecte au moteur de base de données

L'accès du serveur de rapports à une base de données de serveur de rapports dépend des informations d'identification et de connexion, ainsi que de la validité des clés de chiffrement de l'instance de serveur de rapports qui utilise cette base de données. Il est nécessaire de recourir à des clés de chiffrement valides pour stocker et extraire des données sensibles. Des clés de chiffrement sont créées automatiquement lors de la première configuration de la base de données. Une fois les clés créées, vous devez les mettre à jour si vous changez l'identité du service Report Server. Pour plus d'informations sur l'utilisation des clés de chiffrement, consultez Configuration et gestion des clés de chiffrement.

La base de données du serveur de rapports est un composant interne, accessible uniquement par le serveur de rapports. Les informations d'identification et de connexion que vous spécifiez pour la base de données du serveur de rapports sont utilisées exclusivement par le serveur de rapports. Les utilisateurs qui demandent des rapports n'ont pas besoin d'autorisations de base de données ou d'une connexion de base de données pour la base de données du serveur de rapports.

Reporting Services utilise System.Data.SqlClient pour se connecter au moteur de base de données qui héberge la base de données de serveur de rapports. Si vous utilisez une instance locale du moteur de base de données, le serveur de rapports établit la connexion à l'aide de la mémoire partagée. Si vous utilisez un serveur de base de données distant pour la base de données du serveur de rapports, il se peut que vous ayez à activer les connexions distantes selon l'édition que vous utilisez. Si vous utilisez l'édition Developer, les connexions distantes sont désactivées par défaut. Si vous utilisez l'édition Enterprise, les connexions distantes sont activées par défaut pour TCP/IP.

Pour vérifier que l'instance accepte les connexions à distance, cliquez successivement sur Démarrer, Tous les programmes, Microsoft SQL Server 2008 R2, Outils de configuration, Gestionnaire de configuration SQL Server, puis vérifiez que le protocole TCP/IP est activé pour chaque service.

Lorsque vous activez les connexions à distance, les protocoles client et serveur sont également activés. Pour vérifier que les protocoles sont activés, cliquez successivement sur Démarrer, Tous les programmes, Microsoft SQL Server 2008 R2, Outils de configuration, Gestionnaire de configuration SQL Server, Configuration du réseau SQL Server, puis cliquez sur Protocoles pour MSSQLSERVER. Pour plus d'informations, consultez Procédure : activer ou désactiver un protocole réseau de serveur (Gestionnaire de configuration SQL Server) dans la documentation en ligne de SQL Server.

Définition d'une connexion de base de données de serveur de rapports

Pour configurer la connexion, vous devez utiliser le Gestionnaire de configuration de Reporting Services ou l'utilitaire de ligne de commande rsconfig. Un serveur de rapports requiert les informations de connexion suivantes :

  • Nom de l'instance du moteur de base de données hébergeant la base de données du serveur de rapports.

  • Nom de la base de données du serveur de rapports. Lorsque vous créez une connexion pour la première fois, vous pouvez créer une nouvelle base de données de serveur de rapports ou sélectionner une base de données existante. Pour plus d'informations, consultez Création d'une base de données de serveur de rapports.

  • Type d'informations d'identification. Vous pouvez utiliser les comptes de service, un compte de domaine Windows ou une connexion de base de données SQL Server.

  • Nom d'utilisateur et mot de passe (requis seulement si vous utilisez un compte de domaine Windows ou une connexion SQL Server).

Les informations d'identification que vous fournissez doivent disposer de l'accès à la base de données du serveur de rapports. Si vous utilisez l'outil de configuration de Reporting Services, cette opération est effectuée automatiquement. Pour plus d'informations sur les autorisations requises pour accéder à la base de données, consultez la section « Autorisations de base de données » dans cette rubrique.

Stockage des informations de connexion à la base de données

Reporting Services stocke et chiffre les informations de connexion dans les paramètres RSreportserver.config suivants. Vous devez recourir à l'outil de configuration de Reporting Services ou à l'utilitaire rsconfig.exe pour créer des valeurs chiffrées pour ces paramètres.

Certaines valeurs ne sont pas définies pour tous les types de connexion. Si vous configurez la connexion à l'aide de valeurs par défaut (c'est-à-dire avec des comptes de service pour établir la connexion), <LogonUser>, <LogonDomain> et <LogonCred> apparaîtront vides comme suit :

Copier le code
<Dsn></Dsn>
<ConnectionType></ConnectionType>
<LogonUser></LogonUser>
<LogonDomain></LogonDomain>
<LogonCred></LogonCred>

Si vous configurez la connexion de manière à utiliser un compte Windows ou une connexion de base de données spécifique, vous devez mettre à jour les valeurs qui sont stockées si vous changez par la suite le compte ou l'ouverture de session.

Choix d'un type d'informations d'identification

Il existe trois types d'informations d'identification utilisables dans une connexion à une base de données de serveur de rapports :

  • Sécurité intégrée de Windows avec utilisation du compte de service Report Server. Comme le serveur de rapports est implémenté comme service unique, seul le compte sous lequel le service s'exécute requiert l'accès à la base de données.

  • Un compte d'utilisateur Windows Si le serveur de rapports et la base de données du serveur de rapports sont installés sur le même ordinateur, vous pouvez utiliser un compte local. Sinon, vous devez utiliser un compte de domaine.

  • Connexion SQL Server.

Remarque :
Une extension d'authentification personnalisée ne peut pas être utilisée pour établir une connexion à une base de données de serveur de rapports. Les extensions d'authentification personnalisées servent uniquement à authentifier un principal auprès d'un serveur de rapports. Elles n'affectent pas les connexions à la base de données du serveur de rapports ou aux sources de données externes qui fournissent un contenu aux rapports.

Si l'instance du moteur de base de données est configurée pour l'authentification Windows et se trouve dans le même domaine ou un domaine approuvé avec le serveur de rapports, vous pouvez configurer la connexion pour utiliser le compte de service ou un compte d'utilisateur de domaine que vous gérez comme propriété de connexion à travers l'outil de configuration de Reporting Services. Si le serveur de base de données est dans un domaine différent ou si vous utilisez la sécurité de groupe de travail, vous devez configurer la connexion pour utiliser une connexion à une base de données SQL Server. Dans ce cas, veillez bien à chiffrer la connexion. Pour plus d'informations, consultez Chiffrement des connexions à SQL Server dans la documentation en ligne de SQL Server.
Utilisation de comptes de service et de la sécurité intégrée

Vous pouvez utiliser la sécurité intégrée de Windows pour vous connecter via le compte de service Report Server. Le compte bénéficie des droits de connexion à la base de données du serveur de rapports. Il s'agit du type d'informations d'identification par défaut que choisit le programme d'installation si vous installez Reporting Services dans la configuration par défaut.

Le compte de service est un compte approuvé qui implique une faible maintenance de la gestion d'une connexion de base de données de serveur de rapports. Comme le compte de service utilise la sécurité intégrée de Windows pour établir la connexion, il n'est pas nécessaire que les informations d'identification soient stockées. Toutefois, si vous modifiez par la suite l'identité ou le mot de passe du compte de service (par exemple, basculer d'un compte intégré vers un compte de domaine), veillez bien à utiliser l'outil de configuration de Reporting Services pour effectuer la modification. L'outil met automatiquement à jour les autorisations de base de données pour utiliser les informations modifiées sur le compte. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Si vous configurez la connexion de base de données pour qu'elle utilise le compte de service, le compte doit posséder les autorisations réseau si la base de données du serveur de rapports se trouve sur un ordinateur distant. N'utilisez pas le compte de service si la base de données du serveur de rapports se trouve dans un domaine différent, derrière un pare-feu ou si vous utilisez la sécurité des groupes de travail à la place de la sécurité des domaines. Utilisez un compte d'utilisateur de base de données SQL Server à la place.

Utilisation d'un compte d'utilisateur de domaine

Vous pouvez spécifier un compte d'utilisateur Windows pour la connexion à la base de données du serveur de rapports. Si vous utilisez un compte local ou un compte de domaine, vous devez mettre à jour la connexion à la base de données du serveur de rapports chaque fois que vous changez le mot de passe ou le compte. Utilisez toujours l'outil de configuration de Reporting Services pour mettre à jour la connexion.

Utilisation d'une connexion SQL Server

Vous pouvez spécifier une seule connexion SQL Server pour établir la connexion à la base de données du serveur de rapports. Si vous utilisez l'authentification SQL Server et si la base de données du serveur de rapports se trouve sur un ordinateur distant, utilisez IPSec pour sécuriser la transmission des données entre les serveurs. Si vous utilisez une connexion de base de données, vous devez mettre à jour la connexion à la base de données du serveur de rapports chaque fois que vous changez le mot de passe ou le compte.

Autorisations de base de données

Les rôles suivants sont attribués aux comptes utilisés pour la connexion à la base de données du serveur de rapports :

  • Rôles public et RSExecRole pour la base de données ReportServer.

  • Rôle RSExecRole pour les bases de données master, msdb et ReportServerTempDB.

Lorsque vous utilisez l'outil de configuration de Reporting Services pour créer ou modifier la connexion, ces autorisations sont automatiquement accordées. Si vous recourez à l'utilitaire rsconfig.exe et que vous spécifiez un autre compte pour la connexion, vous devez mettre à jour la connexion SQL Server pour ce nouveau compte. Dans l'outil de configuration de Reporting Services, vous pouvez créer les fichiers de script qui mettent à jour la connexion SQL Server pour le serveur de rapports.

Vérification du nom de la base de données

Utilisez l'outil de configuration de Reporting Services pour déterminer quelle est la base de données de serveur de rapports qu'utilise une instance de serveur de rapports particulière. Pour rechercher le nom, connectez-vous à l'instance de serveur de rapports puis ouvrez la page Installation de la base de données.

Utilisation d'une base de données de serveur de rapports différente ou déplacement d'une base de données de serveur de rapports

Vous pouvez configurer une instance de serveur de rapports de manière à utiliser une autre base de données de serveur de rapports en modifiant les informations de connexion. Il est courant de changer de base de données lors du déploiement d'un serveur de rapports de production. C'est généralement au passage d'une base de données de serveur de rapports de test à une base de données de serveur de rapports de production que les serveurs de production sont transférés. Par ailleurs, vous pouvez déplacer une base de données de serveur de rapports vers un autre ordinateur. Pour plus d'informations, consultez Déplacement des bases de données du serveur de rapports vers un autre ordinateur et Migration (Reporting Services) dans la documentation en ligne de SQL Server.

Configuration de plusieurs serveurs de rapports de manière à utiliser la même base de données de serveur de rapports

Vous pouvez configurer plusieurs serveurs de rapports de manière à utiliser la même base de données de serveur de rapports. Cette configuration de déploiement est appelée déploiement avec montée en puissance parallèle. Cette configuration est une condition préalable requise si vous voulez exécuter plusieurs serveurs de rapports dans un cluster de serveurs. Toutefois, vous pouvez aussi utiliser cette configuration pour segmenter les applications de service ou pour tester l'installation et les paramètres d'une nouvelle instance de serveur de rapports afin de la comparer à l'installation existante d'un serveur de rapports. Pour plus d'informations, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

Voir aussi

Concepts

Création d'une base de données de serveur de rapports
Rubriques d'aide à la configuration de Reporting Services
Configuration du compte de service Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration d'un Report Server pour la remise du courrier électronique

Configuration d'un Report Server pour la remise du courrier électronique |
 | Voir aussi
Configuration de Reporting Services >

Reporting Services comprend une extension de la remise du courrier électronique que vous pouvez utiliser pour distribuer les rapports par courrier électronique. Selon la façon dont vous définissez l'abonnement de messagerie électronique, une remise peut consister en une notification, un lien, une pièce jointe ou un rapport incorporé. L'extension de remise de courrier électronique fonctionne avec votre technologie de serveur de messagerie existante. Le serveur de messagerie doit être un serveur SMTP ou redirecteur. Le serveur de rapports se connecte à un serveur SMTP par le biais de bibliothèques CDO (Collaboration Data Objects) (cdosys.dll) fournies par le système d'exploitation.

L'extension de remise du courrier électronique par le serveur de rapports n'est pas configurée par défaut. Vous devez utiliser l'outil de configuration de Reporting Services pour opérer une configuration minimale de l'extension. Pour définir des propriétés avancées, vous devez modifier le fichier RSReportServer.config. Si vous ne pouvez pas configurer le serveur de rapports afin qu'il utilise cette extension, vous pouvez remettre les rapports dans un dossier partagé à la place. Pour plus d'informations, consultez Remise par partage de fichiers dans Reporting Services dans la documentation en ligne de SQL Server.

Configuration requise

  • La remise du courrier électronique par le serveur de rapports est implémentée sur des objets de données de collaboration (CDO) et nécessite un serveur SMTP (Simple Mail Transfer Protocol) local ou distant, ou encore un redirecteur SMTP. Le protocole SMTP n'est pas pris en charge sur tous les systèmes d'exploitation Windows. Si vous utilisez l'édition Itanium de Windows Server 2008, le protocole SMTP n'est pas pris en charge. Pour plus d'informations sur les options de configuration fournies par le biais des objets CDO, consultez Configuration sur MSDN.

  • Le compte de service Report Server doit être autorisé à envoyer du courrier sur le serveur SMTP.

  • L'extension de remise du courrier électronique utilise l'encodage UTF-8 dans les pièces jointes électroniques. Vous ne pouvez pas modifier cet encodage ; l'extension de rendu HTML prend en charge UTF-8 uniquement.

Remarque :
L'extension par défaut de la remise du courrier électronique ne prend pas en charge la signature numérique et le chiffrement des messages sortants.

Configuration d'un Report Server pour un service SMTP local ou distant

Vous pouvez utiliser un service SMTP local ou un serveur ou un redirecteur SMTP distant pour la prise en charge de la remise du courrier électronique. Si vous pouvez accéder à un serveur SMTP existant à distance, pensez à l'utiliser. Si aucun serveur SMTP n'est disponible ou si vous rencontrez par la suite des erreurs liées à la remise des rapports attribuables aux pannes de connexion de l'ordinateur, nous vous recommandons d'utiliser plutôt un service SMTP local. Cette rubrique couvre plus en détail le mode de configuration d'un serveur de rapports pour un service local ou distant.

Définition des options de configuration pour la remise du courrier électronique

Avant d'utiliser la remise du courrier électronique par le serveur de rapports, vous devez définir les valeurs de configuration fournissant des informations sur le mode d'utilisation du serveur SMTP.

Pour configurer un serveur de rapports pour la remise par messagerie, procédez comme suit :

  • Utilisez l'outil de configuration de Reporting Services si vous spécifiez simplement un serveur SMTP et un compte d'utilisateur ayant l'autorisation d'envoyer des messages électroniques. Ce sont les paramètres minimum requis pour configurer l'extension de remise du courrier électronique par le serveur de rapports. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services).

  • (Facultatif) Utilisez un éditeur de texte pour spécifier les paramètres supplémentaires dans le fichier RSreportserver.config. Ce fichier contient tous les paramètres de configuration pour la remise du courrier électronique par le serveur de rapports. La spécification de paramètres supplémentaires dans ces fichiers est obligatoire si vous utilisez un serveur SMTP local ou si vous limitez la remise par messagerie à des hôtes spécifiques. Pour plus d'informations sur la recherche et la modification de fichiers de configuration, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

Remarque :
Les paramètres du courrier électronique pour le serveur de rapports dépendent du CDO. Si vous souhaitez obtenir plus de détails sur des paramètres spécifiques, reportez-vous à la documentation de production CDO.

Configuration du courrier électronique pour Report Server

L'exemple suivant illustre les paramètres dans le fichier RSreportserver.config pour un serveur SMTP distant. Pour plus d'informations sur les descriptions et les valeurs valides de paramètres, consultez Fichier de configuration RSReportServer dans la documentation en ligne de SQL Server ou la documentation de produits CDO.

Copier le code
<RSEmailDPConfiguration>
     <SMTPServer>mySMTPServer.Adventure-Works.com</SMTPServer>
     <SMTPServerPort></SMTPServerPort>
     <SMTPAccountName></SMTPAccountName>
     <SMTPConnectionTimeout></SMTPConnectionTimeout>
     <SMTPServerPickupDirectory></SMTPServerPickupDirectory>
     <SMTPUseSSL></SMTPUseSSL>
     <SendUsing>2</SendUsing>
     <SMTPAuthenticate></SMTPAuthenticate>
     <From>my-rs-email-account@Adventure-Works.com</From>
     <EmbeddedRenderFormats>
          <RenderingExtension>MHTML</RenderingExtension>
     </EmbeddedRenderFormats>
     <PrivilegedUserRenderFormats></PrivilegedUserRenderFormats>
     <ExcludedRenderFormats>
          <RenderingExtension>HTMLOWC</RenderingExtension>
          <RenderingExtension>NULL</RenderingExtension>
     </ExcludedRenderFormats>
     <SendEmailToUserAlias>True</SendEmailToUserAlias>
     <DefaultHostName></DefaultHostName>
     <PermittedHosts>
          <HostName>Adventure-Works.com</HostName>
          <HostName>hotmail.com</HostName>
     </PermittedHosts>
</RSEmailDPConfiguration>

Options de configuration pour la définition du champ À : dans un message

Les abonnements définis par l'utilisateur qui sont créés en fonction des autorisations accordées par la tâche Gérer les abonnements individuels contiennent un nom d'utilisateur prédéfini qui repose sur le compte d'utilisateur de domaine. Lorsque l'utilisateur crée l'abonnement, le nom du destinataire dans le champ À : est configuré automatiquement à l'adresse de la personne qui crée l'abonnement, au moyen du compte d'utilisateur de domaine.

Si vous utilisez un redirecteur ou un serveur SMTP qui utilise des comptes de messagerie différents du compte d'utilisateur de domaine, la remise des rapports échouera lorsque le serveur SMTP tentera de remettre le rapport à cet utilisateur.

Pour contourner ce problème, vous pouvez modifier les paramètres de configuration qui permettent aux utilisateurs d'entrer un nom dans le champ À :.

  1. Ouvrez le fichier RSReportServer.config avec un éditeur de texte.

  2. Définissez SendEmailToUserAlias à False.

  3. Définissez DefaultHostName au nom DNS (Domain Name System) ou à l'adresse IP du redirecteur ou du serveur SMTP.

  4. Enregistrez le fichier.

Options de configuration pour le service SMTP distant

La connexion entre le serveur de rapports et le serveur ou redirecteur SMTP est déterminée par les paramètres de configuration suivants :

  • SendUsing spécifie une méthode pour l'envoi de messages. Vous pouvez choisir entre un service SMTP réseau ou un répertoire de collecte du service SMTP local. Pour utiliser un service SMTP distant, cette valeur doit être définie sur 2 dans le fichier RSReportServer.config.

  • SMTPServer spécifie le serveur ou le redirecteur SMTP distant. Cette valeur est obligatoire si vous utilisez un serveur ou un redirecteur SMTP distant.

  • De définit la valeur qui s'affiche sur la ligne De : d'un message électronique. Cette valeur est obligatoire si vous utilisez un serveur ou un redirecteur SMTP distant.

D'autres valeurs utilisées pour le service SMTP distant comprennent ce qui suit (notez que vous n'avez pas besoin de les spécifier à moins de vouloir remplacer les valeurs par défaut).

  • SMTPServerPort est configuré pour le port 25.

  • SMTPAuthenticate spécifie le mode de connexion du serveur de rapports au serveur SMTP distant. La valeur par défaut est 0 (ou aucune authentification). Dans ce cas, la connexion est effectuée par un accès anonyme. En fonction de la configuration de votre domaine, il est possible que le serveur de rapports et le serveur SMTP soient obligés d'être des membres du même domaine.

    Pour envoyer du courrier électronique aux listes de distribution limitée (par exemple, les listes de distribution qui acceptent des messages entrants uniquement à partir de comptes authentifiés), définissez SMTPAuthenticate sur la valeur 2.

Options de configuration pour le service SMTP local

La configuration d'un service SMTP local est pratique si vous testez ou dépannez la remise du courrier électronique par le serveur de rapports. Par défaut, le service SMTP local n'est pas activé. Pour obtenir des instructions sur la manière de l'activer, consultez Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services).

La connexion entre le serveur de rapports et le serveur ou le redirecteur SMTP local est déterminée par les paramètres de configuration suivants :

  • SendUsing est défini sur 1.

  • SMTPServerPickupDirectory est défini sur un dossier de lecteur local.

    Remarque :
    Assurez-vous de ne pas définir SMTPServer si vous utilisez un serveur SMTP local.

  • De définit la valeur qui s'affiche sur la ligne De : d'un message électronique. Cette valeur est requise.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services
Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration du compte d'exécution sans assistance

Configuration du compte d'exécution sans assistance |
 | Voir aussi
Configuration de Reporting Services >

Reporting Services fournit un compte spécial utilisé pour le traitement de rapport sans surveillance et pour l'envoi de demandes de connexion par le biais du réseau. Le compte est utilisé des façons suivantes :

  • Envoyez les demandes de connexion sur le réseau pour les rapports qui utilisent l'authentification de base de données ou connectez-vous aux sources de données de rapport externes qui ne requièrent pas ou n'utilisent pas l'authentification. Pour plus d'informations, consultez la rubrique Spécification des informations d'identification et de connexion pour les sources de données de rapport dans la documentation en ligne de SQL Server.

  • Extraire des fichiers image externes qui sont utilisés dans un rapport. Si vous souhaitez utiliser un fichier image et que le fichier est inaccessible par le biais de l'accès Anonyme, vous pouvez configurer le compte de traitement de rapport sans surveillance et accorder au compte l'autorisation d'accéder au fichier. Pour plus d'informations sur le compte d'exécution sans surveillance utilisé pour extraire des images, consultez Ajout d'images à un rapport dans la documentation en ligne de SQL Server.

Le traitement sans surveillance des rapports désigne tout processus d'exécution de rapport déclenché par un événement, d'actualisation de données ou piloté par planification, plutôt que par une demande d'utilisateur. Le serveur de rapports utilise le compte de traitement sans surveillance des rapports pour se connecter à l'ordinateur qui héberge la source de données externe. Ce compte est nécessaire car les informations d'identification du compte de service Report Server ne sont jamais utilisées pour la connexion à d'autres ordinateurs.

Important :
La configuration de ce compte est facultative. Cependant, si vous ne le configurez pas, vous limitez vos options pour la connexion à certaines sources de données et vous risquez de ne pas pouvoir récupérer de fichiers image à partir d'ordinateurs distants. Si vous configurez le compte, vous devez le maintenir à jour. Plus spécifiquement, si vous laissez un mot de passe expirer ou si les informations de compte sont modifiées dans Active Directory, vous rencontrerez l'erreur suivante lors du prochain traitement de rapport : « Échec de l'ouverture de session (rsLogonFailed) Échec d'ouverture de session : nom d'utilisateur inconnu ou mot de passe incorrect ». Une maintenance correcte du compte de traitement de rapport sans surveillance est essentielle, même si vous ne récupérez jamais de fichiers image ou si vous n'envoyez jamais de demandes de connexion à des ordinateurs externes. Si vous configurez le compte et constatez ultérieurement que vous ne l'utilisez pas, vous pouvez le supprimer afin d'éliminer des tâches de maintenance de compte routinières.

Comment configurer le compte

Vous devez utiliser un compte utilisateur de domaine. Pour assumer son rôle prévu, ce compte doit être différent de celui utilisé pour exécuter le service Report Server. Veillez à utiliser un compte ayant les autorisations minimales (l'accès en lecture seule avec les autorisations de connexion réseau est suffisant) et un accès limité aux seuls ordinateurs qui fournissent des sources de données et des ressources au serveur de rapports. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Pour spécifier le compte, vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rsconfig.exe. La façon la plus simple de configurer le compte d'exécution sans surveillance consiste à exécuter l'outil de configuration de Reporting Services et à spécifier les informations d'identification dans la page Compte d'exécution.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer. Pour obtenir les instructions, consultez Procédure : lancer la configuration de Reporting Services.

  2. Sur la page Compte d'exécution, activez l'option Spécifier un compte d'exécution.

  3. Tapez le compte et le mot de passe, tapez de nouveau le mot de passe, puis cliquez sur Appliquer.

Utilisation de l'utilitaire RSCONFIG.exe

Une autre méthode pour définir le compte consiste à recourir à l'utilitaire rsconfig.exe. Pour spécifier le compte, utilisez l'argument -e de l'utilitaire rsconfig.exe. La spécification de l'argument -e pour rsconfig.exe commande à l'utilitaire d'écrire les informations de compte dans le fichier de configuration. Vous n'avez pas besoin de spécifier un chemin d'accès à RSreportserver.config. Procédez comme suit pour configurer le compte.

  1. Créez ou sélectionnez un compte de domaine qui ne peut accéder qu'aux ordinateurs et aux serveurs qui fournissent des données ou des services à un serveur de rapports. Vous devez utiliser un compte bénéficiant d'autorisations réduites (telles que des autorisations de lecture seule).

  2. Ouvrez une invite de commandes : dans le menu Démarrer, cliquez sur Exécuter, tapez cmd, puis cliquez sur OK.

  3. Tapez la commande suivante pour configurer le compte sur une instance de serveur de rapports locale :

    rsconfig -e -u< domaine / nom_utilisateur > -p< mot_de_passe >

La commande rsconfig -e prend en charge des arguments supplémentaires. Pour obtenir plus d'informations sur la syntaxe et pour obtenir des exemples de commande, consultez Utilitaire rsconfig dans la documentation en ligne de SQL Server.

Comment les informations sur le compte sont stockées

Lorsque vous définissez le compte, les paramètres suivants sont spécifiés comme valeurs chiffrées dans le fichier RSreportserver.config sur une instance de serveur de rapports locale ou distante :

Copier le code
<UnattendedExecutionAccount>
     <UserName></UserName>
     <Password></Password>
     <Domain></Domain>
</UnattendedExecutionAccount>

Une fois que vous les avez définies, vous ne pouvez pas les déchiffrer pour les consulter sous la forme de texte brut. Si vous n'entrez pas les valeurs correctement ou que vous oubliez les valeurs que vous avez spécifiées, vous devez recommencer la procédure à l'aide de l'outil de configuration de Reporting Services ou de la commande rsconfig -e.

Comment utiliser le compte de traitement de rapport sans surveillance

Pour extraire les fichiers image, le serveur de rapports utilise automatiquement le compte et aucune action spécifique n'est requise de votre part. Pour utiliser le compte pour vous connecter aux sources de données externes qui fournissent les données aux rapports, vous devez spécifier une option Type d'informations d'identification dans la page de propriétés de source de données de la source de données du rapport ou de la source de données partagée :

  • Dans le Gestionnaire de rapports ou sur un site SharePoint, sélectionnez l'option Informations d'identification non requises.

Le compte de traitement des rapports sans assistance est utilisé principalement pour se connecter aux serveurs externes, et non comme connexion aux serveurs de base de données. Si vous souhaitez utiliser les informations d'identification du compte pour vous connecter à une base de données, vous devez spécifier ces informations dans la chaîne de connexion. Vous pouvez spécifier Integrated Security=SSPI si le serveur de base de données prend en charge la sécurité intégrée Windows et si le compte utilisé pour le traitement de rapport sans assistance dispose de l'autorisation de lecture dans la base de données. Sinon, vous devez entrer le nom d'utilisateur et le mot de passe dans la chaîne de connexion, où ces informations apparaissent en texte en clair à tout utilisateur qui peut modifier les propriétés de la connexion à la source de données.

Bien que rien ne vous empêche d'utiliser le compte de traitement de rapport sans assistance pour récupérer les données une fois la connexion établie, il n'est pas recommandé de le faire. Ce compte est prévu pour des fonctions bien spécifiques. Si vous l'utilisez pour récupérer des données, vous allez à l'encontre de sa fonction première.

Comment maintenir le compte de traitement de rapport sans surveillance

Une fois que vous avez défini le compte, vous devez vous assurer que le compte et le mot de passe sont maintenus à jour. Vous pouvez utiliser l'outil de configuration de Reporting Services pour mettre à jour les paramètres de configuration qui stockent les informations relatives à ce compte.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer.

  2. Sur la page Compte d'exécution, vérifiez que l'option Spécifier un compte d'exécution est sélectionnée.

  3. Tapez le nouveau compte ou mot de passe, tapez de nouveau le mot de passe, puis cliquez sur Appliquer.

Comment supprimer le compte de traitement de rapport sans surveillance

Si vous n'utilisez pas le compte, vous pouvez le supprimer afin d'éliminer des tâches de maintenance de compte routinières.

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports que vous voulez configurer.

  2. Sur la page Compte d'exécution, désactivez l'option Spécifier un compte d'exécution.

  3. Cliquez sur Appliquer.

Les informations de compte sont supprimées du fichier RSReportServer.config.

Voir aussi

Concepts

Configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration et gestion des clés de chiffrement

Configuration et gestion des clés de chiffrement |
 | Voir aussi
Configuration de Reporting Services >

Reporting Services Reporting Services utilise les clés de chiffrement pour protéger les informations de connexion et d'identification stockées dans la base de données du serveur de rapports. Dans Reporting Services, le chiffrement est pris en charge par la combinaison d'une clé publique, d'une clé privée et d'une clé symétrique, dont le but est de protéger les données sensibles. La clé symétrique est créée au cours de l'initialisation du serveur de rapports lorsque vous installez ou configurez le serveur de rapports. Elle est utilisée par le serveur de rapports pour chiffrer les données sensibles stockées sur le serveur de rapports. Les clés publiques et privées sont créées par le système d'exploitation et servent à protéger la clé symétrique. Une paire de clés privée et publique est créée pour chaque instance du serveur de rapports qui stocke des données sensibles dans une base de données de serveur de rapports.

La gestion des clés de chiffrement consiste à créer une copie de sauvegarde de la clé symétrique et à savoir quand et comment restaurer, supprimer ou modifier les clés. Si vous migrez une installation de serveur de rapports ou que vous configurez un déploiement avec montée en puissance parallèle, vous devez disposer d'une copie de sauvegarde de la clé symétrique pour pouvoir l'appliquer à la nouvelle installation.

Pour gérer les clés symétriques, utilisez au choix l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt. Les outils fournis dans Reporting Services servent à la gestion de la clé symétrique uniquement (les clés publique et privée sont gérées par le système d'exploitation). L'outil de configuration de Reporting Services et l'utilitaire rsconfig prennent en charge les tâches suivantes :

  • Sauvegarde d'un exemplaire de la clé symétrique pour permettre la récupération de l'installation d'un serveur de rapports ou pour servir dans le processus d'une migration planifiée.

  • Restauration dans une base de données de serveur de rapports d'une clé symétrique préalablement enregistrée afin de permettre à une nouvelle instance de serveur de rapports d'accéder à des données existantes qu'elle n'a pas chiffrées au départ.

  • Suppression des données chiffrées d'une base de données de serveur de rapports au cas improbable où l'accès à ces données chiffrées se révélerait impossible.

  • Recréation de clés symétriques et nouveau chiffrement des données au cas improbable où la sécurité de la clé symétrique serait compromise. La création périodique d'une nouvelle clé symétrique (tous les deux ou trois mois par exemple) est préconisée en tant que mesure de sécurité pour protéger la base de données d'un serveur de rapports contre les cyber-attaques qui tentent de déchiffrer la clé.

  • Ajout ou suppression d'une instance de serveur de rapports dans un déploiement avec montée en puissance parallèle où plusieurs serveurs de rapports partagent une base de données du serveur de rapports unique ainsi que la clé symétrique assurant le chiffrement réversible de cette dernière.

Dans cette section

Initialisation d'un serveur de rapports

Explique la procédure de création des clés de chiffrement.

Sauvegarde et restauration des clés de chiffrement

Explique la procédure de sauvegarde des clés de chiffrement et la façon de restaurer ces clés afin de récupérer l'installation d'un serveur de rapports ou de procéder à sa migration.

Stockage des données chiffrées du serveur de rapports

Décrit le chiffrement sur un serveur de rapports.

Suppression et recréation des clés de chiffrement

Explique comment remplacer une clé symétrique par une nouvelle version de cette dernière et comment recommencer l'opération de chiffrement depuis le début, si la validation des clés symétriques est impossible.

Ajout et suppression de clés de chiffrement pour un déploiement évolutif

Explique la procédure de création et d'ajout des clés de chiffrement pour contrôler l'intégration des serveurs de rapports à un déploiement évolutif.

Voir aussi

Concepts

Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Initialisation d'un serveur de rapports

Initialisation d'un serveur de rapports |
 | Voir aussi
Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Dans Reporting Services, un serveur initialisé est un serveur qui peut chiffrer et déchiffrer les données d'une base de données de serveur de rapports. L'initialisation est une condition obligatoire pour le fonctionnement d'un serveur de rapports. Cette opération s'effectue lorsque le service Report Server est démarré pour la première fois. Elle s'accomplit également lorsque vous intégrez le serveur de rapports au déploiement existant ou lorsque, manuellement, vous recréez les clés dans le cadre d'un processus de récupération. Pour plus d'informations sur l'utilisation des clés de chiffrement et sur leur intérêt, consultez Configuration et gestion des clés de chiffrement et Stockage des données chiffrées du serveur de rapports.

Les clés de chiffrement sont en partie basées sur les informations de profil du service Report Server. Si vous modifiez l'identité de l'utilisateur servant à exécuter le service Report Server, vous devez mettre à jour les clés en conséquence. Si vous utilisez l'outil de configuration de Reporting Services pour changer l'identité, cette opération s'effectue automatiquement.

Si l'initialisation échoue pour une raison quelconque, le serveur de rapports retourne une erreur RSReportServerNotActivated en réponse à l'utilisateur et aux demandes de service. Dans ce cas, le problème se situe peut-être au niveau de la configuration du serveur ou du système. Pour plus d'informations, consultez Correction des erreurs d'initialisation et de clé de chiffrement dans la documentation en ligne de SQL Server.

Vue d'ensemble du processus d'initialisation

Le processus d'initialisation crée et stocke une clé symétrique destinée au chiffrement. Cette clé symétrique est créée par les services de chiffrement de MicrosoftWindows, puis utilisée par le service Report Server pour chiffrer et déchiffrer des données. La clé symétrique est elle-même chiffrée avec une clé asymétrique.

La description du processus d'initialisation est détaillée comme suit :

  1. Au démarrage initial, le service Report Server lit le fichier RSReportServer.config pour récupérer l'identificateur d'installation et les informations de connexion à la base de données.

  2. Le service Report Server fait la demande d'une clé publique auprès des services de chiffrement. Windows crée une clé privée et une clé publique, puis envoie la clé publique au service Report Server.

  3. Le service Report Server se connecte à la base de données du serveur de rapports pour y stocker les valeurs de l'identificateur d'installation et de la clé publique.

  4. Le service Report Server rappelle les services de chiffrement, cette fois-ci pour demander une clé symétrique. Windows crée la clé symétrique requise.

  5. Le service Report Server se connecte à nouveau à la base de données du serveur de rapports et ajoute la clé symétrique aux valeurs de la clé publique et de l'identificateur d'installation stockées au cours de l'étape 3. Avant de la stocker, le service Report Server utilise sa clé publique pour chiffrer la clé symétrique. Une fois cette nouvelle clé stockée, le serveur de rapports est considéré comme initialisé et opérationnel.

Initialisation d'un serveur de rapports pour un déploiement évolutif

Reporting Services prend en charge le modèle de déploiement avec montée en puissance parallèle qui partage une seule base de données de serveur de rapports entre plusieurs instances de serveurs de rapports. Pour intégrer un déploiement évolutif, un serveur de rapports doit créer et stocker sa copie de la clé symétrique dans la base de données partagée. Bien qu'une seule clé symétrique soit utilisée par les serveurs utilisateurs de la base de données, chaque serveur de rapports possède un exemplaire de la clé. Chaque exemplaire est différent en soi puisqu'il est chiffré exclusivement à l'aide de la clé publique de son propriétaire.

Les premières étapes assurant l'initialisation d'un serveur de rapports en vue d'un déploiement évolutif sont identiques aux trois premières étapes de l'initialisation d'une combinaison base de données et serveur unique.

La seule différence réside dans la façon dont le serveur de rapports obtient la clé symétrique au cours du processus d'initialisation pour le déploiement évolutif. Lorsque le premier serveur est initialisé, il obtient la clé symétrique de Windows et Lorsque le deuxième serveur est initialisé durant la configuration du déploiement avec montée en puissance parallèle, il obtient sa clé symétrique du service Report Server déjà initialisé. L'instance du premier serveur de rapports utilise la clé publique de la deuxième instance pour créer un exemplaire chiffré de la clé symétrique pour l'instance du deuxième serveur de rapports. La clé symétrique n'est jamais exposée sous forme de texte brut à un seul stade de ce processus.

Initialisation d'un serveur de rapports

  • Pour initialiser un serveur de rapports, utilisez l'outil de configuration de Reporting Services. L'opération s'effectue automatiquement lorsque vous créez et configurez la base de données du serveur de rapports. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

  • Pour initialiser un serveur de rapports en vue de l'intégrer à un déploiement évolutif, utilisez la page d'initialisation de l'outil de configuration de Reporting Services ou l'utilitaire RSKeymgmt. Pour les instructions détaillées de cette procédure, consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services).

Remarque :
RSKeymgmt est une application console qui s'exécute à partir d'une ligne de commande sur un ordinateur hébergeant une instance de serveur de rapports déjà intégrée à un déploiement évolutif. Lorsque vous exécutez cet utilitaire, vous spécifiez des arguments pour sélectionner une instance de serveur de rapports distante à initialiser.

Un serveur de rapports n'est initialisé que dans la mesure où une correspondance entre l'identificateur d'installation et la clé publique existe. Si la correspondance est trouvée, une clé symétrique permettant le chiffrement réversible est créée. S'il n'existe aucune correspondance, le serveur de rapports est désactivé. Dans ce cas il peut s'avérer nécessaire d'appliquer une clé de sauvegarde ou de supprimer les données chiffrées si aucune clé de sauvegarde n'est disponible ou valide. Pour plus d'informations sur les clés de chiffrement utilisées par un serveur de rapports, consultez Configuration et gestion des clés de chiffrement.

Remarque :
Vous pouvez également utiliser le fournisseur WMI (Windows Management Instrumentation) de Reporting Services pour initialiser un serveur de rapports par programme. Pour plus d'informations, consultez Fournisseur WMI de Reporting Services dans la documentation en ligne de SQL Server.

Confirmation de l'initialisation d'un serveur de rapports

Pour confirmer l'initialisation d'un serveur de rapports, exécutez une commande ping pour le service Web Report Server en tapant http://<nomserveur>/serveurrapports dans la fenêtre de commande. Si l'erreur RSReportServerNotActivated se produit, l'initialisation a échoué.

Voir aussi

Concepts

Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Stockage des données chiffrées du serveur de rapports

Stockage des données chiffrées du serveur de rapports |
 | Voir aussi
Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Remarque Pour SQL Server 2008 R2, il n'y a pas eu de modifications au contenu répertorié dans cette rubrique.

Reporting Services stocke des valeurs chiffrées dans la base de données du serveur de rapports et dans les fichiers de configuration. La plupart des valeurs chiffrées sont des informations d'identification utilisées pour accéder à des sources de données externes fournissant des données aux rapports. Cette rubrique indique quelles valeurs sont chiffrées et décrit la fonctionnalité de chiffrement utilisée dans Reporting Services, ainsi que les autres types de données confidentielles stockées qu'il convient de connaître.

Valeurs chiffrées

La liste suivante décrit les valeurs qui sont stockées dans une installation Reporting Services.

  • Informations de connexion et informations d'identification utilisées par un serveur de rapports pour la connexion à une base de données de serveur de rapports qui stocke des données de serveur internes.

    Ces valeurs sont spécifiées et chiffrées au cours de l'installation ou de la configuration du serveur de rapports. Vous pouvez mettre à jour les informations de connexion à tout moment par le biais de l'outil de configuration de Reporting Services ou de l'utilitaire rsconfig. Le chiffrement des paramètres de configuration s'effectue à l'aide de la clé au niveau machine de l'ordinateur local qui est disponible pour tous les utilisateurs. Les informations chiffrées de connexion au serveur de rapports sont stockées dans le fichier rsreportserver.config (aucun autre fichier de configuration ne possède de paramètres chiffrés). Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

  • Informations d'identification stockées, utilisées par un serveur de rapports pour se connecter à des sources de données externes qui fournissent des données à un rapport.

    Ces valeurs sont définies lorsque vous configurez les informations d'une source de données pour un rapport, puis elles sont stockées sous la forme de valeurs chiffrées dans une base de données du serveur de rapports. Le serveur de rapports utilise une clé symétrique pour chiffrer et déchiffrer ces données. Pour plus d'informations sur les informations d'identification stockées, consultez Planification des services, des comptes et des connexions et Spécification des informations d'identification et de connexion pour les sources de données de rapport dans la documentation en ligne de SQL Server.

  • Un compte d'utilisateur sans assistance utilisé par le serveur de rapports pour se connecter à d'autres ordinateurs afin d'extraire des fichiers images externes ou des données externes utilisées dans un rapport.

    Ce compte est utilisé lorsqu'une connexion à un ordinateur distant est requise et qu'aucune autre information d'identification n'est disponible pour établir la connexion. Ce compte est principalement utilisé pour gérer le traitement de rapports sans assistance qui n'utilise pas d'informations d'identification pour accéder à une source de données. Si vous créez des rapports basés sur des sources de données qui ne nécessitent pas ou n'utilisent pas d'informations d'identification lors de l'accès aux données, vous devez configurer ce compte pour permettre son utilisation par le serveur de rapports.

    Ce compte se révèle indispensable dans certains cas et seul l'outil de configuration de Reporting Services ou l'utilitaire rsconfig peut créer un tel compte. Cette valeur est également stockée dans le fichier rsreportserver.config. Vous devez créer ce compte manuellement. Pour plus d'informations sur ce compte et son utilisation, consultez Configuration du compte d'exécution sans assistance.

  • Clé symétrique utilisée pour un chiffrement.

    Cette valeur est créée pendant l'installation ou la configuration du serveur, elle est ensuite stockée sous forme de valeur chiffrée dans la base de données du serveur de rapports. Le service Windows Report Server utilise cette clé pour chiffrer et déchiffrer des données stockées dans la base de données du serveur de rapports.

Fonctionnalité de chiffrement dans Reporting Services

Reporting Services utilise des fonctions de chiffrement qui font partie du système d'exploitation Windows. Des chiffrements symétriques et asymétriques sont utilisés.

Les données de la base de données du serveur de rapports sont chiffrées à l'aide d'une clé symétrique. Il existe une clé symétrique pour chaque base de données de serveur de rapports. Cette clé symétrique est elle-même chiffrée à l'aide de la clé publique d'une paire de clés asymétriques générée par Windows. La clé privée est détenue par le compte du service Report Server Windows.

Dans un déploiement évolutif de serveur de rapports où plusieurs instances de serveur de rapports partagent la même base de données de serveur de rapports, une clé symétrique unique est employée par tous les nœuds de serveur de rapports. Chaque nœud doit avoir une copie de la clé symétrique partagée. Une copie de la clé symétrique est créée automatiquement pour chaque nœud lorsque le déploiement évolutif est configuré. Chaque nœud chiffre sa copie de la clé symétrique à l'aide de la clé publique d'une paire de clés spécifiques de son compte de service Windows. Pour en savoir plus sur la création de la clé symétrique pour les déploiements à instance unique et évolutifs, consultez Initialisation d'un serveur de rapports.

Remarque :
Lorsque vous changez le compte du service Report Server Windows, les clés asymétriques peuvent devenir non valides, ce qui affecte les opérations du serveur. Pour éviter ce problème, utilisez toujours l'outil de configuration de Reporting Services pour modifier les paramètres de compte de service. Lorsque vous utilisez l'outil de configuration, les clés sont mises à jour automatiquement. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Autres sources de données confidentielles

Un serveur de rapports stocke d'autres données non chiffrées, mais qui contiennent des informations sensibles que vous voulez protéger. Plus particulièrement, les instantanés d'historique de rapport et d'exécution de rapport contiennent des résultats de requêtes pouvant inclure des données destinées exclusivement à des utilisateurs autorisés. Si vous utilisez la fonction d'instantané pour des rapports qui contiennent des données confidentielles, sachez que les utilisateurs capables d'ouvrir des tables dans une base de données du serveur de rapports peuvent être en mesure d'afficher des parties d'un rapport stocké en inspectant le contenu de la table.

Remarque :
Reporting Services ne prend pas en charge la mise en cache ou l'historique de rapport pour les rapports basés sur l'identité de sécurité de l'utilisateur.

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Sauvegarde et restauration des clés de chiffrement

Sauvegarde et restauration des clés de chiffrement |
 | Voir aussi
Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Une part importante de la configuration d'un serveur de rapports est réservée à la création d'une copie de sauvegarde de la clé symétrique utilisée pour le chiffrement d'informations confidentielles. Cet exemplaire de clé sauvegardée est nécessaire dans de nombreuses opérations courantes. Elle vous permet de réutiliser une base de données de serveur de rapports existante dans une nouvelle installation. La restauration de la copie de sauvegarde de la clé de chiffrement est indispensable lorsque l'un des événements suivants se produit :

  • Modification effectuée sur le nom du compte de service Windows Report Server ou réinitialisation du mot de passe. Lorsque vous utilisez l'outil de configuration de Reporting Services, la sauvegarde de la clé est intégrée à une opération de changement de nom du compte de service.

    Remarque :
    La réinitialisation et la modification d'un mot de passe sont deux opérations différentes. La réinitialisation d'un mot de passe requiert l'autorisation permettant de remplacer des informations de compte sur le contrôleur de domaine. Cette opération est effectuée par un administrateur système lorsqu'un utilisateur a oublié ou ne connaît pas un mot de passe particulier. Seule la réinitialisation d'un mot de passe nécessite la restauration de la clé symétrique. Le changement régulier d'un mot de passe de compte ne vous oblige pas à réinitialiser la clé symétrique.

  • Attribution d'un nouveau nom à l'ordinateur ou à l'instance qui héberge le serveur de rapports (une instance de serveur de rapports repose sur un nom d'instance SQL Server).

  • Migration d'une installation de serveur de rapports ou configuration d'un serveur de rapports afin d'utiliser une base de données de serveur de rapports différente.

  • Récupération d'une installation de serveur de rapports suite à une défaillance matérielle.

Une seule copie de sauvegarde de la clé symétrique est nécessaire. Il existe une correspondance unilatérale entre une base de données de serveur de rapports et une clé symétrique. Bien que vous n'ayez besoin que d'un seul exemplaire de clé sauvegardé, il peut s'avérer nécessaire de restaurer cette clé à plusieurs reprises si vous exécutez plusieurs serveurs de rapports dans un modèle de déploiement évolutif. En effet, chaque instance de serveur de rapports nécessite sa copie de la clé symétrique pour verrouiller et déverrouiller des données dans la base de données du serveur de rapports.

Sauvegarde des clés de chiffrement sur disque

La sauvegarde de la clé symétrique est un processus qui consiste à écrire la clé dans le fichier que vous spécifiez, puis à brouiller ces données à l'aide du mot de passe que vous fournissez. En aucun cas la clé symétrique ne peut être conservée sans être chiffrée, vous devez donc fournir un mot de passe afin de rendre la clé illisible au moment de son enregistrement sur un disque. Une fois le fichier créé, vous devez le stocker dans un endroit sécurisé et vous souvenir du mot de passe qui permet de déverrouiller le fichier. Pour sauvegarder la clé symétrique, utilisez soit l'outil de configuration de Reporting Services soit l'utilitaire rskeymgmt.

Procédure de sauvegarde des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports à configurer.

  2. Cliquez sur Clés de chiffrement, puis sur Sauvegarder.

  3. Tapez un mot de passe fort.

  4. Spécifiez un fichier pour contenir la clé stockée. Reporting Services ajoute une extension de fichier .snk au fichier. Prévoyez de conserver le fichier à part sur une disquette, pour qu'il soit indépendant du serveur de rapports.

  5. Cliquez sur OK.

Procédure de sauvegarde des clés de chiffrement (rskeymgmt)

  1. Insérez une disquette dans le lecteur approprié si vous voulez stocker le fichier protégé par mot de passe séparément du serveur de rapports.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Vous devez utiliser l'argument d'extraction -e pour copier la clé, fournir un nom de fichier et spécifier un mot de passe. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -e -f a:\rsdbkey.snk -p<password>
  3. Conservez la disquette en lieu sûr.

Restauration des clés de chiffrement

La restauration de la clé symétrique remplace la clé existante qui est stockée dans la base de données du serveur de rapports. Cette opération permet de remplacer une clé devenue inutilisable par son exemplaire précédemment enregistré sur disquette. La restauration des clés de chiffrement se traduit par les actions suivantes :

  • La clé symétrique est ouverte à l'aide du fichier de sauvegarde protégé par mot de passe.

  • La clé symétrique est chiffrée à l'aide de la clé publique du service Windows Report Server.

  • La clé symétrique chiffrée est stockée dans la base de données du serveur de rapports.

  • Les données de clé symétrique préalablement stockées (par exemple, des informations de clé déjà présentes dans la base de données du serveur de rapports en raison d'un précédent déploiement) sont supprimées.

Pour restaurer une clé de chiffrement, vous devez posséder un exemplaire de la clé de chiffrement dans un fichier et connaître le mot de passe permettant de déverrouiller l'exemplaire stocké. Si vous détenez la clé et le mot de passe, procédez à la restauration en exécutant l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt La clé symétrique doit être identique à l'exemplaire qui verrouille et déverrouille les données chiffrées stockées à ce moment-là dans la base de données du serveur de rapports. Si vous restaurez un exemplaire non valide, le serveur de rapports est incapable d'accéder à ces données. Vous serez amené à supprimer toutes les valeurs chiffrées si jamais la restauration d'une clé valide est impossible. Si, pour une raison quelconque, vous ne pouvez pas restaurer la clé de chiffrement (vous ne possédez pas de copie de sauvegarde par exemple), supprimez la clé et le contenu chiffré. Pour plus d'informations, consultez Suppression et recréation des clés de chiffrement. Pour plus d'informations sur la création des clés symétriques, consultez Initialisation d'un serveur de rapports.

Procédure de restauration des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports à configurer.

  2. Dans la page Clés de chiffrement, cliquez sur Restaurer.

  3. Sélectionnez le fichier .snk contenant la copie de sauvegarde.

  4. Tapez le mot de passe permettant de déverrouiller le fichier.

  5. Cliquez sur OK.

Procédure de restauration des clés de chiffrement (rskeymgmt)

  1. Insérez la disquette qui contient la copie de sauvegarde de la clé de chiffrement.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Utilisez l'argument -a pour restaurer les clés. Vous devez fournir un nom de fichier complet et spécifier un mot de passe. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -a -f a:\rsdbkey.snk -p<password>

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Suppression et recréation des clés de chiffrement

Suppression et recréation des clés de chiffrement |
 | Voir aussi
Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

La suppression et la recréation de clés de chiffrement sont des activités qui dépassent le cadre d'une simple opération de maintenance des clés de chiffrement. Vous effectuez ces tâches en réponse à une menace spécifique pesant sur votre serveur de rapports ou comme ultime recours si vous ne pouvez plus accéder à la base de données du serveur de rapports.

  • Recréez la clé symétrique lorsque vous estimez que la sécurité de la clé existante est compromise. Vous pouvez effectuer cette opération régulièrement en tant que mesure de sécurité.

  • Supprimez les clés de chiffrement existantes et le contenu chiffré inutilisable lorsqu'il vous est impossible de restaurer la clé symétrique.

Recréation des clés de chiffrement

Si vous avez la preuve que la clé symétrique est connue d'utilisateurs non autorisés ou si votre serveur de rapports a subi une attaque et que vous voulez, par mesure de précaution, réinitialiser la clé symétrique, procédez à une nouvelle création de clé. Cette opération implique un nouveau chiffrement de toutes les valeurs chiffrées à l'aide de la nouvelle valeur. Si vous exécutez plusieurs serveurs de rapports dans un déploiement évolutif, tous les exemplaires de la clé symétrique seront mis à jour avec cette nouvelle valeur. Le serveur de rapports utilise les clés publiques disponibles pour cette clé symétrique qu'il met à jour pour chaque serveur dans le déploiement.

La création d'une nouvelle clé symétrique n'est possible que si le serveur de rapports est en cours de fonctionnement. Cette opération, ainsi que le nouveau chiffrement de contenu, peuvent perturber les activités du serveur. Vous devez mettre le serveur en mode hors connexion tandis que vous procédez au nouveau chiffrement. Aucune demande ne doit être adressée au serveur de rapports durant cette opération.

Vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt pour réinitialiser la clé symétrique et les données chiffrées. Pour plus d'informations sur la création de la clé symétrique, consultez Initialisation d'un serveur de rapports.

Procédure de recréation des clés de chiffrement (outil de configuration de Reporting Services)

  1. Désactivez le service Web Report Server et l'accès HTTP en modifiant la propriété IsWebServiceEnabled dans le fichier rsreportserver.config. Cette étape arrête temporairement l'envoi des demandes d'authentification au serveur de rapports sans arrêter complètement le serveur. Vous devez avoir le service minimal afin de pouvoir recréer les clés.

    Si vous recréez des clés de chiffrement pour un déploiement évolutif de serveurs de rapports, désactivez cette propriété sur toutes les instances du déploiement.

    1. Ouvrez l'Explorateur Windows et naviguez jusqu'à lecteur:\Program Files\Microsoft SQL Server\instance_serveur_rapports\Reporting Services. Remplacez lecteur par votre lettre de lecteur et instance_serveur_rapports par le nom du dossier qui correspond à l'instance de serveur de rapports pour laquelle vous souhaitez désactiver le service Web et l'accès HTTP. Par exemple, C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services.

    2. Ouvrez le fichier rsreportserver.config.

    3. Pour la propriété IsWebServiceEnabled, spécifiez False, puis enregistrez vos modifications.

  2. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports que vous voulez configurer.

  3. Dans la page Clés de chiffrement, cliquez sur Modifier. Cliquez sur OK.

  4. Redémarrez le service Windows Report Server. Si vous recréez des clés de chiffrement pour un déploiement évolutif, redémarrez le service sur toutes les instances.

  5. Réactivez le service Web et l'accès HTTP en modifiant la propriété IsWebServiceEnabled dans le fichier rsreportserver.config. Effectuez cette action pour toutes les instances si vous utilisez un déploiement évolutif.

Procédure de recréation des clés de chiffrement (rskeymgmt)

  1. Désactivez le service Web Report Server et l'accès HTTP. Suivez les instructions de la procédure précédente pour interrompre les opérations du service Web.

  2. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Utilisez l'argument -s pour réinitialiser la clé symétrique. Aucun autre argument n'est obligatoire :

    Copier le code
    rskeymgmt -s
  3. Redémarrez le service Windows et activez les opérations du service Web.

Suppression du contenu chiffré inutilisable

Si, pour une raison ou pour une autre, vous ne pouvez pas restaurer la clé de chiffrement, le serveur de rapports sera dans l'incapacité totale de déchiffrer les données chiffrées avec cette clé pour les utiliser. Pour que le serveur de rapports puisse fonctionner de nouveau, vous devez supprimer les valeurs chiffrées qui sont actuellement stockées dans la base de données du serveur de rapports et redéfinir manuellement les valeurs dont vous avez besoin.

La suppression des clés de chiffrement efface toutes les informations de clé symétrique de la base de données du serveur de rapports et supprime tout contenu chiffré. Les données non chiffrées sont intactes, seul le contenu chiffré est supprimé. Lorsque vous détruisez les clés de chiffrement, le serveur de rapports se réinitialise automatiquement en ajoutant une nouvelle clé symétrique. Les événements suivants se produisent lorsque vous supprimez des données chiffrées :

  • Les chaînes de connexion des sources de données partagées sont supprimées. Les utilisateurs qui exécutent des rapports reçoivent le message d'erreur suivant : « La propriété ConnectionString n'a pas été initialisée ».

  • Les informations d'identification sont supprimées. Les rapports et les sources de données partagées sont reconfigurées pour utiliser les informations d'identification qui sont demandées.

  • Les rapports basés sur des modèles (et qui font appel à des sources de données partagées configurées à l'aide d'informations d'identification stockées ou non) ne s'exécutent plus.

  • Les abonnements sont désactivés.

Le contenu chiffré qui est supprimé est irrémédiablement perdu. Vous devez spécifier à nouveau des chaînes de connexion et des informations d'identification stockées, puis activer les abonnements.

Vous pouvez utiliser l'outil de configuration de Reporting Services ou l'utilitaire rskeymgmt pour supprimer ces valeurs.

Procédure de suppression des clés de chiffrement (outil de configuration de Reporting Services)

  1. Démarrez l'outil de configuration de Reporting Services et connectez-vous à l'instance de serveur de rapports que vous voulez configurer.

  2. Cliquez sur Clés de chiffrement, puis sur Supprimer. Cliquez sur OK.

  3. Redémarrez le service Windows Report Server. Pour un déploiement évolutif, effectuez cette opération sur toutes les instances de serveurs de rapports.

Procédure de suppression des clés de chiffrement (rskeymmgt)

  1. Exécutez le fichier rskeymgmt.exe localement sur l'ordinateur qui héberge le serveur de rapports. Vous devez utiliser l'argument d'application -d. L'exemple suivant illustre l'argument que vous devez spécifier :

    Copier le code
    rskeymgmt -d
  2. Redémarrez le service Windows Report Server. Pour un déploiement évolutif, effectuez cette opération sur toutes les instances de serveurs de rapports.

Procédure de redéfinition des valeurs chiffrées

  1. Indiquez de nouveau la chaîne de connexion de chaque source de données partagée.

  2. Pour chaque rapport et chaque source de données partagée utilisant des informations d'identification stockées, vous devez retaper le nom d'utilisateur et le mot de passe, puis les enregistrer. Pour plus d'informations, consultez Spécification des informations d'identification et de connexion pour les sources de données de rapport dans la documentation en ligne de SQL Server.

  3. Pour les abonnements pilotés par les données, ouvrez chaque abonnement et retapez les informations d'identification dans la base de données d'abonnement.

  4. Pour les abonnements utilisant des données chiffrées (ce qui comprend l'extension de remise dans le partage de fichiers et toute extension de remise créées par d'autres développeurs qui utilisent le chiffrement), ouvrez chaque abonnement et retapez les informations d'identification. Les abonnements utilisant la remise par messagerie électronique du serveur de rapports n'ont pas recours aux données chiffrées, ils ne sont donc pas concernés par les modifications apportées à la clé.

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement
Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Ajout et suppression de clés de chiffrement pour un déploiement évolutif

Ajout et suppression de clés de chiffrement pour un déploiement évolutif |
 | Voir aussi
Configuration de Reporting Services > Configuration et gestion des clés de chiffrement >

Vous pouvez exécuter Reporting Services dans un modèle de déploiement avec montée en puissance parallèle si vous configurez plusieurs serveurs de rapports pour qu'ils utilisent une base de données de serveur de rapports partagée. L'appartenance d'un serveur de rapports au déploiement évolutif dépend si ce serveur a déposé ou non une clé de chiffrement dans la base de données de serveurs de rapports. Vous pouvez contrôler un déploiement évolutif en ajoutant et en supprimant des clés de chiffrement pour des instances de serveurs de rapports spécifiques. Si vous supprimez des nœuds du déploiement, vous pouvez les supprimer dans n'importe quel ordre. Si vous ajoutez des nœuds à un déploiement, vous devez joindre toutes les nouvelles instances à partir d'un serveur de rapports faisant déjà partie du déploiement.

Utilisation de l'outil de configuration de Reporting Services pour configurer un déploiement évolutif

Le moyen le plus simple de configurer un déploiement évolutif consiste à utiliser l'outil de configuration de Reporting Services. Pour plus d'informations et obtenir des instructions détaillées, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services et Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services).

Utilisation de l'outil Rskeymgmt pour configurer un déploiement évolutif

Initialisez une instance de serveur de rapports à l'aide de l'utilitaire rskeymgmt.exe pour qu'elle utilise une base de données de serveur de rapports partagée. L'ajout d'un serveur de rapports à un déploiement évolutif requiert l'initialisation du serveur de rapports. L'initialisation nécessite des autorisations d'administrateur. Vous devez disposer d'informations d'identification d'administrateur pour l'ordinateur distant qui héberge le serveur de rapports à intégrer au déploiement.

Procédure d'intégration d'un serveur de rapports à un déploiement évolutif (rskeymgmt)

  1. Exécutez rskeymgmt.exe localement sur l'ordinateur hébergeant un serveur de rapports déjà membre du déploiement évolutif.

  2. Utilisez l'argument -j pour rattacher un serveur de rapports à la base de données de serveur de rapports. Utilisez les arguments -m et -n pour spécifier l'instance de serveur de rapports distante à ajouter au déploiement. Utilisez les arguments -u et -v pour spécifier un compte d'administrateur sur l'ordinateur distant. Si vous créez un déploiement évolutif en utilisant plusieurs instances de serveur de rapports sur le même ordinateur, la syntaxe à utiliser est légèrement différente. Pour plus d'informations sur la syntaxe à utiliser, consultez Utilitaire rskeymgmt.

    L'exemple suivant illustre les arguments que vous devez spécifier si vous ajoutez un serveur de rapports distant à un déploiement évolutif (vous pouvez omettre les informations d'identification si vous avez des autorisations d'administrateur sur l'ordinateur distant) :

    Copier le code
    rskeymgmt -j -m <remotecomputer> -n <namedreportserverinstance> -u <administratoraccount> -v <administratorpassword>

Procédure de suppression d'un serveur de rapports intégré à un déploiement évolutif (rskeymgmt)

  1. Ouvrez le fichier rsreportserver.config du serveur de rapports que vous souhaitez supprimer et recherchez l'ID d'installation. Par défaut, ce fichier se trouve dans Program Files\Microsoft SQL Server\MSSQL.n\Reporting Services\ReportServer).

    Si vous installez une instance unique, il n'y aura qu'un seul fichier rsreportserver.config sur l'ordinateur. Si plusieurs instances de Reporting Services sont installées, utilisez la page État du serveur de l'outil de configuration de Reporting Services pour rechercher l'identificateur d'instance (par exemple, MSSQL.2) pour le serveur de rapports que vous souhaitez supprimer. Le nom du dossier où sont stockés les fichiers programmes de l'instance du serveur de rapports est basé sur l'identificateur de l'instance (par exemple, Program Files\Microsoft SQL Server\MSSQL.2).

  2. Exécutez rskeymgmt.exe. Vous pouvez exécuter cet utilitaire sur n'importe quel serveur de rapports intégré à un déploiement évolutif de serveurs de rapports.

  3. Utilisez l'argument -r pour séparer l'instance de serveur de rapports du déploiement évolutif. L'exemple suivant illustre les arguments que vous devez spécifier :

    Copier le code
    rskeymgmt -r <installation ID>

Ces étapes suppriment le serveur de rapports d'un déploiement avec montée en puissance parallèle, mais ne désinstallent pas l'instance Reporting Services sur le serveur de rapports. Après avoir supprimé le serveur de rapports du déploiement avec montée en puissance parallèle, vous pouvez désinstaller Reporting Services du serveur si vous n'avez plus besoin de Reporting Services sur ce serveur. Pour plus d'informations, consultez Procédure : désinstaller une instance existante de SQL Server (programme d'installation) dans la documentation en ligne de SQL Server.

Voir aussi

Concepts

Configuration et gestion des clés de chiffrement
Initialisation d'un serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services |
 | Voir aussi
Configuration de Reporting Services >

Les déploiements avec montée en puissance parallèle sont utilisés pour augmenter l'évolutivité des serveurs de rapports afin de gérer davantage d'utilisateurs simultanés et de plus grandes charges d'exécution de rapport. Ils peuvent également être utilisés pour dédier des serveurs spécifiques à traiter des rapports interactifs ou planifiés. Les déploiements avec montée en puissance parallèle sont constitués de :

  • Plusieurs instances de serveurs de rapports qui partagent une base de données de serveur de rapports unique.

  • Éventuellement, un cluster à charge réseau équilibrée pour répartir la charge utilisateur interactive parmi les instances de serveurs de rapports.

Lorsque vous déployez Reporting Services sur un cluster à équilibrage de la charge réseau, vous devez vous assurer que le nom du serveur virtuel d'équilibrage de la charge réseau est utilisé dans la configuration des URL de serveurs de rapports et que les serveurs sont configurés pour partager le même état d'affichage.

Reporting Services ne participe pas aux clusters Microsoft Cluster Services. Toutefois, vous pouvez créer la base de données du serveur de rapports sur une instance de Moteur de base de données qui fait partie d'un cluster de basculement.

Pour planifier, installer et configurer un déploiement avec montée en puissance parallèle, suivez ces étapes :

  • Consultez Planification d'un déploiement avec montée en puissance parallèle dans la documentation en ligne de SQL Server pour obtenir des indications sur l'utilisation d'un déploiement avec montée en puissance parallèle.

  • Consultez Procédure : installer SQL Server 2008 R2 (programme d'installation) dans la documentation en ligne de SQL Server pour obtenir des instructions relatives à l'installation des instances de serveurs de rapports.

  • Consultez Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services) pour obtenir des instructions sur le partage d'une base de données du serveur de rapports et la jointure des serveurs de rapports avec montée en puissance parallèle.

  • Éventuellement, si vous configurez la montée en puissance parallèle pour une exécution sur un cluster à charge réseau équilibrée, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau pour obtenir des instructions sur la façon de configurer la validation de l'état d'affichage.

Voir aussi

Concepts

URL des fichiers de configuration (Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration de Reporting Services pour l'intégration de SharePoint 2010

Configuration de Reporting Services pour l'intégration de SharePoint 2010 |
 | Voir aussi
Configuration de Reporting Services >

Vous pouvez configurer un déploiement de SQL Server Reporting Services pour fonctionner avec un déploiement de Microsoft SharePoint Foundation 2010 ou Microsoft SharePoint Server 2010. Vous devez effectuer des étapes de configuration sur un serveur de rapports et un déploiement de produit SharePoint pour que les utilisateurs puissent publier des documents de création de rapports dans les bibliothèques SharePoint et obtenir des services de gestion et d'affichage de rapports sur les sites SharePoint. La procédure de configuration établit des informations de connexion au serveur ; par conséquent, il est important d'effectuer les étapes dans l'ordre.

Cette rubrique fournit une vue d'ensemble des étapes de configuration pour chaque serveur. Elle contient les sections suivantes :

  • Vue d'ensemble des étapes de configuration sur un serveur de rapports

  • Vue d'ensemble des étapes de configuration sur un serveur SharePoint

  • Configuration du compte de service

  • Procédure de configuration de l'intégration de serveur

Pour plus d'informations sur les différentes topologies de serveur, consultez Topologies de déploiement pour Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server. Pour une liste complète de rubriques relatives à l'intégration SharePoint dans la documentation en ligne de SQL Server, consultez Comment en savoir plus sur le mode intégré SharePoint.

Vue d'ensemble des étapes de configuration sur un serveur de rapports

Pour configurer un serveur de rapports pour l'intégration SharePoint, vous devez disposer d'un serveur de rapports autonome existant ou d'un déploiement évolutif. Vous devez effectuer les tâches suivantes sur le serveur de rapports :

  1. Créez une base de données de serveur de rapports en mode intégré SharePoint.

    Cela permet de définir des propriétés de serveur sur le serveur de rapports et d'activer un nouveau point de terminaison de gestion du serveur de rapports SOAP qui est utilisé pour le fonctionnement en mode intégré. Utilisez l'outil de configuration de Reporting Services pour créer la base de données.

  2. Pour les déploiements qui incluent une batterie de serveurs SharePoint, installez un serveur Web frontal SharePoint sur le serveur de rapports. Le serveur Web frontal joint le serveur de rapports à une batterie de serveurs SharePoint. L'installation du serveur Web frontal sur le serveur de rapports est nécessaire uniquement si vous déployez le serveur de rapports et l'instance de technologie SharePoint sur des ordinateurs distincts.

  3. Pour les déploiements qui incluent le placement des bases de données SharePoint sur le même ordinateur que le serveur de rapports, configurez le service Report Server pour s'exécuter sous un compte de domaine. Cette étape est nécessaire uniquement si les serveur de rapports et les bases de données d'application sont un même ordinateur et que l'application Web SharePoint se trouve sur un autre ordinateur.

Remarque :
Les produits et technologies SharePoint 2010 dans une configuration de batterie de serveurs requièrent des comptes de domaine pour la configuration du service comme l'intégration des Reporting Services SharePoint.

À propos de la base de données du serveur de rapports

Une base de données de serveur de rapports offre un espace de stockage interne pour une ou plusieurs instances du serveur de rapports. Une base de données du serveur de rapports peut prendre en charge les opérations en mode natif ou en mode d'intégration SharePoint, mais pas les deux. Le contenu de la base de données dépend du mode et n'est pas interchangeable d'un mode de serveur à l'autre. Si vous créez une base de données de serveur de rapports pour prendre en charge le mode intégré SharePoint, vous ne pouvez convertir ni migrer automatiquement la base de données pour qu'elle s'exécute ultérieurement avec une instance du serveur de rapports en mode natif. Une base de données de serveur de rapports est utilisée de plusieurs manières, selon le mode de serveur :

  • Lorsqu'elle est créée pour un fonctionnement en mode natif, la base de données du serveur de rapports est le seul référentiel pour les données persistantes utilisées par le serveur de rapports.

  • Lorsqu'elle est créée en mode intégré SharePoint, la base de données du serveur de rapports contient les propriétés du serveur, des instantanés d'exécution de rapport, un historique des rapports, des définitions d'abonnement et des planifications. Elle contient une copie secondaire des rapports, des modèles de rapports, des sources de données partagées et des ressources afin d'améliorer les performances de traitement sur le serveur. Le stockage principal pour les documents de rapports se trouve dans les bases de données de contenu SharePoint. Pour plus d'informations, consultez Stockage et synchronisation de contenu de serveur de rapports avec des bases de données SharePoint dans la documentation en ligne de SQL Server.

La création d'une base de données de serveur de rapports pour le mode intégré SharePoint est une première étape importante de la configuration du serveur de rapports pour l'intégration SharePoint. Vous pouvez utiliser l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports et configurer la connexion au serveur de rapports. Seul le serveur de rapports se connecte à la base de données du serveur de rapports. L'instance de SharePoint Foundation 2010 ou de SharePoint Server 2010 ne se connecte jamais à la base de données du serveur de rapports et n'extrait jamais de données de cette dernière.

À propos du déploiement de serveur de rapports avec montée en puissance parallèle et du mode intégré SharePoint

Si vous intégrez un déploiement avec montée en puissance parallèle de serveur de rapports à une batterie de serveurs SharePoint, toutes les instances de serveur de rapports qui font partie du déploiement doivent s'exécuter en mode intégré SharePoint. Vous ne pouvez pas avoir une combinaison de modes de serveur dans le même déploiement évolutif. En outre, vous devez créer un point unique d'entrée au déploiement avec montée en puissance parallèle (autrement dit, une URL résolue à une adresse IP virtuelle pour un cluster à équilibrage de charge réseau sur lequel les instances de serveur de rapports sont installées).

À propos des instances de serveur de rapports multiples et du mode intégré SharePoint

Si vous installez plusieurs instances de Reporting Services sur un ordinateur unique, mais que vous configurez uniquement l'une de ces instances pour le mode intégré SharePoint, assurez-vous d'effectuer les opérations suivantes :

  • Assurez-vous que toutes les instances de Reporting Services sont la même version. SQL Server 2008 Reporting Services introduit une version mise à jour du fournisseur Reporting Services Windows Management Instrumentation (WMI). Vous ne pouvez pas avoir SQL Server 2008 Reporting Services et des versions antérieures à SQL Server 2008 Reporting Services sur le même ordinateur. Par conséquent, il est nécessaire que toutes les instances de serveur de rapports exécutent SQL Server 2008 Reporting Services ou version ultérieure, même si vous n'avez pas besoin de fonctionnalités SQL Server 2008 Reporting Services pour toutes les instances.

  • Si vous exécutez le programme d'installation de SQL Server 2008 R2 pour chaque instance de serveur de rapports à différents moments, redémarrez le service WMI après avoir installé la deuxième instance de SQL Server 2008 Reporting Services.

Vue d'ensemble des étapes de configuration sur un serveur SharePoint

Pour configurer l'intégration sur le serveur qui exécute le produit ou la technologie SharePoint, vous devez effectuer les opérations suivantes :

  1. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

    Le complément installe des fichiers programme et des pages d'application, y compris les pages que vous ouvrez dans l'administration centrale pour définir l'URL du serveur de rapports et d'autres paramètres d'intégration. Vous pouvez spécifier des paramètres d'intégration du serveur de rapports pour une batterie de serveurs SharePoint ou une application Web SharePoint indépendante.

  2. Activez la fonctionnalité de serveur de rapports si vous n'avez pas installé le complément sur une collection de site racine.

  3. Utilisez l'Administration centrale de SharePoint pour configurer l'intégration du serveur de rapports. Les paramètres de configuration incluent la spécification d'une URL de serveur de rapports unique, la définition d'un type d'authentification sur les demandes dirigées vers le serveur de rapports et l'accord des autorisations d'accès aux bases de données au compte de service Report Server.

  4. Éventuellement, dans l'Administration centrale de SharePoint, vous pouvez définir des valeurs par défaut de serveur de rapports qui activent l'enregistrement, la création de rapports ad hoc et des limites pour l'historique de rapport et les valeurs de délai d'attente.

Les produits SharePoint peuvent être déployés sous la forme d'une batterie de serveurs ou d'un serveur autonome. Une batterie de serveurs contient un ou plusieurs serveurs virtuels où chaque serveur virtuel est une application Web SharePoint. Un serveur de rapports s'intègre au niveau de la batterie de serveurs. De la perspective de l'intégration de l'espace de stockage, il peut exister une seule base de données de serveur de rapports pour une batterie de serveurs. Vous pouvez utiliser l'administration centrale de SharePoint pour gérer les paramètres d'intégration pour tous les serveurs de la batterie de serveurs.

Chaque application Web SharePoint dans une batterie de serveurs peut être configurée pour utiliser des fournisseurs d'authentification différents. Cela n'affecte en aucune manière l'intégration du serveur de rapports. Le déploiement du serveur de rapports traitera les demandes pour chaque serveur de la batterie de serveurs, quel que soit le fournisseur d'authentification qu'il utilise.

Chaque application Web possède un site de niveau supérieur par défaut. Vous pouvez définir des autorisations de manière différente sur chaque site de niveau supérieur pour modifier la disponibilité des éléments et des opérations du serveur de rapports entre tous les serveurs d'une batterie de serveurs.

Configuration du compte de service

Un serveur de rapports est implémenté comme service Windows unique qui s'exécute sous un compte intégré ou un compte local ou d'utilisateur Windows de domaine. En mode intégré SharePoint, le service doit se connecter aux bases de données de contenu SharePoint avec des autorisations d'écriture et d'exécution. Étant donné que le service se connecte aux bases de données de contenu SharePoint, le compte que vous utilisez pour exécuter le service aura des spécifications différentes selon que des connexions distantes sont utilisées et que la connexion du point de terminaison proxy de l'URL du serveur de rapports utilise la sécurité intégrée de Windows ou le mode Compte approuvé.

Le tableau suivant fournit des recommandations de compte de service pour différents scénarios de déploiement.

Scénario de déploiement Services Bases de données SharePoint Recommandation de compte pour le service Report Server

Serveur unique

Tous les services sont installés sur le même ordinateur

Sur le même ordinateur

N'importe lequel (NetworkService, utilisateur de domaine, utilisateur local, LocalSystem).

Étant donné que les applications se connectent à l'aide d'une connexion de base de données locale, vous pouvez configurer le service pour s'exécuter sous tout type de compte.

Déploiement distribué sur plusieurs ordinateurs

Application Web SharePoint et serveur de rapports installés sur des ordinateurs différents

Sur un troisième ordinateur

-- ou --

Ordinateur serveur SharePoint

Compte d'utilisateur de domaine

-- ou --

NetworkService, mais uniquement si vous ajoutez NT_AUTHORITY\NetworkService au groupe Windows WSS_WPG sur le serveur de rapports. Pour plus d'informations, consultez Dépannage de problèmes de configuration dans la documentation en ligne de SQL Server.

Déploiement distribué sur plusieurs ordinateurs

Application Web SharePoint et serveur de rapports installés sur des ordinateurs différents

Sur l'ordinateur serveur de rapports

Le compte d'utilisateur de domaine est requis, indépendamment de la façon dont le point de terminaison proxy d'URL du serveur de rapports est configuré.

Lorsque les bases de données SharePoint s'exécutent sur un ordinateur distant, l'application Web SharePoint refuse explicitement l'accès aux bases de données des comptes d'ordinateur d'un ordinateur distant. Si le serveur de rapports se trouve sur le même ordinateur que les bases de données SharePoint et si l'un des services s'exécute sous un compte intégré, l'accès lui sera refusé en conséquence. La configuration du service pour qu'il s'exécute en tant que compte d'utilisateur de domaine garantit que le serveur de rapports ne se verra pas refuser l'accès aux bases de données car il s'exécute sous un compte interdit.
Remarque :
La base de données du serveur de rapports n'est pas incluse dans la discussion des spécifications de compte de service pour les connexions de base de données. Cela est dû au fait que seul le serveur de rapports se connecte à la base de données du serveur de rapports.

À propos des configurations de compte de service SharePoint

Les recommandations de compte de service pour SharePoint Foundation 2010 et SharePoint Server 2010 stipulent que pour un déploiement de batterie de serveurs, vous devez exécuter le processus de pool d'applications comme compte d'utilisateur de domaine, et non comme Service réseau. Bien qu'un compte d'utilisateur de domaine soit recommandé, il n'est pas requis. Toutefois, il est important de savoir que si vous configurez une application Web SharePoint pour s'exécuter comme Service réseau et que le serveur de rapports est sur un ordinateur distant, vous rencontrerez des erreurs lors de l'accès aux rapports et aux fonctionnalités de serveur de rapports d'un site SharePoint si le point de terminaison proxy d'URL du serveur de rapports se connecte en mode Compte approuvé. Pour plus d'informations sur les erreurs de serveur qui se produisent lorsque vous déployez cette configuration, consultez Dépannage de problèmes de configuration dans la documentation en ligne de SQL Server.

Pour plus d'informations sur la connexion des comptes de service à une instance de technologie SharePoint, consultez Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server. Pour plus d'informations sur les recommandations relatives aux comptes de service pour un déploiement SharePoint, consultez Planification des comptes administratifs et comptes de service dans la documentation produit de SharePoint.

Procédure de configuration de l'intégration de serveur

La configuration des serveurs pour un fonctionnement intégré requiert plusieurs outils et étapes. Cliquez sur les liens suivants pour lire les instructions relatives à la configuration de l'intégration de serveur dans des scénarios de déploiement spécifiques :

  • Procédure : configurer l'intégration à SharePoint sur un serveur autonome

  • Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Voir aussi

Concepts

Sauvegarde et restauration des clés de chiffrement
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Rubriques d'aide à la configuration de Reporting Services

Rubriques d'aide à la configuration de Reporting Services
Configuration de Reporting Services >

Cette section contient des procédures qui indiquent comment configurer une instance de serveur de rapports à l'aide de l'outil de configuration de Reporting Services.

Dans cette section

Les rubriques de cette section sont organisées en catégories afin que vous puissiez rechercher plus aisément les instructions que vous souhaitez. La première section contient les rubriques pour les tâches de configuration de base pour un serveur de rapports en mode natif. La deuxième section contient les rubriques de configuration avancées. La troisième section contient les rubriques pour configurer un serveur de rapports afin qu'il s'exécute en mode intégré SharePoint.

Configuration de base

Procédure : lancer la configuration de Reporting Services

Indique la procédure à suivre pour démarrer l'outil de configuration de Reporting Services.

Procédure : configurer un compte de service pour Reporting Services

Explique comment spécifier des informations de compte et de mot de passe pour le service Web Report Server.

Procédure : inscrire un nom de principal du service (SPN) pour Report Server

Explique comment enregistrer manuellement un SPN pour un serveur de rapports qui s'exécute sous un compte d'utilisateur de domaine sur un réseau qui utilise l'authentification Kerberos.

Procédure : configurer une URL (configuration de Reporting Services)

Explique comment établir une ou plusieurs URL utilisées pour accéder au service Web Report Server et au Gestionnaire de rapports.

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Indique la procédure à suivre pour créer une base de données du serveur de rapports. Cette étape est nécessaire pour déployer une installation de Reporting Services.

Configuration avancée ou facultative

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services)

Indique la procédure à suivre pour configurer plusieurs serveurs de rapports afin qu'ils partagent une base de données du serveur de rapports.

Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)

Fournit des instructions de configuration d'un serveur de rapports pour la distribution par messagerie.

Procédure : configurer un pare-feu pour accéder à Report Server

Explique comment ouvrir les ports utilisés pour les demandes entrantes et les réponses sortantes d'un serveur de rapports.

Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008

Décrit les étapes supplémentaires requises pour se connecter au Gestionnaire de rapports ou à un serveur de rapports en utilisant http://localhost.

Procédure : configurer un serveur de rapports pour l'administration à distance

Explique comment configurer une instance de serveur de rapports distante afin que vous puissiez vous y connecter et le configurer à partir d'un autre ordinateur.

Procédure : activer ou désactiver les fonctionnalités Reporting Services

Explique comment supprimer les fonctionnalités inutilisées dans une installation Reporting Services.

Procédure : activer les erreurs distantes (configuration de Reporting Services)

Explique comment définir des propriétés de serveur sur un serveur de rapports de façon à retourner des informations supplémentaires concernant les conditions d'erreur qui se produisent sur des serveurs distants.

Intégration SharePoint

Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Explique comment ajouter des fichiers programme SharePoint utilisés pour joindre un serveur de rapports à une batterie de serveurs SharePoint.

Procédure : installer ou désinstaller le complément Reporting Services

Explique comment installer les pages d'application du serveur de rapports, les pages de configuration et l'URL sur un serveur SharePoint.

Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint

Explique comment activer manuellement la fonctionnalité de serveur de rapports pour une collection de sites si la collection de sites racine n'est pas activée.

Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services)

Explique comment créer une base de données de serveur de rapports pour un serveur de rapports qui s'exécute en mode intégré SharePoint.

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint

Fournit des instructions pour configurer l'intégration dans l'administration centrale de SharePoint.

Procédure : configurer l'intégration à SharePoint sur un serveur autonome

Fournit les instructions pas à pas pour installer tous les composants serveur et bases de données d'application sur un ordinateur unique.

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Fournit les instructions pas à pas pour installer les composants serveur sur plusieurs ordinateurs dans un déploiement de serveurs distribué.

Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Explique comment supprimer une instance de serveur de rapports d'un déploiement d'une technologie ou d'une instance SharePoint afin de pouvoir l'exécuter en tant que serveur de rapports en mode natif.

Comment en savoir plus sur le mode intégré SharePoint dans la documentation en ligne de SQL Server

Fournit une liste de rubriques spécifiques au complément Reporting Services pour les technologies SharePoint.


Procédure : lancer la configuration de Reporting Services

Procédure : lancer la configuration de Reporting Services |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Le Gestionnaire de configuration de Reporting Services permet de configurer une installation Reporting Services. Vous pouvez configurer une instance de serveur de rapports locale ou distante tant que vous êtes membre du groupe d'administrateurs local sur le serveur de rapports. Pour pouvoir configurer une instance de serveur de rapports distante et vous y connecter, vous devez permettre aux appels WMI (Windows Management Instrumentation) distants de traverser le Pare-feu Windows. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration à distance dans la documentation en ligne de SQL Server.

Le Gestionnaire de configuration de Reporting Services est spécifique à la version. L'outil de configuration de Reporting Services installé avec cette version de SQL Server ne peut pas être utilisé pour configurer une version antérieure de Reporting Services. Si vous exécutez des versions anciennes et récentes de Reporting Services côte à côte sur le même ordinateur, vous devez utiliser l'outil de configuration Reporting Services fourni avec chaque version pour configurer chaque instance.

Pour lancer la configuration de Reporting Services

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008 R2, puis sur Outils de configuration.

    Si vous souhaitez configurer une instance de serveur de rapports à partir d'une version antérieure de SQL Server, ouvrez le dossier de programme pour cette version. Par exemple, pointez sur Microsoft SQL Server 2005 au lieu de Microsoft SQL Server 2008 R2 pour ouvrir les outils de configuration pour les composants serveur SQL Server 2005.

  2. Cliquez sur Gestionnaire de configuration de Reporting Services. La boîte de dialogue Se connecter à une instance du serveur de rapports s'affiche pour que vous spécifiiez l'instance de serveur de rapports à configurer.

  3. Dans Nom du serveur, spécifiez le nom de l'ordinateur sur lequel est installée l'instance de serveur de rapports. Le nom de l'ordinateur local apparaît par défaut, mais vous pouvez taper le nom d'une instance SQL Server distante si vous souhaitez vous connecter à un serveur de rapports installé sur un ordinateur distant.

  4. Si vous spécifiez un ordinateur distant, cliquez sur Rechercher pour établir une connexion.

  5. Dans Instance du serveur de rapports, sélectionnez l'instance SQL Server Reporting Services que vous souhaitez configurer. Seules les instances de serveur de rapports pour cette version de SQL Server s'affichent dans la liste. Vous ne pouvez pas configurer d'instances de versions antérieures de Reporting Services.

  6. Cliquez sur Connexion.

Voir aussi

Concepts

Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint

Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

La fonctionnalité d'intégration de serveur de rapports est activée dans l'administration centrale de SharePoint après installation du complément Microsoft SQL Server 2008 R2 Reporting Services pour les produits SharePoint. Pour activer la fonctionnalité de serveur de rapports, utilisez les pages Reporting Services dans la page Paramètres du site de l'Administration centrale de SharePoint.

Si la fonctionnalité Reporting Services n'est pas visible dans la liste des fonctionnalités de la collection de site, le Complément Reporting Services n'est pas installé.

Pour vérifier l'installation, consultez la liste des applications installées dans le Panneau de configuration Microsoft Windows. Si le complément Reporting Services est installé, suivez les instructions dans cette rubrique pour activer la fonctionnalité.

Par défaut, le complément Reporting Services est activé pour la collection de sites racine de l'application Web SharePoint locale. Si le site racine n'est pas activé ou si vous n'avez pas de collection de sites définie lorsque le complément Reporting Services est installé, vous devez activer les paramètres d'intégration de serveur de rapports manuellement.

Remarque :
La version SQL Server 2008 R2 Reporting Services et les versions ultérieures du complément pour les produits SharePoint activeront la fonctionnalité d'intégration du serveur de rapports pour toutes les collections de sites existantes lors de l'installation du complément. En outre, la fonctionnalité sera automatiquement active pour les nouvelles collections de sites.

Remarque :
La version SQL Server 2008 R2 Reporting Services et les versions ultérieures du complément pour les produits SharePoint installera deux fonctionnalités que l'on pourra trouver dans la liste des fonctionnalités de la collection de sites. Il s'agit d'une part de l'intégration générale pour la création de rapports et d'autre part d'une fonctionnalité pour les pages d'administration centrales liée à l'intégration Reporting Services.

Pour activer ou désactiver l'intégration Reporting Services sur une collection de sites

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 2010.

  2. Cliquez sur Actions du site.

  3. Cliquez sur Paramètres du site.

  4. Cliquez sur Fonctionnalités de la collection de sites dans le groupe Administration de la collection de sites.

  5. Recherchez Fonctionnalité d'intégration Report Server et Fonctionnalité d'administration centrale du serveur de rapports dans la liste.

  6. Cliquez sur Activer.
Remarque :
Pour désactiver les fonctionnalités, vous pouvez utiliser la même procédure mais cliquez sur Désactiver au lieu d'Activer.

Étapes suivantes

Une fois la fonctionnalité activée, vous pouvez continuer l'intégration de serveur. Pour obtenir des instructions, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Voir aussi

Concepts

Procédure : installer ou désinstaller le complément Reporting Services
Procédure : installer ou désinstaller le complément Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un pare-feu pour accéder à Report Server

Procédure : configurer un pare-feu pour accéder à Report Server |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Les applications du serveur de rapports et les rapports publiés sont accessibles via les URL qui spécifient une adresse IP, un port et un répertoire virtuel. Si le Pare-feu Windows est activé, le port que le serveur de rapports est configuré pour utiliser est très probablement fermé. La présence d'une page Web vierge après la demande d'un rapport ou l'affichage d'une page vierge lorsque vous tentez d'ouvrir le Gestionnaire de rapports à partir d'un ordinateur client distant constituent une indication qu'un port peut être fermé.

Pour ouvrir un port, vous devez utiliser le Pare-feu Windows sur le serveur de rapports. Reporting Services n'ouvrent pas de ports automatiquement ; vous devez effectuer cette étape manuellement.

Par défaut, le serveur de rapports écoute les requêtes HTTP sur le port 80. De ce fait, les instructions suivantes incluent les étapes qui spécifient ce port. Si vous avez configuré les URL du serveur de rapports pour utiliser un autre port, vous devez spécifier ce numéro de port lors des instructions ci-après.

Si vous accédez à des bases de données relationnelles SQL Server sur des ordinateurs externes, ou si la base de données du serveur de rapports se trouve sur une instance SQL Server externe, vous devez ouvrir les ports 1433 et 1434 sur l'ordinateur externe. Pour plus d'informations, consultez Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données dans la documentation en ligne de SQL Server. Pour plus d'informations sur les paramètres par défaut du Pare-feu Windows et pour obtenir une description des ports TCP qui affectent le moteur de base de données, Analysis Services, Reporting Services et Integration Services, consultez Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server dans la documentation en ligne de SQL Server.

Configuration requise

Ces instructions supposent que vous avez déjà configuré le compte de service, créé la base de données du serveur de rapports et configuré les URLS du service Web Report Server et du Gestionnaire de rapports. Pour plus d'informations, consultez Rubriques d'aide à la configuration de Reporting Services.

Vous devez aussi avoir vérifié que le serveur de rapports est accessible via une connexion locale du navigateur Web à l'instance locale du serveur de rapports. Cette étape établit que votre installation est en état de marche. Vous devez vérifier que l'installation est configurée correctement avant de commencer à ouvrir les ports. Pour compléter cette étape sur Windows Vista ou Windows Server 2008, vous devez également avoir ajouté le site du serveur de rapports aux Sites de confiance. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008.

Ouverture des ports dans le Pare-feu Windows

Il existe des instructions distinctes selon les différentes versions du Pare-feu Windows. Si vous utilisez Windows Vista ou Windows Server 2008, recourez aux instructions à la fin de cette rubrique.

Pour ouvrir le port 80 sur Windows Server 2003 SP2 ou Windows XP SP2

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration, puis sur Pare-feu Windows.

  2. Sous l'onglet Exceptions, cliquez sur Ajouter un port.

  3. Dans la zone Nom, tapez ReportServer (TCP sur le port 80).

  4. Dans la zone Numéro de port, tapez 80.

  5. Vérifiez que le protocole TCP est sélectionné.

  6. Cliquez sur Modifier l'étendue.

  7. Cliquez sur Uniquement mon réseau (ou sous-réseau),, puis cliquez sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue.

  9. Redémarrez l'ordinateur.

Pour ouvrir le port 80 sur Windows Vista

  1. Dans le menu Démarrer, cliquez sur Panneau de configuration, cliquez sur Sécurité, puis sur Pare-feu Windows.

  2. Cliquez sur Autoriser un programme via le Pare-feu Windows.

  3. Cliquez sur Continuer.

  4. Sous l'onglet Exceptions, cliquez sur Ajouter un port.

  5. Dans la zone Nom, tapez ReportServer (TCP sur le port 80).

  6. Dans la zone Numéro de port, tapez 80.

  7. Vérifiez que le protocole TCP est sélectionné.

  8. Cliquez sur Modifier l'étendue.

  9. Cliquez sur Uniquement mon réseau (ou sous-réseau),, puis cliquez sur OK.

  10. Cliquez sur OK pour fermer la boîte de dialogue.

  11. Redémarrez l'ordinateur.

Étapes suivantes

Après avoir ouvert le port et avant de confirmer si les utilisateurs distants peuvent accéder au serveur de rapports sur le port que vous ouvrez, vous devez accorder l'accès utilisateur au serveur de rapports à travers les attributions de rôle sur la page d'Accueil et au niveau du site. Vous pouvez ouvrir un port correctement et que les connexions du serveur de rapports échouent si les utilisateurs n'ont pas les autorisations suffisantes. Pour plus d'informations, consultez Procédure : accorder à un utilisateur l'accès à un serveur de rapports (Gestionnaire de rapports) dans la documentation en ligne de SQL Server.

Vous pouvez également vérifier que le port est ouvert correctement en démarrant le Gestionnaire de rapports sur un autre ordinateur. Pour plus d'informations, consultez Procédure : démarrer le Gestionnaire de rapports dans la documentation en ligne de SQL Server.

Voir aussi

Concepts

Configuration du compte de service Report Server
Configuration des URL de Report Server
Création d'une base de données de serveur de rapports
Configuration du compte de service Report Server
Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services)

Procédure : configurer un serveur de rapports pour la remise par messagerie (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Reporting Services fournit une extension de remise du courrier électronique qui permet aux utilisateurs de s'abonner aux rapports remis par la suite aux boîtes aux lettres électroniques. L'extension de remise du courrier électronique de Report Server doit être configurée avant de pouvoir être utilisée. Pour configurer un serveur de rapports pour la remise du courrier électronique, procédez comme suit :

  • Passerelle ou serveur de protocole SMTP (Simple Mail Transfer Protocol).

  • Compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP. Selon les stratégies de sécurité en vigueur dans votre organisation, vous devrez peut-être demander une autorisation préalable pour envoyer du courrier électronique à partir d'un serveur SMTP d'entreprise. Pour plus d'informations, contactez votre administrateur système ou réseau.

  • Le service Report Server doit avoir les autorisations Send As sur le serveur SMTP.

Pour configurer la messagerie électronique du serveur de rapports, vous pouvez utiliser l'outil de configuration de Reporting Services ou modifier les fichiers de configuration. L'outil de configuration de Reporting Services fournit les paramètres minimaux requis par le serveur de rapports. Si vous souhaitez utiliser le service SMTP local ou spécifier des paramètres avancés, modifiez plutôt les fichiers de configuration.

Si vous souhaitez évaluer la fonctionnalité de messagerie électronique du serveur de rapports ou résoudre un problème d'abonnement ou de remise, vous pouvez configurer la messagerie électronique du serveur de rapports de façon à utiliser un service SMTP local qui remet les rapports à un dossier local. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique.

Si vous ne configurez pas un serveur de rapports pour une remise par messagerie ou si vous n'avez pas accès à un serveur SMTP, vous pouvez utiliser l'extension de remise par partage de fichiers pour distribuer les rapports dans des dossiers partagés accessibles par le biais des connexions réseau.

Pour configurer la messagerie électronique du serveur de rapports à l'aide de l'outil de configuration de Reporting Services

  1. Vérifiez que le service Report Server Windows a des autorisations Send As sur le serveur SMTP.

  2. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports.

  3. Sur la page Paramètres de messagerie, entrez le nom du serveur SMTP. Il peut s'agir d'une adresse IP, du nom UNC d'un ordinateur sur l'intranet de votre entreprise ou d'un nom de domaine complet.

  4. Dans Adresse de l'expéditeur, tapez le nom d'un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  5. Cliquez sur Appliquer.

Pour configurer un service SMTP distant pour le serveur de rapports

  1. Vérifiez que le service Report Server Windows a des autorisations Send As sur le serveur SMTP.

  2. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  3. Vérifiez que <UrlRoot> est paramétré à l'adresse URL du serveur de rapports. Cette valeur est définie lorsque vous configurez le serveur de rapports et elle devrait normalement être déjà définie. Si elle n'est pas définie, tapez l'adresse URL du serveur de rapports.

  4. Dans la section Remise, recherchez <ReportServerEmail>.

  5. Dans <SMTPServer>, tapez le nom du serveur SMTP. Il peut s'agir d'une adresse IP, du nom UNC d'un ordinateur sur l'intranet de votre entreprise ou d'un nom de domaine complet.

  6. Vérifiez que <SendUsing> a la valeur 2. Si la valeur est différente, le serveur de rapports n'est pas configuré pour utiliser un service SMTP distant.

  7. Dans <From>, tapez le nom d'un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  8. Enregistrez le fichier.

    Le serveur de rapports utilise automatiquement les nouveaux paramètres ; il n'est pas nécessaire de redémarrer le service. Vous pouvez spécifier des paramètres SMTP supplémentaires pour configurer comment le serveur SMTP est utilisé pour la remise par messagerie du serveur de rapports. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique et Fichier de configuration RSReportServer dans la documentation en ligne de SQL Server.

Pour configurer un service SMTP local pour le serveur de rapports

  1. Dans le Panneau de configuration, cliquez sur Ajout/Suppression de programmes.

  2. Cliquez sur Ajouter/Supprimer des composants Windows pour démarrer l'Assistant Composants Windows.

  3. Sélectionnez Serveur d'applications et cliquez sur Détails.

  4. Sélectionnez Services Internet (IIS), puis cliquez sur Détails.

  5. Activez la case à cocher Service SMTP, puis cliquez sur OK.

  6. Dans l'Assistant Composants Windows, cliquez sur Suivant. Cliquez sur Terminer.

  7. Vérifiez que le service s'exécute dans la console Services.

  8. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  9. Vérifiez que <UrlRoot> est paramétré à l'adresse URL du serveur de rapports. Cette valeur est définie lorsque vous configurez le serveur de rapports et elle devrait normalement être déjà définie. Si elle n'est pas définie, tapez l'adresse URL du serveur de rapports.

  10. Dans la section Remise, recherchez <ReportServerEmail>.

  11. Dans <SMTPServer>, effacez les valeurs pour ce paramètre, mais ne supprimez pas les balises.

  12. Affectez à <SendUsing> la valeur 1. Si la valeur est différente, le serveur de rapports n'est pas configuré pour utiliser un service SMTP local.

  13. Définissez <SMTPServerPickupDirectory> sur un dossier de lecteur local.

  14. Définissez <From> sur un compte qui a l'autorisation d'envoyer des messages électroniques à partir du serveur SMTP.

  15. Enregistrez le fichier.

Voir aussi

Concepts

Configuration d'un Report Server pour la remise du courrier électronique
Configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008

Procédure : configurer un serveur de rapports pour l'administration locale sur Windows Vista et Windows Server 2008 |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Le déploiement de Reporting Services sur Windows Vista et de Windows Server 2008 nécessite des étapes de configuration supplémentaires si vous souhaitez administrer une instance de serveur de rapports localement. Windows Vista et Windows Server 2008 restreignent tous deux l'emploi excessif d'autorisations élevées en supprimant les autorisations d'administrateur lors de l'accès aux applications. Comme le système d'exploitation supprime les autorisations, les membres du groupe Administrateurs local exécutent la plupart des applications comme s'ils utilisaient le compte Utilisateur standard.

Même si cette solution améliore la sécurité globale de votre système, elle vous empêche d'utiliser les attributions de rôle prédéfinies et intégrées que Reporting Services crée pour les administrateurs locaux. Toutefois, avec une configuration supplémentaire de votre part, vous pouvez gérer efficacement le contenu du serveur de rapports et les opérations utilisant les autorisations d'utilisateur standard en procédant comme suit :

  • Ajoutez les URL Reporting Services aux sites approuvés. Par défaut, Internet Explorer 7.0 sur Windows Vista et Windows Server 2008 s'exécute en mode protégé, fonctionnalité qui empêche les demandes du navigateur d'atteindre les processus globaux qui s'exécutent sur le même ordinateur. Vous pouvez désactiver le mode protégé pour les applications du serveur de rapports en les ajoutant comme Sites de confiance.

  • Créez les attributions de rôle qui vous accordent en tant qu'administrateur du serveur de rapports l'autorisation de gérer le contenu et les opérations sans devoir utiliser la fonctionnalité Exécuter en tant qu'administrateur sur Internet Explorer. En créant les attributions de rôle pour votre compte d'utilisateur Windows, vous accédez à un serveur de rapports avec les autorisations Gestionnaire de contenu et Administrateur système via les attributions de rôle explicites qui remplacent les attributions de rôle prédéfinies et intégrées que Reporting Services crée pour les administrateurs locaux.

Cette rubrique explique comment configurer le serveur de rapports pour l'administration locale à l'issue de l'installation et de la configuration des composants du serveur de rapports. Si vous n'avez pas encore installé ou configuré le serveur de rapports, consultez Procédure : installer SQL Server 2008 R2 (programme d'installation) dans la documentation en ligne de SQL Server et Rubriques d'aide à la configuration de Reporting Services. Pour plus d'informations sur les fonctionnalités du Contrôle de compte d'utilisateur (UAC) et sur la façon de se connecter au moteur de base de données avec les autorisations d'administrateur, consultez Procédure : Se connecter à SQL Server depuis Windows Vista dans la documentation en ligne de SQL Server.

Remarque :
Si vous déployez Reporting Services sur Windows Vista ou Windows Server 2008, veillez bien à ouvrir le port 80 dans le Pare-feu Windows pour autoriser l'accès au serveur de rapports. Pour obtenir des instructions, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

Pour configurer l'administration locale d'un serveur de rapports sur Windows Vista et Windows Server 2008

  1. Ouvrez une fenêtre du navigateur avec les autorisations Exécuter en tant qu'administrateur. Dans le menu Démarrer, cliquez sur Tous les programmes, cliquez avec le bouton droit sur Internet Explorer et sélectionnez Exécuter en tant qu'administrateur.

  2. Cliquez sur Autoriser pour continuer.

  3. Dans l'adresse URL, entrez l'URL du Gestionnaire de rapports. Pour obtenir des instructions, consultez Procédure : démarrer le Gestionnaire de rapports dans la documentation en ligne de SQL Server.

  4. Cliquez sur Outils.

  5. Cliquez sur Options Internet.

  6. Cliquez sur Sécurité.

  7. Cliquez sur Sites de confiance.

  8. Cliquez sur Sites.

  9. Ajoutez http://<nom_serveur>.

  10. Désactivez la case à cocher Nécessite la certification du serveur (https:) pour tous les sites dans cette zone si vous n'utilisez pas HTTPS pour le site par défaut.

  11. Cliquez sur Ajouter.

  12. Cliquez sur OK.

  13. Dans le Gestionnaire de rapports, sur la page d'accueil, cliquez sur Propriétés.

  14. Cliquez sur Nouvelle attribution de rôle.

  15. Tapez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

  16. Sélectionnez Gestionnaire de contenu.

  17. Cliquez sur OK.

  18. Cliquez sur Paramètres du site dans l'angle supérieur de la page d'accueil.

  19. Cliquez sur Configurer la sécurité au niveau du site.

  20. Cliquez sur Nouvelle attribution de rôle.

  21. Tapez votre compte d'utilisateur Windows selon le format : <domaine>\<utilisateur>.

  22. Sélectionnez Administrateur système.

  23. Cliquez sur OK.

  24. Fermez le Gestionnaire de rapports.

  25. Ouvrez à nouveau le Gestionnaire de rapports dans Internet Explorer, sans utiliser Exécuter en tant qu'administrateur.

Utilisation de Business Intelligence Development Studio sur Windows Vista et Windows Server 2008

Si vous avez installé Business Intelligence Development Studio sur Windows Vista ou Windows Server 2008, vous rencontrerez des problèmes de compatibilité avec l'environnement Visual Studio lors de l'utilisation des outils de conception. Si vous souhaitez ouvrir une solution ou un projet existant, ou publiez des éléments du Concepteur de rapports ou du Générateur de modèles sur un serveur de rapports, vous devez ouvrir Business Intelligence Development Studio avec les autorisations élevées :

  1. Dans le menu Démarrer, cliquez sur Tous les programmes, sur SQL Server 2008, cliquez avec le bouton droit sur Business Intelligence Development Studio, puis cliquez sur Exécuter en tant qu'administrateur.

  2. Cliquez sur Continuer.

  3. Cliquez sur Exécuter le programme.

Vous devez maintenant être en mesure de déployer les rapports et autres éléments sur un serveur de rapports. Si vous n'avez pas les autorisations suffisantes, vous rencontrerez des erreurs telles que celles-ci :

  • Accès refusé lorsque vous essayez d'ouvrir un projet existant.

  • Échec de connexion lorsque vous configurez une connexion de la source de données à une source de données partagée.

  • Lors de l'utilisation de l'Assistant Serveur de rapports pour créer un rapport, vous obtenez une erreur d'échec de connexion lorsque l'Assistant tente de se connecter à la source de données externe qui fournit les données au rapport.

Les utilisateurs SQL Server Management Studio doivent utiliser les autorisations Exécuter en tant qu'administrateur pour créer les connexions des utilisateurs qui administrent les bases de données sur le serveur. Pour plus d'informations sur les conditions requises pour les autorisations élevées de Management Studio, consultez Procédure : Se connecter à SQL Server depuis Windows Vista dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Concepts

Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un serveur de rapports pour l'administration à distance

Procédure : configurer un serveur de rapports pour l'administration à distance |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Dans Reporting Services, vous pouvez configurer des instances de serveur de rapports localement ou à distance. Pour configurer une instance de serveur de rapports à distance, vous pouvez faire appel à l'outil de configuration de Reporting Services ou bien écrire un code personnalisé qui utilise le fournisseur WMI (Windows Management Instrumentation) de Reporting Services. L'outil de configuration de Reporting Services offre une interface graphique avec le fournisseur WMI pour vous permettre de configurer un serveur de rapports sans avoir à écrire du code. Lorsque vous démarrez l'outil, vous pouvez spécifier un serveur distant auquel vous connecter.

Avant de pouvoir utiliser l'outil pour configurer un serveur de rapports distant, vous devez suivre les instructions de cette rubrique pour activer les ports du Pare-feu Windows, les connexions à distance et les demandes WMI distantes.

Une configuration appropriée vous aide à éviter l'erreur suivante :

The machine could not be found.

"The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)".

Configuration requise

Pour cela, vous devez ouvrir une session localement et être membre du groupe Administrateurs local. Vous ne pouvez pas modifier les paramètres du pare-feu Windows d'un ordinateur distant sur une connexion distante.

Si vous souhaitez activer l'administration à distance pour un utilisateur non-administrateur, vous devez accorder des autorisations d'activation à distance DCOM (Distributed Component Object Model) au compte. Les instructions de configuration du serveur pour un accès non-administrateur sont fournies dans cette rubrique.

Certaines organisations disposent de stratégies de groupe qui empêchent l'administration serveur à distance pour certains systèmes d'exploitation ou certains utilisateurs. Avant de commencer à modifier les paramètres du pare-feu, vérifiez auprès de votre administrateur réseau si des restrictions s'appliquent dans le cadre de l'administration à distance.

Pour plus d'informations, consultez Connecting Through Windows Firewall dans la documentation du kit de développement Platform SDK sur MSDN.

Tâches

Les tâches qui activent la configuration de serveur de rapports à distance incluent les éléments suivants :

  • Activer les ports du Pare-feu Windows afin d'autoriser les demandes sur les ports utilisés par le serveur de rapports et par l'instance du moteur de base de données SQL Server.

  • Autoriser les connexions distantes à l'instance du moteur de base de données qui héberge la base de données du serveur de rapports. Une connexion distante est nécessaire pour la configuration de la connexion à la base de données du serveur de rapports et la gestion des clés de chiffrement.

  • Activer les demandes WMI distantes pour franchir le Pare-feu Microsoft Windows.

  • Si vous configurez un serveur de rapports distant pour l'administration par un utilisateur non-administrateur, vous devez définir les autorisations DCOM pour activer l'accès WMI distant à un compte d'utilisateur Windows standard. Du fait que WMI utilise DCOM en tant que moyen de transport pour les appels distants, vous devez définir les autorisations DCOM afin que les utilisateurs non connectés en tant qu'administrateur local puissent configurer le serveur.

  • Si vous configurez un serveur de rapports distant pour l'administration par un utilisateur non-administrateur, vous devez également définir les autorisations WMI sur l'espace de noms WMI du serveur de rapports. Par défaut, tous les membres du groupe Administrateurs local ont accès à l'espace de noms WMI du serveur de rapports. Pour accorder un droit d'accès aux personnes qui ne sont pas administrateurs, vous devez définir des autorisations.

Les instructions relatives à l'exécution de ces tâches sont fournies dans cette rubrique.

Pour ouvrir les ports du Pare-feu Windows

  1. Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données.

  2. Procédure : configurer un pare-feu pour accéder à Report Server.

Pour configurer les connexions distantes à la base de données du serveur de rapports

  1. Cliquez sur Démarrer, pointez sur Programmes, sur Microsoft SQL Server 2008 R2 et sur Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.

  2. Dans le volet gauche, développez Configuration du réseau SQL Server, puis cliquez sur Protocoles pour l'instance de SQL Server.

  3. Dans le volet d'informations, activez les protocoles TCP/IP et Canaux nommés, puis redémarrez le service SQL Server.

Pour activer l'administration à distance dans le pare-feu Windows

  1. Ouvrez une session en tant qu'administrateur local sur l'ordinateur où vous souhaitez activer l'administration à distance.

  2. Si le serveur de rapports s'exécute sur Windows Vista, cliquez avec le bouton droit sur Invite de commandes et sélectionnez Exécuter en tant qu'administrateur. Pour d'autres systèmes d'exploitation, ouvrez une fenêtre d'invite de commandes.

  3. Exécutez la commande suivante :

    Copier le code
    netsh.exe firewall set service type=REMOTEADMIN mode=ENABLE scope=ALL

    Vous pouvez spécifier différentes options pour l'étendue. Pour plus d'informations, consultez la documentation produit du pare-feu Windows.

  4. Vérifiez que l'administration à distance est activée. Vous pouvez exécuter la commande suivante pour afficher l'état :

    Copier le code
    netsh.exe firewall show state

  5. Redémarrez l'ordinateur.

Pour définir les autorisations DCOM en vue d'activer l'accès WMI à distance pour les non-administrateurs

  1. Dans le menu Démarrer, pointez sur Outils d'administration, puis cliquez sur Services de composants.

    Pour Windows Vista, dans le menu Démarrer, cliquez sur Tous les programmes, cliquez sur Exécuter, puis entrez mmc comexp.msc.

  2. Ouvrez le dossier Services de composants.

  3. Ouvrez le dossier Ordinateurs.

  4. Sélectionnez Poste de travail.

  5. Dans le menu Action, sélectionnez Propriétés.

  6. Cliquez sur Sécurité COM.

  7. Sous Autorisations d'exécution et d'activation, cliquez sur Modifier les limites.

  8. Si votre nom n'apparaît pas dans la boîte de dialogue Autorisation d'exécution, cliquez sur Ajouter.

  9. Tapez le nom de votre compte d'utilisateur, puis cliquez sur OK.

  10. Dans la zone Autorisation pour <Utilisateur ou groupe>, dans la colonne Autoriser, sélectionnez Exécution à distance et Activation à distance, puis cliquez sur OK.

Pour définir les autorisations sur l'espace de noms WMI du rapport de serveurs pour les non-administrateurs

  1. Dans le menu Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.

  2. Ouvrez le dossier Services et applications.

  3. Cliquez avec le bouton droit sur Contrôle WMI, puis sélectionnez Propriétés.

  4. Cliquez sur Sécurité.

  5. Ouvrez le dossier Root.

  6. Ouvrez le dossier Microsoft.

  7. Ouvrez le dossier SQLServer.

  8. Ouvrez le dossier ReportServer.

  9. Ouvrez le dossier de l'instance. Si vous avez installé l'instance par défaut, le dossier est MSSQLSERVER.

  10. Ouvrez le dossier v10.

  11. Sélectionnez le dossier Admin, puis cliquez sur Sécurité.

  12. Cliquez sur Ajouter, puis tapez le compte d'utilisateur que vous utiliserez pour gérer le serveur.

  13. Dans la colonne Autoriser, sélectionnez Activer le compte, Appel à distance autorisé et Sécurité de lecture, puis cliquez sur OK.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services)

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

La fonctionnalité Reporting Services prend en charge un modèle de déploiement avec montée en puissance parallèle qui vous permet d'exécuter plusieurs instances de serveur de rapports partageant une base de données de serveur de rapports unique.

Pour créer un déploiement avec montée en puissance parallèle, vous devez utiliser le programme d'installation et l'outil de configuration de Reporting Services.

  • Utilisez le programme d'installation pour installer chaque instance de serveur de rapports qui sera jointe au déploiement avec montée en puissance parallèle.

  • Utilisez l'outil de configuration de Reporting Services pour connecter chaque serveur de rapports à la base de données partagée. Vous ne pouvez connecter et configurer qu'un seul serveur de rapports à la fois.

  • Utilisez l'outil de configuration de Reporting Services pour procéder au déploiement avec montée en puissance parallèle en joignant de nouvelles instances de serveur de rapports à la première instance déjà connectée à la base de données de serveur de rapports.

Pour éviter des erreurs de compatibilité de base de données lorsque vous connectez les instances du serveur à la base de données partagée, assurez-vous que toutes les instances soient de la même version. Par exemple, si vous créez la base de données du serveur de rapports à l'aide d'une instance du serveur de rapports SQL Server 2008, l'édition de toutes les autres instances du même déploiement doit également être SQL Server 2008. Pour plus d'informations, consultez Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services.

Les instructions suivantes expliquent comment configurer un déploiement avec montée en puissance parallèle de serveur de rapports à deux nœuds. Répétez les étapes décrites dans cette rubrique pour ajouter des nœuds de serveur de rapports supplémentaires au déploiement.

Si vous prévoyez d'héberger le déploiement avec montée en puissance parallèle sur un cluster à charge réseau équilibrée, vous devez configurer le cluster avant de configurer le déploiement avec montée en puissance parallèle. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau.

Pour installer une instance de SQL Server en vue d'héberger les bases de données du serveur de rapports

  1. Installez une instance de SQL Server sur un ordinateur qui hébergera les bases de données du serveur de rapports. Au minimum, installez le moteur de base de données et Reporting Services.

  2. Si nécessaire, activez le serveur de rapports pour les connexions distantes. Certaines versions de SQL Server n'autorisent pas les connexions TCP/IP et Canaux nommés distantes par défaut. Pour déterminer si les connexions distantes sont autorisées ou non, utilisez l'outil Gestionnaire de configuration SQL Server et vérifiez les paramètres de configuration réseau de l'instance cible. Si l'instance distante est également une instance nommée, vérifiez que le service SQL Server Browser est activé et en cours d'exécution sur le serveur cible. SQL Server Browser fournit le numéro de port utilisé pour se connecter à l'instance nommée.

Pour installer la première instance du serveur de rapports

  1. Installez la première instance du serveur de rapports faisant partie du déploiement. Lorsque vous installez Reporting Services, choisissez l'option Installer mais ne pas configurer le serveur dans la page Options d'installation du serveur de rapports.

  2. Démarrez l'outil de configuration de Reporting Services.

  3. Configurez l'URL de service Web Report Server, l'URL du Gestionnaire de rapports et la base de données du serveur de rapports. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports dans la documentation en ligne de SQL Server.

  4. Vérifiez le fonctionnement du serveur de rapports. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services dans la documentation en ligne de SQL Server.

Pour installer et configurer la deuxième instance du serveur de rapports

  1. Exécutez le programme d'installation pour installer une deuxième instance de Reporting Services sur un ordinateur différent ou comme instance nommée sur le même ordinateur. Lorsque vous installez Reporting Services, choisissez l'option Installer mais ne pas configurer le serveur dans la page Options d'installation du serveur de rapports.

  2. Démarrez l'outil de configuration de Reporting Services et connectez-vous à la nouvelle instance que vous venez d'installer.

  3. Connectez le serveur de rapports à la même base de données que celle utilisée pour la première instance de serveur de rapports.

    1. Cliquez sur Base de données pour ouvrir la page Base de données.

    2. Cliquez sur Modifier la base de données.

    3. Cliquez sur Choisir une base de données de serveur de rapports existante.

    4. Tapez le nom de serveur de l'instance du moteur de base de données SQL Server qui héberge la base de données du serveur de rapports que vous voulez utiliser. Vous devez spécifier le serveur auquel vous vous êtes connecté lors de la procédure précédente.

    5. Cliquez sur Tester la connexion, puis cliquez sur Suivant.

    6. Dans la Base de données du serveur de rapports, sélectionnez la base de données que vous avez créée pour le premier serveur de rapports, puis cliquez sur Suivant. Le nom par défaut est ReportServer. Ne sélectionnez pas ReportServerTempDB ; il est utilisé uniquement pour stocker les données temporaires lors du traitement des rapports. Si la liste de bases de données est vide, répétez les quatre étapes précédentes pour établir une connexion au serveur.

    7. Dans la page Informations d'identification, sélectionnez le type de compte et les informations d'identification que le serveur de rapports utilisera pour se connecter à la base de données du serveur de rapports. Vous pouvez utiliser les mêmes informations d'identification que la première instance du serveur de rapports, ou des informations d'identification différentes. Cliquez sur Suivant.

    8. Cliquez sur Résumé et cliquez sur Terminer.

  4. Configurez l'URL du service Web Report Server. Ne testez pas encore l'URL. Elle ne sera pas résolue tant que le serveur de rapports est joint au déploiement avec montée en puissance parallèle.

  5. Configurez l'URL du Gestionnaire de rapports. Ne testez pas encore l'URL ou essayez de vérifier le déploiement. Le serveur de rapports ne sera pas disponible tant que le serveur de rapports n'est pas joint au déploiement avec montée en puissance parallèle.

Pour joindre la deuxième instance de serveur de rapports au déploiement avec montée en puissance parallèle

  1. Ouvrez l'outil de configuration de Reporting Services, puis reconnectez-vous à la première instance du serveur de rapports. Le premier serveur de rapports étant déjà initialisé pour les opérations de chiffrement réversible ; il est utilisé pour joindre de nouvelles instances du serveur de rapports au déploiement avec montée en puissance parallèle.

  2. Cliquez sur Déploiement avec montée en puissance parallèle pour ouvrir la page Déploiement avec montée en puissance parallèle. Vous devez voir deux entrées, l'une pour chaque instance de serveur de rapports connectée à la base de données du serveur de rapports. La première instance de serveur de rapports doit être jointe. Le deuxième serveur de rapports doit être en attente de rattachement. Si vous ne voyez pas de telles entrées pour votre déploiement, vérifiez que vous êtes connecté au premier serveur de rapports qui est déjà configuré et initialisé pour utiliser la base de données du serveur de rapports.

    Capture d'écran partielle de la page de déploiement avec montée en puissance parallèle

  3. Dans la page Déploiement avec montée en puissance parallèle, sélectionnez l'instance de serveur de rapports qui attend pour joindre le déploiement et cliquez sur Ajouter le serveur.

  4. Vous devez maintenant être en mesure de vérifier que les deux instances de serveur de rapports sont opérationnelles. Pour vérifier la deuxième instance, vous pouvez utiliser l'outil de configuration de Reporting Services pour vous connecter au serveur de rapports et cliquer sur l'URL du service Web ou l'URL du Gestionnaire de rapports.

Si vous envisagez d'exécuter les serveurs de rapports dans un cluster de serveurs avec équilibrage de charge, une configuration supplémentaire est requise. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)
Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)
Procédure : lancer la configuration de Reporting Services

Concepts

Configuration des URL de Report Server
Configuration d'une connexion de base de données de serveur de rapports
Ajout et suppression de clés de chiffrement pour un déploiement évolutif
Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau

Procédure : configurer un serveur de rapports sur un cluster avec équilibrage de la charge réseau |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez la montée en puissance parallèle du serveur de rapports en vue de son exécution sur un cluster avec équilibrage de la charge réseau (NLB, Network Load Balancing), vous devez effectuer les opérations suivantes :

  • S'assurer que le cluster avec équilibrage de la charge réseau est accessible via un nom de serveur virtuel mappé avec l'adresse IP du serveur virtuel. Un nom de serveur virtuel est nécessaire pour configurer un point d'entrée unique au cluster avec équilibrage de la charge réseau. Lorsque vous configurerez une URL pour chaque instance du serveur de rapports, vous spécifierez le nom du serveur virtuel en tant qu'hôte.

  • Configurez la validation de l'état d'affichage pour prendre en charge la consultation des rapports interactifs. Les rapports interactifs sont en général restitués à plusieurs reprises au cours d'une session mono-utilisateur afin de permettre la visualisation de données nouvelles ou différentes en réponse aux actions de l'utilisateur. Configurer la validation de l'état d'affichage assure la continuité au cours de la session utilisateur quel que soit le serveur de rapports qui répond à la demande réelle.

Reporting Services ne fournit pas de fonctionnalités pour l'équilibrage de charge d'un déploiement avec montée en puissance parallèle ou pour définir un point unique d'accès via une URL partagée. Vous devez implémenter une solution logicielle ou matérielle distincte pour la solution de cluster avec équilibrage de la charge réseau afin de prendre en charge un déploiement avec montée en puissance parallèle de Reporting Services.

Vous pouvez installer Reporting Services sur les nœuds qui font déjà partie d'un cluster avec équilibrage de la charge réseau ou configurer d'abord un déploiement avec montée en puissance parallèle, puis installer le logiciel de cluster.

Étapes pour le déploiement du serveur de rapports sur un cluster avec équilibrage de la charge réseau

Appuyez-vous sur les indications suivantes pour installer et configurer votre déploiement :

Étape Description Informations complémentaires

1

Avant d'installer Reporting Services sur les nœuds de serveurs d'un cluster avec équilibrage de la charge réseau, vérifiez les spécifications du déploiement avec montée en puissance parallèle.

Planification d'un déploiement avec montée en puissance parallèle dans la documentation en ligne de SQL Server

2

Configurez le cluster avec équilibrage de la charge réseau et vérifiez son bon fonctionnement.

Veillez à mapper un nom d'en-tête de l'hôte à l'adresse IP du serveur virtuel du cluster avec équilibrage de la charge réseau. Le nom d'en-tête de l'hôte est utilisé dans l'URL du serveur de rapports et présente l'avantage d'être plus facile à retenir et à taper qu'une adresse IP.

Pour plus d'informations, consultez la documentation Windows Server correspondant à la version du système d'exploitation Windows que vous exécutez.

4

Installer Reporting Services en mode fichiers uniquement sur les nœuds qui font déjà partie d'un cluster avec équilibrage de la charge réseau et configurer les instances du serveur de rapports pour un déploiement avec montée en puissance parallèle.

La montée en puissance parallèle que vous configurez ne répond pas aux demandes adressées à l'IP du serveur virtuel. La configuration de la montée en puissance parallèle pour l'utilisation de l'IP du serveur virtuel intervient à un stade ultérieur, après la configuration de la validation de l'état d'affichage.

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services)

5

Configurez la validation de l'état d'affichage.

Pour de meilleurs résultats, effectuez cette étape après avoir configuré le déploiement avec montée en puissance parallèle et avant de configurer les instances du serveur de rapports pour l'utilisation de l'IP du serveur virtuel. En configurant d'abord la validation de l'état d'affichage, vous pouvez éviter les exceptions sur l'échec de la validation de l'état quand les utilisateurs tentent d'accéder aux rapports interactifs.

Comment configurer la validation de l'état d'affichage dans cette rubrique.

6

Configurer Hostname et UrlRoot pour utiliser l'adresse IP de serveur virtuel du cluster avec équilibrage de la charge réseau.

Comment configurer Hostname et UrlRoot dans cette rubrique.

7

Vérifiez que les serveurs sont accessibles via le nom d'hôte que vous avez spécifié.

Vérifiez l'accès au serveur de rapports dans cette rubrique.

Comment configurer la validation de l'état d'affichage

Pour exécuter un déploiement avec montée en puissance parallèle sur un cluster avec équilibrage de la charge réseau, vous devez configurer la validation de l'état d'affichage afin que les utilisateurs puissent consulter les rapports HTML interactifs. Vous devez accomplir ces tâches pour le serveur de rapports et pour le Gestionnaire de rapports.

La validation de l'état d'affichage est contrôlée par ASP.NET. Par défaut, la validation de l'état d'affichage est activée et utilise l'identité du service Web pour effectuer la validation. Toutefois, dans un scénario de cluster avec équilibrage de la charge réseau, il existe plusieurs instances de services et plusieurs identités de services Web qui s'exécutent sur différents ordinateurs. L'identité de service étant différente pour chaque nœud, vous ne pouvez pas vous appuyer sur une seule identité de processus pour effectuer la validation.

Pour contourner ce problème, vous pouvez générer une clé de validation arbitraire pour prendre en charge la validation de l'état d'affichage, puis configurer manuellement chaque nœud de serveur de rapports de manière à ce qu'il utilise la même clé. Vous pouvez utiliser n'importe quelle séquence hexadécimale générée de façon aléatoire. L'algorithme de validation (tel que SHA1) détermine la longueur que doit avoir la séquence hexadécimale.

  1. Générez une clé de validation et clé de déchiffrement en utilisant les fonctionnalités de création automatique fourni par le .NET Framework. À la fin, vous devez avoir une entrée <machineKey> unique que vous pouvez coller dans le fichier Web.config pour chaque instance du Gestionnaire de rapports dans le déploiement avec montée en puissance parallèle.

    L'exemple suivant illustre la valeur que vous devez obtenir. Ne copiez pas cet exemple dans vos fichiers de configuration ; les valeurs de clé ne sont pas valides.

    Copier le code
    <machineKey validationKey="123455555" decryptionKey="678999999" validation="SHA1" decryption="AES"/>
  2. Ouvrez le fichier Web.config du Gestionnaire de rapports, puis, dans la section <system.web>, collez l'élément <machineKey> que vous avez généré. Par défaut, le fichier Web.config du Gestionnaire de rapports se trouve dans \Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportManager\Web.config.

  3. Enregistrez le fichier.

  4. Répétez l'étape précédente pour chaque serveur de rapports impliqué dans le déploiement avec montée en puissance parallèle.

  5. Vérifiez que tous les fichiers Web.Config des dossiers \Reporting Services\ReportManager contiennent des éléments <machineKey> identiques dans la section <system.web>.

Comment configurer Hostname et UrlRoot

Pour configurer un déploiement avec montée en puissance parallèle du serveur de rapports sur un cluster avec équilibrage de la charge réseau, vous devez définir un seul nom de serveur virtuel qui fournit un point d'accès unique au cluster de serveurs. Puis, inscrivez le nom du serveur virtuel auprès du serveur de noms de domaine de votre environnement.

Après avoir défini le nom du serveur virtuel, vous pouvez configurer les propriétés Hostname et UrlRoot du fichier RSReportServer.config de façon à inclure le nom du serveur virtuel dans l'URL du serveur de rapports.

Configurez la propriété Hostname lorsque vous utilisez des réservations d'URL spécifiant des caractères génériques dans votre environnement de création de rapports. Lorsque vous spécifiez la propriété Hostname comme nom de serveur virtuel du serveur avec équilibrage de la charge réseau, le trafic réseau de l'environnement de création de rapports est dirigé vers le serveur avec équilibrage de la charge réseau. Le serveur NLB distribue ensuite les demandes parmi les nœuds du serveur de rapports.

En outre, configurez la propriété UrlRoot afin que les liens du rapport fonctionnent dans les rapports exportés vers des rapports statiques, tels que ceux au format Excel ou PDF, ou dans les rapports créés par abonnements, tels que les abonnements de messagerie électronique.

Si vous intégrez Reporting Services à Windows SharePoint Services 3.0 ou Office SharePoint Server 2007, ou que vous hébergez vos rapports dans une application Web personnalisée, il se peut que vous ayez uniquement besoin de configurer la propriété UrlRoot. Dans ce cas, configurez la propriété UrlRoot comme URL du site SharePoint ou de l'application Web. Le trafic réseau de l'environnement de création de rapports est alors dirigé vers l'application qui gère les rapports, et non vers le serveur de rapports ou le cluster avec équilibrage de la charge réseau (NLB, Network Load Balancing).

Ne modifiez pas ReportServerUrl. Si vous modifiez cette URL, un aller-retour supplémentaire au serveur virtuel sera nécessaire pour chaque demande interne à gérer. Pour plus d'informations, consultez URL des fichiers de configuration (Reporting Services). Pour plus d'informations sur la modification du fichier de configuration, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

  1. Ouvrez RSReportServer.config dans un éditeur de texte.

  2. Recherchez la section <Service>, et ajoutez les informations suivantes au fichier de configuration, en remplaçant la valeur Hostname par le nom de serveur virtuel de votre serveur NLB :

    Copier le code
    <Hostname>virtual_server</Hostname>
  3. Recherchez UrlRoot. L'élément n'est pas spécifié dans le fichier de configuration, mais la valeur par défaut utilisée est une URL au format http:// ou https://<nom_ordinateur>/<serveur_rapports>, où <serveur_rapports> est le nom du répertoire virtuel du service Web Report Server.

  4. Tapez une valeur pour UrlRoot qui inclut le nom virtuel du cluster au format http:// ou https://<serveur_virtuel>/<reportserver>.

  5. Enregistrez le fichier.

  6. Répétez ces étapes dans chaque fichier RSReportServer.config de chaque serveur de rapports impliqué dans le déploiement par montée en puissance parallèle.

Vérifier l'accès au serveur de rapports

Vérifiez que vous pouvez accéder au déploiement avec montée en puissance parallèle via le nom du serveur virtuel (par exemple, https://MyVirtualServerName/reportserver et https://MyVirtualServerName/reports).

Vous pouvez vérifier quel nœud traite effectivement les rapports en examinant les fichiers journaux du serveur de rapports ou en vérifiant le journal d'exécution Reporting Services (la table du journal d'exécution contient une colonne InstanceName qui indique quelle instance a traité une demande particulière). Pour plus d'informations, consultez Fichiers journaux de Reporting Services dans la documentation en ligne de SQL Server.

Si vous ne pouvez pas vous connecter au serveur de rapports, vérifiez l'équilibrage de la charge réseau pour contrôler que les demandes sont envoyées au serveur de rapports et affichez le journal HTTP du serveur de rapports pour être certain que le serveur reçoit les demandes.

Dépannage des demandes ayant échoué

Si les demandes n'atteignent pas les instances du serveur de rapports, consultez le fichier RSReportServer.config pour vérifier que le nom du serveur virtuel est spécifié comme nom d'hôte pour les URL du serveur de rapports :

  1. Ouvrez le fichier RSReportServer.config dans un éditeur de texte.

  2. Recherchez <Hostname>, <ReportServerUrl> et <UrlRoot>, puis vérifiez le nom d'hôte pour chaque paramètre. Si la valeur n'est pas le nom d'hôte attendu, remplacez-le par le nom d'hôte approprié.

Si vous démarrez l'outil de configuration de Reporting Services après avoir effectué ces modifications, l'outil peut remplacer les paramètres <ReportServerUrl> par la valeur par défaut. Conservez toujours une copie de sauvegarde des fichiers de configuration au cas où vous auriez besoin de les remplacer par la version qui contient les paramètres à utiliser.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)
Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services)

Concepts

Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer un compte de service pour Reporting Services

Procédure : configurer un compte de service pour Reporting Services |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Dans une installation Reporting Services, le service Web Report Server, le Gestionnaire de rapports et l'application de traitement en arrière-plan s'exécutent au sein d'un même service. Le compte sous lequel le service s'exécute est défini pendant l'installation lorsque vous spécifiez le compte dans la page Identité du service, mais vous pouvez utiliser l'outil de configuration de Reporting Services si vous souhaitez utiliser un autre compte ou mettre à jour le mot de passe.

Si vous disposez d'un serveur de rapports configuré pour utiliser le mode intégré SharePoint et que vous modifiez le compte de service à l'aide de l'outil de configuration Reporting Services, vous devez également ouvrir l'Administration centrale de SharePoint et vous servir de la page Accorder l'accès à la base de données de Reporting Services pour réappliquer les paramètres du serveur de rapports et de l'instance. Cette étape accorde aux bases de données SharePoint le nouvel accès au compte de service, requis pour intégrer Reporting Services à SharePoint Foundation 2010 ou SharePoint Server 2010. Pour plus d'informations sur la manière d'accorder l'accès à la base de données dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Utilisez toujours l'outil de configuration de Reporting Services pour mettre à jour le compte de service afin que les autres paramètres qui dépendent de l'identité de service puissent être mis à jour simultanément.

Vous ne pouvez pas utiliser les comptes de service Windows intégrés (Service local ou Service réseau) comme comptes de service du serveur de rapports sur un contrôleur de domaine.

Pour configurer le compte de service Report Server

  1. Démarrez le Gestionnaire de configuration de Reporting Services, puis connectez-vous au serveur de rapports.

  2. Dans la page Compte de service, sélectionnez l'option qui décrit le type de compte que vous souhaitez utiliser. Pour obtenir des recommandations sur le type de compte à spécifier, consultez Configuration du compte de service Report Server.

  3. Si vous avez sélectionné un compte d'utilisateur Windows, spécifiez le nouveau compte et le nouveau mot de passe. La longueur du nom du compte ne peut pas excéder 20 caractères.

    Si le serveur de rapports est déployé dans un réseau qui prend en charge l'authentification Kerberos, vous devez inscrire le nom de principal du service (SPN) du serveur de rapports avec le compte d'utilisateur de domaine que vous venez de spécifier. Pour plus d'informations, consultez Procédure : inscrire un nom de principal du service (SPN) pour Report Server.

  4. Cliquez sur Appliquer.

  5. Lorsque vous êtes invité à sauvegarder la clé symétrique, tapez un nom de fichier et un emplacement pour la sauvegarde de la clé symétrique, entrez un mot de passe pour verrouiller et déverrouiller le fichier, puis cliquez sur OK.

  6. Si le serveur de rapports utilise le compte de service pour se connecter à la base de données du serveur de rapports, les informations de connexion seront mises à jour pour utiliser le nouveau compte ou mot de passe. La mise à jour des informations de connexion nécessite que vous vous connectiez à la base de données. Si la boîte de dialogue Connexion de la base de données SQL Server apparaît, entrez les informations d'identification habilitées à se connecter à la base de données, puis cliquez sur OK.

  7. Lorsque vous êtes invité à restaurer la clé symétrique, tapez le mot de passe spécifié à l'étape 5, puis cliquez sur OK.

  8. Examinez les messages d'état dans le volet Résultats pour vérifier que toutes les tâches se sont terminées avec succès.

Dépannage des erreurs de mise à jour de l'identité du service

La modification de l'identité du service initialise une série d'événements qui incluent le redémarrage du service, la mise à jour de la clé de chiffrement protégée par mot de passe, la mise à jour des réservations d'URL et la mise à jour des informations de connexion à la base de données du serveur de rapports si vous utilisez le compte de service pour vous connecter à la base de données du serveur de rapports. Vous pouvez surveiller l'état de ces événements en consultant les notifications dans le volet Résultats en bas de page. Si des erreurs se produisent pendant ce processus, vous pouvez essayer de les résoudre à l'aide des techniques suivantes :

  • Si la clé symétrique ne peut pas être restaurée, vous pouvez essayer de la restaurer manuellement en utilisant Restaurer dans la page Clés de chiffrement. Si cette technique ne fonctionne pas, envisagez de supprimer le contenu chiffré. Vous devrez recréer les abonnements et les informations de connexion à la source de données, mais le reste du contenu demeurera disponible. Pour plus d'informations, consultez Sauvegarde et restauration des clés de chiffrement.

  • Si le service ne démarre pas, redémarrez-le manuellement en utilisant l'application console Services dans les Outils d'administrateur.

  • Les erreurs de réservation d'URL peuvent se produire lorsque vous mettez à jour le compte de service. Chaque réservation d'URL comporte un descripteur de sécurité incluant une liste de contrôle d'accès discrétionnaire (DACL) qui accorde l'autorisation au compte de service d'accepter les demandes sur l'URL. Lorsque vous mettez à jour le compte, l'URL doit être recréée pour mettre à jour la liste DACL avec les nouvelles informations de compte. Si la réservation d'URL ne peut pas être recréée et que vous savez que le compte est valide, essayez de redémarrer l'ordinateur. Si l'erreur persiste, essayez d'utiliser un autre compte.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Référence

Compte de service (configuration de Reporting Services)

Concepts

Configuration du compte de service Report Server
Configuration d'une connexion de base de données de serveur de rapports
Configuration et gestion des clés de chiffrement

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer une URL (configuration de Reporting Services)

Procédure : configurer une URL (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Avant de pouvoir utiliser le Gestionnaire de rapports ou le service Web Report Server, vous devez configurer au moins une URL pour chaque application. La configuration des URL est obligatoire si vous avez installé Reporting Services en mode « fichiers uniquement »(autrement dit, en sélectionnant l'option Installer mais ne pas configurer le serveur sur la page Options d'installation du serveur de rapports dans l'Assistant Installation). Si vous avez installé Reporting Services dans la configuration par défaut, les URL sont déjà configurées pour chaque application. Si vous disposez d'un serveur de rapports configuré pour s'exécuter en mode intégré SharePoint et que vous mettez à jour l'URL du service Web Report Server à l'aide de l'outil de configuration Reporting Services, vous devez également mettre à jour l'URL dans l'Administration centrale de SharePoint.

Utilisez l'outil de configuration de Reporting Services pour configurer les URL. Toutes les parties de l'URL sont définies dans cet outil. Contrairement aux versions précédentes, les sites Web IIS (Internet Information Services) ne fournissent plus l'accès aux applications Reporting Services dans SQL Server 2008.

Reporting Services fournit les valeurs par défaut qui fonctionnent bien dans la plupart des scénarios de déploiement, y compris les déploiements côte à côte avec les autres applications et services Web. Les URL par défaut incorporent les noms d'instance, réduisant le risque de conflits d'URL si vous exécutez plusieurs instances de serveur de rapports sur le même ordinateur.

Cette rubrique fournit des instructions relatives aux tâches suivantes :

  • Créer une URL pour le service Web Report Server.

  • Créer une URL pour le Gestionnaire de rapports.

  • Définir les propriétés URL avancées pour définir des URL supplémentaires.

Pour plus d'informations sur la façon dont les URL sont stockées et maintenues ou sur les problèmes d'interopérabilité, consultez À propos des réservations et de l'inscription d'URL (Reporting Services) et Deploying Reporting Services and Internet Information Services Side-by-Side dans la documentation en ligne de SQL Server. Pour obtenir des exemples d'URL souvent utilisées dans une installation Reporting Services, consultez Exemples d'URL dans cette rubrique.

Configuration requise

Avant de créer ou de modifier une URL, souvenez-vous des points suivants :

  • Vous devez être membre du groupe Administrateurs local sur le serveur de rapports.

  • Si IIS 6.0 ou 7.0 sont installés sur le même ordinateur, vérifiez les noms des répertoires virtuels sur les sites Web qui utilisent le port 80. Si vous consultez les répertoires virtuels qui utilisent les noms de répertoire virtuel Reporting Services par défaut (autrement dit, Reports et ReportServer), choisissez des noms de répertoire virtuel différents pour les URL Reporting Services que vous configurez.

  • Vous devez utiliser l'outil de configuration de Reporting Services pour configurer l'URL : N'utilisez pas d'utilitaire système. Ne modifiez jamais directement les réservations d'URL dans la section URLReservations du fichier RSReportServer.config. L'utilisation de l'outil de configuration de Reporting Services est nécessaire pour mettre à jour la réservation d'URL sous-jacente stockée en interne et pour synchroniser les paramètres URL stockés dans le fichier RSReportServer.config.

  • Choisissez une heure qui présente une activité de rapport basse. À chaque modification de la réservation d'URL, vous pouvez vous attendre à ce que les domaines d'application pour le service Web Report Server et le Gestionnaire de rapports soient recyclés.

  • Pour une vue d'ensemble de la construction et de l'utilisation des URL dans Reporting Services, consultez Configuration des URL de Report Server.

Pour configurer une URL pour le service Web Report Server

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports locale.

  2. Cliquez sur URL du service Web.

  3. Spécifiez le répertoire virtuel. Le nom de répertoire virtuel identifie l'application qui reçoit la demande. Comme une adresse IP et un port peuvent être partagés par plusieurs applications, le nom de répertoire virtuel spécifie quelle application reçoit la demande.

    Cette valeur doit être unique pour garantir que la demande atteint sa destination prévue. Cette valeur est obligatoire. Elle ne respecte pas la casse. Il existe une correspondance univoque entre un nom de répertoire virtuel et une instance d'une application Reporting Services. Si vous créez plusieurs URL vers la même instance d'application, vous devez utiliser le même nom de répertoire virtuel dans toutes les URL que vous définissez pour cette instance d'application.

    Pour le service Web Report Server, le nom du répertoire virtuel par défaut est ReportServer.

  4. Spécifiez l'adresse IP qui identifie de façon unique le serveur de rapports sur le réseau. Si vous souhaitez spécifier un en-tête de l'hôte ou définir des URL supplémentaires pour la même instance d'application, vous devez cliquer sur Avancé. Pour obtenir des instructions sur la façon de définir les propriétés avancées sur l'URL, consultez les instructions plus loin dans cette rubrique. Sinon, utilisez la page URL du service Web pour effectuer une sélection parmi les valeurs suivantes :

    • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

    • Non assigné spécifie que le serveur de rapports reçoit une demande qui n'a pas été gérée par une autre application. Il est recommandé d'éviter cette option. Si vous sélectionnez cette option, il devient possible pour une autre application qui possède une réservation d'URL plus forte d'intercepter les demandes prévues pour le serveur de rapports.

    • 127.0.0.1 est l'adresse IPv4 utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

    • ::1 désigne l'adresse de bouclage au format IPv6.

    • Les adresses IP spécifiques apparaissent également dans cette liste. Les adresses IP peuvent être aux formats IPv4 et IPv6. Nnn.nnn.nnn.nnn est l'adresse IPv4 32 bits d'une carte réseau sur votre ordinateur. Les adresses IPv6 sont de 128 bits, avec huit champs de 4 octets séparés par le signe deux-points : <préfixe>:nnnn:nnnn:nnnn:nnnn:nnnn:nnnn

      Si vous avez plusieurs cartes ou si votre réseau prend en charge les adresses IPv4 et les adresses IPv6, vous visualisez plusieurs adresses IP. Si vous sélectionnez une seule adresse IP, elle limitera l'accès de l'application à la seule adresse IP (et à tout nom d'hôte qu'un serveur de noms de domaine mappe sur cette adresse). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports. En général, si vous sélectionnez cette valeur, c'est parce que vous configurez plusieurs réservations d'URL qui spécifient aussi des adresses IP explicites ou des noms d'hôte (par exemple, un premier pour une carte réseau utilisée pour les connexions intranet et un second utilisé pour les connexions extranet).

  5. Spécifiez le port. Le port 80 est le port par défaut pour Reporting Services sur Windows Server 2003, Windows Vistaet Windows Server 2008, parce qu'il peut être partagé avec d'autres applications. Si vous utilisez Windows XP SP2 32 bits, le port par défaut est 8080. Si vous souhaitez utiliser un numéro de port personnalisé, souvenez-vous que vous devrez toujours le spécifier dans l'URL utilisée pour accéder au serveur de rapports. Vous pouvez utiliser les techniques suivantes pour rechercher un port disponible :

    • À partir d'une invite de commandes, tapez la commande suivante pour retourner la liste des ports TCP utilisés :

      netstat –a –n -p tcp

    • Lisez l'article (en anglais) du support Microsoft Information about TCP/IP port assignments pour comprendre les attributions de port TCP et les différences entre les ports bien identifiés (0 à 1023), les ports inscrits (1024 à 49151) et les ports dynamiques ou privés (49152 à 65535).

    • Si vous utilisez le Pare-feu Windows, vous devez ouvrir le port. Pour obtenir des instructions, consultez Procédure : configurer un pare-feu pour accéder à Report Server.

  6. Si vous ne l'avez pas déjà fait, vérifiez qu'IIS (s'il est installé) n'a pas de répertoire virtuel ayant le même nom que celui que vous projetez d'utiliser.

  7. Si vous avez installé un certificat SSL, vous pouvez le sélectionner pour lier l'URL au certificat SSL installé sur votre ordinateur.

  8. Le cas échéant, si vous sélectionnez un certificat SSL, vous pouvez spécifier un port personnalisé. La valeur par défaut est 443, mais vous pouvez utiliser tout port disponible.

  9. Cliquez sur Appliquer pour créer l'URL.

  10. Testez l'URL en cliquant sur le lien dans la section URL de la page. Notez que la base de données du serveur de rapports doit être créée et configurée avant que vous puissiez tester l'URL. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

  11. De plus, si votre serveur de rapports est configuré pour utiliser le mode intégré SharePoint, configurez l'URL du service Web Report Server dans l'Administration centrale de SharePoint. Pour plus d'informations sur la mise à jour de l'URL du service Web Report Server dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Pour créer une réservation d'URL pour le Gestionnaire de rapports

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports.

  2. Cliquez sur URL du Gestionnaire de rapports.

  3. Spécifiez le répertoire virtuel. Le Gestionnaire de rapports écoute sur la même adresse IP et le même port que le service Web Report Server. Si vous avez configuré le Gestionnaire de rapports pour pointer sur un service Web Report Server différent, vous devez modifier les paramètres d'URL du Gestionnaire de rapports dans le fichier RSReportServer.config. Pour obtenir des instructions, consultez Procédure : configurer le Gestionnaire de rapports dans la documentation en ligne de SQL Server.

  4. Si vous avez installé un certificat SSL, vous pouvez le sélectionner pour exiger que toutes les demandes adressées au Gestionnaire de rapports soient acheminées via le protocole HTTPS.

    Le cas échéant, si vous sélectionnez un certificat SSL, vous pouvez spécifier un port personnalisé. La valeur par défaut est 443, mais vous pouvez utiliser tout port disponible.

  5. Cliquez sur Appliquer pour créer l'URL.

  6. Testez l'URL en cliquant sur le lien dans la section URL de la page.

Définition de propriétés avancées pour spécifier les URL supplémentaires

Vous pouvez réserver plusieurs URL pour le service Web Report Server ou le Gestionnaire de rapports en spécifiant des ports ou des noms d'hôte différents (une adresse IP ou un nom d'en-tête de l'hôte qu'un serveur de noms de domaine peut résoudre en une adresse IP assignée à l'ordinateur). En créant plusieurs URL, vous pouvez définir différents chemins d'accès à la même instance de serveur de rapports. Par exemple, pour activer l'accès intranet et extranet à un serveur de rapports, vous pouvez utiliser l'URL par défaut pour l'accès intranet et un nom d'hôte complet supplémentaire pour l'accès extranet :

  • http://myserver01/reportserver

  • http://www.adventure-works.com/reportserver

Vous ne pouvez pas définir plusieurs noms de répertoire virtuel pour la même instance d'application. Chaque instance d'application de Reporting Services est mappée sur un nom de répertoire virtuel unique. Si vous avez plusieurs instances de Reporting Services sur le même ordinateur, le nom de répertoire virtuel d'une application doit inclure le nom de l'instance pour garantir que chaque demande atteint sa cible prévue.

Pour définir les propriétés avancées sur une URL

  1. Dans l'URL du service Web ou sur la page URL du Gestionnaire de rapports, cliquez sur Avancé.

  2. Cliquez sur Ajouter.

  3. Cliquez sur l'adresse IP ou le nom d'en-tête de l'hôte. Si vous spécifiez un en-tête de l'hôte, veillez bien à spécifier un nom que le service DNS peut résoudre. Si vous spécifiez un nom de domaine disponible publiquement, incluez la totalité de l'URL, y compris http://www.

  4. Spécifiez le port. Si vous spécifiez un port personnalisé, l'URL de l'application doit toujours inclure le numéro de port.

  5. Cliquez sur OK.

  6. Testez l'URL en ouvrant une fenêtre de navigateur et en entrant l'URL.

URL de plusieurs instances de Report Server sur le même ordinateur

Si vous réservez les URL pour plusieurs instances de Reporting Services, vous devez suivre les conventions d'affectation de noms afin d'éviter les conflits de noms. Pour plus d'informations, consultez Réservations d'URL pour les déploiements de serveur de rapports multi-instance.

Exemples de configurations d'URL

La liste suivante présente quelques exemples d'URL de serveur de rapports :

  • http://localhost/serveurderapports

  • http://localhost/serveurderapports_SQLEXPRESS

  • http://ventes01/serveurderapports

  • http://ventes01:8080/serveurderapports

  • https://ventes.adventure-works.com/serveurderapports

  • https://www.adventure-works.com:8080/serveurderapports01

Les URL que vous utilisez pour accéder au Gestionnaire de rapports partagent le même format et sont généralement créées sous le site Web qui héberge le serveur de rapports. La seule différence est le nom du répertoire virtuel (dans ce cas, le nom est rapports, mais vous pouvez configurer le répertoire virtuel pour qu'il utilise le nom de votre choix) :

  • http://localhost/rapports

  • http://localhost/rapports_SQLEXPRESS

  • http://ventes01/rapports

  • http://ventes01:8080/rapports

  • https://ventes.adventure-works.com/rapports

  • https://www.adventure-works.com:8080/rapports

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez un serveur de rapports pour une exécution dans un déploiement d'un produit SharePoint, vous devez spécifier des paramètres d'intégration qui déterminent la connexion entre l'instance de technologie SharePoint et un serveur de rapports Reporting Services :

  • Vous devez être administrateur sur la batterie SharePoint pour configurer l'intégration du serveur de rapports :

  • Vous devez avoir installé le Complément Reporting Services pour les produits SharePoint, lequel fournit les pages de configuration et l'intégration générale.

  • Vous devez également avoir un serveur de rapports cible qui est déjà connecté à une base de données du serveur de rapports créée pour le mode intégré SharePoint.

  • Si vous configurez Reporting Services pour s'exécuter dans une batterie de serveurs SharePoint, un serveur Web frontal SharePoint doit également être installé sur le serveur de rapports.

Les paramètres que vous spécifiez sont stockés dans la base de données de configuration. Si vous configurez l'intégration pour une batterie qui inclut plusieurs serveurs virtuels, les paramètres seront utilisés par tous les serveurs Web frontaux qui sont activés dans une batterie de serveurs SharePoint et qui ont une installation du Complément Reporting Services.

Si vous modifiez ultérieurement les comptes de service Report Server ou que vous étendez une batterie de serveurs SharePoint pour inclure des applications supplémentaires, vous devez réexécuter la commande d'accord d'accès à la base de données afin de mettre à jour les droits d'accès dans la base de données de configuration SharePoint. Pour plus d'informations, consultez Configuration du compte de service Report Server.

Pour plus d'informations sur l'ensemble des tâches à effectuer, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

Remarque :
Une fois que vous avez défini une URL de serveur de rapports, vous devez être très prudent lors de sa modification. Toute modification d'une URL de serveur de rapports perturbe la connexion entre les serveurs, ce qui affecte les rapports et les modèles en cours de traitement. Si vous modifiez l'URL de serveur de rapports sur un serveur de production, assurez-vous de respecter les procédures de temps d'arrêt planifié établies pour votre organisation.

Pour spécifier les paramètres d'intégration de serveur de rapports dans l'administration centrale

  1. Dans Outils d'administration, cliquez sur Administration centrale SharePoint 2010.

  2. Cliquez sur l'onglet Paramètres généraux de l'application.

    Dans la section Reporting Services, vous devez voir les liens suivants : Intégration de Reporting Services, Ajouter un serveur de rapports à l'intégration, Définir des paramètres par défaut serveur. Si vous ne voyez pas la section ou les liens, le Complément Reporting Services n'est pas installé sur l'ordinateur ou la fonctionnalité n'est pas activée. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

  3. Cliquez sur Configuration de Reporting Services.

  4. Dans URL du service Web Report Server, spécifiez le site de serveur de rapports que vous souhaitez utiliser avec le site ou la batterie SharePoint actuel. L'URL peut pointer vers une seule instance de serveur de rapports ou il peut s'agir du nom de serveur virtuel d'un ensemble de serveurs de rapports à équilibrage de charge qui s'exécutent dans un déploiement avec montée en puissance parallèle.

    Pour obtenir l'URL, ouvrez l'outil de configuration de Reporting Services, connectez-vous au serveur de rapports et cliquez sur URL du service Web. Cliquez sur l'URL pour vérifier qu'elle fonctionne. Copiez l'URL et collez-la dans URL du service Web Report Server.

    L'URL du serveur de rapports inclut un nom de serveur et un répertoire virtuel que vous avez spécifiés dans l'outil de configuration Reporting Services. Les exemples suivants illustrent comment une URL du serveur de rapports peut être construite :

    • http://nom-serveur/reportserver (cet exemple peut être utilisé si le serveur de rapports se trouve sur un autre ordinateur).

    • https://nom_votre_serveur:443/reportserver.

    Ne spécifiez pas http://localhost pour l'URL d'un serveur de rapports utilisé dans une batterie SharePoint. Une adresse URL qui spécifie http://localhost n'est pas valide pour les applications Web SharePoint installées sur des serveurs distants.

    Si vous avez installé côte à côte le serveur de rapports et l'instance de technologie SharePoint, vérifiez qu'il n'y a pas de conflits de nom de répertoire virtuel. Pour plus d'informations sur les problèmes d'interopérabilité, consultez Deploying Reporting Services and Internet Information Services Side-by-Sidedans la documentation en ligne de SQL Server.

  5. Dans Mode d'authentification, sélectionnez Authentification Windows ou Compte approuvé pour spécifier si le point de terminaison de serveur de rapports installé sur le serveur SharePoint envoie un en-tête avec un jeton de sécurité pour une connexion avec emprunt d'identité sur le serveur de rapports.

    Toutes les demandes issues d'une action utilisateur sur une page d'application Reporting Services sont transférées par le point de terminaison de serveur de rapports sur l'application Web SharePoint vers un serveur de rapports à des fins de traitement. Selon le mode d'authentification, la demande peut inclure ou non un jeton d'identité d'utilisateur SharePoint dans l'en-tête.

    Si l'application Web SharePoint est configurée pour l'authentification Windows et que le protocole Kerberos est activé, vous pouvez sélectionner Authentification Windows pour vous connecter par le biais de la sécurité intégrée Windows. Dans ce cas, aucun jeton d'identité d'utilisateur n'est envoyé. Éventuellement, vous pouvez sélectionner Compte approuvé pour emprunter l'identité du compte approuvé et passer les informations utilisateur SharePoint dans l'en-tête de demande au serveur de rapports.

    Pour plus d'informations sur les connexions serveur, consultez Vue d'ensemble de la sécurité pour Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  6. Dans Informations d'identification, spécifiez des informations d'identification qui représentent un membre du groupe Administrateurs sur l'ordinateur qui héberge le serveur de rapports.

  7. Dans Activer la fonctionnalité Reporting Services, choisissez l'étendue pour laquelle vous voulez activer la fonctionnalité d'intégration des services de la création de rapport, soit toutes les collections de site soit uniquement celles que vous sélectionnez.

  8. Cliquez sur OK.

  9. Dans la section Reporting Services, cliquez sur Définir des paramètres par défaut serveur.

  10. Dans Captures instantanées d'historique de rapport, spécifiez une valeur par défaut à l'échelle du site pour déterminer le nombre de copies d'historique de rapport à conserver. La valeur par défaut donne un paramètre de départ qui établit le nombre d'instantanés qui peuvent être stockés pour chaque rapport. Vous pouvez spécifier des limites différentes dans les pages de propriétés de rapports particuliers.

  11. Dans Délai de traitement des rapports, spécifiez si le délai de traitement d'un rapport expire sur le serveur de rapports après un certain nombre de secondes. Cette valeur s'applique au traitement du rapport sur le serveur de rapports. Elle n'a aucune incidence sur le traitement des données sur le serveur de base de données qui fournit les données pour le rapport. La minuterie du traitement du rapport commence lorsque le rapport est sélectionné et s'arrête lors de l'ouverture du rapport. La valeur que vous spécifiez doit être suffisante pour terminer le traitement des données et du rapport.

  12. Dans Journal de traitement des rapports, spécifiez si le serveur de rapports génère des journaux de traces et le nombre de jours pendant lesquels ces journaux sont conservés. . Les journaux sont stockés sur l'ordinateur serveur de rapports dans le dossier \Microsoft SQL Server\MSSQL.n\ReportServer\Log. Un nouveau fichier journal est démarré chaque fois que le service est démarré. Pour plus d'informations sur les fichiers journaux, consultez Journal des traces du service Report Server.

  13. Dans Activer la sécurité intégrée de Windows, spécifiez si une connexion à une source de données de rapport peut être établie à l'aide du jeton de sécurité Windows de l'utilisateur qui a demandé le rapport.

  14. Dans Activer l'exécution du rapport ad hoc, spécifiez si les utilisateurs peuvent exécuter des requêtes ad hoc à partir d'un rapport du Générateur de rapports. La définition de cette option spécifie la propriété EnableLoadReportDefinition sur le serveur de rapports. Si vous désactivez cette option, le serveur de rapports ne va pas créer de rapports consultables à l'aide de clics pour les rapports se servant d'un modèle de rapport comme source de données.

  15. Dans Activer le téléchargement du contrôle ActiveX RsClientPrint, spécifiez si les utilisateurs peuvent télécharger le contrôle côté client, ce qui donne accès à des paramètres d'impression.

  16. Dans Activer le téléchargement du Générateur de rapports, spécifiez si les clients sont en mesure de voir le bouton pour le téléchargement de l'application de générateur de rapports.

  17. Dans URL de lancement du Générateur de rapports personnalisée, spécifiez une URL personnalisée lorsque le serveur de rapports n'utilise pas l'URL du Générateur de rapports par défaut. Ce paramètre est facultatif. Si vous ne spécifiez pas de valeur, l'URL par défaut est utilisée, laquelle lance le Générateur de rapports version 3.0. Pour lancer le Générateur de rapports version 1.0 comme une application en un clic, entrez la valeur suivante : http://<computername>/ReportServer/ReportBuilder/ReportBuilder_1_0_0_0.application.

  18. Cliquez sur OK..

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur un serveur autonome
Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs
Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Concepts

Procédure : installer ou désinstaller le complément Reporting Services
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer l'intégration à SharePoint sur un serveur autonome

Procédure : configurer l'intégration à SharePoint sur un serveur autonome |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

L'un des scénarios de déploiement pour exécuter Reporting Services en mode intégré SharePoint consiste à installer tous les composants serveur et bases de données d'application sur un serveur autonome unique. Cette configuration est utile si vous souhaitez en savoir davantage sur l'interaction entre les technologies ou si vous développez une application personnalisée et que vous souhaitez tirer parti de la simplicité liée à la présence de tous les services sur un ordinateur unique.

Configuration requise

Avant de commencer à installer des composants, assurez-vous d'effectuer les opérations suivantes :

  • Étudiez l'introduction aux configurations de déploiement afin de vous familiariser avec les composants que vous allez installer. Pour plus d'informations, consultez Topologies de déploiement pour Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  • Étudiez la rubrique de vue d'ensemble de configuration afin d'en savoir plus sur les recommandations relatives à la configuration des comptes de service et sur les étapes de configuration. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

  • Examinez les configurations matérielle et logicielle requises qui s'appliquent à tous les scénarios de déploiement qui incluent Reporting Services en mode intégré SharePoint. Pour plus d'informations, consultez Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  • Examinez les sections restantes dans cette rubrique afin d'en savoir plus sur les spécifications supplémentaires qui s'appliquent à une configuration de serveur autonome.

Considérations relatives à la base de données pour la configuration du serveur autonome

Reporting Services et les produits et technologies SharePoint utilisent des bases de données relationnelles SQL Server pour stocker des données d'application. Reporting Services requiert une instance du moteur de base de données dans une édition compatible. Les produits et technologies SharePoint peuvent utiliser un serveur de base de données existant si vous en fournissez un. Dans le cas contraire, le programme d'installation installe SQL Server Embedded Edition en tant que composant interne et l'utilise pour les bases de données d'application. Étant donné que vous installez déjà le moteur de base de données pour Reporting Services, vous pouvez envisager d'utiliser cette même instance pour les bases de données d'application SharePoint.

Toutefois, si vous laissez le programme d'installation installer et utiliser SQL Server Embedded Edition, vous pouvez réduire considérablement le nombre d'étapes d'installation et de configuration. Si vous disposez d'un espace disque suffisant, vous devez utiliser l'édition Embedded fournie par SharePoint.

Si vous ne souhaitez pas avoir plusieurs instances de SQL Server sur votre ordinateur, vous pouvez utiliser le moteur de base de données pour les bases de données de configuration et de contenu SharePoint. Pour cela, vous devez choisir l'option d'installation Avancée lorsque vous installez un produit ou une technologie SharePoint.

Remarque :
L'instance de serveur de rapports ne peut pas utiliser l'édition Embedded pour sa base de données. Toutefois, l'instance Embedded Edition installée par le produit ou la technologie SharePoint peut exister côte à côte avec d'autres éditions du moteur de base de données que vous pouvez installer également. Pour plus d'informations sur l'édition requise pour la base de données du serveur de rapports, consultez Création d'une base de données de serveur de rapports.

Ordre d'installation

Vous pouvez installer les technologies de composants dans n'importe quel ordre, mais pour de meilleurs résultats vous devez installer en premier Reporting Services et vérifier que vous avez une installation valide avant d'installer le produit ou la technologie SharePoint.

Pour réduire le nombre d'étapes nécessaires, vous devez installer Reporting Services et le moteur de base de données simultanément Étant donné que vous installez le moteur de base de données et Reporting Services ensemble, vous aurez très probablement l'option d'installer Reporting Services dans la configuration par défaut, où les répertoires virtuels, le compte de service et les bases de données du serveur de rapports sont configurés automatiquement pendant l'installation.

La liste ci-dessous résume les tâches de déploiement à exécuter :

  1. Installez Reporting Services et le moteur de base de données. Si possible, choisissez l'option Installer la configuration par défaut en mode SharePoint lors de l'installation de Reporting Services. Sinon, vous pouvez sélectionner l'option du Installer mais ne pas configurer le serveur et configurer le serveur comme tâche de post-installation.

  2. Configurez le serveur de rapports s'il n'est pas déjà configuré et vérifiez que vous avez une installation valide.

  3. Téléchargez et installez le package redistribuable Microsoft .NET Framework 3.0.

  4. Installez SharePoint Server 2010 ouSharePoint Foundation 2010. Choisissez l'option d'installation Basique.

  5. Exécutez l'Assistant Configuration des produits et technologies SharePoint, puis ouvrez le site SharePoint pour vérifier que vous avez une installation valide.

  6. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

  7. Configurez les fonctionnalités d'intégration du serveur de rapports dans l'Administration centrale.

Pour installer Reporting Services et le moteur de base de données

  • Installer Reporting Services et le moteur de base de données sur le même ordinateur. Pour plus d'informations, consultez Procédure : installer SQL Server 2008 R2 (programme d'installation) dans la documentation en ligne de SQL Server.

  • Configurez le serveur de rapports, mais lorsque vous créez la base de données du serveur de rapports, sélectionnez l'option pour le mode intégré SharePoint. Pour plus d'informations, consultez Procédure : configurer un serveur de rapports dans la documentation en ligne de SQL Server.

Une fois l'installation terminée, vous pouvez vérifier qu'elle a réussi en vous connectant au serveur de rapports. Vous pouvez tester la connexion en entrant http://localhost/reportserver dans l'adresse d'URL d'une fenêtre de navigateur.

Pour télécharger et installer le package redistribuable du .NET Framework 3.0

  1. Téléchargez le package redistributable du .NET Framework 3.0 à partir du Centre de téléchargement Microsoft.

  2. Exécutez le programme d'installation. Le programme d'installation s'exécute en arrière-plan et son exécution peut prendre un certain temps. Pour vérifier sa progression, cliquez sur l'icône d'installation de Microsoft .NET Framework 3.0 dans la zone de notification de la barre des tâches.

Pour installer un produit ou une technologie SharePoint

  1. Exécutez Setup.exe à partir du support d'installation.

  2. Entrez la clé de produit de 25 caractères.

  3. Acceptez le contrat de license de logiciel.

  4. Cliquez sur Basique.

    Cette option fournit le moins d'étapes d'installation. Elle installe immédiatement le logiciel en utilisant toutes les valeurs par défaut. Elle automatise également les étapes de configuration pour la configuration de l'Administration centrale et du site SharePoint par défaut.

    Si vous souhaitez utiliser une instance du moteur de base de données existante, vous devez plutôt cliquer sur Avancée. Lorsque vous choisissez cette option, le programme d'installation fournit l'option d'installation Complète, que vous pouvez utiliser pour spécifier le serveur de base de données à utiliser. Sachez que le fait de choisir l'option d'installation Avancée augmente la complexité des étapes de configuration que vous devez effectuer ultérieurement. Pour plus d'informations sur la façon de spécifier et de configurer une installation Avancée, suivez la procédure « Pour installer un produit ou une technologie SharePoint » dans Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs. Lorsque vous avez terminé l'installation Avancée et les étapes de configuration dans la rubrique de déploiement multi-serveur, retournez à cette rubrique, modifiez l'affectation des ports et continuez les tâches restantes.

  5. Dans la page Terminé, vérifiez que la case à cocher est activée pour Exécuter l'Assistant Configuration des produits et technologies SharePoint.

  6. Cliquez sur Fermer.

    Une fois le programme d'installation fermé, l'Assistant Configuration des produits et technologies SharePoint s'exécute. Lorsque vous sélectionnez l'option d'installation Basique, les tâches de configuration s'exécutent en arrière-plan et vous pouvez cliquer sur Terminer lorsque les tâches de configuration sont terminées.

  7. Vérifiez que l'installation a réussi. Par défaut, un site SharePoint s'ouvre dans une fenêtre de navigateur une fois les tâches de configuration terminées. Cette étape vérifie le processus d'installation et de configuration.

Par défaut, l'Assistant Configuration des produits et technologies SharePoint assigne le port 80 à l'application Web SharePoint, ce qui rend le serveur de rapports indisponible. En conséquence, vous devez maintenant modifier les paramètres de configuration du serveur de rapports de façon à utiliser un port différent et vous devez démarrer le site Web par défaut.

Vérifier que la base de données du serveur de rapports est configurée pour le mode intégré SharePoint

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour obtenir des instructions, consultez Procédure : lancer la configuration de Reporting Services.

  2. Dans la page État de Report Server, vérifiez que Mode du serveur de rapports a la valeur Intégré à SharePoint.

  3. Si le serveur de rapports n'est pas configuré pour le mode intégré SharePoint, cliquez sur Base de données et créez la base de données du serveur de rapports pour le mode intégré SharePoint. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) et Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services).

Si vous utilisez une nouvelle installation de Reporting Services, vous devez également configurer le compte de traitement de rapport sans assistance si vous voulez prendre en charge l'exécution de rapport sans assistance. En option, configurez le serveur de rapports pour la remise de courrier électronique. Pour plus d'informations, consultez Configuration du compte d'exécution sans assistance et Configuration d'un Report Server pour la remise du courrier électronique.

Pour télécharger et installer le Complément Reporting Services pour les technologies SharePoint

  1. Cliquez sur Complément Microsoft SQL Server 2008 Reporting Services pour SharePoint Technologies pour ouvrir la page de téléchargement sur le site Web de Microsoft.

    Important :
    Vous devez être administrateur de batterie de serveurs Web SharePoint et administrateur de collection de site pour installer le Complément Reporting Services.

  2. Choisissez la langue d'installation.

  3. Dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour installer la version 32 bits ou 64 bits du Complément Reporting Services.

  4. Cliquez sur Enregistrer pour enregistrer le fichier dans un emplacement sur votre ordinateur.

  5. Ouvrez l'Explorateur Windows et recherchez le dossier où le fichier se trouve.

  6. Double-cliquez sur SharePointRS.msi pour commencer l'installation. Pour plus d'informations, consultez Procédure : installer ou désinstaller le complément Reporting Services.

  7. Obtenez la version la plus récente du fichier lisez-moi pour le Complément Reporting Services afin d'examiner les modifications de dernière minute et les problèmes connus. Dans la page de téléchargement sur le site Web Microsoft, dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour ouvrir le fichier readme_rsaddin.htm, puis enregistrez le fichier sur votre ordinateur.

Pour configurer l'intégration du serveur de rapports

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 2010.

    Important :
    Pour effectuer les étapes suivantes, vous devez être membre du groupe Administrateur de batterie de serveurs SharePoint et un administrateur de la collection de sites.

  2. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Si vous ne voyez pas cette section, vous devez activer la fonctionnalité d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

    Au minimum, vous devez définir l'URL du serveur de rapports, sélectionner un mode d'authentification et accorder l'accès au serveur de rapports aux bases de données SharePoint. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

  3. Fermez l'Administration centrale.

Étapes suivantes

Vérifiez l'intégration en démarrant l'outil de configuration de Reporting Services et en ouvrant la page Intégration SharePoint pour afficher l'état du serveur. Cliquez sur le lien affiché pour démarrer l'administration centrale de SharePoint.

Vous pouvez également vérifier une installation en ouvrant une fenêtre du navigateur sur le serveur de rapports. L'URL doit ressembler à http://nom-serveur-exemple:8080/serveurderapports. Cette URL pointe sur le point de terminaison de proxy. Après avoir ajouté des éléments de serveur de rapports dans une bibliothèque SharePoint, vous pouvez ouvrir une fenêtre du navigateur sur cette URL pour afficher les éléments sur le site.

Pour finir, vous devez être en mesure d'ouvrir l'application Web SharePoint et de télécharger des rapports et d'autres documents vers une bibliothèque SharePoint.

Après avoir installé tous les composants et configuré les paramètres pour connecter des composants serveur, vous devez assigner des autorisations, ajouter des types de contenu et ajouter des éléments de serveur de rapports à une bibliothèque SharePoint.
Pour finir les tâches de déploiement pour l'intégration de serveur
  1. Ouvrez l'application Web SharePoint. Par défaut, l'URL est http://<votre-nom-serveur>.

  2. Définissez des autorisations pour accorder à l'utilisateur l'accès au site SharePoint. La sécurité est requise, mais si vous voulez hériter des autorisations existantes, vous n'êtes pas tenu de définir des autorisations sur des éléments spécifiques. Pour plus d'informations, consultez Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint ou Procédure : définir les autorisations sur les éléments de serveur de rapports sur un site SharePoint (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  3. Ajoutez les types de contenu Reporting Services si vous voulez créer de nouvelles sources de données partagées, des modèles de rapport et des rapports du Générateur de rapports. Pour plus d'informations, consultez Procédure : ajouter des types de contenu de serveur de rapports à une bibliothèque (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  4. Créez des sources de données partagées à utiliser avec les rapports et les modèles. Pour plus d'informations, consultez Procédure : créer et gérer des sources de données partagées (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  5. Créez des planifications partagées à utiliser avec les abonnements ou le traitement de rapport sans assistance. Pour plus d'informations, consultez Procédure : créer et gérer des planifications partagées (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  6. Publiez des fichiers de définition de rapport (.rdl), des fichiers de source de données (.rds) et des fichiers de modèle de rapport (.smdl) dans une bibliothèque SharePoint. Vous pouvez également utiliser la commande Télécharger dans une bibliothèque SharePoint pour télécharger des fichiers .rdl et .smdl, mais pas des fichiers .rds. Selon vos autorisations, vous pouvez également créer des rapports dans le Générateur de rapports et les enregistrer dans une bibliothèque. Si les rapports incluent des références à des sources de données partagées ou à des fichiers externes, vous devez mettre à jour ces références. Pour plus d'informations, consultez Déploiement de modèles et de sources de données partagées sur un site SharePoint et Procédure : télécharger des documents vers une bibliothèque SharePoint (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

Lorsque vous téléchargez des rapports, assurez-vous que les propriétés de source de données du rapport sont correctes. La source de données doit avoir une chaîne de connexion valide vers une source de données externe. Le type d'informations d'identification doit être valide pour votre topologie de réseau. En particulier, si l'authentification Kerberos n'est pas activée pour votre domaine, vous ne pouvez pas utiliser le type d'informations d'identification de sécurité intégrée de Windows. À la place, vous devez spécifier des informations d'identification stockées. Après avoir vérifié que les propriétés de source de données sont correctes, vous pouvez cliquer sur le nom du rapport pour ouvrir le rapport. Le rapport s'ouvre automatiquement dans le composant WebPart de visionneuse de rapports.

Si le rapport ne s'ouvre pas, vérifiez les autorisations sur le rapport et les propriétés de source de données qui définissent une connexion à la source de données externe. Sur un site ou dans une batterie de serveurs, les autorisations SharePoint permettent de contrôler l'accès aux rapports, aux modèles de rapport, aux sources de données partagées et à l'outil Générateur de rapports utilisé pour créer des rapports appropriés. Si ces éléments ne sont pas visibles pour les utilisateurs, vous devez vérifier que les autorisations sont définies correctement.

Un serveur de rapports qui s'exécute en mode intégré SharePoint ne peut pas être géré par le biais du Gestionnaire de rapports ou de SQL Server Management Studio. Pour obtenir la liste complète des fonctionnalités prises en charge et non prises en charge, consultez Fonctionnalités prises en charge par Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 2010

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs

Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Cette rubrique fournit des instructions étape par étape pour l'installation et la configuration de Reporting Services en mode intégré SharePoint dans une topologie de déploiement sur plusieurs serveurs. Cette configuration est recommandée si de nombreux utilisateurs accèdent aux rapports à partir d'un site SharePoint.

Configuration requise

Avant de commencer à installer des composants, assurez-vous d'effectuer les opérations suivantes :

  • Étudiez l'introduction aux configurations de déploiement afin de vous familiariser avec les composants que vous allez installer. Pour plus d'informations, cliquez sur Topologies de déploiement pour Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  • Étudiez la rubrique de vue d'ensemble de configuration afin d'en savoir plus sur les recommandations relatives à la configuration des comptes de service et sur les étapes de configuration. Pour plus d'informations, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

  • Examinez les configurations matérielle et logicielle requises qui s'appliquent à tous les scénarios de déploiement qui incluent Reporting Services en mode intégré SharePoint. Pour plus d'informations, cliquez sur Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  • Étudiez les éléments restants dans cette section afin d'en savoir plus sur les spécifications supplémentaires qui s'appliquent à une configuration de serveur autonome.
Configuration requise pour les serveurs dans un déploiement sur plusieurs serveurs

Vous devez disposer d'au moins deux ou trois serveurs. L'hébergement des bases de données d'application sur un troisième serveur utilisé exclusivement par le moteur de base de données est une technique courante pour améliorer les performances si vous vous attendez à un nombre d'utilisateurs relativement important.

Si vous utilisez deux serveurs, chacun doit disposer des composants suivants :

  • Sur l'un des serveurs, installez SQL Server 2008 Reporting Services et le moteur de base de données. Ce serveur sera utilisé pour héberger le serveur de rapports avec les bases de données du serveur de rapports et les bases de données d'application SharePoint.

  • Sur le deuxième serveur, installez le package redistribuable Microsoft .NET Framework 3.0, une instance d'un produit ou d'une technologie SharePoint et le complément Reporting Services. Ce serveur constituera le serveur principal de la batterie. L'administration centrale sera installée sur ce serveur. Les utilisateurs accéderont au contenu du serveur de rapports à partir de la collection de sites de cet ordinateur.

Configuration requise pour les comptes dans un déploiement sur plusieurs serveurs

Vous devez disposer d'un compte d'utilisateur de domaine pour connecter l'instance du produit ou de la technologie SharePoint à la base de données SharePoint_config. Les batteries de serveurs requièrent l'utilisation de comptes de domaine pour les services et les connexions de bases de données. Si possible, créez un compte pouvant être utilisé exclusivement pour cette application. Évitez d'utiliser vos propres informations d'identification ou celles d'un utilisateur qui accédera à un site SharePoint en tant qu'utilisateur normal (sous peine de recevoir des erreurs de type « accès refusé »).

Vous devez créer une connexion de base de données SQL Server pour le compte de domaine. La connexion a besoin d'autorisations DBCreator sur le serveur.

Vous devez configurer le compte de processus du pool d'applications SharePoint pour qu'il s'exécute en tant que compte d'utilisateur de domaine.

Vous devez configurer le service Report Server pour qu'il s'exécute en tant que compte d'utilisateur de domaine.

Important :
Pour les déploiements de serveur distribués où le serveur de rapports, l'application Web SharePoint et les bases de données du serveur se trouvent sur trois ordinateurs distincts, vous pouvez utiliser les paramètres par défaut qui incluent le site Web et les affectations de port par défaut. Si vous installez l'application Web SharePoint et le serveur de rapports sur des ordinateurs distincts, tout en plaçant les bases de données SharePoint sur l'ordinateur serveur de rapports, vous rencontrerez des erreurs de connexion, à moins que vous ne suiviez les consignes de configuration des comptes de service décrites dans la section précédente. Pour plus d'informations, consultez Procédure : configurer un compte de service pour Reporting Services.

Des informations d'identification d'administrateur sont requises pour exécuter tous les programmes d'installation, pour accorder des autorisations pour l'administration de collection de sites principale et pour accorder l'accès aux bases de données lorsque vous configurez l'intégration du serveur de rapports.

Ordre d'installation

Vous pouvez installer les technologies de composants dans n'importe quel ordre. Pour de meilleurs résultats, vérifiez que chaque produit ou technologie serveur est correctement installé avant de l'intégrer.

La liste suivante fournit un résumé des tâches de déploiement :

  1. Installez Reporting Services et le moteur de base de données. Si vous installez le logiciel serveur sur un serveur de production ou si vous utilisez une configuration de déploiement à trois serveurs, choisissez l'option Installer mais ne pas configurer le serveur, ce qui vous permettra de contrôler quand et comment configurer le serveur de rapports.

  2. Configurez le serveur de rapports et vérifiez la validité de l'installation.

  3. Téléchargez et installez le package redistribuable .NET Framework 3.0.

  4. Installez SharePoint Server 2010 ouSharePoint Foundation 2010. Choisissez l'option d'installation Avancée, ce qui vous permettra de spécifier un serveur de base de données distant pendant la configuration.

  5. Exécutez l'Assistant Configuration des produits et technologies SharePoint et sélectionnez le serveur de base de données.

  6. Configurez les fonctionnalités de collection de sites dans l'Administration centrale et ouvrez le site SharePoint pour vérifier la validité de l'installation.

  7. Téléchargez et installez le complément Reporting Services pour SharePoint Technologies.

  8. Configurez les fonctionnalités d'intégration du serveur de rapports dans l'Administration centrale.

Pour installer Reporting Services et le moteur de base de données

  • Installez Reporting Services et le moteur de base de données sur le même ordinateur ou sur des ordinateurs distincts. Pour plus d'informations, consultez Considérations sur l'installation de Reporting Services dans la documentation en ligne de SQL Server.

Lorsque le programme d'installation a terminé, configurez le serveur de rapports pour un fonctionnement en mode natif afin de vérifier que l'installation a réussi. Cette façon de procéder vous permet d'utiliser le Gestionnaire de rapports pour vérifier l'installation.

Pour obtenir des instructions sur le démarrage de l'outil de configuration de Reporting Services et la configuration du serveur de rapports pour sa mise en exploitation, consultez Rubriques d'aide à la configuration de Reporting Services.

Pour télécharger et installer le package redistribuable .NET Framework 3.0

  1. Sur un serveur différent de celui que vous utiliserez pour l'instance du produit ou de la technologie SharePoint, téléchargez le package redistribuable .NET Framework 3.0 à partir du Centre de téléchargement Microsoft.

  2. Exécutez le programme d'installation. Le programme d'installation s'exécute en arrière-plan et son exécution peut prendre un certain temps. Pour vérifier sa progression, cliquez sur l'icône d'installation de Microsoft .NET Framework 3.0 dans la zone de notification de la barre des tâches.

Pour installer un produit ou une technologie SharePoint

  1. Exécutez Setup.exe à partir du support d'installation.

  2. Entrez la clé de produit de 25 caractères.

  3. Acceptez le contrat de licence de logiciel.

  4. Cliquez sur Avancé.

    1. Dans Type de serveur, cliquez sur Web frontal.

    2. L'onglet Emplacement des données spécifie l'emplacement des fichiers d'index de recherche. Sous Emplacement des données, utilisez la valeur par défaut ou sélectionnez un ordinateur qui possède un espace disque supplémentaire.

    3. Cliquez sur Installer maintenant.

  5. Configurez le produit ou la technologie SharePoint. L'Assistant Configuration des produits et technologies SharePoint doit démarrer après que l'installation est terminée. Si tel n'est pas le cas, démarrez-le à partir des Outils d'administration.

    1. Dans l'écran de bienvenue, cliquez sur Suivant.

    2. Cliquez sur Oui pour redémarrer les services si besoin est.

    3. Dans la page Se connecter à une batterie de serveurs, cliquez sur Non, je veux créer une batterie de serveurs, puis cliquez sur Suivant.

    4. Dans la page Spécifier les paramètres de la base de données de configuration, entrez le nom du serveur de base de données. Si vous avez installé le moteur de base de données en tant qu'instance par défaut, le nom du serveur de base de données est celui de l'ordinateur.

    5. Dans Nom d'utilisateur et Mot de passe, tapez les informations d'identification d'un compte d'utilisateur de domaine autorisé à se connecter à l'ordinateur et disposant d'une connexion de base de données SQL Server, ainsi que d'autorisations DBCreator sur le serveur. Si possible, spécifiez un compte utilisé uniquement pour exécuter cette application. Ne tapez pas les informations d'identification d'un utilisateur qui accédera ultérieurement au site SharePoint ; cet utilisateur peut en effet recevoir des erreurs de type « accès refusé » ultérieurement, lors de l'accès au contenu du site. Cliquez sur Suivant.

    6. Dans la page Configurer l'application Web Administration centrale de SharePoint, cliquez sur Suivant pour accepter toutes les valeurs par défaut. Si vous savez que les fonctionnalités d'emprunt d'identité et de délégation sont activées pour l'authentification Windows dans votre domaine, vous pouvez sélectionner à la place Négocier (Kerberos). Sinon, sélectionnez la valeur par défaut et cliquez sur Suivant.

    7. Dans Fin de l'Assistant Configuration des produits et technologies SharePoint, cliquez sur Suivant pour commencer la configuration à l'aide des paramètres que vous avez spécifiés.

    8. Cliquez sur Terminer.

Pour configurer l'application Web SharePoint

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 2010. Suivez la liste de vérification qui s'affiche dans Tâches d'administration. Pour plus d'informations sur chaque tâche, cliquez sur le lien À LIRE EN PREMIER - Cliquez sur ce lien pour afficher les instructions de déploiement, puis cliquez sur Lire le Guide de démarrage rapide. Les tâches des étapes suivantes sont obligatoires.

  2. Créez une application Web :

    1. Cliquez sur Créer des sites SharePoint.

    2. Cliquez sur Créer une application Web.

    3. Sélectionnez Créer un nouveau site Web IIS (SharePoint - 80) en utilisant les valeurs par défaut. Ces valeurs incluent l'utilisation du port 80, aucun en-tête d'hôte, le chemin d'accès par défaut, NTLM et pas d'accès anonyme. Veillez à spécifier le compte du processus du pool d'applications. Choisissez un compte d'utilisateur de domaine.

    4. Cliquez sur OK.

  3. Dans la page Application créée, cliquez sur Créer une collection de sites.

    1. Entrez un titre.

    2. Utilisez les valeurs par défaut. Lorsque vous spécifiez l'Administrateur principal de la collection de sites, spécifiez un compte disposant d'autorisations d'administrateur local.

    3. Cliquez sur OK.

  4. Ouvrez une fenêtre d'invite de commandes et tapez iisrest /noforce.

  5. Cliquez sur l'URL pour vérifier le site.

  6. (Facultatif) Dans Administration Centrale, activez la journalisation des diagnostics.

Pour configurer le serveur de rapports pour le mode intégré SharePoint

  1. installez et configurez un serveur Web SharePoint frontal sur l'ordinateur serveur de rapports. Pour obtenir des instructions, consultez Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports..

    1. Une fenêtre de navigateur s'ouvre sur l'Administration Centrale du serveur principal et vous permet de vérifier que la configuration de la batterie de serveurs a réussi.

  2. Configurez le serveur de rapports en vue de l'intégration :

    1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour obtenir des instructions, consultez Procédure : lancer la configuration de Reporting Services.

    2. Dans le volet de navigation, cliquez sur Compte de service. Vérifiez qu'il utilise un compte d'utilisateur de domaine. Si ce n'est pas le cas, configurez-le de sorte qu'il en utilise un.

    3. Dans le volet de navigation, cliquez sur Base de données.

      Remarque :
      Si vous utilisez une instance distante du moteur de base de données, consultez Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services) pour plus d'informations.

    4. Cliquez sur Modifier la base de données.

    5. Sélectionnez Créer une nouvelle base de données.

    6. Cliquez sur Suivant.

    7. Spécifiez l'instance du moteur de base de données qui hébergera la base de données.

    8. Cliquez sur Tester la connexion pour vérifier que vous pouvez vous y connecter.

    9. Cliquez sur Suivant.

    10. Dans Nom de la base de données, tapez un nom pour la nouvelle base de données (par exemple, serveur_rapportsModeSharepoint).

    11. Sélectionnez Mode intégré à SharePoint.

    12. Cliquez sur Suivant.

    13. Spécifiez les informations d'identification que le serveur de rapports utilise pour se connecter à la base de données du serveur de rapports.

    14. Cliquez sur Suivant.

    15. Cliquez sur Suivant.

    16. Cliquez sur Terminer.

    17. Configurez le compte d'exécution sans assistance et tous les autres paramètres que vous souhaitez modifier. Les valeurs du répertoire virtuel Serveur de rapports doivent toujours être valides. Toutefois, le Gestionnaire de rapports n'est plus disponible à présent que vous avez configuré le serveur de rapports pour l'utilisation d'une base de données en mode intégré SharePoint (l'onglet du répertoire virtuel Gestionnaire de rapports doit être grisé).

Pour télécharger et installer le complément Reporting Services

  1. Cliquez sur Microsoft SQL Server 2008 pour ouvrir la page de téléchargement sur le site Web Microsoft.

    Important :
    Vous devez être administrateur de batterie de serveurs Web SharePoint et administrateur de collection de site pour installer le Complément Reporting Services.

  2. Choisissez la langue d'installation.

  3. Dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour installer la version 32 bits ou 64 bits du Complément Reporting Services.

  4. Cliquez sur Enregistrer pour enregistrer le fichier dans un emplacement sur votre ordinateur.

  5. Ouvrez l'Explorateur Windows et recherchez le dossier où le fichier se trouve.

  6. Double-cliquez sur rsSharePoint.msi pour commencer l'installation. Pour obtenir des instructions, consultez Procédure : installer ou désinstaller le complément Reporting Services.

  7. Obtenez la version la plus récente du fichier lisez-moi pour le Complément Reporting Services afin d'examiner les modifications de dernière minute et les problèmes connus. Dans la page de téléchargement sur le site Web de Microsoft, dans Fichiers composant ce téléchargement, cliquez sur Télécharger pour ouvrir le fichier readme_rsaddin.htm, puis enregistrez le fichier sur votre ordinateur.

Pour configurer l'intégration du serveur dans l'Administration centrale

  1. Cliquez sur Démarrer, sur Outils d'administration, puis sur Administration centrale de SharePoint 2010.

    Important :
    Pour effectuer les étapes suivantes, vous devez être membre du groupe Administrateur de batterie de serveurs SharePoint et un administrateur de la collection de sites.

  2. Cliquez sur Gestion des applications. Une nouvelle section nommée Reporting Services doit apparaître. Cette section inclut des liens vers des pages permettant de spécifier les paramètres d'intégration. Si vous ne voyez pas cette section, vous devez activer la fonctionnalité d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

    Au minimum, vous devez définir l'URL du serveur de rapports, sélectionner un mode d'authentification et accorder l'accès au serveur de rapports aux bases de données SharePoint. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

  3. Fermez l'Administration centrale.

Une erreur s'affiche si les services Reporting Services s'exécutent sous des comptes intégrés. Si vous avez déjà configuré les services pour l'utilisation de comptes d'utilisateurs de domaine, redémarrez-les pour effacer les anciennes informations de connexion (à supposer qu'il existe des connexions dans la session active). Pour plus d'informations sur la configuration des comptes de service, consultez Configuration du compte de service Report Server.

Étapes suivantes

Après avoir installé tous les composants et configuré les paramètres pour connecter des composants serveur, vous devez assigner des autorisations, ajouter des types de contenu et ajouter des éléments de serveur de rapports à une bibliothèque SharePoint.

Pour finir les tâches de déploiement pour l'intégration de serveur

  1. Ouvrez l'application Web SharePoint. Par défaut, l'URL est http://<votre-nom-serveur>.

  2. Définissez des autorisations pour accorder à l'utilisateur l'accès au site SharePoint. La sécurité est requise, mais si vous voulez hériter des autorisations existantes, vous n'êtes pas tenu de définir des autorisations sur des éléments spécifiques. Pour plus d'informations, consultez Accord d'autorisations sur des éléments de serveur de rapports sur un site SharePoint ou Procédure : définir les autorisations sur les éléments de serveur de rapports sur un site SharePoint (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  3. Ajoutez les types de contenu Reporting Services si vous voulez créer de nouvelles sources de données partagées, des modèles de rapport et des rapports du Générateur de rapports. Pour plus d'informations, consultez Procédure : ajouter des types de contenu de serveur de rapports à une bibliothèque (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  4. Créez des sources de données partagées à utiliser avec les rapports et les modèles. Pour plus d'informations, consultez Procédure : créer et gérer des sources de données partagées (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  5. Créez des planifications partagées à utiliser avec les abonnements ou le traitement de rapport sans assistance. Pour plus d'informations, consultez Procédure : créer et gérer des planifications partagées (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

  6. Publiez des fichiers de définition de rapport (.rdl), des fichiers de source de données (.rds) et des fichiers de modèle de rapport (.smdl) dans une bibliothèque SharePoint. Vous pouvez également utiliser la commande Télécharger dans une bibliothèque SharePoint pour télécharger des fichiers .rdl et .smdl, mais pas des fichiers .rds. Selon vos autorisations, vous pouvez également créer des rapports dans le Générateur de rapports et les enregistrer dans une bibliothèque. Si les rapports incluent des références à des sources de données partagées ou à des fichiers externes, vous devez mettre à jour ces références. Pour plus d'informations, consultez Déploiement de modèles et de sources de données partagées sur un site SharePoint et Procédure : télécharger des documents vers une bibliothèque SharePoint (Reporting Services en mode intégré SharePoint) dans la documentation en ligne de SQL Server.

Lorsque vous téléchargez des rapports, assurez-vous que les propriétés de source de données du rapport sont correctes. La source de données doit avoir une chaîne de connexion valide vers une source de données externe. Le type d'informations d'identification doit être valide pour votre topologie de réseau. En particulier, si l'authentification Kerberos n'est pas activée pour votre domaine, vous ne pouvez pas utiliser le type d'informations d'identification de sécurité intégrée de Windows. À la place, vous devez spécifier des informations d'identification stockées. Après avoir vérifié que les propriétés de source de données sont correctes, vous pouvez cliquer sur le nom du rapport pour ouvrir le rapport. Le rapport s'ouvre automatiquement dans le composant WebPart de visionneuse de rapports.

Si le rapport ne s'ouvre pas, vérifiez les autorisations sur le rapport et les propriétés de source de données qui définissent une connexion à la source de données externe. Sur un site ou dans une batterie de serveurs, les autorisations SharePoint permettent de contrôler l'accès aux rapports, aux modèles de rapport, aux sources de données partagées et à l'outil Générateur de rapports utilisé pour créer des rapports appropriés. Si ces éléments ne sont pas visibles pour les utilisateurs, vous devez vérifier que les autorisations sont définies correctement.

Un serveur de rapports qui s'exécute en mode intégré SharePoint ne peut pas être géré par le biais du Gestionnaire de rapports. Pour obtenir la liste complète des fonctionnalités prises en charge et non prises en charge, consultez Fonctionnalités prises en charge par Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : configurer l'intégration à SharePoint sur un serveur autonome

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 2010
Configuration du compte d'exécution sans assistance
Configuration d'un Report Server pour la remise du courrier électronique

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Reporting Services utilise une base de données SQL Server pour le stockage interne. La base de données est un composant nécessaire ; elle permet de stocker les rapports publiés, les modèles, les sources de données partagées, les données de session, les ressources et les métadonnées du serveur.

Pour créer une base de données du serveur de rapports ou modifier la chaîne de connexion ou les informations d'identification, utilisez les options de la page Base de données de l'outil de configuration de Reporting Services.

Quand créer ou configurer les bases de données de serveur de rapports

Vous devez créer et configurer la base de données du serveur de rapports si vous avez installé le serveur de rapports en mode fichiers uniquement.

Si vous avez installé Reporting Services dans la configuration par défaut pour le mode natif ou le mode intégré SharePoint, la base de données du serveur de rapports a été créée et configurée automatiquement lorsque l'instance du serveur de rapports a été installée. Vous pouvez utiliser l'outil de configuration de Reporting Services pour afficher ou modifier les paramètres que le programme d'installation a configurés automatiquement.

Avant de commencer

La création ou la configuration d'une base de données de serveur de rapports est un processus comportant plusieurs étapes. Avant de créer la base de données du serveur de rapports, pensez à la façon dont vous souhaitez spécifier les éléments suivants :

Sélectionner un serveur de base de données

Reporting Services requiert une instance du moteur de base de données SQL Server 2005 ou 2008 pour héberger la base de données du serveur de rapports. Vous pouvez utiliser un serveur local ou distant.

Vérifier les spécifications d'édition

Vérifiez que l'édition du moteur de base de données est compatible avec l'édition du serveur de rapports que vous utilisez. Pour plus d'informations sur la compatibilité des éditions, consultez Création d'une base de données de serveur de rapports.

Activer les connexions TCP/IP

Activez les connexions TCP/IP pour le moteur de base de données. Certaines éditions du moteur de base de données n'activent pas TCP/IP par défaut. Les instructions sont fournies dans cette rubrique.

Ouvrir le port pour SQL Server

Pour un serveur distant, si vous utilisez le logiciel de pare-feu, vous devez ouvrir le port sur lequel le moteur de base de données écoute.

Choisir un mode

Une base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Mode natif est la valeur par défaut. Utilisez ce mode lorsque vous souhaitez déployer Reporting Services comme serveur d'applications autonome.

Mode intégré SharePoint est utilisé lorsque vous projetez de déployer le serveur de rapports avec une instance d'un produit ou d'une technologie SharePoint. La base de données est créée lorsque vous exécutez l'Assistant, mais vous n'êtes pas en mesure d'ajouter un contenu ou d'afficher des éléments tant que vous n'avez pas ajouté le serveur de rapports à une batterie de serveurs SharePoint. Pour plus d'informations, consultez Planification d'un mode de déploiement dans la documentation en ligne de SQL Server.

Choisir les informations d'identification du serveur de rapports

Décidez comment le serveur de rapports se connectera aux bases de données de serveur de rapports. Les types d'informations d'identification incluent le compte d'utilisateur de domaine, le compte d'utilisateur de la base de données SQL Server ou le compte de service Report Server.

Ces informations d'identification sont chiffrées et stockées dans le fichier RSReportServer.config. Le serveur de rapports utilise ces informations d'identification pour les connexions continues à la base de données du serveur de rapports. Si vous souhaitez utiliser un compte d'utilisateur Windows ou un compte d'utilisateur de base de données, veillez bien à en spécifier un qui existe déjà. Bien que l'outil de configuration de Reporting Services crée une connexion et définisse les autorisations nécessaires, il ne crée pas de compte automatiquement. Pour plus d'informations, consultez Configuration d'une connexion de base de données de serveur de rapports.

Choisir une langue du serveur de rapports

Choisissez une langue à spécifier pour le serveur de rapports. Les noms de rôle prédéfinis, les descriptions et les dossiers Mes rapports n'apparaissent pas en différentes langues lorsque les utilisateurs se connectent au serveur à l'aide de différentes versions linguistiques d'un navigateur. Pour plus d'informations sur la façon dont les ressources de langue sont utilisées dans un déploiement de serveur de rapports, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services) dans la documentation en ligne de SQL Server.

Vérifier les informations d'identification pour créer et mettre en service la base de données

Vérifiez que les informations d'identification de votre compte ont l'autorisation de créer des bases de données sur l'instance du moteur de base de données. Ces informations d'identification sont utilisées pour une connexion unique afin de créer la base de données du serveur de rapports et RSExecRole. Si une connexion n'existe pas déjà, une connexion d'utilisateur de la base de données est créée pour le compte utilisé par le serveur de rapports pour se connecter à la base de données. Vous pouvez vous connecter sous le compte Microsoft Windows avec lequel vous êtes connecté ou vous pouvez entrer une connexion de base de données SQL Server.

Pour activer l'accès à une base de données distante du serveur de rapports

  1. Si vous utilisez une instance distante du moteur de base de données, ouvrez une session sur le serveur de base de données pour vérifier ou activer les connexions TCP/IP.

  2. Dans le menu Démarrer, pointez successivement sur Tous les programmes, Microsoft SQL Server et Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.

  3. Ouvrez Configuration du réseau SQL Server.

  4. Sélectionnez l'instance.

  5. Cliquez avec le bouton droit sur TCP/IP, puis cliquez sur Activé.

  6. Redémarrez le service.

  7. Ouvrez votre logiciel de pare-feu, ainsi que le port sur lequel SQL Server écoute. Pour l'instance par défaut, il s'agit généralement du port 1433 pour les connexions TCP/IP. Pour plus d'informations, consultez Procédure : configurer un pare-feu Windows pour accéder au moteur de base de données dans la documentation en ligne de SQL Server.

Pour créer une base de données locale du serveur de rapports

  1. Démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports pour laquelle vous créez la base de données. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

  2. Dans la page Base de données, cliquez sur Modifier la base de données.

  3. Cliquez sur Créer une base de données, puis cliquez sur Suivant.

  4. Connectez-vous à l'instance du moteur de base de données que vous allez utiliser pour créer et héberger la base de données du serveur de rapports :

    1. Tapez l'instance du moteur de base de données SQL Server que vous souhaitez utiliser. L'Assistant affiche un moteur de base de données local qui s'exécute comme instance par défaut en cas de disponibilité. Sinon, vous devez entrer le serveur et l'instance à utiliser. Les instances nommées sont spécifiées dans le format suivant : <nom_ serveur>\<nom_instance>.

    2. Entrez les informations d'identification utilisées pour une connexion unique au moteur de base de données en vue de créer les bases de données du serveur de rapports. Pour plus d'informations sur la façon dont ces informations d'identification sont utilisées, consultez Avant de commencer dans cette rubrique.

    3. Pour valider la connexion au serveur, cliquez sur Tester la connexion.

    4. Cliquez sur Suivant.

  5. Spécifiez les propriétés utilisées pour créer la base de données. Pour plus d'informations sur la façon dont ces propriétés sont utilisées, consultez Avant de commencer dans cette rubrique :

    1. Tapez le nom de la base de données du serveur de rapports. Une base de données temporaire est créée parallèlement à la base de données primaire. Pensez à utiliser un nom descriptif qui vous aidera à vous rappeler comment la base de données est utilisée. Notez que le nom que vous spécifiez sera utilisé pendant toute la durée de vie de la base de données. Vous ne pouvez pas renommer une base de données du serveur de rapports après sa création.

    2. Sélectionnez la langue dans laquelle vous souhaitez que les définitions de rôle et Mes rapports apparaissent.

    3. Sélectionnez le mode serveur. Sélectionnez toujours Mode natif à moins que vous ne projetiez de déployer le serveur de rapports avec un produit ou une technologie SharePoint.

    4. Cliquez sur Suivant.

  6. Spécifiez les informations d'identification que le serveur de rapports doit utiliser pour se connecter à la base de données du serveur de rapports.

    1. Spécifiez le type d'authentification :

      Sélectionnez Informations d'identification de la base de données pour vous connecter à l'aide d'une connexion de base de données SQL Server déjà définie. L'utilisation d'informations d'identification de base de données est recommandée si le serveur de rapports se trouve sur un ordinateur qui est dans un domaine différent, un domaine non approuvé ou derrière un pare-feu.

      Sélectionnez Informations d'identification Windows si vous avez un compte d'utilisateur de domaine avec les privilèges les plus faibles qui a l'autorisation de se connecter à l'ordinateur et au serveur de base de données.

      Sélectionnez Informations d'identification du service si vous souhaitez que le serveur de rapports se connecte à l'aide de son compte de service. Avec cette option, le serveur se connecte en utilisant la sécurité intégrée ; les informations d'identification ne sont pas chiffrées ou stockées.

    2. Cliquez sur Suivant.

  7. Examinez les informations sur la page Résumé pour vérifier que les paramètres sont corrects, puis cliquez sur Suivant.

  8. Vérifiez la connexion en cliquant sur une URL de la page URL de Report Server ou de la page URL du Gestionnaire de rapports. Les URL doivent être définies dans l'ordre pour que ce test fonctionne. Si la connexion à la base de données du serveur de rapports est valide, vous pouvez voir l'arborescence des dossiers du serveur de rapports ou le Gestionnaire de rapports dans une fenêtre de navigateur. Pour plus d'informations, consultez Procédure : vérifier une installation de Reporting Services dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Référence

Base de données (configuration de Reporting Services)

Concepts

Configuration d'une connexion de base de données de serveur de rapports
Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services)

Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Utilisez l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports en mode intégré SharePoint et configurer la connexion du serveur de rapports à la base de données du serveur de rapports. Seul le serveur de rapports se connecte à la base de données du serveur de rapports. L'instance de Windows SharePoint Services ou de Office SharePoint Server que vous intégrez au serveur de rapports ne se connecte jamais à la base de données du serveur de rapports ou n'en extrait jamais directement de données.

Une base de données du serveur de rapports peut prendre en charge les opérations en mode natif ou en mode d'intégration SharePoint, mais pas les deux. Si vous créez une base de données du serveur de rapports pour prendre en charge le mode intégré SharePoint, vous ne pouvez ni convertir ni migrer la base de données pour qu'elle s'exécute ultérieurement avec une instance du serveur de rapports en mode natif. La base de données du serveur de rapports contient des métadonnées spécifiques au mode (plus spécifiquement, des informations relatives aux emplacements des éléments et aux autorisations).

Lorsqu'elle est créée en mode intégré SharePoint, la base de données du serveur de rapports contient les propriétés du serveur, des instantanés d'exécution de rapport, un historique des rapports, des définitions d'abonnement et des planifications. Elle contient une copie secondaire des rapports, des modèles de rapports, des sources de données partagées et des ressources afin d'améliorer les performances de traitement sur le serveur. Le stockage principal pour les documents de rapports se trouve dans les bases de données de contenu SharePoint. Pour plus d'informations, consultez Stockage et synchronisation de contenu de serveur de rapports avec des bases de données SharePoint dans la documentation en ligne de SQL Server.

Voici les principaux points à se souvenir à propos d'une base de données du serveur de rapports prenant en charge les intégrations SharePoint :

  • Utilisez l'Assistant Modification de base de données de la page Base de données de l'outil de configuration de Reporting Services pour créer la base de données du serveur de rapports en mode intégré SharePoint. Pour obtenir des instructions, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) dans la documentation en ligne de SQL Server.

  • Utilisez l'outil de configuration de Reporting Services pour maintenir ou mettre à jour les informations de connexion à la base de données du serveur de rapports.

  • Utilisez SQL Server Management Studio et les outils SQL Server pour sauvegarder et administrer une base de données du serveur de rapports. Les fonctionnalités de sauvegarde de base dans Administration Centrale de SharePoint 3.0 ne s'appliquent pas à une base de données du serveur de rapports.

  • La création de la base de données du serveur de rapports ne constitue qu'une étape dans un processus à plusieurs étapes qui configure un serveur de rapports pour les opérations d'intégration. Après avoir créé la base de données, effectuez les étapes d'intégration en démarrant l'administration centrale SharePoint 3.0 et en spécifiant les paramètres d'intégration du serveur de rapports. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 2010
Configuration d'une connexion de base de données de serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : activer les erreurs distantes (configuration de Reporting Services)

Procédure : activer les erreurs distantes (configuration de Reporting Services)
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Remarque Pour SQL Server 2008 R2, il n'y a pas eu de modifications au contenu répertorié dans cette rubrique.

Vous pouvez définir des propriétés de serveur sur un serveur de rapports de façon à retourner des informations supplémentaires concernant les conditions d'erreur qui se produisent sur des serveurs distants. Si un message d'erreur contient le texte « Pour obtenir plus d'informations sur cette erreur, accédez au serveur de rapports sur le serveur local ou activez les erreurs distantes », vous pouvez définir la propriété EnableRemoteErrors de façon à accéder à des informations supplémentaires qui peuvent vous aider à résoudre le problème. Pour plus d'informations, consultez Propriétés système de Report Server dans la documentation en ligne de SQL Server.

Remarque :
Vous pouvez modifier la table ConfigurationInfo dans la base de données du serveur de rapports afin d'affecter la valeur True à EnableRemoteErrors, mais si le serveur de rapports est utilisé de manière active, vous devez utiliser SQL Server Management Studio ou un script pour modifier les paramètres.

Activer les erreurs distantes à travers SQL Server Management Studio

  1. Démarrez Management Studio et connectez-vous à une instance du serveur de rapports. Pour plus d'informations, consultez Procédure : se connecter à un serveur de rapports dans Management Studio dans la documentation en ligne de SQL Server.

  2. Cliquez avec le bouton droit sur le nœud du serveur de rapports et sélectionnez Propriétés.

  3. Cliquez sur Avancé pour ouvrir la page de propriétés. Pour plus d'informations, consultez Server Properties (Advanced Page) - Reporting Services dans la documentation en ligne de SQL Server.

  4. Dans EnableRemoteErrors, sélectionnez True.

  5. Cliquez sur OK.

Activation d'erreurs distantes par le biais d'un script

  1. Créez un fichier texte et copiez-y le script suivant.

    Copier le code
    Public Sub Main()
  Dim P As New [Property]()
  P.Name = "EnableRemoteErrors"
  P.Value = True
  Dim Properties(0) As [Property]
  Properties(0) = P
  Try
    rs.SetSystemProperties(Properties)
    Console.WriteLine("Remote errors enabled.")
  Catch SE As SoapException
    Console.WriteLine(SE.Detail.OuterXml)
  End Try
End Sub

  2. Enregistrez le fichier sous le nom EnableRemoteErrors.rss.

  3. Cliquez sur Démarrer, pointez sur xécuter, tapez cmd et cliquez sur OK pour ouvrir une fenêtre d'invite de commandes.

  4. Accédez au répertoire qui contient le fichier .rss que vous venez de créer.

  5. Tapez la ligne de commande suivante, en remplaçant servername par le nom de votre serveur.

    Copier le code
    rs -i EnableRemoteErrors.rss -s http://servername/ReportServer


Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports. |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous configurez un serveur de rapports pour qu'il s'exécute en mode intégré SharePoint dans une batterie de serveurs SharePoint qui consiste en plusieurs serveurs, vous devez installer l'application Web frontale d'un produit SharePoint sur le serveur de rapports afin de pouvoir joindre le serveur de rapports à la batterie.

Une batterie de serveurs SharePoint consiste en plusieurs serveurs qui utilisent tous la même version du produit SharePoint. Par exemple, si la batterie de serveurs utilise SharePoint Foundation 2010 3.0, vous devez installer SharePoint Foundation 2010 3.0 sur le serveur de rapports.

Pour installer le frontal Web, vous devez être un administrateur d'une batterie de serveurs SharePoint. Vous devez également connaître le nom du serveur de base de données et la base de données de configuration utilisée par la batterie de serveurs.

Les étapes suivantes ne sont requises que si vous déployez un serveur de rapports dans une batterie de serveurs SharePoint. Si toutes les applications serveur s'exécutent sur un seul ordinateur, l'installation du Web frontal sur le serveur de rapports n'est pas nécessaire.

Après avoir installé le Web frontal et joint le serveur de rapports à la batterie, vous pouvez utiliser l'administration centrale de SharePoint pour désactiver les fonctionnalités du Web frontal dont vous n'avez pas besoin.

Pour installer le Web frontal

  1. Sur le serveur qui exécute Reporting Services, exécutez le programme d'installation pour le produit SharePoint utilisé pour la batterie.

  2. Dans Types d'installation, cliquez sur Avancée.

  3. Dans Type de serveur, sélectionnez Frontal Web.

  4. L'onglet Emplacement des données spécifie l'emplacement des fichiers d'index de recherche. Sur Emplacement des données, utilisez la valeur par défaut ou choisissez un ordinateur qui possède un espace disque supplémentaire.

  5. Cliquez sur Installer maintenant.

Après avoir fini l'Installation, vous devez configurer le Web frontal pour le joindre à la batterie de serveurs.

Pour configurer le Web frontal

  1. Exécutez l'Assistant Configuration des produits et technologies SharePoint pour joindre le frontal Web à la batterie de serveurs SharePoint distante. L'Assistant Configuration d'un produit ou d'une technologie SharePoint doit démarrer après que l'installation est terminée. Si tel n'est pas le cas, démarrez-le à partir des Outils d'administration.

  2. Dans l'écran de bienvenue, cliquez sur Suivant.

  3. Cliquez Oui pour redémarrer les services si besoin est.

  4. Dans la page Se connecter à une batterie de serveurs, sélectionnez Oui pour vous connecter à une batterie de serveurs existante. Cliquez sur Suivant.

  5. Dans la page Spécifier les paramètres de la base de données de configuration, spécifiez l'instance du moteur de base de données SQL Server qui héberge la base de données de configuration. Si vous ne connaissez pas le nom de la base de données de configuration, cliquez sur Récupérer les noms de bases de données, puis sélectionnez la base de données de configuration.

  6. Entrez un nom d'utilisateur et un mot de passe que le frontal Web utilisera pour se connecter à la base de données de configuration. Cliquez sur Suivant.

  7. Dans la page Fin de l'Assistant Configuration des produits et technologies SharePoint, cliquez sur Paramètres avancés.

  8. Dans Paramètres avancés, vérifiez que l'option Ne pas utiliser cet ordinateur pour héberger le site Web est sélectionnée.

  9. Cliquez sur OK, sur Suivant, puis terminez l'Assistant.

L'installation du frontal Web n'est qu'une étape dans le processus global de configuration. Pour plus d'informations sur la procédure complète, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

Pour plus d'informations sur la configuration d'un déploiement multi-serveur qui intègre Reporting Services et les produits et technologies SharePoint, consultez Procédure : configurer l'intégration à SharePoint sur plusieurs serveurs.

Voir aussi

Concepts

Procédure : installer ou désinstaller le complément Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : installer ou désinstaller le complément Reporting Services

Procédure : installer ou désinstaller le complément Reporting Services |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Le Complément Microsoft SQL Server Reporting Services pour les produits SharePoint 2010 correspond à un téléchargement Web que vous pouvez installer sur un serveur doté d'une instance d'un produit ou d'une technologie SharePoint. Il fournit un jeu des fonctionnalités qui vous permettent d'exécuter un serveur de rapports dans un plus grand déploiement de Microsoft SharePoint Foundation 2010 ou Microsoft SharePoint Server 2010. Ces fonctionnalités incluent un composant WebPart visionneuse de rapports, un point de terminaison de proxy d'URL et des pages d'application qui vous permettent de créer, d'afficher et de gérer des rapports, des modèles de rapport, des souces de données et tout autre contenu du serveur de rapports sur un site SharePoint. Le complément Reporting Services pour les produits SharePoint 2010 est un composant requis pour un serveur de rapports qui s'exécute en mode intégré SharePoint.

Important :
Un déploiement de Reporting Services est intégré dans un déploiement d'un produit SharePoint 2010 au niveau de la batterie de serveurs. Si vous possédez plusieurs applications Web SharePoint dans une configuration de batterie de serveurs, vous devez installer le complément Reporting Services sur chaque ordinateur qui possède un serveur Web frontal. Il est recommandé d'utiliser l'Assistant Installation pour installer tout d'abord le complément Reporting Services sur l'un des ordinateurs Web frontaux. Utilisez ensuite l'installation en mode fichiers uniquement pour installer le complément de manière séquentielle sur les autres ordinateurs Web frontaux de la batterie de serveurs. Une fois l'installation en mode fichiers uniquement terminée, démarrez l'installation sur l'ordinateur Web frontal suivant, et ainsi de suite jusqu'à ce que vous ayez terminé l'installation sur tous les ordinateurs Web frontaux de la batterie de serveurs SharePoint. Démarrez ensuite l'Administration centrale de SharePoint pour configurer l'intégration du serveur de rapports pour tous les serveurs Web frontaux de la batterie de serveurs SharePoint.

Préparation de l'installation

L'installation du complément Reporting Services est l'une des nombreuses étapes nécessaires pour intégrer un serveur de rapports à une instance d'un produit ou d'une technologie SharePoint. Pour plus d'informations sur la procédure complète, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010. L'ordre des étapes de configuration des serveurs est important. Pour obtenir les meilleurs résultats possibles, prenez soin de les exécuter dans l'ordre.

Pour préparer l'installation du complément Reporting Services :

  1. Connectez-vous en tant qu'administrateur d'une batterie de serveurs SharePoint pour installer le complément Reporting Services.

  2. Vérifiez que vous disposez de deux installations de serveur – un serveur de rapports et un serveur SharePoint – qui répondent aux conditions requises pour le fonctionnement intégré. Pour plus d'informations, consultez Configuration requise pour l'exécution de Reporting Services en mode intégré SharePoint dans la documentation en ligne de SQL Server.

  3. Téléchargez le complément Reporting Services sur un serveur doté d'une instance du produit SharePoint.

    1. Accédez à la page du complément Microsoft SQL Server Reporting Services pour les produits SharePoint 2010 sur le Centre de téléchargement Microsoft.

    2. Sélectionnez et téléchargez la version linguistique à installer. Le composant WebPart visionneuse de rapports (ReportViewer.dwp) sera disponible uniquement dans la langue que vous choisissez. Les pages et messages d'application seront disponibles dans toutes les langues prises en charge, quelle que soit la langue que vous sélectionnez dans la page Téléchargement. Pour plus d'informations sur les langues prises en charge, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services) dans la documentation en ligne de SQL Server.

  4. Si vous intégrez Reporting Services à une batterie de serveurs SharePoint qui possède plusieurs applications Web frontales, copiez ou téléchargez le fichier rsSharepoint.msi sur chaque ordinateur de la batterie de serveurs qui possède un serveur Web frontal. Effectuez cette opération uniquement pour les serveurs Web frontaux qui seront utilisés pour accéder à du contenu de serveur de rapports.

Installation du complément

Pour installer le complément Reporting Services, vous devez être administrateur sur l'ordinateur.

Vous devez être administrateur de collection de sites pour activer la fonctionnalité d'intégration Reporting Services.

Dans cette version, le complément peut être installé avant ou après l'installation de SharePoint. Le complément suit les normes de prédéploiement SharePoint et installe les fichiers dans les emplacements utilisés par l'installation SharePoint.

Remarque :
L'avantage de l'installation du complément avant le produit ou la technologie SharePoint est que le complément Reporting Services est configuré et activé par la batterie de serveurs SharePoint à mesure que les nouveaux serveurs sont ajoutés à la batterie.

Installation du complément avant un produit ou une technologie SharePoint

Le complément doit être installé sur tous les serveurs qui s'exécuteront en tant que serveurs Web frontaux SharePoint Web et que vous souhaitez intégrer avec Reporting Services. Si le produit ou la technologie SharePoint n'a pas encore été installé, vous pouvez exécuter l'Assistant Installation de complément sur tous les serveurs.

  1. Téléchargez le programme d'installation (rsSharepoint.msi) du complément Reporting Services.

  2. En tant qu'administrateur, lancez rsSharepoint.msi pour exécuter l'Assistant Installation. L'Assistant affiche une page d'accueil, les termes du contrat de licence logiciel et une page d'information relative à l'inscription. L'installation crée des dossiers SharePoint 2010 sous %program files%\common files\Microsoft Shared\ et copie des fichiers vers ces dossiers. Vous devez exécuter le fichier .msi en tant qu'administrateur ; pour ce faire, commencez par ouvrir une fenêtre d'invite de commandes avec des privilèges élevés, puis exécutez rsSharepoint.msi à partir de la ligne de commande.

  3. Configurez les paramètres d'intégration du serveur de rapports et l'activation de fonctionnalités dans l'Administration centrale de SharePoint.

Installation du complément après l'installation d'un produit ou d'une technologie SharePoint

Lors de l'installation du complément sur les serveurs après l'installation d'un produit ou d'une technologie SharePoint, vous ne pouvez exécuter l'installation complète du complément que sur un seul serveur SharePoint. Pour les autres serveurs SharePoint de la batterie, vous devez exécuter l'installation de fichiers uniquement pour le complément à partir de la ligne de commande. L'installation de fichiers uniquement installe les fichiers mais ignore la section Actions personnalisées de la procédure d'installation.

Après avoir installé le complément sur chaque serveur, démarrez l'Administration centrale de SharePoint pour configurer l'intégration du serveur de rapports.

Installation de fichiers uniquement

Pour installer les fichiers mais ignorer les étapes Actions personnalisées, exécutez le fichier .msi à partir de la ligne de commande avec l'option SKIPCA :

  1. En utilisant des autorisations d'administrateur, ouvrez une invite de commandes.

  2. Exécutez msiexec -i rsSharePoint.msi SKIPCA=1.

Deux étapes pour une installation complète du complément

Si vous obtenez des erreurs pendant l'installation, vous pouvez exécuter le programme d'installation comme un processus en deux étapes à partir de la ligne de commande. Commencez par exécuter le programme d'installation afin d'installer les fichiers et d'ignorer les actions personnalisées, puis lancez un exécutable d'actions personnalisées. Pour installer le complément Reporting Services en mode fichiers uniquement, procédez comme suit :

  1. En utilisant des autorisations d'administrateur, ouvrez une invite de commandes.

  2. Exécutez msiexec -i rsSharePoint.msi SKIPCA=1.

  3. Recherchez le fichier rsCustomAction.exe dans le système de fichiers. Ce fichier est copié sur votre ordinateur par le programme d'installation. Il se trouve dans le répertoire %Temp%.

    Pour obtenir les informations relatives au chemin d'accès à ce fichier, cliquez sur Démarrer, sur Exécuter, puis tapez %temp%. Le fichier doit se trouver dans \Documents and Settings\<votre_nom>\LOCALS~1\Temp.

    Ouvrez une fenêtre d'invite de commandes. Pour cela, cliquez sur Démarrer, sur Exécuter, puis tapez cmd. Sur les systèmes d'exploitation plus récents, vous devrez peut-être élever vos autorisations et réaliser l'exécution avec les autorisations d'administrateur.

  4. Naviguez jusqu'au dossier contenant l'exécutable rsCustomAction.

  5. Entrez la commande suivante. Cette étape de configuration nécessitera plusieurs minutes. Le service W3SVC sera redémarré pendant ce processus.

    Copier le code
    rsCustomAction.exe /i

Procédure de suppression du complément Reporting Services

Vous pouvez désinstaller le complément Reporting Services pour les produits SharePoint 2010 en exécutant le programme d'installation (rsSharepoint.msi) en mode de désinstallation. La désinstallation du complément entraîne la suppression des fonctionnalités d'intégration utilisées pour traiter les rapports et les modèles sur un serveur de rapports.

Pour désinstaller le complément Reporting Services, une installation SharePoint Foundation 2010 ou SharePoint Server 2010 2007 doit être en cours d'exécution. Si vous désinstallez d'abord le programme SharePoint 2010, vous devez le réinstaller pour pouvoir désinstaller le complément Reporting Services.

Remarque :
La suppression du complément à partir d'un serveur qui est actif dans la batterie supprime le complément sur tous les serveurs dans la batterie. Si vous ne souhaitez supprimer le complément que sur un seul serveur, commencez par supprimer ce serveur de la batterie de serveurs SharePoint, puis désinstallez le complément.

  • Sur le site SharePoint, supprimez tous les rapports et autres éléments de serveur de rapports que vous n'utilisez plus. Ils ne pourront plus être exécutés après la suppression du complémentReporting Services.

  • Dans le Panneau de configuration, dans Programmes, sélectionnez Désinstaller un programme, puis Complément Microsoft SQL Server 2008 R2 Reporting Services pour SharePoint.

  • Cliquez sur Supprimer.

Les étapes de désinstallation du complément sont identiques pour les serveurs autonomes et les batteries de serveurs. Le programme d'installation supprimera les fichiers de programme et tous les paramètres de configuration qui ont été ajoutés durant l'installation.

Les éléments suivants ne seront pas supprimés :

  • Les comptes de connexion créés pour le compte de service Report Server qui étaient utilisés pour accéder aux bases de données de contenu et de configuration SharePoint. Vous devez supprimer les comptes de connexion pour le compte de service Report Server à partir de l'instance du moteur de base de données SQL Server utilisée pour héberger les bases de données SharePoint.

  • Autorisations ou groupes créées pour les utilisateurs de rapports. Si vous avez créé des groupes SharePoint ou des niveaux d'autorisation personnalisés pour accorder l'accès aux fonctionnalités du serveur de rapports, vous devez révoquer toutes les autorisations qui ne sont plus nécessaires.

  • Fichiers de données que vous avez téléchargés vers une bibliothèque SharePoint, y compris les fichiers de définition de rapport (.rdl), de modèle de rapport (.smdl), de source de données partagée (.rsds) et d'éléments de rapports publiés (.rsc). Ces fichiers ne seront pas supprimés mais ils ne s'exécuteront plus. Vous devez les supprimer manuellement.

  • Le programme d'installation ne supprimera pas la base de données du serveur de rapports et ne modifiera pas l'instance du serveur de rapports utilisée pour les opérations intégrées. Après avoir désinstallé le complément, vous pouvez exécuter le serveur de rapports en mode natif si vous souhaitez utiliser l'instance comme application de création de rapports autonome.

Procédure d'exécution de rsSharePoint.msi à partir de la ligne de commande

Vous pouvez exécuter le programme d'installation à partir de la ligne de commande pour réparer ou désinstaller le complément Reporting Services.

  • Exécutez rsSharePoint.msi -r pour réparer une installation existante.

  • Exécutez rsSharePoint.msi -u pour désinstaller une installation existante du complément.

Fichiers journaux d'installation

Lors de son exécution, le programme d'installation enregistre des informations dans un fichier journal, dans le dossier %temp% de l'utilisateur qui installe le complément Reporting Services. Le nom de ce fichier est RS_SP_<numéro>.log. Chaque erreur consignée dans ce journal commence par la chaîne « SSRSCustomActionError ».

Configuration et activation

Après avoir installé le complément, vous devez configurer et vérifier l'activation de la fonctionnalité à partir de l'Administration centrale de SharePoint. Pour plus d'informations, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint et Procédure : activer la fonctionnalité Report Server dans l'Administration centrale SharePoint.

Mise à niveau

Si vous avez une installation existante du complément Reporting Services, vous pouvez effectuer une mise à niveau vers la version actuelle. Le programme d'installation détectera la version existante et vous invitera à confirmer la mise à jour. Si vous confirmez, la version antérieure du complément sera supprimée, puis la nouvelle installée.

Notez que le complément Reporting Services n'est pas dépendant des instances. Vous ne pouvez avoir qu'une seule instance du complément sur un ordinateur. Vous ne pouvez pas exécuter des versions antérieures côte à côte avec la version actuelle.

Voir aussi

Tâches

Procédure : basculer entre les modes serveur (configuration de Reporting Services)
Procédure : installer un serveur Web SharePoint frontal sur un serveur de rapports.

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 2010

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : inscrire un nom de principal du service (SPN) pour Report Server

Procédure : inscrire un nom de principal du service (SPN) pour Report Server |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous déployez Reporting Services dans un réseau qui utilise le protocole Kerberos pour l'authentification mutuelle, vous devez créer un nom de principal du service (SPN) pour le service Report Server si vous le configurez pour s'exécuter en tant que compte d'utilisateur de domaine. De plus, lorsque vous configurez un utilisateur de domaine en tant que compte de service, le serveur de rapports doit être configuré de manière à utiliser l'authentification NTLM.

À propos des noms principaux de service

Un nom principal de service est un identificateur unique pour un service sur un réseau qui utilise l'authentification Kerberos. Il est composé d'une classe de service, d'un nom d'hôte et d'un port. Sur un réseau qui utilise l'authentification Kerberos, un nom principal de service pour le serveur doit être inscrit sous un compte d'ordinateur prédéfini (tel que NetworkService ou LocalSystem) ou un compte d'utilisateur. Les noms principaux de service sont enregistrés automatiquement pour les comptes intégrés. Toutefois, lorsque vous exécutez un service sous un compte d'utilisateur de domaine, vous devez inscrire manuellement le nom principal de service pour le compte que vous souhaitez utiliser.

Pour créer un nom principal de service, vous pouvez utiliser l'utilitaire de ligne de commande SetSPN. Pour plus d'informations, consultez Setspn sur Microsoft Windows Server TechCenter.

Vous devez être administrateur de domaine pour exécuter l'utilitaire sur le contrôleur de domaine.

Syntaxe

La syntaxe de commande pour utiliser l'utilitaire SetSPN en vue de créer un SPN pour le serveur de rapports ressemble à ce qui suit :

Copier le code
Setspn -a http/<computername>.<domainname>:<port> <domain-user-account>

SetSPN est disponible avec le pack d'outils de support Windows Server 2003 Service Pack 1, que vous devez télécharger séparément. L'argument -a est utilisé pour inscrire un nom de principal du service auprès d'un compte particulier.

HTTP est la classe de service. Le service Web Report Server s'exécute dans HTTP.SYS. L'une des conséquences de la création d'un nom principal de service pour HTTP est que des tickets seront accordés à toutes les applications Web sur le même ordinateur qui s'exécutent dans HTTP.SYS (y compris les applications hébergées dans les services Internet (IIS)) en fonction du compte d'utilisateur de domaine. Si ces services s'exécutent sous un compte différent, les demandes d'authentification échouent. Pour éviter ce problème, assurez-vous de configurer toutes les applications HTTP pour qu'elles s'exécutent sous le même compte ou envisagez la création d'en-têtes d'hôtes pour chaque application puis la création de noms principaux de service distincts pour chaque en-tête d'hôte. Lorsque vous configurez des en-tête de l'hôte, les modifications de DNS sont requises indépendamment de la configuration Reporting Services.

Les valeurs que vous spécifiez pour <nom_ordinateur>, <nom_domaine> et <port> identifient l'adresse réseau unique de l'ordinateur qui héberge le serveur de rapports. Ce peut être un nom d'hôte local ou un nom de domaine complet (FQDN). Si vous n'avez qu'un seul domaine et que vous utilisez le port 80, vous pouvez omettre <nom_domaine> et <port> de votre ligne de commande. <compte_utilisateur_domaine> est le compte d'utilisateur qu'exécute le service Report Server et pour lequel le nom principal de service (SPN) est inscrit.

Inscrire un nom principal de service pour un compte d'utilisateur de domaine

Pour inscrire un nom principal de service pour un service Report Server qui s'exécute en tant qu'utilisateur de domaine

  1. Installez Reporting Services et configurez le service Report Server pour qu'il s'exécute en tant que compte d'utilisateur de domaine. Notez que les utilisateurs ne seront pas en mesure de se connecter au serveur de rapports tant que vous n'aurez pas terminé les étapes suivantes.

  2. Téléchargez et installez les Outils de support de Windows Server 2003 Service Pack 1 à partir du Centre de téléchargement.

  3. Ouvrez une session sur le contrôleur de domaine en tant qu'administrateur de domaine.

  4. Ouvrez une fenêtre d'invite de commandes.

  5. Copiez la commande suivante, en remplaçant les valeurs d'espaces réservés par des valeurs réelles valides pour votre réseau :

    Copier le code
    Setspn -a http/<computer-name>.<domain-name>:<port> <domain-user-account>

  6. Exécutez la commande.

  7. Ouvrez le fichier RsReportServer.config et recherchez la section <AuthenticationTypes>. Ajoutez <RSWindowsNegotiate/> comme première entrée de cette section pour activer NTLM.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services

Concepts

Configuration du compte de service Report Server
Rubriques d'aide à la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : basculer entre les modes serveur (configuration de Reporting Services)

Procédure : basculer entre les modes serveur (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Si vous avez configuré un serveur de rapports pour qu'il s'exécute en mode intégré SharePoint, vous pouvez détacher le serveur de rapports d'un déploiement d'une instance de technologie SharePoint en basculant le serveur en mode natif.

Pour basculer entre les modes, vous devez pointer le serveur sur une base de données de serveur de rapports en mode natif. Il n'est pas nécessaire de réinstaller le serveur de rapports pour passer d'un mode à l'autre.

Bien que vous puissiez changer de mode pour le serveur de rapports, vous ne pouvez pas changer de mode pour la base de données du serveur de rapports. Une base de données de serveur de rapports contient des données spécifiques au mode qui ne sont pas utilisables dans un contexte différent. Si vous avez créé une base de données de serveur de rapports en mode intégré SharePoint, vous ne pouvez pas l'utiliser avec un serveur de rapports en mode natif.

Trois méthodes permettent de passer du mode intégré SharePoint au mode natif. Dans l'outil de configuration de Reporting Services, dans la page Installation de la base de données, effectuez l'une des opérations suivantes :

  • Cliquez sur Modifier et créez une nouvelle base de données.

  • Dans la liste des bases de données existantes, sélectionnez une base de données de serveur de rapports existante qui s'exécute déjà en mode natif, spécifiez les informations d'identification et cliquez sur Appliquer.

  • Cliquez sur Nouveau et créez une nouvelle base de données. Assurez-vous de désactiver la case à cocher Utiliser le schéma qui prend en charge le mode intégré SharePoint.

Cette rubrique fournit la procédure correspondant à la première approche. Pour plus d'informations sur la manière de configurer un serveur de rapports en mode natif pour qu'il s'exécute en mode intégré à SharePoint, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

Pour passer au mode natif

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008 R2, puis sur Outils de configuration.

  2. Cliquez sur Configuration de Reporting Services. La boîte de dialogue Sélection de l'instance d'installation de Report Server s'affiche pour que vous puissiez spécifier l'instance de serveur de rapports à configurer.

  3. Dans Nom de l'ordinateur, spécifiez le nom de l'ordinateur sur lequel est installée l'instance de serveur de rapports. Le nom de l'ordinateur local est spécifié par défaut, mais vous pouvez également taper le nom d'une instance de SQL Server distante.

  4. Dans Nom de l'instance, choisissez l'instance de SQL Server Reporting Services que vous souhaitez configurer.

  5. Cliquez sur Connexion.

  6. Cliquez sur Installation de la base de données pour afficher la page Installation de la base de données. Cette page contient des informations sur la base de données actuellement utilisée. Mode serveur doit avoir la valeur Intégré à SharePoint.

  7. Cliquez sur Modifier.

  8. Cliquez sur OK pour confirmer la création d'une nouvelle base de données.

  9. Dans la boîte de dialogue Connexion SQL Server, entrez un nom pour la nouvelle base de données.

  10. Vérifiez que la case à cocher Créez la base de données de serveur de rapports en mode intégré à SharePoint est désactivée.

  11. Cliquez sur OK.

  12. Dans la page Installation de la base de données, spécifiez les informations d'identification utilisées pour la connexion à la base de données du serveur de rapports.

    1. Choisissez Informations d'identification du service pour utiliser le compte de service Windows et le compte de service Web pour vous connecter par le biais de la sécurité intégrée.

    2. Choisissez Informations d'identification Windows pour spécifier un compte d'utilisateur de domaine. Un compte d'utilisateur de domaine doit être spécifié sous la forme <domaine>\<utilisateur>.

    3. Choisissez Informations d'identification SQL Server pour spécifier un compte de connexion SQL Server.

  13. Cliquez sur Appliquer.

Lorsque vous basculez d'un serveur de rapports en mode intégré SharePoint vers le mode natif, l'emplacement du contenu et les autorisations utilisées pour contrôler l'accès au contenu sont redéfinis. Le contenu doit être republié sur le serveur de rapports, vous devez attribuer des rôles sur le serveur de rapports qui accorde l'accès aux éléments et aux opérations, et vous devez redéfinir les abonnements et les opérations planifiées. L'historique de rapport que vous avez créé sur le serveur de rapports qui s'exécutait en mode intégré SharePoint ne peut pas être recréé sur un serveur de rapports en mode natif.

Voir aussi

Tâches

Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint

Concepts

Configuration de Reporting Services pour l'intégration de SharePoint 2010
Procédure : installer ou désinstaller le complément Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services)

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Procédure : activer ou désactiver les fonctionnalités Reporting Services

Procédure : activer ou désactiver les fonctionnalités Reporting Services |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide à la configuration de Reporting Services >

Vous pouvez désactiver les fonctionnalités de serveur de rapports que vous n'utilisez pas dans le cadre d'une stratégie de verrouillage pour réduire l'exposition aux attaques d'un serveur de rapports de production. Dans la plupart des cas, vous préférerez exécuter les fonctionnalités de Reporting Services conjointement afin de bénéficier de toutes les fonctionnalités offertes dans Reporting Services. Toutefois, vous pouvez désactiver les fonctionnalités dont vous n'avez pas besoin, selon votre modèle de déploiement. Par exemple, vous pouvez activer le traitement en arrière-plan uniquement si le traitement de tous les rapports a été planifié. De même, vous pouvez exécuter simplement le service Web Report Server si vous souhaitez disposer uniquement de rapports interactifs à la demande.

Les procédures passées en revue dans cette rubrique vous indiquent comment désactiver des fonctionnalités Reporting Services. Les fonctionnalités peuvent être configurées de différentes façons, par exemple en modifiant directement le fichier RsReportServer.config ou en utilisant la facette Configuration de la surface d'exposition pour Reporting Services de Gestion basée sur des stratégies dans SQL Server Management Studio. Utilisez les liens pour localiser les procédures qui expliquent comment activer ou désactiver une fonctionnalité :

  • Service Web Report Server

  • Traitement et événements planifiés

  • Gestionnaire de rapports

  • Générateur de rapports

  • Sécurité intégrée de Windows pour les sources de données de rapports

Service Web Report Server

Pour activer le service Web Report Server en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour plus d'informations, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

  2. Pour activer le service Web Report Server, affectez à IsWebServiceEnabled la valeur true :

    Copier le code
    <IsWebServiceEnabled>true</IsWebServiceEnabled>

  3. Pour désactiver le service Web Report Server, affectez à IsWebServiceEnabled la valeur false :

    Copier le code
    <IsWebServiceEnabled>false</IsWebServiceEnabled>

  4. Enregistrez vos modifications et fermez le fichier.

Pour activer ou désactiver le service Web Report Server en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer le service Web Report Server, affectez à WebServiceAndHTTPAccessEnabled la valeur True.

    • Pour désactiver le service Web Report Server, affectez à WebServiceAndHTTPAccessEnabled la valeur False.

  5. Cliquez sur OK.

Événements planifiés et remise

Pour activer ou désactiver les événements planifiés et la remise en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour plus d'informations, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

  2. Pour activer le traitement et la remise des rapports planifiés, affectez à IsSchedulingService, IsNotificationService et IsEventService la valeur true :

    Copier le code
    <IsSchedulingService>true<\IsSchedulingService>
<IsNotificationService>true<\IsNotificationService>
<IsEventService>true<\IsEventService>

  3. Pour désactiver le traitement et la remise des rapports planifiés, affectez la à IsSchedulingService, IsNotificationService et IsEventService la valeur false :

    Copier le code
    <IsSchedulingService>false<\IsSchedulingService>
<IsNotificationService>false<\IsNotificationService>
<IsEventService>false<\IsEventService>

  4. Enregistrez vos modifications et fermez le fichier.
Remarque :
Vous ne pouvez pas désactiver complètement le traitement en arrière-plan car il fournit des fonctionnalités de maintenance de base de données requises pour les opérations de serveur.

Pour activer ou désactiver les événements planifiés et leur remise en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer les événements planifiés et leur remise, affectez à ScheduleEventsAndReportDeliveryEnabled la valeur True.

    • Pour désactiver les événements planifiés et leur remise, affectez à ScheduleEventsAndReportDeliveryEnabled la valeur False.

  5. Cliquez sur OK.

Remarque :
Vous ne pouvez pas désactiver complètement le traitement en arrière-plan car il fournit des fonctionnalités de maintenance de base de données requises pour les opérations de serveur.

Gestionnaire de rapports

Pour activer ou désactiver le Gestionnaire de rapports en modifiant la configuration

  1. Ouvrez le fichier RsReportServer.config dans un éditeur de texte. Pour obtenir des instructions, consultez Procédure : modifier un fichier de configuration Reporting Services dans la documentation en ligne de SQL Server.

  2. Pour activer le Gestionnaire de rapports, affectez à IsReportManagerEnabled la valeur true:

    Copier le code
    <IsReportManagerEnabled>true<\IsReportManagerEnabled>

  3. Pour désactiver le Gestionnaire de rapports, affectez à IsReportManagerEnabled la valeur false:

    Copier le code
    <IsReportManagerEnabled>false<\IsReportManagerEnabled>

  4. Enregistrez vos modifications et fermez le fichier.

Pour activer ou désactiver le Gestionnaire de rapports en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, pointez sur Stratégies, puis cliquez sur Facettes.

  3. Dans la liste Facette, sélectionnez Configuration de la surface d'exposition pour Reporting Services.

  4. Sous Propriétés de la facette :

    • Pour activer le Gestionnaire de rapports, affectez à ReportManagerEnabled la valeur True.

    • Pour désactiver le Gestionnaire de rapports, affectez à ReportManagerEnabled la valeur False.

  5. Cliquez sur OK.

Générateur de rapports

Pour activer ou désactiver le Générateur de rapports en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés du serveur, sous Sélectionner une page, cliquez sur Sécurité.

    • Pour activer le Générateur de rapports, sélectionnez l'option Activer les exécutions de rapports ad hoc.

    • Pour désactiver le Générateur de rapports, désélectionnez l'option Activer les exécutions de rapports ad hoc.

  4. Cliquez sur OK.

Sécurité intégrée de Windows

Pour activer ou désactiver la sécurité intégrée de Windows en utilisant SQL Server Management Studio

  1. Ouvrez SQL Server Management Studio, puis connectez-vous à l'instance Reporting Services à configurer.

  2. Dans l'Explorateur d'objets, cliquez avec le bouton droit sur le noeud Reporting Services, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés du serveur, sous Sélectionner une page, cliquez sur Sécurité.

    • Pour activer la sécurité intégrée de Windows, sélectionnez l'option Activer la sécurité intégrée Windows pour les sources de données de rapport.

    • Pour désactiver la sécurité intégrée de Windows, désélectionnez l'option Activer la sécurité intégrée Windows pour les sources de données de rapport.

  4. Cliquez sur OK.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Rubriques d'aide F1 sur la configuration de Reporting Services

Rubriques d'aide F1 sur la configuration de Reporting Services |
 | Voir aussi
Configuration de Reporting Services >

Cette section décrit l'aide accessible par la touche F1 de l'outil Configuration de Reporting Services.

Dans cette section

  • Se connecter à un serveur de rapports

  • État de Report Server

  • Compte de service

  • URL du service Web

  • Configuration avancée de plusieurs sites Web

  • Base de données

  • Assistant Modification de base de données

  • Assistant Modifier les informations d'identification

  • URL du Gestionnaire de rapports

  • Paramètres de messagerie

  • Compte d'exécution

  • Clés de chiffrement

  • Sauvegarder la clé de chiffrement

  • Restaurer la clé de chiffrement

  • Déploiement avec montée en puissance parallèle

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Se connecter à un serveur de rapports (Configuration de Reporting Services)

Se connecter à un serveur de rapports (Configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette boîte de dialogue pour vous connecter à une instance du serveur de rapports SQL Server 2008 (ou ultérieure) Reporting Services, locale ou distante. Vous ne pouvez pas utiliser cet outil pour vous connecter aux versions antérieures de serveurs de rapports Reporting Services. Vous ne pouvez vous connecter qu'à une instance à la fois.

  • Pour vous connecter à une instance locale du serveur de rapports, utilisez les valeurs par défaut et cliquez sur Se connecter. L'outil de configuration de Reporting Services fournit le nom du serveur local et détecte l'instance par défaut. Dans la plupart des cas, vous pouvez cliquer sur Se connecter sans avoir à modifier les valeurs. Si vous avez installé plusieurs instances, vous devez sélectionner celle que vous souhaitez utiliser.

  • Pour vous connecter à une instance de serveur de rapports distante, tapez le nom du serveur, cliquez sur Rechercher, sélectionnez l'instance, puis cliquez sur Se connecter.

Pour ouvrir cette boîte de dialogue, démarrez l'outil de configuration de Reporting Services. Cette boîte de dialogue apparaît immédiatement lorsque vous démarrez l'outil. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Nom du serveur

Entrez le nom de réseau de l'ordinateur sur lequel SQL Server 2008 (ou ultérieure) Reporting Services est installé. Tapez simplement le nom de l'ordinateur, sans inclure de préfixe ou de barre oblique.

Rechercher

Recherchez l'ordinateur spécifié dans Nom du serveur.

Instance du serveur de rapports

Sélectionnez l'instance à laquelle se connecter si plusieurs instances de serveur de rapports sont installées. Seules les instances valides sont disponibles pour la sélection. Si vous exécutez côte à côte des versions antérieures de Reporting Services et une instance SQL Server, ces instances n'apparaîtront pas dans la liste.

Connecter

Connectez-vous au serveur et à l'instance que vous avez spécifiés.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


État de Report Server (configuration de Reporting Services)

État de Report Server (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour afficher les informations sur l'instance du serveur de rapports à laquelle vous êtes connecté. Cette page est la page de démarrage pour la configuration du serveur de rapports. Des pages supplémentaires sont disponibles pour configurer les URL, le compte de service, la base de données du serveur de rapports, la remise des messages électroniques du serveur de rapports, le déploiement avec montée en puissance parallèle et les clés de chiffrement.

Pour ouvrir la page, démarrez l'outil de configuration de Reporting Services, puis connectez-vous à l'instance du serveur de rapports. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Si vous vous connectez au serveur de rapports et que tous les liens de page sont grisés, vérifiez que le service Report Server est démarré. Vous pouvez utiliser l'application de console Services dans les Outils d'administration pour vérifier l'état du service.

Options

Instance SQL Server

Affiche les informations sur l'instance du serveur de rapports à laquelle vous êtes connecté. Les noms des instances du serveur de rapports sont basés sur les instances nommées de SQL Server. L'instance par défaut est MSSQLSERVER. Une instance nommée correspond à une valeur que vous avez spécifiée pendant l'installation. Pour plus d'informations sur les instances, consultez Utilisation de plusieurs versions et instances de SQL Server dans la documentation en ligne de SQL Server.

Remarque :
Dans SQL Server Express with Advanced Services, l'instance par défaut est SQLExpress.

ID de l'instance

Correspond à un dossier sur le système de fichiers contenant les fichiers programme de l'instance SQL Server à laquelle vous êtes connecté. La valeur ID d'instance est affectée par le programme d'installation au format composant.instance, où composant est une valeur qui représente un composant SQL Server et instance un nom d'instance. MSSQLSERVER est le nom de l'instance par défaut. Par exemple, si vous installez des instances par défaut des composants du moteur de base de données, Analysis Services et Reporting Services, les noms de dossiers correspondants sont MSSQL10_50.MSSQLSERVER, MSAS10_50.MSSQLSERVER et MSRS10_50.MSSQLSERVER, respectivement. Si vous installez une deuxième instance d'un composant que vous avez déjà installé, tel que le moteur de base de données, et que vous nommez l'instance Contoso, l'ID d'instance est MSSQL10_50.Contoso.

Edition

Affiche les informations sur l'édition. Reporting Services est disponible dans les éditions Workgroup, Developer, Evaluation, Standard et Enterprise de SQL Server Express with Advanced Services.

Version du produit

Affiche la version de Reporting Services que vous avez installée.

Base de données du serveur de rapports

Affiche le nom de la base de données du serveur de rapports qui stocke les données d'application pour l'instance du serveur de rapports en cours.

Mode du serveur de rapports

Indique si le serveur de rapports est déployé en mode natif ou en mode intégré SharePoint. Cette valeur est définie sur Mode intégré SharePoint si la base de données du serveur de rapports a été créée à l'aide d'un schéma qui prend en charge ce mode d'opération. Pour plus d'informations sur les modes de déploiement, consultez Planification d'un mode de déploiement dans la documentation en ligne de SQL Server. Pour plus d'informations sur toutes les étapes requises pour configurer des opérations intégrées, consultez Configuration de Reporting Services pour l'intégration de SharePoint 2010.

État de serveur

Indique si le service Report Server est en cours d'exécution.

Démarrer

Démarre le service Report Server. Le redémarrage du service est nécessaire après certains changements de configuration (par exemple, lors de la reconfiguration d'un serveur de rapports après un changement du nom de l'ordinateur). Si vous reconfigurez les réservations d'URL, le service redémarrera automatiquement. Le redémarrage est nécessaire pour prendre en compte les modifications.

Arrêter

Arrête le service Report Server. L'arrêt du service provoque l'arrêt du serveur de rapports. Pour plus d'informations, consultez Démarrage et arrêt du service Report Server dans la documentation en ligne de SQL Server.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Initialisation d'un serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Compte de service (configuration de Reporting Services)

Compte de service (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Compte de service pour spécifier le compte sous lequel le service Report Server est exécuté. Ce compte est au départ configuré pendant l'installation. Vous pouvez le modifier si vous souhaitez modifier le compte ou le mot de passe. Le service Web Report Server, le Gestionnaire de rapports et l'application de traitement en arrière-plan s'exécutent tous sous l'identité du service que vous spécifiez dans cette page.

Le compte que vous spécifiez pour le service Report Server requiert une autorisation pour accéder au Registre, aux fichiers programme de serveur de rapports et à la base de données du serveur de rapports. Toutes les autorisations sont configurées automatiquement pour le compte lorsque vous utilisez l'outil de configuration de Reporting Services pour définir le compte. Si vous utilisez le compte de service pour vous connecter à la base de données du serveur de rapports, l'outil crée une connexion de base de données pour le compte et configure des autorisations de base de données en assignant le compte au RSExecRole sur l'instance SQL Server qui héberge la base de données du serveur de rapports. La base de données du serveur de rapports est le seul magasin de données dans lequel un serveur de rapports écrit. Le compte de service ne requiert pas d'autorisations à d'autres magasins de données.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez le lien dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Important :
Lorsque vous devez mettre à jour le compte ou le mot de passe, il est vivement recommandé d'utiliser l'outil de configuration de Reporting Services. L'utilisation de cet outil pour mettre à jour le compte garantit que les autres paramètres internes qui dépendent de l'identité de service sont mis à jour automatiquement en même temps.

Options

Utiliser un compte intégré

Sélectionnez Service réseau, Système Local ou Service local dans la liste. Seul Service réseau est recommandé ; toutefois, vous pouvez configurer le compte de façon à utiliser tout compte disponible.

Utiliser un autre compte

Sélectionnez cette option pour spécifier un compte d'utilisateur Windows. Vous pouvez entrer un compte d'utilisateur Windows local ou un compte d'utilisateur de domaine. Spécifiez un compte de domaine sous ce format : <domaine>\<utilisateur>. Spécifiez un compte d'utilisateur Windows local sous ce format : <nom d'ordinateur>\<utilisateur>. Vous pouvez sélectionner uniquement un compte existant ; vous ne pouvez pas créer de nouveaux comptes dans l'outil Configuration de Reporting Services.

Le nom du compte ne doit pas comporter plus de 20 caractères.

Si votre réseau utilise l'authentification Kerberos et que vous configurez le serveur de rapports pour s'exécuter sous un compte d'utilisateur de domaine, vous devez inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom de principal du service (SPN) pour Report Server.

Si vous changez de type de compte (par exemple, en remplaçant un compte Windows par un autre ou en remplaçant un compte intégré par un compte de domaine Windows), vous serez invité à créer une copie de sauvegarde de la clé de chiffrement. La copie de sauvegarde sera restaurée automatiquement lorsque vous sélectionnerez le nouveau compte.

Remarque :
Le Gestionnaire de configuration Reporting Services vous invite à sauvegarder et à restaurer la clé de chiffrement à chaque modification du compte de service. Ces étapes sont nécessaires pour garantir que les données chiffrées restent disponibles pour le serveur de rapports. Pour plus d'informations sur ces actions, consultez Clés de chiffrement (Configuration de Reporting Services)..

De plus, si vous disposez d'un serveur de rapports configuré pour s'exécuter en mode intégré SharePoint et que vous modifiez le compte de service à l'aide de l'outil de configuration Reporting Services, vous devez également ouvrir l'Administration centrale de SharePoint et vous servir de la page Accorder l'accès à la base de données de Reporting Services pour réappliquer les paramètres du serveur de rapport et de l'instance. Cette étape accordera aux bases de données SharePoint le nouvel accès au compte de service, requis pour intégrer Reporting Services à un produit ou une technologie SharePoint. Pour plus d'informations sur la manière d'accorder l'accès à la base de données dans l'Administration centrale de SharePoint, consultez Procédure : configurer l'intégration de Report Server dans l'administration centrale SharePoint.

Choix d'un compte

Pour de meilleurs résultats, spécifiez un compte qui a des autorisations de connexion réseau, avec un accès aux contrôleurs de domaine réseau et aux passerelles ou serveurs SMTP d'entreprise. Le tableau suivant fournit une synthèse des comptes et des recommandations pour leur utilisation.

Compte Explication

Comptes d'utilisateurs de domaine

Si vous avez un compte d'utilisateur de domaine Windows qui possède les autorisations minimales requises pour les opérations de serveur de rapports, vous devez l'utiliser.

Un compte d'utilisateur de domaine est recommandé car il isole le service Report Server des autres applications. L'exécution de plusieurs applications sous un compte partagé, tel que Service réseau, accroît le risque qu'un utilisateur malveillant prenne le contrôle du serveur de rapports car une violation de la sécurité pour l'une des applications peut facilement s'étendre à toutes les applications qui s'exécutent sous le même compte.

Un compte d'utilisateur de domaine est requis si vous configurez le serveur de rapports pour la délégation contrainte, ou pour le mode intégré SharePoint avec des produits SharePoint 2010 qui requièrent des comptes d'utilisateurs de domaine plutôt que des comptes d'ordinateurs intégrés.

Notez que si vous utilisez un compte d'utilisateur de domaine, vous devrez modifier régulièrement le mot de passe si votre organisation impose une stratégie d'expiration des mots de passe. Vous devrez peut-être également inscrire le service avec le compte d'utilisateur. Pour plus d'informations, consultez Procédure : inscrire un nom de principal du service (SPN) pour Report Server.

Évitez d'utiliser un compte d'utilisateur Windows local. En général, les comptes locaux ne disposent pas des autorisations suffisantes pour accéder aux ressources sur d'autres ordinateurs. Pour plus d'informations sur la manière dont l'utilisation d'un compte local limite la fonctionnalité du serveur de rapports, consultez Considérations relatives à l'utilisation des comptes locaux dans cette rubrique.

Service réseau

Service réseau est un compte intégré doté des privilèges minimaux, qui possède les autorisations d'ouverture de session sur le réseau. Ce compte est recommandé si vous n'avez pas de compte d'utilisateur de domaine disponible ou si vous souhaitez éviter toute interruption de service qui peut se produire à cause des stratégies d'expiration de mot de passe.

Si vous sélectionnez Service réseau, essayez de réduire le nombre d'autres services qui s'exécutent sous le même compte. Une violation de la sécurité pour l'une des applications compromettra la sécurité de toutes les autres applications qui s'exécutent sous le même compte.

Service local

Service local est un compte prédéfini qui s'apparente à un compte d'utilisateur Windows local authentifié. Les services qui s'exécutent au moyen du compte Service local accèdent aux ressources réseau dans le cadre d'une session nulle, sans informations d'identification. Ce compte ne convient pas aux scénarios de déploiement intranet où le serveur de rapports doit se connecter à une base de données de serveur de rapports distante ou à un contrôleur de domaine réseau afin d'authentifier un utilisateur avant d'ouvrir un rapport ou de traiter un abonnement.

Système local

Système local est un compte doté de privilèges élevés qui n'est pas obligatoire pour l'exécution d'un serveur de rapports. Évitez ce compte pour les installations de serveur de rapports. Choisissez un compte de domaine ou Service réseau à la place.

Considérations relatives à l'utilisation des comptes locaux

La principale considération liée à l'utilisation des comptes locaux concerne l'obligation, pour le serveur de rapports, de pouvoir accéder aux serveurs de base de données, serveurs de messagerie et contrôleurs de domaine distants. Si vous configurez le serveur de rapports pour s'exécuter en tant que compte d'utilisateur Windows local, Service local ou Système Local, vous introduisez des considérations qui doivent être prises en compte lors de la définition d'autres paramètres de configuration et de la création et remise d'abonnement :

  • L'exécution du service sous un compte local limitera ultérieurement vos options si vous configurez une connexion à une base de données de serveur de rapports distante. En particulier, si vous utilisez une base de données de serveur de rapports distante, vous devez configurer la connexion afin d'utiliser un compte d'utilisateur de domaine ou un utilisateur de base de données SQL Server qui dispose de l'autorisation d'ouverture de session sur l'instance SQL Server distante.

  • L'exécution du service sous un compte local introduira de nouvelles conditions requises en matière de création d'abonnement. Le serveur de rapports stocke des informations sur l'utilisateur qui crée l'abonnement. Si l'utilisateur crée l'abonnement alors qu'il est connecté sous un compte de domaine, le service Report Server essaie de se connecter à un contrôleur de domaine pour authentifier l'utilisateur lors du traitement de l'abonnement. Si le service s'exécute sous un compte local, la demande d'authentification échoue lorsque le serveur de rapports essaie d'envoyer la demande à un contrôleur de domaine distant. Pour contourner cette limitation, vous pouvez utiliser une extension personnalisée d'authentification basée sur les formulaires ou faire en sorte que tous les utilisateurs se connectent à un serveur de rapports sous un compte d'utilisateur local.

  • L'exécution du service sous un compte local introduira de nouvelles conditions requises en matière de remise des abonnements. Certaines extensions de remise ont les informations du compte d'utilisateur dans la définition de l'abonnement. Si vous envoyez des rapports à des adresses de messagerie basées sur des comptes d'utilisateur de domaine et que vous exécutez le service Report Server sous un compte local, il ne peut pas accéder à un contrôleur de domaine distant pour résoudre le compte de messagerie cible.

Voir aussi

Tâches

Procédure : configurer un compte de service pour Reporting Services

Concepts

Configuration du compte de service Report Server
Rubriques d'aide F1 sur la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


URL du service Web (configuration de Reporting Services)

URL du service Web (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page URL du service Web pour configurer ou modifier l'URL permettant d'accéder au serveur de rapports. Une réservation d'URL est créée en fonction de l'URL que vous spécifiez. La réservation d'URL définit la syntaxe et les règles de toutes les URL qui peuvent être utilisées par la suite pour accéder au service Web Report Server. Elle spécifie le préfixe, l'hôte, le port et le répertoire virtuel pour le service Web Report Server. Selon la façon dont vous spécifiez l'hôte, plusieurs URL peuvent être possibles pour une réservation unique. La valeur par défaut pour l'hôte spécifie un caractère générique fort. Un caractère générique fort vous permet de spécifier dans une URL un nom d'hôte qui peut être résolu sur l'ordinateur qui héberge le serveur de rapports. Pour plus d'informations sur la configuration et les réservations d'URL, consultez Procédure : configurer une URL (configuration de Reporting Services) et Configuration des URL de Report Server.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur URL du service Web dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Cette page fournit les valeurs utilisées communément dans les URL de serveurs de rapports. Si vous souhaitez créer des URL supplémentaires, utiliser les en-têtes de l'hôte ou spécifier l'adresse IP dans un format particulier, cliquez sur Avancé.

Un lien vers le service Web apparaît sur cette page après que vous avez cliqué sur Appliquer. Si vous cliquez sur ce lien avant que la base de données du serveur de rapports ne soit créée, vous pouvez vous attendre à voir l'erreur « Page introuvable ». Cette erreur n'apparaît plus une fois la base de données configurée. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services).

Si vous avez réinstallé Reporting Services et constatez que vous obtenez une erreur lors de la tentative d'utiliser la valeur d'adresse IP par défaut « Assigné » et le port 80, vous pouvez généralement résoudre l'erreur en recréant l'URL après avoir redémarré le service. Pour obtenir des instructions, consultez Dépannage de problèmes de configuration dans la documentation en ligne de SQL Server.

Options

Répertoire virtuel

Spécifie le nom de répertoire virtuel pour le service Web Report Server. Vous ne pouvez avoir qu'un nom virtuel pour chaque instance du service Web Report Server sur le même ordinateur.

Adresse IP

Identifie le serveur de rapports sur un réseau TCP/IP. Les valeurs valides sont les suivantes :

  • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

  • Non assigné spécifie que le serveur de rapports accepte toute demande qui n'a pas de correspondance exacte pour l'adresse IP ou le nom d'hôte. N'utilisez pas cette valeur si une autre application Web l'utilise déjà. Sinon, vous interromprez le service pour l'autre application.

  • 127.0.0.1 est utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

  • Nnn.nnn.nnn.nnn est l'adresse IPv4 d'une carte réseau sur votre ordinateur. Si votre réseau utilise l'adressage IPv6, l'adresse IP est une valeur 128 bits de 8 champs de 4 octets semblable au format suivant : <en-tête>:nnnn:nnnn:nnnn:nnnn.

    Si vous avez plusieurs cartes, une adresse IP apparaît pour chacune d'elles. Si vous sélectionnez uniquement cette valeur, elle limite l'accès de l'application à la seule adresse IP (et à tout nom d'hôte mappé sur cette adresse par un serveur de noms de domaine). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports.

Port TCP

Spécifie le port que le serveur de rapports surveille pour les requêtes HTTP pour les URL qui incluent le nom de répertoire virtuel de serveur de rapports.

Certificat SSL

Lie un certificat à l'adresse IP que vous avez spécifiée. Le certificat doit être installé et configuré sur le serveur. Reporting Services ne fournit pas de fonctionnalités pour gérer des certificats. Le certificat doit être émis sur un nom d'hôte ou un nom d'ordinateur qui se résout en une adresse IP. Par exemple, pour utiliser un certificat délivré à http://salesreports, l'adresse IP que vous avez spécifiée doit être résolue en un serveur intitulé « salesreports ».

Si vous utilisez un certificat, vous devez également modifier le paramètre de configuration UrlRoot dans le fichier RSReportServer.config, afin qu'il spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Port SSL

Spécifie le port pour les connexions SSL.

URL

Affiche les URL définies pour l'instance en cours du serveur de rapports.

Avancé

Cliquez pour créer des URL supplémentaires pour l'instance d'application en cours.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Configuration avancée de plusieurs sites Web (configuration de Reporting Services)

Configuration avancée de plusieurs sites Web (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > URL du service Web (configuration de Reporting Services) >

Utilisez cette boîte de dialogue pour créer et gérer les URL permettant d'accéder à un serveur de rapports ou au Gestionnaire de rapports. La boîte de dialogue Configuration de site Web multiple avancée est utilisée pour créer des URL supplémentaires, des URL personnalisées qui incluent un nom d'en-tête de l'hôte ou spécifier une adresse IP au format IPv4 ou IPv6.

La création de plusieurs URLS est utile si vous souhaitez configurer les différents moyens d'accéder à un serveur de rapports. Par exemple, l'accès au serveur de rapports via une connexion intranet et extranet requiert en général que vous ayez une URL différente pour chaque type de connexion.

Pour ouvrir la boîte de dialogue Configuration de site Web multiple avancée, cliquez sur Avancé dans l'URL du service Web ou sur la page URL du Gestionnaire de rapports dans l'outil de configuration de Reporting Services. Une fois la boîte de dialogue Configuration de site Web multiple avancée ouverte, vous pouvez cliquer sur Ajoutez ou sur Modifier pour définir de nouvelles URL ou modifier ou supprimer les URL existantes.

Cliquez sur OK pour enregistrer vos modifications. Si vous ajoutez ou supprimez des URL, mais en revanche fermez la boîte de dialogue sans cliquer d'abord sur OK, vos modifications seront perdues.

Options

Adresse IP

Identifie le serveur de rapports sur un réseau TCP/IP. Les valeurs valides sont les suivantes :

  • Assigné spécifie que chacune des adresses IP assignées à l'ordinateur peut être utilisée dans une URL qui pointe sur une application du serveur de rapports. Cette valeur comprend également les noms d'hôte conviviaux (tels que les noms d'ordinateur) qui peuvent être résolus par un serveur de noms de domaine en une adresse IP assignée à l'ordinateur. Il s'agit de la valeur par défaut pour une URL Reporting Services.

  • Non assigné spécifie que le serveur de rapports accepte toute demande qui n'a pas de correspondance exacte pour l'adresse IP ou le nom d'hôte. N'utilisez pas cette valeur si une autre application Web l'utilise déjà. Sinon, vous interromprez le service pour l'autre application.

  • 127.0.0.1 est utilisée pour l'accès à localhost. Cette valeur prend en charge l'administration locale sur le serveur de rapports. Si vous sélectionnez uniquement cette valeur, seuls les utilisateurs qui se connectent localement au serveur de rapports ont accès à l'application.

  • Nnn.nnn.nnn.nnn est l'adresse IPv4 d'une carte réseau sur votre ordinateur. Si votre réseau utilise l'adressage IPv6, l'adresse IP est une valeur 128 bits de 8 champs de 4 octets semblable au format suivant : <en-tête>:nnnn:nnnn:nnnn:nnnn.

    Si vous avez plusieurs cartes, une adresse IP apparaît pour chacune d'elles. Si vous sélectionnez uniquement cette valeur, elle limite l'accès de l'application à la seule adresse IP (et à tout nom d'hôte mappé sur cette adresse par un serveur de noms de domaine). Vous ne pouvez pas utiliser localhost pour accéder à un serveur de rapports, et vous ne pouvez pas utiliser les adresses IP des autres cartes réseau installées sur le serveur de rapports.

Port

Spécifie le port que surveille le serveur de rapports pour les demandes. Le port par défaut est le port 80. Si vous utilisez le port 80, vous n'avez pas à l'inclure dans l'URL. Si vous utilisez un autre numéro de port, vous devez toujours l'inclure dans l'URL (par exemple, http://localhost:8181/reports).

En-tête de l'hôte

Si vous avez déjà un en-tête de l'hôte défini sur un serveur de noms de domaine qui se résout sur votre ordinateur, vous pouvez spécifier cet en-tête de l'hôte dans une URL que vous configurez pour l'accès au serveur de rapports.

Un en-tête de l'hôte est un nom unique qui permet à plusieurs sites Web de partager une même adresse IP et un même port. Les noms d'en-tête de l'hôte sont plus faciles à mémoriser et à taper que les adresses IP et les numéros de port. Un exemple de nom d'en-tête de l'hôte peut être www.adventure-works.com.

Port SSL

Spécifie le port pour les connexions SSL. Le numéro de port SSL par défaut est 443.

Certificat SSL

Spécifie le nom de certificat d'un certificat SSL que vous avez installé sur cet ordinateur. Si le certificat est mappé sur un caractère générique, vous pouvez l'utiliser pour une connexion de serveur de rapports.

Spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Le nom que vous spécifiez doit être identique au nom pour lequel le certificat est enregistré.

Un certificat doit être installé pour utiliser cette option. Vous devez également modifier le paramètre de configuration UrlRoot dans le fichier RSReportServer.config, afin qu'il spécifie le nom complet de l'ordinateur pour lequel le certificat est enregistré. Pour plus d'informations, consultez Configuration d'un serveur de rapports pour des connexions SSL (Secure Sockets Layer) dans la documentation en ligne de SQL Server.

Délivré à

Nom de l'ordinateur sur lequel le certificat a été créé.

Ajouter

Définissez une URL supplémentaire.

Modifier

Modifiez une partie de la syntaxe d'URL.

Supprimer

Supprimez une entrée URL de la liste.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services
Procédure : configurer une URL (configuration de Reporting Services)

Concepts

Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Base de données (configuration de Reporting Services)

Base de données (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Base de données pour créer et configurer les bases de données du serveur de rapports qui fournissent le stockage interne pour une ou plusieurs instances du serveur de rapports. Si vous configurez un serveur de rapports pour utiliser une base de données de serveur de rapports, vous devez utiliser l'outil de configuration de Reporting Services pour créer la base de données.

La création d'une base de données de serveur de rapports et la configuration de la connexion est un processus comportant plusieurs étapes. Pour vous guider à travers les étapes, cette page propose un Assistant pour chaque type de tâche. Les autorisations et les connexions sont créées ou mises à jour automatiquement. Vous pouvez surveiller l'état de chaque étape dans la page Progression. Si une erreur se produit, vous pouvez cliquer sur l'erreur pour obtenir plus d'informations sur sa résolution.

Une base de données de serveur de rapports doit prendre en charge un mode serveur spécifique. Le mode par défaut est le mode natif, mais vous pouvez également créer une base de données de serveur de rapports en mode intégré SharePoint si vous exécutez un serveur de rapports dans un déploiement plus vaste d'un produit ou d'une technologie SharePoint. Pour plus d'informations, consultez Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services) et Procédure : créer une base de données du serveur de rapports pour le mode intégré SharePoint (configuration de Reporting Services).

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur Base de données dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Nom du serveur SQL Server

Dans la base de données en cours du serveur de rapports, Nom du serveur SQL spécifie le nom du moteur de base de données SQL Server 2008 qui exécute la base de données du serveur de rapports. Vous pouvez utiliser une instance par défaut ou nommée sur un ordinateur local ou distant.

Nom de la base de données

Spécifie le nom de la base de données du serveur de rapports qui stocke les données du serveur.

Mode du serveur de rapports

Indique si la base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Pour plus d'informations, consultez Planification d'un mode de déploiement.

Modifier la base de données

Démarrez un Assistant qui vous guide à travers toutes les étapes requises pour créer ou sélectionner une base de données de serveur de rapports.

Type d'informations d'identification

Détermine les informations d'identification utilisées par le serveur de rapports pour la connexion à la base de données du serveur de rapports. Les types d'informations d'identification que vous pouvez spécifier incluent le compte de service, un utilisateur de domaine Windows, un utilisateur local Windows ou une connexion à une base de données SQL Server. Pour plus d'informations sur la sélection des informations d'identification, consultez Configuration d'une connexion de base de données de serveur de rapports.

Nom d'utilisateur

Spécifie un compte d'utilisateur du domaine si vous utilisez les informations d'identification Windows ou une connexion SQL Server si vous utilisez les informations d'identification SQL Server. Si vous utilisez les informations d'identification Windows, indiquez-les sous le format suivant : <domaine>\<compte>.

Mot de passe

Spécifie le mot de passe du compte.

Modifier les informations d'identification

Démarrez un Assistant qui vous guide à travers toutes les étapes requises pour sélectionner un autre compte ou mettre à jour le mot de passe du compte utilisé pour se connecter à la base de données du serveur de rapports.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Autres ressources

Base de données de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Assistant Modification de base de données (configuration de Reporting Services)

Assistant Modification de base de données (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Base de données (configuration de Reporting Services) >

L'outil de configuration de Reporting Services propose l'Assistant Modification de la base de données pour vous guider à travers les différentes étapes de la création d'une base de données du serveur de rapports ou de la sélection d'une base de données existante du serveur de rapports en vue de l'utiliser avec l'instance en cours du serveur de rapports.

Si vous sélectionnez une base de données du serveur de rapports d'une version antérieure, elle sera mise à niveau pour correspondre à la version de l'instance du serveur de rapports à laquelle elle est connectée. Lorsque le service démarre, il vérifie automatiquement la version de la base de données et la met automatiquement à niveau avec le schéma en cours.

Pour démarrer l'Assistant, cliquez sur Modifier la base de données dans la page Base de données de l'outil de configuration de Reporting Services. Pour plus d'instructions sur le démarrage de l'outil de configuration de Reporting Services, consultez Procédure : lancer la configuration de Reporting Services.

Options

Action

Sélectionnez la tâche à exécuter. Vous pouvez créer une base de données en mode natif ou en mode intégré SharePoint. Ou, vous pouvez sélectionner une base de données existante du serveur de rapports afin de l'utiliser avec l'instance en cours du serveur de rapports.

Serveur de base de données

Spécifiez le nom de l'instance du moteur de base de données SQL Serverqui héberge la base de données du serveur de rapports. Vous pouvez utiliser une instance SQL Server 2005 ou SQL Server 2008. Vous pouvez utiliser une instance par défaut ou une instance nommée sur un ordinateur local ou distant. Si vous vous connectez à une instance nommée, entrez le nom du serveur sous la forme <serveur>\<instance>.

Pour vous connecter à l'instance du moteur de base de données, vous devez utiliser les informations d'identification qui ont l'autorisation de se connecter au serveur et de mettre à jour les informations de la base de données. L'outil de configuration de Reporting Services utilise vos informations d'identification Windows courantes, mais si vous n'avez pas de connexion ou d'autorisations sur la base de données, vous devez spécifier une connexion à une base de données SQL Server. Vous ne pouvez pas spécifier d'autres informations d'identification Windows. Si vous souhaitez vous connecter en tant qu'utilisateur Windows différent, connectez-vous comme cet utilisateur et démarrez l'outil de configuration de Reporting Services.

La connexion à une instance distante nécessite que vous activiez au préalable cette instance pour les connexions distantes. Certaines versions et éditions de SQL Server n'autorisent pas les connexions distantes par défaut. Pour vérifier si les connexions distantes sont autorisées, utilisez l'outil Gestionnaire de configuration SQL Server et confirmez que les protocoles TCP/IP et des canaux nommés sont activés. Si l'instance distante est également une instance nommée, vérifiez que le service SQL Server Browser est activé et en cours d'exécution sur le serveur cible. SQL Server Browser fournit le numéro de port utilisé par l'instance nommée à l'outil de configuration de Reporting Services.

Base de données

Spécifie le nom de la base de données du serveur de rapports qui stocke les données du serveur. Vous pouvez spécifier une base de données existante ou en créer une.

Les propriétés utilisées pour créer une base de données apparaissent dans l'Assistant lorsque vous sélectionnez Créer une nouvelle base de données sur la page Actions. L'outil de configuration de Reporting Services crée deux bases de données liées par le nom : une base de données pour contenir les données statiques et une base de données temporaire pour stocker les données de session et les données de travail. Pour plus d'informations, consultez Base de données de Report Server dans la documentation en ligne de SQL Server.

Vous pouvez également choisir une base de données existante du serveur de rapports. L'outil de configuration de Reporting Services ne filtre pas les bases de données non valides. Les bases de données valides sont basées sur le schéma de base de données du serveur de rapports (vous ne pouvez pas sélectionner une base de données où manquent les tables, les vues ou les procédures stockées nécessaires). Si vous choisissez une base de données créée à partir d'une version antérieure de Reporting Services, la base de données sera mise à niveau au format actuel.

Langue

Cette valeur est définie uniquement lorsque vous créez une nouvelle base de données du serveur de rapports.

Avec cette valeur, vous spécifiez la langue dans laquelle les définitions de rôle et les descriptions sont créées. Reporting Services fournit un modèle d'autorisation à base de rôles qui inclut un ensemble de rôles prédéfinis. Ces rôles sont créés une fois dans la langue spécifiée. Les noms des rôles et les descriptions n'apparaissent jamais dans d'autres langues, même si vous vous connectez au serveur de rapports à l'aide d'un navigateur dont les paramètres de culture ou de langue sont pris en charge par le serveur. La langue que vous spécifiez détermine aussi celle utilisée pour créer le nom du dossier Mes rapports et les dossiers Utilisateurs qui font partie de la fonctionnalité Mes rapports. Pour plus d'informations sur la prise en charge de la langue dans Reporting Services, consultez Considérations sur la conception de la solution pour les déploiements multilingues ou globaux (Reporting Services) dans la documentation en ligne de SQL Server.

Mode serveur

Une base de données de serveur de rapports prend en charge le mode natif ou le mode intégré SharePoint. Les modes s'excluent mutuellement.

Si vous créez une base de données du serveur de rapports, vous devez spécifier un mode. Le mode que vous sélectionnez détermine la structure de la base de données du serveur de rapports et attribue à la propriété système SharePointIntegrated du serveur de rapports la valeur true ou false.

Si vous sélectionnez une autre base de données du serveur de rapports, le mode de la base de données courante s'affiche afin que vous sachiez comment celle-ci est utilisée. Vous pouvez sélectionner une base de données créée pour un mode différent. Ce choix entraîne une bascule du mode serveur de l'instance en cours du serveur de rapports. Pour plus d'informations sur les modes, consultez Planification d'un mode de déploiement dans la documentation en ligne de SQL Server.

Informations d'identification

Spécifie le compte utilisé par le serveur de rapports pour se connecter à la base de données du serveur de rapports. Les valeurs valides incluent le compte de service du service Web Report Server, la connexion à une base de données SQL Server définie sur l'instance du moteur de base de données que vous utilisez pour héberger le serveur de rapports, ou un compte Windows. Si vous utilisez un compte Windows, vous pouvez spécifier un compte local (<nom_ordinateur>\<nom_utilisateur>) si le serveur de rapports et la base de données sont sur le même ordinateur, ou un compte d'utilisateur de domaine (<domaine>\<nom_utilisateur>) s'ils sont sur des ordinateurs différents du même domaine.

Le serveur de rapports crée alors une connexion de base de données et attribue les autorisations de base de données au compte que vous spécifiez.

Le serveur de rapports ne crée pas le compte lui-même. Le compte que vous spécifiez doit déjà exister et doit être valide pour votre configuration de déploiement. Plus particulièrement, si la base de données se trouve sur un ordinateur distant et que vous souhaitez utiliser un compte Windows, vous devez spécifier un compte qui a les autorisations de connexion sur cet ordinateur.

Si l'ordinateur se trouve dans un domaine différent ou non approuvé, pensez à utiliser la connexion à une base de données SQL Server. Pour plus d'informations sur le choix d'un compte, consultez Configuration d'une connexion de base de données de serveur de rapports.

Résumé

Vérifiez les paramètres avant que le programme d'installation ne configure la connexion.

État d'avancement et fin

Surveillez la progression de chaque tâche.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Référence

Base de données (configuration de Reporting Services)
Assistant Modification des informations d'identification (configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Assistant Modification des informations d'identification (configuration de Reporting Services)

Assistant Modification des informations d'identification (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Base de données (configuration de Reporting Services) >

Le Gestionnaire de configuration de Reporting Services fournit l'Assistant Modification des informations d'identification pour vous guider à travers les étapes de reconfiguration du compte que le serveur de rapports utilise pour se connecter à la base de données du serveur de rapports. Lorsque vous modifiez les informations d'identification, l'outil met à jour toutes les autorisations et informations de connexion de base de données sur le serveur de base de données pour la base de données du serveur de rapports en cours d'utilisation par le serveur de rapports.

Pour démarrer l'Assistant, cliquez sur Modifier les informations d'identification dans la page Base de données du Gestionnaire de configuration de Reporting Services. Pour plus d'instructions sur le démarrage du Gestionnaire de configuration de Reporting Services, consultez Procédure : lancer la configuration de Reporting Services.

Options

Serveur de base de données

Spécifiez le nom de l'instance du moteur de base de données SQL Server qui exécute la base de données du serveur de rapports.

Pour vous connecter à l'instance du moteur de base de données, vous devez utiliser les informations d'identification qui ont l'autorisation de se connecter au serveur et de mettre à jour les informations de la base de données. L'outil de configuration de Reporting Services utilise vos informations d'identification Windows courantes, mais si vous n'avez pas de connexion ou d'autorisations sur la base de données, vous pouvez spécifier une connexion à une base de données SQL Server.

Vous ne pouvez pas spécifier d'autres informations d'identification Windows. Si vous souhaitez vous connecter en tant qu'utilisateur Windows différent, connectez-vous comme cet utilisateur et démarrez l'outil de configuration de Reporting Services.

Informations d'identification

Spécifie le compte utilisé par le serveur de rapports pour se connecter à la base de données du serveur de rapports. Les valeurs valides incluent le compte de service du service Web Report Server, la connexion à une base de données SQL Server définie sur l'instance du moteur de base de données que vous utilisez pour héberger le serveur de rapports, ou un compte Windows. Si vous utilisez un compte Windows, vous pouvez spécifier un compte local (<nom_ordinateur>\<nom_utilisateur>) si le serveur de rapports et la base de données sont sur le même ordinateur, ou un compte d'utilisateur de domaine (<domaine>\<nom_utilisateur>) s'ils sont sur des ordinateurs différents du même domaine.

Le serveur de rapports crée alors une connexion de base de données et attribue les autorisations de base de données au compte que vous spécifiez.

Le serveur de rapports ne crée pas le compte lui-même. Le compte que vous spécifiez doit déjà exister et doit être valide pour votre configuration de déploiement. Plus particulièrement, si la base de données se trouve sur un ordinateur distant et que vous souhaitez utiliser un compte Windows, vous devez spécifier un compte qui a les autorisations de connexion sur cet ordinateur.

Si l'ordinateur se trouve dans un domaine différent ou non approuvé, pensez à utiliser la connexion à une base de données SQL Server. Pour plus d'informations sur le choix d'un compte, consultez Configuration d'une connexion de base de données de serveur de rapports.

Résumé

Vérifiez les paramètres avant l'Assistant ne s'exécute.

État d'avancement et fin

Surveillez la progression de chaque tâche.

Voir aussi

Tâches

Procédure : créer une base de données du serveur de rapports (outil de configuration de Reporting Services)

Référence

Base de données (configuration de Reporting Services)
Assistant Modification de base de données (configuration de Reporting Services)

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Configuration d'une connexion de base de données de serveur de rapports
Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


URL du Gestionnaire de rapports (configuration de Reporting Services)

URL du Gestionnaire de rapports (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page URL du Gestionnaire de rapports pour configurer ou modifier l'URL permettant d'accéder au Gestionnaire de rapports. Par défaut, l'URL du Gestionnaire de rapports hérite du préfixe, de l'adresse IP et du port de l'URL du service Web Report Server URL. La raison en est que le Gestionnaire de rapports fournit l'accès frontal au service Web qui s'exécute au sein du même service Report Server. Si vous isolez les applications de service et utilisez le Gestionnaire de rapports pour accéder à un service Web Report Server sur un autre ordinateur, vous devez modifier le fichier RSReportServer.config pour pointer le Gestionnaire de rapports sur une instance différente. Pour plus d'informations sur la configuration d'une connexion du Gestionnaire de rapports avec un serveur de rapports distant, consultez Procédure : configurer le Gestionnaire de rapports dans la documentation en ligne de SQL Server.

Si vous êtes en train de configurer le serveur de rapports pour qu'il s'exécute en mode intégré SharePoint, ne créez pas l'URL du Gestionnaire de rapports. Le Gestionnaire de rapports n'est pas pris en charge sur un serveur de rapports exécuté en mode intégré SharePoint. Si une URL existe déjà pour le Gestionnaire de rapports, elle devient indisponible après que vous avez configuré le serveur de rapports pour qu'il s'exécute en mode intégré SharePoint.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur URL du Gestionnaire de rapports dans le volet de navigation. Pour plus d'informations sur le démarrage de l'outil, consultez Procédure : lancer la configuration de Reporting Services.

Remarque :
Si le Gestionnaire de rapports n'est pas activé, vous ne pouvez pas définir d'options sur cette page. Pour plus d'informations sur l'activation du Gestionnaire de rapports, consultez Procédure : activer ou désactiver les fonctionnalités Reporting Services.

Options

Répertoire virtuel

Spécifie le nom de répertoire virtuel pour le Gestionnaire de rapports. Vous ne pouvez avoir qu'un seul nom de répertoire virtuel pour chaque instance du Gestionnaire de rapports sur le même ordinateur.

URL

Affiche l'URL définie pour l'instance en cours du Gestionnaire de rapports.

Avancé

Ajoutez une URL supplémentaire pour l'instance en cours du Gestionnaire de rapports.

Voir aussi

Tâches

Procédure : configurer une URL (configuration de Reporting Services)

Concepts

URL des fichiers de configuration (Reporting Services)
Configuration des URL de Report Server

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Paramètres de messagerie (Configuration de Reporting Services)

Paramètres de messagerie (Configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour spécifier les paramètres du protocole SMTP (Simple Mail Transfer Protocol) qui activent la remise du courrier électronique à partir du serveur de rapports. Vous pouvez utiliser l'extension de remise du courrier électronique Report Server pour distribuer des rapports ou des notifications de traitement de rapport par le biais d'abonnements à la messagerie. L'extension de remise par messagerie Report Server nécessite un serveur SMTP et une adresse de messagerie à utiliser dans le champ De :.

Des paramètres de configuration supplémentaires peuvent être utilisés pour personnaliser davantage les abonnements à la messagerie, notamment les paramètres qui limitent les hôtes de serveur de messagerie et la disponibilité de l'extension de rendu. Vous ne pouvez pas spécifier ces paramètres dans l'outil de configuration de Reporting Services. Pour configurer les paramètres supplémentaires, vous devez modifier manuellement le fichier RSReportServer.config. Pour plus d'informations, consultez Configuration d'un Report Server pour la remise du courrier électronique et Fichiers de configuration (Reporting Services) dans la documentation en ligne de SQL Server.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et cliquez sur Paramètres de messagerie dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Adresse de l'expéditeur

Spécifie l'adresse de messagerie à utiliser dans le champ De : d'un message généré. Vous devez spécifier un compte d'utilisateur qui a l'autorisation d'envoyer du courrier depuis le serveur SMTP.

Méthode actuelle de remise SMTP

Spécifie que le message du serveur de rapports est acheminé par le biais d'un serveur SMTP. Il s'agit du seul mode de remise que vous pouvez spécifier dans l'outil Configuration de Reporting Services.

Un autre mode de remise consiste à utiliser un répertoire de collecte local du service SMTP. Vous pouvez utiliser ce mode de remise si aucun service réseau SMTP n'est disponible. Pour spécifier un répertoire de collecte local du service SMTP, vous devez modifier le fichier RSReportServer.config. Si vous éditez le fichier de configuration pour qu'il utilise un répertoire de collecte local du service SMTP, l'outil Configuration de Reporting Services définit l'option Mode de remise sur Personnalisé pour indiquer que le mode de remise est spécifié dans le fichier de configuration.

Dans le fichier de configuration, le mode de remise est défini par le biais du paramètre de configuration SendUsing. Pour plus d'informations sur la spécification du paramètre SendUsing, consultez Configuration d'un Report Server pour la remise du courrier électronique.

Serveur SMTP

Spécifiez le serveur ou la passerelle SMTP à utiliser. Vous pouvez utiliser un serveur local ou un serveur SMTP sur votre réseau.

Voir aussi

Concepts

Configuration d'un Report Server pour la remise du courrier électronique
Rubriques d'aide F1 sur la configuration de Reporting Services

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Compte d'exécution (configuration de Reporting Services)

Compte d'exécution (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour configurer un compte à utiliser pour le traitement sans assistance. Ce compte est utilisé dans des circonstances particulières lorsque d'autres sources d'informations d'identification ne sont pas disponibles :

  • lorsque le serveur de rapports se connecte à une source de données qui n'exige pas d'informations d'identification ; les documents XML et certaines applications de base de données côté client sont des exemples de sources de données qui n'ont pas nécessairement besoin d'informations d'identification.

  • lorsque le serveur de rapports se connecte à un autre serveur pour extraire des fichiers image externes ou d'autres ressources référencées dans un rapport.

La définition de ce compte est facultative, mais si vous ne définissez pas le compte, l'utilisation des images externes et des connexions à certaines sources de données est limitée. Lorsque vous récupérez des fichiers image externes, le serveur de rapports vérifie si une connexion anonyme peut être établie. Si la connexion est protégée par mot de passe, le serveur de rapports utilise le compte de traitement sans assistance pour se connecter au serveur de rapports. Lors de l'extraction des données pour un rapport, le serveur de rapports emprunte l'identité de l'utilisateur actuel, invite l'utilisateur à fournir des informations d'identification, utilise des d'informations d'identification stockées ou utilise le compte de traitement sans assistance si la connexion de la source de données spécifie Aucun comme type d'informations d'identification. Le serveur de rapports n'autorise pas la délégation ou l'emprunt d'identité des informations d'identification de son compte de service lors de la connexion à d'autres ordinateurs. Par conséquent, il doit utiliser le compte de traitement sans assistance si aucune information d'identification n'est disponible.

Le compte que vous spécifiez doit être différent de celui utilisé pour exécuter le compte de service. Si vous configurez ce compte, il est stocké dans le fichier RSReportServer.config sous forme de valeur chiffrée. Si vous exécutez le serveur de rapports dans un déploiement avec montée en puissance parallèle, vous devez configurer ce compte de la même façon sur chaque serveur de rapports.

Vous pouvez utiliser n'importe quel compte d'utilisateur Windows. Pour optimiser les résultats, choisissez un compte possédant des autorisations en lecture et des autorisations de connexion réseau afin de prendre en charge les connexions à d'autres ordinateurs. Il doit posséder des autorisations en lecture sur un fichier de données ou image externe que vous voulez utiliser dans un rapport. Ne spécifiez pas un compte local sauf si toutes les images externes et les sources de données de rapport sont stockées sur l'ordinateur du serveur de rapports. Utilisez le compte uniquement pour le traitement sans assistance des rapports.

Remarque :
Si vous utilisez SQL Server 2008 Express with Advanced Services, vous devez simplement configurer ce compte si vous faites référence à des images externes dans un rapport et qu'une autorisation est requise pour accéder au fichier image. SQL Server Express ne prend pas en charge une connexion de source de données à un serveur distant.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez Compte d'exécution dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Spécifier un compte d'exécution

Sélectionnez un compte.

Compte

Entrez un compte d'utilisateur de domaine Windows. Utilisez ce format : <domaine>\<compte d'utilisateur>.

Mot de passe

Tapez le mot de passe.

Confirmer le mot de passe

Tapez de nouveau le mot de passe.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Stockage des données chiffrées du serveur de rapports
Configuration du compte d'exécution sans assistance

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Clés de chiffrement (Configuration de Reporting Services).

Clés de chiffrement (Configuration de Reporting Services). |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez la page Clés de chiffrement pour gérer la clé symétrique utilisée pour chiffrer et déchiffrer les données dans un serveur de rapports. La gestion des clés de chiffrement représente une partie importante de la configuration du serveur de rapports. Bien que la clé symétrique soit créée et appliquée automatiquement lors de la création de la base de données du serveur de rapports, vous devez créer une copie de sauvegarde de la clé symétrique de façon à pouvoir exécuter les opérations de maintenance de routine. Les tâches de maintenance suivantes nécessitent une copie valide de la clé symétrique :

  • Modification du compte du service Report Server

  • Migration d'une installation de Reporting Services vers un autre ordinateur

  • Configuration d'une nouvelle instance de serveur de rapports pour partager ou utiliser une base de données existante du serveur de rapports

La restauration de la clé symétrique est nécessaire si vous avez mis à jour le compte d'utilisateur du service Report Server (et si vous avez utilisé un outil autre que l'outil de configuration de Reporting Services pour modifier le compte) ou si vous effectuez la migration d'une installation de serveur de rapports vers un nouveau serveur.

Pour protéger la clé symétrique de tout accès non autorisé, cette clé est chiffrée à l'aide de la clé privée du service Report Server. Seul le service Report Server est capable de déverrouiller et d'utiliser la clé symétrique dans le but de stocker des données sensibles dans la base de données du serveur de rapports. Si vous modifiez l'identité du service Report Server ou si vous effectuez la migration du serveur de rapports vers un nouvel ordinateur, la clé privée du service Report Server ne sera plus capable de déverrouiller la clé symétrique. Pour restaurer l'accès à la clé symétrique, celle-ci doit être chiffrée une nouvelle fois à l'aide de la clé privée de la nouvelle identité du service Report Server. La restauration de la clé symétrique est le processus qui conduit au nouveau chiffrement.

Vous devez restaurer une clé symétrique seulement s'il s'agit de la même clé actuellement utilisée pour chiffrer et déchiffrer les données dans la base de données du serveur de rapports. Si vous restaurez une clé symétrique non valide, vous ne serez plus en mesure d'accéder aux données sensibles. Dans ce cas, vous devez supprimer et recréer la clé.

Important :
La suppression de la clé symétrique et la création d'une nouvelle clé correspondent à une action irréversible qui peut avoir d'importantes conséquences sur votre installation actuelle. Si vous supprimez la clé, toute donnée existante chiffrée par la clé symétrique sera supprimée avec la clé. Les données supprimées incluent les chaînes de connexion aux sources de données de rapport externes, les chaînes de connexion stockées et certaines informations d'abonnement.

Pour ouvrir cette page, démarrez l'outil de configuration de Reporting Services et sélectionnez le lien dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Sauvegarde

Copie la clé symétrique dans un fichier que vous spécifiez. La clé symétrique n'est jamais stockée en texte clair. Vous devez taper un mot de passe pour protéger le fichier.

Restaurer

Applique une copie de la clé symétrique enregistrée précédemment à la base de données du serveur de rapports. Vous devez fournir un mot de passe pour déverrouiller le fichier.

La copie précédente de la clé symétrique de l'instance du serveur de rapports à laquelle vous est actuellement connecté est remplacée par la version restaurée. Après avoir restauré la clé symétrique, vous devez initialiser tous les serveurs de rapports qui utilisent la base de données du serveur de rapports. Pour plus d'informations sur l'initialisation des serveurs de rapports, consultez Initialisation d'un serveur de rapports.

Modifier

Recrée la clé symétrique et rechiffre toutes les valeurs chiffrées de la base de données du serveur de rapports. Veillez à arrêter le service Report Server avant de recréer la clé symétrique.

Dans un déploiement avec montée en puissance parallèle, toutes les copies de la clé symétrique sont remplacées par les versions plus récentes. Avant de remplacer la clé symétrique, veillez à passer en revue la liste des serveurs joints au déploiement avec montée en puissance parallèle pour vérifier que seules les instances valides du serveur de rapports obtiennent un accès à la nouvelle clé. Les serveurs qui font partie d'un déploiement avec montée en puissance parallèle sont répertoriés dans la page Déploiement avec montée en puissance parallèle. Arrêtez le service sur chaque serveur de rapports du déploiement avant de recréer la clé.

Notez que la régénération de la clé symétrique peut prendre du temps s'il existe un grand nombre de sources de données et d'abonnements.

Supprimer

Supprime la clé symétrique de la totalité du contenu chiffré, notamment les chaînes de connexion et les informations d'identification stockées. Vous devez supprimer uniquement la clé symétrique si vous ne pouvez pas la restaurer.

Une fois la clé symétrique supprimée, vous devez réentrer les chaînes de connexion et les informations d'identification stockées manquantes dans les rapports et les sources de données partagées qui ne contiennent plus ces valeurs Vous devez également mettre à jour tous les abonnements dont les extensions de remise stockent des données chiffrées. Il s'agit notamment de l'extension de remise de partage de fichiers et des éventuelles extensions de remise tierces qui utilisent les valeurs chiffrées.

Il n'existe pas de méthode automatique de mise à jour de ces informations. Les rapports, les abonnements et les sources de données partagées qui utilisent des informations d'identification stockées et des chaînes de connexion doivent être mis à jour l'un après l'autre.

Voir aussi

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Sauvegarder la clé de chiffrement (configuration de Reporting Services)

Sauvegarder la clé de chiffrement (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Clés de chiffrement (Configuration de Reporting Services). >

Reporting Services utilise une clé de chiffrement pour sécuriser les données sensibles stockées dans la base de données du serveur de rapports. La possession d'une sauvegarde de cette clé est essentielle pour garantir l'accès continu aux chaînes de connexion et aux informations d'identification chiffrées.

Vous devez avoir une copie de sauvegarde de cette clé si vous déplacez la base de données du serveur de rapports vers un autre ordinateur ou si vous modifiez le nom d'utilisateur ou le mot de passe du compte de service Report Server. Ces deux opérations nécessitent la restauration de la clé à partir d'une copie de sauvegarde que vous avez créée précédemment.

Pour ouvrir la boîte de dialogue Clé de chiffrement de sauvegarde, cliquez sur Clés de chiffrement dans le volet de navigation de l'outil Configuration de Reporting Services, puis cliquez sur Sauvegarder. La boîte de dialogue apparaît également lorsque vous mettez à jour le compte de service à l'aide de la page Compte de service de l'outil Configuration de Reporting Services.

Options

Emplacement du fichier

Spécifiez un nom et un emplacement de fichier pour la clé symétrique Reporting Services. La clé symétrique n'est jamais stockée en texte clair. Vous devez taper un mot de passe pour protéger le fichier.

Mot de passe

Entrez un mot de passe qui protège le fichier contre tout accès non autorisé. Seuls les utilisateurs qui connaissent le mot de passe seront en mesure de restaurer la clé verrouillée à l'intérieur du fichier. Reporting Services met en vigueur une stratégie de mot de passe forte. Le mot de passe doit comporter au moins 8 caractères et inclure une combinaison de caractères alphanumériques majuscules et minuscules, ainsi qu'au moins un caractère symbole.

Confirmer le mot de passe

Retapez le mot de passe que vous avez entré.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Référence

Clés de chiffrement (Configuration de Reporting Services).

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Restaurer la clé de chiffrement (configuration de Reporting Services)

Restaurer la clé de chiffrement (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services > Clés de chiffrement (Configuration de Reporting Services). >

Reporting Services utilise une clé de chiffrement pour sécuriser les données sensibles stockées dans la base de données du serveur de rapports. Pour garantir un accès ininterrompu aux données chiffrées, il importe que vous créiez une sauvegarde de la clé de chiffrement au cas où vous devriez la restaurer ultérieurement en raison de modifications dans le compte de service ou dans le cadre d'une migration planifiée.

Pour restaurer la clé, vous devez avoir enregistré préalablement une copie de sauvegarde de la clé sur un fichier protégé par mot de passe. Pendant la restauration de la clé, le serveur de rapports remplace la clé existante par la clé trouvée dans le fichier protégé par mot de passe. La clé qui est à l'intérieur du fichier doit être identique à celle utilisée pour chiffrer et déchiffrer les données.

Pour vérifier que vous avez restauré une clé valide, utilisez le Gestionnaire de rapports pour consulter les abonnements ou un rapport ayant une source de données qui utilise des informations d'identification stockées. Si vous recevez une erreur selon laquelle « Le serveur de rapports ne peut pas accéder aux données chiffrées » lors de la tentative d'ouverture d'une page de définition d'abonnement, ou si vous êtes invité à entrer des informations d'identification lorsque vous ouvrez un rapport qui utilisait précédemment les informations d'identification stockées pour la source de données du rapport, vous avez restauré une clé non valide.

Si vous restaurez une clé non valide différente de celle utilisée pour chiffrer les données, il est impossible de déchiffrer les données actuellement stockées dans la base de données du serveur de rapports. Si vous restaurez une clé non valide, vous devez restaurer immédiatement une copie de sauvegarde de la clé correcte, si elle est disponible. Si vous ne disposez pas de la copie de sauvegarde de la clé utilisée pour chiffrer les données, vous devez supprimer toutes les données chiffrées. À cette fin, cliquez sur le bouton Supprimer de la page Clés de chiffrement. Après avoir supprimé le contenu chiffré, vous devez mettre à jour tous les abonnements manuellement et spécifier à nouveau toutes les informations d'identification stockées définies pour les rapports et les abonnements pilotés par les données sur le serveur de rapports.

Pour ouvrir la boîte de dialogue Restaurer la clé de chiffrement, cliquez sur Clés de chiffrement dans le volet de navigation de l'outil de configuration de Reporting Services, puis cliquez sur Restaurer. La boîte de dialogue apparaît également lorsque vous mettez à jour le compte de service à l'aide de la page Compte de service de l'outil de configuration de Reporting Services.

Options

Emplacement du fichier

Sélectionnez le fichier protégé par mot de passe qui contient une copie de la clé symétrique. L'extension de fichier par défaut est .snk.

Mot de passe

Entrez le mot de passe permettant de déverrouiller le fichier. Seuls les utilisateurs qui connaissent le mot de passe peuvent restaurer la clé. Reporting Services applique une stratégie de mot de passe fort. Le mot de passe doit contenir au moins 8 caractères et inclure une combinaison de caractères alphanumériques majuscules et minuscules, ainsi qu'au moins un caractère symbole.

Voir aussi

Tâches

Procédure : lancer la configuration de Reporting Services

Référence

Clés de chiffrement (Configuration de Reporting Services).

Concepts

Rubriques d'aide F1 sur la configuration de Reporting Services
Sauvegarde et restauration des clés de chiffrement
Suppression et recréation des clés de chiffrement
Initialisation d'un serveur de rapports
Stockage des données chiffrées du serveur de rapports

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Déploiement avec montée en puissance parallèle (configuration de Reporting Services)

Déploiement avec montée en puissance parallèle (configuration de Reporting Services) |
 | Voir aussi
Configuration de Reporting Services > Rubriques d'aide F1 sur la configuration de Reporting Services >

Utilisez cette page pour afficher l'état d'initialisation d'un déploiement avec montée en puissance parallèle ou pour joindre un serveur de rapports à un déploiement avec montée en puissance parallèle.

Un serveur de rapports initialisé décrit un serveur qui peut chiffrer et déchiffrer les données sensibles stockées dans une base de données de serveur de rapports (par exemple, les informations d'identification et les chaînes de connexion). L'initialisation d'un serveur de rapports est nécessaire à son fonctionnement.

Un déploiement avec montée en puissance fait référence à deux ou plusieurs instances de serveurs de rapports qui partagent une même base de données de serveur de rapports. Cette configuration est utilisée dans les scénarios suivants :

  • Comme condition préalable pour l'équilibrage de charge de plusieurs serveurs de rapports dans un cluster de serveurs. Avant de pouvoir soumettre plusieurs serveurs de rapports à l'équilibrage de charge, vous devez les configurer pour qu'ils partagent la même base de données de serveur de rapports.

  • Pour segmenter les applications du serveur de rapports sur différents ordinateurs, en utilisant un serveur pour le traitement interactif des rapports et un autre serveur pour le traitement planifié des rapports. Dans ce scénario, chaque instance de serveur traite les différents types de demandes pour le même contenu de serveur de rapports stocké dans la base de données partagée du serveur de rapports.

Pour configurer un déploiement avec montée en puissance parallèle, commencez par deux instances de serveurs de rapports ou plus qui sont toutes connectées à la même base de données de serveur de rapports. Après que toutes les instances ont été installées, vous vous connectez au premier serveur de rapports, puis utilisez la page Déploiement avec montée en puissance parallèle pour attacher chaque instance supplémentaire. Seul un serveur de rapports déjà initialisé pour utiliser une base de données peut initialiser des nœuds supplémentaires.

Pour ouvrir la page, démarrez l'outil de configuration Reporting Services et sélectionnez Déploiement avec montée en puissance parallèle dans le volet de navigation. Pour plus d'informations, consultez Procédure : lancer la configuration de Reporting Services.

Options

Nom du serveur SQL Server

Spécifiez le nom de l'instance du moteur de base de données SQL Server qui héberge la base de données du serveur de rapports.

Nom de la base de données

Spécifie le nom de la base de données à laquelle l'instance de serveur de rapports est connectée.

Mode serveur

Affiche le mode du serveur et de la base de données. Le mode du serveur est le mode natif ou le mode intégré SharePoint. Les déploiements avec montée en puissance parallèle sont pris en charge pour les deux modes.

Serveur

Affiche le nom du serveur de rapports. Dans la plupart des cas, il s'agit du nom de l'ordinateur sur lequel le serveur de rapports est installé.

Instance

Affiche le nom de l'instance du serveur de rapports. Les instances de serveur de rapports sont basées sur les instances SQL Server.

État

Indique si le serveur de rapports est initialisé ou en attente de rejoindre un déploiement avec montée en puissance parallèle :

  • Pour un serveur de rapports qui ne fait pas partie d'un déploiement avec montée en puissance parallèle, cette page montre que l'instance du serveur de rapports est initialisée par rapport à sa base de données de serveur de rapports dédiée. L'état est défini sur Joint.

  • Pour un serveur de rapports en attente de joindre un déploiement avec montée en puissance parallèle, cette page contient les valeurs vides de Serveur, Instance et État. Un serveur de rapports attend de joindre un déploiement avec montée en puissance parallèle si vous avez sélectionné une base de données existante du serveur de rapports déjà utilisée par une autre instance de serveur de rapports. Un message de cette page vous demande de vous connecter à un serveur de rapports déjà joint à la batterie de serveurs. Pour compléter cette demande, cliquez sur Se connecter, sélectionnez un serveur de rapports déjà initialisé pour utiliser la base de données du serveur de rapports, cliquez sur Déploiement avec montée en puissance parallèle, sélectionnez l'instance de serveur de rapports En attente de joindre, puis cliquez sur Initialiser.

  • Pour un serveur de rapports qui fait actuellement partie d'un déploiement avec montée en puissance parallèle, cette page indique l'état d'initialisation de toutes les instances de serveur de rapports qui partagent la même base de données de serveur de rapports. Lors de l'affichage de l'état d'un déploiement avec montée en puissance parallèle, peu importe le serveur auquel vous êtes connecté. Les informations d'état sont signalées de manière identique pour tous les nœuds du déploiement avec montée en puissance parallèle.

    Pour un serveur de rapports qui fait déjà partie d'un déploiement avec montée en puissance parallèle, vous pouvez utiliser cette page pour ajouter ou supprimer des nœuds.

Initialiser

Cliquez sur Initialiser pour ajouter un serveur de rapports au déploiement avec montée en puissance parallèle. Cette étape configure un serveur de rapports de telle sorte qu'il utilise une clé symétrique dans une base de données de serveur de rapports partagée. Vous pouvez utiliser Initialiser pour ajouter une instance de serveur de rapports à un déploiement avec montée en puissance parallèle ou pour résoudre un problème de migration ou d'installation.

Une instance de serveur de rapports est disponible uniquement si vous avez précédemment configuré une connexion à une base de données de serveur de rapports partagée. De plus, vous devez effectuer l'initialisation à partir d'un serveur de rapports qui est déjà initialisé pour utiliser la base de données du serveur de rapports.

Supprimer

Cliquez sur Supprimer pour supprimer de la base de données du serveur de rapports les clés de chiffrement de l'instance sélectionnée du serveur de rapports. Vous pouvez supprimer des clés pour retirer un serveur de rapports d'un déploiement avec montée en puissance parallèle ou pour résoudre un problème de migration ou d'installation. Avec cette option, seules les clés de chiffrement de l'instance spécifiée du serveur de rapports sont supprimées. Les données chiffrées dans la base de données du serveur de rapports ne sont pas concernées.

Par précaution, veillez à créer une copie de sauvegarde de la clé symétrique avant de la supprimer. Après avoir supprimé de la liste les clés de chiffrement du dernier serveur de rapports, vous introduisez de nouvelles conditions sur toutes les initialisations ultérieures de serveur de rapports pour cette base de données. En effet, après avoir initialisé un serveur de rapports, vous devez restaurer une copie de sauvegarde de la clé symétrique. La restauration de la clé symétrique est nécessaire pour pouvoir accéder aux données chiffrées actuellement présentes dans la base de données du serveur de rapports.

Si vous n'avez plus besoin des données chiffrées ou si vous ne possédez pas de copie de sauvegarde de la clé, vous devez supprimer les données chiffrées. Pour plus d'informations, consultez Clés de chiffrement (Configuration de Reporting Services)..

Voir aussi

Tâches

Procédure : configurer un déploiement avec montée en puissance parallèle de Report Server (configuration de Reporting Services)

Concepts

Configuration d'un déploiement avec montée en puissance parallèle de Reporting Services
Initialisation d'un serveur de rapports
Configuration et gestion des clés de chiffrement

Aide et informations

Assistance sur SQL Server 2008
© 2010 Microsoft Corporation. Tous droits réservés.


Mentions légales relatives à la documentation

Mentions légales relatives à la documentation

Le présent document porte sur la version commerciale définitive du logiciel « SQL Server 2008 R2 ». Ce document est confidentiel et demeure la propriété de Microsoft Corporation.

Il est fourni « en l'état ». Les informations et les opinions exprimées dans ce document, y compris les adresses URL et les autres références à des sites Internet, peuvent faire l'objet de modifications sans préavis. Vous assumez tous les risques liés à son utilisation. Certains exemples mentionnés dans ce documents ne sont fournis qu'à titre indicatif et sont fictifs. Toute ressemblance ou similitude avec des éléments réels est purement fortuite et involontaire.

Ce document ne vous concède aucun droit de propriété intellectuelle portant sur les produits Microsoft. Vous pouvez copier et utiliser ce document à titre de référence pour un usage interne.

© 2010 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server et Windows Vista sont des marques du groupe Microsoft.

SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

Documentation - Stratégie de support et de mise à niveau

La documentation de Microsoft SQL Server 2008 R2 inclut la documentation en ligne de SQL Server, les fichiers Lisez-moi, les documents relatifs aux problèmes connus, les exemples de code et d'applications, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux fonctions et fonctionnalités SQL Server (l'ensemble de la « Documentation »). Le résumé ci-dessous décrit la stratégie de support et de mise à niveau pour certaines fonctions et fonctionnalités référencées dans la Documentation.

Exemples. Les exemples présentés dans cette Documentation servent principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Le support technique de Microsoft n'est pas disponible pour les exemples contenus dans la Documentation.

Espaces réservés. Dans certains cas, une fonctionnalité particulière de SQL Server 2008 R2 n'a pas été suffisamment testée ou développée pour être utilisée. Ces fonctionnalités sont souvent répertoriées dans la documentation en ligne, un fichier Lisez-moi ou toute autre Documentation sous forme d'espaces réservés et sont fournies à titre de notations pour une utilisation interne par Microsoft. Elles ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Toute tentative d'utilisation de ces fonctionnalités peut provoquer une perte de données.

Contenu tiers. Sauf spécification contraire de la Documentation, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec SQL Server 2008 R2, n'est pas pris en charge par le support technique de Microsoft.

Points d'entrée non documentés. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent des points d'entrée non documentés comme les API non documentées, y compris, entre autres, les éléments suivants : procédures stockées, procédures stockées étendues, fonctions, vues, tables, colonnes, propriétés ou métadonnées. Une telle utilisation peut provoquer une perte de données.

Mises à niveau. Les mises à niveau de serveur et de base de données vers les versions ultérieures de SQL Server 2008 R2 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge par le support technique de Microsoft.

Pour plus d'informations sur la stratégie de cycle de vie du support technique de Microsoft, visitez le site Web à l'adresse suivante : http://support.microsoft.com/lifecycle.