Aide sur le Gestionnaire de configuration SQL Server

Aide du Gestionnaire de configuration SQL Server
Aide sur le Gestionnaire de configuration SQL Server |
 | Voir aussi

Le Gestionnaire de configuration SQL Server vous permet de configurer les services SQL Server et la connectivité réseau. Pour créer ou gérer des objets de base de données, configurer la sécurité et écrire des requêtes Transact-SQL, utilisez SQL Server Management Studio. Pour SQL Server Express, utilisez l'outil Express Manager. Pour plus d'informations sur SQL Server Management Studio et Express Manager, consultez Gestion des services SQL Server 2000.

Cette section contient les rubriques d'aide accessibles au moyen de la touche F1, relatives aux boîtes de dialogue du Gestionnaire de configuration SQL Server.

Remarque :
Le Gestionnaire de configuration SQL Server ne peut pas configurer les versions de SQL Server antérieures à Microsoft SQL Server 2005.

Services

Le Gestionnaire de configuration SQL Server gère les services liés à SQL Server. Bien que beaucoup de ces tâches puissent être réalisées à l'aide de la boîte de dialogue Services Microsoft Windows, il est important de noter que le Gestionnaire de configuration SQL Server effectue des opérations supplémentaires sur les services qu'il gère, telles que l'application des autorisations adéquates lors de la modification du compte des services. L'utilisation de la boîte de dialogue Services Windows normale pour configurer l'un des services SQL Server peut provoquer un dysfonctionnement de celui-ci.

Utilisez le Gestionnaire de configuration SQL Server pour accomplir les tâches suivantes relatives aux services :

  • Démarrer, arrêter et suspendre les services

  • Configurer les services de manière à ce qu'ils démarrent automatiquement ou manuellement, désactiver les services ou modifier d'autres paramètres des services

  • Modifier les mots de passe des comptes utilisés par les services SQL Server

  • Démarrer SQL Server à l'aide d'indicateurs de trace (paramètres de ligne de commande)

  • Afficher les propriétés des services

Configuration du réseau SQL Server

Le Gestionnaire de configuration SQL Server vous permet de réaliser les tâches suivantes relatives aux services SQL Server installés sur cet ordinateur :

  • Activer ou désactiver un protocole réseau SQL Server

  • Configurer un protocole réseau SQL Server

Remarque :
Pour vous procurer un didacticiel sommaire sur la manière de configurer les protocoles et de vous connecter au Moteur de base de données SQL Server, consultez Didacticiel : Mise en route du moteur de base de données.

Configuration de SQL Server Native Client

Les clients SQL Server se connectent à SQL Server à l'aide de la bibliothèque réseau SQL Server Native Client. Le Gestionnaire de configuration SQL Server vous permet de réaliser les tâches suivantes relatives aux applications clientes installées sur cet ordinateur :

  • Pour les applications clientes SQL Server installées sur cet ordinateur, spécifier l'ordre des protocoles lors de la connexion à des instances de SQL Server

  • Configurer les protocoles de connexion clients

  • Pour les applications clientes SQL Server, créer des alias pour les instances de SQL Server afin que les clients puissent se connecter à l'aide d'une chaîne de connexion personnalisée

Pour plus d'informations sur chacune de ces tâches, consultez la rubrique d'aide correspondante accessible à l'aide de la touche F1.

Pour ouvrir le Gestionnaire de configuration SQL Server

  • Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server, puis cliquez sur Gestionnaire de configuration SQL Server.

Voir aussi

Référence

Services SQL Server 2008
Configuration du réseau SQL Server 2008
Configuration de SQL Server Native Client
Gestion des services SQL Server 2000

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Services SQL Server 2008

Services SQL Server 2008 |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server >

Cette section contient des rubriques d'aide (accessibles via la touche F1) relatives aux boîtes de dialogue des Services SQL Server du Gestionnaire de configuration Microsoft SQL Server.

Remarque :
Si vous ouvrez le Gestionnaire de configuration SQL Server sur un nœud d'un cluster qui n'héberge pas les ressources, les services apparaissent comme arrêtés.

Remarque :
Si les nœuds des services SQL Server ne sont pas remplis avec les services SQL Server disponibles sur l'ordinateur, vous ne disposez peut-être pas des autorisations suffisantes pour accéder à Windows Management Instrumentation (WMI). Pour configurer les autorisations sur WMI, recherchez la rubrique « Procédure : configurer WMI pour afficher l'état du serveur dans les outils SQL Server », dans la documentation en ligne.

Voir aussi

Concepts

Aide sur le Gestionnaire de configuration SQL Server

© 2010 Microsoft Corporation. Tous droits réservés.


Analysis Server <serveur> (Gestionnaire de configuration SQL Server)

Analysis Server <serveur> (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge Microsoft Analysis Services. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour plus d'informations sur Analysis Services, consultez la documentation en ligne.


Propriétés de Analysis Server (onglet Ouvrir une session)

Propriétés de Analysis Server (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de Analysis Server permet de spécifier le compte utilisé par le service SSAS, ainsi que de démarrer et d'arrêter ce service.

Remarque :
Lorsque vous modifiez le Nom du compte utilisé par un service sur une instance cluster, le nouveau compte doit être un membre du groupe de domaine spécifié au cours de l'installation pour le service modifié ou vous devez posséder l'autorisation d'ajouter des membres à ce groupe. Si vous ne disposez pas de l'autorisation de modifier l'appartenance aux groupes, contactez l'administrateur de domaine.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Cependant, le compte système local peut limiter l'interaction du service avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifie un compte d'utilisateur local ou de domaine qui utilise l'authentification Microsoft Windows. Microsoft recommande l'utilisation d'un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, recherchez dans la documentation en ligne la rubrique « Configuration des comptes de services Windows ».

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Propriétés de Analysis Server (onglet Service)

Propriétés de Analysis Server (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service est le Microsoft Analysis Services. Ce service doit être en cours d'exécution pour que SSAS fonctionne correctement. Les valeurs des propriétés en gris clair ne peuvent pas être modifiées à l'aide de cette application.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant SSAS.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche le numéro qu'utilise Microsoft Windows pour effectuer le suivi des processus de ce programme.

Type de service SQL

Affiche le type de service fourni aux processus appelants. Microsoft SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé.


Propriétés de Analysis Server (onglet Avancé)

Propriétés de Analysis Server (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service correspond à Microsoft Analysis Services. Si des propriétés personnalisées sont définies, elles apparaissent dans cet onglet, avec les valeurs correspondantes.

Options

Cluster

Indique si ce service est installé en tant que ressource d'un serveur cluster.

Commentaires client

Indique si le contrôle SQM (Service Quality Monitoring) a été activé sur ce service. Pour plus d'informations sur Commentaires client, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

Répertoire de vidage

Affiche l'emplacement où sont placés les vidages de mémoire en cas d'erreur.

Rapport d'erreurs

Lorsque cette option a pour valeur Oui, le programme Dr Watson transfère les informations à Microsoft ou au serveur d'erreur en cas de problème sérieux. Pour plus d'informations sur les rapports d'erreurs, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

ID de l'instance

Indique l'instance qui utilise ce service.


Notification Services (Gestionnaire de configuration SQL Server)

Notification Services (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge Notification Services. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour plus d'informations sur Notification Services, consultez la documentation en ligne.


Propriétés de NS$<Nom service> NS$ (onglet Ouvrir une session)

Propriétés de NS$<Nom service> NS$ (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de Notification Services permet de spécifier le compte utilisé par le service Notification Services, ainsi que de démarrer et d'arrêter ce service.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Cependant, le compte système local peut limiter l'interaction du service avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Microsoft Windows. Microsoft recommande l'utilisation d'un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, recherchez dans la documentation en ligne la rubrique « Configuration des comptes de services Windows ».

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Propriétés de NS$<Nom service> (onglet Service)

Propriétés de NS$<Nom service> (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service est le service Microsoft Notification Services. Les valeurs des propriétés en gris clair ne peuvent pas être modifiées à l'aide de cette application.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant la recherche en texte intégral.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Microsoft Windows.

Type de service SQL

Type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé.


Propriétés de NS$<Nom service> (onglet Avancé)

Propriétés de NS$<Nom service> (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Notification Services est mis en œuvre sous la forme d'un service dont le nom est formé selon la syntaxe suivante : NS$<user_configured name>. Si des propriétés personnalisées sont définies, elles apparaissent dans cet onglet, avec les valeurs correspondantes. Il est possible qu'aucune propriété ne soit répertoriée dans cet onglet.


Report Server <serveur> (Gestionnaire de configuration SQL Server)

Report Server <serveur> (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge Microsoft Reporting Services. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour plus d'informations sur Reporting Services, consultez la documentation en ligne.


Proprétés de SQL Server Reporting Services (onglet Ouvrir une session)

Proprétés de SQL Server Reporting Services (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Proprétés de SQL Server Reporting Services permet de spécifier le compte utilisé par le service Report Server, ainsi que de démarrer et d'arrêter ce service.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Cependant, le compte système local peut limiter l'interaction du service avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifie un compte d'utilisateur local ou de domaine qui utilise l'authentification Microsoft Windows. Microsoft recommande l'utilisation d'un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, recherchez dans la documentation en ligne la rubrique « Configuration des comptes de services Windows ».

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Propriétés de Report Server (onglet Service)

Propriétés de Report Server (onglet Service) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service est le service Microsoft SQL Server Report Server. Les valeurs des propriétés en gris clair ne peuvent pas être modifiées à l'aide de cette application.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique « SERVICE_ERROR_NORMAL ». Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant la recherche en texte intégral.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Microsoft Windows.

Type de service SQL

Type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé.

Voir aussi

Référence

Services SQL Server 2008

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de Report Server (onglet Avancé)

Propriétés de Report Server (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service est le Microsoft Reporting Services. Si des propriétés personnalisées sont définies, elles apparaissent dans cet onglet, avec les valeurs correspondantes.

Options

Commentaires client

Indique si le contrôle SQM (Service Quality Monitoring) a été activé sur ce service. Pour plus d'informations sur Commentaires client, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

Répertoire de vidage

Affiche l'emplacement où sont placés les vidages de mémoire en cas d'erreur.

Rapport d'erreurs

Lorsque cette option a pour valeur Oui, le programme Dr Watson transfère les informations à Microsoft ou au serveur d'erreur en cas de problème sérieux. Pour plus d'informations sur les rapports d'erreurs, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

ID de l'instance

Indique l'instance qui utilise ce service.


Agent SQL Server<serveur> (Gestionnaire de configuration SQL Server)

Agent SQL Server<serveur> (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge l'Agent SQL Server. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

L'Agent SQL Server est un service Microsoft Windows qui exécute des tâches administratives planifiées, nommées travaux. Pour plus d'informations sur l'Agent SQL Server, consultez « À propos de l'Agent SQL Server » dans la documentation en ligne de SQL Server.


Propriétés de l'Agent SQL Server (onglet Ouvrir une session)

Propriétés de l'Agent SQL Server (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de l'Agent SQL Server permet de spécifier le compte utilisé par le service de l'Agent SQL Server, ainsi que de démarrer et d'arrêter ce service. La modification du mot de passe d'un compte prend effet immédiatement sans redémarrer le service.

Remarque :
Lorsque vous modifiez le nom du compte utilisé par un service sur une instance cluster, le nouveau compte doit être un membre du groupe de domaine spécifié au cours de l'installation pour le service modifié ou vous devez disposer de l'autorisation d'ajouter des membres à ce groupe. Si vous ne disposez pas de l'autorisation de modifier l'appartenance aux groupes, contactez l'administrateur de domaine.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Cependant, le compte système local peut limiter l'interaction du service avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Windows. Microsoft recommande l'utilisation d'un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, recherchez « Configuration des comptes de service Windows » dans la documentation en ligne.

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Propriétés de l'Agent SQL Server (onglet Avancé)

Propriétés de l'Agent SQL Server (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Cinq propriétés figurent par défaut dans l'onglet Avancé. Si des propriétés personnalisées sont définies, elles apparaissent également dans cet onglet, avec les valeurs correspondantes.

Options

Cluster

Indique si ce service est installé en tant que ressource d'un serveur cluster.

Commentaires client

Indique si le contrôle SQM (Service Quality Monitoring) a été activé sur ce service. Pour plus d'informations sur Commentaires client, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

Répertoire de vidage

Affiche l'emplacement où sont placés les vidages de mémoire en cas d'erreur.

Rapport d'erreurs

Lorsque cette option a pour valeur Oui, le programme Dr Watson transfère les informations à Microsoft ou au serveur d'erreur en cas de problème sérieux. Pour plus d'informations sur les rapports d'erreurs, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

ID de l'instance

Indique l'instance qui utilise ce service.


Propriétés de l'Agent SQL Server (onglet Service)

Propriétés de l'Agent SQL Server (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Ce service est le service de l'Agent Microsoft SQL Server. Les valeurs des propriétés en gris clair ne peuvent pas être modifiées à l'aide de cette application.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant l'Agent SQL Server.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Microsoft Windows.

Type de service SQL

Affiche le type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.


SQL Server Browser (Gestionnaire de configuration SQL Server)

SQL Server Browser (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge SQL Server Browser. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour une description du service SQL Server Browser et de son fonctionnement, consultez Service SQL Server Browser.


Propriétés de SQL Server Browser (onglet Ouvrir une session)

Propriétés de SQL Server Browser (onglet Ouvrir une session) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Le programme SQL Server Browser s'exécute sur le serveur en tant que service. SQL Server Browser est à l'écoute des demandes entrantes pour les ressources Microsoft SQL Server et fournit des informations sur les instances SQL Server installées sur l'ordinateur.

SQL Server Browser est à l'écoute d'un port UDP et accepte les demandes non authentifiées via le protocole SSRP (SQL Server Resolution Protocol).

La modification du mot de passe d'un compte prend effet immédiatement sans redémarrer le service.

Options

Compte système local

Exécutez le service SQL Server Browser dans le contexte de sécurité du compte système local. Quand cela est possible, utilisez à la place de celui-ci un compte à faible niveau d'autorisation.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Windows. Nous vous recommandons d'utiliser un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, consultez « Configuration des comptes de service Windows » dans la documentation en ligne de SQL Server.

Parcourir

Recherchez une entité de sécurité utilisateur ou intégrée.

Important :
Utilisez un compte à faible niveau d'autorisation. Pour plus d'informations sur les autorisations requises pour le service SQL Server Browser, consultez la section relative à la sécurité de la rubrique Service SQL Server Browser.

Mot de passe

Entrez le mot de passe de l'entité de sécurité.

Confirmer le mot de passe

Confirmez le mot de passe de l'entité de sécurité.

État du service

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.

Démarrer

Démarre le service SQL Server Browser.

Arrêter

Arrête le service SQL Server Browser.

Suspendre

Interrompt le service SQL Server Browser.

Reprendre

Reprend un service SQL Server Browser suspendu.

Voir aussi

Concepts

Service SQL Server Browser

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de SQL Server Browser (onglet Service)

Propriétés de SQL Server Browser (onglet Service) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Le programme SQL Server Browser s'exécute sur le serveur en tant que service. SQL Server Browser est à l'écoute des demandes entrantes pour les ressources Microsoft SQL Server et fournit des informations sur les instances SQL Server installées sur l'ordinateur.

L'onglet Service de la boîte de dialogue Propriétés de SQL Server Browser vous permet d'afficher les options suivantes. Toutes les propriétés, à l'exception de Mode de démarrage, sont accessibles en lecture seule.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant le service SQL Server Browser.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Windows.

Type de service

Affiche le type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.

Voir aussi

Concepts

Service SQL Server Browser

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de SQL Server Browser (onglet Avancé)

Propriétés de SQL Server Browser (onglet Avancé) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Le programme SQL Server SQL Browser s'exécute sur le serveur en tant que service. SQL Server SQL Browser est à l'écoute des demandes entrantes pour les ressources Microsoft SQL Server et fournit des informations sur les instances SQL Server installées sur l'ordinateur.

Options

Cluster

Indique si ce service est installé en tant que ressource d'un serveur cluster.

Commentaires client

Indique si le contrôle SQM (Service Quality Monitoring) a été activé sur ce service. Pour plus d'informations sur Commentaires client, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

Répertoire de vidage

Emplacement où sont placés les vidages de mémoire en cas d'erreur.

Rapport d'erreurs

Lorsque cette option a pour valeur Oui, le programme Dr Watson transfère les informations à Microsoft ou au serveur d'erreur en cas de problème sérieux. Pour plus d'informations sur les rapports d'erreurs, recherchez dans la documentation en ligne la rubrique « Paramètres des rapports d'erreurs et d'utilisation ».

ID de l'instance

Indique l'instance SQL Server qui a utilisé cette instance de l'Agent SQL Server. L'instance par défaut est MSSQL10_50.MSSQLSERVER.

Voir aussi

Concepts

Service SQL Server Browser

© 2010 Microsoft Corporation. Tous droits réservés.


SQL Server <serveur> (Gestionnaire de configuration SQL Server)

SQL Server <serveur> (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge le Moteur de base de données Microsoft SQL Server. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour plus d'informations sur le Moteur de base de données SQL Server, consultez la documentation en ligne.


Propriétés de SQL Server (onglet Ouvrir une session)

Propriétés de SQL Server (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de SQL Server permet de spécifier le compte utilisé par le service SQL Server, de modifier le mot de passe d'un compte, ainsi que de démarrer et d'arrêter ce service. La modification du mot de passe d'un compte prend effet immédiatement.

Remarque :
Lorsque vous modifiez le nom du compte utilisé par un service sur une instance cluster, le nouveau compte doit être un membre du groupe de domaine spécifié au cours de l'installation pour le service modifié ou vous devez disposer de l'autorisation d'ajouter des membres à ce groupe. Si vous ne disposez pas de l'autorisation de modifier l'appartenance aux groupes, contactez l'administrateur de domaine.

Pour plus d'informations sur la sélection d'un compte pour exécuter le service, consultez « Configuration des comptes de service Windows » dans la documentation en ligne de SQL Server .

Options

Compte intégré
Système local
  • Spécifiez le compte système local. Ce compte ne nécessite pas de mot de passe. Toutefois, le compte système local peut empêcher le service d'interagir avec les autres serveurs, en fonction des privilèges accordés au compte.

Service local
  • Spécifiez le compte de service local. Ce compte ne nécessite pas de mot de passe. Cependant, le compte de service local peut empêcher le service d'interagir avec les autres serveurs, en fonction des privilèges accordés au compte.

Service réseau
  • Il est recommandé de ne pas utiliser le compte de service réseau pour les services SQL Server et SQL Server Agent. Les comptes d'utilisateur local et d'utilisateur de domaine conviennent mieux à ces services.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Windows. Nous vous recommandons d'utiliser un compte d'utilisateur de domaine doté d'autorisations minimales pour les services.

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.

Remarque :
Lors du démarrage de SQL Server, une erreur WMI contenant l'expression « non implémenté [0x80004001] » peut indiquer que SQL Server n'est pas installé sur l'ordinateur cible.


Propriétés de SQL Server (onglet Service)

Propriétés de SQL Server (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Service de la boîte de dialogue Propriétés de SQL Server vous permet d'afficher ou de spécifier les options suivantes.

Options

Chemin d'accès binaire

Répertorie l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant le service Microsoft SQL Server.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Windows.

Type de service

Affiche le type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.


Propriétés de SQL Server (onglet FILESTREAM)

Propriétés de SQL Server (onglet FILESTREAM)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Utilisez cette page pour activer FILESTREAM pour cette installation de SQL Server 2008.

Activer FILESTREAM pour l'accès Transact-SQL

Sélectionnez cette option pour activer FILESTREAM pour l'accès Transact-SQL. Ce contrôle doit être activé pour que les autres options de contrôle soient disponibles.

Activer FILESTREAM pour l'accès en continu des E/S de fichier

Sélectionnez cette option pour activer l'accès en continu Win32 pour FILESTREAM.

Nom du partage Windows

Utilisez ce contrôle pour entrer le nom du partage Windows dans lequel les données FILESTREAM doivent être stockées.

Permettre aux clients distants d'avoir un accès en continu aux données FILESTREAM

Sélectionnez ce contrôle pour permettre aux clients distants d'accéder à ces données FILESTREAM sur ce serveur.


Propriétés de SQL Server (onglet Avancé)

Propriétés de SQL Server (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Les propriétés suivantes figurent par défaut dans l'onglet Avancé. Si des propriétés personnalisées sont définies, elles apparaissent également dans cet onglet, avec les valeurs correspondantes.

Options

Cluster

Indique si ce service est installé en tant que ressource d'un serveur cluster.

Commentaires client

Indique si le contrôle SQM (Service Quality Monitoring) a été activé sur ce service. Pour plus d'informations sur Commentaires client, recherchez dans la documentation en ligne la rubrique « Paramètres de rapports d'erreurs et d'utilisation ».

Chemin d'accès aux données

Affiche le chemin d'accès des binaires SQL Server pour cette installation de SQL Server.

Répertoire de vidage

Affiche l'emplacement où sont placés les vidages de mémoire en cas d'erreur.

Rapport d'erreurs

Lorsque cette option a pour valeur Oui, le programme Dr Watson transfère les informations à Microsoft ou au serveur d'erreur en cas de problème sérieux. Pour plus d'informations sur les rapports d'erreurs, recherchez dans la documentation en ligne la rubrique « Paramètres de rapports d'erreurs et d'utilisation ». Pour modifier cette valeur, dans l'Explorateur d'objets SQL Server Management Studio, cliquez avec le bouton droit sur votre serveur, cliquez sur Propriétés, puis sur la page Paramètres divers du serveur. Les options figurent dans la zone Rapport d'information .

Version de fichier

Affiche la version de l'exécutable SQL Server.

Chemin d'accès à l'installation

Affiche le chemin d'accès des binaires SQL Server pour cette installation de SQL Server.

ID de l'instance

Indique l'instance SQL Server qui a utilisé ce service.

Langue

Affiche la langue par défaut des messages du serveur.

Racine du Registre

Affiche l'emplacement des clés de Registre utilisées par cette application.

Niveau du Service Pack

Affiche le niveau du Service Pack de cette instance de SQL Server.

Nom du SKU

Affiche le SKU (stock keeping unit) du produit, parfois appelé « édition du produit ».

Paramètres de démarrage

Répertorie tous les paramètres de démarrage utilisés par cette instance de SQL Server. Les paramètres sont séparés par des points-virgules. Les paramètres par défaut comprennent les chemins d'accès au fichier de données de la base de données master (master.mdf), le fichier journal de la base de données master (mastlog.ldf) et le fichier journal des erreurs. Pour connaître la syntaxe des paramètres de démarrage, recherchez dans la documentation en ligne la rubrique Utilisation des options de démarrage du service SQL Server.

Version

Affiche le numéro SKU (stock keeping unit) du produit.

Version

Affiche le numéro de version de cette instance de SQL Server.

Nom du serveur virtuel

Nom du serveur virtuel lorsque SQL Server est installé sur un serveur cluster.


SQL Server Integration Services 10.0 (Gestionnaire de configuration SQL Server)

SQL Server Integration Services 10.0 (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Il s'agit du service qui prend en charge SSIS. Pour afficher les propriétés du service, cliquez avec le bouton droit sur son nom dans le volet d'informations, puis cliquez sur Propriétés.

Pour plus d'informations sur SSIS, consultez la documentation en ligne.


Propriétés de SQL Server Integration Services (onglet Ouvrir une session)

Propriétés de SQL Server Integration Services (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de Integration Services permet de spécifier le compte utilisé par le service Integration Services, ainsi que de démarrer et d'arrêter ce service.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Cependant, le compte système local peut limiter l'interaction du service avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifie un compte d'utilisateur local ou de domaine qui utilise l'authentification Microsoft Windows. Microsoft recommande l'utilisation d'un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, recherchez dans la documentation en ligne la rubrique « Configuration des comptes de services Windows ».

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Propriétés de SQL Server Integration Services (onglet Service)

Propriétés de SQL Server Integration Services (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

L'onglet Service de la boîte de dialogue Propriétés de Integration Services vous permet d'afficher ou de spécifier les options suivantes.

Options

Chemin d'accès binaire

Affiche l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Code d'erreur Microsoft Windows définissant tout problème rencontré au démarrage ou à l'arrêt du service. Cette propriété a pour valeur ERROR_SERVICE_SPECIFIC_ERROR (1066) quand l'erreur est unique pour le service représenté par cette classe, et les informations sur l'erreur sont disponibles dans la propriété ServiceSpecificExitCode. Le service définit cette valeur à NO_ERROR (0) lors du fonctionnement, et à nouveau lors d'une fin normale.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant le service SSIS.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Windows.

Type de service SQL

Affiche le type de service fourni aux processus appelants. Microsoft SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.


Propriétés de SQL Server Integration Services (onglet Avancé)

Propriétés de SQL Server Integration Services (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Microsoft Integration Services est mis en œuvre en tant que service Integration Services. Si des propriétés personnalisées sont définies, elles apparaissent dans cet onglet, avec les valeurs correspondantes. Il est possible qu'aucune propriété ne soit répertoriée dans cet onglet.


Lanceur de démon de filtre de texte intégral SQL (Gestionnaire de configuration SQL Server)

Lanceur de démon de filtre de texte intégral SQL (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

À compter de SQL Server 2008, le service du lanceur de démon de filtre de texte intégral SQL (lanceur FDHOST) est utilisé par la recherche en texte intégral dans SQL Server pour démarrer le processus hôte de démon de filtre, qui gère l'analyse lexicale et le filtrage de recherche en texte intégral. Ce service doit être en cours d'exécution pour que la recherche en texte intégral puisse être utilisée. Le service du lanceur FDHOST est un service dépendant d'une instance qui est associé à une instance spécifique de SQL Server. Le service du lanceur FDHOST propage les informations sur le compte de service à chaque processus hôte de démon de filtre démarré. Pour plus d'informations sur les processus hôte de démon de filtre, consultez « Architecture de la recherche en texte intégral » dans la documentation en ligne de SQL Server.


Lanceur de démon de filtre de texte intégral SQL (onglet Ouvrir une session)

Lanceur de démon de filtre de texte intégral SQL (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

À compter de SQL Server 2008, le lanceur de démon de filtre de texte intégral SQL (service de lancement FDHOST) est utilisé par la recherche en texte intégral SQL Server. Ce service doit être en cours d'exécution pendant que vous utilisez la recherche en texte intégral. Pour plus d'informations sur les processus hôte de démon de filtre, consultez « Architecture de la recherche en texte intégral » dans la documentation en ligne de SQL Server.

L'onglet Ouvrir une session de la boîte de dialogue Propriétés de Lanceur de démon de filtre de texte intégral SQL permet de spécifier le compte utilisé par le service de recherche en texte intégral SQL Server, de modifier le mot de passe d'un compte, ainsi que de démarrer et d'arrêter ce service. La modification du mot de passe d'un compte prend effet après le redémarrage du service.

Remarque :
Lorsque vous modifiez le nom du compte utilisé par un service sur une instance en cluster, soit le nouveau compte doit être un membre du groupe de domaine spécifié au cours de l'installation pour le service, soit vous devez disposer de l'autorisation d'ajouter des membres à ce groupe. Si vous ne disposez pas de l'autorisation de modifier l'appartenance aux groupes, contactez l'administrateur de domaine.

Pour plus d'informations sur la sélection d'un compte pour exécuter le service, consultez « Configuration des comptes de service Windows » dans la documentation en ligne de SQL Server.

Options

Compte intégré
Système local

Spécifiez le compte système local. Ce compte ne nécessite pas de mot de passe. Toutefois, le compte système local peut empêcher le service d'interagir avec les autres serveurs, en fonction des privilèges accordés au compte.

Service local

Spécifiez le compte de service local. Ce compte ne nécessite pas de mot de passe. Cependant, le compte de service local peut empêcher le service d'interagir avec les autres serveurs, en fonction des privilèges accordés au compte.

Service réseau

Il est recommandé de ne pas utiliser le compte de service réseau pour les services SQL Server ou l'Agent SQL Server. Les comptes d'utilisateur local et d'utilisateur de domaine conviennent mieux à ces services.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Windows. Nous vous recommandons d'utiliser un compte d'utilisateur de domaine doté d'autorisations minimales pour les services.

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service. Non disponible pour ce service.

Reprendre

Reprend un service suspendu.


Lanceur de démon de filtre de texte intégral SQL (onglet Service)

Lanceur de démon de filtre de texte intégral SQL (onglet Service)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

À compter de SQL Server 2008, le lanceur de démon de filtre de texte intégral SQL (service de lancement FDHOST) est utilisé par la recherche de texte intégral SQL Server. Ce service doit être en cours d'exécution pendant que vous utilisez la recherche en texte intégral. Pour plus d'informations sur les processus hôte de démon de filtre, consultez « Architecture de la recherche en texte intégral » dans la documentation en ligne de SQL Server.

Utilisez l'onglet Service de la boîte de dialogue Propriétés de Lanceur de démon de filtre de texte intégral SQL pour afficher ou indiquer les options suivantes.

Options

Chemin d'accès binaire

Répertorie l'emplacement des fichiers programme utilisés par ce service.

Contrôle d'erreurs

1 indique SERVICE_ERROR_NORMAL. Si le lancement du service échoue pendant le démarrage de l'ordinateur, le programme de démarrage consigne l'erreur et affiche une boîte de message, mais poursuit l'opération de démarrage. Cette valeur ne peut pas être modifiée.

Code de sortie

Lorsqu'une erreur se produit, le numéro d'erreur apparaît dans cette zone. Pour dépanner des incidents, recherchez ce numéro dans la Base de connaissances Microsoft ou communiquez-le au personnel en charge du support technique.

Nom d'hôte

Affiche le nom de l'ordinateur ou du cluster exécutant le service Microsoft SQL Server.

Nom

Indique le nom d'affichage du service.

ID de processus

Affiche l'ID de processus Windows.

Type de service SQL

Affiche le type de service fourni aux processus appelants. SQL Server installe plusieurs services.

Mode de démarrage

Les options disponibles pour ce service sont les suivantes :

  • Manuel : ce service n'est pas automatiquement lancé au démarrage de l'ordinateur. Vous devez démarrer le service à l'aide du Gestionnaire de configuration SQL Server ou d'un autre outil.

  • Automatique : ce service essaie de se lancer au démarrage de cet ordinateur.

  • Désactivé : ce service ne peut pas être démarré.

État

Indique si ce service est en cours d'exécution, arrêté ou désactivé. « … » indique qu'un changement d'état est en attente.


Lanceur de démon de filtre de texte intégral SQL (Avancé)

Lanceur de démon de filtre de texte intégral SQL (Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

À compter de SQL Server 2008, le service du lanceur de démon de filtre de texte intégral SQL est utilisé par la recherche en texte intégral SQL Server. Ce service doit être en cours d'exécution pendant que vous utilisez la recherche en texte intégral. Pour plus d'informations sur les processus hôte de démon de filtre, consultez « Architecture de la recherche en texte intégral » dans la documentation en ligne de SQL Server.

Aucune propriété n'apparaît sous l'onglet Avancé par défaut. Si des propriétés personnalisées sont définies, elles apparaissent également sous cet onglet, avec les valeurs correspondantes.


Service inconnu (onglet Ouvrir une session)

Service inconnu (onglet Ouvrir une session)
Aide sur le Gestionnaire de configuration SQL Server > Services SQL Server 2008 >

Le Gestionnaire de configuration Microsoft SQL Server n'est pas en mesure d'identifier ce service.

Le Gestionnaire de configuration SQL Server reçoit des informations de service émanant du fournisseur WMI installé sur l'ordinateur exécutant le service. Une erreur s'est produite lors de la lecture des propriétés du service ou celles-ci sont incomplètes. Pour résoudre le problème, essayez de fermer puis de rouvrir le Gestionnaire de configuration SQL Server, ou vérifiez le fournisseur WMI installé sur l'ordinateur exécutant le service.

Le fournisseur WMI est un composant Windows. Pour plus d'informations sur la manière de vérifier les autorisations sur le fournisseur WMI, consultez « Procédure : configurer WMI pour afficher l'état du serveur dans les outils SQL Server » dans la documentation en ligne de SQL Server.

Si vous pensez que vous examinez le service approprié, utilisez l'onglet Ouvrir une session de la boîte de dialogue Propriétés de Service inconnu pour spécifier le compte utilisé par ce service, ainsi que pour démarrer et arrêter le service.

Options

Compte système local

Spécifie un compte système local, qui ne requiert pas de mot de passe. Toutefois, le compte système local peut empêcher le service d'interagir avec les autres serveurs, en fonction des privilèges accordés au compte.

Ce compte

Spécifiez un compte d'utilisateur local ou de domaine qui utilise l'authentification Windows. Nous vous recommandons d'utiliser un compte d'utilisateur de domaine doté d'autorisations minimales pour les services. Pour plus d'informations sur la sélection d'un compte, consultez « Configuration des comptes de service Windows » dans la documentation en ligne de SQL Server.

Nom du compte

Spécifie le nom de compte d'utilisateur local ou de domaine.

Mot de passe

Tapez le mot de passe du compte.

Confirmer le mot de passe

Tapez de nouveau le mot de passe du compte.

Démarrer

Démarre le service.

Arrêter

Arrête le service.

Suspendre

Suspend le service.

Reprendre

Reprend un service suspendu.


Configuration du réseau SQL Server 2008

Configuration du réseau SQL Server 2008 |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server >

Cette section contient les rubriques d'aide accessibles au moyen de la touche F1, relatives aux boîtes de dialogue Configuration réseau du serveur du Gestionnaire de configuration SQL Server.

Voir aussi

Concepts

Aide sur le Gestionnaire de configuration SQL Server

© 2010 Microsoft Corporation. Tous droits réservés.


Protocoles pour <serveur> (Gestionnaire de configuration SQL Server)

Protocoles pour <serveur> (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

Pour configurer les protocoles utilisés par le Moteur de base de données, sélectionnez Protocoles pour l'instance du serveur de votre choix dans le volet de la console, cliquez avec le bouton droit sur le protocole approprié dans le volet d'informations, puis cliquez sur Propriétés.


Propriétés de Protocoles pour MSSQLSERVER (onglet Indicateurs)

Propriétés de Protocoles pour MSSQLSERVER (onglet Indicateurs)
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

Lorsqu'un certificat est installé sur le serveur, utilisez l'onglet Indicateurs de la boîte de dialogue Propriétés de Protocoles pour MSSQLSERVER pour afficher ou spécifier les options de chiffrement de protocole et de masquage d'instance. Vous devez redémarrer Microsoft SQL Server pour activer ou désactiver le paramètre ForceEncryption.

Pour chiffrer les connexions, vous devez fournir un certificat au Moteur de base de données SQL Server. Si aucun certificat n'est installé, SQL Server génère un certificat autosigné lors du démarrage de l'instance. Ce certificat autosigné peut être utilisé à la place d'un certificat émanant d'une autorité de certification approuvée, mais il ne fournit ni authentification ni non-répudiation.

Attention :
Les connexions SSL (Secure Sockets Layer) chiffrées à l'aide d'un certificat autosigné n'offrent pas une sécurité renforcée. Elles sont vulnérables à des attaques humaines. Ne faites jamais confiance à une connexion SSL utilisant des certificats autosignés dans un environnement de production ou sur des serveurs connectés à Internet.

Pour plus d'informations sur le chiffrement, consultez « Chiffrement des connexions à SQL Server » dans la documentation en ligne de SQL Server.

Le processus de connexion est toujours chiffré. Lorsque l'option ForceEncryption a la valeur Oui, toutes les communications client/serveur sont chiffrées et les clients qui se connectent au Moteur de base de données doivent être configurés de manière à approuver l'autorité racine du certificat du serveur. Pour plus d'informations, consultez « Procédure : activer des connexions chiffrées dans le moteur de base de données (Gestionnaire de configuration SQL Server) » dans la documentation en ligne de SQL Server.

Serveurs clusters

Si vous souhaitez utiliser le chiffrement à l'aide d'un cluster de basculement, vous devez installer le certificat du serveur avec le nom DNS complet du serveur virtuel sur tous les nœuds du cluster de basculement. Si, par exemple, vous disposez d'un cluster à deux nœuds nommés « test1.<votre société>.com » et « test2.<votre société>.com », ainsi que d'un serveur virtuel nommé « virtsql », vous devez installer un certificat pour « virtsql.<votre société>.com » sur les deux nœuds. Vous pouvez ensuite activer la case à cocher ForceEncryption du Gestionnaire de configurations SQL Server pour configurer le chiffrement du cluster de basculement.

Options

Forcer le chiffrement

Force le chiffrement du protocole. Le chiffrement est une méthode permettant de préserver la confidentialité des informations en changeant les données en un format non lisible. Le chiffrement garantit que les données demeurent confidentielles, même si les paquets de transmission sont visualisés pendant la transmission. Pour utiliser une liaison de canal, choisissez la valeur Activé pour l'option Forcer le chiffrement et configurez la Protection étendue sous l'onglet Avancé.

Masquer l'instance

Empêche le service SQL Server Browser d'exposer cette instance du moteur de base de données aux ordinateurs clients dont les utilisateurs tentent de localiser l'instance à l'aide du bouton Parcourir. Dans le cas d'instances nommées sur le serveur, les applications clientes doivent spécifier les informations de point de terminaison de protocole pour se connecter. Par exemple, le numéro de port ou le nom de canal nommé, tel que tcp:server,5000. Pour plus d'informations, consultez Connexion au moteur de base de données SQL Server.

Pour plus d'informations, consultez « Procédure : activer des connexions chiffrées dans le moteur de base de données (Gestionnaire de configuration SQL Server) » dans la documentation en ligne.


Propriétés de Protocoles pour MSSQLSERVER (onglet Certificat)

Propriétés de Protocoles pour MSSQLSERVER (onglet Certificat)
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

L'onglet Certificat de la boîte de dialogue Propriétés de Protocoles pour MSSQLSERVER vous permet de sélectionner un certificat pour Microsoft SQL Server ou d'afficher les propriétés d'un certificat. Tous les champs sont vides tant qu'aucun certificat n'est sélectionné.

Les certificats sont stockés localement sur l'ordinateur pour les utilisateurs. Pour charger un certificat en vue de son utilisation par SQL Server, vous devez exécuter le Gestionnaire de configuration SQL Server sous le même compte d'utilisateur que le service SQL Server.

En-tête de page

Afficher

Fournit des détails supplémentaires sur le certificat. Cette option n'est disponible qu'une fois qu'un certificat est sélectionné dans la zone Certificat. Pour plus d'informations sur les détails des certificats, consultez la documentation Microsoft Windows 2000 ou Microsoft Windows Server 2003.

Effacer

Supprime la sélection de la zone Certificat.

Certificat

Nom de certificat tel que déterminé par le fournisseur de sécurité. Sélectionnez un certificat pour en afficher les détails dans la grille des propriétés.

Options

Date d'expiration

Date de fin de la période de validité du certificat.

Nom convivial

Nom convivial ou courant représentant la personne ou l'Autorité de certification destinataire du certificat.

Émis par

Informations relatives à l'Autorité de certification qui a émis le certificat.

Délivré à

Informations relatives au destinataire du certificat.


Propriétés de Protocoles pour MSSQLSERVER (onglet Avancé)

Propriétés de Protocoles pour MSSQLSERVER (onglet Avancé)
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

Utilisez l'onglet Avancé dans la boîte de dialogue Propriétés de Protocoles pour MSSQLSERVER pour configurer la Protection étendue de l'authentification du moteur de base de données SQL Server. La Protection étendue est une fonctionnalité des composants réseau implémentée par le système d'exploitation. La Protection étendue est disponible dans Windows 7 et Windows Server 2008 R2 et est incluse dans les Service Packs des précédents systèmes d'exploitation. SQL Server est plus sécurisé lorsque les connexions sont établies à l'aide de la Protection étendue. Certains avantages de la Protection étendue requièrent de sélectionner l'option Forcer le chiffrement sous l'onglet Indicateurs.

Important :
Windows n'active pas la Protection étendue par défaut. Pour plus d'informations sur l'activation de la Protection étendue dans Windows, consultez l'article de la Base de connaissances, Protection étendue de l'authentification

Pour plus d'informations sur la configuration d'autres services SQL Server et une description complète de la Protection étendue, consultez les informations plus récentes sur Microsoft.com

Options

Protection étendue

Il existe trois valeurs possibles :

  • Lorsque la valeur est Désactivée, la Protection étendue est désactivée. L'instance de SQL Server acceptera les connexions de tous les clients, qu'ils soient protégés ou non. La valeur Off est compatible avec les anciens systèmes d'exploitation non corrigés, mais elle est moins sécurisée. Utilisez ce paramètre uniquement lorsque vous savez que les systèmes d'exploitation clients ne prennent pas en charge la Protection étendue.

  • Lorsque la valeur est Autorisée, la Protection étendue est requise pour les connexions à partir des systèmes d'exploitation qui prennent en charge la Protection étendue. Les connexions provenant d'applications clientes non protégées qui s'exécutent sur des systèmes d'exploitation clients protégés sont rejetées. La Protection étendue est ignorée pour les connexions provenant de systèmes d'exploitation non protégés. Ce paramètre offre une meilleure protection que la valeur Désactivé, mais ce n'est pas la configuration la plus sécurisée. Utilisez ce paramètre dans des environnements mixtes, dans lesquels certains systèmes d'exploitation prennent en charge la Protection étendue et d'autres non.

  • Lorsque la Protection étendue est affectée de la valeur Requis, seules les connexions provenant d'applications protégées sur des systèmes d'exploitation protégés sont acceptées. Ce paramètre est le plus sécurisé des trois options mais les connexions provenant de systèmes d'exploitation qui ne prennent pas en charge la Protection étendue ne pourront pas se connecter à SQL Server.

Noms principaux de service (SPN) NTLM acceptés

Lorsque l'instance de SQL Server est identifiée par plusieurs noms principaux de service (SPN) NTLM, répertoriez-les ici sous la forme d'une série de chaînes séparées par des points-virgules. Par exemple, la valeur MSSQLSvc/NomHôte1.Contoso.com;MSSQLSvc/NomHôte2.Contoso.com indique que les clients qui essaient de se connecter aux noms principaux de service (SPN) MSSQLSvc/HÔTE1 et MSSQLSvc/HÔTE2 sont autorisés. La variable a une longueur maximale de 2 048 caractères.


Propriétés de Mémoire partagée

Propriétés de Mémoire partagée |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

La page Protocole de la boîte de dialogue Propriétés de Mémoire partagée permet d'activer ou de désactiver le protocole Mémoire partagée. Il s'agit du protocole le plus simple à utiliser et pour lequel aucun paramètre ne doit être configuré. Étant donné que les clients qui utilisent le protocole de mémoire partagée peuvent se connecter uniquement à une instance Microsoft SQL Server exécutée sur le même ordinateur, il n'est pas utile pour la plupart des activités de base de données. Utilisez le protocole de mémoire partagée pour débloquer une situation dans laquelle vous suspectez que les autres protocoles ne sont pas configurés correctement.

Pour activer ou désactiver le protocole, SQL Server doit être redémarré.

Options

Activé

Les valeurs possibles sont Oui et Non. Le protocole de mémoire partagée est activé par défaut.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de Canaux nommés

Propriétés de Canaux nommés |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

Utilisez la page Protocole de la boîte de dialogue Propriétés de Canaux nommés pour afficher ou modifier le canal nommé sur lequel écoute Microsoft SQL Server, lors de l'utilisation du protocole Canaux nommés.

Pour activer ou désactiver le protocole, ou modifier le canal nommé, SQL Server doit être redémarré.

Options

Activé

Les valeurs possibles sont Oui et Non.

Nom du canal

Spécifie le canal nommé sur lequel écoute SQL Server. Par défaut, SQL Server est à l'écoute sur \\.\pipe\sql\query pour l'instance par défaut et sur \\.\pipe\MSSQL$<instancename>\sql\query pour une instance nommée. Ce champ est limité à 2 047 caractères.

Création d'un autre canal nommé

Pour modifier le canal nommé, tapez le nom du nouveau canal dans la zone Nom du canal puis arrêtez et redémarrez SQL Server. Étant donné que sql\query est connu comme étant le canal nommé utilisé par SQL Server, le fait de modifier ce canal peut permettre de réduire les risques d'attaques par des programmes malveillants.

Exemple

Tapez \\.\pipe\unit\app pour écouter sur le canal unit\app.

Tapez \\.\pipe\acct pour écouter sur le canal acct.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide de canaux nommés

Concepts

Choix d'un protocole réseau

Autres ressources

Procédure : activer ou désactiver un protocole réseau de serveur (SQL Server PowerShell)

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de TCP/IP (onglet Protocoles)

Propriétés de TCP/IP (onglet Protocoles) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

La boîte de dialogue Propriétés de TCP/IP permet de configurer les options du protocole TCP/IP. Cliquez sur TCP/IP dans le volet gauche pour afficher les configurations de chaque adresse IP dans le volet d'informations.

Pour appliquer les modifications, redémarrez SQL Server.

Options

Activée

Les valeurs possibles sont Oui et Non.

Keep Alive

Spécifiez la fréquence (millisecondes) à laquelle les paquets de maintien d'activité sont transmis pour vérifier si l'ordinateur situé à l'extrémité distante d'une connexion est toujours disponible.

Écouter tout

Spécifiez si SQL Server doit écouter sur toutes les adresses IP liées aux cartes réseau de l'ordinateur. Si vous choisissez la valeur Non, configurez chaque adresse IP séparément en utilisant la boîte de dialogue des propriétés de chaque adresse IP. Si vous choisissez la valeur Oui, les paramètres de la zone des propriétés de IPAll s'appliquent à toutes les adresses IP. La valeur par défaut est Oui.

Aucun délai

SQL Server n'implémente pas les modifications apportées à cette propriété.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP

Concepts

Choix d'un protocole réseau

Autres ressources

Procédure : activer ou désactiver un protocole réseau de serveur (SQL Server PowerShell)

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés TCP/IP (onglet Adresses IP)

Propriétés TCP/IP (onglet Adresses IP) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

La boîte de dialogue Propriétés TCP/IP (onglet Adresses IP) permet de configurer les options du protocole TCP/IP pour une adresse IP spécifique. Seules les options Ports TCP dynamiques et Port TCP peuvent être configurées pour toutes les adresses en une seule fois en sélectionnant IPAll.

Les modifications sont appliquées au redémarrage de Microsoft SQL Server. Pour obtenir des informations sur le démarrage et l'arrêt du service SQL Server Browser, consultez Procédure : démarrer et arrêter le service SQL Server Browser dans la documentation en ligne.

Ports statiques et ports dynamiques

L'instance par défaut de SQL Server écoute les connexions entrantes sur le port 1433. Le port peut être modifié pour des raisons de sécurité ou parce qu'une application cliente le requiert. Par défaut, les instances nommées (y compris SQL Server Express) sont configurées pour être à l'écoute sur les ports dynamiques. Pour configurer un port statique, ne complétez pas la zone Ports TCP dynamiques et spécifiez un numéro de port disponible dans la zone Port TCP. Pour plus d'informations sur l'ouverture de ports dans le pare-feu, consultez Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server dans la documentation en ligne.

Ports dynamiques

Au démarrage, lorsqu'une instance de SQL Server est configurée pour écouter sur des ports dynamiques, elle vérifie s'il existe un port disponible dans le système d'exploitation et ouvre un point de terminaison pour ce port. Les connexions entrantes doivent spécifier ce numéro de port pour se connecter. Étant donné qu'il est possible de modifier le numéro de port à chaque démarrage de SQL Server, SQL Server fournit le service SQL Server Browser pour analyser les ports et diriger les connexions entrantes vers le port actif de cette instance. L'utilisation des ports dynamiques complique la connexion de SQL Server par le biais d'un pare-feu, car le numéro de port peut changer lors du redémarrage de SQL Server, ce qui nécessite la modification des paramètres du pare-feu. Pour éviter les problèmes de connexion liés à un pare-feu, configurez SQL Server de manière à utiliser un port statique.

Options

Actif

Indique que l'adresse IP est active sur l'ordinateur. Option non disponible pour IPAll.

Activée.

Si la propriété Écouter tout des Propriétés TCP/IP (onglet Protocole) a la valeur Non, elle indique si SQL Server est à l'écoute sur l'adresse IP. Si la propriété Écouter tout des Propriétés TCP/IP (onglet Protocole) a la valeur Oui, la propriété est ignorée. Option non disponible pour IPAll.

Adresse IP

Afficher ou modifier l'adresse IP utilisée par cette connexion. Indique l'adresse IP utilisée par l'ordinateur et l'adresse de boucle IP, 127.0.0.1. Option non disponible pour IPAll. L'adresse IP peut être au format IPv4 ou IPv6.

Ports TCP dynamiques

Aucune valeur si les ports ne sont pas activés. Pour utiliser les ports dynamiques, indiquez la valeur 0.

Pour IPAll, affiche le numéro du port dynamique utilisé.

Port TCP

Afficher ou modifier le port sur lequel écoute SQL Server. L'instance par défaut de Moteur de base de données écoute sur le port 1433 par défaut.

Le Moteur de base de données SQL Server peut être à l'écoute sur plusieurs ports sur la même adresse IP. Répertorie les ports, séparés par des virgules, au format 1433,1500,1501. Ce champ est limité à 2 047 caractères.

Pour configurer une seule adresse IP pour l'écoute sur plusieurs ports, le paramètre Écouter tout doit également être défini avec la valeur Non, dans l'onglet Protocoles de la boîte de dialogue Propriétés de TCP/IP. Pour plus d'informations, consultez « Procédure : configurer le moteur de base de données de manière à écouter sur plusieurs ports TCP » dans la documentation en ligne de SQL Server.

Ajout ou suppression d'adresses IP

Le Gestionnaire de configuration SQL Server affiche les adresses IP qui étaient disponibles au moment de l'installation de SQL Server. Les adresses IP disponibles peuvent changer lorsque : des cartes réseau sont ajoutées ou supprimées, une adresse IP affectée dynamiquement arrive à expiration, une structure de réseau est reconfigurée ou un ordinateur est déplacé physiquement, par exemple si un ordinateur portable est connecté au réseau d'un autre bâtiment. Pour changer une adresse IP, modifiez la zone Adresse IP, puis redémarrez SQL Server.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP

Concepts

Choix d'un protocole réseau
Service SQL Server Browser

© 2010 Microsoft Corporation. Tous droits réservés.


Propriétés de VIA

Propriétés de VIA |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration du réseau SQL Server 2008 >

La boîte de dialogue Propriétés de VIA permet d'afficher ou de spécifier les options ci-dessous pour le protocole VIA (Virtual Interface Adapter).

Pour activer ou désactiver le protocole, ou appliquer les modifications apportées aux paramètres, Microsoft SQL Server doit être redémarré.

Options

Port par défaut

Le paramètre par défaut est 0:1433, au format <network interface card number>:<port number>.

Activé

Les valeurs possibles sont Oui et Non. Le protocole VIA est désactivé par défaut.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Écouter les informations

Le paramètre par défaut est 0:1433, au format <network interface card number>:<port number>.

Lorsque vous répertoriez plusieurs ports, séparez-les par des virgules. Ce champ est limité à 2 047 caractères.

Attention :
Lorsque plusieurs instances de SQL Server sont installées, étudiez les paramètres de port et configurez chaque port pour qu'il soit utilisé par une seule instance. SQL Server ne permet pas à deux instances d'écouter sur le même port avec le protocole TCP/IP, mais cela est possible avec le protocole VIA. Si deux instances écoutent sur le même port, les connexions VIA entrantes peuvent ne pas parvenir à se connecter ou se connecter à une instance inappropriée.

Voir aussi

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Configuration de SQL Server Native Client

Configuration de SQL Server Native Client
Aide sur le Gestionnaire de configuration SQL Server >

Cette section contient les rubriques d'aide accessibles au moyen de la touche F1, relatives aux boîtes de dialogue de Configuration de SQL Server Native Client du Gestionnaire de configuration Microsoft SQL Server. SQL Server Native Client est la bibliothèque réseau que les ordinateurs clients utilisent pour se connecter à SQL Server, à compter de Microsoft SQL Server.

Les paramètres définis dans la configuration de SQL Server Native Client sont utilisés sur l'ordinateur exécutant le programme client. Lorsqu'ils sont configurés sur l'ordinateur exécutant SQL Server, ils n'affectent que les programmes clients en cours d'exécution sur le serveur.

Ces paramètres n'affectent pas les clients qui se connectent aux versions antérieures de SQL Server, sauf s'ils utilisent les outils clients disponibles à partir de SQL Server, tels que SQL Server Management Studio.

Dans cette section

  • Création d'une chaîne de connexion valide à l'aide du protocole VIA

  • Protocoles clients (Gestionnaire de configuration SQL Server)

    • Propriétés de protocoles clients (onglet Ordre)

    • Protocoles clients - Propriétés de Mémoire partagée (onglet Protocole)

    • Protocoles clients - Propriétés de TCP/IP (onglet Protocole)

    • Protocoles clients - Propriétés de Canaux nommés (onglet Protocole)

    • Protocoles clients - Propriétés de VIA (onglet Protocole)

  • Alias (Gestionnaire de configuration SQL Server)

    • Nouvel alias (onglet Alias)

    • Propriétés <Alias> (onglet Alias)

    • Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée

    • Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP

    • Création d'une chaîne de connexion valide à l'aide de canaux nommés

    • Création d'une chaîne de connexion valide à l'aide du protocole VIA


Propriétés de la configuration de SQL Server Native Client (onglet Indicateurs)

Propriétés de la configuration de SQL Server Native Client (onglet Indicateurs)
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client >

Les clients Microsoft SQL Server installés sur cet ordinateur communiquent avec les serveurs SQL Server à l'aide des protocoles fournis dans le fichier de bibliothèque SQL Server Native Client. Cette page permet de configurer l'ordinateur client de manière à ce qu'il demande une connexion chiffrée utilisant le protocole SSL (Secure Sockets Layer). En cas d'impossibilité d'établir une connexion chiffrée, la connexion échoue.

Le processus de connexion est toujours chiffré. Les options ci-dessous s'appliquent uniquement aux données de chiffrement. Pour plus d'informations sur la manière dont SQL Server chiffre les communications et pour obtenir des instructions sur la manière de configurer le client pour qu'il approuve l'autorité racine du certificat du serveur, consultez « Chiffrement des connexions à SQL Server » et « Procédure : activer des connexions chiffrées dans le moteur de base de données (Gestionnaire de configuration SQL Server ) » dans la documentation en ligne de SQL Server .

Options

Forcer le chiffrement du protocole

Demande une connexion utilisant le protocole SSL.

Faire confiance au certificat de serveur

Lorsque cette option a la valeur Non, le processus client tente de valider le certificat du serveur. Le client et le serveur doivent tous les deux posséder un certificat émanant d'une autorité de certification publique. Si le certificat n'est pas présent sur l'ordinateur client ou que la validation du certificat échoue, la connexion prend fin.

Lorsque l'option a la valeur Oui, le client ne valide pas le certificat du serveur, ce qui permet d'utiliser un certificat autosigné.

L'indicateur Faire confiance au certificat de serveur est utilisé seulement si l'option Forcer le chiffrement du protocole a la valeur Oui .


Protocoles clients (Gestionnaire de configuration SQL Server)

Protocoles clients (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client >

Pour configurer l'ordre dans lequel les clients Microsoft SQL Server utilisent les protocoles sur cet ordinateur, cliquez avec le bouton droit sur Protocoles clients dans le volet console, puis cliquez sur Propriétés, ou cliquez avec le bouton droit sur un protocole dans le volet d'informations, puis cliquez sur Ordre.

Pour configurer les propriétés des protocoles clients utilisés par les clients SQL Server sur cet ordinateur, dans le volet console, cliquez sur Protocoles clients, dans le volet d'informations, cliquez avec le bouton droit sur le protocole de votre choix, puis cliquez sur Propriétés.


Propriétés de protocoles clients (onglet Ordre)

Propriétés de protocoles clients (onglet Ordre) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Protocoles clients (Gestionnaire de configuration SQL Server) >

La page Ordre de la boîte de dialogue Propriétés de protocoles clients vous permet d'afficher et d'activer les protocoles clients.

Cliquez sur un protocole, puis sur Activer ou Désactiver pour déplacer le protocole sélectionné vers la liste Protocoles désactivés ou Protocoles activés.

Les protocoles sont essayés dans l'ordre dans lequel ils sont répertoriés, en commençant par le premier de la liste. Déplacez les protocoles vers le haut ou vers le bas dans la liste Protocoles activés, en cliquant sur les flèches haut et bas. Lorsque vous vous connectez à Microsoft SQL Server à partir d'un client installé sur cet ordinateur, le protocole Mémoire partagée est toujours essayé en premier, s'il est activé.

Remarque :
Ces paramètres ne sont pas utilisés par Microsoft SqlClient .NET. L'ordre des protocoles pour SqlClient .NET commence par TCP, puis viennent les canaux nommés, qui ne peuvent pas être modifiés.

Options

Protocoles désactivés

Répertorie les protocoles installés mais actuellement non utilisés.

Protocoles activés

Répertorie les protocoles disponibles pour les clients Microsoft SQL Server sur cet ordinateur.

>

Active le protocole actuellement affiché en surbrillance dans la zone Protocoles désactivés, en le déplaçant vers la zone Protocoles activés.

<

Désactive le protocole actuellement affiché en surbrillance dans la zone Protocoles activés, en le déplaçant vers la zone Protocoles désactivés.

Flèche haut

Déplace le protocole affiché en surbrillance vers le haut de la liste. Cela vous permet d'augmenter la priorité avec laquelle la Net-Library essaie d'utiliser le protocole sélectionné pour les connexions.

Flèche bas

Déplace le protocole affiché en surbrillance vers le bas de la liste. Cela vous permet de diminuer la priorité avec laquelle la Net-Library essaie d'utiliser le protocole sélectionné pour les connexions.

Activer le protocole de mémoire partagée

Lors de l'établissement d'une connexion à SQL Server à partir d'un client installé sur cet ordinateur, active le protocole de mémoire partagée qui est toujours essayé en premier (s'il est activé).

Remarque :
Si le protocole est spécifié par le biais d'un préfixe ou à l'intérieur de la chaîne de connexion, seul le protocole spécifié est essayé.

Voir aussi

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Protocoles clients - Propriétés de Mémoire partagée (onglet Protocole)

Protocoles clients - Propriétés de Mémoire partagée (onglet Protocole) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Protocoles clients (Gestionnaire de configuration SQL Server) >

Dans le Gestionnaire de configuration Microsoft SQL Server, utilisez l'onglet Protocole de la boîte de dialogue Propriétés de Mémoire partagée pour visualiser ou modifier la mémoire partagée. Pour plus d'informations sur les chaînes de connexion, consultez Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée.

Options

Activé

Les valeurs possibles sont Oui et Non.

Voir aussi

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Protocoles clients - Propriétés de TCP/IP (onglet Protocole)

Protocoles clients - Propriétés de TCP/IP (onglet Protocole) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Protocoles clients (Gestionnaire de configuration SQL Server) >

Dans le Gestionnaire de connexions de Microsoft SQL Server , utilisez l'onglet Protocole de la boîte de dialogue Propriétés de TCP/IP pour afficher ou spécifier les options suivantes. Pour vous connecter à un autre port, tapez le numéro du port dans la zone Port par défaut. Pour plus d'informations sur les chaînes de connexion, consultez Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP.

Options

Port par défaut

Spécifie le port par défaut que la Net-Library TCP/IP essaie d'utiliser pour se connecter à l'instance cible de SQL Server. Le port par défaut est 1433.

Lorsqu'un client se connecte à une instance par défaut du Moteur de base de données, il utilise cette valeur. Si une instance par défaut a été configurée pour écouter sur un port différent, remplacez cette valeur par ce numéro de port.

Lorsqu'un client se connecte à une instance nommée de Moteur de base de données, il essaie d'obtenir le numéro de port auprès du service SQL Server Browser exécuté sur l'ordinateur serveur. Si le service SQL Server Browser n'est pas en cours d'exécution, le numéro de port doit être spécifié par le biais de ce paramètre ou dans la chaîne de connexion.

Activé

Les valeurs possibles sont Oui et Non.

Keep Alive

Ce paramètre (valeur exprimée en millisecondes) contrôle la fréquence à laquelle TCP tente de vérifier qu'une connexion inactive est toujours intacte en envoyant un paquet KEEPALIVE. La valeur par défaut est 30 000 millisecondes.

Intervalle Keep Alive

Ce paramètre, dont la valeur est exprimée en millisecondes, détermine l'intervalle qui sépare les retransmissions KEEPALIVE jusqu'à ce qu'une réponse soit reçue. La valeur par défaut est 1 000 millisecondes.

Voir aussi

Référence

Nouvel alias (onglet Alias)
Propriétés <Alias> (onglet Alias)

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Protocoles clients - Propriétés de Canaux nommés (onglet Protocole)

Protocoles clients - Propriétés de Canaux nommés (onglet Protocole) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Protocoles clients (Gestionnaire de configuration SQL Server) >

Dans le Gestionnaire de configuration Microsoft SQL Server, utilisez l'onglet Protocole de la boîte de dialogue Propriétés de Canaux nommés pour visualiser ou modifier la description du canal par défaut. Pour vous connecter à un autre canal, tapez son nom dans la zone Canal par défaut. Pour plus d'informations sur les chaînes de connexion, consultez Création d'une chaîne de connexion valide à l'aide de canaux nommés.

Options

Canal par défaut

Spécifie le canal par défaut que la Net-Library des canaux nommés essaie d'utiliser pour se connecter à l'instance cible de SQL Server. Par défaut, SQL Server est à l'écoute sur : \\.\pipe\sql\query

Pour vous connecter au canal par défaut, entrez sql\query

Activé

Les valeurs possibles sont Oui et Non.

Voir aussi

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Protocoles clients - Propriétés de VIA (onglet Protocole)

Protocoles clients - Propriétés de VIA (onglet Protocole) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Protocoles clients (Gestionnaire de configuration SQL Server) >

Dans le Gestionnaire de configuration Microsoft SQL Server, l'onglet Protocole de la boîte de dialogue Propriétés de VIA vous permet d'afficher ou de spécifier les options suivantes du protocole VIA (Virtual Interface Adapter). Pour plus d'informations sur les chaînes de connexion, consultez Création d'une chaîne de connexion valide à l'aide du protocole VIA.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Options

NIC par défaut

Indique la carte d'interface réseau à laquelle le protocole VIA est lié. Les cartes d'interface réseau sont numérotées à partir de zéro. Les ordinateurs dotés d'une seule carte d'interface réseau indiquent 0.

Serveur par défaut

Port VIA sur lequel le protocole VIA est à l'écoute lors de l'acceptation de connexions à partir de clients VIA.

Activé

Les valeurs possibles sont Oui et Non.

Voir aussi

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Alias (Gestionnaire de configuration SQL Server)

Alias (Gestionnaire de configuration SQL Server)
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client >

Un alias est un nom de remplacement permettant d'établir une connexion. L'alias encapsule les éléments requis d'une chaîne de connexion, puis les expose sous un nom choisi par l'utilisateur. Pour créer un alias pour les clients Microsoft SQL Server installés sur cet ordinateur, cliquez avec le bouton droit sur Alias dans le volet de console, puis cliquez sur Nouvel alias. Pour configurer un alias existant pour les clients SQL Server installés sur cet ordinateur, cliquez sur Alias dans le volet de console, cliquez avec le bouton droit sur l'alias existant de votre choix dans le volet d'informations, puis cliquez sur Propriétés.


Nouvel alias (onglet Alias)

Nouvel alias (onglet Alias)
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Un alias est un nom de remplacement permettant d'établir une connexion. L'alias encapsule les éléments requis d'une chaîne de connexion, puis les expose sous un nom choisi par l'utilisateur. La page Alias de la boîte de dialogue Alias - Nouveau vous permet de spécifier les éléments de la chaîne de connexion d'un alias. Pour modifier la chaîne de connexion d'un alias existant, consultez Propriétés <Alias> (onglet Alias).

Il n'est pas nécessaire de renseigner toutes les valeurs de la grille Propriétés. Le protocole sélectionné détermine les combinaisons valides. Voir les rubriques indiquées ci-après pour obtenir des exemples de combinaisons valides.

Nom de l'alias

Nom (alias) à utiliser pour faire référence à cette connexion.

Nom du canal / Numéro de port / Paramètres VIA

Éléments supplémentaires de la chaîne de connexion. Le nom de cette zone varie en fonction du protocole sélectionné.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Protocole

Protocole utilisé pour la connexion.

Serveur

Nom de l'instance Microsoft SQL Server vers laquelle la connexion est établie.

Cas d'utilisation d'un alias

Par défaut, SQL Server se connecte à une instance locale de SQL Server en utilisant le protocole de mémoire partagée, et à une instance de SQL Server sur un autre ordinateur à l'aide du protocole TCP/IP ou du protocole des canaux nommés. Créez un alias lorsque vous utilisez le protocole TCP/IP, des canaux nommés ou VIA, et que vous souhaitez fournir une chaîne de connexion personnalisée ou utiliser un nom différent du nom de serveur pour la connexion.

Exemples

  • SQL Server n'étant pas à l'écoute sur le port TCP/IP 1433 par défaut, vous pouvez fournir une chaîne de connexion comportant un numéro de port différent.

  • SQL Server n'étant pas à l'écoute sur le canal nommé par défaut, vous pouvez fournir une chaîne de connexion comportant un nom de canal différent.

  • Une application doit normalement se connecter à une base de données située sur le serveur nommé ACCT, mais cette base de données a été consolidée sous la forme d'une instance nommée ACCT sur un serveur nommé CENTRAL. L'application ne peut pas être facilement modifiée. Créez un alias nommé ACCT, avec une chaîne de connexion pointant vers CENTRAL\ACCT.

Création d'une chaîne de connexion valide

Les rubriques suivantes décrivent et illustrent des combinaisons valides de propriétés d'alias :

  • Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée

  • Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP

  • Création d'une chaîne de connexion valide à l'aide de canaux nommés

  • Création d'une chaîne de connexion valide à l'aide du protocole VIA


Propriétés <Alias> (onglet Alias)

Propriétés <Alias> (onglet Alias) |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Un alias est un nom de remplacement permettant d'établir une connexion. L'alias encapsule les éléments requis d'une chaîne de connexion, puis les expose sous un nom choisi par l'utilisateur. Utilisez la page Alias de la boîte de dialogue Propriétés <Nom alias> pour afficher ou spécifier les éléments de chaîne de connexion d'un alias.

Options

Nom de l'alias

Nom (alias) à utiliser pour faire référence à cette connexion.

Nom du canal / Numéro de port / Paramètres VIA

Éléments supplémentaires de la chaîne de connexion. Le nom de cette zone varie en fonction du protocole sélectionné. Consultez les rubriques ci-après pour obtenir des exemples.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Protocole

Protocole utilisé pour la connexion.

Serveur

Nom de l'instance Microsoft SQL Server vers laquelle la connexion est établie.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée
Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP
Création d'une chaîne de connexion valide à l'aide de canaux nommés
Création d'une chaîne de connexion valide à l'aide du protocole VIA

© 2010 Microsoft Corporation. Tous droits réservés.


Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Les connexions à Microsoft SQL Server à partir d'un client exécuté sur le même ordinateur utilisent le protocole de mémoire partagée. La mémoire partagée ne possède aucune propriété configurable. La mémoire partagée est toujours sollicitée en premier et ne peut pas être déplacée depuis sa position initiale dans la liste des Protocoles activés dans la boite de dialogue de Propriétés de protocoles clients. Le protocole de mémoire partagée peut être désactivé, ce qui est utile lors du dépannage de l'un des autres protocoles.

Vous ne pouvez pas créer un alias utilisant le protocole de mémoire partagée mais, si la mémoire partagée est activée, la connexion au Moteur de base de données à partir du nom crée une connexion de mémoire partagée. Une chaîne de connexion de mémoire partagée utilise le format lpc:<servername>[\instancename].

Connexion au serveur local

Lorsque vous vous connectez à SQL Server alors que celui-ci s'exécute sur le même ordinateur que l'ordinateur client, vous pouvez utiliser (local) comme nom de serveur. Cette option n'est pas conseillée dans la mesure où elle est source d'ambiguïté ; toutefois, elle peut s'avérer utile lorsqu'il est certain que le client s'exécute sur l'ordinateur visé. Par exemple, lorsque vous créez une application destinée à des utilisateurs itinérants déconnectés, par exemple à une force de vente, là où SQL Server s'exécute sur des ordinateurs portables et stocke des données de projet, un client établissant une connexion à (local) se connectera toujours au SQL Server en cours d'exécution sur l'ordinateur portable. Vous pouvez utiliser le mot localhost ou un point (.) à la place de (local).

Vérification du protocole de connexion

La requête suivante renvoie le protocole utilisé pour la connexion en cours.

Copier le code
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

Exemples :

Les noms suivants permettent d'établir une connexion à l'ordinateur local avec le protocole de mémoire partagée si celui-ci est activé :

<servername>

<servername>\<instancename>

(local)

localhost

Vous ne pouvez pas créer un alias pour une connexion de mémoire partagée.

Remarque :
La spécification d'une adresse IP dans la zone Serveur génère une connexion TCP/IP.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP
Création d'une chaîne de connexion valide à l'aide de canaux nommés
Création d'une chaîne de connexion valide à l'aide du protocole VIA

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP

Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Pour créer une chaîne de connexion valide à l'aide du protocole TCP/IP, procédez comme suit :

  • Spécifiez un nom d'alias.

  • Pour le Serveur, entrez le nom d'un serveur auquel vous pouvez vous connecter à l'aide de l'utilitaire PING ou une adresse IP à laquelle vous pouvez vous connecter à l'aide de l'utilitaire PING. Pour une instance nommée, ajoutez son nom.

  • Spécifiez TCP/IP comme Protocole.

  • Vous pouvez éventuellement entrer un numéro de port dans Numéro de port. La valeur par défaut est 1433 ; il s'agit du numéro de port de l'instance par défaut du Moteur de base de données sur un serveur. Pour vous connecter à une instance nommée ou à une instance par défaut qui n'est pas à l'écoute sur le port 1433, vous devez spécifier le numéro de port ou démarrer le service SQL Server Browser. Pour plus d'informations sur la configuration du service SQL Server Browser, consultez Service SQL Server Browser.

Au moment de la connexion, le composant SQL Server Native Client lit dans le Registre les valeurs de serveur, protocole et port pour le nom d'alias spécifié, et crée une chaîne de connexion au format tcp:<servername>[\<instancename>],<port> ou tcp:<IPAddress>[\<instancename>],<port>.

Remarque :
Microsoft Windows XP Service Pack 2 prend en charge le pare-feu Windows, qui ferme le port 1433 par défaut. Comme Microsoft SQL Server communique via le port 1433, vous devez rouvrir le port si SQL Server est configuré pour être à l'écoute des connexions clientes entrantes utilisant TCP/IP. Pour plus d'informations sur la configuration d'un pare-feu, consultez « Procédure : configurer un pare-feu pour accéder à SQL Server » dans la documentation en ligne SQL Server ou passez en revue la documentation de votre pare-feu.

SQL Server et SQL Server Native Client prennent intégralement en charge IPv4 (Internet Protocol version 4) et IPv6 (Internet Protocol version 6). Le Gestionnaire de configuration SQL Server accepte les deux formats IPv4 et IPv6 pour les adresses IP. Pour plus d'informations sur IPv6, consultez « Connexion avec IPv6 » dans la documentation en ligne de SQL Server.

Connexion au serveur local

Lorsque vous vous connectez à SQL Server alors que celui-ci est exécuté sur le même ordinateur que l'ordinateur client, vous pouvez utiliser (local) comme nom de serveur. Cette option n'est pas conseillée dans la mesure où elle est source d'ambiguïté ; toutefois, elle peut s'avérer utile lorsqu'il est certain que le client s'exécute sur l'ordinateur visé. Par exemple, lorsque vous créez une application destinée à des utilisateurs itinérants déconnectés, tels que des vendeurs, pour lesquels SQL Server s'exécute sur des ordinateurs portables et stocke les données de projet, un client établissant une connexion à (local) se connecte toujours à l'instance de SQL Server en cours d'exécution sur l'ordinateur portable. Vous pouvez utiliser le mot localhost ou un point (.) à la place de (local).

Vérification de votre protocole de connexion

La requête suivante retourne le protocole utilisé pour la connexion active.

Copier le code
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

Exemples

Connexion à partir du nom de serveur :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <servername>

Connexion à une instance nommée à partir du nom de serveur :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <servername>\<instancename>

Connexion à un port spécifié à partir du nom de serveur :

Copier le code
Alias Name         <serveralias>
Port No            <port>
Protocol           TCP/IP
Server             <servername>

Connexion par l'adresse IP :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <IPAddress>

Connexion par l'adresse IP à une instance nommée :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             <IPAddress>\<instancename>

Connexion par l'adresse IP à un port spécifié :

Copier le code
Alias Name         <serveralias>
Port No            <port number>
Protocol           TCP/IP
Server             <IPAddress>

Connexion à l'ordinateur local à l'aide du paramètre (local) :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             (local)

Connexion à l'ordinateur local à l'aide du paramètre localhost :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             localhost

Connexion à une instance nommée sur l'ordinateur local localhost :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             localhost\<instancename>

Connexion à l'ordinateur local à l'aide d'un point :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             .

Connexion à une instance nommée sur l'ordinateur local à l'aide d'un point :

Copier le code
Alias Name         <serveralias>
Port No            <blank>
Protocol           TCP/IP
Server             .\<instancename>
Remarque :
Pour plus d'informations sur la spécification du protocole réseau en tant que paramètre sqlcmd, consultez « Procédure : se connecter au moteur de base de données à l'aide de sqlcmd.exe » dans la documentation en ligne de SQL Server.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée
Création d'une chaîne de connexion valide à l'aide de canaux nommés
Création d'une chaîne de connexion valide à l'aide du protocole VIA

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Création d'une chaîne de connexion valide à l'aide de canaux nommés

Création d'une chaîne de connexion valide à l'aide de canaux nommés |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Sauf modification par l'utilisateur, lorsque l'instance par défaut de Microsoft SQL Server est à l'écoute sur le protocole des canaux nommés, elle utilise \\.\pipe\sql\query comme nom de canal. Le point indique que l'ordinateur est l'ordinateur local, pipe indique que la connexion est un canal nommé et sql\query est le nom du canal. Pour définir la connexion au canal par défaut, l'alias doit avoir \\<computer_name>\pipe\sql\query comme nom de canal. Si SQL Server a été configuré de manière à être à l'écoute sur un autre canal, le nom de canal doit correspondre à ce canal. Par exemple, si SQL Server utilise \\.\pipe\unit\app comme canal, l'alias doit utiliser \\<computer_name>\pipe\unit\app comme nom de canal.

Pour créer un nom de canal valide, vous devez procéder comme suit :

  • Spécifiez un nom d'alias.

  • Sélectionnez Canaux nommés en tant que Protocole.

  • Entrez le Nom du canal. Vous pouvez également ne pas compléter le Nom du canal et le Gestionnaire de configuration SQL Server spécifiera le nom de canal approprié une fois que vous aurez spécifié le Protocole et le Serveur.

  • Spécifiez un Serveur. Pour une instance nommée, vous pouvez indiquer un nom de serveur et un nom d'instance.

Au moment de la connexion, le composant SQL Server Native Client lit dans le Registre les valeurs de serveur, protocole et nom de canal pour le nom d'alias spécifié et crée un nom de canal au format np:\\<computer_name>\pipe\<pipename> ou np:\\<IPAddress>\pipe\<pipename>. Pour une instance nommée, le nom de canal par défaut est \\<computer_name>\pipe\MSSQL$<instance_name>\sql\query.

Remarque :
Microsoft Windows XP Service Pack 2 prend en charge le pare-feu Windows, qui ferme le port 445 par défaut. Comme Microsoft SQL Server communique par le biais du port 445, vous devez ouvrir de nouveau le port si SQL Server est configuré pour être à l'écoute des connexions clientes entrantes utilisant des canaux nommés. Pour plus d'informations sur la configuration d'un pare-feu, consultez « Procédure : configurer un pare-feu pour accéder à SQL Server » dans la documentation en ligne SQL Server ou passez en revue la documentation de votre pare-feu.

Connexion au serveur local

Lorsque vous vous connectez à SQL Server alors que celui-ci est exécuté sur le même ordinateur que l'ordinateur client, vous pouvez utiliser (local)comme nom de serveur. L'utilisation de (local) n'est pas conseillée dans la mesure où elle est source d'ambiguïté ; toutefois, elle peut s'avérer utile lorsqu'il est certain que le client s'exécute sur l'ordinateur prévu. Par exemple, lorsque vous créez une application destinée à des utilisateurs itinérants déconnectés, tels que des vendeurs, pour lesquels SQL Server s'exécute sur des ordinateurs portables et stocke les données de projet, un client établissant une connexion à (local) se connecte toujours à l'instance de SQL Server en cours d'exécution sur l'ordinateur portable. Vous pouvez utiliser le mot localhost ou un point (.) à la place de (local).

Vérification de votre protocole de connexion

La requête suivante renvoie le protocole utilisé pour la connexion actuelle.

Copier le code
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

Exemples

Connexion au canal par défaut à partir du nom de serveur :

Copier le code
Alias Name         <serveralias>
Pipe Name          <blank>
Protocol           Named Pipes
Server             <servername>

Connexion au canal par défaut à partir de l'adresse IP :

Copier le code
Alias Name         <serveralias>
Pipe Name          <leave blank>
Protocol           Named Pipes
Server             <IPAddress>

Connexion à partir du nom de serveur à un canal autre que celui utilisé par défaut :

Copier le code
Alias Name         <serveralias>
Pipe Name          \\<servername>\pipe\unit\app
Protocol           Named Pipes
Server             <servername>

Connexion à une instance nommée à partir du nom de serveur :

Copier le code
Alias Name         <serveralias>
Pipe Name          \\<servername>\pipe\MSSQL$<instancename>\SQL\query
Protocol           Named Pipes
Server             <servername>

Connexion à l'ordinateur local à l'aide du paramètre localhost :

Copier le code
Alias Name         <serveralias>
Pipe Name          <blank>
Protocol           Named Pipes
Server             localhost

Connexion à l'ordinateur local à l'aide d'un point :

Copier le code
Alias Name         <serveralias>
Pipe Name          <left blank>
Protocol           Named Pipes
Server             .
Remarque :
Pour spécifier le protocole réseau en tant que paramètre sqlcmd, consultez « Procédure : se connecter au moteur de base de données à l'aide de sqlcmd.exe » dans la documentation en ligne de SQL Server.

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée
Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP
Création d'une chaîne de connexion valide à l'aide du protocole VIA

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Création d'une chaîne de connexion valide à l'aide du protocole VIA

Création d'une chaîne de connexion valide à l'aide du protocole VIA |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server > Configuration de SQL Server Native Client > Alias (Gestionnaire de configuration SQL Server) >

Pour créer une chaîne de connexion valide à l'aide du protocole VIA (Virtual Interface Adapter), vous devez indiquer chacun des éléments suivants :

  • Spécifiez un nom d'alias.

  • Indiquez le numéro de carte d'interface réseau, suivi d'un numéro de port, dans la zone Paramètres VIA. En l'absence de valeur, le protocole VIA essaie d'établir une connexion au port <NIC#>:1433.

  • Spécifiez VIA comme Protocole.

  • Dans le champ Serveur, entrez le nom du serveur ou <servername>\<instancename> pour une instance nommée.

Au moment de la connexion, le composant SQL Server Native Client lit dans le Registre les valeurs Serveur, Protocole et Paramètres VIA relatives au Nom d'alias spécifié et crée une chaîne de connexion selon le format via:<servername> [\instancename],<nic number>:<port>.

Important :
Lorsque au moins deux instances de Microsoft SQL Server sont installées sur le même ordinateur, les connexions VIA peuvent être ambiguës. Lorsqu'il est activé, le protocole VIA essaie d'utiliser les paramètres TCP/IP et est à l'écoute sur le port 0:1433. Dans le cas des pilotes VIA ne permettant pas la configuration du port, les deux instances de SQL Server sont à l'écoute sur le même port. Les connexions clientes entrantes peuvent recevoir une connexion à l'instance de serveur correcte, à l'instance de serveur incorrecte ou un refus de connexion parce que le port est en cours d'utilisation.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Vérification du protocole de connexion

La requête suivante retournera le protocole utilisé pour la connexion active.

Copier le code
SELECT net_transport
FROM sys.dm_exec_connections
WHERE session_id = @@SPID;

Exemples :

Connexion à partir du nom de serveur :

Copier le code
Alias Name         ServerAlias
Via Parameters     0:1433
Protocol           VIA
Server             <servername>

Connexion à une instance nommée à partir du nom de serveur :

Copier le code
Alias Name         ServerAlias
Via Parameters     0:1433
Protocol           VIA
Server             <servername>\<instancename>
Remarque :
Pour spécifier le protocole réseau sous forme de paramètre sqlcmd, recherchez dans la documentation en ligne la rubrique « Procédure : se connecter au moteur de base de données à l'aide de sqlcmd.exe ».

Voir aussi

Référence

Création d'une chaîne de connexion valide à l'aide du protocole de mémoire partagée
Création d'une chaîne de connexion valide à l'aide du protocole TCP/IP
Création d'une chaîne de connexion valide à l'aide de canaux nommés

Concepts

Choix d'un protocole réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Service SQL Server Browser

Service SQL Server Browser |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server >

Le programme SQL Server Browser s'exécute en tant que service Windows. SQL Server SQL Browser est à l'écoute des demandes entrantes pour les ressources Microsoft SQL Server et fournit des informations sur les instances SQL Server installées sur l'ordinateur. SQL Server Browser contribue aux actions suivantes :

  • Affichage de la liste des serveurs disponibles

  • Connexion à l'instance correcte du serveur

  • Connexion aux points de terminaison d'une connexion administrateur dédiée (DAC)

Pour chaque instance du moteur de base de données et de SSAS, le service SQL Server Browser (sqlbrowser) fournit le nom de l'instance et le numéro de version. SQL Server Browser est installé avec SQL Server et fournit ce service pour les versions antérieures de SQL Server s'exécutant sur cet ordinateur, à compter de SQL Server 7.0.

SQL Server Browser peut être configuré pendant l'installation ou en utilisant le Gestionnaire de configuration SQL Server. Par défaut, le service SQL Server Browser démarre automatiquement :

  • lors de la mise à niveau d'une installation ;

  • lors d'une installation côte à côte avec une instance de SQL Server 2000 ;

  • lors d'une installation sur un cluster ;

  • lors de l'installation d'une instance nommée du moteur de base de données SQL Server, notamment toutes les instances de SQL Server Express ;

  • lors de l'installation d'une instance nommée d'Analysis Services.

Historique

Avant SQL Server 2000, seule une instance de SQL Server pouvait être installée sur un ordinateur. SQL Server était à l'écoute des demandes entrantes sur le port 1433, attribué à SQL Server par l'IANA (Internet Assigned Numbers Authority). L'utilisation d'un port étant limitée à une seule instance de SQL Server, lorsque SQL Server 2000 a introduit la prise en charge de plusieurs instances de SQL Server, le protocole SSRP (SQL Server Resolution Protocol) a été développé afin de permettre une écoute sur le port UDP 1434. Ce service d'écoute répondait aux demandes des clients avec les noms des instances installées et les ports ou les canaux nommés utilisés par l'instance. Pour parer aux limites du système SSRP, SQL Server 2005 introduit le service SQL Server Browser en remplacement de SSRP.

Fonctionnement de SQL Server Browser

Au moment du démarrage d'une instance de SQL Server, si les protocoles TCP/IP ou VIA sont activés pour SQL Server, un port TCP/IP est attribué au serveur. Si le protocole des canaux nommés est activé, SQL Server est à l'écoute d'un canal nommé spécifique. Ce port, ou « canal de communication », est utilisé par cette instance spécifique pour l'échange de données avec les applications clientes. Au cours de l'installation, le port TCP 1433 et le canal de communication \sql\query sont affectés à l'instance par défaut, mais ceux-ci peuvent être modifiés ultérieurement par l'administrateur du serveur via le Gestionnaire de configuration SQL Server. Dans la mesure où un port ou un canal de communication ne peut être utilisé que par une seule instance de SQL Server, différents numéros de ports et noms de canaux de communication sont attribués pour les instances nommées, y compris SQL Server Express. Par défaut, lorsque les instances nommées et SQL Server Express sont activés, ils sont configurés pour utiliser des ports dynamiques. En d'autres termes, un port disponible est attribué lors du démarrage de SQL Server. Si nécessaire, un port spécifique peut être attribué à une instance de SQL Server. Au moment de la connexion, les clients peuvent désigner un port spécifique. Toutefois, si le port est attribué dynamiquement, le numéro de port peut changer lors de chaque redémarrage de SQL Server, auquel cas le numéro de port correct est inconnu du client.

Lors du démarrage, SQL Server Browser réclame le port UDP 1434. SQL Server Browser lit le Registre, identifie toutes les instances de SQL Server sur l'ordinateur, puis note les ports et autres canaux nommés qu'elles utilisent. Lorsqu'un serveur est équipé de deux cartes réseau ou plus, SQL Server Browser renvoie le premier port activé qu'il détecte pour SQL Server. SQL Server Browser pend en charge les protocoles Ipv6 et ipv4.

Lorsque les clients SQL Server demandent des ressources SQL Server, la bibliothèque réseau cliente envoie un message UDP au serveur à l'aide du port 1434. SQL Server Browser répond avec le port TCP/IP ou canal nommé de l'instance demandée. La bibliothèque réseau de l'application cliente établit alors la connexion en envoyant une demande au serveur en utilisant le port ou le canal nommé de l'instance souhaitée.

Pour plus d'informations sur le démarrage et l'arrêt du service SQL Server Browser, consultez Procédure : démarrer et arrêter le service SQL Server Browser.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Utilisation de SQL Server Browser

Si le service SQL Server Browser n'est pas en cours d'exécution, vous pouvez quand même vous connecter à SQL Server, à condition d'indiquer le numéro de port ou le canal nommé correct. Par exemple, vous pouvez vous connecter à l'instance par défaut de SQL Server via le protocole TCP/IP si elle s'exécute sur le port 1433.

Toutefois, si le service SQL Server Browser n'est pas en cours d'exécution, les connexions suivantes ne fonctionnent pas :

  • tout composant essayant de se connecter à une instance nommée sans spécifier intégralement tous les paramètres (tels que le port TCP/IP ou le canal nommé) ;

  • tout composant générant ou transmettant des informations serveur/instance qui pourraient être utilisées ultérieurement par d'autres composants pour se reconnecter ;

  • connexion à une instance nommée sans fournir le numéro de port ou le canal de communication ;

  • connexion administrateur dédiée (DAC) à une instance nommée si le port TCP/IP 1433 n'est pas utilisé ;

  • service redirecteur OLAP ;

  • énumération de serveurs dans SQL Server Management Studio, Enterprise Manager ou dans l'Analyseur de requêtes.

Si vous utilisez SQL Server dans un scénario client-serveur (par exemple, lorsque votre application accède à SQL Server à travers un réseau) et que vous arrêtez ou désactivez le service SQL Server Browser, vous devez attribuer un numéro de port spécifique à chaque instance et écrire le code de votre application cliente afin de toujours utiliser ce numéro de port. Cette approche présente les inconvénients suivants :

  • Vous devez mettre à jour et maintenir le code de l'application cliente pour vous assurer qu'elle se connecte au bon port.

  • Le port que vous choisissez pour chaque instance peut être utilisé par un autre service ou une autre application présents sur le serveur, ce qui entraîne la non-disponibilité de l'instance de SQL Server.

Installation côte à côte avec SQL Server 2000

Dans SQL Server 2000, l'identification des points de terminaison d'une connexion serveur est assurée par le service SQL Server. Dans SQL Server 2005, cette fonction est remplacée par le service SQL Server Browser. Si vous installez SQL Server sur un ordinateur qui exécute également SQL Server 2000 ou MSDE, vous devez vous assurer que SQL Server 2000 ou MSDE est mis à niveau avec le Service Pack 3a (SP3a) ou une version ultérieure. Les versions antérieures au SP3a ne permettent pas un partage correct du port 1434 et risquent de rendre vos instances de SQL Server indisponibles aux applications clientes émettant des demandes. Même si vous avez la possibilité de modifier l'ordre de démarrage des services de sorte que le service SQL Server Browser démarre avant SQL Server 2000 ou MSDE, nous vous recommandons de mettre à jour toutes les versions antérieures de SQL Server avec le Service Pack le plus récent.

Lorsqu'une instance de SQL Server 2000 n'ayant pas été mise à jour avec le Service Pack 3a est installée sur l'ordinateur, le service d'écoute de SQL Server 2000 démarre si SQL Server Browser n'est pas en cours d'exécution. Si le service SQL Server Browser démarre après le service d'écoute, il attend 5 secondes que SQL Server 2000 abandonne le port 1434. Si cela n'aboutit pas, SQL Server Browser ne démarre pas. Pour résoudre ce problème avec les versions de SQL Server 2000 antérieures au Service Pack 3a, arrêtez SQL Server 2000, démarrez SQL Server Browser, puis redémarrez SQL Server 2000. Toutefois, dans la mesure où le service d'écoute de SQL Server 2000 tentera toujours de démarrer sur le port 1434, il est recommandé de mettre à niveau l'instance SQL Server 2000 avec le Service Pack 3a dés que possible.

SQL Server 7.0 ne disposant pas de fonctionnalités analogues, il ne se produit aucun conflit avec SQL Server Browser.

Clustering

SQL Server Browser n'est pas une ressource cluster et ne prend pas en charge le basculement d'un nœud de cluster à l'autre. Par conséquent, dans le cas d'un cluster, SQL Server Browser doit être installé et activé pour chaque nœud du cluster. Dans les clusters, SQL Server Browser est à l'écoute de IP_ANY.

Remarque :
Dans ce cas, si vous activez l'écoute sur des ports IP spécifiques, l'utilisateur doit configurer le même port TCP sur chaque adresse IP, car SQL Server Browser renvoie la première paire IP/port qu'il détecte.

Installation, désinstallation et exécution à partir de la ligne de commande

Par défaut, le programme SQL Server Browser est installé à l'emplacement C:\Program Files\Microsoft SQL Server\100\Shared\sqlbrowser.exe. Si SQL Server 2000 est installé sur l'ordinateur mais qu'il n'a pas été mis à niveau avec le Service Pack 3, et si l'instance de SQL Server 2000 ne fait pas l'objet d'une mise à niveau, SQL Server 2000 doit être arrêté pendant l'installation de SQL Server. Si SQL Server 2000 est en cours d'exécution, SQL Server Browser ne peut pas démarrer et réclamer le port 1434, et l'installation risque d'échouer pour cause de connectivité insuffisante.

Le service SQL Server Browser est désinstallé dés que la dernière instance de SQL Server est supprimée. Les instances de SQL Server 2000 retrouvent leur comportement d'origine.

SQL Server Browser peut être démarré à partir de l'invite de commandes pour des besoins de dépannage au moyen du commutateur -c :

Copier le code
<drive>\<path>\sqlbrowser.exe -c

Sécurité

Privilèges de compte

SQL Server Browser est à l'écoute d'un port UDP et accepte les demandes non authentifiées via le protocole SSRP (SQL Server Resolution Protocol). SQL Server Browser doit être exécuté dans le contexte de sécurité d'un utilisateur doté de faibles privilèges afin de limiter les risques d'une attaque malveillante. Le compte de connexion peut être modifié à partir du Gestionnaire de configuration SQL Server. Les droits d'utilisateur minimaux pour SQL Server Browser sont les suivants :

  • Refuser l'accès à cet ordinateur à partir du réseau

  • Refuser les ouvertures de session locales

  • Refuser l'ouverture de session en tant que programme de traitement par lots

  • Interdire l'ouverture de session par les services Terminal Server

  • Ouvrir une session en tant que service

  • Lire et écrire les clés de Registre SQL Server relatives à la communication réseau (ports et canaux de communication)

Compte par défaut

Le programme d'installation configure SQL Server Browser de sorte qu'il utilise le compte sélectionné pour les services au cours de l'installation. Les autres comptes possibles sont les suivants :

  • Tout compte domain\local

  • Le compte de service local (non disponible sur les plateformes W2K)

  • Le compte système local (non recommandé car doté de privilèges inutiles)

Masquage de SQL Server

Les instances masquées sont des instances de SQL Server qui ne prennent en charge que les connexions de mémoire partagée. Pour SQL Server, définissez l'indicateur HideInstance pour indiquer que SQL Server Browser ne doit pas répondre par des informations sur cette instance de serveur. SQL Server Browser prend également en charge la méthode de masquage d'instances de SQL Server 2000, activée en définissant l'option HideServer via l'utilitaire réseau du serveur. Pour plus d'informations sur la configuration de l'option HideServer, consultez « Procédure : masquer une instance du moteur de base de données SQL Server » dans la documentation en ligne de SQL Server.

Utilisation d'un pare-feu

Pour communiquer avec le service SQL Server Browser sur un serveur situé derrière un pare-feu, ouvrez le port UDP 1434 en plus du port TCP utilisé par SQL Server (par ex., le port 1433). Pour plus d'informations sur l'utilisation d'un pare-feu, consultez « Procédure : configurer un pare-feu pour accéder à SQL Server » dans la documentation en ligne de SQL Server.

Voir aussi

Autres ressources

Protocoles réseau et bibliothèques réseau

© 2010 Microsoft Corporation. Tous droits réservés.


Connexion avec IPv6

Connexion avec IPv6 |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server >

SQL Server et SQL Server Native Client prennent intégralement en charge IPv4 (Internet Protocol version 4) et IPv6 (Internet Protocol version 6). Quand Windows est configuré avec IPv6 les composants SQL Server détectent automatiquement la présence d'IPv6. Aucune configuration particulière de SQL Server n'est nécessaire.

La prise en charge inclut, entre autres, les éléments suivants :

  • Le Moteur de base de données SQL Server et les autres composants serveur peuvent écouter simultanément sur les deux adresses IPv4 et IPv6. Quand IPv4 et IPv6 sont tous deux présents, vous pouvez utiliser le Gestionnaire de configuration SQL Server pour configurer le moteur de base de données de façon à n'écouter que les adresses IPv4 ou IPv6.

  • Quand le service SQL Server Browser en cours d'exécution sur un ordinateur qui prend en charge à la fois IPv4 et IPv6 est interrogé sur une adresse IPv4, il répond avec une adresse IPv4 et le premier port TCP IPv4 de la liste. En cas d'interrogation sur une adresse IPv6, il répond avec une adresse IPv6 et le premier port TCP IPv6 de la liste. Pour éviter toute incohérence, nous recommandons de configurer les écouteurs IPv4 et IPv6 de façon à ce qu'ils écoutent sur le même port.

  • Des outils comme SQL Server Management Studio et le Gestionnaire de configuration SQL Server acceptent les deux formats IPv4 et IPv6 pour les adresses IP. Dans la plupart des cas, la chaîne de connexion n'a pas besoin d'être modifiée si < nom_ordinateur> \< nom_instance> est spécifié avec le nom d'hôte du serveur ou le nom de domaine complet. Si l'ordinateur serveur possède à la fois IPv4 et IPv6, son nom d'hôte ou son nom de domaine complet est résolu en plusieurs adresses IP, incluant au moins une adresse IPv4 et plusieurs adresses IPv6. SQL Server Native Client tente d'établir des connexions à l'aide de ces adresses IP en respectant l'ordre reçu depuis TCP/IP et utilise la première connexion qui aboutit. Du fait que SQL Server Native Client est dans l'impossibilité de prévoir l'ordre, celui-ci doit être considéré comme aléatoire. Les adresses IPv4 sont tentées en premier si les adresses IPv4 et IPv6 sont toutes deux présentes. Pour les utilisateurs d'ODBC, OLE DB ou ADO.NET, la logique est totalement transparente.

    Remarque :
    Si le moteur de base de données n'écoute pas sur IPv4, la tentative de connexion IPv4 doit attendre la période d'expiration avant de tenter l'adresse IPv6. Pour pallier ce désagrément, connectez-vous directement à l'adresse IPv6 ou configurez un alias sur le client avec l'adresse IPv6.

Voir aussi

Autres ressources

Gestionnaire de configuration SQL Server

© 2010 Microsoft Corporation. Tous droits réservés.


Choix d'un protocole réseau

Choix d'un protocole réseau
Aide sur le Gestionnaire de configuration SQL Server >

Pour se connecter au moteur de base de données SQL Server, un protocole réseau doit être activé. Microsoft SQL Server peut traiter les demandes sur plusieurs protocoles à la fois. Les clients se connectent à SQL Server avec un seul protocole. Si le programme client ne connaît pas le protocole sur lequel SQL Server écoute, configurez le client pour qu'il essaie plusieurs protocoles en séquence. Le Gestionnaire de configuration SQL Server vous permet d'activer, de désactiver et de configurer des protocoles réseau.

Mémoire partagée

Il s'agit du protocole le plus simple à utiliser et pour lequel aucun paramètre ne doit être configuré. Étant donné que les clients qui utilisent le protocole de mémoire partagée peuvent se connecter uniquement à une instance SQL Server exécutée sur le même ordinateur, il n'est pas utile pour la plupart des activités de base de données. Utilisez le protocole de mémoire partagée pour débloquer une situation dans laquelle vous suspectez que les autres protocoles ne sont pas configurés correctement.

Remarque :
Les clients utilisant MDAC 2.8 ou une version antérieure ne peuvent pas utiliser le protocole de mémoire partagée. S'ils tentent d'utiliser ce protocole, ils sont automatiquement basculés sur le protocole de canaux nommés.

TCP/IP

TCP/IP est un protocole courant dont l'utilisation est largement répandue sur Internet. Il communique à travers des réseaux interconnectés d'ordinateurs dotés de différentes architectures matérielles et de divers systèmes d'exploitation. Le protocole TCP/IP comprend des normes qui permettent d'acheminer le trafic réseau et offre des fonctionnalités de sécurité avancées. Il est aujourd'hui le plus utilisé dans le monde de l'entreprise. La configuration de votre ordinateur pour l'utilisation du protocole TCP/IP peut s'avérer complexe, mais la plupart des ordinateurs en réseau sont déjà correctement configurés. Pour configurer les paramètres du protocole TCP/IP qui ne sont pas exposés dans le Gestionnaire de configuration SQL Server, consultez la documentation Microsoft Windows.

Canaux nommés

Les canaux nommés sont développés pour les réseaux locaux. Une partie de la mémoire est utilisée par un processus pour transmettre des informations à un autre processus, de sorte que la sortie d'un processus constitue l'entrée de l'autre. Le deuxième processus peut être local (situé sur le même ordinateur que le premier) ou distant (sur un ordinateur du réseau).

VIA

Le protocole VIA (Virtual Interface Adapter) fonctionne avec le matériel VIA. Pour obtenir des informations sur l'utilisation du protocole VIA, contactez votre fournisseur de matériel.

Important :
Le protocole VIA est déconseillé. Cette fonctionnalité sera supprimée dans une prochaine version de Microsoft SQL Server. Évitez d'utiliser cette fonctionnalité dans de nouveaux travaux de développement et prévoyez de modifier les applications qui utilisent actuellement cette fonctionnalité.

Canaux nommés ou sockets TCP/IP

Dans un environnement de réseau local rapide, les clients utilisant les canaux nommés et les sockets TCP/IP (Transmission Control Protocol/Internet Protocol) sont comparables au niveau des performances. Toutefois, la différence de performances entre les clients utilisant les canaux nommés et ceux utilisant les sockets TCP/IP devient évidente avec des réseaux plus lents, comme les réseaux étendus (WAN) ou les réseaux commutés. Ceci est dû aux différences dans la manière dont les mécanismes de communication interprocessus IPC communiquent entre homologues.

Pour les canaux nommés, les communications réseau sont généralement plus interactives. Un homologue n'envoie pas de données tant qu'un autre homologue ne l'a pas demandé par le biais d'une commande de lecture. Une lecture via un réseau implique généralement une série de messages lus par les canaux nommés avant qu'elle ne commence à lire les données. Ces dernières peuvent se révéler très coûteuses sur un réseau lent et provoquer un trafic excessif qui finit par affecter d'autres clients du réseau.

Il est également important de faire la distinction entre les canaux locaux et les canaux réseau. Si l'application serveur fonctionne localement sur l'ordinateur exécutant une instance de SQL Server, le protocole local des canaux nommés est envisageable. Les canaux nommés locaux fonctionnent en mode noyau et sont extrêmement rapides.

Pour les sockets TCP/IP, les transmissions de données sont plus rationalisées et représentent une charge inférieure. Les transmissions de données peuvent également bénéficier des mécanismes d'amélioration des performances des sockets TCP/IP telles que le fenêtrage, les accusés de réception différés, etc. Cette option peut s'avérer fort utile dans le cadre d'un réseau lent. Selon le type d'application, les différences de performances peuvent être importantes.

Les sockets TCP/IP prennent également en charge une file d'attente de backlog, ce qui peut procurer un effet de lissage limité par rapport aux canaux de communication nommés, et conduire à des erreurs liées à l'encombrement des canaux lorsque vous tentez de vous connecter à SQL Server.

En général, il est préférable d'utiliser TCP/IP dans un réseau local, étendu (WAN) ou distant lent, alors que les canaux nommés peuvent s'avérer un meilleur choix si la vitesse du réseau ne pose pas problème ; TCP/IP offre davantage de fonctions et d'options de configuration et il est plus facile à utiliser.

Activation du protocole

Pour pouvoir fonctionner, le protocole doit être activé sur le client et le serveur. Le serveur peut écouter les demandes simultanément sur tous les protocoles activés. Les ordinateurs clients peuvent en choisir un ou essayer d'utiliser les protocoles dans l'ordre dans lequel ils figurent dans le Gestionnaire de configuration SQL Server.

Remarque :
Microsoft SQL Server ne prend pas en charge les protocoles réseau Banyan VINES Sequenced Packet Protocol (SPP), Multiprotocol, AppleTalk et NWLink IPX/SPX Les clients qui étaient connectés au moyen de ces protocoles doivent sélectionner un autre protocole pour se connecter à SQL Server.

Pour vous procurer un didacticiel sommaire sur la manière de configurer les protocoles et de vous connecter au moteur de base de données, consultez Didacticiel : Mise en route du moteur de base de données.


Gestion des services SQL Server 2000

Gestion des services SQL Server 2000
Aide sur le Gestionnaire de configuration SQL Server >

Les services SQL Server 2000 ne peuvent être gérés ni avec SQL Server Management Studio ni avec le Gestionnaire de configuration SQL Server. Vous devez utiliser SQL Server 2000 Enterprise Manager pour modifier les comptes de service, le Gestionnaire de services SQL Server pour démarrer et arrêter les services, l'Utilitaire réseau SQL Server pour gérer les protocoles serveur et l'Utilitaire réseau du client SQL Server pour gérer les alias et les protocoles client.


Surveillance des journaux d'erreurs

Surveillance des journaux d'erreurs
Aide sur le Gestionnaire de configuration SQL Server >

SQL Server consigne certains événements système et certains événements définis par l'utilisateur dans le journal des erreurs SQL Server et le journal des applications Microsoft Windows. Tous les événements consignés dans ces deux journaux sont automatiquement datés. Utilisez les informations du journal des erreurs SQL Server pour résoudre des problèmes liés à SQL Server.

Le journal des applications Windows fournit une vue d'ensemble des événements survenus dans le système d'exploitation Windows, ainsi que des événements survenus dans SQL Server et dans l'Agent SQL Server. Utilisez l'Observateur d'événements Windows pour afficher le journal des applications Windows et filtrer les informations. Par exemple, vous pouvez filtrer des d'événements, comme les informations, les avertissements, les erreurs, les audits de succès et les audits d'échecs.

Comparaison des sorties des journaux d'erreurs et d'applications

Vous pouvez utiliser le journal des erreurs de SQL Server et le journal des applications Windows pour identifier les causes des problèmes. Par exemple, pendant la surveillance du journal des erreurs SQL Server, vous pouvez rencontrer des messages d'erreur qui ne contiennent pas d'informations sur la cause. En comparant les dates et les heures des événements intervenus entre ces journaux, vous pouvez réduire la liste des causes possibles. La visionneuse du fichier journal de SQL Server Management Studio permet d'intégrer l'Agent SQL Server, SQL Server et les journaux Windows dans une même liste, facilitant ainsi la compréhension d'événements serveur et d'événements SQL Server liés. Pour plus d'informations, consultez la rubrique relative à la visionneuse du fichier journal dans la documentation en ligne de SQL Server.

Dans cette section

Rubrique | Description
Consultation du journal des erreurs de SQL Server | Contient des informations sur le journal des erreurs SQL Server et la procédure pour l'afficher.
Affichage du journal d'application Windows | Contient des informations sur le journal des applications Windows et la procédure pour l'afficher.


Consultation du journal des erreurs de SQL Server

Consultation du journal des erreurs de SQL Server
Aide sur le Gestionnaire de configuration SQL Server > Surveillance des journaux d'erreurs >

Consultez le journal des erreurs de SQL Server pour vérifier que l'exécution des processus a réussi (par exemple les opérations de sauvegarde et de restauration, les commandes de traitement ou d'autres scripts et processus). Cela peut s'avérer utile pour détecter tout problème en cours ou potentiel, y compris les messages de récupération automatique (surtout si une instance de SQL Server a été arrêtée puis redémarrée), les messages du noyau ou autres messages d'erreur de niveau serveur.

Consultez le journal des erreurs SQL Server à l'aide de SQL Server Management Studio ou de n'importe quel éditeur de texte. Par défaut, le journal des erreurs se trouve dans les fichiers Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\LOG\ERRORLOG et ERRORLOG.n.

Un nouveau journal des erreurs est créé à chaque démarrage d'une instance de SQL Server, bien que la procédure stockée système sp_cycle_errorlog puisse être utilisée pour recycler les fichiers du journal des erreurs sans devoir redémarrer l'instance de SQL Server. En principe, SQL Server conserve une copie de sauvegarde des six derniers journaux des erreurs, attribuant l'extension .1 au plus récent, l'extension .2 à celui qui le précède, et ainsi de suite. Le journal des erreurs en cours n'a aucune extension.


Affichage du journal d'application Windows

Affichage du journal d'application Windows
Aide sur le Gestionnaire de configuration SQL Server > Surveillance des journaux d'erreurs >

Lorsque SQL Server est configuré pour utiliser le journal d'application Windows, chaque session SQL Server écrit un nouvel événement dans ce journal. Contrairement au journal des erreurs de SQL Server, un nouveau journal d'application n'est pas créé chaque fois que vous démarrez une instance de SQL Server.

Affichez et gérez le journal d'application Windows en utilisant l'Observateur d'événements de Windows ou la Visionneuse du journal de SQL Server Management Studio.

Il existe trois journaux pouvant être affichés avec l’Observateur d’événements.

Type de journal Windows | Description
Journal système | Il enregistre les événements consignés par les composants du système d'exploitation Windows. L'échec du chargement d'un pilote ou d'un autre composant du système lors du démarrage, par exemple, est consigné dans le journal système.
Journal de sécurité | Il enregistre les événements de sécurité comme les tentatives de connexion qui ont échoué. Cela permet de rechercher les modifications du système de sécurité et d'identifier les violations possibles de la sécurité. Par exemple, les tentatives de connexion au système doivent être enregistrées dans le journal de sécurité, en fonction des paramètres d'audit du gestionnaire des utilisateurs. Seuls les membres du rôle serveur fixe sysadmin peuvent afficher le journal de sécurité.
Journal d'application | Il enregistre les événements qui sont consignés par les applications. Par exemple, une application de base de données peut enregistrer un fichier d'erreurs dans le journal des applications.

Pour plus d'informations sur l'utilisation de l'Observateur d'événements, la gestion du journal d'application et la signification des données qui y figurent, consultez la documentation de Windows.
Pour consulter le journal d'application Windows

Procédure : Affichage du journal des applications de Windows (Windows)


Mentions légales relatives à la documentation

Mentions légales relatives à la documentation
Aide sur le Gestionnaire de configuration SQL Server >

Le présent document porte sur la version commerciale définitive du logiciel « SQL Server 2008 R2 ». Ce document est confidentiel et demeure la propriété de Microsoft Corporation.

Il est fourni « en l'état ». Les informations et les opinions exprimées dans ce document, y compris les adresses URL et les autres références à des sites Internet, peuvent faire l'objet de modifications sans préavis. Vous assumez tous les risques liés à son utilisation. Certains exemples mentionnés dans ce documents ne sont fournis qu'à titre indicatif et sont fictifs. Toute ressemblance ou similitude avec des éléments réels est purement fortuite et involontaire.

Ce document ne vous concède aucun droit de propriété intellectuelle portant sur les produits Microsoft. Vous pouvez copier et utiliser ce document à titre de référence pour un usage interne.

© 2010 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server et Windows Vista sont des marques du groupe Microsoft.

SAP NetWeaver est une marque déposée de SAP AG en Allemagne et dans plusieurs autres pays.

Toutes les autres marques sont la propriété de leurs propriétaires respectifs.

Stratégie de documentation pour le support et la mise à niveau de SQL Server

Documentation - Stratégie de support et de mise à niveau

La documentation de Microsoft SQL Server 2008 R2 inclut la documentation en ligne de SQL Server, les fichiers Lisez-moi, les documents relatifs aux problèmes connus, les exemples de code et d'applications, les exemples de bases de données et les articles de la Base de connaissances publiés par Microsoft – l'ensemble de ces éléments recouvre le contenu relatif aux fonctions et fonctionnalités SQL Server (l'ensemble de la « Documentation »). Le résumé ci-dessous décrit la stratégie de support et de mise à niveau pour certaines fonctions et fonctionnalités référencées dans la Documentation.

Exemples. Les exemples présentés dans cette Documentation servent principalement à illustrer un concept ou l'utilisation raisonnable d'une instruction ou d'une clause particulière. La plupart des exemples ne reprennent pas la totalité du code normalement utilisé dans un système en production puisque certaines parties de la validation des données et de la gestion des erreurs sont retirées pour mettre l'accent sur un concept ou une instruction particulière. Le support technique de Microsoft n'est pas disponible pour les exemples contenus dans la Documentation.

Espaces réservés. Dans certains cas, une fonctionnalité particulière de SQL Server 2008 R2 n'a pas été suffisamment testée ou développée pour être utilisée. Ces fonctionnalités sont souvent répertoriées dans la documentation en ligne, un fichier Lisez-moi ou toute autre Documentation sous forme d'espaces réservés et sont fournies à titre de notations pour une utilisation interne par Microsoft. Elles ne sont pas destinées à votre utilisation et ne sont pas prises en charge par le support technique de Microsoft. Toute tentative d'utilisation de ces fonctionnalités peut provoquer une perte de données.

Contenu tiers. Sauf spécification contraire de la Documentation, le contenu tiers, y compris les problèmes qui résultent de son utilisation avec SQL Server 2008 R2, n'est pas pris en charge par le support technique de Microsoft.

Points d'entrée non documentés. Le support technique de Microsoft n'assure pas la prise en charge des bases de données ou des applications qui exploitent ou utilisent des points d'entrée non documentés comme les API non documentées, y compris, entre autres, les éléments suivants : procédures stockées, procédures stockées étendues, fonctions, vues, tables, colonnes, propriétés ou métadonnées. Une telle utilisation peut provoquer une perte de données.

Mises à niveau. Les mises à niveau de serveur et de base de données vers les versions ultérieures de SQL Server 2008 R2 pour les applications et les bases de données qui exploitent et utilisent des points d'entrée non documentés (qui peuvent ne pas fonctionner) ne sont pas prises en charge par le support technique de Microsoft.

Pour plus d'informations sur la stratégie de cycle de vie du support technique de Microsoft, visitez le site Web à l'adresse suivante : http://support.microsoft.com/lifecycle.


À propos des termes du contrat de licence SQL Server

À propos des termes du contrat de licence SQL Server |
 | Voir aussi
Aide sur le Gestionnaire de configuration SQL Server >

Les termes de la Licence d'utilisation du logiciel Microsoft sont copiés vers l'ordinateur local lorsque SQL Server est installé. Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue. Les fichiers sont enregistrés dans : %ProgramFiles%\Microsoft SQL Server\100\License Terms\ ou %ProgramFiles(x86)%\Microsoft SQL Server\100\License Terms\.

Lorsque plusieurs instances des mêmes édition et langue de SQL Server sont installées sur le même ordinateur, une seule copie du contrat de licence s'applique à toutes les instances de cette édition et de cette langue.

Le nom de fichier des termes du contrat de licence indique l'édition de SQL Server ainsi que l'édition linguistique de SQL Server : Par exemple :

  • License_DEV_ENU.txt pour SQL Server Developer, édition en langue anglaise.

  • License_STD_ITA.txt pour SQL Server Standard, édition en langue italienne.

  • License_UA_JPN.txt pour le Conseiller de mise à niveau SQL Server, édition en langue japonaise.

  • License_SQLNCLI_ENU.txt pour SQL Server Native Client, édition en langue anglaise.

  • License_SQLXML4_KOR.txt pour SQLXML, édition en langue coréenne.

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • DC - Datacenter

  • ENT - Enterprise

  • DEV - Developer

  • STD - Standard

  • WKGP - Workgroup

  • WEB - Web

  • EXPR - Express

  • UA - Conseiller de mise à niveau

Les segments de noms de fichiers suivants sont utilisés pour identifier les langues de SQL Server :

  • ENU - Anglais

  • JPN - Japonais

  • FRA - Français

  • ITA - Italien

  • KOR - Coréen

  • DEU - Allemand

  • ESN - Espagnol

  • CHS - Chinois simplifié

  • CHT - Chinois traditionnel

  • NLA - Néerlandais

  • PTB - Portugais (Brésil)

  • SVE - Suédois

  • RUS - Russe

Options de licences de SQL Server

Pour plus d'informations sur les prix et les options de licences de SQL Server, consultez le site Web Microsoft SQL Server 2008 R2.

Voir aussi

Concepts

Mentions légales relatives à la documentation

Autres ressources

Déclaration de confidentialité de SQL Server 2008 R2

© 2010 Microsoft Corporation. Tous droits réservés.