Objets Client des discussions sur le Web Microsoft Office

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Légende

Objet et collection
Objet seulement


Vue d'ensemble des serveurs de discussion et des discussions

Dans Microsoft Office, la bibliothèque Client de discussions sur le Web vous permet de contrôler des objets des collections Discussions et DiscussionServers via des programmes. Vous pouvez ajouter des discussions et serveurs de discussion nouveaux, ou vous pouvez lire, modifier ou supprimer les discussions et serveurs de discussion existants.

Important : Pour activer la bibliothèque OSE dans votre environnement de programmation, vous devez d'abord définir une référence à la bibliothèque Client de discussions sur le Web Microsoft Office (OWSCTL.DLL).

L'objet Global constitue le point de départ à l'exploration de discussions et de serveurs de discussion. L'objet Global représente une instance d'un serveur de discussion. L'objet Global vous permet d'ajouter des abonnements à des serveurs de discussion, d'obtenir le nom de l'utilisateur Microsoft Office en cours, et de renvoyer la collection de serveurs de discussion ou la collection de discussions sur un serveur de discussion spécifique.

L'objet Collection DiscussionServers contient un ou plusieurs objets DiscussionServer. Chaque objet DiscussionServer représente un serveur de discussion enregistré sur l'ordinateur que vous utilisez actuellement. Un objet DiscussionServer est composé d'un nom convivial et d'une URL (Uniform Resource Locator) qui fournissent aux utilisateurs les informations de connexion concernant le serveur de discussion.

Vous pouvez ouvrir la collection Discussions pour une URL en particulier à l'aide de la méthode OpenDiscussions de l'objet Global pour renvoyer la collection Discussions pour le document spécifié par l'URL. Cette collection Discussions peut contenir plusieurs niveaux de discussions ; ces niveaux sont organisés hiérarchiquement. Chaque objet Discussion d'une collection Discussions supérieure constitue un commentaire sur le document de la rubrique. Chaque objet Discussion peut contenir des objets Discussion enfant, qui constituent des réponses à l'objet Discussion d'origine. Les réponses aux réponses se trouvent au niveau suivant dans la hiérarchie de la discussion, etc. Vous pouvez parcourir la hiérarchie des discussions à l'aide de la propriété Discussions de l'objet Discussion.


Renvoyer un objet à partir d'une collection

La propriété Item renvoie un seul objet d'une collection. L'exemple suivant montre comment affecter à la variable dscSupplies un objet Discussion qui représente la première discussion de la collection Discussions.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://samples.microsoft.com")
Dim dscSupplies As Discussion
Set dscSupplies = dscDiscussions.Item(1)

La propriété Item étant la propriété par défaut de la plupart des collections, vous pouvez écrire la même instruction de manière plus concise en omettant le mot clé Item.

Set dscSupplies = dscDiscussions(1)

Pour plus d'informations sur une collection spécifique, consultez la rubrique d'aide de la collection, ou la rubrique d'aide de la propriété Item de la collection.


Discussion, objet

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Représente une discussion dans l'application hôte Microsoft Office. L'objet Discussion est un membre de la collection Discussions.

Utiliser l'objet Discussion

Spécifiez Discussions(Index), Index étant le numéro d'index d'une discussion, pour renvoyer un simple objet Discussion. L'exemple suivant montre comment affecter à la variable dscOfficeSupplies la première discussion de la collection Discussions.

Set dscOfficeSupplies = dscDiscussions(1)

Spécifiez la propriété AutoCommit pour définir ou renvoyer l'état d'opérations Commit, qui déterminent si les modifications effectuées dans les propriétés d'un objet Discussion affectent immédiatement le lieu de stockage de la discussion. Spécifiez la méthode Commit pour forcer l'application à enregistrer toutes les propriétés de l'élément de la dicussion en cours (y compris les modifications de propriété) au lieu de stockage de la discussion sur le serveur. L'exemple suivant montre comment vérifier la valeur de AutoCommit de la discussion spécifiée et, si la propriété se voit affecter la valeur False, l'exemple montre comment spécifier la méthode Commit pour enregistrer les modifications sur le lieu de stockage de la discussion.

If dscDiscussions(1).Discussions(4).AutoCommit = False Then
    dscDiscussions(1).Discussions(4).Commit
End If

Spécifiez la propriété Author pour obtenir le nom d'utilisateur de l'auteur de la dicussion en cours. Spécifiez la propriété LoginName pour obtenir le nom de connexion sous Microsoft Windows NT de l'auteur de la discussion. Spécifiez la propriété Timestamp pour obtenir la date et l'heure de création de la discussion ou celles de la plus récente modification de la discussion. L'exemple suivant montre comment afficher le nom de l'auteur, la date et l'heure de création ou celles de la plus récente modification, et le nom de connexion sous Microsoft Windows NT de la discussion spécifiée.

MsgBox dscDiscussions(1).Discussions(5).Author & _
    " created this discussion at " & _
    dscDiscussions(1).Discussions(5).Timestamp & _
    " while logged in as Windows NT user " & _
    dscDiscussions(1).Discussions(5).LoginName

Spécifiez la propriété Discussions pour renvoyer la collection de tous les éléments de discussion qui constituent les réponses à la dicussion en cours. La collection renvoyée peut également contenir une collection Discussions composée de réponses à la discussion parente, à laquelle vous pouvez accéder à l'aide de la propriété Discussions d'une discussion spécifique de cette collection.

Spécifiez les propriétés Subject, Text, et Bookmark pour renvoyer ou définir ces éléments de la discussion spécifiée.


Discussions, collection

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Collection d'objets Discussion qui représentent des discussions enregistrées dans l'application hôte Microsoft Office.

Utiliser la collection Discussions

Spécifiez la méthode OpenDiscussions de l'objet Global pour renvoyer la collection Discussions pour le document accédé via l'URL (Uniform Resource Locator) spécifiée. L'exemple suivant montre comment renvoyer la collection Discussions pour le dossier « http://examples.microsoft.com ».

Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")

Spécifiez la méthode Add pour ajouter un nouvel objet Discussion à la collection Discussions. L'exemple suivant montre comment ajouter une nouvelle réponse de discussion au premier objet Discussion de la collection.

Set myResponse = dscDiscussions(1).Discussions.Add _
    Subject:="Supply information", Text:="Staples are here!", Bookmark:="Staples"

Spécifiez la propriété URL pour renvoyer l'URL du document contenant la collection Discussions, tel qu'il est indiqué dans l'exemple suivant.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
MsgBox dscDiscussions.URL

Spécifiez Discussions(Index), Index étant le numéro d'index d'une discussion, pour renvoyer un seul objet Discussion. L'exemple suivant montre comment affecter à la variable dscOfficeSupplies la première discussion de la collection Discussions.

Set dscOfficeSupplies = dscDiscussions(1)


DiscussionServer, objet

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Représente un serveur de discussion dans l'application hôte Microsoft Office. L'objet DiscussionServer est un membre de la collection DiscussionServers.

Utiliser l'objet DiscussionServer

Spécifiez DiscussionServers(Index), Index étant le numéro d'index du serveur de discussion spécifié, pour renvoyer un simple objet DiscussionServer. L'exemple suivant montre comment affecter à la variable dscAccounting le troisième serveur de la collection DiscussionServers.

Set dscAccounting = dscServers(3)

Spécifiez la propriété FriendlyName pour définir ou renvoyer le nom convivial du serveur de discussion spécifié. L'exemple suivant montre comment modifier le nom convivial du premier serveur de la collection en « Shipping Department Server ».

dscServers(1).FriendlyName = _
    "Shipping Department Server"

Spécifiez la propriété ServerAddress pour définir ou renvoyer l'URL (Uniform Resource Locator) du serveur de discussion spécifié. L'exemple suivant montre comment modifier l'URL du premier serveur de la collection en « http://example.microsoft.com ».

dscServers(1).ServerAddress = _
    "http://example.microsoft.com/"

Spécifiez la méthode SetAsDefault pour définir le serveur de discussion spécifié comme serveur par défaut pour l'interface utilisateur de discussions et pour tous les appels futurs à la méthode globale OpenDiscussions. L'exemple suivant montre comment définir le troisième serveur de la collection DiscussionServers comme serveur de discussion par défaut.

dscServers(3).SetAsDefault


DiscussionServers, collection

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Collection d'objets DiscussionServer qui représentent les serveurs de discussion dans l'application hôte Microsoft Office.

Utiliser la collection DiscussionServers

Spécifiez la méthode OpenDiscussions de l'objet Global pour renvoyer la collection DiscussionServers pour tous les serveurs de discussion enregistrés sur l'ordinateur en cours d'utilisation. L'exemple suivant montre comment renvoyer la collection DiscussionServers et afficher un message contenant le nombre de serveurs de la collection.

Dim dscDiscussionServersCollection As DiscussionServers
Set dscDiscussionServersCollection = DiscussionServers
MsgBox dscDiscussionServersCollection.Count

Spécifiez la méthode Add pour ajouter un nouveau serveur de discussion à la collection. L'exemple suivant montre comment ajouter un nouveau serveur de discussion avec le nom convivial « Sample Server » et l'URL (Uniform Resource Locator) http://samples.microsoft.com.

Dim dscServers As DiscussionServers
Set dscServers = DiscussionServers
dscServers.Add FriendlyName:="Sample Server", _
    ServerAddress:="http://samples.microsoft.com/"

Spécifiez DiscussionServers(Index), Index étant le numéro d'index du serveur de discussion spécifié, pour renvoyer un simple objet DiscussionServer. L'exemple suivant montre comment affecter à la variable dscAccounting le troisième serveur de la collection DiscussionServers.

Set dscAccounting = dscServers(3)


Global, objet

Global
DiscussionServers (DiscussionServer)
Discussions (Discussion)

Représente une instance de la bibliothèque Extensions Serveur Microsoft Office (OSE). À l'aide de l'objet Global, vous pouvez ajouter des abonnements à des serveurs de discussion, obtenir le nom de l'utilisateur Microsoft Office en cours, et renvoyer la collection de serveurs de discussion ou la collection de discussions sur l'hôte OSE.

Utiliser l'objet Global

Spécifiez la propriété CurrentUserName pour renvoyer le nom de l'utilisateur Microsoft Office en cours. L'exemple suivant montre comment afficher un message contenant le nom de l'utilisateur en cours.

MsgBox "The current Microsoft Office user is " & _
    CurrentUserName

Spécifiez la méthode OpenDiscussions pour renvoyer la collection Discussions pour le document spécifié par l'URL (Uniform Resource Locator). L'exemple suivant montre comment renvoyer la collection Discussions pour le dossier http://examples.microsoft.com.

Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")


Add, méthode

Méthode Add telle qu'elle s'applique à l'objet Discussions.

Ajoute un nouvel objet Discussion à la collection Discussions spécifiée.

expression.Add(Subject, Text, Bookmark)

expression Obligatoire. Expression qui renvoie l'un des objets ci-dessus.

Subject Argument de type String facultatif. Sujet de la discussion spécifiée.

Text Argument de type String facultatif. Texte du corps de la discussion spécifiée.

Bookmark Argument de type String facultatif. Unique identificateur représentant l'emplacement de la discussion spécifiée dans le document.

Note

La propriété Author de la nouvelle discussion est automatiquement définie pour le nom d'utilisateur en cours déterminé par l'application hôte Microsoft Office.

Méthode Add telle qu'elle s'applique à l'objet DiscussionServers.

Ajoute un nouvel objet DiscussionServer à la collection DiscussionServers.

expression.Add(FriendlyName, ServerAddress)

expression Obligatoire. Expression qui renvoie l'un des objets ci-dessus.

FriendlyName Argument de type String obligatoire. Nom convivial du serveur de discussion spécifié.

ServerAddress Argument de type String obligatoire. URL (Uniform Resource Locator) du serveur de discussion spécifié.

Note

L'URL spécifiée dans l'argument ServerAddress doit contenir un caractère représentant une barre oblique, comme dans l'exemple suivant qui utilise l'URL http://samples.microsoft.com.

dscServers.Add "Samples Folder", _
    http://samples.microsoft.com/

Exemples

Telle qu'elle s'applique à l'objet Discussions.

Cet exemple montre comment ajouter une nouvelle réponse de discussion à l'objet Discussion spécifié.

Set strResponse = dscDiscussions(1).Discussions.Add _
    ("Supply information", "Staples are here!", "Staples")

Telle qu'elle s'applique à l'objet DiscussionServers.

Cet exemple montre comment ajouter un nouveau serveur de discussion ayant comme nom convivial « Corporate Information Server » et comme URL http://samples.microsoft.com.

Dim dscServers As DiscussionServers
Set dscServers = DiscussionServers
dscServers.Add "Corporate Information Server", _
    "http://samples.microsoft.com/"


Commit, méthode

Applique toutes les propriétés de l'objet Discussion spécifié (y compris les modifications de propriété) sur le lieu de stockage de la discussion sur le serveur.

expression.Commit

expression Expression qui renvoie un objet Discussion.

Exemple

Cet exemple montre comment appliquer toutes les propriétés (y compris toutes les modifications de propriétés) qui affectent la discussion spécifiée.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions(URL:="http://samples.microsoft.com")
dscDiscussions(1).Discussions(1).Commit


Delete, méthode

Supprime l'objet spécifié de l'objet qui le contient.

expression.Delete

expression Expression qui renvoie un objet Discussion ou un objet DiscussionServer.

Note

Lorsque vous spécifiez la méthode Delete pour supprimer un élément de discussion d'un objet DiscussionServer, toute réponse à l'élément de discussion est automatiquement déplacée au niveau de l'élément supprimé.

Exemple

Cet exemple montre comment supprimer le troisième élément de la discussion de la collection Discussions. Toutes les discussions qui sont les descendants de la discussion affectée sont déplacées au niveau de l'élément supprimé.

dscCurrentCollection(3).Delete


OpenDiscussions, méthode

Renvoie la collection Discussions pour le document spécifié par l'URL (Uniform Resource Locator). Argument de type Object en lecture seule.

expression.OpenDiscussions(URL)

expression Expression qui renvoie un objet Extensions Serveur Microsoft Office (OSE).

URL Obligatoire. Chaîne représentant l'URL du serveur de discussion.

Exemple

Cet exemple montre comment renvoyer la collection Discussions pour le dossier http://examples.microsoft.com.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")


SetAsDefault, méthode

Définit le serveur de discussion spécifié comme serveur par défaut pour l'interface utilisateur des discussions et pour tous les appels futurs de la méthode globale OpenDiscussions.

expression.SetAsDefault

expression Expression qui renvoie un objet DiscussionServer.

Note

Le serveur de discussion par défaut est toujours le premier objet DiscussionServer de la collection DiscussionServers. La méthode SetAsDefault réorganise les membres de la collection DiscussionServers de sorte que le serveur par défaut se trouve à l'emplacement indiqué par Item(1). Ainsi, une fois la méthode appelée, vous devez réinitialiser les variables qui se voient affecter d'anciens objets DiscussionServer.

Exemple

Cet exemple montre comment définir le troisième serveur de la collection DiscussionServers comme serveur de discussion par défaut.

dscServers(3).SetAsDefault


Author, propriété

Contient le nom d'utilisateur de l'auteur de l'élément de discussion en cours. Argument de type String en lecture seule.

expression.Author

expression Obligatoire. Expression qui renvoie un objet Discussion.

Exemple

Cet exemple montre comment affecter True à la valeur booléenne positiveMatch si la propriété Author renvoie le nom « Jim Hance ».

Dim dscDiscussions As Discussions
Dim positiveMatch As Boolean
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
If dscDiscussions(1).Discussions(2).Author = "Jim Hance" Then
    positiveMatch = True
End If


AutoCommit, propriété

Renvoie ou définit une valeur qui spécifie si les modifications effectuées dans les propriétés de l'objet Discussion spécifié affectent immédiatement le lieu de stockage de la discussion. Argument de type Boolean en lecture/écriture.

expression.AutoCommit

expression Obligatoire. Expression qui renvoie un objet Discussion.

Notes

Si cette propriété se voit affecter la valeur True, toutes les modifications effectuées via des programmes dans les propriétés individuelles d'un objet Discussion sont immédiatement répercutées sur le lieu de stockage de la discussion. Si elle se voit affecter la valeur False, aucune modification de propriété n'est répercutée sur le lieu de stockage de la discussion jusqu'à ce que vous appeliez la méthode Commit. Si vous n'appelez pas la méthode Commit avant la fin de la session, toutes les modifications de propriété en attente sont perdues. La valeur par défaut est True.

Pour des raisons de performance, il se peut que vous souhaitiez affecter à la propriété AutoCommit la valeur False, et spécifier la méthode Commit si approprié.

Exemple

Cet exemple montre comment affecter à la propriété AutoCommit la valeur False pour l'objet Discussion spécifié.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(1).AutoCommit = False


Bookmark, propriété

Renvoie ou définit un argument de type String représentant l'identificateur unique de la position de l'objet Discussion dans le document.

expression.Bookmark

expression Obligatoire. Expression qui renvoie un objet Discussion.

Exemple

Cet exemple montre comment affecter au signet de la discussion spécifiée le texte « Supplies ».

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Bookmark = _
    "Supplies"


Count, propriété

Renvoie le nombre d'éléments de la collection spécifiée. Argument de type Long en lecture seule.

Note

Discussions(1).Count renvoie le nombre ou le décompte des éléments de la première discussion de la collection Discussions. La propriété Count ne compte pas de manière récursive, cependant toute discussion qui constitue une réponse à l'objet Discussion(1) n'est pas incluse dans le décompte.

Exemple

Cet exemple montre comment afficher un message contenant le nombre ou le décompte de toutes les discussions de la collection Discussions.

Dim dscDiscussions As Discussions
Set dscDiscussions = _
    OpenDiscussions("http://examples.microsoft.com")
dscDiscussions.Add "Supply room questions", _
    "Did anyone order staples?",
MsgBox dscDiscussions.Count


CurrentUserName, propriété

Renvoie ou définit le nom de l'utilisateur Microsoft Office en cours. Argument de type String en lecture/écriture.

expression.CurrentUserName

expression Obligatoire. Expression qui renvoie un objet Global.

Exemple

Cet exemple montre comment afficher un message contenant le nom de l'utilisateur Microsoft Office en cours.

MsgBox "The current Microsoft Office user is " & _
    CurrentUserName


Discussions, propriété

Renvoie la collection de tous les objets Discussion qui constituent les réponses à l'objet Discussion spécifié.

expression.Discussions

expression Obligatoire. Expression qui renvoie l'un des objets de la liste S'applique à.

Note

La collection renvoyée peut également contenir une collection Discussions composée des réponses à une discussion parent, à laquelle vous pouvez accéder à l'aide de la propriété Discussions d'un objet Discussion spécifique de cette collection. Il n'existe aucune limite quant au nombre de niveaux de discussions, autre que la limite du périphérique de stockage qui héberge le serveur que vous êtes en train d'utiliser.

Exemple

Cet exemple montre comment spécifier la propriété Discussions pour renvoyer une discussion qui constitue une réponse à la discussion spécifiée, puis comment définir le sujet de la discussion renvoyée à « More Supply Questions ».

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Subject = _
    "More Supply Questions


FriendlyName, propriété

Définit ou renvoie le nom convivial du serveur de discussion spécifié. Argument de type String en lecture-écriture.

Exemple

Cet exemple montre comment modifier le nom convivial du serveur de discussion spécifié en « Accounting Department Information Server ».

dscServers(1).FriendlyName = _
    "Accounting Department Information Server"


Index, propriété

Numéro d'index de l'objet Discussion spécifié de la collection Discussions. Type de données Long en lecture seule.

expression.Index

expression Obligatoire. Expression qui renvoie l'un des objets de la liste S'applique à.

Exemple

Cet exemple montre comment spécifier la propriété Index pour rechercher l'emplacement de l'objet Discussion spécifié dans la collection Discussions.

Set myResponse = dscDiscussions(1).Discussions.Add _
    ("Supply information", "Staples are here!", "Staples")
MsgBox myResponse.Index


Item, propriété

Renvoie un objet Discussion d'une collection Discussions, ou renvoie un objet DiscussionServer d'une collection DiscussionServers.

expression.Item(Index)

expression Obligatoire. Expression qui renvoie un objet Discussion ou DiscussionServer.

Index Argument de type Variant obligatoire. Numéro d'index de la discussion ou du serveur de discussion à renvoyer.

Exemple

Cet exemple montre comment spécifier la propriété Item pour afficher un message contenant le nom de l'auteur de la deuxième réponse à la cinquième discussion sur le fichier ou dossier en cours.

MsgBox dscDiscussions.Item(5).Discussions.Item(2).Author


LoginName, propriété

Renvoie des données de type String représentant l'alias Microsoft Windows NT de l'auteur de l'objet Discussion spécifié.

expression.LoginName

expression Obligatoire. Expression qui renvoie l'un des objets de la liste S'applique à.

Note

Le nom de connexion est généralement le même que l'alias d'adresse de messagerie de l'utilisateur.

Exemple

Cet exemple montre comment afficher un message contenant le nom de connexion de l'utilisateur Microsoft Windows NT actuel.

MsgBox dscDiscussions(1).LoginName


Parent, propriété

Renvoie l'objet parent de l'objet spécifié.

expression.Parent

expression Obligatoire. Expression qui renvoie l'un des objets de la liste S'applique à.


ServerAddress, propriété

Définit ou renvoie l'URL (Uniform Resource Locator) du serveur de discussion spécifié. Argument de type String en lecture-écriture.

Exemple

Cet exemple montre comment modifier l'URL du serveur de discussion spécifié en http://example.microsoft.com.

dscServers(1).ServerAddress = _
    "http://example.microsoft.com/"


Subject, propriété

Renvoie ou définit des données de type String représentant le sujet de l'objet Discussion spécifié.

expression.Subject

expression Obligatoire. Expression qui renvoie un objet Discussion.

Exemple

Cet exemple montre comment définir le sujet de la discussion spécifiée à « More Supply Questions ».

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
dscDiscussions(1).Discussions(3).Subject = _
    "More Supply Questions"


Text, propriété

Renvoie ou définit des données de type String représentant le corps du texte de l'objet Discussion spécifié.

expression.Text

expression Obligatoire. Expression qui renvoie l'un des objets de la liste S'applique à.

Note

Une discussion peut contenir jusqu'à 64 Ko de texte.

Exemple

Cet exemple montre comment définir le texte de la discussion spécifiée à « Who do I see to get more staples? ».

Dim dscDiscussions As DiscussionsSet dscDiscussions = _
                OpenDiscussions("http://samples.microsoft.com")

dscDiscussions(1).Discussions(3).Text = _
    "Who do I see to get more staples?"


Timestamp, propriété

Renvoie des données de type Date représentant la date et l'heure de création de l'objet Discussion spécifié ou les date et heure de la plus récente modification de l'objet Discussion.

expression.Timestamp

expression Obligatoire. Expression qui renvoie un objet Discussion.

Exemple

Cet exemple montre comment afficher les date et heure de création ou de la plus récente modification de la discussion spécifiée.

MsgBox dscDiscussions(1).Timestamp


URL, propriété

Renvoie l'URL (Uniform Resource Locator) du document contenant la collection Discussions spécifiée. Argument de type String en lecture seule.

Exemple

Cet exemple montre comment afficher l'URL de la collection Discussions spécifiée.

Dim dscDiscussions As Discussions
Set dscDiscussions = OpenDiscussions("http://samples.microsoft.com")
MsgBox dscDiscussions.URL


Élément de langue masqué

Vous avez demandé de l'aide concernant un élément de langue qui est masqué, et par conséquent qui est indisponible pour un accès à la programmation.


Élément de langue non pris en charge

Vous avez demandé de l'aide concernant un élément de langue non pris en charge.


INDEX~TEXT
seealso~"Voir&nbsp;aussi"
appliesto~"S'applique&nbsp;à"
elements~"Éléments"
properties~"Propriétés"
methods~"Méthodes"
events~"Événements"
example~"Exemple"
specifics~"Spécificités"
show~"Afficher&nbsp;la&nbsp;description"
hide~"Masquer&nbsp;la&nbsp;description"


DiscussionServers, collection

 Discussions, collection


Discussion, objet


Discussion, objet

 DiscussionServer, objet


Global, objet


DiscussionServer, objet


Author, propriété

 AutoCommit, propriété

 Bookmark, propriété

 Discussions, propriété

 Index, propriété

 LoginName, propriété

 Parent, propriété

 Subject, propriété

 Text, propriété

 Timestamp, propriété
Discussions, collection


Add, méthode
Count, propriété

 Item, propriété

 Parent, propriété

 URL, propriété
Discussion, objet


Delete, méthode

 SetAsDefault, méthode
FriendlyName, propriété

 ServerAddress, propriété


Add, méthode


OpenDiscussions, méthode
CurrentUserName, propriété


Discussion, objet

 DiscussionServers, collection

 Discussions, collection


Discussions, collection