Bienvenue dans l’aide du programme d’installation

Sommaire :

  • Termes du contrat de licence logiciel Microsoft
  • Types d’installation
  • Mettre à niveau les versions antérieures
  • Choisir le type de serveur
  • Sélectionner un emplacement de données
  • Terminer la configuration du serveur
  • Comment lancer l’Assistant Configuration des produits SharePoint
  • Commutateurs de ligne de commande setup.exe pour SharePoint
  • Échec de la configuration pendant la suppression
  • Modifier votre installation


Modifier votre installation

Réparer

Vous pouvez utiliser l’option Réparer pour remplacer les fichiers et les paramètres du Registre qui sont modifiés ou endommagés.

Par exemple, vous pouvez utiliser l’option Réparer lorsque vous voulez restaurer le paramètre par défaut d’une entrée de Registre qui a été remplacée.

Lorsque vous réparez une installation, les fichiers déjà installés sont vérifiés, les composants manquants sont détectés et la configuration est réparée.

Remarque Si vous avez appliqué des mises à jour de logiciels, par exemple un Service Pack, vous pouvez tout de même réparer votre installation. Cependant, notez que seuls les fichiers d’origine sont réparés, pas les fichiers mis à jour à l’aide de versions plus récentes.

Supprimer

Vous pouvez utiliser l’option Supprimer pour désinstaller Microsoft Search Server 2010. La désinstallation entraîne la suppression de la plupart des fichiers et sous-dossiers situés dans les dossiers d’installation. Les bases de données Microsoft SQL Server sont détachées mais pas complètement supprimées du serveur de base de données. Lorsque vous supprimez Search Server 2010, toutes les données utilisateur sont conservées dans les fichiers de base de données. L’option Supprimer permet de supprimer les serveurs Web et les serveurs d’applications, mais pas les serveurs de bases de données de la batterie de serveurs. Pour supprimer un serveur de base de données d’une batterie de serveurs, vous devez d’abord déplacer les bases de données hébergées par ce serveur vers un autre serveur de base de données de la batterie de serveurs. Vous pouvez ensuite utiliser l’Administration centrale pour supprimer le serveur de base de données.


Sélectionner un emplacement de données

Vous pouvez spécifier le chemin d’accès où stocker les fichiers d’index de recherche. Le chemin d’accès par défaut est %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\Data.

Si vous souhaitez modifier l’emplacement des fichiers d’index de recherche, cliquez sur Parcourir en regard de la seconde zone de texte, puis sélectionnez le chemin souhaité.

Remarque Si vous effectuez une mise à niveau à partir d’un autre produit serveur SharePoint, l’emplacement des données ne peut pas être modifié.

Si vous recevez un message d’erreur ou rencontrez un problème, visitez le site Centre de ressources du programme d’installation de Microsoft Office 2010 pour obtenir des informations de dépannage et contacter le Support technique Microsoft.


Types d’installations

Lorsque vous choisissez une installation autonome, un seul ordinateur autonome est configuré à l’aide de tous les paramètres par défaut. Par ailleurs, Microsoft SQL Server 2008 Express Edition est installé en tant que moteur de base de données. Dans une installation de batterie de serveurs, vous devez installer SQL Server 2005 avec Service Pack 2 (SP2), SQL Server 2005 avec Service Pack 3 (SP3) ou SQL Server 2008 (Standard ou Enterprise), dans leurs éditions 64 bits.

La planification, l’évolutivité, le stockage des données et la complexité de la configuration sont les éléments à prendre en considération lors du choix du type d’installation (Autonome ou Batterie de serveurs).

Autonome

L’installation autonome configure un seul ordinateur avec tous les fichiers et les paramètres nécessaires pour créer une implémentation comprenant toutes les fonctionnalités, y compris un serveur Web et un moteur de base de données. SQL Server 2008 Express Edition est installé et configuré pour fournir des fonctionnalités de stockage de données. SQL Server Express Edition est basé sur l’architecture Microsoft SQL Server, mais comporte les limitations suivantes :

  • Pas de prise en charge des fonctionnalités d’entreprise, par exemple les options de haute disponibilité.
  • Limité à un seul processeur
  • Limite de mémoire d’un gigaoctet pour le pool de tampons
  • Taille des bases de données limitée à 4 Go.

En raison des limitations de SQL Server 2008 Express Edition, si vous avez besoin d’une prise en charge d’une configuration de batterie de serveurs, d’un ordinateur multiprocesseur, ou si vous prévoyez d’étendre les capacités du système, nous vous conseillons une installation de batterie de serveurs.

Optez pour une installation autonome si vous recherchez :

  • une installation de petite envergure ;
  • un environnement de développement ou de test ;
  • un environnement pour évaluer les fonctionnalités du produit.

Attention Une installation autonome ne peut pas être convertie en installation de batterie de serveurs. Si vous anticipez la nécessité d’utiliser plus tard plusieurs serveurs dans une batterie de serveurs, choisissez l’installation de batterie de serveurs. Si vous choisissez l’installation autonome maintenant, et si vous décidez ultérieurement de passer à une batterie de serveurs, vous devez effectuer une désinstallation, puis une réinstallation de type batterie de serveurs.

Batterie de serveurs

L’option d’installation batterie de serveurs permet de distribuer les fonctionnalités sur un ou plusieurs ordinateurs et de préserver les possibilités d’extension de votre système. Pour ce type d’installation, vous devez fournir les paramètres de connectivité et les informations d’identification pour la connexion à une instance existante de SQL Server pouvant servir de magasin de données sous-jacent. Si vous choisissez l’option batterie de serveurs, vous devez spécifier le rôle que doit assurer l’ordinateur en cours d’installation dans la batterie de serveurs. Vous avez le choix entre les rôles suivants au cours de l’installation :

Complète – Installe tous les composants. Possibilité d’ajouter des serveurs pour former une batterie SharePoint.

L’option Complète installe un serveur Web et configure l’ordinateur pour fournir les fonctionnalités d’un serveur d’applications. Elle ne fournit pas les fonctionnalités d’une base de données. Vous devez fournir les paramètres de connectivité et les informations d’identification pour vous connecter à une instance SQL Server existante. Bien que SQL Server puisse être installé sur ce même ordinateur, nous vous recommandons d’installer ce produit sur un ordinateur distinct.

Remarque Vous pouvez également installer Microsoft Search Server 2010 pour un serveur Web frontal au lieu d’effectuer une installation complète. Cependant, pour ce faire, vous devez utiliser la ligne de commande.

Autonome – Installe tous les composants sur un seul ordinateur, y compris SQL Server Express 2008. Cette configuration ne permet pas d’ajouter des serveurs pour créer une batterie SharePoint.

L’option de configuration autonome lance l’installation autonome décrite plus haut, mais vous pouvez configurer le chemin d’installation et définir les options de commentaires.


Comment : démarrer l’Assistant Configuration des produits SharePoint

Une fois l’exécution de l’Assistant Installation terminée, vous pouvez à tout moment faire appel à l’Assistant Configuration des produits SharePoint.

Pour démarrer l’Assistant Configuration des produits SharePoint

  • Cliquez sur Démarrer, pointez sur Tous les programmes, cliquez sur Outils d’administration, puis sur Assistant Configuration des produits SharePoint.


Choisir le type de serveur

Vous pouvez installer les configurations suivantes :

Complète – Installe tous les composants. Il est possible d’ajouter des serveurs pour former une batterie SharePoint.

L’option Complète installe un serveur Web et configure l’ordinateur pour fournir les fonctionnalités de serveur d’applications. Elle ne fournit pas les fonctionnalités de base de données. Vous devez fournir les paramètres de connectivité et d’identification pour vous connecter à une instance SQL Server existante. Bien que SQL Server puisse être installé sur ce même ordinateur, il est recommandé d’installer ce produit sur un ordinateur distinct.

Remarque Vous pouvez également installer Microsoft Search Server 2010 pour un serveur Web frontal au lieu d’effectuer une installation complète. Cependant, pour ce faire, vous devez utiliser la ligne de commande.

Autonome – Installe tous les composants sur un seul ordinateur, y compris SQL Server Express 2008. Cette configuration ne permet pas d’ajouter des serveurs pour créer une batterie SharePoint.

L’installation autonome configure un seul ordinateur avec tous les fichiers et les paramètres nécessaires pour créer une implémentation de SharePoint comprenant toutes les fonctionnalités, y compris un serveur Web, un serveur d’applications et une base de données. SQL Server Express est installé et configuré pour fournir des fonctionnalités de stockage de données. Bien que SQL Server Express soit basé sur l’architecture Microsoft SQL Server, il comporte les limitations suivantes :

  • Fonctionnalités Entreprise non prises en charge
  • Limité à un seul processeur
  • Limite de mémoire d’un gigaoctet pour le pool de tampons
  • Taille des bases de données limitée à 4 Go.

SQL Server Express ne prend pas en charge une configuration de batterie de serveurs ou un ordinateur multiprocesseur. Si vous pensez avoir besoin d’évoluer vers une installation plus importante ou plus robuste, choisissez l’option Complète.

Remarque Vous pouvez effectuer une installation autonome en sélectionnant Autonome dans cet écran ou en cliquant sur Autonome dans l’écran précédent. La procédure d’installation des deux options est similaire à une seule différence près : si vous cliquez sur Autonome, vous pouvez choisir le chemin d’installation et définir les options relatives aux commentaires. Lorsque vous accédez à l’écran suivant, les deux options suivent les mêmes étapes et produisent le même résultat.


Terminer la configuration du serveur

Installation terminée

L’Assistant Installation vient de terminer les opérations suivantes :

  • Validation des prérequis logiciels.
  • Installation des fichiers nécessaires.
  • Installation de tous les composants et services.

L’étape suivante consiste à exécuter l’Assistant Configuration des produits SharePoint. Cet Assistant configure les activités à exécution unique et les services. Une fois l’exécution de cet Assistant terminée, vous pouvez commencer la configuration du serveur de recherche. Ce processus consiste notamment à :

  • configurer le rôle de l’ordinateur ;
  • activer ou désactiver des services ;
  • rassembler toutes les informations utiles à la définition exacte du rôle de l’ordinateur ;
  • effectuer toutes les opérations de configuration requises.

Vous pouvez exécuter l’Assistant Configuration immédiatement après l’Assistant Installation, mais vous avez également la possibilité de l’exécuter ultérieurement s’il vous manque certaines informations de configuration.

Pour exécuter l’Assistant Configuration des produits SharePoint immédiatement après l’Assistant Installation

  • Activez la case à cocher Exécuter l’Assistant Configuration des produits SharePoint, puis cliquez sur Fermer. L’Assistant Configuration démarre automatiquement.

Pour exécuter l’Assistant Configuration ultérieurement, désactivez la case à cocher Exécuter l’Assistant Configuration des produits SharePoint, puis cliquez sur Fermer. Lorsque vous êtes prêt à exécuter l’Assistant Configuration, suivez la procédure décrite dans la rubrique Procédure : démarrer l’Assistant Configuration des produits SharePoint.

Échec du programme d’installation

Si une erreur est détectée, le processus d’installation s’arrête et une erreur est consignée dans le fichier journal d’installation. Le fichier journal d’installation est stocké dans le répertoire temp du compte de l’utilisateur qui exécute le programme d’installation (%USERTEMP% ou %WINDIR%\Users\compte d’utilisateur\AppData\Local\Temp). Vous pouvez consulter les messages d’erreur du fichier journal. Une fois que vous avez déterminé l’origine de l’erreur, résolvez le problème, puis réexécutez le programme d’installation.

Remarque Si vous êtes confronté à un problème durant le processus de désinstallation, voir Problème de configuration en cours de désinstallation. Si vous recevez un message d’erreur ou rencontrez un problème, visitez le site Centre de ressources du programme d’installation de Microsoft Office 2010 pour obtenir des informations de dépannage et contacter le Support technique Microsoft.


Consulter les termes du contrat de licence logiciel Microsoft

Les termes du contrat de licence logiciel Microsoft définissent les conditions légales de l’utilisation du logiciel. Dans le programme d’installation, activez la case à cocher J’accepte les termes de ce contrat pour activer le bouton Continuer.


Commutateurs de ligne de commande setup.exe pour les produits SharePoint

Dans les produits SharePoint, l’outil en ligne de commande Setup.exe est utilisé pour quelques rares opérations, par ailleurs quasiment exclusivement réservées aux administrateurs informatiques.

Dans cet article
  • Comment utiliser un commutateur de ligne de commande Setup.exe
  • Commutateurs et paramètres disponibles
  • Exécuter Setup.exe avec un fichier Config.xml à une invite de commandes
  • Trouver des informations supplémentaires sur Microsoft Office System TechCenter

Comment utiliser un commutateur de ligne de commande Setup.exe

Lorsque vous exécutez Setup.exe à partir de la ligne de commande, vous pouvez spécifier des commutateurs et des paramètres pour fournir des instructions spécifiques qui donnent au programme des informations supplémentaires sur l’exécution de la commande. Le tableau de la section suivante contient plusieurs exemples de commutateurs.

Haut de la page

Commutateurs et paramètres disponibles

Dans les produits SharePoint, Setup.exe reconnaît les options de ligne de commande suivantes.

Commutateur ou paramètre Description
/config [chemin d’accès et nom de fichier]

Spécifie le fichier de configuration que Setup.exe utilise lors de l’installation. Par défaut, le fichier Config.xml stocké dans le dossier principal du produit indique à Setup.exe d’installer ce produit. Vous pouvez modifier le fichier Config.xml pour apporter des personnalisations supplémentaires à l’installation, ou vous pouvez pointer vers un fichier de configuration différent.

Utilisez /config dans la ligne de commande du programme d’installation pour spécifier l’emplacement du fichier config.xml par défaut d’un produit spécifique ou un fichier de configuration personnalisé.

Exemples

Pour pointer vers un fichier config.xml personnalisé :

\\serveur\partage\setup.exe /config \\serveur\partage\dossier\Config.xml

où dossier correspond au dossier contenant le fichier config.xml. Pour pointer vers un autre fichier de configuration :

Remarque Vous devez utiliser un chemin d’accès complet. Setup.exe ne reconnaît pas les chemins d’accès relatifs contenant /config.

/modify [ID_Produit]

Utilisé avec un fichier config.xml modifié afin d’exécuter Setup.exe en mode maintenance et de modifier une installation Office existante (ajout ou suppression de fonctionnalités, par exemple). Dans le fichier setup.xml, recherchez la valeur de [ID_Produit] correspondant au produit à modifier. Le fichier setup.xml est situé dans le dossier de produit principal. Dans setup.xml, [ID_Produit] correspond à la valeur de l’attribut Id de l’élément Setup.

/repair [ID_Produit]

Exécute Setup.exe pour réparer les fichiers nécessaires du produit spécifié. Recherchez la valeur de [IDProduit] dans le fichier Setup.xml du produit que vous souhaitez modifier. L’exécution de Setup.exe en mode réparation affecte uniquement les fichiers du programme et ne répare pas votre configuration de serveur ou des sites.

Remarque Vous devez également exécuter l’Assistant Configuration des produits SharePoint après avoir exécuté Setup.exe /repair afin de terminer la réparation de la configuration. Si vous utilisez une configuration autonome, vous pouvez exécuter Psconfig.exe -setup à partir d’une ligne de commande pour réparer la configuration, au lieu d’utiliser l’Assistant. Si vous êtes dans une configuration de batterie de serveurs, utilisez l’interface d’Assistant complète. Pour plus d’informations, voir l’aide relative à l’Assistant Configuration des produits SharePoint.

/uninstall [ID_Produit]

Supprime le produit spécifié de l’ordinateur de l’utilisateur. Dans le fichier setup.xml, recherchez la valeur de [ID_Produit] correspondant au produit à modifier.

Haut de la page

Exécuter Setup.exe avec un fichier Config.xml à une invite de commandes

L’exécution de Setup.exe avec un fichier de configuration vous permet de spécifier des choix de configuration (par exemple l’emplacement des données ou le rôle serveur) durant une installation sans assistance. Par exemple, vous pouvez utiliser le fichier Config.xml pour :

  • effectuer une installation sans assistance ;
  • effectuer une installation à l’aide d’une configuration commune sur plusieurs serveurs ;
  • effectuer une installation automatisée ou basée sur un script.

Procédez comme suit pour exécuter Setup.exe avec un fichier de configuration (Config.xml) à une invite de commandes.

  1. Sur le lecteur qui contient le DVD du produit, accédez au répertoire racine afin de localiser le fichier Setup.exe.
  2. Exécutez Setup.exe avec le fichier Config.xml sélectionné.

    3. setup /config <chemin d’accès et nom de fichier>

    Remarque Vous pouvez soit sélectionner l’un des exemples de fichiers inclus dans le DVD du produit, soit personnaliser votre propre fichier de configuration.

  3. Appuyez sur Entrée.

Pour plus d’informations, voir le Guide de référence de la ligne de commande sur TechNet.

Haut de la page

Rechercher des informations sur le Centre technique Microsoft Office

Office 2010 TechCenter fournit du contenu aux administrateurs, par exemple le guide de déploiement, qui contient des informations supplémentaires sur les options et propriétés de ligne de commande Setup.exe.

Remarque Pour pouvoir consulter ce contenu, vous devez être connecté à Internet.


Échec de la configuration pendant la suppression

Lorsque vous choisissez Supprimer dans Ajout/Suppression de programmes, l’Assistant Configuration démarre et tente de désinstaller le produit. Si une erreur se produit, le processus de désinstallation est interrompu et l’erreur est consignée dans le fichier journal d’installation.

Remarque Le fichier journal d’installation est stocké dans le répertoire temp du compte de l’utilisateur qui exécute le programme d’installation (%USERTEMP% ou %WINDIR%\Users\compte d’utilisateur\AppData\Local\Temp).

Vous pouvez consulter les messages d’erreur du fichier journal. Une fois que vous avez compris l’erreur, vous pouvez soit arrêter la procédure de suppression, essayer de résoudre le problème et exécuter à nouveau Supprimer, soit continuer la procédure de désinstallation.

Si vous quittez l’installation à la suite d’une erreur, les fichiers binaires ne sont pas supprimés. Toutefois, les tâches terminées avec succès ne sont pas annulées. Cette méthode vous permet de restaurer le serveur en exécutant l’Assistant Configuration en mode Réparer.

Si vous décidez de continuer la procédure de désinstallation, les fichiers binaires sont supprimés. L’état de l’ordinateur dépendra alors de l’étape à laquelle la désinstallation aura été arrêtée. Par exemple, l’ordinateur sera :

  • joignable par le serveur,
  • enregistré dans la base de données de configuration, avec une chaîne de connexion sur l’ordinateur local,
  • doté de services en cours d’exécution.

Une fois les fichiers binaires supprimés, vous ne pourrez plus utiliser l’Assistant Configuration pour nettoyer les paramètres de configuration sur l’ordinateur local ou dans la base de données de configuration.


Mettre à niveau les versions antérieures

Vous pouvez effectuer une mise à niveau sur place de Microsoft Search Server 2008 avec Service Pack 2 vers Microsoft Search Server 2010 ou de Microsoft Search Server Express 2008 avec Service Pack 2 vers Microsoft Search Server 2010 Express.

Lorsque vous cliquez sur Installer maintenant, une mise à niveau sur place de l’intégralité de votre installation est immédiatement effectuée. Les paramètres par défaut sont utilisés et l’Assistant ne vous demande aucune information. Une fois l’opération terminée, l’ensemble de votre site est à niveau par rapport à la dernière version disponible.

Mettre à niveau une batterie de serveurs

Si vous mettez à niveau une batterie de serveurs, appliquez la procédure suivante :

  1. Exécutez le programme d’installation, puis exécutez l’Assistant Configuration des produits SharePoint sur le serveur qui exécute l’Administration centrale de SharePoint dans votre batterie de serveurs.
  2. Lorsqu’un message s’affiche, vous invitant à exécuter le programme d’installation sur les autres serveurs de la batterie, vous devez faire de même et exécuter le programme d’installation puis l’Assistant Configuration des produits SharePoint sur les autres serveurs.
  3. Lorsque tous les serveurs de la batterie affichent le message, revenez au premier serveur Web puis cliquez sur OK pour continuer le processus de mise à niveau du premier serveur.
  4. Au terme de l’exécution de l’Assistant sur le premier serveur, configurez successivement tous les autres serveurs.

Pour plus d’informations sur la mise à niveau d’une batterie de serveurs, voir TechNet.

Dépannage